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Introduction
Enterprise Sync is a bundle of products that allows you to connect your mainframe Endevor system to an
AccuRev system to synchronize the files between the systems. Using AccuRev, you will have file history,
visual representations of files navigating through the development process, easy to generate differences
reports between file versions, etc.
The bundle is comprised of and requires the following products, some of which must be installed
separately:
Server Componets
Micro Focus
Mainframe
Access Server

Mainframe Access Server is a mainframe server component that communicates with
Endevor.

Enterprise Sync
Server

The Micro Focus Enterprise Sync Server components synchronize sources and meta
data between the SCM on the mainframe and sources managed on a distributed
platform. The server components that make up Enterprise Sync include:
Mainframe
Access Client

Communicates with Mainframe SCCM through the MFA
Server.

AccuRev Client

End-users and client programs perform operations on the
AccuRev client. Operations can take place from the command
line, AccuRev GUI, Web UI, or through an IDE Plugin. The
client process is installed as part of the installation and
communicates with the server process.

Micro Focus
Connect

Manages and performs the synchronization process.

AccuRev Server

AccuRev is a centralized version control system which uses a client/server model.
The AccuRev Server maintains all the source and metadata within a data repository.
The data repository is built around a database technology that is transaction-based
and manages the tables as append-only. There is a server process installed as part of
the AccuRev Server that manages the AccuRev repositories and handles all
communication between the server and the AccuRev clients.

Micro Focus
Workflow
Manager
Endevor
Attachment

An Application Workflow Manager model that provides integration to Endevor and
AccuRev tools and processes directly from an Enterprise Developer Eclipse project.
Refer to the Enterprise Developer documentation for more details.

Client Components
AccuRev Client

Windows based GUI to allow developer to access version controlled source
assets managed in the AccuRev Server.

AccuRev Eclipse Plugin Provides access to version controlled source assets directly from the
Enterprise Developer Eclipse IDE.
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Enterprise Sync Data
Enterprise Sync is a synchronization tool capable of mapping data between SCM systems.
Enterprise Sync syncs data to and from CA Endevor libraries on the IBM mainframe and source libraries
maintained on a distributed system. This allows developers to take advantage of modern tools for
managing source change in parallel with efficient source merging and retrofitting of changes but having
these changes automatically synchronized with the main source streams maintained on the mainframe.
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Components
The components in the Enterprise Sync solution communicate with each other in the following manner:
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Installation and Configuration
The topics in the section will walk you through configuring your systems and installing the required
components. It is important to follow these procedures in the order that they are listed.

AccuRev Configuration
Enterprise Sync works with the AccuRev 6.2.3 release. For full installation/configuration procedures for the
AccuRev client and server, refer to the AccuRev Installation and Release Notes: https://
supportline.microfocus.com/productdoc.aspx.
The following sections are required to configure AccuRev with Enterprise Sync.

Define AccuRev User
Define an AccuRev user that will be used later during the synchronization process. This user must have
a password defined (not optional).

Define AccuRev Depot
Define at least one depot used as a target for synchronizing Endevor elements (we will use BANKDEMO
in these samples).

Installation and Configuration
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Define AccuRev Stream Structure
The Bankdemo sample uses the streams PROD, EMER, QA and TEST structured as shown in the image
below. It is assumed that the corresponding Endevor installation contains two Endevor environments:
environment SMPLPROD with the stage 1 EMER and stage 2 PROD and environment SMPLTEST
with stage 1 TEST and stage 2 QA.
Important: All streams used for synchronization must be defined in AccuRev and must be empty
before running the first synchronization. Also note: We do not recommend using the root entry
bankdemo as stream used for synchronization of the Endevor production stage.
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Stop AccuRev Services
1. Close the AccuRev GUI.
2. Stop the AccuRev Server (use the Services panel and then right click Stop on the AccuRev Server
entry).

Modify the acserver.cnf File
1. Edit the acserver.cnf file and add a CC_USER line referencing the defined synchronization userid
(syncuser in our sample).
# Enterprise Sync User
CC_USER = syncuser
Important: The CC_USER and the user configured in the AccuRev data source in Micro Focus
Connect must be the same.
2. Save and close the file.
3. Return to the Services panel and restart the AccuRev Server.

Using the AccuRev WebUI
These optional steps allow you to use the AccuRev WebUI within Enterprise Developer:
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1. Stop the AccuRev Tomcat server.
2. Create a settings file, settings.xml, in the following directory: C:\Program Files\AccuRev
\storage\site_slice\dispatch\config.
3. Add the following content to the file:
<settings>
<webui url="http://###.#.#.#:####/accurev"/>
</settings>
Note: Replace the numbers with the IP Address followed by the port number.
4. Restart the AccuRev Tomcat server.

Installing Mainframe Access Server
Follow the steps at the following location to install the Mainframe Access Server: http://
documentation.microfocus.com/help/topic/
com.microfocus.eclipse.infocenter.enterprisedeveloper.eclipsewin/GUID-AEE9760E-7A58-4162-A180E0DB2FBDF886.html

Installing Enterprise Sync
You will need the AccuRev Host Name/IP Address and Port during this installation.
Use the following steps to install Enterprise Sync.
1. Using Administrator credentials, double click the installation media (enterpriseSync.exe)to start the
install.
2. Click Next on the Introduction screen.
3. Read the license agreement and check the I accept the terms of the license agreement checkbox.
4. Click Next.
5. On the Choose Install Folder screen, either accept the default location or choose another one. Click
Next.
6. On the AccuRev server parameters page, enter the Host Name and Port of the AccuRev server. Click
Next.
7. On the Choose Shortcut Folder, enter the location for the product icons. Click Next.
8. Review the Pre-Installation Summary page and click Install to install the components.
9. When the wizard is finished, click Done.
Two Enterprise Sync Services were started automatically: Enterprise Sync Web Service and
EnterpriseSyncConnect.
To verify the installation:
1.
2.
3.
4.

Open the page http://localhost/ConnectWeb in your browser.
Enter user Administrator and password Administrator.
Use the DefaultAuthenticator.
Click Login.
Note: User name and password are case sensitive.
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Installing the AWM Endevor Model
The Workflow Manager (AWM) Endevor Attachment must be installed and configured. The specific AWM
model NDVACONF - which is part of the Endevor Attachment - has to be used to support the client access to
the AccuRev server and to Endevor.
Find the Enterprise Developer 2.3 Update 1 for Eclipse product documentation for details how to install
and to configure this feature (http://documentation.microfocus.com/help/index.jsp).

http://documentation.microfocus.com/help/topic/
com.microfocus.eclipse.infocenter.enterprisedeveloper.eclipsewin/GUID-C1553D93-753E-4B7D-9DD0E66F025E11CE.html

Configuring Sync Rules
This topic will walk you through mapping your Endevor environment to your AccuRev environment using
the Micro Focus Connect UI. However, the following must be complete before continuing this procedure:
AccuRev server

Must be installed. You will need the AccuRev server address and port, the AccuRev
user/password and the depot and stream names during the configuration.

Enterprise Sync
server

Must be installed.

MFA server

Must be installed on the mainframe. You will need the mainframe hostname or IP
Address and the MFA port during the configuration and the mainframe userid/
password used to connect to the mainframe.
Note: A connection to the mainframe is already required during the
configuration, not only when running the synchronization.

1. On the machine where Enterprise Sync is installed, type the following into your browser: http://
localhost/ConnectWeb. This opens Micro Focus Connect.
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2. Enter User Administrator and Password Administrator. User name and password are case
sensitive.
3. For the Authenticator, use the DefaultAuthenticator.
4. Click Login.
5. Click Actions (

) and then select Settings. The Global Settings screen appears.

6. In the Sync Settings group, enter 1 for the Maximum Number of Threads.
7. Click Save.
8. Click on the Data Source tab, then click Create New Data Source.
9. Enter a Name for the AccuRev data source. For example: AccuRevDS.
10.Select AccuRev as the Data Source Product.
11.Click Add Data Source.
12.Select the added data source for AccuRev on the left side of the page and then enter the AccuRev
specific connect parameters.
Note the following:
Exclude List

This is a colon separated string that does pattern matching against files and can be
used to exclude files from sync operations. If you add a directory named source in
AccuRev and you don't want it to sync, the exclude list would include source. If
there was a specific file in source you don't want, for example, source
\readme.txt you would include that in the string. So multiples would look like:
source:docs\readme.txt:bin
This would exclude elements at the root of your AccuRev streams and workspaces
source, bin and the file docs\readme.txt.

12

Full Path to
AccuRev
executable

If AccuRev is not installed separately on this machine, you will find the path to the
AccuRev executable in a sub directory of the Enterprise Sync installation path, by
default here: C:\Program Files (x86)\Micro Focus\Enterprise Sync
\connectors\accurev\accurev.

Time OffSet

You can leave this blank.

User Name

This field must match the CC_USER name described in Modify the acserver.cnf File.
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13.Click Save Changes.
14.Click Create New Data Source again.
15.Enter a name for the data source. For example: EndevorDS. Select the Data Source Product Endevor.
16.Click Add Data Source.
17.Select the added data source for Endevor on the left side of the page and then enter the Endevor
specific connect parameters:
.

Note the following:
Endevor Node

Enter the mainframe IP address in the field.

Endevor Port

Enter the MFA port

Endevor Server

Must contain a unique server name for this connection (any unique value).

Include
SubSystem in
Path

Select True if you want to include Endevor subsystem names in the
synchronization path. Normally you would select False if an Endevor system has
exactly one subsystem, and the subsystem name is not relevant in this context.

Extensions File

The format of the file content will follow: java.util.Properties:
KEY=VALUE, PROCESSOR-GROUP
COBOL=CBL,*NOPROC*
COPY=CPY, CICS
EXE=EXE
TRS=TRS
ASM=asm
BMS=asm
JCL=jcl,CICS
JCLPROC=jcl,CICS
Put the full path and name. For example: C:\TEMP
\endevorExtensions.properties.
KEY

A valid Endevor Type

VALUE

A file extension which is added to the Endevor element name
when synchronizing files to AccuRev.
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Processor
Group

The Processor group is optional, if not supplied, the default
*NOPROC* will be used.

For example: COBOL=cbl
An Endevor COBOL element COB0001 is synchronized as COB0001.cbl
Time OffSet

You can leave this blank.

18.Click Save Changes.
19.Click the Connections tab and then click Add.
20.On the Create Connection Wizard page enter a name for the new connection (for example, NDV2ACC)
and select the Endevor data source as the Master and the AccuRev data source as the Target. Then
click Next.
21.On the Types and Fields page select From Master as the Default Sync Direction and then click
Add Type Mapping.
22.Select ChangeSet for both AccuRev and Endevor Types, ignore all other entries, and click OK.
23.Click Next on the Types and Fields tab.
24.On the Projects tab click Add for each required mapping from Endevor to an AccuRev stream. In our
BANKDEMO sample we will synchronize from Endevor to AccuRev the BANKDEMO subsystem in the
stages PROD, EMER and QA. Therefore we will have to define the following three mappings.
Do not define the mapping for stage TEST in this dialog because you will need a bi-directional mapping
for stage TEST. After all relevant mappings have been added click Save to save this connection and to
leave this connection wizard.

25.Repeat the previous steps and define the required bi-directional mappings. In our sample, this is the
mapping of subsystem BANKDEMO from the Endevor stage TEST to stream TEST.
26.The initial status is New connection but will change to Disabled. Use the refresh button on the right
side of the page to update the status fields.
27.To start the sync, click the Start button. Depending on the number of elements to synchronize the initial
synchronization process will take a while.
The icon changes if the synchronization is running.
You can stop the synchronization process, if required. Use the Refresh button to see the current status.
When the initial synchronization process is running the status is Restarting.
Micro Focus Connect will begin running regular synchronizations based on the duration configured in the
Synchronization Frequency setting. You can change this in Global Settings.
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Configuring Enterprise Developer for Enterprise Sync
The following must be configured before continuing this procedure:
Enterprise
Sync

Installation must be complete and configured successfully for the synchronization process.
All required initial syncs running successfully. See Configuring Sync Rules.

An Enterprise Developer for z Systems license or an Enterprise Developer Connect
Enterprise
license is required (see Enterprise Developer 2.3 Update 1 for Eclipse product
Developer
2.3 Update 1 documentation for details how to install and to configure this product).
HotFix 1
installed.

AccuRev
Eclipse
Plugin
installed into
Enterprise
Developer

Use the installation process via an Eclipse Update Site: In Enterprise Developer select
Help > Install New Software and follow the installation steps described in AccuRev
Plug-In for Eclipse -Installation and Release Notes - Version
2015.1.

Workflow
Manager
(AWM)
Endevor
Attachment

Must be installed and configured. See Installing the Endevor Model.

1. Start Enterprise Developer and open the Team Developer Perspective and load the application
Enterprise Sync V2.0 Endevor Application in the Team Developer tree. If this application is
not visible make sure that the Workflow Manager Endevor Attachment has been fully installed and
configured.
2. Click File > Import. Select AccuRev and then Project from AccuRev.
3. Select the correct AccuRev server and add your login credentials and then click OK.
4. Select the stream for which you would like to create a new AccuRev workspace. For our BANKDEMO
sample we will select stream TEST.
5. Enter an appropriate Workspace name and location and then click Next.
6. Select the Check out a project using the new project wizard option. Enter a project name and click
Next.
7. Select General > Project, then click Next and then Finish. This creates the Eclipse project with the
AccuRev workspace entries

Installation and Configuration
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8. You can now directly access the AccuRev workspace and the AccuRev team actions from the Team
Developer tree. Expand the loaded application, then expand the entry Workspace, navigate to one of
the sources and find all relevant AccuRev actions on the Team context menu.
9. To test the Endevor mainframe access expand the Endevor entry on the loaded application a few times
until your subsystem is listed under stage PROD. Then select Show all elements from the context menu
of the subsystem.
10.The Endevor element list is opened in the Team Developer Table view and the context menu of an
Endevor element supports the corresponding Endevor actions.
11.To test the integration with Enterprise Developer projects we define a new Mainframe COBOL Project
named BANKDEMO with an empty COBOL folder. Selecting the COPY folder in the AccuRev workspace
and selecting the BANKDEMO project via New > Folder > Link Folder to Project creates a link of the
AccuRev folder into the ED project.
Same could be done with other folders, but we could also decide to link files explicitly to an ED project
using New > File > Link File to Folder.
12.After setting the Enterprise Developer projects properties correctly (build path and directives) the
programs are compiled successfully and the COBOL editor supports full smart edit capabilities.

Getting started with Enterprise Developer
The following are required before proceeding with this procedure:
•
•
•
•
•
•

Enterprise Sync installed and configured.
AccuRev server installed and configured.
Enterprise Developer installed with AccuRev plug-in.
AWM Endevor attachment installed and configured.
AccuRev workspace created in EDz and mapped to an Eclipse project.
Enterprise Developer mainframe COBOL project BANKDEMO created with link to the COBOL source
BBANK10P and link to the Copybook folder.

Sample Environment Stream Mapping
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1. Start Enterprise Developer, open the Team Developer Perspective and load the application
Enterprise Sync V2.0 Endevor Application in the Team Developer tree.
2. Expand the COBOL folder in the BANKDEMO project and edit BBANK10P.cbl. Make a small change. For
example, add the comment Change done in AccuRev workspace and then save and close the
file.

Installation and Configuration
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3. The COBOL program is compiled automatically. You would now be able to test and debug this module
using the integrated Enterprise Server features.
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4. Assuming the test was successful, navigate to the workspace entry and promote the program to the
TEST stream. Right click BBANK10P.cbl, select Team > Promote. The Promote dialog box appears.
5. Enter a comment, for example, Test ACC2NDV, and click OK.
6. After the promote to stream TEST the file is automatically synchronized to Endevor. Navigate to the
Endevor BANKDEMO subsystem in stage TEST to find this element in Endevor. The file was also
generated successfully in Endevor. Thus, an integration test could be executed on the mainframe.
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7. Assuming the integration test was successful, promote this file in Endevor from the TEST to the QA
stage. Right click the BBANK10P item, then select Actions > Move Element . The Move an Element
dialog box appears.
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8. Enter a CCID and a Comment and click OK.
9. After the Move is done in Endevor, this promote function is automatically synchronized in AccuRev. You
can verify this in Enterprise Developer using Show History. Right click the item in the tree, select Team
> AccuRevHistory.
10.The move from QA to stage PROD is supported in the same way, navigating to the Endevor file in stage
QA, moving the file in Endevor to the PROD stage. After repeating steps 7-9 you can verify that this
promote is synchronized as well.

11.Now we will do an emergency change directly in Endevor using the remote Edit action on the PROD
level of the element.
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12.After saving and closing the file it is stored in Endevor stage EMER and automatically synchronized to
the AccuRev stream EMER.
13.Promote this change to the PROD stage which synchronizes this change with AccuRev.
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14.On the AccuRev workspace entry, compare the workspace file with the emergency changes done on
the mainframe.
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15.The Merge action can be used to merge the emergency changes into the workspace file.

24

| Installation and Configuration

Installation and Configuration

| 25

Troubleshooting
Use the topics in this section to troubleshoot common issues.

Reviewing Log Files
Do the following to locate the log files:
1. Open <install path>\Micro Focus\Enterprise Sync\local.properties.
2. Find the USER_DIRECTORY= entry. It will be something similar to:
c:/users/Administrator/AppData/Local/Micro Focus/Enterprise Sync
3. Open that directory and you will find a logs directory.
Changing the Logs to Debug Level
If you require more detailed log file information, change the logging level to DEBUG:
Open the local.properties file.
Locate the # debug=HIGH entry.
Uncomment the line by removing the # .
Save and close the file.
Find and open for editing the log4j.xml file in the Enterprise Sync directory.
Locate the <logger ... elements. There are many. They each contain a <level> element. One full
entry will look similar to:
<logger name="stderr" additivity="false">
<level value="INFO"/>
<appender-ref ref="DEFAULT"/>
<appender-ref ref="ERROR"/>
</logger>
7. Change the value="INFO" to value="DEBUG".
8. Save and close the file.
9. Re-start the EnterpriseSyncConnect service.
1.
2.
3.
4.
5.
6.

Resetting Mappings
Use the following procedure to restart with an initial sync:
Reset All Mappings
Note: Find referenced files in C:\Users\<user>\AppData\Local\Micro Focus\Enterprise
Sync.
1. Stop Micro Focus Connect.
2. For all mapped AccuRev streams, perform a Revert to Basis for all elements:
a.
b.
c.
d.
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In the AccuRev UI, open a stream.
Select Mode: Outgoing.
Turn on the Stranded filter.
Select all elements in the main panel.

e. Click Revert To Basis.
The stream is empty and ready for an initial sync.
3. Delete the file Connect.MostRecentSync.xml.
4. Restart Micro Focus Connect. Initial syncs from Endevor to AccuRev will be performed.
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