Micro Focus Academic Program 2.3

Release Notes

Micro Focus
The Lawn
22-30 Old Bath Road
Newbury, Berkshire RG14 1QN
UK
http://www.microfocus.com

Copyright © Micro Focus 2009-2015. All rights reserved.
MICRO FOCUS, the Micro Focus logo and Visual COBOL are trademarks or registered
trademarks of Micro Focus IP Development Limited or its subsidiaries or affiliated
companies in the United States, United Kingdom and other countries.
All other marks are the property of their respective owners.
2015-11-10

ii

Contents
Micro Focus Academic Program 2.3 - Release Notes

.....................................4

System Requirements .........................................................................................................5
Hardware Requirements .......................................................................................... 5
Operating Systems Supported ................................................................................. 6
Software Requirements ............................................................................................6
Installation ........................................................................................................................... 8
Installation Restrictions and Requirements .............................................................. 8
Downloading the Products ....................................................................................... 9
Installing the Products .............................................................................................. 9
After Installing ...........................................................................................................9
Repairing ................................................................................................................ 10
Uninstalling .............................................................................................................11
Known Issues ....................................................................................................................11
Significant Changes in Behavior or Usage ........................................................................14
Disclaimer ......................................................................................................................... 20

Contents | 3

Micro Focus Academic Program 2.3 Release Notes
These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.
Overview
The Micro Focus Academic Program brings contemporary software development tools and technologies to
COBOL development helping to bridge the gap between the old and the new.
COBOL applications still run many of the world’s business systems, therefore teaching the COBOL
language is a great way to prepare your university's students for a robust IT career in today’s economy.
The Micro Focus Academic Program is designed to support the education and use of the COBOL language
within the academic setting. This program supports our academic partner community through the use of
our COBOL development tools and materials within the classroom.
This program will enable your university to quickly join this growing league of similar academic
organizations in support of the promotion and education of the COBOL language.
Welcome! We’re excited to have you join our growing academic community.
Product Description
The Micro Focus Academic Program Edition package comprises the following products:
•

Visual COBOL - delivers the richest development experience for COBOL programming. On Windows,
Visual COBOL is available for use with Microsoft's Visual Studio or with the Eclipse integrated
development environments. On UNIX or Linux, it is available for use with Eclipse. Visual COBOL
supports the development and deployment of both JVM COBOL and .NET COBOL, and of native
COBOL applications.
Variants of Visual COBOL include:

•

• Visual COBOL for Visual Studio 2012, Visual Studio 2013 or Visual Studio 2015
• Visual COBOL for Eclipse (Windows)
Enterprise Developer - a contemporary development suite for Microsoft Visual Studio or for Eclipse that
enables mainframe developers to maintain, develop and modernize mainframe applications regardless
of whether these are to be deployed back on the mainframe or onto an alternative platform. Enterprise
Developer supports IBM COBOL, IBM PL/I, IBM Assembler, IBM CICS, IBM IMS, IBM JCL, IBM DB2,
IBM z/OS file formats and common batch utilities including SORT. This means you can develop and
maintain the core mainframe online and batch applications under Enterprise Developer, then deploy
them back on the mainframe or migrate them onto one of the Micro Focus production platforms
available on UNIX, Linux, or Windows. Variants include:
•
•

Enterprise Developer for Visual Studio 2012, Visual Studio 2013 or Visual Studio 2015
Enterprise Developer for Eclipse

Micro Focus Academic Program differs from the full version of these products in a number of ways. The
differences are:
•
•
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You cannot deploy applications on other machines, so Micro Focus COBOL Server and Enterprise
Server are not supplied.
An authorization code for the Micro Focus Rumba 3270 terminal emulator is not supplied.
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Note: Micro Focus Academic Program is supplied for Academic use only. It is not to be used for any
commercial purposes. You must be a registered Micro Focus Academic Program Partner in order to
use this software.
For more information, follow the link in the Electronic Product Delivery email for the End User License
Agreement.
Reporting Issues
•

For the latest information and discussions on this product, or to report issues, visit the Micro Focus
Community Web site.
Note:
•

•
•
•

This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link.
Web sites by their nature can change very rapidly and although we try to keep our links up-to-date,
we cannot guarantee that they will always work as expected.
Check the Product Documentation section of the Micro Focus SupportLine Web site and the Micro
Focus Infocenter for any updates to the documentation which might have been uploaded.
Starting with this product release, Micro Focus no longer supports Visual COBOL for Visual Studio
2010.
This product includes OpenSSL version 1.0.1m.

System Requirements
Hardware Requirements
In general, most modern machines will have the required processor and available RAM to run the Micro
Focus products under Windows effectively. For planning purposes, you should consider having a minimum
of 2GB of RAM though Micro Focus recommends at least 4GB of RAM for optimal performance.
Visual COBOL and Enterprise Developer for Visual Studio
Visual COBOL and Enterprise Developer have the following requirements in addition to the requirements of
Microsoft Visual Studio. See the Visual Studio documentation for details of the Microsoft requirements.
The disk space requirements are:
Product

Maximum Disk Space
Requirements

Sentinel RMS License Manager

Visual COBOL

1.2GB

75MB

Enterprise DeveloperEnterprise
Developer

2.3GB

75MB

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.
Visual COBOL and Enterprise Developer for Eclipse on Windows
The disk space requirements are:
Product

Maximum Disk Space
Requirements

Sentinel RMS License Manager

Visual COBOL

3.7GB

75MB
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Product

Maximum Disk Space
Requirements

Sentinel RMS License Manager

Enterprise Developer

4.5GB

75MB

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

Operating Systems Supported
Note: If you are using Visual COBOL or Enterprise Developer on a 64-bit operating system, you can
produce either 32-bit or 64-bit applications.
For a list of the operating systems each individual product in this package supports, check the Product
Availability section on the Micro Focus SupportLine Web site: http://supportline.microfocus.com/
prodavail.aspx.
•

Visual COBOL for Visual Studio is not supported on versions of Windows earlier than Windows 7.

Software Requirements
Windows
Note: The setup file will check your machine for whether the prerequisite software is installed and will
install any missing prerequisites and the product components.
Visual COBOL and Enterprise Developer for Visual Studio:
This product requires Microsoft's Visual Studio - either the Visual Studio Integrated Shell or a more
advanced version of Visual Studio.
The following advanced editions of Visual Studio are required:
Professional, Premium, or Ultimate (for Visual Studio 2012)
Professional, Premium, Ultimate or Community Edition (for Visual Studio 2013)
Professional, Enterprise or Community Edition (for Visual Studio 2015)
If there is no Visual Studio installed on your machine, the setup file for Visual COBOL for Visual Studio
2012 or 2013 will install the Visual Studio Integrated Shell.
Important:
•

A problem with Microsoft's Windows 10 prevents installing the Visual Studio 2013 Shell on that
version of the OS. You must install an advanced edition of Visual Studio 2013 on Windows 10
before you start the installation of Visual COBOL for Visual Studio 2013.

•

Code generation issues in Microsoft's 64-bit JIT (just-in-time) compiler delivered as part of .NET
Framework version 4.6 can result in incorrect execution of some COBOL code compiled to .NET.
Version 4.6 of the .NET Framework is currently shipped as default with Visual Studio 2015 and
Microsoft's Windows 10. The problems include incorrect execution of MOVE and STRING
statements applied to alphanumeric operands, and incorrect execution of the ROUNDED phrase
for arithmetic statements.
Some of these issues only seem to be reproducible in COBOL language applications compiled
to .NET and some can be reproduced in other languages (C# or Visual Basic).
These problems have been reported and acknowledged by Microsoft and it is our belief that they
either have resolutions or are working on fixes for all of them. For further information about these
issues and guidelines on how to disable the latest version of the 64-bit JIT compiler, see RyuJIT
Bug Advisory and Troubleshooting RyuJIT.

6
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As of October 2015, Microsoft have released the following updates that address these issues with
the .NET Framework 4.6:
•
•
•

•
•

Hotfix rollup 3088955 for the .NET Framework 4.6 on Windows Server 2012 and Windows 8 see: http://www.microfocus.com/docs/links.asp?vc=mskb3088955.
Hotfix rollup 3088956 for the .NET Framework 4.6 on Windows Server 2012 R2 and Windows
8.1 - see: http://www.microfocus.com/docs/links.asp?vc=mskb3088956
Hotfix rollup 3088957 for the .NET Framework 4.6 on Windows 7 SP1, Windows Server 2008
SP2, Windows Server 2008 R2 SP1, and Windows Vista SP2 - see: http://
www.microfocus.com/docs/links.asp?vc=mskb3088957.
Cumulative update 3093266 for Windows 10: September 30, 2015 (available through Windows
Update) - see: http://www.microfocus.com/docs/links.asp?vc=mskb3093266.

Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a
number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the
setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that
there is an advanced edition of Visual Studio 2015 installed on your machine.

Note:
•

•
•

On Windows 8.1 RT, Windows 8.1 or Windows Server 2012 R2, you must have the Windows
update KB 2919355 before you install Visual Studio 2015. Download KB 2919355 from the
Microsoft Download Center.
Microsoft Visual Studio Express Edition is not supported.
You can download the Visual Studio Integrated Shell from the Microsoft Download Center. If you
choose to install the Shell, ensure you run the installer to complete the installation - run
vsintshell.enu.exe from the location where you installed the download.
Note that some Visual Studio features might not be available with the Shell. This includes WCF or
the Visual Studio 2013 Connected IDE experience in the Visual Studio 2013 Shell - the help for
more details.

The following software is also required:
•
•
•
•

Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft
Download Center and search for Windows SDK.
Microsoft .NET Framework 4.5. This is included with Visual Studio 2012.
Microsoft .NET Framework 4.5.1. This is included with Visual Studio 2013.
Microsoft .NET Framework 4.6. This is included with Visual Studio 2015.

Visual COBOL and Enterprise Developer for Eclipse:
The following requirements apply to both Visual COBOL and Enterprise Developer:
•
•
•

Though Visual COBOL does not support the 64-bit Eclipse, you can use the 32-bit Eclipse to create
both 32-bit and 64-bit applications.
Visual COBOL requires a 32-bit Java installation.
Visual COBOL ships with Eclipse 4.4.2. After the installation, you can install the Visual COBOL plug-in
into other instances of Eclipse available on the same machine. The supported versions are 4.2 and 4.3
for the 32-bit Eclipse only. See Installing Visual COBOL into other instances of Eclipse for instructions.

The setup file will check your machine for whether the prerequisite software is installed and will install any
missing prerequisites and the product components.
•

Oracle's Java Platform, Enterprise Edition (Java EE) 7 or Java 8 is required to run the Eclipse IDE, to
execute COBOL JVM code and for native COBOL and Java interoperability. The setup file installs Java
8 u51 32-bit. You can download Oracle's Java EE from Oracle's Web site and install it anywhere on your
machine.
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•

Note: If you have Java 7 installed on your machine and you do not want the setup file to install
Java 8, you can install the product silently and use the skipjre=1 command line option to skip
installing Java 8. See Installing Silently on Windows for more details.
The setup file also installs .NET Framework v4.5.2 and the Microsoft Visual C++ 2010 and 2012
Redistributables.

Installation
Installation Restrictions and Requirements
Before starting the installation you should be aware of the following:
•
•
•

•

•

•
•

•

Visual COBOL and COBOL Server cannot coexist on the same machine.
Visual COBOL and Enterprise Developer cannot coexist on the same machine regardless of which IDE
(Visual Studio or Eclipse) you install.
If, when you install Visual COBOL for Visual Studio , the machine does not have Microsoft Visual C++
Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of
Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital signatures,
into the winsxs directory.
If, when you install Visual COBOL for Visual Studio 2013, the machine does not have Microsoft Visual C
++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital
signatures, into the winsxs directory.
You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.
If you are installing this as an upgrade, make sure that none of the product files are in use when you
start the installation. Also, the Visual Studio Help Viewer must not be opened.
You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.
Before installing this product , make sure that any existing Micro Focus Directory Server (MFDS) or
CCITCP2 Windows service (on Windows) from an existing product is stopped and uninstalled. On
Windows, do this as follows:
1. Stop the service, using either the Windows Service Management Console GUI or from a command
line prompt by typing: net stop mf_ccitcp2 Only one instance of the MFDS or CCITCP2
service can run on a Windows machine.
2. Uninstall the MFDS or CCITCP2 service.
For MFDS, from a command line prompt enter: mfds -u
For CCITCP2: ccitcp2 -u
To run an earlier version of MFDS as a service after you have installed a later version:
1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:
a. Open a Visual COBOL command prompt.
b. Install the service. Enter the following command: mfds -i
c. Start the service. Enter the following command: net start mf_ccitcp2

8
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Note: The two versions use different paths for environment and registry values, so the list of
configured Enterprise Servers might be different depending on which version has been started,
since, by default, different MFDS data repositories are used.
MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier
versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later
versions.
It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the
"mfcobol" port is used (86) and this can only be used by one process at a time

Downloading the Products
1. Use the download links in your Electronic Product Delivery email.
For more information follow the links for the installation instructions and the End User License
Agreement.

Installing the Products
Use the individual setup files to install each product from the Micro Focus Academic Program package as
follows:
Windows
1. Run the productname.exe file and follow the wizard instructions to complete the installation.

After Installing
Visual COBOL and Enterprise Developer for Visual Studio
You are now ready to run Visual COBOL or Enterprise Developer. From the Windows taskbar click Start >
All Programs > Micro Focus Product Name > Product Name for Visual Studio.
Note: The Start menu is not available on Windows 8 and Windows Server 2012. You use the Start
screen to invoke programs.
Please refer to the Start Here and Product Information sections in your product Help. Here, you will find
information on getting started including tutorials and demonstration programs.
Note:
•

•
•

•

To view the help in Visual Studio 2012, ensure that the Visual Studio Help Library is pointing to
local help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help
Browser.
For full details of the Visual Studio Help system, see the locally installed Microsoft Help Viewer 2.0
Help, which is available from Help menu in the IDE.
In Visual Studio 2012, you may sometimes receive a message "Cannot find requested topic on
your computer" when you click Help > Micro Focus Product Help > Product Documentation.
You need to click Micro Focus Visual COBOL n.n for Visual Studio 2012 in the Contents tab to
display the documentation as expected.
If you install Visual COBOL for Visual Studio 2012 and its documentation is not available in the
Microsoft Help Viewer, perform the following:
1. In Visual Studio, click Help > Add and Remove Help Content.
2. Choose the Manage Content tab.

Micro Focus Academic Program 2.3 - Release Notes
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3. Check the Disk radio button, then navigate to the folder containing the Visual COBOL for Visual
Studio 2012 documentation. By default, this is %ProgramFiles(x86)%\Micro Focus
\Visual COBOL for Visual Studio 2012\help.
4. Select helpcontentsetup.msha, and click Open.
5. In the content list, click Add next to the Visual COBOL entry.
6. Click Update.
7. Click Yes on the User Account Control and Microsoft Help Viewer dialog boxes to enable the
update to continue.
The documentation for Visual COBOL for Visual Studio 2012 is added to the Microsoft Help
Viewer.
Note:
This problem only occurs if you install Visual COBOL while the documentation for Visual
Studio itself is being downloaded or updated. This might happen the first time you install or
run Visual Studio.
Visual COBOL and Enterprise Developer for Eclipse
If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installing any Micro Focus product. To pick up any new features, you must reset the COBOL
perspective after installation:
1. Open the existing workspace with this product.
2.
3.
4.
5.

You may receive some warnings or errors which you can ignore.
Make sure you are in the COBOL perspective by clicking Window > Open Perspective > COBOL.
Click Window > Reset Perspective.
Click OK.
Reapply any customizations.

Installing X Windows on Windows
Some features of Visual COBOL for Eclipse and Enterprise Developer for Eclipse on Windows require an X
Windows installation, so Micro Focus ViewNowX is provided with the product. To install, run the file
ViewNow_X_Server.exe in your Visual COBOL installation. By default this will be in the
%ProgramFiles(x86)%\Micro Focus\Visual COBOL for Visual Studio 2012\ViewNowX
folder.
ViewNowX requires that your client machine has Microsoft Visual C++ 2008 SP1 Redistributable Package
(x86) installed. If it is missing from your machine, the ViewNowX installation will offer a link to download the
package.

Repairing
Windows
If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.
To repair your installation on versions of Windows Vista or later:
1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.
UNIX
If a file in the installation of the product becomes corrupt, or is missing, we recommend that you reinstall
the product.

10
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Uninstalling
Windows
To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:
1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs in Control Panel.
3. Select the product and click Remove or Uninstall as appropriate.
When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.
Note: The installer creates separate installations for Visual COBOL, Enterprise Developer, Enterprise
Server for .NET, and Micro Focus License Administration. Uninstalling only Visual COBOL does not
automatically uninstall Enterprise Server for .NET, the Micro Focus License Manager or any of the
prerequisite software.
Enterprise Server for .NET must be uninstalled before you remove Visual COBOL. To completely
remove the product you must uninstall the Micro Focus License Manager as well.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.
Some registry entries are not removed by the uninstallation process and you need to manually delete
them.
The following folders might not be removed:
•
•
•
•

Micro Focus Product Name folder in the Start menu - you can delete it manually.
%systemdrive%\Users\Public\Documents\Micro Focus - includes the binaries and the log
files of the samples which you have built.
%ProgramData%\Micro Focus - includes some data files used by the Micro Focus licensing system.
%Program Files%\Micro Focus - you can delete it manually.

Known Issues
Refer to the Known Errors and Restrictions topic in the Product Information section of your product Help.
In addition, note the following:
Application Workflow Manager
•

•

In an Application Workflow Manager modelled action, you retrieve a file from the remote zOS system
directly into a COBOL project, you must set the text file encoding of the COBOL project to UTF-8 in the
project properties in order for the Compiler to correctly process the source code. To set the encoding, in
the project properties of the COBOL project and on the Micro Focus > Project Settings > COBOL,
specify the source-encoding(utf8) Compiler directive in the Additional directives field.
Sequential MVS files are not locked when opened from zExplorer or from an AWM model using the Edit
MVS File tool from the MVS function package. This means sequential MVS files can be opened in
parallel in write mode and could be mutually overwritten.

Debugging
Remote debugging does not work for programs running on AIX or HP machines, if you are trying to debug
using Visual COBOL installed on a Linux machine.

Micro Focus Academic Program 2.3 - Release Notes
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Documentation
•

•

In Visual Studio 2012, clicking Help > Micro Focus Product Help > Product Documentation results in
the message "Cannot find requested topic on your computer". If you see this message, click Micro
Focus Visual COBOL x. x for Visual Studio 2012 in the Contents tab to display the documentation as
expected.
If you install Visual COBOL for Visual Studio 2012 and its documentation is not available in the
Microsoft Help Viewer, perform the following steps:
1. In Visual Studio 2012, click Help > Add and Remove Help Content.
2. Choose the Manage Content tab.
3. Check the Disk radio button, then navigate to the folder containing the Visual COBOL for Visual
Studio 2012 documentation. By default, this is C:\Program Files (x86)\Micro Focus
\<product name>\help.
4. Select helpcontentsetup.msha and click Open.
5. In the content list, click Add next to the Visual COBOL entry.
6. Click Update.
7. Click Yes on the User Account Control and Microsoft Help Viewer 2.0 dialog boxes to enable the
update to continue.
The documentation for Visual COBOL for Visual Studio 2012 is added to the Microsoft Help Viewer.
Note:
This problem only occurs if you install Visual COBOL for Visual Studio 2012 while documentation
for Visual Studio 2012 is being downloaded or updated, which typically happens when you install
Visual Studio 2012 or run it for the first time.

•

•

The tutorial "Calling JVM COBOL programs as part of an Axis Web service" in the product help for
Visual COBOL 2.3 for Eclipse cannot be completed. This is due to unresolved configuration issues with
some third-party components. The tutorial is not available in the documentation available on the Micro
Focus Infocenter.
A known issue in JRE 1.7.0_45 (issue JDK-8028111) causes problems with searching and indexing the
help in the Eclipse help viewer if you are running Eclipse on a machine that has this version of JRE
installed.

Database Access
If you have a remote COBOL project under Eclipse that uses DB2 ECM in Visual COBOL or HCO for DB2
LUW in Enterprise Developer and the DB2 software is not installed on the client machine where you are
using the Eclipse IDE, you receive background parsing errors in your application. To resolve the issue, you
can do either one of the following:
•
•

Disable background parsing Window > Preferences > Micro Focus > COBOL > Editor and disabling
the checkbox for Background parsing.
Install the IBM DB2 client-side software on the machine on which you are running Eclipse. Go to the
IBM Support Home and locate the page entitled "IBM Download Fix Packs for IBM Data Server Client
Packages" .

Enterprise Server
•
•

12

The Historical Statistics Facility may generate incorrect records for SSTM-enabled enterprise servers.
On Windows 10, if you are using Microsoft's EDGE browser to access the Enterprise Server
Administration GUI, issues with EDGE can cause the automatic refresh feature to display a dialog
asking whether you want to resubmit a form. To work around this issue, cancel the resubmit request and
then refresh the server list page or the Home page of Enterprise Server Administration. You can also
turn off the automatic refresh by setting the Auto-refresh interval setting on the Home page of
Enterprise Server Administration to 0.
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•

Enterprise Server instances will fail to start if they have been configured with the MLDAP ESM module
to use external security and are started using Enterprise Server credentials that are not configured with
"user administration" privileges (that is they do not have an allow update ACE in the "User
Administration" security resource in the Enterprise Server Administration). A fix for this is available if you
install HotFix 1 of version 2.3. of this product.

IDE
•

•

If you are upgrading your license from Visual COBOL for Eclipse Personal Edition (v2.2 or earlier) to
Visual COBOL, or from Visual COBOL Connect (v2.2.1 or later) to Visual COBOL, any existing projects
compiled to either .exe or .dll files using the old license must be updated in order to recreate
the .cobolBuild file. You can do this done by adding or removing files from the project or by deleting
the .cobolBuild file. Updating the project in this way ensures Eclipse will fully build the executable
files.
When searching in Visual Studio using the Find in Files command, if Look in scope is set to COBOL
Project Copybook Paths, you might get a message that no files can be found and the search might
erroneously return no results.
To work around this issue, add the copybook folders you want to search to the solution and then, in the
Find and Replace dialog box, specify Entire Solution in the Look in field.
-2835506 (1101288)

•

•
•

When you add a COPY statement in a COBOL program and then show it in Expanded Copybook View,
the line for the copybook statement is read-only. If you then perform an Undo in the COBOL program,
the COPY statement is removed while the contents of the copybook is still shown in the program.
Replace All does not work inside the Expanded Copybook View
For copybooks with file extensions that are not traditionally associated with COBOL you must first add
the file extension to the list of known copybooks extensions in Tools > Options > Text Editor > File
Extensions before you can show them in Expanded Copybook View.

ICETOOL Emulation
ICETOOL emulation for managed code is not available in this release.
Linking
Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C object
code built with that version of Visual Studio in the same executable. In this scenario, you must use the
Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro Focus
cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might also need to
specify some additional C runtime libraries - see the Microsoft documentation for more details.
Note that when using COBOL and C object code together, Micro Focus recommends you build and keep
the COBOL and C executables separate, and use import libraries and the Micro Focus C functions for
calling COBOL (see "C functions for calling COBOL" in the product help) to resolve calls between them.
Micro Focus Rumba
On versions of Windows Vista and later, Enterprise Server listens only on the IPv4 loopback address
(127.0.0.1). As a result, an attempt to connect to localhost with a TN3270 emulator such as Micro Focus
Rumba may fail. To work around this issue, in your emulator's configuration use 127.0.0.1 in preference to
localhost or your host machine's name.
PL/I Support
•

The Micro Focus PL/I Macro Preprocessor supports the majority of the IBM PP(MACRO) functions. The
only support for PP(PLX) is for the deprecated KEYS option. There are no plans to further extend the
existing support for PLX.
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•

•

On SUSE, the PL/I CodeWatch debugger does not display output with MicroFocus ViewNowX. To
resolve this issue, you need to install a HotFix of ViewNowX - contact Micro Focus SupportLine for more
details.
Trying to debug remote PL/I projects that compile to 32-bit using the CodeWatch debugger fails. To work
around this issue, you must set the environment variable $COBMODE to COBMODE=32 on the remote
machine before you start the RDO daemon.

Resource Adapters
Trying to deploy the local resource adaptor mfcobol-localtx.rar to WebLogic may fail with a
ClassCastException. To work around this issue, you need to deploy mfcobol-xa.rar first, then need to
undeploy this file and deploy the local one, mfcobol-localtx.rar. If there are issues deploying using
the WebLogic GUI, you can use the command line. If there are issues with this as well, try reducing the
length of the command (for example, by moving the file to a location with a shorter path).
REST/JSON IMTK implementation and the same-origin policy (SOP)
HTTP requests sent from scripts within a web browser to REST services deployed on an enterprise server
might fail due to the same-origin policy (SOP). Some browsers might implement (or support plugins that
implement) techniques for relaxing SOP such as cross-origin resource sharing (CORS) that enable
sending cross-origin requests successfully. For REST services, Enterprise Server does not implement a
method for relaxing SOP. This means that browsers that implement CORS (or any other SOP relaxation
technique) might still forbid requests made from scripts due to Enterprise Server not implementing the
equivalent technique on the server side.
Setup
•

A problem with Microsoft's Windows 10 prevents installing the Visual Studio 2013 Shell on that version
of the OS. You must install an advanced edition of Visual Studio 2013 on Windows 10 before you start
the installation of Visual COBOL for Visual Studio 2013.

•

Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a
number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the
setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that there is
an advanced edition of Visual Studio 2015 installed on your machine.

z/Server
IBM's PTF UA75804 causes ISPF dialogs in a user server to stop working. If you have this PTF installed,
contact Micro Focus SupportLine to obtain a fix for this issue.
-2814867 (1098663)

Significant Changes in Behavior or Usage
This section describes significant changes in behavior or usage. These changes could potentially affect the
behavior of existing applications or impact the way the tools are used.
Where present, the numbers that follow each issue are the Support Incident Numbers followed by the
Reported Problem Incident (RPI) number (in parentheses).
•
•
•
•
•
•

14

AMB
Assembler Support
Building
Converting Additional Directives to Projects' Properties
CAS Security
CAS XA Switch modules
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•
•
•
•
•
•
•
•
•
•
•
•

Compiler
Data Tools
Discontinued Support for cwgui
File Handling - External File Handler
IDE
J2EE Connector
JCL Support
Mainframe Access
MF Server Administrator (GUI)
PL/I Support
SQL - HCO for SQL Server
Updated Run-Time System

AMB
Back to the list
•

Loading PSBs sometimes caused an error that prevented the building of DDI symbols required for
generation.
2813119 (1098471)

Assembler Support
Back to the list
•

Previously, the Assembler run-time error SOC4 (Invalid 370 address abend) was mapped to the COBOL
run-time error 200 (Internal logic error) which was misleading. It is now mapped to the COBOL run-time
error 205 (COBRT205 Invalid mainframe pointer value (Fatal)). Note that, in most cases, you receive an
Assembler SOC4 abend if the calling COBOL program was compiled without the AMODE(24) or the
AMODE(31) Compiler directives.
2806239 (1097738)

Building
Back to the list
•

Visual COBOL now supports Visual Studio parallel builds for COBOL projects. Parallel builds enable
you to build multiple projects faster on multi-CPU machines.
If, after upgrading to this version of Visual COBOL, you start receiving unexpected build errors when
compiling an existing multi-project solution, this may be a result of enabling support for parallel project
builds. These are a couple of examples of issues that might be causing these errors:
•

•

Using file references to project outputs in the same solution. You need to use project-to-project
references instead.
Use Project > Project Dependencies to manage the project dependencies and build order within
your solution.
A customized build process such as one that is using pre- or post- build events.

If resolving any of these issues does not help resolve the build errors, consider disabling the parallel
build support - click Tools > Options > Projects and Solutions > Build and Run and set maximum
number of parallel project builds to 1.
Note: Parallel builds are not supported with Personal Edition licensing or with Mainframe
Subsystem COBOL projects.
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Converting Additional Directives to projects' properties
Back to the list
Starting with this release, an Update Project Properties dialog box might start to appear when you are
opening existing COBOL solutions. The dialog box recommends converting some of the directives
specified in Additional directives to project's properties. This is to address an issue where you might try
to set file properties that differ from the project directives and the directives specified in Additional
directives that have a property equivalent take precedence over the file properties. As a result of this you
might receive unexpected build issues when building your applications.
This dialog box helps eliminate the issue by converting the directives specified in Additional directives to
project properties.
If you do not want the IDE to perform this check, click Tools > Options > Micro Focus > General and
uncheck Check Additional Directives for project properties.
CAS Security
Back to the list
•

The Enterprise Server External Security Facility now includes MLDAP ESM Module 2.0, with a new
algorithm for identifying the best-matching resource-access rule and ACE for resource-access security
checks. This algorithm is faster and matches most customers' expectations. The new algorithm also
provides an optional "username substitution" feature. It can be enabled by setting "rule substitutions" to
"yes" in the [Operation] section in the Security Manager configuration text area. When this is enabled,
the string "${user}" in a resource-rule name will be replaced with the name of the user that makes the
request. For example, a DATASET rule named "USERS.${user}.**" would apply to datasets with the
requesting user's name as the second qualifier. In rare cases, customers with complex, ambiguous
resource-access security rules might see experience changes in behavior as a result of the new
algorithm. The old algorithm is still supported and can be enabled by setting "version 1 authentication"
to "yes" in the [Operation] section of the Security Manager configuration.
2807531 (1097783)

CAS XA Switch modules
Back to the list
•

The XA switch modules now support dynamic registration.

•

2682101 (1092325)
The XA switch modules now support batch-only operations when multiple XA Resource Managers have
been defined.

•

2664675 (1091082)
In Visual COBOL 2.2 update 2, Micro Focus identified undefined run-time behavior when the following
combination of directives was specified: SIGN"EBCDIC", CHARSET"ASCII", and one of the following:
HOST-NUMMOVE, HOST-NUMCOMPARE or SIGN-FIXUP. Previously (Visual COBOL 2.2 update 1 and
earlier), if this combination was specified, the SIGN”EBCDIC” directive should have been ignored, to
avoid a mixture of ASCII and EBCDIC characters; however, SIGN”EBCDIC” was still being honored,
resulting in undefined run-time behavior. Therefore, this combination of directives is now invalid for
Visual COBOL 2.2 update 2 or later, and if specified, will be rejected at compile time.
2786397 (1095265)

Compiler
Back to the list
•

For native COBOL, the size limit of the Data Division now stands at 2GB -1.
2796076 (1096384)
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•

COBDATA has no effect on compilation. The output of the Compiler is the same location regardless of
whether COBDATA is set.
Previously, it was not possible to specify sign(EBCDIC) with sign-fixup, host-num-move or with hostnum-compare. This combination is now supported in native COBOL but remains invalid for managed
COBOL code. This is applicable to version 2.2 U2 HotFix 10 onwards.
2824577 (1100823)

Data Tools
Back to the list
•

DFCONV now returns the correct return-code; previously, it would always return 0.

Discontinued support for cwgui
Back to the list
The cwgui debugger is no longer available. You can now use the cw_java debugger which provides a richer
graphical debugging experience.
File Handling - External File Handler
Back to the list
•

Custom file handlers (using DYNREDIR) are now called for each part of a concatenated file.
2795077 (1096322)

IDE
Back to the list
•

•

•

•

Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C
object code built with that version of Visual Studio in the same executable. In this scenario, you must
use the Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro
Focus cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might
also need to specify some additional C runtime libraries - see the Microsoft documentation for more
details.
Note that when using COBOL and C object code together, Micro Focus recommends you build and
maintain the COBOL and C executables as separate projects, and use import libraries and the Micro
Focus C functions for calling COBOL (see "C functions for calling COBOL" in the product help) to
resolve calls between them.
The default warning level for new COBOL projects in Visual COBOL for Visual Studio is now "Include
recoverable errors (Level E)". This also includes "Severe errors only (Level S)" and unrecoverable (Level
U) errors. Micro Focus recommends you set the warning level on the COBOL page in a project's
properties to "Include warnings (Level W)" where appropriate to help avoid potential coding problems.
Visual COBOL for Eclipse now ships with Eclipse 4.4.2 (Luna). If your applications contain JVM COBOL
code that was built with a previous version of the product, those parts of your application must be
rebuilt; otherwise you will experience errors at either compilation or run time.
(609469)
A project can have one of two connection modes: NFS/Samba, where the target location is mounted as
a local drive, and RSE, which is a purely remote connection to the target location. For project types
such as Mainframe COBOL, NFS/Samba is required to use some tools which do not support RSE. For
most other projects, it is possible to switch between connection modes using the Remote Settings
context menu option. In the dialog box, there are radio buttons allowing for selection of connection
modes. On changing mode, you must select an existing connection of the appropriate type, or create a
new one. If switching to NFS/Samba mode, you must specify the local path to the project.
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•

2792882 (1096196)
By setting "-Denable.projectrepair=true" in the eclipse.ini file, .cobolProj and .pliProj files will be repaired
to reflect the workspace on project refresh.
2696707 (1095994)

J2EE Connector
Back to the list
•

This release provides a new command-line argument to Java, mf.ssl.algorithm, which can be set to an
appropriate algorithm.
2799213 (1096684)

JCL Support
Back to the list
•

•

•

•
•

•

•

•

When allocating a dataset to a step using MVSCTLBP, the values returned for the dataset attributes are
those defined in the catalog. If these are unset in the catalog, then the values defined in the
MVSCTLBP call are returned.
2816179 (1098882)
The program attributes for the SSTM job have been changed to default to a mainframe dialect, AMODE
31 program. These attributes will be used when constructing the MVS Control Blocks for the job, which
means that the pointers to the sub-block areas will be in mainframe format rather than native format.
2815695 (1098825)
Any OUTPUT statement information passed to the printer exit now includes the correct class of that
statement.
2814249 (1098636)
In ESMAC, when deleting the Spool, the physical spool files and the entries in casspool.dat are deleted.
2812899 (1098412)
New functionality has been added to the printer exit interface that enables you to delete the printer spool
file after a file has been printed. Set (ws)-prn-file-disp, which is defined in cascbprn.cpy, to 1 to delete
the spool file after printing. Additionally, the environment variable ES_JESYSMSG_OUTPUT=Y now
correctly routes spool files to the Output queue. Previously, ESMAC still showed the job on the HELD
display, even when there were no spool files HELD.
2812899 (1099966)
A new environment variable has been introduced - ES_JESYSMSG_RESTRICTED. JESYSMSG spool
files are normally routed to HELD. This can be overridden by setting the environment variable
ES_JESYSMSG_OUTPUT=Y, which causes all JESYSMSG spool files to be routed to OUTPUT. If
ES_JESYSMSG_OUTPUT=Y is set but you require specific classes to be held, set the environment
variable ES_JESYSMSG_RESTRICTED to a string containing the classes to be HELD.
2812878 (1098417)
The IEBDG PICTURE value length must match the length specified. The value can now contain any
characters including quotes as on the mainframe.
2794881 (1096221)
Changes to the IDCAMS ALTER processing prohibit applying MGMTCLASS changes to GDGs and to a
VSAM element other than a Cluster. Shareoption settings in a SMS DATACLASS are now applied to the
VSAM elements correctly.
2789939 (1095803)

JVM COBOL
Visual COBOL for Eclipse now ships with Eclipse 4.4.2 (Luna). A consequence of this is that if your
application also contains JVM COBOL code that was built with a version of Visual COBOL prior to version
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2.3, those parts of your application must be rebuilt; otherwise you will experience errors at either
compilation or run time.
Mainframe Access
Back to the list
Mainframe Access is now built using the IBM XL/C compiler rather than the SAS/C compiler that was used
previously. This change requires you to update your production JCL procedures with reference to the
supplied samples MFA, MFAS, and MFAAS. In each JCL procedure, change the STEPLIB DD statement
and add a new one, CEEOPTS.
The web administration feature is no longer available in Visual COBOL.
To use the Mainframe Access support for Endevor you must be using Endevor R14 or later. CA stabilized
the Endevor API at R14, so if you upgrade from R14 to a later version you will not need to update the
support module that Mainframe Access uses.
MF Server Administrator (GUI)
Back to the list
•

Passwords that entered through either the MFDS or the ESMAC interface now use the same encoding.
2792382 (1096011)

PL/I Support
Back to the list
•

•

•

•
•

•

•

For BASED variables declared using the form BASED (ADDR(x)), storage checking is now performed
on the base reference “x”. This behavior requires the compiler option –nolaxbased. See the Open-PLI
User guide for more information on the options –[no]laxbased and –[no]laxdefined.
2819663 (1099293)
The behavior of the –zp1 option has been reverted to that of before Enterprise Developer 2.2 Update 1,
with an additional correction relating to Char Varying data items. For a full description of the –zp1
option, refer to the Open-PLI User’s Guide in your product help. If you are installing ED 2.2 U1 HF5 as
an upgrade to ED 2.2 U1, you must rebuild any applications that are compiled using the –zp1 option
after the upgrade.
2789213 (1095636)
Previously, when using any of the complier options -mvs, -dli, -ims, or -cics, the BINARY attribute was
incorrectly applied if the FIXED attribute is specified without BINARY or DECIMAL. The default attribute
DECIMAL is now applied.
The BIGENDIAN attribute, when explicitly applied to a structure, is now propagated to its CHAR
VARYING and WIDECHAR VARYING members.
Declarations using DEFINED storage are now checked for compatible types between the DEFINED
variable and its base variable. This behavior requires the compiler option –nolaxdefined. See the OpenPLI User guide for more information on the options –[no]laxbased and –[no]laxdefined.
The PL/I Macro preprocessor has been enhanced to support the use of the ANSWER statement from
within a PL/I Macro.
2698537 (1094243)
The macro preprocessor has been enhanced to support arrays of CHAR and FIXED variables. New
macro builtin functions have been implemented (HBOUND, LBOUND, DIMENSION).
2696129 (1094011)

SQL: HCO for SQL Server
Back to the list
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•

The return type for the HCOSS DB2 CHAR() function has changed from CHAR(255) to
VARCHAR(255).
2804069 (1097253)

Updated Run-Time System
Back to the list
•

COBOL Server now provides an execution environment capable of running applications that were each
built using different development products. A consequence of this is that if your application has a main
COBOL executable (.exe) that was built with a version of Visual COBOL prior to version 2.3, you should
ensure that the executable is rebuilt and packaged with the new run-time system. This does not affect
mainframe subsystem projects deployed to COBOL Server. You can rebuild from the IDE or the
command line.
Other COBOL subprograms built with previous versions of Visual COBOL are not required to be rebuilt.

Disclaimer
This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either
express or implied, including the warranties of merchantability and fitness for a particular purpose. In no
event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect,
incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers
have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation
of liability for consequential or incidental damages so the foregoing limitation may not apply.
Micro Focus is a registered trademark.
Copyright © Micro Focus 1984-2015. All rights reserved.
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