Micro Focus Visual COBOL 2.2 for ISVs

Release Notes

Micro Focus
The Lawn
22-30 Old Bath Road
Newbury, Berkshire RG14 1QN
UK
http://www.microfocus.com

Copyright © Micro Focus 2009-2013. All rights reserved.
MICRO FOCUS, the Micro Focus logo and Visual COBOL are trademarks or registered
trademarks of Micro Focus IP Development Limited or its subsidiaries or affiliated
companies in the United States, United Kingdom and other countries.
All other marks are the property of their respective owners.
2013-10-22

ii

Contents
Micro Focus Visual COBOL 2.2 for ISVs Release Notes ................................ 5
System Requirements ........................................................................................6
System Requirements for Visual COBOL for Visual Studio ................................................ 6
Hardware Requirements .......................................................................................... 6
Operating Systems Supported ................................................................................. 6
Software Requirements ............................................................................................6
System Requirements for Visual COBOL for Eclipse (Windows) ....................................... 7
Hardware Requirements .......................................................................................... 7
Operating Systems Supported ................................................................................. 7
Software requirements ............................................................................................. 8
System Requirements for Visual COBOL for Eclipse (UNIX) ............................................. 8
Hardware Requirements .......................................................................................... 8
Operating Systems Supported ................................................................................. 8
Software Requirements ............................................................................................8
System Requirements for Visual COBOL Development Hub ........................................... 10
Hardware Requirements ........................................................................................ 10
Operating Systems Supported ............................................................................... 10
Software Requirements ..........................................................................................10

Installation

........................................................................................................ 12

Installing Visual COBOL for Visual Studio ........................................................................ 12
Installation restrictions and requirements ...............................................................12
Downloading the Product ....................................................................................... 13
Installing Visual COBOL for Visual Studio ..............................................................13
Installing as an Upgrade .........................................................................................13
After Installing .........................................................................................................13
Repairing ................................................................................................................ 14
Uninstalling .............................................................................................................14
Installing Visual COBOL for Eclipse (Windows) ................................................................15
Installation restrictions and requirements ...............................................................15
Downloading the Product ....................................................................................... 15
Installing ................................................................................................................. 15
Installing into different Eclipse packages ............................................................... 16
After Installing .........................................................................................................18
Installing X Windows on Windows ..........................................................................18
Repairing ................................................................................................................ 18
Uninstalling .............................................................................................................19
UNIX Installer Issues .........................................................................................................20
Installing Visual COBOL for Eclipse (UNIX) ......................................................................20
Downloading the Product ....................................................................................... 20
Installing ................................................................................................................. 20
Installing as an upgrade ......................................................................................... 21
Installing into different Eclipse packages ............................................................... 22
After Installing .........................................................................................................23
Configuring the Environment for Developing RDBMS Applications on UNIX .........23
Repairing ................................................................................................................ 23
Uninstalling .............................................................................................................23
Installing Visual COBOL Development Hub ......................................................................24
Downloading the Product ....................................................................................... 24
Installing ................................................................................................................. 24
Installing as an Upgrade .........................................................................................26
Configuring the Environment for Developing RDBMS Applications on UNIX .........26

Contents | 3

Configuring the Remote System Explorer Support
............................................... 27
Repairing on UNIX ................................................................................................. 28
Uninstalling .............................................................................................................28

Licensing Information

......................................................................................29

To activate Visual COBOL Personal Edition ..................................................................... 29
To request and activate a 30-day trial license for Visual COBOL ..................................... 30
To buy and activate a full unlimited license .......................................................................31
To start Micro Focus License Administration
................................................................... 32
Installing licenses .............................................................................................................. 32
If you have a license file ......................................................................................... 32
If you have an authorization code .......................................................................... 32

New Features in Visual COBOL 2.2

................................................................ 35

ACUCOBOL-GT Compatibility .......................................................................................... 35
Application configuration ................................................................................................... 35
COBOL Source Information (CSI) .....................................................................................35
Compiler Directives ........................................................................................................... 36
Converting Net Express projects .......................................................................................36
Debugging .........................................................................................................................36
Enhanced ACCEPT and DISPLAY Statements ..................................................... 37
Enhancements for Visual COBOL 2.2 for Visual Studio 2012 .......................................... 37
File Handling ..................................................................................................................... 38
Grouping files in virtual folders in Solution Explorer ..........................................................38
Interface Mapping Toolkit ..................................................................................................38
Managed COBOL ..............................................................................................................38
Problems View .................................................................................................................. 39
Searching in copybooks .................................................................................................... 39
COBOL editor enhancements ........................................................................................... 40
Support for SOA ................................................................................................................40
Upgrading from Net Express to Visual COBOL ................................................................ 40
WCF REST Service Application projects .......................................................................... 40
Windows Azure ...................................................................................................... 40
XML Extensions ................................................................................................................ 41

Known Issues ................................................................................................... 42
Significant Changes in Behavior or Usage ....................................................45
Resolved Issues ............................................................................................... 50
Updates and SupportLine ................................................................................70
Further Information and Product Support ..........................................................................70
Information We Need ........................................................................................................ 70
Creating Debug Files ........................................................................................................ 71

Disclaimer

4 | Contents

......................................................................................................... 72

Micro Focus Visual COBOL 2.2 for ISVs
Release Notes
The Micro Focus Visual COBOL for ISVs package comprises the following products which you can
download from your Electronic Product Delivery Note:
•

Visual COBOL for Visual Studio - delivers the richest development experience for COBOL programming
available on Windows using either Microsoft's Visual Studio 2010 or Visual Studio 2012 integrated
development environments. Visual COBOL supports the development and deployment of both
managed .NET and native code applications.
Note: The product is available in two variants - Visual COBOL for Visual Studio 2010, and Visual
COBOL for Visual Studio 2012.
Visual COBOL for Visual Studio 2010 and Visual COBOL for Visual Studio 2012 each target a
different version of the COBOL run-time system - COBOL Server 2010 and COBOL Server 2012
respectively.
Ensure that after you've edited the project in the preferred version of Visual Studio, you compile
your source code in that version of Visual COBOL which targets the version of the COBOL runtime in which you want your applications to run.

•

•

For example, if you build your application using Visual COBOL for Visual Studio 2010 you cannot
deploy the target files to COBOL Server 2012; you must use COBOL Server 2010.
Visual COBOL for Eclipse - provides an Eclipse-based integrated COBOL development environment for
Windows or Linux. Provides COBOL JVM support and enhanced compatibility with ACUCOBOL. Can
be used standalone for developing local applications or in conjunction with the Development Hub to
develop remote projects in Linux and UNIX.
Visual COBOL Development Hub - provides a rich desktop development environment based on the
Eclipse IDE with high-performance server-based tools for managing builds, source code access and
debugger engine. The Development Hub also provides a central administration site, simplifying the
development tool distribution and maintenance process.

These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.
Note: Visual COBOL now includes support for creating Web service and Enterprise Java Bean
applications using the Interface Mapping Toolkit (IMTK) in conjunction with Enterprise Server. If you
are upgrading to this release from an earlier version of Visual COBOL, you may need to apply for a
new authorization code in order to access the functionality - please contact Micro Focus SupportLine
to receive an updated authorization code. Note that the Visual COBOL Personal Edition license does
not support the IMTK functionality.
Note: This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link. Web
sites by their nature can change very rapidly and although we try to keep our links up-to-date, we
cannot guarantee that they will always work as expected.
Important: Application executables that were compiled using earlier Micro Focus products must be
recompiled from the sources using Visual COBOL.

Micro Focus Visual COBOL 2.2 for ISVs Release Notes
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System Requirements
System Requirements for Visual COBOL for Visual Studio
Hardware Requirements
Visual COBOL has the following requirements in addition to the requirements of Microsoft Visual Studio.
See the Visual Studio documentation for details of the Microsoft requirements.
The disk space requirements are:
Platform

Visual COBOL

Sentinel RMS License Manager

x86 Windows platforms

380MB

35MB

x64 Windows platforms

500MB

35MB

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

Operating Systems Supported
Note: If you are using Visual COBOL on a 64-bit operating system, you can produce either 32-bit or
64-bit applications.
For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.
Note:
•

Visual COBOL for Visual Studio 2012 is not supported on versions of Windows earlier than
Windows 7.

Software Requirements
Visual Studio IDE
This product requires any of the following versions of Visual Studio:
•

A full version of Microsoft Visual Studio 2010 or Microsoft Visual Studio 2012 (Premium, Professional,
or Ultimate), or the respective version of the Microsoft Visual Studio Integrated Shell.
Note:
•
•

•
•
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Microsoft Visual Studio Express Edition is not supported.
You can download the Visual Studio Integrated Shell from the Microsoft Download Center. If
you choose to install the Shell, ensure you run the installer to complete the installation - run
vsintshell.enu.exe from the location where you installed the download.
If you do not have any of these versions of Visual Studio installed, the setup file will install the Visual
Studio Integrated Shell.
Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft
Download Center and search for Windows SDK.
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•
•

Microsoft .NET Framework 4.0. This is included with the above versions of Visual Studio.
Microsoft .NET Framework 4.5. This is included with Visual Studio 2012.
Note:
•

•

Visual Studio 2010 Service Pack 1 is required if you are using Visual COBOL for Visual Studio
2010 and Visual COBOL for Visual Studio 2012 on the same machine. If you are connected to the
Internet, the setup file downloads and installs Visual Studio 2010 Service Pack 1 automatically. If
you do not have Internet access, you need to download Visual Studio 2010 Service Pack 1 on a
machine that has Internet connection, and then copy the installer to your machine.
In addition, when building a native COBOL project that contains resources you must replace the
cvtres.exe in the bin and bin64 directories of your Visual COBOL installation with the version
of the file which gets installed with Visual Studio 2010 SP1. You can download Service Pack 1 for
Visual Studio 2010 from the Microsoft Download Center.

Other Requirements
Important: This release requires version 10000.2.990 or later of the Micro Focus licensing software.
For local servers, you do not need to install it separately, as the setup file installs a new Visual
COBOL client and a new licensing server on the same machine.
If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus Licensing System Administration tool. To check the version of the license server on UNIX,
run /var/microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.
You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

System Requirements for Visual COBOL for Eclipse
(Windows)
Hardware Requirements
Visual COBOL has the following requirements in addition to the requirements of Eclipse. See the Eclipse
documentation for details of its requirements.
The disk space requirements for Windows are:
Platform

Visual COBOL

Sentinel RMS License Manager

x86 Windows platforms

1.05GB

35MB

x64 Windows platforms

1.2GB

35MB

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

Operating Systems Supported
Note: You can produce 64-bit and 32-bit applications on 64-bit operating systems.
For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

System Requirements
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Software requirements
Note: The setup file will check your machine for whether the prerequisite software is installed and will
install any missing prerequisites and the product components.
Important: This release requires version 10000.2.990 or later of the Micro Focus licensing software.
For local servers, you do not need to install it separately, as the setup file installs a new Visual
COBOL client and a new licensing server on the same machine.
If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus Licensing System Administration tool. To check the version of the license server on UNIX,
run /var/microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.
You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

System Requirements for Visual COBOL for Eclipse
(UNIX)
Hardware Requirements
Visual COBOL has the following requirements in addition to the requirements of Eclipse. See the Eclipse
documentation for details of its requirements.
The disk space requirements are approximately:
Platform

Visual COBOL

Sentinel RMS license server

x86-64 running Red Hat Linux

664MB

33MB

x86-64 running SuSE SLES

666MB

33MB

Note: The installation requires extra disk space that equals the size of the product you install.

Operating Systems Supported
Note: You can produce 64-bit and 32-bit applications on 64-bit operating systems.
For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

Software Requirements
Before installing this product, you must have the following software installed on your computer:
•
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The Korn shell is required for the licensing daemon. After the installation, if the licensing daemon does
not start, check and ensure the Korn shell is installed and then run the /var/
microfocuslicensing/bin/startmfcesd.sh script to start the daemon.
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•

•

The pax archiving utility is required by the setup file. Pax is distributed with most UNIX/Linux systems
but, if it is missing, you must install it separately. To verify pax is installed, run pax --help or pax -version at the command line.
On Red Hat 6.x, you must have the following operating system libraries installed:
All Visual COBOL products

Additional libraries for Visual COBOL for Eclipse

Additional libraries for Micro Focus Visual COBOL
Development Hub

glibc-*.x86_64
glibc-*.i686
libgcc-*.x86_64
libgcc-*.i686
PackageKit-gtk-module-*.x86_64
PackageKit-gtk-module-*.i686
gtk2-*.x86_64
gtk2-*.i686
gtk2-engines.*.x86_64
gtk2-engines.*.i686
libXtst-*.x86_64
libXtst-*.i686
libcanberra-gtk2-*.x86_64
libcanberra-gtk2-*.i686
webkitgtk.x86_64
webkitgtk.i686
xterm (any version)
libgnome.x86_64
libgnome.i686
glibc-devel-*.x86_64
glibc-devel-*.i686

Visit the Red Hat Web site for more information.
•

Xterm, the terminal emulator for the X Window System, is part of your UNIX/Linux distribution but is not
installed by default. Use your UNIX/Linux installation media to install it.
Important: This release requires version 10000.2.990 or later of the Micro Focus licensing software.
For local servers, you do not need to install it separately, as the setup file installs a new Visual
COBOL client and a new licensing server on the same machine.
If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus Licensing System Administration tool. To check the version of the license server on UNIX,
run /var/microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.
You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

Before you start the installation, you need to set the environment as follows:
•

You need to set the JAVA_HOME environment variable. When installing the product, set this variable to
a 32-bit Java installation or the installation terminates. For example, execute the following:
JAVA_HOME=java_install_dir
where java_install_dir is the path to the JAVA installation directory such as /usr/java/javan.n

System Requirements
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•

You need to add $JAVA_HOME/bin to your system PATH variable. To do this, execute:

•

export PATH=$JAVA_HOME/bin:$PATH
You need to set the LANG environment variable to pick up localized messages. The LANG settings are
English and Japanese only.

System Requirements for Visual COBOL Development
Hub
Hardware Requirements
The disk space requirements are approximately:
Platform

Micro Focus Visual COBOL
Development Hub (MB)

Sentinel RMS license server (MB)

POWER running AIX

359

26

HP IA

714

54

System Z running Red Hat Linux

296

28

x86-64 running Red Hat Linux

323

33

SPARC running Solaris

393

31

x86-64 running Solaris

327

23

System Z running SuSE SLES

300

28

x86-64 running SuSE SLES

324

33

Note: The installation requires extra disk space that equals the size of the product you install.

Operating Systems Supported
For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

Software Requirements
Before installing this product, you must have the following software installed on your computer:
•

•

•

The Korn shell is required for the licensing daemon. After the installation, if the licensing daemon does
not start, check and ensure the Korn shell is installed and then run the /var/
microfocuslicensing/bin/startmfcesd.sh script to start the daemon.
The pax archiving utility is required by the setup file. Pax is distributed with most UNIX/Linux systems
but, if it is missing, you must install it separately. To verify pax is installed, run pax --help or pax -version at the command line.
On Red Hat 6.x, you must have the following operating system libraries installed:
All Visual COBOL products
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glibc-*.x86_64
glibc-*.i686
libgcc-*.x86_64
libgcc-*.i686

Additional libraries for Visual COBOL for Eclipse

Additional libraries for Micro Focus Visual COBOL
Development Hub

PackageKit-gtk-module-*.x86_64
PackageKit-gtk-module-*.i686
gtk2-*.x86_64
gtk2-*.i686
gtk2-engines.*.x86_64
gtk2-engines.*.i686
libXtst-*.x86_64
libXtst-*.i686
libcanberra-gtk2-*.x86_64
libcanberra-gtk2-*.i686
webkitgtk.x86_64
webkitgtk.i686
xterm (any version)
libgnome.x86_64
libgnome.i686
glibc-devel-*.x86_64
glibc-devel-*.i686

Visit the Red Hat Web site for more information.
•

Xterm, the terminal emulator for the X Window System, is part of your UNIX/Linux distribution but is not
installed by default. Use your UNIX/Linux installation media to install it.
Important: This release requires version 10000.2.990 or later of the Micro Focus licensing software.
For local servers, you do not need to install it separately, as the setup file installs a new Visual
COBOL client and a new licensing server on the same machine.
If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus Licensing System Administration tool. To check the version of the license server on UNIX,
run /var/microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.
You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

Before you start the installation, you need to set the environment as follows:
•

•
•

You need to set the JAVA_HOME environment variable. When installing the product, set this variable to
a 32-bit Java installation or the installation terminates. For example, execute the following:
JAVA_HOME=java_install_dir
where java_install_dir is the path to the JAVA installation directory such as /usr/java/javan.n
You need to add $JAVA_HOME/bin to your system PATH variable. To do this, execute:
export PATH=$JAVA_HOME/bin:$PATH
You need to set the LANG environment variable to pick up localized messages. The LANG settings are
English and Japanese only.

System Requirements
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Installation
Installing Visual COBOL for Visual Studio
Installation restrictions and requirements
Before starting the installation you should consider the following:
•

•

•
•

•

If, when you install Visual COBOL for Visual Studio 2010, the machine does not have Microsoft Visual
C++ 2010 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2010 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.
If, when you install Visual COBOL for Visual Studio 2012, the machine does not have Microsoft Visual
C++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2012 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.
If you are installing this as an upgrade, make sure that none of the product files are in use when you
start the installation. Also, the Visual Studio Help Viewer must not be opened.
You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.
Before installing this product, make sure that any existing Micro Focus Directory Server (MFDS) or
CCITCP2 Windows service (on Windows) or a process (on UNIX) from an existing product is stopped
and uninstalled. On Windows, do this as follows:
1. Stop the MFDS and CCITCP2, using either the Windows Service Management Console GUI
(services.msc) or from a command line prompt by typing:
net stop mf_ccitcp2
Only one instance of the MFDS or CCITCP2 service can run on a Windows machine.
2. Uninstall the MFDS or CCITCP2 service.
For MFDS, from a command line prompt enter: mfds -u
For CCITCP2: ccitcp2 -u
To run an earlier version of MFDS as a service after you have installed a later version:
1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:
a. Open a Visual COBOL command prompt.
b. Install the service. Enter the following command: mfds -i
c. Start the service. Enter the following command: net start mf_ccitcp2
Note: The two versions use different paths for environment and registry values, so the list of
configured enterprise servers might be different depending on which version has been started,
since, by default, different MFDS data repositories are used.
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MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier
versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later
versions.
It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the
"mfcobol" port is used (86) and this can only be used by one process at a time

Downloading the Product
1. Use the download links in your Electronic Product Delivery email.
For more information follow the links for the installation instructions and the End User License
Agreement.

Installing Visual COBOL for Visual Studio
To install this product:
1. Run the vcvs2010_22.exe (or vcvs2012_22.exe when installing the product for Visual Studio
2012) file and follow the wizard instructions to install the prerequisite software and the product.
Note:
•

•
•
•

If you are installing onto a machine that has an existing Micro Focus product that uses an older
Sentinel RMS License Manager, you might be prompted to remove it and install the Micro Focus
License Administration. By doing this you maintain the existing Sentinel RMS license files while
adding the Micro Focus License Administration. If you are unsure about existing licenses on your
computer or removing the Sentinel RMS License Manager, consult your System Administrator. If
you want to proceed, remove Sentinel RMS License Manager by using Add or Remove
Programs (Windows XP) or Program and Features (Windows Vista or later), and rerun the
installation file.
Trial licenses cannot be used with remote desktop services. If you want to use your product in this
way, please contact Micro Focus SupportLine to obtain a relevant license.
We recommend that you install any updates for Visual Studio and the .NET Framework that are
available at the Microsoft Download site.
If you install JDK you might be prompted to install the latest update. The latest update is not
required for use with Visual COBOL but you can install it if you wish.

Installing as an Upgrade
This release will update existing installations of Visual COBOL for Visual Studio, versions 2.1 and 2.1
Update 1.

After Installing
You are now ready to run Visual COBOL. From the Windows taskbar click Start > All Programs > Micro
Focus Visual COBOL > Visual COBOL for Visual Studio nnnn.
Note: The Start menu is not available on Windows 8 and Windows Server 2012. You use the Start
screen to invoke programs.
Note: For applications created with earlier Micro Focus products or earlier versions of Visual COBOL,
note the following:
Database Access

Managed applications using SQL(DBMAN=ODBC) that were compiled in
Visual COBOL 2.1 Update 1 must be recompiled in Visual COBOL 2.2.

Installation
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Existing
Applications

Application executables that were compiled using earlier Micro Focus products
must be recompiled from the sources using Visual COBOL.

Please refer to the Start Here and Product Information sections in your product Help. Here, you will find
information on getting started including tutorials and demonstration programs.
Note:
•

•

•
•

•

•
•

The first release of Visual Studio 2010 has a browser-based help system, Microsoft Help Viewer
1.0, which does not include an index for the locally-installed help. Navigation of the content is only
available using the table of contents and Search and the help contents for the Help system does
not expand and collapse in the same way as previous Help systems.
If you have problems trying to view the Micro Focus help, ensure that the Visual Studio Help
Library is pointing to local help. From the Visual Studio menu click Help > Manage Help Systems
> Choose online or local help and check the I want to use local help button.
Visual Studio 2010 SP1 provides an upgrade of the help system, Microsoft Help Viewer 1.1, which
provides a stand-alone help viewer with an index and a fully expandable table of contents.
If you do not want to install Visual Studio 2010 SP1, you can install some third-party tools that
enable the index or the fully expanding table of contents. For more information, see the topic Help
on Help.
To view the help in Visual Studio 2012, ensure that the Visual Studio Help Library is pointing to
local help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help
Browser.
For full details of the Visual Studio 2012 Help system, see the locally installed Microsoft Help
Viewer 2.0 Help, which is available from Help menu in the IDE.
On Windows 8 and Windows Server 2012, an issue with Microsoft Help Viewer 2.0 and Internet
Explorer's security being turned on can cause the Help content to be displayed as raw HTML
code. To resolve the issue, you need to turn off the Internet Explorer Enhanced Security
Configuration (IE ESC) for both administrators and users. Check the Microsoft Windows help for
more information on how to do this.

Repairing
If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.
To repair your installation on versions of Windows Vista or later:
1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.
To repair your installation on older versions of Windows, such as Windows XP:
1.
2.
3.
4.

Click Start Menu > Control Panel > Add/Remove Programs.
Click your Micro Focus product in the list of installed programs.
Click Click here for support information.
Click Repair.

Uninstalling
Windows
To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:
1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs (or Add/Remove Programs on older versions of
Windows) in Control Panel.

14

| Installation

3. On older versions of Windows such as Windows XP, ensure that Show Updates (at the top of the Add
or Remove Programs dialog) is checked, so that any hot fixes or WrapPacks are listed.
4. Select the product and click Remove or Uninstall as appropriate.
When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.
Note: The installer creates separate installations for Micro Focus Visual COBOL and Micro Focus
License Administration. Uninstalling only Visual COBOL does not automatically uninstall the Micro
Focus License Administration or any of the prerequisite software.
To completely remove the product you must uninstall the Micro Focus License Administration as well.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.
Some registry entries are not removed by the uninstallation process and you need to manually delete
them.
The following folders might not be removed:
•
•
•
•

The Micro Focus Product Name folder in the Start menu - you can delete it manually.
%systemdrive%\Users\Public\Documents\Micro Focus - includes the binaries and the log
files of the samples which you have built.
%ProgramData%\Micro Focus - includes some data files used by the Micro Focus licensing system.
%Program Files%\Micro Focus - you can delete it manually.

In addition, the following registry entries are not removed. These are created the first time that an
Enterprise Server that has been enabled for performance monitoring starts up:
•
•

Micro Focus Server\Performance\Active Servers
Micro Focus Server\Performance\PerfIniFile

Installing Visual COBOL for Eclipse (Windows)
Installation restrictions and requirements
Before starting the installation, you should consider the following:
•
•

Visual COBOL and COBOL Server cannot coexist on the same machine.
Visual COBOL and Enterprise Developer cannot coexist on the same machine.

Downloading the Product
1. Use the download links in your Electronic Product Delivery email.
For more information follow the links for the installation instructions and the End User License
Agreement.

Installing
These are the steps to install this product:
1. Run the vce_22.exe file and follow the wizard instructions to complete the installation.
A full version of Eclipse, with the Micro Focus plugins already installed, will be present in the C:\Users
\Public\Micro Focus\Product Name\eclipse directory. On older versions of Windows, Eclipse
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might be installed in a different folder, such as for Windows XP, in %ProgramFiles(x86)%\Micro
Focus\Visual COBOL\eclipse.
Note:
•

If you are installing onto a machine that has an existing Micro Focus product that uses an older
Sentinel RMS License Manager, you might be prompted to remove it and install the Micro Focus
License Administration. By doing this you maintain the existing Sentinel RMS license files while
adding the Micro Focus License Administration. If you are unsure about existing licenses on your
computer or removing the Sentinel RMS License Manager, consult your System Administrator. If
you want to proceed, remove Sentinel RMS License Manager by using Add or Remove
Programs (Windows XP) or Program and Features (Windows Vista or later), and rerun the
installation file.
Trial licenses cannot be used with remote desktop services. If you want to use your product in this
way, please contact Micro Focus SupportLine to obtain a relevant license.
We recommend that you install any updates for Visual Studio and the .NET Framework that are
available at the Microsoft Download site.
If you install JDK you might be prompted to install the latest update. The latest update is not
required for use with Visual COBOL but you can install it if you wish.

•
•
•

Installing into different Eclipse packages
Micro Focus Visual COBOL uses Eclipse 3.8, but it will also work with Eclipse 3.7. If you want to use Visual
COBOL in Eclipse packages based on version 3.7, you must also install the Visual COBOL update site,
and the RSE and AspectJ plugins. The following sections show how to install into Eclipse 3.8 and into
Eclipse 3.7.
Important: We recommend you back up all existing Eclipse configuration files first.

Installing into Eclipse 3.8
1. Install Visual COBOL.
2. Copy the required Visual COBOL resources to your existing Eclipse as follows:
a. Extract the contents of the following .zip files in %ProgramFiles(x86)%\Micro Focus
\Visual COBOL\eclipse\installer (Windows) or /opt/microfocus/<product>/
eclipse (UNIX) to a temporary folder:
ajdt_2.2.2_for_eclipse_4.2.zip
RSE-runtime-3.3.zip
dtp_1.10.2.zip
emf-runtime-2.8.3.zip
emf-transaction-runtime-1.6.0M7.zip
emf-validation-runtime-1.6.0M7.zip
GEF-runtime-3.8.2.zip
org.eclipse.graphiti.site_0.9.2.201302110913.zip
wtp4x-R-3.4.2-20130208151217.zip
xsd-runtime-2.8.3.zip
b. Copy the extracted folders to <your existing Eclipse>\eclipse\dropins (Windows) or
<your existing Eclipse>/eclipse/dropins (UNIX).
c. Rename each of the folders:
•
•
•
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From ajdt_2.2.2_for_eclipse_4.2 to AJDTUpdateSite
From RSE-runtime-3.3 to RSEUpdateSite
From EDUpdateSite to COBOLUpdateSite

•
•
•
•
•
•

From dtp_1.10.2/eclipse to DTPUpdateSite
From emf-runtime-2.8.3/eclipse to EMFUpdateSite
From emf-transaction-runtime-1.6.0M7/eclipse to EMFTransactionUpdateSite
From emf-validation-runtime-1.6.0M7.eclipse to EMFValidationUpdateSite
From GEF-runtime-3.8.2/eclipse to GEFUpdateSite
From org.eclipse.graphiti.site_0.9.2.201302110913/eclipse to
GraphitiUpdateSite
• From wtp4x-R-3.4.2-20130208151217/eclipse to WTPUpdateSite
• From xsd-runtime-2.8.3.zip to XSDUpdateSite
Edit
the eclipse.ini file in <your existing Eclipse>\eclipse (Windows) or <your
d.
existing Eclipse>/eclipse (UNIX):
•

•

Add
Dosgi.framework.extensions=reference:file:../dropins/AJDTUpdateSite/
plugins/org.eclipse.equinox.weaving.hook_1.0.200.I20130127-2000.jar
as a property at the end of the file
Add
Dosgi.bundles=reference:file:../dropins/AJDTUpdateSite/plugins/
org.eclipse.equinox.weaving.aspectj_1.0.200.I20130127-2000.jar@2:start,
reference:file:
../plugins/
org.eclipse.equinox.simpleconfigurator_1.0.301.v20120914-163612.jar@1
as a property at the end of the file.

Note: There is an eclipse.ini in the %ProgramFiles(x86)%\Micro Focus\Visual
COBOL (Windows) or $COBDIR (UNIX) folder but it might conflict with the existing
eclipse.ini in your existing installation. You need to decide which pieces are relevant.
3. Restart Eclipse at the command line with the -clean option.
Installing into Eclipse 3.7
1. Install Visual COBOL.
2. Copy the required Visual COBOL resources to your existing Eclipse as follows:
1. From the http://www.eclipse.org website, locate the following packages from the project download
archive:
• ajdt_2.1.3_for_eclipse_3.7.zip
• RSE-runtime-3.3.zip
2. Copy the extracted folders to <your existing Eclipse>\eclipse\dropins (Windows) or
<your existing Eclipse>/eclipse/dropins (UNIX).
3. Copy %ProgramFiles(x86)%\Micro Focus\Visual COBOL\UpdateSite (Windows) or
$COBDIRUpdateSite (Windows) or to <your existing Eclipse>\eclipse\dropins
\COBOL\UpdateSite (Windows) or <your existing Eclipse>/eclipse/dropins/COBOL/
UpdateSite (UNIX).
4. Rename each of the folders:
• From ajdt_2.1.3_for_eclipse_3.7 to AJDTUpdateSite
• From RSE-runtime-3.3 to RSEUpdateSite
5. Move the the contents of the <your existing Eclipse>\eclipse\dropins
\RSEUpdateSite\eclipse (Windows) or <your existing Eclipse>/eclipse/dropins/
RSEUpdateSite/eclipse (UNIX) folder up a level (that is, to <your existing Eclipse>
\eclipse\dropins\RSEUpdateSite (Windows) or <your existing Eclipse>/eclipse/
dropins/RSEUpdateSite (UNIX)) and delete the empty folder.
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6. You might need to edit the eclipse.ini file in <your existing Eclipse>\eclipse
(Windows) or <your existing Eclipse>/eclipse (UNIX):
•

•

Add
-Dosgi.framework.extensions=reference:file:../dropins/AJDTUpdateSite/
plugins/org.eclipse.equinox.weaving.hook_1.0.100.HEAD.jar
as a property at the end of the file
Add
-Dosgi.bundles=reference:file:../dropins/AJDTUpdateSite/plugins/
org.eclipse.equinox.weaving.aspectj_1.0.1.HEAD.jar@2:start,reference:fi
le:
../plugins/
org.eclipse.equinox.simpleconfigurator_1.0.200.v20110502-1955.jar@1:sta
rt

as a property at the end of the file
3. Restart Eclipse at the command line with the -clean option.

After Installing
If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installing any Micro Focus product. To pick up any new features, you must reset the COBOL
perspective after installation:
1. Open the existing workspace with this product.
2.
3.
4.
5.

You may receive some warnings or errors which you can ignore.
Make sure you are in the COBOL perspective by clicking Window > Open Perspective > COBOL.
Click Window > Reset Perspective.
Click OK.
Reapply any customizations.
Note: For applications created with earlier Micro Focus products or earlier versions of Visual COBOL,
note the following:
Database Access

Managed applications using SQL(DBMAN=ODBC) that were compiled in
Visual COBOL 2.1 Update 1 must be recompiled in Visual COBOL 2.2.

Existing
Applications

Application executables that were compiled using earlier Micro Focus products
must be recompiled from the sources using Visual COBOL.

Installing X Windows on Windows
Some features of Visual COBOL for Eclipse on Windows require an X Windows installation, hence Micro
Focus ViewNowX is provided with the product. To install, run the file ViewNow_X_Server.exe in your
Visual COBOL installation. By default this will be in the %ProgramFiles(x86)%\Micro Focus\Visual
COBOL\ViewNowX folder.
ViewNowX requires that your client machine has Microsoft Visual C++ 2008 SP1 Redistributable Package
(x86) installed. If it is missing from your machine, the ViewNowX installation will offer a link to download the
package.

Repairing
If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.
To repair your installation on versions of Windows Vista or later:
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1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.
To repair your installation on older versions of Windows, such as Windows XP:
1.
2.
3.
4.

Click Start Menu > Control Panel > Add/Remove Programs.
Click your Micro Focus product in the list of installed programs.
Click Click here for support information.
Click Repair.

Uninstalling
Windows
To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:
1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs (or Add/Remove Programs on older versions of
Windows) in Control Panel.
3. On older versions of Windows such as Windows XP, ensure that Show Updates (at the top of the Add
or Remove Programs dialog) is checked, so that any hot fixes or WrapPacks are listed.
4. Select the product and click Remove or Uninstall as appropriate.
When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.
Important: The installer creates separate installations for Micro Focus Visual COBOL and Micro
Focus License Administration. Uninstalling only Visual COBOL does not automatically uninstall the
Micro Focus License Administration or any of the prerequisite software.
To completely remove the product you must uninstall the Micro Focus License Administration as well.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.
UNIX
Note: Before you uninstall the product, ensure that the Enterprise Server instances and the Micro
Focus Directory Service (MFDS) are stopped.
To uninstall this product:
1. Execute as root the Uninstall_VisualCOBOL2.2.sh script in the $COBDIR/bin directory.
Note: The installer creates separate installations for the product and for Micro Focus License
Administration. Uninstalling the product does not automatically uninstall the Micro Focus License
Administration or the prerequisite software. To completely remove the product you must uninstall the
Micro Focus License Administration as well.
To uninstall Micro Focus License Administration:
1. Execute as root the UnInstallMFLicenseServer.sh script in the /var/
microfocuslicensing/bin directory.
The script does not remove some of the files as they contain certain system settings or licenses.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.
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UNIX Installer Issues
Licensing
Daemon

If the Korn shell is not installed on your machine when you run the installer, the
licensing daemon will not be started. To resolve this after you install the product, install
the Korn shell and then run the /var/microfocuslicensing/bin/
startmfcesd.sh script to start the daemon.

License
Infrastructure
Installer

On some Solaris platforms, you can receive the following error message when SafeNet
license server needs to be installed or upgraded on your machine:
tar: /safenet.tar: No such file or directory
To resolve this issue, wait for the installation to complete and then perform the
following:
1. Navigate to the safenet directory in the COBDIR location.
2. With superuser permissions execute: ./MFLicenseServerInstall.sh

License Server You need to configure the computer hostname to ensure the license server will start
properly.
To avoid performance issues, "localhost" and the computer hostname must not both be
mapped to IP address 127.0.0.1. You should only map "localhost" to IP address
127.0.0.1.
The following is an example of how to specify these entries correctly in the etc/hosts
file:
127.0.0.1 localhost.localdomain localhost
IP machinelonghostname machineshorthostname
where IP is the unique IP address of the computer in xx.xx.xx.xx format.

Installing Visual COBOL for Eclipse (UNIX)
Downloading the Product
1. Use the download links in your Electronic Product Delivery email.
For more information follow the links for the installation instructions and the End User License
Agreement.

Installing
These are the steps to install this product:
1. Give execute permissions to the setup file:
chmod +x setup_visualcobol_deveclipse_2.2_platform
2. Run the setup file with superuser permissions:
./setup_visualcobol_deveclipse_2.2_platform
If you don't run this as superuser, you are prompted to enter the superuser password during the install.
The COBOL environment is installed by default into /opt/microfocus/product-name, (COBDIR).
A full version of Eclipse, with the Micro Focus plugins already installed, is present in the $COBDIR/
eclipse directory.
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To install in a different location use the -installlocation="Location" parameter to specify an
alternative directory location. For example:
./setup_visualcobol_deveclipse_2.2_platform -installlocation="full path of
new location"
You can see details about which additional parameters can be passed to the install script if you enter
the -help option.
Note:
•

•

The installation of this product could affect the SafeNet Sentinel licensed components running
on your machine. During installation licensing is shutdown to allow files to be updated. To
ensure the processes running on your machine are not affected, you need to use the skipsafenet option, which skips the installation of SafeNet:
./setup_visualcobol_deveclipse_2.2_platform -skipsafenet
To protect the SafeNet Sentinel installation from accidental updating you can create an empty
file named SKIP_SAFENET_INSTALL in /var/microfocuslicensing/ as follows:
touch /var/microfocuslicensing/SKIP_SAFENET_INSTALL
While the file is present, the SafeNet installer does not make changes to the installation or
shutdown the running license daemons. If licensing needs to be updated later, remove the file
and install Sentinel RMS server manually.

When you have installed the product, you need to set the environment as described below.
1. To set up your product, execute:
. /opt/microfocus/VisualCOBOL/bin/cobsetenv
To
verify that your product is installed, execute:
2.
cob -V
Important: These commands set the environment only for the current shell. You need to execute
them for each new shell that you start.
To avoid having to run cobsetenv for every shell, add these commands to the shell initialization files
(such as etc/profile, etc/bashrc).
Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.
Start the Product
To start Eclipse:
1. Double-click the product icon (automatically installed on your desktop).
Note: The installer automatically creates a shortcut icon for the product on the desktop for the user
for which you ran the install script. If you need to create desktop icons for other users' desktops on
the same machine, or if the icon was not created on the desktop for the root user, run the following
shell script as the user you need to login as:
$COBDIR/bin/createdesktopicon.sh

Installing as an upgrade
This release works concurrently with the previous version of Visual COBOL, so you do not need to uninstall
it. There are two options for installing the latest version in this case:
•

Move the existing installation to a different location and install the latest version to the default install
location specified by the COBDIR environment variable ( /opt/microfocus/VisualCOBOL, by
default).
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This ensures you do not need to change your environment. To move the existing older installation to a
different location:

•

1. Execute the following command as root:
mv /opt/microfocus/VisualCOBOL /opt/microfocus/VisualCOBOLversion
2. Install the latest version as described in the section Installing.
Install the latest version in a different location and set the environment to point to it. To do this, run the
Visual COBOL installer with the –installlocation option:
1. Execute the following command:
. /InstallFile -installlocation="/opt/microfocus/VisualCOBOL"
Note: You can use variables or the tilde syntax for the path for –installlocation. For
example, the following examples are equivalent:
-installlocation="/home/myid/installdir"
-installlocation="~myid/installdir"
-installlocation="~/installdir"
-installlocation="$HOME/installdir"
2. Execute cobsetenv to set the environment and point to the new install location:
. /opt/microfocus/VisualCOBOL/bin/cobsetenv
Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.

Installing into different Eclipse packages
Micro Focus Visual COBOL uses Eclipse 3.8, but it will also work with Eclipse 3.7. If you want to use Visual
COBOL in Eclipse packages based on version 3.7, you must also install the Visual COBOL update site,
and the RSE and AspectJ plugins. The following sections show how to install into Eclipse 3.8 and into
Eclipse 3.7.
Important: We recommend you back up all existing Eclipse configuration files first.
1. Install Visual COBOL as directed above.
2. Copy the required Visual COBOL resources to your existing Eclipse as follows:
For UNIX environments
1. Extract the contents of the following .zip files in /opt/microfocus/VisualCOBOL/eclipse to
a temporary folder:
• ajdt_2.1.3_for_eclipse_3.7.zip
• RSE-runtime-3.3.zip
• UpdateSite.zip
2. Copy the extracted folders to <your existing Eclipse>/eclipse/dropins.
3. Rename each of the folders:
• From ajdt_2.1.3_for_eclipse_3.7 to AspectJUpdateSite
• From RSE-runtime-3.3 to RSEUpdateSite
• From UpdateSite to COBOLUpdateSite
4. Move the the contents of the <your existing Eclipse>/eclipse/dropins/
RSEUpdateSite/eclipse folder up a level (that is, to <your existing Eclipse>/eclipse/
dropins/RSEUpdateSite) and delete the empty folder.
5. Copy the eclipse.ini file in /opt/microfocus/VisualCOBOL/eclipse/eclipse to <your
existing Eclipse>/eclipse, overwriting the existing file.
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6. If necessary, edit eclipse.ini so that the -vm parameter is set to the requisite Java folder.
3. Restart Eclipse.

After Installing
If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installing any Micro Focus product. To pick up any new features, you must reset the COBOL
perspective after installation:
1. Open the existing workspace with this product.
2.
3.
4.
5.

You may receive some warnings or errors which you can ignore.
Make sure you are in the COBOL perspective by clicking Window > Open Perspective > COBOL.
Click Window > Reset Perspective.
Click OK.
Reapply any customizations.

Configuring the Environment for Developing RDBMS
Applications on UNIX
Note:
•
•

If you are working with remote projects, you need to configure the environment before you start the
remote server process.
On UNIX, if you are working with local projects, you need to configure the environment before you
start Eclipse.

1. Ensure the COBOL and the third-party software environments are set.
2. Set up the RDBMS environment.
Refer to your RDBMS vendor documentation for details.
3. Set COBCPY as required in order for the IDE to locate any copybooks that are external to your project.
4. If working with Pro*COBOL/Cobsql applications you need to set COBOPT. This sets the appropriate
linker options for the platform and the COBOL working mode:
To do this, execute the following at the command line:
$COBDIR/src/oracle/set_cobopt_oracle
COBOPT=$PWD/cobopt.ora
export COBOPT

Repairing
If a file in the installation of the product becomes corrupt, or is missing, we recommend that you reinstall
the product.

Uninstalling
Note: Before you uninstall the product, ensure that the Enterprise Server instances and the Micro
Focus Directory Service (MFDS) are stopped.
To uninstall this product:
1. Execute as root the Uninstall_VisualCOBOL2.2.sh script in the $COBDIR/bin directory.
Note: The installer creates separate installations for the product and for Micro Focus License
Administration. Uninstalling the product does not automatically uninstall the Micro Focus License
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Administration or the prerequisite software. To completely remove the product you must uninstall the
Micro Focus License Administration as well.
To uninstall Micro Focus License Administration:
1. Execute as root the UnInstallMFLicenseServer.sh script in the /var/
microfocuslicensing/bin directory.
The script does not remove some of the files as they contain certain system settings or licenses.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Installing Visual COBOL Development Hub
Downloading the Product
1. Use the download links in your Electronic Product Delivery email.
For more information follow the links for the installation instructions and the End User License
Agreement.

Installing
Note:
During the installation process, the installer configures the product's Enterprise Server System
Administrator Process User ID. The Process User ID will be the owner of all Enterprise Server
processes except the one for the Micro Focus Directory Server (MFDS). The Directory Server
process (Enterprise Server Administration) runs as root as this allows it to access the system files and
ports.
All Enterprise Server processes you start from Enterprise Server Administration run under the
Process User ID which can affects the file access and creation.
By default, the installer uses the login id of the user that runs the installer for the Process User ID. To
change the user id after you complete the installation, execute $COBDIR/bin/casperm.sh.
These are the steps to install this product:
1. Give execute permissions to the setup file:
chmod +x setup_visualcobol_devhub_2.2_platform
2. Run the installer with superuser permissions:
./setup_visualcobol_devhub_2.2_platform
If you don't run this as superuser you will be prompted to enter the superuser password during the
installation.
The COBOL environment is installed by default into /opt/microfocus/product-name, (COBDIR).
To install in a different location use the -installlocation="Location" parameter to specify an
alternative directory location. For example:
./setup_visualcobol_devhub_2.2_platform -installlocation="full path of new
location"
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Note: You can use variables or the tilde syntax for the path for –installlocation. For
example, the following examples are equivalent:
-installlocation="/home/myid/installdir"
-installlocation="~myid/installdir"
-installlocation="~/installdir"
-installlocation="$HOME/installdir"
You can see details about which additional parameters can be passed to the install script if you enter
the -help option.
You can use the following options to configure the Enterprise Server installation: [ ESsysLog="location" ] [ -ESadminID="User ID" ] [ -CASrtDir="location" ],
where:
-ESsysLog

Specifies a location in which the build will create the Enterprise Server System log file for example, -ESsysLog="/home/esuser/logs". The default location is /var/
mfcobol/logs.

-ESadminID Sets the Enterprise Server System Administrator Process User ID from the command
line - for example, -EDadminID="esadm". The default user ID is the one that runs the
installer.
-CASrtDir

Specifies the location were the Enterprise Server run-time system files are placed - for
example, -CASrtDir="/home/esuser/casrt/es". The default location is /var/
mfcobol/es.

Note:
•

•

The installation of this product could affect the SafeNet Sentinel licensed components running
on your machine. During installation licensing is shutdown to allow files to be updated. To
ensure the processes running on your machine are not affected, you need to use the skipsafenet option, which skips the installation of SafeNet:
./setup_visualcobol_devhub_2.2_platform -skipsafenet
To protect the SafeNet Sentinel installation from accidental updating you can create an empty
file named SKIP_SAFENET_INSTALL in /var/microfocuslicensing/ as follows:
touch /var/microfocuslicensing/SKIP_SAFENET_INSTALL
While the file is present, the SafeNet installer does not make changes to the installation or
shutdown the running license daemons. If licensing needs to be updated later, remove the file
and install Sentinel RMS server manually.

When you have installed the product, you need to set the environment as described below.
1. To set up your product, execute:
. /opt/microfocus/VisualCOBOL/bin/cobsetenv
2. To verify that your product is installed, execute:
cob -V
Important: These commands set the environment only for the current shell. You need to execute
them for each new shell that you start.
To avoid having to run cobsetenv for every shell, add these commands to the shell initialization files
(such as etc/profile, etc/bashrc).
Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.
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Note: For information about the Visual COBOL Development Hub, check the help for Visual COBOL
for Eclipse that is available online on the Micro Focus Infocenter.

Installing as an Upgrade
This release works concurrently with the previous version of Visual COBOL, so you do not need to uninstall
it. There are two options for installing the latest version in this case:
•

Move the existing installation to a different location and install the latest version to the default install
location specified by the COBDIR environment variable ( /opt/microfocus/VisualCOBOL, by
default).
This ensures you do not need to change your environment. To move the existing older installation to a
different location:

•

1. Execute the following command as root:
mv /opt/microfocus/VisualCOBOL /opt/microfocus/VisualCOBOLversion
2. Install the latest version as described in the section Installing.
Install the latest version in a different location and set the environment to point to it. To do this, run the
Visual COBOL installer with the –installlocation option:
1. Execute the following command:
. /InstallFile -installlocation="/opt/microfocus/VisualCOBOL"
Note: You can use variables or the tilde syntax for the path for –installlocation. For
example, the following examples are equivalent:
-installlocation="/home/myid/installdir"
-installlocation="~myid/installdir"
-installlocation="~/installdir"
-installlocation="$HOME/installdir"
2. Execute cobsetenv to set the environment and point to the new install location:
. /opt/microfocus/VisualCOBOL/bin/cobsetenv
Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.

Configuring the Environment for Developing RDBMS
Applications on UNIX
Note:
•
•

If you are working with remote projects, you need to configure the environment before you start the
remote server process.
On UNIX, if you are working with local projects, you need to configure the environment before you
start Eclipse.

1. Ensure the COBOL and the third-party software environments are set.
2. Set up the RDBMS environment.
Refer to your RDBMS vendor documentation for details.
3. Set COBCPY as required in order for the IDE to locate any copybooks that are external to your project.
4. If working with Pro*COBOL/Cobsql applications you need to set COBOPT. This sets the appropriate
linker options for the platform and the COBOL working mode:
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To do this, execute the following at the command line:
$COBDIR/src/oracle/set_cobopt_oracle
COBOPT=$PWD/cobopt.ora
export COBOPT

Configuring the Remote System Explorer Support
The remote development support from the Eclipse IDE relies upon Visual COBOL Development Hub
running on the UNIX machine and handling all requests from the IDE for building and debugging programs.
Visual COBOL Development Hub provides a UNIX daemon, the Remote Development Option (RDO)
daemon, which initiates the RDO as Eclipse clients connect to it. Whichever environment is used to start
the RDO daemon will be inherited for all servers and hence all build and debug sessions.
Configuring the Environment
You may need to configure some aspects of the environment before you start the daemon. This is because
when a build or debug session is initiated on the Development Hub from one of the Eclipse clients, the
environment used will be inherited from whatever was used to start the daemon. A typical example of the
kind of environment that might need to be set up would include database locations and settings for SQL
access at build/run time.
Starting the Daemon
Important: Before starting the daemon you must have the following on your UNIX machine:
•
•
•

a version of Perl
a version of Java
the as (assembler) and ld (linking) programs on the path, as specified by the PATH environment
variable

To start the daemon on the default port (4075) as a background process, perform this command with
superuser authority:
$COBDIR/remotedev/startrdodaemon
The daemon will now listen for any Eclipse client processes connecting to that machine on port 4075. If
you want to use another port, specify another port number on the startrdodaemon command.
The daemon can also be configured to instantiate the servers on a specified port or range of ports. This is
particularly relevant when you want to only open certain ports through a firewall. To do this, perform this
command with superuser authority:
$COBDIR/remotedev/startrdodaemon [<port> | <low port>-<high port>]
where:
•

<port> is the port number the daemon should use to listen for connections from Eclipse on the client
machine. If no value is given, it will be assigned a default value of 4075. This value matches the value
assigned within the Eclipse installation.
For example,
$COBDIR/remotedev/startrdodaemon 4999

•

This command will start a daemon listening on port 4999 and will use random server ports.
<low port>-<high port> is the range of ports on which the servers (launched by the daemon) should use
to communicate with Eclipse on the client machine.
For example,
$COBDIR/remotedev/startrdodaemon 4080 4090-4999
This command will start a daemon listening on port 4080 and server ports will be in the range 4090 to
4999.
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Stopping the Daemon
To stop the daemon, type the following command with superuser authority:
$COBDIR/remotedev/stoprdodaemon <port>

Repairing on UNIX
If a file in the installation of the product becomes corrupt, or is missing, we recommend that you reinstall
the product.

Uninstalling
Note: Before you uninstall the product, ensure that the Enterprise Server instances and the Micro
Focus Directory Service (MFDS) are stopped.
To uninstall this product:
1. Execute as root the Uninstall_VisualCOBOL2.2.sh script in the $COBDIR/bin directory.
Note: The installer creates separate installations for the product and for Micro Focus License
Administration. Uninstalling the product does not automatically uninstall the Micro Focus License
Administration or the prerequisite software. To completely remove the product you must uninstall the
Micro Focus License Administration as well.
To uninstall Micro Focus License Administration:
1. Execute as root the UnInstallMFLicenseServer.sh script in the /var/
microfocuslicensing/bin directory.
The script does not remove some of the files as they contain certain system settings or licenses.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.
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Licensing Information
Note:
•
•
•
•

This package provides eight licenses for using Micro Focus Development Hub on all platforms.
This release uses the authorization code for the Visual COBOL 2.0 release.
The latest version of the SafeNet licensing software is required. See Software Requirements in
this document for more details.
If you are unsure about what your licensing policy is or what sort of license you require, consult
your System Administrator or Micro Focus SupportLine to obtain a valid license.

To activate Visual COBOL Personal Edition
Note: Having activated Visual COBOL Personal Edition, you can use it for a limited period of 365
days. After this period you will need to enter an authorization code in order to continue using it, either
for a 30-day trial or full license of Visual COBOL.
1. Start Visual COBOL.
If you have not installed a license for Visual COBOL, starting the IDE for the first time after you install
the product opens the Micro Focus Visual COBOL Product Licensing dialog box. If you cancel this
dialog box, you can invoke it again from Help > Micro Focus > Product Licensing.
If you have not installed a license for Visual COBOL, starting the IDE and trying to create a COBOL
project opens the Micro Focus Visual COBOL Product Licensing dialog box. If you cancel this dialog
box, you can invoke it again from Help > Micro Focus Product Help > Product Licensing.
2. Click I want to activate the free product.
3. Ensure that the email address used to register the product is in the Email address text entry field. If
you haven't registered your email address yet, click registration page and follow the instructions on
that page.
4. Select one of the following options:
Automatic Use this if you have Internet access.
1. Click Activate License (in Visual Studio) or Finish (in Eclipse) to activate your copy of
Visual COBOL Personal Edition.
Manual

Use this if you are not connected to the Internet.
In Visual Studio:
1. Click Send email.
This opens your default email client and creates a new email filled in with the details to
send to Micro Focus about activating your copy of the free Personal Edition of the
product.
Note: If there is no mail client installed on your machine, you will be presented
with a template that includes the email address, the subject and the contents of
an email to send with a mail client of your choice. Do not modify the details.
You will receive a response email with details about your authorization request.
2. Paste the contents of the response email in the designated field in the Micro Focus
Visual COBOL Product Licensing dialog box.
3. Click Activate License.
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This displays a message confirming your request for authorization has been
successful.
4. Click Close.
In Eclipse:
1. Click Next and then click Send email.
This opens your default email client and creates a new email filled in with the details to
email to Micro Focus about activating your copy of the free Personal Edition product.
2. Send the email.
3. If there is no mail client installed on your machine, copy the email address, the subject
and the exact contents from the Email details fields and paste them into an email to
sent to Micro Focus using a mail client of your choice. Do not modify or add to the text.
You will receive a response email with information with details about your authorization
request.
4. Paste the body text of the response email into the text entry field of the Manual
Activation dialog box.
5. Click Finish.
You should receive a message that the activation has been successful.
6. Restart Eclipse to complete the activation process.

To request and activate a 30-day trial license for Visual
COBOL
1. In the IDE, click Help > Micro Focus > Product LicensingHelp > Micro Focus Product Help >
Product Licensing.
This opens the Micro Focus Visual COBOL Product Licensing dialog box.
2. Type your email address in the Email address text entry field.
You need to use the same email address you used for the registration.
3. Select one of the following options:
Automatic Use this if you have Internet access.
1. Click Activate License (in Visual Studio) or Finish (in Eclipse) to activate the trial
license for Visual COBOL.
Important: After clicking Finish, if you click the Cancel button in the progress
dialog box to stop the activation process, the trial license might have registered on
Micro Focus servers but not yet be registered on your machine. If you request a
trial again then you can get a message saying that a trial license has already been
used. If this happens, you should contact a Micro Focus Sales representative to
obtain a new license.
You can do this by sending an email to VCBuyNow@microfocus.com, or selecting
Help > Micro Focus > Buy Now and using the contact options in the dialog box.
Manual

Use this if you are not connected to the Internet.
In Visual Studio:
1. Click Send email.
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This opens your default email client and creates a new email filled in with the details to
send to Micro Focus about activating the trial license for Visual COBOL.
Note: If there is no email client installed on your machine, you will be presented
with a template that includes the email address, the subject and the contents of
an email to send with a mail client of your choice. Do not modify the details.
2. Send the email.
You will receive a response email with details about your authorization request.
3. Paste the contents of the response email in the designated field in the Micro Focus
Enterprise Developer Product Licensing dialog box.
4. Click Activate License.
This displays a message confirming your request for authorization has been
successful.
5. Click Close.
In Eclipse:
1. Click Next and then click Send email.
This opens your default email client and creates a new email filled in with the details to
email to Micro Focus about activating your trial of Visual COBOL.
2. Send the email.
3. If there is no email client installed on your machine, copy the email address, the
subject and the exact contents from the Email details fields and paste them into an
email to send to Micro Focus using a mail client of your choice. Do not modify or add
the text.
You will receive a response email with information with details about your authorization
request.
4. Paste the contents of the response email into the text entry field of the Manual
Activation dialog box.
5. Click Finish.
You receive a message that the activation has been successful.
6. Restart Eclipse to complete the activation process.
After activation, you can see how many days your trial license has remaining by selecting Help > Micro
Focus > Product Licensing, or by using Micro Focus License Administration.

To buy and activate a full unlimited license
Note: You can only activate a full license from the IDE if you haven't yet activated Personal Edition.
To activate a full version at any other time you must use the Micro Focus License Administration tool.
For instructions on using the Micro Focus Licensing Administration Tool, see Licensing in the Visual
COBOL help.
1. In the IDE, click Help > Micro Focus > Product Licensing > Buy NowHelp > Micro Focus Product
Help > Product Licensing.
This opens the Micro Focus Buy Now dialog box.
2. Ensure that the email address you used to register the product is in the Email address text entry field.
3. Click Send email.
This opens your default mail client and creates a new email filled in with the details to contact Micro
Focus. Send the email.
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If there is no mail client installed on your machine, you will be presented with a template that includes
the email address and subject line for an email to send to Micro Focus using a mail client of your
choice.
You will be contacted by a Micro Focus Sales representative.

To start Micro Focus License Administration
Windows
From the Windows Taskbar click Start > All Programs >Micro Focus License Manager > License
Administration.
Note: On Windows 8 and Windows Server 2012, you use the Start screen to invoke programs.

UNIX
Log on as root, and from a command prompt type:
/var/microfocuslicensing/bin/cesadmintool.sh

Installing licenses
If you have a license file
Windows
1. Start Micro Focus License Administration.
2. Click the Install tab.
3. Do one of the following:
•

Click Browse next to the License file field and select the license file (which has an extension
of .mflic).
• Drag and drop the license file from Windows Explorer to the License file field.
• Open the license file in a text editor, such as Notepad, then copy and paste the contents of the file
into the box below the License file field.
4. Click Install Licenses.
UNIX
1. Start the Micro Focus License Administration tool and select the Manual License Installation option by
entering 4.
2. Enter the name and location of the license file.

If you have an authorization code
Authorizing your product when you have an Internet connection
Note: This topic only applies if you have an authorization code.
The following procedure describes how to authorize your product using a local or network license server.
The license server is set up automatically when you first install the product.
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Windows
1.
2.
3.
4.

Start Micro Focus License Administration.
Click the Install tab.
Type the authorization code in the Enter authorization code field.
Click Authorize.

If you change the name of the machine running your license server after it has granted licenses, the
licenses stop working.
UNIX
1. Start Micro Focus License Administration.
2. Select the Online Authorization option by entering 1 and pressing Enter.
3. Enter your authorization code at the Authorization Code prompt and then press Enter

Authorizing your product when you don't have an Internet connection
Note: This topic only applies if you have an authorization code.
This method of authorization is required if your machine does not have an Internet connection or if normal
(automatic) authorization fails.
Windows
1.
2.
3.
4.

Start Micro Focus License Administration.
Click Manual Authorization on the Install page.
Make a note of the contents of the Machine ID field. You will need this later.
Do one of the following:
•
•

If your machine has an Internet connection, click the SupportLine Web link in the Manual
Authorization Information window.
If your machine does not have an Internet connection, make a note of the Web address and type it
into a Web browser on a machine that has an Internet connection.

The Micro Focus SupportLine Manual product authorization Web page is displayed.
5. Type the authorization code in the Authorization Code field. The authorization code is a 16-character
alphanumeric string supplied when you purchased your product.
6. Type the Machine ID in the Machine ID field.
7. Type your email address in the Email Address field.
8. Click Generate.
9. Copy the generated license string (or copy it from the email) and paste it into the box under the License
file field on the Install page.
10.Click Install Licenses.
UNIX
In order to authorize your product you must have the following:
•
•

Your authorization code (a 16-character alphanumeric string).
The machine ID. To get this, start the Micro Focus License Administration tool and select the Get
Machine Id option by inputting 6. Make a note of the "Old machine ID".

If you have previously received the licenses and put them in a text file, skip to step 6.
1. Open the Micro Focus license activation web page http://supportline.microfocus.com/activation in a
browser.
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2. Enter your authorization code and old machine ID and, optionally, your email address in the Email
Address field.
3. Click Generate.
4. Copy the licenses strings from the web page or the email you receive into a file.
5. Put the license file onto your target machine.
6. Start the Micro Focus License Administration tool and select the Manual License Installation option by
inputting 4.
7. Enter the name and location of the license file.
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New Features in Visual COBOL 2.2
ACUCOBOL-GT Compatibility
The following support has been added to Visual COBOL in this release:
Accessing data files through AcuServer
You can now access your ACUCOBOL-GT data files, both sequential and Vision files, through AcuServer.
Standard library routines
Support for the following library routines has been added:
•
•
•
•
•
•
•
•
•
•
•

C$GETPID
C$JUSTIFY
C$LIST-DIRECTORY
C$LOCKPID
C$REGEXP
C$RUN
C$SLEEP
C$SYSTEM
C$TOLOWER
C$TOUPPER
I$IO

Using Vision files with Micro Focus Data File Tools
You can now use some of the Data File Tools functionality with Vision files. You can:
•
•

Convert Vision files to Micro Focus format using the Data File Converter and the DFCONV command
line utility.
Edit Vision files using the Data File Editor.
Note: The Data File Converter and DFCONV command line utility options are only available if you
have installed the free Data Tools AddPack; for more information, see Data Tools.

Application configuration
You can now set environment variables for when you run native projects from within the IDE from the
project's properties - click Environment on the Application tab in the project properties.

COBOL Source Information (CSI)
COBOL Source Information (CSI) provides a quick and easy way of providing you with information about
your program when you are working on it. You enter a query in the Quick Browse dialog box and CSI
returns the results of the query in the Output window's COBOL Source Information tabSearch view.
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Compiler Directives
The following Compiler directives are new:
ACU-UNDERSCORE

This directive treats underscores in COBOL words as hyphens.

ILSHOWPERFORMOVERLAP This managed COBOL-only directive generates a warning when an
overlapping PERFORM range is detected in the program.
ILEXPONENTIATION

This managed COBOL-only directive enables you to optimize
exponential arithmetic operations by specifying the calculation method
used.

EXITPROGRAM

This directive determines how the EXIT PROGRAM statement is
executed.

The following Compiler directives have changed:
CHANGE-MESSAGE The scope of this directive has been widened to allow you to change the severity
of different types of error messages, not just syntax checking messages.
DIALECT"RM"

DIALECT"RM" now sets PERFORM-TYPE"RM". If you recompile an application
that uses DIALECT"RM", the behavior may change for nested PERFORM
statements. If that is the case, explicitly set PERFORM-TYPE"MF" after
DIALECT"RM" to continue with the previous behavior.

HIDE-MESSAGE

The scope of this directive has been widened to allow you to hide different types
of error messages, not just syntax checking messages.

PRESERVECASE

This directive now defaults to PRESERVECASE when compiling native COBOL;
managed COBOL compilation already defaults to PRESERVECASE. This results
in externally visible identifiers preserving their case instead of being converted to
uppercase.

Converting Net Express projects
Conversion of Net Express projects has been enhanced. You now use the Visual Studio Conversion
Wizard to import and convert Net Express projects (.app files) to Visual Studio solutions.

Debugging
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Displaying debug
information for
managed
applications

You can set the DEBUG constant for managed COBOL projects on the COBOL
tab in the project properties. This enables you to use the
System.Diagnostics.Debug class in your applications to ensure they write
diagnostic information in the Output window for projects compiled for Debug but
not for projects compiled for Release.

Changing the
display format for
individual items in
the Watch window

It is now possible to change the display format for individual items in the Watch
window in COBOL. To do this, click a row, press F2, and type: Variable,h or
Variable,x to always display the values in hexadecimal format; Variable,d
to always display the values of variables in decimal format, and of strings - as
text.
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Enhanced ACCEPT and DISPLAY Statements
Two of the existing Enhanced ACCEPT and DISPLAY settings available through Adis have additional
values, which are aimed at RM/COBOL users migrating their source code to Visual COBOL. The new
values are:
•
•

Emulation of RM/COBOL-85 style data entry for numeric data entry on ACCEPT statements.
Emulation of an RM/COBOL backspace in free format fields when in replacement editing mode, in that
deleted characters are removed and characters to the right are shifted left, the same as when in
insertion editing mode.

For more information on how to set these values, refer to Configuring Enhanced ACCEPT and DISPLAY

Enhancements for Visual COBOL 2.2 for Visual Studio
2012
The following enhancements are applicable to Visual COBOL for Visual Studio 2012:
Copybook Dependencies
Solution Explorer shows a tree view of the dependencies of the COBOL programs and copybooks on
copybooks in a project to help you navigate easily around the source code.
Expanded Copybook View - Technical Preview
The COBOL editor supports showing the contents of copybooks inline at the place where they are
referenced in a program or a copybook. Features include:
•
•

•

You can edit the code of copybooks in the expanded copybook view (except for copybooks shown with
replaced values).
For copybooks referenced using a COPY... REPLACING statement, you can show either the original
contents of the copybook file or show its contents with replaced values. The expanded copybook view
with replaced values is read-only which is indicated by a yellow background color.
Note: You can configure the background color of the read-only view from Tools > Options >
Environment > Fonts and Colors, and changing the background color for the COBOL ReadOnly Background item.
Go To Definition, Find All References, navigation using the drop-down types and members, and
navigating to an error from the Error List window all find results or locate information in the expanded
copybook view.
Note: The following limitations apply:
•
•

•
•
•

•

IntelliSense and code snippets are not supported when editing a copybook in expanded copybook
view.
In expanded copybook view, it is not possible to edit copybooks referenced through a COPY...
REPLACING statement when the expanded copybook view shows the replaced values. In this
case, the expanded copybook view is read-only.
Outlining is not supported in the expanded copybook view.
Navigating to items in the expanded copybook view is not supported from the Class View or using
the Navigate To option.
References to file locations in the output windows such as pointing to the build output, or in the
results received by Find in Files, Quick Browse (COBOL Source Information), do not point to items
in expanded copybook view.
It is not possible to step in the expanded copybook view while debugging.
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•

The expanded copybook view supports breakpoints setting but the Breakpoint icon does not
appear in it but only in the original copybook file.

File Handling
New features include:
•
•
•

Converting and editing Vision and RM/COBOL indexed data files using the Data File tools is now
supported.
Access to data files (either sequential or indexed) through AcuServer is now supported.
Access to Vision and RM/COBOL indexed data files through Enterprise Server is now supported.

Grouping files in virtual folders in Solution Explorer
Visual COBOL now provides a Virtual View of a project within Solution Explorer. In the Virtual View you
use virtual folders to improve navigation by logically grouping the files that make up the project. You can
also create your own virtual folders to group files of your choice (a file can only belong to one virtual folder).
The files can be of different file types.

Interface Mapping Toolkit
Restriction: This topic applies only when the Enterprise Server feature is enabled.
Visual COBOL now supports the creation and deployment of COBOL program-based services using the
Interface Mapping Toolkit (IMTK).

Managed COBOL
Documentation A guide that provides a basic introduction to Object-Oriented Programming (OOP) for
COBOL developers, An Introduction to Object-Oriented Programming for COBOL
Developers, with examples is now available from the Product Documentation section on
the Micro Focus SupportLine Web site - click here to download it.
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Procedural
Multi-Output
Project type

A new .NET managed project template, Procedural Multi-Output Project, is now
available. The project compiles procedural programs to individual managed assemblies
or executables as opposed to the standard managed project templates that produce a
single assembly. This project type is useful when you are moving existing procedural
applications that consist of multiple programs to Visual COBOL and to managed code.
When calling a subprogram, the COBOL run-time system can locate the assembly using
the name of the called program which will match the assembly file name. In this case,
the assembly does not have to be preloaded. See Types of COBOL Project Templates
for more details and for a list of the limitations of this project type.

Named and
optional
parameters

Two new types of parameter have been introduced for use during method invocation:
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Named
parameters

As part of the invocation expression, you can define a value for a
parameter named in the method definition. The named argument
must be specified after any positional arguments, and must not
correspond to any of those preceding arguments.

Optional
parameters

Delegates
and events

Optional parameters are parameters defined with a default value in
the procedure division header of the invoked method. If none of the
arguments passed in during invocation correspond to this parameter,
the default value is used in the method; if an argument does
correspond, the value that was passed in is used.

A number of new features have been added that relate to delegates and events:
Note: Some of these features were also available in previous versions of Visual
COBOL.
The ATTACH and
DETACH statements

Use these statements to attach or detach a delegate, method
group or an anonymous method to or from an event.

The RUN statement

Use this statement to invoke a delegate once it has been
created.

Combining
delegates

Use the '+' operator to add a method group, anonymous method
or another delegate to a delegate, and use the '-' operator to
remove a method or another delegate from a delegate.

Method groups
conversions

Use the METHOD keyword to specify a compatible method from
a method group, and convert it to a delegate.

Problems View
The Problems view now has a 'Program' column that displays the name of the program in which the
problem occurred. Click this column heading to sort the errors by program.

If the column is not present in the view by default, you can add it through the Configure Columns dialog
box in the View Menu.

Searching in copybooks
The search in copybook files has been enhanced. Visual Studio's Find in Files now enables you to
perform a search in all copybooks - the ones that are part of the project, and in the ones that are found in
the paths defined on the Dependency Paths tab in the project's properties. To do so, set the search scope
in the Find and Replace dialog to COBOL Project Copybook Paths.
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COBOL editor enhancements
Navigating in the editor is now more similar to the editor navigation in Net Express. You can configure
things like word wrap and indentation, the movement of the cursor using the Home and End keys, the style
of the ruler and the colors of the text and the margins:
Smart editing
mode

The default mode in the editor is now Smart edit mode. It controls the word wrapping
and the indentation in the different COBOL areas. You can configure the Smart edit
mode from the Tools > Options > Text Editor > Micro Focus COBOL > Margins
page. To toggle the mode, click
toolbar.

Home and End
keys navigation

(in Visual Studio 2012) in the COBOL

You can configure how the Home and End keys move the cursor in the editor on the
Tools > Options > Text Editor > Micro Focus COBOL > Margins page. To toggle
the mode, click

Configuring the
ruler

or

or

(in Visual Studio 2012) in the COBOL toolbar.

You can specify whether to display the horizontal ruler in the editor and also choose
its style, a default style or a mainframe style for which the ruler indicates COBOL area
A/B, from Tools > Options > Text Editor > Micro Focus COBOL > Margins and
check Show ruler.

Support for SOA
Restriction: This topic applies only when the Enterprise Server feature is enabled.
Visual COBOL now includes support for creating Web service and Enterprise Java Bean applications using
the Interface Mapping Toolkit (IMTK) in conjunction with Enterprise Server. If you are upgrading to this
release from an earlier version of Visual COBOL, you may need to apply for a new authorization code in
order to access the functionality - please contact Micro Focus SupportLine to receive an updated
authorization code. Note that the Visual COBOL Personal Edition license does not support the IMTK
functionality.

Upgrading from Net Express to Visual COBOL
A new section in the product help, Upgrading from Net Express to Visual COBOL for Eclipse, provides
guidance on how to move existing applications either developed or debugged in the Net Express IDE into
the Visual Studio IDE.

WCF REST Service Application projects
Visual COBOL now provides a project template for creating COBOL WCF REST Application services. The
requirements are - Visual Studio Professional, Premium, or Ultimate (Visual Studio Shell does not support
WCF applications), and versions of the .NET Framework 4.0 and later. For more information about WCF
and REST, check Microsoft's MSDN.

Windows Azure
Visual COBOL for Visual Studio now enables you to create, build, debug, run, and package COBOL
applications for use with Windows Azure. It provides:
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•
•
•

Project template for a COBOL cloud service. This creates a solution containing a project for the cloud
service and projects for the web and worker roles you specify.
Demonstration projects, showing a web and worker role in COBOL, with the business logic remaining in
unchanged COBOL programs.
Help. This includes a tutorial that shows how to create a simple cloud service for COBOL and how to
deploy and run the service as an off-premises Windows Azure instance.

This functionality was previously available as an AddPack but is now integrated into Visual COBOL.

XML Extensions
You can now use XML Extensions in your managed COBOL projects.
Use XML Extensions to import and export XML documents to and from COBOL working storage.
Specifically, XML Extensions allows data to be imported from an XML document by converting data
elements (as necessary) and storing the results into a matching COBOL data structure. Similarly, data is
exported from a COBOL data structure by converting the COBOL data elements (as necessary) and
storing the results in an XML document.
While importing or exporting data to or from XML documents, you can apply XSLT transforms to the data
by using XSLT stylesheets.
For more information, refer to the XML Extensions User's Guide, available from the product documentation
section of the SupportLine website (http://SupportLine.MicroFocus.com/ProductDoc.aspx)
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Known Issues
Refer to the Known Errors and Restrictions topic in the Product Information section of your product Help.
In addition, note the following:
AcuCOBOL File When using an interface of ACUFH other than MSSQL, you may experience a file
operation delay when the interface fails to connect to a database. This failed
Handler
connection also results in a memory leak. Set the environment variable
MSSQL_DETACH to 1 to avoid both issues.
ASP.NET

It is not possible to run ASP.NET Web Sites or Web Services on a production machine
(one that has Micro Focus COBOL Server installed) without an additional setup. This
is because the production machine does not contain development tools such as the
COBOL Compiler. To workaround this, you need to do the following steps:
1. Precompile the site before you deploy it using the Publish Web Site command in
Visual Studio.
2. Edit the .asmx file of the Web service project or the .aspx file of the Web site and
delete the Language="COBOL" statement.
3. Edit the Web.config file with a text editor and delete the line which contains:
<compiler language="COBOL"...
4. Ensure that a .NET Server license is installed using Apptrack.

COBOL
Watchpoints

The debugger ignores a COBOL watchpoint that is hit if there is no statement following
the statement that modifies the data on which that watchpoint is set.

Compiler

When running with Java 1.7, if your class contains a static method called 'main' with a
single string array parameter, in order for this class to be executable from the
command line that main method should not have a returning item.

Debugging

There is an issue with "Wait for attachment" when you use Visual COBOL for Eclipse
to debug applications that run on some UNIX/Linux platforms. Eclipse connects to the
debugger on the remote machine, but might not attach to the process to debug the
code.
To work around this issue, ensure that on the remote machine the TMPDIR
environment variable is unset or has the same value for both Micro Focus Visual
COBOL Development Hub server and for the running process you wish to debug. The
Micro Focus Visual COBOL Development Hub server is the server which you started
either directly with the $COBDIR/remotedev/startrdoserver script or indirectly using the
daemon which is started with the $COBDIR/remotedev/startrdodaemon script.
To check the variable used by the Micro Focus Visual COBOL Development Hub
server:
1. Open Remote Systems view in Eclipse on the Windows machine.
2. Right-click the Shells element of the server connection to be tested and click
Launch Shell.
3. In the Remote Shell view, type echo $TMPDIR in the Command field, and press
Enter.
The value of the TMPDIR environment variable is shown - ensure it is the same as
the one used by the process to be debugged.
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Note: The value of TMPDIR used by the Development Hub server cannot be
changed in the remote shell and must be set before you start the daemon or
server.
Documentation

•

•

In Visual Studio 2012, clicking Help > Micro Focus Product Help > Product
Documentation results in the message "Cannot find requested topic on your
computer". If you see this message, click Micro Focus Visual COBOL 2.2 for Visual
Studio 2012 in the Contents tab to display the documentation as expected.
If you install Visual COBOL for Visual Studio 2012 and its documentation is not
available in the Microsoft Help Viewer, perform the following steps:
1. In Visual Studio 2012, click Help > Add and Remove Help Content.
2. Choose the Manage Content tab.
3. Check the Disk radio button, then navigate to the folder containing the Visual
COBOL for Visual Studio 2012 documentation. By default, this is C:\Program
Files (x86)\Micro Focus\<product name>\help.
4. Select helpcontentsetup.msha and click Open.
5. In the content list, click Add next to the Visual COBOL entry.
6. Click Update.
7. Click Yes on the User Account Control and Microsoft Help Viewer 2.0 dialog
boxes to enable the update to continue.
The documentation for Visual COBOL for Visual Studio 2012 is added to the
Microsoft Help Viewer.
Note:
This problem only occurs if you install Visual COBOL for Visual Studio 2012
while documentation for Visual Studio 2012 is being downloaded or updated,
which typically happens when you install Visual Studio 2012 or run it for the
first time.

Database
Access

If you have a remote COBOL project under Eclipse that uses DB2 ECM in Visual
COBOL or HCO for DB2 LUW in Enterprise Developer and the DB2 software is not
installed on the client machine where you are using the Eclipse IDE, you receive
background parsing errors in your application. To resolve the issue, you can do either
one of the following:
•
•

Enterprise
Server

•
•

Expanded
•
Copybook View
(in Visual Studio
2012)
•

Disable background parsing Window > Preferences > Micro Focus > COBOL >
Editor and disabling the checkbox for Background parsing.
Install the IBM DB2 client-side software on the machine on which you are running
Eclipse. Go to the IBM Support Home and locate the page entitled "IBM Download
Fix Packs for IBM Data Server Client Packages" .
The Historical Statistics Facility may generate incorrect records for SSTM-enabled
enterprise servers.
In Visual Studio, using Submit JCL from within the IDE does provide the option to
create a temporary enterprise server when your project is not associated with an
enterprise server.
When you add a COPY statement in a COBOL program and then show it in
Expanded Copybook View, the line for the copybook statement is read-only. If you
then perform an Undo in the COBOL program, the COPY statement is removed
while the contents of the copybook is still shown in the program.
Replace All does not work inside the Expanded Copybook View
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•
•

ICETOOL
Emulation

ICETOOL emulation for managed code is not available in this release.

Installation

•

When installing this product for Visual Studio 2010, if you already have Visual
Studio 2010 Isolated Shell with Service Pack 1 (SP1) installed, you might
experience problems with starting Visual Studio after the installation. This is a
Microsoft issue relating to the Integrated Shell (installed as part of the Micro Focus
product installer) overwriting some Visual Studio SP1 components. To resolve the
issue you need to repair Visual Studio 2010 SP1.

•
•

On UNIX, check UNIX Installer Issues before you start the installation.
If you are using the latest version of Java 1.7 on Linux, you might receive some
warnings when you start this product. To resolve the issue, it is recommended that
you install an earlier version of Java 1.7 and set JAVA_HOME to that.

Native COBOL

On Windows XP, when building a native COBOL application in Visual Studio, a dialog
may pop up with error "Unhandled exception at 0xc0006866 in cobol.exe:
0xC0000005: Access violation reading location 0xc0006866)". This is caused by
Symantec antivirus runtime protection. To resolve this, you need to apply the following
fix from Symantec: http://www.symantec.com/business/support/index?
page=content&id=TECH97280&locale=en_US.

Resource
Adapters

Trying to deploy the local resource adaptor mfcobol-localtx.rar to WebLogic
may fail with a ClassCastException. To work around this issue, you need to deploy
mfcobol-xa.rar first, then need to undeploy this file and deploy the local one,
mfcobol-localtx.rar. If there are issues deploying using the WebLogic GUI, you
can use the command line. If there are issues with this as well, try reducing the length
of the command (for example, by moving the file to a location with a shorter path).

Visual Studio
IDE

•

•
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Trying to paste a block selection inside the Expanded Copybook View does not
work and deletes all lines of code which the block selection overlaps.
For copybooks with file extensions that are not traditionally associated with COBOL
you must first add the file extension to the list of known copybooks extensions in
Tools > Options > Text Editor > File Extensions before you can show them in
Expanded Copybook View.

In your project properties, the Application page currently allows you to select any of
the static methods in the application as a Startup object. This is incorrect. You
should always set only the first static method or the program name as a Startup
object in order for the project to build.
In Visual Studio, the controls on the COBOL page in the project properties are not
displayed for a WPF project. To workaround this issue, open the Application page
in the project properties and from the drop-down list under Output type choose the
same output type that was already selected. Close the project property pages and
save the project. The next time you open the project properties, the COBOL page
is properly displayed.

Significant Changes in Behavior or Usage
This section describes significant changes in behavior or usage. These changes could potentially affect the
behavior of existing applications or impact the way the tools are used.
The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem
Incident (RPI) number (in parentheses).
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

.NET Compiler
CCI Session Layer Code
Compiler
Eclipse IDE
MF Directory Server
MF Server Administrator (GUI)
MFBSI
MTO - IMS Other
MTO - JCL MVS
MTO - JCL System Catalog
Open PL/I Compiler
Open PL/I Debugger
Open PL/I RTS
Request Handler
Samples Browser
Visual Studio IDE

.NET Compiler
Back to the list
•

The use of ILSMARTLINKAGE in sub-programs is now working correctly. In previous versions, if it was
specified in a sub-program, a dynamic call of that program from another program could cause execution
failure.

•

2608825 (1087435)
In managed code, the statement DISPLAY UPON SYSERR now behaves as expected. Previously, it
was behaving the same as DISPLAY UPON CONSOLE.

•

2589053 (1085576)
When the PROPERTY keyword is used on a numeric edited field, the SET method now works correctly
when the program specifies DECIMAL POINT IS COMMA.
2588508 (1085560)

CCI Session Layer Code
Back to the list
•

A new option, use_global_namespace, is available for the cci.ini file in the Windows %SystemRoot%
folder. If use_global_namespace is set, all the ccishared memory objects are created in a system-wide
address space, and the applications hosted by different users, including system services, can
communicate. To use this facility, edit the cci.ini file and ensure use_global_namespace is set to "yes".
[ccismem-base] # Allow interaction between users on a # single system. Using this option reduces
security as # all users will have access to the same name space. use_global_namespace=yes If the
value of this option is anything other than "yes", or if the option is missing, no change is made to the
existing behavior.
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2195519 (1062800)
Compiler
Back to the list
•

•

•

The default for the NSYMBOL directive under DIALECT(ENTCOBOL) has been changed to
NSYMBOL(NATIONAL) to emulate the equivalent IBM default.
2657471 (1090355)
To improve RM/COBOL and ACUCOBOL compatibility, the SIGN clause at a group level is no longer
applied to non-DISPLAY usage signed numeric data items within the group, just as it is not applied to
unsigned numeric data items and non-numeric data items within the group.
2549904 (1082171)
Previously, even though no code was generated, the Compiler allowed the ON EXCEPTION and NOT
ON EXCEPTION phrases in the DISPLAY statement in formats that do not allow these phrases. As a
result, if the DISPLAY statement was in the ON EXCEPTION phrase of another statement, the NOT ON
EXCEPTION phrase would bind incorrectly with the DISPLAY statement instead of with the intended
containing statement - for example, ACCEPT or CALL.

Eclipse IDE
Back to the list
•

•

•
•

The Problems view now has a 'Program' column that displays the name of the program in which the
problem occurred. If the column is not present in the view by default, it can be added through the
Configure Columns dialog box in the View Menu.
2608496 (1088530)
The outline of the ruler in the COBOL editor now changes on modelChanged depending on the current
source format.
2488419 (1077143)
Deleting a Web service or a Java interface mapping now deletes the files relating to it from the repos
directory and, if it is empty after the files have been deleted, will remove the repos directory itself.
The IDE now performs an automatic directive determination when files are added to a project. You can
also use a command to perform directive determination of the project manually.

MF Directory Server
Back to the list
•

•

The mfds command line option for exporting registered Enterprise Server definitions to an XML file now
supports the "*" option. This exports all registered servers rather than a specified server. Multiple server
definitions are now exported into the target directory and saved into a file with the default name
ALLSERVERS.xml. The import option now also supports the import of multiple server definitions from a
single XML file.
2641890 (1088838)
mdump now supports a new option, -e, to help you query the Security Manager configuration details.
The possible values of the option are: "1" - shows security configuration that applies to any returned
enterprise servers; "2" - shows security configuration for MFDS and the default Enterprise Server
security configuration. This requires MFDS version 1.15.00 or higher; "3" - returns the properties of all
configured external Security Managers.
2487164 (1081693)

MF Server Administrator (GUI)
Back to the list
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•

When adding a user to an external security manager, you can now include a password expiry time in
the Advanced Configuration section of the Add New User wizard in Enterprise Server Administration.
The field value is specified using generalized time format (YYYYMMDDHHMMSS.0Z), and can be used
by the MLDAP ESM for calculating whether a user's password has expired and requires updating. This
value may only be specified using this page when adding a user. You need to use an external directory
services configuration tool to edit it.
2562118 (1083203)

Request Handler
Back to the list
•

A problem that caused BIS to create log files in a directory named C:\ProgramData\AcuCorp\BIS
\LogFiles was fixed. BIS no longer creates log files unless specified and the BIS logging service is now
disabled by default. To enable it, you need to use the following global environment variable:
BIS_LOG=[ OFF | ON | <directory> ] Where the values are:
•
•
•

OFF - disables logging (the same as if BIS_LOG is not specified or is left blank)
ON - enables logging and directs the log files into the default location, which must not be read-only.
<directory> - enables logging and directs the log files into the specified directory. The user must
ensure that the BIS request handler has write rights for this directory. The directory must be an
absolute path or network path. If the specified directory does not exist, BIS will attempt to create it.
The containing directory must exist.

The BIS_LOG variable is only examined when the BIS application pool is started or recycled. After
setting or changing BIS_LOG, IIS must be restarted in order for the variable to take effect.
Samples Browser
Back to the list
•

If you have installed the version of this product for both Visual Studio 2010 and Visual Studio 2012, the
Samples Browser now provides links for you to open the samples in either one of them.

Visual Studio IDE
Back to the list
•

•

•

•

Performance when loading and building COBOL projects that consist of a large number of files has
been improved.
2657121 (1090316)
When building a project outside of the IDE, adding a new file to a project no longer results in a full
rebuild of the project.
2617003 (1089623)
You can now change the display format of values on individual rows in the Watch window using
modifiers after the names of variables and expressions. To do this, click a row, press F2, and type a
modifier after the name of the variable or the expression as follows - type VariableName,h or
VariableName,x to always display the variable or the expression in hexadecimal format; type
VariableName,d to always display numeric variables in decimal format and strings - as text.
2614182 (1087959)
When you perform a search in the IDE for copybooks that your programs depend upon, the COPYEXT
directive you set from the Additional directives field on the COBOL tab in your project's properties is
now used in preference to the list of copybook extensions specified in Tools > Options > Text Editor >
Micro Focus COBOL > Advanced, and in Copybook extensions. This change does not affect the project
build and background parsing that already use COPYEXT.
2612053 (1087773)
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•

Attempting to restart an enterprise server failed if the process took longer than fifteen seconds.

•

2607051 (1087259)
When you debug native code and query a data item which contains null bytes, the value displayed in
the Watch window is no longer truncated at the first null byte.

•

2604749 (1087235)
A new setting, "Define DEBUG constant", is now available on the COBOL page in the project properties
of managed projects for the Debug configuration. You can select it to add "constant"DEBUG(1)"" to the
build directives.

•

2600567 (1086629)
The Output window now displays a notification when the compilation of the IMS files has been
successful.

•

2600137 (1086667)
A problem with the value of "Link with objs" setting being duplicated after you reload the COBOL Link
properties page has been resolved.

•

2595408 (1086091)
IntelliSense now displays data names longer than 32 characters correctly.

•

2594901 (1086053)
Previously, when you upgraded COBOL projects with signed assemblies from Visual Studio 2003
format to Visual Studio 2010 format, the signed assembly property was lost.

•

2585458 (1085258)
There is an improvement in the performance of the cursor in the text editor when working with larger
files and projects.

•

2585450 (1085255)
Using linked files in projects has been improved as follows:
•
•
•
•

Folders that only contain linked files no longer disappear from the project when you reload it.
The location of linked files is preserved in the project structure when you reload the project.
Moving a linked file within a project no longer moves the actual file on the disk but only moves the
link inside the project structure.
It is no longer possible to copy a linked file into the same project where, previously, this created a
copy of the actual file on the disk.

•

2574102 (1084208)
When you convert Net Express projects that compile to .int or .gnt files to Visual COBOL for Visual
Studio, the application environment variables are now imported successfully.

•

2569777 (1083953)
It is now possible to convert Net Express projects that do not contain any COBOL source files to Visual
Studio projects.

•

2568638 (1083900)
You can now set environment variables used by the native COBOL Run-Time system during
initialization from the project properties - click Environment on the Application tab.

•
•

2539447 (1081251)
Pressing Enter to create a new line now preserves the indent in the COBOL editor in Smart edit mode.
2496411 (1077769)
Pressing End inside the writing area of the COBOL editor now positions the cursor on the first nonblank character, if columns 12-72 contain any text. If the line is blank, the cursor is positioned on
column 73.
2496351 (1077767)
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•

•

•
•
•
•
•
•
•
•
•
•
•
•

•
•
•
•
•
•
•
•

•

The COBOL editor now supports a "Smart edit mode" (see Tools > Options > Text Editor > Micro Focus
COBOL > Margins) which is enabled by default. In Smart edit mode, when you press ENTER in the
code (A/B) area the comments move to the next line and stay in the right-hand area.
2496350 (1077768)
You now receive a suitable error message when you try to use "Start Without Debugging" with
Mainframe Subsystem Application projects.
2495298 (1078343)
You can now use Solution folders to group projects in your solution.
2259310 (1065760)
If, when you start debugging, the debug target does not exist you now receive an error message that
correctly states the missing filename.
Any leading or trailing spaces you added to the name specified in the "Output name" field on the
Application tab in the properties of a native project are now ignored.
Class view no longer contains outdated information from previous background syntax checking after
classes have been renamed.
Class view no longer contains outdated information from previous background syntax checking when
the files defining types have been removed.
A problem with navigating to member definitions from the Class View has been resolved.
A problem with navigating to member definitions from the Class View has been resolved.
An issue where canceling some of the dialogs in Tools > Options resulted in the changes being saved
anyway, or the pages not reverting when next loaded, has been resolved.
You can now start and stop servers from the Server Explorer when using the local machine's IP
address or DNS name.
It is now possible to debug a project that has its "Compile for debugging" setting enabled in the project
properties for the Release configuration.
Selecting a project in Class View now triggers background syntax checking, if it has not been performed
for that project yet.
If you have .NET Framework v. 4.5 installed, creating a COBOL Web application with Visual Studio
2010 Shell was failing with a Signal 114 error and was causing the IDE to crash. This issue has been
resolved for the IDE. To work around the issue when you compile COBOL Web Applications from the
command line, you need to manually set the environment variable VisualStudioVersion to 10.0 before
compiling.
Using the tab character in comments no longer causes issues with the colorization of the code.
The Visual Studio IDE no longer crashes if you try to close it while directives scan is in progress.
Adding files to a project when directives scan is disabled was taking a long time to complete.
Friend assemblies (as identified by the InternalsVisibleToAttribute) are now correctly handled during
syntax checking, and types are correctly found within friend assemblies when they are present.
An issue with adding new platforms or configurations to a project or solution when the project contains
pre- or post-build events has been resolved.
A problem with navigating to member definitions from the Class View, when the definitions occurred
within copybooks used within partial classes, has been resolved.
A problem where trying to navigate to the source of an item from the Class View positioned you on the
wrong line, has been resolved.
An issue where the Implements smart tag was present for interfaces that were fully implemented (when
some of the methods from that interface were implemented explicitly; and in addition to another
interface which was not fully implemented) has been fixed.
An issue where method signatures were rendered incorrectly if the member had a 78 level item in its
local storage has been resolved.
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Resolved Issues
The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem
Incident (RPI) number (in parentheses).
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

.NET Compiler
.NET ESQL Support
.NET Native Debug
.NET RTS
Adis
Animator (Character version)
CAS (COBOL App Server) General
CAS Security
CAS XA Switch modules
CCI TCP/IP
Compiler
Cob/Cbllink/Cblnames (32-bit PC)
Data Tools Converter
Data Tools Editor
Data Tools Layouts
Documentation
Eclipse - Debug
Eclipse IDE
File Handling - External File Handler
File Handling - Fileshare
IDE Debugging
JVM - Compiler
JVM - RTS
MF Common Client
MF Communications Server
MF Directory Server
MF Server Administrator (GUI)
MVS REXX Emulation
NCG
RTS
Samples Browser
Setup Issues
Setup Issues (UNIX)
SQL: DB2 ECM
SQL: OpenESQL
Vision File System
Visual Studio IDE
XML Extensions
XML syntax support runtime

.NET Compiler
Back to the list
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•

•

•

It is now possible to query data items during debugging for programs containing multiple entry points,
compiled with the directive PERFORMTYPE"OSVS".
2663738 (1090935)
The correct calling conventions are now used for programs that have multiple platform invokes with
different calling conventions.
2660948 (1090751)
Accessing an ILSMARTLINKAGE class built for a group containing an OCCURS DEPENDING ON item
no longer causes unexpected results, as it now uses the maximum length for the OCCURS
DEPENDING ON item within the property access methods for the group.

•

2654127 (1090119)
A SEARCH statement where the table name contains DBCS characters now compiles to managed
code successfully.

•

2652827 (1089896)
When compiling managed COBOL, a move from an alphanumeric field to a numeric property no longer
causes an error. (This was an error that was introduced in Visual COBOL 2.1 update 1.)

•

2651658 (1089833)
Incorrect code is no longer produced when creating WCF services.

•

2649616 (1089641)
'Illegal format: literal' errors are no longer generated when building and running a website.

•

2645733 (1089290)
Incorrect control flow no longer occurs when an EXIT PROGRAM statement is in a paragraph by itself,
and that paragraph is performed from elsewhere in the program. Previously, this could result in the
EXIT PROGRAM being ignored.

•

2642765 (1089164)
When debugging .NET COBOL on a 64-bit system, the result field is now updated correctly when you
step over a divide operation.

•

2642169 (1088841)
Previously, if a .NET managed program called a C++ method, where one of the parameters was
marked with the IsLong modifier, the code failed at run time with a "method not found" error.

•

2615417 (1088095)
The Form Designer is now working correctly when PIC 1 data items containing boolean literal values
are inserted into a working-storage section associated with a Windows form.

•

2612621 (1087910)
Previously, when a callfh directive targeted a method expecting more than the normal two parameters,
you received a system error at compile time.

•

2611093 (1087662)
Stepping over an IF statement while debugging now works as expected. Previously, it could leave the
cursor pointing at the first statement following the IF, even though the associated conditional expression
evaluated to false.

•

2610824 (1087679)
A new directive, ILSHOWPERFORMOVERLAP, which identifies those procedures that form part of an
overlapping perform range is now available.

•

2607319 (1087299)
The ATTACH and DETACH statements no longer produce compiler errors when referencing an event
declared in a different class.

•

2604429 (1086973)
A SORT statement used in an object method, where the program did not have OBJECT/END OBJECT
markers, could result in an "index out-of-range" exception at run time.
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•

2596409 (1086418)
In managed code, some COBOL numeric fields are now optimised to 32-bit or to 64-bit binary fields,
regardless of their definition in the COBOL source. This means that fields defined as DISPLAY or
COMP-3, for instance, which do not form a part of a group, may be stored as binary fields. The
Compiler inserts the required code to make the behavior of these fields the same as if they had not
been optimised.

•

2595775 (1086432)
In .NET COBOL, when HOSTNUMCOMPARE is specified, a numeric item containing a level 88 with
multiple values no longer produces invalid code.

•

2595331 (1086088)
The use of EXTERNAL files in class programs compiled for managed code no longer leads to invalid
code generation.

•

2595177 (1086071)
When defining a field using the syntax: 01 s1 type String. an EVALUATE statement using the field as
the subject now executes the correct control flow.

•
•
•
•
•
•

2594906 (1086055)
The use of host variables defined as type DateTime no longer produce spurious compiler errors.
2594156 (1085997)
An error that could cause a MissingMethodException for managed programs compiled with
charset(ebcdic) has been fixed.
When a COMPUTE target had more than 18 significant digits and the COMPUTE expression included
division, the decimal scaling could be lost, producing incorrect results.
The error reporting for forward references and ambiguous references has been enhanced.
In managed COBOL, a statement of the form "set string-type to interface-type", where string-type is an
item of type string and interface-type is an item of some interface type, was producing invalid code.
Spurious errors relating to indexed file keys are no longer produced as a result of using implicit local
declaration.

.NET ESQL Support
Back to the list
•

•
•

•

Previously, OpenESQL incorrectly handles Oracle NOWAIT, WAIT n and SKIP LOCKED cursor options
when SQL(TARGETDB) was set to ORACLE.
2649989 (1089640)
The OpenESQL preprocessor now accepts SQL(DATE=ODBC) and SQL(TIME=ODBC).
2641087 (1088749)
The behavior of various cursor types in different usage scenarios is now documented, showing how the
product behavior is now more consistent across different database types for error detection and
reporting.
2614802 (1088009)
Previously, a nullable host variable in a stored procedure call might have generated an invalid call
statement.

.NET Native Debug
Back to the list
•

Stepping a program that contains a screen section and compiles to .int code no longer causes the IDE
to hang when an error occurs in the screen section.
2613594 (1087908)
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.NET RTS
Back to the list
•

Using binary floating-point items on a machine with a non-English locale no longer produces errors.

•

2657599 (1090407)
The RuntimeServices Add() method for .NET COBOL no longer gives an exception for some instances
of COBOL classes.

•

2642836 (1088926)
Using "DIVIDE ... GIVING quotient ROUNDED" where "quotient" evaluates to zero no longer causes an
exception.

•

2641108 (1088761)
An error in JVM COBOL converting the result of a floating point expression to a fixed point expression
has been fixed.

•

2610381 (1087558)
Computation of fractional exponents in .NET managed COBOL has been improved and is now much
faster.
2594740 (1086047)

Adis
Back to the list
•

•

Statements of type "DISPLAY SPACES AT LINE... POSITION... SIZE..." now only clear the screen at
the specified coordinates and for the specified size.
2644054 (1089103)
The Compiler and ADIS now support RM/COBOL ACCEPT and DISPLAY behavior, including when the
Compiler DIALECT(RM) directive and the RM2VCOB configuration in ADISCTRL are both used.
2616898 (1088510)

Animator (Character version)
Back to the list
•

Animator now displays the correct program name on the status bar.

•

2475333 (1076125)
An error message is now displayed if there is a problem accessing the terminal when animating using
Character Animator.
2050690 (1050314)

CAS (COBOL App Server) General
Back to the list
•
•

•

casgate no longer crashes when it receives a shutdown request from MFCS.
2657261 (1090327)
When an MFCS process terminated while it was processing an EZASOKET function for an application,
the SEP remained in a waiting state indefinitely. Recovery processing now dispatches the SEP with a
TERMAPI.
2653313 (1090061)
EZASOKET applications are now tied to a single comms process for the life of a task. Previously, in the
event of termination of a comms process (if the process was not being used by an active EZASOKET
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application), recovery would cause any active EZASOKET applications to dispatch the new comms
process on the next EZASOKET call (which would then fail) rather than the one it was already using.
•

•

•

2653313 (1090060)
When an enterprise server was processing a very large number of JCL jobs for the same class, a job
could be locked for dispatch in SYSZJOBD forever.
2617413 (1088420)
The EZ sockets SELECT and SELECTEX APIs now duplicate mainframe behavior in ignoring mask bits
that do not correspond to allocated descriptors. This means, for example, that SELECT can be passed
as a mask set to -1 (all bits set) to refer to any sockets the application has open.
2609555 (1087715)
A problem with submitting jobs when "Local ES Security enabled" is checked for mfuser on the Users
page in ESMAC has been resolved.

•

2605873 (1087287)
Jobs active during shutdown are moved back to the input queue when the server restarts.

•

2588701 (1085584)
Previously, when retrieving the spool information, the text of some error messages has been truncated.

•

•

2582713 (1085017)
Logging has been added for the resource managers to facilitate recovery from failures that leave the
resource managers such as DB2 and MQ with in-doubt transactions. You only need to log if the
resource manager switch modules are configured to respond to xa_recover() calls. Logging may affect
the performance so you can disable it as follows - edit the server from the Enterprise Server
Administration, click the General tab and type the following in the Configuration Information text box:
[ES-Environment] ES_XA_LOG_SUPPRESS=Y
2582570 (1085539)
If you define an XA resource definition in MFDS for MQSeries, you must deselect IBM MQ in the SIT
definition in ESMAC, otherwise you will get a -5 error when the XA Switch is used.

CAS Security
Back to the list
•

•

•

A "redundant" or "high-availability" mode is now available in the Enterprise Server External Security
Facility. It enables you to configure multiple equivalent Security Managers and let processing continue
as long as at least one Security Manager is available. To enable this feature, add the following to the
configuration text area for the security configuration (either in the default Enterprise Server Security, the
MFDS Security, or on the Security tab for a specific enterprise server): [Operation] redundant=yes
2646298 (1089343)
Previously, when using IMS with LDAP-based security, the system could sometimes stop processing
requests for four minutes, and then issue a series of messages in the console log to indicate that
threads had timed out waiting for a thread lock. The system would then generally recover and start
processing again.
2640581 (1089108)
The fix for this RPI addresses the following specific situations:
1. Installation with an ESM that is not case sensitive for user IDs (for example - when sysad, SYSAD,
SysAd and other case combinations are all recognized by the ESM as the same user).
2. Installations where all user IDs are of a the same case - either uppercase or lowercase.
3. Installations where the user IDs are of mixed case and you would like to suppress any additional
ESM authorization attempts for keying errors.
4. Only ESM-backed security is affected.
You can now use the environment variable "ES_ESM_IDPW_CASE=xy" where "x" = user; ID case and
"y" = Password case. The values for "x" and "y" are:
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•
•
•

U = Always uppercase
L = Always lowercase
M = Mixed case and case sensitive

When this environment variable is set, Enterprise Server will only make one attempt to identify a user
presenting the user ID and password as is (M), folded to uppercase (U) or folded to lowercase(L). If this
environment variable is not set, the legacy Enterprise Server behavior will be used. For the legacy
behavior for CICS, the User ID and the password are used as supplied possibly filtered by the
uppercase translation configuration of the sign-on transaction. For the legacy behavior for ESMAC and
IMS you have the following sequence - first, the user ID and password are used as supplied. If the
authentication fails, the User ID is folded to uppercase and used again. If this fails as well, both the user
ID and the password are folded to uppercase and the used.
•

•

•

•

•

2640427 (1088819)
For Enterprise Server External Security, the MLDAP ESM Module now supports retrying the connection
to the LDAP server if it fails to connect. This provides some fault tolerance if the server is not
immediately reachable. See the MLDAP ESM Module documentation for more information.
2619088 (1088485)
When using an External Security Manager (ESM), an IMS printer no longer passes authorization
incorrectly when it is unknown to the ESM.
2617526 (1088978)
When the LDAP-based security has a long timeout (over four minutes) configured for LDAP operations,
the ESF Manager now increases the timeout for thread locks accordingly so thread locks do not expire
prematurely while the MLDAP ESM Module is waiting for a slow LDAP server.
In Enterprise Server's External Security Facility, the MLDAP ESM Module normally attempts to set a
user's failed-login count and last-login-time if the user class includes the associated LDAP attributes
(microfocus-MFDS-User-LoginAttempts and -LastLoginTime). You can now disable this from the
Security Manager configuration. See the documentation for the MLDAP ESM Module for more
information.
The cas-to-ad utility, which is used when initially configuring LDAP-based security for Enterprise Server,
now picks up the correct path for the default location of the CICS resource definition file (dfhdrdat).

CAS XA Switch modules
Back to the list
•

•

If a ROLLBACK is already in operation when an XA ROLLBACK is requested, Enterprise Server sees
the rollback as being successful.
2653121 (1089931)
The XDB XA switch module was updated to add a missing variable definition which prevented
compilation.
2638370 (1088599)

CCI TCP/IP
Back to the list
•

•

CCITCP now supports more than 4000 clients per server process on UNIX systems. CCITCP's memory
consumption with large numbers of clients should also be reduced, compared with previous releases.
2589460 (1089134)
CCI has been extended to allow the user to tune the content and location of first failure error messages
produced by CCI. This is controlled by the errlog_path option in the cci.ini configuration file.
2083845 (1053206)
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Compiler
Back to the list
•

Programs with data names containing certain DBCS characters now compile as expected. Previously,
they would incorrectly report error message "COBCH0005 User-name not unique.".

•

2663436 (1090882)
VALUE clauses on THREAD-LOCAL data items are now always correctly initialized on a per thread
basis.

•

2659874 (1090647)
Debugging with Expression view expanded to show many qualification levels of a data record no longer
causes the IDE to crash.

•

2659532 (1090682)
A MOVE of a numeric literal to a JUSTIFIED RIGHT data item now executes as expected.

•

2658757 (1090641)
The MOVELENCHECK directive now also includes checking when the source item is an alphanumeric
literal.

•

2656595 (1090311)
When compiling with DIALECT"ACU", a comparison between a numeric item and the figurative
constant NULL now works as expected.

•

2653033 (1089923)
Comp-1 data items are now processed correctly under DIALECT"RM". Previously, they were treated as
binary floating point items.

•

2652327 (1089892)
Preprocessors now work as expected with the DIALECT"ACU" compiler option.

•

2649324 (1089577)
The DIALECT(RM) directive now sets PERFORM-TYPE(RM).

•

2647147 (1089366)
Large EXEC statements containing DBCS characters now compile without error.

•

2645584 (1089204)
List file output with the DATAMAP directive is now shown correctly for SJIS data names.

•

2643308 (1088962)
The DBCS hyphen character x"817C" is now treated as occupying the correct number of column
positions, and so prevents spurious compile errors for comments in Area C.

•

2642431 (1088863)
Programs using ACUCOBOL-GT index names now execute as expected.

•

2641124 (1088755)
A VALUE clause on a national data item that specifies a figurative constant now works as expected.

•

2640826 (1088820)
An "out of memory" error when compiling ACUCOBOL-GT programs with both COPY REPLACING and
REPLACE statements has been fixed.

•

2640304 (1088671)
$DISPLAY of SJIS characters now works as expected.

•

2640050 (1088644)
Tab characters on the same line as DBCS characters no longer cause margin issues.
2638792 (1088607)
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•

The maximum number of extensions supported by the COPYEXT directive has been increased to 25.

•

2618274 (1088353)
Literals assigned to DBCS data items are now checked for valid content.

•

2618240 (1088339)
When running under RM/COBOL or ACUCOBOL-GT emulation, appropriate declaratives are now
executed for an unsuccessful DELETE FILE operation.

•

2616717 (1088313)
The emulation of RM/COBOL has been improved regarding the default encoding of numerics types.

•

2607368 (1088045)
Preprocessor-generated error messages now appear correctly in the Eclipse IDE.

•

2603384 (1087029)
The error message for when special register names are used as data-names has been improved.

•

•

2599694 (1086646)
A qualified reference to a paragraph in another section followed by an unqualified reference to the same
paragraph now compiles without error.
2598461 (1086498)
Display statements are now displayed correctly when using the window1 preprocessor.

•

2591903 (1085826)
A syntax error is now produced if you attempt to use a data item with more than 18 numeric positions in
extended ACCEPT/DISPLAY syntax.

•

2590649 (1085688)
The COPY statement no longer requires Katakana characters in a copybook's name to be enclosed in
quotation marks in order for the copybook to be found.

•

2582689 (1085009)
With regards to file handling, the DIALECT(RM) compiler directive now better emulates the default
behavior of the latest RM/COBOL product.

•

2582096 (1084955)
An error with EXTERNAL files where the fd name is the same as the name of an OS function (e.g. sin
or strcpy), which caused an rts error 114, has been fixed.

•

2492339 (1077479)
An error in ADD statements with multiple targets, where one of the targets has a subscripted subscript,
has been fixed.

•

2189318 (1062255)
Error messages 'RTS226 External file definition inconsistent' and 'RTS227 External data definition
inconsistent (Fatal)' have been enhanced to give additional information.

•
•
•
•
•
•

2188868 (1062214)
Parsing and consistency checking of the FOREGROUND-COLOR attribute in DISPLAY statements has
been improved.
The Compiler no longer crashes when processing the USE Compiler directive and the specified
directive file does not exist.
Under a Shift-JIS locale, you can now successfully compile a program containing tilde characters.
EXEC statements are now subject to the action of REPLACE statements (INCLUDE names excepted).
An INSPECT statement with both 'TALLYING .. FOR TRAILING ..' and 'REPLACING TRAILING ..'
syntax now compiles successfully and executes as expected.
The CHANGE-MESSAGE and HIDE-MESSAGE directives have been enhanced to allow non-severe
SQL and CICS errors to be configured (their severity changed or completely suppressed). This can be
achieved using the error message's 2-character sub-component prefix; for example, CHANGEMESSAGE(ES1000 N). If no prefix is specified, CH is assumed.
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•

•
•

You now receive a warning when you use a TYPEDEF-NAME as a parameter for the PROCEDURE
DIVISION header of an ENTRY statement, except for external programs or program prototypes where
this syntax is legal.
The Compiler no longer crashes with an RTS114 error after finding multiple Report Writer syntax errors.
A error processing a bitwise logical expression that has a subscripted operand where the subscript is an
arithmetic expression has been fixed.

Cob/Cbllink/Cblnames (32-bit PC)
Back to the list
•

CBLLINK no longer gives an error when an object file is specified in a fully qualified path containing a
dot.
2605052 (1087384)

Data Tools Converter
Back to the list
•

DFCONV no longer fails on non-Intel byte order processors when the conversion uses an STR file.

•

2658596 (1090476)
Converting a Mainframe-Report-ANSI file to a PC-Print file where the file begins with a form feed no
longer results in a line feed being inserted in the PC-Print file before the form feed.

•

2652812 (1089911)
The Data File Converter no longer fails with DFC661 Error during conversion when executed in 64-bit
mode.

•

2649118 (1089569)
dfconv no longer fails with "DFC161 Error during conversion" if the profile file extension (.PRO) is not in
upper case on UNIX and Linux platforms.
2642112 (1088846)

Data Tools Editor
Back to the list
•

The Data File Tools editor no longer crashes when inserting a record after the last record of the file.

•

2655432 (1090160)
The Data File Tools editor no longer corrupts a PIC 9 data item when the field is edited from within the
record layout view.
2655011 (1090143)

Data Tools Layouts
Back to the list
•

Setting a condition value for a PIC 9 data item no longer displays a corrupt value.

•

2612439 (1087833)
Setting a condition value for a PIC 9 data item no longer displays a corrupt value.
2612152 (1087782)

Documentation
Back to the list
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•

The documentation was not clear about the range of acceptable values of EX_XA_????_NB_RETRIES
or the consequent system behaviours. This has been corrected.

•

2593300 (1085893)
The documentation has been amended to alert users that under certain conditions, a dynamic binding
error is possible

•

2553077 (1082557)
You no longer need a 64-bit enterprise server in order to communicate with Microsoft BizTalk Host
Integration Server on a 64-bit machine.

•

2614060 (1087978)
The documentation has been updated so that the help page more accurately reflects the ESMAC
screen.

•

2611733 (1087753)
The product documentation now includes information about the ES_JESYSMSG_OUTPUT
environment variable.

•

2604533 (1087004)
The documentation has been updated to clarify the effect of escape characters on path names.

•

2594224 (1086013)
The CPMT transaction no longer supports the CEDF or NOCEDF functions.

•

2527592 (1089531)
The documentation has been updated to remove references to ERRORLEVEL in UNIX environments.

•
•

2610423 (1087575)
The documentation has been updated to provide more information about the MFJAMS LISTCAT
command.
When invoking MFSORT from the command line, the maximum length of the command is 1024
characters. Characters after this limit are ignored, and if this truncation causes an invalid/incomplete
command, an error is produced.

Eclipse - Debug
Back to the list
•

The process being debugged will no longer hang when there is an error in the JCL code after a Stop
Debugging request.

•

2651928 (1089990)
The contents of the COBPATH environment variable are now picked up correctly when debugging.

•

2641660 (1089106)
Eclipse no longer exits with a Run-Time System error 153 during remote debugging.

•

2616122 (1088263)
On Windows, JIT debugging no longer fails to attach to the process being debugged.

•

•

2614145 (1088667)
Debugging multiple programs while there are items in the Expression View no longer results in the
Eclipse IDE closing when the program changes.
(595485)
The value of variables shown by the debugger was truncated by LOW-VALUE characters. It is now
possible to modify variables containing LOW-VALUES only in the Hex mode of the Change Value
dialog.
(595390)
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Eclipse IDE
Back to the list
•

The items in COBOL Explorer are now ordered using the whole file name rather than using the suffix
and then the rest of the name.

•

2653659 (1089996)
Trying to open a COBOL file from the CVS Repositories view resulted in the tree view display becoming
corrupted and the editor was not displayed.

•

2652853 (1090200)
The COBOL Copy view no longer shows corrupted text when the replacement text was shorter than the
text it replaced.

•

2652219 (1089888)
File level SQL settings can now override project level SQL settings.

•

2647596 (1089619)
You can now start debugging after choosing a different program name or launcher in a Remote COBOL
Application debug configuration.

•

2647181 (1089402)
The error markers in the current project are now correctly removed when all errors in projects upon
which the current project depends are fixed.

•

2646469 (1089305)
list files generated for the IMS files in your project are now produced in subfolders of the Listing
directory of the project.

•

2640473 (1088709)
Double-clicking an error in the Problems view in Eclipse now opens the correct file.

•

2610500 (1088142)
Typing '*' in column 1 in the editor for applications that use a mainframe dialect no longer comments out
the line.

•

2608522 (1087593)
The performance of the background syntax checking has been improved so it does not slow down the
debugger.

•

2606836 (1087240)
Background parsing of programs in remote projects would sometimes fail to complete if a COBOL
Editor window was open when Eclipse was started.

•

•

2605902 (1087319)
The .cobolBuild file now includes properties to control the fails on error. From the command line, you
can set the value of these properties to true in order to make Ant abort the build at the first error. Use
the general property "failOnError" if you need to abort on errors in any file types - COBOL, cobollink, lbr,
bms, ims. The following properties control failing on error in the specific file types: cobolFailOnError,
cobollinkFailOnError, lbrFailOnError, bmsFailOnError, imsFailonError. Note that lbrs cannot be created
through Enterprise Developer but only using Visual COBOL.
2587325 (1085781)
COBOL Copy view no longer shows corrupted text if there were REPLACE statements that introduced
additional source lines.

•

2586983 (1085408)
Previously configured remote connection details are now preserved when you restart Eclipse.

•

2575926 (1085613)
The remotedev scripts now allow you to have a default shell of /bin/csh.
2571165 (1088947)
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File Handling - External File Handler
Back to the list
•

•

•

•

•

•

•
•

•

•

•

•

For SORTIN, all data sets in a concatenation must use the same RECFM - either all fixed-length or all
variable-length. Also, if using fixed-length records, LRECL must be set the same for all data sets.
2654517 (1090095)
A COMMITFLUSH no longer causes file corruption. Previously, corruption was possible with
COMMITFLUSH on when a process, having done only a rewrite that changes non-key data, is
committed after another process has altered the files size.
2652378 (1090281)
The RM RECOVER1 utility is now distributed with Visual COBOL in case RM indexed files need to be
recovered or rebuilt.
2650917 (1090175)
Support has been added for the ASSIGN TO PRINT syntax when accessing RM/COBOL data files.
Specifically, BEFORE ADVANCING <count>, AFTER ADVANCING <count>, BEFORE ADVANCING
PAGE, and AFTER ADVANCING PAGE now work correctly and produce the same print file contents as
they do in RM/COBOL.
2649809 (1089792)
The RM/COBOL configuration option
RMFM_RUN_INDEX_FILES_DEFAULT_FILE_VERSION_NUMBER 2 now correctly creates a version
2 RM/COBOL indexed file.
2649414 (1089679)
A SORT action no longer fails due to an illegal filename when the SORTTEMP file is specified to be an
RM file using EXTFH.CFG.
2648865 (1090292)
File names containing embedded spaces now work correctly in XML Extensions.
2648306 (1089486)
The correct file status "23" is now stored in the file status data item, which will cause the proper
INVALID KEY condition action for REWRITE RANDOM or DELETE RANDOM I/O operations on an
RM/COBOL data file.
2648182 (1089461)
A WRITE or REWRITE operation on a fixed record length RM/COBOL or ACUCOBOL-GT file no longer
generates an erroneous 44 error after a READ of a short record.
2647143 (1089369)
DELETE and REWRITE operations on an RM/COBOL indexed file with DYNAMIC access and where
the prime key allows duplicates now work correctly, meaning that the behavior matches RM/COBOL,
where the operation behaves like sequential access and deletes or rewrites the current record.
2646274 (1089289)
When opening an RM/COBOL data file for input, a READ WITH LOCK after a READ WITH NO LOCK
no longer returns an erroneous 99 (record locked) error. This matches RM/COBOL behavior for a file
opened in the input mode.
2644830 (1089726)
When accessing RM/COBOL data files, a file status of 04 is correctly returned where appropriate.

•

2616717 (1088310)
When accessing RM/COBOL data files or calling C$RERR, file statuses '44,03', '44,04', and '44,07' are
correctly returned where appropriate.

•

2616717 (1088465)
When accessing RM/COBOL data files or calling C$RERR, file status '47,01' is correctly returned where
appropriate.
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•

2616717 (1088467)
When accessing RM/COBOL data files or calling C$RERR, file status '48,01' is correctly returned where
appropriate.

•

2616717 (1088468)
When accessing RM/COBOL data files or calling C$RERR, file statuses '93,02' and '90,05' are correctly
returned where appropriate.

•

2616717 (1088469)
A file status of 90,05 is now correctly displayed as 90.

•

2616717 (1088449)
C$RERR now reports a meaningful 30,22,nnnnn error, where nnnnn is the Micro Focus extended
status, when the File Handler diagnoses an operation error on an RM/COBOL data file.

•

2616717 (1088470)
File Handler now converts the charset of all instream data in a concatenated dataset to that of the
calling program.

•

2606382 (1087212)
The file locking for VB files with DISP=SHR has been removed. It is now the user's responsibility to
ensure that other users do not update the file at the same time.

•

2605857 (1087302)
EXTFH configuration options specified under the FOLDER tag now work correctly with UNIX files when
they are specified with an absolute path in the SELECT statement of a COBOL program.

•

2594733 (1086089)
Concatenating multiple SYSIN DD statements now works correctly.

•

2590465 (1085905)
File corruption no longer occurs when you make two rewrites of a record in the same transaction, where
the first rewrite changes an alternate key and the second rewrite changes it back again.

•

2576793 (1084780)
CTF tracing no longer defaults to showing CTF handles as errors. CTF tracing for handles now only
appears for DEBUG and ERROR levels.

•

2566161 (1083551)
If the DDname is missing from JCL, the value of COBDATA is not used to search for a file.

•
•

2559292 (1084935)
The rebuild help message file has been updated to correct a typo.
Fileshare now supports the ACU and RM file formats.

File Handling - Fileshare
Back to the list
•

SORT no longer abends if the SORTIN file is a Fileshare file.

•

2653753 (1090002)
A commit-prepare now returns non-zero error code if the Fileshare server is not running.

•

•

2637773 (1088492)
If the Fileshare server crashes before a commit or a rollback in the two-phase commit, the transactions
before a commit-prepare are now committed while recovering the file.
2637773 (1088493)
Byte-stream routines called from Fileshare clients now work correctly with a 64-bit Fileshare server.
2607314 (1088601)
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IDE Debugging
Back to the list
•

If you set the debug_on_error tunable to 1, then the debugger will now attach for all RTS errors.

JVM - Compiler
Back to the list
•

•
•

•

•
•

Previously, a program using a MAX OR MIN function with an ALL parameter was generating bad code
when compiled for JVM.
2647112 (1089359)
Previously, you could receive some warnings for calls to the RM library routine C$GetEnv.
2601487 (1086710)
When compiling JVM COBOL, if the PERFORMTYPE directive is not set to the default value of mf, very
large programs sometimes do not compile. In such cases, 'COBCH1633 - Procedure division too large
or complex - try using performtype(mf)' is displayed. Compiling with performtype(mf) normally fixes the
problem.
2581224 (1084860)
In Windows environments, if a COPY statement specified a file name that was not in quotation marks,
or did not include the full extension, then setting a breakpoint in that copy file was not always
successful.
2577765 (1084637)
Copy statements that reference a file whose path contains spaces no longer cause errors.
2577765 (1086750)
Previously, the JVM Compiler did not recognize COBOL static inner classes (that is - nested classes
without a SHARING PARENT, or nested classes produced using ILSMARTNEST).

JVM - RTS
Back to the list
•

•
•

When using JVM COBOL with Apache Tomcat, you no longer see warning messages from the
org.apache.catalina.loader.WebappClassLoader checkThreadLocalMapForLeaks class relating to
classes in the package com.microfocus.cobol and below.
2612595 (1088144)
When creating a debug configuration for a JVM COBOL application, superfluous classes are no longer
listed on searching for a Main class.
Previously, when a thread called a subprogram with thread-local storage it might have intermittently got
reset when creating many threads quickly.

MF Common Client
Back to the list
•

•

A problem with the Micro Focus Common Client not supporting 64-bit COBOL programs on UNIX and
Linux has been fixed. This enables ECI functionality for 64-bit COBOL programs, and may correct
issues with certain other features such as Web Services clients.
2642116 (1088854)
When there are multiple directories configured in mf-client.dat, the service deployment tools (such as
imtkmake) and the IDE features now correctly scan all directories for deployment destinations and not
only the first one.
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MF Communications Server
Back to the list
•

•

•
•

•
•

In EZASOKET/EZACICAL applications, the "reserved" portion of the socket-address information
returned by API calls (such as GETSOCKADDR and GETPEERADDR) is now set to low-values, for
improved mainframe compatibility.
2659699 (1090549)
You no longer receive a run-time system error when an invalid IMS Connect message is received with a
missing end-of-message indicator.
2649746 (1089727)
A problem causing IMS Connect conversations to an enterprise server to hang has been resolved.
2645771 (1089247)
For SSL-enabled listeners in Enterprise Server, MFCS now offers the option of setting SSL keyfile
passphrases using a user exit module. For instructions and a sample module, contact Micro Focus
SupportLine.
2641670 (1088950)
Intermittent failures in the CICS Web Interface servers that send chunked responses have been fixed.
The SO_LINGER socket option in CICS sockets (EZASOKET / EZACICAL) now works correctly.

MF Directory Server
Back to the list
•

•

2654069 (1090069)
The MFDS XML import command line option correctly sets the value of the listener's SSL client
authentication option on import.

•

2653699 (1090115)
The MFDS command line options to export or import server configuration data when using an external
Security Manager now work correctly.

•

•

2652779 (1089981)
If the custom configuration text for an Enterprise Server instance was larger than 4K and the "Create
XML repository copy" repository option was selected or, if the server configuration was exported in XML
format, the MFDS process could terminate.
2650330 (1089683)
The MFDS -x and -g command line options for creating and importing Enterprise Server instance
configuration in XML format can now be run against an MFDS process running on a specific TCP
address and port by using the CCITCP2 and CCITCP2_PORT environment variables.

•

2646427 (1089303)
The correct details for Enterprise Server "MSS Inter-System Communication" conversation type
listeners can now be exported and imported using the MFDS XML export/import feature.

•

2644237 (1089091)
The "Directories" link in the Enterprise Server Administration GUI did not function correctly based on the
configured Security Manager permissions for a logged on user.

•
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In the Enterprise Server Administration HTML GUI, clicking "Update All" on the Security Manager List
page while an enterprise server instance using external security was started would cause the MFDS
process to terminate.
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2583624 (1085073)
When you use casstart from the command line to start an enterprise server instance that appears as
"Not Responding" in the Enterprise Server Administration, the status log for that server is now cleared
when the server reaches "Started" state.

2570318 (1086170)
MF Server Administrator (GUI)
Back to the list
•

When viewing Enterprise Server Administration from within the Visual Studio IDE, you no longer receive
a script error when clicking Renew in the left-hand side panel.

MVS REXX Emulation
Back to the list
•

•

The REXX engine previously assumed that all hexadecimal strings represented EBCDIC characters.
This resulted in the X2C built-in function producing an incorrect result when a hexadecimal string
representing ANSI data was used. The MFREXX_CHARSET environment variable can now be used to
indicate whether the REXX engine should use EBCDIC or ANSI when working with hexadecimal strings
or performing string comparisons.
2647920 (1089596)
Trace options set in a parent procedure are now propagated to a CALLed internal procedure.

•

2612317 (1087818)
Execs residing in temporary datasets allocated to SYSEXEC or SYSPROC no longer sometimes fail to
load.

•

2579785 (1086478)
The LASTPOS function no longer returns an incorrect result if the 'start' parameter value exceeds the
length of the 'haystack' parameter.

NCG
Back to the list
•

You no longer receive an RTS 114 error when stepping EXEC SQL statements in debug mode.

•
•

2611568 (1088003)
A bug in "display ... upon environment-name" with the [NOT] ON EXCEPTION clause has been fixed.
A bug that affected querying linkage items in a program that has parameters in working-storage has
been fixed.

RTS
Back to the list
•

Using the CBL_EXEC_RUN_UNIT library routine to repeatedly execute non-COBOL processes no
longer causes a 'COBRT105 Memory Allocation Error' error to be produced.

•

2651531 (1090239)
The library routine C$OSLockInfo now works correctly when used in a program compiled with the
DIALECT(RM) directive.

•

2643661 (1089044)
The RANDOM intrinsic function, when compiled in a program using the HOSTNUMMOVE directive, no
longer produces a runtime error if the argument is a literal or a numeric expression.

•

2596268 (1086174)
Dynamic memory allocations using the CBL_ALLOC_MEM call are no longer limited to 2Gb on 64-bit
processes.

•

2513886 (1079960)
On Windows, if an error occurs when creating a coredump file, then a message box is no longer
displayed for core_on_error settings greater than 127.
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•

•

2509666 (1079870)
Reading from STDIN has been enhanced when STDIN is being redirected from a file or from a pipe line
on UNIX. It now automatically reflects the file type without the need for you to use any runtime tunables.
The record size line sequential files return is now the size of the data that is actually read. The full
record size is now read for record sequential files or when you use CBL_READ_FILE.
2468412 (1075670)
When using the kterm terminal emulator, any new terminal Windows created by COBOL will now be
kterm, in preference to xterm. By default, it will use ShiftJis kanji mode and 16 point fonts but these can
be overridden by setting the COBTERMOPTS environment variable. For example, to use EUC kanji
mode and 14 point fonts, use: export COBTERMOPTS="-fn a14 -fk k14 -km euc"

Samples Browser
Back to the list
•

Enterprise Developer now includes samples for the ACU/RM conversion utility and for XML Extensions
and Xcentrisity.
2600450 (1086612)

Setup Issues
Back to the list
•

The Start and Stop scripts for mfcesd and lserv have been improved for handling the possible states
that services and system files may be in.
2657001 (1090384)

Setup Issues (UNIX)
Back to the list
•

startmfcesd.sh has been updated and no longer includes /tmp/mfcesclient* which it starts up. for i in
`ls /tmp/mfcesclient* 2>/dev/null` do rm -rf $i done If no files are present, remove command is skipped.
2657021 (1090386)

SQL: DB2 ECM
Back to the list
•

A required file for the DB2(GEN-SQLCA)directive was missing, causing the directive to work improperly.

•

2659056 (1090501)
The DB2 pre-compiler now saves or restores the RETURN-CODE special register so executing EXEC
SQL statements no longer affects that register.

•

2655173 (1090353)
Previously, the DB2 preprocessor sometimes incorrectly defined the number of host variables to use for
a singleton SELECT when a group host variable was redefined using FILLER.

•

2613602 (1088069)
Previously, the DB2 preprocessor would not generate calls to a system program unless it was linked in.

•

2611937 (1087736)
Previously, the DB2 preprocessor might incorrectly flag indicator arrays as invalid.
2546456 (1088155)

SQL: HCO for SQL Server
Back to the list
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•

•
•

•

•

•

•

•
•

Previously, the SPD Generator tool could generate invalid COBOL parameter names if no parameter
name was pecified and the parameter type was DECIMAL.
2664672 (1091009)
Some thread safety issues that occurred in SQL run-time allocation under load have been resolved.
2658581 (1090459)
The performance of forward-only, read-only cursors in SQL CLR stored procedures has been improved
and a new Compiler directive, SQL(OPTION=OPTIMIZESPCURSORS), has been added to provide
additional control.
2644905 (1089182)
When SQL(DETECTDATE) is used with SQL(DIALECT=MAINFRAME), and the mainframe time format
is ISO, the second component of the time value must be present. This is to avoid ambiguity and
unwanted conversion of simple numeric character strings.
2641203 (1090111)
Under HCOSS, SQL error messages returned from calls to DSNTIAR did not always get translated to
EBCDIC when executing the application in that mode.
2615782 (1088148)
There are new directives, SQL(OPTION=SQCLRTRANS) and
SQL(OPTION=SPCOMMITONRETURN), that resolve some issues with stored procedures that expect
COMMIT and ROLLBACK to behave the same as mainframe DB2.
2611786 (1087718)
You can now use DISPLAY statements with COBOL stored procedures for diagnostics in the same way
as with applications, when you set the SQL(OPTION=SPDISPLAY) directive.
2598617 (1086941)
Previously, after a FETCH NEXT ROWSET statement, the number of rows returned was incorrectly
reported in SQLERRD(3).
Dynamic SQL statements executed by EXEC SQL EXECUTE IMMEDIATE are now correctly converted
to T-SQL when the SQL(DIALECT=MAINFRAME) directive is set.

SQL: OpenESQL
Back to the list
•

Previously, the OpenESQL runtime did not work correctly with the unixODBC 2.3.1 and later ODBC
Driver Managers on AIX platforms.

•

2658290 (1090583)
Using a java.math.BigDecimal host variable as an input parameter to SQL statements caused an
ORA-17041 error.

•

2652362 (1089847)
Previously, when using OpenESQL for ADO.NET, an SQL-CODE error occured when a query timeout
was set from a host variable.

•

2650030 (1089675)
Previously, OpenESQL threw an exception while attempting to set a default JDBC login timeout at
connect time.

•

2647801 (1089421)
When using the Progress Oracle ODBC driver, the OpenESQL runtime incorrectly reported a failure for
a successful INSERT when a successful INSERT was followed by a failing INSERT.

•

2646958 (1089336)
OpenESQL now accepts EXEC SQL DECLARE x STATEMENT END-EXEC statements, where x is a
dynamic SQL statement name. This statement has no effect but is accepted for compatibility with other
ESQL SQL dialects.
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•

2643884 (1089076)
When using SQL Native Client or SQL Server Native Client ODBC drivers, the PIC N(xx) USAGE
NATIONAL host variable caused an error when used with the NVARCHAR(MAX) SQL Server data
type.

•

2601192 (1087619)
When executing code compiled for the JVM, if the run-time system encounters a duplicate symbol, it
now reports an RTS119 error, "the symbol is not unique".

•

2598694 (1086469)
Previously, the precompiler incorrectly reset run time information in large Object-Oriented applications
that had SQL statements across multiple methods which resulted in incorrect SQL runtime errors.

•

2597319 (1086681)
When compiling Oracle applications and using SQL(CHECK), errors were reported for SELECT
statements only. This has been corrected to report errors for all statements.

•
•

2566933 (1083631)
You no longer receive an internal buffer error message when compiling OpenESQL applications under
an MBCS UTF8 locale.
EXEC SQL DESCRIBE or PREPARE INTO now return the correct sqltype for VARCHAR columns
when the SQL(OPTION=DESCRIBEVARCHAR) directive is used. The SQL(DATE) and SQL(TIME)
directives now apply to date and time host variables that are declared with SQL TYPE as well as with
PIC X.

Vision File System
Back to the list
•

RMFM now correctly generates 04,05 (and 04,06) statuses and the file status variable contains 04.

Visual Studio IDE
Back to the list
•

Compiler directives files containing & comment entries are now processed correctly during a
background syntax check.

•

2643547 (1089039)
Using unsupported directives such as "$CONTROL DYNAMIC" no longer causes a message "The IDE
has encountered an unexpected error and is no longer stable. You should save your work and exit."

•

2615891 (1088262)
Projects under source control in Team Foundation Server were not opened correctly in Visual COBOL
for Visual Studio 2012.

•

2611808 (1087801)
Background syntax checking performance has been improved.

•

2574012 (1084232)
Find in Files now includes an option for searching in the copybook paths - COBOL Project Copybook
Paths.

•
•

2495750 (1077749)
You can now successfully rename and change the case of filenames from Solution Explorer.
Previously, when opening a solution that references a missing or inaccessible COBOL project file,
Visual Studio offered to upgrade the missing project file.

XML Extensions
Back to the list
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•
•

A compiler error when processing XML extensions with dialect(rm) set has been fixed.
2589841 (1085641)
Previously, in native code, XML Extensions treated negative literals (such as in the value of a name/
value pair for XML SET XSL-PARAMETERS) specified as parameters in native code as a large positive
literal. It now correctly treats them as negative literals.

XML syntax support runtime
Back to the list
•

Block comments in XML instance documents no longer cause a 201 parsing error.

•

2618943 (1088554)
The XML preprocessor now generates correct output for the COUNT IN clause.
2596137 (1086285)
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Updates and SupportLine
Our Web site gives up-to-date details of contact numbers and addresses.

Further Information and Product Support
Additional technical information or advice is available from several sources.
The product support pages contain a considerable amount of additional information, such as:
•
•
•

The WebSync service, where you can download fixes and documentation updates.
The Knowledge Base, a large collection of product tips and workarounds.
Examples and Utilities, including demos and additional product documentation.

To connect, enter http://www.microfocus.com in your browser to go to the Micro Focus home page.
Note: Some information may be available only to customers who have maintenance agreements.
If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web
site, www.microfocus.com. If you obtained the product from another source, such as an authorized
distributor, contact them for help first. If they are unable to help, contact us.

Information We Need
However you contact us, please try to include the information below, if you have it. The more information
you can give, the better Micro Focus SupportLine can help you. But if you don't know all the answers, or
you think some are irrelevant to your problem, please give whatever information you have.
•
•
•
•
•
•

The name and version number of all products that you think might be causing a problem.
Your computer make and model.
Your operating system version number and details of any networking software you are using.
The amount of memory in your computer.
The relevant page reference or section in the documentation.
Your serial number. To find out these numbers, look in the subject line and body of your Electronic
Product Delivery Notice email that you received from Micro Focus.

On Windows, if you are reporting a protection violation you might be asked to provide a dump ( .dmp) file.
To produce a dump file you use the Unexpected Error dialog box that is displayed when a protection
violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as Normal
(recommended), click Dump, then specify a location and name for the dump file. Once the dump file has
been written you can email it to Micro Focus SupportLine.
Alternatively, you might be asked to provide a log file created by the Consolidated Tracing Facility (CTF) a tracing infrastructure that enables you to quickly and easily produce diagnostic information detailing the
operation of a number of Micro Focus software components.
On UNIX, you can use the Micro Focus UNIX Support Scan Utility, mfsupport, to create a log file that
contains the details about your environment, product, and settings. The mfsupport script is stored in
$COBDIR/bin.
To run mfsupport:
1. Start a UNIX shell.
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2. Set COBDIR to the product with issues.
3. Execute mfsupport from a directory where you have write permissions.
This creates a log file, mfpoll.txt, in that directory.
4. When the script finishes, send the mfpoll.txt file to your Micro Focus SupportLine representative.
Note:
If COBDIR is set to a location that does not contain etc/cobver, the script outputs the contents
of /opt/microfocus/logs/MicroFocusProductRegistry.dat which keeps a list of the
installed Micro Focus products.

Creating Debug Files
If you encounter an error when compiling a program that requires you to contact Micro Focus SupportLine,
your support representative might request that you provide additional debug files (as well as source and
data files) to help us determine the cause of the problem. If so, they will advise you how to create them.
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Disclaimer
This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either
express or implied, including the warranties of merchantability and fitness for a particular purpose. In no
event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect,
incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers
have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation
of liability for consequential or incidental damages so the foregoing limitation may not apply.
Micro Focus is a registered trademark.
Copyright © Micro Focus 1984-2013. All rights reserved.
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