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Micro Focus Academic Program 2.2 Release Notes
These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.
Note: This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link. Web
sites by their nature can change very rapidly and although we try to keep our links up-to-date, we
cannot guarantee that they will always work as expected.
Overview
The Micro Focus Academic Program brings contemporary software development tools and technologies to
COBOL development helping to bridge the gap between the old and the new.
COBOL applications still run many of the world’s business systems, therefore teaching the COBOL
language is a great way to prepare your university's students for a robust IT career in today’s economy.
The Micro Focus Academic Program is designed to support the education and use of the COBOL language
within the academic setting. This program supports our academic partner community through the use of
our COBOL development tools and materials within the classroom.
This program will enable your university to quickly join this growing league of similar academic
organizations in support of the promotion and education of the COBOL language.
Welcome! We’re excited to have you join our growing academic community.
Product Description
The Micro Focus Academic Program Edition package comprises the following products:
•

Visual COBOL 2.2 - delivers the richest development experience for COBOL programming. On
Windows, Visual COBOL is available for use with Eclipse or with Microsoft's Visual Studio 2010 or
Visual Studio 2012 integrated development environments. On UNIX or Linux, it is available for use with
Eclipse. Visual COBOL supports the development and deployment of both JVM COBOL and .NET
COBOL, and of native COBOL applications.
Variants of Visual COBOL include:

•

• Visual COBOL for Visual Studio 2010 and Visual COBOL for Visual Studio 2012.
• Visual COBOL for Eclipse.
Enterprise Developer 2.2 - a contemporary development suite for Microsoft Visual Studio 2010 or for
Eclipse that enables mainframe developers to maintain, develop and modernize mainframe applications
regardless of whether these are to be deployed back on the mainframe or onto an alternative platform.
Enterprise Developer supports IBM COBOL, IBM PL/I, IBM Assembler, IBM CICS, IBM IMS, IBM JCL,
IBM DB2, IBM z/OS file formats and common batch utilities including SORT. This means you can
develop and maintain the core mainframe online and batch applications under Enterprise Developer,
then deploy them back on the mainframe or migrate them onto one of the Micro Focus production
platforms available on UNIX, Linux, or Windows. Variants include:
•
•

Enterprise Developer 2.2 for Visual Studio
Enterprise Developer 2.2 for Eclipse

Micro Focus Academic Program differs from the full version of these products in a number of ways. The
differences are:

4

| Micro Focus Academic Program 2.2 - Release Notes

•
•

You cannot deploy applications on other machines, so Micro Focus COBOL Server and Enterprise
Server are not supplied.
An authorization code for the Micro Focus Rumba 3270 terminal emulator is not supplied.
Note: Micro Focus Academic Program is supplied for Academic use only. It is not to be used for any
commercial purposes. You must be a registered Micro Focus Academic Program Partner in order to
use this software.

For more information, follow the link in the Electronic Product Delivery email for the End User License
Agreement.
Reporting Issues
For the latest information and discussions on this product, or to report issues, visit the Micro Focus
Community Web site.
To check the latest documentation of this product online, go to the Micro Focus Infocenter.

System Requirements
Hardware Requirements
In general, most modern machines will have the required processor and available RAM to run the Micro
Focus products under Windows effectively. For planning purposes, it is recommended to have a minimum
of 2GB of RAM.
Visual COBOL and Enterprise Developer for Visual Studio
Visual COBOL and Enterprise Developer have the following requirements in addition to the requirements of
Microsoft Visual Studio. See the Visual Studio documentation for details of the Microsoft requirements.
The disk space requirements are:
Platform

Visual COBOL

Enterprise Developer

Sentinel RMS License
Manager

x86 Windows platforms

380MB

600MB

35MB

x64 Windows platforms

500MB

750MB

35MB

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.
Visual COBOL and Enterprise Developer for Eclipse on Windows
The disk space requirements for Windows are:
Platform

Visual COBOL

Enterprise Developer

Sentinel RMS License
Manager

x86 Windows platforms

1.05GB

1.2GB

35MB

x64 Windows platforms

1.3GB

1.45GB

35MB

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.
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Visual COBOL for Eclipse on UNIX/Linux
Visual COBOL has the following requirements in addition to the requirements of Eclipse. See the Eclipse
documentation for details of its requirements.
Platform

Visual COBOL

Sentinel RMS license server

x86-64 running Red Hat Linux

664MB

33MB

x86-64 running SuSE SLES

666MB

33MB

Note: The installation requires extra disk space that equals the size of the product you install.

Operating Systems Supported
Note: If you are using Visual COBOL or Enterprise Developer on a 64-bit operating system, you can
produce either 32-bit or 64-bit applications.
For a list of the operating systems each individual product in this package supports, check the Product
Availability section on the Micro Focus SupportLine Web site: http://supportline.microfocus.com/
prodavail.aspx.
•
•

Enterprise Developer is currently supported on Windows 7, Windows 8, Windows Server 2012, and
Windows Server 2008 only.
Visual COBOL for Visual Studio 2012 is not supported on versions of Windows earlier than Windows 7.

Software Requirements
Windows
Note: The setup file will check your machine for whether the prerequisite software is installed and will
install any missing prerequisites and the product components.
Visual Studio IDE
The following Microsoft software is required if you are going to use Visual COBOL or Enterprise Developer
with Visual Studio.
•

A full version of Microsoft Visual Studio 2010 or Microsoft Visual Studio 2012 (Premium, Professional,
or Ultimate), or the the respective version of the Microsoft Visual Studio Integrated Shell. If you do not
have any of them installed, the setup file will install the Visual Studio Integrated Shell.
Note:
•

•
•
•

Microsoft Visual Studio Express Edition is not supported.

Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft
Download Center and search for Windows SDK.
Microsoft .NET Framework 4.0. This is included with the above versions of Visual Studio.
Microsoft .NET Framework 4.5. This is included with Visual Studio 2012.
Note: Visual Studio 2010 Service Pack 1 (SP1) is required if you are using Visual COBOL for Visual
Studio 2010 and Visual COBOL for Visual Studio 2012 on the same machine. If you are connected to
the Internet, the setup file downloads and installs Visual Studio 2010 SP1 1 automatically. If you do
not have Internet access, you need to download Visual Studio 2010 SP1 1 on a machine that has
Internet connection, and then copy the installer to your machine.
In addition, when building a native COBOL project that contains resources you must replace the
cvtres.exe in the bin and bin64 directories of your Visual COBOL installation with the version of
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the file which gets installed with Visual Studio 2010 SP1. You can download Service Pack 1 for Visual
Studio 2010 from the Microsoft Download Center.
UNIX/Linux
The following list contains additional information for installing on UNIX or Linux:
•

•

•

The Korn shell is required for the licensing daemon. After the installation, if the licensing daemon does
not start, check and ensure the Korn shell is installed and then run the /var/
microfocuslicensing/bin/startmfcesd.sh script to start the daemon.
The pax archiving utility is required by the setup file. Pax is distributed with most UNIX/Linux systems
but, if it is missing, you must install it separately. To verify pax is installed, run pax --help or pax -version at the command line.
On Red Hat 6.x, you must have the following operating system libraries installed:
All Visual COBOL products

Additional libraries for Visual COBOL for Eclipse

Additional libraries for HCO for SQL Server Tools

glibc-*.x86_64
glibc-*.i686
libgcc-*.x86_64
libgcc-*.i686
PackageKit-gtk-module-*.x86_64
PackageKit-gtk-module-*.i686
gtk2-*.x86_64
gtk2-*.i686
gtk2-engines.*.x86_64
gtk2-engines.*.i686
libXtst-*.x86_64
libXtst-*.i686
libcanberra-gtk2-*.x86_64
libcanberra-gtk2-*.i686
webkitgtk.x86_64
webkitgtk.i686
xterm (any version)
libgnome.x86_64
libgnome.i686
glibc-devel-*.x86_64
glibc-devel-*.i686

Visit the Red Hat Web site for more information.
•

Xterm, the terminal emulator for the X Window System, is part of your UNIX/Linux distribution but is not
installed by default. Use your UNIX/Linux installation media to install it.

•

You need to set the JAVA_HOME environment variable. When installing the product, set this variable to
a 32-bit Java installation or the installation terminates. For example, execute the following:
JAVA_HOME=java_install_dir

•
•

where java_install_dir is the path to the JAVA installation directory such as /usr/java/javan.n
You need to add $JAVA_HOME/bin to your system PATH variable. To do this, execute:
export PATH=$JAVA_HOME/bin:$PATH
You need to set the LANG environment variable to pick up localized messages. The LANG settings are
English and Japanese only.
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•

GNOME menus and buttons have been standardized across all applications so that icons are not
displayed by default. To keep the icons and the look and feel of previous versions, enable the
menus_have_icons property with the command:
gconftool-2 --type boolean --set /desktop/gnome/interface/menus_have_icons
true

Installation
Installation Restrictions and Requirements
Before starting the installation you should be aware of the following:
•

•

•

•
•
•
•
•

•

•
•

•

If, when you install Visual COBOL for Visual Studio 2010, the machine does not have Microsoft Visual
C++ 2010 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2010 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.
If, when you install Visual COBOL for Visual Studio 2012, the machine does not have Microsoft Visual
C++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2012 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.
You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.
Visual COBOL and COBOL Server cannot coexist on the same machine.
Visual COBOL for Eclipse and Visual COBOL for Visual Studio can exist on the same machine, but this
might cause unpredictable behaviour.
COBOL Server 2010 and COBOL Server 2012 can coexist on the same machine.
Visual COBOL and Enterprise Developer cannot coexist on the same machine.
If, when you install Visual COBOL for Visual Studio 2010, the machine does not have Microsoft Visual
C++ 2010 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2010 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.
If, when you install Visual COBOL for Visual Studio 2012, the machine does not have Microsoft Visual
C++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2012 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.
If you are installing this as an upgrade, make sure that none of the product files are in use when you
start the installation. Also, the Visual Studio Help Viewer must not be opened.
You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.
Before installing this product , make sure that any existing Micro Focus Directory Server (MFDS) or
CCITCP2 Windows service (on Windows) or a process (on UNIX) from an existing product is stopped
and uninstalled. On Windows, do this as follows:
1. Stop the service, using either the Windows Service Management Console GUI or from a command
line prompt by typing: net stop mf_ccitcp2 Only one instance of the MFDS or CCITCP2 service
can run on a Windows machine.
2. Uninstall the MFDS or CCITCP2 service.
For MFDS, from a command line prompt enter: mfds -u
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For CCITCP2: ccitcp2 -u
To run an earlier version of MFDS as a service after you have installed a later version:
1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:
a. Open a Visual COBOL command prompt.
b. Install the service. Enter the following command: mfds -i
c. Start the service. Enter the following command: net start mf_ccitcp2
Note: The two versions use different paths for environment and registry values, so the list of
configured Enterprise Servers might be different depending on which version has been started,
since, by default, different MFDS data repositories are used.
MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier
versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later
versions.
It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the
"mfcobol" port is used (86) and this can only be used by one process at a time

Product Co-Existence
•

Visual COBOL and Enterprise Developer cannot coexist on the same machine regardless of which IDE
(Visual Studio or Eclipse) you install.

Downloading the Products
1. Use the download links in your Electronic Product Delivery email.
For more information follow the links for the installation instructions and the End User License
Agreement.

Installing the Products
Use the individual setup files to install each product from the Micro Focus Academic Program package as
follows:
Windows
1. Run the productname.exe file and follow the wizard instructions to complete the installation.
UNIX
1. Give execute permissions to the setup file:
chmod +x setupfilename
2. Run the installer with superuser permissions:
./setupfilename
If you don't run this as superuser, you are prompted to enter the superuser password during the install.
The COBOL environment is installed by default into /opt/microfocus/Visual COBOL or /opt/
microfocus/Enterprise Developer.
A full version of Eclipse with the Micro Focus plugins already installed is present in the /opt/
microfocus/Visual COBOL/eclipse or /opt/microfocus/Enterprise Developer/
eclipse folders.
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To install in a different location use the -installlocation="Location" parameter to specify an
alternative directory location. For example:
./setupfilename -installlocation="full path of new location"
You can see details about which additional parameters can be passed to the install script if you enter
the -help option.
Note:
•

•

The installation of this product could affect the SafeNet Sentinel licensed components running
on your machine. During installation licensing is shutdown to allow files to be updated. To
ensure the processes running on your machine are not affected, you need to use the skipsafenet option, which skips the installation of SafeNet:
./ -skipsafenet
To protect the SafeNet Sentinel installation from accidental updating you can create an empty
file named SKIP_SAFENET_INSTALL in /var/microfocuslicensing/ as follows:
touch /var/microfocuslicensing/SKIP_SAFENET_INSTALL

While the file is present, the SafeNet installer does not make changes to the installation or
shutdown the running license daemons. If licensing needs to be updated later, remove the file
and install Sentinel RMS server manually.
3. Set up the environment:
./opt/microfocus/<ProductName>/bin/cobsetenv
4. To verify that your product is installed, execute:
cob -V
Important: These commands set the environment only for the current shell. You need to execute
them for each new shell that you start.
To avoid having to run cobsetenv for every shell, add these commands to the shell initialization
files (such as etc/profile, etc/bashrc).
Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It
is not compatible with C-shell or pre-XPG4 Bourne shell.
To start Eclipse on Unix:
•

•

If you are using a GUI interface, double-click the product icon (automatically installed on your desktop).
Note: The installer automatically creates a shortcut icon for the product on the desktop for the user
for which you ran the install script. If you need to create desktop icons for other users' desktops on
the same machine, or if the icon was not created on the desktop for the root user, run the following
shell script as the user you need to login as: $COBDIR/bin/createdesktopicon.sh
If you are using a non-GUI interface, such as a terminal emulator, type the following from a command
prompt:
eclipse

UNIX Installer Issues
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Licensing
Daemon

If the Korn shell is not installed on your machine when you run the installer, the
licensing daemon will not be started. To resolve this after you install the product, install
the Korn shell and then run the /var/microfocuslicensing/bin/
startmfcesd.sh script to start the daemon.

License
Infrastructure
Installer

On some Solaris platforms, you can receive the following error message when SafeNet
license server needs to be installed or upgraded on your machine:
tar: /safenet.tar: No such file or directory
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To resolve this issue, wait for the installation to complete and then perform the
following:
1. Navigate to the safenet directory in the COBDIR location.
2. With superuser permissions execute: ./MFLicenseServerInstall.sh
License Server You need to configure the computer hostname to ensure the license server will start
properly.
To avoid performance issues, "localhost" and the computer hostname must not both be
mapped to IP address 127.0.0.1. You should only map "localhost" to IP address
127.0.0.1.
The following is an example of how to specify these entries correctly in the etc/hosts
file:
127.0.0.1 localhost.localdomain localhost
IP machinelonghostname machineshorthostname
where IP is the unique IP address of the computer in xx.xx.xx.xx format.

After Installing
Visual COBOL and Enterprise Developer for Visual Studio
You are now ready to run Visual COBOL or Enterprise Developer. From the Windows taskbar click Start >
All Programs > Micro Focus Product Name > Product Name for Visual Studio.
Note: The Start menu is not available on Windows 8 and Windows Server 2012. You use the Start
screen to invoke programs.
Please refer to the Start Here and Product Information sections in your product Help. Here, you will find
information on getting started including tutorials and demonstration programs.
Note:
•

If you have problems trying to view the Micro Focus help, ensure that the Visual Studio Help
Library is pointing to local help. From the Visual Studio menu click Help > Manage Help Systems
> Choose online or local help and check the I want to use local help button.

•

To view the help in Visual Studio 2012, ensure that the Visual Studio Help Library is pointing to
local help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help
Browser.
For full details of the Visual Studio 2012 Help system, see the locally installed Microsoft Help
Viewer 2.0 Help, which is available from Help menu in the IDE.

•
•

•

In Visual Studio 2012, you may sometimes receive a message "Cannot find requested topic on
your computer" when you click Help > Micro Focus Product Help > Product Documentation.
You need to click Micro Focus Visual COBOL n.n for Visual Studio 2012 in the Contents tab to
display the documentation as expected.
If you install Visual COBOL for Visual Studio 2012 and its documentation is not available in the
Microsoft Help Viewer, perform the following:
1. In Visual Studio, click Help > Add and Remove Help Content.
2. Choose the Manage Content tab.
3. Check the Disk radio button, then navigate to the folder containing the Visual COBOL for
Visual Studio 2012 documentation. By default, this is %ProgramFiles(x86)%\Micro Focus
\Visual COBOL\help.
4. Select helpcontentsetup.msha, and click Open.
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5. In the content list, click Add next to the Visual COBOL entry.
6. Click Update.
7. Click Yes on the User Account Control and Microsoft Help Viewer dialog boxes to enable the
update to continue.
The documentation for Visual COBOL for Visual Studio 2012 is added to the Microsoft Help
Viewer.
Note:
This problem only occurs if you install Visual COBOL while the documentation for Visual
Studio itself is being downloaded or updated. This might happen the first time you install or
run Visual Studio.
Visual COBOL and Enterprise Developer for Eclipse
If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installing any Micro Focus product. To pick up any new features, you must reset the COBOL
perspective after installation:
1. Open the existing workspace with this product.
2.
3.
4.
5.

You may receive some warnings or errors which you can ignore.
Make sure you are in the COBOL perspective by clicking Window > Open Perspective > COBOL.
Click Window > Reset Perspective.
Click OK.
Reapply any customizations.

Installing X Windows on Windows
Some features of Visual COBOL for Eclipse and Enterprise Developer for Eclipse on Windows require an X
Windows installation, so Micro Focus ViewNowX is provided with the product. To install, run the file
ViewNow_X_Server.exe in your Visual COBOL installation. By default this will be in the
%ProgramFiles(x86)%\Micro Focus\Visual COBOL\ViewNowX folder.
ViewNowX requires that your client machine has Microsoft Visual C++ 2008 SP1 Redistributable Package
(x86) installed. If it is missing from your machine, the ViewNowX installation will offer a link to download the
package.

Repairing
Windows
If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.
To repair your installation on versions of Windows Vista or later:
1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.
To repair your installation on older versions of Windows, such as Windows XP:
1.
2.
3.
4.

12

Click Start Menu > Control Panel > Add/Remove Programs.
Click your Micro Focus product in the list of installed programs.
Click Click here for support information.
Click Repair.
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UNIX
If a file in the installation of the product becomes corrupt, or is missing, we recommend that you reinstall
the product.

Uninstalling
Windows
To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:
1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs (or Add/Remove Programs on older versions of
Windows) in Control Panel.
3. On older versions of Windows such as Windows XP, ensure that Show Updates (at the top of the Add
or Remove Programs dialog) is checked, so that any hot fixes or WrapPacks are listed.
4. Select the product and click Remove or Uninstall as appropriate.
When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.
Note: The installer creates separate installations for Visual COBOL, Enterprise Developer, Enterprise
Server for .NET, and Micro Focus License Administration. Uninstalling only Visual COBOL does not
automatically uninstall Enterprise Server for .NET, the Micro Focus License Manager or any of the
prerequisite software.
Enterprise Server for .NET must be uninstalled before you remove Visual COBOL. To completely
remove the product you must uninstall the Micro Focus License Manager as well.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.
Some registry entries are not removed by the uninstallation process and you need to manually delete
them.
The following folders might not be removed:
•
•
•
•

Micro Focus Product Name folder in the Start menu - you can delete it manually.
%systemdrive%\Users\Public\Documents\Micro Focus - includes the binaries and the log
files of the samples which you have built.
%ProgramData%\Micro Focus - includes some data files used by the Micro Focus licensing system.
%Program Files%\Micro Focus - you can delete it manually.

UNIX
Note: Before you uninstall the product, ensure that the Enterprise Server instances and the Micro
Focus Directory Service (MFDS) are stopped.
To uninstall this product:
1. Execute as root the Uninstall_VisualCOBOL22.sh script in the $COBDIR/bin directory.
Note: The installer creates separate installations for the product and for Micro Focus License
Administration. Uninstalling the product does not automatically uninstall the Micro Focus License
Administration or the prerequisite software. To completely remove the product you must uninstall the
Micro Focus License Administration as well.
To uninstall Micro Focus License Administration:

Micro Focus Academic Program 2.2 - Release Notes
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1. Execute as root the UnInstallMFLicenseServer.sh script in the /var/
microfocuslicensing/bin directory.
The script does not remove some of the files as they contain certain system settings or licenses.
You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Known Issues
Refer to the Known Errors and Restrictions topic in the Product Information section of your product Help.
In addition, note the following:
AcuCOBOL File When using an interface of ACUFH other than MSSQL, you may experience a file
operation delay when the interface fails to connect to a database. This failed
Handler
connection also results in a memory leak. Set the environment variable
MSSQL_DETACH to 1 to avoid both issues.
ASP.NET

It is not possible to run ASP.NET Web Sites or Web Services on a production machine
(one that has Micro Focus COBOL Server installed) without an additional setup. This
is because the production machine does not contain development tools such as the
COBOL Compiler. To workaround this, you need to do the following steps:
1. Precompile the site before you deploy it using the Publish Web Site command in
Visual Studio.
2. Edit the .asmx file of the Web service project or the .aspx file of the Web site and
delete the Language="COBOL" statement.
3. Edit the Web.config file with a text editor and delete the line which contains:
<compiler language="COBOL"...
4. Ensure that a .NET Server license is installed using Apptrack.

CICS

•
•

An EXEC CICS DELAY statement may sometimes produce a difference of one
second.
When Visual COBOL for Visual Studio is initially installed, no CICSECM directives
will be set on assembler files that are added to a project even when the IDE is
configured to do so. To work around this problem, click Tools > Options > Micro
Focus > Directives. Disable and then enable the check boxes under COBOL
CICS and Assembler CICS.

COBOL
Watchpoints

The debugger ignores a COBOL watchpoint that is hit if there is no statement
following the statement that modifies the data on which that watchpoint is set.

Compiler

When running with Java 1.7, if your class contains a static method called 'main' with a
single string array parameter, in order for this class to be executable from the
command line that main method should not have a returning item.

Debugging

There is an issue with "Wait for attachment" when you use Visual COBOL for Eclipse
to debug applications that run on some UNIX/Linux platforms. Eclipse connects to the
debugger on the remote machine, but might not attach to the process to debug the
code.
To work around this issue, ensure that on the remote machine the TMPDIR
environment variable is unset or has the same value for both HCO for SQL Server
Tools server and for the running process you wish to debug. The HCO for SQL Server
Tools server is the server which you started either directly with the $COBDIR/
remotedev/startrdoserver script or indirectly using the daemon which is started with
the $COBDIR/remotedev/startrdodaemon script.
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To check the variable used by the HCO for SQL Server Tools server:
1. Open Remote Systems view in Eclipse on the Windows machine.
2. Right-click the Shells element of the server connection to be tested and click
Launch Shell.
3. In the Remote Shell view, type echo $TMPDIR in the Command field, and press
Enter.
The value of the TMPDIR environment variable is shown - ensure it is the same as
the one used by the process to be debugged.
Note: The value of TMPDIR used by the Development Hub server cannot be
changed in the remote shell and must be set before you start the daemon or
server.
Documentation

•

•

In Visual Studio 2012, clicking Help > Micro Focus Product Help > Product
Documentation results in the message "Cannot find requested topic on your
computer". If you see this message, click Micro Focus Visual COBOL 2.2 for Visual
Studio 2012 in the Contents tab to display the documentation as expected.
If you install Visual COBOL for Visual Studio 2012 and its documentation is not
available in the Microsoft Help Viewer, perform the following steps:
1. In Visual Studio 2012, click Help > Add and Remove Help Content.
2. Choose the Manage Content tab.
3. Check the Disk radio button, then navigate to the folder containing the Visual
COBOL for Visual Studio 2012 documentation. By default, this is C:\Program
Files (x86)\Micro Focus\<product name>\help.
4. Select helpcontentsetup.msha and click Open.
5. In the content list, click Add next to the Visual COBOL entry.
6. Click Update.
7. Click Yes on the User Account Control and Microsoft Help Viewer 2.0 dialog
boxes to enable the update to continue.
The documentation for Visual COBOL for Visual Studio 2012 is added to the
Microsoft Help Viewer.
Note:
This problem only occurs if you install Visual COBOL for Visual Studio 2012
while documentation for Visual Studio 2012 is being downloaded or updated,
which typically happens when you install Visual Studio 2012 or run it for the
first time.

Database
Access

If you have a remote COBOL project under Eclipse that uses DB2 ECM in Visual
COBOL or HCO for DB2 LUW in Enterprise Developer and the DB2 software is not
installed on the client machine where you are using the Eclipse IDE, you receive
background parsing errors in your application. To resolve the issue, you can do either
one of the following:
•
•

Enterprise
Server

•

Disable background parsing Window > Preferences > Micro Focus > COBOL >
Editor and disabling the checkbox for Background parsing.
Install the IBM DB2 client-side software on the machine on which you are running
Eclipse. Go to the IBM Support Home and locate the page entitled "IBM Download
Fix Packs for IBM Data Server Client Packages" .
The Historical Statistics Facility may generate incorrect records for SSTM-enabled
enterprise servers.
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Expanded
•
Copybook View
(in Visual Studio
2012)
•
•
•
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In Visual Studio, using Submit JCL from within the IDE does provide the option to
create a temporary enterprise server when your project is not associated with an
enterprise server.
When you add a COPY statement in a COBOL program and then show it in
Expanded Copybook View, the line for the copybook statement is read-only. If you
then perform an Undo in the COBOL program, the COPY statement is removed
while the contents of the copybook is still shown in the program.
Replace All does not work inside the Expanded Copybook View
Trying to paste a block selection inside the Expanded Copybook View does not
work and deletes all lines of code which the block selection overlaps.
For copybooks with file extensions that are not traditionally associated with COBOL
you must first add the file extension to the list of known copybooks extensions in
Tools > Options > Text Editor > File Extensions before you can show them in
Expanded Copybook View.

ICETOOL
Emulation

ICETOOL emulation for managed code is not available in this release.

Installation

•

When installing this product for Visual Studio 2010, if you already have Visual
Studio 2010 Isolated Shell with Service Pack 1 (SP1) installed, you might
experience problems with starting Visual Studio after the installation. This is a
Microsoft issue relating to the Integrated Shell (installed as part of the Micro Focus
product installer) overwriting some Visual Studio SP1 components. To resolve the
issue you need to repair Visual Studio 2010 SP1.

•
•

On UNIX, check UNIX Installer Issues before you start the installation.
If you are using the latest version of Java 1.7 on Linux, you might receive some
warnings when you start this product. To resolve the issue, it is recommended that
you install an earlier version of Java 1.7 and set JAVA_HOME to that.

JCL VSE

When running Enterprise Server applications on HP Itanium in 32-bit mode, if you
receive an error such as "CASCD1057S JES Initiator for Server ... abended by signal
00004", you need to set the environment value COBMAINSTACK to a value greater
than 500000 to increase the default stack size.

Micro Focus
Rumba

On versions of Windows Vista and later, Enterprise Server listens only on the IPv4
loopback address (127.0.0.1). As a result, an attempt to connect to localhost with a
TN3270 emulator such as Micro Focus Rumba may fail. To work around this issue, in
your emulator's configuration use 127.0.0.1 in preference to localhost or your host
machine's name.

Native COBOL

On Windows XP, when building a native COBOL application in Visual Studio, a dialog
may pop up with error "Unhandled exception at 0xc0006866 in cobol.exe:
0xC0000005: Access violation reading location 0xc0006866)". This is caused by
Symantec antivirus runtime protection. To resolve this, you need to apply the following
fix from Symantec: http://www.symantec.com/business/support/index?
page=content&id=TECH97280&locale=en_US.

Open PL/I

Currently, the Open PL/I Codewatch debugger does not run on 64-bit Windows 8.

Resource
Adapters

Trying to deploy the local resource adaptor mfcobol-localtx.rar to WebLogic
may fail with a ClassCastException. To work around this issue, you need to deploy
mfcobol-xa.rar first, then need to undeploy this file and deploy the local one,
mfcobol-localtx.rar. If there are issues deploying using the WebLogic GUI, you
can use the command line. If there are issues with this as well, try reducing the length
of the command (for example, by moving the file to a location with a shorter path).
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Visual Studio
IDE

•

•

In your project properties, the Application page currently allows you to select any of
the static methods in the application as a Startup object. This is incorrect. You
should always set only the first static method or the program name as a Startup
object in order for the project to build.
In Visual Studio, the controls on the COBOL page in the project properties are not
displayed for a WPF project. To workaround this issue, open the Application page
in the project properties and from the drop-down list under Output type choose the
same output type that was already selected. Close the project property pages and
save the project. The next time you open the project properties, the COBOL page
is properly displayed.

Disclaimer
This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either
express or implied, including the warranties of merchantability and fitness for a particular purpose. In no
event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect,
incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers
have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation
of liability for consequential or incidental damages so the foregoing limitation may not apply.
Micro Focus is a registered trademark.
Copyright © Micro Focus 1984-2013. All rights reserved.
This product includes software developed by Computing Services at Carnegie Mellon University (http://
www.cmu.edu/computing/)".
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