Borland® Together® 2008 Release 4 Release Notes

Last updated: September 28, 2011

This file contains important information that may not appear in the online Help. Please read this file in its entirety.

What's New and Fixed in This Release

System Requirements/Prerequisites

Installation Instructions

Licensing

Known Issues and Limitations

Together Capabilities

Finding Out More

Getting assistance

What's New and Fixed in This Release

This release of Together includes improvements in functionality and fixed bugs since Together 2008 Release 3. The important changes introduced in this release are highlighted below.

Modeling and Diagrams

MDA and Operational QVT (QVTo)

Documentation Generation

Source Code Projects

Documentation Generation

DSL Modeling

General

Back to top

Integrations

Since version Together 2007 integrations with version control systems (StarTeam®) and requirement management products (CaliberRM™, RequisitePro) are not part of Together product. These integrations should be available separately from Borland. The Together 2008 R4 help still includes information about these integrations. However, newer versions of integrations may have some changes in functionality, so it is recommended that you check the release notes that are provided with each integration package.

Back to top

System Requirements/Prerequisites

Following are the system requirements for installing and running Borland Together 2008 R4:

Resources Requirements Notes
Hardware
CPU Intel® Pentium® 4 1GHz (or compatible) Intel® Pentium® 4 2.8 GHz or more recommended
Memory 1 GB minimum 2 GB is recommended. For optimal performance when working with large-scale projects, you might need to adjust the JVM heap setting in the Together.ini, .bat, .cmd, or .sh files found in the eclipse subfolder of the Together installation folder. For more information, refer to the Sun® FAQ: http://java.sun.com/docs/hotspot/PerformanceFAQ.html.
Disk Space up to 700 MB May be less if some of the needed Eclipse components are already installed.
Video High color mode, 1024x768 Recommended resolution: 1600x1200
DVD Drive Optional Necessary if installing from DVD.
Software
Operating system Microsoft Windows Vista, Microsoft Windows XP Pro with Service Pack 2, Microsoft Windows 7 (32/64 bit)
Red Hat Enterprise Linux 5, x86-32/64

 

IDE Platform Eclipse 3.7.1 platform  
Java Platform Sun® J2SE 5.0 Update 22, J2SE 6.0 update 17 (latest update is recommended). JVM should already be installed prior installing Together. Please make sure that the required version of JVM is configured to run Eclipse where Together is going to be installed. Please refer Installation Instructions section for details.
Eclipse components and projects
  • Eclipse 3.7.1
  • GEF SDK 3.7.1 RC2
  • EMF SDK 2.7.1 (EMF + XSD)
  • EMF Transaction SDK 1.5.0
  • MDT OCL SDK 3.1.1
  • MDT UML2 SDK 3.2.1
  • GMF SDK 2.4.0 RC2
  • MDT UML2TOOLS SDK (Incubation) 0.9.1 (build 2010-07-08)
  • M2M QVTOML SDK 3.1.0
  • Birt 3.7.1 + DTP 1.9.1 + WTP WST 3.3.1
  • CDT SDK 8.0.1
Eclipse SDK should be already installed prior to installing Together. Please refer Installation Instructions section for details.
Web Browser Any web browser that supports frames Microsoft Internet Explorer 6.0 or later is recommended on Windows systems.
Other
SVG Viewer Adobe SVG viewer version 3.0 or later. Follow the link to download this viewer from Adobe web site:
http://www.adobe.com/svg/viewer/install/mainframed.html.

Back to top

Installation Instructions

Together 2008 Release 4 can be installed to an existing instance of Eclipse SDK version 3.7.1 from the online or archived update site. Therefore Eclipse SDK as well as Java Virtual Machine needed to run it should be already installed prior to installing Together. If you have both installed please omit the following two subsections and jump right to the subsection Installing Together.

Installing Java Virtual Machine

If you already have an instance of Eclipse 3.7.1 installed you must have the JVM needed to run it installed as well. You may want to verify that the recommended version of JVM is used by Eclipse at the configurations details: once Eclipse is running invoke Help -> About from the main menu, then press Installation Details button, switch to Configuration page and look for java.home, java.version lines.

Together shares the requirements of Eclipse; namely it needs Java 5 update 22, or Java 6 update 17. Note that later updates of Java 6 contain the important fixes, so the latest available Java 6 update is recommended.

If the appropriate JVM version is not installed, please download the latest one from the Java downloads area at the Oracle web site. If you need Java 5, you may download JRE 5 update 22 from the Archive area. Installing JVM is pretty straightforward, however if you need help please refer Installation Instructions at the Oracle web site.

Installing Eclipse SDK

If there is no any instance of Eclipse 3.7.1 on your system, please visit Eclipse Indigo downloads page at the Eclipse web site and download Eclipse classic 3.7.1 package. The installation is as simple as unpacking the archive to the folder of your choice.

If you would like to add Together to an existing Eclipse installation, note that Together needs Eclipse SDK. Thus please make sure your Eclipse contains the Eclipse SDK feature.

If it is not the case perform the following steps prior installing Together:

If it appears you have several JVMs installed, note that it is possible to enforce Eclipse to use a particular Java Machine. It is necessary to add -vm <path to JVM> parameter in eclipse.ini files, for example:
Original file:

-startup
...
--launcher.defaultAction
openFile
-vmargs
...

File with changes:
-startup
...
--launcher.defaultAction
openFile
-vm
C:\Program Files\Java\jre1.5.0_22\bin
-vmargs
...
Important: Make sure you preserve the line breaks.

Without these parameters Eclipse will first try to look for a Java machine in the ./jre subfolder of its home folder. If there is not one it will use the JVM installed in your system. In the later case, to check what version of JVM going to be used you may run the console at the Eclipse home folder and execute the command:

java -version

Installing Together

For installing Together in an existing Eclipse instance, use Borland Together 2008 R4 archived update site or Borland Eclipse 3.7 online update site.

Adjusting parameters in Together.ini and command line launchers

If you have several JVMs installed and need Together to use a particular one, you may want to edit Together.ini file. Please refer to the instructions and the example provided above in the section Installing Eclipse SDK for the eclipse.ini file. Perform similar operations for Together.ini in order to add -vm <path to JVM> parameter Without this parameter Together looks for a Java Virtual Machine first in a ./jre directory in the root of Eclipse and then on the search path.

Together command line launchers look for a java virtual machine first in a ./jre directory in the root of Eclipse, and then use the JAVA_HOME environment variable. You can adjust the JAVA_HOME environment variable in your system settings or edit command line launcher files specifying the path to the location where the required JVM is installed. For example at gendoc.cmd:
REM Unless you have a JRE installed in the Eclipse home, please define JAVA_HOME ...
set JAVA_HOME=C:\Program Files\Java\jre1.5.0_22

Note: Please refer the System Requirements section for the information about the required JVM version.

Together.ini and command line launchers are preconfigured to work with Eclipse version 3.7.1 and so refer to Equinox launcher (org.eclipse.equinox.launcher) and launcher library of explicit versions 1.2.0.v20110502 and 1.1.100.v20110502 respectively. Other versions of Eclipse may have a different version of this plugin. If you choose to install Together in an Eclipse version other than 3.7.1 you may need to replace all occurrences of the Equinox plugin version in the Together.ini and command line launchers with the actual version.

Back to top

Licensing

Once you have a serial number for your order please visit the following page to obtain license keys for Together: http://supportline.microfocus.com/licensing/borlandactivatelic.aspx.
Depending on the type of license you ordered you will be prompted for additional information to get your license keys.

Existing customers with active support contracts please contact Support Line to request your new license keys. License keys from previous versions are not suitable for Together 2008 R4.

If you requested a trial license key and got your activation file by e-mail please save that file on your hard drive. Then register from the running product using Help -> Borland Licensing -> Register Borland Together, choose Have Activation File path, complete the registration by following the prompts.

More details about Together licensing are available at the RegisteringTogether.html document located in the ./docs folder of the product installation.
Note: Please don't confuse the serial number from the order (a 10 to 12 digit string) and the serial number which is part of the serial/key pair.
The latter is a string of 4 dash-separated character groups like XXXX-XXXXXX-XXXXXX-XXXX supplied with a key like XXX-XXX.

For the license keys that need registration from the product UI using Help -> Borland Licensing -> Register Borland Together please make sure to switch to the Modeling Perspective using Window -> Open Perspective... -> Modeling. If Modeling is not shown in the list you may need to choose Other... and check Show all. Without the Modeling perspective active the needed menu items may be not available.

Back to top

Known Issues and Limitations

New issues may be identified and/or resolved after release. Please check the latest version of the Together Release Notes at Together Technical Publications page for changes to the known issues below.

Modeling and Diagrams

Together OCL and QVT

C++/IDL Modeling Projects

Documentation Generation and Printing

Import Together Project Wizard

Referenced Projects

XMI Import/Export

DSL Development

Workflow

Miscellaneous

Back to top

Together Capabilities

The default capabilities are different for classic Together Modeling and the DSL Toolkit. Select Window -> Preferences, then select the General node and the Capabilities node. You can click the Advanced button to enable/disable capabilities at a more granular level.

The following table lists the Together capabilities that are enabled and disabled for classic Together Modeling and the DSL Toolkit:

Capability group Advanced Capability item Description Classic Together Modeling default DSL Toolkit default
DSL Development   Features related to domain-specific language and model-driven development. Disabled Enabled
  Diagram Definition Diagram definition capabilities for domain models. Disabled Enabled
  Domain Modeling Capabilities associated with modeling a domain-specific model. Disabled Enabled
  DSL Project General features for working with DSL Projects. Disabled Enabled
Model to Model Transformations   Features for model-to-model transformations. Disabled Enabled
  Operational Mapping Language (QVT) Operational mapping language (QVT) features. Disabled Enabled
  Operational QVT Debugging Operational QVT debugging features. Disabled Enabled
Model to Text Transformation   Features for model-to-text transformations. Disabled Enabled
  Template Authoring Template authoring features. Disabled Enabled
  Template Exploring Template exploring features. Disabled Enabled
  Template Exploring (Legacy) Legacy template exploring. Disabled Disabled
Model Workflow   Features for model workflow. Disabled Enabled
  Workflow Definition Workflow definition features. Disabled Enabled
  Workflow Execution Workflow execution features. Disabled Enabled
Modeling   Modeling Capabilities. Enabled Disabled
  Business Process Modeling Business Process Modeling. Enabled Disabled
  C++ Modeling C++ Modeling. Enabled Disabled
  Data Modeling Data Modeling. Enabled Disabled
  Documentation Documentation generation. Enabled Disabled

Enhanced Rich Text Editor
Enhanced Rich Text Editor
Enabled
Disabled
  IDL Modeling IDL Modeling. Enabled Disabled
  Java Modeling Java Modeling. Enabled Disabled
  Manage element persistence Ability to manage element persistence state, make it stand-alone or packaged along with other elements in containing package. Disabled Disabled
  MDL and MDX Imports MDL and MDX Imports. Enabled Disabled
  Model QA Model Quality Assurance. Enabled Disabled
  Modeling profiles Profiles. Enabled Disabled
  Patterns Patterns Definition and Registry, Patterns Recognition. Enabled Disabled
  Source code QA Source code Quality Assurance. Enabled Disabled
  Together Project Import Import project from one of the previous versions of Together. Enabled Disabled
  Together QVT QVT implementation initially appeared at Together 2006, primary engine to work with Together models. Enabled Disabled
  UML 1.4 UML 1.4 Modeling. Enabled Disabled
  UML 2.0 UML 2.0 Modeling. Enabled Disabled
  XMI Import/Export XMI Import/Export. Enabled Disabled
  XSL XSL transformations. Enabled Disabled
Modeling Tools   Features for modeling tools. Disabled Enabled
  Hyperlinks and Requirement Traces (Early Access) Hyperlinks and requirement traces features (early access). Disabled Disabled
  Model Refactoring (Early Access) Model refactoring features (early access). Disabled Enabled
Reporting   Features for reporting. Disabled Enabled
  Model Reporting Model reporting features. Disabled Enabled
Team        
  CVS Support for Modeling CVS Actions for Model Navigator and Diagram Editors. Adds several variants of Edit/Unedit actions to the Team menu for model elements. When work with CVS in watch/edit mode and autocheckout turned off, those actions simplify taking required resources behind the selected model element for editing. Disabled Disabled
UML Modeling   Features for UML modeling. Disabled Disabled
  UML2 Diagramming UML2 diagramming features. Disabled Disabled
  UML2 Model Development UML2 model development features. Disabled Disabled

Back to top

Finding Out More

Online Help

Together provides online help through your Eclipse help browser. Select Help Contents on the Help menu. When the help browser opens, click Borland® Together® Modeling Guide, Borland® Together® DSL Toolkit Guide, Borland® Together® UML 2.1 Guide, or another online help section.

Online technical publications

The latest versions of Release Notes and product documentation are published at Together Technical Publications page

Back to top

Getting Assistance

Visit Micro Focus SupportLine at http://supportline.microfocus.com, http://support.borland.com/

Visit Borland at http://www.borland.com/

Back to top

 

Copyright © 2011 Micro Focus IP Development Limited. All Rights Reserved. Portions Copyright © 1998-2010 Borland Software Corporation (a Micro Focus company).
BORLAND, the Borland logo, and Borland product names are trademarks or registered trademarks of Borland Software Corporation or its subsidiaries or affiliated companies in the United States, United Kingdom, and other countries. All other marks are the property of their respective owners.