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Introduction
Micro Focus Rumba+ Server is a server application that runs on one of the supported Java application
servers. It allows you run Rumba+ Web or Rumba+ Mobile applications on an intranet, extranet, or on the
Internet. Rumba+ Server provides access to IBM mainframe and to IBM AS/400 hosts.

You customize host screens in the Rumba Screen Designer, which is provided as part of Rumba+ Desktop.

You deploy screen customizations using the Rumba+ Build Tool, which is provided with Rumba+ Server.
The Rumba+ Build Tool exports Rumba+ screen customizations to a Web archive package which you then
deploy on one of the supported application servers.

System administrators can use the Rumba+ Server Administration Application to:

• Monitor client sessions.
• Manage licenses.
• View details of deployed applications.
• Use tracing to troubleshoot problems.

Note: All URLs, file paths, and file names mentioned in this guide are case sensitive.
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Before You Start
This section provides important information you should read before you start installing Rumba+ Server.

Prerequisites
Rumba+ Server .war package file to deploy a Rumba+ application. To create this package file, the
following are required:

Rumba Screen Designer
You use the Rumba Screen Designer to customize host screens.

The Screen Designer is provided as part of Rumba Desktop.

Rumba+ Server Build Tool
You use the Rumba+ Server Build Tool to export a screen customization project and create a .war
package file.

The Rumba+ Server Build Tool is provided with Rumba+ Mobile and Rumba+ Web.

Installing the Rumba+ Server Build Tool

1. Double-click the RPSBuildTool.msi file. 

The Rumba+ Server Build Tool wizard starts.

2. Click Next. 

The License Agreement window appears.

3. Select I accept the terms of the license agreement.

4. Click Next. 

The Destination Folder window appears.

5. Click Next. 

The Ready to Install the Program window appears.

6. Click Install. 

The Installing Rumba+ Server Build Tool window appears.

When installation is complete, the final wizard window appears.

7. Click Finish.

Using the command line
You can use the Rumba+ Server Build Tool command line to build a deployment package from a Rumba
Screen Designer project. This is particularly useful if you need to rebuild a deployment package after
upgrading to newer version of the Build Tool. For this reason, we recommend that each time you create a
deployment package, you retain the appconfig.xml file that is produced so that you can upgrade it later
if necessary.
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Syntax
<BuildToolInstallDir>\RPSBuildTool.exe -conf <source> [-verbose]

where:
<BuildToolInstallDir>

Specifies the full path to the folder where the Build Tool is installed.

-conf <source>

Specifies the full path to the appconfig.xml configuration file.

-verbose

When used, shows detailed information about the Build Tool operation. Optional.

Example

C:\Program Files (x86)\Micro Focus\Rumba+ Server Build Tool\RPSBuildTool.exe -
conf "%LOCALAPPDATA%\Micro Focus\Rumba+ Server Build Tool
\RumbaPlusSvrAppConfig\appconfig.xml

Batch operation

You might well have a number of deployment files to rebuild. In this case, you can create a .bat batch file
containing a command for each deployment. For example:

C:\Program Files (x86)\Micro Focus\Rumba+ Server Build Tool\RPSBuildTool.exe -
conf  "%LOCALAPPDATA%\Micro Focus\Rumba+ Server Build Tool
\RumbaPlusSvrAppConfig\Deploy 1\appconfig.xml 
C:\Program Files (x86)\Micro Focus\Rumba+ Server Build Tool\RPSBuildTool.exe -
conf  "%LOCALAPPDATA%\Micro Focus\Rumba+ Server Build Tool
\RumbaPlusSvrAppConfig\Deploy 2\appconfig.xml 
C:\Program Files (x86)\Micro Focus\Rumba+ Server Build Tool\RPSBuildTool.exe -
conf  "%LOCALAPPDATA%\Micro Focus\Rumba+ Server Build Tool
\RumbaPlusSvrAppConfig\Deploy 3\appconfig.xml 
C:\Program Files (x86)\Micro Focus\Rumba+ Server Build Tool\RPSBuildTool.exe -
conf  "%LOCALAPPDATA%\Micro Focus\Rumba+ Server Build Tool
\RumbaPlusSvrAppConfig\Deploy 4\appconfig.xml 
C:\Program Files (x86)\Micro Focus\Rumba+ Server Build Tool\RPSBuildTool.exe -
conf  "%LOCALAPPDATA%\Micro Focus\Rumba+ Server Build Tool
\RumbaPlusSvrAppConfig\Deploy 6\appconfig.xml 
C:\Program Files (x86)\Micro Focus\Rumba+ Server Build Tool\RPSBuildTool.exe -
conf  "%LOCALAPPDATA%\Micro Focus\Rumba+ Server Build Tool
\RumbaPlusSvrAppConfig\Deploy 7\appconfig.xml 

Supported hardware and software

Hardware
For hardware requirements, refer to the documentation for the application server you plan to use..

Software
The following software is supported:
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Application servers
• Apache Tomcat 7.0.35
• IBM WebSphere 8.5.5
• Oracle Glassfish 3.1.2.2
• JBoss EAP 6.1 and AS 7.1.1
• Oracle WebLogic 12c

Java
• Oracle Sun JRE 1.6 update 30 and higher

for Apache Tomcat, JBoss, Oracle GlassFish, and Oracle WebLogic
• IBM J9 VM, build 2.6, JRE 1.6.0

for IBM WebSphere

Databases
• Microsoft SQL Server 2008
• MySQL Server 5.6

Browsers
• Chrome 20+
• Internet Explorer 9 or higher

Recommended screen resolutions
The following screen resolutions are recommended when working Rumba+ applications:

• 1920 x 1200
• 1280 x 1024
• 1280 x 800
• 1024 x 768
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Setting Up SQL Databases
This section describes how to set up either Microsoft SQL Server or MySQL Server, as well as how to
install the Rumba+ database.

Microsoft SQL

Setting Up the Microsoft SQL Server database
Download and install Microsoft Server SQL Database 2008 from http://www.microsoft.com/en-us/sqlserver/
get-sql-server/try-it.aspx#tab3.

For technical details and installation information, go to http://technet.microsoft.com/en-us/sqlserver/
bb671410.

Installing the Microsoft SQL Server Rumba+ database
This section describes how to use the Microsoft SQL Server Management Studio to create a database
within Microsoft SQL Server to hold your Rumba+ server applications data.

1. Login to the SQL Server with administrator permissions.

2. In the Tools > Options > Query Execution pane, ensure By default, open new queries in SQLCMD
mode is checked.

3. In the Object Explorer, ensure the SQL Server Agent is started.

4. In the main menu, select File > Open > File.

5. Browse to the location of the Microsoft SQL script file RPS_schema_create.sql which is shipped as
part of the product, then click Open. 

The script is loaded into a new tab.

6. On the tab toolbar, click Execute. 

When execution is complete, the Rumba+ Server database is created and ready to use.

Note: The SQL script uses the following values:

Parameter Value

database name RPSADMIN

user rps

password rps

These values can be changed in the installation script:

:setvar dbname RPSADMIN
:setvar dbuser rps    
:setvar dbuserpwd rps

MySQL
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Setting Up the MySQL Server database
Download and install the latest MySQL Community Server appropriate to your platform from http://
dev.mysql.com/downloads/mysql/.

For details, refer to http://dev.mysql.com/doc/.

Installing the MySQL Server Rumba+ database

Using MySQL Workbench

1. If not installed, download and install the latest MySQL Workbench from http://dev.mysql.com/
downloads/tools/workbench/.

2. Run MySQL Workbench.

3. Click New Connection. 

The Setup New Connection dialog appears.

4. Complete the following:

a) Provide the most appropriate Connection Name.
b) On the Parameters page, specify: 

• The hostname and port number to use to connect to your database.
• The username and password to log on to your database.

5. Double-click the created connection to open an SQL Editor.

6. In the editor, select File > Open SQL Script.

7. Browse to the RPS_schema_create.sql file. 

This file is provided as part of the product.

The script is loaded into a page.

8. Do one of the following:

• On the toolbar, click Execute.
• From the main menu, select Query > Execute (All or Selection).

When the script runs, the Rumba+ Server Database is created and is ready to use.

Using the MySQL command line

1. Copy the RPS_schema_create.sql script to a temporary location. For example, C:\temp\ on a
Windows machine).

2. Connect to the MySQL server using the MySQL command-line client: 

mysql.exe -u root –p

3. Enter your password when prompted. 

A non-root account can be used as long as the account has privileges to create new databases.

4. Run the RPS_schema_create.sql script to create the database structure with the following
command: 

mysql> SOURCE C:\<tmp_location>\RPS_schema_create.sql

where <tmp_location> is where you copied the script file.

Note: database name, username, and password in the RPS_schema_create.sql script should
be the same ones as those specified for the application server while configuring the JNDI resource.
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Upgrading SQL databases
Scripts to upgrade from a previous version of the Rumba+ database to 1.3 are provided for MSSQL and
MYSQL servers.

To upgrade a database:

1. Stop any running applications. 

Upgrade scripts throw an error if a running application (according to the database data) is found.

2. MySQL Only:If you use MySQL, turn on the toolbar icon Toggle whether execution of SQL script
should continue after failed statements in MySQL Workbench. 

This makes the script terminate if a statement fails.

3. Run the script RPS_schema_upgrade.sql. This file is shipped as part of the product.

• Microsoft SQL: Open the file in the Object Explorer, then click Execute on the new tab.
• MySQL: Open the file in MySQL Workbench SQL Editor, then click Execute on the toolbar.

4. Remove the previous version of the Rumba+ Server Administration Application from the application
server you use.

5. Deploy the Rumba+ Server Administration Application 1.3 on the application server. 

For more information, see the deployment section for your application server.

6. Use the Rumba+ Server Administration Application to remove previous licenses for previous versions.

7. Use the Rumba+ Server Administration Application to deploy licenses for version 1.3. 

For more information, see the deployment section for your application server.

The table below describes statuses of deployed applications before and after a database upgrade:

Rumba+ Server
Administration
Application
Previous Version

Rumba+ Server
Administration
Application 1.3

Application Deployed
with Rumba+ Server
Previous Version

Application
Deployed with
Rumba+ Server 1.3

Database Schema
Previous Version

Succeeds. Fails with conflicting
versions error.

Succeeds. Fails with conflicting
versions error.

After Upgrade to
Database Schema
1.3

Works with limited
functionality. Not
documented.

Succeeds. Succeeds. Succeeds.
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Installing and Configuring Apache Tomcat
This section describes how to install and configure Apache Tomcat for Rumba+.

Installing Apache Tomcat Server
1. Download the latest Apache Tomcat from http://tomcat.apache.org/download-70.cgi. 

For fast installation, download the 32-bit/64-bit Windows Service Installer to install Apache Tomcat as
service.

2. Install Apache Tomcat to default ports. 

Ensure the ports do not conflict with others.

3. Ensure the Apache Tomcat Server service is started.

Configuring Apache Tomcat to work with Microsoft SQL

Connecting Tomcat to the database using JDBC
1. Download the Microsoft JDBC Driver for SQL Server 4.0 package,

sqljdbc_4.0.2206.100_enu.tar.gz, from http://www.microsoft.com/en-us/download/
details.aspx?displaylang=en&id=11774.

2. Extract the downloaded package to a temporary location.

3. Copy the sqljdbc4.jar file to the $CATALINA_HOME/lib folder. 

Note: By default, $CATALINA_HOME is set to <Tomcat_Installation_Directory>

4. We recommend that you restart the application server.

Configuring the database as a JNDI resource
The Java Servlet specification, which Apache Tomcat implements, requires resources to be declared in two
places:

1. As a resource in the $CATALINA_HOME/conf/context.xml Tomcat file. 

In this case, the database is available to multiple Rumba+ Server applications.

Example of a resource configuration template:

<Context>
…
<Resource name="jdbc/[JNDIDataSourceName]" auth="Container"
type="javax.sql.DataSource" 
maxActive="100" maxIdle="30" maxWait="10000" 
testWhileIdle="true"  validationQuery="SELECT 1" 
timeBetweenEvictionRunsMillis="[TimeInMillisecondsLessThanDatabaseInactiveCo
nnectionTimeout]"
username="[DatabaseUsername]" password="[DatabasePassword]"
driverClassName="com.microsoft.sqlserver.jdbc.SQLServerDriver"
url="jdbc:sqlserver://[DatabaseServerNameOrIP]:
[PortNumber];databaseName=[DatabaseName]"/>
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…
</Context>

Example of a resource configuration filled with values for Rumba+ Web applications:

<Context>
…
<Resource name="jdbc/RPSDB" auth="Container"
type="javax.sql.DataSource" 
maxActive="100" maxIdle="30" maxWait="10000" 
testWhileIdle="true"  validationQuery="SELECT 1" 
timeBetweenEvictionRunsMillis="180000"
username="rps" password="rps"
driverClassName="com.microsoft.sqlserver.jdbc.SQLServerDriver"
url="jdbc:sqlserver://localhost:1433;databaseName=RPSADMIN"/>
…
</Context>

2. As a resource reference in the Rumba+ application. 

This reference is set for you automatically when using the Rumba+ Server Build Tool to build any
Rumba+ Web application.

Configuring Apache Tomcat to work with MySQL

Connecting Tomcat to the database using JDBC
Connector/J is the JDBC driver needed to connect to the MySQL database. The latest version is available
from the MySQL Web site:

http://www.mysql.com/downloads/connector/j/

1. Download the Platform Independent file.

2. Extract the distribution package and find the mysqlconnector-java-version-bin.jar file.

3. Copy the .jar file to: 

$CATALINA_HOME/lib

This makes the driver available to JDBC.

Note: By default, $CATALINA_HOME is set to <Tomcat_Installation_Directory>

4. We recommend that you restart the application server.

Configuring the database as a JNDI resource
The Java Servlet specification, which Apache Tomcat implements, requires resources to be declared in two
places:

1. As a resource in the $CATALINA_HOME/conf/context.xml Tomcat file. 

In this case, the database is available to multiple Rumba+ Server applications.

Example of a resource configuration template:

<Context>
…
<Resource name="jdbc/[JNDIDataSourceName]" auth="Container"
type="javax.sql.DataSource" 
maxActive="100" maxIdle="30" maxWait="10000" 
testWhileIdle="true"  validationQuery="SELECT 1" 
timeBetweenEvictionRunsMillis="[TimeInMillisecondsLessThanDatabaseInactiveCo
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nnectionTimeout]"
username="[DatabaseUsername]" password="[DatabasePassword]"
driverClassName="com.mysql.jdbc.Driver" 
defaultTransactionIsolation="READ_COMMITTED"
url="jdbc:mysql://[DatabaseServerNameOrIP]:[PortNumber]/[DatabaseName]"/>
…
</Context>

Example of a resource configuration filled with values for Rumba+ Web applications:

<Context>
…
<Resource name="jdbc/RPSDB" auth="Container"
type="javax.sql.DataSource" 
maxActive="100" maxIdle="30" maxWait="10000" 
testWhileIdle="true"  validationQuery="SELECT 1" 
timeBetweenEvictionRunsMillis="180000"
username="rps" password="rps"
driverClassName="com.mysql.jdbc.Driver"
defaultTransactionIsolation="READ_COMMITTED"
url="jdbc:mysql://localhost:3306/RPSADMIN"/>
…
</Context>

2. As a resource reference in the Rumba+ application. 

This reference is set for you automatically when using the Rumba+ Server Build Tool to build any
Rumba+ Web application.

Deploying your Rumba+ license
Before you can run a Rumba+ application, you must deploy your Rumba+ license.

To do this, use the Rumba+ Server Administration Application. For more information, see the Rumba+
Server Administration Application Help.

Deploying and testing a Rumba+ application
This section first describes how to deploy and test the Rumba+ Server Administration Application. It then
describes how to deploy and test a Rumba+ application.

Before you deploy a Rumba+ application, you must first deploy the Rumba+ Server Administration
Application.

Deploying the Rumba+ Server Administration
Application

Using the Tomcat Web Application Manager
The Rumba+ Administration Application is deployed using the RPSAdmin.war package that is shipped
with the product.

1. Open a browser and navigate to: 

http://<host>:<port>/manager/html

Note: The default port is 8080.

2. Provide the user name and password of the Tomcat administrator. 
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If you do not have them, check the Tomcat documentation and ensure that the manager role and admin
user are defined in $CATALINA_HOME/conf/tomcat-users.xml as follows:

<role rolename="manager"/>

<user username="admin" password="password" roles="manager"/>

3. Next to Select WAR file to upload click Choose File and select the RPSAdmin.war file.

4. Click Deploy. The page reloads.

5. Check to see that the new row Rumba+ Server Administration Application is in the Applications
section. 

The application is now available at the following URL:

http://<host>:<port>/RPSAdmin

Using auto-deployment
Copy the Rumba+ Administration Application package RPSAdmin.war to the $CATALINA_HOME
\webapps folder.

Tomcat deploys the application automatically.

Note: We recommend that you use auto-deployment only in development mode, not production
mode.

Verifying the installation
Navigate to http://<host>:<port>/RPSAdmin to access the Administration Application.

See Supported Browsers.

Deploying a Rumba+ application
Deploy the Rumba+ .war file package in the same way you deployed the Rumba+ Server Administration
Application.

Using WebSockets
Rumba+ applications designed to run under Apache Tomcat can be configured to use WebSockets for
faster communication. This feature is supported by Apache Tomcat 7.0.35 and above.

Verifying the installation
Navigate to http://<host>:<port>/<application_name>.
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Installing and Configuring IBM WebSphere
This section describes how to install and configure IBM WebSphere Application Server for Rumba+.

Installing WebSphere
1. Download the latest IBM WebSphere from http://www.ibm.com/developerworks/downloads/ws/was/.

2. Install the application server using the documentation at http://www-03.ibm.com/systems/i/software/
websphere/indexb855.html.

Configuring WebSphere to work with Microsoft SQL

Connecting WebSphere to the database using JDBC
1. Download the Microsoft JDBC Driver for SQL Server 4.0 package,

sqljdbc_4.0.2206.100_enu.tar.gz, from http://www.microsoft.com/en-us/download/
details.aspx?displaylang=en&id=11774.

2. Extract the downloaded package to a temporary location.

3. Copy the sqljdbc4.jar driver file to the ${WAS_INSTALL_ROOT}/lib folder or other location of
your choice.

4. We recommend that you restart the application server.

Creating the JDBC provider definition for Microsoft
SQL
1. In the WebSphere Administrative Console navigation tree, select Environment > WebSphere

Variables.

2. In the right pane, select MICROSOFT_JDBC_DRIVER_PATH.

3. Under General Properties, in the Value field, type the path to the sqljdbc4.jar file that you created
when you installed the Microsoft SQL Server database driver.

4. Click OK.

5. In the Messages frame, click Save directly to master configuration.

6. In the Create new JDBC provider pane, set the following configurations:

a) From the Database type list, select SQL Server.
b) From the Provider type list, select Microsoft SQL Server JDBC Driver.
c) From the Implementation type list, select Connection Pool Data Source.
d) From the Name field, either type Microsoft SQL Server JDBC Driver or accept the default

value.

7. Click Next.

8. To define the location of the .jar file, in the Enter database class path information pane, replace the
existing entry with 

${MICROSOFT_JDBC_DRIVER_PATH}/sqljdbc4.jar
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Note: If you have set the WebSphere MICROSOFT_JDBC_DRIVER_PATH variable, the database
class path information is populated automatically.

9. Click Next.

10.In the Summary pane, click Finish.

11.To update the master repository with your changes, click Save directly to master configuration.

Configuring J2C authentication for the data source
Before you configure the data source, you must configure J2C authentication for the data source.

1. In the WebSphere Administrative Console navigation tree, select Security > Global Security.

2. Under Authentication, select Java Authentication and Authorization Service > J2C authentication
data.

3. Click New.

4. Provide the appropriate information in the following fields:

a) In the Alias field, type a name that is appropriate for the database user. For example, RPSAUTH.
b) In the User ID field, type a user ID. 

This ID is the login credential that is used to access the Rumba+ Plus Server database to be used
with the data source. For example, rps.

c) In the Password field, type a password for the user.

5. Click OK or Apply.

6. To update the master repository with your changes, click Save directly to master configuration.

Creating a JDBC data source
Go through the steps below to create the SQL Server data source.

1. In the navigation tree, select Resources > JDBC > JDBC Providers.

2. In the right pane, select the provider that you created in Creating the JDBC provider definition for
Microsoft SQL.

3. Under Additional Properties, click Data sources, then click New.

4. In the Enter basic data source information pane, set the following configurations:

a) In the Data source name field, type the name of the data source. For example, MSSQL RPS
DataSource.

b) In the JNDI name field, type jdbc/RPSDB.

5. Click Next.

6. In the Enter database specific properties for the data source pane, type the database name, port
number, and server name in the appropriate Value fields. 

Note: The default RPS database name is RPSADMIN. The name of the database should match the
name used in the schema when creating the database.

7. Click Next.

8. In the Container managed authentication alias list, select the authentication alias that you created for
this data source.

9. Click Next.

10.In the Summary pane, click Finish.

11.To update the master repository with your changes, click Save directly to master configuration.
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Testing the data source
1. On the Data sources page, select the alias you configured previously for container-managed sign-on to

the data source

2. Select the data source you configured.

3. Click Test Connection to test your database connection.

Configuring WebSphere to work with MySQL

Connecting WebSphere to the database using JDBC
Connector/J is the JDBC driver needed to connect to the MySQL database.

1. Download the latest version from the MySQL Web site: 

http://www.mysql.com/downloads/connector/j/

2. Copy the mysql-connector-java-5.1.24-bin.jar driver file to the $
{WAS_INSTALL_ROOT}/lib folder.

3. We recommend that you restart the application server.

Creating the JDBC provider definition for MySQL
1. In the WebSphere Administrative Console navigation tree, select Resources > JDBC > JDBC

Providers.

2. In the Scope drop-down list in the right pane, select Node=NodeName, Server=ServerName as the
level.

3. Click New.

4. In the Create new JDBC provider pane, set the following configurations:

a) From the Database type list, select User-defined.
b) From the Implementation class name field, type: 

com.mysql.jdbc.jdbc2.optional.MysqlConnectionPoolDataSource

This should be the same path as in the actual .jar file:

mysql-connector-java-5.1.24-bin.jar\com\mysql\jdbc\jdbc2\optional\

c) From the Name field, either type MSSQL Driver or accept the default value.

5. Click Next.

6. In the Class path field, type the path to the .jar file. 

For example:

${WAS_INSTALL_ROOT}/lib/mysql-connector-java-5.1.24-bin.jar

You can also define your own environment variable for the path. You can use this in the same way as for
the Microsoft SQL driver.

7. Click Next.

8. In the Summary pane, click Finish.

9. To update the master repository with your changes, click Save directly to master configuration.
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Configuring J2C authentication for the data source
Before you configure the data source, you must configure J2C authentication for the data source.

1. In the WebSphere Administrative Console navigation tree, select Security > Global Security.

2. Under Authentication, select Java Authentication and Authorization Service > J2C authentication
data.

3. Click New.

4. Provide the appropriate information in the following fields:

a) In the Alias field, type a name that is appropriate for the database user. For example, RPSAUTH.
b) In the User ID field, type a user ID. 

This ID is the login credential that is used to access the Rumba+ Plus Server database to be used
with the data source. For example, rps.

c) In the Password field, type a password for the user.

5. Click OK or Apply.

6. To update the master repository with your changes, click Save directly to master configuration.

Creating a JDBC data source
Go through the steps below to create the SQL Server data source.

1. In the navigation tree, select Resources > JDBC > JDBC Providers.

2. In the right pane, select the provider that you created in Creating the JDBC provider definition for
MySQL.

3. Under Additional Properties, click Data sources, then click New.

4. In the Enter basic data source information pane, set the following configurations:

a) In the Data source name field, type the name of the data source. For example, MySQL RPS
DataSource.

b) In the JNDI name field, type jdbc/RPSDB.

5. Click Next.

6. In the Data store helper class name field, type: 

com.ibm.websphere.rsadapter.GenericDataStoreHelper

7. Click Next.

8. In the Container managed authentication alias list, select the authentication alias that you created for
this data source.

9. Click Next.

10.In the Summary pane, click Finish.

11.To update the master repository with your changes, click Save directly to master configuration.

Adding custom JDBC data source properties
You now need to specify some additional custom properties so that WebSphere can connect to the MySQL
Rumba+ administration database.

1. Select Resources > Data sources.

2. In the Data sources view, click your MySQL RPS data source to open it.

3. Under Additional properties, click Custom properties.

4. Add the following custom properties: 
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Name Type Value

databaseName java.lang.string RPSADMIN

portNumber java.lang.string 3306

serverName java.lang.string localhost

5. Click Apply.

Testing the data source
1. On the Data sources page, select the data source you configured.
2. Click Test Connection to test your database connection.

Deploying your Rumba+ license
Before you can run a Rumba+ application, you must deploy your Rumba+ license.

To do this, use the Rumba+ Server Administration Application. For more information, see the Rumba+
Server Administration Application Help.

Deploying and testing a Rumba+ application
This section first describes how to deploy and test the Rumba+ Server Administration Application. It then
describes how to deploy and test a Rumba+ application.

Before you deploy a Rumba+ application, you must first deploy the Rumba+ Server Administration
Application.

Deploying the Rumba+ Server Administration
Application

Using the Administrative Console
1. Select Applications > New Application. 

The New Application page appears.
2. Click New Enterprise Application. 

The Path to the new application page appears.
3. Click Choose File. 

The Open dialog box appears.
4. Select the RPSAdmin.war file, then click Open.

5. Click Next. 

The Summary page appears.
6. Click Finish. 

The application is installed.
7. When installation is complete, click Save.
8. Select the new application from the list on the Enterprise Applications page.
9. Click Start. 

In the Application Status column, the following icon appears to show that the application is running:
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Using auto-deployment

1. Select Applications > Application Types > Global deployment settings 

The Global deployment settings page appears.

2. Under Monitored Directory Deployment, ensure that Monitor directory to automatically deploy
applications is checked. 

The default value is:

${USER_INSTALL_ROOT}/monitoredDeployableApps

For example:

C:\Program Files (x86)\IBM\WebSphere\AppServer\profiles
\AppSrv01\monitoredDeployableApps\servers\server1

Note: If you enable this option, you must restart WebSphere Application Server.

3. Copy the Rumba+ application .war file to the monitored directory location. 

WebSphere Application Server deploys and starts the new .war file automatically. The application the
appears in the list on the Enterprise Applications page.

Note: We recommend that you use auto-deployment only in development mode, not production
mode.

Verifying the installation

1. Select the new application the applications list and click Start. 

A green arrow appears next to the application name to show that the application has started.

2. Use a Web browser to navigate to: 

http://<server>:<port>/RPSAdmin

Note: The default port is 9080.

Deploying a Rumba+ application
Deploy the Rumba+ .war file package in the same way you deployed the Rumba+ Server Administration
Application.

Verifying the installation

1. Select the application from the applications list and click Start. 

A green arrow  appears next to the application name to show that the application has started.

2. Navigate to http://<server>:<port>/application_name>.

Using WebSockets
Not supported.
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Installing and Configuring JBoss
This section describes how to install and configure JBoss AS for Rumba+.

Installing JBoss
1. Download JBoss AS7 from http://www.jboss.org/jbossas/downloads (JBoss AS 7.1.1.Final).

2. Install the application by following the instructions in the JBoss Admin Guide at https://docs.jboss.org/
author/display/AS71/Admin+Guide?_sscc=t.

3. For more documentation, see https://docs.jboss.org/author/display/AS71/Documentation.

Configuring JBoss to work with Microsoft SQL

Connecting JBoss to the database using JDBC
1. Download the Microsoft JDBC Driver for SQL Server 4.0 package,

sqljdbc_4.0.2206.100_enu.tar.gz, from http://www.microsoft.com/en-us/download/
details.aspx?displaylang=en&id=11774.

2. Extract the downloaded package to a temporary location.

3. Copy the sqljdbc4.jar driver file to your downloads folder and make a note of where you have saved
it.

4. We recommend that you restart the application server.

Installing the JDBC driver as a deployment
Based on the mode you are using to run JBoss, you can install the sqljdbc4.jar JDBC driver by
deploying it directly to:

<server>/standalone/deployments

Alternatively, you can follow the steps below:

1. From the JBoss Application Server Console, select Deployments > Manage Deployments.

2. Click Add Content. 

The Upload wizard starts.

3. On the Deployment Selection page, select Choose File.

4. Browse to the JDBC connector sqljdbc4.jar file, then select Open.

5. On the Deployment Selection page, click Save.

6. On the Verify Deployment Names page, click Save.

7. On the Deployments page, click Enable on the row containing the connector.

Installing the JDBC driver as a module
Another option is to install the JDBC Driver as a module. This requires defining a new module for the JDBC
Driver inside the <server>/modules directory.
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1. Move the sqljdbc4.jar driver to <server>/modules/com/microsoft/main.

2. In the same directory, create a file called module.xml with the following content: 

<module xmlns="urn:jboss:module:1.1" name="com.microsoft">  
  <resources>  
    <resource-root path="sqljdbc4.jar"/>  
  </resources>  
  <dependencies>  
    <module name="javax.api"/>  
    <module name="javax.transaction.api"/>  
  </dependencies>  
</module>  

3. Open one of the following files:

• <server>/standalone/configuration/standalone.xml

• <server>/domain/configuration/domain.xml

4. Add the driver declaration tag referring to the module: 

<drivers>
<driver name="MSSQLJDBCDriver" module="com.microsoft">  
    <driver-class>com.microsoft.sqlserver.jdbc.SQLServerDriver</driver-
class>  
</driver>   
</drivers>

By default, the driver declaration tag already contains the declaration for <driver name=”h2”
module=”com.h2database.h2”>.

This is declared as <driver name=”MSSQLJDBCDriver” module=”com.microsoft”/>

5. Create a data source in JBoss.

6. In the <drivers> section, you can then refer to this module name com.microsoft.

Creating a JDBC data source
After installing the JDBC Driver:

1. Start JBoss and log in to the Administration Console using, for example: 

http://localhost:9990/console

2. Click the Profile tab.

3. In the left pane, select Connector > Datasources.

4. On the JDBC Datasources page, click Add. 

The Create Datasource wizard starts.

5. On the Datasource Attributes page, type the data source name in the Name field. For example,
RPSDB.

6. In the JNDI Name field, type: 

java:/RPSDB

7. Click Next. 

The JDBC Driver page appears.

8. Select the installed JDBC driver. 

This is called either sqljdbc4.jar or MSSQLDBCDriver, depending on the selected driver
configuration.

9. Click Next. 

The Connection Settings page appears.
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10.In the Connection URL field, type the URL to the database: jdbc:sqlserver://
<server_name>:<server_port>;databaseName=<database_name>

For example:

jdbc:sqlserver://localhost:1433;databaseName=RPSADMIN

11.In the Username field, type the user ID to access the Rumba+ database to be used with the data
source. The default is rps.

12.In the Password field, type the password for the user. 

Note: The user name and password should match the ones used in the schema when creating the
Rumba+ Server database.

13.Click Done.

Configuring JBoss to work with MySQL

Connecting JBoss to the database using JDBC
Connector/J is the JDBC driver needed to connect to the MySQL database.

1. Download the latest version from the MySQL Web site: 

http://www.mysql.com/downloads/connector/j/

2. Extract the downloaded package.

3. Copy the mysql-connector-java-5.1.24-bin.jar file to a folder of your choice.

4. We recommend that you restart the application server.

Installing the JDBC driver as a deployment
Based on the mode you are using to run JBoss, you can install the mysql-connector-java-5.1.24-
bin.jar JDBC driver by deploying it directly to:

<server>/standalone/deployments

Alternatively, you can follow the steps below:

1. From the JBoss Application Server Console, select Deployments > Manage Deployments.

2. Click Add Content. 

The Upload wizard starts.

3. On the Deployment Selection page, select Choose File.

4. Browse to the JDBC connector mysql-connector-java-5.1.24-bin.jar file, then select Open.

5. On the Deployment Selection page, click Save.

6. On the Verify Deployment Names page, click Save.

7. On the Deployments page, click Enable on the row containing the connector.

Installing the JDBC driver as a module
Another option is to install the JDBC Driver as a module. This requires defining a new module for the JDBC
Driver inside the <server>/modules directory.

1. Create a directory called com/mysql/main in the <server>/modules directory.

2. Move the mysql-connector-java-5.1.24-bin.jar driver file to <server>/modules/com/mysql/main.
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3. In the same directory, create a file called module.xml with the following content: 

<?xml version="1.0" encoding="UTF-8"?>
<module xmlns="urn:jboss:module:1.0" name="com.mysql">
    <resources>
        <resource-root path="mysql-connector-java-5.1.24-bin.jar"/>
    </resources>
    <dependencies>
        <module name="javax.api"/>
        <module name="javax.transaction.api"/>
    </dependencies>
</module>

4. Open one of the following files:

• <server>/standalone/configuration/standalone.xml

• <server>/domain/configuration/domain.xml

5. Add the driver declaration tag referring to the module: 

<drivers>
    <driver name="MySqlJDBCDriver" module="com.mysql" />   <!-- This line 
has been added -->
    <driver name="h2" module="com.h2database.h2">
        <xa-datasource-class>
            org.h2.jdbcx.JdbcDataSource
        </xa-datasource-class>
    </driver>
</drivers>

Note: By default, the driver declaration tag already contains the declaration for <driver
name=”h2” module=”com.h2database.h2”>.

This is declared as <driver name=”MySqlJDBCDriver” module=”com.mysql”/>

6. Create a data source in JBoss.

7. In the <drivers> section, you can then refer to this module name com.mysql.

Creating a JDBC data source
After installing the JDBC Driver:

1. Start JBoss and log in to the Administration Console using, for example: 

http://localhost:9990/console

2. Click the Profile tab.

3. In the left pane, select Connector > Datasources.

4. On the JDBC Datasources page, click Add. 

The Create Datasource wizard starts.

5. On the Datasource Attributes page, type the data source name in the Name field. For example,
RPSDB.

6. In the JNDI Name field, type: 

java:/RPSDB

7. Click Next. 

The JDBC Driver page appears.

8. Select the installed JDBC driver. 

This is called either mysql-connector-java-5.1.24-bin.jar or MySqlJDBCDriver, depending
on the driver configuration.

9. Click Next. 
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The Connection Settings page appears.

10.In the Connection URL field, type the URL to the database: 

<server>:<port>/<datababase_name>

For example:

jdbc:mysql://localhost:3306/RPSADMIN

11.In the Username field, type the user ID to access the Rumba+ database to be used with the data
source. The default is rps.

12.In the Password field, type the password for the user. 

Note: The user name and password should match the ones used in the schema when creating the
Rumba+ Server database.

13.Click Done.

Deploying your Rumba+ license
Before you can run a Rumba+ application, you must deploy your Rumba+ license.

To do this, use the Rumba+ Server Administration Application. For more information, see the Rumba+
Server Administration Application Help.

Deploying and testing a Rumba+ application
This section first describes how to deploy and test the Rumba+ Server Administration Application. It then
describes how to deploy and test a Rumba+ application.

Before you deploy a Rumba+ application, you must first deploy the Rumba+ Server Administration
Application.

Deploying the Rumba+ Administration Application

Using the JBoss Administration Console

1. In the Runtime view, select Manage Deployments > Deployments > Add Content.

2. In the Deployment section, click Choose File.

3. Browse to the RPSAdmin.war file, then click Open.

4. In Verify Deployment Names, click Next.

5. Click Save.

6. In the Deployments pane, click Enable next to the application.

Using auto-deployment
Copy the RPSAdmin.war file to the <server>/standalone/deployments directory.

JBoss deploys the application automatically.

Note: We recommend that you use auto-deployment only in development mode, not production
mode.

Verifying the installation
Navigate to http://<server>:<port>/RPSAdmin to access the Administration Application.
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Note: The default port is 8080.

Deploying a Rumba+ application
Deploy a Rumba+ application in the same way as you deployed the Rumba+ Server Administration
Application.

Verifying the installation
Navigate to http://<server>:<port>/<application_name>

Using WebSockets
Not supported
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Installing and Configuring Oracle
GlassFish

This section describes how to install and configure Oracle GlassFIsh for Rumba+.

Installing GlassFish
1. Download the Oracle GlassFish Server Installer from http://www.oracle.com/technetwork/middleware/

glassfish/downloads/ogs-3-1-1-downloads-439803.html.

2. Ensure that your system meets the software and hardware requirements describe in Hardware and
Software Requirements in the Oracle GlassFish Server Release Notes (http://docs.oracle.com/cd/
E26576_01/doc.312/e24939/toc.htm). 

3. Follow the instructions in the GlassFish Server Installation Guide (http://docs.oracle.com/cd/E26576_01/
doc.312/e24935/toc.htm).

For more documentation, see http://docs.oracle.com/cd/E26576_01/index.htm.

Configuring GlassFish to work with Microsoft SQL

Connecting GlassFish to the database using JDBC
1. Download the Microsoft JDBC Driver for SQL Server 4.0 package,

sqljdbc_4.0.2206.100_enu.tar.gz, from http://www.microsoft.com/en-us/download/
details.aspx?displaylang=en&id=11774.

2. Extract the downloaded package to a temporary location.

3. Copy the sqljdbc4.jar file from the downloaded package to the <server>/glassfish/lib
directory.

4. Restart the GlassFish application server.

You are now ready to create JDBC connection pools and JDBC resources.

Creating a connection pool
1. In the Glassfish Administration Console, select Resources > JDBC Connection Pools.

2. In the JDBC Connection Pools pane click New. 

The New JDBC Connection Pool wizard starts.

3. Under General Settings, in the Pool Name field, type a name for the connection pool. For example,
MSSQLPool.

4. From the Resource Type list, select javax.sql.DataSource.

5. From the Database Driver Vendor list, select MicrosoftSqlServer.

6. Click Next.

7. Scroll down to Additional Properties.

8. In Additional Properties, set the following properties:
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• ServerName - The server to connect to. For example, localhost.
• User - The user name with which to connect to Microsoft SQL Server. The default value is rps.
• Password - The corresponding password for the user.
• DatabaseName - The database to connect to, RPSADMIN.

Notes:

• The default port number value is 1433. If you want to override this value, you need to set the
new value for the two following properties:

Port, PortNumber - Port number of the Microsoft SQL server.
• Generally, there is no need to set the URL value, as correct properties are already provided.

You can either clear the values from the URL field, or you can set them to the correct values.

Syntax: jdbc:sqlserver://<ServerName>:<Port>;databaseName=<DatabaseName>

9. Click Finish.

10.In the JDBC Connection Pools pane, select the connection pool you just created. 

Here you can review and edit information about the connection pool.

11.To test your connection pool, click Ping. A message is displayed to confirming that the ping succeeded.

Now that you have created a connection pool, you must create a JDBC data source.

Creating a JDBC data source
A Rumba+ application references a data source object to establish a connection with the Rumba+
database. To create a data source:

1. In the Glassfish Administration Console, select Resources > JDBC > JDBC Resources.

2. Click New. 

The New JDBC Resource pane appears.

3. In the JNDI Name field, type jdbc/RPSDB. This is the JNDI name to be used to access this resource.

4. From the Pool Name list, select the Microsoft SQL Server connection pool you just created -
MSSQLPool.

5. Optional: In the Description field, type a description for the resource.

6. Optional: Additional properties can be added if required.

7. Click OK to create the new JDBC resource. 

The JDBC Resources pane lists all available JDBC Resources.

Now your Rumba+ applications are ready to the connect to the Rumba+ Server database.

Configuring GlassFish to work with MySQL

Connecting GlassFish to the database using JDBC
1. Download the MySQL JDBC Driver for SQL Server from http://dev.mysql.com/downloads/connector/j/.

2. Copy the mysql-connector-java-5.1.24-bin.jar file from the downloaded package to the
<server>/glassfish/lib directory.

3. Restart the GlassFish application server.

You are now ready to create JDBC connection pools and JDBC resources.
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Creating a connection pool
1. In the Glassfish Administration Console, select Resources > JDBC Connection Pools.

2. In the JDBC Connection Pools pane click New. 

The New JDBC Connection Pool wizard starts.

3. Under General Settings, in the Pool Name field, type a name for the connection pool. For example,
MySQLPool.

4. From the Resource Type list, select javax.sql.DataSource.

5. From the Database Driver Vendor list, select MySQL.

6. Click Next.

7. Scroll down to Additional Properties.

8. In Additional Properties, set the following properties:

• ServerName - The server to connect to. For example, localhost.
• User - The user name with which to connect to MySQL Server. The default value is rps.
• Password - The corresponding password for the user.
• DatabaseName - The database to connect to, RPSADMIN.

Notes:

• The default port number value is 3306. If you want to override this value, you need to set the
new value for the two following properties:

Port, PortNumber - Port number of the MySQL server.
• Generally, there is no need to set the URL value, as correct properties are already provided.

You can either clear the values from the URL field, or you can set them to the correct values.

Syntax: jdbc:mysql://<ServerName>:<PortNumber>/<DatabaseName>

9. Click Finish.

10.In the JDBC Connection Pools pane, select the connection pool you just created. 

Here you can review and edit information about the connection pool.

11.To test your connection pool, click Ping. A message is displayed to confirming that the ping succeeded.

Now that you have created a connection pool, you must create a JDBC data source.

Creating a JDBC data source
A Rumba+ application references a data source object to establish a connection with the Rumba+
database. To create a data source:

1. In the Glassfish Administration Console, select Resources > JDBC > JDBC Resources.

2. Click New. 

The New JDBC Resource pane appears.

3. In the JNDI Name field, type jdbc/RPSDB. This is the JNDI name to be used to access this resource.

4. From the Pool Name list, select the MySQL Server connection pool you just created - MySQLPool.

5. Optional: In the Description field, type a description for the resource.

6. Optional: Additional properties can be added if required.

7. Click OK to create the new JDBC resource. 

The JDBC Resources pane lists all available JDBC Resources.

Now your Rumba+ applications are ready to the connect to the Rumba+ Server database.
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Deploying your Rumba+ license
Before you can run a Rumba+ application, you must deploy your Rumba+ license.

To do this, use the Rumba+ Server Administration Application. For more information, see the Rumba+
Server Administration Application Help.

Deploying and testing a Rumba+ application
This section first describes how to deploy and test the Rumba+ Server Administration Application. It then
describes how to deploy and test a Rumba+ application.

Before you deploy a Rumba+ application, you must first deploy the Rumba+ Server Administration
Application.

Deploying the Rumba+ Administration Application

Using the GlassFish Administration Console
1. Select Common Tasks > Applications.
2. Click Deploy.
3. Under Deploy Applications or Modules, click Choose file next to Location.
4. Browse to the RPSAdmin.war file, then click Open.
5. Click OK.

Using auto-deployment
Copy the RPSAdmin.war file to the auto-deployment directory. This is usually <server>/glassfish3/
glassfish/domains/domain1/autodeploy.

GlassFish deploys the application automatically.

Note: We recommend that you use auto-deployment only in development mode, not production
mode.

Verifying the installation
Navigate to http://<server>:<port>/RPSAdmin to access the Rumba+ Server Administration Application.

Note: The default port is 8080.

Deploying a Rumba+ application
Deploy the Rumba+ .war file package in the same way you deployed the Rumba+ Server Administration
Application.

Verifying the application
Navigate to http://<server>:<port>/<application_name>

Using WebSockets
If your Rumba+ application runs in GlassFish Application Server v3.1.2.2, you can set up your Rumba+
application and application server to use WebSockets for faster communication.
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Note: Rumba+ applications do not support GlassFish v4.0 native WebSockets implementation.

Enabling WebSockets support

1. In the Oracle GlassFish Admin Console, select Configurations > server-config > Network Config >
Protocols > http-listener1.

2. Select Edit Protocol > HTTP.

3. On the HTTP tab, find WebSockets Support and check Enable.

Building and deploying a Rumba+ application

1. Use the Rumba+ Server Build Tool to export your customization project. On the Application
Configuration page, check the option Support WebSockets For Faster Communication.

2. Deploy the application to the application server.
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Installing and Configuring Oracle
WebLogic

This section describes how to install and configure Oracle WebLogic for Rumba+.

Installing WebLogic
1. Download the Oracle WebLogic Server Installer from http://www.oracle.com/technetwork/

middleware/ias/downloads/wls-main-097127.html.

2. Ensure that your system meets appropriate hardware and software requirements described in http://
docs.oracle.com/middleware/1212/core/WLSIG/planning.htm#WLSIG237.

3. Follow the instructions to install the software.

4. After installing WebLogic, copy the Native IO library from C:\Weblogic\wlserver\server\native
\win\<32|x64>\wlntio.dll to the %JAVA_HOME%\bin directory.

5. Increase the initial thread pool size to 1500 threads. For example, use the the -
Dweblogic.threadpool.MinPoolSize=1500 flag.

Configuring WebLogic to work with Microsoft SQL

Connecting WebLogic to the database using JDBC
1. Download the Microsoft JDBC Driver for SQL Server 4.0 package,

sqljdbc_4.0.2206.100_enu.tar.gz, from http://www.microsoft.com/en-us/download/
details.aspx?displaylang=en&id=11774.

2. Extract the downloaded package to a temporary location.

3. Copy the sqljdbc4.jar file from the downloaded package to the <server>/user_projects/
domains/weblogic/lib directory.

4. Restart the WebLogic application server.

Creating a JDBC data source
1. In the JDBC Administration Console, select Services > Data Sources. 

The Summary of JDBC Data Sources page appears.

2. Select New > Generic Data Source. 

The Create a New JDBC Data Source page appears.

3. In the Name field, type a name for the data source. For example, MSSQLRPSDB.

4. In the JNDI Name field, type jdbc/RPSDB.

5. From the Database Type list, select MS SQL Server.

6. Click Next.

7. From the Database Driver list, select the Oracle built-in driver Microsoft’s MS SQL Server Driver
(Type 4) Versions: 2005 and later.
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8. Click Next.

9. On the Transaction Options page, use all the defaults and click Next.

10.In the Database Name field, type the Rumba+ database name, RPSADMIN.

11.In the Host Name field, type the name of the server you want to connect to. For example, localhost.

12.In the Port field, type the port number. The default Microsoft SQL server port is 1433.

13.In the Database User Name field, enter the login credentials to access the Rumba+ database to be
used with the data source. The default is rps.

14.In the Password field, type the password for this user. 

Note: Credentials must match the ones used in the schema when creating the Rumba+ Server
database.

15.Click Next.

16.Under Test Connection, click Test Configuration.

17.Click Finish.

Deploying the data source
1. On the Summary of JDBC Data Source page, select the newly created data source.

2. On the Targets page, select the server or clusters on which you would like to deploy the data source.

3. Click Save.

The data source is now ready to use with a Rumba+ application.

Configuring WebLogic to work with MySQL

Connecting WebLogic to the database using JDBC
Connector/J is the JDBC driver needed to connect to the MySQL database.

1. Download the latest version from the MySQL Web site: 

http://www.mysql.com/downloads/connector/j/

2. Copy the connector-java-5.1.24-bin.jar file from the downloaded package to the <server>/
user_projects/domains/weblogic/lib directory.

3. Restart the WebLogic application server.

Creating a JDBC data source
1. In the JDBC Administration Console, select Services > Data Sources. 

The Summary of JDBC Data Sources page appears.

2. Select New > Generic Data Source. 

The Create a New JDBC Data Source page appears.

3. In the Name field, type a name for the data source. For example, MySQLRPS.

4. In the JNDI Name field, type jdbc/RPSDB.

5. From the Database Type list, select MySQL.

6. Click Next.

7. From the Database Driver list, select the Oracle built-in driver MySQL's Driver (Type 4)
Versions:using com.mysql.jdbc.Driver.
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8. Click Next.

9. On the Transaction Options page, use all the defaults and click Next.

10.In the Database Name field, type the Rumba+ database name, RPSADMIN.

11.In the Host Name field, type the name of the server you want to connect to. For example, localhost.

12.In the Port field, type the port number. The default MySQL server port is 3306.

13.In the Database User Name field, enter the login credentials to access the Rumba+ database to be
used with the data source. The default is rps.

14.In the Password field, type the password for this user. 

Note: Credentials must match the ones used in the schema when creating the Rumba+ Server
database.

15.Click Next.

16.Under Test Connection, click Test Configuration.

17.Click Finish.

Deploying the data source
1. On the Summary of JDBC Data Source page, select the newly created data source.

2. On the Targets page, select the server or clusters on which you would like to deploy the data source.

3. Click Save.

The data source is now ready to use with a Rumba+ application.

Deploying your Rumba+ license
Before you can run a Rumba+ application, you must deploy your Rumba+ license.

To do this, use the Rumba+ Server Administration Application. For more information, see the Rumba+
Server Administration Application Help.

Deploying and testing a Rumba+ application
This section first describes how to deploy and test the Rumba+ Server Administration Application. It then
describes how to deploy and test a Rumba+ application.

Before you deploy a Rumba+ application, you must first deploy the Rumba+ Server Administration
Application.

Deploying the Rumba+ Administration Application

Using the WebLogic Administration Console

1. In the WebLogic domain structure tree, click Deployment/ 

The Summary of Deployments page appears.

2. Click Install. 

The Install Application Assistant appears.

3. In Locate deployment to install and prepare for deployment, click the link to upload your files.

4. In the Deployment Archive, click Browse.

Installing and Configuring Oracle WebLogic | 35



5. Browse to the Rumba+ application .war file, select the file, then click Open.

6. Click Next.

7. Click Next.

8. In Choose targeting style, select the Install this deployment as an application option.

9. Click Next.

10.In Optional Settings, use the defaults, then click Next.

11.Review your choices, then click Finish. 

The settings page for your application appears.

12.Click Save.

13.On the Testing Tab > Deployment Tests page, under the name of the newly deployed application, click
the default URL (this is the default URL of the server).

Using auto-deployment
Copy the RPSAdmin.war file to the <server>/user_projects/domains/weblogic/autodeploy
directory.

WebLogic deploys the application automatically.

Note: We recommend that you use auto-deployment only in development mode, not production
mode.

Switching from production mode to development mode:

1. Edit the config.xml file to set <production-mode-enabled>false</production-mode-
enabled>.

2. Restart the WebLogic application server.

Switching from development mode to production mode:

1. In the WebLogic console, under Domain Structure, select the domain name.
2. In the right pane, navigate to the Configuration - General page.
3. Check Production Mode.
4. Save the changes and click Activate Changes.
5. Restart the WebLogic application server.

Verifying the installation
Navigate to http://<server>:<port>/RPSAdmin to access the Administration Application.

Note: The default port is 7001.

Deploying a Rumba+ application
Deploy the Rumba+ .war file package in the same way you deployed the Rumba+ Server Administration
Application.

Verifying the application
Navigate to http://<host>:<port>/<application_name>

Using WebSockets
Not supported
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Configuring Rumba+ Server
You can use the following parameters to configure Rumba+ Server. These parameters are contained in the
<application_name>\WEB-INF\web.xml file for each Rumba+ application.

Parameter Default value Units Description

HostSettleDelay 400 ms Time that the Rumba+ Server waits for synchronous
connection before it decides that the host completed
sending its data.

MaxDecoderThreads 100 Maximum number of threads working on decoding the host
screen.

MinDecoderThreads 100 Minimum number of threads working on decoding the host
screen.

RequestTimeout 10 s Time to wait for response from host after sending data in
synchronous mode.

ConnectRequestTime
out

20 s Time to wait for response from host after connect request
in synchronous mode.

UserKerberos Boolean True, if Kerberos authentication to host has to be used.

Recommended configuration for Highload:

Change this parameter ... To this ...

MinDecoderThreads From 100 to 200.

MaxDecoderThreads From 100 to 200.

ConnectionCheckTimeout From 5 (default) to 0. This is the interval between
periodic host connection checking. 0 means never check

ImmediateConnectionCheckDelay From 400 (default) to 0. This is the delay before checking
the host connection inside the synchronous keys sending
a request. 0 means no connection check while inside the
request.

Configuring Rumba+ Server | 37



Using External Session Configuration
Parameters

The default session configuration in RPS is that each session connected to the same application has the
same configuration. However, you can define a separate configuration for a session by using external
session configuration parameters.

1. Add to the session URL a set of RPS session parameters to be posted by the client. For example: 

http://appserver1:8080/MyApp1?var1=one&var2=two&RPS_CFG_Host=cics1
&RPS_CFG_Port=2030&RPS_CFG_Model=5&RPS_CFG_DeviceName=DSPDEV01 …

2. Modify the AllowedParameters.properties file to provide a list of parameters that can be
overridden, without the prefix RPS_CFG_. For example: 

Host
Port
Model
DeviceName

Note: The AllowedParameters.properties

file is supplied with the deployed application.

Reference
The following parameters can be used with a URL:

Parameter Type

RPS_CFG_AsyncRequestTimeout Positive number (seconds)

RPS_CFG_ConnectRequestTimeout Positive number (seconds)

RPS_CFG_DeviceName Text

RPS_CFG_EnablePrinting Boolean

RPS_CFG_ExtendedAttributes Boolean

RPS_CFG_ForceSync Boolean

RPS_CFG_Host Text

RPS_CFG_HostLocale Text

RPS_CFG_HostSettleDelay Positive number (milliseconds)

RPS_CFG_ImmediateConnectionCheckDelay Positive number (milliseconds)

RPS_CFG_KeyboardLockDelay Positive number (milliseconds)

RPS_CFG_LogMaskHidden Boolean

RPS_CFG_Model 2/3/4/5

RPS_CFG_Port Positive number

RPS_CFG_PrintDocumentFormat "PDF" / "HTML"

RPS_CFG_PrinterConnectRequestTimeout Positive number (seconds)
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Parameter Type

RPS_CFG_PrinterDeviceName Text

RPS_CFG_PrinterDeviceNameOption "PrinterDeviceName" / "AssociatePrinter" /
"ManualPrinterDeviceName"

RPS_CFG_PrinterPollingInterval Positive number (seconds)

RPS_CFG_PrinterWaitInterval Positive number (milliseconds)

RPS_CFG_Protocol "3270" / "5250"

RPS_CFG_ProxyEnabled Boolean

RPS_CFG_ProxyName Text

RPS_CFG_ProxyPort Positive number

RPS_CFG_ProxyType Positive number

RPS_CFG_RSS Boolean

RPS_CFG_RSSAddress Text

RPS_CFG_RSSKeepAliveTimeout Positive number

RPS_CFG_RSSPort Positive number

RPS_CFG_RequestTimeout Positive number (seconds)

RPS_CFG_SSL * Boolean

RPS_CFG_ScreenAggregationInterval Positive number (milliseconds)

RPS_CFG_SharePrinter Boolean

RPS_CFG_StrictSSL Boolean

RPS_CFG_TerminalType Text

RPS_CFG_UseKerberos Boolean

* Not supported as an external parameter in this version.
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Contacting Micro Focus
Micro Focus is committed to providing world-class technical support and consulting services. Micro Focus
provides worldwide support, delivering timely, reliable service to ensure every customer's business
success.

All customers who are under a maintenance and support contract, as well as prospective customers who
are evaluating products are eligible for customer support. Our highly trained staff respond to your requests
as quickly and professionally as possible.

Visit http://supportline.microfocus.com/assistedservices.asp to communicate directly with Micro Focus
SupportLine to resolve your issues or e-mail supportline@microfocus.com.

Visit Micro Focus SupportLine at http://supportline.microfocus.com for up-to-date support news and access
to other support information. First time users may be required to register.

Information needed by Micro Focus SupportLine
When contacting Micro Focus SupportLine, please include the following information, if possible. The more
information you can give, the better Micro Focus SupportLine can help you.

• The name and version number of all products that you think might be causing an issue.
• Your computer make and model.
• System information such as operating system name and version, processors, and memory details.
• Any detailed description of the issue, including steps to reproduce the issue.
• Exact wording of any error messages involved.
• Your serial number. To find this number, look in the subject line and body of your Electronic Product

Delivery Notice e-mail that you received from Micro Focus.

Additional information needed by Micro Focus
SupportLine

If reporting a protection violation, you might be asked to provide a dump (.dmp) file. To produce a dump
file, use the Unexpected Error dialog box that is displayed when a protection violation occurs.

Unless requested by Micro Focus SupportLine, leave the dump setting as Normal (recommended), click
Dump, then specify a location and name for the dump file. Once the dump file has been written, you can e-
mail it to Micro Focus SupportLine.

You may also be asked to provide a log file created by the Consolidated Tracing Facility (CTF) - a tracing
infrastructure that enables you to quickly and easily produce diagnostic information detailing the operation
of a number of Micro Focus software components.
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Tell Us What You Think
We welcome your feedback regarding Micro Focus documentation.

Submit feedback regarding this Help

Click the above link to e-mail your comments to Micro Focus.
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