Micro Focus Enterprise Analyzer 3.4

Installation Guide

Micro Focus
The Lawn
22-30 Old Bath Road
Newbury, Berkshire RG14 1QN
UK
http://www.microfocus.com

Copyright © Micro Focus 2009-2013. All rights reserved.
MICRO FOCUS, the Micro Focus logo and Enterprise Analyzer are trademarks or registered
trademarks of Micro Focus IP Development Limited or its subsidiaries or affiliated
companies in the United States, United Kingdom and other countries.
All other marks are the property of their respective owners.
2013-04-26

ii

Contents
Overview

............................................................................................................. 4

Installation Tasks ................................................................................................................ 4
Deployment ......................................................................................................................... 5
Mainframe and Network Server ................................................................................5
Repository Server .....................................................................................................5
EA Server ................................................................................................................. 5
EA Client .................................................................................................................. 6
Single User Installation .............................................................................................6
Database Setup .................................................................................................................. 6
DB2 User Privileges ................................................................................................. 6
Oracle User Privileges ..............................................................................................7
SQL Server Database Setup ....................................................................................8

Hardware and Software Requirements

.......................................................... 10

Repository Server Hardware Requirements ..................................................................... 10
Repository Server Software Requirements .......................................................................10
EA Server Hardware Requirements ..................................................................................10
EA Server Software Requirements ................................................................................... 11
EA Client Hardware Requirements ................................................................................... 12
EA Client Software Requirements .....................................................................................12

Installing and Uninstalling Enterprise Analyzer

............................................14

Installing the Database Client ........................................................................................... 14
Installing the Oracle Client ..................................................................................... 14
Installing the DB2 Client ......................................................................................... 15
Installing EA on the Server or Client ................................................................................. 16
Installing the EA File Server or File Server Client (Optional) ............................................ 16
Installing the Java Add-On ................................................................................................ 17
Uninstalling Enterprise Analyzer ....................................................................................... 17

Post-Installation Administrative Tasks

.......................................................... 19

Configuring Enterprise Analyzer ....................................................................................... 19
Licensing ........................................................................................................................... 19
Upgrading Customers ............................................................................................ 19
Concurrent Use ...................................................................................................... 19
Enterprise Analyzer Licensing ................................................................................20
Business Rule Manager Licensing ......................................................................... 20
Configuring an ODBC Data Source Name ........................................................................20
Configuring an Oracle ODBC Data Source Name ................................................. 20
Configuring a DB2 ODBC Data Source Name ....................................................... 21
Creating a Shared Folder for Workspaces ........................................................................22
File Server Setup .............................................................................................................. 22
Upgrading Workspaces .....................................................................................................23

Troubleshooting the Installation

.....................................................................25

Troubleshooting Oracle Errors .......................................................................................... 25
Troubleshooting Workspace Access .................................................................................25

Contents | 3

Overview
This manual describes how to install and configure Micro Focus Enterprise Analyzer (EA), a suite of
software products for analyzing and modernizing legacy applications.
Enterprise Analyzer Standard Edition provides insight into the technical reality of complex application
portfolios, including
•
•
•

Tools for application and program level understanding, utilizing extensive metrics, reports,
diagrammatic views and querying tools to support myriad of business initiatives.
Quality Assessment with standard code quality queries to serve as a guidance to a code quality practice
in both development and maintenance phases.
Portability Assessment to help you generate various HTML reports to identify points of interest for
migrations.

Enterprise Analyzer Developer Edition adds developer in-depth analysis tools to promote efficiency in the
performance of daily tasks such as field changes, understanding of data propagation through a program,
and dead code removal.
Business Rule Manager mines business logic from program code and encapsulates the logic in business
rules.
While all products are installed with Enterprise Analyzer, each product is licensed separately.
EA is deployed in a multi-user environment with access to a common repository of application objects.
Repository setup is the responsibility of a master user, leaving team members free to focus on their tasks.
The database for the repository is assumed to be the customer's own.
EA installations consist of the following components:
•
•
•

The EA Server which hosts EA workspace files and related support files.
EA Clients which host the link files used to connect to workspaces on the server.
The EA File Server which is an optional product for sites that want to restrict Windows access to
application source files. As long as you set up workspace folder privileges correctly, ordinary users can
view and analyze source files in EA, but cannot access them otherwise. Only the master user has
Windows access to the source files.

This manual also describes how to install and configure the database client used to connect to repositories,
for sites at which the database client is not already installed. If you store repositories in Oracle or DB2, a
database client must be installed wherever the EA client or EA server is installed.

Installation Tasks
The table below describes the tasks involved in installing Enterprise Analyzer and the order in which the
tasks must be performed.
Task

Order

Notes

Install Database Client

1

The EA package installs SQL Server Express. This is
enough for a small sized repository (up to 10 GB).
Beyond that, an Oracle or DB2 database client must be
installed wherever the EA client or EA server is installed.
Install only if the database client is not already installed.

Install EA on Server
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Task

Order

Notes

Install Java add-on on Server

3

Optional.

Install File Server

4

Optional.

Install EA on Clients

5

Install Java add-on on Clients

6

Optional.

Install File Server Clients

7

Optional.

Each task is described and explained in the chapters of the Installation Guide.

Deployment
The figure below shows the standard EA deployment scenario. The role each machine performs and its
key relationships are described in the following sections.

Mainframe and Network Server
The mainframe typically hosts the application to be modeled in EA. Application source files are
downloaded from the mainframe (and, if necessary, a network server) to the EA server via FTP or SFTP.

Repository Server
The Repository Server hosts the database for one or more multiuser repositories, one repository per EA
workspace. This server provides centralized, network-accessible storage for parsed data and analysis
output.

EA Server
The EA Server hosts workspaces, workspace support files (including the copies of application source files
EA creates at workspace loading), and workspace output. This server leverages multiple processes to
enhance parsing performance in online or batch mode.
Parsed data is sent via ODBC to the repository server. Some analysis output is stored on the EA server as
well.
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Note: In a multi-user environment, the EA Server cannot reside on the same machine as the EA
Repository. The installation program is the same for the EA client and EA server.

EA Client
EA Clients host the link files that let team members connect to workspaces on the EA server. These clients
access repository data stored in the repository server via ODBC.
Note: The installation program is the same for the EA client and EA server.

Single User Installation
You can configure EA to build a workspace on one machine for a single user. You can use Microsoft SQL
Server Express - installed by default - to create a workspace on your local machine. Enterprise Analyzer
creates a database for the workspace "on the fly," with no intervention on your part. If you do use SQL
Server Express, bear in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.
Restriction: The database size limit when using the SQL Server Express option is 10 GB.

Database Setup
If you use Oracle or DB2, your DBA must set up a schema for each repository you plan to create. Each EA
user who accesses the repository must supply credentials for a database user with appropriate access
privileges to the repository.
If you use Microsoft SQL Server, the DBA must set up a SQL Server database for each workspace
repository you plan to create. EA users typically supply Windows credentials to access the repository.

DB2 User Privileges
If your site uses a DB2 database, your DBA must set up a database schema for each repository you plan
to create. Use the scripts provided with EA to create the DB2 database and tablespace, and the required
schemas. The scripts are located in the [Enterprise Analyzer_Installation_Directory]\DB2
Scripts folder.

Creating a Database and Tablespace
Run the following scripts provided with EA to create the DB2 database and tablespace. Open
the[Enterprise Analyzer_Installation_Directory]\DB2 Scripts folder:
1. Double-click [Enterprise Analyzer_Installation_Directory]\DB2 Scripts
\crtmwdb.cmd to create the database.
2. Open [Enterprise Analyzer_Installation_Directory]\DB2 Scripts\crttblspace.cmd
in an editor. Replace [ADMINISTRATOR_USER_ NAME] and [PASSWORD] with the user name and
password of a user with administrative privileges for the database. Save and close the file.
3. Double-click [Enterprise Analyzer_Installation_Directory]\DB2 Scripts
\crttblspace.bat to create the tablespace.
Modify the database (mwdb), buffer pool (mwbp), and tablespace (mwtblsp) names (optional). Modify the
names in any scripts that reference them.
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Note: The tablespace page size must be 32K. To improve the performance (optional) specify a
second tablespace for use in storing database indexes. Users specify both tablespaces when they
create an EA workspace. For instructions on how to create a workspace, see Getting Started in the
EA documentation set.

Creating a Schema
Set up a DB2 schema for each repository you plan to create. Run the following scripts provided with EA to
create a schema. In the [Enterprise Analyzer_Installation_Directory]\DB2 Scripts
folder:
1. Open crtschema.cmd in an editor. Replace [ADMINISTRATOR_USER_ NAME] and [PASSWORD]
with the user name and password of a user with administrative privileges for the database. Replace
each instance of [SCHEMA_NAME] with the name of the schema and [USER_NAME] with the database
user name. Save and close the file.
2. Double-click crtschema.bat to create the schema.
Repeat these steps for each schema you need to create.
Each EA user who accesses a repository must supply credentials for a database user with appropriate
access privileges to the schema. These credentials are typically those for the Windows domain user. The
table below shows the required privileges.
Type
Database Privileges

Schema Privileges

Tablespace Privileges

Privilege

BINDADD
CREATETAB
CONNECT
IMPLICIT_SCHEMA
CREATEIN
DROPIN
ALTERIN
USE OF

Oracle User Privileges
If your site uses an Oracle database, your DBA must set up a database schema for each repository you
plan to create. Each EA user who accesses the repository must supply the name and password of a
database user with appropriate access privileges to the schema. The table below shows the required
privileges.
Type

Privilege

Roles

GATHER_SYSTEM_STATISTICS (required only for Compute Database Statistics
method. See Getting Started in the EA documentation set.)

System Privileges

ALTER SESSION
CREATE SESSION
CREATE PROCEDURE
CREATE SEQUENCE
ALTER ANY SEQUENCE
CREATE SYNONYM
CREATE TRIGGER
CREATE ANY TABLE
DROP ANY TABLE
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Type

Privilege

ALTER ANY INDEX
CREATE ANY INDEX
DROP ANY INDEX
[UNLIMITED TABLESPACE]1
Object Privileges

SELECT on SYS.V_$INSTANCE
SELECT on SYS.V_$SESSION
SELECT on SYS.V_$PARAMETER

SQL Server Database Setup
If you use Microsoft SQL Server, you must set up a SQL Server database for each workspace repository
you plan to create. If EA users will connect to the repository through a SQL Server login account, make
sure the server authentication property is set to SQL Server and Windows Authentication mode, as
described below.
The following instructions assume you are using the SQL Server Management Studio tool for SQL Server
2008. The procedure for the SQL Server Management Studio Express tool for SQL Server 2005 is similar.
Note: For Windows XP installations using the Italian locale, you must set the Time format in the
Control Panel Regional Language Options to "HH:mm:ss" before attempting to verify an EA
workspace with a SQL Server repository. Click Settings > Control Panel > Regional and Language
Options > Customize > Time and choose "HH:mm:ss" from the Time format drop-down.
1. Choose Start > Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.
2. In the Connect to Server screen, select:
• Database engine in the Server type drop-down.
• The server on which you want to create the repository database in the Server name drop-down.
• Windows Authentication in the Authentication drop-down.
3. Click Connect. The Microsoft SQL Server Management Studio window opens. In the Object Explorer
pane, expand the folder for the server. Click Databases and choose New Database... from the rightclick menu. The New Database window opens.
4. Select the General page. In the Database name field, enter the name of the database for the
repository. Modify the logical name and initial sizes of the database and log files if needed, then click
OK. The new database is displayed in the Object Explorer pane.

5.

6.
7.
8.

9.
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Note: Check the SQL Server Management Studio documentation for details on other database
settings.
If EA users will connect to the workspace repository through a Windows user account, skip the
remaining steps. If EA users will connect to the workspace repository through an SQL Server login
account, click the server name in the Object Explorer pane and choose Properties from the right-click
menu. The Server Properties window opens.
Select the Security page. In the Server authentication area, select SQL Server and Windows
Authentication mode, then click OK.
In the Object Explorer pane, click Security > Logins and choose New Login... from the right-click
menu. The Login - New window opens.
Select the General page. In the Login name field, enter the database login name, then choose SQL
Server authentication. Enter the password for the database login in the Password and Confirm
password fields, then click OK. The new login is displayed in the Object Explorer pane.
In the Object Explorer pane, expand the database you created for the workspace repository. Click
Security > Users and choose New User... from the right-click menu. The Database User - New window
opens.

10.Select the General page. Define the database user:
•
•

•

In the User name field, enter the database user name.
In the Login name field, enter the database login name. Use the browse button to browse for the
login name.
Note: You specify the login name, not the database user name, when you create or connect to
a workspace, so it is usually best to make the user name and login name the same.
In the Database role membership pane, check db_owner, then click OK. The new user is displayed
in the Object Explorer pane.
Tip: You can use the same login and database user for multiple databases/workspaces.

You can configure EA to build a workspace on one machine for a single user. You can use Microsoft SQL
Server Express - installed by default - to create a workspace on your local machine. Enterprise Analyzer
creates a database for the workspace "on the fly," with no intervention on your part. If you do use SQL
Server Express, bear in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.
Restriction: The database size limit when using the SQL Server Express option is 10 GB.
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Hardware and Software Requirements
The following sections describe the hardware, disk space, operating system, and software requirements for
EA installations.
Note: The hardware and software requirements in the EA client and EA server tables apply equally to
the database client and the file server.

Repository Server Hardware Requirements
The table below lists the hard drive storage requirements for the Repository Server. For other hardware
recommendations, check with support services.
Type

Requirement

Notes

Hard Drive Storage

Variable

Minimum of 20 GB disk space needed for the
software installation of the RDBMS and the
EA template database. Plus approximately
60x the size in bytes of the application
source code modeled in EA (e.g., 100 MB
source = 6 GB).

Repository Server Software Requirements
The table below lists the software requirements for the Repository Server.
Type

Requirement

SQL Server

MS SQL Server 2005 or 2008

Oracle

Oracle 10g, 11g
Note: If you run the Batch Refresh Process (BRP) on
the repository server, Oracle must be .NET-enabled.
Oracle requirements for local BRP execution are as
follows:
•
•
•

DB2

For Windows XP and Windows Server 2003, Oracle 10g,
Fix Pack 2, Oracle 11g
For Windows Vista and Windows Server 2008, Oracle 10g,
Fix Pack 3, Oracle 11g
For Windows 7, Oracle 11g

DB2 9.5

EA Server Hardware Requirements
The table below lists the hardware requirements for EA Server installations. Hardware requirements may
vary depending on the size of the application you are analyzing.
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Type

Requirement

Notes

Processor

2.6 GHz Dual Core or 2x 3.0+ GHz
Processors

Dual processing capability with multiple cores
in a processor or separate physical
processors.

Physical Memory

3 GB RAM

Virtual Memory

1 GB to 3 GB

Hard Drive Storage

Variable

For EA workspaces, approximately 40x size
in bytes of the application source code
modeled in EA (for example, 100 MB source
= 4 GB).
For EA software, minimum 200 MB.
For Java add-on, minimum 115 MB.
For database client, minimum 200 MB.

EA Server Software Requirements
The table below lists the software requirements for EA Server installations.
Type

Requirement

Operating System

Microsoft Windows Server 2008, 32-bit and 64-bit
Microsoft Windows Server 2003, 32-bit and 64-bit
Microsoft Windows 7, 32-bit and 64-bit
Microsoft Windows XP Professional, Service Pack 3 or higher,
32-bit and 64-bit

Database Client

For Oracle or DB2, one configured ODBC data source name
(DSN) per database instance. The database client must
be .NET-enabled. Oracle database client requirements are as
follows:
•
•
•

Pre-Requisite Software

Note: The pre-requisite software is automatically
installed by the installer.
•
•
•
•
•
•
•
•

Internet Explorer 6.0 or higher (optional)

For Windows XP and Windows Server 2003, Oracle 10g,
Fix Pack 2, Oracle 11g
For Windows Server 2008, Oracle 10g, Fix Pack 3, Oracle
11g
For Windows 7, Oracle 11g

Windows Installer 4.5
Primary Interoperability Assemblies 2005 1.0.0
Sentinel RMS License Manager
.NET Framework 3.5 Service Pack 1
.Net Framework 4.0
Visual C++ 2005 Redistributable SP1 8.0_2.0.0
Visual C++ 2010 Redistributable 10.0_2.0.0
SQL Server 2008 R2 Express (installed automatically but
not required)

Required to view HTML report outputs.
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Type

Requirement

Microsoft Office (optional)

Required by EA tools with reporting capabilities to save to
Microsoft Office file formats. Excel is required for standard
deviation charts in the Executive Report.

Microsoft Visio (optional)

Required to generate output as Microsoft Visio .VSD files.
Note: Visio .VDX files are XML-based and may be
generated without Visio being installed on the EA client.

JRE 1.5.0 or higher (optional)

Required for Java add-on.

Adobe Flash Player 8.0 or higher

Required to see charts in the EA main window Chart Viewer.

EA Client Hardware Requirements
The table below lists the hardware requirements for EA Client installations. Hardware requirements may
vary depending on the size of the application you are analyzing.
Type

Requirement

Notes

Processor

3.0 GHz Processor

Single processor (single or dual core).

Physical Memory

1GB RAM

Virtual Memory

1GB to 3GB

Hard Drive Storage

Variable

For EA software, minimum 200MB.
For Java add-on, minimum 115MB.
For database client, minimum 200MB.

EA Client Software Requirements
The table below lists the software requirements for EA Client installations.
Type

Requirement

Operating System

Microsoft Windows 7, 32-bit and 64-bit
Microsoft Windows XP Professional, Service Pack 3 or higher,
32-bit and 64-bit
Microsoft Windows Server 2008, 32-bit and 64-bit
Microsoft Windows Server 2003, 32-bit and 64-bit

Database Client

For Oracle or DB2, one configured ODBC data source name
(DSN) per database instance. The database client must
be .NET-enabled. Oracle database client requirements are as
follows:
•
•
•

Pre-Requisite Software

Note: The pre-requisite software is automatically
installed by the installer.
•
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For Windows XP and Windows Server 2003, Oracle 10g,
Fix Pack 2, Oracle 11g
For Windows Server 2008, Oracle 10g, Fix Pack 3, Oracle
11g
For Windows 7, Oracle 11g

Windows Installer 4.5

Type

Requirement
•
•
•
•
•
•
•

Primary Interoperability Assemblies 2005 1.0.0
Sentinel RMS License Manager
.NET Framework 3.5 Service Pack 1
.Net Framework 4.0
Visual C++ 2005 Redistributable SP1 8.0_2.0.0
VisualC++ 2010 Redistributable 10.0_2.0.0
SQL Express 2008 R2 (installed automatically but not
required)

Internet Explorer 6.0 or higher (optional)

Required to view HTML report outputs.

Microsoft Office (optional)

Required by EA tools with reporting capabilities to save to
Microsoft Office file formats. Excel is required for standard
deviation charts in the Executive Report.

Microsoft Visio (optional)

Required to generate output as Microsoft Visio .VSD files.
Note: Visio .VDX files are XML-based and may be
generated without Visio being installed on the EA
Client.

JRE 1.5.0 or higher (optional)

Required for Java add-on.

Adobe Flash Player 8.0 or higher

Required to see charts in the EA main window Chart Viewer.

Hardware and Software Requirements
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Installing and Uninstalling Enterprise
Analyzer
Before running an installation program described in this section, make sure you have administrative
permissions for the machine on which you are performing the installation. If you do not have administrative
permissions, the installation program will not let you continue.
Note: You can run the Windows Installer (.msi) installation programs "silently." That is particularly
useful when you are installing clients on a network. Check with support services for the appropriate
sequence of commands.

Installing the Database Client
If you use Oracle or DB2, a database client must be installed wherever the EA client or EA server is
installed. If the RDBMS client software is not already installed on your machine, follow the instructions in
this section to install it.

Installing the Oracle Client
You will need the following information from your DBA to install and configure Oracle client software:
•
•
•
•

The TNS Service Name for the database in which your workspace repositories will be stored.
The host name for the computer on which the database resides.
The port number for communications with the host, if it is not the standard port number.
A database user ID and password.

1. Double-click the setup.exe program for the Oracle client installation. The Welcome screen opens.
2. Click Next. The Select Installation Type screen opens. Select Custom.
3. Click Next. The Specify Home Details screen opens. Enter an alternate name and path for the
installation, if desired. Otherwise, accept the defaults.
4. Click Next. The Available Product Components screen opens. Select the following components:
•
•
•
•
•

SQL *Plus
Oracle JDBC/THIN Interfaces
Oracle Windows Interfaces. Deselect every choice under Oracle Windows Interfaces except Oracle
ODBC Driver.
Oracle Call Interface (OCI)
Oracle Net

5. Click Next. The installer checks for prerequisites to ensure your environment meets the minimum
requirements for installation. Resolve any flagged items, if necessary.
6. Click Next. Review the Summary screen to confirm your selections. Use the Back button to correct any
errors. When you are satisfied that all the information is correct, click Install.
7. When installation completes, the Oracle Net Configuration Assistant is launched.
8. Click Next. The Naming Methods Configuration screen opens. Verify that Local Naming is shown in the
Selected Naming Methods field.
9. Click Next. The Net Service Name Configuration screen opens. In the Service Name field, enter the
TNS Service Name for the database your workspace repositories will be stored in. This name is
provided by your DBA.
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10.Click Next. The Select Protocols screen opens. Select TCP.
11.Click Next. The TCP/IP Protocol screen opens. Enter the host name for the computer on which the
Oracle database resides. This name is provided by your DBA. Use the standard port number of 1521
unless otherwise instructed by your DBA.
12.Click Next. The Test screen opens. Select Yes, perform a test.
13.Click Next. You should receive a message that the test did not succeed. This is because the default
login used for the test is the Oracle SYSTEM login. You must change the user name and password to
those provided by your DBA.
14.Click Change Login. In the Change Login dialog, enter the user ID and password provided by your
DBA.
15.Click OK. You should now receive a message that the connection test was successful. If the test
remains unsuccessful, click Change Login and confirm that you entered the correct credentials as
provided by your DBA. If problems persist, contact your DBA for assistance.
16.Click Next. The Net Service Name screen opens.
17.The Net Service Name field is prefilled with the TNS Service Name you specified in Net Service Name
Configuration screen. Click Next. The Additional Net Service Names screen opens.
18.In the Additional Net Service Names screen, configure additional TNS Service Names, one per
database instance you need to connect with. This step is optional. Select Yes to configure additional
TNS Service Names. Select No to complete the configuration.
Note: If you need to connect to additional database instances at a later date, you can add TNS
Service Names by manually editing the tnsnames.ora file in Repository_Client_HOME. See
your DBA for details.
19.Click Next. Then click Next on the following two screens to complete the Oracle Net Configuration.
20.On the Oracle Net Configuration completion screen, click Finish to exit the Net Configuration Assistant.
21.The Oracle Installer window opens Click Exit. You are prompted to confirm that you want to exit. Click
Yes.

Installing the DB2 Client
Follow the instructions in this section to install the DB2 client.
Note: The DB2 client must be .NET-enabled. Choosing the Typical DB2 client installation ensures
that .NET support is available.
1. Double-click the setup.exe program for the DB2 client installation. The Welcome screen opens. Click
Install a Product.
2. A screen prompts you to select the product you want to install. Under IBM Data Server Client, click
Install New.
3. The DB2 Setup Wizard opens. Click Next.
4. The Software License Agreement screen opens. Read the License Agreement carefully. Click I accept
the terms in the license agreement to accept its terms, then click Next.
5. A screen prompts you to select the installation type. Select Typical, then click Next.
6. A screen prompts you to install the IBM Data Server Client. Select Install IBM Data Server Client on
this computer, then click Next.
7. A screen prompts you to select an installation folder. To accept the prefilled value, click Next. To
specify a different folder, click Change and follow the substeps below.
a) Navigate the folder structure to find a suitable location. If the destination folder does not exist, the
installation creates it.
b) Click OK to exit the screen and return to the installation folder screen.
c) Click Next in the installation folder screen.

Installing and Uninstalling Enterprise Analyzer
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8. A screen prompts you to enable operating system security for DB2 objects. Unless otherwise instructed
by your system or database administrator, deselect Enable operating system security, then click
Next.
9. A screen prompts you to start copying installation files to your computer. Click Install to begin
transferring files to your machine. A progress meter indicates the progress of the transfer.
10.When the transfer is complete, a screen informs you that setup is complete. Click Next.
11.A screen prompts you to install additional products. Click Finish.

Installing EA on the Server or Client
The EA Server hosts EA workspace files and related support files. EA Clients host the link files used to
connect to workspaces on the server. Follow the instructions in this section to install EA on the client or
server. The Micro Focus License Manager is packaged with the installation.
Note: The EA Server cannot reside on the same machine as the EA Repository. The installation
program is the same for the EA client and EA server.
1. Double-click [Enterprise Analyzer_Installation_Directory]\setup.exe. (On Windows 7
and Windows 2008 right-click setup.exe and choose Run as administrator).
•
•

If the prerequisite software is installed on your machine, the Welcome screen opens.
If the prerequisite software is not installed on your machine, the Enterprise Analyzer Setup screen
prompts you to install the missing software. Click Install. When the software is installed, the
Welcome screen opens.

2. Click Next. The License Agreement screen opens. Read the License Agreement carefully. Click I
accept the terms in the license agreement to accept its terms, then click Next.
3. The Customer Information screen opens. Enter your user name and organization in the User Name and
Organization fields, respectively. Click Next.
4. The Destination Folder screen opens. Choose an installation folder. To accept the prefilled value, click
Next. To specify a different folder, click Change and follow the substeps below.
a) Navigate the folder structure to find a suitable location. If the destination folder does not exist, the
installation creates it.
b) Click OK to exit the Change Current Destination Folder screen and return to the Destination Folder
screen.
c) Click Next in the Destination Folder screen.
5. The Ready to Install the Program screen opens. Click Install to begin transferring files to your machine.
A progress meter indicates the progress of the transfer.
Note: To make changes to the settings, click Back repeatedly until you find the information you
are looking for, make the required changes, then click Next until you return to the Ready to Install
the Program screen.
6. When the transfer is complete, the Setup Complete screen opens. Click Finish.

Installing the EA File Server or File Server Client
(Optional)
The EA File Server is an optional product for sites that want to restrict Windows access to application
source files. As long as you set up workspace folder privileges correctly, ordinary users can view and
analyze source files in EA, but cannot access them otherwise. Only the master user has Windows access
to the source files. If you use the file server, it must be installed on the same machine as the EA server; the
file server client must be installed on the same machine as the EA client.
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1. Double-click[EA_File_Server_Installation_Directory]\setup.exe. The Welcome screen
opens.
2. Click Next. The License Agreement screen opens. Read the License Agreement carefully. Click I
accept the terms in the license agreement to accept its terms, then click Next.
3. The Destination Folder screen opens. Choose an installation folder. To accept the prefilled value, click
Next. To specify a different folder, click Change and follow the substeps below.
a) Navigate the folder structure to find a suitable location. If the destination folder does not exist, the
installation creates it.
b) Click OK to exit the Change Current Destination Folder screen and return to the Destination Folder
screen.
c) Click Next in the Destination Folder screen.
4. The Setup Type screen opens. Choose Custom, then click Next.
5. The Custom Setup screen opens. ChooseEA File Server, then click Next.
6. The Ready to Install the Program screen opens. Click Install to begin transferring files to your machine.
A progress meter indicates the progress of the transfer.
Note: To make changes to the settings, click Back repeatedly until you find the information you
are looking for, make the required changes, then click Next until you return to the Ready to Install
the Program screen.
7. When the transfer is complete, the Setup Complete screen opens. Click Finish.

Installing the Java Add-On
Note: JRE must be installed before installing the Java add-On.
Follow the instructions below to install the Java add-on. If you are installing in a distributed environment, be
sure to install the add-on on EA clients as well as the EA server.
1. Double-click [Enterprise Analyzer_Installation_Directory]\setup.exe. (On Windows 7
and Windows 2008 right-click setup.exe and choose Run as administrator).
2. Click Next. The License Agreement screen opens. Read the License Agreement carefully. Click I
accept the terms in the license agreement to accept its terms, then click Next.
3. The Ready to Install the Program screen opens. Click Install to begin transferring files to your machine.
A progress meter indicates the progress of the transfer.
Note: To make changes to the settings, click Back repeatedly until you find the information you
are looking for, make the required changes, then click Next until you return to the Ready to Install
the Program screen.
4. When the transfer is complete, the Setup Complete screen opens. Click Finish.

Uninstalling Enterprise Analyzer
Follow the instructions below to uninstall an Enterprise Analyzer product. Make sure you close any open
EA programs before running the uninstall program.
1. Choose Start > Settings > Control Panel.
2. Depending on the OS version:
a) (For Windows XP) In the Control Panel window, double-click Add/Remove Programs.
b) (For others) Click Start > Control Panel > Programs and features > Uninstall programs
3. In the Add/Remove Programs window, select the product you want to uninstall, then click Remove. You
are prompted to confirm that you want to uninstall the product. Click Yes.
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4. When the uninstall process completes, it prompts you to restart your computer. Click Yes to restart
immediately, or No if you plan to restart later.
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Post-Installation Administrative Tasks
Before you can work in Enterprise Analyzer, you must complete the basic administrative tasks described in
this section. You are prompted to perform the first of these tasks, configuring the EA, when you complete
the installation.

Configuring Enterprise Analyzer
Use the Configuration Manager in the Enterprise Analyzer Administration tool to configure EA options and
displays for the programming languages, dialects, character sets, and products in use at your site.
If you configure your EA for COBOL, for example, you will see only the EA options and displays
appropriate for COBOL modernization. You need to configure your EA for PL/I as well, you can come back
to the Configuration Manager later and select PL/I in addition to COBOL.
1. Open the Configuration Manager window.
•
•

If you are installing EA, the Configuration Manager window opens after you finish the installation.
If you have previously installed EA and want to reconfigure it, choose Start > Programs > Micro
Focus > Enterprise Analyzer > Enterprise Analyzer Administration. The Enterprise Analyzer
Administration window opens. In the Administer menu, choose Configure Micro Focus Enterprise
Analyzer. The Configuration Manager window opens.
Note: If EA is open, you are prompted to exit. Click OK, then close EA.

2. Select each programming language, dialect, and character set in use at your site. Select each EA
product you want to use at your site. The core Application Analyzer product is always selected. Select
Additional Tools to enable tools not used in typical EA configurations. When you are satisfied with
your choices, click OK.
Note: If you modify your EA configuration, make sure you upgrade workspaces created under the
previous configuration.

Licensing
Although all three Enterprise Analyzer products (Enterprise Analyzer Standard Edition, Enterprise Analyzer
Developer Edition and Business Rule Manager) are installed, each product is licensed separately. Follow
the instructions in the topics listed below to manage your licenses for EA products.

Upgrading Customers
A customer upgrading from Modernization Workbench version 3.1 or later may use the existing license key
to enable Enterprise Analyzer for the same number of users.

Concurrent Use
You can license Enterprise Analyzer and Business Rule Manager for concurrent use. In this mode, one
license key for the purchased number of end users will be registered to a license server and each user
instance will contact it for authorization.
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Enterprise Analyzer Licensing
Enterprise Analyzer users are issued 30-day trial licenses at installation, so that they can work in the
product out-of-the-box. A Sentinel RMS license server is installed with the product.
Depending on the licensing model in use at your site, you can manage your license:
•
•

Locally, using the installed Sentinel RMS license server.
Remotely, using a Sentinel RMS license server that has been configured to manage licenses centrally.
Note: The remote license server uses the same software as the local license server that is
installed with Enterprise Analyzer.

Each time you start Enterprise Analyzer during the trial period, the Micro Focus Licensing System
Administration tool notifies you how much of the trial period remains. You will need to enter an
authorization code in the License Management System to continue using Enterprise Analyzer after the trial
period ends:
•
•

If you use a local license server, enter the 16-character license authorization code for Enterprise
Analyzer in the Authorization tab, then click Authorize.
If you use a remote license server, click Options > Advanced Configuration, then click Change in the
License server field. Enter the IP address or server name of the license server, then click Save.
Note: You can start the Licensing System Administration tool at any time by choosing Start >
Programs > Micro Focus License Manager > License Management System.

Your License System Administrator can tell you which licensing model your site uses and provide you with
the name of the remote license server if needed. For complete information, including how to configure a
remote license server, refer to the help provided with the Licensing System Administration tool.

Business Rule Manager Licensing
Trial licenses are not provided for Business Rule Manager. Before you can work with it, you must enter the
16-character license authorization code:
•

Choose Start > Programs > Micro Focus License Manager > License Management System. In the
Licensing System Administration tool, click the Authorize tab, then enter the authorization code in the
Enter authorization code field and click Authorize.

Configuring an ODBC Data Source Name
An ODBC data source name (DSN) is a set of credentials for connecting with a database instance. If you
use Oracle or DB2, you must configure a DSN for the database that holds your workspace repositories.

Configuring an Oracle ODBC Data Source Name
To configure an Oracle Data Source Name (DSN), you must have specified a TNS Service Name for the
database in which your workspace repositories will be stored. This is the TNS Service Name you entered
when you installed the repository client.
Check the file tnsnames.ora in Repository_Client_HOME to make sure the TNS Service Name exists.
The entry should look like this, where RMWPROD is the TNS Service Name:
RMWPROD
(DESCRIPTION=
(ADDRESS_LIST=
(ADDRESS=(PROTOCOL=TCP)(HOST=tiger)(PORT=1521))
)
(CONNECT_DATA=
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(SID=lnx)
)
)
You will also need to obtain a database user ID and password from your DBA to configure the Oracle DSN.
Note: Keep the DSN handy. You will need to specify it when you create an EA workspace. For
instructions on how to create a workspace, see Getting Started in the EA documentation set.
1. In the Windows Control Panel, double-click Administrative Tools. The Administrative tools window
opens.
2. Double-click Data Sources (ODBC). The ODBC Data Source Administrator window opens.
3. Select the System DSN tab and click Add. The Create New Data Source dialog opens.
4. Select an appropriate Oracle driver and click Finish. The Oracle ODBC Driver Configuration window
opens.
5. Specify the following information in the Oracle ODBC Driver Configuration window:
•
•
•

•

In the Data Source Name field, enter a name of your choice to identify the data source. If your DBA
has supplied a common DSN for use across the enterprise, enter it here.
In the Description field, enter an optional description for the data source.
In the TNS Service Name drop-down, select the TNS Service Name for the database in which your
workspace repositories will be stored. If no choices are shown, or if you are unsure which name to
select, contact your DBA.
In the User ID field, enter the database user ID supplied by your DBA.

6. Click Test Connection. The Oracle ODBC Driver Connect window opens.
7. In the Oracle ODBC Driver Connect window the Service Name and User ID fields are prefilled with the
information you supplied in the Oracle ODBC Driver Configuration window. Enter the password for your
user ID and click OK. You are notified that the connection was created successfully. Click OK.
Note: If you receive an error, verify the driver configuration settings and retest the connection. See
your DBA if the problem persists.
8. Click OK to exit the Driver Configuration window. Then click OK again to exit the ODBC Data Source
Administrator window.

Configuring a DB2 ODBC Data Source Name
You will need the following information from your DBA to configure a DB2 ODBC data source name (DSN):
•
•
•

The name of the database in which your workspace repositories will be stored.
The host name for the computer on which the database resides.
The port number for communications with the host, if it is not the standard port number.
Note: Keep the DSN handy. You will need to specify it when you create an EA workspace. For
instructions on how to create a workspace, see Getting Started in the EA documentation set.

1. In the Windows Control Panel, double-click Administrative Tools. The Administrative tools window
opens.
2. Double-click Data Sources (ODBC). The ODBC Data Source Administrator window opens.
3. Select the System DSN tab and click Add. The Create New Data Source window opens.
4. Select IBM DB2 ODBC DRIVER - DB2COPY1 and click Finish. The ODBC IBM DB2 Driver
configuration dialog opens.
5. In the Data Source Name field, enter a name of your choice to identify the data source. If your DBA
has supplied a common DSN for use across the enterprise, enter it here.
6. In the Description field, enter an optional description for the data source.
7. In the Database alias field, select an existing database alias from the drop-down, then click OK.
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8. If a database alias has not been defined, click Add. The CLI/ODBC Settings window opens.
9. In the Data Source tab, the Data source name and Description fields are pre filled with the information
you supplied in the ODBC IBM DB2 Driver configuration dialog. In the User ID field, enter your domain
user name. In the Password field, enter your domain user password. The fields are case-sensitive.
10.Select the TCP/IP tab and specify the following information:
•
•
•
•

In the Database name field, enter the name of the database in which your workspace repositories
will be stored.
In the Database alias field, enter a database alias.
In the Host name field, enter the host name for the computer on which the database resides.
In the Port number field, enter the port number for communications with the host. Use the standard
port number of 50000 unless otherwise instructed by your DBA.

11.Click OK. You are returned to the ODBC Data Source Administrator window. Select the new data
source name and click Configure. The CLI/ODBC Settings window for the data source opens.
12.In the Data Source tab, the Data source name and Description fields are pre filled with the information
you supplied in the ODBC IBM DB2 Driver configuration dialog. In the User ID field, enter your domain
user name. In the Password field, enter your domain user password. The fields are case-sensitive.
Click Connect to test the database connection. You are notified that the connection was created
successfully. Click OK.
Note: If you receive an error, verify the driver configuration settings and retest the connection. See
your DBA if the problem persists.
13.Click OK to exit the CLI/ODBC Settings window. Then click OK again to exit the ODBC Data Source
Administrator window.

Creating a Shared Folder for Workspaces
The folder in which you plan to create workspaces must be shared with team members. It is typically more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path as described in Getting Started in the EA documentation set.
Follow the instructions below to create a shared folder for workspaces. You must be an administrator to
create a shared folder.
1. On the EA server, create a folder for EA workspaces.
2. Select the folder and choose Sharing and Security from the right-click menu. The Properties dialog for
the folder opens. In the Sharing tab for the Properties dialog, select Share this folder on the network
(or, on a machine in a Windows domain, Share this folder). Enter the share name in the Share name
field and click Apply.
Note: Do not embed spaces in the share name. Doing so may cause other users to be unable to
access the folder.
3. Click Permissions. The Permissions for Folder dialog opens. Specify the appropriate permissions for
users sharing the folder and click OK.

File Server Setup
The EA File Server is an optional product for sites that want to restrict Windows access to application
source files. As long as you set up workspace folder privileges correctly, ordinary users can view and
analyze source files in EA, but cannot access them otherwise. Only the master user has Windows access
to the source files.
Follow the instructions below to set up workspace folder privileges. You must be an administrator to
perform the first two steps.
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Note: If your site uses the EA File Server, you cannot configure master users on EA client machines.
All users on client machines must be ordinary users.
1. On the EA server machine, open Settings > Control Panel > Administrative Tools > Computer
Management. In the Computer Management window, create two groups, EAMasters and EAUsers.
The EAMasters group should contain master users, including the administrator. The EAUsers group
should contain ordinary users and, if you use the Three-Group Security Policy, subject matter experts
(SMEs).
Note: Group names are arbitrary. You can use any names you want.
2. On the EA server machine, create a folder for EA workspaces. Select the folder and choose Sharing
and Security in the right-click menu. The Properties dialog for the folder opens. In the Sharing tab for
the Properties dialog, select Share this folder on the network (or, on a machine in a Windows
domain, Share this folder). Enter the share name in the Share name field and click Apply.
Note: Do not embed spaces in the share name. Doing so may cause other users to be unable to
access the folder.
3. On the Security tab for the Properties dialog, give full access permissions for the shared folder to the
EAMasters and EAUsers groups and to the local SYSTEM account, then click OK.
4. Create a new workspace in the shared folder. After defining the connection parameters on the
Connection tab, click the Security tab and choose Secure sources access via EA file server. The server
name should be the name of the EA server machine. Leave the port number value as is, then click OK.
Note: For complete instructions on creating a new workspace, see Getting Started in the EA
documentation set.
5. In the folder for the workspace, right-click the Sources subfolder and choose Properties. In the Sources
Properties dialog, click the Security tab. On the Security tab, click Advanced. In the Advanced Security
Settings for Sources dialog, deselect Inherit from parent… A Security dialog opens. In the Security
dialog, click Copy. You are returned to the Advanced Security Settings for Sources dialog.
6. In the Advanced Security Settings for Sources dialog, select Replace permission entries… In the
Permission entries list, select the EAUsers group and click Remove.
7. In the Advanced Security Settings for Sources dialog, click Add. The Select Computer, User, or Group
dialog opens. In the Select Computer, User, or Group dialog, enter EAMasters (or whatever name you
chose for the EA master users group) and click OK. The Permission Entry for Sources dialog opens.
For the Full Control setting, check Allow, then click OK. You are returned to the Advanced Security
Settings for Sources dialog.
8. In the Advanced Security Settings for Sources dialog, click OK. You are prompted to continue. Click
Yes. In the Sources Properties dialog, click OK.

Upgrading Workspaces
When you modify your EA configuration, you must upgrade every workspace created with the previous
configuration. Only the master user can upgrade a workspace.
1. Choose Start > Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The EA Administration window opens.
2. In the Administration window, choose Administer > Upgrade Workspace. The Upgrade workspace
dialog opens.
3. Choose the workspace you want to upgrade, then click Open. A Workspace Upgrade window opens.
4. Click Start to begin the upgrade. In the Workspace Upgrade window you see the upgrade process (The
parts that are being upgraded are highlighted and the checkbox next to each upgraded part is checked
when the upgrade is complete.) You can Pause the upgrade and Resume it later.
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Note: Upgrades that have stopped due to an error can be reset from the File menu.
5. (optional) Click Workspace Upgrade > File >Export DDL Script to export the DDL script to perform
the upgrade and give it to a DBA.
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Troubleshooting the Installation
Follow the instructions in this section to troubleshoot an EA installation.

Troubleshooting Oracle Errors
Follow the instructions in this section to troubleshoot common Oracle errors.

ORA-00958: name is already used by an existing object
This error occurs because the schema for the workspace was created with an Oracle ID already used to
create another schema. A unique Oracle ID must be used to create an Oracle schema.

ORA-01034: ORACLE not available; ORA-27101
These errors occur because the Oracle instance is not running. You could be receiving ORA-27101
because you tried to modify database parameters such as SGA size.

Troubleshooting Workspace Access
The folder in which you plan to create workspaces must be shared with team members. If users are unable
to access workspaces, it may be because:
•
•
•

You have not shared the folder for workspaces. Share the folder, then refresh the workspace path as
described in Getting Started in the EA documentation set.
You shared the folder for workspaces after creating a workspace. Refresh the workspace path as
described in Getting Started in the EA documentation set.
You embedded spaces in the value of the Share name field for the folder. Remove the spaces, then
refresh the workspace path as described in Getting Started in the EA documentation set.
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