
Print out all or portions of this document and keep it handy for quick reference (use a color 
printer when available).

DevPartner Features
Use the links in the left column in the following table to locate reference information about 
DevPartner features.

More Information
Refer to the DevPartner online help or to the Understanding DevPartner manual for more 
information.

Common Elements
The DevPartner software provides these common elements, regardless of feature.

• DevPartner Toolbar
• DevPartner Menu
• DevPartner File Extensions
• Command Line Instrumentation Options

DevPartner Menu and Toolbar
Accessed from the DevPartner menu or toolbar in Visual Studio..

To solve this problem Use this DevPartner 
feature

Diagnose run-time errors in the source code Error Detection

Locate performance bottlenecks in the application Coverage and Performance 
Analysis

Ensure code base stability throughout development and testing phases Coverage Analysis Session Data

Choose this menu or toolbar item To
 Error detection Perform run-time error detection using 

BoundsChecker technology 

 Coverage Analysis Perform run-time code coverage analysis

 Error detection and Coverage Analysis Perform run-time error detection with code 
coverage analysis

 Performance Analysis Execute run-time performance analysis 

Error Detection Rules Access error detection rules management, 
used to filter or suppress detected errors

 Native C/C++ Instrumentation Perform compile-time instrumentation for: 
Error detection, Error detection with 
coverage, performance or coverage analysis 

Native C/C++ Instrumentation Manager Access the Instrumentation Manager

Correlate Correlate performance or coverage files

Merge Coverage Files Merge coverage analysis sessions

 Options Access DevPartner options
Choices include: Analysis, Code review, 
Error detection



Common Elements
DevPartner File Extensions
File extensions for session files.

Command Line Instrumentation Options

NMCL Options
The following table lists the NMCL options that you can use to instrument your unmanaged 
(native) C++ code from the command line. Use NMCL.EXE only to compile unmanaged C++ 
code with DevPartner performance and coverage or error detection instrumentation. NMCL is 
not used with managed code, which DevPartner instruments as it is passed to the common lan-
guage runtime during execution.

Note All NMCL options must begin with a forward slash (shown in the following list) or 
hyphen, followed by the letters NM. For example: /NMoption or –NMoption.

When using NMCL, add the directory containing these utilities to your path. For example, if 
you installed the product into the default directory, add the following directory to your path: 

C:\Program Files\Common Files\Micro Focus\NMShared 

Note: For installs on 64-bit versions of Windows, add the following directory to your path:

C:\Program Files (x86)\Common Files\Micro Focus\NMShared 

Running this DevPartner feature Creates this session file (extension)
Code coverage .dpcov

Code coverage merge files .dpmrg

Error detection .dpbcl

Performance analysis .dpprf

Use... To...
/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not 

have the directory that contains NMCL on your path.

/NMclpath:cl-path Specify the directory location of cl.exe. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

/NMhelp or /? Display help text

/NMignore:source-file or 
/NMignore:source-file:method source-file

Specify a source file or a method in a source file that should 
not be instrumented

/NMlog:log-file Specify a log file for NMCL messages (default: stdout)

/NMnogm Ignore the CL /Gm (minimal rebuild) option if it appears on 
the command line. You can use this option to avoid a 
known conflict between the NMAKE /A and CL /Gm 
options.

/NMonly:source-file Specify a single source file that should be instrumented

/NMopt:option-file or 
/NM@option-file

Specify an option file (an ASCII file containing individual 
command-line options, each on a separate line)

/NMpass Specify pass-through mode, which instructs NMCL to call 
CL without intervention. In this case, no instrumentation 
takes place.

/NMstoponerror Stop NMCL if an error occurs during instrumentation. If this 
option is not specified, the default behavior is to fall back to 
a standard CL compile.

/NMbcOn Use DevPartner Error Detection instrumentation. This is the 
default setting.

/NMtxOn Specifies instrumentation for performance and coverage 
analysis.

/NMtxInlines Instruments methods that are marked as inlineable if inline 
optimizations are enabled (using the /O1, /O2, /Ob1, or 
/Ob2 option)

/NMtxNoLines Instruct DevPartner not to collect line information. When 
you use this option, DevPartner does not display any line 
data in the Source tab. You can also use this to improve the 
time required to instrument and run your application.

/NMtxpath:tx-path Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

Use... To...
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Common Elements
NMLINK Options
The following table lists the NMLINK options that you can use to link your unmanaged (native 
code) C++ application to DevPartner.

Note: All NMLINK options must begin with a forward slash (shown in the following list) or 
hyphen, followed by the letters NM. For example: /NMoption or –NMoption.

When using NMCL and NMLINK, add the directory containing these utilities to your path. For 
example, if you installed the product into the default directory, add the following directory to 
your path:

C:\Program Files\Common Files\Micro Focus\NMShared

Note: For installs on 64-bit versions of Windows, add the following directory to your path:

C:\Program Files (x86)\Common Files\Micro Focus\NMShared 

Use... To...
/NMbcOn Use DevPartner Error Detection instrumentation. This is the 

default setting.

/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not 
have the directory that contains NMCL on your path.

/NMhelp or /? Display help text

/NMlinkpath:link-path Specify the directory location of LINK.EXE. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

/NMpass Specify pass-through mode, which instructs NMLINK to call 
LINK without intervention.

/NMtxOn Specifies instrumentation for performance and coverage 
analysis.

/NMtxpath:tx-path Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

Use... To...
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Coverage and Performance Analysis
Coverage and Performance Analysis
Determine application test coverage and profile application performance.

General and Data Collection Properties
The following data collection properties apply to coverage and performance analysis. 

DevPartner toolbar buttons for Coverage and Performance

Property Default setting
Automatically Merge Session Files Ask me if I would like to merge it

Collect information about .NET assemblies True

Collect COM Information True

Exclude Others True

Instrument inline functions True

Instrumentation Level Line

Track System Objects True

Select analysis preference
Coverage Analysis

Error Detection with Coverage

Performance Analysis

Native C/C++ Instrumentation
Enable/disable instrumentation

Set DevPartner Options

Performance and Coverage Analysis Session Toolbars

Performance Session toolbar

Compare sessions

View Call Graph

Find method in source code

Coverage Session toolbar

Choose instrumentation type
DevPartner Studio Quick Reference - 4



Coverage Analysis
Coverage Analysis

Coverage Analysis Session Data

Filter the data view View coverage metrics for methods

View execution data for 
lines of source code 

Merge coverage sessions and record merge history

View statistics for sessions or 
merge file

Results Summaries
DevPartner displays results for coverage analysis in Visual Studio or in the Coverage Analysis 
Viewer. Session files present data in tabbed format, including the following tabs:

• Method List
• Source Code
• Merge History
• Session or Merge Summary
DevPartner Studio Quick Reference - 5



Performance Analysis
Performance Analysis

Performance Analysis Session Data

Filter the data view 

View performance metrics for methods View session statistics
Locate methods in source code

Explore calling 
sequence of methods 
and identify critical path

Compare session data to 
assess impact of code changes

Results Summaries
DevPartner displays results for performance analysis in Visual Studio or in the Performance 
Analysis Viewer. Session files present data in tabbed format, including the following tabs:

• Method List
• Source Code
• Session Summary
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Using DPAnalysis.exe
Using DPAnalysis.exe
Use DPAnalysis.exe to run coverage or performance analysis sessions from the command line. 
DPAnalysis.exe accepts command line switches or an XML configuration file.

Command Line Operations
Use this syntax to run coverage or performance sessions from the command line:

DPAnalysis.exe [a] {b} {c} {d} [e] target {target args}

DPAnalysis.exe requires Analysis Type and Target Type switches. Use of other switches is 
optional.

The following table lists the switches used with DPAnalysis.exe:

Category Switches
[a] Analysis Type /Cov[erage] - Sets analysis type to DevPartner coverage analysis

/Perf[ormance] - Sets analysis type to DevPartner performance analysis

{b} Data Collection /E[nable] - Enables data collection for the specified process or service

/D[isable] - Disables data collection for the specified process or service

/R[epeat] - Profiling will occur any time you run the specified process until you use 
the /D switch to disable profiling.

{c} Other Options /O[utput] - Specify the session file output directory and/or filename

/W[orkingDir] - Specify working directory for the process or service

/H[ost] - Specify the target’s host machine

/NOWAIT - Do not wait for the process to exit, just wait for it to start

/NO_UI_MSG - Set this switch to true to suppress UI error messages. The
default is false.

/N[ewconsole] - Run the process in its own command window

/F[orce_profiling] - Forces profiling for coverage or performance of applications 
written without managed code or CTI.

/A[ssembly_dir] - For Coverage Analysis only. A list of path(s) that contain referenced 
DLL/PDB files. Use this switch to specify any referenced but not loaded DLL/PDB files 
to display in a Coverage session file. Separate multiple paths with a semicolon (;).

{d} Analysis Options /NO_QUANTUM - Disables excluding time spent on other threads

/NM_METHOD_GRANULARITY - Sets data collection granularity to method-level 
(line-level is default)

/EXCLUDE_SYSTEM_DLLS - Excludes data collection for system dlls (performance 
analysis only)

/NM_ALLOW_INLINING - Enable run-time instrumentation of inline methods 
(coverage and performance analysis only)

/NO_OLEHOOKS- Disable collection of COM

/NM_TRACK_SYSTEM_OBJECTS - Track system object allocation (memory analysis 
only)

[e] Target Type Identifies target that follows as either a process or service. Pick only one. All 
statements that follow the target name/path are considered arguments to the target

/P[ocess] - Specify a target process (followed by arguments to process)

/S[ervice] - Specify a target service (followed by arguments to service)

/C[onfig] - Path to configuration file

Category Switches
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Using DPAnalysis.exe
Configuration File
Use this syntax to run coverage or performance analysis sessions through a configuration file: 

DPAnalysis.exe /config c:\temp\config.xml

The following table briefly describes the XML elements. See the DevPartner online help or the 
Understanding DevPartner manual for more information.

Element Description
AnalysisOptions (Optional) For each Process or Service, zero or one. Defines runtime attributes for the 

specified target process or service. Attributes correspond to DevPartner properties 
accessible from the Properties Window in Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_QUANTUM

Arguments (Optional) For each Process or Service, zero or one. Defines runtime attributes for the 
specified target process or service. Attributes correspond to DevPartner Coverage, 
Memory and Performance Analysis properties accessible from the Properties Window in 
Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_QUANTUM

ExcludeImages (Optional) For each Process or Service, zero or one. No default if omitted. Defines 
images (at least one, no maximum) which, if loaded by the target process or service, 
will not be profiled. No attributes.

Host (Optional) For each Process or Service, zero or one. No default if omitted. Sets the host 
machine of the target process or service. No attributes.

Name One required for each service. Provides the name of the service as registered with the 
service control manager. This is the same name you would use for the system's NET 
START command. No attributes.

Path One required for each process. Specify a fully qualified or relative path to the 
executable. You can specify the executable name without the path if the executable 
exists in the current directory. No attributes.

Process The configuration file must contain at least one Process or one Service element. 
Specifies a target executable.
Attributes: CollectData, Spawn, NoWaitForCompletion, NewConsole 

RuntimeAnalysis Required; one only. Defines the type of analysis and maximum session time.

Service The configuration file must contain at least one Process or one Service element. 
Specifies a target service.
Attributes: CollectData, Start, RestartIfRunning, RestartAtEndOfRun

Targets Required. One only. Begins a block of one or more Process or Service entries. Target 
processes and services are started in the order they are listed in the configuration file.
Attributes: RunInParallel

Element Description
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Error Detection
Error Detection

File Extensions Used by Error Detection

Default Options (DevPartner Studio Professional and Enterprise Editions) 
or Settings (Visual C++ BoundsChecker Suite)

Extension File Type Description
.dpbcl Error Detection Session File This is the Error Detection log for the user's program 

execution.

.dpbcc

.dpbcd
Error Detection Settings File This file contains the various settings for Error 

Detection. The .dpbcd extension refers to the default 
settings file created, while .dpbcc refers to a custom 
settings file that has been saved separately.

.dpsup Error Detection Suppressions File This file contains the various suppressions for the user's 
program.

.dpflt Error Detection Filters File This file contains the various filters for the user's 
program.

.dprul Error Detection Rules File This is a database of the user's suppressions and filters.

Category Settings
General On Log events

On Display error and pause

Off Prompt to save program results

Off Show memory and resource viewer when application exits

On Source file search path - based on the location of the .EXE (standalone), 
.DSW (C++), or .SLN (Visual Studio). 

- Override symbol path (standalone only) - Default: empty

- Working directory (standalone only) based on the location of the .EXE 

- Command line arguments (standalone only) - Default: empty

Data Collection On Call parameter coding depth = 1

On Maximum call stack depth on allocation = 5

On Maximum call stack depth on error = 20

On NLB file directory is based on the location of the .EXE (standalone), 
.DSW (C++), or .SLN (Visual Studio). 

API Call Reporting Off Enable API call reporting. All selections are unavailable until you select this 
item.

- Collect window messages - Default when active: Off

- Collect API method calls and returns. - Default when active: On

- View only modules needed by this application - Default when active: On

- All modules (tree view). - Default when active: All selected 

Call Validation Off Enable call validation. All selections unavailable until you select this item

- Enable memory block checking - Default when active: Off

- Fill output argument before call - Default when active: Off

- COM failure codes - Default when active: On

- Check for COM “Not Implemented” return code - Default when active: 
On

- API failure codes - Default when active: On

- Check invalid parameter errors: API, COM - Default when active: both On

- Category: Handle and pointer arguments - Default when active: On

- Category: Flag, range and enumeration arguments - Default when 
active: On

- Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default 
when active: All items selected

COM Call Reporting Off Enable COM method call reporting on objects that are implemented in 
the selected modules

- Report COM method calls on objects implemented outside of the listed 
modules - Default when active: On

- All components tree view - Default when active: All selected 

COM Object Tracking Off Enable COM object tracking

- All COM classes tree view - Default when active: All selected

Category Settings
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Error Detection
Error Detection Toolbar in Visual Studio
Deadlock Analysis Off Enable deadlock analysis

- Assume single process - Default when active: On

- Enable watcher thread - Default when active: Off

- Generate errors when: A critical section is re-entered - Default when 
active: Off

- Generate errors when: A wait is requested on an owned mutex - Default 
when active: Off

- Number of historical events per resource - Default when active: 10

- Report synchronization API timeouts - Default when active: Off

- Report wait limits or actual waits exceeding (seconds) - Default when 
active: 60

- Synchronization Naming Rules - Default when active: Don’t warn about 
resource naming

Memory Tracking On Enable memory tracking

Off Enable Leak Analysis Only

Off Show leaked allocation blocks

On Enforce strict reallocation semantics

On Enable FinalCheck

On Enable guard bytes; Pattern = FC; Count = 4 bytes

- Check heap blocks at runtime: On free

On Enable fill on allocation; Pattern = FB

On Check uninitialized memory; Size = 2 bytes

On Enable poison on free; Pattern = FD

.NET Analysis Off Enable .NET analysis

- Exception monitoring - Default when active: On 

- Finalizer monitoring - Default when active: On

- COM interop monitoring - Default when active: On

- PInvoke interop monitoring - Default when active: On

- Interop reporting threshold - Default when active: 1

.NET Call Reporting Off Enable .NET method call reporting

- All types (tree view node) - Default when active: Selected.

- .NET User Assemblies (tree view node) - Default when active: Selected

- .NET System Assemblies (tree view node) - Default when active: Not 
selected

Resource Tracking On Enable resource tracking

On Resources tree view. All listed resources are selected by default

Category Settings

Set DevPartner Options

Start with Error Detection
Start with Coverage Analysis
Start with Error Detection and Coverage Analysis
Start without debugging with Performance Analysis
Note: The arrows next to each button allow you to start with or without 
debugging, depending on the default action of the button.

Native C/C++ Instrumentation
Enable/disable instrumentation
Choose instrumentation type
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Error Detection
Error Detection Window Icons Used in the Results Pane

Icons Used in the Details Pane

Details Pane
Displays long description of detected 
error; call stack information; reference 
count graph (see inset below).

Results Pane
Summary, Memory Leaks, Other Leaks, Errors, .NET 
Performance, Modules, Transcript tabs provide 
overview and detail about detected errors.

Source Pane

Displays source code for the 
detected error, if available.

Details Pane - Reference Count Graph
Displays Reference Count View and Object Identity 
View tabs when you select an Interface Leak in the 
Results pane.

Icon Description Appears in...
Memory Leaks Summary, Memory Leaks, and Transcript tabs

Other Leaks Summary, Other Leaks, and Transcript tabs

Errors Summary, Errors, and Transcript tabs

.NET Performance Summary, .NET Performance tabs

Module Load Event Summary, Modules, and Transcript tabs

Subroutine call Transcript tab

Garbage Collection Event Transcript tab

Event Begins Transcript tab

Event Resumes Transcript tab

Event Ends Transcript tab

Icon Description
Subroutine call

Entry Parameters

Exit Parameters

Return Value

Property (default) for data types

Property for data types
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Error Detection
Reference Count Graph Toolbar

Program Error Detected Dialog Box

Memory and Resource Viewer Dialog Box

Scale to Size
Select Viewing Area

Vertical Zoom Out
Vertical Zoom In 

Horizontal Zoom Out
Horizontal Zoom In

Error description

Call stack information Source code for the detected error

Tabs for multiple call stacks

Memory Contents PaneResults Pane
Displays Memory, Resource, and Summary tabs

Source Pane
Displays source code for the 
detected error, if available.

Stack Pane

Mark and Close
Click to mark existing allocations and close the 
dialog box. Marked items will not be shown when 
Memory and Resource viewer reappears. 
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Error Detection
ActiveCheck and FinalCheck Error Detection

ActiveCheck
ActiveCheck™ analyzes your program and searches for errors in your program executable as 
well as the dynamic-link libraries (DLLs), third-party modules, and COM components used by 
your program. The following tables list the types of errors found with ActiveCheck error 
detection.

FinalCheck Compile Time Instrumentation - Deepest Error Detection
FinalCheck™ compile time instrumentation (CTI) enables Error Detection to find more errors 
(memory leaks, pointer errors, data corruption errors, and so on) as they occur in real time. 
FinalCheck finds these types of errors, plus all errors found with ActiveCheck.

Deadlock-related Errors API and COM Errors
Deadlock COM interface method failure

Potential deadlock Invalid argument

Thread deadlocked Parameter range error

Critical section errors Questionable use of thread

Semaphore errors Windows function failed

Resource usage and naming errors Windows function not implemented

Suspicious or questionable resource usage Invalid COM interface method argument

Handle errors

Event errors

Mutex errors

Windows event errors

.NET Errors Pointer and Leak Errors
Finalizer errors Interface leak

GC.Suppress finalize not called Memory leak

Dispose attributes errors Resource leak

Unhandled native exception passed to managed 
code

Memory Errors
Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memory block

Stack memory overrun

Static memory overrun

Memory Errors Pointer and Leak Errors
Reading overflows buffer Array index out of range

Reading uninitialized memory Assigning pointer out of range

Writing overflows buffer Expression uses dangling pointer

Expression uses unrelated pointers

Function pointer is not a function

Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free

Memory leaked due to reassignment

Memory leaked leaving scope

Returning pointer to local variable
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Export DevPartner Data: Command Line Use
List of Available Keyboard Commands - Visual Studio Export DevPartner Data: Command Line Use
You can use DevPartner.Analysis.DataExport.exe from the command line to convert DevPartner 
coverage analysis (.dpcov), coverage analysis merge (.dpmrg), and performance analysis 
(.dpprf) session file data to XML. 

Use this syntax to export session data to XML:
DevPartner.Analysis.DataExport.exe [sessionfilename|pathtodirectory] {options}

Options
The following table lists the command line options for DevPartner.Analysis.DataExport.exe.

You can use an equal sign, a colon, or a space to separate an option from the value or values 
you specify. 

Command Action
Ctrl+Shift+O File > Open > Project

Ctrl+Shift+N File > New > Project

Ctrl+S File > Save Project

Ctrl+Shift+S File > Save All

Ctrl+Shift+F Edit > Find in Files

Ctrl+Shift+H Edit > Replace in Files

Alt+F12 Edit > Find Symbol

Ctrl+Alt+L View > Solution Explorer

Ctrl+Shift+C View > Class View

Ctrl+Alt+S View > Server Explorer

Ctrl+Shift+E View > Resource View

F4 View > Properties Window

Ctrl+Alt+X View > Toolbox

Shift+Alt+Enter View > Full Screen

Shift+F4 View > Property Pages

Ctrl+Shift+B Build > Build Solution

F5 Debug > Start

Ctrl+F5 Debug > Start Without Debugging

Ctrl+Alt+E Debug > Exceptions

F11 Debug > Step Into

F10 Debug > Step Over

Ctrl+B Debug > New Breakpoint

Ctrl+F1 Help > Dynamic Help*

Ctrl+Alt+F1 Help > Contents*

Ctrl+Alt+F2 Help > Index*

Ctrl+Alt+F3 Help > Search*

Shift+Alt+F2 Help > Index results*

Shift+Alt+F3 Help > Search results*

* Visual Studio 2005, 2008

Switch Description
/out[put]=<String> Specify the output directory for exported XML files. Creates the directory 

if the directory does not exist.

/r[ecurse] Search subdirectories for DevPartner session files. 

/f[ilename]=<String> Specify the name of the XML output file. Appends .xml to the name 
specified.

/showAll Shows all performance and coverage session file data available in a 
performance or coverage session file.
For example, if you export a performance session file with this option, 
the resulting XML file contains both performance and coverage data 
fields.

/w[ait] Wait for input before closing console window. 

/nologo Do not display the logo or copyright notice. 

/help or /? Display help in the console window. 
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