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AccuRev Plug-In for Visual Studio PE
Installation and Release Notes
This book is your guide to installing AccuRev Plug-In for Visual Studio® PE. It is intended for AccuRev®
and Visual Studio system administrators.
Note: Prior to Release 2013.1, AccuRev Plug-In for Visual Studio PE was called AccuBridge for
Visual Studio PE.

What is AccuRev Plug-In for Visual Studio PE?
AccuRev Plug-In for Visual Studio® PE (AccuRev Plug-In) is the integration between AccuRev and the
following Visual Studio products:
•
•
•
•

Visual Studio 2010
Visual Studio 2012
Visual Studio 2013
Visual Studio 2015

AccuRev Plug-In supports all versions of these Visual Studio products except the Express version.
AccuRev Plug-In implements the SCC provider interfaces that are part of the Visual Studio Package
Technology (VSPT) instead of using the Microsoft Common Source Code Control Interface (MCSCCI). This
enables the integration to provide better access to AccuRev’s unique software configuration management
features.

Contacting Technical Support
AccuRev offers a variety of options to meet your technical support needs as summarized in the following
table.
For

Visit

Information about technical support services

http://supportline.microfocus.com/

Information about platforms support

http://supportline.microfocus.com/prodavail.aspx

Product downloads and installations

http://supportline.microfocus.com/websync/

Product documentation

http://supportline.microfocus.com/productdoc.aspx

SupportLine phone numbers, listed by country

http://www.microfocus.com/about/contact/support/

When you contact technical support, please include the following information:
•
•
•
•
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The version of AccuRev and any other AccuRev products you are using (AccuSync or GitCentric, for
example)
Your operating system
The version of relevant third-party software (if you are using AccuSync, for example the version of your
ITS)
A brief description of the problem you are experiencing. Be sure to include which AccuRev interface you
were using (Web user interface, Java GUI, or CLI), any error messages you received, what you were
doing when the error occurred, whether the problem is reproducible, and so on
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•
•

A description of any attempts you have made to resolve the issue
A simple assessment of how the issue affects your organization

Highlights of this Release
AccuRev Plug-In Version 2016.1 includes the following enhancements:
•

Added support for Visual Studio 2015

Installation Notes
This section describes how to install and configure AccuRev Plug-In for Visual Studio® PE (AccuRev PlugIn). It provides information on system requirements and prerequisites, as well as information on repairing
an existing AccuRev Plug-In installation.

System Requirements
AccuRev Plug-In for Visual Studio PE is currently supported on these operating systems:
•
•
•

Microsoft Windows XP, Service Pack 2 (or higher)
Microsoft Windows Vista
Microsoft Windows 7, Windows 8, Windows 10
Note: AccuRev recommends that you install the appropriate operating system service packs before
installing AccuRev Plug-In.

Prerequisites
The following applications must be installed on your machine before you install AccuRev Plug-In:
•
•

AccuRev Version 5.6 or higher
One of the following Microsoft Visual Studio products:
•
•
•
•

Visual Studio 2010
Visual Studio 2012
Visual Studio 2013
Visual Studio 2015

Installing AccuRev Plug-In
Use this procedure if you are installing AccuRev Plug-In for the first time. If you are upgrading from an
existing installation of either AccuRev Plug-In or AccuBridge for Visual Studio, go to Upgrading to AccuRev
Plug-In topic.
Note: Administrator privileges are required to install AccuRev Plug-In for Visual Studio PE.
1. Go to the Micro Focus SupportLine page: http://supportline.microfocus.com/websync/
productupdatessearch.aspx.
2. Locate and download the ZIP file for this product.
3. Unpack the ZIP file to any location.
4. Execute the AccPkgVSInstaller.msi file. AccuRev Plug-In is installed in <AccuRevinstallation-dir>\bin\VSPackage by default.
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After you have successfully installed AccuRev Plug-In for Visual Studio PE, you must configure Visual
Studio to use it as the source control plug-in. Go to Configuring Visual Studio to Use AccuRev Plug-In
topic.

Upgrading AccuRev Plug-In
Use the following procedure to upgrade to the current version of AccuRev Plug-In from an existing
AccuRev Plug-In installation or from AccuBridge for Visual Studio.
Note: The steps for upgrading from AccuBridge vary based on whether or not your current
AccuBridge version is earlier than Version 2008.1.
Note: If you are currently using AccuBridge Version earlier than 2008.1, you must unbind preexisting
solutions. See Unbinding Preexisting Solutions, then return to this upgrade procedure.
1. Uninstall your existing AccuRev Plug-In or AccuBridge. See Uninstalling Existing AccuRev Plug-In and
AccuBridge Installations for more information.
2. Download and install the new AccuRev Plug-In. See Installing AccuRev Plug-In for more information.

Unbinding Preexisting Solutions
Note: You need to perform this procedure only if you are using a version of AccuBridge for Visual
Studio PE earlier than 2008.1.
AccuBridge for Visual Studio PE is implemented using package technology. AccuBridge versions prior to
version 2008.1 used add-in technology. Existing Visual Studio solutions that are managed by versions of
AccuBridge for Visual Studio PE that use add-in technology must be modified before they can be used with
the current AccuBridge for Visual Studio PE version. This process is called unbinding.
Use the following procedure to unbind any Visual Studio solution that is using a version of AccuBridge for
Visual Studio PE earlier than 2008.1:
1. Load the solution into Visual Studio.
2. Invoke the command File > Source Control > Change Source Control.
3. Unbind the solution and all projects that are displayed in the dialog.
4. Close the dialog.
5. Invoke the command Tools > Options > Source Control , and change the provider to AccuBridge for
Visual Studio PE.
6. Invoke the command File > AccuRev > Refresh.
After you have unbound preexisting solutions, you need to uninstall your current AccuBridge for Visual
Studio. Go to Uninstalling Existing AccuRev Plug-In and AccuBridge Installations.

Uninstalling Existing AccuRev Plug-In and AccuBridge
Installations
1. Close all instances of Visual Studio.
2. Uninstall the existing version of the AccuRev plug-in for Visual Studio PE:
•
•
•
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(Windows XP) From the Start menu, select Settings > Control Panel, and choose the Add or
Remove Programs applet.
(Windows Vista, and Windows 7) From the Start button, select Control Panel. Choose the
Programs and Features applet.
(Windows 8) Right-click in the bottom-left corner and choose the Control Panel from the pop-up
menu. Choose Uninstall a Program from the Programs category.
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•

(Windows 10) Type Control Panel in Search. Click Programs and Features.

3. Select AccuRev Plug-In for Visual Studio PE or AccuBridge for Visual Studio PE from the list of installed
programs as appropriate and click Uninstall.
After you have uninstalled your current AccuRev Plug-In or AccuBridge for Visual Studio PE, you are ready
to install the latestAccuRev Plug-In for Visual Studio PE. Go to Installing AccuRev Plug-In topic.

Configuring Visual Studio to Use AccuRev Plug-In
1. In Visual Studio, select Tools > Options to open the Options dialog.
2. Expand the Source Control entry in the navigation pane and choose Plug-in Selection.
3. In the content pane, open the Current source control plug-in drop-down list and select AccuRev
Plug-In for Visual Studio PE.
4. In the navigation pane, select AccuRev Options Page, select the Configuration tab in the content
pane and verify that the path to your accurev.exe file in the AccuRev Executable field is accurate.
The path to the accurev.exe file generally takes the following form: <accurev_install_dir>\bin
\accurev.exe.
5. Click OK to save your selections and close the dialog.
When you have successfully configured Visual Studio PE to use AccuRev, the following changes
become apparent in the Visual Studio PE interface:
•
•
•

The AccuRev - Searches window appears
The AccuRev toolbar appears
An AccuRev pane in the Output window is available

Repairing/Uninstalling AccuRev Plug-In
Re-executing the AccuRev Plug-In installer causes it to run in Repair or Remove mode. You can restart
the installer from its location on disk or by using the Add or Remove Programs control panel applet.

Release Notes
This section describes new features and issues fixed in the current version of AccuRev Plug-In for Visual
Studio PE. It also identifies known issues, if any.

Version 2016.1
32561 ( 1102978) -- Visual
Studio .net plug-in not appearing
after administrator installs the
plug-in

After the plugin was installed by user with administrator privileges
on a multi-user system with remote desktop logins, user from
remote desktop logged in to this machine and they had to run the
installer again to make it visible as a plug-in visual studio. This
issue has been resolved in the current release.

36935 ( 1098589) -- Visual Studio When using the right-click menu within the solution, many items
right click menu, items grayed out appear grey when they should be active. This doesn't appear when
opening from Explore. This issue has been resolved in the current
that should be active
release.
39441 (1102890) -- Visual Studio
integration installer fails to find
VS.Net

The Visual Studio integration installer is not finding VS.Net on the
system, even though it is installed on the system. Is appears that
the installer is looking for the wrong registry. This issue has been
resolved in the current release.
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The AccuRev Executable path available on the AccuRev option
39653 -- AccuRev Executable
path available on AccuRev option page by default (Tools > Option > Source Control) is not correct.
Page by default
This issue has been resolved in the current release.
Server IP addresses do not display in login dialog. The issue has
39662 -- Server details not
displaying when logging in for the been resolved in the current release.
first time
(1100817) -- Support for Visual
Studio 2015

With this release, AccuRev supports Visual Studio 2015.

Version 2014.3
28048 -- Unable to add files to
AccuRev that are in the Visual
Studio solution but not in the
project

In previous releases, if a file was in a Visual Studio solution but not in a
Visual Studio project that was under AccuRev source control, users
were unable to add the file to AccuRev source control. This problem
has been fixed in the current release.

32653 -- Performance
degrades when promoting by
issue

In previous releases, performance degraded when users attempted to
promote by issue if the number of issues returned by the AccuWork
query that populates the Select Issue (Change Package) dialog box
was large (for example, 20,000 or more). This problem has been fixed
in the current release.

33531 -- Performance
degrades when searching for
modified files in large
workspaces

In previous releases, the performance experienced by users who were
searching for modified files in a large workspace (> 1GB) was
degraded in the AccuRev Plug-In for Visual Studio PE. This problem
has been fixed in the current release.

34651 -- Restarting Visual
Studio required after
changing to a wired adapter

In previous releases, users who switched from a wireless internet
connection to a wired adapter had to restart Visual Studio. This
problem has been fixed in the current release.

Version 2014.2
The AccuRev Status, History, and Synchronize windows are
27625 -- New: AccuRev Window
options have been added to the Visual now available in the Visual Studio View > Other Windows
Studio View menu
menu options.
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27756 -- New: The ability to perform
diff operations from an element
history

When viewing the history of an element, users can select a
transaction and perform a diff operation against another
version or against the version currently in the workspace.

33136 -- Element link status in
AccuRev becomes corrupt when the
file is modified in Visual Studio

In previous releases, creating an element link (elink) to a file
and then editing that file in Visual Studio produced an elink
status of (backed)(elink)(corrupted) instead of (backed)(elink)
(modified-target). This problem has been fixed in the current
release.

33525 -- New: The ability to perform
keep and promote operations in the
Workspace Explorer

Users can perform AccuRev keep and promote operations
from the Outgoing view of the AccuRev Workspace Explorer.

33526 -- New: The ability to promote
non-overlapped files in the Stream
Explorer

Users can perform AccuRev promote operations from the
AccuRev Stream Explorer on files that do not have an Overlap
status.
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After installing AccuRev Plug-In for Visual Studio version
33569, 33587 -- Unable to log in to
AccuRev when using AccuRev Plug-In 2014.1, users could not successfully log in to AccuRev. This
problem has been fixed in the current release.
for Visual Studio version 2014.1

Version 2014.1
Users can launch Visual Studio from within the AccuRev GUI by double-clicking a
28297 -- New:
Visual Studio solution definition file (*.sln).
Open Visual
Studio by
double-clicking
the .sln file
32552 -- New:
Added support
for log4net
capabilities

Support for Apache log4net logging capabilities has been added in the current release.
To configure Apache log4net to log transactions between AccuRev and Visual Studio
PE:
1. Navigate to the <AccuRev-installation-dir>\bin directory.
2. Open the App.config file and specify the log file location in the file value
parameter, as shown in the following example:
<appender name="LogFileAppender"
type="log4net.Appender.RollingFileAppender">
<file value="C:\MyLog\AccuRevLog.log"/>
<appendToFile value="true"/>
<rollingStyle value="Size"/>
<maxSizeRollBackups value="5"/>
<maximumFileSize value="10MB"/>
<staticLogFileName value="true"/>
<layout type="log4net.Layout.PatternLayout">
<conversionPattern value="%d [%t] %-5p %c %m%n"/>
</layout>
</appender>
3. Import the following lines into a class:
using log4net.Config;
using log4net;

32555 -- New:
Open the file
view for the
current
workspace

A new option called AccuRev Workspace Explorer has been added to the View menu.
You can use the Workspace Explorer option to view the folders and files in the current
workspace in a tree view.

Version 2013.6
28544 -- New: the Query
Editor

A New Query icon has been added to the AccuRev tool bar. The New
Query icon opens the Query Editor. You can use the Query Editor to
construct and run queries of AccuWork issues.

28545 -- New: View files and
versions associated with
AccuWork issues

You can use the Query Editor to view files and versions associated with
specific AccuWork issues that are returned by AccuWork queries, and
you can also perform diff operations on these files.

28550 -- Shelve AccuWork
issues returned by queries

You can use the Query Editor to shelve AccuWork issues that are
returned by AccuWork queries. To shelve an issue means that changes
you have made to files that are associated with the issue are purged
from your workspace.
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28551 -- Editing AccuWork
issues returned by queries

You can use the Query Editor to edit AccuWork issues that are returned
by AccuWork queries.

31832, 32057 -- Support for
Visual Studio 2013

AccuRev Plug-In version 2013.6 supports Visual Studio 2013.

Version 2013.5
27947 -- New:
simplified process
for adding a new
project to a new
AccuRev
workspace

In previous releases, you could add new Visual Studio projects to AccuRev only if
the project’s physical location was in an existing AccuRev workspace. This is no
longer required, and you can create a new AccuRev workspace for new Visual
Studio projects as described in the following procedure:
1. In Visual Studio, click File > New > Project.
2. In the New Project dialog box:
•
•

Select the template you want to use to create the project.
In the Name field, enter the project name. (Visual Studio uses this value for
the Solution name, but you can change that if you want.)
• If the Solution field is displayed, leave its value as Create new solution.
• In the Location field, optionally change where you want to create the
AccuRev workspace for the new project.
• Make sure the Add Solution to AccuRev check box is selected.
3. Click OK. The New Workspace wizard appears.
You use the first page of the New Workspace wizard to specify the depot and
backing stream for the new workspace, as well as whether or not you want to
append the workspace name to its location.
4. Click Next to continue. The next page of the New Workspace wizard appears.
You use this page to specify the characteristics and initial content of the new
workspace. By default, it will contain all project files as well as all files from the
AccuRev stream you chose as the basis stream. If you want to choose specific
directories and files from the basis stream, choose the Pick and choose from
basis stream option.
5. Click Finish. The new workspace is created with characteristics and content
you specified.
27958 -- New: ability
to ignore
directories and files
in AccuRev

AccuRev allows you to exclude external files and directories from various
operations to enhance performance and reduce visual clutter. For example, if you
never put program-generated executables under AccuRev control, you can tell
AccuRev to ignore such files. In AccuRev Plug-In Release 2013.5, you can specify
the files and directories you want AccuRev to ignore directly from the Solution
Explorer.
Note: A directory or file must belong to the Visual Studio project before you
can ignore it in AccuRev.
To specify directories and/or files you want AccuRev to ignore:
1. In the Visual Studio, open the Solution Explorer.
2. Choose the directories and/or files you want AccuRev to ignore.
Tip: Use Ctrl+ click to select multiple objects.
3. Right-click and choose AccuRev > Ignore in AccuRev from the shortcut menu.
A .acignore file appears in the same directory as the file; if you selected a
directory, the .acignore file appears in the parent directory.
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28823 -- New:
improved usability
for AccuRev
Options Page

The AccuRev Options page (Tools > Options > Source Control > AccuRev
Options Page) has been reorganized to improve usability.
•
•

•
28869 -- New: File
View in the Depot
Explorer

The Web UI tab has been renamed Configuration to better reflect the broader
range of settings and information provided on the tab.
In addition to existing configuration settings for the Web UI, the Configuration
tab also includes a new field, AccuRev Executable, that lets you specify the
path of the AccuRev executable. You can enter the path manually, or use the
Browse... button to navigate to the executable’s location. If this field is left
blank, AccuRev Plug-In uses the value in your system PATH.
Version Details information has moved from the General Options tab to the
renamed Configuration tab.

AccuRev Plug-In Release 2013.3 introduced the Depot Explorer, a dockable
window that allows you to create and view a navigable list of depots. A new File
View has been added to the Depot Explorer for Release 2013.1 that displays the
files associated with a selected stream or workspace. To display the File View:
1. In the Depot Explorer, navigate to the stream or workspace whose files you
wish to view.
2. Right click the stream or workspace, and choose Open File View from the
shortcut menu.
The File View appears on a new tab in the Depot Explorer.

29472 -- New: ability
to add existing
solutions and
projects to AccuRev

You can now add an existing Visual Studio solution or project to AccuRev. Just
right-click the solution or project and choose AccuRev > Add to AccuRev . When
you do, AccuRev starts the New Workspace wizard, which lets you create a
workspace using the solution or project name and lets you specify the depot and
basis stream for the workspace.

30048 -- Refresh no
longer required to
see new
workspaces in
Depot Explorer

In the previous release, you needed to manually refresh the Depot Explorer in
order to see newly created workspaces. This problem has been corrected in the
current release, and the Depot Explorer now refreshes automatically.

Version 2013.4
28873 -- Depot
Explorer
enhancements

The Depot Explorer, introduced in Release 2013.3, has been enhanced to
support new functionality:
•
•
•

Creating streams and workspaces
Changing streams
Reparenting streams and workspaces

Note that depot explorer trees are not saved when you close Visual Studio.

Version 2013.3
28868 -- New: Depot
Explorer

The new Depot Explorer is a dockable window that allows you to create a
read-only navigable list of depots.
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Version 2013.2
27626 -- New method
for working with
solutions in AccuRev

The Open from AccuRev menu choice is a quick and simple way to create a
new AccuRev workspace on your system for a solution that is already known
to AccuRev. You might want to use this feature, for example, so you can
contribute to a solution being developed by a colleague who is developing the
solution in his or her own workspace. The Open from AccuRev command is
available from the File > AccuRev and File > New menus in Visual Studio.

27638 -- AccuRev PlugIn connects to AccuRev
Server only when
necessary

In previous releases, AccuRev Plug-In attempted to connect to the AccuRev
Server when starting Visual Studio with an active AccuRev Plug-In, even if
there were no solutions or projects open in Visual Studio. If your AccuRev
Server was not accessible, this would appear to cause Visual Studio to hang.
This problem has been corrected in the current release, and AccuRev Plug-In
attempts to connect to the AccuRev Server only when necessary.

29083 -- Login menu
choice removed after
login

In previous releases, the Login menu (AccuRev > Login, for example) would
remain displayed and enabled even after successfully logging in to the
AccuRev Server. This problem has been corrected in the current release, and
the AccuRev menu will now display Login or Logout as appropriate.

29144 -- New label
decorations for
AccuRev statuses

AccuRev Plug-In introduces new label decoration icons to represent AccuRev
statuses. The new icons are larger, easier to read, and easier to understand.

29306 -- Login menu
choice no longer
requires a solution to
be open

In previous releases, the Login menu (AccuRev > Login, for example) was
available only if a solution was already open in Visual Studio. As of this
release, you can log in to AccuRev regardless of whether or not a solution is
open in Visual Studio.

Version 2013.1
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27572 -- Defunct action
displayed on context
menus

The Defunct action is now displayed on the context menu that is displayed
when you right-click on elements in a workspace.

27573 -- Update and
Update Preview button
icons are different

In previous releases, users who customized the AccuRev toolbar in Visual
Studio discovered that the same icon was used for both Update and Update
Preview actions. This problem has been corrected in the current release.

27574 -- Output window
cleared with each new
AccuRev command

In previous releases, the Output window would collect all the AccuRev
commands that were executed during a session. Over time, the Output
window could become cluttered, making it difficult to locate relevant
information. This problem has been corrected in the current release, and
AccuRev Plug-In now clears the Output window each time a command is
executed.

27576 -- Support for
third-party issue keys

AccuRev Plug-in now supports the use of third-party issue tracking system
keys. If you have enabled change packages at your site, you can now specify
third-party issue keys instead of AccuWork issue numbers when promoting
changes, for example.

27623 -- AccuRev splash
screen removed from
setting source control
preference

In previous releases, the AccuRev splash screen appeared after you selected
AccuRev Plug-In on the Plug-In Selections page of the Visual Studio
Preferences dialog box. The AccuRev splash screen no longer appears, and
the option allowing you to hide the splash screen is no longer available.
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27639 -- Workspace
In previous AccuRev Plug-In releases, choosing AccuRev > Workspace
information displayed in Information from the context menu of a solution file displayed information in
new dialog box
the Output window, which was easy to overlook. Workspace information such
as the AccuRev Server host name and version, and depot and workspace
name is now displayed in the AccuRev Workspace Information dialog box.
27645 – AccuRev PlugIn promote sequence
matches that in
AccuRev GUI

In AccuRev Plug-In version 2013.1, if you have change packages
implemented at your site, AccuRev Plug-In now prompts you to first select an
issue to associate with the changes you are promoting and then enter an
optional comment. In previous releases, AccuRev Plug-In prompted you for
the comment before asking you to choose an issue to promote against.

27654 -- Support for
Visual Studio 2012

AccuRev Plug-In version 2013.1 supports Visual Studio 2012.

27796 -- AccuRev PlugIn version number
displayed in Visual
Studio Options

The version number of the currently installed AccuRev Plug-in is now
displayed on the General Options tab of the AccuRev Options Page in the
Visual Studio Options dialog box. To view the version number here, Tools >
Options > Source Control > AccuRev Options Page. The new Version
Details group box lists:
•
•
•

29923 -- Support
for .NET Framework 4.0

Version: The currently installed version
Date: The date this version was built
Transaction: The AccuRev transaction number associated with the
version’s build

AccuRev Plug-In can now be installed on the Windows machines running
Microsoft .NET Framework 4.0.

Known Issues for Visual Studio 2015
File and Folder Decorators for
AccuRev Aren't Available in Visual
Studio 2015

Visual Studio 2015 decorators have changed or have been
broken. After you install AccuRev plugin for Visual Studio, the
decorators won't be visible.

Known Issues for Visual Studio 2010
The following issues have been identified in AccuRev Plug-In for Visual Studio when used with Visual
Studio 2010.
•
•

No SCC glyphs are displayed for WebSite projects.
No animation is displayed in the lower left corner of the status bar when an AccuRev operation is
running.

Known Issues in AccuRev Plug-In for Visual Studio PE
The following issue has been identified in AccuRev Plug-In for Visual Studio PE.
31104 In AccuRev 6.0 and AccuRev 5.7, the executable for the AccuRev Diff tool, acdiffgui.exe, did not
list all of the jar files needed to run the AccuRev Diff tool from within AccuRev Plug-In for Visual
Studio PE. This prevented users with AccuRev 6.0 or AccuRev 5.7 from using the AccuRev Diff
and Merge tools from AccuRev Plug-In. This problem has been corrected in AccuRev 6.0.1. If you
recently upgraded to AccuRev 6.0, you should upgrade to AccuRev 6.0.1. If you are using either
AccuRev 6.0 or AccuRev 5.7 and do not plan to upgrade, contact AccuRev technical support.
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