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Preface
This book is your guide to installing AccuRev Plug-In for Visual Studio® PE. It is intended for AccuRev® 
and Visual Studio system administrators.

Note: Prior to Release 2013.1, AccuRev Plug-In for Visual Studio PE was called AccuBridge for Visual 
Studio PE.

What is AccuRev Plug-In for Visual Studio® PE?
AccuRev Plug-In for Visual Studio® PE (AccuRev Plug-In) is the integration between AccuRev and these 
Visual Studio products:

• Visual Studio 2010

• Visual Studio 2012 

• Visual Studio 2013

AccuRev Plug-In supports all versions of these Visual Studio products except the Express version.

AccuRev Plug-In implements the SCC provider interfaces that are part of the Visual Studio Package 
Technology (VSPT) instead of using the Microsoft Common Source Code Control Interface (MCSCCI). 
This enables the integration to provide better access to AccuRev’s unique software configuration 
management features.

Using This Book
This book assumes you are familiar with your operating system and its commands, as well as with 
AccuRev, AccuWork, and Visual Studio PE.

The remaining chapters in this book describe how to install AccuRev Plug-In and provide information 
about current and recent AccuRev Plug-In releases:

Typographical Conventions
This book uses the following typographical conventions:

Chapter Description

Chapter 1 Introduction Introduces the current release and describes its highlights.

Chapter 2 Installation Notes Describes how to install AccuRev Plug-In.

Chapter 3 Release Notes Provides information about enhancements, fixes, and known issues in 
current and recent AccuRev Plug-In releases.

Convention Description

blue sans-serif Used for sample code or output.

red monospace Used for examples.
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Contacting Technical Support
AccuRev offers a variety of options to meet your technical support needs. For complete information about 
AccuRev technical support services, visit our Web site:

http://www.accurev.com/customer-support-resources 

License Issues
If you are having trouble with a license for your AccuRev product, visit the License Self Help page first to 
see if there is a solution for your problem:

http://www.accurev.com/support/license-self-help.html

Other Support Issues
To obtain technical support for an AccuRev product:

• Go to http://accurev.force.com/customerportal 

• Or write AccuRev technical support at support@accurev.com

When you contact AccuRev technical support, please include the following information:

• The version of AccuRev and any other AccuRev products you are using (AccuSync or GitCentric, for 
example)

• Your operating system

• The version of relevant third-party software (if you are using AccuSync, for example the version of 
your ITS)

• A brief description of the problem you are experiencing. Be sure to include which AccuRev interface 
you were using (Web user interface, Java GUI, or CLI), any error messages you received, what you 
were doing when the error occurred, whether the problem is reproducible, and so on.

• A description of any attempts you have made to resolve the issue, including using the resources 
described in Other Resources.

• A simple assessment of how the issue affects your organization.

Other Resources
In addition to contacting AccuRev technical support, consider taking advantage of the following resources:

• AccuRev Known Problems and Solutions – http://www.accurev.com/support/kps.html

The AccuRev Known Problems and Solutions page describes known problems in released versions of 
AccuRev products.

bold Used for command names, and button names in the 
AccuSync Web user interface

light italic Used for emphasis, book titles, and for first use of important terms

blue italic Identifies a hyperlink (to a page or Web URL, for example)

Convention Description
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• AccuRev User Forum – http://www.accurev.com/ubbthreads/

The AccuRev User Forum is a valuable resource. In addition to access to AccuRev’s international user 
community, the User Forum is the place to go for resources like:

• The AccuRev knowledge base

• The AccuRev FAQ

Register as a User Forum member today.

• AccuRev documentation – http://www.accurev.com/documentation.html

This page provides access to AccuRev product documentation for all current and previous releases of 
most AccuRev products.
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1. Introduction
AccuRev Plug-In for Microsoft Visual Studio PE (AccuRev Plug-In) integrates AccuRev functionality 
with the Microsoft Visual Studio PE IDE (Integrated Development Environment). 

This chapter describes the highlights of the current release.

Note: Prior to Release 2013.1, AccuRev Plug-In for Visual Studio PE was called AccuBridge for Visual 
Studio PE.

Highlights of this Release
AccuRev Plug-In Version 2014.1 includes the following enhancements:

• New: Open the file view for the current workspace. Users can view the folders and files in the 
current workspace in a tree view by invoking the AccuRev Workspace Explorer from the View menu 
in Visual Studio. Additionally, users can filter their views of outgoing changes according to their 
AccuRev status.

• Added support for additional logging capabilities. Users can utilize Apache log4net 
capabilities when logging transactions between AccuRev and Visual Studio.

• Open Visual Studio by double-clicking the .sln file. Users can launch Visual Studio from 
within the AccuRev GUI by double-clicking a Visual Studio solution definition file.

• User documentation is unchanged. The AccuRev Plug-In for Visual Studio PE User’s Guide is 
unchanged for this release.

What to Do Next
To install AccuRev Plug-In, see Chapter 2 Installation Notes.

For details about the specific changes introduced in this release, see Chapter 3 Release Notes.
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2. Installation Notes
This chapter describes how to install and configure AccuRev Plug-In for Visual Studio® PE (AccuRev 
Plug-In). It provides information on system requirements and prerequisites, as well as information on 
repairing an existing AccuRev Plug-In installation.

Note: Prior to Release 2013.1, AccuRev Plug-In for Visual Studio PE was called AccuBridge for Visual 
Studio PE.

System Requirements
AccuRev Plug-In for Visual Studio PE is currently supported on these operating systems:

• Microsoft Windows XP, Service Pack 2 (or higher)

• Microsoft Windows Vista

• Microsoft Windows 7, Windows 8

Note: AccuRev recommends that you install the appropriate operating system service packs before 
installing AccuRev Plug-In.

Prerequisites
The following applications must be installed on your machine before you install AccuRev Plug-In:

• AccuRev Version 5.6 or higher

• One of the following Microsoft Visual Studio products:

• Visual Studio 2010

• Visual Studio 2012

• Visual Studio 2013
AccuRev Plug-In for Visual Studio® PE Installation and Release Notes 3



Installing AccuRev Plug-In
Use this procedure if you are installing AccuRev Plug-In for the first time. If you are upgrading from an 
existing installation of either AccuRev Plug-In or AccuBridge for Visual Studio, go to Upgrading to 
AccuRev Plug-In Version 2014.1 on page 4.

Note: Administrator privileges are required to install AccuRev Plug-In for Visual Studio® PE.

To install AccuRev Plug-In:

1. Go to the AccuRev Integrations downloads page on the AccuRev web site:

http://www.accurev.com/customer-support-resources/downloads/integration-packages

2. Locate and download the ZIP file for this product in the table titled AccuRev IDE Plug-Ins.

3. Unpack the ZIP file to any location.

4. Execute the AccPkgVSInstaller.msi file.

AccuRev Plug-In is installed in <AccuRev-installation-dir>\bin\VSPackage by default, but the installer 
lets you select a different pathname.

What to Do Next 
After you have successfully installed AccuRev Plug-In for Visual Studio PE, you must configure Visual 
Studio to use it as the source control plug-in. Go to Configuring Visual Studio® to Use AccuRev Plug-In on 
page 6.

Upgrading to AccuRev Plug-In Version 2014.1
Use the following procedure to upgrade to AccuRev Plug-In Version 2014.1 from:

• An existing AccuRev Plug-In installation

• AccuBridge for Visual Studio

Note that the steps for upgrading from AccuBridge vary based on whether or not your current AccuBridge 
version is earlier than Version 2008.1.

1. Are you upgrading from an existing AccuRev Plug-In installation?

• Yes. Go to Step 3

• No, I am currently using AccuBridge. Go to Step 2.

2. If you are currently using AccuBridge Version earlier than 2008.1, you must unbind preexisting 
solutions. See Unbinding Preexisting Solutions on page 5. Otherwise, go to Step 3.

3. Uninstall your existing AccuRev Plug-In or AccuBridge.

See Uninstalling Existing AccuRev Plug-In and AccuBridge Installations on page 5 for more 
information.

4. Download and install the new AccuRev Plug-In.

See Installing AccuRev Plug-In on page 4 for more information.
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Unbinding Preexisting Solutions
Note: You need to perform this procedure only if you are using a version of AccuBridge for Visual Studio 
PE earlier than 2008.1.

AccuBridge for Visual Studio PE is implemented using package technology. AccuBridge versions prior to 
version 2008.1 used add-in technology. Existing Visual Studio solutions that are managed by versions of 
AccuBridge for Visual Studio PE that use add-in technology must be modified before they can be used 
with the current AccuBridge for Visual Studio PE version. This process is called unbinding. 

Use the following procedure to unbind any Visual Studio solution that is using a version of AccuBridge for 
Visual Studio PE earlier than 2008.1:

1. Load the solution into Visual Studio.

2. Invoke the command File > Source Control > Change Source Control.

3. Unbind the solution and all projects that are displayed in the dialog. Then close the dialog.

4. Invoke the command Tools > Options > Source Control, and change the provider to AccuBridge for 
Visual Studio PE.

5. Invoke the command File > AccuRev > Refresh.

What to Do Next 
Once you have unbound preexisting solutions, you need to uninstall your current AccuBridge for Visual 
Studio. Go to Uninstalling Existing AccuRev Plug-In and AccuBridge Installations on page 5.

Uninstalling Existing AccuRev Plug-In and AccuBridge Installations
To uninstall existing versions of AccuRev Plug-In or AccuBridge for Visual Studio:

1. Shut down all instances of Visual Studio.

2. Uninstall the existing version of the AccuRev Add-in for Visual Studio PE:

• (Windows XP) From the Start menu, select Settings > Control Panel, and choose the Add or 
Remove Programs applet.

• (Windows Vista and Windows 7) From the Start button, select Control Panel. Choose the 
Programs and Features applet.

3. Select AccuRev Plug-In for Visual Studio PE or AccuBridge for Visual Studio PE from the list of 
installed programs as appropriate and choose Uninstall. 

What to Do Next 
Once you have uninstalled your current AccuRev Plug-In or AccuBridge for Visual Studio PE, you are 
ready to install AccuRev Plug-In for Visual Studio® PE 2014.1. Go to Installing AccuRev Plug-In on 
page 4.
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Configuring Visual Studio® to Use AccuRev Plug-In
To configure Visual Studio to use AccuRev Plug-In:

1. In Visual Studio, select Tools > Options to open the Options dialog.

2. Expand the Source Control entry in the navigation pane and choose Plug-in Selection, as shown 
above.

3. In the content pane, open the Current source control plug-in drop-down list.

4. Select AccuRev Plug-In for Visual Studio PE, then click OK to save your selection and close the 
dialog.

When you have successfully configured Visual Studio PE to use AccuRev, the following changes become 
apparent in the Visual Studio PE interface:

• The AccuRev - Searches window appears

• The AccuRev toolbar appears

• An AccuRev pane in the Output window is available

Repairing/Uninstalling AccuRev Plug-In
Re executing the AccuRev Plug-In installer causes it to run in Repair or Remove mode. You can restart 
the installer from its location on disk or by using the Add or Remove Programs control panel applet.
6 AccuRev Plug-In for Visual Studio® PE Installation and Release Notes



3. Release Notes
This chapter describes new features and issues fixed in the current version of AccuRev Plug-In for Visual 
Studio PE. It also identifies known issues, if any.

Note: Prior to Release 2013.1, AccuRev Plug-In for Visual Studio PE was called AccuBridge for Visual 
Studio PE.

Version 2014.1
28297 -- New: Open Visual Studio by double-clicking the .sln file

Users can launch Visual Studio from within the AccuRev GUI by double-clicking a Visual Studio 
solution definition file (*.sln).

32552 -- New: Added support for log4net capabilities
Support for Apache log4net logging capabilities has been added in the current release. 
To configure Apache log4net to log transactions between AccuRev and Visual Studio PE:
1. Navigate to the <AccuRev-installation-dir>\bin directory.

2. Open the App.config file and specify the log file location in the file value parameter, as shown in 
the following example:
<appender name="LogFileAppender" type="log4net.Appender.RollingFileAppender">

      <file value="C:\MyLog\AccuRevLog.log"/>

      <appendToFile value="true"/>

      <rollingStyle value="Size"/>

      <maxSizeRollBackups value="5"/>

      <maximumFileSize value="10MB"/>

      <staticLogFileName value="true"/>

      <layout type="log4net.Layout.PatternLayout">

        <conversionPattern value="%d [%t] %-5p %c %m%n"/>

      </layout>

 </appender>

3. Import the following lines into a class:
using log4net.Config;

using log4net;
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32555 -- New: Open the file view for the current workspace
A new option called AccuRev Workspace Explorer has been added to the View menu. 

The AccuRev Workspace Explorer opens with the Workspace Explorer option selected:

You can use the Workspace Explorer option to view the folders and files in the current workspace in 
a tree view.
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If you want to view the elements that have changed in the workspace, you can select the Outgoing 
mode to display only those files and directories that have been added to, changed in, or removed from 
the current workspace. 
When you select the Outgoing option, the AccuRev Workspace Explorer expands to display another 
panel on the right that contains the Member, Overlap, Missing, Modified, and External buttons. 

When you select one of these buttons, the AccuRev Workspace Explorer displays the elements with 
that AccuRev status in the current workspace. The following example shows the files in the workspace 
with a Member status:

Version 2013.6
28544 -- New: Create a query of AccuWork issues

A New Query icon has been added to the AccuRev tool bar. The New Query icon opens the Query 
Editor. You can use the Query Editor to construct and run queries of AccuWork issues. 
To create a query of AccuWork issues:

1. When logged into AccuRev, select the New Query icon  in the AccuRev tool bar.
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The Query Editor dialog box appears:

2. Select the Field field and select a setting from the drop-down menu.

3. Select the Value field and select a setting from the drop-down menu.

Notes: 

• The implied condition for the relationship between the Field and Value settings in the Query 
Editor is an equivalency (=). 

• You can have multiple rows of criteria. The implied join between the rows of criteria is an 
AND condition.

4. After you have specified the criteria for your query, select Run Query.
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The query results appear in the bottom portion of the Query Editor dialog box. In the following 
example, the Field is State and the Value is Open:

5. If you want to remove the current criteria at any time, select Clear Query.

28545 -- New: View files and versions associated with AccuWork issues
You can view files and versions associated with specific AccuWork issues that are returned by 
AccuWork queries, and you can also perform diff operations on these files.
To view files and versions associated with AccuWork issues:

1. When logged into AccuRev, select the New Query button  in the AccuRev tool bar.

2. In the Query Editor dialog box, select the Field field and select a setting from the drop-down 
menu.

3. Select the Value field and select a setting from the drop-down menu.

4. Select Run Query.

5. In the query results in the bottom portion of the Query Editor dialog box, right-click the issue you 
want to view the associated files for and select View File Versions from the context menu.
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The files associated with the currently selected issue appear on the Changes tab of the 
<issue_number> dialog box:

You can perform a diff operation on a file by right-clicking on it and selecting Diff Against Basis.

28550 -- Shelve AccuWork issues returned by queries
You can shelve AccuWork issues that are returned by AccuWork queries. 
In some cases, you may want to stop working on a project for the time being and to remove elements 
related to that issue from your workspace. This process is known as shelving an issue. To shelve an 
issue means that changes you have made to files that are associated with the issue are purged from 
your workspace. For example, suppose that you are working on issue 1 and you change file1.xml and 
file3.java and you then perform a keep operation on the files and add them to the issue. If you then 
shelve the issue, the AccuRev Plug-In for Visual Studio PE purges those files from your workspace. 
The files are still associated with the issue, but they are no longer in your workspace.
To shelve an AccuWork issue returned by a query:

1. When logged into AccuRev, select the New Query button  in the AccuRev tool bar.

2. In the Query Editor dialog box, select the Field field and select a setting from the drop-down 
menu.

3. Select the Value field and select a setting from the drop-down menu.

4. Select Run Query.

5. In the query results in the bottom portion of the Query Editor dialog box, right-click the issue you 
want to shelve and select Shelve from the context menu.

28551 -- Editing AccuWork issues returned by queries
You can edit AccuWork issues that are returned by AccuWork queries.
To edit an AccuWork issue returned by a query:

1. When logged into AccuRev, select the New Query button  in the AccuRev tool bar.

2. In the Query Editor dialog box, select the Field field and select a setting from the drop-down 
menu.
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3. Select the Value field and select a setting from the drop-down menu.

4. Select Run Query.

5. In the query results in the bottom portion of the Query Editor dialog box, double-click the issue 
you want to edit.

6. Select Edit to make the issue fields active. 

You can now make changes to the issue fields.
31832, 32057 -- Support for Visual Studio 2013

AccuRev Plug-In version 2013.6 supports Visual Studio 2013.

Version 2013.5
27947 -- New: simplified process for adding a new project to a new AccuRev workspace 

In previous releases, you could add new Visual Studio projects to AccuRev only if the project’s 
physical location was an existing AccuRev workspace. This is no longer required, and you can create a 
new AccuRev workspace for new Visual Studio projects as described in the following procedure.
1. In Visual Studio, click File > New > Project. 

2. In the New Project dialog box:

• Select the template you want to use to create the project.

• In the Name field, enter the project name. (Visual Studio uses this value for the Solution 
name, but you can change that if you want.)

• If the Solution field is displayed, leave its value as Create new solution.

• In the Location field, optionally change where you want to create the AccuRev workspace for 
the new project.

• Make sure the Add Solution to AccuRev check box is selected.

3. Click OK.
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The New Workspace wizard appears.

You use the first page of the New Workspace wizard to specify the depot and backing stream for 
the new workspace, as well as whether or not you want to append the workspace name to its 
location.

4. Click Next to continue.
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The next page of the New Workspace wizard appears. 

You use this page to specify the characteristics and initial content of the new workspace. By 
default, it will contain all project files as well as all files from the AccuRev stream you chose as 
the basis stream. If you want to choose specific directories and files from the basis stream, choose 
the Pick and choose from basis stream option.

5. Click Finish.

The new workspace is created with characteristics and content you specified.
27958 -- New: ability to ignore directories and files in AccuRev

AccuRev allows you to exclude external files and directories from various operations to enhance 
performance and reduce visual clutter. For example, if you never put program-generated executables 
under AccuRev control, you can tell AccuRev to ignore such files. In AccuRev Plug-In Release 
2013.5, you can specify the files and directories you want AccuRev to ignore directly from the 
Solution Explorer.
Note: A directory or file must belong to the Visual Studio project before you can ignore it in AccuRev.
To specify directories and/or files you want AccuRev to ignore:
1. In the Visual Studio, open the Solution Explorer.

2. Choose the directories and/or files you want AccuRev to ignore.

Tip: Use Ctrl+ click to select multiple objects.
3. Right-click and choose AccuRev > Ignore in AccuRev from the shortcut menu.

A .acignore file appears in the same directory as the file; if you selected a directory, the .acignore 
file appears in the parent directory.
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28823 -- New: improved usability for AccuRev Options Page
The AccuRev Options page (Tools > Options > Source Control > AccuRev Options Page) has been 
reorganized to improve usability.
• The Web UI tab has been renamed Configuration to better reflect the broader range of settings 

and information provided on the tab.

• In addition to existing configuration settings for the Web UI, the Configuration tab also includes a 
new field, AccuRev Executable, that lets you specify the path of the AccuRev executable. You 
can enter the path manually, or use the Browse... button to navigate to the executable’s location. If 
this field is left blank, AccuRev Plug-In uses the value in your system PATH.

• Version Details information has moved from the General Options tab to the renamed 
Configuration tab.

28869 -- New: File View in the Depot Explorer
AccuRev Plug-In Release 2013.3 introduced the Depot Explorer, a dockable window that allows you 
to create and view a navigable list of depots. A new File View has been added to the Depot Explorer 
for Release 2013.1 that displays the files associated with a selected stream or workspace. An example 
of the File View for the velo_dfoster workspace is shown here:

To display the File View:

1. In the Depot Explorer, navigate to the stream or workspace whose files you wish to view.

2. Right click the stream or workspace, and choose Open File View from the shortcut menu.

The File View appears on a new tab in the Depot Explorer.
16 AccuRev Plug-In for Visual Studio® PE Installation and Release Notes



29472 -- New: ability to add existing solutions and projects to AccuRev
You can now add an existing Visual Studio solution or project to AccuRev. Just right-click the solution 
or project and choose AccuRev > Add to AccuRev. When you do, AccuRev starts the New 
Workspace wizard, which lets you create a workspace using the solution or project name and lets you 
specify the depot and basis stream for the workspace. For details on using the New Workspace wizard, 
see the description for 27947 -- New: simplified process for adding a new project to a new AccuRev 
workspace on page 12.

30048 -- Refresh no longer required to see new workspaces in Depot Explorer
In the previous release, you needed to manually refresh the Depot Explorer in order to see newly 
created workspaces. This problem has been corrected in the current release, and the Depot Explorer 
now refreshes automatically.

Version 2013.4
28873 -- Depot Explorer enhancements

The Depot Explorer, introduced in Release 2013.3, has been enhanced to support new functionality:
• Creating streams and workspaces

• Changing streams 

• Reparenting streams and workspaces

Note that depot explorer trees are not saved when you close Visual Studio.

Creating Streams
Use this procedure to create a new dynamic stream, snapshot stream, or pass-through stream.
1. Select the depot or stream off which you want to create the new stream.

2. Right-click and choose New Stream from the context menu.

Tip: If you want to create a snapshot stream, choose New Snapshot.
3. In the Name field of the dialog box that appears, enter a name for the new stream.

4. In the Stream Type field, choose the type of stream you want to create.

5. In the Basis Time field, specify the watermark you want to use when creating this stream.

Note: You cannot specify a basis time for pass-through streams.
6. Click Ok.

Creating Workspaces
Use this procedure to create a new workspace.
1. Select the stream off which you want to create the new workspace.

2. Right-click and choose New Workspace from the context menu.

3. Follow instructions in the New Workspace to create the new workspace. 

4. Click Finish to create the new workspace using default settings for locking, workspace contents, 
and end-of-line characters.
AccuRev Plug-In for Visual Studio® PE Installation and Release Notes 17



Tip: The Next button is active only if you customize the new workspace by changing one of the 
default settings.

5. Right-click and choose Refresh from the context menu to view the new workspace.

Changing Streams
Use this procedure to change a stream’s name, its basis stream, or (for dynamic and time basis streams 
only) its basis time. This procedure cannot be used with snapshot streams.
Tip: Changing the basis stream has the same effect as reparenting.
1. Select the stream you want to change.

2. Right-click the stream and choose Change Stream from the context menu.

3. Optionally change one or more of the following:

• Name

• Basis stream

• Basis time (dynamic and time basis streams only)

4. Click Ok to complete the change.

Reparenting Streams and Workspaces
You can reparent a dynamic, pass-through, or time-basis stream or workspace using drag-and-drop or 
the context menu.
To reparent a stream using drag-and-drop:
1. Press and hold mouse button 1 on the stream or workspace you want to reparent.

2. Drag the mouse and place the pointer over the stream you want to use as the new backing stream.

3. Release mouse button 1.

To reparent a stream or workspace using the context menu:
1. Select the or workspace you want to reparent.

2. Right-click the stream and choose Reparent from the context menu.

The pointer changes shape.
3. Click the stream you want to use as the stream’s or workspace’s new backing stream.

4. Click Ok to dismiss the informational message and complete the reparenting operation.
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Version 2013.3
28868 -- New: Depot Explorer

The new Depot Explorer is a dockable window that allows you to create a read-only navigable list of 
depots, as shown in the following illustration:

To create a navigable tree of the streams and workspaces in an AccuRev depot:
1. Open a solution that is known to AccuRev. 

Tip: This solution can be on any AccuRev Server, not necessarily the one for which you want to 
create the depot explorer.

2. Choose View > AccuRev Depot Explorer from the Visual Studio menu. 

An empty Depot Explorer window appears.
3. Click the plus symbol at the top of the tab.

The Login to AccuRev Server dialog box appears.
4. Log in to the AccuRev Server for which you want to create the depot explorer tree and click Ok.

Tip: This login is used solely to create the depot explorer tree; it does not interfere or change the 
AccuRev Server you are currently logged in to through Visual Studio. For example, you can 
currently be logged in to the AccuRev Server at falcon:5050 and create a depot explorer tree for 
the AccuRev Server at kestrel:5050.
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A Depots symbol appears in the Depot Explorer window.
5. Expand the nodes you wish to explore by clicking that node’s plus symbol.

To close a depot explorer tree, right-click the tab and choose Close.

To refresh the depot explorer tree, right-click the depot or stream and choose Refresh.

In AccuRev Plug-In Version 2013.3, depot explorer trees are not saved when you close Visual Studio.

Version 2013.2
27626 -- New method for working with solutions in AccuRev

The Open from AccuRev menu choice is a quick and simple way to create a new AccuRev workspace 
on your system for a solution that is already known to AccuRev. You might want to use this feature, for 
example, so you can contribute to a solution being developed by a colleague who is developing the 
solution in his or her own workspace. The Open from AccuRev command is available from the File > 
AccuRev and File > New menus in Visual Studio.

27638 -- AccuRev Plug-In connects to AccuRev Server only when necessary
In previous releases, AccuRev Plug-In attempted to connect to the AccuRev Server when starting 
Visual Studio with an active AccuRev Plug-In, even if there were no solutions or projects open in 
Visual Studio. If your AccuRev Server was not accessible, this would appear to cause Visual Studio to 
hang. This problem has been corrected in the current release, and AccuRev Plug-In attempts to connect 
to the AccuRev Server only when necessary.

29083 -- Login menu choice removed after login
In previous releases, the Login menu (AccuRev > Login, for example) would remain displayed and 
enabled even after successfully logging in to the AccuRev Server. This problem has been corrected in 
the current release, and the AccuRev menu will now display Login or Logout as appropriate.

29144 -- New label decorations for AccuRev statuses
AccuRev Plug-In introduces new label decoration icons to represent AccuRev statuses. The new icons 
are larger, easier to read, and easier to understand. Changes to the status icons are summarized in the 
following table:

Status Previous Releases Version 2013.2

Modified

Backed

Member

Overlap
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29306 -- Login menu choice no longer requires a solution to be open
In previous releases, the Login menu (AccuRev > Login, for example) was available only if a solution 
was already open in Visual Studio. As of this release, you can log in to AccuRev regardless of whether 
or not a solution is open in Visual Studio.

Version 2013.1
27572 -- Defunct action displayed on context menus

The Defunct action is now displayed on the context menu that is displayed when you right-click on 
elements in a workspace.

27573 -- Update and Update Preview button icons are different
In previous releases, users who customized the AccuRev toolbar in Visual Studio discovered that the 
same icon was used for both Update and Update Preview actions. This problem has been corrected in 
the current release.

27574 -- Output window cleared with each new AccuRev command
In previous releases, the Output window would collect all the AccuRev commands that were executed 
during a session. Over time, the Output window could become cluttered, making it difficult to locate 
relevant information. This problem has been corrected in the current release, and AccuRev Plug-In 
now clears the Output window each time a command is executed.

27576 -- Support for third-party issue keys
AccuRev Plug-in now supports the use of third-party issue tracking system keys. If you have enabled 
change packages at your site, you can now specify third-party issue keys instead of AccuWork issue 
numbers when promoting changes, for example.

27623 -- AccuRev splash screen removed from setting source control preference
In previous releases, the AccuRev splash screen appeared after you selected AccuRev Plug-In on the 
Plug-In Selections page of the Visual Studio Preferences dialog box. The AccuRev splash screen no 
longer appears, and the option allowing you to hide the splash screen is no longer available.

27639 -- Workspace information displayed in new dialog box
In previous AccuRev Plug-In releases, choosing AccuRev > Workspace Information from the 
context menu of a solution file displayed information in the Output window, which was easy to 
overlook. Workspace information such as the AccuRev Server host name and version, and depot and 
workspace name is now displayed in the AccuRev Workspace Information dialog box.

27645 – AccuRev Plug-In promote sequence matches that in AccuRev GUI
In AccuRev Plug-In version 2013.1, if you have change packages implemented at your site, AccuRev 
Plug-In now prompts you to first select an issue to associate with the changes you are promoting and 
then enter an optional comment. In previous releases, AccuRev Plug-In prompted you for the comment 
before asking you to choose an issue to promote against.

27654 -- Support for Visual Studio 2012
AccuRev Plug-In version 2013.1 supports Visual Studio 2012.
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27796 -- AccuRev Plug-In version number displayed in Visual Studio Options
The version number of the currently installed AccuRev Plug-in is now displayed on the General 
Options tab of the AccuRev Options Page in the Visual Studio Options dialog box. To view the version 
number here, Tools > Options > Source Control > AccuRev Options Page. The new Version Details 
group box lists:
• Version: The currently installed version

• Date: The date this version was built

• Transaction: The AccuRev transaction number associated with the version’s build

29923 -- Support for .NET Framework 4.0
AccuRev Plug-In can now be installed on the Windows machines running Microsoft .NET Framework 
4.0.

Known Issues for Visual Studio 2010
The following issues have been identified in AccuRev Plug-In for Visual Studio when used with Visual 
Studio 2010. 

• No SCC glyphs are displayed for WebSite projects.

• No animation is displayed in the lower left corner of the status bar when an AccuRev operation is 
running.

Known Issues in AccuRev Plug-In for 
Visual Studio PE
The following issue has been identified in AccuRev Plug-In for Visual Studio PE.

31104
In AccuRev 6.0 and AccuRev 5.7, the executable for the AccuRev Diff tool, acdiffgui.exe, did not list 
all of the jar files needed to run the AccuRev Diff tool from within AccuRev Plug-In for Visual Studio 
PE. This prevented users with AccuRev 6.0 or AccuRev 5.7 from using the AccuRev Diff and Merge 
tools from AccuRev Plug-In. 
This problem has been corrected in AccuRev 6.0.1. If you recently upgraded to AccuRev 6.0, you 
should upgrade to AccuRev 6.0.1. If you are using either AccuRev 6.0 or AccuRev 5.7 and do not plan 
to upgrade, contact AccuRev technical support at http://accurev.force.com/customerportal/.
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