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Preface

This book is your guide to using AccuRev® Plug-In for Visual Studio® PE. It is intended for 
AccuRev® and Visual Studio users.

Note: Prior to Release 2013.1, AccuRev Plug-In for Visual Studio PE was called AccuBridge for 
Visual Studio PE.

What is AccuRev Plug-In for Visual Studio® PE?

AccuRev® Plug-In for Visual Studio® PE (AccuRev Plug-In) is the integration between AccuRev and 
these Visual Studio products:

• Visual Studio 2010 

• Visual Studio 2012

AccuRev Plug-In supports all versions of these Visual Studio products except the Express version.

AccuRev Plug-In implements the SCC provider interfaces that are part of the Visual Studio Package 
Technology (VSPT) instead of using the Microsoft Common Source Code Control Interface 
(MCSCCI). This enables the integration to provide better access to AccuRev’s unique software 
configuration management features.

Using This Book

This book assumes you are familiar with your operating system and its commands, as well as with 
AccuRev, AccuWork, and Visual Studio PE. 

The remaining chapters in this book describe how to get started using AccuRev Plug-In and provide 
overview material on AccuRev concepts, commands, and the AccuRev Plug-In interface:

Chapter Description

Chapter 1 Introduction Provides an introduction to AccuRev Plug-In for Visual Studio PE.

Chapter 2 Getting Started Describes how to get up and running with AccuRev Plug-In for 
Visual Studio PE.

Chapter 3 AccuRev-Specific Windows Describes AccuRev Plug-In for Visual Studio PE’s use of windows 
within the Visual Studio interface.

Chapter 4 AccuRev Command 
Reference

Provides a reference to AccuRev commands and where to find 
them.

Appendix A The AccuRev Usage 
Model

Provides a quick overview of AccuRev SCM concepts and terms.
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Typographical Conventions

This book uses the following typographical conventions:

Contacting Technical Support

AccuRev offers a variety of options to meet your technical support needs. For complete information 
about AccuRev technical support services, visit our Web site:

http://www.accurev.com/support.html

License Issues

If you are having trouble with a license for your AccuRev product, visit the License Self Help page 
first to see if there is a solution for your problem:

http://www.accurev.com/support/license-self-help.html

Other Support Issues

To obtain technical support for an AccuRev product:

• Go to http://support.accurev.com/

• Or write AccuRev technical support at support@accurev.com

When you contact AccuRev technical support, please include the following information:

• The AccuRev version 

• The operating system

• If you are using an AccuBridge™ or AccuSync product:

• The AccuBridge version

• The version of the third-party system (JIRA or Rally, for example)

• A brief description of the problem you are experiencing. Be sure to include which AccuRev 
interface you were using (Web user interface, Java GUI, or CLI), any error messages you received, 
what you were doing when the error occurred, whether the problem is reproducible, and so on.

• A description of any attempts you have made to resolve the issue, including using the resources 
described in Other Resources.

• A simple assessment of how the issue affects your organization.

Convention Description

blue sans-serif Used for sample code or output.

red monospace Used for examples.

bold Used for command names, and button names in the 
AccuSync Web user interface

light italic Used for emphasis, book titles, and for first use of important terms

blue italic Identifies a hyperlink (to a page or Web URL, for example)
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Other Resources

In addition to contacting AccuRev technical support, consider taking advantage of the following 
resources:

• AccuRev Known Problems and Solutions – http://www.accurev.com/support/kps.html

The AccuRev Known Problems and Solutions page describes known problems in released 
versions of AccuRev products.

• AccuRev User Forum – http://www.accurev.com/ubbthreads/

The AccuRev User Forum is a valuable resource. In addition to access to AccuRev’s international 
user community, the User Forum is the place to go for resources like:

• The AccuRev knowledge base

• The AccuRev FAQ

Register as a User Forum member today.

• AccuRev documentation – http://www.accurev.com/documentation.html

This page provides access to AccuRev product documentation for all current and previous 
releases of most AccuRev products.
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1. Introduction

AccuRev Plug-In for Visual Studio PE is a package that integrates AccuRev’s source control 
management capabilities with Visual Studio 2010 and 2012. It enables you to execute AccuRev 
commands from within Visual Studio.

This document describes how to use AccuRev Plug-In for Visual Studio PE. For system requirements, 
installation/upgrading instructions, and release notes, please see the Installation and Release Notes 
document.

For a short introduction to AccuRev source control concepts, see The AccuRev Usage Model on 
page 31. For news on this product, visit the integrations download page on the AccuRev, Inc. Web 
site: http://www.accurev.com.

Changes to the Visual Studio Interface

AccuRev Plug-In for Visual Studio PE extends Visual Studio’s user interface in several ways:

• an AccuRev toolbar

• an AccuRev submenu on the Visual Studio main menu (also available under File > AccuRev)

• an AccuRev submenu on Solution Explorer context menus

• an AccuRev submenu on the Visual Studio editor context menu (when editing source and text 
files)

• AccuRev status indicators and tooltips available in the Solution Explorer

• an AccuRev window, containing History, Searches, and Synchronize tabs 

• an AccuRev pane in Visual Studio’s Output window

AccuRev Toolbar

AccuRev Plug-In for Visual Studio PE provides an AccuRev toolbar, which you can display with the 
View > Toolbars > AccuRev command.

Commands that are not applicable to the currently selected item(s) in the Solution Explorer are 
disabled. The Toolbar Options control (down-arrow) at the end of the toolbar lets you add or remove 
buttons. 
AccuRev® Plug-In for Visual Studio® PE User’s Guide 1



The AccuRev toolbar includes buttons for these AccuRev commands:

AccuRev Menu

AccuRev Plug-In for Visual Studio PE adds an AccuRev submenu 
to Visual Studio’s main menu. This submenu is also accessible 
through File > AccuRev. The menu contains “global” AccuRev 
commands, which are not specific to any file selection.

The AccuRev submenu contains these commands:

Update
Update Preview
Update with Merges
Login
Create Workspace
Synchronize Time
Workspace Information
Refresh
Open in Web
View Streams
Create Issue
View Issue Queries
Cancel

If some commands on this menu are disabled, either you need to log in to the AccuRev Server, or 
your solution is not in an AccuRev workspace. If Login fails, check your connection to the AccuRev 
Server process.

Add to Depot
Keep
Anchor
Promote
Merge
History
Annotate
Web UI Version Browser
Populate
Workspace Information

View Streams
Create Issue
View Issue Queries
Revert to Most Recent Version
Revert to Backed Version
Diff Against Most Recent Version
Diff Against Backed Version
Diff Against Basis Version
Diff Against File on Disk
2 AccuRev® Plug-In for Visual Studio® PE User’s Guide



AccuRev Status Indicators

When you are working on a project 
located in an AccuRev workspace that 
belongs to you, AccuRev Plug-In for 
Visual Studio PE adds a decoration to 
each item’s icon in the Solution Explorer, 
according to its AccuRev status. An 
AccuRev element can have several status 
indicators; if you hold the cursor over an 
item’s icon, the complete set of AccuRev 
status indicators appears in a tooltip.

If your project is not within an AccuRev 
workspace that belongs to you, no icon 
decorations appear, and the tooltip Not in 
a workspace appears when you hold the 
mouse over an item’s icon.

This table shows the icon decoration scheme:

Directory (folder) items do not have icon decorations. Project and solution items do have icon 
decorations, indicating the status of the project file and the solution file.

Status Icon Decoration

(backed)
 green computer

(member)
 blue dot

(modified)
 white wrench

(missing)
 red circle

(overlap)
 white exclamation mark

(stale)
 white arrow
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2. Getting Started

This chapter describes tasks that get you up and running with AccuRev Plug-In for Visual Studio PE.

Establishing Your Identity

All AccuRev commands must be executed by an AccuRev user. Before you can begin using AccuRev 
Plug-In for Visual Studio PE, you must establish your identity to AccuRev. Your AccuRev 
installation can use either of these user-authentication methods:

• In traditional authentication mode, AccuRev Plug-In for Visual Studio PE defaults to using 
your operating system username as your AccuRev username, and stores authentication 
information, user preferences and other information in the .accurev subdirectory of your home 
directory. 

To customize that behavior, set these two user-level (not system-level) environment 
variables before starting Visual Studio: 

• To use a different username, set ACCUREV_PRINCIPAL to that username.

• To place your .accurev directory elsewhere, set ACCUREV_ HOME to the new location.

• In accurev_login authentication mode, you must explicitly log in to an AccuRev Server. You can do 
so using Visual Studio’s File > AccuRev > Login command.

See the AccuRev Administrator’s Guide for complete information on AccuRev user management.

Establishing AccuRev Source Control

The commands executed by AccuRev Plug-In for Visual Studio PE move data between the central 
source-code repository (a depot) and a personal AccuRev work area (a workspace). To establish 
AccuRev source control over your Visual Studio project, it must be contained in a workspace, and the 
project’s files must be explicitly placed under source control with the Add to Depot command. 

If you have been working with a previous version of AccuRev Plug-In for Visual Studio PE, installing 
the new version automatically updates existing Visual Studio projects or solutions already under 
AccuRev source control to use the new version. The sections below describe how to initialize 
AccuRev source control for new and existing projects. The instructions assume that any needed 
depots and/or streams have already been created and properly configured.

Placing an Existing Project Under Source Control

Method 1: 

1. Create a new workspace in the project’s location using the instructions in Creating an AccuRev 
Workspace. The name of the new workspace should be the Visual Studio project name. Its 
location on disk should be the location of the project files.

2. Execute the command File > AccuRev > Refresh.
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3. Right-click the solution name in the Solution Explorer, and invoke the command AccuRev > Add 
to Depot.

Method 2: 

1. Shut down Visual Studio.

2. Move the project folder to an existing AccuRev workspace.

3. Restart Visual Studio.

4. Load the project from its new location.

5. Right-click the solution name in the Solution Explorer, and invoke the command AccuRev > Add 
to Depot.

Placing a New Project Under Source Control

1. (optional) Create a new workspace, using the instructions in Creating an AccuRev Workspace.

2. Create the new project in the workspace, using the instructions in Adding a New Project to a 
Workspace.

Creating an AccuRev Workspace

Start the wizard with the command File > AccuRev > Create 
Workspace. Then:

1. When the New Workspace wizard appears, choose a depot 
and a backing stream for the workspace, and click Next.

2. Choose the workspace name and location on disk, and click 
Next. The location can be on a local hard drive or on a 
network drive.

3. Set the workspace options — contents, type, and end-of-line 
(EOL) character(s) — then click Finish to create the 
workspace.

1
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Adding a New Project to a Workspace

In Visual Studio, create a project in a directory within a workspace:

If the Add Solution to AccuRev checkbox is checked when you create a project, AccuRev Plug-In for 
Visual Studio PE runs the Add to Depot command on the entire contents of the project.

2

3
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A Visual Studio project can occupy all or part of an AccuRev workspace. To create a project that 
occupies its entire workspace, enter the pathname of the workspace’s root directory in the Location 
field. To create a project that occupies a subtree of a workspace, enter a Location below the workspace’s 
root directory:

Setting AccuRev Options

Use the Tools > Options command to display the Options dialog. Then choose Source Control > 
AccuRev Options Page from the tree of option types. (If this page does not appear in the tree, select 
the Show all settings checkbox at the bottom of the dialog.) You can set user preferences for 
AccuRev’s Diff/Merge functionality, as well as more general options.

Diff/Merge Options

This set of options allows you to specify the text file comparison and merge tools that AccuRev Plug-
In for Visual Studio PE will use, as well as how certain characters are treated if you use AccuRev’s 
tools.
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When specifying values for the Diff Tools and Merge Tools fields, you have several options:

• Use AccuRev’s own tools — By default, the setting is “AccuRev”, indicating the graphical diff and 
merge tools that are part of the AccuRev product.

• Choose another tool from the drop-down list — The change affects AccuRev Plug-In for Visual Studio 
PE only; it does not affect the AccuRev GUI (which can also be configured to use third-party diff 
and merge tools).

• Specify a command line to be executed when the Diff or Merge command is invoked — This command line 
must contain the name of a text file comparison or merge tool, and a series of substitution 
patterns which indicate the files being compared or merged. The tool must either be in a directory 
on your search path, or be specified with an absolute path.

Note: These patterns look like Windows batch file variables, but they aren’t. They are merely 
placeholders that AccuRev Plug-In for Visual Studio PE will replace with character strings.

Diff Substitution Patterns

%1%When the command line is executed, this pattern will be replaced by the quoted
pathname of the first version to be compared.
%2%Will be replaced by the quoted pathname of the second version to be compared.
%3%Will be replaced by a displayable title string (unquoted) for the first version.
%4%Will be replaced by a displayable title string (unquoted) for second version.

Merge Substitution Patterns

%a%When the command line is executed, this pattern will be replaced by the quoted
pathname of the closest common ancestor version.
%1%Will be replaced by the quoted pathname of the non-workspace version.
%2%Will be replaced by the quoted pathname of the version in the workspace.
%3%Will be replaced by a displayable title string (unquoted) for the closest common
ancestor version.
%4%Will be replaced by a displayable title string (unquoted) for the non-workspace
version.
%5%Will be replaced by a displayable title string (unquoted) for the workspace version.
%o%Will be replaced by the quoted pathname of a temporary file, in which the results
of the merge can be stored.

The next three options affect AccuRev's graphical Diff and Merge tools only. If you configure other 
text file comparison or merge tools, these settings are ignored.

• Ignore Whitespace — Controls whether whitespace is taken into account when comparing text 
lines. Overrides the Ignore Changes in Whitespace option.

• Ignore Changes in Whitespace — Controls whether a change in the amount of whitespace in a 
text line is considered to be a change.

• Ignore Case — Controls whether uppercase and lowercase characters are considered to be the 
same when comparing text lines.
AccuRev® Plug-In  for Visual Studio® PE User’s Guide 9



General Options

• Allow Keep of Kept and Backed Files — Controls whether files with statuses of (kept) and 
(backed) appear in the Keep dialog when you invoke the Keep command.

• Anchor on Edit — Causes an AccuRev Anchor command to be performed automatically when 
you start to edit a file element in an anchor-required or exclusive-file-locking workspace. If the 
option is disabled, an Anchor command is performed when you invoke File > Save.

• Enable update when solution opened — Causes an Update command (from the Synchronize tab 
of the AccuRev window) to be performed automatically when you open a Visual Studio solution.

• Enable commit when solution closed — Causes a Commit command (from the Synchronize tab 
of the AccuRev window) to be performed automatically when you close a Visual Studio solution.

• Add to depot when a new file is added to solution — Causes an AccuRev Add command to be 
invoked automatically when you add a new object to a Visual Studio project (Add > New Item, 
Add > Existing Item, or Add > New Folder).

• Update Status on Save — Causes an automatic call to the AccuRev Server whenever you execute 
the Visual Studio command File > Save on a file. This determines the new AccuRev status of the 
saved file and updates its icon decoration.

This option is turned on by default. Turning it off improves performance by eliminating the call to 
the AccuRev Server. To display the correct icon decoration for the saved file when the option is 
turned off, invoke the command AccuRev > Refresh.

• Always bring AccuRev output window pane to the top -- Ensures that the AccuRev pane in the 
Output window is always brought to the top when you have more than one tab displayed.

• Separate name and in-folder columns — pathname is split over two columns: a Name column 
with the “leaf ” name, and an In Folder column with the folder/directory pathname to the 
element. If this option is not selected, entire pathname appears in a single column, labeled Name.

• Number of comments to keep in history — The number of choices to appear in the Select 
Previous Comment drop-down box in the dialog boxes for the Add to Depot, Keep, and Promote 
commands.
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• Version Detaiils -- Information about the current AccuRev Plug-In version:

• Version: The currently installed version.

• Date: The date this version was built.

• Transaction: The AccuRev transaction number associated with the version’s build.
AccuRev® Plug-In  for Visual Studio® PE User’s Guide 11
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3. AccuRev-Specific Windows

This chapter describes AccuRev Plug-In for Visual Studio PE’s use of windows within the Visual 
Studio interface:

• A special “AccuRev” window, containing several tabs for executing — and displaying the results 
of — AccuRev commands.

• An “AccuRev” pane in Visual Studio’s standard Output window.

The AccuRev Window

AccuRev Plug-In for Visual Studio PE provides an “AccuRev” window, in which you can view the 
results of AccuRev commands and invoke AccuRev commands. To display this window, use the 
View > AccuRev Window command. It appears automatically when you invoke AccuRev’s History 
command in the Solution Explorer.

As long as the current solution remains open, you can close and reopen the AccuRev window without 
losing information.

The AccuRev window contains three tabs, Searches Tab, the History Tab, and the Synchronize Tab. 
Each tab contains a table, which you can manipulate in the standard ways:

• Clicking a column header sorts the table’s row on that column’s contents. Clicking again reverses 
the sort order, indicated by a triangle.

• Drag column headers to the left or right to change the column order.

• Drag column separators to change column widths.

Searches Tab

In the Searches tab, you can search for items based on their AccuRev status, and execute commands 
on search results items.
AccuRev® Plug-In for Visual Studio® PE User’s Guide 13



To perform a search, click a button on the tab’s toolbar. The items that satisfy the search criterion are 
displayed in a table, with these columns:

• Type — Visual Studio file type

• Status — AccuRev status indicator(s)

• Location — location within the workspace

• Version — AccuRev version-ID

• Overlap Stream — AccuRev stream containing the overlapped version

The tab’s toolbar includes these additional buttons:

• Click Status to display the status of all items in the workspace.

• The Search Entire Workspace button is a toggle switch that controls the scope of the search. If 
the toggle is on (highlighted), the results table includes matching items in all the workspaces that 
contain projects in the current solution. If the toggle is off (not highlighted), the results table only 
includes matching items in the current solution.

Updating Search Results

Clicking a button again reruns the search. If you change an element’s status within Visual Studio (for 
example, by editing a file) while the Searches tab is loaded with search results, the results table is 
updated automatically.

Invoking AccuRev Commands

You can invoke AccuRev commands in the Searches tab: select one or more items, then right-click to 
bring up a context menu. A command in enabled only if it applies to at least one of the selected items. 
The Searches tab commands are the same as those available in the Solution Explorer, with the 
addition of Defunct and Locate in Solution Explorer. See AccuRev Command Reference on page 19 for 
full descriptions of the AccuRev commands.

History Tab

The History tab displays a table containing the results of a History command. Each row lists an 
AccuRev transaction that created a new version of the element.

 

The table contains these columns:

• Name — the element's pathname within the workspace.

• Time — a timestamp, indicating when the transaction took place.
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• Transaction — The unique number (within this AccuRev depot) of the transaction.

• Action — the kind of AccuRev transaction: keep, promote, etc.

• User — the AccuRev username of the user who performed the transaction.

• Version — the unique version-ID of the element version that was created in this transaction.

• Comment — the user-supplied comment for this transaction.

Invoking AccuRev Commands

You can select one or two transactions from an item’s history, then invoke an AccuRev command 
from the selection’s context menu:

• Diff Against Workspace — Compares the version in the selected transaction with the version 
currently in your project.

• Diff Against Version — Compares the versions created in the two selected transactions.

• Checkout Version — Replaces the version in your workspace with the version in the selected 
transaction.

• Show Transaction — Pops up another window (“Transaction History”), showing the complete 
contents of the selected transaction.

Synchronize Tab

The Synchronize tab shows an element-by-element listing that answers the question: What are the 
current differences between my project(s) and the backing stream(s) in the AccuRev repository?

The Synchronize tab’s toolbar provides 
command buttons to filter project files 
by how they differ from the backing-
stream versions in the AccuRev 
repository:

Incoming

The element changed in the 
repository, but not in the project. 
Objects with AccuRev status (stale), (overlap), (underlap), or (missing) are selected by this filter.

Outgoing

The element changed in the project, but not in the repository. Objects with AccuRev status 
(modified), (kept), (member), (external), (overlap), (underlap), or (missing) are selected by this 
filter.

Note: The AccuRev command Anchor changes a file’s AccuRev status to (member), but doesn’t 
affect the file’s contents. Such a file is classified as Outgoing in the Synchronize tab, even though 
there might be no difference between the file’s contents in the project and in the repository.

Incoming/Outgoing 

Shows elements from both the Incoming and Outgoing categories.
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Conflicting

Shows elements that have changed in both the project and the repository. Objects with AccuRev 
status (overlap) or (underlap) are selected by this filter.

Two additional buttons affect the 
display of elements in the 
Synchronize tab:

Refresh

Retrieves the AccuRev status of 
all the files in the project, and updates the current display.

Sync Entire Workspace

Toggles the scope of the Synchronize tab. If the toggle is on (highlighted), the tab includes items 
from the entire AccuRev workspace containing the current solution. And if the solution contains 
multiple projects that are contained in multiple workspaces, the tab includes items from the 
entirety of all those workspaces.

If the toggle is off (not highlighted), only items that are contained in the current solution are 
displayed.

Invoking AccuRev Commands to Synchronize the Project with the Repository

The Synchronize tab’s toolbar includes two command 
buttons that initiate AccuRev commands to bring your 
project into closer (or complete) synchronization with 
your workspace’s backing stream.

Update

Pops up an Update Incoming Changes window, in which you can bring changes into your project, 
with the AccuRev commands Merge, Revert to Backed Version, and Update.
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You can process an (overlap)-status item with either Merge or Revert to Backed Version. The only 
command available for a (stale)-status item is Update.

Clicking the Update button at the bottom of this window launches a series of AccuRev 
commands to perform the operations you’ve configured.

Note: The AccuRev Update command operates on the entire workspace, not on individual 
elements within it. Accordingly, clearing the checkbox for an item to be processed with the 
Update command has no effect.

Commit

Pops up a Commit Outgoing Changes window, in which you can send your changes to the 
repository, using the AccuRev commands, Add to Depot, Merge, and Promote. (You can also 
choose to “undo” changes to files, using the Revert to Backed Version and Revert to Most Recent 
Version commands.)

Note: For items with (member) status, the “Keep” choice in the Command column performs a 
Keep-and-Promote sequence.

Clicking the Commit button at the bottom of this window launches a series of AccuRev 
commands to perform the operations you’ve configured.

Manual Synchronization

Instead of clicking the Commit or Update button in the Synchronize tab, you can invoke AccuRev 
commands on specific items: select one or more items, then right-click to bring up a context menu. A 
command in enabled only if it applies to at least one of the selected items. The AccuRev commands 
available here are the same as those available in the Solution Explorer, with the addition of Defunct, 
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Locate in Solution Explorer, and Open File. See AccuRev Command Reference on page 19 for full 
descriptions of the AccuRev commands.

AccuRev Pane in the Output Window

Messages generated by AccuRev commands are directed to the AccuRev pane of Visual Studio’s 
Output window. 
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4. AccuRev Command Reference

To execute AccuRev commands in the Solution Explorer:

1. Select one or more files or directories.

2. Right-click to 
display the 
selection’s 
context menu, 
and choose a 
command 
from the 
AccuRev 
submenu.

Alternatively, 
click a 
command 
button on the 
AccuRev 
toolbar.

In other situations 
— for example, in 
the AccuRev 
window — 
AccuRev 
commands appear 
at the top level of 
a selection’s 
context menu.

Commands that 
operate on files and directories are enabled if they apply to one or more items in the current selection. 
Certain commands, such as History, are enabled only if a single item is selected.

Command enabling and execution takes into account the fact that a project consists of a hierarchy of 
items. In particular, invoking a command on an item sometimes causes the item’s subhierarchy to be 
processed, also. Examples:

• Invoking the Keep command on a directory operates on files within that directory. If no files are 
candidates for Keep, the command is disabled.

• Invoking the Keep command on a project or solution item provides an easy way to invoke the 
command on all the project’s or solution’s (modified)-status elements.

• A Keep command invoked on code file MainForm.vb can also include its subitems: the form-
design file MainForm.designer.vb and the resources file MainForm.resx.

The sections below describe the AccuRev commands that are available within Visual Studio:
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• Section Commands that Operate on Files and Directories on page 20 describes most of the 
commands that you’ll use on a day-to-day basis. These commands are available in the Solution 
Explorer and also on the Searches Tab and the Synchronize Tab of the AccuRev window.

• A few additional commands, which operate on historical versions of elements, are described in 
section Commands Available on the History Tab on page 27.

• Commands that don’t operate on individual files and directories are described in section 
Commands Available on the AccuRev Menu on page 28.

• Certain Visual Studio operations cause AccuRev commands to be executed automatically. This is 
discussed in section Automatic Invocation of AccuRev Commands on page 30.

Commands that Operate on Files and Directories

The following commands operate on the files and directories within Visual Studio projects and 
solutions. Most are available in the Solution Explorer, and are also available in the Searches Tab and 
the Synchronize Tab of the AccuRev window.

Add to Depot

Converts the selected items into AccuRev version-controlled elements. The directory containing the 
files is also converted to an element, if necessary. You are prompted to enter a comment, just as with 
the Keep command.

This command applies only to items not already under AccuRev version control — that is, to items 
whose AccuRev status is (external).

Keep

Saves the changes you’ve made to one or more elements as “private” versions in the AccuRev 
repository. These versions are visible only in your workspace — not in the backing stream or other 
users’ workspaces. Use the Promote command to send versions created with Keep to the backing 
stream, making them public.

You are prompted to enter a comment, which can span multiple lines. You can reuse a comment that 
you have entered previously for a Keep, Add to Depot, Promote, or Defunct command — in this Visual 
Studio session or in a previous one.
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After selecting an old comment, you can revise it before submitting it as the comment for the current 
command.

Anchor

Activates the selected file in your workspace, adding it to the workspace’s default group. Doing so 
ensures that:

• The file is not read-only.

• The file won’t be overwritten by an Update command.

If your workspace uses the exclusive file locking or anchor-required feature, its files are initially 
read-only. In that case, you can Anchor the file before editing it, or AccuRev Plug-In for Visual Studio 
PE will invoke Anchor automatically when you save the file.

Promote

Converts the “private” versions of one or more file elements into “public” versions. It takes versions 
that you previously created in your workspace with Keep, and sends them to the backing stream 
shared by you and other members of your development team. You are prompted to enter a comment, 
just as with the Keep command.

If any of the selected files have been changed since their last Keep — and so have (modified) status — 
this command first Keeps the changed files, then Promotes all files in the selection with (kept) status.

Change Package Trigger

If a change package trigger is defined for the current depot’s issue database, a Select Issue Number(s) 
dialog box appears, displaying a set of AccuWork issue records. The change package trigger definition 
includes a query, which dynamically selects the set of issue records to display. (If you are using a third-
party issue tracking system with AccuRev, this dialog box gives you the option of displaying issues 
using either the AccuWork issue number or the third-party system key, as shown below.)
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Depending on the issue database configuration, there might also be a drop-down box that enables you 
to restrict the issue record display to a subset — for example, to the subset whose Assigned To value is 
derek.

You must select one or more of these issue records by point-and-click, or by typing in the Issue 
Number(s) input field. Use SPACE characters to separate multiple issue numbers. When you click 
OK, the versions being promoted are added to the change packages of the selected issue record(s).

Merge

Combines two versions of an element, producing a new version in your workspace (recorded as a 
Keep transaction). Typically, you need to merge when you and another team member both modify the 
same element, and your colleague Promotes her changes to the common backing stream before you 
do. (This command is the equivalent of “Resolve” in other source code management terminologies.)

If the element type is binary, merging amounts to 
picking your own version or the backing-stream 
version. AccuRev does not support combining the 
contents of binary files.

If the element type is text, the versions’ contents 
are merged with an external program — by default, AccuRev's own Merge tool, which uses a three-
way merge algorithm.
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You can configure another merge tool, using the Tools > Options command. See Setting AccuRev 
Options on page 8.

A merge might be 
required on the 
“namespace” level 
instead of, or in addition 
to, the content level. This 
occurs when the file or 
directory has been 
renamed or moved, both 
in your AccuRev 
workspace / Visual 
Studio project and in the 
backing stream version. 
The Merge command 
has you choose which namespace change to use. You can also choose to reject both changes, and use 
the element’s “original” name in the common-ancestor version.

Note: After a namespace-level merge in which you choose not to retain the name in your 
workspace, the project file must be updated to reflect the name change. In many cases, you can 
Update your workspace to bring in a new version of the project file that contains the name change. 
If not, use Visual Studio's Delete command to remove the old name from the project file, then use 
Add > Existing Item to include the renamed item in the project.
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Another special case 
occurs if an item has 
(defunct) status in 
your workspace. 
(You performed a 
Visual Studio 
Delete, which 
triggered an 
AccuRev Defunct.) 
A dialog appears, in 
which you can 
reinstate (“undefunct”) the item; this enables you to change your mind about deleting it, and 
incorporate the changes in the backing-stream version instead. Choosing Purge performs a Revert to 
Backed Version command, which discards all your changes to the item, including the Delete/
Defunct.

If you really want the item to be removed from the project:

1. Choose Purge in this dialog.

2. Update your workspace.

3. Delete the item again, and allow AccuRev Plug-In for Visual Studio PE to Defunct it.

4. Promote the (defunct) item to the backing stream.

History

Displays the AccuRev transactions that created versions of the selected element in the History tab of 
the AccuRev window. See History Tab on page 14.

Locate in Solution Explorer

(available in the AccuRev window only) Highlights the selected item in the Solution Explorer pane, 
expanding the item’s project hierarchy if necessary to make it visible.

Open File

(available in the AccuRev window only) Opens the selected file in Visual Studio’s tabbed document 
window.

Populate

Restores a file with (missing) status to your project. To locate such files, use the Missing element 
search — see the documentation for the Searches Tab on page 13. 

The Populate command copies the version currently in the workspace stream (in the AccuRev 
repository) to the workspace. For more information, see “What’s the Difference between Populate 
and Update?” in AccuRev Technical Notes.

Invoking the Populate command displays a dialog listing the files and directories to be populated. Use 
the checkboxes in the Populate column to choose which of the listed items will be populated. 

There are two other controls at the bottom of the dialog:
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• Recursive – For each item in the list that is a directory, perform a Populate command on that 
element and on all elements below it.

• Overwrite – For each item in the list that is a file, replace the file (if any) currently in your 
workspace. If this checkbox is not selected, no files will be overwritten.

Annotate

Displays a read-only copy of the selected file, prefixing each line with one or more of the following: 
the user who created the line, the transaction in which the line was added or most recently modified, 
the timestamp of that transaction, the version-ID of the version created in that transaction. Also noted 
are lines that have been modified in the workspace but not yet kept or promoted.

Defunct

Deletes the selected file from disk, and marks it with (defunct) status in the AccuRev workspace. You 
are prompted to enter a comment, just as with the Keep command.

A defunct file is no longer on your disk, but appears in the results of an AccuRev search for Defunct, 
Pending, or Default Group elements. It disappears entirely from the AccuRev workspace when you 
Promote the element to the backing stream.

Note: You can also defunct a directory element, but this can have far-reaching consequences. 
Before doing so, consult the description of the defunct command in the AccuRev CLI User’s Guide.

Visual Studio’s Delete command removes a file from your project (and local disk storage), then 
automatically offers to perform a Defunct, as well:
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Be sure to proceed with the Defunct, to keep the Visual Studio project in sync with the AccuRev 
repository. If you don’t, the element will have (missing) status in your workspace.

Revert to Most Recent Version 

Similar to Revert to Backed Version, but rolls back a file only as far as the private version you recently 
created with Keep. This command is useful when you edit a file, save it with File > Save, then decide 
to discard the changes.

Revert to Backed Version

Discards the changes you’ve made to a file. It restores the version that was in the backing stream at 
the time of your most recent Update command. (But if you promoted one or more versions of the 
element to the backing stream since your most recent Update, it restores the most recently promoted 
version.)

Diff Against Most Recent Version

(text files only; single-file selection only) Compares your file with the private version you recently 
created with Keep. It answers the question What have I changed since my last Keep?

Diff Against Backed Version

(text files only; single-file selection only) Compares your file with the version currently in the 
workspace’s backing stream.

Diff Against Basis Version

(text files only; single-file selection only) Compares your file with the more recent of these ancestor 
versions:
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• A version that was originally created in another workspace, and brought into your workspace 
with an Update.

• A version that you created and Promoted to the backing stream.

It answers the question What changes have I made recently to this file?

Diff Against File on Disk

(text files only; single-file selection only) Compares your file with another file you select, using a 
standard Open dialog.

Commands Available on the History Tab

These commands are available only through context menus on the AccuRev window’s History Tab.

Diff Against Workspace

Compares the version created by the selected transaction with the file that is currently in your project.

Diff Against Version

Compares the versions created by the two selected transactions.

Checkout Version

Performs an AccuRev checkout (co) command, which replaces the version in your workspace with 
the selected version. This is similar to the Anchor command, but activates a historical version rather 
than the workspace’s current version.

The element must currently be inactive in your workspace — that is, it must have (backed) status.

Show Transaction

Displays a Transaction History window, showing the complete contents of the selected transaction. 
Some kinds of transactions can create a new version of multiple elements.
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Commands Available on the AccuRev Menu

These commands are available under AccuRev on Visual Studio’s main 
menu. They are also available under File > AccuRev.

The AccuRev menu appears only if a solution is active in the Solution 
Explorer. The solution need not have any projects under AccuRev 
source control.

Update

Performs an AccuRev Update command on all workspaces that contain projects in the current 
solution. An update copies versions into your workspace from your workspace’s backing stream. This 
has the effect of incorporating other people's changes, which they have promoted to the backing 
stream, into your workspace.
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Update Preview

Lists the changes that would be made by an actual workspace update in the Output window’s 
AccuRev pane.

Login

If AccuRev is configured to use the accurev_login user-
authentication scheme, you must execute this 
command before you can perform any AccuRev 
operations within Visual Studio.

Do not use this command if AccuRev is configured to 
use the traditional user-authentication scheme. See 
Establishing Your Identity on page 5 for more 
information.

Create Workspace

Invokes a wizard that leads you through the creation of a new AccuRev workspace. See Creating an 
AccuRev Workspace on page 6.

Synchronize Time

Adjusts the system clock on your machine to match the clock on the AccuRev Server machine. This 
requires administrator-level permissions at the operating system level.

Workspace Information

Displays information regarding your current AccuRev work environment.
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Refresh

Contacts the AccuRev Server and updates the status of all items in the solution. Use this command if 
a process other than Visual Studio has modified development files.

Automatic Invocation of AccuRev Commands

When you perform a Visual Studio operation that changes a project’s “namespace”, an AccuRev 
command is executed automatically, in order to keep the Visual Studio project namespace in sync 
with the AccuRev repository namespace.

Rename

If you perform a Rename command on an element, a corresponding AccuRev Rename (or move) 
command is invoked automatically. The change is logged to the AccuRev pane of the Output 
window:

Starting rename operation on '.\ValidateText\Documentation\ReadMe.htm' ...

Moving \.\ValidateText\Documentation\ReadMe.htm to

\.\ValidateText\Documentation\ReadMeFirst.htm

Operation completed successfully

Delete

If you perform a Delete command on an element, a corresponding AccuRev Defunct command is 
invoked automatically. Be sure to proceed — don’t choose to cancel in the Defunct dialog box. If you 
cancel, the element’s status becomes (missing).

Moving an Element

You can change the location of an element by dragging it from one directory to another — perhaps to 
a location in another project — while holding down the SHIFT key. You can also move an element 
with the Cut and Paste commands. AccuRev Plug-In for Visual Studio PE handles such operations as 
follows:

• If the destination is within the same AccuRev workspace — though not necessarily within the 
same Visual Studio project — an AccuRev Rename (or move) command is invoked 
automatically. (Note that in a C++ project, the copy operation does not create a file system object, 
merely a reference in the project file.)

• If the destination is not within the same AccuRev workspace, the AccuRev Rename command 
fails.

Note: A “plain” drag-and-drop, without holding down the SHIFT key, implements a copy 
operation, as does a Copy-Paste sequence. No AccuRev command is invoked in this situation. If 
you copy the item to a location within an AccuRev workspace, the new copy becomes an 
(external) item.
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A. The AccuRev Usage Model

AccuRev's flexibility makes it easy to use for a variety of development scenarios. But like every 
software system, AccuRev has usage models that were foremost in the minds of its architects. This 
section describes the most common usage model.

AccuRev is a software configuration management (SCM) system, designed for use by a team of 
people (users) who are developing a set of files. This set of files might contain source code in any 
programming language, images, technical and marketing documents, audio/video tracks, etc. The 
files — and the directories in which the files reside — are said to be “version-controlled” or “under 
source control”. AccuRev also version-controls links. Version-controlled objects are termed elements.

Workspaces and Streams

For maximum productivity, the team's users must be able to work independently of each other — 
sometimes for just a few hours or days, other times for many weeks. Accordingly, each user has his 
own private copy of all the version-controlled elements. The private copies are stored on the user's own 
machine (or perhaps in the user's private area on a public machine), in a directory tree called a 
workspace. We can picture the independent workspaces for a three-user team as follows:

This set of users' workspaces uses the convention of having like names, suffixed with the individual 
usernames. AccuRev enforces this username-suffix convention. talon_dvt might mean “development 
work on the Talon product”; john, mary, and derek would be the users' operating system login names.

From AccuRev's point of view, development work in this set of workspaces is a continual back-and-
forth between “getting in sync” and “getting out of sync”:

• Initially, the workspaces are completely synchronized: they all have copies of the same set of 
version-controlled elements.

• The workspaces lose synchronization as each user makes changes to some of the elements.

AccuRev uses the same synchronization paradigm as CVS — instead of transferring data directly 
between private areas (that is, between users' workspaces), AccuRev organizes the data transfer into 
two steps:
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1. One user makes his changes 
public — available to all the other 
members of his team. This step is 
called promoting. (CVS calls this 
step “committing”.)

2. Whenever they wish, other team 
members incorporate the public 
changes into their own 
workspaces. This step is called 
updating.

You can use the Synchronize tab to 
organize and perform both your 
promoting work and your updating 
work. See Synchronize Tab on 
page 15.

The first step, promoting, sends your changes to a public data area, called a stream. AccuRev has 
several kinds of streams; the kind that we referred to is called a backing stream. The data in this 
public stream “is in back of ” or “provides a backstop for” all the private workspaces of the team 
members. (The term “parent stream” is equivalent to “backing stream”.)

The second step, updating, copies other users’ changes from the backing stream to your AccuRev 
workspace.

AccuRev allows you to save any number of intermediate versions of an element in your workspace, 
before making your changes public. Such “private” versions of an element are created by the keep 
operation.

AccuRev Element Status

Each AccuRev element (version-controlled file, directory, or link) has a status, expressed as a set of 
status indicators. An element’s status addresses the question, “for this element, what is the 
relationship between the version in my workspace and the version in the AccuRev repository?”. There 
are quite a few status indicators, because AccuRev tracks an element’s status in three locations, not 
just two:

• The workspace tree: the directory tree on your machine, which you access as a Visual Studio 
project.

• The workspace stream: a corresponding area in the AccuRev repository that provides permanent 
storage for the private versions that you create in your workspace (for example, with the Keep 
command).

• The backing stream: the public area in the AccuRev repository that is accessed by you and other 
team members.

Following are descriptions of the AccuRev element status indicators.

Presence of the element in the workspace:

• (defunct) — the element has been marked for removal from the workspace stream with the 
Defunct command.
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• (external) — the file or directory has not been placed under version control. (It is in the 
workspace tree, but not in the workspace stream.)

• (excluded) — the element does not appear in the workspace because it has been excluded, using 
the Include/Exclude facility. The AccuRev plug-in does not provide an interface to this facility.

• (link) — the element is a file link or a directory link.

• (missing) — the workspace “should” include a version of this element, but doesn’t. This occurs 
when you delete version-controlled files from the workspace tree using operating system 
commands.

• (twin) — the element is one of multiple elements in the workspace that exist at the same 
pathname. At most one of these elements can be accessed through the pathname; the other(s) can 
be accessed through their unique element-IDs. The AccuRev plug-in does not provide for access 
by element-ID.

• (stranded) — the element is active in the workspace, but there currently is no pathname to the 
element.

Changes to the element in the workspace:

• (modified) — the file has been modified in the workspace since the most recent update or keep.

• (kept) — you have created a new, private version of the element, and you have not yet made the 
version public with Promote.

• (member) — the element is “active” in your workspace, because you have created a new, private 
version of it with Keep or Anchor.

Relationship to the version in the backing stream:

• (backed) — an element that you’re not currently working on: the versions in the Visual Studio 
project (workspace tree), the workspace stream, and the backing stream are all the same.

• (stale) — the element needs to be updated, because the version in the backing stream has changed 
since the workspace’s latest Update.

• (overlap) — the element has changed both in the backing stream and in your workspace. This 
indicates that a Merge is required before you can Promote your changes to the backing stream.

• (underlap) — similar to (overlap): the element has changed both in the backing stream and in 
your workspace, but the changes in your workspace have already been promoted to the backing 
stream.
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