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Preface

This book is your guide to installing Eclipse Plug-in for AccuRev (Eclipse Plug-in). It is intended for 
the AccuRev system administrator. This book provides information specific to this release, including 
notes on platform support and a summary of changes for the current and recent releases.

See the Eclipse Plug-in for AccuRev User’s Guide for information about using the Eclipse Plug-in within 
the Eclipse environment.

For news on this product, visit the integrations page on the AccuRev Web site:
http://www.accurev.com/integrations.html.

Using This Book

This book assumes you are familiar with your operating system and its commands, as well as with 
AccuRev and Eclipse. The remaining chapters in this book tell you how to prepare for and install 
Eclipse Plug-in and provide information on features, fixes, and known issues in the current and recent 
releases:

Typographical Conventions

This book uses the following typographical conventions:

Chapter Description

Chapter 1 Introduction Introduces the current release and describes its highlights.

Chapter 2 Installing Eclipse Plug-in 
for AccuRev

Provides background information and procedures for installing Eclipse 
Plug-in.

Chapter 3 Release Notes New features, fixes, and known issues in the current and recent 
releases.

Convention Description

blue sans-serif Used for sample code or output.

red monospace Used for examples.

bold Used for command names, and button names in the 
AccuSync Web user interface

light italic Used for emphasis, book titles, and for first use of important terms

blue italic Identifies a hyperlink (to a page or Web URL, for example)
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Contacting Technical Support

AccuRev offers a variety of options to meet your technical support needs. For complete information 
about AccuRev technical support services, visit our Web site:

http://www.accurev.com/support.html

License Issues

If you are having trouble with a license for your AccuRev product, visit the License Self Help page 
first to see if there is a solution for your problem:

http://www.accurev.com/support/license-self-help.html

Other Support Issues

To obtain technical support for an AccuRev product:

• Go to http://support.accurev.com/

• Or e-mail AccuRev technical support at support@accurev.com

When you contact AccuRev technical support, please include the following information:

• The AccuRev version

• The operating system

• If you are using an AccuBridge™ or AccuSync product:

• The product version

• The version of the third-party system (JIRA or Rally, for example)

• A brief description of the problem you are experiencing. Be sure to include which AccuRev 
interface you were using (Web user interface, Java GUI, or CLI), any error messages you received, 
what you were doing when the error occurred, whether the problem is reproducible, and so on.

• A description of any attempts you have made to resolve the issue, including using the resources 
described in Other Resources.

• A simple assessment of how the issue affects your organization.

Other Resources

In addition to contacting AccuRev technical support, consider taking advantage of the following 
resources:

• AccuRev Known Problems and Solutions – http://www.accurev.com/support/kps.html

The AccuRev Known Problems and Solutions page describes known problems in released 
versions of AccuRev products.
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• AccuRev User Forum – http://www.accurev.com/ubbthreads/

The AccuRev User Forum is a valuable resource. In addition to access to AccuRev’s international 
user community, the User Forum is the place to go for resources like:

• The AccuRev knowledge base

• The AccuRev FAQ

Register as a User Forum member today.

• AccuRev documentation – http://www.accurev.com/documentation.html

This page provides access to AccuRev product documentation for all current and previous 
releases of most AccuRev products.
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1. Introduction

Eclipse Plug-in for AccuRev (Eclipse Plug-in) integrates AccuRev functionality with the Eclipse 
Platform IDE (Integrated Development Environment). 

This chapter describes the highlights of the current release.

Highlights of this Release

Eclipse Plug-in for AccuRev Version 2012.1 includes several enhancements and numerous bug fixes, 
including:

• Checkout Wizard for Creating New Projects – The Checkout Wizard has been redesigned. 
The new features of the Checkout Wizard include:

• The Checkout Wizard simplifies the process of creating an Eclipse project and placing it 
in a new or existing AccuRev workspace. You can choose to create the project with an 
existing .project file or create a new .project file using the wizard. The wizard is available 
by selecting File>New>Project and then selecting the AccuRev wizard.

• The Checkout Wizard includes a tree structure for selecting depots, streams, workspaces, 
and folders.

• You can now create multiple Eclipse projects, one for each specified folder within an 
AccuRev stream. These projects are automatically shared with AccuRev.

• The Checkout Wizard creates include rules for the AccuRev workspace based on the 
selected folders.

• The Checkout Wizard can now be used to import existing Eclipse projects and place them 
in new AccuRev workspaces. The imported projects are shared with AccuRev with no 
need to perform a separate step for sharing. The wizard is available by selecting 
File>Import and then selecting the AccuRev wizard.

• New Functionality for Sharing Eclipse Projects with AccuRev – You can now use a tree 
view to choose the depot and stream for sharing projects with AccuRev and the process allows 
more user options and control.

• New Functionality for Adding and Selecting AccuRev Servers – You can now add 
AccuRev servers to a list of available servers and then select the server you want to use.

• New Ignore options for AccuRev Diff – You can now specify whether or not you want the 
AccuRev Diff tool to ignore one or more of the following during the diff operation: whitespace, 
changes in whitespace, and case. It is not necessary to return to the Preferences dialog box.

Next Steps

To install Eclipse Plug-in, see Chapter 2 Installing Eclipse Plug-in for AccuRev.

For details about the specific changes introduced in this release, see Chapter 3 Release Notes.
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2. Installing Eclipse Plug-in

for AccuRev

Before installing Eclipse Plug-in for AccuRev (Eclipse Plug-in), ensure that you have an AccuRev 
client on the machine running Eclipse. See the Installation and Release Notes document for your version 
of AccuRev for instructions on installing AccuRev.

Note: Eclipse Plug-in version 2010.1 and later provide access to the AccuRev Web Interface (Web 
UI). For instructions on configuring this option, see Configuring Access to the AccuRev Web Interface on 
page 10.

Platform Support

Eclipse Plug-in version 2012.1 has been validated with Eclipse Platform Versions 3.7.x, 3.6.x, 3.5.x, 
3.4.x, and 3.3.x. 

AccuRev recommends Java 2 Runtime Environment 5.0 and higher; versions 1.4.2 and higher are 
supported. 

Installing on Eclipse 3.5, 3.6, or 3.7

Use the procedures described in this section to add the AccuRev update site to the Eclipse repository 
and to install Eclipse Plug-in.

Adding the AccuRev Update Site

AccuRev provides the standard plug-in installation method for the Eclipse IDE via an update site. If 
you require offline or local network access to an update site for installing the plug-in, see the section 
titled Setting Up a Local Update Site on page 10.

Otherwise, follow this procedure to add the AccuRev update site to the list of sites that Eclipse can 
contact:

1. Start the Eclipse IDE.

2. Select Help > Install New Software from the Eclipse menu.

The first page of the Install New Software wizard appears.
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3. Click Add.

The Add Repository dialog box appears.

4. In the Add Repository dialog box:

• In the Name field, enter a unique name for the AccuRev plug-in.

• In the Location field, enter the URL of the AccuRev update site:
http://www.accurev.com/download/eclipseupdate 

5. Click OK to add the AccuRev update site to the Eclipse repository.

6. To continue installing Eclipse Plug-in, go to Step 3 in Installing Eclipse Plug-in for AccuRev on 
page 4. If you want to install Eclipse Plug-in at a later time, click Cancel to stop the Eclipse Install 
New Software wizard.

Installing Eclipse Plug-in for AccuRev 

Before you begin, add the AccuRev update site to the Eclipse repository if you have not done so 
already. See Adding the AccuRev Update Site on page 3.

1. Start the Eclipse IDE.

2. Select Help > Install New Software from the Eclipse menu.

The first page of the Install New Software wizard appears.
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3. Select the AccuRev plug-in site from the Work with drop-down list.

4. Select the checkbox next to AccuRev Eclipse plugin and click Next.

5. Click through the wizard to review the installation and to confirm the license agreement.

Eclipse installs Eclipse Plug-in.

Note: During installation, you might receive a security warning about unsigned content. Click 
OK to acknowledge the warning and finish the installation.

When the installation finishes, Eclipse prompts you to restart the Eclipse IDE.

6. Click Restart Now to restart the Eclipse IDE and complete the installation.

When you restart Eclipse, it opens in the AccuRev perspective, as shown in the following 
illustration:

Installing on Eclipse C/C++ Development Tooling (CDT) Installations

Installation on Eclipse CDT 3.6 requires that you first install the Java Development Tools (JDT) 3.6.1 
or later. Once the JDT is installed, you can successfully install the Eclipse Plug-in.

To install the JDT on Eclipse CDT 3.6:

1. In Eclipse C++, select Help > Install New Software from the menu.

The Install wizard appears.

2. In the filter field following the Work with field, type java.

The table displays available Java plug-ins.

3. Select Eclipse Java Development Tools.
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4. Click Next to complete the Eclipse Install wizard.

Installing on Wind River Workbench

Installation on Wind River Workbench requires that you first install the Java Development Tools 
(JDT) 3.6.1 or later.

To install the JDT on Wind River Workbench:

1. Select Window > Open Perspective > Advanced Device Development from the Workbench 
menu to open the Advanced Device Development perspective.

2. Select Help > Install New Software from the Advanced Device Development perspective menu.

3. In the Preferences dialog box, select Install/Update > Available Software Sites.

4. Locate and select Eclipse Galileo Repository, click the Enable button, and then click OK.

5. In the Install dialog box, locate and select Eclipse Java Development Tools.

6. Click Next to complete the Wind River Install wizard.

Verifying the Installation

To verify that the installation of Eclipse Plug-in was successful:

1. Start the Eclipse IDE.

2. Select Help > About Eclipse from the Eclipse menu. 

3. Click Installation Details, and go to the Installed Software tab on the Eclipse Installation Details 
dialog box.

4. Verify that an Eclipse Plug-In for AccuRev entry exists.

Uninstalling Eclipse Plug-in for AccuRev

1. Start the Eclipse IDE.

2. Select Help > Install New Software from the Eclipse menu.

3. Click Installation Details, and go to the Installed Software tab on the Eclipse Installation Details 
dialog box.

4. Highlight the Eclipse Plug-in for AccuRev entry.
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5. Click the Uninstall... button. 

Note: If this button is disabled, you manually installed an earlier version of Eclipse Plug-in. 
Instead of using this procedure, shut down the Eclipse IDE, then search for and delete files and 
folders in your Eclipse installation directory that start with com.accurev.eclipse.

6. When the Uninstall window appears, verify that you want to uninstall the items shown, and click 
Finish to uninstall the plug-in.

Installing on Eclipse 3.4

Use the procedures described in this section to add the AccuRev update site to the Eclipse repository 
and to install Eclipse Plug-in.

Adding the AccuRev Update Site

AccuRev provides the standard plug-in installation method for the Eclipse IDE via an update site. If 
you require offline or local network access to an update site for installing the plug-in, see the section 
titled Setting Up a Local Update Site on page 10.

Otherwise, follow this procedure to add the update site to the list of sites that Eclipse can contact:

1. Start the Eclipse IDE.

2. Select Help > Software Updates from the Eclipse menu, and go to the Available Software tab on 
the Software Updates and Add-ons window that appears.

3. Click Add Site.

4. Fill in the AccuRev update site URL (http://www.accurev.com/download/eclipseupdate) in the 
Location field, and click OK. The new update site appears on the list of remote sites.

Installing Eclipse Plug-in for AccuRev

To install Eclipse Plug-in after creating the new remote site:

1. Select Help > Software Updates from the Eclipse menu, and go to the Available Software tab on 
the Software Updates and Add-ons window that appears.

2. Expand the AccuRev update site in the list.

3. Select the checkbox next to Eclipse Plug-in for AccuRev and click Install to proceed.

4. Click Next to confirm.

5. Accept the license agreement and click Next to proceed.

6. Click Finish to install the plugin.

7. Restart the Eclipse IDE to complete the installation.

Verifying the Installation

Eclipse Plug-in will be loaded and enabled automatically when you restart Eclipse. To verify that the 
installation was successful:

1. Start the Eclipse IDE.
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2. Select Help > Software Updates from the Eclipse menu and go to the Installed Software tab on 
the Software Updates and Add-ons window that appears.

3. Verify that an Eclipse Plug-in for AccuRev entry exists in the configuration window.

Updating Eclipse Plug-in for AccuRev

If an older version of the Eclipse Plug-in is currently included in your Eclipse configuration, you will 
need to uninstall it and add a new update site as described in Adding the AccuRev Update Site on page 7 
and Installing Eclipse Plug-in for AccuRev on page 7 to install the latest version.

Uninstalling Eclipse Plug-in for AccuRev

1. In the IDE, select Help > Software Updates from the Eclipse menu and go to the Installed 
Software tab on the Software Updates and Add-ons window that appears.

2. Highlight the Eclipse Plug-in for AccuRev entry.

3. Click the Uninstall... button. 

Note: If this button is disabled, you manually installed an earlier version of Eclipse Plug-in. 
Instead of using this procedure, shut down the Eclipse IDE, then search for and delete files and 
folders in your Eclipse installation directory that start with com.accurev.eclipse.

4. When the Uninstall window appears, verify that you want to uninstall the checked items, and 
click Finish to uninstall the plug-in.

Installing on Eclipse 3.3

Use the procedures described in this section to add the AccuRev update site to the Eclipse repository 
and to install Eclipse Plug-in.

Adding the AccuRev Update Site

AccuRev provides the standard plug-in installation method for the Eclipse IDE via an update site. If 
you require offline or local network access to an update site for installing the plug-in, see the section 
titled Setting Up a Local Update Site on page 10.

Otherwise, follow this procedure to add the update site to the list of sites that Eclipse can contact:

1. Start the Eclipse IDE.

2. Select Help > Software Updates > Find and Install from the Eclipse menu.

3. Select Search for new features to install on the dialog that appears, and click Next to proceed.

4. Click New Remote Site.

5. Fill in the Name and URL of the update site on 
the New Update Site dialog, and click OK to 
proceed.

The new update site appears on the list of remote 
sites.

6. Click Finish to update the list of sites and search 
for features available on the new site.
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An Updates dialog will display if there are new plug-ins or features available.

Installing Eclipse Plug-in for AccuRev

To install Eclipse Plug-in after creating the new remote site:

1. Expand the tree on the Updates dialog to show the available software.

2. Select the checkbox next to Eclipse Plug-in for AccuRev and click Next to proceed.

3. Accept the license agreement and click Next. (You may be presented with optional features; 
ignore this prompt and proceed to the next screen. These features are specific to Eclipse 3.4.)

4. Click Finish to install the plug-in.

5. Verify that you want to install an unsigned feature by clicking Install All.

6. Restart the Eclipse IDE to complete the installation.

Verifying the Installation

The AccuRev plug-in will be loaded and enabled automatically when you restart Eclipse. To verify 
successful installation:

1. Start the Eclipse IDE.

2. Select Help > Software Updates > Manage Configuration from the Eclipse menu, then expand 
the entry that indicates the pathname of your Eclipse installation.

3. Verify that an Eclipse Plug-in for AccuRev entry exists in the configuration window.

Updating Eclipse Plug-in for AccuRev

If an older version of Eclipse Plug-in is currently included in your Eclipse configuration, you will need 
to uninstall it and add a new update site as described in Adding the AccuRev Update Site on page 8 to 
install the latest version.

The Updates dialog will display to install the new plug-in. Follow the prompts to finish the 
installation.

Disabling and Uninstalling Eclipse Plug-in for AccuRev

A plugin to Eclipse can be disabled, which prevents the feature from being used, but leaves the feature 
installed on your machine. Once it has been disabled, a plug-in can be uninstalled.

Disabling Eclipse Plug-in for AccuRev

1. Select Help > Software Updates > Manage Configuration from the Eclipse menu, to display the 
Product Configuration window.

2. Expand the entry that indicates the pathname of your Eclipse installation.

3. Select the Eclipse Plug-in for AccuRev subentry.

4. Click the Disable task link, and click OK in the confirmation dialog.

5. Click Yes in the dialog that offers to restart Eclipse.
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Uninstalling Eclipse Plug-in for AccuRev

1. Disable Eclipse Plug-in, as described in Disabling Eclipse Plug-in for AccuRev.

2. Select Help > Software Updates > Manage Configuration from the 
Eclipse menu, to display the Product Configuration window.

3. Click the Show Disabled Features toolbar button.

4. Expand the entry that indicates the pathname of your Eclipse 
installation.

5. Select the Eclipse Plug-in for AccuRev subentry.

6. Click the Uninstall task link, and click OK in the confirmation dialog.

7. Click Yes in the dialog that offers to restart Eclipse.

Setting Up a Local Update Site

If your organization’s IT policies do not allow regular Eclipse plug-in updates using a remote update 
site, you can create an update site on your local network instead. 

To create a local update site:

1. Create a directory on a locally accessible machine called eclipseupdate.

2. Using a Web browser, access the Eclipse Plug-in update site: 

http://www.accurev.com/download/eclipseupdate 

3. Download the update-site.zip and site.xml files to the local eclipseupdate directory you created.

4. Navigate to the local eclipseupdate directory and extract the ZIP file contents.

5. Distribute the location of the eclipseupdate directory to Eclipse users in your organization. When 
they define a new update site, they will enter the location of the eclipseupdate directory rather 
than the AccuRev URL. (Eclipse 3.3 users must specify a New Local Site.)

Configuring Access to the AccuRev Web Interface

Version 2010.1 and later of Eclipse Plug-in provides access to the AccuRev Web Interface (Web UI). 
This section describes how to configure the AccuRev Web UI to work with Eclipse.

Features Available through the Web UI

When you configure access to the AccuRev Web UI, you make the following features available to 
your users:

• Version Browser

• StreamBrowser™

• Annotate

• Create New Issue

• Open Issue Queries
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Before You Begin

Before performing the configuration procedure, obtain the URL used to access the Web UI. For 
example, http://localhost:8080/accurev. You will need this URL to complete the configuration 
procedure.

How to Configure the AccuRev Web UI

To configure the AccuRev Web UI to work with Eclipse, you need to modify the AccuRev Server 
settings.xml file as described in the following procedure:

1. Shut down Eclipse.

2. Create a file called settings.xml and add these lines:

<settings>

<webui url="http://webui-host:port/accurev"/>

</settings>

Where webui-host:port is the server name and port of the server hosting the AccuRev 
Web UI — localhost:8080, for example.

3. On the AccuRev Server, save settings.xml in the storage\site_slice\dispatch\config directory 
where you installed AccuRev.

4. If you are using AccuRev replica servers, create and save settings.xml to the 
storage\site_slice\dispatch\config directories on those machines as well.

5. Restart Eclipse.

Several new buttons appear on the AccuRev perspective toolbar as shown in the following 
illustration:

The highlighted groups of buttons are for features that are accessible only after access to the 
Web UI has been configured:

• Version Browser

• Annotate

• Open the Web UI

• Open the StreamBrowser™

• Create New Issue
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• Open Issue Queries

6. Click the Open Web UI button to start the AccuRev Web UI within the Eclipse framework. 

Note: If you are not already logged in to AccuRev, you are prompted to do so. See Logging In to 
AccuRev in the Eclipse Plug-in for AccuRev User’s Guide for more information.

Adding AccuRev Executables to the PATH (Mac OS X 

Only)

To ensure that all AccuRev executables are on your system’s PATH, create the following files as 
"sudo":

• /etc/paths.d/AccuRev: 

sudo echo "/Applications/AccuRev/bin" > /etc/paths.d/AccuRev

• /etc/paths.d/Acdiffgui: 

sudo echo "/Applications/AccuRev/bin/acdiffgui.app/Contents/MacOS" > 
/etc/paths.d/Acdiffgui

• /etc/paths.d/Acgui:

sudo echo "/Applications/AccuRev/bin/acgui.app/Contents/MacOS" > /etc/paths.d/Acgui

Enabling the AccuRev Diff Tool to Work as a 

Standalone (Mac OS X Only)

To enable the AccuRev diff GUI tool (acdiffgui) to work stand-alone as well as from an IDE 
integration such as Eclipse, do the following:

1. Make a backup copy of acdiffgui:

cd /Applications/AccuRev/bin/acdiffgui.app/Contents/MacOS

mv acdiffgui acdiffgui.orig

2. Create a new acdiffgui file with the following content:

#!/usr/bin/perl

$cmd = "java -Duser.dir=/Applications/AccuRev/bin -Xms32M -Xmx512M 
-classpath \"/Applications/AccuRev/bin/oro.jar:/Applications/AccuRev/bin/
xercesImpl.jar:/Applications/AccuRev/bin/xml-apis.jar:/Applications/
AccuRev/bin/fw.jar:/Applications/AccuRev/bin/werken.opt.jar:/Applications/
AccuRev/bin/diff.jar\" diff.DiffApp ";

foreach $arg(@ARGV){

 $cmd .= "\"$arg\" ";

}

system ($cmd);

3. Close any shells.

4. Open a new shell.

Running acdiffgui should now bring up the AccuRev graphical diff tool, and it should also work 
from within any integrated IDE.
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The AccuRev Diff Tool Must be on Your PATH (Linux/

Unix Only) 

The Merge and Diff Against commands in the AccuRev perspective rely on access to the acdiffgui 
executable (which is part of the AccuRev product installation). If the acdiffgui executable or a link to 
it is not in your PATH and accessible by the currently logged-in user, these operations will fail silently.
Eclipse Plug-in for AccuRev® Installation and Release Notes 13



14 Eclipse Plug-in for AccuRev® Installation and Release 



3. Release Notes

This chapter describes the changes to Eclipse Plug-in for AccuRev (Eclipse Plug-in) in version 2012.1, 
as well as the two previous Eclipse Plug-in releases.

Version 2012.1

This section describes changes to Eclipse Plug-in version 2012.1.

820— Checkout from AccuRev available from File>Import menu choice

The File > Import menu choice now opens a wizard to allow you to easily import existing 
Eclipse projects into new AccuRev workspaces. With File > Import, you are able to create a new 
workspace and associate the Eclipse projects with AccuRev as you progress through the wizard 
pages. 

21871 — Support for login sessions on different servers

In previous releases, logging in to one AccuRev server would disable access to projects on the 
AccuRev server to which you had previously been logged in. Eclipse Plug-in now supports login 
sessions, which allows you log in to multiple AccuRev servers. 

23484 — AccuRev search not refreshed after a Delete operation

If you executed an AccuRev Search (Team > AccuRev Searches) operation and then executed 
Delete operation on one of the files in the result, the AccuRev Search/Status tab was not 
refreshed to reflect the Delete operation. This problem has been corrected in the current release.

23485 — AccuRev toolbar not always correctly refreshed

In previous releases, there were several cases in which the availability of toolbar buttons did not 
accurately reflect the current state. For example, after creating a new file, AccuRev toolbar 
buttons were disabled; after certain operations, Merge and Promote buttons were incorrectly 
enabled or disabled. This problem has been corrected in the current release.

23495 — Long DBCS file names not merged successfully

In the previous release, changes to a file name composed of a large number (90 or more) double-
byte characters (DBCS) were not merged successfully. This problem has been corrected in the 
current release.

23496 — Text labels suppressed for a file with the same name

If you enabled text labels for AccuRev elements in Eclipse preferences (Window > Preferences > 
Team > AccuRev > Label Decorations), labels were not displayed for files with the same name 
as the label text you specified. This problem has been corrected in the current release.

23501 — Duplicate network errors displayed when Checkout from AccuRev is stopped

In previous releases, AccuRev displayed two network errors if the AccuRev service stopped 
running during a Checkout from AccuRev operation. This problem has been corrected in the 
current release. 
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23502 — AccuRev identified as provider for Eclipse SDK plug-ins

In previous releases, AccuRev was not identified as the provider for several plug-in files for the 
Eclipse SDK. This problem has been corrected in the current release.

23510 — Project Name field obscured values

The Project Name field in the New Project Details dialog box was not always rendered correctly: 
its height was sometimes too narrow, preventing data entered in the field from being completely 
visible. This problem has been corrected in the current release.

23525 — New projects sometimes created with (missing) files

If you created a new Eclipse project using a new or existing AccuRev workspace that had either 
Anchor Required or Exclusive Lock attributes, all the files in the new project had a status of 
(missing). This problem has been corrected in the current release.

23527 — Workspace Information fields reorganized

The Workspace Information fields on the Create New Workspace page of the Checkout from 
AccuRev wizard have been reorganized to simplify the process of specifying a workspace.

23528 — New ignore options for AccuRev Diff tool

You can now specify whether or not you want the AccuRev Diff tool to ignore one or more of the 
following: whitespace, changes in whitespace, and case.

23540 — Checkout Wizard needed for Eclipse plug-in

The Checkout Wizard for creation of Eclipse projects has been redesigned. You can choose to use 
existing .project files or create new .project files for the Eclipse projects. A tree structure makes it 
easy to select streams, workspaces, and files. The Checkout Wizard is available by selecting either 
File > New >Project or File > Import. Projects are automatically shared with AccuRev and 
there is no need to perform a separate step for sharing.

23547 —Synchronize tab not refreshed after an overlapped folder is merged

The AccuRev Synchronize tab within Eclipse was not refreshed after performing a merge in an 
overlapped file. This problem has been corrected in the current release.

23550 —Multi-line comments had extra character appended

New comments added for the Add to Depot, Keep, or Promote functions were displayed with a 
"/" character appended. This problem has been corrected in the current release.

23740 — Null pointer exception when Quick Diff is checked

In previous versions, selecting the Enable quick diff box on the Eclipse Quick Diff Preferences 
page could result in an error when the following events occurred:

1. The user logged onto AccuRev "server_1" through the Eclipse Plug-in.

2. There was a shared-with-AccuRev project in Eclipse.

3. The user logged onto AccuRev "server_2" through the AccuRev GUI, and then 

4. The user attempted to open one of the files from AccuRev "server_1" through the Eclipse 
Plug-in. 

This problem has been corrected in the current release.
16 Eclipse Plug-in for AccuRev® Installation and Release 



Version 2011.3

This section describes changes to Eclipse Plug-in version 2011.3.

19045 — Files not marked as missing in Synchronize view after parent folder is deleted

In the previous release, files in a hierarchy of folders were not displayed in the Synchronize view if 
the parent folder was deleted and then populated: when the Synchronize view was refreshed using 
the Tree presentation, the file should have appeared and been marked Missing. This problem has 
been corrected in the current release.

20473 — Promote command is now recursive

The Promote command now recursively searches the currently selected folder for all pending and 
external elements. Pending elements are automatically selected for promote; you can choose 
which, if any, external elements you want to promote. Element information includes name, 
project, and status in sortable columns.

20508 — Add and Keep commands now recurse automatically

The Add and Keep commands now recursively search the currently selected folder for all pending 
and external elements; the command is performed automatically on any files in the tree of the 
selected folder.

21548 — Web UI URL error message improved

In previous releases, Eclipse Plug-in did not always notify the user if the URL for the Web UI was 
specified incorrectly. This problem has been corrected in the current release.

22370 — Show Properties button added to the AccuRev toolbar

The Show Properties button has been added to the AccuRev toolbar. Clicking the button displays 
the Properties dialog box for the selected element.

22484 — Decorations for elink element now refreshed 

In previous releases, Eclipse Plug-in did not always refresh label decorations for elink elements. 
This problem has been corrected in the current release.

22724 — Renaming nested projects caused Eclipse Plug-in to hang

In previous releases, if you renamed Java projects created in nested AccuRev workspaces one after 
another without waiting for the first update operation to finish, the Updating statuses... process 
would sometimes hang. This problem has been corrected in the current release.

22792 — Null pointer exception during operations on deleted or renamed project

In previous releases, Eclipse Plug-in would throw a null pointer exception if you renamed or 
deleted a project while a Merge operation was being executed on that project. This problem has 
been corrected in the current release.

22945 — Support for Eclipse 3.7 (Indigo)

Eclipse Plug-in for AccuRev now supports Eclipse 3.7 (Indigo). However, AccuRev recommends 
that you use Eclipse Plug-in for AccuRev with Eclipse 3.7 (Helios) due to known performance 
issues associated with managing large projects in Eclipse 3.7.
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22966 — No Synchronize results when project folder specified as output folder

In the previous release, the Synchronize view was empty following the Synchronize operation 
(Team > Synchronize with AccuRev Repository) if the project folder was set as the default 
output folder. This problem has been corrected in the current release.

22973 — Duplicate elements removed from .tmp file created for files command

In the previous release, elements in the .tmp file created by the files command were duplicated 
when a change was made to a file in a nested project within the same eclipse workspace. This 
problem has been corrected in the current release.

23020 — Quick Diff supports AccuRev basis version

You can now specify the AccuRev basis version as the reference source for the Eclipse Quick Diff 
(Window > Preferences > General > Editors > Text Editors > Quick Diff).

23027 — Merge message formatting corrected

In previous releases, the merge message displayed for binary files sometimes displayed some 
formatting irregularities which made the message difficult to read. This problem has been 
corrected in the current release.

23052 — Error shown when keeping stranded elements

In previous releases, AccuRev did not always display an error message when performing a Keep 
operation on folder that contained one or more stranded elements. This problem has been 
corrected in the current release.

23053 — Top-level project context menus simplified

In previous releases, the context menu for a project created on the top level of an AccuRev 
workspace included several choices that were not applicable: Populate, Revert to Most Recent 
Version, and Copy as Link. These choices are no longer included in the context menu at this level.

23083 — Duplicate file command for Revert operations

In previous releases, a duplicate file command was displayed in the log for the project at the top 
level of the AccuRev workspace containing the reverted file. This problem has been corrected in 
the current release.

23151 — Editing UML no longer requires anchoring the file

In previous releases, AccuRev incorrectly determined that files associated with UML projects 
(like .emx, for example) were read-only in serial development mode and required you to anchor 
the file before you could edit it. This problem has been corrected in the current release.

23168 — Merge on Deep Overlap files stopped working

In the previous release, Eclipse Plug-in could not successfully perform the Merge operation on 
Deep Overlap files. This problem has been corrected in the current release.

23180 — Share existing projects with AccuRev

A new feature allows you to place an existing Eclipse project under AccuRev control by creating a 
new AccuRev workspace. Eclipse project files are placed in the depot and stream you specify; you 
can optionally promote these files when the workspace is created.
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23332 — New way to specify project settings

During project creation, you can now indicate whether you want to specify settings for the new 
project type (Java, CVS, General, and so on) manually, using the wizard; or whether you want to 
use settings specified in an existing Eclipse .project file.

23336 — Merge operation failed in IBM RAD

In the previous release, the Merge operation failed when using Eclipse Plug-in with IBM Rational 
Application Developer (RAD). This problem has been corrected in the current release.

Version 2011.2

This section describes changes to Eclipse Plug-in for AccuRev version 2011.2.

21313 — New projects created in an AccuRev workspace

In previous releases, Eclipse Plug-in would not allow you to create a new Eclipse project in an 
AccuRev workspace if the AccuRev workspace was created within the currently opened Eclipse 
workspace. This problem has been corrected in the current release.

21364 — Support for Wind River Workbench

You can install Eclipse Plug-in in Wind River Workbench. Note that Wind River is based on 
Eclipse C/C++ Development Tooling (CDT). Because of this, you must first install Eclipse Java 
Development Tools (JDT) 3.6.1 or later in Wind River Workbench before you can successfully 
install Eclipse Plug-in. See Installing on Eclipse C/C++ Development Tooling (CDT) Installations on 
page 5 and Installing on Wind River Workbench on page 6 for more information.

21371 — Error message when logging in to other AccuRev servers

In previous releases, Eclipse Plug-in would allow you to create a project associated with the 
default AccuRev server and share it. When prompted to log in to the default server, AccuRev 
would not warn you if you instead logged in to a different AccuRev server. This problem has been 
corrected in the current release.

21372 — Pending Search tab not updated correctly

In the previous release, nested projects remained displayed on the Pending Search tab even after 
the parent project was unshared. This problem has been corrected in the current release.

21376 — Merge functionality added for overlapping element and symbolic links

Eclipse Plug-in now displays a dialog box that helps you resolve overlapping element links and 
symbolic links exposed by a Merge operation.

21469 — Symbolic link and element link operations added to AccuRev Synchronize view

The Team menu in the Synchronize view now has Copy as Link and Paste as Link choices that 
allow you to create element links and symbolic links for AccuRev files.

21500 — Target Pathname added to file Properties dialog box

The Target Pathname has been added to the Properties dialog box for link and target element 
names.

21501 — Show Properties added to AccuRev Search/Status and Navigator Team menus

A Show Properties choice has been added to the Team menus in the AccuRev Search/Status 
view and Navigator view. This displays the Properties dialog box, which provides information 
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about the currently selected file including path name, element type and element ID, version, and 
status. 

21615 — Refresh performance improved

In previous releases, performance would sometimes appear to be sluggish when refreshing a view. 
with numerous elements. This problem has been corrected in the current release.

21633 — Properties dialog box displays correct icon

The Properties dialog box now displays the AccuRev icon. This dialog box showed a generic icon 
in previous releases. 

21657 — Adding existing project to an existing workspace simplified

The process for adding an existing Eclipse project to an existing AccuRev workspace has been 
simplified. During import, you can now choose to use the existing Eclipse project, rather than 
importing and then sharing the project, as was the case in previous releases.

21817 — Keep dialog box redraws correctly

In the previous release, if you clicked the Advanced button on the Keep dialog box, the dialog box 
did not always redraw correctly when you clicked the Basics button to hide the advanced settings. 
This issue has been corrected in the current release.

21818 — Support for IBM RAD 7.5

Eclipse Plug-in supports IBM Rational Application Developer (RAD) 7.5.x. RAD 7.5.x is also 
supported by Eclipse Plug-in 2011.1.

21821 —Clipboard retains copied links after failed paste operation

In the previous release, element links and symbolic links copied to the clipboard did not remain 
on the clipboard if the paste operation failed. This issue has been corrected in the current release.

21822 — Warn when creating patches with the same name

Eclipse Plug-in now displays a warning when you create a patch with the same name as an 
existing patch.

21870 — Warnings mistakenly written to log

In the previous release, Eclipse Plug-in mistakenly wrote warnings to the log when starting 
Eclipse after installing Eclipse Plug-in. This issue has been addressed in the current Eclipse Plug-
in release.

21963 — Creation of a symbolic link from a folder

In the previous release, Eclipse Plug-in did not successfully create symbolic links on project 
folders. This problem has been corrected in the current release.

21969 — Typographical error corrected

During search operations, the status message displayed "Search elements". This message has been 
changed to "Searching elements" in the current release.

22093 — Copy as Link/Paste as Link errors in Synchronize view

In the previous release, Eclipse Plug-in exhibited unexpected behavior when performing Copy as 
Link/Paste as link on files in the Synchronize view: decorators were not created for modified 
elements, and duplicate files were created. These problems have been corrected in the current 
release.
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22157 —Merge, Diff Against operations fail when full path is specified

In previous releases, the Merge and Diff Against operations would fail when the full path to the 
AccuRev CLI was specified on the AccuRev page of the Preferences dialog box (Window > 
Preferences > Team > AccuRev). This problem has been corrected in the current release.

22661 — Updating multiple projects from different AccuRev workspaces

You can now update multiple projects from different AccuRev workspaces. In addition, the log 
has been enhanced to include individual messages for each workspace that is updated; messages 
are identified using the workspace name.

22262 — Improved Import project creation

The process of importing a project from an AccuRev workspace has been simplified.

22496 – Full support for third-party Diff and Merge tools

You can now fully specify third-party Diff and Merge tools on the AccuRev panel of the 
Preferences dialog box (Window > Preferences > Team > AccuRev). Available command 
parameters are identified, and a read-only version of the command line you create is displayed so 
you can verify it before running it.

22528 —(Japanese version only) Merge operation failed with non-ASCII character sets

The Merge operation failed with files using non-ASCII encoding (such as UTF-8 or EUCJP). 
This problem has been corrected in the current release.

22589 — Merge operation fails with multibyte character file names

In the previous release, the Merge operation failed on files that used multibyte characters in their 
file names. This problem has been corrected in the current release.

22646 — Issues using Flex Builder 4 and Eclipse IDE with AccuRev

In the previous release, some Flex Builder 4 and Eclipse IDE users experienced these problems 
with AccuRev:

• Flex Builder 4 and Eclipse projects could not be shared with the AccuRev repository.

• In Flex Builder 4, Icons indicating a shared project did not always appear as expected.

• In Flex Builder 4, Merge, Revert, and Promote operations did not always succeed.

These issues have been corrected in the current release.

22695 — Anchor fails on anchor-required workspace

The anchor command would sometimes fail on elements in an anchor-required workspace, 
displaying a No elements selected error message even if one or more elements had been selected in 
the Anchor dialog box. This issue has been corrected in the current release.
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