Integrating with Microsoft® Visual Studio® Team System

For Borland® CaliberRM™ Users
Getting Started

Borland CaliberRM for Visual Studio Team System ................................................................. 8
System Requirements and Prerequisites .................................................................................. 11
Enabling the Visual Studio Team System Integration on Your CaliberRM Server ...................... 12
Concepts

Concepts
Visual Studio Team System Work Items and Tests ................................................................. 16
Requirement Traceability ....................................................................................................... 18
Procedures

Working with Visual Studio Team System Tests ................................................................. 21
  Browsing Lists of Tests in a Visual Studio Team System Project ........................................ 22
  Connecting to a Team Foundation Server ........................................................................ 23
  Creating a Trace Between a Requirement and a Visual Studio Team System Test .......... 24
  Determining Visual Studio Team System Test Status ...................................................... 25
  Reporting on Traceability Between Requirements and Visual Studio Team System Tests ... 26
  Viewing Visual Studio Team System Test Results ............................................................ 27
  Viewing Visual Studio Team System Tests in the Traceability Diagram ............................. 28
  Viewing Visual Studio Team System Tests in the Traceability Matrix ............................... 29

Working with Visual Studio Team System Work Items ....................................................... 30
  Browsing Lists of Work Items in a Visual Studio Team System Project ............................. 31
  Connecting to a Team Foundation Server ........................................................................ 32
  Creating a Visual Studio Team System Work Item .......................................................... 33
  Creating a Trace Between a Requirement and a Visual Studio Team System Work Item .... 34
  Reporting on Traceability Between Requirements and Visual Studio Team System Work Items ... 35
  Viewing Visual Studio Team System Work Items in the Traceability Diagram ................... 36
  Viewing Visual Studio Team System Work Items in the Traceability Matrix ..................... 37
  Viewing Individual Visual Studio Team System Work Item Details .................................. 38
Getting Started
Getting Started

The topics in this section are designed to help you understand and begin using the CaliberRM for Visual Studio Team System — Traceability Add-ins easily and quickly.

In This Section

- **Borland CaliberRM for Visual Studio Team System**
  This section provides information about the integration between Visual Studio Team System and CaliberRM.

- **System Requirements and Prerequisites**
  This section provides information about the system requirements and prerequisites of the CaliberRM for Visual Studio Team System — Traceability Add-ins component.

- **Enabling the Visual Studio Team System Integration on Your CaliberRM Server**
  This section describes how to enable the integration with Visual Studio Team System.
Borland CaliberRM for Visual Studio Team System

CaliberRM for Visual Studio Team System integrates Visual Studio Team System with Borland CaliberRM, the leader in requirements management. This integration provides Visual Studio Team System users (architects, developers, testers) visibility into the latest requirements. It provides CaliberRM users (analysts) visibility into Visual Studio Team System work items and tests, and the ability to include Visual Studio Team System work items and tests into traceability reports.

About CaliberRM for Visual Studio Team System

CaliberRM for Visual Studio Team System complements Visual Studio Team System with a fully featured Requirement Management solution. CaliberRM for Visual Studio Team System is designed to work within the Visual Studio Team Foundation Server infrastructure, maximizing the contribution of the analyst within the development process and enabling all stakeholders to collaborate more effectively.

Whether you use Microsoft’s MSF process templates or a custom process template, a key component of the process template should be a clear definition of the project goals and the capability to manage those goals throughout the project lifecycle. Designed to capture and manage business, technical, functional, and operational requirements, Borland CaliberRM enables this clear definition so that projects are delivered on time, within budget, and to specification.

Using Borland CaliberRM for Visual Studio Team System, teams using Team System projects can gain visibility to the requirements that are driving the project—without leaving their environment. You can enable any new or existing Team Projects for CaliberRM Requirements Management—irrespective of the underlying process template.

Features by Role

<table>
<thead>
<tr>
<th>CaliberRM Analyst</th>
<th>Visual Studio Team System Developer</th>
<th>Tester</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Create, Organize, Filter, Compare, and Prioritize Requirements</td>
<td>• View Requirements (minimal requirement creation is available)</td>
<td>• View Requirements (minimal requirement creation is available)</td>
</tr>
<tr>
<td>• Create Requirement Reports</td>
<td>• Edit Requirements</td>
<td>• Edit Requirements</td>
</tr>
<tr>
<td>• Define Glossary Terms Used in Requirement Descriptions</td>
<td>• View Baselines</td>
<td>• View Baselines</td>
</tr>
<tr>
<td>• Create, View, Approve, and Compare Baselines</td>
<td>• Create Traces Between Work Items and Requirements</td>
<td>• Create Traces Between Work Items and Requirements</td>
</tr>
<tr>
<td>• Create, View, and Assess Traces</td>
<td>• Participate in Requirement Discussions</td>
<td>• Participate in Requirement Discussions</td>
</tr>
<tr>
<td>• Participate in Requirement Discussions</td>
<td></td>
<td>• View Requirements (minimal requirement creation is available)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Edit Requirements</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• View Baselines</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Create Traces Between Work Items and Requirements</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Participate in Requirement Discussions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• View and Edit Validation Procedures</td>
</tr>
</tbody>
</table>

About the Integration

CaliberRM for Visual Studio Team System consists of the three components:

Product components
<table>
<thead>
<tr>
<th>Component title</th>
<th>Component group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CaliberRM For Team Foundation Server</td>
<td>Server</td>
<td>This is a server component. It installs in the Microsoft Team Foundation Server the necessary server components for the Microsoft Visual Studio Team System integration to CaliberRM.</td>
</tr>
<tr>
<td>CaliberRM Client For Visual Studio Team System</td>
<td>Client</td>
<td>This client component integrates into Microsoft Visual Studio Team System. It enables you to access CaliberRM requirements in Team Explorer. This component includes Traceability Add-ins.</td>
</tr>
<tr>
<td>CaliberRM for Visual Studio Team System — Traceability Add-ins</td>
<td>Client</td>
<td>This client component enables you to manage traceability to VSTS Tests and VSTS Work Items from the standalone CaliberRM client. This component is designed especially for analysts. For more information about the CaliberRM client, please consult the CaliberRM User Guide. This component is always installed together with CaliberRM Client For Visual Studio Team System, but you can install it separately as well.</td>
</tr>
</tbody>
</table>

Each of these components has a separate installer.

Which components you need to install depends on your role. The general configuration can include single or dual server computers. See two diagrams below. They illustrate typical single and dual server configurations.
You can also install Borland CaliberRM Server on the same computer with Microsoft Team Foundation Server, or with Microsoft SQL Server.


Related Concepts

- Requirement Traceability
- Visual Studio Team System Work Items and Tests

Related Procedures

- Enabling the Visual Studio Team System Integration on Your CaliberRM Server

Related Reference

- About Microsoft Visual Studio Team System
System Requirements and Prerequisites

The **CaliberRM for Visual Studio Team System — Traceability Add-ins** component of CaliberRM for Visual Studio Team System requires the following software tools available on the same computer:

- Borland CaliberRM Client
- Microsoft Visual Studio Team Explorer (a component of Microsoft Visual Studio Team Foundation Server)

**Note:** For RAM, processor, hard disk space, and OS requirements, please refer to Microsoft system requirements (see the link below).

**Related Concepts**

- Borland CaliberRM for Visual Studio Team System

**Related Reference**

- Microsoft Visual Studio System Requirements
Enabling the Visual Studio Team System Integration on Your CaliberRM Server

Follow the steps below to enable the integration with Visual Studio Team System objects for separate projects on the CaliberRM server.

To enable the integration with Visual Studio Team System objects

1. In the CaliberRM Framework Administrator, choose View ▶ Projects.
2. Select the project to enable the integration with Visual Studio Team System in.
3. Click the External Traceability tab.
4. Click New.... The New Integration dialog box opens.

To enable the integration with Visual Studio Team System work items

1. In the Vendor Name: field, type VSTS Work Items.
   
   **Note:** You can type any text string in the Vendor Name: field. The string is used as a tab name in the CaliberRM client. For the purposes of this documentation, VSTS Work Items is used to refer to the tab.

2. In the Library Name: field, type VSTS.
3. Click Change Icon... and select the icon to associate with the integration.
4. Click OK.
5. Select VSTS Work Items from the Disabled list on the External Traceability tab.
6. Click the Move Left button to add VSTS Work Items to the Enabled list.
7. Choose File ▶ Save Changes from the main menu to save the information. To cancel the changes, choose Edit ▶ Cancel Changes from the main menu.

To enable the integration with Visual Studio Team System tests

1. In the Vendor Name: field, type VSTS Tests.
   
   **Note:** You can type any text string in the Vendor Name: field. The string is used as a tab name in the CaliberRM client. For the purposes of this documentation, VSTS Tests is used to refer to the tab.

2. In the Library Name: field, type VSTSTests.
   
   **Note:** Do not use spaces in the library name.

3. Click Change Icon... and select the icon to associate with the integration.
4. Click OK.
5. Select VSTS Tests from the Disabled list on the External Traceability tab.
6. Click the Move Left button to add VSTS Tests to the Enabled list.
7. Choose File ▶ Save Changes from the main menu to save the information. To cancel the changes, choose Edit ▶ Cancel Changes from the main menu.
Note: To enable the integration with Visual Studio Team System objects for another project on the server, move VSTS Work Items and VSTS Tests from the Disabled list to the Enabled list on the External Traceability tab.

Related Concepts
- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures
- Creating a Trace Between a Requirement and a Visual Studio Team System Work Item
- Creating a Trace Between a Requirement and a Visual Studio Team System Test
Concepts
Concepts

This section provides detailed information about Visual Studio Team System artifacts and requirement traceability.

In This Section

- Visual Studio Team System Work Items and Tests
  This section provides brief information about Visual Studio Team System tests and work items.

- Requirement Traceability
  This section provides information about requirement traceability.
Visual Studio Team System Work Items and Tests

CaliberRM for Visual Studio Team System provides connectivity of CaliberRM requirements with the following Visual Studio Team System artifacts:

- Work items
- Tests

Work Items

A work item is a unit of work assigned to a user in the Team Foundation Server to track the assignment and state of work. The types are: bug, quality of service requirement, risk, scenario, and task.

You can display the work items associated with a requirement on the Traceability tab of the requirement.

Analysts can perform the following actions with work items:

- Analysts can create a work item to fulfill a specific requirement by tracing an existing requirement to a new work item
- Analysts can view the requirements to work items coverage using traceability matrices
- Analysts can determine which work items are impacted by requirement change
- Analysts can set the work item discipline to "requirements"
- Analysts can schedule a work item to a specific iteration
- Analysts can assign work items to users
- Analysts can attach files to work items
- Analysts can fill in a work item description


Tests

A test is a program, a script (manual or automated), a specific set of steps, or general instructions that you can run repeatedly against software, and that will yield a test result such as pass, fail, or other results that finally can resolve to pass or fail. The types are: generic test, unit test, load test, web test, and so on. You can work with tests after you create a code project, build it and put it under version control.

Tip: Do not forget to add your tests to test lists.

You can display the tests associated with a requirement on the Traceability tab of the requirement.

Please consult the documentation for Microsoft Visual Studio Team System for further information about work items, tests, and Team Foundation Server.

Analysts can perform the following actions with tests:

- Analysts can view the requirements to tests coverage using traceability matrices
- Analysts can determine which tests are impacted by requirement change
- Analysts can view current test results
- Analysts can view the history of test results in all builds

Related Concepts
Borland CaliberRM for Visual Studio Team System

Related Procedures
Working with Visual Studio Team System Work Items
Working with Visual Studio Team System Tests

Related Reference
About Microsoft Visual Studio Team System
Requirement Traceability

The traceability feature allows you to create and track relationships between requirements and other related development and testing information in your Visual Studio Team System team project. These relationships are called "traces" in CaliberRM. You can view them on the Traceability tab.

Changing an object, whether it is a requirement, a test step, or a section of source code, can potentially require changes in other elements of the project. Connecting related objects together helps to ensure that changes are implemented correctly at all levels.

Requirements can trace to or from

- Another requirement in the same CaliberRM project or across projects on the same CaliberRM Server
- A work item in Visual Studio Team System projects
- A test in Visual Studio Team System projects
- An object supported by custom vendor add-in modules

When you create a trace, CaliberRM for Visual Studio Team System automatically creates traces to other requirements that can be affected. For example, if there are direct traces between a software requirement and an interface requirement, and between the interface requirement and a coding requirement, there is also an implied trace between the software requirement and the coding requirement.

When you change a requirement, traces to other objects become suspect. Suspect traces are an indicator that other objects can be affected by the changed requirement and you should review them.

**Note:** For more information on requirement traceability, refer to the CaliberRM User Guide.

Related Concepts

- Visual Studio Team System Work Items and Tests
- Borland CaliberRM for Visual Studio Team System

Related Procedures

- Creating a Trace Between a Requirement and a Visual Studio Team System Test
- Creating a Trace Between a Requirement and a Visual Studio Team System Work Item
Procedures
Procedures

This section provides how-to information for users of the CaliberRM for Visual Studio Team System — Traceability Add-ins.

In This Section

- Working with Visual Studio Team System Tests
  This section provides information about performing tasks with Visual Studio Team System tests from CaliberRM.

- Working with Visual Studio Team System Work Items
  This section provides information about performing tasks with Visual Studio Team System work items from CaliberRM.
Working with Visual Studio Team System Tests

This section provides information about performing tasks with Visual Studio Team System tests from CaliberRM.

In This Section

- **Browsing Lists of Tests in a Visual Studio Team System Project**
  This section describes how to browse lists of tests in a Visual Studio Team System project.

- **Connecting to a Team Foundation Server**
  This section describes how to connect to a Team Foundation Server while working with Visual Studio Team System artifacts.

- **Creating a Trace Between a Requirement and a Visual Studio Team System Test**
  This section describes how to create a trace between a requirement and a Visual Studio Team System test.

- **Determining Visual Studio Team System Test Status**
  This section describes how to determine Visual Studio Team System test status.

- **Reporting on Traceability Between Requirements and Visual Studio Team System Tests**
  This section describes how to report on traceability between requirements and Visual Studio Team System tests.

- **Viewing Visual Studio Team System Test Results**
  This section describes how to view results of Visual Studio Team System tests.

- **Viewing Visual Studio Team System Tests in the Traceability Diagram**
  This section describes how to view Visual Studio Team System tests in the Traceability Diagram.

- **Viewing Visual Studio Team System Tests in the Traceability Matrix**
  This section describes how to view Visual Studio Team System tests in the Traceability Matrix.
**Browsing Lists of Tests in a Visual Studio Team System Project**

**Note:** For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System tests is called **VSTS Tests**.

**To browse lists of tests in a Visual Studio Team System project**

1. Select a CaliberRM requirement.
2. Click the **Traceability** tab.
3. Click the **Modify...** button. The **Traceability Modification** window opens.
4. Click the **VSTS Tests** tab. A list of associated Visual Studio Team System project tests opens.

**Note:** If you have not yet established a connection to the Microsoft Team Foundation Server, the **Connect to Team Foundation Server** dialog box opens. See **Related Procedures** below.

**Related Concepts**
- Visual Studio Team System Work Items and Tests
- Requirement Traceability

**Related Procedures**
- Enabling the Visual Studio Team System Integration on Your CaliberRM Server
- Connecting to a Team Foundation Server
- Viewing Visual Studio Team System Test Results
- Determining Visual Studio Team System Test Status
Connecting to a Team Foundation Server

Performing tasks with Visual Studio Team System work items and tests requires connection to the Microsoft Team Foundation Server. If you have not yet established a connection to the Microsoft Team Foundation Server, the Connect to Team Foundation Server dialog box opens.

**To connect to a Team Foundation Server**

1. Select the required server from the drop-down list in the Connect to Team Foundation Server dialog box.

   **Note:** If the drop-down server list is empty or does not contain the required server, you need to add the server to the list manually. See To add a Microsoft Team Foundation Server to the drop-down list below.

2. Check the check box of the project to connect to.

   **Note:** You can select only one project at a time.

3. Click OK.

**To add a Microsoft Team Foundation Server to the drop-down list**

1. Click the Servers button. The Add/Remove Team Foundation Server dialog box opens.

2. Click the Add button. The Add Team Foundation Server dialog box opens.

3. Specify your Team Foundation **Server name**, **port number**, and **protocol**.

4. Click OK. This populates your **Team Foundation Server list** with your Team Foundation Server name and URL.

5. Click the Close button. The Add Team Foundation Server dialog box closes and the list of Team projects on your Team Foundation Server opens in the Connect to Team Foundation Server.

**Related Concepts**

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

**Related Procedures**

- Browsing Lists of Work Items in a Visual Studio Team System Project
- Creating a Trace Between a Requirement and a Visual Studio Team System Work Item
- Viewing Individual Visual Studio Team System Work Item Details
- Browsing Lists of Tests in a Visual Studio Team System Project
- Creating a Trace Between a Requirement and a Visual Studio Team System Test
- Viewing Visual Studio Team System Test Results
Creating a Trace Between a Requirement and a Visual Studio Team System Test

Note: For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System tests is called **VSTS Tests**.

To establish a trace between a requirement and a Visual Studio Team System test

1. Select the CaliberRM requirement to trace with a Visual Studio Team System test.
2. Click the **Traceability** tab.
3. Click the **Modify...** button.
4. Click the **VSTS Tests** tab. A list of available tests opens.

   **Note:** If you have not yet established a connection to the Microsoft Team Foundation Server, the **Connect to Team Foundation Server** dialog box opens. See **Related Procedures** below.

5. Select the test to establish a trace with. Choose **Trace** ▶ **Trace To** or **Trace** ▶ **Trace From** to add a trace to or from the test.

6. Choose **Trace** ▶ **Save Changes** to save the trace.

   **Note:** The **Enter a Comment** dialog box opens. Enter a comment and click **OK**, or click **Cancel** if a comment is not required. Select the **Do not show this dialog box again** check box if you do not want this dialog box to appear when you save changes to traces.

7. Close the **Traceability Modification** window.

Related Concepts

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures

- Enabling the Visual Studio Team System Integration on Your CaliberRM Server
- Browsing Lists of Tests in a Visual Studio Team System Project
- Connecting to a Team Foundation Server
Determining Visual Studio Team System Test Status

You can view Visual Studio Team System test status in the following CaliberRM client components:

- On the requirement **Traceability** tab
- In the **Traceability Modification** dialog box
- In the **Traceability Matrix**
- In the **Traceability Diagram**

To determine a Visual Studio Team System test status

1. Open one of the CaliberRM client components listed above. For details, refer to **Related Procedures** below.
2. Navigate to the Visual Studio Team System test that you want to determine the status of. CaliberRM displays an icon next to the test name. The icon changes to reflect the test status:

   - ![Folder Icon] — if the test has not been run yet
   - ![Checkmark Icon] — if the test has passed in the latest build
   - ![X Icon] — if the test has failed in the latest build

Related Concepts

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures

- Creating a Trace Between a Requirement and a Visual Studio Team System Test
- Browsing Lists of Tests in a Visual Studio Team System Project
- Viewing Visual Studio Team System Tests in the Traceability Diagram
- Viewing Visual Studio Team System Tests in the Traceability Matrix
- Viewing Visual Studio Team System Test Results
Reporting on Traceability Between Requirements and Visual Studio Team System Tests

You can create reports on traceability between requirements and tests using CaliberRM Document Factory and CaliberRM Datamart.


Datamart extracts data from a CaliberRM repository, transforms the data and loads it into a relational database. Microsoft Access, Microsoft SQL Server and Oracle Database Server are supported. To work with the data, you will need a relational database analysis tool, such as Business Objects.

**Note:** You must have Microsoft Office installed to use Document Factory.

To create reports using Document Factory

1. Prepare a Document Factory template. To include traces between requirements and Visual Studio Team System tests into your report, use the <<traces>> keyword or the $BEGIN_TRACES()/$END_TRACES commands with appropriate keywords.
2. Choose Programs ► CaliberRM ► Document Factory from the Windows Start menu or Tools ► Document Factory from the main CaliberRM client menu to run the CaliberRM Document Factory wizard.
3. Follow the instructions on the screen. Document Factory generates the report.

**Note:** For detailed information on running Document Factory, refer to the *CaliberRM User Guide*.

To create reports using Datamart

1. Choose Programs ► CaliberRM ► Datamart Configuration from the Windows Start menu to run the CaliberRM Datamart Configuration Wizard.
2. Follow the instructions on the screen. The Datamart configuration file is created.
3. Run the Datamart Extractor command-line utility specifying the configuration file created in the previous step. The data is extracted into a relational database.

**Note:** For detailed information on running Datamart, refer to the *CaliberRM Datamart User Guide*.

Related Concepts

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures

- Enabling the Visual Studio Team System Integration on Your CaliberRM Server
Viewing Visual Studio Team System Test Results

You can view Visual Studio Team System test results:

- Before a trace is created
- After a trace is created

**Note:** For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System tests is called **VSTS Tests**.

**To view test results before a trace is created**

1. Select a CaliberRM requirement.
2. Click the **Traceability** tab.
3. Click the **Modify...** button.
4. Click the **VSTS Tests** tab. A list of available tests opens.

   **Note:** If you have not yet established a connection to the Microsoft Team Foundation Server, the **Connect to Team Foundation Server** dialog box opens. See **Related Procedures** below.

5. Right-click the test to display the context menu.
6. Choose **Show Test Results...**. This displays the **Results for test:** window.
7. Click the **Close** button when you finish viewing the test results.

**To view test results after a trace is created**

1. Select the CaliberRM requirement that is traced to or from a Visual Studio Team System test.
2. Click the **Traceability** tab. This displays traces to and from this requirement.
3. Select a trace to or from a test.
4. Right-click the trace to display the context menu.
5. Choose **Show Test Results...**. This displays the **Results for test:** window.
6. Click the **Close** button when you finish viewing the test results.

**Note:** You can open the **Results for test:** window from the **Traceability Diagram**. See **Related Procedures** below.

**Related Concepts**

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

**Related Procedures**

- Enabling the Visual Studio Team System Integration on Your CaliberRM Server
- Connecting to a Team Foundation Server
- Browsing Lists of Tests in a Visual Studio Team System Project
- Determining Visual Studio Team System Test Status
- Viewing Visual Studio Team System Tests in the Traceability Diagram
Viewing Visual Studio Team System Tests in the Traceability Diagram

To view Visual Studio Team System tests in the Traceability Diagram

1. Select a CaliberRM requirement that has traces to or from Visual Studio Team System tests.
2. Choose Tools ► Traceability Diagram. The Traceability Diagram displays the CaliberRM requirement with traces to and/or from Visual Studio Team System tests.

Tip: Right-clicking a test and choosing Show Test Results... from the context menu opens the Results for test: window where you can view the results of the test.

Related Concepts
- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures
- Viewing Visual Studio Team System Tests in the Traceability Matrix
- Determining Visual Studio Team System Test Status
- Viewing Visual Studio Team System Test Results
Viewing Visual Studio Team System Tests in the Traceability Matrix

Note: For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System tests is called **VSTS Tests**.

To view Visual Studio Team System tests in the Traceability Matrix

1. Choose **Tools ▶ Traceability Matrix** from the main menu. The **Traceability Matrix** window opens.
2. Choose **View ▶ Filter...** from the **Traceability Matrix** menu. The **Traceability Filter** dialog box opens.
3. Click the **VSTS Tests** tab.
4. Check the **Rows** and/or **Columns** check boxes in the **Show VSTS Tests Objects in:** field.
5. Click **OK**. The **Traceability Matrix** window displays Visual Studio Team System tests.

   **Note:** Right-clicking a test and choosing **Properties** opens the test **Properties** window where you can view the trace details.

Related Concepts

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures

- Enabling the Visual Studio Team System Integration on Your CaliberRM Server
- Viewing Visual Studio Team System Tests in the Traceability Diagram
- Determining Visual Studio Team System Test Status
Working with Visual Studio Team System Work Items

This section provides information about performing tasks with Visual Studio Team System work items from CaliberRM.

In This Section

- **Browsing Lists of Work Items in a Visual Studio Team System Project**
  This section describes how to browse lists of work items in a Visual Studio Team System project.

- **Connecting to a Team Foundation Server**
  This section describes how to connect to a Team Foundation Server while working with Visual Studio Team System artifacts.

- **Creating a Visual Studio Team System Work Item**
  This section describes how to create a Visual Studio Team System work item from the CaliberRM client.

- **Creating a Trace Between a Requirement and a Visual Studio Team System Work Item**
  This section describes how to create a trace between a requirement and a Visual Studio Team System work item.

- **Reporting on Traceability Between Requirements and Visual Studio Team System Work Items**
  This section describes how to report on traceability between requirements and Visual Studio Team System work items.

- **Viewing Visual Studio Team System Work Items in the Traceability Diagram**
  This section describes how to view Visual Studio Team System work items in the Traceability Diagram.

- **Viewing Visual Studio Team System Work Items in the Traceability Matrix**
  This section describes how to view Visual Studio Team System work items in the Traceability Matrix.

- **Viewing Individual Visual Studio Team System Work Item Details**
  This section describes how to view details of individual Visual Studio Team System work items.
Browsing Lists of Work Items in a Visual Studio Team System Project

Note: For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System work items is called VSTS Work Items.

To browse lists of work items in a Visual Studio Team System project

1. Select a CaliberRM requirement.
2. Click the Traceability tab.
3. Click the Modify... button. The Traceability Modification window opens.
4. Click the VSTS Work Items tab. The list of all work items ("All Work Items" Visual Studio query) defined in the Visual Studio Team System project opens.

Note: If you have not yet established a connection to the Microsoft Team Foundation Server, the Connect to Team Foundation Server dialog box opens. See Related Procedures below.

Related Concepts
Visual Studio Team System Work Items and Tests
Requirement Traceability

Related Procedures
Enabling the Visual Studio Team System Integration on Your CaliberRM Server
Viewing Individual Visual Studio Team System Work Item Details
Connecting to a Team Foundation Server
Connecting to a Team Foundation Server

Performing tasks with Visual Studio Team System work items and tests requires connection to the Microsoft Team Foundation Server. If you have not yet established a connection to the Microsoft Team Foundation Server, the Connect to Team Foundation Server dialog box opens.

To connect to a Team Foundation Server

1. Select the required server from the drop-down list in the Connect to Team Foundation Server dialog box.
   
   **Note:** If the drop-down server list is empty or does not contain the required server, you need to add the server to the list manually. See To add a Microsoft Team Foundation Server to the drop-down list below.

2. Check the check box of the project to connect to.
   
   **Note:** You can select only one project at a time.

3. Click OK.

To add a Microsoft Team Foundation Server to the drop-down list

1. Click the Servers button. The Add/Remove Team Foundation Server dialog box opens.
2. Click the Add button. The Add Team Foundation Server dialog box opens.
3. Specify your Team Foundation Server name, port number, and protocol.
4. Click OK. This populates your Team Foundation Server list with your Team Foundation Server name and URL.
5. Click the Close button. The Add Team Foundation Server dialog box closes and the list of Team projects on your Team Foundation Server opens in the Connect to Team Foundation Server.

Related Concepts

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures

- Browsing Lists of Work Items in a Visual Studio Team System Project
- Creating a Trace Between a Requirement and a Visual Studio Team System Work Item
- Viewing Individual Visual Studio Team System Work Item Details
- Browsing Lists of Tests in a Visual Studio Team System Project
- Creating a Trace Between a Requirement and a Visual Studio Team System Test
- Viewing Visual Studio Team System Test Results
Creating a Visual Studio Team System Work Item

**Note:** For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System work items is called **VSTS Work Items**.

**To create a Visual Studio Team System work item**

1. Select a CaliberRM requirement.
2. Click the **Traceability** tab.
3. Click the **Modify...** button. The **Traceability Modification** window opens.
4. Click the **VSTS Work Items** tab. A list of available work items opens.
   
   **Note:** If you have not yet established a connection to the Microsoft Team Foundation Server, the **Connect to Team Foundation Server** dialog box opens. See **Related Procedures** below.

5. Right-click the list of work items to display the context menu.
6. Choose **New Work Item**. A **Work Item Properties** dialog box opens.
   
   **Note:** If the **Work Item Properties** dialog box does not open, it is likely because you have not installed the Visual Studio Team Explorer, a required component to view work items details from CaliberRM. See **Related Concepts** below.

7. Edit the new work item details.
8. Click **Save**. The **Traceability Modification** window opens.
9. Choose **View** ➤ **Refresh** to see the new work item on the list.
   
   **Note:** To create a trace to or from the new work item, choose **Trace** ➤ **Trace To** or **Trace From** from the menu. For more information on creating traces between requirements and work items, see **Related Procedures** below.

**Related Concepts**

- Visual Studio Team System Work Items and Tests
- Requirement Traceability
- System Requirements and Prerequisites

**Related Procedures**

- Enabling the Visual Studio Team System Integration on Your CaliberRM Server
- Creating a Trace Between a Requirement and a Visual Studio Team System Work Item
- Connecting to a Team Foundation Server
Creating a Trace Between a Requirement and a Visual Studio Team System Work Item

**Note:** For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System work items is called **VSTS Work Items**.

To establish a trace between a requirement and a Visual Studio Team System work item

1. Select the CaliberRM requirement to trace with a Visual Studio Team System work item.
2. Click the **Traceability** tab.
3. Click the **Modify...** button.
4. Click the **VSTS Work Items** tab. A list of available work items opens.
   
   **Note:** If you have not yet established a connection to the Microsoft Team Foundation Server, the **Connect to Team Foundation Server** dialog box opens. See **Related Procedures** below.

5. Select the work item to establish a trace with. Choose **Trace ▶ Trace To** or **Trace ▶ Trace From** to add a trace to or from the work item.
6. Choose **Trace ▶ Save Changes** to save the trace.
   
   **Note:** The **Enter a Comment** dialog box opens. Enter a comment and click **OK** or click **Cancel** if a comment is not required. Select the **Do not show this dialog box again** check box if you do not want this dialog box to appear when you save changes to traces.

7. Close the **Traceability Modification** window.

Related Concepts

- **Visual Studio Team System Work Items and Tests**
- **Requirement Traceability**

Related Procedures

- **Enabling the Visual Studio Team System Integration on Your CaliberRM Server**
- **Browsing Lists of Work Items in a Visual Studio Team System Project**
- **Connecting to a Team Foundation Server**
Reporting on Traceability Between Requirements and Visual Studio Team System Work Items

You can create reports on traceability between requirements and work items using CaliberRM Document Factory and CaliberRM Datamart.


Datamart extracts data from a CaliberRM repository, transforms the data and loads it into a relational database. Microsoft Access, Microsoft SQL Server and Oracle Database Server are supported. To work with the data, you will need a relational database analysis tool, such as Business Objects.

Note: You must have Microsoft Office installed to use Document Factory.

To create reports using Document Factory

1. Prepare a Document Factory template. To include traces between requirements and Visual Studio Team System work items into your report, use the <<traces>> keyword or the $BEGIN_TRACES()/$END_TRACES commands with appropriate keywords.
2. Choose Programs ► CaliberRM ► Document Factory from the Windows Start menu or Tools ► Document Factory from the main CaliberRM client menu to run the CaliberRM Document Factory wizard.
3. Follow the instructions on the screen. Document Factory generates the report.

Note: For detailed information on running Document Factory, refer to the CaliberRM User Guide.

To create reports using Datamart

1. Choose Programs ► CaliberRM ► Datamart Configuration from the Windows Start menu to run the CaliberRM Datamart Configuration Wizard.
2. Follow the instructions on the screen. The Datamart configuration file is created.
3. Run the Datamart Extractor command-line utility specifying the configuration file created in the previous step. The data is extracted into a relational database.

Note: For detailed information on running Datamart, refer to the CaliberRM Datamart User Guide.

Related Concepts

Visual Studio Team System Work Items and Tests
Requirement Traceability

Related Procedures

Enabling the Visual Studio Team System Integration on Your CaliberRM Server
Viewing Visual Studio Team System Work Items in the Traceability Diagram

To view Visual Studio Team System work items in the Traceability Diagram

1. Select a CaliberRM requirement that has traces to or from Visual Studio Team System work items.

2. Choose Tools ▶ Traceability Diagram. The Traceability Diagram displays the CaliberRM requirement with traces to and/or from Visual Studio Team System work items.

Tip: Right-clicking a work item displays the context menu. Choosing Properties... opens the Work Item Properties window where you can view or modify the work item details. Choosing New Work Item opens the Work Item Properties window where you can specify the details of a new work item.

Related Concepts

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures

- Viewing Visual Studio Team System Work Items in the Traceability Matrix
Viewing Visual Studio Team System Work Items in the Traceability Matrix

**Note:** For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System work items is called **VSTS Work Items**.

To view Visual Studio Team System work items in the Traceability Matrix

1. Choose **Tools ▶ Traceability Matrix** from the main menu. The **Traceability Matrix** window opens.
2. Choose **View ▶ Filter...** from the **Traceability Matrix** menu. The **Traceability Filter** dialog box opens.
3. Click the **VSTS Work Items** tab.
4. Check the **Rows** and/or **Columns** check boxes in the **Show VSTS Work Items Objects in:** field.
5. Click **OK**. The **Traceability Matrix** window displays Visual Studio Team System work items.

**Note:** Right-clicking a work item and choosing **Properties** opens the work item **Properties** window where you can view the trace details.

Related Concepts

- [Visual Studio Team System Work Items and Tests](#)
- [Requirement Traceability](#)

Related Procedures

- [Enabling the Visual Studio Team System Integration on Your CaliberRM Server](#)
- [Viewing Visual Studio Team System Work Items in the Traceability Diagram](#)
Viewing Individual Visual Studio Team System Work Item Details

You can view details of individual Visual Studio Team System work items:

- Before a trace is created
- After a trace is created

Note: For the purposes of this documentation, the user-customized tab that refers to Visual Studio Team System work items is called **VSTS Work Items**.

To view individual Visual Studio Team System work item details before a trace is created

1. Select a CaliberRM requirement.
2. Click the **Traceability** tab.
3. Click the **Modify...** button.
4. Click the **VSTS Work Items** tab. A list of available work items opens.
   
   **Note:** If you have not yet established a connection to the Microsoft Team Foundation Server, the **Connect to Team Foundation Server** dialog box opens. See Related Procedures below.
5. Right-click the work item to display the context menu.
6. Choose **Properties...**. This displays the **Work Item Properties** window where you can view and modify the work item details.

To view individual Visual Studio Team System work item details after a trace is created

1. Select the CaliberRM requirement that is traced to or from a Visual Studio Team System work item.
2. Click the **Traceability** tab. This displays traces to and from this requirement.
3. Select a trace to or from a Visual Studio Team System work item.
4. Right-click the trace to display the context menu.
5. Choose **Properties...**. This displays the **Work Item Properties** window where you can view and modify the work item details.

Related Concepts

- Visual Studio Team System Work Items and Tests
- Requirement Traceability

Related Procedures

- Enabling the Visual Studio Team System Integration on Your CaliberRM Server
- Browsing Lists of Work Items in a Visual Studio Team System Project
- Connecting to a Team Foundation Server
Index

Borland CaliberRM, 8
  connecting
    Team Foundation Server, 23 32
Datamart, 26
Document Factory, 26
fail, 16
Framework Administrator, 12
generic test, 16
integration, 8
  enabling, 12
introduction to product, 8
load test, 16
Microsoft SQL Server, 8
Microsoft Team Foundation Server, 8
pass, 16
port number, 23
protocol, 23
Server name, 23
system requirements, 11
Team Foundation Server, 16
test, 16
  creating a trace to, 24
  determining status of, 25
  reporting on traceability, 26
  traceability diagram, 28
  traceability matrix, 29
  viewing, 22
  viewing results of, 27
Traceability Add-ins, 8
traceability
  requirements, 18
traces, 18
unit test, 16
vendor add-in modules, 18
Visual Studio Team Foundation Server, 8
Visual Studio Team System objects, 16
web test, 16
work item, 16
  creating, 33
  creating a trace to, 34
  reporting on traceability, 35
  traceability diagram, 36
  traceability matrix, 37
  viewing, 31
  viewing details of, 38