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StarTeam Eclipse Client
StarTeam provides an automated and comprehensive software configuration management (SCM) system
for supporting the management of assets and application life cycle tasks, all from within a single repository.
Note: If your Internet access is limited by network security, or if your computer is protected by a
personal firewall, the Web-based links in this Help system might not function properly.
StarTeam facilitates both local and remote team collaboration through the use of tightly integrated
components commonly used during product development. It allows you to:
•
•
•
•
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Store everything related to a group of projects in the same place. For example, you can store test and
binary files, change requests and discussions about the project.
Access information and collaborate via a LAN, WAN or the Internet securely.
Improve project teamwork.
Make testing easier and save maintenance time because of the tight integration between change
requests and code and content files.
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•
•
•
•

Makes tracking requirements easier because of the tight integration between requirements and code
and content files.
Makes project management easier because the tight integration between tasks and code and content
files.
Keep track of who did what and when.
Take advantage of true client/server access to data.

What's New in StarTeam Eclipse Client
Extended Eclipse Support
Additional support has been added for Eclipse versions 3.7 and 4.2, including continued support of version
3.6.

Change View Added
This release supports the addition of a new StarTeam Change view, which by default displays in the lower
pane of the Client.
Every time you make an update to a file or folder, there will be an entry in the details of the new Change
view. It shows a description of the change or action performed, for example "Workspace Changes on
<date>". The Change view also lists the process item used for the check in. Whenever a process item is
used or specified for check in, a change package is created even if the process item is not directly
changed, for example, "set to fixed as part of the check in".

Workspace (Check-in) Change Packages
The creation of process tasks and the Enhanced Process Model have been replaced by workspace (checkin) change packages. Files linked to a process item can now be viewed in the details of the new Change
view.
Workspace (check-in) change packages are created when the following actions are performed on files and
folders:
•
•
•
•

Add and check-in
Move
Rename
Delete

Custom Process Rules
Project process rules have been enhanced to allow the selection of any Item type as a valid process item,
including newly added custom components. For each valid process item type, an enumerated property is
chosen with active and closed states to provide full process item supporting capabilities.

Getting Started
Includes basic concepts about software change management and information on features and functionality
to get you started with using the Borland StarTeam Eclipse Client.

Borland StarTeam Eclipse Client
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Installation and Licensing for StarTeam
Installation
Installation instructions for installing StarTeam products can be found in the StarTeam Installation Guide.
Licensing
StarTeam is available in three licensing packages:
Enterprise

StarTeam Enterprise provides a basic feature set, including the StarTeam Server,
StarTeamMPX (StarTeamMPX Event Transmitter and StarTeamMPX Message Broker),
the Cross-Platform Client, StarTeam Web Client, LDAP QuickStart Manager, and the
SDK. The requirements component is not available with this license, however, it does
provide access to custom fields.

Express

StarTeam Express provides the same basic feature set as StarTeam Enterprise.
Additionally, StarTeam Express contains a limited number of free named user licenses.

Enterprise
Advantage

StarTeam Enterprise Advantage has all the StarTeam Enterprise features plus the
Requirement component, StarTeamMPX (Cache Agent and StarTeamMPX File
Transmitter), and StarTeam Workflow Extensions which include alternate property editors
(APEs) that enable you to create custom forms and design workflow rules to control how
all the items in a component move from state to state. StarTeam Datamart is available for
purchase.

Logging On
Before you can use StarTeam from within Eclipse, you must create a connection to a StarTeam server
configuration and then log on to that server configuration.
StarTeam uses a standard Eclipse feature to store password information. The Eclipse encryption tool
keeps password information securely hidden.
1. Open the Server Explorer.
2. Right click on the server configuration that you wish to access, and choose Log On from the context
menu. The Log On dialog box opens.
3. Type a User name and Password in the appropriate text boxes.
Passwords are case sensitive and may have length restrictions.
4. Check Save as default credentials for this server.
5. Click OK.
Once you are connected to a StarTeam server configuration, the name of the logged on user displays in
the Server Explorer and in the status bar at the bottom of the Eclipse UI.
Note: The Log On dialog box does not use cached logon data. If you need to log on as a different
user, run the Log On command again from the context menu.

Logging Off
1. Open the Server Explorer.
2. Right click on the server configuration that you wish to access, and choose Log Off from the context
menu. A confirmation dialog box displays asking if you want to completely log off this server.
3. Click Yes to continue.
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StarTeam closes all connections to the specified server configuration that you have logged into during this
session.

Tour of the UI
This section describes the Perspectives and Views that make up the StarTeam Eclipse Client user
interface.

Perspectives
In the StarTeam Eclipse Client, you can access the StarTeam Activity and StarTeam Classic perspectives
by performing one of the following:
•
•

Selecting Window > Open Perspective and choosing the desired StarTeam perspective from the
menu.
Selecting Window > Open Perspective > Other and choosing the desired StarTeam perspective from
the StarTeam tree node.

StarTeam Activity Perspective
The StarTeam Activity perspective provides a suggested UI layout for activity-driven development. You
can use the views in this perspective when working with and editing your files and using StarTeam as your
source control provider.
The perspective shows the item and details views side-by-side and provides editor space so you can
compare file edits and review changes before synchronizing with the StarTeam repository. It also provides
an activity-driven development approach enabling you to select assigned action items, work on them in the
editor area, change the status of the process item, and/or check in the work related to it.
The StarTeam Activity perspective opens all views provided in the StarTeam Classic perspective
including the Editor view.
By default, this perspective includes the following views:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Editor
Server Explorer
Package Explorer
Navigator
Change Request
Requirement
Task
Topic
Audit Log
Properties
History
Label
Link
Reference

When opening any of the perspectives or views, a main menu command displays along with additional
StarTeam-specific toolbar buttons.
Note: Once connected to a StarTeam server configuration, the Navigator and Package Explorers
display the StarTeam project or view name in brackets next to the root folder name. For example, if
your root Eclipse project folder is MyProject, your project name is StarDraw, and your view name is
MyView, the Navigator and Package Explorers display: MyProject [StarDraw/MyView]

Borland StarTeam Eclipse Client
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StarTeam Classic Perspective
The StarTeam Classic perspective is provided to mimic the Cross-Platform Client and make users
accustomed to the client feel at home. Choose this perspective if you want to work as if you are working in
the client. You can use this perspective for reviewing Change Requests, Topics, or other components that
require a large viewing space.
The StarTeam Classic perspective opens all views provided in the StarTeam Activity perspective,
excluding the Editor view.
By default, the StarTeam Classic perspective provides the following views:
•
•
•
•
•
•
•
•
•
•
•
•
•

Server Explorer
Package Explorer
Navigator
Change Request
Requirement
Task
Topic
Audit Log
Properties
History
Label
Link
Reference

When opening any of the perspectives or views, a main menu command displays along with additional
StarTeam-specific toolbar buttons.
Note: Once connected to a StarTeam server configuration, the Navigator and Package Explorers
display the StarTeam project or view name in brackets next to the root folder name. For example, if
your root Eclipse project folder is MyProject, your project name is StarDraw, and your view name is
MyView, the Navigator and Package Explorers display: MyProject [StarDraw/MyView]

Views
Important: The term view is used here in terms of the Eclipse UI. This term should not be confused
with the StarTeam usage of view. In StarTeam, a view consists of an application folder tree view and
the items associated with each folder in that tree.
You can access the StarTeam views by performing one of the following:
•
•

Selecting Window > Show View and selecting the desired view from the menu.
Selecting Window > Show View > Other and selecting the desired view from the StarTeam tree node.

When opening any of the perspectives or views, a main menu command displays along with additional
StarTeam-specific toolbar buttons.
When you create a project, an initial or root view of that project is also created. This initial view, which has
the same name as the project, consists of the root folder and a tree view of the child folder. It is always
read/write.
The root view is called a dynamic view, because it shows all items in the project as they change, making it
ideal for collaborative development.
To accommodate both user and project needs, however, the application enables you to create additional
views of a project based on this view. These additional views may contain some or all of the contents of the
original view and may behave differently.
For example, you might use views to:

10
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•
•

•

Implement the same folder tree for both the 2.5 release and the 3.0 release of a product. The easiest
way to do this is by creating a new view for the 3.0 release based on the view used for the 2.5 release.
Limit the portion of the project that certain team members see. Developers might need to see only the
project's source code folder and its child folders; marketing personnel might need to see only the
marketing folder and its child folders; and so on. Each of these views can have a different folder as its
root.
Support branching and parallel development. By branching files and other data in a new view, you
organization can start to work on the 2.0 version of a product without hampering the creation of service
packs for the 1.0 version.

Views represent configurations of items and support different development baselines of the same code
base. If desired, views can be compared and merged. For example, you might want eventually to merge
files from 4.5 Maintenance and 5.0 New Development into the Baseline view. Views are highly flexible. For
example, they can be re-configured to show items as they existed at an earlier point in time or based on a
view label or associated promotion state. Rollback views are read-only, as they show a precise state of the
items, and no longer permit changes.
Server Explorer
The top-level node is the unique name that you provide to the server configuration in the Share Project
wizard. Expanding the root server configuration node reveals StarTeam projects, views, folders, and files.
You can open the Server Explorer by doing one of the following:
•
•

Select Window > Show View > Server Explorer
Select Window > Show View > StarTeam Other, and choosing Server Explorer from the tree node.

A connection to the server configuration is present if you see a logged in name next to the server
configuration name in the Server Explorer or in the status bar at the bottom of the workbench.
The Server Explorer view displays the server configuration, project, view, and folder tree view. With this
view you can perform the following operations:
•

•

•

Display information using icons: A specific icon precedes each server, view, project and folder
name. Selecting one of the nodes in this tree view causes all other StarTeam-related views to update
with information relevant to this selection.
Expand and collapse branches: You can expand or collapse branches in the Server Explorer. A plus
sign identifies a collapsed branch. Clicking it expands the branch. A minus sign identifies an expanded
branch. Clicking it collapses the branch.
Right-click for context menu commands: After selecting a node in the Server Explorer, right-click to
display a context menu offering commands specific to the selected node.

Server Explorer Context Menu Actions
At the server configuration level, context menus enable you to:
•
•
•
•

Create new StarTeam projects, views, and folders
Modify existing server configuration connection properties
Delete a connection to a server configuration
Log on to the server configuration

At the project level, context menus enable you to:
•
•
•
•
•

Open projects in various StarTeam views, including Change Request, Requirement, Task, and Topic
views
Create new views and folders
Delete projects
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
Modify project properties including options like keyword expansion and process rules

At the view level, context menus enable you to:

Borland StarTeam Eclipse Client
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•
•
•
•
•
•

Open views in various StarTeam views, including Change Request, Requirement, Task, and Topic
views
Create new views and folders
Create, delete, and modify labels and promotion states
Modify view properties, including the view name, branching settings, and the working folder
configuration
Delete views
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client

At the folder level, context menus enable you to:
•
•
•
•
•

•
•
•
•
•
•
•

Create new folders, change requests, requirements, tasks, or topics
Open folders in various StarTeam views, including Change Request, Requirement, Task, and Topic
views
Open the folder locally
Check out a folder as a workspace project, to include in an existing workspace project, or configure with
the New Project wizard
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open the folder in
StarTeam
Create, attach, detach, and modify properties for labels
Modify folder properties including the folder name and files to exclude from folders
Add, edit, enable, or disable custom fields
Modify folder configuration
Delete folders
Create, complete, and cancel links
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client

At the file level, context menus enable you to:
•
•
•
•
•

•
•
•
•
•
•

Open files in various StarTeam views, including Change Request, Requirement, Task, and Topic views
Open the local folder containing the file
Send file properties information as an email message, along with additional text.
Set the lock status
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open the file in
StarTeam
Create, attach, and detach labels
Flag and remove flags from files
Delete files
Create, complete, and cancel links
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
View and modify file properties, such as the file name, description, and file storage options

Annotate View
Annotations show historical information about changes that were made to a text document. The Annotate
view is a tabbed pane which is displayed in the same location as other StarTeam views, such as the
Detail, History, Links, and Labels views. It displays the contents of the selected text file, a working folder
hyperlink to the file in the Server Explorer, and annotation information in the left margin which contains the
following information:
•
•
•
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The name of each user who wrote or changed specific lines, and which lines were changed.
The dot notation of the file revision in which each change was made.
A hyperlink to the properties for the associated process item, if one was linked to the file revision.
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•

An Info icon which, when clicked, displays the details about the file revision and the associated process
item.

You can open the Annotate view by taking the following actions:
•
•

Select Window > Show View > Annotate
Select Window > Show View > Other, and choose Annotate from the StarTeam tree node.

Annotate View Toolbar and Menu Actions
The following actions are available from the Annotate View toolbar and list box:
•
•
•
•
•

Link (unlink) the view to the selected StarTeam item
Refresh
Back to previous contents
Forward to next contents
Open StarTeam Preferences

Editor Annotations
The StarTeam annotate feature also provides a Team > Show Annotation context-menu action which
displays annotation information in the left margin of the editor, and can be invoked for any shared file or
repository file. This menu action is available by right-clicking a text file in the Server Explorer, Navigator,
or Package Explorer. Annotations utilize the StarTeam quick diff provider for displaying revision
information, and StarTeam requests that you switch to it for the current editor.
Annotations are displayed in the left panel of the editor, and are synchronized with the Annotate view so
that when you select an annotation in the editor, it selects that annotation in the Annotate view. The
default coloring for the left gutter is by revision age. The color gradually brightens from dark (latest
changes) to light (earliest changes). You can modify the coloring to distinguish authors who contributed the
change, or display both revision age and authors.
The contents of the generic History view are also synchronized with the annotations in the editor.
Selecting a revision in the History view highlights the left gutter annotation borders of all the lines in the
document that were contributed by the selected revision, and the right margin shows the range of the
changes created by the selected revision. Conversely, selecting an annotation in the left gutter of the editor
highlights the corresponding revision in the History view.
The fields in the left gutter are sensitive to mouse moves and show hover information with more details
about the contributed changes. This information is the same information obtained by clicking the
Information icon in the Annotate view. Pressing F2 over a hover window gives it focus, allowing you to
read the details or use the hyperlinks to possible process items linked to the revision. Clicking a link to a
process item in the annotation information also selects and displays that item in the Change Request,
Task, or Requirement view.
Annotation Context-Menu Actions in the Editor
There are no context-menu actions in the Annotate view, however, there are several actions available
from the Annotation pane of the editor using the following Revisions context-menu items:
•
•
•
•
•
•

Hide or display revision information.
Display the border color by the revision date.
Display the border color by the author who made the changes.
Combine the border coloring to show the revision date and the author.
Show the author's name.
Show the revision ID (dot notation revision number).

Borland StarTeam Eclipse Client
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Audit Log View
The Audit Log view provides a chronological record accumulating data about the actions performed on
folders, files, requirements, change requests, tasks, and topics.
You can open the Audit Log view by doing one of the following:
•
•

Selecting Window > Show View > Audit
Selecting Window > Show View > Other, and choosing Audit from the StarTeam tree node.

When you open the Audit Log view, a list of audit logs displays for the selected view.
All audits shown in the Audit Log view:
•
•
•

Are attached to the folder selected from the Server Explorer.
Match the filter selected from the Filter list box.
Match the depth specified by the All Descendants button.

Using the Audit Log List
Audit log entries cannot be moved, shared, modified, or branched in StarTeam. However, a few operations
can be performed on these items. For example, you can search for items in the Audit Log view by clicking
on the list box arrow of the Audit Log view toolbar, and selecting Find, Find Next, or Find Previous to
locate items in the Audit log list with a specified value in a column.
Filter and Sort Audit Log Data
You can sort the audit log by the data in a column and change the display based on a predefined filter
available in the Audit Log view toolbar.
You can click on an audit column header to perform a sort based on the value in that column. The sort is
usually in ascending numeric or alphanumeric order, depending on the data. To change the sort order from
ascending to descending (or vice versa), click the header a second time. A triangle indicating the direction
of the sort appears on the header of the primary sort column.
Default Audit Log View Columns
You can view the following default columns in the Audit Log view:
•
•
•
•
•
•
•

User– Person performing the action.
Created Time – Date and time of the action.
Class Name – Type of object, such as file, folder, change request, or topic
Event – Name of the action, such as Created, Added, Deleted, Modified, Branched, Moved From,
Shared, Locked, Unlocked, Moved to, or Lock broken.
Item – Item number associated with the Class Name. That is, the type of item created, such as a task,
topic, change request, and so on.
View – Name of the view in which the object is located.
Project – Name of project where the object is located.

Audit Log View Toolbar and Context Menu Actions
The Audit Log view toolbar and context menu allow you to:
•
•
•
•
•

•
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Filter log entries with predefined filters
Search (CTRL+F) audit log entries
Link (unlink) the view to the selected StarTeam item
Optionally show all descendants to determine the depth for which the client displays information
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open to the item of
interest in StarTeam
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
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Change View
The Change view shows all the actions performed on a process item or workspace (check-in) change
package.
You can open the Change view by taking one of the following actions:
•
•

Select Window > Show View > Change
Select Window > Show View > Other, and choose Change from the Server Explorer tree node.

Every time you make an update to a file or folder, there will be an entry in the details of the new Change
view. It shows a description of the change or action performed, for example "Workspace Changes on
<date>". The Change view also lists the process item used for the check in. Whenever a process item is
used or specified for check in, a change package is created even if the process item is not directly
changed, for example, "set to fixed as part of the check in".
Change View Context Menu Actions
The Change view context menu enables you to complete the following tasks:
•
•
•
•
•

View historical information about changes made to a file.
Highlight a selected item in the Server Explorer view. This option cannot be used on custom
components.
View properties of two items to compare changes between them.
View contents of two items to compare changes between them.
View properties of the workspace (check-in) change package.

Change Request View
The Change Request view provides a powerful search and/or reporting mechanism that allows change
requests and suggestions about possible improvements to a project to be entered, assigned to a team
member, and tracked.
You can open the Change Request view by taking one of the following actions:
•
•

Select Window > Show View > Change Request
Select Window > Show View > Other, and choose Change Request from the StarTeam tree node.

When you open the Change Request view, a list of change requests displays.
All change requests shown in the Change Request view have the following characteristics:
•
•
•

Are attached to the folder selected from the Server Explorer.
Match the filter selected from the Filter list box.
Match the depth specified by the All Descendants button.

Using the Change Request List
From the Change Request list that displays in the Change Request view, you can perform a variety of
operations, including the following options:
•

•

View unread items: To see the change requests for which you are responsible but have not reviewed,
look for the change requests in boldface type. The change requests in regular type are those that you
have read or those for which you are not responsible.
View properties: To open the Properties dialog box for a specific change request, double click on it.

Filter and Sort Change Request Data
You can sort the change requests by the data in a column and change the display based on a predefined
filter available in the Change Request view toolbar.
You can sort change requests by clicking on a column header to sort the displayed change requests based
on the value in that column. The sort is usually in ascending numeric or alphanumeric order, depending on
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the data. The ascending order for Severity displays from Low to Medium to High. The ascending order for
Status reflects the life cycle of the change request, so these items display from New to Closed. The
ascending order for Priority displays from No to Yes. To change the sort order from ascending to
descending, click the header a second time. A triangle indicating the direction of the sort appears on the
header of the primary sort column.
Default Change Request View Columns
You can view the following default columns in the Change Request view:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

CR Number: Number that StarTeam assigned to the change request when it was first submitted.
Synopsis: Short explanation of the change request.
Type: Defect or Suggestion.
Status: Indication of the change request life cycle. Status classifications include New, Open, Cannot
Reproduce, As Designed, Fixed, Documented, Is Duplicate, or Deferred.
Severity: Seriousness of the change request. Severity can be Minor, Normal, Major, or Critical.
Responsibility: Person who is responsible for the change request.
Addressed In: Build in which the change request is resolved.
Addressed By: Name of user who resolved the change request. A change request has been resolved
when its status becomes Cannot Reproduce, As Designed, Fixed, Documented, or Is Duplicate.
Last Build Tested: Build in which the change request occurs.
Work Around: Solution to a change request other than a fix.
Modified Time: Time the change request was last modified.
Priority: Indication that the change request is or is not a Priority.
Description: Complete explanation of the defect or suggestion, including the steps to be taken to
reproduce the problem.
Test Command: Command that can be used to test the change request’s solution.
Fix: Solution to the problem addressed by the change request.
Entered On: Date and time the change request was submitted.
Entered By: Person who submitted the change request.

Change Request View Toolbar and Context Menu Actions
In addition to the other capabilities described in this section, the Change Request view toolbar and context
menu enable you to use the following options:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
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Apply predefined filters for viewing lists of change requests.
Search (CTRL+F) for change requests.
Link (unlink) the view to the selected StarTeam item.
Optionally show all descendants to determine the depth for which the client displays information
Select all items.
Select items using a label or pre-defined query.
Determine which fields to display in the view.
Perform up to fourth order sorts.
Create, edit, copy, or delete queries
Save or reset current view filters
Create, edit, save, or delete filters
Create new change requests
Open change requests in various views, including History, Label, Link, and Reference views
Modify and review change request properties
Email a text representation of the change request's properties, along with additional text. The
information sent includes the fields displayed in the view.
Compare the properties of two change requests.
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•
•
•
•

•
•
•
•
•
•

Set the lock status.
Mark the item as read or unread.
Add, edit, enable, or disable custom fields.
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open the item in
StarTeam
Create, attach, and detach labels.
Flag and remove flags from files.
Delete change requests.
Create, complete, and cancel links
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
Set or clear the item as an active process item.

Detail View
The Detail view displays a customized summary and text details of the properties for the selected item.
You can open the Detail view by taking either of the following actions:
•
•

Selecting Window > Show View > Detail
Selecting Window > Show View > Other, and choosing Detail from the StarTeam tree node.

Detail View Toolbar and Menu Actions
The following actions are available from the Detail View toolbar and drop-down menu:
•
•
•
•
•

Link (unlink) the view to the selected StarTeam item
Refresh
Back to previous contents
Forward to next contents
Open StarTeam Preferences

Detail View Context-Menu Actions
No context-menu actions are available in the Detail view.
History View
The History view displays historical information about the selected item. This view plays an important role
in version control. After you select the appropriate file or item, the History view automatically displays a list
of all the past revisions of that file or item. The revisions are listed from the tip revision to the initial revision.
Double-clicking a revision displays its properties. Right-clicking displays a context menu that enables you
to review the properties for the revision, to compare revisions, and to change the comment associated with
that revision. For files, you can also view the file in the default editor or open in an appropriate application.
You can open the History view by taking one of the following actions:
•
•

Select Window > Show View > History
Select Window > Show View > Other, and choose History from the Server Explorer tree node.

Default columns provided in the History view include the following columns:
•
•
•
•
•

View – View to which the file belongs.
Revision – Number StarTeam assigned to the revision when it was checked in.
Author – Person who checked in the revision.
Time – Date and time of the revision.
Comment – Reason for creating the revision.
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•

Branch Revision – Indicates the branch number for the item.

History View Context Menu Actions
The History view context menu enables you to complete the following tasks:
•
•
•
•
•
•

•
•

View content of revision in a default editor (files only)
Display the properties of a revision
Compare revisions
Compare properties of revisions
Change comments associated with revisions
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open the item in
StarTeam
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
Open the local folder containing the selected file

Label View
The Label view provides a list of labels assigned to a corresponding folder or item. In version control, the
term label corresponds to the act of attaching a view or revision label (name) to one or more folders and/or
items. You can attach a label to almost any type of StarTeam item.
You can open the Label view by taking one of the following actions:
•
•

Selecting Window > Show View > Label
Selecting Window > Show View > Other, and choosing Label from the StarTeam tree node.

StarTeam offers two types of labels:
•

•

View labels, which are automatically and immediately attached to all folders and items in a view at the
time they are created. They have multiple purposes, but are primarily used as a time stamp for the view
and as build labels.
Revision labels, which are not automatically attached to any item in the view. Instead, they are used to
designate a set of folders or items within a view. For example, you might want to label a group of files
that should be checked in and out together.

Label View Context Menu Actions
The Label view toolbar and context menu allow you to:
•
•
•

Link (unlink) the view to the selected item
Attach/detach labels
Modify label properties

Link View
The Link view displays a connection between two folders, two items, or a folder and an item.
You can open the Link view by doing one of the following:
•
•

Selecting Window > Show View > Link
Selecting Window > Show View > Other, and choosing Link from the StarTeam tree node.

Link View Context Menu Actions
The Link view toolbar and context menu enable you to accomplish the following tasks:
•
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Link (unlink) the view to the selected item
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•
•
•
•
•

Select linked items
Attach/detach labels to/from linked files
Float (allow the link source or target to change from tip revision to tip revision as new revisions are
created) and pin (lock the link to the tip revision) links
Delete links
Modify link and source/target item properties

Reference View
The Reference view indicates the relationships between an original folder or item and those that are based
on it. By looking at the Reference view, you can decide whether the changes made to a folder or item in
one location need to be applied elsewhere.
You can open the Reference view by doing one of the following:
•
•

Selecting Window > Show View > Reference
Selecting Window > Show View > Other, and choosing Reference from the StarTeam tree node.

Reference View Context Menu Actions
The Reference view toolbar and context menu allow you to accomplish the following tasks:
•
•

Link (unlink) the view to the selected StarTeam item.
Modify the referenced item's properties.

Requirement View
You can open the Requirement view by doing one of the following:
•
•

Select Window > Show View > Requirement
Select Window > Show View > Other, and choose Requirement from the StarTeam tree node.

When you open the Requirement view, a list of requirements displays.
All requirements shown in the Requirement view have the following characteristics:
•
•
•

Are attached to the folder selected from the Server Explorer.
Match the filter selected from the Filter list box.
Match the depth specified by the All Descendants button.

Requirement View Toolbar and Context Menu Actions
The Requirement view toolbar and context menu allow you to accomplish the following tasks:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Apply predefined filters for viewing lists of requirements
Search (CTRL+F) for requirements
Link (unlink) the view to the selected item
Optionally show all descendants to determine the depth for which the client displays information
View in list or tree format
Select all items
Select items using a label or pre-defined query
Determine which fields to display in the view
Perform up to fourth order sorts
Create, edit, copy, or delete queries
Save or reset current view filters
Create, edit, save, or delete filters
Create new requirements and child requirements
Open requirements in various views, including History, Label, Link, and Reference views
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•
•
•
•
•
•
•

•
•
•
•
•
•

Modify and review requirement properties
Email a text representation of the requirement's properties, along with additional text. The information
sent includes the fields displayed in the view.
Compare the properties of two requirements
Set the lock status
Mark the item or thread as read or unread
Add, edit, enable, or disable custom fields
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open the item in
StarTeam
Create, attach, and detach labels
Flag and remove flags from files
Delete requirements
Create, complete, and cancel links
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
Set or clear the item as an active process item

Task View
In the Task view, team members can easily see who should do what tasks and when tasks should be
done. It also enables team members to see current task status, estimate the time required for a task,
record the time spent, and compare estimated to actual times.
You can open the Task view by taking one of the following actions:
•
•

Select Window > Show View > Task
Select Window > Show View > Other, and chooseTask from the StarTeam tree node.

When you open the Task view, existing tasks display. Double-clicking a task or subtask opens the
Properties dialog box for the selected task.
All tasks displayed in the Task view have the following characteristics:
•
•
•

Are attached to the folder selected from the Server Explorer.
Match the filter selected from the Filter list box.
Match the depth specified by the All Descendants button.

Task View Toolbar and Context Menu Actions
The Task view toolbar and context menu allow you to complete the following tasks:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
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Apply predefined filters for viewing lists of tasks
Search (CTRL+F) for tasks
Link (unlink) the view to the selected StarTeam item
Optionally show all descendants to determine the depth for which the client displays information
View in list or tree format
Select all items
Select items using a label or pre-defined query
Determine which fields to display in the view
Perform up to fourth order sorts
Create, edit, copy, or delete queries
Save or reset current view filters
Create, edit, save, or delete filters
Create new tasks and subtasks
Add work records to tasks or subtasks
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•
•
•
•
•
•
•
•

•
•
•
•
•
•

Open tasks in various views, including History, Label, Link, and Reference views
Modify and review task properties
Email a text representation of the task's properties, along with additional text. The information sent
includes the fields displayed in the view.
Compare the properties of two tasks
Set the lock status
Mark the item or thread as read or unread
Add, edit, enable, or disable custom fields
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open the item in
StarTeam
Create, attach, and detach labels
Flag and remove flags from files
Delete tasks
Create, complete, and cancel links
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
Set or clear the item as an active process item

Topic View
In the Topic view, team members can raise and discuss issues about a project, specific files, defects, and
so on.
You can open the Topic view by taking one of the following actions:
•
•

Select Window > Show View > Topic
Select Window > Show View > Other, and choose Topic from the StarTeam tree node.

When you open the Topic view, existing topics and responses display. Double-clicking on a topic or
response in the Topic view opens the Properties dialog box.
All topics and responses displayed in the Topic view have the following characteristics:
•
•
•

Are attached to the folder selected from the Server Explorer or from one of the Eclipse Explorers.
Match the filter selected from the Filter list box in the Topic view toolbar.
Match the depth specified by the All Descendants option in the Topic view toolbar.

Topic View Toolbar and Context Menu Actions
The Topic view toolbar and context menu allow you to:
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Apply predefined filters for viewing lists of topics
Search (CTRL+F) for topics
Link (unlink) the view to the selected item
Optionally show all descendants to determine the depth for which the client displays information
View in list or tree format
Select all items
Select items using a label or pre-defined query
Determine which fields to display in the view
Perform up to fourth order sorts
Create, edit, copy, or delete queries
Save or reset current view filters
Create, edit, save, or delete filters
Create new topics and respond to existing topics
Open topics in various views, including History, Label, Link, and Reference.
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•
•
•
•
•
•
•

•
•
•
•
•
•

Modify and review topic properties
Email a text representation of the topic's properties, along with additional text. The information sent
includes the fields displayed in the view.
Compare the properties of two topics
Set the lock status
Mark the item or thread as read or unread
Add, edit, enable, or disable custom fields
Create URLs and HTML representations and copy them to the Windows Clipboard and paste them into
email applications, Word documents, Excel spreadsheets, and so on to quickly open the item in
StarTeam
Create, attach, and detach labels
Flag and remove flags from files
Delete topics
Create, complete, and cancel links
Create desktop shortcuts (.stx) to quickly launch the Cross-Platform Client
Set or clear the item as an active process item

Search Results View
Once you have entered the expression for which you would like to search you can specify the following:
•
•
•
•

Type – Select the item type from the available list box. For example you can search just Topic items.
Search in – Select the check box next to any server, view, project, or folder to be included in the
search.
Look in – Select how the item properties should narrow the scope of the search.
Options – Select the appropriate check box to make the search recursive and the expression match
text case.

The results of the StarTeam search display in the Search Results view.

Item Editors
There are two ways to create and edit change requests, requirements, tasks, and topics:
•
•

Dialog box property editors (modal)
Embedded property editors (non-modal)

Each has its own advantages.
Dialog Box Property Editors
Dialog box editors open in a separate window for creating new items, and for editing or checking the status
of existing ones.
Dialog box property editors enable you to do the following:
•
•

Create or modify an item without disturbing your workspace.
Open a dialog box property editor from within another dialog box, such as the file Check In or Check
Out dialog box.
For example, from the Process Item or the Changes area in the Check In dialog box, you might open
the property dialog box for the process item you are using and copy its synopsis to the description field
in the Check In dialog box. This is not allowed in embedded editor because the Check In dialog box
itself is modal and blocks the workspace UI.
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Embedded Property Editors
Embedded property editors open in the Eclipse editor pane using the Eclipse forms look and feel. When an
item is opened in an embedded editor, the embedded property editor takes precedence and the controls in
the properties dialog box for that item are disabled.
Embedded property editors enable you to do the following:
•
•
•
•
•
•
•
•

Continue to do other work in Eclipse while the embedded property editor is open.
Open multiple embedded property editors at the same time.
Drag text content from one property editor to another.
Drag a block of text from a file in the editor to a field in an embedded property editor.
Drag and drop files, such as images or log files, from the Server Explorer onto the attachment tab of an
embedded property editor.
Quickly open item property editors by dragging one or more items from the Item view into the editor
pane.
View warnings and error messages in the header of the active tab page.
See when changes to an item are unsaved, represented by an asterisk next to the editor title on the tab.

Fields
You can display both common and advanced fields as columns in the Change Request, Requirement,
Task, and Topic views or use in queries along with relational operators that you can use with those fields
to define conditions. The StarTeam Eclipse Client comes preconfigured to use the default fields that
normally display in the Cross-Platform Client. You can sort fields by clicking on a column header in the
view to sort the data in the selected column. You can display additional fields using Show Fields
command found in the list box toolbar menu for the Change Request, Requirement, Task, and Topic
views.

Sharing Workspace Projects
Follow the high-level steps below when using the Share Project wizard.
These steps assume that:
•
•
•

You have not yet created a connection with a StarTeam Server configuration.
You have already created multiple Eclipse projects in the Workspace to share.
You have pre-existing StarTeam projects created for the StarTeam Server configuration that you are
sharing with the Eclipse projects.

1.
2.
3.
4.
5.
6.

Open the Share Project wizard.
If necessary, create a new StarTeam connection.
Log on to a StarTeam Server.
Enter repository location information.
Synchronize your workspace project with the StarTeam repository.
Check in the workspace project files to the repository.

Create Projects and Synchronize Local Files
At a high-level, creating a new StarTeam project and associating an existing workspace project with it
involves the following steps:
These steps assume that:
•
•

You have not yet created a connection to a StarTeam server configuration.
You have already created an Eclipse project in the Workspace to share.
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Checking Out Existing Folders
1. Open the StarTeam perspective.
2. Choose Window > Open Perspective > Other.
3. Select StarTeam Classic or StarTeam Activity from the list, and click OK.
4. Open the Server Explorer, and navigate to the appropriate StarTeam project, view, and folder.
You can multi-select folders to check out in the Server Explorer.
Note: If you have not logged on to the server, right click on the server configuration node, and
choose Log On. The status bar at the bottom of the Workbench reflects the logged on user name.
5. Right-click and choose Check Out As Project. The Check Out As wizard opens.
6. Choose one of the following options:
Option

Description

Check out as project in the
workspace

Enter a project name in the text box provided or use the default
folder name, and click Next. Select a location where you want to
check out the files to, and click Next.

Check out into existing project

Click Next to choose a valid target project, and click Finish.

Check out as a project
configured using New Project
Wizard

Click Finish , and follow the steps in the New Project wizard.

Note: If you want to use a location within the workspace that is not the default (that is, you select
either the second or third option), then you must use the StarTeam Cross-Platform Client to check
out the project and then import it from within the StarTeam Eclipse Client.
7. If you chose to Check out as project in the workspace, specify any check out options as follows:
•

Expand Reference By, and select one of the following options for the files you wish to check out:
•
•

•

Current revision : The most current (tip) revision.
Label: A specific file revision. The existing view and revision labels are listed in reverse
chronological order based on the time at which they were created. The view labels precede the
revision labels in the list.
• Promotion state: A specific promotion state.
• Configuration as of: The revision that was the tip revision at the specified date and time. Click
the Date/Year button to use the calendar, and specify the time by typing in the time or using the
spin boxes.
Expand Lock Status, and select one of the following lock options:

•

• Unlocked: Releases your lock on the files after check-in.
• Exclusive: Indicates that you intend to make further changes to the files.
• Non-exclusive: Indicates that you are working on the files and may possibly make changes.
• Keep Current: Retains the current lock status. Selected by default.
Optional: Expand EOL Conversion, and choose one of the following:

•

• None or another button to change your current EOL conversion setting.
• For Windows, the EOL marker is CR-LF (carriage return/line feed).
• For UNIX, it is LF (line feed).
• For Macintosh operating systems, it is CR (carriage return).
Expand Advanced to optionally select an appropriate File Encoding from the drop-down list to
support keyword expansion for non-English code pages.

8. Click Next. The Mapping preferences page opens.
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9. Choose your desired settings, or accept the default settings, and click Finish.

Setting Preferences
To review a description of the preferences you can set, see the links at the end of this topic.
1. Choose Window > Preferences from the main menu. The Preferences dialog box opens.
2. In the resulting dialog box, expand Team > StarTeam.
3. Select the node containing the options that you want to change.
4. Make the desired changes, then click OK.

Opening Perspectives and Views
1. Choose Window > Open Perspective > Other from the main menu. The Open Perspective dialog
box opens.
2. Select one of the following perspectives:
•
•

StarTeam Activity
StarTeam Classic

3. Click OK.
The specified perspective opens. For descriptions of the StarTeam perspectives, see the links at the end of
this topic.

Configuring Capabilities
This task describes how to enable and disable StarTeam as your source control provider plug in. By
default, when you install StarTeam, it is automatically enabled.
To enable and disable StarTeam capabilities
1. Choose Window > Preferences from the main menu. The Preferences dialog box opens.
2. In the resulting dialog box, expand General and select Capabilities.
3. Click Advanced. The Advanced dialog box opens.
4. Take one of the following actions to complete your task:
•
•

To disable StarTeam capabilities, expand Team, and clear the StarTeam Support check box.
To enable disabled StarTeam capabilities, expand Team, and check StarTeam Support.

5. Click OK. The Advanced dialog box closes.
6. Click OK. The Preferences dialog box closes.

Creating a New Connection
1. Select Create a new StarTeam connection and click Next.
2. Type a unique, easy-to-remember description in the Server description text box.
The server description is not case-sensitive and can contain colons ( : ).
3. Type the computer name or IP address in the Server address text box.
See your administrator for the server address, protocol, and endpoint information.
4. Type the endpoint (TCP/IP port number) associated with the protocol in the TCP/IP endpoint text box.
5. Click Test Connection.
6. Choose to specify any of the following optional settings:
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•
•

•

Check the Save Password option to enable the User Name and Password text boxes.
Select an Encryption type to encrypt data transferred between your workstation and the server.
Encryption protects files and other project information from being read by unauthorized parties over
unsecured network lines. The encryption types are ordered (top to bottom) based on speed. Each
type is slower, but safer, than the type that precedes it.
Check the option to Compress transferred data if you want to use compression.

7. Click Next when you are finished.

Removing Connections
1. Open an Eclipse Explorer.
2. Select the project node that you wish to remove StarTeam sharing with.
3. Right-click on the project node, and choose Team > Remove Share.

Configuring Profiles
Use this task to configure StarTeamMPX profiles for an existing StarTeam server configuration.
1. Open the Server Explorer.
2. Right-click on the root node for the desired server configuration connection, and choose Properties.
The Properties dialog box opens.
3. Expand Server Description, and choose MPX Profiles. The Properties dialog box lists each profile
defined in the Event Transmitter XML file for this server configuration.
4. Select the desired profile.
If you wish to restore the client default profile for this configuration, click Restore Default.
5. Click Close on this dialog, and then click OK on the Properties dialog box.

Deleting Server Configurations
1. Open the Server Explorer.
2. Select the root server configuration node that you wish to remove.
3. Right-click on the server configuration node, and choose Delete.
4. Click OK.
The Server Explorer updates to remove the deleted server configuration.

Linking Views with Selections
Automatic refresh of the view contents on selection changes in other views may be undesirable as it can
considerably slow down the work flow. You may also want views to show the same content during the
whole session such as change requests in process-related folders.
1. Take one of the following actions:
•
•

Open one of the StarTeam perspectives; or
Open a single StarTeam view.

2. Click Link with Selection in the view's toolbar.
3. To unlink, click Link with Selection again.
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Exporting a Set of Team Preferences
1. Choose File > Export from the main menu. The Export wizard opens.
2. Expand Team, and select Team project set from the list.
3. Click Next. The Export a Team Project Set page of the wizard opens.
4. Take the following actions:
a) Select a project or multiple projects that you wish to include in the set of team preferences.
b) Choose an export location for the project set file.
c) Click Finish.
Eclipse creates the projectSet.psf file and exports it to the location specified.

Importing a Set of Team Preferences
If you work in a team environment, you can import a set of team preferences.
1. Choose File > Import from the main menu. The Import wizard opens.
2. Expand Team, and select Team project set from the list.
3. Click Next. The Import a Team Project Set page of the wizard opens.
4. Take the following actions to complete the task:
•
•

Select the *.psf file name to import. The application automatically names the file, projectSet.psf.
If the *.psf file contains more than one project, you can optionally check the option to Create a
working set containing the imported projects, and enter a name for the working set.
• Click Finish.
5. Open the Server Explorer.
6. Right-click on the server configuration connection and choose Log On.
7. Enter your log on credentials for the server configuration, and click OK.

Setting Background Operations
1. Choose Window > Preferences from the main menu. The Preferences dialog box opens.
2. Select General.
3. Check Always run in background.
4. Click OK.

Viewing Background Operations
1. Choose Window > Show View > Other from the main menu. The Show View dialog box opens.
2. Expand General and select Progress.
3. Click OK. The Progress view opens.
Note: To cancel background operations click Stop to the right of the progress bar.

Refreshing Server Configurations
If your StarTeam server goes down, you can still work with other server configurations checking out files
from various server configurations in parallel.
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1. Open the Server Explorer.
2. Select the server configuration with a Pending status.
3. Right-click on the server configuration and choose Refresh.
If it is available, the StarTeam Eclipse Client reconnects to the selected server configuration.

Compare Revisions
You can use the Compare With context menu commands for, among other things, comparing local
versions of files and folders to those in the StarTeam Server repository.
Using the Compare With context menu commands, you can complete the following actions:
•
•
•
•
•
•

Compare your local file to the latest tip revision stored in the repository.
Compare a local folder or file to a labeled version stored in the repository.
Compare a local folder or file to a copy in a different StarTeam view stored in the repository.
Compare a local folder or file to a copy of that same item determined by a date.
Compare a local file to a specific revision stored in the repository.
Select two files or two folders and compare their properties.

Components
This section provides descriptions of the components available in the StarTeam. The application displays
each component in the Eclipse Workbench using corresponding views.

Containers
StarTeam server configurations, projects, and views are containers that allow you to organize artifacts
based on application, module, business unit, or other criteria.
Server Configurations as Containers
A server configuration is a single deployment instance of StarTeam. All files, change requests, and other
artifacts that can be interrelated and managed as a whole reside within a single server configuration. All
data and metadata for a server configuration are stored in a database. File contents are managed in
operating system-level files collectively known as the vault. Vault information is divided into separate areas
for storing archive and cache files. The vault, database and other related files, such as configuration files,
attachments, and logs are all referred to as the repository.
Projects as Containers
Within a server configuration, artifacts are organized into projects. Before a server configuration can be
used, at least one project must be created to hold files and other objects. A server configuration can hold
multiple projects, each oriented to the lifecycle needs of a specific team, application, or component.
Views as Containers
A StarTeam project can possess one or more views. Every project automatically receives a main view
through which folders, files, and other objects can be organized. Additional child views can be created to
represent subsets of the main project information, historic snapshots of project information, or work areas
for new development work. StarTeam provides a wide range of options for view creation to support a wide
range of development scenarios.

28

| Borland StarTeam Eclipse Client

An Example StarTeam Server Configuration

Throughout the documentation, a server configuration is often referred to as a server. These terms are
used interchangeably. This is because each server configuration is often deployed on its own server
machine, managed by its own StarTeam server process. However, be aware that StarTeam allows multiple
server configurations and server processes on a single machine, so the server configuration-to-machine
relationship does not have to be one-to-one.

Folders
This topic provides an overview of planning a folder tree and provides some tips for working with new and
existing folders. The project or server administrator usually creates projects and project views. If you are a
typical user, you routinely open a particular project view and manage your folders and their contents, such
as files and change requests. Managing application folders is very similar to managing a project. You can
create folders, delete folders, and modify their properties if you have the correct access rights.

Files
To place a file under version control, it must be added to an application folder. Adding the file causes a
copy of the file to be stored in the StarTeam repository. After the file has been added to file under version,
you and other members of your team can check it out, revise it, and check in new revisions, while file under
version maintains information on all revisions of the file. Note that all check-ins in file under version are
atomic. That means that if you check in multiple files, none of them are checked in if the check-in operation
for any one of them fails.
When checking out a file revision, you should verify that you have the tip or latest version of the file. Doing
this ensures that the file you see contains the latest changes. If you intend to modify the file, you should
check it out with an exclusive lock, to indicate to others that you are working on it.
When you check a file in, file under version records the file changes as a new revision. As part of the
check-in process, you can remove the lock, making the file available to others, or maintain the lock so you
can continue working on a locked file. If someone else checks in a file you are working on, your revision
becomes out of date. file under version assigns a Merge status to the file indicating that your changes need
to be merged with those made by someone else. You could do a force check-in of your changes, but that
would overwrite another person's work. It is usually best to check the file out a second time, merging it with
the changes you have already made. When you are sure that the file is correct, you can check it in.
Note: Using the StarTeam Eclipse Client, operations for files are surfaced using the:
•
•
•
•
•

StarTeam main menu commands;
Context menus provided in the various StarTeam views;
StarTeam-specific toolbar buttons;
Team context menu; or
Team Synchronizing perspective.

If a file resides in the working folder of an application folder, you can add that file to the application folder.
This operation places that file under version control. A copy of the working file becomes the first revision of
that file stored in the repository. If the working file is deleted later, the data is not lost because a copy exists
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in the repository. The application creates a new revision of this file in the repository every time you check
the file in.
Every time you check a file revision out, its contents are copied to a working folder. Checking out a revision
also ensures that you have the tip or a specific revision to work on.
The application enables you to label the tip revisions of every item within a view. For example, when the
project reaches a particular milestone (such as beta), you might give the view's items a label, called a view
label. Then you can configure the view to return to the way it was at the time the label was applied, check
out revisions as a group using that label, create a new view based on the label, or assign the label to a
promotion state.
The application also provides revision labels. You can label one or more revisions as you check them in or
by applying the label to each of the revisions using Labels found on the view's context menu in the Server
Explorer or the Labels command on the File menu. StarTeam makes it easy to check out those files as a
group using the label. A file revision can have any number of labels. However, no two revisions of the
same file in the same view can have the same label.
Recommendations for Working with Files Under Version Control
Here are some recommendations about using files under version control:
•
•
•
•

To let other team members know that you intend to make changes to a file, change the lock status to
exclusive as part of the check-out procedure.
As part of the check-in process, change the lock status to unlocked, making it available to others.
If you intend to continue making changes to the file but still want to check it in for backup purposes,
keep the file locked.
To prevent yourself from changing a file that you have not locked, select Window > Preferences >
Mark Unlocked Working Files Read-only the Mark Unlocked Working Files Read-only preference.
Then, if you check out a file that you have not locked, the working copy becomes read-only.

Change Requests
A change request is a request to change something within the scope of a project. For example, you might
suggest a product enhancement or request a fix for an error or problem. To use the change request
tracking system effectively, you need to understand the model on which it is based.
The change request component allows you to:
•

•

•

•
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Attach change requests to any folder. In the application, change requests can be attached to any
application folder or shared to other application folders in other views within the server configuration.
You can also link a change request to any other item, such as a file.
Make only appropriate status changes. When you create a change request, the status options are New,
Open, Deferred or a resolution. The resolutions are Cannot Reproduce, As Designed, Fixed,
Documented, and Is Duplicate. After resolution, a change request can only be verified or reopened.
After verification, a change request can only be closed or reopened.
Benefit from automatic changes based on the status of the change request. The application
automatically changes the person responsible to coincide with the current status of the change request.
When a change request is resolved, the responsibility for the change request automatically reverts to
the person who entered the change request, who is usually the best person to verify its resolution.
When a change request is reopened after being resolved, the responsibility is automatically set to the
user who resolved it. If desired, you can override these automatic changes and make another person
responsible.
Base change requests on the build in which the change request is resolved. When a change request
receives a Fixed or Documented status, the value of its Addressed In Build field becomes Next Build.
When that build label is created, the application replaces Next Build with the name of the build label,
letting testers know the build to use when verifying change requests.
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Note: This help system explains how to use the standard property dialog to create and edit change
requests. Depending on how your team has set up the application, you may see a different dialog
called an alternate property editor (APE). Even if you use the standard property dialog for change
requests, your company or team leader may implement change request guidelines that differ from
those discussed in this help system.

Requirements
Requirements are supported for the Enterprise Advantage license and display in the Requirement view in
the Workbench. With the Requirement component, you can create requirements within the application and
show the dependencies among them. For example, if one requirement must be fulfilled before a second
requirement can be fulfilled, the first can be made a child of the second. If your company enforces process
rules, the requirements you establish can also be used to drive the development process. Administrators
and other authorized users can publish requirements from Caliber to StarTeam using StarTeam Caliber
Requirements Publisher, which is delivered with Caliber.
Requirement Characteristics
The requirements displayed in the Requirement view have the following characteristics:
•
•
•

They are attached to the folder selected.
They match the filter selected from the Filter list box.
They match the depth specified by the all descendants button. (You can click the All descendants
button on the Requirements view toolbar.)
Note: Icons display to the left of a requirement in the Requirement view to indicate its status and
whether you have read the latest revision.

How Requirements Can Help
By using requirements-driven development processes, companies can prevent time-consuming, costly
misunderstandings and shorten time to market. To accomplish this, you can use the StarTeam built-in
Requirement component as your basic tool, or publish complex requirements to StarTeam from Caliber.
Using requirements enables business analysts, managers, developers, QA staff, and others to:
•
•
•
•
•
•
•
•
•
•

Organize business, user, and functional requirements in a hierarchical format.
Indicate the dependencies among requirements.
See all layers of requirements at all times.
Prioritize requirements by importance.
Identify the impact of changes to requirements.
Use requirements to estimate work.
Identify the person creating the requirement.
Notify those who will be responsible for fulfilling the requirements.
Track the requirement lifecycle from submitted to completed or rejected.
Provide requirements with a context by linking them to files, change requests, tasks, and topics.

Tasks
The Task component allows the creation of task lists and work assignments. As a standalone, the Task
component is very useful for managing a project. It allows team members to indicate who should do what
and when, see current task status, estimate hours required to complete a task, record hours spent
completing the task, and compare estimated to actual times. Because the application contains both a
version control system and a change request system, it also allows tasks to be linked to the files and
product defects or suggestions with which they are associated.
The Task component can be used independently or interoperate with data from Microsoft Project. It can
display tasks in a tree format, which clearly shows the relationship between tasks and subtasks, or in a list
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format, which allows tasks to be sorted, grouped, or queried, or specific fields to be selected for display. To
improve efficiency, each task displays icons that identify its status, priority, milestone, and need for
attention. For information about interoperating with Microsoft Project, see the documentation for the
StarTeam Microsoft Project Integration.
With the Task component, you can create an individual task or a summary task that has a set of subtasks.
It is recommended that you plan tasks before entering them because:
•

•

A task that has even one subtask cannot have work records added to it, although work records can be
added to subtasks. Some customers name the task to indicate the goal or milestone that will be
reached when the subtasks are completed.
After a work record has been added to a task, you cannot create subtasks for it.
Note: Regardless of whether work records can be added to a task, you should assign the
responsibility for its completion to a specific team member. If work records can be added to a task,
you should also estimate how long the task should take.

Topics
Topics are threaded conversations. They are a series of messages that indicate how the messages are
related. Each series of messages forms a tree with the initial message at its root. The Topic component
provides threaded conversations that you can place in specific project folders and link to specific project
items. For example, you can link a topic to the change requests and file revisions that result from the topic
discussion.
The Topic view consists of topics and a series of responses to each topic. A series of topic trees are
eventually formed, each of which consists of a root topic and its responses. The topic tree resembles a
conversation that may go on among several people. By reading each response in a thread, one after the
other, and the responses to those responses, you can see how the discussion has evolved. A number of
other operations can be performed on topics or responses such as moving or sharing them.
Historical Value of Topics
Topics can raise general questions about the project or start very specific discussions about issues, such
as feature implementation. While the responses can lead to resolution of these issues, the historical value
of these conversations to the project can be even more significant. Future team members can:
•
•
•

Reassess decisions more capably
Avoid retrying solutions that were previously found faulty
Understand why a particular solution to a problem became necessary and, therefore, not replace that
solution with one that does not meet all the necessary criteria

How Topics Can Help
Any type of threaded messaging improves teamwork on product development. However, because
StarTeam has tightly integrated components, it enables team members to:
•
•
•
•
•
•
•
•
•
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Search topics and responses for specific words or phrases
Sort topics and responses
Filter topics and responses
View relationships between topics and their responses
Move and share topics (from the tree format)
Link topics directly to folders or other items, such as change requests.
Ask questions and quickly receive input while working on a file.
Attach notes to a topic explaining why a particular method was used.
Point out aspects of the project that may need to change in a later release.
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Audit Logs
By default, the Server is automatically configured to generate audit logs. With this option activated, the
Server logs audit events for projects in the server configuration database. For example, the log records
when change requests are created, and when a file is added. The audit log entries can be viewed from a
client by opening the Audit view in the Workbench.
Note: This operation can be performed only on a server configuration that is running.
A chronological record, the Audit log accumulates data about the actions performed on folders, files,
requirements, change requests, tasks, and topics. Each log entry shows the user who carried out the
action, the date and time the action was performed, the class name (type of item), the event (type of
action), the view name, and the project name. By using filters or queries, you can locate all the entries for a
particular item.
For most items, events may be added, branched, commented, created, deleted, modified, moved from,
moved to, and shared. For files, events may also include converted, edited, item overwritten, locked, lock
broken, and unlocked. Log entries themselves cannot be moved, shared, modified, or branched.
Note: If the Audit view displays no entries, your administrator has probably disabled the Audit log
function.

Audit Fields
This section lists all the audit fields in alphabetical order.
Fields

Description

Class Name 1

Values: text
Internal Identifier: Class Name 1 (contains spaces)
The name of the class of items, such as Label, Promotion State, Folder, File,
Change Request, Topic, or Task.

Class Name 2

Values: text
Internal Identifier: Class Name 2 (contains spaces)
The name of the class of items, such as Folder, File, Change Request, Label,
Topic, or Task.

Class Name 3

Values: text
Internal Identifier: Class Name 3 (contains spaces)
The name of the class of items, such as Folder, File, Change Request, Label,
Topic, or Task.

Created By

Values: list of users, <None>
Internal Identifier: CreatedUserID
Always empty because the audit entry is created by the system.

Created Time

Values: date/time
Internal Identifier: CreatedTime
The time at which this entry was created.

Deleted By

Values: list of users, <None>
Internal Identifier: DeletedUserID
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Fields

Description
The name of the user who deleted an audit entry. Because deleted entries do not
appear in the list, this information is unavailable to users.

Deleted Time

Values: date/time
Internal Identifier: DeletedTime
The time at which an audit entry was deleted. Because deleted entries do not
appear in the list, this information is unavailable to users.

Event

Values: Added, Branched, Comment Edited, Created,
Deleted, Edited, Item Overwritten, Label Attached,
Label Created, Label Deleted, Label Detached, Label
Frozen, Label Modified, Label Moved, Label Unfrozen,
Lock Broken, Locked, Modified, Moved From, Moved To,
Promotion Model Modified, Promotion State Modified,
Shared, Unlocked, Vault Converted
Internal Identifier: EventID
The name of the operation being recorded.

Folder

Values: text
Internal Identifier: Folder
The name of the folder that stores the audit entry.

Folder Path

Values: text
Internal Identifier: Folder
Path (contains spaces)The path to the folder that stores the audit entry.

Folder VMID (Advanced)

Values: number
Internal Identifier: FolderVMID
The ID assigned to the folder that stores the item.

Item 1

Values: text
Internal Identifier: Item 1 (contains spaces)
Indicates what class 1 item received the audited operation. This can be the name
of a file or task, the number of a change request or requirement, or the title of a
topic.

Item 1 Info

Values: text
Internal Identifier: Info
Provides the revision number in dot notation for the class 1 item, if it is
revisionable. For example, a label can be a class 1 item and it does not have
revisions.

Item 2

Values: text
Internal Identifier: Item 2 (contains spaces)
Indicates what class 2 item received the audited operation. For example, if a
label was attached to a file, the class 1 item is the label and the class 2 item is
the file.

Item 2 Info

Values: text
Internal Identifier: Info2
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Fields

Description
Provides the revision number in dot notation for the class 2 item, if it is
revisionable. For example, a label can be a class 2 item and it does not have
revisions.

Item 3

Values: text
Internal Identifier: Item 3 (contains spaces)
Indicates what class 3 item received the audited operation. For example, if a
label was moved from one revision to a file to another, the class 1 item is the
label, the class 2 item is the revision of the file that was initially , and the class 3
item is the final revision of the file.

Item 3 Info

Values: text
Internal Identifier: Info3
Provides the revision number in dot notation for the class 3 item, if it is
revisionable. For example, a label can be a class 1 item and it does not have
revisions.

Modified By

Values: list of users, <None>
Internal Identifier: ModifiedUserID
Does not apply to audit entries.

Modified Time

Values: date/time
Internal Identifier: ModifiedTime
Does not apply to audit entries.

Object ID

Values: number
Internal Identifier: ID
Each audit entry is assigned an object ID when it is added to a view.

Project

Values: list of projects in this server configuration, <None>
Internal Identifier: ProjectID
The name of the project in which an audit entry was recorded.

Target 1 Class ID (Advanced)

Values: number
Internal Identifier: Target 1 Class ID (contains spaces)
The ID number assigned to class 1 items or a -1 if there is no ID.

Target 1 Object ID (Advanced)

Values: number
Internal Identifier: Target 1 Object ID (contains spaces)
The object ID for the class 1 item that received the audited operation or a -1 if
there is no ID.

Target 1 Revision Time

Values: date/time
Internal Identifier: Target 1 Revision Time (contains spaces)
The time at which the last revision was made to the class 1 item that received the
audit operation.

Target 2 Class ID (Advanced)

Values: number
Internal Identifier: Target 2 Class ID (contains spaces)
The ID number assigned to class 2 items or a -1 if there is no ID.
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Fields

Description

Target 2 Object ID (Advanced)

Values: number
Internal Identifier: Target 2 Object ID (contains spaces)
The object ID for the class 2 item that received the audited operation or a -1 if
there is no ID.

Target 2 Revision Time

Values: number
Internal Identifier: Target 2 Revision Time (contains spaces)
The time at which the last revision was made to the class 2 item that received the
audit operation.

Target 3 Class ID (Advanced)

Values: number
Internal Identifier: Target 3 Class ID (contains spaces)
The ID number assigned to class 3 items or a -1 if there is no ID.

Target 3 Object ID (Advanced)

Values: number
Internal Identifier: Target 3 Object ID (contains spaces)
The object ID for the class 3 item that received the audited operation or a -1 if
there is no ID.

Target 3 Revision Time

Values: date/time
Internal Identifier: Target 3 Revision Time (contains spaces)
The time at which the last revision was made to the class 3 item that received the
audit operation.

User

Values: list of users, <None>
Internal Identifier: UserID
The name of the user who performed the recorded operation.

View

Values: list of views, <None>
Internal Identifier: ViewID
The name of the view in which an audit entry was recorded.

Objects
Objects are the core information artifacts within a server. Objects, also known as content objects, are
versioned so that individual revisions can be accessed, labeled, branched, and so on. The content of an
object is stored by StarTeam as a series of properties, each of which has a name and a value. For each
object type, you can add custom properties if you need to store more information than is available in the
built-in properties. StarTeam supports files, folders, change requests, requirements, tasks, and topics as
object types.
Objects are exposed by items in StarTeam, so the terms object and item are sometimes used
interchangeably throughout the documentation. However, objects and items are distinct entities.
File Objects
Files are often the most important artifacts you store in StarTeam. File properties contain metadata such as
the Modified By property, security, and history, all of which is stored in the repository. Files also contain
binary or textual data, which is stored in the vault. Files are versioned and can be branched into separate
version trees. Files are supported by other configuration and management features such as links and
labels.
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Folder Objects
Every view has a root folder, which typically contains a tree of subfolders beneath it. A folder can contain
objects of any type, including other folders. Although folders are containers, they have properties and are
versioned, so they are also objects and, like files and change requests, can branch. Note that the logical
path name of a folder is defined by prefixing its name with that of its parent folders names. However, the
corresponding working folder path, which is where files within the folder are stored locally at the client, may
not match the logical path name. The working folder path can be overridden on a per-folder and per-client
basis.
Change Request Objects
StarTeam supports integrated defect and enhancement request tracking via change requests. Like files,
change requests can be versioned and branched, linked, labeled and so on. Change requests are typically
used to represent discrete requests such as bug reports or new feature suggestions.
Requirement Objects
StarTeam supports lightweight requirements objects that can be used to document early development
lifecycle steps. Requirements can be authored and utilized directly in StarTeam, or they may be imported
and synchronized with objects from formal requirements management systems such as Caliber using the
StarTeam Caliber Requirements Publisher. Requirement objects support versioning, linking, and labeling
but do not branch.
Task Objects
StarTeam tasks are analogous to work items found in project management systems such as Microsoft
Project. The StarTeam Microsoft Project Integration enables you to synchronize tasks with Microsoft
Project tasks. A task typically represents a step in a larger work plan and may be assigned to multiple
people. Therefore, a task may be divided into subtasks and tracked via multiple work records. Tasks are
versioned and can be labeled, linked, and so forth, however they do not branch like files and change
requests.
Topic Objects
A topic is a newsgroup-like message that can be posted by one user, responded to by another, and so on.
A chain of topics on a given subject create a threaded discussion that can be attached to a file, change
request, or other object to capture a conversation important to a development activity. Like tasks, topics
are versioned but do not branch.

Objects Versus Items
It is important to understand how objects are surfaced through views. Every content object is exposed to a
view by an association object called an item (also called a view member). When a new object, for example
a file, is added to a view, StarTeam creates a new file object with version 1.0, and it creates a new item
that points to that file. The item not only specifies which file is referenced, but it specifies the folder in which
the file appears. For example, if you move the file from one folder to another, you actually modify the file
item to point to a different parent folder item, but the file and folder objects are not actually modified.
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Relationship Between Items and Objects

The figure above shows the relationship between items and objects. In this example, two views are shown,
each of which points to its root folder item. Every item points to a corresponding object, which holds the
object properties, and every item other than the root folder item points to a parent folder item, that
designates the folder where it resides.
Child Items
An item created on behalf of a new object is a parent item. Copying a parent or child item creates a child
item. This allows the same object to be surfaced in another location. A child item points to the parent item
from which it was copied. Child items are created in two situations:
•

•

Child views: When a new view is created as a child of another view, the items in the parent view are
copied to create the items in the child view. The objects themselves are not copied. The new child view
items point to the same objects.
Shares: An item can be explicitly copied, creating a share item. This is done, for example, by holding
the Control key and dragging an item from one folder to another in the Server Explorer. In this case, the
selected item is copied, initially pointing to the same object as the original item.

Separation Between Object and Item Properties
The primary difference between child view items and child share items is their initial configuration. The
behavior of an object is partly influenced by the configuration of the parent or child item through which it is
manipulated. To understand how parent and child items behave, it is necessary to understand the
separation between object and item properties:
•

•
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Object properties: Most of the properties you see in StarTeam-name, modified by, version, data (for a
file), and so on-belong to the object. When the object is modified in any way, another revision of the
object is created. For example, if the current revision of a change request is 1.2 and the Responsibility
property is modified, the modified change request is stored as revision 1.3. If a new version of a file
currently at revision 1.4.1.2 is checked in, the new version is 1.4.1.3.
Item properties: An item contains properties that define the object referenced, the folder where it should
appear, and how updates to the object through the item should be handled. Most of the properties for
an item such as parent view and parent folder are implicitly managed by StarTeam based on client
actions. There are three key item properties that affect the manipulation of the object referenced by the
item:
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Object ID

This property defines the object branch to which the item
refers. Each new object receives a unique object ID, and
its revision number begins at 1.0. The revision number for
the object increments each time it is updated (1.1, 1.2,
and so on), but the object ID is not changed. Therefore,
the object ID referenced by an item points to the entire
object branch and possibly a specific revision. When an
object branches, a new object with a new object ID is
created, and its revision number is extended to reflect the
branch point (for example, 1.2.1.0). An item refers to the
new branch by updating the object ID to which it points.

Behavior Configuration

This property defines whether the item is floating or
pinned to a specific point in time. When the behavior of
an item is set to floating, the item points to the tip revision
of the object branch to which the item refers. When the
behavior of an item is set to a specific point in time, the
item refers to the object revision that was current at that
time.

Branch-on-change

This property is only valid for a child item referencing a
file or change request. It controls what happens if the
object is modified through the item. If this property is true,
branch-on-change causes a modification to start a new
branch for the object. For example, a file checked in
through the item when the current revision is 1.2 will start
branch 1.2.1.0. When the branch-on-change property is
false, either the underlying object has already branched
through this item, or updates through the item operate on
the same object as the parent item, or the item is readonly (frozen).

Child view items are automatic shares that are created and managed by manipulating the views to which
they belong. Therefore, you can usually focus on managing the view itself without worrying about the child
items.
However, manual shares that you create within the UI or by using SDK commands require more attention
to item properties to understand how updates will propagate to other items in the same share tree. For
example, shared item operation can be complicated when a parent item is deleted, if an intermediate
behavior of a shared item changes, or if the shared item is a folder. For these reasons, shares should be
used cautiously. Furthermore, shares across project boundaries should be used with even greater scrutiny.

Lifecycle Features
By themselves, containers, objects, and items allow you to capture development artifacts and organize
them according to the needs of your projects and teams. StarTeam provides additional core features that
support processes such as builds, releases, and change management. These features, links, labels, and
process rules, focus on the development lifecycles through which information flows.
Links
StarTeam links allow arbitrary objects to be related. For example, you can link a change request to the files
modified to fix it. Each end-point of a link can be pinned to a specific revision of an item or float to the latest
version of the item.
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Labels
A specific set of item revisions can be referenced by means of a label. A view label typically references a
specific revision of every item in a view, while a revision label references specific revisions of a small group
of items.
Process Rules
A project can be configured to enforce process rules, which require the use of specific change requests,
tasks, or requirements as controlling items for file check-ins. When activated, process rules promote
change traceability by linking new and modified files to the process items to which they are related.

Projects
A project is a way to group related items (such as files and change requests) hierarchically. Views and
folders enable you to organize these related items more efficiently. For example, if you create a project for
a software product, the files containing the product's functional specification, marketing requirements
document, source code, and test suites can each be stored in separate folders.
Views can be used in a variety of ways. For example, different views can be used so that developers see
only the project's source code folder and its child folders, marketing personnel see only the project's
marketing folder and its child folders, and so on. In this case, each view has a different folder as its root.
Views also support branching and parallel development
At the view level or item by item, you can branch data such as files and change requests. The branching
enables you to create a special variation of your product. For example, you can start on the 2.0 version of
your product without hampering the creation of service packs for the 1.0 version
You can create a project on any StarTeam server configuration, if your computer has access to that server
and you have been granted the rights needed to create projects in that location. When you create a project,
you must provide a project name and designate a working folder location for the project's root (initial)
folder. The initial view of the project is created at the same time you create the project. It has the same
name as the project, although you can change the name later if you choose. The root folder is also created
at this time. If your computer is not currently set up to access the server on which the project will reside,
you can add access to that server as part of creating the project.

Project Structure
An instance of the Server controls the storage of your files. Each Server instance runs a server
configuration. Below are some diagrams illustrating how all these pieces fit and work together.
Server-level Hierarchy
The server can manage any number of projects.

Project-level Hierarchy
Each project has one root view and any number of child views.
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View-level Hierarchy
The root view and every child view has one application folder as a root folder.

Folder-level Hierarchy
An application root folder can have any hierarchy of child folders. This is called the folder hierarchy.

Keeping Projects Autonomous
The time-honored programming tenets of high cohesion and low coupling apply to StarTeam projects as
well. The more independent your StarTeam projects are, the easier they are to secure, administer, and
even separate from the original StarTeam configuration if necessary. Keeping projects autonomous means
keeping cross-project links and shares to a minimum, avoiding them completely if possible.
Below are some guidelines for deciding what should be in the same project:
•

A project should be used to manage the lifecycle artifacts of a cohesive application set or application
component set. Examples are a commercial software product or a foundation library package. Multiple
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•

•

•

•

•

application or component sets can be managed in a single project if they are interrelated and generally
enhanced and released together.
A project should include all of the artifacts required to manage the lifecycle of the supported
applications or components. This includes early lifecycle artifacts such as requirements documents,
modeling diagrams, and design documents, as well as construction phase artifacts such as source files.
A project should include files required to perform authoring. This includes, for example, all files authored
by the IDEs such as workspace/project files, source code, and resource files. It also includes "input
files" such as .h, .lib, .jar, or .dll files that are authored or generated elsewhere but required by
the project's IDEs or build processes. Input files may originate from third parties or from other projects in
the same or other StarTeam configurations. (Transferring artifacts from one project to another is
discussed further later.)
Files directly generated from authored files such as .obj, .class, and .lib files generally do not need to be
checked into the project. However, it is common practice to check in "final" binaries such
as .jar, .war, and .exe files that are delivered to other projects, engineering test, QA, or other
deployment phases. The need to place generated files under version control is highly dependent on
your own development, testing, and release methodologies.
A project should have a long-term view of the products or components it supports. That is, it should
house all artifacts generated over multiple iterations through the lifecycle. This means that the project
supports multiple versions of its applications or components, representing the complete history of those
modules.
StarTeam works best when the supplemental objects (change requests, tasks, topics, and
requirements) related to a project's files are stored in the same project. This allows, for example, a
change request to be entered, tracked, and linked to the files in the same project to which the change
request is related. This approach requires some special considerations for activities such as "change
request triaging" and cross-project reporting. These issues are discussed later.

Some customers have attempted to use projects to separate development phases (for example, design
and development) or development artifact types (like files and change requests). The artifacts are then
interrelated by sometimes heavy use of links or shares. However, experience has found that copious use
of shares "especially cross-project shares" results in difficulties in version control, reporting, security, and
even performance. Evidence suggests that artifacts that are related to the same applications and
components, though of different types and/or lifecycle relevance, are more effectively managed in the
same project.
Example 1: A Simple Client/Server Application
Scenario: A commercial software application consists of a server written in C++ and a
single client, also written in C++. Furthermore, the client and server modules share a
fair amount of source code and IDE projects that generate common DLLs. The client
and server modules are generally enhanced and released together.
In this scenario, a single StarTeam project should be used to manage the combined
files of both the client and server modules. The sharing of source code and shared
release schedules suggest that the modules are cohesive parts of a single application.
Requirements, design documents, change requests, and other objects required for all
lifecycle phases of the client and server modules should be managed in the same
project.
Example 2: An Independent Client Module
Scenario: A new Java client application is developed that uses the same server
described in Example 1. Building and compiling the Java client requires some of the
header files and one of the DLLs used by the server to produce a JNI wrapper, but no
other source files. Furthermore, the Java application accesses other third-party servers
and is generally enhanced and released on independent schedules from those used by
the client/server modules.
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In this scenario, it is reasonable to use a separate StarTeam project to manage the
Java client's artifacts. The latest header files and generated DLL needed by the Java
client are checked into a "external components" folder by the build process used in the
client/server project. All change requests, tasks, and other lifecycle objects related to
the Java client are managed in the same project.

Example 3: A Complex Financial Application Suite
Scenario: A complex application suite consists of a set of foundation components and
nearly 100 separate applications, divided into five functional areas: accounting,
insurance, forecasting, etc. The applications are developed by different teams and all
use the foundation components, which are jointly maintained by the development
teams. Applications within a functional area are highly interrelated, but applications
between functional areas are fairly independent. The foundation component library is
enhanced and released on its own schedule, but the entire application suite is released
as a commercial product in coordinated releases.
Although the entire application suite is interrelated, multiple projects should be used due
to the overall application suite size. The foundation components are managed in one
project, and each of the five functional areas utilize a separate project to manage the
corresponding applications (six projects total). The foundation project is enhanced, built,
and then "deployed" to each of the functional area projects by checking in generated jar
files. Each development team generally opens only one project to perform their normal
work. However, a special build script (using the StarTeam SDK) is used to extract files
from multiple projects and generate "whole suite" builds. The build script also automates
the management of common view labels and promotion states across projects.

Cross-Project File Dependencies
When projects are highly cohesive, cross-project dependencies will be minimal, yet cross-project file
relationships may still occur. Some files, either authored or generated, may need to be used in multiple
projects.
The impulsive way to handle this situation may be to share the codependent files from one project to
another. On the surface, this approach works, but experience has shown that cross-project sharing is
problematic for several reasons:
•

•

•

•
•

If a share's behavior is configured to "floating", changes from the parent project flow into the child
project immediately, sometimes at inconvenient times. Many StarTeam users find that they need to
manage the update propagation on a more scheduled basis.
If a share's behavior is configured to a specific timestamp, it must be occasionally adjusted to allow
updates to propagate. This makes the shared item read-only, and continually adjusting the configuration
timestamp for a large number of shares can become burdensome.
If a share's branch-on-change property is set to "true" (perhaps accidentally), and a change is made to
the child share, the object will branch in the child project. This severs the share from the parent object
and is difficult to reverse. If the child share is a folder, an innocuous change such as modifying the
working folder will cause the folder object to branch.
When an update is made to an item that participates in a share tree, every item in the tree must be
locked. As the share tree grows, update performance is impacted proportionately.
Normally, when obsolete views and projects are deleted, the StarTeam purge utility can be used to
return unused database records and archive files. However, shares used by a deleted project or view
can prevent the purge utility from achieving the expected reduction in database and archive size. In
short, it might not be possible to reduce the size of servers that use cross-product sharing.

Because of these reasons, other techniques have proven to be more effective at handling cross-project file
dependencies. Below are some alternatives to sharing that work in different situations. In the end, shares
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still may be the most appropriate way to expose files from one project to another, but the approaches
below should be considered first.
Deployment Approach
If a project "owns" a set of files that must be checked into other projects, you can establish a process in
which the files are periodically "deployed". This means that the file set is checked into the target project(s)
on an as-needed basis, perhaps by a script. Often, a build script is a good place to embed the deployment
task, especially if the file(s) to be deployed are generated by the build.
Configuration Approach
Sometimes the codependent files don"t need to be checked into each project, but they need to participate
in a common process such as a build or delivery process. In these cases, a simple XML file can be
constructed that defines the files that participate in process. If the file is checked into an established
location and updated when the configuration changes, then build, release, or other scripts can check out
the XML file, parse it, and base their processing on its instructions.
Link Approach
In lieu of shares, links can be used to connect objects across servers. Links do not possess many of the
problems exhibited by shares, and they can be pinned, unpinned, and moved to refer to different object
revisions. The downside of using links is that they are untyped, not versioned, and possess no properties
other than a link comment to distinguish them from other links that may be present.

Cross-Project Activities
Regardless of how you partition your projects, you may find that certain lifecycle activities span multiple
projects. Some examples of these scenarios and how they can be addressed are provided below:
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Multi-project Builds

Build procedures that require files from multiple projects
can use the StarTeam SDK, which can open multiple
projects at the same time. Alternatively, iterative calls to
the StarTeam command line tool (stcmd) can be used to
check-out files from each of the required projects.

Defect Triaging

When a new defect is discovered, it is often entered as a
CR before the module that must be repaired is known.
This means that, if CRs are normally managed in the
project containing the files that will be modified, a
paradox exists in determining where to create the CR in
the first place. A project leader or other person usually
"triages" the CR by assigning it to whoever he or she
thinks should handle it. As the CR is analyzed and
addressed, the module that is ultimately modified to
address it may not be known for a while. A simple
solution for this scenario is to place all CRs in a well
known place (perhaps a "new defects" project) and
"move" (not copy) them to the appropriate project as
needed.

Cross-project Reporting

Currently, StarTeam does not provide built-in, crossproject reports. Consequently, if you want to generate
reports such as "all open CRs across all projects" or
"cross-server file metrics", your best option is to use the
StarTeam SDK to write simple reporting apps in Java,
VB, or your favorite language of choice.
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Working with Projects
A StarTeam project is a way of grouping together all the items associated with a particular endeavor. Most
frequently, this endeavor is a software application created by your company or a component of that
application.
A project may include views, folders, files, change requests, requirements, tasks, topics, and audit log
entries. It resides on a single server and server configuration.
When a project is first created, it has an initial or root view. However, over time, any number of child views
may be derived from that view.
StarTeam uses views to:
•

•

Provide access to a subset of the files in a project. For example, a developer may not need to see the
project files used for marketing purposes, while a market researcher might not need to see the source
code files. With StarTeam, both can work on the same project in different views, each of which is a
subset of the root view. Such views are called reference views.
Provide a branch for the project. For example, suppose the root (or initial) view of a project stores
source code for Release 1.0 of a software application. After the application is released, your company
plans to work on Release 2.0 in the root view. Therefore, it creates a branch view for work on a
maintenance release (e.g., Release 1.0 Service Pack 1). Because the branch has a different view, it
allows files with the same names to contain different code. StarTeam allows you to merge such files
when required.

All views, whether they are a root view or a child view, have a single StarTeam folder as a root folder.
However, a root folder can contain a hierarchy of child folders.
When you create a project, its root view and root folder are created automatically and given the same
name as the project. You can change these names at any time, if you have the appropriate access rights.
Each folder has a corresponding working folder on your workstation – that is, a location to which files are
checked out. You can set up your working folders to form a hierarchy similar to that of the Server Explorer
or to have different paths.

Sharing Workspace Projects
Follow the high-level steps below when using the Share Project wizard.
These steps assume that:
•
•
•

You have not yet created a connection with a StarTeam Server configuration.
You have already created multiple Eclipse projects in the Workspace to share.
You have pre-existing StarTeam projects created for the StarTeam Server configuration that you are
sharing with the Eclipse projects.

1.
2.
3.
4.
5.
6.

Open the Share Project wizard.
If necessary, create a new StarTeam connection.
Log on to a StarTeam Server.
Enter repository location information.
Synchronize your workspace project with the StarTeam repository.
Check in the workspace project files to the repository.

Opening the Share Project Wizard
1. In the Navigator or Package Explorer, select the root nodes of the projects you want to share.
2. Right click on the selected projects and choose Team > Share Project. The Share Project wizard
opens.
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3. Select StarTeam as the repository type and click Next. The next screen of the wizard opens enabling
you to configure your workspace project to use the StarTeam repository.
Creating a New Connection
1. Select Create a new StarTeam connection and click Next.
2. Type a unique, easy-to-remember description in the Server description text box.
The server description is not case-sensitive and can contain colons ( : ).
3. Type the computer name or IP address in the Server address text box.
See your administrator for the server address, protocol, and endpoint information.
4. Type the endpoint (TCP/IP port number) associated with the protocol in the TCP/IP endpoint text box.
5. Click Test Connection.
6. Choose to specify any of the following optional settings:
•
•

Check the Save Password option to enable the User Name and Password text boxes.
Select an Encryption type to encrypt data transferred between your workstation and the server.
Encryption protects files and other project information from being read by unauthorized parties over
unsecured network lines. The encryption types are ordered (top to bottom) based on speed. Each
type is slower, but safer, than the type that precedes it.
• Check the option to Compress transferred data if you want to use compression.
7. Click Next when you are finished.
Logging on Server with Existing Connection
1. Select Use an existing StarTeam connection, and choose your server configuration from the list.
If you did not enter your log-on information on the New Server Connection page, the Log On dialog
box opens.
2. Enter a User name and Password in the appropriate text boxes.
Passwords are case sensitive and may have length restrictions.
3. Optional: Check Save as default credentials for this server.
4. Click OK.
Designating a Project View and Folder to Share
1. Expand the nodes of your server configuration to select a project view.
2. Click Next.
3. Do one of the following:
•
•

Select a folder from the resulting list.
Click New Folder to create one.
4. Click Next.
By default, this setting maps to the default setting for StarTeam server-side (remote) folders. Most users
will accept this as their default setting. This means that you are using the default folder name provided
by StarTeam Server to name your local folders. However, while sharing the Eclipse project with
StarTeam, you can override this setting at the project-level by checking Enable project-specific
settings.
5. Choose desired settings in the Mapping Preferences page, or accept the default settings, and click
Finish . A dialog box opens asking you if you would like to synchronize the newly-shared project.
Synchronizing Newly-Shared Projects
1. Click Synchronize. The Team Synchronizing perspective opens. The Incoming/Outgoing mode is
automatically selected showing the files to add to the repository.

46

| Borland StarTeam Eclipse Client

2. Select the appropriate files or folders that you wish to check in, right-click, and choose Check In. The
Check In dialog box opens.

Opening an Existing Project View
Before you can access an existing StarTeam project view, you must log onto the appropriate server
configuration to display the projects and views associated with it.
Important: The term view should not be confused with the Eclipse UI usage of view. In StarTeam, a
view consists of an application folder tree and the items associated with each folder in that hierarchy.
1. Open Server Explorer.
2. Right-click the name of the StarTeam server configuration on which the project is located, and choose
Log On. The Log On dialog box opens.
3. Type User name and Password.
4. Click OK.
5. Expand the server configuration name to display the list of projects for the selected server configuration.
6. Expand the project you wish to open. Displays the name of the project root view.
7. Expand to the folder level.

Create Projects and Synchronize Local Files
At a high-level, creating a new StarTeam project and associating an existing workspace project with it
involves the following steps:
These steps assume that:
•
•

You have not yet created a connection to a StarTeam server configuration.
You have already created an Eclipse project in the Workspace to share.

Creating Projects
1. Open a StarTeam perspective or view.
2. Choose StarTeam > Project > New.
Alternative 1: In the toolbar, click Create a new StarTeam Project. Alternative 2: Open the Server
Explorer, select a server configuration node, and choose New > Project from the context menu.
The New Project wizard opens.
3. If you do not have a project selected before using one of the commands above, you must select a
server configuration for the project from the server list, and click Next.
If the server you want is not in the Server/Project Tree, click Add Server and add it using the Add
Server dialog box.
4. Type the name and description for the new project in the Project Name and Project Description fields.
5. Click Next.
6. Browse to the folder on your computer that will be the default working folder for the project root folder.
If the working folder does not exist, type the folder path and name and the New Project wizard creates
it for you.
Note: The default working folder must point to a location that is physically discrete for each user,
such as a drive on your local computer or a personal directory on a shared file server.
7. Click Next.
8. Choose any folders to exclude from the StarTeam project, and click Next.
You may want to use this option to exclude status data from other version control systems like
Subversion (.svn) or CVS (CVS, .cvsignore).
9. Optional: If the working folder has child folders, uncheck any child folders you do not want added to the
project.
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Click Select All to include the previously excluded folders.
10.Click Finish.
After you create a project, the Server Explorer displays a hierarchical view of it. You can add other folders
or StarTeam items using the context menus provided in the Server Explorer or various StarTeam views.
Sharing Workspace Projects with New Project
1. Select your workspace project in the Package or Navigator Explorers, and choose Team > Share
Project.
2. Select StarTeam.
3. Click Next.
4. Select your server configuration containing the newly-created StarTeam project and view.
5. Click Next.
6. Select a folder from the list, or click New Folder to create one.
7. Click Next. The Mapping preferences page opens. By default, this setting maps to the default setting for
StarTeam server-side (remote) folders. Most users will accept this as their default setting. This means
that you are using the default folder name provided by StarTeam Server to name your local folders.
However, while sharing the Eclipse project with StarTeam, you can override this setting at the projectlevel by checking Enable project-specific settings.
8. Choose desired settings in the Mapping Preferences page, or accept the default settings, and click
Finish. A dialog box opens asking you if you would like to synchronize the newly-shared project.
Synchronizing Newly-Shared Projects
1. Click Synchronize. The Team Synchronizing perspective opens. The Incoming/Outgoing mode is
automatically selected showing the files to add to the repository.
2. Select the appropriate files or folders that you wish to check in, right-click, and choose Check In. The
Check In dialog box opens.

Deleting Projects
To delete a project you must have the delete privilege or access right.
Once a project is deleted, you and other members of your team will no longer be able to access any item in
the project. If other users are connected to the project at the time it is deleted, they will receive a message
the next time they initiate a project or view command. Deleting a project does not remove any data from
the server database. However, items that are not shared will no longer be accessible.
Caution: Deleting a project is an unrecoverable operation.
1. Open the Server Explorer.
2. Right-click on the project name, and choose Delete. A message displays, asking you to confirm the
deletion.
3. Click OK. A dialog box opens requesting you to enter the exact name of the project that you wish to
delete.
4. Type the name in the text box provided.
5. Click OK.

Changing Project Names or Descriptions
1. Choose StarTeam > Project > Properties
Alternative: In the Server, Navigator, or Package Explorers, right click on the project, and choose
Properties.
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The Properties dialog box opens.
2. Do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Project.
If opened from the StarTeam main menu or Server Explorer, select Project.

3. Select the Name tab.
4. Type a new project name in the Name text box.
5. Type a new project description in the Description text box.
6. Click OK.

Refactoring
"Team refactoring" involves renaming or moving files and folders that have been placed under version
control in a shared environment.
Note: When conflicts occur, the client provides immediate feedback, and a dialog box opens asking
you to confirm the change.
1. In the Navigator or Package Explorer, select an item.
2. Right-click and choose either:
• Move
• Rename
3. Do one of the following:
•
•

For a move, select the destination on the Folder Selection dialog box, and click OK.
For a rename, type the new name, and press Enter.
Note: Before renaming a folder, click F5 to perform a refresh in Eclipse.

If you use the Move command on your project items and you try to check in your changes, Eclipse
reports this and suggests that you use the Move action in the Synchronize view to preserve the
resource history.
4. Open the Team Synchronizing perspective's Synchronize view to review any items reflecting a
[moved] status.
5. Multi-select any [moved] items in the Synchronize view and choose Move.

Viewing or Modifying Project Properties
With appropriate access rights, you can configure each project with properties that allow you to specify the
project name, enable keyword expansion, require revision comments on check-in, specify file locking
behavior on check-in, define process rules and process items, and specify alternate property editors.
1. With a StarTeam perspective or view open, choose StarTeam > Project > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the project, and choose Properties from
the context menu.
The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Project.
If opened from the StarTeam main menu or Server Explorer, select Project.

3. Select a tab containing properties you want to view or change.
4. Make all desired changes, then click OK.
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Enabling Keyword Expansion
Keywords are automatically expanded during file check-outs to provide file and revision information within
the file. You should use only one keyword per line. Keyword expansion should work for all "ASCII-based"
encodings, which includes UTF-8, Cp1252, and so on. It does not include the various UTF-16 encodings.
StarTeam currently treats UTF-16 encodings as binary and does not attempt to perform either EOL or
keyword expansion on them.
Important: Never use a keyword in a revision comment, as it will be expanded during the keyword
expansion process.
1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Project > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the project, and choose Properties
from the context menu.

The Properties dialog box opens.
2. Do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Project.
If opened from the StarTeam main menu or Server Explorer, select Project.

3. Select the Options tab.
4. Check the Keyword Expansion check box to enable keyword expansion and use keywords in your text
files.
This check box applies to files added or checked in from StarTeam or from integrations with third-party
applications.
5. Type the file extensions in the Expand Keywords for These File Extensions text box for which you
want to use keywords.
You can use a space, comma, or semicolon as keyword delimiters. The file extensions list can contain a
maximum of 254 characters. If you leave this text box blank, no keywords will be expanded.
.bat, .cpp
Note: When Keyword Expansion is enabled, the StarTeam Eclipse Client uses the encoding specified
in the StarTeam Properties dialog box to expand the keywords in files as the files are checked-out.
After check-out, any encoding changes are managed by Eclipse, not the StarTeam Eclipse Client.

Establishing Process Rules for Projects
Establishing a system of process rules allows you to:
•
•
•

Require that process items are used every time files are added or checked into the project.
Stipulate that only certain types of items with specific statuses can be used as process items in the
project.
Enable the use of enhanced process links for the project.
Note: To set process rules, you must have the access rights required to change project properties.
Usually, only team leaders and administrators have these rights. You must also verify that project
users have the rights to see and modify items in the project view, to create and modify links on files
and process items, and to create tasks and link to tasks if using the enhanced model.

Requiring Process Items at Check-in
1. Choose Project > Properties.
2. Expand StarTeam Provider, and select Project.
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3. Check Require Selection Of Process Items When Files Are Added Or Checked In on the Process
Rules tab.
4. Check which types of items you want to allow for use as process items.
Permitting Change Requests as Process Items
1. Check Permit Selection Of Change Requests As Process Items.
2. Do one of the following:
•
•
•
•

Check Open to use only change requests with Open status.
Check In Progress to use only change requests with In Progress status.
Check both Open and In Progress to use only change requests with either of these statuses.
Uncheck both Open and In Progress to allow any change request to be used as a process item,
regardless of status.

Permitting Requirements as Process Items
1. Check Permit Selection Of Requirements As Process Items.
2. Do one of the following:
•
•

Check Approved to use only requirements with Approved status.
Uncheck Approved to allow any requirement to be used as a process item, regardless of status.

Permitting Tasks as Process Items
1. Check Permit Selection Of Tasks As Process Items.
2. Do one of the following:
•
•
•
•

Check Ready To Start to use only tasks with Ready To Start status.
Check In Progress to use only tasks with In Progress status.
Check both Ready To Start and In Progress to use only tasks with either of these statuses.
Uncheck both Ready To Start and In Progress to allow any tasks to be used as a process item,
regardless of status.

Excluding Files and Folders
Some types of files will never be added to a StarTeam project, although they may reside in a working
folder. For example, suppose you are creating files with an application that makes an automatic backup
(.bak) copy of each file every time you save the file. Although your working folder might contain
several .bak files, you would have no reason to check them into (or out of ) the repository. Therefore, you
should exclude them from the project view. Exclude lists can also be inherited from parent folders.
1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Folder > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the desired folder, and choose
Properties.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Folder.
If opened from the StarTeam main menu or Server Explorer, select Folder.

3. Select the Exclude tab.
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Note: The Exclude tab does not affect files that are already part of the project.
4. Choose one of the following:
Option
Description
Inherit and Use Local Excludes files that match the exclude list specifications set for this folder as
Exclude List
well as those of its parent folder. If the Local Exclude List text box does not
yet include any file specifications, add them.
Use Local Exclude
List

Excludes files that match the exclude list specifications set for this folder. If
the Local Exclude List text box does not yet include any file specifications,
add them.

No Exclude List

Includes all files.

5. Type one or more file specifications to use for matching files.
Use the standard expressions (with * and ? wild cards) separated by commas, spaces, or semicolons.
To include a comma, space or semicolon as part of the specification, enclose the specification in double
quotes. A trailing / character represents Not-in-View folders to be excluded. For example, bin/ would
cause all Not-in-View folders named bin to be excluded from the folder tree.
Note: The \ character does not work; it is treated as an escape character.

Requiring Exclusive Locks for Check-ins
Files are not required to be locked in order to make changes. However, users with required privileges can
mandate exclusive locks if necessary.
Although this requirement helps you to avoid merge situations, you still must:
•
•
•

Notice whether a file is already exclusively locked by another user before they check it out to work on it.
Lock each file before making changes, to alert other users to their intentions.
Be sure that the status for each working file is Current to avoid changing older revisions of the files. If a
file status is not Current, the file must be checked out before any changes are made.

1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Project > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the project, and choose Properties.

The Properties dialog box opens.
2. Do one of the following:
• If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Project.
• If opened from the StarTeam main menu or Server Explorer, select Project.
3. Select the Options tab.
4. Check Require Exclusive Lock When Files are Checked In.
When this option is selected, only a person who has exclusively locked a file can check it in.
Note: If you are using an application integration for a development environment, such as StarTeam
Visual Studio 2010 Integration, you cannot check in files from that environment if both the Require
Exclusive Lock When Files are Checked In check box in the Project Properties dialog box, and
the Use Non-exclusive Locks in Integrations check box on the Preferences dialog box (File tab)
are selected. In this situation, uncheck Use Non-exclusive Locks in Integrations to check files in.

Requiring Revision Comments
Administrators can force users to supply a check-in reason by adjusting the properties for the project. This
requirement will apply no matter which way users perform the check-in.
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1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Project > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the project, and choose Properties.

The Properties dialog box opens.
2. Do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Project.
If opened from the StarTeam main menu or Server Explorer, select Project.

3. Select the Options tab.
4. Check Require Revision Comment When Files are Checked In.
Note: This check box applies only to the application, not to integrations.
5. Click OK.
From this time on, the Check-in dialog box will always open when users check in files, and they will
need to type text in the Reason for Check-in text box before completing the operation.

Marking Unlocked Files Read-only
In many cases, users make edits before realizing that their files must be exclusively or non-exclusively
locked to check them in. If the files are read-only, users are less likely to make this mistake.
1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Project > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the project, and choose Properties.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Project.
If opened from the StarTeam main menu or Server Explorer, select Project.

3. Select the Options tab.
4. Check Mark Unlocked Working Files Read-only,
This applies to files that are unlocked in the application or in application integrations with third-party
applications. If this check box is cleared, you must use the operating system to change the read-only
attribute to read/write. Working copies of unlocked files will now become read-only when the following
file operations are performed:
•
•
•

File check-ins
File check-outs
File unlocks
Note: This StarTeam project property overrides the identical Mark Unlocked Working Files Readonly personal preference setting. If you change your mind after selecting the property (or the
equivalent personal preference), verify that no files are writable before clearing the check box. Next,
force a check out and lock all the files (or just the read-only files). Finally, unlock them.

Searching Projects
1. Open a StarTeam perspective or view.
2. Click Search for StarTeam Items.
Alternative: you can choose Search > Search from the menu.
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The Search dialog box opens.
3. Select the StarTeam Search tab.
4. Type the text for which you want to search into the Regular expression text box.
5. In the Search in area of the dialog box, select any desired server, project, view, or folder that you wish
to search in.
6. Use the Type drop down list to narrow your search to specific StarTeam item types and properties.
Select Files in from the drop down list and then choose the Comments property from the Look in
options to search Comments included with Files only.
7. From the Look in options, choose one of the following:
•
•

•

All properties if you want the search to return all item properties. An item is accepted if the string
representation of the value of any of the item properties matches the given regular expression.
All properties by current filters if you want the search to process only properties in the current
filter that are applicable to the chosen type.
Note: you can see the list of these properties by opening the This property list box when
Choose from all properties by current filters is selected.
Select This property to specify a single property to be processed.

8. From Options, you can:
•
•

Select the Match case check box to have search return only items that match the case as entered
into the Regular expression text box
Select the Recursive check box to have search seek matches in all folders beneath the selected
items from Look in.

9. Click Search.
The results will be displayed in the Search view and on the StarTeam Search Results tab.

Synchronization
The StarTeam Eclipse Client allows projects on the StarTeam server and projects in the Eclipse workspace
to be shared. The client sits on top of and supports the standard Team Synchronization perspective in
Eclipse. All incoming and outgoing changes within shared projects are synchronized on a regular basis
with the StarTeam repository. In Eclipse terminology, synchronizing outgoing changes sends all changes
and new files created in Eclipse to StarTeam Server, while synchronizing incoming changes brings all
changes and new files from StarTeam Server into Eclipse.
The client provides StarTeam perspectives and views and menu commands added to the standard Team
context menu. The Team context menu is surfaced throughout the Eclipse UI and provides the default
Team menu commands and several StarTeam-specific commands enabling you to work in a team
environment with StarTeam as your source control provider. Using the StarTeam perspectives and views
along with the Team context menu commands provides the quickest route to working with your StarTeam
source control items.
Additionally, the Team Synchronizing perspective provided in Eclipse allows you to review the current
status of each conflict and resolve the majority of problems.
Synchronizing with the Repository
1. Do one of the following:
•
•

Select an item from the Navigator or Package Explorers, and choose Team > Synchronize with
Repository.
Open the Team Synchronizing perspective and choose Window > Open Perspective > Team
Synchronizing.

The Team Synchronizing perspective opens.
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2. In the Synchronize view, select the Incoming/Outgoing mode.
3. Select the appropriate files or folders that you wish to perform operations on.
4. Use the context menu commands in the Synchronize view to perform check in or check out operations.
Synchronizing Newly-Shared Projects
1. Click Synchronize. The Team Synchronizing perspective opens. The Incoming/Outgoing mode is
automatically selected showing the files to add to the repository.
2. Select the appropriate files or folders that you wish to check in, right-click, and choose Check In. The
Check In dialog box opens.

Copying URLs
Note: StarTeam shortcuts use the file extension .stx.
1. Select one or more items in an item view or the Server Explorer.
2. Right-click the selected items and choose Copy URL to clipboard. This action places in the clipboard
a plain text version of the URL to the selected items and an HTML representation of the links to the
selected items. From the clipboard, you can paste the URL to a selected application.
3. Paste the URL to the application of choice.
Copying a URL to the clipboard is equivalent to dragging an item or items from the list pane or folder
tree onto an application. Not all applications support pasting the HTML representation, although Word,
Excel, and Outlook do support HTML data.

Project Properties
This section presents the StarTeam project properties and their descriptions as displayed in the Properties
dialog box.

Name (Project Properties)
StarTeam > Project > Properties > Name
Describes the options on the Name page of the Properties dialog box.
Item

Description

Name

Specifies the project name.

Description

Specifies the project description.

Created By

Displays the name of the person who created the project.

(Created) On

Displays the date on which the project was created.

Type

Displays the project type.

Options (Project Properties)
StarTeam > Project > Properties > Options
Describes the options on the Options page of the Properties dialog box.
Item

Description

Keyword Expansion

Enables keyword expansion.

Expand Keywords For These File Extensions

Restricts keyword expansion to files with the specified
extensions.
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Item

Description

Require Revision Comment When Files Are Checked In

Specifies that revision comments are required when
checking in files to the project.

Require Exclusive Lock When Files Are Checked In

Specifies that all files checked in must be exclusively
locked to enable check-in.

Mark Unlocked Working Files Read-Only

Specifies that all unlocked working files are marked as
read-only if they are checked in, checked out, or unlocked
when file locking is required. This option applies to files
that are unlocked in the application or in application
integrations with third-party applications. The project
property overrides the identical Mark Unlocked Working
Files Read-only personal preference setting.

Process Rules (Project Properties)
StarTeam > Project > Properties > Process Rules
Describes the options on the Process Rules page of the Properties dialog box.
Item

Description

Require Selection Of Process Items When Files Are
Added Or Checked In

Enforces selection of process items when files are added
or checked in.

Permit Selection Of Change Requests As Process Items

Permits the selection of change requests as process
items, and restricts them based on which status fields are
checked in the Restrict Status To check boxes:
If Open is checked, only change requests with a status of
Open can be used as process items.
If In Progress is checked, only change requests with a
status of In Progress can be used as process items.
If both Open and In Progress are checked, only change
requests with a status or Open or In Progress can be
used as process items.
If neither Open and In Progress are checked, all change
requests can be used as process items, regardless of
their status.

Permit Selection Of Requirements As Process Items

Permits the selection of requirements as process items,
and restricts them based on which status fields are
checked in the Restrict Status To check boxes:
If Approved is checked, only requirements with a status
of Open can be used as process items.
If Approved is unchecked, all requirements can be used
as process items, regardless of their status.

Permit Selection Of Tasks As Process Items

Permits the selection of tasks as process items, and
restricts them based on which status fields are checked in
the Restrict Status Tocheck boxes:
If Ready To Start is checked, only tasks with a status of
Ready To Start can be used as process items.
If In Progress is checked, only tasks with a status of In
Progress can be used as process items.
If both Ready To Start and In Progress are checked,
only tasks with a status or Ready To Start or In
Progress can be used as process items.
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Item

Description
If neither Ready To Start and In Progress are checked,
all tasks can be used as process items, regardless of
their status.

Enable Enhanced Process Links

Enables the client to use enhanced process links.

Editors (Project Properties)
StarTeam > Project > Properties > Editors
Item

Description

Use Alternate Property Editor For Files

Specifies that for files, StarTeam should use the specified
alternate property editor in the corresponding field.

Use Alternate Property Editor For Change Requests

Specifies that for change requests, StarTeam should use
the specified alternate property editor in the
corresponding field.

Use Alternate Property Editor For Requirements

Specifies that for requirements, StarTeam should use the
specified alternate property editor in the corresponding
field.

Use Alternate Property Editor For Tasks

Specifies that for tasks, StarTeam should use the
specified alternate property editor in the corresponding
field.

Use Alternate Property Editor For Topics

Specifies that for topics, StarTeam should use the
specified alternate property editor in the corresponding
field.

Note: For more information creating APEs, see the "StarTeam Extensions User's Guide" in the
StarTeam documentation.

Provider Properties
This topic presents the StarTeam Provider properties and their descriptions as displayed in the Provider
Properties dialog box when opened from the context menu. The information in the Provider Properties
dialog box is different for each type of selected, shared resource: project, folder, or file.
Shared Project
The following properties are displayed for the shared project.
Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

Change Sharing

Opens the Share a Project dialog box where you can
change the sharing options.

Change View

Opens the Select a StarTeam View dialog box where
you can change which view you are sharing.
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Property

Description

Change Kind

Reveals the types and directions of changes that can be
found in any resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
folder used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server. It is possible for the dot-notation
to be higher, indicating a newer version is available in the
repository.

Shared Folder
The following properties are displayed for the shared folder.
Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

Change Kind

Reveals the types and directions of changes that can be
found in any resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
folder used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server. It is possible for the dot-notation
to be higher, indicating a newer version is available in the
repository.

Convert Change Kind To

Allows you to invert the direction and type of a deletion or
an addition. This is sometimes necessary when a project
was re-shared or hooked up with another view. Changes
on the server or in the workspace may be interpreted
assuming the wrong intention. A folder listed as
[outgoing deletion] may simply have been added to the
view by another developer at some time, and thus be
considered an [incoming addition]. The two buttons,
Incoming Deletion and Outgoing Addition, allow you to
change

Shared File
The following properties are displayed for the shared file.
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Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.
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Property

Description

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

MD5:

Displays the current MD5 hash value for the local
revision.

Stored Remote MD5:

Displays what the provider remembers the MD5 hash
value to have been at the last check in or check out.

Current Remote MD5:

Displays the MD5 hash value for the tip revision. By
comparing the stored MD5 hash value with the current
MD5 hash value, the provider can detect incoming
changes in spite of differing remote and local MD5 values
due to EOL differences.

Base Modification Timestamp:

Shows the last date and time the local and remote files
were current.

Local Modification Timestamp

Shows the date and time of the last modification to the
local file.

Remote Modification Timestamp:

Shows the date and time of the last modification to the
remote file.

Change Kind

Reveals the types and directions of changes that can be
found for any file resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
file used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server (tip revision). It is possible for the
dot-notation to be higher, indicating a newer version is
available in the repository.

Convert Change Kind To

Allows you to invert the direction and type of a deletion or
an addition. This is sometimes necessary when a project
was re-shared or hooked up with another view. Changes
on the server or in the workspace may be interpreted
assuming the wrong intention. A folder listed as
[outgoing deletion] may simply have been added to the
view by another developer at some time, and thus be
considered an [incoming addition]. The two buttons,
Incoming Deletion and Outgoing Addition, allow you to
change.

Stored EOL Conversion

Specifies which EOL (End of Line) conversion settings to
store. When you click OK or Apply after changing this
setting, the MD5 values will be recomputed and the
status refreshed in an attempt to identify the type of
change.
Note: The StarTeam Eclipse Client uses MD5
hash values exclusively for status computation,
therefore it needs to remember which EOL
conversion was in effect at the last check in or
check out so it can adjust the computed MD5.
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View Configuration and Management
Views are one of the most important configuration concepts in StarTeam. They represent "portals" into
project artifacts that can serve a wide range of development process activities. Each project has only one
root view, which is created automatically when the project is created. The root view may have several child
views, each of which may have several child views of their own. A view that has child views can be referred
to as a parent view.
This section discusses the basic view types and their general characteristics. It also provides some basic
view "do's and don'ts" and suggestions on how views can be used to address various development
lifecycle scenarios.

Branching Views
A branching view is a view that permits branching -- that is, the folders and other items in the view can
separate from the corresponding items in the parent.
Branching views serve many purposes. For example, you can create a branching view to:
•
•
•

Meet different needs from those of your main line of development. For example, you might create a
maintenance release or a custom version of your product, branched from a prior commercial release.
Start development on the next release of your product by using some or all of the files from the previous
release
Keep an area of your project private until it is completed and tested. Then you can merge your changes
into the main line of development when and where necessary.

A branching view should use a different working folder than that of its parent view. Using the same working
folder for both views is not only confusing but can create serious problems:
Until an item branches, the corresponding items in both views remain identical. After an item branches,
they are no longer identical, and the revision number indicates the new branch. The only way to make the
items identical again is to manually merge them by comparing and merging views. After branching occurs,
StarTeam no longer sends updates to nor applies updates from the corresponding item in the parent view.
For reasons of safety, deletions made in the parent view are not propagated to the child view and vice
versa. If you want to delete a folder or item from all related views, you have to delete it manually from each
of those views.
Similarly, moving a folder or item is considered a copy operation followed by a delete operation. Because
the delete operation is not propagated, the view in which the move was made has one copy of the folder or
item in the new location, while related views have two copies of the folder or item, one in the original
location and one in the new location. Thus, a move is equivalent to a share in the related views.
Also, remember that a move is considered a copy operation followed by a delete operation. Consequently,
the view in which the move was made has one copy of a folder or item in the new location, while the
related views have two copies of the folder or item, one in the original location and one in the new location.
Note: Only folders, files, and change requests can branch. Requirements, tasks and topics never
branch. Changes to such items can be made in the view in which they were created, in a view in
which they have been moved or shared, or in floating child views that are not read-only. New
revisions of such items can be reviewed from any floating child view.

View Types
There are many types of views whose functionality varies based on the options used to create them. Some
view types are useful for specific situations; some views are rarely useful. Since view behavior is based on
the options used to create them, view types are not formally defined, which can make them a little
confusing.
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Below are the basic view types and a description of their general functionality:
Non-derived View

This is also called a "blank" view. It is not derived from any existing views, rather it
starts out empty. A parent is selected for them and they display in the tree view. If
only new folders, files, and other objects are added to it, it effectively acts like a
project except that, as a view, it still "belongs" to the project from which it was
created. If objects that originate elsewhere are shared into a non-derived view, it acts
like an arbitrary assembly of objects. The shared items can float and therefore be
updated, or they can be fixed and therefore read-only. Non-derived views are rarely
used.

Derived View

A derived view is created with some other view as the "perspective". One of the
perspective view's folders is chosen as the root of the derived view, hence the
derived view is a "window" into the objects at which it is rooted. However, a derived
view has many different behaviors and uses depending on other options.

Reference View

A reference view is a derived view that is a pure subset of the objects that are
exposed through it. That is, the parent and reference view refer to the exact same
objects, so changes though one affect the other view. Items in a reference view do
not branch, hence reference views are also called "non-branching views'. The
reference view utilizes the same view labels as its parent. These read/write views
reference a subset of items found in the current configuration of the parent view.
They often contain only the items of interest to a specific group of workers or an
individual. Reference views can be further divided into two types:
Updatable Reference View

The items in an updatable reference view
"float" to the tip revision of corresponding
objects, hence the objects can be updated
via the reference view. These changes
appear immediately in the parent view as
well. In practice, updatable reference views
are rarely used. They can be confusing since
updates to the reference view flow through to
the parent view and vice versa. The "subsetting" ability of the reference view may be
useful in some cases, but similar functionality
can be accomplished with security settings.

Read-only Reference View

These views are based upon a specific state
of the original view and are read-only. They
are typically created for convenience so that
revisions of items used in specific product
releases can be easily located. For example,
a 4.1 Release view might be used to rebuild
the 4.1 Release in the future. These views
may be float or be frozen.
A floating Reference View stays current with
the parent view. For example, a floating view
could be created for team members who are
monitoring changes to a project. Read-only
reference views that float can be rolled back.
A frozen (or fixed) Reference view captures
the parent view at a particular date and time.
For example, a frozen view might be created
as a milestone against which to change
further progress on a project. Read-only
reference views that are frozen cannot be
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rolled back. Some or all of the view's items
configuration may be "floating", allowing
changes from the (updatable) parent view to
show through. Conversely, items can be
pinned to a specific configuration and hence
won't reflect changes to the underlying
objects unless the item configuration(s) are
changed. Both pinned and floating read-only
views are occasionally useful for read-only
applications such as build scripts.
Variant View
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In contrast to a reference view, a variant view is not a pure subset of its parent view.
Instead, the objects to which it refers may branch when updated, although each
item's branch-on-change behavior can be set individually. Consequently, variant
views are also called "branching views". How the view's items are initially configured
cause variant views to behave in very different ways:
Branch-none View

In these views, which are also based on a
configuration of the current view, none of
the items are set to branch on change
when they are modified. An item cannot
branch until its behavior is changed. If a
variant view's items are initially configured
with branch-on-change set to "false", it
acts like a reference view, except that the
view doesn't share labels with its parent. If
the view's item configurations are set to
"float", updates through those items will
float to the parent. (This is sometimes
called a "floating view".) If item
configurations are configured to a specific
timestamp, those items will be read-only.
Some users have tried to create branchnone views and hand-tweak item
configuration and branch-on-change, but
this approach has proven tricky at best and
sometimes disastrous. Consequently,
branch-none variant views are not advised.

Branch-all View

In these views, which are based on a
configuration of the current view, all items
are set to branch when they are modified.
They are typically used to create and
support a maintenance baseline. Branchall variant views are perhaps the most
useful of all views. After the view is
created, however, this behavior can be
changed for individual items. Branching
views can be used to modify the items
found in a specific view without affecting
these items in other views. All items are
initialized with branch-on-change set to
"true", hence they can be updated
regardless of their configuration. Setting
the item's initial configuration to floating

versus a specific timestamp makes the
view useful in different ways.

Basic Properties of View Types
The basic properties and usefulness of the various view types are summarized in the following table:
View Type

Reference
versus Variant

Shares Labels
Items Can
with Parent View Branch

Items Can be
Updated

Usefulness

Non-derived

N/A

N/A

Only if shared

Yes

Low

Updatable
reference View

Reference

Yes

No

No

Low

Read-only
Reference View

Reference

Yes

No

No

Medium (for readonly applications)

Branch-none
View

Variant

No

Initially No

Only if floating

Medium (tricky to
manage)

Branch-all View

Variant

No

Yes

Yes

Highs

Proper Use of Views
Irrespective of view type, below are some general do's and don'ts to consider when creating and managing
views.
DO Treat Views As "Streams"

Treat each view as a "stream" for a specific lifecycle
activity. The view may receive lots of updates, few
updates, or none at all depending on the type of activity it
supports.

DO Use The Main View as the Main Baseline

Use the main view as the project's "production" baseline.
As such, it will accumulate all artifacts for the applications
or components supported by the project. Depending on
your lifecycle model and the size of your development
team, changes can be made in a variety of ways, as
discussed later. However, changes eventually migrate "up"
to the main view.

DO Use Branch-All Views

Make branch-all views your primary workhorse. Use
reference views for read-only activities such as build
scripts.

DO Use View Labels and Promotion States

View labels and promotion states are easy to use and
efficient. With a view label you can quickly mark all
artifacts in a view, perform check outs and builds based on
the label, and adjust the revision of individual files that are
included in the label. Promotion states allow you to define
logical lifecycle states such as engineering test or release
candidate and map each one to a view label, which can be
adjusted or easily "promoted" to the next state. New views
can also be created based on view labels and promotion
states.

DO NOT Go Beyond 2 or 3 View Levels

Views are generally only needed as immediate children of
the main view. Third-level (grandchild) views are
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occasionally necessary. View levels deeper than 3
probably mean you probably aren't using views efficiently.
DO NOT Use Some View Types Except in Special
Circumstances

Don't use non-derived views, floating views, or reference
views that can be updated, except in very special
circumstances where you thoroughly understand the
behavior of these view types and that behavior best
matches your use case.

DO NOT Use Too Many Views

Views are somewhat "heavyweight" objects: They can take
many minutes to create when derived from an existing
view with many items, and they typically add thousands of
new child items to the database. It's safe to up to several
hundred views in a singleStarTeam server, but you don't
want to have thousands of views. This means that views
don't work well as a "personal workspace" for individual
developers.

Views Supporting Iterative Development
This section describes various iterative development scenarios and suggests how views can be used to
support each one.
•
•

•

The main view is used for the production baseline.
The project is configured to enforce process items, hence a change request, task, or requirement object
is created for each "unit" of work. A "unit" is loosely defined to be the amount encompassing the checkin of a related set of files.
View labels (and possibly promotion states) are used for routine builds. This means, for example, that a
nightly view label is applied from which a build is generated and then tested. View labels, promotion
states, and process items are used to support "intra view" update steps.

View Type Options and Settings
The table below lists the settings that must be selected in the New View Wizard to create the different
views.
Desired Characteristics

Options to Set

Branching: Branch All (Floating)

View Type:

New Items:

Branch All

New items in the child view do not appear in the parent
Root Folder:
view; new items in the parent view appear in both views if
Selected from parent view
they are in the subset accessed by the child view. In the
child view, new items from the parent have the Branch on Working Folder:
Change check box selected.
Should be different from that of the parent, to avoid
conflicts
Existing Items:
Changes to existing items in the parent view appear in
Configuration:
the child view until the corresponding item in the child
Floating
view branches. Changes to existing items in the child
view can appear in the parent view, but only if the Branch
Note: If users are likely to perform many move
on Change check box for that item is cleared. However,
and share operations, using branching, floating
items deleted from one view are not deleted from the
views can result in multiple unwanted references
other.
to the same folders or items, causing confusion.
Also, if a change request has "Next Build" in the
Item Behavior:
Addressed In Build field when the child view is
created, "Next Build" will be replaced by the
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Desired Characteristics
Branch on Change check box is enabled and selected for
all items that can branch. Any change to a child item that
can branch results in the branching of that item, unless its
Branch on Change check box has been cleared. After
branching, the box is disabled.

Options to Set
parent's next build label, unless the change
request is first branched.

Branching: Branch All (Not Floating)

View Type:

New Items:

Branch All

New items in the child view do not appear in the parent
view; new items in the parent view do not appear in the
child view.

Root Folder:

Existing Items:

Selected from parent view
Working Folder:

Should be different from that of the parent, to avoid
Existing items in the child view are the same as in parent
conflicts
view at the time of configuration, until the item in the child
view branches. Changes cannot be made to an item in
Configuration:
the child view if the change does not result in branching.
Other than floating (Labeled, Promotion state, or As of
specific date)
Item Behavior:
Branch on Change check box is enabled and selected for Note: Addressed In Build field when the child view is
all items that can branch. Any change to a child item that created, "Next Build" will not be replaced by a build label
can branch results in the branching of that item, unless its until the change request branches.
Branch on Change check box has been cleared. After
branching, the check box is disabled.
Branching: Branch None (Floating)

View Type:

New Items:

Branch None

New items in the child view appear in the parent view;
Root Folder:
new items in the parent view appear in the child view if
Selected from parent view
they are in the subset accessed by the child view. In the
child view, new items from the parent have the Branch on Working Folder:
Change check box cleared.
Should be different from that of the parent to avoid
conflicts.
Existing Items:
Existing items are the same in the child view as in the
parent view; they can be changed in either the parent or
child view until the item in the child view branches.
However, items deleted from one view are not deleted
from the other.
Item Behavior:
Branch on Change check box enabled, but cleared
No change to a child item that can branch results in
branching until the Branch on Change check box is
selected. After branching, the check box is disabled.

Configuration:
Floating
Note: If users perform many move and share operations,
using branching, floating views can result in multiple
unwanted references to the same folders or items,
causing confusion. Also, if a change request has "Next
Build" in the Addressed In Build field when the child view
is created, "Next Build" will be replaced by the parent's
next build label, unless the change request branches in
the child view.

Branching: Branch None (Not Floating)

View Type:

New Items:

Branch None

New items in the child view do not appear in the parent
view; new items in the parent view do not appear in the
child view.

Root Folder:

Existing Items:
view as in the parent view at the time of configuration,
until the item in the child view branches. Changes cannot
be made to an item in the child view if that change does
not result in branching.

Selected from parent view
Working Folder:
Should be different from that of the parent, to avoid
conflicts Configuration:
Configuration:
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Desired Characteristics

Options to Set

Item Behavior:

Other than floating (Labeled, Promotion State, or As of
specific date)

Branch on Change check box enabled, but cleared.
No change to a child item that can branch results in
branching until the Branch on Change check box is
selected. After branching, the box is disabled.
Reference View (Also called Read/Write Reference
View_
New Items:
New items in the child view appear in both views; new
items in the parent view appear in both views if they are
in the subset accessed by the child view.

Note: Addressed In Build field when the child view is
created, "Next Build" will not be replaced by a build label
until the change request branches.
View Type:
Reference
Root Folder:
Selected from parent view
Working Folder:

Existing Items:

Usually the same as that of the parent view

Existing items are the same in the child view and the
parent view; they can be changed from either view.

Configuration:
N/A; always floats.

Item Behavior:
Branch on Change Disabled.
Note: Labels created and objects deleted in the child view
appear and disappear in the parent view; this is not true
for other types of child views.
Read-only Reference View (Frozen)

View Type:

New Items:

Read-only Reference

New items cannot be added to child view; new items in
parent view appear in child view.

Root Folder:

Existing Items:
Existing items are the same in the child view and the
parent view; they can be changed only from the parent
view.
Item Behavior:
Branch on Change Disabled.

Selected from parent view
Working Folder:
Usually the same as that of the parent view
Configuration:
Other than Floating (Labeled, Promotion State, or AS of
Specified Date)
These views can be rolled back.

Non-derived View (also called Blank Branching View)

View Type:

New Items:

Non-Derived

New items in child view do not appear in the parent view;
new items in the parent view do no appear in the child
view.

Root Folder:N/A
Working Folder:

Existing Items:

Should be different from that of the parent to avoid
conflicts.

Existing items in the parent view do not appear in the
child view.

Configuration:

Item Behavior:
Branch on Change check box disabled.

N/A
These views can be rolled back.

StarTeam View Configuration Options
This table describes the view configuration options available in the New View Wizard.
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Configuration

Description

Floating Configuration

All the items in the new view will be identical to the
corresponding items in the current parent view. Changes
to an item in the parent view will be made to the
corresponding item in the new view until that item
branches, while changes to an item in the new view will
be reflected in the parent until the item in the new view
branches. (In many cases, the first change to that item
will result in branching). New items in the parent view will
appear in a branching view. However, new items added
to a branching view will appear in the parent view only if
the new view is the Branch none type.

Labeled Configuration

Changes to the parent view do not affect the new view.
Unless an item is set to Branch on change in the new
view, it will be read-only and you cannot change it.

Promotion State Configuration

All the items in the new view will have the promotion state
you specify and be rolled back to that state. This option is
disabled if the parent view has no promotion states
defined for it. Changes to the parent view will not affect
the new view. Unless a specific item is set to Branch on
change in the new reference view, it will be read-only and
you cannot change it.

Configuration As Of

The new view will contain only the items that existed at
the date and time you specify, and they will be rolled back
to just before that date and time. Changes to the parent
view will not affect the new view. Unless a specific item is
set to Branch on change in the new view, it will be readonly and you cannot change it.

Working with Views
This section contains tasks related to using and managing views.

Opening Perspectives and Views
1. Choose Window > Open Perspective > Other from the main menu. The Open Perspective dialog
box opens.
2. Select one of the following perspectives:
•
•

StarTeam Activity
StarTeam Classic

3. Click OK.
The specified perspective opens. For descriptions of the StarTeam perspectives, see the links at the end of
this topic.

Creating and Configuring Views
1. Open a StarTeam perspective or view.
2. Choose StarTeam > View > New from the main menu.
Alternative1: Click Create new view in StarTeam project in the toolbar. Alternative2: Open the Server
Explorer, select a server configuration, project, or view node, and choose New > View.
The New View wizard opens.
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Note: If opening the New View wizard from a server configuration node context menu, select a
project on which to create the new view, and click Next.
3. Do one of the following:
•
•

To create a referencing or branching view, check Derive new view from selected view, and select
a view from the view hierarchy box.
To create a non-derived view, clear Derive new view from selected view, and click Next.

4. If creating a referencing or branching view, select one of the available View Properties options as
follows, and click Next:
Note: You do not need to specify these options if creating a non-derived view.
•
•

Check Read-only to create a read-only reference view.
Check Permit items to branch within this view to create a branching view, and then select
whether to have the items branch on change by choosing either Branch all or Branch none.

5. Type a View Name and a Description for the view in the appropriate text boxes, and click Next.
6. Select the Root Folder for the new view.
Note: The New View wizard skips this step for a Non-Derived view.
7. Click Next.
8. Type or browse for the name of an appropriate Default Working Folder.
Important: For a Branch All, Branch None, or Non-Derived view, always use a working folder
that is different from the one used by the parent view. Using the same working folder for the parent
and child views can cause changes in one view to be overwritten when files are checked out from
the other view. It can also result in incorrect or, at least, misleading file status indicators. For a
Reference or Read-Only Reference view, you can use the same working folder as the parent
view.
9. Click Next to display the View Configuration page. If you are creating a Non-derived or Reference
view, click Finish.
Note: It is not necessary to display the Configuration page for a Non-Derived view because no
items from the parent view are included. It is also not necessary to display the Configuration
page for a Reference view because the items have the same configuration as those in the parent
view.
10.Select one of the available configuration options on the View Configuration page, and click Finish.

Deleting Views
Note: Before deleting a project view, be absolutely certain that you wish to do so. After performing
this operation, you will no longer be able to access any item in the view that is not shared with
another project or view. Deleted views are also not visible in the Select View dialog box, although
deleting a view does not remove any data from the server database. If other users are connected to
the project view when it is deleted, they will receive a Deleted message the next time they initiate a
view command.
1. Open the Server Explorer.
2. Right-click on the view name, and choose Delete. A message displays, asking you to confirm the
deletion.
3. Click OK. A dialog box opens requesting you to enter the exact name of the StarTeam view that you
wish to delete.
4. Type the name in the text box provided.
5. Click OK.
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Viewing or Modifying View Properties
If you have access rights to do so, you can modify view properties.
1. Do one of the following:
•
•
•

With a StarTeam perspective or view open, choose StarTeam > View > Properties.
In the Server Explorer, right click on the view node, and choose Properties.
In the Navigator or Package Explorers, right click on the project, and choose Properties.

The Properties dialog box opens.
2. Do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select View.
If opened from the StarTeam main menu or Server Explorer, select View.

3. Select the Name tab to see or change the following:
•
•
•
•

Name and description of the view
Who created the view and when it was created
Whether the items are set to branch on change
Working/Alternate folder path
Note: Your access rights determine which items you can change.

4. Select the Hierarchy tab to review the list of views for this project and their relationship to one another.
5. Click OK or Cancel to close the dialog box.

Creating View Labels
View labels can be extremely useful when you want to label every folder and item in a particular view.
1. Do one of the following:
•
•
•

With a StarTeam perspective or view open, choose StarTeam > View > Labels or StarTeam >
View > Properties from the main menu.
In the Server Explorer, right click on the view node, and choose Labels or Properties from the
context menu.
In the Navigator or Package Explorers, right click on the project, and choose Properties or Team >
Labels.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Labels
(for view).
If opened from the StarTeam main menu or Server Explorer, select Labels.

This View tab lists existing view labels in reverse chronological order, based on the time at which they
were created.
3. Click New to create a new label and add its name to the list box. The View Label dialog box opens.
4. Type a name and description for the label in the appropriate text boxes.
The maximum label name length is 64 characters, and the description length is 254 characters.
5. Optional: Check Use As Build Label to update each change request that has Next Build as the setting
for its Addressed In Build property. If this option is not selected, change requests will still have the
view label, but it will not affect the setting of the Addressed In Build property.
6. Optional: To freeze the label so that the revisions attached to it cannot be changed, check Frozen.
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7. Select one of the following options:
•
•
•

•

Current Configuration: This attaches the label to the tip revision of every item in this view's current
configuration.
Labeled Configuration: This option attaches the label to the revision with the label you specify.
(Creating a view label based on another view label is equivalent to copying that view label.)
Promotion State Configuration: This option attaches the label to the revision currently in the
promotion state that you specify. (Actually, the label is attached to the revision that has the
promotion state's current view label.)
Configuration As Of: This option attaches the label to the revision that was the tip revision at the
specified date and time.

8. Click OK.
Note: If you select the current time for the label configuration, it is important to synchronize the dates
and times of the computers that run the StarTeam clients and the StarTeam server. Otherwise, the
labels may not be immediately visible.

Changing Default and Alternate Working Folders
Changing the view's working folder for working Eclipse projects is not recommended. Eclipse projects
should be recreated after changing the view's working folder. If you want to use a different location for your
working folder other than the Default Working Folder path, it is recommended that you specify an Alternate
Working Folder path.
Caution: Do not change the Default Working Folder unless you are a project administrator. It is
critical that before you change the Default Working Folder, you lock the server and everybody should
be logged off, just as when you change custom fields or anything else that effects all users. If you
change the working folder while the StarTeam Eclipse Client is running, it can cause Team
Synchronization errors.
These default settings affect ALL users and incorrect settings cause other users to be unable to check out
StarTeam files. The default settings should only be set to the name of the folder.
1. In the StarTeam view, choose StarTeam > View > Properties.
•
•

Alternative1: In the Server Explorer, right click on the view node, and choose Properties.
Alternative2: In the Navigator or Package Explorers, right click on the project, and choose
Properties.

The Properties dialog box opens.
2. Select View.
3. Click the Name tab.
4. Select Alternate to create a different working folder for only yourself.
Alternative: If you are a project administrator, select Default to specify the default folder path for all
users.
5. Type the name of a new working folder or browse for a path to a working folder.
If you browse for the path, it becomes an absolute path. This path can be edited, however, to enable
you to work on a computer that uses a different letter for its hard drive.
Note: It is important that the Default Working Folder point to a location that is physically discrete
for each user, such as a drive on that user's workstation or a personal directory on a shared file
server.

Switching Between StarTeam Project Views
By default, the newly selected view always opens with the Current configuration, regardless of the
configuration it had when you last exited it.
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1. In the Package or Navigator Explorers, right-click on the root project node, and choose Properties. The
Properties dialog box opens.
2. Select StarTeam Provider from the menu tree.
3. Click Change View. A dialog box opens showing all views for the project.
4. Select the desired view and click OK.
5. Click OK to close the Properties dialog box.

Copying View Labels
Note: You cannot copy a view label unless it already exists in the view in which you are performing
this operation. The view configuration must also be current.
1. With a StarTeam perspective or view open, choose StarTeam > View > Labels or StarTeam > View >
Properties from the main menu.
•
•

Alternative 1: In the Server Explorer, right click on the view node, and choose Labels or Properties
from the context menu.
Alternative 2: In the Navigator or Package Explorers, right click on the project, and choose
Properties or Team > Labels from the context menu.

The Properties dialog box opens.
2. Do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Labels
(for view).
If opened from the StarTeam main menu or Server Explorer, select Labels.

This View tab lists existing view labels in reverse chronological order, based on the time at which they
were created.
3. Click New to create a new label and add its name to the list box. The View Label dialog box opens.
4. Type a name and description for the label in the appropriate text boxes.
The maximum label name length is 64 characters, and the description length is 254 characters.
5. Select the Labeled Configuration option to attach the label to item revisions that have an existing
label.
6. Optional: Uncheck Use As Build Label if you do not want this label to be a build label.
Note: By default all view labels are designated as build labels.
7. Click OK.
The new view label is now attached to the same revisions as the existing label. You can now use the
context menus provided in the Eclipse Explorers or StarTeam views to attach or detach labels for which
the new label must differ.
8. Detach the new label from items that you do not want to include. Do one of the following:
•
•

Select the items in the Package or Navigator Explorers, and choose Team > Labels > Detach from
the context menu.
Select the items in the Server Explorer or StarTeam views (change request, requirements, and so
on), and choose Labels > Detach from the context menu.

9. Attach the new label to items formerly not included, and/or attach the new label to different revisions of
items to which it is already attached. Do one of the following:
•
•

Select the items in the Package or Navigator Explorers, and choose Team > Labels > Attach from
the context menu.
Select the items in the Server Explorer or StarTeam views (change request, requirements, and so
on), and choose Labels > Attach from the context menu.
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Promoting View Labels
You can promote a view label from one promotion state to the next if you have the appropriate access
rights, and when it satisfies the criteria established for that state.
1. Choose StarTeam > View > Promotion or StarTeam > View > Properties
Alternative 1: In Server Explorer, right click on the view node, and choose Promotion or Properties.
Alternative 2: In the Navigator or Package Explorers, right click on the project, and choose Properties
or Team > Labels.
The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select
Promotion.
If opened from the StarTeam main menu or StarTeam, select Promotion.

The states are displayed from the final state down to the initial state.
3. Select the promotion state currently associated with the view label that you want to promote.
4. Click Promote. The dialog box indicates that the view label is now associated with the next state (the
state immediately above the selected state in the Properties dialog box).
5. Click OK.
The view label now applies to both the original state and the new state. Usually, your next action is to
associate a new view label with the original state.

Demoting View Labels
1. Do one of the following:
•
•
•

With a StarTeam perspective or view open, choose StarTeam > View > Promotion or StarTeam >
View > Properties.
In the Server Explorer, right click on the view node, and choose Promotion or Properties.
In the Navigator or Package Explorers, right click on the project, and choose Properties or Team >
Labels.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, choose StarTeam Provider > Promotion.
If opened from the StarTeam main menu or Server Explorer, select Promotion.

3. Click Edit to open the Promotion State dialog box.
4. Select a different view label from the View Label list box.
5. Click OK.

Branching
A branching view is a view that permits branching -- that is, the folders and other items in the view can
separate from the corresponding items in the parent.
Branching views serve many purposes. For example, you can create a branching view to:
•
•
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Meet different needs from those of your main line of development. For example, you might create a
maintenance release or a custom version of your product, branched from a prior commercial release.
Start development on the next release of your product by using some or all of the files from the previous
release.
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•

Keep an area of your project private until it is completed and tested. Then you can merge your changes
into the main line of development when and where necessary.

Only folders, files, and change requests can branch, although not every folder or every item in a branching
view must branch. Requirements, tasks, and topics never branch.
Until an item branches, the corresponding items in both views remain identical. After an item branches,
they are no longer identical, and the revision number indicates the new branch. The only way to make the
items identical again is to manually merge them by comparing and merging views. After branching occurs,
StarTeam no longer sends updates to nor applies updates from the corresponding item in the parent view.
For reasons of safety, deletions made in the parent view are not propagated to the child view and vice
versa. If you want to delete a folder or item from all related views, you have to delete it manually from each
of those views.
Also, a move is considered a copy operation followed by a delete operation. Consequently, the view in
which the move was made has one copy of a folder or item in the new location, while the related views
have two copies of the folder or item, one in the original location and one in the new location.
Note: Branching a view negates all shares, not just the ones between parent and child views.

Branching Options
Understanding branching behavior is important because when a view that permits branching is created
with the New View Wizard, you must decide whether to select the Branch All option or Branch None
option. Your decision will affect every item in the new view that is derived from the parent view at the time
the view is created
Branching occurs when an item in the child view changes and has its behavior set to allow branching and
to Branch On Change. When an item branches, a separation occurs between the item and its
corresponding item in the parent view. These items also begin to have different branch revision numbers.
When an item branches, the application no longer sends or applies updates from the corresponding item in
the parent view.
Branching Notes
•
•

•
•

If you select Branch All, the behavior of every item that is in the view at the time the view is created is
set to Branch On Change.
If you select Branch None, the behavior of every item in the view at the time the view is created is not
set to Branch On Change. In other words, for any item with a floating configuration, changes to these
items can be propagated to the parent view. (The changes might also be propagated to the
corresponding items in some of the parent view's other child views--depending on what the
corresponding item's current behavior and configuration is.)
When you branch a view, any manual shares between items in the same view are not retained in the
view's child view.
As you add, move, share, and modify items, their behaviors can change. The next few sections explain
what particular behavior settings mean.
Note: Any item with a frozen or fixed configuration is read-only when its behavior is not set to Branch
On Change. Read-only means that no data about this item within the view can be changed. For
example, although you may be able to edit a file, you cannot check it in or change its properties.

Branching is Disabled
When the check box for Branch On Change is disabled, one of the following is true:
•
•

The item has already branched.
The item cannot be changed. For example, if the item is in a reference view, branching is not permitted.
When such a view permits changes, the changes are automatically propagated to the parent view. No
separation between the item and its corresponding item in the parent view ever occurs.
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•

Branching makes no sense for the item, given where and when it was created, moved, shared, etc. For
example, a file that has just been added to a root view has no reason to be branched. An item that has
no corresponding item in the parent view has no reason to branch.

If you create a blank branching view (a view that is not derived from a parent view), no items are initially in
the view. Therefore, no corresponding items exist in the parent view, so branching behavior is disabled.
Note: In a branching view, when you add an item to a folder that does not branch (that is, the folder's
Branch On Change check box is cleared in the Folder Behavior dialog box), the new item has no
corresponding item in the parent view. Because this new item is independent of the parent view,
branching is disabled.
Branching Is Set to Branch On Change
When Branch On Change is both enabled and selected, branching occurs the next time the item changes.
At that time, a separation occurs between the item in the new view and its corresponding item in the parent
view. The item that becomes separated from its corresponding item in the parent view takes on the
following behaviors:
•
•

Its Branch On Change check box becomes disabled
Its revision number is new and not shared with a revision in the parent view

Branching Is Not Set to Branch On Change
When the Branch On Change check box is enabled but cleared, branching does not occur when you
change the item.
If the item's configuration floats, the item's change is propagated to the parent view (and sometimes to
other child views of the parent view).
If the item's configuration does not float, the item cannot be changed because the parent view cannot be
updated. The item is treated as though it were read-only. Read-only means that the data of this item
cannot be changed from within this view. For example, although you can edit a file, you cannot check it in
or change its properties.

Branching Behavior of Folders or Items
Given the appropriate settings for folders, files, and change requests, you can branch these items in a child
view -- that is, you can separate these items from the corresponding items in the parent view.
Note: Branching a folder does not branch its child folders or files.
After a folder or item branches, it receives a new revision number. For example, if the revision number of a
file is 1.13 before the file branches, it becomes 1.13.1.0 after branching. The next change to the file in the
parent view will receive the revision number 1.14.
Below are the basic facts about branching behavior:
•
•
•

Folders and change requests branch when their properties change.
Files branch when either their contents or their properties change.
Requirements, tasks, and topics can never branch.

Typical Branching Scenario
Suppose you are working on a product and a customer requests a special edition of the product. For
example, the customer wants few special features tailored specifically for them. To separate the items,
such as files and change requests, for the current product from those for the special request, a branching
view is created.
When items are branched, they are derived from other items that become their ancestors. Items may have
several completely different revision histories with common ancestries. In the case of a text file, for
example, the branched item can later be merged with the file from which it originated. For example, the
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development of a product for a new operating system may start with the existing files for the first operating
system as its base.
History Affects Branching Behavior
Whether or not a folder, file, or change request has the ability to branch depends on its history. If you do
not know the complete history, you should not assume that you know its behavior.
For example,
•

•

•

If a folder or item was in the parent view at the time the branching view was created, and if the
branching view was created with Branch All as its branching option in the New View Wizard, the folder
or item's branching behavior is initially enabled and the Branch On Change check box is selected in
the Folder Behavior dialog box.
If a folder or item was in the parent view at the time the branching view was created, and if the
branching view was created with Branch None as its branching option, the folder or item's branching
behavior is initially enabled and the Branch On Change check box is cleared. However, this behavior
can be changed.
If a folder or item is added to the branching view after the view is created, the folder or item's branching
behavior is disabled. The Branch On Change check box is disabled and cleared in the Folder
Behavior dialog box. However, if you share that folder or item, its branching behavior becomes enabled
automatically in its new view.

Effects on Change Requests When Branched, Moved, and Shared
The workflow of a change request may be significantly affected when the change request is moved,
merged, or branches:
•

•

•

If the Last Build Tested and the Addressed In Build fields have build labels as their values (in other
words, if these fields are not empty and do not contain the value Next Build) the altered change
request retains those values. In the new view, these values can be changed, but only to the names of
build labels that exist in that view.
If the Addressed In Build field contains the value Next Build at the time of the operation, this value
is replaced by the name of the next build label created in the original view, not the next build label
created in the new view. This action occurs even if other alterations have been made to the change
request in the new view.
If the Last Build Tested and the Addressed In Build fields have no values at the time of the operation,
their workflow is specific to the view in which they currently reside.
Note: If a change request branches, its workflow is affected by its values in the Last Build Tested
and the Addressed In Build fields at the time it branches.

Personal Preferences
The application enables you to set personal preferences that suit your individual work styles. These
preferences apply to the currently logged-on user on a given workstation. The Preferences command on
the Window menu allows you to adjust the way the following elements work. If you have other StarTeam
clients installed, any analogous option settings made in those clients are automatically set in the StarTeam
Eclipse Client and vice versa.

Set of Team Preferences
When you choose to export a set of team preferences in Eclipse, StarTeam provides all the needed IDs,
the original server description, and the host and port information. It does not store things settings such as
compression or what kind of encryption to use. The user importing the preferences can turn on
compression if he or she works remotely or turn on encryption if outside of the firewall. StarTeam
automatically sets the encryption level so there is no loss of information.
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Also, during an import, you can choose to change the IP addresses on the fly. If a user exported
preferences on one machine using internal IP addresses, the user importing may choose to override those
with host names and addresses permeable through the firewall.
During an import, you can choose to change the IP addresses of the associated server configurations on
the fly. If a user exported preferences on one machine using internal IP addresses, the user importing may
choose to override those with host names and addresses permeable through the firewall.

Setting Preferences
To review a description of the preferences you can set, see the links at the end of this topic.
1. Choose Window > Preferences from the main menu. The Preferences dialog box opens.
2. In the resulting dialog box, expand Team > StarTeam.
3. Select the node containing the options that you want to change.
4. Make the desired changes, then click OK.

StarTeam Preferences
Window > Preferences > Team > StarTeam
The general StarTeam preference settings allow you to select a variety of options that affect the way your
workstation operates.
Item

Description

Default Setting

Save dirty editors before operations

Before performing an operation with
StarTeam, this setting allows you to
choose how to handle outstanding
edits. Choose one of the following:

Prompt

•

•

•

Synchronize, check-in, or check-out
after sharing

Specifies the default synchronization,
check-in, or check-out action after
sharing. Choose one of the following:
•
•

Prompt

Never - never synchronize after a
StarTeam operation begins.
Prompt - the application prompts
you whether to synchronize after a
check-in or check-out operation.

Comment History

Specifies the maximum number of
comments to retain.

30

Connect to StarTeam Server

Specifies the default action to take
when selecting a server in the Server
Explorer. Choose from:

Prompt

•
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Never - never save unsaved edits
before a StarTeam operation
begins.
Prompt - the application prompts
you whether to save unsaved
edits before a StarTeam operation
begins.
Auto-save - automatically saves
edits before a StarTeam operation
begins.
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Never - never connect to the
server. Work offline.

Item

Description
•
•

Property editors style

Prompt - always prompt the user
whether to connect to the server.
Always - always connect to the
server without prompting the user.

Specifies which style of property
editor opens when double-clicking a
selected item in the item view.
Choose from:
•

•

•
•

•
•

Link view with selection

Default Setting

Not specified

Embedded editor - double click
opens the selected item in the
non-modal embedded editor.
Property dialog - double click
opens the selected item in the
modal property dialog box.
Wrap text in multi-line text
fields
Use new date/time controls displays the Eclipse calendar
controls instead of combo boxes.
Require confirmation on dirty
editors cancellation
Embedded alternate property
editors - Allow alternate property
editors to open as embedded
editors.

When opening a connection to a
All views selected
server configuration, all StarTeam
views are updated to reflect the
contents of the currently selected
server configuration in the Server
Explorer. Depending on how much
information is in the repository, it can
take some time to load all of this
information. This setting allows you to
check or clear the views that you
want updated.

Note: Click Restore Defaults to restore the default values for these settings.

Change Request Preferences
Window > Preferences > Team > StarTeam > Change Request
The change request preferences enable you to specify the criteria that the application uses to determine
whether a change request has been read. You can also indicate how often the application should search
for new change requests and how change request locking issues should be handled.
Item

Description

Default Setting

Mark as read

Choose one of the following options:

Only when manually
marked as read

•

When change request is selected - Marks a change request
read as soon as you select it. An unread change request is
displayed with bold font. A read change request is displayed with
regular font.
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Item

Description
•

•

Default Setting

When selected for ___ seconds - Marks a change request read
after it has been selected for the specified number of seconds. The
range is from 15 to 9999 seconds.
Only when manually marked as read - Marks a selected change
request read when you choose Mark as Read from the Change
Request view's context menu.
Note: Change requests are always marked as read when
you display their properties.

System tray
notifications

You can set the following options:
•

•

Locking

Check for new or
modified change
Check for new or modified change requests - Checks for new
requests - every 10
or modified change requests at regular intervals and lets you know minutes
that you have become responsible for new change requests. If this
option is checked, you must also specify the number of minutes
between checks in the Interval option below. When unchecked, the
application does not place an icon in the system tray for a new
change request.
Interval (in minutes) - Specifies the number of minutes between
automatic checks for new or modified change requests.

Choose one of the following options:
•

•

Not specified

Exclusively lock change request during edit - Locks a change
request when you open its Properties dialog box for editing. If
unchecked, the application does not lock change requests when
you open its Properties dialog box.
Clear manually locked change requests after edit - Unlocks a
locked change request after you have edited its properties, and
clicked OK to create a new revision. If unchecked, the application
does not remove the locks.
Note: If you do not select either of the locking options, opening
a change request will not lock it; you must manually lock and
unlock it. If you select the Exclusively Lock option only,
change requests that are not already locked become locked
when you open them and unlocked when you click Cancel or
OK. If you select the Clear change request Locks option
only, any change request that you have locked manually
becomes unlocked when you click OK to create a new
revision. If you select both options, you can lock change
requests manually or by opening them. These change requests
become unlocked when you click OK to create new revisions
or (if they were not locked prior to being opened) when you
click Cancel.

URL Options

Specify the following:
•
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Display template - Specifies a special template used to generate
an HTML representation of an item when the item's URL is copied
to the Clipboard. With no format, there is a default HTML
representation that specifies the type of item and identifies it by
name and number, for example, Change Request #39,849. When
the text is generated from the template, the specified property
values are substituted for the variables in ~~*~~. The variables
may be referenced by the same names used in report templates
(available in the Cross-Platform Client), as well as by the display
name of the property. When using the display name, you can omit
spaces, and case will be ignored. For example, if you use the
following sample template for a file: Change Request:~~CR

Generate ID-based
URLs

Item

Description

Default Setting

Number~~:~~CreatedBy~~, the HTML representation will be
the Change Request:38,849:Tom Smith.
•

Generate ID-based URLs - Specifies the URL by ID rather than
by name. For example, an ID-based URL would be

starteam://hostname:
49201/12;ns=Project;scheme=id , while a name-based
URL would be starteam://hostname:49201/
myproject.
Note: Folders always use an ID-based URL.

Console Preferences
Window > Preferences > Team > StarTeam > Console
The Console preference settings allow you to configure the StarTeam console. You can set properties for
output colors and text font and configure the console to open automatically when the application generates
output.
Item

Description

Default Setting

Enable console

When checked, displays the console
window.

Unchecked

Fixed width console

When enabled, specifies the width of
lines output to the console. Enabling
this option allows you to specify the
console width using the Character
width preference setting.

Not specified

Character width

Specifies the width of lines output to
the console. You can specify this
option when activating the Fixed
width console preference.
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Limit console output

Limits the number of characters
Activated
buffered by the console. Use this
option with the Console buffer size (in
characters) preference to set the
console buffer size.

Console buffer size (in characters)

Use this option with the Limit console 500000 characters
output preference to set the number
of characters buffered by the console.

Show StarTeam console
automatically when command is run

Shows the output of StarTeam
commands in the Console view.

Not specified

Note: With this option
enabled, you may experience
slower command operation.
Console text color settings

You can customize the text colors in
the StarTeam console for the
following:
•
•
•

Command line - Black Message Blue Error - Red

Command line
Message
Error
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File Preferences
Window > Preferences > Team > StarTeam > File
In File Preferences, you can choose a variety of options to customize the way you work with files, such as
select check-out, locking, merging, end-of-line, file encoding, and display template options.
Item

Description

Default Setting

Check-out

Choose from the following options:

Not specified

•

•

Locking

Choose from the following options:
•

•

•

•

•

•

Merging

•

•
•
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Exclusively lock files on check-out - Sets the default Lock
Status option to Exclusive in the Check Out dialog box .
Otherwise, the default is Keep Current.
Clear file locks on check-in - Sets the default Lock Status
option to Unlock in the Check Out dialog box. Otherwise,
the default is Keep Current.
Use non-exclusive locks in integration - Creates a nonexclusive lock when locking a file from the application
integration-that is, a lock that allows others to check in the
file. Using non-exclusive locks also allows more than one
person to edit a file at one time. If team members are not
editing the same lines of the file, the merged file usually has
no conflicts.
Mark unlocked working files read-only - Sets working
copies of files that you have not locked to read-only when
you add files, check in files, check out files, or unlock files. If
this check box is selected, only locked files can be edited.
Check file revision on modification - Upon editing a file in
the workspace, this option checks if there is a newer version
of the file in the repository. If a newer version exists, the
application prompts the user to check out the latest version
before continuing with any changes.
Lock files on modification - Sets all StarTeam-controlled
files to read-only.

Choose one of the following:
•
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Use last modification time for checked-out files - Uses
the same time for each checked-out file as the time stamp of
the revision being checked out. Otherwise, the time stamp
used for the checked-out file is the current time (the time
check-out occurs.)
Optimize for slow connections - Sends only the delta
(difference between the revision in the working folder and the
revision being checked out) on check-out operations if this
speeds up the data transfer. When this box is unchecked,
the server always sends the entire revision of the file.

Always pop-up merge utility - Opens the merge utility to
display the merged file even when there are no conflicts.
Pop-up merge utility in case of conflicts only - Opens the
merge utility only if the merged file contains conflicts. If
unchecked, files will be checked in and out automatically.
Use Eclipse compare/merge - Select to use the default
Eclipse compare/merge utility.
Use StarTeam compare/merge - Select to use StarTeam's
File Compare/Merge as the alternate compare/merge utility
instead of the default tool. Use the following command-line

Use non-exclusive locks
in integration

Always pop-up merge
utility

Item

Description

Default Setting

options to specify File Compare/Merge as your alternate
compare/merge tool:
•

Merge utility - C:\Program Files\Borland

\StarTeam Cross-Platform Client
<version>\File Compare Merge.exe
•

Options: Use the following command-line options to
represent files sent by STEC to the alternate merge
utility:

-automerge $branchtip $usertip
$branchtip A place holder for the path to the tip
revision of the file to be merged.
$usertip A place holder for the path to the local
working file to be merged.

-base $basefile A place holder for the path to the
common ancestor for the $branchtip and
$usertip files.

•

-result $resultfile A place holder for the path
to the file that will store the output from the merged file.
Comparison utility - C:\Program Files\Borland
\StarTeam Cross-Platform Client
<version>\File Compare Merge.exe

•

Options:- Use the following command-line options to
represent files sent by STEC to the alternate compare utility:

$file1 A place holder for the path to the first of the two
files to be compared.

$file2 A place holder for the path to the second of the two
files to be compared.
EOL

Automatic EOL conversion for check-out operations Performs an automatic EOL conversion on check-out
operations. If checked, also select the operating system on
which you are working: Windows (CR-LF), Unix(LF), or Mac®).

Not specified

Encoding

Specifies the default code page to be used for keyword
expansion by choosing a default file encoding from the dropdown list.

windows-1252

URL Options

Specify the following:

Generate ID-based
URLs

•

Display template - Specifies a special template used to
generate an HTML representation of an item when the item's
URL is copied to the Clipboard. With no format, there is a
default HTML representation that specifies the type of item
and identifies it by the filename, for example,
buildinfo.properties. When the text is generated from the
template, the specified property values are substituted for
the variables in ~~*~~. The variables may be referenced by
the same names used in report templates (available in the
StarTeam Cross-Platform Client), as well as by the display
name of the property. When using the display name, you can
omit spaces, and case will be ignored. For example, if you
use the following sample template for a file:
~~FolderPath~~:~~Name~~, the HTML representation
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Item

Description

Default Setting

will be the StarTeam path to the selected file: StarTeam

\:buildinfo.properties.
•

Generate ID-based URLs - Specifies the URL by ID rather
than by name. For example, an ID-based URL would be

starteam://hostname:
49201/12;ns=Project;scheme=id, while a namebased URL would be starteam://hostname:49201/
myproject.
Note: Folders always use an ID-based URL.

Folder Preferences
Window > Preferences > Team > StarTeam > Folder
You can customize the following folder options:
•
•

Exclusively locking folders during edits.
Clearing manually locked folders after edits.

Item

Description

Default Settings

Locking

Choose from the following options:

Not specified

•

•

Exclusively Lock Folder During Edit - Locks a folder when you
open its Properties dialog box for editing. If unchecked, the
application does not lock folders when you open its Properties
dialog box.
Clear Manually Locked Folders After Edit - Unlocks a locked
folder after you have edited its properties, and clicked OK to create
a new revision. If unchecked, the application does not remove the
locks.
Note: If you do not select either of the locking options, opening a
folder will not lock it; you must manually lock and unlock it. If you
select the Exclusively Lock option only, folders that are not
already locked become locked when you open them and
unlocked when you click Cancel or OK. If you select the Clear
manually locked folders after edit option only, any folder that
you have locked manually becomes unlocked when you click OK
to create a new revision. If you select both options, you can lock
folders manually or by opening them. These folders become
unlocked when you click OK to create new revisions or (if they
were not locked prior to being opened) when you click Cancel

.
URL Options

Specify the following:
•
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Display template - Specifies a special template used to generate an
HTML representation of an item when the item's URL is copied to
the Clipboard. With no format, there is a default HTML
representation that specifies the type of item and identifies it by the
folder name. For example, ReadMe. When the text is generated
from the template, the specified property values are substituted for
the variables in ~~*~~. The variables may be referenced by the
same names used in report templates, as well as by the display
name of the property. When using the display name, you can omit
spaces, and case will be ignored. For example, if you use the
following sample template for a file:

Generate ID-based URLs

Item

Description

•

Default Settings

~~FolderPath~~:~~Name~~, the HTML representation will be
the StarTeam path to the selected folder: SampleProject
\ReadMe.
Generate ID-based URLs - Specifies the URL by ID rather than by
name. For example, an ID-based URL would be starteam://
hostname:49201/12;ns=Project;scheme=id, while a
name-based URL would be starteam://hostname:49201/
myproject.
Note: Folders always use an ID-based URL.

Mapping Preferences
Window > Preferences > Team > StarTeam > Folder > Mapping
Note: You can set folder mappings in the client using the Mapping options in the Preferences dialog
box or at the project-level using the Properties menu found in the Eclipse Explorers on shared
projects.
The Mapping preference settings allow you to map repository folders to your Eclipse workspace folders.
These preferences enable you to change the naming of local folders taken from either the human-readable
names of StarTeam folders or their path fragments. These options correspond to using default or alternate
working folders in the Cross-Platform Client.
Note: Most users should use the default setting. It is not advisable to change the folder mappings onthe-fly. You should keep your folder mappings consistent for the duration of the workspace.
You can customize the following mapping options at the default and project-specific levels:
•
•

Map name (and replace non-path characters by '-'): The default setting.
Map path fragment: The setting used to indicate alternate folder names.

In the StarTeam Eclipse Client, you do not have to be concerned with Mapping preferences for project,
view, or root folder names. These names are associated with internal identifiers (IDs), so there is no need
to use any type of Mapping preferences. You can name your local project whatever you like. Mapping does
not apply at all in this case, and the default name suggested for the local project is the root folder name of
the view; however, since the project, view, and folder IDs are used for sharing, the local project name can
be changed at your own discretion.
However, the client handles local folder names differently. While the relationship between local folders and
remote (server-side) folders is established by an ID, on an initial folder mapping or a local folder creation
and naming, the Mapping Preferences apply for how the client identifies folders that have not yet been
shared and finds suitable remote folders for them.
Path fragments are server-side only and do not change any property for the client. However, if you choose
in the client to use path fragments for the workspace folder naming, you may need to refresh the latter to
be aware of the remote changes. A local, automatic adjustment does not exist if you change the path
fragment so drastically that the local folder is no longer named accordingly. If this happens, the local folder
will loose its relationship to its remote peer despite the folder ID it remembers and show up as a local
addition in the client.
Note:
•

By default, StarTeam uses remote (server-side) folder names for the local workspace folder
names. The standard mapping setting is not to allow mapping at all. However, you can change the
Mapping options to use the folder path fragment. Relative paths (../../x/y/z) are not
accepted. Alternatively, the mapping can default to the last segment of the path fragment.
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•

You can check-in the Eclipse <project>/.settings/
com.borland.team.starteam.provider.prefs file to share the same folder mapping
settings for that project across teams. To provide general mapping coherence, you can export and
share the preferences on a file server for importing by team members.

Item

Description

Default Setting

Map name (and
replace non-path
characters by '-')

The default setting. Maps to the default setting for StarTeam
server-side (remote) folders. Most users will use this as their
default setting. This means that you are using the default folder
name provided by the Server to name your local folders.

Activated

Map working folder

Use this option to set alternate working folders. You can choose
from the following options to handle an absolute or relative
working folder path:

Report error

•

•

Configure project
specific settings

Default to last segment - Use this setting to keep the last
segment of the path. This is helpful for users that redirect
folders to other locations without actually changing the last
segment of the working folder path from the initial short
working folder. For example, you may want to use this option
for folders that you never perform a check-in on, such as a
folder that you locally name as, plugins[DO NOT CHECK IN].
Report error - Does not allow remote folders with complex
working folder paths to be mapped. This option keeps you
from checking out folders that are pointing to other locations
other than the default setting on the Server.

You can overload preferences on a per-project basis. This link
opens the Project Specific Configuration dialog box where
you can select a project and configure mapping preferences
specifically for it.

Not specified

Overloaded preference settings are stored within a project in the
path ".settings/
com.borland.team.starteam.provider.prefs".
You can check them in and share them across teams to enforce
the same folder mapping for every team member.

Folder Mapping Examples
Let's imagine a StarTeam Project that has the following Folder structure (folder name in
quotes, working folders in parenthesis):
"<My Project>" (C:\prj)
"CRs/Tasks/Requirements" (process)
"Documentation" (../html/docs)
"Source" (S:\src\java)
The three mapping methods create the following workspace structures:
Map name (and replace non-path characters by '_') ... "comments
in quotes"
_My Project_ ... "the '<' and '>' characters in the
root folder name get replaced by '_' to comply with eclipse
resource naming rules"
CRs_Tasks_Requirements ... "the '/' characters in
this folder name get replaced by '_' to comply with platform
file and folder naming rules"
Documentation ... "no conversion needed for this
folder name"
Source ... "no conversion needed for this folder
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name"

Map working folder ...
... If absolute or relative working folder is set ...
... Default to last segment
prj ... "the last segment of the absolute path in the
view '<My Project>' working folder 'C:\prj' is used"
docs ... "the last segment of the relative path in
the 'Documentation' folder's working folder '../html/docs' is
used"
java ... "the last segment of the absolute path on
another drive in the 'Source' folder's working folder 'S:\src
\java' is used"
process ... "the working folder of folder 'CRs/
Tasks/Requirements' can be taken unchanged"
... Report error ()
An exception would be thrown at sharing, indicating
the first absolute path used for the view's working folder as
non-mappable.
The Cross-Platform Client allows folders with an empty working folder property. Such folders will not map
into Eclipse workspaces when using working folder mapping, and a thrown exception prevents projects
with such folder structures from synchronizing properly.
Note: The workspace project name does not need to be the same as the folder name and working
folder path. The sharing parameters are ID-based to allow both remote and local renaming without
losing the sharing. Nonetheless, wizards that check out repository folders as workspace projects
observe the mapping preferences, and choose the suggested project name based on the general
mapping preferences. If mapping is not configured to use folder names, the last segment of the
working folder is suggested for project naming.

Label Decorations Preferences
Window > Preferences > Team > StarTeam > Label Decorations
Label Decorations show extra information about an item on its label or icon. The preferences enable you
customize the text, font, and icons associated with your projects, folders, and files. You can indicate what
text label flags you want to use for various file states and which variables should display with files, folders,
and projects.
Note: To display label decorations, the StarTeam Provider and StarTeam Server Explorer options
must be checked in the General > Appearance > Label Decorations options of the Preferences
dialog box.
Item

Description

Default Setting

General

Use the options on this page to
configure general preferences about
the decorators:

Not specified

Enable color decoration - This
option enables color decorations. You
can configure the colors used for
incoming changes, outgoing changes,
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Item

Description

Default Setting

invisible folders, and other changes
using the General > Appearance >
Colors and Fonts preference page.
Enable font decoration - This option
enables font decorations. You can
configure the fonts used for incoming
changes, outgoing changes, invisible
folders, and other changes using the
Colors and Fonts preference page.
When you activate Enable font
decoration, the application also
activates the following options:
•
•
•

Decorate incoming changes
Decorate outgoing changes
Decorate bidirectional changes

Text Decorations

These settings specify how StarTeam
information displays on text labels.
Use the File Decoration, Folder
Decoration, and Project Decoration
options to edit the variable(s) that
display for a file, folder, or project and
the order in which they should
display. To add a variable to the
format, click Add Variables, select
the desired variable(s) from the list,
and click OK. Use the Branch on
check-in flag to enter your preferred
text indicator.

Icon Decorations

All activated
These settings specify the overlay
icons used to show StarTeam-specific
information in views. You can activate
icon decorations for the following:
•
•
•
•
•
•

File Decoration: ${name} ($
{dot_notation}) Folder Decoration: $
{name} Project Decoration: ${name}
[${view_path}] Branch on check-in
flag: !

Current
Outgoing changes
Incoming changes
Bidirectional changes
Locked exclusively
Excluded

The Preview pane at the bottom of the Label Decorations preference page shows you the various icon and
text decorations associated with the various states of StarTeam items.

Label Decorations (for Provider) Preferences
Window > Preferences > Team > StarTeam > Label Decorations (for Provider)
Label Decorations show extra information about an item on its label or icon. In your StarTeam Label
Decorations (for Provider) preferences, you can indicate what text label flags you want to use for various
file states and which variables should display with files, folders, and projects.
Note: To display label decorations, the StarTeam Provider and StarTeam Server Explorer options
must be checked in the General > Appearance > Label Decorations options of the Preferences
dialog box.
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Item

Description

Default Setting

General

Use the options on this page to
configure general preferences about
the decorators:

Not specified

Enable color decoration - This
option enables color decorations. You
can configure the colors used for
incoming changes, outgoing changes,
invisible folders, and other changes
using the General > Appearance >
Colors and Fonts preference page.
Enable font decoration - This option
enables font decorations. You can
configure the fonts used for incoming
changes, outgoing changes, invisible
folders, and other changes using the
General > Appearance > Colors
and Fonts preference page. When
you activate Enable font decoration,
the application also activates the
following options:
•
•
•

Decorate incoming changes
Decorate outgoing changes
Decorate bidirectional changes

Text Decorations

These settings specify how StarTeam
information displays on text labels.
Use the File Decoration, Folder
Decoration, and Project Decoration
options to edit the variable(s) that
display for a file, folder, or project and
the order in which they should
display. To add a variable to the
format, click Add Variables, select
the desired variable(s) from the list,
and click OK. Use the Branch on
check-in flag to enter your preferred
text indicator.

Icon Decorations

All activated
These settings specify the overlay
icons used to show StarTeam-specific
information in views. You can activate
icon decorations for the following:
•
•
•
•
•
•

File Decoration: ${name} ($
{dot_notation}) Folder
Decoration: ${name} Project
Decoration: ${name} [$
{view_path}] Branch on
check-in flag: !

Current
Outgoing changes
Incoming changes
Bidirectional changes
Locked exclusively
Excluded

Tip: The Preview pane at the bottom of the page shows you the various icon and text decorations
associated with the various states of StarTeam items.

Label Decorations (for Server Explorer) Preferences
Window > Preferences > Team > StarTeam > Label Decorations (for Server Explorer)
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Label Decorations show extra information about an item on its label or icon. In your StarTeam Label
Decorations preferences, you can indicate what text label flags you want to use for various file states and
which variables should display with files, folders, and projects.
Note: To display label decorations, the StarTeam Provider and StarTeam Server Explorer options
must be checked in the General > Appearance > Label Decorations options of the Preferences
dialog box.
Item

Description

Default Setting

General

Currently, there are no general
preferences to set for the Server
Explorer.

N/A

Text Decorations

These settings specify how StarTeam
information displays on text labels.
Use decoration field to edit the
variable(s) that display for the
corresponding item, view, project, or
server, and to specify the order in
which they should display. To add a
variable to the format, click Add
Variables, select the desired
variable(s) from the list, and click OK.
Use the Branch on check-in flag to
enter your preferred text indicator.

Task Decoration: ${name} Topic
Decoration: ${name}
Requirement Decoration: $

Icon Decorations

{name}
File Decoration: ${name} ($

{property:DotNotation})
Locker: $
{property:ExclusiveLocker
} Folder Decoration: ${name}
Project Decoration: ${name}
Server Decoration: ${name} [$
{property:LoggedInUser}]

All activated
These settings specify the overlay
icons used to show StarTeam-specific
information in views. You can activate
icon decorations for the following:
•
•
•
•

Not-in-view Folder
Locked exclusively
Flagged
Task status

Tip: The Preview pane at the bottom of the page shows you the various icon and text decorations
associated with the various states of StarTeam items.

Password Management Preferences
Window > Preferences > Team > StarTeam > Password Management
The Password Management preference settings allow you to view the stored information for your
configured StarTeam repository locations and enables you to delete this information.
Note: StarTeam uses a standard Eclipse feature to store password information. The Eclipse
encryption tool keeps password information securely hidden.
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Item

Description

Connection

This field displays the connection name that you supply in
the Server description field when creating a connection to
a StarTeam server configuration.

User

This field displays the user currently logged in to the
specified server configuration.

Status

This field indicates whether the user is logged on or off of
the specified server configuration.
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Item

Description

Remove

Select one row from the list, and click Remove to delete
the stored information.

Remove All

Deletes all stored information.

Requirement Preferences
Window > Preferences > Team > StarTeam > Requirement
The Requirement preferences enable you to specify the criteria that the application uses to determine
whether a requirement has been read. You can also indicate how often the application should search for
new requirements and how requirement locking issues should be handled.
Item

Description

Default Setting

Mark as read

Choose one of the following options:

Only when manually
marked as read

•

•

•

When requirement is selected - Marks a requirement read as
soon as you select it. An unread requirement is displayed with bold
font. A read requirement is displayed with regular font.
When selected for ___ seconds - Marks a requirement read after
it has been selected for the specified number of seconds. The
range is from 15 to 9999 seconds.
Only when manually marked as read - Marks a selected
requirement read when you choose Mark as Read from the
Requirement view's context menu.
Note: Requirements are always marked as read when you
display their properties.

System tray
notifications

You can set the following options:
•

•

Locking

Check for new or modified requirements - Checks for new or
modified requirements at regular intervals and lets you know that
you have become responsible for new requirements. If this option
is checked, you must also specify the number of minutes between
checks in the Interval option below. When unchecked, the
application does not place an icon in the system tray for a new
requirement.
Interval (in minutes) - Specifies the number of minutes between
automatic checks for new or modified requirements.

Choose one of the following options:
•

•

Check for new or modified
requirements - every 0
minutes

Not specified

Exclusively lock requirement during edit - Locks a requirement
when you open its Properties dialog box for editing. If unchecked,
the application does not lock requirements when you open its
Properties dialog box.
Clear manually locked requirements after edit - Unlocks a
locked requirement after you have edited its properties, and
clicked OK to create a new revision. If unchecked, the application
does not remove the locks.
Note: f you do not select either of these options, opening an
requirement will not lock it; you must manually lock and unlock
it. If you select the Exclusively lock requirement during edit
option only, requirements that are not already locked become
locked when you open them and unlocked when you click
Cancel or OK. If you select the Clear manually locked
requirements after edit option only, any requirement that you
have locked manually becomes unlocked when you click OK to
create a new revision. If you select both options, you can lock
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Item

Description

Default Setting

requirements manually or by opening them. These
requirements become unlocked when you click OK to create
new revisions or (if they were not locked prior to being opened)
when you click Cancel.
URL Options

Specify the following:
•

•

Generate ID-based URLs

Display template - Specifies a special template used to generate
an HTML representation of an item when the item's URL is copied
to the Clipboard. With no format, there is a default HTML
representation that specifies the type of item and identifies it by
name and number. For example, Requirement #34,132. When the
text is generated from the template, the specified property values
are substituted for the variables in ~~*~~. The variables may be
referenced by the same names used in report templates (available
in the Cross-Platform Client), as well as by the display name of the
property. When using the display name, you can omit spaces, and
case will be ignored. For example, if you use the following sample
template for a file: Requirement #~~Number~~:
~~Status~~, the HTML representation will be Requirement
#34,132: Submitted.
Generate ID-based URLs - Specifies the URL by ID rather than
by name. For example, an ID-based URL would be

starteam://hostname:
49201/12;ns=Project;scheme=id, while a namebased
URL would be starteam://hostname:49201/
myproject.
Note: Folders always use an ID-based URL
.

StarTeamMPX Preferences
Window > Preferences > Team > StarTeam > StarTeamMPX
Tip: If you have StarTeamMPX enabled, there is no need to use the Team > Refresh Status context
menu command.
Server configurations that use StarTeamMPX offer additional caching services and performance
enhancements. But to take advantage of these benefits, StarTeamMPX must be enabled on your
workstation so that any open project view can take advantage of StarTeamMPX.
The right end of the application status bar displays the current status of StarTeamMPX on your
workstation. The words and icons on the status bar for StarTeamMPX are as follows:
•
•
•

•
•
•
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An icon with a yellow lightning bolt indicates that StarTeamMPX is available and enabled for the
currently selected project view.
An icon with a gray lightning bolt indicates that StarTeamMPX is available for the currently selected
project view but that it has not been enabled.
An icon displaying a small circle with a diagonal line through it indicates that StarTeamMPX was
enabled for the currently selected project view but that the connection has been broken. The network
may not be working properly.
No icon indicates that StarTeamMPX is disabled for the currently selected project view.
Instant indicates that StarTeamMPX’s autorefresh is turned on.
Auto indicates that your workstation’s autorefresh is turned on, but that StarTeamMPX autorefresh is
either turned off or unavailable.
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•

Manual indicates that your workstation’s auto-refresh is turned off and that StarTeamMPX autorefresh
is either turned off or unavailable.

Item

Description

Enable StarTeamMPX

Enables your workstation to use StarTeamMPX if it is
available on the server. Changing this check box does
not affect open projects. StarTeamMPX is enabled by
default.

Automatic refresh with

Enables automatic refresh of the application window by
way of MPX, with options for setting the minimum and
maximum delay times between refreshes. The default
minimum is 5 seconds, and the default maximum is 30
seconds. If this option is unchecked, you must refresh
manually (F5.)
When Automatic Refresh is enabled, after every change
to the view, StarTeam waits a minimum number of
seconds before refreshing. That means that if changes
are infrequent, the application performs a refresh almost
immediately. However, if changes are frequent, the
minimum refresh timer is constantly being reset and
never reaches the number of seconds set for a refresh. In
such cases, the next refresh occurs when the maximum
number of seconds between refreshes forces a refresh.
Automatic refresh is designed to perform even if the client
is minimized. When Automatic refresh is enabled, if the
network is down, Automatic refresh will attempt to refresh
the data in the client resulting in a connection error.

Enable StarTeamMPX Cache Agent

Uses a StarTeamMPX Cache Agent when checking out
files.

Use Cache Agent at

Designates a specific Cache Agent to use by IP address
and port number.

Automatically locate the closest Cache Agent for
StarTeamMPX Server

Locates the network nearest Cache Agent automatically,
but only if the server is MPX-enabled.

Maximum request threads

Specifies the maximum number of request threads
allowed. The default is 2, and 2 to 3 should be adequate
for most of your needs.

Task Preferences
Window > Preferences > Team > StarTeam > Task
The Task preferences enable you to specify the criteria that the application uses to determine whether a
task has been read. You can also indicate how often the application should search for new tasks and how
task locking issues should be handled.
Item

Description

Default Setting

Mark as read

Choose one of the following options:

Only when manually
marked as read

•

•

•

When task is selected - Marks a task read as soon as you select it.
An unread task is displayed with bold font. A read task is displayed
with regular font.
When selected for ___ seconds - Marks a task read after it has
been selected for the specified number of seconds. The range is from
15 to 9999 seconds.
Only when manually marked as read - Marks a selected task read
when you choose Mark as Read from the Task view's context menu.
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Item

Description

Default Setting

Note: Tasks are always marked as read when you display
their properties.
System tray
notifications

You can set the following options:
•

•

Locking

Check for new or
modified tasks - every
Check for new or modified tasks - Checks for new or modified tasks 10 minutes
at regular intervals and lets you know that you have become
responsible for new tasks. If this option is checked, you must also
specify the number of minutes between checks in the Interval option
below. When unchecked, the application does not place an icon in the
system tray for a new task.
Interval (in minutes) - Specifies the number of minutes between
automatic checks for new or modified tasks.

Choose one of the following options:
•

•

Not specified

Exclusively lock task during edit - Locks a task when you open its
Properties dialog box for editing. If unchecked, the application does
not lock tasks when you open its Properties dialog box.
Clear manually locked tasks after edit - Unlocks a locked task after
you have edited its properties, and clicked OK to create a new
revision. If unchecked, the application does not remove the locks.
Note: If you do not select either of these options, opening an task
will not lock it; you must manually lock and unlock it. If you select
the Exclusively lock task during edit option only, tasks that are
not already locked become locked when you open them and
unlocked when you click Cancel or OK. If you select the Clear
manually locked tasks after edit option only, any task that you
have locked manually becomes unlocked when you click OK to
create a new revision. If you select both options, you can lock
tasks manually or by opening them. These tasks become
unlocked when you click OK to create new revisions or (if they
were not locked prior to being opened) when you click Cancel

URL Options

Specify the following:
•

•

Display template - Specifies a special template used to generate an
HTML representation of an item when the item's URL is copied to the
Clipboard. With no format, there is a default HTML representation that
specifies the type of item and identifies it by name and number. For
example, Task #1,456. When the text is generated from the template,
the specified property values are substituted for the variables in
~~*~~. The variables may be referenced by the same names used in
report templates (available in the Cross-Platform Client), as well as by
the display name of the property. When using the display name, you
can omit spaces, and case will be ignored. For example, if you use
the following sample template for a file: Task #~~Task
Number~~:~~Status~~:~~Responsibility~~, the HTML
representation will be Task #1,456:Ready To Start:Tom
Smith.
Generate ID-based URLs - Specifies the URL by ID rather than by
name. For example, an ID-based URL would be starteam://
hostname:49201/12;ns=Project;scheme=id, while a
namebased URL would be starteam://hostname:49201/
myproject.
Note: Folders always use an ID-based URL
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Generate ID-based
URLs

Item

Description

Default Setting

.

Topic Preferences
Window > Preferences > Team > StarTeam > Topic
The Topic preferences enable you to specify the criteria that the application uses to determine whether a
topic has been read. You can also indicate how often the application should search for new topics and how
topic locking issues should be handled.
Item

Description

Default Setting

Mark as read

Choose one of the following options:

Only when manually
marked as read

•

•

•

System tray
notifications

You can set the following options:
•

•

Locking

When topic is selected - Marks a topic read as soon as you
select it. An unread topic is displayed with bold font. A read topic is
displayed with regular font.
When selected for ___ seconds - Marks a topic read after it has
been selected for the specified number of seconds. The range is
from 15 to 9999 seconds.
Only when manually marked as read - Marks a selected topic
read when you choose Mark as Read from the Topic view's
context menu. Note: Topics are always marked as read when you
display their properties.

Check for new or modified topics - Checks for new or modified
topics at regular intervals and lets you know that you have become
responsible for new topics. If this option is checked, you must also
specify the number of minutes between checks in the Interval
option below. When unchecked, the application does not place an
icon in the system tray for a new topic.
Interval (in minutes) - Specifies the number of minutes between
automatic checks for new or modified topics.

Choose one of the following options:
•

•

Check for new or
modified topics - every
10 minutes

Not specified

Exclusively lock topic during edit - Locks a topic when you
open its Properties dialog box for editing. If unchecked, the
application does not lock topics when you open its Properties
dialog box.
Clear manually locked topics after edit - Unlocks a locked topic
after you have edited its properties, and clicked OK to create a
new revision. If unchecked, the application does not remove the
locks.
Note: If you do not select either of these options, opening an
topic will not lock it; you must manually lock and unlock it. If
you select the Exclusively lock topic during edit option only,
topics that are not already locked become locked when you
open them and unlocked when you click Cancel or OK. If you
select the Clear manually locked topics after edit option
only, any topic that you have locked manually becomes
unlocked when you click OK to create a new revision. If you
select both options, you can lock topics manually or by
opening them. These topics become unlocked when you click
OK to create new revisions or (if they were not locked prior to
being opened) when you click Cancel.
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Item

Description

Default Setting

URL Options

Specify the following:

Generate ID-based
URLs

•

•

Display template - Specifies a special template used to generate
an HTML representation of an item when the item's URL is copied
to the Clipboard. With no format, there is a default HTML
representation that specifies the type of item and identifies it by
name and number. For example,Topic #34,132. When the text is
generated from the template, the specified property values are
substituted for the variables in ~~*~~. The variables may be
referenced by the same names used in report templates (available
in the Cross-Platform Client), as well as by the display name of the
property. When using the display name, you can omit spaces, and
case will be ignored. For example, if you use the following sample
template for a topic: Topic # ~~topicnumber~~:
~~Title~~, Status - ~~status~~, the HTML representation
will be Topic #34,132: Topic Title, Status Active.
Generate ID-based URLs - Specifies the URL by ID rather than
by name. For example, an ID-based URL would be

starteam://hostname:
49201/12;ns=Project;scheme=id, while a namebased
URL would be starteam://hostname:49201/
myproject.
Note: Folders always use an ID-based URL.

Workspace Preferences
Window > Preferences > Team > StarTeam > Workspace
The Workspace preferences allow you to select a variety of options that affect the way your workspace
operates.
Confirm
Item

Description

Delete

Displays a Confirm dialog box for deletions.

Move/Share

Displays a Confirm dialog box for move and share
operations.

Warnings

Displays a Confirm dialog box for warnings.

Display
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Item

Description

Status bar

Displays the Status Bar.

Show history times as UTC

Displays time stamps in the Time column of the History view
in UTC times. UTC times end in "Z" to differentiate them
from local times (Z stands for the "zero meridian", which
goes through Greenwich, England). Displays time stamps in
local time when unchecked.

Sort view labels by name

Automatically sorts view labels alphabetically.

Reset scope to local on folder change

Resets the All Descendants button on the toolbar every
time you change a folder. This saves you the time StarTeam
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Item

Description
would take to scan items. If unchecked, you must select the
button manually.

Maintain group state on folder/scope change

Keeps your place in the selected view even when you
change folders or reset the All Descendants button. If
unchecked, all groups collapse when you make a folder or
scope change.

Filter drop-down menus - limit number of filter menu items to Specifies the maximum number of filter items listed in the
__.
Filter list box.

Check In and Check Out dialogs
Item

Description

Hide Changes area

Hide the Changes area of the Check In/Check Out dialog
boxes by default.

Hide Process Item section (if no process rules)

Hide the Process Item section of the Check In/Check Out
dialog boxes when there are no process rules being used in
the project.

Hide Label section

Hide the Label section in the Check In/Check Out dialog
boxes.

EOL Conversion and Advanced sections

Hide the EOL Conversion and Advanced sections in the
Check In/Check Out dialog boxes.

Change Requests section

Hide the Change Requests section in the Check In/Check
Out dialog boxes.

Hide Reference By section

Periodic refresh
Item

Description

Automatic refresh with maximum delay of ___ minutes

Specifies the maximum number of minutes between
refreshes of your project. This refresh is the equivalent of
pressing F5 and updates the Server Explorer. It happens
every X minutes unless an operation by the user such as
pressing F5 forces a refresh and resets the timer.Automatic
refresh is designed to perform even if the client is
minimized. When Automatic refresh enabled, if the network
is down, Automatic refresh will attempt to refresh the data
in the client resulting in a connection error.

Check-in and Check-out Operations
One of the main functions of a source control management application is to place files into a project under
version control. After it is under version control, team members can check files out, revise the files, and
check in new revisions. The application preserves historical information about each file revision. And
because of its linking capabilities, you can link a file revision to other items that affected the file or a
particular revision of it. A number of other operations can be performed on files, such as moving a file or
changing its branching behavior.

Atomic Check-ins
All check-ins in StarTeam Eclipse Client are atomic. Whenever more than one file is checked in as the
result of a single transaction all of the files, and their associated process items, are updated in a single
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action. If for some reason, the check-in fails, none of the files are checked in, and the status of the
associated process items is not updated.
For example, suppose User A selects to check in all modified files in a StarTeam Eclipse Client folder, but
one of the selected files is locked by User B. Because of the locked file, none of the files are checked in
(and none of the process items are updated as fixed). User A is notified that none of the files were checked
in because one of the files was locked by User B.
Note: All check-outs are also atomic. If the check-out fails, nothing is created in the Workspace.

Check-in and Check-out Overview
To place a file under version control, it must be added to a folder in a project view, which stores a copy of
the file in the repository. After the file has been added to the repository, you and other members of your
team can check it out, revise it, and check in new revisions, while the application maintains information on
all revisions of the file. When checking out a file revision, you should verify that you have the tip or latest
version of the file. Doing this ensures that the file you see contains the latest changes. If you intend to
modify the file, you should check it out with an exclusive lock, to indicate to others that you are working on
it.
If two team members change the same text file simultaneously, or if one member changes an outdated file,
the application contains a merge option that allows the file changes to be combined so that no work is lost.
In such cases, the application assigns a Merge status to the file.
When you check in a file from a working folder on your computer, the application stores it by the MD5 value
of its contents. If the file is identified as one that compresses well, it is compressed and placed in the hive's
archive with a .gz extension. Otherwise, the uncompressed version is placed in the hive's archive. When
you check out a file, the application copies the requested revision of that file to the appropriate working
folder. If a copy of that file is already in the working folder, it is overwritten unless the working file appears
to be more recent. In that case, you are prompted to confirm the check out.
You can perform check-out operations on more than one file at a time. For example, you can select files
across multiple child folders, or you can check out all the files in the selected folder and its descendant
folders.
Check-in and Check-out Recommendations
Every time you check a file revision out, its contents are copied to a working folder. Checking out a revision
also ensures that you have the tip or a specific revision to work on. For example, you may need a team
member's most recent changes to a file, or you may have deleted the working file from your hard drive and
now need another copy.
Below are some recommendations about using files that are under version control:
•
•
•
•

•
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To let other team members know that you intend to make changes to a file, change the lock status to
exclusive as part of the check-out process.
As part of the check-in process, you can notify others both that you are finished making your changes to
the file and that it is available for them to check out by removing the lock status.
If you intend to continue making changes to the file but still want to check it in for backup purposes,
keep the file locked.
If two team members change the same text file simultaneously or if one member changes an outdated
file, you can use the merge option to combine the changes in these files so no work is lost. In such
cases, the application gives the file a Merge status.
To prevent yourself from changing a file that you have not locked, select the Mark Unlocked Working
Files Read-only Preferences option. Then, if you check out a file that you have not locked, the working
copy becomes read-only.
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Note: StarTeam recognizes the operating systems where the case-sensitivity of file names is
important and handles files accordingly.

Checking In Files
You can check in files:
•
•

Without opening a dialog box to set any specific check in options using the StarTeam-specific toolbar
button, Put outgoing changes to StarTeam Server.
By opening a Check In dialog box and setting specific check-in options, such as Lock Status, using
the Team > Check In command.
Note: Unlike other StarTeam clients, the StarTeam Eclipse Client does not have a special Add Files
dialog for putting new files (files with the status in not-in-view) under version control. You use the
same standard Check In dialog box for files that have been modified while under version control and
for files that are new.

1. Choose Team > Check In from one of the Eclipse Explorers or from any view that surfaces the Team
context menu. The Check In dialog box opens.
2. Type a check in comment.
A list box below the main comment text area provides previous check in comments for you to select
from.
3. Optional: Check Force check-in to overwrite the tip revision in StarTeam.
4. Optional: Check Show check-in statistics.
For a particular check-in operation, you can see how many files are being sent by StarTeam Server
directly and how many are being sent by Cache Agent, by displaying the check-in statistics. After the
check-in operation completes, the Check In Statistics dialog box opens displaying the elapsed time,
total number of files, total number of bytes, and whether the operation skipped or failed to check in any
of the files.
5. Expand Lock Status to select one of the following Lock Status options:
•
•
•
•

Unlocked: Releases your lock on the files after check-in.
Exclusive: Indicates that you intend to make further changes to the files.
Non-exclusive: Indicates that you are working on the files and may possibly make changes.
Keep Current: Retains the current lock status.

6. Optional: Select the following options in the Check In dialog box.
•
•

•
•
•

•

Check Delete working files to remove the selected files from your working folder.
Expand Process Item (required if process rules are enforced). Link and Pin Process Item to link
the files to a process item.
Clicking Select opens the Select Process Item dialog which displays available items in the current
View. You can filter the list of available process items in this dialog box, and you can use the tree to
browse to a process item in a different project or view.
If work on the active process item is now complete, check Mark selected process item to closed
state if work on the active process item is now complete.
To make changes to the selected process item's properties during the check-in process, check
Show property editor for selected process item.
Expand Label and select a Revision label from the drop-down list, or create a new revision label by
typing its name.
Check Move the label if it's already assigned to a previous revision if the label in use.
Expand Advanced. Check Set EOL check-out format (for text files only) to control the EOL
character stored with the files. The default setting is based on the EOL setting in the File Properties
dialog box. In addition, select a file type of ASCII, Binary, or Unicode.
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Choose a File Encoding from the drop-down list. The default setting is based on the EOL setting in
the Preferences dialog box.
• Expand Change Requests to review the change requests linked to the files you are checking in.
7. The bottom of the dialog box provides a Changes area. You can optionally:
•
•
•
•
•
•
•

Show flat, tree, or compressed folder views by selecting the various toolbar buttons.
Select Additions only to show only not-in-view files (files to add).
Select Changes only to show only modified files (changed files).
Click Edit Description to edit the main description for the checked in items.
Select a file or multiple files, and click Edit Comment to edit its check-in comment individually (or
leave it blank).
Select a file or multiple files, and click Delete Comment to remove a comment associated with the
checked-in item.
Select a file and click Compare with Revision to compare the files you are checking in with the tip
revision of the files in the repository.

Tip: The dialog box also provides a Configure Personal File Options link so you can quickly
make modifications to file options before completing the check-in.
8. Click OK.

Checking Out Files
1. Select the file(s) that you wish to check out from one of the Eclipse Explorers or from any view that
surfaces the Team context menu.
2. Choose Team > Check Out or Team > Force Check Out from the context menu.
Note: Using Force Check Out overwrites any files with the same name in your working folder,
even if they are more recent.
3. Click Get incoming changes from StarTeam Server within a StarTeam view.
4. Choose Team Synchronizing > Synchronize > Check Out/Force Check Out. The Check Out dialog
box does not open, and the files are checked out to your local working folder.

Checking Out Files with Options
1. Select the file(s) that you wish to check out from one of the Eclipse Explorers or from any view that
surfaces the Team context menu.
2. Choose Team > Check Out with Options from the context menu. The Check Out dialog box opens.
3. Optional: Check the following options:
•
•

Force check out to overwrite any files with the same name in your working folder, even if they are
more recent.
Show check-out statistics

For a particular check-out operation, you can see how many files are being sent by StarTeam directly
and how many are being sent by Cache Agent by displaying the check-out statistics. After the check out
operation completes, the Check Out Statistics dialog box opens displaying the elapsed time, total
number of files, total number of bytes, and whether the check-out operation skipped or failed to check
out any of the files.
4. Expand Reference By, and select one of the following options for the files you wish to check out:
•
•
•
•
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Current revision: The most current (tip) revision.
Label : A specific file revision. The view labels precede the revision labels in the list.
Promotion state: A specific promotion state.
Configuration as of: The revision that was the tip revision at the specified date and time. Click the
Date/Year button to use the calendar, and specify the time by typing in the time or using the spin
boxes.
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5. Expand Lock Status, and select one of the following lock options:
•

•
•
•

Unlocked: Does not lock the files you are about to check out, or causes them to be unlocked if you
currently have them locked. Be aware that when you check out an unlocked file, it may become
read-only in your working folder.
Note: There is a project property and a Preferences option that controls the read-only or read/
write status of working files.
Exclusive: Indicates that you intend to make further changes to the files.
Non-exclusive: Indicates that you are working on the files and may possibly make changes.
Keep Current: Retains the current lock status.

6. Optional: expand EOL Conversion, and choose one of the following:
•
•
•
•

None or another button to change your current EOL conversion setting.
For Windows, the EOL marker is CR-LF (carriage return/line feed).
For UNIX, it is LF (line feed).
For Macintosh operating systems, it is CR (carriage return).

EOL settings on this dialog override the default setting you selected on the File page of the Personal
Preferences dialog box.
7. Expand Advanced to optionally select an appropriate File Encoding from the list box to support
keyword expansion for non-English code pages.
8. In the Changes area you can optionally: Show flat, tree, or compressed folder views by selecting the
various toolbar buttons in the Changes area toolbar.
9. Select a file and click Compare with Revision in the Changes area toolbar to compare the local file
with the tip revision of the file in the repository.
Note: The dialog box also provides a Configure Personal File Options link so you can quickly
make modifications to file options before completing the checkout.
10.Click OK to complete the check out.
Note: You can also use the Get incoming changes from StarTeam Server button on the toolbar
to check out files without using the Check Out dialog box. If process rules are required, the Check
Out dialog box opens automatically.

Checking Out Existing Folders
1. Open the StarTeam perspective.
2. Choose Window > Open Perspective > Other.
3. Select StarTeam Classic or StarTeam Activity from the list, and click OK.
4. Open the Server Explorer, and navigate to the appropriate StarTeam project, view, and folder.
You can multi-select folders to check out in the Server Explorer.
Note: If you have not logged on to the server, right click on the server configuration node, and
choose Log On. The status bar at the bottom of the Workbench reflects the logged on user name.
5. Right-click and choose Check Out As Project. The Check Out As wizard opens.
6. Choose one of the following options:
Option

Description

Check out as project in the
workspace

Enter a project name in the text box provided or use the default
folder name, and click Next. Select a location where you want to
check out the files to, and click Next.

Check out into existing project

Click Next to choose a valid target project, and click Finish.
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Option

Description

Check out as a project
configured using New Project
Wizard

Click Finish , and follow the steps in the New Project wizard.

Note: If you want to use a location within the workspace that is not the default (that is, you select
either the second or third option), then you must use the StarTeam Cross-Platform Client to check
out the project and then import it from within the StarTeam Eclipse Client.
7. If you chose to Check out as project in the workspace, specify any check out options as follows:
•

Expand Reference By, and select one of the following options for the files you wish to check out:
•
•

•

Current revision : The most current (tip) revision.
Label: A specific file revision. The existing view and revision labels are listed in reverse
chronological order based on the time at which they were created. The view labels precede the
revision labels in the list.
• Promotion state: A specific promotion state.
• Configuration as of: The revision that was the tip revision at the specified date and time. Click
the Date/Year button to use the calendar, and specify the time by typing in the time or using the
spin boxes.
Expand Lock Status, and select one of the following lock options:

•

• Unlocked: Releases your lock on the files after check-in.
• Exclusive: Indicates that you intend to make further changes to the files.
• Non-exclusive: Indicates that you are working on the files and may possibly make changes.
• Keep Current: Retains the current lock status. Selected by default.
Optional: Expand EOL Conversion, and choose one of the following:

•

• None or another button to change your current EOL conversion setting.
• For Windows, the EOL marker is CR-LF (carriage return/line feed).
• For UNIX, it is LF (line feed).
• For Macintosh operating systems, it is CR (carriage return).
Expand Advanced to optionally select an appropriate File Encoding from the drop-down list to
support keyword expansion for non-English code pages.

8. Click Next. The Mapping preferences page opens.
9. Choose your desired settings, or accept the default settings, and click Finish.

EOL Conversion Handling Overview
StarTeam provides support for fixed EOL conversion files. For example, files can be checked out in LF
format on every platform, regardless of specific options. Also, Update Status works for all text files once
EOL Format is defined, regardless of what EOL format was used when they were checked-out. For
compatibility with older releases of the Cross-Platform Client, if check-out "EOL conversion" is not
requested, and EOL Format is Undefined, files are still checked out with the EOL conversion with which
they were added to the StarTeam Server.
Note: The default for automatic EOL conversion for check-out operations is “checked” if the user
does not have that option defined already.

EOL Format Property
The EOL format property displays as EOL Character in file details.
The EOL format property is only meaningful for text files during the check-out operation.
By default, the SDK will compute the EOL format under the following conditions:
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•

•
•

When a new text file is added or a new revision is checked in for a text file whose EOL format is
Undefined, the file's EOL convention matches the platform default, EOL format is set to Client
Defined. Otherwise, EOL format is set to the convention found: Fixed LF, Fixed CR, or Fixed
CRLF.
The user can change EOL format to any value (other than Undefined) at any time.
Regardless of their EOL format setting, text files added or checked in always use a canonical (CRLF)
format in the vault.

The EOL format property can be manually set in the Check In dialog box and the File Properties dialog
box.

EOL Property Values
The EOL property value is displayed as EOL Character.
The EOL Format property can be set in the Check In and File Preferences dialog boxes. If selected in the
Check In dialog box, StarTeam Eclipse Client uses the settings specified in the File Preferences dialog
box.
The EOL Property values are:
•
•
•

Undefined (null in the SDK): Used for files added before StarTeam Eclipse Client 2009 Release 2.
Client Defined: Causes workstation default or per-checkout EOL conversion option to be used.
Fixed CR, Fixed LF, and Fixed CRLF: Causes this EOL format to be used always; the workstation/
checkout conversion option is ignored.

Consistent Check-ins and Check-outs
Developers can use various StarTeam features to allow or avoid conflicts with other developers on the
same files (in the same view). In a low-contention environment, developers can check-out files without
locks, modify them, "refresh" to identify and resolve merge conflicts, and then check in modified files. All
check-ins in StarTeam are atomic. Whenever more than one file is checked in as the result of a single
transaction all of the files, and their associated process items, are updated in a single action. If for some
reason, the check-in fails, none of the files are checked in, and the status of the associated process items
is not updated. In general, you can achieve consistent check-ins and check-outs by doing the following:
•
•

Exclusively lock files before checking them in or out and unlock files after a successfully checking them
in or out; or
Temporarily change your view configuration to a known "stable" point

In higher contention environments, developers may want more assurance of getting consistent sets of files
during check-out, that is, avoiding files that are a partial set of someone else's check-in. The easiest way to
achieve this need is "by convention". Each developer exclusively locks all files before checking them in,
and unlocks them when they are "complete", either at check-in or soon thereafter. Correspondingly, each
developer exclusively locks all files before checking them out, and unlocks them when complete. If a
developer cannot get all the locks at once, they are potentially about to interfere with another developer, so
they unlock files they currently have locked, wait a bit (probably talk with the developer they are conflicting
with), and then try again. One implication of this "by convention" approach is that a developer could be
blocked while waiting for another developer to finish-up.
Note: The view configuration change is only at the client -- the underlying "real" view is not modified.
Also, note that "rolled-back" views are read-only: they must be reset to the "current" configuration
before new/modified files can be checked-in. An implication to be aware of with this approach is that
the time to switch the configuration can take a few seconds to a few minutes on very large views.

Optimizing File Check-outs Over a Slow Connection
Not surprisingly, one of the most bandwidth-demanding operations is file check-out. Even with
compression strategy, checking out a large number of files can require a lot of data transfer.

Borland StarTeam Eclipse Client

| 101

Most StarTeam users maintain a working set of files on their local disks, allowing them to check out only
the new file revisions they need to make the files current. Suppose, for example, that you are working on a
project for which StarTeam tells you that you have 75 "out of date" files. This means that you have an older
revision of each file on your local drive, but you need a newer revision to make the files current. Normally,
when you select those files and perform a check-out, StarTeam sends you each new file as a "full"
revision. For high-speed to broadband network connections, normal file check-out will give you satisfactory
performance.
But what if network bandwidth is very tight or congestion is a constant concern? StarTeam provides an
option to check out newer file revisions with a different strategy called "delta check-out". Instead of sending
full file revisions, delta check-out causes "delta" records to be sent by the StarTeam server that allow the
existing revision of each file to be "patched" to the revision you are checking out. Because delta records
are usually much smaller than the whole file revision, they require even smaller file check-out messages.
Delta check-out is enabled individually at the client level by choosing Personal Preferences > File >
Optimize for Slow Connections.
Below are some points to consider in deciding if delta check-outs will help you:
•
•

•

Delta check-out is possible only with text-based files. Binary files are always checked out by sending full
file revisions.
Delta check-out requires more CPU time and disk I/O than normal (full version) check-out because the
existing work file must be "patched" up to the selected version. Hence, you should use this option only
when network bandwidth is highly constrained (think modem kind of bandwidth).
Delta checkouts are not used, nor are they necessary, when you are checking out from a
StarTeamMPX Cache Agent.

Process Items and Process Rules
This section discusses the use of process items and process rules.

Process Items
Modern development practices require increased control over the entire development process. StarTeam
enables developers to follow a defined development process, one that ensures that all file content changes
be linked to either a change request, requirement, task, or custom component. Items used in this way are
known as process items.
Specifically, a process item is a change request, requirement, task, or custom component that is specified
by the user as the reason for making a given set of changes. Process items are supported by the Add
Files and Check In dialog boxes. As a result, source code and content are modified only to meet clearly
defined and approved objectives, as expressed in the process item.
Out-of-view Process Items
Historically, the StarTeam Cross-Platform Client has supported the selection of a process item from only
within the current view. This functionality is useful in many processes, but it does not support a process
where change requests, tasks, requirements, or custom components live in a different view than the source
code files.
To support out-of-view process, the StarTeam Cross-Platform Client now enables you to choose a valid
process item for file add or check-in operation from any view on the same server as the files being
committed. You can choose an item selected in the Items pane as the active process item for the current
view, an open view on the same server, or a different view on the same server.
Also, the Active Process Item toolbar button contains a list enabling you to select the active process item
from any opened view.
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Process Item Selection
The StarTeam Cross-Platform Client currently allows a process item to be selected as the active process
item, which results in that process item being used by default in the File Add and File Checkin dialog
boxes. The File Add and File Checkin dialog boxes also allow you to change the active process item prior
to adding or checking in the files.

Process Items and Workspace Change Packages
Process items act like lightweight change containers. Using process items enables you to link and track
changes made to your files, even when you and other members of your development team are not required
to use process rules. They provide traceability, allowing you to trace file changes to their purpose or
context. They also provide a way to identify file revisions for a specific change request, task, or
requirement so that, for example, you can attach those revisions to a view or revision label.
Note: The creation of process tasks and the Enhanced Process Model has been replaced by
workspace (check-in) change packages. Files linked to a process item can now be viewed in the
details of the Change tab or view.
Workspace (check-in) change packages are created when the following actions are performed on files and
folders:
•
•
•
•

Add and check-in
Move
Rename
Delete

When files are committed using a process item, the process item is linked via a trace to a workspace (or
check-in) change package representing the atomic commit of files. Additionally, if an active process item is
available in the StarTeam Cross-Platform Client at the time of a move or delete of files, then a workspace
change package is created for the transaction and a trace is created from the active process item to the
workspace change package.
Specifically:
•
•

The process item can be a change request, a task, a requirement, or other custom component defined
for Process Rules in the Project Properties.
The process item can live in any view. It does not necessarily have to reside in the same view where
the changes are being performed.

The StarTeam administrator can enforce the use of process items for a project by establishing process
rules. You define process rules in the Project Properties dialog box. Process rules specify that process
items must be used when checking in files, and they establish which type of items can be used as process
items.
When process rules are enforced, you must link and pin all files you add or check in to a process item. If
process rules are not enforced, you can still take advantage of the linking and tracking made possible with
process items. As you add files or check them in, you indicate that the new file revisions are to be linked
and pinned to a specific process item. You do this by selecting a change request, requirement, task, or
custom component as the process item for the operation. At the same time you can mark the change
request as fixed, the requirement as complete, or the task as finished.
Note: If there is an active process item available, the Check In dialog box automatically fills in the
Process Item field.
Using process items enables you to clearly distinguish the following:
•
•
•

Which file revisions are related to or fix a specific change request.
Which file revisions are related to or complete a specific requirement.
Which file revisions are related to or finish a specific task.
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Each view can have a different active process item. As you change from view to view, the process item
information displayed on the status bar changes.

Process Rules
Each project has the option of enforcing the use of process items by specifying certain process rules.
When enforced, the process rules require you to specify a specific process item (change request,
requirement, or task) for file add or check-in operations within the project.
Process Rules Review
If process rules are not enforced, any change request, requirement, or task can be used as a process item,
regardless of its status. However, if process rules are enforced, you may be able to select only one type of
item as a process item. In addition, acceptable process items may be limited to those with specific
statuses.
You can determine whether process rules are in effect for a specific project, and what those rules are, by
reviewing project properties. If you do not have the access rights necessary to do this, ask your
administrator what process items apply to the project and what restrictions have been placed on them.
To set process rules, you must have the access rights required to change project properties. As a rule, only
team leaders and administrators have these rights. To use process items, project users must have the
necessary access rights, which are the rights to:
•
•
•

See and modify the types of items used as process items in the project view.
Create and modify traces.
View and create change packages.

Advantages of Process Rules
Establishing a system of process rules allows you to:
•
•

Require that process items be used every time files are added or checked into the project.
Stipulate that only certain types of items with specific statuses can be used as process items in the
project.

If process rules are not enforced, linking and pinning to a process item during file add and check-in is
optional, and you can select any change request, requirement, or task as a process item, regardless of its
status.
Note: As a convenience, you can select a change request, requirement, task, or other custom
component that has been established as a valid process item type, as the Active Process Item prior to
adding or checking in files so the check-in automatically use that process item during check-in.

Active Process Items
The Client enables you to pre-select a process item as the active process item to use the next check-in
operation. This type of process item is referred to as an active process item.
You can select a change request, requirement, task, or custom component as an active process item
before adding or checking in files. Pre-selecting an active process item is a convenient way to save time
when you know that you will be adding files or checking them in later using the designated process item.
When you have a process item selected on the upper pane, making it the active process item is a simple
operation. Before or during each check-in operation, make sure you select the correct active process item.
The active process item is the default selection when you add files or check them in. However, you can
change your mind and select another appropriate item. An active process item is used until its status
becomes ineligible or another process item is chosen. Additionally, if an active process item is available in
the StarTeam Cross-Platform Client at the time of a move or delete of files, then a workspace change
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package is created for the transaction and a trace is created from the active process item to the workspace
change package.
The Status bar displays the name of the active process item. If the active process item is from a different
view and project than the current view, you can hover over the active process item shown in the status bar
and see a tool tip showing the project and view as well as the process item description. The Status bar
pre-pends the name of the active process item with the name of the project and view. To see details about
a process item, you can double-click the item in the status bar to open the Properties dialog box with more
information.
Note: You can only specify one item for each view as an active process item. Selecting a second
active process item clears the first.
Tip: After you finish with a process item, you should choose Clear Active Process Item on the menu
so that it cannot be accidentally reused. That removes the information from the status bar and keeps
the process item from reappearing in the File Add or File Checkin dialog boxes.

Process Links
A link is a relationship between two items. StarTeam can link any two items in the same repository,
regardless of project or view. You can use links to form associations between artifacts for any reason. For
example, you can link a requirement to a design document, a change request to a duplicate instance of the
same defect, a task to a design specification, and so on.
A process item is a change request, task, or requirement used as the context for a set of file content
changes. Process items can be used in any view for file add or check-in operations, but some projects
require them. Furthermore, project properties can define which artifact types are valid process items and
which statuses are valid for each artifact type.
Link Endpoints
Each endpoint of a link points to a specific item. An endpoint always stores the initial revision for which the
link is valid. An endpoint can be pinned to a specific revision or float to the latest revision referenced by the
item. A link also has a comment property that can be used to describe the link, why it was updated, and so
forth. Links are versioned, which means that if you look at a historic configuration of a view, you’ll see the
links as they existed in the historic snapshot.
Process Links: Standard and Enhanced
A process link is a StarTeam link that is used to indicate which revision of a file is relevant to a particular
change. Process links are always pinned to a specific item revision at both ends. Links with floating
endpoints are never considered process links.
StarTeam provides two models for implementing process links: The standard model and the enhanced
model.

Standard Process Items and Process Links
StarTeam has historically created process links following the standard model. In this model, one end of
each process link is to a process item. The other end is to a changed file.
For example,
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When you add or check in files to a view in a project that uses standard process links, you select the
process item to which your files will be linked. One process link will be created for each of the files in the
operation. One end of the link will be pinned to a new file revision and the other end will be pinned to the
current revision of the change request, requirement, or task.
As part of the add files or check-in process, you can change a change request’s status to Fixed, a
requirement’s status to Complete, or a task’s status to Finished. If the process item becomes fixed,
complete, or finished, each new file revision is pinned to the new revision of the process item, the one with
the correct status.
Note: If you have selected a disabled requirement as a process item, such as a read-only
requirement published to StarTeam from Caliber, it cannot be marked complete.
You can manually link one item to another more than once. When the application links a file to a process
item through multiple add and check-in operations, it updates the existing link instead of creating a new
link. Therefore, no matter how many revisions of the same file were pinned to revisions of the same
process item, the latest revision of the file pinned to the process item is the only one specified in the link
properties. To determine what file revisions are associated with a process item, you can review the links for
that item.

Promoting File Changes Into Baselines
Process rules are useful when creating baseline builds or configurations. A build is a labeled configuration
that identifies the file revisions and process items that define the code and content baseline. Process rules
require that each new file revision be linked to a process item, which allows the development team to
promote these changes into baselines.
If process rules are not enforced, developers using the application can create baselines either by:
•
•

Labeling an entire project view at a specific point in time.
Associating file revisions with a revision label on check-in.

1. Start with the previous baseline (for example, check it out based on its label.)
2. Select process items for inclusion in the new baseline.
3. Label the new baseline You can use process items for tracking purposes when adding or checking in
files.

Finding Files Associated with Active Process Items
When you have files associated with an active process item, you can quickly find all associated file
changes by following the steps below.
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1. Open the view containing the active process item.
You can see what item is the active process item by looking at the Eclipse Status Bar.
The Status Bar displays the Active Process Item icon, followed by the name of the item.
Tip: The Server Explorer also reflects when you have an active process item specified at the view
level on the View icon followed the active process item informational text.
2. Open the Link view.
3. Click Link with Selection in the toolbar.
4. Select the active process item in the appropriate Change Request, Requirement, or Task view.
5. Right click on a link and choose Select Linked Item. The view opens containing the target of the
associated item.

Linking Files to Process Items
To link and pin a file revision to a process item
1. From one of the Eclipse Explorers, choose Team > Check In from the context menu.
The Check In dialog box opens.
2. Expand Process Item, and check Link and pin process item.
3. Click Select. The Select Process Item dialog box opens.
4. Select one of the following to limit the list of possible process items:
•
•
•

List All Permitted Items: Displays all items that can be used as process items. If process rules are
not enforced, the list contains all change requests, requirements, and tasks.
List All Permitted Items Assigned To Me: Displays all the items for which you are responsible that
can be used as process items.
List Linked Items: Lists the process items that are already linked to at least one of the files you are
checking in. No process item appears on the list more than once, even if it is linked to several files.
Also, when a process item is linked to more than one file, the dialog box displays the name of only
one file. Despite this fact, the application will update or create links for every file being added.

5. Select the Change Request, Requirement, Task, or Custom Component tab to restrict the list to a
specific type of item.
6. Select one item in the list to be the active process item and click OK.
7. Optional: In the Check In dialog box select one or both of the following check boxes:
a) Check Mark selected process item to closed state if work on the process item is completed.
a) To make changes to the selected process item's properties during the check-in process, check
Show property editor for selected process item.
8. Complete filling in the fields in the Check In dialog box and click OK.
Tip: If process rules are enforced, the use of some change requests, requirements, or tasks as
process items may not be permitted because of their status. If you select such an item and click OK,
the application notifies you of this fact.
To link and pin a file revision to the active process item
1. Click the File tab and select a file or files to be checked in.
2. Choose Team > Check In from the context menu to display the Check In dialog box.
If you have already specified a process item, it will appear by default in the Link and pin process item
field.
3. Check Link and pin process item to accept this active process item.
4. Optionally, in the Check In dialog box, check Mark selected process item to closed state if work on
the active process item is completed.
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Note: Selecting this option will change the value of the process item's status property to the
Closed State specified on the Project Properties dialog box.
5. Complete filling in the fields in the Check In dialog box and click OK.

External Linking
The external linking feature provides the ability to link between items on different servers. The process for
creating external links is basically the same as for creating links between items on the same server.
•

•

•
•
•
•

•

•

All the same linking operations are available for external links that are available for standard links, such
as Create Link, Complete Link, and drag and drop operations. To create external links, the projects on
both servers containing the items you want to link need to be opened in Eclipse at the same time.
External links are surfaced in the Links view which shows the difference between internal and external
links. For example, there is an external link icon to differentiate external links from standard links. There
is also a check box for viewing or hiding external links.
The Link view has a Show External Links option to display links in all Servers that you are logged on.
When creating an external link, a URL that contains the unique identity of that item represents the
external link item details in the Link view.
External link options are the same as standard links, such as being able to view the link properties.
However, floating and pinning external links are not available.
External links have directions. Therefore, whether viewing the external link from the source item or the
link, such as a Change Request, or viewing the item on the external Server, such as the file being
linked to the Change Request, the source and target information always remains the same and does
not change based on the item selected.
Some information which is available for standard links is not available for external links because not all
information from the external item is available, such as file status, who has the file locked on the
external Server, folder path, and folder in which the item actually exists.
Access Rights dialog boxes contain External Links container level access rights.

Establishing Process Rules for Projects
Establishing a system of process rules allows you to:
•
•
•

Require that process items are used every time files are added or checked into the project.
Stipulate that only certain types of items with specific statuses can be used as process items in the
project.
Enable the use of enhanced process links for the project.
Note: To set process rules, you must have the access rights required to change project properties.
Usually, only team leaders and administrators have these rights. You must also verify that project
users have the rights to see and modify items in the project view, to create and modify links on files
and process items, and to create tasks and link to tasks if using the enhanced model.

Requiring Process Items at Check-in
1. Choose Project > Properties.
2. Expand StarTeam Provider, and select Project.
3. Check Require Selection Of Process Items When Files Are Added Or Checked In on the Process
Rules tab.
4. Check which types of items you want to allow for use as process items.

Permitting Change Requests as Process Items
1. Check Permit Selection Of Change Requests As Process Items.
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2. Do one of the following:
•
•
•
•

Check Open to use only change requests with Open status.
Check In Progress to use only change requests with In Progress status.
Check both Open and In Progress to use only change requests with either of these statuses.
Uncheck both Open and In Progress to allow any change request to be used as a process item,
regardless of status.

Permitting Requirements as Process Items
1. Check Permit Selection Of Requirements As Process Items.
2. Do one of the following:
•
•

Check Approved to use only requirements with Approved status.
Uncheck Approved to allow any requirement to be used as a process item, regardless of status.

Permitting Tasks as Process Items
1. Check Permit Selection Of Tasks As Process Items.
2. Do one of the following:
•
•
•
•

Check Ready To Start to use only tasks with Ready To Start status.
Check In Progress to use only tasks with In Progress status.
Check both Ready To Start and In Progress to use only tasks with either of these statuses.
Uncheck both Ready To Start and In Progress to allow any tasks to be used as a process item,
regardless of status.

Displaying Only Enhanced Process Links
If your project previously had enhanced process links enabled, you can choose to display only enhanced
process links.
1. Click the Link tab at in the StarTeam perspective.
2. Right-click the drop-down arrow in the Link tab toolbar and choose Show enhanced links only.
Now when you select an item in the item view that has links, the Link view only shows enhanced links, not
standard links.

Setting Active Process Items
Setting an active process item is a convenient way of saving time when you know that you will be adding
files or checking them in later. You can make a selected change request, task, or requirement the active
process item for the current view, an open view on the same server, or a different view on the same server.
You can only specify one active process item for each view. Setting a second active process item for the
same view at one time clears the first one.
1. Open your project in a StarTeam perspective.
2. Click the Change Request, Requirement, or Task tab, and select the item you want to use as the
active process item.
3. Do one of the following:
•
•
•

Right-click and choose Set Active Process Item > Current View to choose the current view.
Right-click and choose Set Active Process Item > [view name] to choose from the listed opened
views on the server.
Right-click and choose Set Active Process Item > Select View to open a dialog box and choose
any other view on the server.
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Note: You can also set the currently-selected item as a process item by using the Use As Active
Process Item button on the toolbar.
The active process item you selected is used by default when you add files or check them in. However, you
can override this default and select another appropriate item when adding or checking in files.
Tip: After you finish with a process item, you should right-click it and choose Clear Active Process
Item so that it cannot be accidentally reused. That removes the information from the status bar and
keeps the process item from reappearing in the File Add or File Checkin dialog boxes.

Filtering Process Tasks From Other Tasks
If you have previously enabled enhanced process links in your project so that StarTeam created process
tasks, you can filter your tasks to separate the process tasks from the regular tasks. Use the Usage field
value to determine the difference between process tasks and standard tasks. If the Usage value is
anything other than Other, then it is a process task.
1. Choose Filters > Filters in the Task view of a StarTeam perspective. This displays the Filters dialog
box.
2. Click New and give the new filter a name.
Alternative: Copy an existing filter by selecting it, clicking Save As, and giving it a new name. Then
select the copied filter and continue with the next steps.
3. Click Fields.
4. Move the Usage field from the Available Fields list to the Show Fields in this Order list.
5. Click OK.
6. Click Query. This opens the Edit Query dialog box. The Queries dialog box opens.
7. Click New. The Edit Query dialog box opens
8. Type a Name for the new query.
9. Choose the following in the Condition Node section:
•
•
•

Field = Usage
Operator = Not Equal
Value = Other

10.Click Add to add the condition to the query.
11.Click Save to save the query. Returns to the Queries dialog box. Your new query is now highlighted in
the list of queries.
12.Click Select in the Queries dialog box use this query in your new filter. You are returned to the Filters
dialog box, and your new filter should be highlighted.
13.Click Save As to save the filter.
Note: Conversely, you can create a filter that displays only the standard tasks. In the query, use the
condition Usage Equals Other.
Tip: If you use tasks on a regular basis and not just for process tasks, add Usage Equals Other to
existing queries so you never see process tasks when working on tasks that have been manually
created, or imported from Microsoft Project using Borland's Microsoft Project integration.

File Compare/Merge
File Compare/Merge is a graphical file and folder comparison and merge tool delivered with StarTeam. It
enables you to compare the contents of two files or folders, and manually or automatically merge the
contents. The File Compare/Merge panes highlight differences using a configurable color scheme, and
dynamic action buttons display in the highlighted areas to simplify the merging process.
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There are three versions of File Compare/Merge, and how you start File Compare/Merge determines which
features are available. The ability to edit text files in a File Compare/Merge pane depends on which version
of File Compare/ Merge you are using, and what type of files you are comparing and merging.
Tip: In File Preferences, you can specify File Compare/Merge as the alternate compare/merge utility
to use instead of the default tool.
The following list describes editing capabilities in each version of File Compare/Merge.
File Compare/Merge Version

Capability

Main File Compare/Merge

Edit a local file, a merged base file, and a copy of a
repository revision.

Embedded File Compare/Merge

No editing is possible.

Standalone File Compare Merge

Edit all files being compared and merged.

Note: You cannot edit the actual historical revision of a file in the StarTeam repository.

Main File Compare/Merge
The main File Compare/Merge window is displayed using menu commands in the client, and it opens in a
separate window enabling you to do the following:
•

•
•
•

Compare the contents of a local file with the tip revision stored in the StarTeam repository. You can also
edit the contents of the local file from within the File Compare/Merge window, and save the changes for
check-in.
Compare two revisions of a file listed on the History view tab in the StarTeam Eclipse Client application
window. Editing the content of historical revisions is not allowed.
Merge the contents of a local file with the tip revision in the StarTeam repository. The merge results are
stored locally, and the file status is changed to Modified in StarTeam so you can check in the file.
Edit the temporary local copy of a repository revision and save it as a file with a different name.

The main File Compare/Merge gives you the option of viewing a third pane for displaying the merge
results. You can edit the contents in the third pane and save your merged results.
You can start File Compare/Merge using context menus on selected files in the StarTeam Eclipse Client, or
by checking in an older version of a file which causes a merge situation.

Embedded File Compare/Merge
The embedded File Compare/Merge gives you a quick way to do a comparison of text in two files or
versions of the same file, as well as compare properties of non-file items such as change requests. If you
are comparing two text files, it performs a dynamic comparison of two selected files, or the selected
repository file with your local working copy. It displays the text contents of both files in an embedded pair of
panes at the bottom of the StarTeam window. These embedded panes only compare the contents of two
text files, and do not permit editing or merging.
If you are comparing the properties of two non-file items, only the property values of each selected item
display in the embedded panes.
When the embedded File Compare/Merge is activated, it immediately compares the files or properties
when you do one of the following:
•
•

Select a file or other item in the upper pane, or the History view. The comparison is between the local
working copy of the item and the selected item revision in StarTeam.
Select two items in the History view. The comparison is between the two historical revisions in
StarTeam.
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Standalone File Compare/Merge
The standalone File Compare/Merge is started outside of the StarTeam Eclipse Client from the Windows
Start menu. This File Compare/Merge compares files, folders, and images, and it can merge the contents
of two text files or two folders. Unlike the main File Compare/Merge, the standalone version does not
compare any local files with files that are in the StarTeam repository. It compares and merges two or three
files, folders, or images that are on your local computer or network. You can edit text file contents directly
in the File Compare/Merge panes, and you can move lines or blocks of text between the panes. You can
also move folders between the panes during a folder comparison or merge.

Specifying FCM as Alternate Compare/Merge Tool
When StarTeam Eclipse Client is installed, the Eclipse compare/merge tool is selected as the default
comparison/merge utility. If you want to use File Compare/Merge as your alternate compare/merge tool
instead, you must configure those settings in Preferences.
Note: Refer to the StarTeam Eclipse Client Release Notes for information on installing the File
Compare/Merge application.
1. Choose Window > Preferences from the main menu.
2. In the Preferences dialog box, expand Team > StarTeam > File.
3. In the File panel, select Use StarTeam compare/merge.
4. Select the applicable check box for one or both application types you want to use: Merge utility and/or
Comparison utility.
5. Type or browse to the path for the executable file for each selected File Compare/Merge application.
6. In Options, type any options you want to use for the selected applications
7. Click OK.

References
You can base a folder or item in one application location on another folder or item stored in a different
location within the same server configuration. References indicate the relationships between an original
folder or item and the others based on it. References can be used to decide whether the changes you have
made to a folder or item in one location need to be applied elsewhere.
The Reference view shows the relationships between the selected item and other folders or items with
which it is associated. A folder or item may be associated with more than one project, view, or parent folder
in the same server configuration because of sharing or because a child view has been created. Each
instance of the original folder or item has a reference. Item references (including folders) can be viewed in
the Reference view. You can also view folder references from the Server Explorer by right clicking the
folder and choosing Open In > Reference Viewor from the Team > Open In > Reference View in the
Package and Navigator Explorers.

Understanding References
StarTeam creates at least one reference to a folder or item whenever:
•
•

•
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You create or add a folder or item to StarTeam.
A branching child view is created that will contain that folder or item. As a branching child view is
created from its parent, a subset of the folders or items in the parent becomes part of the child view.
StarTeam automatically shares the folders and items in that subset into the child view.
You manually share a folder or item from one location to another.
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As you add, share, or move a folder or item, more than one reference to it may occur if the view is a child
view that branches and floats, or if the view has child views that branch and float.

Actions Causing StarTeam to Create References
For example, suppose you want to move a file from one folder to another in the same view. Suppose that
the view has two child views, both of which contain the file. That means that there are at least three
references to this file, one in each of three views. Now, you move the file to another folder in the same
view. The reference in the current view is moved to represent the new location of the file. Depending on the
properties of the two child views, a new reference may be created for the file in each of the child views.
The references in those child views to the file in its original location still exist, because the application does
not assume that you want to change those references just because you have moved the file in the current
view. You may end up with five references to this file that formerly had three references.
Note: Most administrators avoid branching, floating views if users are likely to perform many
operations that result in additional references. For example, moving and sharing can result in multiple
unwanted references to the same folders or items, which can cause confusion.
The following table explains what references creates in the current view, the recipient view, the parent of
the recipient view, and the children of the recipient view. This is often recursive. For example, if a reference
is created in the parent view, new references might be created in the other children of that view or in the
parent of that view, and so on, depending on what views are floating.
When a folder or item is... ...is a reference added to
the view of the recipient?

...is a reference added to
the parent view of the
recipient view?

Part of a newly-created
view

Yes, unless the new view is
a reference view. In this
case, a new view is not
really being created,
because a reference view is
just a new way of looking at
an existing view.) There is
one reference for the folder
or item in the newly-created
view.

No, because the parent
No, because the newlyview is the source of the
created view has no child
folder or item, so the
views.
reference in the parent view
already exists.

Added to the current view

Yes, there is one reference
for the new folder or item in
the current view.

Yes, if the current view is a
branch none, floating child
of the parent view.
Otherwise, no.

...is a reference added to
the child views of the
recipient view?

Yes, if the child view is a
branching (either branch
none or branch all), floating
child of the current view.
Otherwise, no.

Shared within the current
view

Yes, a new reference is
created for the shared
folder or item in the new
location in the current view.

Yes, if the current view is a
branch none, floating child
of the parent view.
Otherwise, no.

Yes, if the child view is a
branching (either branch
none or branch all), floating
child of the current view.
Otherwise, no.

Moved within the current
view

No, the original reference is Yes, if the current view is a
updated to reflect the move. branch none, floating child
of the parent view.
Otherwise, no.

Yes, if the child view is a
branching (either branch
none or branch all), floating
child of the current view.
Otherwise, no.
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References View Examples
Consider the following example of four references displaying in the References view:
•
•
•
•

Help Files::Help Files::Help Files::starteam,1.0
Help Files::Help Files\Freeze Check::Help Files\release 4\starteam, 1.0
Help Files::Help Files\Freeze Check\New View::\Help Files\release
4\starteam, 1.0
Help Files::Help files\variant 2::Help Files\release 4\starteam, 1.0.1.2

In the above example, the selected folder has four references.
The Current icon indicates which reference represents the currently selected folder or item. Otherwise,
the Reference view contains the same information regardless of the view in which you selected the folder.
Each reference shows the following, separated by double colons (::):
•
•

•
•
•

The project name (for example, Help Files).
The path from the root view to the view containing the folder (or item). For example, Help Files
\Freeze Check\New View, where Help Files is the name of the root view, Freeze Check is a
child of the root view, and New View is a child of the Freeze Check view.
The path to the folder within the view. In the case of an item, the path is to the parent folder of the item.
In the case of an item, the name or number associated with that item. This can be the filename, change
request number, the requirement number, the task number, or topic number.
The tip revision number for the folder (or item) in that view. (This information is separated from the rest
of the reference by a comma, rather than the double colon.) For example, the folder in the example is
revision 1.0 in all views except for the variant 2 view (see the last leaf in the example tree). In the
variant 2 view, the revision number for the folder is 1.0.1.2 which indicates that the folder has
been branched from the 1.0 revision in its parent view and has had three revisions in the variant 2
view. Those revisions are 1.0.1.0, 1.0.1.1, and 1.0.1.2.

In this example, the name of the project, the name of the root view, and the root folder in the root view all
have the same name.
The references in bold indicate which revisions of the currently selected folder or item are its descendants.
In other words, the currently selected folder or item is part of the revision history for the references that are
in bold.
Consider the following example from the Reference view shows the references for a file (AUDITSCC.DOC).
The reference for the currently selected file indicates that revision of the file is 1.6. As indicated by the
bolding of its reference, revision 1.8 is the only descendant of revision 1.6. If a defect is found in revision
1.6 of AUDITSCC.DOC, the bolding helps you determine which descendants of 1.6 may also need the
corrected lines. In this case, you may only new to update 1.8.
•
•
•
•
•

Help Files::Help Files::Help Files\starteamp::AUDITSCC.DOC, 1.8
Help Files::Help Files\Freeze Check::Help Files\starteamp::AUDITSCC.DOC, 1.1
Help Files::Help Files\Freeze Check::New View2::starteamp::AUDITSCC.DOC,
1.1.1.0
Help Files::Help Files\varc::Help Files\starteamp::AUDITSCC.DOC, 1.6
Help Files::Help Files\variant 2::starteamp::AUDITSCC.DOC, 1.2

Initial References
When you add a folder or item to the application, StarTeam creates a reference. Consider the following
example of a folder hierarchy for a newly-created project. In this example, it is the folder hierarchy for the
root view of that project.
•
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•
•
•

Marketing Documents
Online Help
Source Code

Before you make any changes to the folder properties of the Source Code folder, the References view
would contain exactly one reference to it. For example, Big Product::Big Product::Big Product
\Source Code, 1.0.
As you make changes to the folder properties of the Source Code folder, the revision number might
change from 1.0 to 1.1 and later 1.2. However, there will still be only one reference to this folder in the
Reference view.
If a reference view is created (to be used, for example, by a group of reviewers), the view hierarchy for the
Big Product project would contain two views, but the Source Code folder would continue to have just one
reference. A Reference view contains a subset of the folders in its parent view, but those folders are the
same folders as those in the parent view. They cannot branch. For example, after creating a reference
view for reviewers, the Reference view would contain the following information:
Big Product::Big Product::Big Product\Source Code, 1.2.
Once you share the folder manually or share it automatically when you create a branching child view,
additional references then display in the Reference view.
Tip: Do not confuse reference views with folder and item references. A reference view looks like a
new view, but it is really a subset of an existing view. A folder or item reference is like a reference
count. It indicates how many copies of the object exist or can exist if the object branches in each of its
new locations. The creation of a reference view does not result in the creation of any folder or item
references.

References Created by Branching Views
When you create a branching view in StarTeam, each folder or item automatically shared from the parent
view to the child view acquires an additional reference. In the tree view, the new reference is a child of the
original reference.
Folder References Created by Branching Views
Suppose that when the 1.0 version of Big Product ships, the team leader creates a branching view, based
on the ship date for the 1.0 version, to be used for service packs, while new development on version 2.0
still continues in the project root view. These actions would result in the following tree view:
•
•
•

Big Product
Big Product 1.0 Plus Service Packs
Reference view for reviewers

At this point, two references display in the Folder References dialog box. When you are in the root view,
Big Product, the Folder References dialog box for the Source Code folder contains the following
information:
•
•

Big Product::Big Product::Big Product\Source Code, 1.2
Big Product::Big Product\Big Product 1.0 Plus Service Packs::Big Product
\Source Code, 1.2

When you are in the child view, Big Product 1.0 Plus Service Packs, the Folder References dialog box for
the Source Code folder contains the following information:
•
•

Big Product::Big Product::Big Product\Source Code, 1.2
Big Product::Big Product\Big Product 1.0 Plus Service Packs::Big Product
\Source Code, 1.2

The Current (You Are Here) icon indicates which reference represents the currently selected folder or
item. Otherwise, this dialog contains the same information regardless of the view in which you selected the
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folder. StarTeam indents the reference for a child view beneath the reference for its parent. The references
in bold indicate which revisions of the folder or item are descendants of the folder or item with the Current
(You Are Here) icon. In other words, the current folder or item is part of the history for the revisions that
are in bold.
In the previous two examples, both references were represented in bold text. In the next example, this is
not the case. This is because the properties of the Source Code folders in both the parent view and the
child view have changed. The folder for the parent has revision 1.3, and the folder for the child has revision
1.2.1.0. Both folder histories have gone in different directions.
•
•

Big Product::Big Product::Big Product\Source Code, 1.3
Big Product::BigProduct\Big Product 1.0 Plus Service Packs::Big Product
\Source Code, 1.2.1.0

The current folder is a descendant of itself, so it is always represented in bold text. However, it has evolved
from the parent folder, so it is no longer in the history of the current folder. Accordingly, the Folder
References dialog box for the parent folder would present the following information:
•
•

Big Product::Big Product::Big Product\Source Code, 1.3
Big Product::BigProduct\Big Product 1.0 Plus Service Packs::Big Product
\Source Code, 1.2.1.0

File References Created by Branching Views
When you look at the history of a folder or item, you see its ancestors, not its descendants. However, if you
change the tip revision in one location and that revision is an ancestor of the tip revision in another
location, you might also want to apply your change to the tip revision in the other location (the object of the
first descendant). The way to tell if a revision has descendants is to look at its references. Consider the
following example showing the references for a file (AUDITSCC.DOC):
•
•
•
•
•

Help Files::Help Files::Help Files\starteamp::AUDITSCC.DOC, 1.8
Help Files::Help Files\Freeze Check::Help Files\starteamp::AUDITSCC.DOC, 1.1
Help Files::Help Files\Freeze Check::New View2::starteamp::AUDITSCC.DOC,
1.1.1.0
Help Files::Help Files\varc::Help Files\starteamp::AUDITSCC.DOC, 1.6
Help Files::Help Files\variant 2::starteamp::AUDITSCC.DOC, 1.2

As the bold text indicates, if the current revision is 1.6, then 1.8 is its only descendant. This also means
that you would find revision 1.6 in the history for 1.8.
If a defect is found in revision 1.6 of AUDITSCC.DOC, the bold text helps you determine the descendants of
1.6 that may also need the corrected lines. In this case, 1.8 may need to be updated. The other references
are for revisions of the file that:
•
•

Have already diverged (branched) and may be quite different than the current file.
Are ancestors of the current file and less likely to need a change. For example, they may be in views
that are read-only or no longer in use. Whatever the reason for the gap, the ancestors might require far
more work than the changes you are about to check in.

You should check for descendants before (and perhaps after) you create a new revision of a folder or item.
Before the change becomes a new revision in the application, you can see the descendants. Afterwards,
you may see what other references have the same revision number as the newly-changed folder or item. If
they, too, have the new revision number, then they, too, already have the new change. For example, the
file may be floating in other views.

References Created by Adding Items to Views
The addition of a new folder or item to a parent or child view can result in one or two references, depending
on the relationship between the two views.
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If the child view is a branching, floating view, StarTeam creates a reference in each view when a new
folder or item is added to the parent.
If the child view is a branching, floating view created using the Branch None option, StarTeam creates a
reference in each view when a new folder or item is added to the child.
Floating Down in the Hierarchy
When a view has a branching child view (whether created with the Branch None or Branch All option)
and the child view is floating, any folder or item added to the parent view becomes visible in both views.
The history of the folder or item indicates the view in which the object was created, and the reference
hierarchy displays the reference that identifies the parent view as the parent reference.
For example, if a file you add a file to the parent view, its history in either view shows the name of the
parent view until the file branches in the child view.
The following table shows the history in the parent view for a file that was added to the parent view and
floated downwards.
Tip: You can review historical item information using the History view in the client.
View

Revision

Branch Revision

Big Product

2

1.1

Big Product

1

1.0

The following table shows the history in the child view for a file that was added to the parent view and
floated downwards. The history of the file displays the name of the view from which the file was originally
added to the application until the file branches. Then it displays the name of the view in which the file
branched.
View

Revision

Branch Revision

branch none floating

3

1.1.1.0

Big Product

2

1.1

Big Product

1

1.0

If you were to display the References view for this file (marketshares.doc) after it has branched in the child
view, you would see the following information:
•
•

Big Product::Big Product::Big Product\Marketing Documents::marketshares.doc,
1.1
Big Product::Big Product\branch none floating::Big Product\Marketing
Documents::marketshares.doc, 1.1.1.0

Notice that the history clearly shows the parent view as Big Product before the file branches. The history
and references for folders and items added to the parent view are similar to those for folders and items that
were in the parent view at the time the child view was created.
Note: The name of the views in these examples makes the information easier to understand. You
would probably never name a view parent or any other of the names shown these examples.
Floating Up in the Hierarchy
When a view has a branching child view (created with the Branch None option) and the child view is
floating, any folder or item added to the child view becomes visible in both views. This is not true of
branching, floating child views that were created using the Branch All option.
The history of the folder or item indicates the view in which the object was created, but the reference
hierarchy always displays the reference that identifies the parent view as the parent reference.
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The following table shows the history in the parent view for a file that was added to a child view and floated
upwards. Notice that, even though this is the history in the parent view, the history displays the name of the
view from which the file was originally added to the application.
View

Revision

Branch Revision

branch none floating

3

1.2

branch none floating

2

1.1

branch none floating

1

1.0

The following table shows the history in the child view for a file that was added to the child view and floated
upwards. The history of the file displays the name of the view from which the file was originally added to
the application until the file branches. Then it displays the name of the view in which the file branched. In
this case, those two views just happen to be the same view.
View

Revision

Branch Revision

branch none floating

3

1.1.1.0

branch none floating

2

1.1

branch none floating

1

1.0

When you view the reference hierarchy for a file that floats upwards, you cannot tell that the file was added
to the application from the branching child view, and you must investigate the history (using the History
view) of the file to determine where the file originated. For example, the Reference view would contain the
following reference hierarchy for the slant.doc file that floated upwards:
•
•

Big Product::Big Product::Big Product\Source Code\Timeout::slant.doc, 1.2
Big Product::Big Product\branch none floating::Big Product\Source Code
\Timeout::slant.doc, 1.1.1.0

Floating Up and Down in the Hierarchy
If the view hierarchy is deep (the root view has grandchildren, great-grandchildren, and so on), the use of
branching, floating views can cause a great deal of confusion. For example, suppose you add a file to a
grandchild of the root view. Further, suppose that this grandchild view was created using the Branch None
option and that its parent (a child of the root view) was created using the Branch None option. The file you
add can float up to the parent and grandparent of the current view from which it will, in turn, float back
down to the current view. This results in:
•
•
•

One reference to the file in the current view
One reference to the file in the parent of the current view (the result of floating up from the current view)
One reference to the file in the root view (the result of floating up from the parent of the current view)

More references are created if the current view has floating children, grandchildren, and so on. Still more
are created if the root view or parent view have other floating children besides the ones mentioned above.

References Created by Manually Sharing Objects
As you share a folder or item from one location to another, whether in the same view or a different one, an
additional reference is created for that object in the new location. The reference for the new folder or item
becomes a child of the reference from the folder or item that was shared.
Reference Hierarchy Example for a Manually Shared File
The following example shows two references for a file named timeout.cpp. The file was manually
shared from a folder named Source Code to a folder named Timeout in the same view. Notice that the
second reference is based on the first, but created as a by-product of creating a branching view.
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•
•

Big Product::Big Product::Big Product\Source Code::timeout.cpp, 1.0
Big Product::Big Product::Big Product\Source Code::Timeout::timeout.cpp,
1.0

The application does not differentiate between references based on what caused them to be created.
However, you can tell from the tree view that the first reference is the source of the second reference,
because the second reference is indented under the first. You can also tell, because they are in the same
view, that a manual share or move occurred. (The second reference would be in a different view if it was
created automatically when a child view was created.
A shared folder or item can branch, but may never do so. Regardless, some subset of its history is part of
the history of the original folder or item.
Floating Up and Down in the Hierarchy
If the view hierarchy is deep, the use of branching, floating views can cause a great deal of confusion.
Suppose all the views except the root view branch and float. At its new location, depending on how views
were created, the folder or item you share can float:
•
•
•

Up the view hierarchy from the recipient view to the root view
Down to all the recipient children of the view, grandchildren, and so on
From the recipient view's parents, grandparents, and so on, to all of their other children

This can result in a reference to the folder or item in the new location in every view in the project's view
hierarchy. Many of those views may have already had a reference to the folder or item in its old location.
The following example shows all the references created by sharing a file named shared within child
view.doc from one location in the branch none floating view to another location in that same view. The
first three references are the references that existed prior to the sharing operation. The fourth reference is
the new reference in the root folder. It is shown as a child of the first location in the branch none floating
view because it floated up from that view. The fifth and sixth references resulted from references that
floated down to the branch none floating child view of that view.
•
•
•
•
•
•

Big Product::Big Product::Big Product\Online Help::shared within child
view.doc, 1.0
Big Product::Big Product\branch none floating::Big Product\Online
Help::shared within child view.doc, 1.0
Big Product::Big Product\branch none floating\branch none floating 2::Big
Product\Online Help::shared within child view.doc, 1.0
Big Product::Big Product::Big Product\Source Code:;shared within child
view.doc, 1.0
Big Product::Big Product\branch none floating::Big Product\Source
Code::shared within child view.doc, 1.0
Big Product::Big Product\branch none floating\branch none floating 2::Big
Product\Source Code::shared within child view, 1.0

The next example shows that the file named shareall.doc existed only in the branch all floating view
before it was shared to another view. The reference to the root folder starts the references that occurred as
a result of the share operation. However, the recipient view could have been any of the other views,
because the file would float up to the root and back down. On the way down, a second reference was
created in the branch all floating view.
•
•
•
•

Big Product::Big Product::branch all floating::Big Product\Marketing
Documents::shareall.doc, 1.0
Big Product::Big Product::Big Product::shareall.doc, 1.0
Big Product::Big Product\branch all floating::Big Product::shareall.doc, 1.0
Big Product::Big Product\branch none floating::Big Product::shareall.doc,
1.0
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•
•

Big Product::Big Product\branch none floating\branch none floating2::Big
Product::shareall.doc, 1.0
Big Product::Big Product\branch none floating\branch none floating 2\branch
none floating3::Big Product::shareall.doc, 1.0

References Created by Moving Objects
When you move a folder or item from one location to another within the same view, StarTeam deletes the
object at the old location and reinstates it at the new location. However, there can be side effects in the
parents and children of the view if any of the views are floating. This is because the copy at the old location
is not deleted except in the current view. The parent and child views may end up with two references (one
to the old location and one to the new location) instead of one to the new location.
Reference Hierarchy Examples
Suppose you move the file named timeout.doc from the Marketing Documentation
folder to the Timeout folder in a given view that has no branching child views.
The following two examples show the references for this file before and after the move.
The number of references is the same; only the path to the file has changed. The file
has been deleted from its original location and added to its new location.
Before the move: Big Product::Big Product::Big Product\Marketing
Documents::timeout.doc, 1.0
After the move:
Big Product::Big Product::Big Product\Source Code
\Timeout::timeout.doc, 1.0
However, suppose this view has a child view that was created without cutting off the
connection to the parent. In other words, the child view is branched and floating. In the
child view, if the moved file has not yet branched, it is not deleted from its old location
because you might really still want it here. However, it is added to the new location
because it is perceived as a change to the parent that should be reflected in the child.
Notice that the file has only one reference in the parent but that it has two in the child
view.
•
•
•

Big Product::Big Product::Big Product\Source Code
\Timeout::timeout.doc, 1.0
Big Product::Big Product\branched floating::Big Product
\Marketing Documents::timeout.doc, 1.0
Big Product::Big Product\branched floating::Big Product
\Source Code\Timeout::timeout.doc, 1.0

Some StarTeam users sort items using folders. For example, they decide to create a
series of folders in a view to classify change requests by criteria such as:
•
•

Will definitely make the next release
Are under consideration for the next release (time permitting)

These change requests are usually moved from the root folder to one of the sorting
folders, or later rearranged and moved from one sorting folder to another. This is a
convenience in the current view, but it can cause multiple references in a parent or child
view. If the view hierarchy is deep, the current view's parents, grandparents, children,
grandchildren, and so on may be affected. Users who use such systems usually create
child views that do not float.
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Floating Up and Down in the View Hierarchy
If the view hierarchy is deep, the use of branching, floating views can cause a great deal of confusion.
Suppose all the views except the root view branch and float. At its new location, the folder or item you
move can float:
•
•
•

Up the view hierarchy from the recipient view to the root view
Down to all the children, grandchildren, and so on of the recipient view
From the parents, grandparents, and so on of the recipient view to all of their other children

A move operation results in one fewer reference to the moved folder or item in the view from which it was
moved, and one more reference to it in the recipient view.
The following example shows that a file named move within parent view was moved from one
location in the root view to another location in that same view. Originally, the file was referenced in five
views. The move caused a new reference in all the child views of the root folder, giving each of them two
references to the moved file (one reference in its original location and one in its new location).
•
•
•
•
•
•
•
•
•

Big Product::Big Product::Big Product\Source Code::moved within parent
view.doc, 1.0
Big Product::Big Product\branch all floating::Big Product::moved within
parent view.doc, 1.0
Big Product::Big Product\branch none floating::Big Product::moved within
parent view.doc, 1.0
Big Product::Big Product\branch none floating\branch none floating2::Big
Product::moved within parent view.doc, 1.0
Big Product::Big Product\branch none floating\branch none floating2\branch
none floating3::Big Product::moved within parent view.doc, 1.0
Big Product::Big Product\branch all floating::Big Product\Source Code::moved
within parent view.doc, 1.0
Big Product::Big Product\branch none floating::Big Product\Source
Code::moved within parent view.doc, 1.0
Big Product::Big Product\branch none floating\branch none floating2::Big
Product\Source Code::moved within parent view.doc, 1.0
Big Product::Big Product\branch none floating\branch none floating2\branch
none floating3::Big Product\Source Code::moved within parent view.doc, 1.0

Folders
This topic provides an overview of planning a folder tree and provides some tips for working with new and
existing folders. The project or server administrator usually creates projects and project views. If you are a
typical user, you routinely open a particular project view and manage your folders and their contents, such
as files and change requests. Managing application folders is very similar to managing a project. You can
create folders, delete folders, and modify their properties if you have the correct access rights.

Folder Tree Hierarchy
When you create projects, you typically select locations on your workstations as the working folders for
those projects. The working folder designated for a project also becomes the working folder for the project
root view and for the root folder in the folder tree of that view.
StarTeam treats folders as both containers and items. You can group items within a project view by placing
them into folders. For example, a folder named Source Code can contain source code files and requested
changes to those files. You can create folders automatically when you create a project, or add folders after
you create the project. Project or server administrators usually create projects, but anyone can create
projects if they have the correct access rights. See your server administrator if you have questions
regarding the access rights assigned to you.
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When you create a project, StarTeam automatically creates the parent or root folder for that project at the
same time. It is actually the root folder of the project root (or initial) view. The project, view, and this root
folder initially have the same name, although those names can be changed.
Usually, the user who creates a project sets up a hierarchy (tree) of folders on a workstation before
creating the project. The user designates the root folder of that tree as the project's working folder. Then
the application can automatically create an application folder for each of the child folders in the tree. The
child folder becomes the application folder's working folder.
If child application folders are created at the time the project is created, then:
•
•
•

The application folder's working folders were part of an existing tree on the project creator's workstation.
Their names are the same as the names of their working folders, but they can be changed later.
Their working folders remain hierarchically connected to the root folder's working folder. That is, if you
change the path to the root folder's working folder, you also change the path to this folder (unless you
manually set an absolute path for these working folders). In other words, the application stores a
relative path to each child folder.

One of the most important properties to notice about your folder is its working folder. You will need to know
where on your workstation the application will copy file revisions that you check out so that you locate
those revisions as needed for modifications. A number of other operations can be performed on folders,
such as moving a folder or changing its branching behavior.
A working folder is a property of the folder and represents the actual location on your workstation where
StarTeam saves files that you check-out. Despite the fact that these are both called folders, the working
folder and the folder are not identical. Their differentiating characteristics include:
•
•

•

The path to the working folder can be totally different from the path within the application to the
application folder.
An application folder is an object controlled from within the application. The data associated with this
folder is stored in the database that stores all the project data. The checked-in revisions of the files
associated with this folder are stored in the vault.
A working folder is an object controlled by your operating system. It stores files that are checked out
from the application.

A project, its root view, and the root folder of the root view all have the same working folder. For additional
views, each view and its root folder have the same working folder.
The working folder for the view/root folder always has an absolute path (starting with the drive letter and
specifically naming the folders at subsequent levels until you reach the working folder itself).
If you look at the properties for the root folder, you will see that the working folder is the same. However, it
is displayed in the Complete Working Folder Path display box instead of the Default text box. Since you
can only change the working folder at the view level, all of the text boxes for the root folder's working folder
are always disabled.
For the child folders that were created at the same time as the project, the application stores the path to
each working folder as a relative path.

Folders in Views
You can add new folders and Not-in-View (NIV) folders to views in StarTeam. A NIV folder is a folder on
your local disk that does not map to a folder in the StarTeam repository. A NIV folder is displayed as a
white folder with a black, dotted border. NIV folders (as with NIV files) do not necessarily need to be added
to a view, but you may choose to do so if you just created it and want it to be part of the StarTeam view.
However, if the folder is NIV because someone else deleted it from the view, you may need to delete it
from your working folder.
If you add a new folder to a view, its working folder can be any of the following:
•

122

Any folder on your workstation specified by you.

| Borland StarTeam Eclipse Client

•
•

A non-existing working folder specified by you and created by the application on your workstation. If the
existing folder has child folders, one or more of them can also be added to the view.
A child of the parent application folder's working folder. If you do not specify a working folder, the
application appends the new folder's name to its parent's complete working folder path.
Note: If the parent folder's working folder path length exceeds the operating system's maximum
working folder path length of 254 characters, including (\) backslashes, the application does not allow
you to create the new working folder. Also, you cannot add a folder to a view if the parent folder is
read-only. The newly added folder assumes the parent folder's behavior, with a few exceptions. For
example, the child folder might have the Branch On Change check box disabled because it makes
no sense for this folder to branch.

New Folders
You can easily add folders to a project view. When a new folder is added:
•

•
•

The working folder for the new application folder does not have to belong to the same tree as the other
application folder's working folders. If you do not specify a working folder, the new folder's working
folder is relative, based on its parent's working folder path.
Its name can be different from the name of its working folder.
If the new working folder has child folders, a folder can be created for each of the children. Essentially,
the newly added folder becomes the root of a new branch of folders. The application folders created for
the child folders take the names of their working folder's at least initially. The working folders retain their
relationship to the working folder that is the root of their tree. If you change the path to the newly added
folder's working folder, you also change the path to these working folders unless you manually set an
absolute path for these working folders.

StarTeam indicates folders on disk that do not map to a StarTeam folder with a Not-In-View icon . This
indicates that you do not have the folder in the project view.

Existing Folders
You can add more folders to a view by moving them or sharing them from other views on the same server
configuration. When a folder is moved or shared, it either keeps its absolute path or its relative path and is
applied to its new parent folder. When a moved folder's path is relative, it usually ends up with a different
working folder than it previously had. When a shared folder's path is relative, the shared folder has a
different working folder in each location.
Note: The application does not allow you to create a working folder if a shared or moved folder's new
working folder path exceeds the operating system's maximum working folder path length of 254
characters including (\) backslashes.
Both the current view and the view from which the folders are moved or shared must use the same server
configuration.

Folders and Paths
In StarTeam, three types of folders play important, yet dissimilar, roles.
Original workstation folder

Users set up this folder and its contents on a workstation,
then use the New Project Wizard to create a new
StarTeam project. This folder, which may contain files
and other folders, becomes the root folder of the new
project, i.e., it becomes the root folder of the project's
initial or root view. The folder takes the name of the
project, regardless of the name of the workstation folder
on the operating system, and has an absolute path
(rather than a relative one), which starts with the drive
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letter and lists the appropriate directories until it reaches
the working folder itself.
StarTeam creates the project, the root view of the project,
and root folder at the same time and they all have the
same working folder. The project, view, and root folder
initially have the same name, although the name can be
changed later. If additional views of the project are
created, each view and its root folder have the same
working folder. The hierarchy of StarTeam folders in the
current view appears as a folder tree in the Server
Explorer.
StarTeam folder

These folders are used in StarTeam to group items in a
project view. For example, a folder named Source Code
can group source code files, requested changes to those
files, and other related items. These folders can be
created automatically at the same time as a project or
added later by administrators or team members with the
appropriate privileges. The hierarchy of StarTeam folders
in the current view appears as a folder tree in the Server
Explorer. When the StarTeam (application) folder is
created automatically at the same time as a StarTeam
project, it takes the name of the working folder and has a
relative path.

Working folder on the workstation

A working folder is actually a property of a StarTeam
folder, but is quite different, as it is an object controlled by
the operating system. It stores files that are copied or
checked out from StarTeam or that will be added to
StarTeam . A StarTeam folder is an object controlled from
within StarTeam. Data about it is stored in the database
that holds all project data.

You can add to a StarTeam project at any time after it has been created. These folders can be moved from
or shared with another StarTeam view or added from a workstation.
Understanding Working Folders
Understanding the relationship between application folders and their working folders is important because
the working folder stores the files that you check in and check out.
Each folder has a default working folder from which you modify working files. For team members that use
the same folders, the working folder structure on a workstation is often the same as those on another
workstation.
When you check out a file, the application copies the requested file revision to the appropriate working
folder. If the working folder does not already exist on your workstation, the application automatically
creates it for you as you check out files that go in that folder.
The application expects you to add and check in new file revisions from those working folders. If the
working folder does not exist on your workstation, you can create it manually or automatically using the
Create Working Folders command. After the working folder exists, you can add files to it.
The exact location of a working folder is displayed as one of the application folder's properties.
Alternate Working Folders
The view's working folder may not be the optimal choice for all users. You, or any other user with the
access rights to do so, can select a more useful location for the view's working folder on your own
workstation by designating an alternate working folder. For example, you might want to use a shorter path
or a different drive letter. Remember that a working folder must point to a physically discrete location, such

124

| Borland StarTeam Eclipse Client

as a drive on your workstation or a personal directory on a shared file server. Borland does not recommend
putting your settings on a mapped network drive.
The alternate working folder path for the view is specific to the workstation and user. For example, if you
log onto the project as another user or use another workstation, your alternate working folder setting is not
known.
When you designate an alternate working folder for the view, the path to the working folder for each child
folder in the view may be similarly modified for your workstation.
For every folder in the tree whose working folder is relative to the path of the view's working folder (as
opposed to having an absolute path or an alternate working folder path of its own), your alternate path for
the view's working folder becomes part of the paths to its child folders working folders.
Folder Paths
StarTeam often stores working folder paths from development environment applications as relative paths.
For example, ..\sc may be the working folder for a projects Source Code folder. If you move a folder to
another location in the StarTeam tree view, its working folder may end up in an unexpected location. This
result occurs because the application applies the relative path to the working folder path for the new parent
folder. Therefore, if you move a folder, you may want to specify a working folder path that is not relative, to
avoid accidentally changing the working folder path on users workstations.
Server Explorer
The StarTeam Eclipse Client includes a hierarchical view of the projects, views, and folders of a server
configuration. The hierarchy of StarTeam folders in the current view appears as a folder tree in the Server
Explorer. When you expand the tree-view of a server configuration in the Server Explorer, the nodes
provide context menus containing many of the same menu commands that you would use when working
with files, change requests, requirements, and so on.
Folder states in the Server Explorer are represented by the following folder icons:
Regular StarTeam folder.
Invisible Folder: Indicates a folder where the Visible property has been
unchecked in the Folder Properties dialog box.
Not-in-View Folder: Indicates a folder on your local disk that does not map to a
StarTeam folder.
Missing Working Folder: Indicates that local working folders do not exist.
Folder uses an alternate working folder path than the default one set up by the
project.

Default and Alternate Working Folders
It is critical that before you change the Default Working Folder, you lock the server and everybody should
be logged off just as when you change custom fields or anything else that effects all users.
When a view is created, a default location is specified for its working folder. If you change the Default
Working Folder, not only the path to the working folder but the path to each child folder in the view may be
similarly modified -- not just for you, but for everyone working with that view. Therefore, before making
such changes, it is important to understand the relationship of the working folder to the StarTeam view.
•

•

The Default Working Folder path is used by everyone sharing that view, unless they have specified an
Alternate Working Folder path. Only change the Default Working Folder if you want to change the path
for everyone who shares the view.
The Alternate Working Folder path lets you specify a different location for your own working folder than
the Default Working Folder. If you do not want to use the Default Working Folder path, specify an
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Alternate Working Folder path -- do NOT change the Default Working Folder. If you specify an Alternate
Working Folder path, it is used instead of the Default Working Folder path. The Default Working Folder
path must point to a location that is physically discrete for each user, such as a drive on that user's
workstation or a personal directory on a shared file server.
The working folder for the view's root folder has an absolute path (for example C:\New Product). The
path used for the working folder of a child folder depends upon how the child folder was created and what
changes have been made to the path since that time. Generally, the working folder for a child folder is
relative to that of the view (that is, relative to the working folder used for the root folder). For example,
suppose that the path to the view's working folder is C:\New Product and that the root folder has a child
folder named Online Help. In this case, the path to the Online Help working folder would be C:\New
Product\Online Help. When the path to the view's working folder changes, the path to the child's
working folder changes automatically.
If a new child folder is added to the view after it is created, the path to the child's working folder will usually
be relative. However, if its working folder is on a different drive than the working folder for the root, its path
will be absolute.

Folder Properties
This topic presents the folder properties and their descriptions as displayed in the Folder Properties
dialog box. The Folder Properties dialog box contains the following tabbed pages of properties.
Name
The following properties are on the Name page.
Property

Description

Name

Displays the name of the file.

Description

Displays the file description.

Created By

Displays the name of the person who created the file.

(Created) On

Displays the date on which the file was created.

Visible

Indicates whether the file is to be visible in the view or
not.

Working Folder

Displays the path to the default and alternate working
folders.
Default –This path location points to the default working
folder, and applies to everyone accessing the project
repository. Do not change this path unless you are a
project administrator.
Alternate – This path points to an alternate working
folder on your machine. Specifying an alternate working
folder affects only you, not any of the other team
members.

Complete Working Folder Path

Exclude
The following properties are on the Exclude page.
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Displays the complete path to the selected working folder
(default or alternate.)

Property

Description

Files To Be Excluded

Indicates which files or types of files to exclude from
visibility in the folder. The exclude list has no effect on
files that are already part of the project. It only affects
those with Not In View as their status. Exclude lists can
be inherited from parent folders. Exclude options include:
•

•

•

Local Exclude List

Inherit And Use Local Exclude List – Indicates that
files matching the exclude list specifications set for
this folder and those of its parent folder will be
excluded.
Use Local Exclude List – Indicates that files
matching the only specifications set for the exclude
list this folder will be excluded.
No Exclude List – Specifies that all files are included
in the folder.

Displays the exclude specifications to use for excluding
files from this folder. The exclude list is limited to a
maximum of 255 characters. It contains file specifications
(using the standard * and ? wild cards), separated by
commas, spaces, or semicolons. To include a comma,
space, or semicolon as part of the specification, enclose
the specification in double-quotes. For example,

*.exe,*.dll p*z.doc;*.t?t "test *.*"
Inherited Exclude List

Displays the exclude specifications to use from the parent
folder for excluding files from this folder.

History
The History page displays all the revisions of the file. The following properties are on displayed the
History page for each revision.
Property

Description

View

Displays the name of the view to which this file belongs.

Revision

Displays the file revision number.

Author

Displays the name of the person who created the file.

Time

Displays the date and time the revision created.

Comment

Displays a comment explaining why the revision was
created.

Branch Revision

Displays the branch number of the revision.

Link
The following properties are on the Link page which displays all the links to this folder.
Property

Description

Created By

Displays the name of the person who created the link to
the folder.

Created On

Displays the date on which the link was created.
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Property

Description

View

Displays the name of the current view if the link was
created in the current view, or displays the name of view
where the link was created and from which the link is
shared.

Folder

Displays the name of the folder in which the folder or item
in the link resides.

Item Type

Identifies the type of item to which the target end of the
link is attached. This item is listed in the link list.

Item

Identifies the item to which the target end of the link is
attached. It is identified by its folder name, filename,
change request number, task number, topic number, or
requirement number.

Item Details

Describes the item, using a folder description, file
description, change request synopsis, task name, topic
title, or requirement name.

Item Version

Displays the version number of the target end of the link if
that revision is in the current view. When no revision
number is displayed in the column, that end of the link is
floating rather than pinned.

Selection Version

Displays the version number of the source end of the link
if that revision is in the current view. When no revision
number is displayed in the column, that end of the link is
floating rather than pinned.

Comment

Displays a comment about this particular link.

File Status

Displays the status of a file that is linked to the folder.

Locked By

Displays the name of the person who locked the file
linked to the folder.

Folder Path

Shows folder path information only when the linked item
is in the same view. Otherwise, it displays the message,

"Unavailable. Item in another view."

Sample Folder Template
You can use the following sample for customizing the Detail view for the Folder component.
Sample Folder HTML Template
<html>
<head></head>
<body>
<table bgcolor=#aaabbbccc width=100%>
<tr>
<td align=center><b>~~Name~~<b></td>
</tr>
</table>
<table>
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<tr>
<td align=left><b>Status:</b></td>
<td>~~Status~~</td>
</tr>
<tr>
<td align=left><b>Working folder:</b></td>
<td>~~LocalPath~~</td>
</tr>
<tr>
<td align=left><b>Project Folder Path:</b></td>
<td>~~Folder Path~~</td>
</tr>
</table>
<hr>
<b>Last modified by: </b>~~Author~~, ~~Date&Time~~<br>
<b>Comment:</b><i>~~Comment~~</i>
</body>
</html>
Fields Used in Detail View Templates
The fields used in the Detail view HTML templates are recognized by the client when they are contained
between double tilde ~~ characters. For example, ~~LocalPath~~ represents the path to your local
working folder represented by the Complete working folder path field found in the Name tab of the
Folder Properties dialog box.

Provider Properties
This topic presents the StarTeam Provider properties and their descriptions as displayed in the Provider
Properties dialog box when opened from the context menu. The information in the Provider Properties
dialog box is different for each type of selected, shared resource: project, folder, or file.
Shared Project
The following properties are displayed for the shared project.
Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

Change Sharing

Opens the Share a Project dialog box where you can
change the sharing options.
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Property

Description

Change View

Opens the Select a StarTeam View dialog box where
you can change which view you are sharing.

Change Kind

Reveals the types and directions of changes that can be
found in any resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
folder used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server. It is possible for the dot-notation
to be higher, indicating a newer version is available in the
repository.

Shared Folder
The following properties are displayed for the shared folder.
Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

Change Kind

Reveals the types and directions of changes that can be
found in any resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
folder used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server. It is possible for the dot-notation
to be higher, indicating a newer version is available in the
repository.

Convert Change Kind To

Allows you to invert the direction and type of a deletion or
an addition. This is sometimes necessary when a project
was re-shared or hooked up with another view. Changes
on the server or in the workspace may be interpreted
assuming the wrong intention. A folder listed as
[outgoing deletion] may simply have been added to the
view by another developer at some time, and thus be
considered an [incoming addition]. The two buttons,
Incoming Deletion and Outgoing Addition, allow you to
change

Shared File
The following properties are displayed for the shared file.
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Server Description

Displays the name of the Server on which the shared
project is located.
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Property

Description

Project Name

Displays the name of the selected shared project.

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

MD5:

Displays the current MD5 hash value for the local
revision.

Stored Remote MD5:

Displays what the provider remembers the MD5 hash
value to have been at the last check in or check out.

Current Remote MD5:

Displays the MD5 hash value for the tip revision. By
comparing the stored MD5 hash value with the current
MD5 hash value, the provider can detect incoming
changes in spite of differing remote and local MD5 values
due to EOL differences.

Base Modification Timestamp:

Shows the last date and time the local and remote files
were current.

Local Modification Timestamp

Shows the date and time of the last modification to the
local file.

Remote Modification Timestamp:

Shows the date and time of the last modification to the
remote file.

Change Kind

Reveals the types and directions of changes that can be
found for any file resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
file used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server (tip revision). It is possible for the
dot-notation to be higher, indicating a newer version is
available in the repository.

Convert Change Kind To

Allows you to invert the direction and type of a deletion or
an addition. This is sometimes necessary when a project
was re-shared or hooked up with another view. Changes
on the server or in the workspace may be interpreted
assuming the wrong intention. A folder listed as
[outgoing deletion] may simply have been added to the
view by another developer at some time, and thus be
considered an [incoming addition]. The two buttons,
Incoming Deletion and Outgoing Addition, allow you to
change.

Stored EOL Conversion

Specifies which EOL (End of Line) conversion settings to
store. When you click OK or Apply after changing this
setting, the MD5 values will be recomputed and the
status refreshed in an attempt to identify the type of
change.
Note: The StarTeam Eclipse Client uses MD5
hash values exclusively for status computation,
therefore it needs to remember which EOL
conversion was in effect at the last check in or
check out so it can adjust the computed MD5.
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Working with Folders and Items
This section contains information related to working with folders and items.

Adding Folders to Views
1. Open a StarTeam perspective or view.
2. Do one of the following:
•
•
•

Choose StarTeam > Folder > New.
In the toolbar, click Create a new StarTeam Folder.
Open the Server Explorer, select a StarTeam project and/or view, and choose New > Folder.

The New Folder wizard opens.
3. Select a project and view clicking Next after each selection
4. Select a parent folder for the new folder in the folder tree.
5. Click Next. The new folder will be created as a child of the selected folder, and the Folder Name page
of the wizard displays.
6. Type a name and description for the new folder.
The folder name can be up to 254 characters.
7. Do one of the following:
Option

Description

Select Default

This option automatically provides a working folder by appending the name of
the new StarTeam folder to the path of the working folder.

Select Change
Default

Type in or browse to the path for an existing working folder. When you
browse for a path, you create an absolute path to this folder's working folder.

Select Map to
Workspace

This creates the working folder in your Eclipse-defined workspace path for the
associated Eclipse project.

The Sub-folder Inclusions (for including child folders) page of the New Folder wizard displays the new
folder and any child folders. If the working folder has child folders, a StarTeam folder is created for each
of them.
8. Do one of the following:
•
•
•

To exclude a child folder from your project, clear the check box next to the folder name in the folder
tree.
To exclude all child folders, click Deselect All.
To reselect folders you have excluded, click Select All.

9. Click Finish.

Attaching New Labels to Folders
Determine whether a label is a revision label or a view label by opening the Label view, and double-click
the label (or select the label, and then choose Properties from the context menu). A revision label has a
name and a description. A view label has a name, description, and a configuration time.
1. Select a folder in the Server Explorer or from one of the Eclipse Explorers.
2. Choose StarTeam > Folder > Labels.
Alternative 1: From the Server Explorer, right-click on the folder, and choose Labels. Alternative 2:
From one of the Eclipse Explorers, choose Team > Labels.
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Note: If you open the Properties dialog box using the Team > Labels command, expand
StarTeam Provider, and select Labels.
The Properties dialog box opens.
3. Select the revision that will receive the new label.
4. Click New. The Attach a New Revision Label dialog box opens.
5. Type a name and description for the label in the appropriate text boxes.
6. Optional: Check Frozen to ensure that only the selected revision can have this label.
7. Select one of the following options:
•
•
•

Folder Only to attach a label to only the selected folder.
Folder and Items Contained in Folder to attach a label to the folder and its items.
Everything in Subtree Rooted at Folder to attach a label to the folder, its items, and its child
folders and their items.

8. Click OK. The Properties dialog box displays the newly-created revision label.
9. Click OK.

Attach Existing View or Revision Labels to a Folder
Determine whether a label is a revision label or a view label by opening the Label view, and double-click
the label (or select the label, and then choose Properties from the context menu). A revision label has a
name and a description. A view label has a name, description, and a configuration time.
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Choose StarTeam > Folder > Labels.
Alternative 1: From the Server Explorer, right-click on the folder, and choose Labels. Alternative 2:From
one of the Eclipse Explorers, choose Team > Labels.
Note: If you open the Properties dialog box using the Team > Labels command, expand
StarTeam Provider, and select Labels.
The Properties dialog box opens.
3. Click Attach. The Attach a Label dialog box lists all the existing labels and identifies them as view or
revision labels. By default, both the View Labels and Revision Labels check boxes are selected. To
display only view labels or revision labels, clear the appropriate check box.
4. Select a label from the list.
5. Select one of the following options:
•
•
•

Folder Only to attach a label to only the selected folder.
Folder and Items Contained in Folder to attach a label to the folder and its items.
Everything in Subtree Rooted at Folder to attach a label to the folder, its items, and its child
folders and their items.
Note: Attaching a label to a folder always attaches it to the current configuration of each folder and
item. It is not possible to label a past revision of a folder, although you can do so for items

6. Click OK in the Attach a Label dialog box.
7. Click OK to close the Properties dialog box.

Attaching Labels to Items
1. Select one or more items in the Server Explorer, any StarTeam view, or in the Eclipse Explorers.
2. If selecting items from the Server Explorer or a StarTeam view, right-click and choose Labels > New. If
selecting items from an Eclipse Explorer, right-click and choose Team > Labels > New. The Attach a
New Revision Label dialog box opens.
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3. Type a name and description for the label in the appropriate text boxes.
The maximum label name length is 64 characters and the description length is 254 characters.
4. Optional: Check Frozen to ensure that only the selected item revision can have this label.
5. Select one of the following configuration options:
•
•
•

•

Current Configuration to attach the label to the tip revision.
Labeled Configuration to attach the label to the revision with a specified label. The labels are in
reverse chronological order based on the time at which they were created.
Promotion State Configuration to attach the label to the revision currently in a specified promotion
state. (Actually, the label is attached to the revision that has the promotion state's current view
label.)
Configuration As Of to attach the label to the revision that was the tip revision at a specified date
and time.

6. Click OK.

Attaching Existing View or Revision Labels to Items
1. Select one or more items in theServer Explorer, any StarTeam view, or in the Eclipse Explorers.
2. If selecting items from the Server Explorer or a StarTeam view, right-click and choose Labels > Attach.
If selecting items from an Eclipse Explorer, right-click and choose Team > Labels > Attach. The
Attach a Label dialog box opens. By default, both the View Labels and Revision Labels options are
checked.
3. Optional: Uncheck View Labels or Revision Labels to limit the list to one specific type of label.
4. Select a label from the list.
5. Optional: Change the selection for what item revision is to receive this label by selecting a configuration
option. The choices are:
•
•
•

•

Current Configuration to attach the label to the tip revision.
Labeled Configuration to attach the label to the revision with a specified label. The labels are in
reverse chronological order based on the time at which they were created.
Promotion State Configuration to attach the label to the revision currently in a specified promotion
state. (Actually, the label is attached to the revision that has the promotion state's current view
label.)
Configuration As Of to attach the label to the revision that was the tip revision at a specified date
and time.

6. Click OK.
Note: A Label can be attached to only one revision of an item.

Changing Default and Alternate Working Folders
Changing the view's working folder for working Eclipse projects is not recommended. Eclipse projects
should be recreated after changing the view's working folder. If you want to use a different location for your
working folder other than the Default Working Folder path, it is recommended that you specify an Alternate
Working Folder path.
Caution: Do not change the Default Working Folder unless you are a project administrator. It is
critical that before you change the Default Working Folder, you lock the server and everybody should
be logged off, just as when you change custom fields or anything else that effects all users. If you
change the working folder while the StarTeam Eclipse Client is running, it can cause Team
Synchronization errors.
These default settings affect ALL users and incorrect settings cause other users to be unable to check out
StarTeam files. The default settings should only be set to the name of the folder.
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1. In the StarTeam view, choose StarTeam > View > Properties.
•
•

Alternative1: In the Server Explorer, right click on the view node, and choose Properties.
Alternative2: In the Navigator or Package Explorers, right click on the project, and choose
Properties.

The Properties dialog box opens.
2. Select View.
3. Click the Name tab.
4. Select Alternate to create a different working folder for only yourself.
Alternative: If you are a project administrator, select Default to specify the default folder path for all
users.
5. Type the name of a new working folder or browse for a path to a working folder.
If you browse for the path, it becomes an absolute path. This path can be edited, however, to enable
you to work on a computer that uses a different letter for its hard drive.
Note: It is important that the Default Working Folder point to a location that is physically discrete
for each user, such as a drive on that user's workstation or a personal directory on a shared file
server.

Changing Name or Description of Folders and Items
1. Select a folder or item in one of the StarTeam or Eclipse views.
2. Right-click the folder or item and choose Properties.
If you open the Properties dialog box from one of the Eclipse Explorers, expand StarTeam Provider in
the dialog box to surface the available StarTeam properties. If you open the Properties dialog box
within a StarTeam view or from the Server Explorer, this action is not required.
3. Change the Name and/or Description for the folder or item.
4. Click OK. The folder or item name and/or description is changed in both the StarTeam repository and in
your working folder.

Compare Revisions
You can use the Compare With context menu commands for, among other things, comparing local
versions of files and folders to those in the StarTeam Server repository.
Using the Compare With context menu commands, you can complete the following actions:
•
•
•
•
•
•

Compare your local file to the latest tip revision stored in the repository.
Compare a local folder or file to a labeled version stored in the repository.
Compare a local folder or file to a copy in a different StarTeam view stored in the repository.
Compare a local folder or file to a copy of that same item determined by a date.
Compare a local file to a specific revision stored in the repository.
Select two files or two folders and compare their properties.

Comparing Local Files to Tip Revisions
1. Select a file in one of the Eclipse Explorers.
2. Right-click and choose Compare With > Latest from StarTeam.
The comparison editor opens displaying the differences between the two file versions.
Comparing to a Label
1. Select a folder or file in one of the Eclipse Explorers.
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2. Right-click on the item and choose Compare With > Label.
For folders, the Synchronize view opens along with the Compare editor. For files, the Compare editor
opens. In the Compare Editor, you can select a Label and the editor automatically updates to reflect the
differences between the local copy and the labeled copy.
Comparing to a Different View
1. Select a folder or file in one of the Eclipse Explorers.
2. Right-click on the item and choose Compare With > View.
3. Select the appropriate view, and click OK.
For files, the Compare editor opens displaying the differences between the local and remote file. For
folders, the Synchronize view opens.
Comparing by Date
1. Select a folder or file in one of the Eclipse Explorers.
2. Right-click on the item and choose Compare With > Date.
3. Select the desired date and time.
4. Click OK.
For files, the Compare editor opens displaying the differences between the local and remote file. For
folders, the Synchronize view opens.
Comparing a Local File to a Revision
1. Select the file in one of the Eclipse Explorers.
2. Right-click on the file and choose Compare With > Revision.
The Compare editor opens. The available revisions display at the top of the Compare editor. Selecting a
revision displays the differences between the local file and the selected revision in the lower section of the
Compare editor.
Comparing Properties for Files or Folders
1. Select two files or two folders in one of the Eclipse Explorers.
2. Right-click on one of the selected items and choose Compare With > Compare Properties. The
informational Compare Properties dialog box opens. By default, differing properties display in blue
text.
3. Click Close.

Rolling Back Folders
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open a StarTeam perspective or view, and choose StarTeam > Folder > Advanced > Behavior.
Alternative1: If selecting a folder from the Server Explorer, right-click and choose Advanced >
Behavior from the context menu. Alternative2: If selecting a folder from an Eclipse Explorer, right-click
and choose Team > Advanced > Behavior.
The Item Behavior dialog box opens.
3. On the Configuration tab, select a configuration option:
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•

•

•

Labeled Revision: This option uses the folder or item revision with the specified view label as the tip
revision. Existing view labels are listed in reverse chronological order based on the time for which
they were created. This option is disabled if the view has no labels defined.
Promotion State Configuration: This option uses the folder or item revision with the view label
assigned to the selected promotion state as the tip revision. This option is disabled if this view has
no promotion states defined.
Configuration As Of: This option uses the folder or item revision just prior to the specified point in
time as the tip revision. It defaults to the current date and time, but you can select a date and time in
the past, as long as it is after the time when the folder or item was created.

4. Click OK.

Modifying Folder Configurations
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Item Behavior dialog box, in one of the following ways:
•
•

If using the Server Explorer, right-click on the folder, and choose Advanced > Behavior.
If using one of the Eclipse Exploreres, right-click on the folder, and choose Team > Advanced >
Behavior.

3. Check Branch on change in the Modify tab.
This is not available on the main branch of the item.
4. On the Configuration tab, choose one of the following:
•
•
•
•

Current configuration radio button to keep all revisions current.
Labeled configuration radio button to point the configuration to a specific label.
Promotion state configuration radio button to point to a specific promotion state.
Configuration as of <date> radio button to point to a specific date.

5. Check Apply to entire folder tree to have all items beneath the selection reflect the same
configuration settings.

Creating Working Folders
The default working folder must point to a location that is physically discrete for each user, such as a drive
on that user's workstation or a personal directory on a shared file server.
1. Select a missing folder in one of the Eclipse Explorers.
A folder that exists in the StarTeam repository, but not on your local workstation is represented in the
Server Explorer using the missing folder icon.
2. Right-click on the folder, and choose Team > Create Working Folders.
After the working folder exists, you can copy files to it or create files in it and add them to the StarTeam
repository.
Note: If the working folder path for a shared or moved folder exceeds the operating system's
maximum working folder path length of 254 characters (including [ \ ] backslashes), StarTeam
will not allow you to create the working folder and displays an error message.

Customizing Link Properties
1. Click Link with Selection in the Link view toolbar.
2. Select an item in one of the StarTeam views, Server Explorer, or Eclipse Explorers that links to a folder
or another item. The Link view displays all links for the selected item.
3. Right-click on a link in the Link view and choose Properties. The Properties dialog box opens.
4. Select the Link node to view or modify certain link properties.
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5. Click OK.

Deleting Folders
1. Open the Server Explorer.
2. Select the folder you want to delete in the project view.
3. Right-click the selected folder, and choose Delete. A dialog box opens prompting you to confirm the
deletion.
4. Click OK.

Displaying Location References
1. Open the Reference view.
2. Click Link with Selection.
3. Do one of the following:
•

Select a folder in the Server Explorer or from one of the Eclipse Explorers.

•

Select an item from one of the StarTeam views.

The Reference view automatically updates showing any references for the selected folder or item.

Emailing Item Properties
The information sent for each item includes the fields displayed in the view. For items such as change
requests, the item's properties, which are the same as its contents, are sent in the email. For files, only the
properties can be sent. Items are considered to have been sent by the application, not by you. Therefore,
copy yourself on the email to receive the message.
Note: If you select a filter in the view and email an item, only the fields displayed by the filter are sent
to the recipient.
1. Do one of the following:
•
•
2.
3.
4.
5.
6.
7.
8.
9.

Select a file or folder from one of the Eclipse Explorers, and choose Team > Send To from the
context menu.
Open one of the StarTeam views, and choose Send To from the context menu.

The Send To dialog box opens.
Click To or CC to select the email recipients.
Move the team member names from the Available Users to Selected Users list.
Click OK.
Type a Subject.
Optional: Check Send A Copy To Myself if you want to receive a copy of the email.
Optional: Check Attach Item Shortcut to include a shortcut to this specific item in the email.
Type any additional information in the Add Text To The Mail Message text box.
Click Send Now to send the message.
Note: Unlike automatic email notification, this message will not display the word notification in the
subject line. Do not confuse email messages sent by individuals with email notification messages
automatically sent by the server. If your administrator has enabled email notification, you will
automatically receive email messages notifying you about items for which you are responsible and
topics for which you are listed as a recipient.

Excluding Files and Folders
Some types of files will never be added to a StarTeam project, although they may reside in a working
folder. For example, suppose you are creating files with an application that makes an automatic backup
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(.bak) copy of each file every time you save the file. Although your working folder might contain
several .bak files, you would have no reason to check them into (or out of ) the repository. Therefore, you
should exclude them from the project view. Exclude lists can also be inherited from parent folders.
1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Folder > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the desired folder, and choose
Properties.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Folder.
If opened from the StarTeam main menu or Server Explorer, select Folder.

3. Select the Exclude tab.
Note: The Exclude tab does not affect files that are already part of the project.
4. Choose one of the following:
Option

Description

Inherit and Use Local Excludes files that match the exclude list specifications set for this folder as
Exclude List
well as those of its parent folder. If the Local Exclude List text box does not
yet include any file specifications, add them.
Use Local Exclude
List

Excludes files that match the exclude list specifications set for this folder. If
the Local Exclude List text box does not yet include any file specifications,
add them.

No Exclude List

Includes all files.

5. Type one or more file specifications to use for matching files.
Use the standard expressions (with * and ? wild cards) separated by commas, spaces, or semicolons.
To include a comma, space or semicolon as part of the specification, enclose the specification in double
quotes. A trailing / character represents Not-in-View folders to be excluded. For example, bin/ would
cause all Not-in-View folders named bin to be excluded from the folder tree.
Note: The \ character does not work; it is treated as an escape character.

Finding Items
You can search all items displayed in views for the data contained in any displayed field.
1. Select a folder in Server Explorer or in one of the Eclipse Explorers.
2. Open the Change Request, Requirement, Task, or Topic view.
3. Enter CTRL+F. The Find dialog box opens.
4. Type part or all of the data in the Search For text box.
Do not use wild cards.
5. Select Forward to search the view from the top to the bottom, or select Backward to search the view
from the bottom to the top.
6. Select Starting at: Currently Selected Item to begin searching from the item that is presently selected,
or select Starting at: First Item to search from the first item in the view.
7. Select either All Displayed Fields or This Field.
If you select This field, select the field for which you want to search from the list box.

Borland StarTeam Eclipse Client

| 139

8. Check Match Case if a case-sensitive search is appropriate.
9. Click Find to search.
Note: Use Ctrl+F to start a search. Use F3 to find the next item that matches the search text and
Shift+F3 to find the previous item that matches the search text

Hiding Folders and Files
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Choose StarTeam > Folder > Properties from the main menu.
Alternative: From the Server Explorer or from one of the Eclipse Explorers, right-click on the folder, and
choose Properties.
Note: If you open the Properties dialog box from one of the Eclipse Explorers, expand StarTeam
Provider, and select Folder in the Properties dialog box.
The Properties dialog box opens.
3. Select the Name tab In the Properties dialog box, and clear the Visible option to hide the folder and
the files it contains.
4. Click OK to close the dialog box and save the folder properties.
Note: To make the folder visible again, check the Visible option in the Properties dialog box.

Highlighting Items
Flags are set, viewed, and removed by the user who created them. If an item has been flagged, the Flag
field displays Yes. If an item is not flagged, the Flag field displays No.
Tip: To display flagged items, the StarTeam view must be in list format. In the Task, Topic, or
Requirement views, click View as list in the view toolbar.
1. Select an item in one of the Eclipse Explorers or in one of the StarTeam Change Request,
Requirement, Task, or Topic views.
2. Do one of the following:
•
•

If selecting an item from one of the Eclipse Explorers, right-click on the item, and choose Team >
Flag from the context menu.
If selecting an item from one the StarTeam Change Request, Requirement, Task, or Topic views,
right-click on the item, and choose Flag from the context menu.

3. If reviewing flagged items in the Change Request, Requirement, Task, or Topic view, click the Filter
list box for the view, and choose the Flagged Items filter.

Linking Items Internally and Externally
It is possible to link two items, either internally in the same server configuration, or linking between two
items located on different server configurations, called external linking.
In StarTeam, an item is a file, change request, requirement, task, or topic. A link is a connection between
two folders, two items, or a folder and an item. Creating links can be quite useful. For example, linking a file
to a change request allows you to mark it as fixed when you check in the edited file. By linking files to the
requirements document that the files fulfill, you can easily refer to or update the document.
You can create several links at the same time if you want to link several items of the same type to one
particular item. For example, you might wish to link several change requests to a single file. To accomplish
this, you can create links using the context menu or Link button on the toolbar.
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Note: When creating external links between items on different server configurations, both server
configurations need to be opened in Eclipse to be able to create or view the external links.
1. Open a StarTeam perspective. If you want to link two items on different server configurations, open
both server configurations and perspectives.
2. Select file(s) or folder(s) in the Server Explorer or in one of the Eclipse Explorers, or by selecting the
item(s) in one of the StarTeam Change Request, Requirement, Task, or Topic views.
3. Click Create/Complete Link in the main toolbar.
4. Complete the link by selecting:
•
•
•
•
•
•

A folder.
One or more other files.
One or more change requests.
One or more requirements.
One or more topics and/or responses.
One or more tasks and/or subtasks.

To locate all items, you may need to switch to a different StarTeam view or use the All Descendants
button located on the toolbar of the Change Request, Requirement, Task, and Topic views.
5. To complete the link, click Create/Complete Link again in the main toolbar.
You can also view a link by selecting either of its ends. The end you select, whether a folder or an item, is
called the source. The other end of the link is called the target and is listed in the Item Type column on the
Link view.
Tip: If you change your mind about creating a link after you have started to create it, but before you
have finished completing it, you can press Esc.

Locking and Unlocking Items
Before changing the contents of a file or editing item properties, you should exclusively lock the file or item.
This action informs other team members that you intend to make changes.
1. Select one or more items.
2. Click the Lock or Unlock button on the toolbar.
The selected items become exclusively locked, and you are listed as the user who has locked them.
To lock an item using a context menu
1. Open the appropriate view to select a folder, file, change request, task, topic, or requirement.
2. Right-click an item, and choose Lock/Unlock.The Set My Lock Status dialog box opens.
Note: If setting a lock for a file in the Navigator or Package Explorers, choose Team > Lock/
Unlock.
3. Select a lock status option:
•
•

Unlocked: Removes your exclusive or non-exclusive lock on the selected items.
Exclusive: Prevents others from creating new revision of this item (until you release the lock or
another person breaks your lock).
• Non-exclusive: Indicates that you are working on the item and may possibly make changes (not
recommended for items other than files).
4. Optional: Check Break Existing Lock to break another team member's lock on the item. If e-mail is
enabled, StarTeam will send an e-mail message to the team member whose lock has been broken to
inform him or her of this fact.
Note: You must be granted the appropriate privileges to be able to break another person's locks.

Borland StarTeam Eclipse Client

| 141

Marking Items Read/Unread
To reread all the items on a certain subject, it is sometimes convenient to mark all of the items unread to
ensure that you do not miss any. You can also mark an entire requirement, task, or topic tree as unread.
1. Open the Change Request, Requirement, Task, or Topic view.
2. Select one or more items in the view that you want made unread or read.
3. Right-click the selected items, and choose Mark As Unread or Mark As Read. The items are marked
as specified, and the type style changes accordingly.

Moving Folders
Labels cannot move from view to view.
Note: When you move a folder, the access rights set at the folder level accompany it. Also, in some
cases, moving a folder to another view enables its disabled Branch on Change check box.
1. Open the Server Explorer.
2. Locate the folder or file that you wish to move.
3. Drag the folder or file that is to be moved from one location in the view to another. A dialog box opens,
asking you to confirm this change.
Tip: You can optionally move the working folder/file using this dialog box. This option is
automatically selected. If you do not want to move the working folder or file, clear the check box.
4. Click OK.

Moving Items
Labels cannot move from view to view.
Note: When you move an item, the access rights set at the item level accompany it. Also, in some
cases, moving an item to another view enables its disabled Branch on Change check box.
1. Open the Server Explorer.
2. Navigate to the project, view, and folder containing the item that you wish to move.
3. Open the view in which the item resides, and click Link with Selection in the view toolbar.
4. Select the item that you wish to move.
Tip: If you cannot locate the item in the view, click All Descendants in the view's toolbar.
5. Drag the item from the appropriate item view to the desired project, view, and folder.
You can move items between projects located on the same server configuration.
Important: You cannot move tasks and subtasks that have been exported from MS Project to
StarTeam.

Opening a Local Folder
You can open a local folder in a file browser from within the StarTeam client that enables you to perform
basic file and folder management tasks.
1. Select up to two folders in the Server Explorer or one of the Eclipse Explorers.
2. Do one of the following:
•
•
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In the Server Explorer, choose Open Local Folder.
In one of the Eclipse Explorers, choose Team > Open Local Folder.
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On a Windows system, this opens an instance of Windows Explorer for each location on disk that
corresponds to a selected folder. This applies to all folders except those whose status is Missing since
their local folders do not exist.

Renaming Files
If you want to rename a file in your project, you should rename it within the StarTeam Eclipse Client. This
retains the properties associated with that file, such as history and links. However, when you roll a view or
item back to a configuration prior to the name change, the old name is not restored. This can cause
problems. For example a setup script from an earlier build or release might fail because it uses the file’s
former name.
If you rename a file outside the application (for example, by using Windows Explorer), the application
considers the file to be a new file. When you add the file with the new name, it will have no connection to
the history, links, or other properties of the original file.
1. Select the file you want to rename.
2. Right-click on the file, and choose Properties. The Properties dialog box opens. If you opened the
Properties dialog box from one of the Eclipse Explorers, expand StarTeam Provider.
3. Select the File node.
4. Click the General tab in the Properties dialog box.
5. Change the Name.
6. Click OK.
The file is renamed in both the StarTeam repository and in your working folder.

Replacing Files and Folders
Describes how to replace files and folders with other versions in the StarTeam repository.
Rolling Back a Folder or File
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > Latest from StarTeam.
Replacing a Folder/File with a Specific View Configuration
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > View.
3. In the resulting dialog box, select a StarTeam view.
4. Click OK.
Replacing a Folder/File Under a Specific Labels
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > Label.
3. In the resulting dialog box, select a desired labeled configuration.
4. Click OK.
Rolling Back a Folder/File to a Specific Date
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > Date.
3. Select a date and (optionally) time configuration that you wish to roll back to.
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4. If including a time option, specify whether the time is local or UTC.
5. Click OK.

Searching Projects
1. Open a StarTeam perspective or view.
2. Click Search for StarTeam Items.
Alternative: you can choose Search > Search from the menu.
The Search dialog box opens.
3. Select the StarTeam Search tab.
4. Type the text for which you want to search into the Regular expression text box.
5. In the Search in area of the dialog box, select any desired server, project, view, or folder that you wish
to search in.
6. Use the Type drop down list to narrow your search to specific StarTeam item types and properties.
Select Files in from the drop down list and then choose the Comments property from the Look in
options to search Comments included with Files only.
7. From the Look in options, choose one of the following:
•
•

•

All properties if you want the search to return all item properties. An item is accepted if the string
representation of the value of any of the item properties matches the given regular expression.
All properties by current filters if you want the search to process only properties in the current
filter that are applicable to the chosen type.
Note: you can see the list of these properties by opening the This property list box when
Choose from all properties by current filters is selected.
Select This property to specify a single property to be processed.

8. From Options, you can:
•
•

Select the Match case check box to have search return only items that match the case as entered
into the Regular expression text box
Select the Recursive check box to have search seek matches in all folders beneath the selected
items from Look in.

9. Click Search.
The results will be displayed in the Search view and on the StarTeam Search Results tab.

Sorting and Grouping Data
1. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
2. Choose Filters > Sort and Group. The Sort and Group dialog box opens displaying four group boxes,
each indented slightly more to the right than the one above it. The first group box designates a primary
sort order, the second designates a secondary sort, and so on.
3. Optional: Check the Show Advanced Fields check box to list all the fields in First By and Then By list
boxes.
4. Select a field from the First By list box.
If you are grouping the items, you do not need to display the field in the view. If you are not grouping the
items, you can sort them based on a field that is not displayed, but you will not be able to tell where one
group leaves off and the next begins.
5. Click Ascending or Descending option button.
The default setting is ascending order.
6. Select Group By to group the items which have the same values in this field.
If you do not select any additional sort options, text fields are sorted in ASCII order. Enumerated and
user ID fields are sorted by their internal order or internal keys. That is, enumerated fields are sorted in
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the order given to them by the person who created the field; user ID fields are sorted in the order in
which they were created. The application disables the Sort Options button for numeric and date/time
fields.
7. Optional: Click Sort Options for additional sorting selections.
The Sort Options dialog box opens.
a) Select By internal key or order to sort enumerated and user ID files by their internal order or
internal keys.
b) Select As text to sort enumerated and user ID fields by the names of their possible values. For text
fields, As Text is your only choice.
c) Uncheck Case-sensitive to sort alphabetically or check it to sort in ASCII order (where uppercase
letters precede lowercase letters).
8. Add secondary and lower order sorts by using the Then By Group boxes as needed.

Displaying Additional Fields
1. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
2. Choose Filters > Show Fields.
The Available Fields list box contains all the fields that you could potentially display as column headers
but are not currently displayed. The Show These Fields in This Order list box displays all the fields
currently displayed in the view.
The Show Fields dialog box opens displaying two lists.
3. Do any combination of the following:
Description
Option
Display additional fields

Select the fields to display as the column headers from the Available
fields list. Then click Add.

Stop displaying fields

Select the fields to be removed from the Show these fields in this order
list box. Then click Remove.

Change the order of the
fields

Drag each field name to the desired location in the Show these fields in
this order list box.

4. Click OK.
Note: Double-clicking a field name moves it from one list box to the other. The Show Fields dialog
box initially displays the most commonly used fields. Check Show Advanced Fields to select from
a complete list of the available fields.

Viewing or Modifying Item Properties
Depending on how your team has set up the application, you may see a totally different dialog box called
an alternate property editor (APE). Every time the properties of an item are modified, a new revision of that
item is created. If you modify a property, you should also create a revision comment explaining the
modification using the Comment tab provided in the Properties dialog box.
1. Select an item in one of the StarTeam or Eclipse views.
2. Do one of the following:
•
•

Select an item and double click on it.
Right-click the folder or item, and choose Properties from the context menu.
Note: If you open the Properties dialog box from one of the Eclipse Explorers, expand StarTeam
Provider in the dialog box to surface the available StarTeam properties. If you open the
Properties dialog box within a StarTeam view or from the Server Explorer, this action is not
required.
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3. Modify any of the property fields in the corresponding Properties dialog box.
4. Click OK.

Comparing Properties
1. For files and folders, open the Server Explorer or one of the Eclipse Explorers.
For other item types, open the Change Request, Requirement, Task, or Topic views.
2. Select two items in the open view.
Use Ctrl+Click to select the second item.
3. For files and folders selected in one of the Eclipse views, right-click and choose Compare > Compare
Properties.
For items selected in the Server Explorer or in one of the item (change request, task, topic, and so on)
views, right-click, and choose Compare Properties.
The Compare Properties dialog box opens.
4. Click Closed.

Setting Active Process Items
Setting an active process item is a convenient way of saving time when you know that you will be adding
files or checking them in later. You can make a selected change request, task, or requirement the active
process item for the current view, an open view on the same server, or a different view on the same server.
You can only specify one active process item for each view. Setting a second active process item for the
same view at one time clears the first one.
1. Open your project in a StarTeam perspective.
2. Click the Change Request, Requirement, or Task tab, and select the item you want to use as the
active process item.
3. Do one of the following:
•
•
•

Right-click and choose Set Active Process Item > Current View to choose the current view.
Right-click and choose Set Active Process Item > [view name] to choose from the listed opened
views on the server.
Right-click and choose Set Active Process Item > Select View to open a dialog box and choose
any other view on the server.
Note: You can also set the currently-selected item as a process item by using the Use As Active
Process Item button on the toolbar.

The active process item you selected is used by default when you add files or check them in. However, you
can override this default and select another appropriate item when adding or checking in files.
Tip: After you finish with a process item, you should right-click it and choose Clear Active Process
Item so that it cannot be accidentally reused. That removes the information from the status bar and
keeps the process item from reappearing in the File Add or File Checkin dialog boxes.

Selecting Items
1. Open the Change Request, Requirement, Task, or Topic views.
2. Click the toolbar list box in the corresponding view, and choose one of the following:
•

Select > Select All: Selects all displayed items in the view.
Note: The Audit Log view also provides this menu command.

•
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Select > By Query: Opens the Select Query dialog box where you can choose the desired query to
apply for displaying in the view.
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•

Select > By Label: Opens the Select a Label dialog box where you can specify a label for
displaying items in the view.
3. To select items in Server Explorer, select an item, right-click and choose Team > Show in Server
Explorer.

Copying Items
You can copy items from one server and paste them to another server. This excludes Folders and Files. To
copy a StarTeamItem from one Server and paste the item in a different Server:
1.
2.
3.
4.
5.

Open a source view on one server and the target view on another server.
In the source view, navigate to the item to copy.
Right-click on the item and choose Team > Copy.
Navigate to the target view on the other server where you want to paste the item.
Right-click in the view and choose Team > Paste. A new Item is created on the selected Server with the
same values as the copied Item. When the paste operation is selected, a confirmation dialog asks if you
also would like to create an External Link between the two Items.

Files
To place a file under version control, it must be added to an application folder. Adding the file causes a
copy of the file to be stored in the StarTeam repository. After the file has been added to file under version,
you and other members of your team can check it out, revise it, and check in new revisions, while file under
version maintains information on all revisions of the file. Note that all check-ins in file under version are
atomic. That means that if you check in multiple files, none of them are checked in if the check-in operation
for any one of them fails.
When checking out a file revision, you should verify that you have the tip or latest version of the file. Doing
this ensures that the file you see contains the latest changes. If you intend to modify the file, you should
check it out with an exclusive lock, to indicate to others that you are working on it.
When you check a file in, file under version records the file changes as a new revision. As part of the
check-in process, you can remove the lock, making the file available to others, or maintain the lock so you
can continue working on a locked file. If someone else checks in a file you are working on, your revision
becomes out of date. file under version assigns a Merge status to the file indicating that your changes need
to be merged with those made by someone else. You could do a force check-in of your changes, but that
would overwrite another person's work. It is usually best to check the file out a second time, merging it with
the changes you have already made. When you are sure that the file is correct, you can check it in.
Note: Using the StarTeam Eclipse Client, operations for files are surfaced using the:
•
•
•
•
•

StarTeam main menu commands;
Context menus provided in the various StarTeam views;
StarTeam-specific toolbar buttons;
Team context menu; or
Team Synchronizing perspective.

If a file resides in the working folder of an application folder, you can add that file to the application folder.
This operation places that file under version control. A copy of the working file becomes the first revision of
that file stored in the repository. If the working file is deleted later, the data is not lost because a copy exists
in the repository. The application creates a new revision of this file in the repository every time you check
the file in.
Every time you check a file revision out, its contents are copied to a working folder. Checking out a revision
also ensures that you have the tip or a specific revision to work on.
The application enables you to label the tip revisions of every item within a view. For example, when the
project reaches a particular milestone (such as beta), you might give the view's items a label, called a view
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label. Then you can configure the view to return to the way it was at the time the label was applied, check
out revisions as a group using that label, create a new view based on the label, or assign the label to a
promotion state.
The application also provides revision labels. You can label one or more revisions as you check them in or
by applying the label to each of the revisions using Labels found on the view's context menu in the Server
Explorer or the Labels command on the File menu. StarTeam makes it easy to check out those files as a
group using the label. A file revision can have any number of labels. However, no two revisions of the
same file in the same view can have the same label.
Recommendations for Working with Files Under Version Control
Here are some recommendations about using files under version control:
•
•
•
•

To let other team members know that you intend to make changes to a file, change the lock status to
exclusive as part of the check-out procedure.
As part of the check-in process, change the lock status to unlocked, making it available to others.
If you intend to continue making changes to the file but still want to check it in for backup purposes,
keep the file locked.
To prevent yourself from changing a file that you have not locked, select Window > Preferences >
Mark Unlocked Working Files Read-only the Mark Unlocked Working Files Read-only preference.
Then, if you check out a file that you have not locked, the working copy becomes read-only.

Working With Files
This section contains a list of procedures related to managing files.

Checking In Files
You can check in files:
•
•

Without opening a dialog box to set any specific check in options using the StarTeam-specific toolbar
button, Put outgoing changes to StarTeam Server.
By opening a Check In dialog box and setting specific check-in options, such as Lock Status, using
the Team > Check In command.
Note: Unlike other StarTeam clients, the StarTeam Eclipse Client does not have a special Add Files
dialog for putting new files (files with the status in not-in-view) under version control. You use the
same standard Check In dialog box for files that have been modified while under version control and
for files that are new.

1. Choose Team > Check In from one of the Eclipse Explorers or from any view that surfaces the Team
context menu. The Check In dialog box opens.
2. Type a check in comment.
A list box below the main comment text area provides previous check in comments for you to select
from.
3. Optional: Check Force check-in to overwrite the tip revision in StarTeam.
4. Optional: Check Show check-in statistics.
For a particular check-in operation, you can see how many files are being sent by StarTeam Server
directly and how many are being sent by Cache Agent, by displaying the check-in statistics. After the
check-in operation completes, the Check In Statistics dialog box opens displaying the elapsed time,
total number of files, total number of bytes, and whether the operation skipped or failed to check in any
of the files.
5. Expand Lock Status to select one of the following Lock Status options:
•
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•
•
•

Exclusive: Indicates that you intend to make further changes to the files.
Non-exclusive: Indicates that you are working on the files and may possibly make changes.
Keep Current: Retains the current lock status.

6. Optional: Select the following options in the Check In dialog box.
•
•

•
•
•

•

•

Check Delete working files to remove the selected files from your working folder.
Expand Process Item (required if process rules are enforced). Link and Pin Process Item to link
the files to a process item.
Clicking Select opens the Select Process Item dialog which displays available items in the current
View. You can filter the list of available process items in this dialog box, and you can use the tree to
browse to a process item in a different project or view.
If work on the active process item is now complete, check Mark selected process item to closed
state if work on the active process item is now complete.
To make changes to the selected process item's properties during the check-in process, check
Show property editor for selected process item.
Expand Label and select a Revision label from the drop-down list, or create a new revision label by
typing its name.
Check Move the label if it's already assigned to a previous revision if the label in use.
Expand Advanced. Check Set EOL check-out format (for text files only) to control the EOL
character stored with the files. The default setting is based on the EOL setting in the File Properties
dialog box. In addition, select a file type of ASCII, Binary, or Unicode.
Choose a File Encoding from the drop-down list. The default setting is based on the EOL setting in
the Preferences dialog box.
Expand Change Requests to review the change requests linked to the files you are checking in.

7. The bottom of the dialog box provides a Changes area. You can optionally:
•
•
•
•
•
•
•

Show flat, tree, or compressed folder views by selecting the various toolbar buttons.
Select Additions only to show only not-in-view files (files to add).
Select Changes only to show only modified files (changed files).
Click Edit Description to edit the main description for the checked in items.
Select a file or multiple files, and click Edit Comment to edit its check-in comment individually (or
leave it blank).
Select a file or multiple files, and click Delete Comment to remove a comment associated with the
checked-in item.
Select a file and click Compare with Revision to compare the files you are checking in with the tip
revision of the files in the repository.
Tip: The dialog box also provides a Configure Personal File Options link so you can quickly
make modifications to file options before completing the check-in.

8. Click OK.

Checking Out Files
1. Select the file(s) that you wish to check out from one of the Eclipse Explorers or from any view that
surfaces the Team context menu.
2. Choose Team > Check Out or Team > Force Check Out from the context menu.
Note: Using Force Check Out overwrites any files with the same name in your working folder,
even if they are more recent.
3. Click Get incoming changes from StarTeam Server within a StarTeam view.
4. Choose Team Synchronizing > Synchronize > Check Out/Force Check Out. The Check Out dialog
box does not open, and the files are checked out to your local working folder.
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Checking Out Files with Options
1. Select the file(s) that you wish to check out from one of the Eclipse Explorers or from any view that
surfaces the Team context menu.
2. Choose Team > Check Out with Options from the context menu. The Check Out dialog box opens.
3. Optional: Check the following options:
•
•

Force check out to overwrite any files with the same name in your working folder, even if they are
more recent.
Show check-out statistics

For a particular check-out operation, you can see how many files are being sent by StarTeam directly
and how many are being sent by Cache Agent by displaying the check-out statistics. After the check out
operation completes, the Check Out Statistics dialog box opens displaying the elapsed time, total
number of files, total number of bytes, and whether the check-out operation skipped or failed to check
out any of the files.
4. Expand Reference By, and select one of the following options for the files you wish to check out:
•
•
•
•

Current revision: The most current (tip) revision.
Label : A specific file revision. The view labels precede the revision labels in the list.
Promotion state: A specific promotion state.
Configuration as of: The revision that was the tip revision at the specified date and time. Click the
Date/Year button to use the calendar, and specify the time by typing in the time or using the spin
boxes.

5. Expand Lock Status, and select one of the following lock options:
•

•
•
•

Unlocked: Does not lock the files you are about to check out, or causes them to be unlocked if you
currently have them locked. Be aware that when you check out an unlocked file, it may become
read-only in your working folder.
Note: There is a project property and a Preferences option that controls the read-only or read/
write status of working files.
Exclusive: Indicates that you intend to make further changes to the files.
Non-exclusive: Indicates that you are working on the files and may possibly make changes.
Keep Current: Retains the current lock status.

6. Optional: expand EOL Conversion, and choose one of the following:
•
•
•
•

None or another button to change your current EOL conversion setting.
For Windows, the EOL marker is CR-LF (carriage return/line feed).
For UNIX, it is LF (line feed).
For Macintosh operating systems, it is CR (carriage return).

EOL settings on this dialog override the default setting you selected on the File page of the Personal
Preferences dialog box.
7. Expand Advanced to optionally select an appropriate File Encoding from the list box to support
keyword expansion for non-English code pages.
8. In the Changes area you can optionally: Show flat, tree, or compressed folder views by selecting the
various toolbar buttons in the Changes area toolbar.
9. Select a file and click Compare with Revision in the Changes area toolbar to compare the local file
with the tip revision of the file in the repository.
Note: The dialog box also provides a Configure Personal File Options link so you can quickly
make modifications to file options before completing the checkout.
10.Click OK to complete the check out.
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Note: You can also use the Get incoming changes from StarTeam Server button on the toolbar
to check out files without using the Check Out dialog box. If process rules are required, the Check
Out dialog box opens automatically.

Checking Out Existing Folders
1.
2.
3.
4.

Open the StarTeam perspective.
Choose Window > Open Perspective > Other.
Select StarTeam Classic or StarTeam Activity from the list, and click OK.
Open the Server Explorer, and navigate to the appropriate StarTeam project, view, and folder.
You can multi-select folders to check out in the Server Explorer.

Note: If you have not logged on to the server, right click on the server configuration node, and
choose Log On. The status bar at the bottom of the Workbench reflects the logged on user name.
5. Right-click and choose Check Out As Project. The Check Out As wizard opens.
6. Choose one of the following options:
Option

Description

Check out as project in the
workspace

Enter a project name in the text box provided or use the default
folder name, and click Next. Select a location where you want to
check out the files to, and click Next.

Check out into existing project

Click Next to choose a valid target project, and click Finish.

Check out as a project
configured using New Project
Wizard

Click Finish , and follow the steps in the New Project wizard.

Note: If you want to use a location within the workspace that is not the default (that is, you select
either the second or third option), then you must use the StarTeam Cross-Platform Client to check
out the project and then import it from within the StarTeam Eclipse Client.
7. If you chose to Check out as project in the workspace, specify any check out options as follows:
•

Expand Reference By, and select one of the following options for the files you wish to check out:
•
•

•

Current revision : The most current (tip) revision.
Label: A specific file revision. The existing view and revision labels are listed in reverse
chronological order based on the time at which they were created. The view labels precede the
revision labels in the list.
• Promotion state: A specific promotion state.
• Configuration as of: The revision that was the tip revision at the specified date and time. Click
the Date/Year button to use the calendar, and specify the time by typing in the time or using the
spin boxes.
Expand Lock Status, and select one of the following lock options:

•

• Unlocked: Releases your lock on the files after check-in.
• Exclusive: Indicates that you intend to make further changes to the files.
• Non-exclusive: Indicates that you are working on the files and may possibly make changes.
• Keep Current: Retains the current lock status. Selected by default.
Optional: Expand EOL Conversion, and choose one of the following:

•

• None or another button to change your current EOL conversion setting.
• For Windows, the EOL marker is CR-LF (carriage return/line feed).
• For UNIX, it is LF (line feed).
• For Macintosh operating systems, it is CR (carriage return).
Expand Advanced to optionally select an appropriate File Encoding from the drop-down list to
support keyword expansion for non-English code pages.
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8. Click Next. The Mapping preferences page opens.
9. Choose your desired settings, or accept the default settings, and click Finish.

Comparing and Merging Files
Important: You must specify File Compare/Merge as the alternate compare/merge tool before you
can use it to compare and merge files.
This procedure presents the basic high-level task involved in comparing and merging a local file with a file
in the StarTeam repository, which opens the File Compare/Merge component.
1. There are two ways within the StarTeam Eclipse Client that you can launch File Compare/Merge. Do
one of the following:
•
•

In the History view, select two files to compare.
In the Package Explorer view, select a StarTeam repository file in the view to compare with your
local file or select two files to compare.
2. Done one of the following from the context menu:
•

Right-click and select Merge File Contents.

•

Right-click and select Compare With > Remote File in External Comparison Application or
Compare With > Each Other in External Comparison Application.

The File Compare/Merge session opens in a separate view or window, with each file in its own edit
pane.
3. Perform any required edits to the files directly in the edit panes.
Tip: You can find additional procedures for Comparing and Merging Files in the online help of the File
Compare/Merge tool.

Converting Resource Change Status
Converting the change status does not require check in or check out as it only affects local sync data, and
it is reversible.
1. Right-click the file or folder in the Navigator view. and choose Properties.
Alternative: Right-click the file or folder in the Synchronize view and choose Convert To.
2. Choose Properties.
3. Click the appropriate button for the desired change on the StarTeam Provider page.
4. Click OK.

Editing Check-in Comments
1. Select the file or multi-select files in one of the Eclipse Explorers.
2. Right-click, and choose Team > Comment for Next Check-in > Edit. The Comment dialog box opens.
Note: To remove a previously-added check-in comment, choose Team > Comment for Next
Check-in > Remove.
3. Type the text you want for the comment.
Tip: Comment fields allow up to 30,000 characters.
4. Click OK.
Note: You can also open the Check In dialog box and use the toolbar in the Changes area to edit
and remove check-in comments.
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Enabling Concurrent File Editing
Note: The administrator usually determines the setting of the Require Exclusive Lock When Files
Are Checked In check box when determining the properties for a StarTeam project. However,
preferences are set by you for your workstation.
1. Choose Window > Preferences from the main menu. The Preferences dialog box opens.
2. In the resulting dialog box, expand Team > StarTeam.
3. Select the File node, and check Use non-exclusive locks in integration.
4. Click OK.
Note: If you have checked Use Non-exclusive Locks In Integrations and experience check-in
problems, try clearing the check box. You may want to talk to your administrator about the setting for
the Require Exclusive Lock When Files Are Checked In check box.

Enabling Quick Diff in Text Editors
1. Choose Window > Preferences The Preferences dialog box opens.
2. Expand the General > Editors > Text Editors nodes.
3. Select Quick Diff.
4. Check Enable Quick Diff.
5. Under the option, Use this reference source, choose Latest StarTeam Revision from the list box.
6. Click OK.
After activating Quick Diff and opening a text editor, the text editor displays colored gutter bars on the left
to indicate differences from the latest StarTeam revision of the opened file. Hover text displays the
differences as you hover your mouse over the gutter bars.

Excluding Files and Folders
Some types of files will never be added to a StarTeam project, although they may reside in a working
folder. For example, suppose you are creating files with an application that makes an automatic backup
(.bak) copy of each file every time you save the file. Although your working folder might contain
several .bak files, you would have no reason to check them into (or out of ) the repository. Therefore, you
should exclude them from the project view. Exclude lists can also be inherited from parent folders.
1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Folder > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the desired folder, and choose
Properties.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Folder.
If opened from the StarTeam main menu or Server Explorer, select Folder.

3. Select the Exclude tab.
Note: The Exclude tab does not affect files that are already part of the project.
4. Choose one of the following:
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Option

Description

Inherit and Use Local Excludes files that match the exclude list specifications set for this folder as
Exclude List
well as those of its parent folder. If the Local Exclude List text box does not
yet include any file specifications, add them.
Use Local Exclude
List

Excludes files that match the exclude list specifications set for this folder. If
the Local Exclude List text box does not yet include any file specifications,
add them.

No Exclude List

Includes all files.

5. Type one or more file specifications to use for matching files.
Use the standard expressions (with * and ? wild cards) separated by commas, spaces, or semicolons.
To include a comma, space or semicolon as part of the specification, enclose the specification in double
quotes. A trailing / character represents Not-in-View folders to be excluded. For example, bin/ would
cause all Not-in-View folders named bin to be excluded from the folder tree.
Note: The \ character does not work; it is treated as an escape character.

Finding Files Associated with Active Process Items
When you have files associated with an active process item, you can quickly find all associated file
changes by following the steps below.
1. Open the view containing the active process item.
You can see what item is the active process item by looking at the Eclipse Status Bar.
The Status Bar displays the Active Process Item icon, followed by the name of the item.
Tip: The Server Explorer also reflects when you have an active process item specified at the view
level on the View icon followed the active process item informational text.
2. Open the Link view.
3. Click Link with Selection in the toolbar.
4. Select the active process item in the appropriate Change Request, Requirement, or Task view.
5. Right click on a link and choose Select Linked Item. The view opens containing the target of the
associated item.

Force Check-out with Keyword Expansion
This process allows you to get the local file contents replaced by the remote version and thus have
keywords expanded after the project settings for keywords were changed.
1. Select the workspace file, and choose Replace with > Revision from the context menu.
2. Select the latest revision. Doing so does not change the file; however any keywords in the file (such as,
$Header$) are expanded.

Locking and Unlocking Items
Before changing the contents of a file or editing item properties, you should exclusively lock the file or item.
This action informs other team members that you intend to make changes.
1. Select one or more items.
2. Click the Lock or Unlock button on the toolbar.
The selected items become exclusively locked, and you are listed as the user who has locked them.
To lock an item using a context menu
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1. Open the appropriate view to select a folder, file, change request, task, topic, or requirement.
2. Right-click an item, and choose Lock/Unlock.The Set My Lock Status dialog box opens.
Note: If setting a lock for a file in the Navigator or Package Explorers, choose Team > Lock/
Unlock.
3. Select a lock status option:
•
•

Unlocked: Removes your exclusive or non-exclusive lock on the selected items.
Exclusive: Prevents others from creating new revision of this item (until you release the lock or
another person breaks your lock).
• Non-exclusive: Indicates that you are working on the item and may possibly make changes (not
recommended for items other than files).
4. Optional: Check Break Existing Lock to break another team member's lock on the item. If e-mail is
enabled, StarTeam will send an e-mail message to the team member whose lock has been broken to
inform him or her of this fact.
Note: You must be granted the appropriate privileges to be able to break another person's locks.

Modifying the EOL Conversion Mode
StarTeam Eclipse uses MD5 hash values for status calculation and revision matching. Therefore, it needs
to know what EOL conversions were used for a file at the last file check-in and check-out operation.
StarTeam Eclipse needs to remember these EOL conversions to adjust the locally computed MD5 hash
value to the remotely reported ones. For instance, when using the Cross-Platform Client and StarTeam
Eclipse in parallel, operations performed by the Cross-Platform Client bypass the StarTeam Eclipse EOL
persistency, and result in incorrectly reported statuses.
1. Right-click the file in the Navigator view and choose Properties.
2. Select the desired EOL conversion mode on StarTeam Provider page: Windows, Unix, Mac, or None.
3. Click Apply or OK .

Modifying File Properties
1. Open a StarTeam Perspective, and select a file from the Server Explorer or in one of the Eclipse
Explorers.
2. Lock the file.
3. Right click and select Properties. The Properties dialog box opens.
Note: If you open the Properties dialog box from one of the Eclipse Explorers, expand StarTeam
Provider and select File from the tree-view list.
4. On the General tab, you can change the file name and description or set the Executable flag.
Changing a file name also changes name of the working file.
5. Select the Archive tab where you can optionally change the following settings:
•
•

Change the Compression setting to None, Maximize speed, Default (a compromise between
speed and compression), or Maximize compression.
Select the Store versions as deltas check box to store text files using the forward delta method.
Clear it to store file revisions in entirety.

6. Select the Custom tab.
If your company uses StarTeam Repository Customization feature, your administrator may have
created additional file properties.
a) To change a custom property, double-click on its name. The Edit Property dialog box opens.
b) Select a new value for the property.
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For integer, text, and real fields, Value is a text box. For enumerated types and user IDs, it is a list
box. For dates and times, Value has a date check box and a time check box, each of which is
followed by a date or time in the format for your locale.
7. Select the Comments tab.
8. Type the reason for changing the file’s properties in the text box.

Marking Unlocked Files Read-only
In many cases, users make edits before realizing that their files must be exclusively or non-exclusively
locked to check them in. If the files are read-only, users are less likely to make this mistake.
1. Do one of the following:
•
•

With a StarTeam perspective or view open, choose StarTeam > Project > Properties from the main
menu.
In the Server, Navigator, or Package Explorers, right click on the project, and choose Properties.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select Project.
If opened from the StarTeam main menu or Server Explorer, select Project.

3. Select the Options tab.
4. Check Mark Unlocked Working Files Read-only,
This applies to files that are unlocked in the application or in application integrations with third-party
applications. If this check box is cleared, you must use the operating system to change the read-only
attribute to read/write. Working copies of unlocked files will now become read-only when the following
file operations are performed:
•
•
•

File check-ins
File check-outs
File unlocks
Note: This StarTeam project property overrides the identical Mark Unlocked Working Files Readonly personal preference setting. If you change your mind after selecting the property (or the
equivalent personal preference), verify that no files are writable before clearing the check box. Next,
force a check out and lock all the files (or just the read-only files). Finally, unlock them.

Monitoring Check-out Statistics using Cache Agent
Over time, more and more of the files will come from Cache Agent, reducing the strain on StarTeam
Server. As a result, the check-out speed should continue to improve until all files are available from Cache
Agent.
For a particular check-out operation, you can see how many files are being sent by StarTeam Server
directly and how many are being sent by Cache Agent, by displaying the check-out statistics.
1. Select the files to be checked out in the StarTeam client.
2. Right-click the selected files and choose Check Out with Options. The Check Out dialog box opens.
3. Check Show check-out statistics.
4. Select any other option settings that are appropriate to your check-out operation.
5. Click OK. After the check-out operation completes, the Check-out Statistics dialog box opens
displaying the elapsed time, total number of files, total number of bytes, and whether the operation
skipped or failed to check out any of the files.
6. Click OK.
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Opening Files
1. Select the file in the Server Explorer.
2. Right click the file and choose Open.
If the file does not open in an associated application, an association may not have been created for the
selected file type. You can set file associations in Eclipse using the Preferences dialog box (Window >
Preferences).

Replacing Files and Folders
Describes how to replace files and folders with other versions in the StarTeam repository.
Rolling Back a Folder or File
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > Latest from StarTeam.
Replacing a Folder/File with a Specific View Configuration
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > View.
3. In the resulting dialog box, select a StarTeam view.
4. Click OK.
Replacing a Folder/File Under a Specific Labels
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > Label.
3. In the resulting dialog box, select a desired labeled configuration.
4. Click OK.
Rolling Back a Folder/File to a Specific Date
1. Select the folder or file in one of the Eclipse Explorers.
2. Right-click on the file, and choose Replace With > Date.
3. Select a date and (optionally) time configuration that you wish to roll back to.
4. If including a time option, specify whether the time is local or UTC.
5. Click OK.

Setting the File Executable Bit for UNIX
1. Select a file in the Server Explorer or any of the Eclipse Explorers.
2. Right-click on the file, and choose Properties. The Properties dialog box opens.
3. Do one of the following:
•
•

If opened from one of the Eclipse Explorers, such as the Navigator or Package Explorers, expand
StarTeam Provider and select File.
If opened from the Server Explorer, select File.

4. On the General page of the Properties dialog box, check or uncheck Executable.
5. Click OK.
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Viewing Annotations
1. Select a text file in the Server Explorer, Navigator, or Package Explorer.
2. Choose Window > Show View > Annotate.
Alternative: Right-click the selected file and choose Team > Show Annotations.
The Annotate view displays the contents of the selected file, and the annotation information in the left
gutter of the view.
3. Click Info in the gutter to view the details about a specific revision.

Viewing or Modifying Item Properties
Depending on how your team has set up the application, you may see a totally different dialog box called
an alternate property editor (APE). Every time the properties of an item are modified, a new revision of that
item is created. If you modify a property, you should also create a revision comment explaining the
modification using the Comment tab provided in the Properties dialog box.
1. Select an item in one of the StarTeam or Eclipse views.
2. Do one of the following:
•
•

Select an item and double click on it.
Right-click the folder or item, and choose Properties from the context menu.
Note: If you open the Properties dialog box from one of the Eclipse Explorers, expand StarTeam
Provider in the dialog box to surface the available StarTeam properties. If you open the
Properties dialog box within a StarTeam view or from the Server Explorer, this action is not
required.

3. Modify any of the property fields in the corresponding Properties dialog box.
4. Click OK.

Viewing Previous File Revisions
1. Open the History view, and click Link with Selection.
2. Select a file in the Server Explorer or from one of the Eclipse Explorers.
3. In the History view, select the specific revision of the file that you want to review.
4. Right-click the selected item, and choose Open Revision Content. This command copies the revision
to a temporary file and displays it in the associated application.

File Properties
Listed below are the file properties and their descriptions as displayed in the File Properties dialog box.
The File Properties dialog box contains the following tabbed pages of properties.
General
The following properties are on the General page.
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Property

Description

Name

Displays the name of the file.

Description

Displays the description of the file.

Status

Indicates the relationship between the copy of the file in
your working folder and the tip revision in the repository.
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Property

Description

Size

Displays the size of the tip revision of the file in bytes.

Last Modified By

Displays the name of the person who last modified the
file.

Last Modified On

Displays the date on which the file was last modified.

File Time Stamp

Displays the time at which the file was last modified.

Locked Exclusively By

Displays the name of the user who has exclusively locked
the file.

Locked Non-Exclusively By

The name of user who has non-exclusively locked a file.

File Type

Indicates file type selected: ASCII, Binary, or Unicode.

Executable

Indicates whether the executable bit should be set for a
UNIX file.

Working File
The following properties are on the Working File page.
Property

Description

Path

Displays the Path to the working folder for the file.

File Exists

Indicates whether the file exists in the working folder.

Size

Displays size of the file in the working folder in bytes.

Time Stamp

Displays the time that the working folder file was last
modified.

Executable

Indicates whether the executable bit should be set for a
UNIX file.

Archive
The following properties are on the Archive page.
Property

Description

Type

Indicates whether a file is stored as a StarTeam (Native)
file, or as another type of file.

Format

Indicates the vault storage format for the file. StarTeam
2006 uses only Native-II storage.

Archive File Name

Displays the name of the Native-II Vault file that stores
the tip revision. This name is the MD5 value of that file
revision's content, converted to a 32-digit hex string.

Compression

Indicates a file's level of compression.
Default: A compromise between Maximize Compression
and Maximize Speed
Maximize Compression: The densest possible
compression of file revisions. Used to save space on the
server.
Maximize Speed: The fastest possible compression of
file revisions. Used to improve server performance.
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Property

Description
None: No compression.

Custom
You can create custom properties for an item which will display in the item Properties dialog box. The
following properties are on the Custom page.
Property

Description

Property

Displays each custom property name.

Value

Displays the values for each custom property. Doubleclick the property name to edit the value.

Comment
The following properties are on the Comment page.
Property

Description

Comment For This Revision

Displays the reason for the changes to the current
revision.

Comment For New Revision

Displays the reason for the changes to the new revision.

Sample File Detail View Template
You can use the following sample for customizing the Detail view for the File component.
Sample File HTML Template
<html>
<head></head>
<body>
<table bgcolor=#aaabbbccc width=100%>
<tr>
<td align=center><b>~~Name~~<b></td>
</tr>
</table>
<table>
<tr>
<td align=left><b>Status:</b></td>
<td>~~Status~~</td>
</tr>
<tr>
<td align=left><b>Size:</b></td>
<td>~~FileSize~~</td>
</tr>
<tr>
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<td align=left><b>Working folder:</b></td>
<td>~~Path~~</td>
</tr>
<tr>
<td align=left><b>Project Folder Path:</b></td>
<td>~~Folder Path~~</td>
</tr>
</table>
<hr>
<b>Last modified by: </b>~~Author~~, ~~Date&Time~~<br>
<b>Comment:</b><i>~~Comment~~</i>
</body>
</html>
Fields Used in Detail View Templates
The fields used in the Detail view HTML templates are recognized by the client when they are contained
between double tilde ~~ characters. For example: ~~Path~~ represents the path to your local working
folder represented by the Path field found in the Working File tab of the File Properties dialog box.

File Fields
This section lists all the file fields in alphabetical order.
Note: Client-calculated fields cannot be used in custom email notifications or Notification Agent.
Reports can use any field name.
Field

Description

Archive Format (Advanced)

Values: Native-II
Internal Identifier: ArchiveFormat
Indicates whether the format in which file revisions are stored.

Archive Path

Values: text
Internal Identifier: ArchivePath
The path to the PVCS archive or VSS project containing a file.

Archive Name (Advanced)

Values: 32-digit hex string representing the MD5 value of the file
Internal Identifier: STArchiveName
For a file stored in a Native-II Valuet, indicates the name of the file that
stores the tip revision. This name is the MD5 value of that file revision's
content, converted to a 32-digit hex string.

Archive Type

Values: Native, PVCS, VSSInternal Identifier: Type
Indicates whether a file is stored as a StarTeam (Native, PVCS, or VSS
file.

Branch On Change (Advanced)

Values: No Yes
Internal Identifier: BranchOnChange
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Field

Description
Indicates if a file will branch when it changes.
The value is No if the file's behavior is not set to Branch On Change.
Reasons for this may be:
•
•
•

The file is in the root or a reference view and the Branch On
Change feature is disabled.
The file is in a branching view but as a result of a change, which,
results in disabling theBranch On Change feature.
The file is in the branching view, but its behavior currently does not
permit it to branch on change. This means that modifications are
checked into the parent view.
Note: If the value is No, the value of the Branch State explains
the No.

Branch State (Advanced)

Values: Branched, Not Branched, Root
Internal Identifier: BranchState
Indicates whether a file has branched in the child view, is still
unbranched (and therefore is part of the parent view), or was created in
the view in which it resides.
The values Branched and Not Branched apply to files in branching
views. The value Root applies to files created in the view in which the
file currently resides.
If the view is a reference view, it reflects the state of the file in the
reference view’s parent.

Comment

Values: text
Internal Identifier: Comment
The initial 2000 characters provided as the reason for changing a file’s
properties or contents are stored in the Short Comment field. The
Comment field stores those 2000 characters and any additional text.
Changing a file’s properties causes the application to create a new
revision.
Note: To include a Link comment, the Comment field is the
value to use in an HTML Report.

CommentID (Advanced)

Values: number
Internal Identifier: CommentID
The ID number assigned to revision comment. Displays -1 if no revision
comment was supplied.

Compression Level

Values: Default, Maximize Compression, Maximize Speed, None
Internal Identifier: Compression
Indicates a file's level of compression.
Default: A compromise between Maximize Compression and Maximize
Speed.
Maximize Compression: The densest possible compression of file
revisions to improve server performance.
Maximize Speed: The fastest possible compression of file revisions to
improve server performance.
None: No compression.
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Field

Description

Configuration Time

Values: date/time
Internal Identifier: ConfigurationTime
Indicates the time to which a file is configured. If you configure a file to
a specific time, this field contains that time. If you configure a file to a
label or promotion state, this field shows either the time at which the
label was created, or the time at which the label associated with the
promotion state was created.

Content Revision

Values: number
Internal Identifier: ContentVersion
The number of times a file has been checked in. If the file is in a child
view, it includes all the content revisions from the parent view in this
number. Each revision appears in the file’s history.

Created By

Values: list of users, <None>
Internal Identifier: CreatedUserID
The name of the user who created the first revision in the view. This is
either the user who added the file to the project, or the user who
checked in the revision that branched.

Created Time

Values: date/time
Internal Identifier: CreatedTime
The time at which the first revision in the view was created.

Deleted By

Values: list of users, <None>
Internal Identifier: DeletedUserID
The name of the user who deleted a file. Because deleted files do not
appear in the list, this information is unavailable to users. Internal Use
Only.

Deleted Time

Values: date/time
Internal Identifier: DeletedTime
The time at which a file was deleted. Because deleted files do not
appear in the list, this information is unavailable to users. Internal Use
Only.

Description

Values: text
Internal Identifier: Description
The description provided for a file at the time it was added to the view,
including any later edits to it.

Dot Notation

Values: text
Internal Identifier: DotNotation
The branch revision number, for example, 1.2.1.0.

End Modified Time (Advanced)

Values: date/time
Internal Identifier: EndModifiedTime
The date and time at which a revision ceased to be the tip revision.
Although this field can be displayed in the upper pane, its value is
always blank. This is because, at any given configuration time, the item
is still the tip revision.
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Field

Description

EOL Character

Values: numeric representation of ANSI character
Internal Identifier: EOL
For internal use only. This field is primarily used to determine an ANSI
character to use when breaking up lines within files for delta storage
with Native-1 Vaults.

Executable

Values: No, Yes
Internal Identifier: Executable
Indicates whether the executable bit should be set for a UNIX file.

Extension

Values: text
Internal Identifier: Extension
Displays the extension of the file. This field is client-calculated.

File Time Stamp at Check-In

Values: date/time
Internal Identifier: Modified
The file’s time stamp at the time it was last checked in.

File Type

Values: ASCII, Binary, Unicode
Internal Identifier: Charset
Indicates whether the file is an ASCII (text), binary, or Unicode.

Flag

Values: No, Yes
Internal Identifier: Flag
Marks or bookmarks files in the upper pane on your workstation. This is
a client-calculated field.

Flag User List (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex
format. For example, [14 00 00 00] indicates a specific user.
Internal Identifier: FlagUserList
Cannot be used in queries. Identifies users who have set flags on a
given item.

Folder

Values: text
Internal Identifier: Folder
The name of the folder with which a file is associated. This is not the
name of the working folder.

Folder Path

Values: text
Internal Identifier: Folder Path (contains spaces)
The path to the folder with which a file is associated. This is not the
path to the working folder. This is a client-calculated field.

Hive ID (Advanced)

Values: number assigned by the Server
Internal Identifier: HiveID
Indicates the ID number of the hive that stores the tip revision for a file
stored in a Native-II Vault.

Item Deleted By

Values: list of users, None
Internal Identifier: ItemDeletedUserID
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Field

Description
The name of the user who deleted this item. Because deleted items do
not appear in the list, this information is unavailable to users. Internal
Use Only.

Item Deleted Time

Values: date/time
Internal Identifier: ItemDeltedTime
The time at which the item was created. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use
Only.

Local Name

Values: text
Internal Identifier: LocalName
Name of the working file. This is a client–calculated field.

Local Path

Values: text
Internal Identifier: LocalPath
Path name to the folder containing the working file. This is a client
calculated field.

Locked By

Values: list of users, <None>
Internal Identifier: ExclusiveLocker
The name of the user who has exclusively locked a file.

MD5 Checksum

Values: byte array; displayed as a bracketed series of numbers in hex
format. The StarTeam client displays only significant zeroes so the 05
and 0A would become just 5 and A, and A–F as a–f.
Internal Identifier: MD5
Cannot be used in queries. The MD5 checksum for the tip revision.

Modified By

Values: list of users, <None>
Internal Identifier: ModifiedUserID
The name of the user who last modified a file.

Modified Time

Values: date/time
Internal Identifier: ModifiedTime
The time at which a file was last modified. The file may have been
checked in or had its properties changed. This has nothing to do with
the working file. Use Local Time Stamp for the time a working file was
last modified.

My Lock

Values: Exclusively Locked By Me, Non-exclusively Locked By Me, Not
Locked By Me
Internal Identifier: MyLock
Indicates whether the current user has the file locked and, if so,
whether that lock is exclusive or not. This is a client-calculated field.

Name

Values: text
Internal Identifier: Name
Displays the name of the file.

New Revision Comment (Advanced)

Values: text
Internal Identifier: NewRevisionComment
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Field

Description
Internal use only. the client uses this value during the item update
process. The field always appears empty if added to the upper pane.
This is a clientcalculated field.

Non-Exclusive Lockers

Values: text
Internal Identifier: NonExclusiveLockers
The names of the users who have locked the file non-exclusively.

Object ID

Values: number
Internal Identifier: ID
Each file is assigned an object ID when it is added to a view. When it is
branched in a child view, it is assigned another object ID. The original
ID belongs to the file in the parent view.

Parent Branch Revision (Advanced)

Values: number
Internal Identifier: PathRevision
The last digit in the branch revision number before a file branched. For
example, if this number is 7, the branch revision was 1.7 at the time the
file branched (becoming 1.7.1.0, as seen in the file’s history). This
number is -1 if a file was not inherited from the parent view.

Parent ID (Advanced)

Values: number
Internal Identifier: ParentObjectID
The object ID of a file in the parent view. The Parent ID is -1 if this view
has no parent view.

Parent Revision (Advanced)

Values:
Internal Identifier: ParentRevision
The revision number at which a file branched. For example, if this
number is 8, this file’s revision number in the parent view was 8 at the
time the file branched. The history should show that revision 9 in the
first revision in the current view. This number is 0 if this file was not
inherited from the parent view.

Path

Values: text
Internal Identifier: Path
The path to a file’s working folder. This is a client-calculated field.

Project ID (Advanced)

Values: number
Internal Identifier: ProjectID
The ID number assigned to a project. Within a server configuration,
projects are assigned ID numbers in the order in which they are
created. The first project has ID 0.

PVCS Revision (Advance)

Values: text
Internal Identifier: PVCSRev
The file’s revision number in PVCS’s dot notation.

Read Only (Advanced)

Values: No, Yes
Internal Identifier: ReadOnly
Indicates whether the file’s configuration is read-only (as in a rollback
configuration of a view) and/or its behavior does not allow it to branch
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Field

Description
on modification. Do not confuse a read-only configuration (an
application issue) with a read-only file (an operating system issue). A
read-only file cannot be edited and saved to disk. A file whose
configuration is read-only can be edited and saved to disk; it just cannot
be checked in.

Revision

Values: number
Internal Identifier: ViewVersion
The number of times a file has been checked in or had its properties
changed. If the file is in a child view, it includes all the revisions from the
parent view in this number. This is a client-calculated field.

Revision Flags (Advanced)

Values: 0
Internal Identifier: RevisionFlags
Internal use only.

Revision on Disk

Values: number
Internal Identifier: SyncPathVersion
The number of the revision that is currently in the working folder on your
workstation. The application displays no number if the file’s status is
Missing. This is a client-calculated field.

Root Object ID (Advanced)

Values: number
Internal Identifier: RootObjectID
The object ID of the oldest ancestor of a file. For example, if a file was
not inherited from a parent view, the root object ID is the same as its
object ID. If it was inherited from a parent view, the root object ID is the
Parent ID, or the parent's Parent ID.

Share State

Values: DerivedShare, Not Shared, Root Share
Internal Identifier: ShareState
Indicates whether this item is shared. Not Shared means that the item
is not shared. Root Share means that the item is shared and this item is
the original (or root) reference. DerivedShare means that the item is
shared, but this item is not the original (or root) reference.

Short Comment

Values: text
Internal Identifier: ShortComment
Stores the initial 2000 characters provided as the reason for changing a
file’s properties or contents. Additional text is stored in the Comment
field.

Size

Values: number
Internal Identifier: FileSize
The tip revision’s size in bytes.

Status

Values: Current, Merge, Missing, Modified, Not In View, Out Of Date,
Unknown
Internal Identifier: Status
Indicates the relationship between the copy of a file in your working
folder and the tip revision in the repository.

Sync Branch Version

Values: number
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Field

Description
Internal Identifier: SyncObjectVersion
A field used to determine status. The last number of the branch revision
that was most recently checked out to the working folder. This is a client
calculated field.

Sync Content Version

Values: number
Internal Identifier: SyncContentVersion
A field used to determine status. The revision checked out as the
working file or, if the file needs to be merged, a number higher than
that. This is a client-calculated field.

Sync Known

Values: No, Yes
Internal Identifier: SyncKnown
A field used to determine status. Indicates whether the server knows
the working file’s relationship to the tip revision. This is a clientcalculated field.

Sync Local Size

Values: number
Internal Identifier: SyncSize
A field used to determine status. The size of the working file in bytes.
This is a client-calculated field.

Sync Local Time Stamp

Values: date/time
Internal Identifier: SyncTime
A field used to determine status. The time stamp for the working file.
This is a client-calculated field.

Sync MD5

Values: byte array; displayed as a bracketed series of numbers in hex
format. The StarTeam client displays only significant zeroes, so 08, 0B,
and 06 would become just 8, B, and 6, and A–F as a–f.
Internal Identifier: SyncMD5
Can not be used in queries. A field used to determine status. The MD5
checksum of the working file. This is a client-calculated field.

Sync On Path To Root

Values: No, Yes
Internal Identifier: SyncOnPathToRoot
A field used to determine status. When the working file is not based on
the tip revision, this field indicates whether the server knows the
relationship between the two. A Yes value in this field means that the
working file needs to be merged or is out of date. A No value means
that the relationship cannot be determined. This is a client-calculated
field.

Vault Branch Version (Advanced)

Values: number
Internal Identifier: VaultVersion
The number of times a file has been checked in from the current view.

Version (Advanced)

Values: number
Internal Identifier: RevisionNumber
The last number in the branch revision number. For example, if the
branch revision number is 1.3.1.2, the version is 2.
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Field

Description

View

Values: list of views, <None>
Internal Identifier: ViewID
The name of the view in which the item last branched. For example, if a
file is inherited from a parent view but is branched in a child view, the
value of this field in the child view changes from the name of the parent
view to the name of the child view for the revision that branched and
subsequent revisions in the child view.

Working File Executable

Values: text
Internal Identifier: No, Yes
Indicates whether the working file is executable. This is a clientcalculated field.

Working File Exists

Values: No, Yes
Internal Identifier: LocalFileExists
Indicates whether a copy of a file is in its working folder. This is a
clientcalculated field.

Working File Size

Values: number
Internal Identifier: LocalSize
The size of the working file. This is a client-calculated field.

Working File Time Stamp

Values: date/time
Internal Identifier: LocalTimestamp
The time stamp of the working file. This is a client-calculated field.

Provider Properties
This topic presents the StarTeam Provider properties and their descriptions as displayed in the Provider
Properties dialog box when opened from the context menu. The information in the Provider Properties
dialog box is different for each type of selected, shared resource: project, folder, or file.
Shared Project
The following properties are displayed for the shared project.
Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

Change Sharing

Opens the Share a Project dialog box where you can
change the sharing options.

Change View

Opens the Select a StarTeam View dialog box where
you can change which view you are sharing.
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Property

Description

Change Kind

Reveals the types and directions of changes that can be
found in any resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
folder used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server. It is possible for the dot-notation
to be higher, indicating a newer version is available in the
repository.

Shared Folder
The following properties are displayed for the shared folder.
Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

Change Kind

Reveals the types and directions of changes that can be
found in any resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
folder used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server. It is possible for the dot-notation
to be higher, indicating a newer version is available in the
repository.

Convert Change Kind To

Allows you to invert the direction and type of a deletion or
an addition. This is sometimes necessary when a project
was re-shared or hooked up with another view. Changes
on the server or in the workspace may be interpreted
assuming the wrong intention. A folder listed as
[outgoing deletion] may simply have been added to the
view by another developer at some time, and thus be
considered an [incoming addition]. The two buttons,
Incoming Deletion and Outgoing Addition, allow you to
change

Shared File
The following properties are displayed for the shared file.
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Property

Description

Server Description

Displays the name of the Server on which the shared
project is located.

Project Name

Displays the name of the selected shared project.
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Property

Description

View Name

Displays the name of the view which contains the shared
project.

Folder

Displays the folder on the server that is used for sharing.

MD5:

Displays the current MD5 hash value for the local
revision.

Stored Remote MD5:

Displays what the provider remembers the MD5 hash
value to have been at the last check in or check out.

Current Remote MD5:

Displays the MD5 hash value for the tip revision. By
comparing the stored MD5 hash value with the current
MD5 hash value, the provider can detect incoming
changes in spite of differing remote and local MD5 values
due to EOL differences.

Base Modification Timestamp:

Shows the last date and time the local and remote files
were current.

Local Modification Timestamp

Shows the date and time of the last modification to the
local file.

Remote Modification Timestamp:

Shows the date and time of the last modification to the
remote file.

Change Kind

Reveals the types and directions of changes that can be
found for any file resource within the project. If it reads [in
sync], there are no files and folders that are not "current".

Base Bytes

Shows both the dot-notation and the ID for the StarTeam
file used for sharing.

Remote Bytes

Shows the same as Base Bytes, but reflects the current
situation on the Server (tip revision). It is possible for the
dot-notation to be higher, indicating a newer version is
available in the repository.

Convert Change Kind To

Allows you to invert the direction and type of a deletion or
an addition. This is sometimes necessary when a project
was re-shared or hooked up with another view. Changes
on the server or in the workspace may be interpreted
assuming the wrong intention. A folder listed as
[outgoing deletion] may simply have been added to the
view by another developer at some time, and thus be
considered an [incoming addition]. The two buttons,
Incoming Deletion and Outgoing Addition, allow you to
change.

Stored EOL Conversion

Specifies which EOL (End of Line) conversion settings to
store. When you click OK or Apply after changing this
setting, the MD5 values will be recomputed and the
status refreshed in an attempt to identify the type of
change.
Note: The StarTeam Eclipse Client uses MD5
hash values exclusively for status computation,
therefore it needs to remember which EOL
conversion was in effect at the last check in or
check out so it can adjust the computed MD5.
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Change Requests
A change request is a request to change something within the scope of a project. For example, you might
suggest a product enhancement or request a fix for an error or problem. To use the change request
tracking system effectively, you need to understand the model on which it is based.
The change request component allows you to:
•

•

•

•

Attach change requests to any folder. In the application, change requests can be attached to any
application folder or shared to other application folders in other views within the server configuration.
You can also link a change request to any other item, such as a file.
Make only appropriate status changes. When you create a change request, the status options are New,
Open, Deferred or a resolution. The resolutions are Cannot Reproduce, As Designed, Fixed,
Documented, and Is Duplicate. After resolution, a change request can only be verified or reopened.
After verification, a change request can only be closed or reopened.
Benefit from automatic changes based on the status of the change request. The application
automatically changes the person responsible to coincide with the current status of the change request.
When a change request is resolved, the responsibility for the change request automatically reverts to
the person who entered the change request, who is usually the best person to verify its resolution.
When a change request is reopened after being resolved, the responsibility is automatically set to the
user who resolved it. If desired, you can override these automatic changes and make another person
responsible.
Base change requests on the build in which the change request is resolved. When a change request
receives a Fixed or Documented status, the value of its Addressed In Build field becomes Next Build.
When that build label is created, the application replaces Next Build with the name of the build label,
letting testers know the build to use when verifying change requests.
Note: This help system explains how to use the standard property dialog to create and edit change
requests. Depending on how your team has set up the application, you may see a different dialog
called an alternate property editor (APE). Even if you use the standard property dialog for change
requests, your company or team leader may implement change request guidelines that differ from
those discussed in this help system.

Change Request Tracking System Model

The above diagram and steps show the change request tracking process. The boxes represent the steps
taken from the time that the change request is submitted until the time it is closed. Each box indicates an
action and the team member most likely to be responsible for performing this action. The arrows show the
status of the change request at the time of each step.
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The change request tracking system consists of the following steps:
1. A team member creates a new change request that does either of the following:
•
•

Summarizes a problem with the product and lists the steps taken to reproduce the problem.
Suggests an enhancement to the product.
Note: This change request has a status of New.

2. Another person, such as an administrator or team leader, decides whether to fix the problem or add the
suggested enhancement to the product. This person can:
•
•
•

•

Set the status of the change request to Open, and assign a team member to resolve it.
Set the status of the change request to Deferred because it is worthwhile but will not be done at this
time.
Set the status of the change request to Is Duplicate because this is not the first time it has been
submitted. If desired, a link can be created between a change request and the original submission
so that you can track the change request along with the original submission.
Set the status of the change request to As Designed because the product is supposed to work this
way, meaning there is no defect.
Note: Change requests with an Open status go to step 3.

3. The person assigned to resolving the change request changes the status of the change request to In
Progress. Later on, after this person finishes examining the change request, he or she changes the
status to one of the following:
• Fixed
• Documented
• Cannot Reproduce
4. Next, a team member (usually a tester or quality assurance engineer) verifies the change request. For
example, a test case may be developed to determine if the problem is really fixed, documented or not
reproducible and changes the status to one of the following verified statuses:
• Verified As Designed
• Verified Cannot Reproduce
• Verified Documented
• Verified Fixed
• Verified Is Duplicate
5. Finally, another team member changes the status to Closed. This person may then perform activities
related to closing the change request, such as retesting the change request before closing it or adding it
to a report to be included in the next release of the product.
In most of the above steps, the change request can be reopened and reprocessed.

Change Request Status Field
StarTeam's built-in workflow for change requests is based on the setting of the Status field for the change
request. For this reason, you cannot add additional settings to the Status field. However, you can rename
them to better suit preferences set by your organization. For example, your organization may prefer to
change the name of the status New to New Change Request.
When you alter the status of a change request, the built-in workflow automatically selects the appropriate
properties associated with the change in status.
After selecting New, Open, or In Progress, six new statuses display in the Status drop-down list box. These
statuses, which are associated with the status you selected, are:
•

Deferred
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•
•
•
•
•

Cannot Reproduce
As Designed
Fixed
Documented
Is Duplicate

Change Request Lifecycle

The above diagram shows the lifecycle for a change request with an initial status of Open. The status was
then set to Fixed. After this setting, the built-in workflow added an additional status field of Verified Fixed.
Finally, the change request was closed, meaning its status was set to Closed (Fixed).
The diagram also shows that a change request can be reopened at any stage in its lifecycle because the
arrows leading from each of the three fixed statuses can lead back to the Open status at any time.

Change Request Built-in Workflow
The following table summarizes the steps used in processing change requests. It includes the built-in
workflow changes the application makes to change requests based on their statuses.
Step

Description

Submit

Anyone (usually a tester or quality assurance engineer)
can submit a change request. Process: Open the Change
Request view, and choose New from the context menu. A
change request has the following default properties
(which you can change if necessary).
•
•
•
•
•

Status: New
Severity: Low
Priority: Not prioritized
Type: Defect
Platform: All

•
•

Last Build Tested: Current build label
Entered by: Person currently logged on to the
application

Many other fields are initially blank. Some team leaders
prefer to have all change requests submitted at the root
folder. They use drag-and-drop to move the change
requests to the appropriate child folders.
Assign
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Process: The team leader finds all new change requests
and does one of the following:

Step

Description
•

•
•

Opens the change request and assigns it to a
developer, help writer, or other appropriate team
member.
Defers the change request until a later date, perhaps
the next release of the product.
Specifies that the change request is As Designed and
not to be fixed.

If the change request status is Open, no automatic
changes occur. If the change request status is Deferred
or As Designed, then Addressed in Build is disabled and
the responsibility is assigned to the user who created the
change request.
Resolve

Process: Users find the Open or In Progress change
requests assigned to them, and do one of the following
for each request:
•

•

Resolve the problem in the system and update the
properties of the change request. (The statuses that
indicate that a change request has been resolved are
Cannot Reproduce, As Designed, Fixed,
Documented, or Is Duplicate.)
Defer the change request until a later date, perhaps
the next release of the product.

If the change request status is one of the possible
resolution statuses, then Addressed in Build becomes
Next Build for Fixed and Documented statuses. It
becomes disabled for other statuses.
By default, the responsibility is assigned to the person
who submitted the change request, who is expected to
verify the resolution.
If the change request status is Deferred, then Addressed
in Build is disabled and the responsibility is assigned, by
default, to the user who created the change request.
Build

Who builds the project? The project view may have a
formal or informal build process. At some point, a build
label is created and becomes attached to all the items in
the view at that time.
Effect on change requests: For any resolved change
request that has Next Build as the setting for its
Addressed In Build property, Next Build is replaced with
the next build label that is created.
Note: If a new build label is based on a past
configuration (rather than the current
configuration), it has no effect on the Addressed In
Build property.
If a change request has not branched in its current
location, Next Build may be replaced with a build label
from another view. For example, suppose you create a
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Step

Description
branching child view or share a folder from one view to
another. Suppose that Next Build is the value of some
change request's Addressed In Build property and that
change request has not branched. When a build label is
created in the source view, Next Build is replaced with the
name of that build label, regardless of the location.

Verify

The person who submitted the change request (usually a
tester or quality assurance engineer) verifies a resolution.
Process: Install the build in which the resolution is to be
verified and determine whether the change request has
been resolved correctly. Do one of the following:
•

•

Verify the change request, marking it as Verified
Cannot Reproduce, Verified As Designed, Verified
Fixed, Verified Documented, or Verified Is Duplicate.
Reopen the change request and update the setting for
Last Build Tested.

If the change request status is Verified, no automatic
changes occur.
If the change request status is Open, Addressed in Build
is blank. If the change request has changed from
resolved to Open, the user who changed the status to
Fixed or Documented becomes responsible.
Close

Usually the team leader closes the change request.
Process: The team leader does one of the following:
•

Reviews and closes the verified change request.

•

Reopens the change request.

If the change request status is Closed, then no automatic
changes occur.
If the change request status is Open, then Addressed in
Build is blank. If the change request has changed from
resolved to Open, the user who changed the status to
Fixed or Documented becomes responsible.
If the status of a change request changes from Verified to
Open, the user who changed the status to Fixed or
Documented becomes responsible and Addressed in
Build is blank.

Note: Changes in status can result in automatic changes to other properties.

Default and Required Change Request Fields
The following table lists the fields on the Change Request dialog box, explains their uses, and indicates
which fields are required. In the table, CR is used as an acronym for change requests.
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Field

Required?

Description

Example

Status

Y

For new CRs, set the
In this example, the status
Status field to New. The
should be New.
Status is changed to Open
when the CR is assigned to
a developer.

Severity

Y

Specify the seriousness of
the problem. High severity
items are usually
associated with data loss or
corruption, system crashes,
etc. Low severity items are
generally misspelled items
and cosmetic errors.

Priority

Y

In most defect tracking
In this example, leave the
systems, Priority is a multi- Priority field cleared.
level choice (usually on a 1
to 5 scale). In StarTeam,
however, it is a Yes or No
choice. The priority of a CR
is sometimes determined by
the tester and sometimes
by the developer. In most
cases, it reflects the need to
get a particular defect fixed
before others. If the defect
is catastrophic or prevents
your team from accessing
other major areas of the
application, select the
Priority field.

Platform

Y

Indicate what type of
operating system
environment the defect
occurs in. If the defect
happens only on Windows
NT, select Windows NT. In
most cases, the defect will
appear on all platforms.

In this example, set
Platform to All.

External Reference

N

Specify information
received from outside the
company, such as a note
about a defect from an
outside testing service or a
customer. Currently this
field is not used.

In this example, leave the
field empty.

Component

N

Identify the component of
the product in which the
defect occurs.Currently this
field is not used.

In this example, leave the
field empty.

Category

N

Identify a subcomponent of In this example, leave the
the product. It is used with
field empty.
the Component field to
identify the location in which
the defect occurs.Currently
this field is not used.

In this example, the
problem is comparatively
minor (that is, if it does not
cause the system to crash
or lose data), so classify it
as Medium.
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Field

Required?

Description

Example

Synopsis

Y

Use to give a brief summary
of the problem encountered
or the suggested
enhancement. Consider the
synopsis to be a title for the
defect.

For this example, a
synopsis might be:

"Available fields
disappear when
using the Advanced
Fields box."

Note: The Synopsis
should only contain
information for one
defect. If the
reported defect
uncovers or relates
to another defect,
the second defect
should be written up
separately and
referenced to the
first defect in the
synopsis (for
example, "CR

#3109 also
relates to
this defect").
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Type

Y

If the CR is a reproducible
problem in the software,
select Defect. If it is a
customer request or a
feature enhancement
request, select
Suggestion.

Last Build Tested

Y

Indicate the build number of For this example, select the
the software in which the
most current build number.
defect was discovered or
last tested. If you are writing
a CR, select the build
number from the application
(often found in the About
dialog box). If you are
verifying or regressing the
CR, and the problem still
exists in the current build,
change this field to the build
number you are currently
testing.

Addressed in Build

Y

Indicate the build in which
For this example, leave the
the fix first appears. In most field empty.
cases, after the engineer
fixes the defect, the field will
be set to Next Build. This
field changes to the correct
build when that version is
actually built.

Responsibility

N

Indicate the person who
should act on the defect.
Depending on the position
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For this example, select
Defect.

For this example, either
leave this field blank, or
assign it to the lead

Field

Required?

Description

Example

of the CR in the CR life
engineer on the project,
cycle, this person could be who will assign it to the
a developer, a QA
appropriate person.
engineer, or the person who
first reported the CR.
Addressed by

Y

This field is automatically
NA
filled with the name of the
person who originally wrote
up the CR. It is not editable.

Description/Steps to
Reproduce

Y

Select the Description tab.
In the Description/ Steps
to Reproduce field, enter
detailed information about
the defect. Specifically, the
description should build on
the synopsis
information.The Steps to
Reproduce information is
the most important data
entered in the CR because
it provides a detailed stepby-step method of
reproducing the defect. The
more detailed the
information, the more likely
the responsible developer
will be able to determine the
cause of the defect and fix
the defect.

Steps to Reproduce might
look as follows:
1. RClick the column
headers in the upper
pane.
2. Select Show Fields.
3. LClick Show Advanced
Fields check box. // The
check box is activated.
4. LClick Show Advanced
Fields check box. // The
check box is
deactivated.
5. EXP: The standard
fields appear in the
Available Fields list
box.
6. ACT: No fields appear
in the Available Fields
list box.

Commonly Used Change Request Abbreviations
When using a defect tracking system, most organizations employ a special syntax or shorthand to describe
the steps required to reproduce a problem.
Shorthand

Description

1, 2, 3,...

Number the steps.

LClick

Click the left mouse button.

RClick

Click the right mouse button.

DClick

Double click the left mouse button.

[]

A keyboard button to be pressed.
For example, [F1] for Help or [F5] for Refresh.

<>

A dialog button.
For example: Press <OK> or <Cancel>.

>

Menu separator.
For example: Select File > Open or Topic >
Tools > Reports.
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Shorthand

Description

//

A comment that is not an actual step.
For example: 3) LClick the field. // At

this point my machine started to
smoke.
EXP

Expected results.
For example: EXP: The focus moves to the
next field.

ACT

Actual results.
For example: ACT: The application crashes.

Change Request Properties
The Change Request Properties dialog box contains the following tabbed pages of properties.
Synopsis
The following properties are on the Synopsis page.
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Property

Description

Status

Displays the status of the change request.

Priority

Displays the priority level of the change request. Many
people use repository customization to extend this field to
include other values because Boolean values in the
application are treated as enumerated types. For
example, No is 0 and Yes is 1. An administrator might
change No to Not A Priority, Yes to Priority 1, and add
Priorities 2 through 10.

Type

Displays the type of change request, a Defect or a
Suggestion.

Severity

Indicates the severity of the change request: Low,
Medium, or High.

Platform

Indicates which operating system platform the to which
the change request applies.

Last Build Tested

Displays the build label selected by a user to represent
the last build in which a change request was tested.

External Reference

Indicates the customer or other outside source who
provided the data for this change request.

Addressed In Build

Indicates the next build label created and applied to the
view after the resolution to a change request occurs.

Component

Displays the component in which the defect occurs. It is
often used with the Category property to narrow that
identification to a subcomponent.

Category

Displays the name of the subcomponent in which the
defect occurs. It is usually used in combination with the
Component property.

Synopsis

Displays a brief description of the change request.
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Property

Description

Responsibility

Displays the name of the person currently responsible for
the change request.

Entered By

Displays the name of the person who entered the change
request.

Description
This page also contains Browse button for locating the command to test, and a Run button for running the
test. The following properties are on the Description page.
Property

Description

Description And Steps To Reproduce

Displays a complete, detailed description of the change
request.

Test Command

Displays the command to use to test the solution for the
change request.

Solution
The following properties are on the Solution page.
Property

Description

Work Around

Explains the solution to the change request other than the
fix.

Fix

Displays the solution to the problem addressed by the
change request.

Custom
You can create custom properties for an item which will display in the item Properties dialog box. The
following properties are on the Custom page.
Property

Description

Property

Displays each custom property name.

Value

Displays the values for each custom property. Doubleclick the property name to edit the value.

Attachments
The Attachments page contains a list of all the files attached to the current change.
Comment
The following properties are on the Comment page.
Property

Description

Comment For This Revision

Displays the reason for the changes to the current
revision.

Comment For New Revision

Displays the reason for the changes to the new revision.

Sample Change Request Detail View Template
Use the following sample for customizing the Detail view for the change request component.
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Cut and paste the HTML contents below into a file named changerequest.details.html, and place it
in the Application Data\Borland\StarTeam folder for the current user. For example, on a
Windows system, this file would be located in the C:\Documents and Settings\USER\Application
Data\Borland\StarTeam folder.
Sample Change Request HTML Template
<html>
<head></head>
<body>
<table width=100% border=1>
<tr bgcolor=#aabbcc>
<th>CR Number</th>
<th>Status</th>
<th>Priority</th>
<th>Type</th>
<th>Responsibility</th>
</tr><tr>
<td align=center>~~ChangeNumber~~</td>
<td align=center>~~Status~~</td>
<td align=center>~~Priority~~</td>
<td align=center>~~Type~~</td>
<td align=center>~~Responsibility~~</td>
</tr>
</table>
<p align=right
<b>Entered By</b>: ~~EnteredBy~~, ~~EnteredOn~~ </p>
<b>Synopsis</b>:<br> ~~Synopsis~~ <br><br>
<b>Description</b>:<br> ~~Description~~ <br><br>
<b>Work Around</b>:<br> ~~WorkAround~~ <br><br>
<b>Fix</b>: ~~Fix~~<br> <br><hr>
<i>Last modified by: ~~ModifiedUserID~~, ~~ModifiedTime~~</i><br>
<b>Number of attachments</b>: ~~AttachmentCount~~<br>
<!-<b>Flag User List</b>: ~~FlagUserList~~<br>
<b>Version</b>: ~~RevisionNumber~~<br>
<b>Branch State</b>: ~~BranchState~~<br>
<b>Read Status User List</b>: ~~ReadStatusUserList~~<br>
<b>Branch On Change</b>: ~~BranchOnChange~~<br>
<b>Attachment IDs</b>: ~~AttachmentIDs~~<br>
<b>Closed On</b>: ~~ClosedOn~~<br>

182

| Borland StarTeam Eclipse Client

<b>Component</b>: ~~Component~~<br>
<b>Parent ID</b>: ~~ParentObjectID~~<br>
<b>Root Object ID</b>: ~~RootObjectID~~<br>
<b>Created Time</b>: ~~CreatedTime~~<br>
<b>Share State</b>: ~~ShareState~~<br>
<b>CommentID</b>: ~~CommentID~~<br>
<b>Folder</b>: ~~Folder~~<br>
<b>Created By</b>: ~~CreatedUserID~~<br>
<b>Deleted Time</b>: ~~DeletedTime~~<br>
<b>Dot Notation ID</b>: ~~DotNotationID~~<br>
<b>Parent Revision</b>: ~~PathRevision~~<br>
<b>Last Build Tested</b>: ~~LastBuildTested~~<br>
<b>Non-Exclusive Lockers</b>: ~~NonExclusiveLockers~~<br>
<b>Short Comment</b>: ~~ShortComment~~<br>
<b>Locked By</b>: ~~ExclusiveLocker~~<br>
<b>Folder Path</b>: ~~Folder Path~~<br>
<b>Object ID</b>: ~~ID~~<br>
<b>Flag</b>: ~~Flag~~<br>
<b>Platform</b>: ~~Platform~~<br>
<b>Severity</b>: ~~Severity~~<br>
<b>Read Only</b>: ~~ReadOnly~~<br>
<b>My Lock</b>: ~~MyLock~~<br>
<b>Configuration Time</b>: ~~ConfigurationTime~~<br>
<b>Comment</b>: ~~Comment~~<br>
<b>Revision Flags</b>: ~~RevisionFlags~~<br>
<b>Parent Branch Revision</b>: ~~ParentRevision~~<br>
<b>External Reference</b>: ~~ExternalReference~~<br>
<b>Category</b>: ~~Category~~<br>
<b>End Modified Time</b>: ~~EndModifiedTime~~<br>
<b>New Revision Comment</b>: ~~NewRevisionComment~~<br>
<b>Addressed In</b>: ~~AddressedIn~~<br>
<b>Resolved On</b>: ~~ResolvedOn~~<br>
<b>View</b>: ~~ViewID~~<br>
<b>Addressed In View</b>: ~~AddressedInView~~<br>
<b>Addressed By</b>: ~~AddressedBy~~<br>
<b>Verified On</b>: ~~VerifiedOn~~<br>
<b>Deleted By</b>: ~~DeletedUserID~~<br>
<b>Test Command</b>: ~~TestCommand~~<br>
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<b>Attachment names</b>: ~~AttachmentNames~~<br>
<b>Dot Notation</b>: ~~DotNotation~~<br>
<b>Read Status</b>: ~~ReadStatus~~<br>
-->
</body>
</html>
Fields Used in Detail View Templates
The fields used in the Detail view HTML templates are recognized by the client when they are contained
between double tilde ~~ characters. For example: ~~Status~~ represents the Status field found in the
Change Request Properties dialog box. Refer to the link at the bottom of this topic for more information
about the fields that you can use in the Detail view templates.

Change Request Fields
This section lists all the change request fields in alphabetical order.
Field

Description

Addressed By

Values: list of users, <None>
Internal Identifier: AddressedBy
Indicates the user who resolved a change request (resolved statuses are
Cannot Reproduce, As Designed, Fixed, Documented, and Is Duplicate).

Addressed In

Values: list of view labels, <None>
Internal Identifier: AddressedIn
Indicates the next build label created and applied to the view after the
resolution to a change request occurs.

Addressed In View

Values: list of views, <None>
Internal Identifier: AddressedIn
View Indicates in what view the change request has been resolved. This is
important for shared, and perhaps moved, change requests.

Attachment Count

Values: number
Internal Identifier: AttachmentCount
The number of files attached to a change request.

Attachment IDs (Advanced)

Values: Values: byte array; displayed as a bracketed series of numbers in
hex format. For example, [00 00 00 00 02 00 00 00] indicates two
specific attachments.
Internal Identifier: AttachmentIDs
Cannot be used in queries. The ID numbers assigned to attachments. For
example, the first attachment within a project is 00 00 00 00.

Attachment Names

Values: text containing a series of file names separated by spaces
Internal Identifier: AttachmentNames
The names of the files attached to a change request.

Branch On Change (Advanced)

Values: No, Yes
Internal Identifier: BranchOnChange
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Field

Description
Indicates whether a change request will branch when it changes.The value is
No if the change request's behavior is not set to Branch On Change.
Reasons for this may be:
•
•

•

•

The change request is in the root or a reference view and the Branch
On Change feature is disabled.
The change request is in a branching view but has already branched as a
result of a change, which, in turn, results in the Branch On Change
feature becoming disabled.
The change request is in a branching view, but its behavior currently does
not permit it to branch on change. This means that modifications are
checked into the parent view.
The change request is in a branching view, but its behavior currently does
not permit it to branch on change. This means that modifications are
checked into the parent view.
Note: If the value is No, the value of the Branch State explains
the No.

The value Yes indicates that the change request resides in a branching
view, has its behavior set to Branch On Change, but has yet to be
changed.
Branch State (Advanced)

Values: Branched, Not Branched, Root
Internal Identifier: BranchState
Indicates whether a change request has branched in the child view, is still
unbranched and, therefore, a part of the parent view, or was created in the
view in which it resides.
The values Branched and Not Branched apply to change requests in
branching views.
The value Root applies to files created in the view in which the change
request currently resides.
If the view is a reference view, it reflects the state of the change request in
the reference view's parent.

Category

Values: text
Internal Identifier: Category
Text identifying the subcomponent in which the defect occurs. It is usually
used in combination with the Component field.

Closed On

Values: date/time
Internal Identifier: ClosedOn
The date and time at which a change request was closed.

Comment

Values: text
Internal Identifier: Comment
The initial 2000 characters provided as the reason for changing a change
request's properties are stored in the Short Comment field. The Comment
field stores those 2000 characters and any additional text. Changing a
change request's properties causes the application to create a new revision.

CommentID (Advanced)

Values: number
Internal Identifier: CommentID

Borland StarTeam Eclipse Client

| 185

Field

Description
The ID number assigned to revision comment. Displays -1 if no revision
comment was supplied.

Component

Values: text
Internal Identifier: Component
Text identifying the component in which the defect occurs. It is often used
with the Category field to narrow that identification to a subcomponent.

Configuration Time

Values: date/time
Internal Identifier: ConfigurationTime
Indicates the time to which a change request is configured. If you configure a
change request to a specific time, this field contains that time. If you
configure a change request to a label or promotion state, this field shows
either the time at which the label was created or the time at which the label
associated with the promotion state was created.

CR Number

Values: number
Internal Identifier: ChangeNumber
The number assigned to a change request. For example, if the Object ID
is 0, the change request number is 1.

Created By (Advanced)

Values: list of users, <None>
Internal Identifier: CreatedUserID
The name of the user who created the first revision in the view. This is either
the user who initiated the change request or the user who modified the
revision that branched.

Created Time (Advanced)

Values: date/time
Internal Identifier: CreatedTime
The time at which the first revision in the view was created.

Deleted By

Values: list of users, <None>
Internal Identifier: DeletedUserID
The name of the user who deleted a change request. Because deleted
change requests do not appear in the list, this information is unavailable to
users. Internal Use Only.

Deleted Time

Values: date/time
Internal Identifier: DeletedTime
The time at which a change request was deleted. Because deleted change
requests do not appear in the list, this information is unavailable to users.
Internal Use Only.

Description

Values: text
Internal Identifier: Description
The text in the Description field.

Dot Notation

Values: text
Internal Identifier: DotNotation
The ID assigned to a particular branch revision number. For example, if a
change request was added to the current view (as opposed to inherited by
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Field

Description
the current view), its branch revision number is 1.x and its branch revision
ID is 0. If a change request was branched in the current view, its branch
revision ID is dependent on the revision number in the parent view and the
number of IDs already assigned in the current view. For example, if a change
request's revision number in the parent view is 1.7 at the time of the branch,
and another change request with that same parent revision number was
given the Branch Revision ID 6, this change request will also be given the
Branch Revision ID 6.

End Modified Time (Advanced)

Values: date/time
Internal Identifier: EndModifiedTime
The date and time at which a revision ceased to be the tip revision. Although
this field can be displayed in the view, its value is always blank. This is
because, at any given configuration time, the item is still the tip revision.

Entered By

Values: list of users, <None>
Internal Identifier: EnteredBy
The name of the user who created this change request.

Entered On

Values: date/time
Internal Identifier: EnteredOn
The time at which this change request was created.

External Reference

Values: text
Internal Identifier: ExternalReference
Text usually used to indicate a customer or other outside source who
provided the data for this change request.

Fix

Values: text
Internal Identifier: Fix
The text in the Fix field.

Flag

Values: No, Yes
Internal Identifier: Flag
A flag specifically marks/bookmarks change requests in the view on your
workstation. This is a client-calculated field.

Flag User List (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: FlagUserList
Cannot be used in queries. Identifies users who have set flags on a given
item.

Folder

Values: text
Internal Identifier: Folder
The name of the folder that stores the change request. This is a clientcalculated field.

Folder Path

Values: text
Internal Identifier: Folder Path (contains spaces)
The path to the folder that stores the change request. This is a clientcalculated field.
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Field

Description

Item Deleted By

Values: list of users, None
Internal Identifier: ItemDeletedUserID
The name of the user who deleted this item. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Item Deleted Time

Values: date/time
Internal Identifier: ItemDeletedTime
The time at which the item was created. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Last Build Tested

Values: list of view labels, <None>
Internal Identifier: LastBuildTested
The build label selected by a user to represent the last build in which a
change request was tested.

Locked By

Values: list of users, <None>
Internal Identifier: ExclusiveLocker
The name of user who has exclusively locked a change request.

Modified By

Values: list of users, <None>
Internal Identifier: ModifiedUserID
The name of the user who last modified a change request.

Modified Time

Values: date/time
Internal Identifier: ModifiedTime
The time at which a change request was last modified.

My Lock

Values: Exclusively Locked By Me, Non-exclusively
Locked By Me, Not Locked By Me
Internal Identifier: MyLock
Indicates whether the current user has the change request locked and, if so,
whether that lock is exclusive or not. This is a client-calculated field.

New Revision Comment (Advanced)

Values: text
Internal Identifier: NewRevisionComment
Internal use only. The client uses this value during the item update process.
The field always appears empty if added to the view. This is a clientcalculated field.

Non-Exclusive Lockers

Values: text
Internal Identifier: NonExclusiveLockers
The names of the users who have locked the change request nonexclusively.

Object ID

Values: number
Internal Identifier: ID
Each change request is assigned an object ID when it is added to a view.
When it is branched in a child view, it is assigned another object ID. The
original ID belongs to the change request in the parent view.

Parent Branch Revision (Advanced)
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Values: number

Field

Description
Internal Identifier: PathRevision
The last number in the branch revision number before a change request
branched. For example, if this number is 7, the branch revision was 1.7 at the
time the change request branched (becoming 1.7.1.0, as seen in the change
request's history). This number is -1 if a change request was not inherited
from the parent view.

Parent ID (Advanced)

Values: number
Internal Identifier: ParentObjectID
The object ID of a change request in the parent view. The Parent ID is -1 if
this view has no parent view.

Parent Revision (Advanced)

Values: number
Internal Identifier: ParentRevision
The revision number at which a change request branched. For example, if
this number is 8, this change request's revision number in the parent view
was 8 at the time the change request branched. The history should show that
revision 9 in the first revision in the current view. This number is 0 if this
change request was not inherited from the parent view.

Platform

Values: All, MacOS, Other, Unix, Windows 2000,
Windows 95, Windows 98, Windows NT, Windows XP
Internal Identifier: Platform
The value of the Platform field.

Priority

Values: No, Yes
Internal Identifier: Priority
The value of the Priority field. Many people use repository customization to
extend this field to include other values because Booleans in the application
are treated as enumerated types. For example, No is 0 and Yes is 1. An
administrator might change No to Not A Priority, Yes to Priority 1,
and add Priority 2 through Priority 10.

Read Only (Advanced)

Values: No, Yes
Internal Identifier: ReadOnly
Indicates whether the change request's configuration is read-only (as in a
rollback configuration of a view) and/or its behavior does not allow it to
branch on modification.

Read Status

Values: Read, Unread
Internal Identifier: ReadStatus
Indicates whether a change request is considered read or not read. This is a
client-calculated field.

Read Status User List

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: ReadStatusUserList
Can not be used in queries. Identifies users for whom a given item's status is
Unread.

Resolved On

Values: date/time
Internal Identifier: ResolvedOn
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Field

Description
The time at which a change request was resolved. The resolution can be:
Cannot Reproduce, As Designed, Fixed, Documented, or Is Duplicate.

Responsibility

Values: list of users, <None>
Internal Identifier: Responsibility
The name of the user who is currently responsible for a change request.

Revision Flags (Advanced)

Values: 0
Internal Identifier: RevisionFlags
Internal use only.

Root Object ID (Advanced)

Values: number
Internal Identifier: RootObjectID
The object ID of the oldest ancestor of a change request. For example, if a
change request was not inherited from a parent view, the root object ID is the
same as its object ID. If it was inherited from a parent view, the root object ID
is the Parent ID, or the parent's Parent ID.

Severity

Values: High, Low, Medium
Internal Identifier: Severity
The value of the Severity field.

Share State

Values: DerivedShare, Not Shared, Root Share
Internal Identifier: ShareState
Indicates whether this item is shared. Not Shared means that the item is not
shared. Root Share means that the item is shared and this item is the
original (or root) reference. DerivedShare means that the item is shared,
but this item is not the original (or root) reference.

Short Comment

Values: text
Internal Identifier: ShortComment
Stores the initial 2000 characters provided as the reason for changing a
change request's properties. Additional text is stored in the Comment field.

Status

Values: New, Open, In Progress, Deferred, Cannot
Reproduce, As Designed, Fixed, Documented, Is
Duplicate, Verified Deferred, Verified Cannot
Reproduce, Verified As Designed, Verified Fixed,
Verified Documented, Verified Is Duplicate, Closed
Deferred, Closed Cannot Reproduce, Closed As
Designed, Closed Fixed, Closed Documented, Closed
Is Duplicate
Internal Identifier: Status
The value of the Status field.

Synopsis

Values: text
Internal Identifier: Synopsis
The value of the Synopsis field.

Test Command

Values: text
Internal Identifier: TestCommand
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Field

Description
The text in the Test Command field.

Type

Values: Defect, Suggestion
Internal Identifier: Type
The value of the Type field.

Verified On

Values: date/time
Internal Identifier: VerifiedOn
The time at which a change request was verified. The resolution can be
Verified Cannot Reproduce, Verified As Designed, Verified Fixed,
Verified Documented, or Verified Is Duplicate.

Version (Advanced)

Values: number
Internal Identifier: RevisionNumber
The last number in the branch revision number. For example, if the branch
revision number is 1.3.1.2, the version is 2.

View

Values: list of views, <None>
Internal Identifier: ViewID
The name of the view in which the item last branched. For example, if a
change request is inherited from a parent view but is branched in the child
view, the value of this field in the child view changes from the name of the
parent view to the name of the child view for the revision that branched and
subsequent revisions in the child view.

Work Around

Values: text
Internal Identifier: WorkAround
The text in the Work Around field.

Working with Change Requests
This section contains tasks related to working with change requests.

Creating Change Requests
Development teams create change requests to record problems and enhancement requests, and track
their resolution or implementation. Many teams have adopted specific guidelines that govern the creation
and content of change requests.
1. Open a StarTeam perspective, and select the Change Request view.
2. Right-click inside the Change Request view and choose New... .
Alternative: Right-click inside the Change Request view and choose New in Editor.
The Change Request dialog box opens.
3. In the Change Request dialog box or embedded editor, do the following:
a)
b)
c)
d)
e)
f)

Define the change request summary information on the Synopsis tab.
Describe the change request on the Description tab.
Optionally, specify a temporary workaround on the Solution tab.
Optionally, specify custom change request properties on the Custom tab.
Optionally, attach files related to this change request on the Attachments tab.
Optionally, add comments about the change request on the Comments tab.
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4. Click Finish, or if using the embedded editor, click Save.
This creates and saves the change request. StarTeam assigns a unique number to the change request
and displays the summary information in the Change Request view.
Note: To edit a change request, right-click the change request in the Change Request view and
choose Edit.
Specifying Change Request Summary Information
1. Choose a status type from Synopsis Tab > Status.
2. Select a severity type from the Severity list box.
The team leader usually sets the criteria for high, medium and low status.
3. Select Yes from the Priority list box if the change request needs immediate attention.
4. Select Defect or Suggestion from the Type list box to specify the type of change request.
5. Select the platform to which the change request applies from the Platform list box.
6. Type a summary of the change request in the Synopsis text box.
The application can accept a maximum of 20K characters in this text box, but your database may
accept fewer characters.
7. Select the name of the team member responsible for correcting the change request from the
Responsibility drop-down list box.
8. Click Finish to save your changes.
Specifying Change Request Descriptions
1. Click the Description tab.
2. Type a detailed description of the change request in the Description and steps to reproduce text box.
Include the steps to reproduce the problem, or in the case of an enhancement request, a detailed
description of the enhancement.
3. Optional: Type or browse for the path to a test for the change request in the Test command text box.
4. Click Apply.
Specifying Change Request Solutions
1. Click the Solution tab.
2. Optional: Type the steps you can follow to work around the problem in the Work around text box.
3. Optional: Type the solution to the problem in the Fix text box.
The Fix text box is usually completed by the user who fixes the code. In this box, the application can
accept a maximum of 20K characters, but your database may accept fewer characters.
4. Click Finish to save your changes.
Modifying Custom Options for Change Requests
1. Click the Custom tab.
2. Click the name of the custom property. The Edit Property dialog box opens.
3. Select a new value for the property.
For integer, text, and real fields, Value is a text box. For enumerated types and user IDs, it is a list box.
For dates and times, Value has a Date check box and a Time check box, each of which is followed by
a date or time in the format for your locale.
4. Click Finish.
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Adding Change Request Attachments
1. Click the Custom tab.
2. Click Add to attach a file to the change request.
3. Select the files to be attached from the Open dialog box.
4. Click Open.
5. Optional: Add more attachments.
6. Click Finish.

Adding Change Request Comments
1. Click the Comments tab.
The Comment for this revision lists any comments that were entered for the current version of the
change request only. That is, each time you change the change request and type a comment, the new
comment replaces the old comment when you save the change request.
2. Type your comments in the Comment for new revision text box.
You must make a change to a property for this change request before you can type a comment.
3. Click Finish.

Editing Change Requests
1. Open a StarTeam perspective, and select the Change Request view.
2. Double-click the change request. The Change Request Properties dialog box opens.
3. Alternative: Right-click the change request and choose Edit. A Change Request property editor
opens, embedded in the Eclipse editor. The embedded property editor allows you to open other items
and editors at the same time, and enables you to drag and drop files or content from other items into
the change request fields. Since the embedded editor is non-modal, you can continue to do other work
while it is open.
4. Make any desired changes to the change request properties.
5. Click Finish in the Change Request Properties dialog box or if using the embedded editor, click Save
on the main toolbar.
Note: To edit the change request, right-click it in the Change Request view and choose Edit.

Assigning Change Requests
To assign change requests, you must first select a folder in the Server Explorer or in one of the Eclipse
views and then open the Change Request view.
Tip:
•
•
•

To find all change requests in a folder, select All Descendants on the toolbar in the Change
Request view.
If desired, you can use a predefined filter provided in the filter drop down list in the Change
Request view toolbar.
You can also sort the Status column to find all New change requests.

1. Click Link with Selection in the Change Request view toolbar.
2. Select the folder containing the change request in the Server Explorer or in one of the Eclipse
Explorers.
3. Do one of the following:
•

Double click on the change request.
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•

Right-click on the change request, and choose Properties.

The Change Request Properties dialog box opens.
4. Choose a status.
•
•
•
•

Open
Is Duplicate
As Designed
Deferred

If you select Open, the Responsibility changes to the person best qualified to fix or enhance the
product, as described in the change request. If you select Is Duplicate or As Designed, the
Responsibility changes to the person who submitted the change request. The assumption is that the
person who submitted the change request will want to know about, verify, or perhaps challenge this
change in status.
5. Click Apply.
6. Click Next or Previous to review another change request in the list.
7. Click OK.

Resolving Open Change Requests
To locate change requests that need to be resolved, you must first select a folder in the Server Explorer or
in one of the Eclipse views and then open the Change Request view.
Tip:
•
•
•

To find all change requests in a folder, select the All Descendants button on the toolbar in the
Change Request view.
If desired, you can use a predefined filter provided in the filter drop down list in the Change
Request view toolbar.
You can also sort the Status column to find all Open change requests.

1. Open the Change Request view.
2. Click Link with Selection.
3. Select the folder containing the change request in the Server Explorer or in one of the Eclipse
Explorers.
4. Do one of the following:
•
•

Double click on the change request.
Right-click on the change request, and choose Properties.

The Change Request Properties dialog box opens.
5. Change the status of the change request to one of the resolved statuses:
•
•
•
•

Fixed
Documented
Cannot
Reproduce

Alternative: You might use Is Duplicate or As Designed, if either of these is appropriate
Note: If you choose Fixed or Documented as the new status, select the Solution tab and enter
the appropriate information in the Work Around and/or Fix text boxes. Often a change request
suggests one or more fixes for a problem, and none of these suggestions are implemented. To
avoid confusion, the fix that is implemented must be described in precise detail. Testers and
writers rely heavily on this information.
6. Click Apply, then click Next or Previous to review another change request in the list.
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7. Click OK to close the dialog box.
When you select a resolved status, StarTeam automatically makes the following changes to the change
request:
•

•

Places the name of the person who submitted the change request in the Responsibility field. The
assumption is that the person who submitted the change request will want to know about, verify, or
perhaps challenge the change in status.
Changes the setting for the Addressed In Build field to “Next Build” (if the status has changed to Fixed
or Documented). When the next build label is created, “Next Build” changes to the name of the build
label. The assumption is that the person who verifies that the change request has been implemented
should test the correct build of the product.

Although StarTeam makes these automatic changes immediately, you can change the Responsibility or
Addressed In Build setting before you click OK (or Apply , if appropriate). In this way, you can bypass the
automatic workflow and route the change request as your team requires.

Verifying Resolved Change Requests
To mark a change request as verified, you must first select a folder in the Server Explorer or in one of the
Eclipse views and then open the Change Request view.
Tip:
•
•
•
•

To find all change requests in a folder, select All Descendants on the toolbar in the Change
Request view.
If desired, you can use a predefined filter provided in the filter drop down list in the Change
Request view toolbar.
You can also sort the Status column to find the change requests.
If you determine that a change request is not really resolved, you can reopen it.

1. Open the Change Request view. and
2. Click Link with Selection.
3. Select the folder containing the change request in the Server Explorer or in one of the Eclipse
Explorers.
4. Do one of the following:
•
•

Double click on the change request.
Right-click on the change request, and choose Properties from the context menu.

The Change Request Properties dialog box opens.
5. Change the status to Open or Verified.
StarTeam has the following verified statuses:
•
•
•
•
•

Verified As Designed
Verified Cannot Reproduce
Verified Documented
Verified Fixed
Verified Is Duplicate

If you change the status to Open, enter the word “Reopen” and the date in the Synopsis text box.
Otherwise, the team member who resolved the change request may think that he or she forgot to mark
it resolved and, without investigating further, mark it resolved a second time.
6. Click Apply.
7. Click Next or Previous to review another change request in the list.
8. Click OK to close the dialog box.
When you re-open a change request, StarTeam automatically does the following:
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•

•

Places the name of the person who resolved the change request in the Responsibility field. The
assumption is that the person who resolved the change request the first time should be the person to
continue working on it.
Blanks out the setting for the Addressed In Build field. The assumption is that the change request has
not been resolved and, therefore, has not been addressed in any build.

Closing Verified Change Requests
To close Verified change requests, you must first select a folder in the Server Explorer or in one of the
Eclipse views and then open the Change Request view.
1. Open the Change Request view.
2. Click Link with Selection in the Change Request view toolbar.
3. Select the folder containing the change request in the Server Explorer or in one of the Eclipse
Explorers.
4. Double click on the change request. The Change Request Properties dialog box opens.
5. Change the status to one of the following Closed status types.
•
•
•
•
•
•

Closed (As Designed)
Closed (Cannot Reproduce)
Closed (Deferred)
Closed (Documented)
Closed (Fixed)
Closed (Is Duplicate)

6. Click Apply.
7. Click Next or Previous to review another change request in the list.
8. Click OK.

Finding Items
You can search all items displayed in views for the data contained in any displayed field.
1. Select a folder in Server Explorer or in one of the Eclipse Explorers.
2. Open the Change Request, Requirement, Task, or Topic view.
3. Enter CTRL+F. The Find dialog box opens.
4. Type part or all of the data in the Search For text box.
Do not use wild cards.
5. Select Forward to search the view from the top to the bottom, or select Backward to search the view
from the bottom to the top.
6. Select Starting at: Currently Selected Item to begin searching from the item that is presently selected,
or select Starting at: First Item to search from the first item in the view.
7. Select either All Displayed Fields or This Field.
If you select This field, select the field for which you want to search from the list box.
8. Check Match Case if a case-sensitive search is appropriate.
9. Click Find to search.
Note: Use Ctrl+F to start a search. Use F3 to find the next item that matches the search text and
Shift+F3 to find the previous item that matches the search text

Reviewing Linked Change Requests
1. Select the file that is linked to the change request in one of the Eclipse Explorers.
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2. Right-click on the file, and choose Team > Check In. The Check In dialog box opens.
3. Expand the Change Requests section. This section expands and displays a list of any Change
Requests Linked In This View.
Note: No change request displays in the list more than once, even if it is linked to several of the files
you are checking in. When a change request is linked to more than one file, the list displays the name
of only one of the files.

Viewing or Modifying Item Properties
Depending on how your team has set up the application, you may see a totally different dialog box called
an alternate property editor (APE). Every time the properties of an item are modified, a new revision of that
item is created. If you modify a property, you should also create a revision comment explaining the
modification using the Comment tab provided in the Properties dialog box.
1. Select an item in one of the StarTeam or Eclipse views.
2. Do one of the following:
•
•

Select an item and double click on it.
Right-click the folder or item, and choose Properties from the context menu.
Note: If you open the Properties dialog box from one of the Eclipse Explorers, expand StarTeam
Provider in the dialog box to surface the available StarTeam properties. If you open the
Properties dialog box within a StarTeam view or from the Server Explorer, this action is not
required.

3. Modify any of the property fields in the corresponding Properties dialog box.
4. Click OK.

Working with Change Request Lists
Change requests are listed in the Change Request view. You can sort the change requests by the data in
a column and change the display based on a predefined filter.
Displaying the List of Change Requests
1. Open the Change Request view.
2. Click Link with Selection.
3. Select the folder containing the change request in the Server Explorer or in one of the Eclipse
Explorers.
A list of change requests for the selected folder displays in the Change Request view. All change
requests shown in the Change Request view:
•
•
•

Are attached to the folder selected from the Server Explorer or Eclipse Explorers.
Match the filter selected in the Change Request view toolbar from the Filter list box.
Match the depth specified by the All Descendants button when selected in the Change Request
view toolbar.

Viewing Unread Change Requests
1. Look for change requests in bold type.
These are the change requests you are responsible for but have not yet reviewed.
Note: Change requests in regular type are those that you have read or those for which you are not
responsible.
2. Click on the Responsibility column header, then scroll down to your name.
All change requests in bold are unread.
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Moving Change Requests
1. Locate the change request you want to move. You can move a change request from one folder to
another.
2. Click on the change request and drag it to a new folder.

Marking Items Read/Unread
To reread all the items on a certain subject, it is sometimes convenient to mark all of the items unread to
ensure that you do not miss any. You can also mark an entire requirement, task, or topic tree as unread.
1. Open the Change Request, Requirement, Task, or Topic view.
2. Select one or more items in the view that you want made unread or read.
3. Right-click the selected items, and choose Mark As Unread or Mark As Read. The items are marked
as specified, and the type style changes accordingly.

Customizing the Detail View
The name of the template file controls the StarTeam component to be modified. For example, a template
named changerequest.detail.html controls the format and content of the Detail pane display for the
Change Request component.
Note: Sample Detail view templates are installed under the StarTeam for Eclipse installation folder in
the samples\details-templates folder.
1. Create an HTML template file for the corresponding component that you wish to customize.
If you want to format the contents of the Detail view for a change request, you would create a template
file named changerequest.details.html.
You must use the following file names for the component detail panes that you wish to customize:
•
•
•
•
•
•

folder.details.html
file.details.html
changerequest.details.html
task.details.html
topic.details.html
requirement.details.html

Tip: Refer to the links at the end of this topic to review sample template files that you can use as a
starting point for creating your own templates for customizing the Detail view.
2. Make any desired modifications to the template file.
Follow the formatting example in the sample template file. The fields used in the Detail view HTML
templates are recognized by the client when they are contained between double tilde characters.
~~Status~~ represents the Status field found in the Change Request Properties dialog box.
3. Save the template files in the same directory as the starteam-servers.xml and starteamclient-options.xml files.
On a Windows system these files could be located in the C:\Documents and Settings\USER
\Application Data\Borland\StarTeam folder.

Labels and Promotion States
This section contains information related to managing labels and promotion states.
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Labels
In version control, the term label corresponds to the act of attaching a view or revision label (name) to one
or more folders and/or items. StarTeam enables you to create two types of labels:
•

•

View labels are automatically and immediately attached to all folders and items in a view at the time you
create the view label. View labels have multiple purposes, but you primarily use them to place a time
stamp on the entire contents of the view and as build labels. When you roll back the view to that label,
you see everything that existed at that point in time--unless the label has been adjusted. You can create
a view label for a specific point in time or as a copy of another existing view label. Unless the view label
is frozen, you can adjust it to include or exclude some folders and items by attaching or detaching view
labels. You can also move a view label from one revision to another.
Revision labels are not attached automatically to any item in the view. Instead, they are used to
designate a set of folders or items within a view. For example, you might want to label a group of files
that should be checked in and out together.

About Labels in General
You can attach a label to any type of StarTeam item, including folder, files, requirements, change requests,
tasks, topics, and audit entries. Any item can have more than one label. However, no two revisions of the
same item can have the same label at the same time.
Every label is unique within its view. That is, no view label can have the same name as any other view
label, no revision label can have the same name as any other revision label, and no view label and revision
label can have the same name.
You can manually attach or detach both view labels and revision labels to or from a folder or item. In
addition, you can use either type of label to identify a file when it is checked out. When you check a file in,
you can attach and create a revision label for that file or attach an existing revision label.
You can select any type of item by its label. For example, you can select all files with a particular revision
label and roll them back to that label, making the revision with that label the tip revision. Then you can
compare your working files to the rolled-back revisions.
You can set access rights for labels at the view level or at the folder or item level. You must grant the rights
to create labels, edit their properties, and delete them at the view level. However, you can grant the right to
move a label (also called adjust a label) at the folder or item level.
Note: You must set access rights using the Cross-Platform Client.

Time Stamps and Build Labels
Using a view label as a time stamp, you can roll a view back to see everything in the view as it was at the
time the label was attached. For example, to see if a particular file was in the beta version of a product, you
can roll back the view to the beta label.
You may also use a view label as a build label, which allows the QA team to immediately determine what
build to test for a fix to any given change request. To use a view label for this purpose:
•
•

It must be designated as a build label.
It must be created while the Addressed in build property for the change request contains the value Next
Build.

When StarTeam creates the label, each change request with Next Build as its Addressed in build property
will be reset to the build label.
To create a view label, you must select the current configuration of the view. Historical configurations are
read only, and adding a label is considered a change. However, if a label already exists for a prior
configuration, you can adjust its name, files and folders can be added to it or detached from it, and so on.
You can also move a view label from one revision to another.

Borland StarTeam Eclipse Client

| 199

For example, suppose your administrator creates a view label before each build, giving that label to the tip
revision of each file in the view, and then checks out all the files with that label for the build. If the tip
revision of one file does not change for a few weeks (or longer), it can acquire several view labels, while a
file that changes frequently may have several revisions with no view labels and other revisions with only
one view label.
When you detach a view label from a folder, StarTeam automatically detaches the label from everything in
the subtree for which the folder is the root. If you roll back a view to a specific view label and a folder does
not have that label, you cannot see the children of that folder and their contents anyway.
You can only create a view label at the view level and only while the configuration is current. However, you
can create a view label for the current configuration or for a time in the past. In either of these two cases,
StarTeam attaches the new label to the tip revision of each folder, file, change request, task, or topic that
belonged to the view at the specified time.
You can also create a view label as a copy of an existing view label or as a copy of the view label currently
attached to a promotional state. In these two cases, StarTeam attaches the new label to exactly the same
items and revisions as the existing view label.
You can check file revisions out using this label or roll back the view to this label and see all the items
associated with that label. For example, if you create the view label Build 100 as you make Build 100 of
your product from a view, all the files in the view will have the label Build 100.
If some items should not be included, you can detach the label from those items individually. For example,
if some file should not have that label, select the file then right-click and select Labels > Detach from the
context menu to detach that label. If the files that should not be included all belong to the same folder and
are the only files in that folder, use the Labels command on the folder's context menu. For example, if the
help files were not checked in until after the view label was attached, you can move that label from the
previous revisions of the help files to the newly checked-in help files.

Attaching New Labels to Folders
Determine whether a label is a revision label or a view label by opening the Label view, and double-click
the label (or select the label, and then choose Properties from the context menu). A revision label has a
name and a description. A view label has a name, description, and a configuration time.
1. Select a folder in the Server Explorer or from one of the Eclipse Explorers.
2. Choose StarTeam > Folder > Labels.
Alternative 1: From the Server Explorer, right-click on the folder, and choose Labels. Alternative 2:
From one of the Eclipse Explorers, choose Team > Labels.
Note: If you open the Properties dialog box using the Team > Labels command, expand
StarTeam Provider, and select Labels.
The Properties dialog box opens.
3. Select the revision that will receive the new label.
4. Click New. The Attach a New Revision Label dialog box opens.
5. Type a name and description for the label in the appropriate text boxes.
6. Optional: Check Frozen to ensure that only the selected revision can have this label.
7. Select one of the following options:
•
•
•

Folder Only to attach a label to only the selected folder.
Folder and Items Contained in Folder to attach a label to the folder and its items.
Everything in Subtree Rooted at Folder to attach a label to the folder, its items, and its child
folders and their items.

8. Click OK. The Properties dialog box displays the newly-created revision label.
9. Click OK.
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Attaching Labels to Items
1. Select one or more items in the Server Explorer, any StarTeam view, or in the Eclipse Explorers.
2. If selecting items from the Server Explorer or a StarTeam view, right-click and choose Labels > New. If
selecting items from an Eclipse Explorer, right-click and choose Team > Labels > New. The Attach a
New Revision Label dialog box opens.
3. Type a name and description for the label in the appropriate text boxes.
The maximum label name length is 64 characters and the description length is 254 characters.
4. Optional: Check Frozen to ensure that only the selected item revision can have this label.
5. Select one of the following configuration options:
•
•
•

•

Current Configuration to attach the label to the tip revision.
Labeled Configuration to attach the label to the revision with a specified label. The labels are in
reverse chronological order based on the time at which they were created.
Promotion State Configuration to attach the label to the revision currently in a specified promotion
state. (Actually, the label is attached to the revision that has the promotion state's current view
label.)
Configuration As Of to attach the label to the revision that was the tip revision at a specified date
and time.

6. Click OK.

Configuring or Viewing Label Properties
View label properties include a name, description, frozen/unfrozen status, configuration, and build label
status. Revision label properties include a name, description, and frozen/unfrozen status.
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Choose StarTeam > View > Labels The Properties dialog box opens.
3. Select the Labels node.
If you open the Properties dialog box from one of the Eclipse Explorers, you must expand the
StarTeam Provider node first, then select the Labels (per View) node.
4. Select a label on the View or Revision tabs. .
5. Click Properties. The Edit Label dialog box opens enabling you to modify the label name or
description, and freeze or unfreeze the label.

Displaying Folder Label Properties
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Choose StarTeam > Folder > Properties The Properties dialog box opens.
3. Select the Labels node.
If you open the Properties dialog box from one of the Eclipse Explorers, you must expand the
StarTeam Provider node first, then select the Labels (for Folder) node.
This displays all of the labels attached to the folder
4. Select a label from the list and click Properties. A read-only dialog box opens enabling you to view the
properties for the selected label.

Copying Revision Labels
This procedure assumes that you are dealing with files, but can be adapted for other types of items.
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1. Select the appropriate folder in the Server Explorer or in one of the Eclipse Explorers.
2. Choose StarTeam > View > Labels from the main menu, and select the Labels node in the Properties
dialog box opens.
If you open the Properties dialog box from one of the Eclipse Explorers, you must expand the
StarTeam Provider node first, then select the Labels (for View) node.
3. Select the Revision tab.
4. Click New to open the Revision Label dialog box.
5. Type a name and description for the revision label.
6. Check Copy From Another Revision Label.
7. Click Select. The Copy a Revision dialog box opens.
8. Select a project from Project from the list, a view in the View tree, and a revision label in the Labels
list.
9. Click OK. The new revision label is attached to the same revisions as the existing label.

Creating Revision Labels
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Select an item in the Server Explorer or in one of the Eclipse Explorers.
Alternative: Open the Change Request, Requirement, Task, or Topic view, and select one or more
items.
3. Choose StarTeam > View > Labels from the main menu. The Properties dialog box opens.
4. Select the Labels node, and click the Revision tab.
The labels are listed in reverse chronological order based on the time at which they were created.
5. Click New.
The Revision Label dialog box opens.
6. Type a name and description for the label.
The maximum label name length is 64 characters and the description length is 254 characters.
7. Optional: Check Frozen to freeze the label so that revisions attached to it cannot be changed.
8. Click OK to close the Revision Label dialog box.
9. Click OK to close the Properties dialog box.

Creating View Labels
View labels can be extremely useful when you want to label every folder and item in a particular view.
1. Do one of the following:
•
•
•

With a StarTeam perspective or view open, choose StarTeam > View > Labels or StarTeam >
View > Properties from the main menu.
In the Server Explorer, right click on the view node, and choose Labels or Properties from the
context menu.
In the Navigator or Package Explorers, right click on the project, and choose Properties or Team >
Labels.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•
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This View tab lists existing view labels in reverse chronological order, based on the time at which they
were created.
3. Click New to create a new label and add its name to the list box. The View Label dialog box opens.
4. Type a name and description for the label in the appropriate text boxes.
The maximum label name length is 64 characters, and the description length is 254 characters.
5. Optional: Check Use As Build Label to update each change request that has Next Build as the setting
for its Addressed In Build property. If this option is not selected, change requests will still have the
view label, but it will not affect the setting of the Addressed In Build property.
6. Optional: To freeze the label so that the revisions attached to it cannot be changed, check Frozen.
7. Select one of the following options:
•
•
•

•

Current Configuration: This attaches the label to the tip revision of every item in this view's current
configuration.
Labeled Configuration: This option attaches the label to the revision with the label you specify.
(Creating a view label based on another view label is equivalent to copying that view label.)
Promotion State Configuration: This option attaches the label to the revision currently in the
promotion state that you specify. (Actually, the label is attached to the revision that has the
promotion state's current view label.)
Configuration As Of: This option attaches the label to the revision that was the tip revision at the
specified date and time.

8. Click OK.
Note: If you select the current time for the label configuration, it is important to synchronize the dates
and times of the computers that run the StarTeam clients and the StarTeam server. Otherwise, the
labels may not be immediately visible.

Deleting Labels
When you delete a label, it is no longer visible in any list of labels, nor is it attached to any folders or items.
If a label is frozen, you must unfreeze it before you can delete it.
1. Select the view in the Server Explorer for which you want to delete a label.
2. Choose StarTeam > View > Labels from the main menu. The Properties dialog box opens.
3. Select the Labels node.
4. Click the View tab for a view label or the Revision tab for a revision label.
These tabs list existing labels in reverse chronological order, based on the time that they were created.
5. Select the label.
6. Click Delete. This removes the label from the view.

Demoting View Labels
1. Do one of the following:
•
•
•

With a StarTeam perspective or view open, choose StarTeam > View > Promotion or StarTeam >
View > Properties.
In the Server Explorer, right click on the view node, and choose Promotion or Properties.
In the Navigator or Package Explorers, right click on the project, and choose Properties or Team >
Labels.

The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, choose StarTeam Provider > Promotion.
If opened from the StarTeam main menu or Server Explorer, select Promotion.
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3. Click Edit to open the Promotion State dialog box.
4. Select a different view label from the View Label list box.
5. Click OK.

Detaching a Label from a Specific Revision
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Select one or more items that you want to detach. Do one of the following:
•
•

Select one or more items in the Server Explorer or in one of the Eclipse Explorers.
Open the Change Request, Requirement, Task, or Topic view, and select one or more items.

3. Open the Label view.
4. Click Link with Selection.
5. Expand a revision in the Label view to see all labels attached to it as children of the revision.
6. Right-click the label you wish to remove and choose Detach. A confirmation dialog box opens.
7. Click OK.

Detaching Labels from Folders
Note: You can attach and detach any labels from items in current view configurations, but you cannot
see deleted items in those configurations. You can detach view labels from deleted items only if you
roll back the view to a configuration based on the label you want to detach.
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Choose StarTeam > Folder > Labels from the main menu. The Properties dialog box opens.
3. Select the Labels node.
The Labels page of the Properties dialog box lists the labels currently attached to this folder.
4. Select the label to be detached from the folder and click Detach. The Detach a Label dialog box
opens.
5. Select one of the following options:
•
•
•

Folder Only
Folder And Items Contained In Folder
Everything In Subtree Rooted At Folder

6. Click OK to close the Detach a Label dialog box.
7. Click OK to close the Properties dialog box.
The folder from which the label is detached disappears after a refresh.
Note: When you detach a view label from a folder, the label is automatically detached from the items
that the folder contains. It is also automatically detached from the child folders and their contents.

Detaching Labels from Items
Note: You can attach and detach any labels from items in current view configurations, but you cannot
see deleted items in those configurations. You can detach view labels from deleted items only if you
roll back the view to a configuration based on the label you want to detach.
1. Select one or more items that do not require the label.
2. Do one of the following:
•
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•

Open the Change Request, Requirement, Task, or Topic view, and select one or more items.

3. Right-click the selected items and choose Labels > Detach.
Note: If selecting items in one of the Eclipse Explorers, choose Team > Labels > Detach.
The Detach a Label dialog box opens and displays all existing labels, identifying them as view or
revision labels. By default, both View Labels and Revision Labels display.
4. Select a label from the list.
5. Click OK.

Freezing or Unfreezing Labels
When a label is frozen, the label cannot be:
•
•
•

Attached to any additional folders or items.
Detached from any folder or items.
Moved from one revision of a folder or item to another.

1. Choose StarTeam > View > Labels. The Properties dialog box opens.
2. Select the Labels node.
3. Do one of the following:
•
•

Click the View tab if the label to be frozen is a view label.
Click the Revision tab if the label to be frozen is a revision label.

Both tabs list existing labels in reverse chronological order, based on the time they were created.
4. Select the label from the list box.
5. Click Freeze or Unfreeze.
6. Click OK.

Promoting View Labels
You can promote a view label from one promotion state to the next if you have the appropriate access
rights, and when it satisfies the criteria established for that state.
1. Choose StarTeam > View > Promotion or StarTeam > View > Properties
Alternative 1: In Server Explorer, right click on the view node, and choose Promotion or Properties.
Alternative 2: In the Navigator or Package Explorers, right click on the project, and choose Properties
or Team > Labels.
The Properties dialog box opens.
2. In the resulting dialog box, do one of the following:
•
•

If opened from the Navigator or Package Explorers, expand StarTeam Provider and select
Promotion.
If opened from the StarTeam main menu or StarTeam, select Promotion.

The states are displayed from the final state down to the initial state.
3. Select the promotion state currently associated with the view label that you want to promote.
4. Click Promote. The dialog box indicates that the view label is now associated with the next state (the
state immediately above the selected state in the Properties dialog box).
5. Click OK.
The view label now applies to both the original state and the new state. Usually, your next action is to
associate a new view label with the original state.
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Promotion States
A promotion state is a state through which a product passes. For example, most software products go
through a release or production cycle -- that is, the product moves from developers to testers and back
again, until it is ready to go to the marketplace. Promotion states provide a convenient mechanism for
ensuring that the right files or other items are available to the right people at the right stage of this cycle.
For example, if a software administrator creates Test and Release promotion states, files that are ready for
testing can be assigned to the Test state and files that have been tested successfully can be assigned to
the Release state.
The promotion state feature permits an administrator to create promotion states and associate a view label
with each state. An administrator creates a new promotion state configuration which is the basis for a new
view or a reconfigured view containing only items with a specified promotion state. Administrators can also
set access rights for promotion states. The view labels assigned to a promotion state are usually also used
as build labels, so that they can serve as properties in change requests.
The view label for a state can be changed whenever appropriate. It can also be promoted from one state to
the succeeding state. For example, although testers may always be using files in the Test promotion state,
the files may be from Build 07 in one week and from Build 08 in the next. Users usually configure the
project view for their job assignment by promotion state instead of by view label. For example, testers
would configure their view to the Test promotion state.
Many features of the application depend on calculations involving times and dates. In particular, labels,
configurations, and promotion states are all governed by time and date calculations. If the clients and the
Server are not kept synchronized, a number of operations (such as checkouts, file status displays, or label
creation) may fail or produce inaccurate or unreliable results.

Access Rights for Promotion States
Each view has its own set of promotion states. Access to these states is controlled by:
•

•

The Define Promotion Model right which is set on the View node of the Access Rights dialog box for
both projects and views. A user with the Define Promotion Model right can do anything to the promotion
model.
Access rights that govern access to individual promotion states. These are Generic Object Rights and
Promotion State Specific Rights which are set on the Promotion State node of the Access Rights
dialog box for both projects and views. They also appear on the access rights for individual promotion
states.

The rights for an individual promotion state are checked at the state level; if necessary, the checking
continues at the view level and eventually the project level. If a user is granted a given right at one level,
there is no need to check the next.
•
•

When a right is granted at the view level, it applies to all states in the view, unless access is denied at
the state level.
When a right is granted at the project level, it applies to all the states in all the views within the project,
unless access is denied at the state or view levels.
Note: You must set access rights using the Cross-Platform Client.

Promotion States Example
Suppose a software company wants to use the following promotion states to correspond with its use of the
application:
Development
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Developers work with the tip revisions of files. These files
have no view label because they are constantly changing.
Many companies do not use Development as a promotion

state, because configuring a view to a promotion state,
even when the view label for the state is <current>,
makes the view read-only.
White Box Test

Testers check both the source code and the compiled
executable file for problems that need to be fixed. The
source code will have a view label to ensure that the
testers are looking at an unchanging set of files. The view
label will be attached to a promotion state named White
Box Test. (White box testing is testing with full knowledge
of what is in the source code.)
The executable files are not stored in the application
because they can be easily built from the source code.
Testers install them from a Builds folder on the network.
This folder has child folders named Build 1, Build 2, and
so on.
Change requests are entered against the executable files
only. Developers make repairs in the current source
code, sometimes reviewing the files with the view label
attached to the Black Box Test promotion state.

Black Box Test

Testers install the executable file, just as they would with
white box testing. However, they do not need to see the
source code or use promotion states with it. (Black box
testing is testing with no knowledge of what is in the
source code.)
Change requests are entered against the executable files
only. Developers make repairs in the current source
code, sometimes reviewing the files with the view label
attached to the Black Box Test promotion state.

Alpha Test

End users of the software product being developed install
the product executable files and test the product in their
own environments.
Change requests are entered by the alpha coordinator
and/or the users against the executable files only.
Developers make repairs in the current source code,
sometimes reviewing the files with the view label attached
to the Alpha promotion state.

Beta Test

Beta testing is similar to alpha testing, but the group of
users is greatly expanded because the product is much
more stable.
Change requests are entered by the beta coordinator
and/or the users against the executable file only.
Developers make repairs in the current source code,
sometimes reviewing the files with the view label attached
to the Beta promotion state.

Release

The product is now sold in the marketplace. Users install
the executable file and call product support. Product
support enters change requests against the executable
files only. Developers make repairs in the current source
code, sometimes reviewing the files with the view label
attached to the Release promotion state.

Borland StarTeam Eclipse Client

| 207

The fixes go into future product releases and service
packs to releases already in the marketplace.

In this example, every time the source files are used to produce a build (set of executable files) for testing,
a view label is applied to the files to identify them for future reference. It is convenient to use view labels
such as Build 1, Build 2, and so on, so that it is clear which source code files were used to create which set
of executable files.
Over time, the build or view label associated with a promotion state will change. For example, the Release
state may initially be associated with <current>, rather than a view label, because no files are candidates
for release and no appropriate view label has been created. When white box testers decide that the set of
files that they have examined is ready for black box testing, the view label associated with the White Box
Test promotion state will be moved to the Black Box Test promotion state, and so on.
If promotion states are used, developers and testers who look at source code do not need to know that
view label Build 120 is currently being checked by white box testers, that the executable files for Build
117 are currently undergoing black box testing, and other details.

Configure Promotion States
When creating promotion states, many administrators assign <current> to the initial promotion state
instead of a view label because that state always uses the tip revisions. They also often assign <current>
to later promotion states for which no view labels currently exist. These states may receive a view label
later when the files associated with a view label meet the criteria required by the state. Alternatively, a view
label may be promoted from the preceding state to the label-less state.
You can create promotion states only if you have the required access rights, which are found at the project
or view level.
Creating Promotion States
You can create promotion states only if you have the required access rights, which are found at the project
or view level.
1. Choose StarTeam > View > Promotion from the main menu. The Properties dialog box opens.
2. Select the Promotion node.
The Promotion page of the Properties dialog box displays the states currently created for this view.
The final state displays at the top of the list.
3. Click Add. The Promotion State dialog box opens.
4. Type the Name and Description of the promotion state.
5. Assign a view label to this state by selecting it from the View Label list box.
The labels are listed in reverse chronological order, based on the time at which they were created. You
can change the label when appropriate by using this dialog box or assign it to the next state by
promoting it.
6. Click OK.
Editing/Deleting Promotion States
1. Choose StarTeam > View > Promotion from the main menu. The Properties dialog box opens.
2. Select the Promotion node. The Promotion page of the Properties dialog box displays the states
currently created for this view. The final state displays at the top of the list.
3. Click Edit. to open the Promotion State dialog box. The Promotion State dialog box opens.
4. Modify the Name, Description, or View Label.
5. Click OK.
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Requirements
Requirements are supported for the Enterprise Advantage license and display in the Requirement view in
the Workbench. With the Requirement component, you can create requirements within the application and
show the dependencies among them. For example, if one requirement must be fulfilled before a second
requirement can be fulfilled, the first can be made a child of the second. If your company enforces process
rules, the requirements you establish can also be used to drive the development process. Administrators
and other authorized users can publish requirements from Caliber to StarTeam using StarTeam Caliber
Requirements Publisher, which is delivered with Caliber.
Requirement Characteristics
The requirements displayed in the Requirement view have the following characteristics:
•
•
•

They are attached to the folder selected.
They match the filter selected from the Filter list box.
They match the depth specified by the all descendants button. (You can click the All descendants
button on the Requirements view toolbar.)
Note: Icons display to the left of a requirement in the Requirement view to indicate its status and
whether you have read the latest revision.

How Requirements Can Help
By using requirements-driven development processes, companies can prevent time-consuming, costly
misunderstandings and shorten time to market. To accomplish this, you can use the StarTeam built-in
Requirement component as your basic tool, or publish complex requirements to StarTeam from Caliber.
Using requirements enables business analysts, managers, developers, QA staff, and others to:
•
•
•
•
•
•
•
•
•
•

Organize business, user, and functional requirements in a hierarchical format.
Indicate the dependencies among requirements.
See all layers of requirements at all times.
Prioritize requirements by importance.
Identify the impact of changes to requirements.
Use requirements to estimate work.
Identify the person creating the requirement.
Notify those who will be responsible for fulfilling the requirements.
Track the requirement lifecycle from submitted to completed or rejected.
Provide requirements with a context by linking them to files, change requests, tasks, and topics.

Requirement Properties
This topic presents the requirement properties and their descriptions as displayed in the Requirement
Properties dialog box.
Requirements
The Requirement Properties dialog box contains the following tabbed pages of properties.The following
properties are on the Requirement page.
Property

Description

Name

Displays the requirement name.
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Property

Description

Created By

Displays the name of person who created the first
revision of the requirement in the view.

Created On

Displays the date on which first revision of the
requirement was created.

Attachments

Indicates the number of files attached to the requirement.

Modified By

Displays the name of the last person who last modified
the requirement.

Modified On

Displays the date on which the requirement was last
modified.

Type

Displays the requirement type.

Owner

Displays the name of person ultimately responsible for
the fulfillment of the requirement.

Status

Displays the current status of the requirement. This
indicates the progress from submitted to rejected or
completed. Note: The status ReadyForCCP means the
requirement is ready for review by the Change Control
Board.

External Reference

External source or reference for this requirement. This
usually is the name of an external customer who asked
for the requirement. If you are publishing requirements
from CaliberRM to StarTeam, this property displays its
identification for this requirement.

Description

Provides a description of the requirement, usually revised
over time to eliminate ambiguities.

Responsibility
The Responsibility page lists the people responsible for completion of the requirement. You can add or
remove people from the list. These people will be notified of changes to the requirement if notification is
enabled.
Ambiguity Review
The following properties are on the Ambiguity Review page. Reviewers will use the Ambiguity Review
page to locate ambiguities in the initial description and revise that description.
Property

Description

Number Of Ambiguities Found

Indicates the number of ambiguities reviewers have found
in the initial description of the requirement.

Revised Description

Provides a new, revised description because of
ambiguities found in the original description or for other
reasons.

Comments

Provides comments stating what the ambiguities are in
the original requirement and why you have made the
changes to the description.

Estimate
The following properties are on the Estimate page.
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Property

Description

Expected Effort

Indicates the expected case estimate for how long it will take to implement the
requirement fully. If you are publishing requirements from CaliberRM to StarTeam,
these fields will already be filled with data based on a specific unit, such as hours or
days. Otherwise, the units are arbitrary, but should be the same for the Low Effort and
the High Effort fields, and should be used consistently for all requirements.

High Effort

Indicates the worst case estimate for how long it will take to implement the requirement
fully. If you are publishing requirements from CaliberRM to StarTeam, these fields will
already be filled with data based on a specific unit, such as hours or days. Otherwise,
the units are arbitrary, but should be the same for the Low Effort and the Expected
Effort properties, and should be used consistently for all requirements.

Low Effort

Indicates the best case estimate for how long it will take to implement the requirement
fully. If you are importing requirements from CaliberRM, these fields will already be filled
with data based on a specific unit, such as hours or days. Otherwise, the units are
arbitrary, but should be the same for the Expected Effort and the High Effort fields,
and should be used consistently for all requirements.

Custom
You can create custom properties for an item which will display in the item Properties dialog box. The
following properties are on the Custom page.
Property

Description

Property

Displays each custom property name.

Value

Displays the values for each custom property. Doubleclick the property name to edit the value.

Attachments
The Attachments page contains a list of all the files attached to the current requirement.
Comment
The following properties are on the Comment page.
Property

Description

Comment For This Revision

Displays the reason for the changes to the current
revision.

Comment For New Revision

Displays the reason for the changes to the new revision.

Sample Requirement Detail View Template
You can use the following sample for customizing the Detail view for the requirement component.
Sample Requirement HTML Template
<html>
<head></head>
<body>
<b>Requirement</b>: #~~Number~~<br>
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<b>Name</b>: ~~Name~~<br>
<b>Version</b>: ~~RevisionNumber~~<br>
<b>Modified By</b>: ~~ModifiedUserID~~<br>
<b>Modified On</b>: ~~ModifiedTime~~<br>
<b>Comment</b>: ~~Comment~~<br>
<b>Created By</b>: ~~CreatedUserID~~<br>
<b>Created On</b>: ~~CreatedTime~~<br>
<b>Owner</b>: ~~Owner~~<br>
<b>Status</b>: ~~Status~~<br>
<b>Priority</b>: ~~Priority~~<br>
<b>Locked By</b>: ~~ExclusiveLocker~~<br>
<b>Description</b>: ~~Description~~<br>
<b>Attachments</b>: ~~AttachmentLinks~~<br>
<b>Attachment Count</b>: ~~AttachmentCount~~<br>
<b>Attachment names</b>: ~~AttachmentNames~~<br>
<b>Read Status User List</b>: ~~ReadStatusUserList~~<br>
<b>Share State</b>: ~~ShareState~~<br>
<b>CommentID</b>: ~~CommentID~~<br>
<b>Disabled</b>: ~~Disabled~~<br>
<b>Children Count</b>: ~~ChildrenCount~~<br>
<b>Child Type</b>: ~~ChildType~~<br>
<b>Non-Exclusive Lockers</b>: ~~NonExclusiveLockers~~<br>
<b>Short Comment</b>: ~~ShortComment~~<br>
<b>Recipient Count</b>: ~~RecipientCount~~<br>
<b>Folder Path</b>: ~~Folder Path~~<br>
<b>Object ID</b>: ~~ID~~<br>
<b>Flag</b>: ~~Flag~~<br>
<b>Read Only</b>: ~~ReadOnly~~<br>
<b>My Lock</b>: ~~MyLock~~<br>
<b>Configuration Time</b>: ~~ConfigurationTime~~<br>
<b>End Modified Time</b>: ~~EndModifiedTime~~<br>
<b>Am I Responsible?</b>: ~~AmIResponsible~~<br>
<b>New Revision Comment</b>: ~~NewRevisionComment~~<br>
<b>Type</b>: ~~Type~~<br>
<b>Attachment IDs</b>: ~~AttachmentIDs~~<br>
<b>Dot Notation</b>: ~~DotNotation~~<br>
<b>Read Status</b>: ~~ReadStatus~~<br>
<b>Parent Requirement ID</b>: ~~ParentRequirementID~~<br>
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<b>Ambiguities Found</b>: ~~AmbiguitiesFound~~<br>
<b>Expected Effort</b>: ~~ExpectedEffort~~<br>
<b>External Reference</b>: ~~ExternalReference~~<br>
<b>High Effort</b>: ~~HighEffort~~<br>
<b>Low Effort</b>: ~~LowEffort~~<br>
<b>Notes</b>: ~~Notes~~<br>
<b>Responsible Count</b>: ~~ResponsibleCount~~<br>
<b>Responsible Names</b>: ~~ResponsibleNames~~<br>
<b>Revised Description</b>: ~~RevisedDescription~~<br>
</body>
</html>
Fields Used in Detail View Templates
The fields used in the Detail view HTML templates are recognized by the client when they are contained
between double tilde ~~ characters. For example: ~~Status~~ represents the Status field found in the
Requirement dialog box. Refer to the link at the bottom of this topic for more information about the fields
that you can use in the Detail view templates.

Requirement Fields
This section lists all the requirement fields in alphabetical order.
Note: Client-calculated fields cannot be used in custom email notifications or Notification Agent.
Reports can use any field name.
Field

Description

Am I Responsible?

Values: No, Yes
Internal Identifier: AmIResponsible
Indicates whether the logged-on user is responsible for a requirement. This is
a client-calculated field.

Ambiguities Found

Values: number
Internal Identifier: AmbiguitiesFound
Indicates the number of ambiguities found in the requirement.

Attachment Count

Values: number
Internal Identifier: AttachmentCount
The number of files attached to a requirement.

Attachment IDs (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [00 00 00 00 02 00 00 00] indicates two specific
attachments.
Internal Identifier:
Cannot be used in queries. The ID numbers assigned to attachments. For
example, the first attachment within a project is 00 00 00 00.

Attachment Names

Values: text containing a series of file names separated by spaces
Internal Identifier: AttachmentNames
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Field

Description
The names of the files attached to a requirement.

Children Count

Values: number
Internal Identifier: ChildrenCount
The number of responses that are children of this requirement. This is a
client-calculated field.

ChildType

Values: Child Requirement, Requirement
Internal Identifier: ChildType
Indicates whether the requirement is the root of a requirement tree or a child
of another requirement. This is a client-calculated field.

Comment

Values: text
Internal Identifier: Comment
The initial 2000 characters provided as the reason for changing a
requirement's properties are stored in the Short Comment field. This field,
the Comment field, stores those 2000 characters and any additional text.
Changing a requirement's properties causes the application to create a new
revision.

CommentID (Advanced)

Values: number
Internal Identifier:CommentID
The ID number assigned to a revision comment. Displays -1 if no revision
comment was supplied.

Comments

Values: text
Internal Identifier: Comments
Provides comments about the revised description created because of
ambiguities found in the original description or for other reasons.

Configuration Time

Values: date/time
Internal Identifier: ConfigurationTime
Indicates the time to which a requirement is configured. If you configure a
requirement to a specific time, this field contains that time. If you configure a
requirement to a label or promotion state, this field shows either the time at
which the label was created or the time at which the label associated with the
promotion state was created.

Created By

Values: list of users, <None>
Internal Identifier: CreadedUserID
The name of the user who created the first revision in the view. This is the
user who initiated the requirement.

Created Time

Values: date/time
Internal Identifier: CreatedTime
The time at which the first revision in the view was created.

Deleted By

Values: list of users, <None>
Internal Identifier: DeletedUserID
The name of the user who deleted a requirement. Because deleted items do
not appear in the list, this information is unavailable to users. Internal Use
Only.
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Field

Description

Deleted Time

Values: date/time
Internal Identifier: DeletedTime
The time at which a requirement was deleted. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Description

Values: text
Internal Identifier: Description
The text in the Description field.

Disabled

Values: No, Yes
Internal Identifier: Disabled
Indicates whether the requirement is disabled.

Dot Notation

Values: text
Internal Identifier: DotNotation
The branch revision number, for example, 1.2.

End Modified Time (Advanced)

Values: date/time
Internal Identifier: EndModifiedTime
The date and time at which a revision ceased to be the tip revision. Although
this field can be displayed in the view, its value is always blank. This is
because, at any given configuration time, the item is still the tip revision.

Expected Effort

Values: number
Internal Identifier: ExpectedEffort
Indicates the expected case estimate for how long it will take to implement
the requirement fully. If you are publishing requirements from CaliberRM to
StarTeam, these fields will already be filled with data based on a specific unit,
such as hours or days. Otherwise, the units are arbitrary, but should be the
same for the Low Effort and the High Effort fields, and should be used
consistently for all requirements.

External Reference

Values: text
Internal Identifier: ExternalReference
Usually provides the name of an external customer who asked for this
requirement.

Flag

Values: No, Yes
Internal Identifier: Flag
A flag specifically marks/bookmarks requirements in the view on your
workstation. This is a client-calculated field.

Flag User List (Advanced)

Values: byte array; displayed as a bracketed series numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: FlagUserList
Can not be used in queries. Identifies users who have set flags on a given
item.

Folder Path

Values: text
Internal Identifier: Folder Path (contains spaces)
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Field

Description
The path to the folder that stores the requirement. This is a client-calculated
field.

High Effort

Values: number
Internal Identifier: HighEffort
Indicates the worst case estimate for how long it will take to implement the
requirement fully. If you are publishing requirements from CaliberRM to
StarTeam, these fields will already be filled with data based on a specific unit,
such as hours or days. Otherwise, the units are arbitrary, but should be the
same for the Low Effort and the Expected Effort fields, and should be used
consistently for all requirements.

Item Deleted By

Values: list of users, None
Internal Identifier: ItemDeletedUserID
The name of the user who deleted this item. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Item Deleted Time

Values: date/time
Internal Identifier: ItemDeltedTime
The time at which the item was created. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Locked By

Values: list of users, <None>
Internal Identifier: ExclusiveLocker
The name of the user who has exclusively locked a requirement.

Low Effort

Values: number
Internal Identifier: LowEffort
Indicates the best case estimate for how long it will take to implement the
requirement fully. If you are publishing requirements from CaliberRM to
StarTeam, these fields will already be filled with data based on a specific unit,
such as hours or days. Otherwise, the units are arbitrary, but should be the
same for the Expected Effort and the High Effort fields, and should be used
consistently for all requirements.

Modified By

Values: list of users, <None>
Internal Identifier: ModifiedUserID
The name of the user who last modified a requirement.

Modified Time

Values: date/time
Internal Identifier: ModifiedTime
The time at which a requirement was last modified.

My Lock

Values: Exclusively Locked By Me, Non-exclusively
Locked By Me, Not Locked By Me
Internal Identifier: MyLock
Indicates whether the current user has the requirement locked and, if so,
whether that lock is exclusive or not. This is a client-calculated field.

Name

Values: text
Internal Identifier: Name
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Field

Description
The name of the requirement.

New Revision Comment (Advanced)

Values: text
Internal Identifier: NewRevisionComment
Internal use only. A client uses this value during the item update process. The
field always appears empty if added to the view. This is a client-calculated
field.

Non-Exclusive Lockers

Values: text
Internal Identifier: NonExclusiveLockers
The names of the users who have locked the requirement non-exclusively.

Notes

Values: text
Internal Identifier: Notes
Text comments on the effort levels for this requirement.

Number

Values: number
Internal Identifier: RequirementNumber
Number identifying the requirement. For example, if the Object ID is 0, the
requirement number is 1.

Object ID

Values: number
Internal Identifier: ID
Each requirement is assigned an object ID when it is added to a view.

Owner

Values: list of users, <None>
Internal Identifier: Owner
Indicates who is ultimately responsible for this requirement.

Parent Requirement ID (Advanced)

Values: number
Internal Identifier: ParentRequirementID
The object ID of a requirement in the parent view. The Parent ID is 1 if this
view has no parent view.
Values:
Internal Identifier:

Priority

Values: Desirable, Essential, Unassigned, Useful
Internal Identifier: Priority
The value of the Priority field. You can use repository customization to
change the names of these values or include other values.

Read Only (Advanced)

Values: No, Yes
Internal Identifier: ReadOnly
Indicates whether the requirement's configuration is read-only (as in a
rollback configuration of a view).

Read Status

Values: Read, Unread
Internal Identifier: ReadStatus
Indicates whether a requirement is considered read or not read. This is a
client-calculated field.
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Field

Description

Read Status User List

Values:
Internal Identifier:

Read Status User List

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: ReadStatusUserList
Can not be used in queries. Identifies users for whom a given item's status is
Unread.

Responsible Count

Values: number
Internal Identifier: ResponsibleCount
The number of users who are responsible for a requirement.

Responsible IDs

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: ResponsibleIDs
Can not be used in queries. The ID numbers assigned to the users who are
responsible for the requirement.

Responsible Names

Values: text containing a series of user names separated by spaces.
Internal Identifier: ResponsibleNames
The names of the users responsible for this requirement.

Reviewed By

Values: byte array
Internal Identifier: ReviewedByIDs
Can not be used in queries. Should not be used at all.

Revised Description

Values: text
Internal Identifier: RevisedDescription
Provides a new, revised description because of ambiguities found in the
original description or for other reasons.

Revision Flags (Advanced)

Values: 0
Internal Identifier: RevisionFlags
Internal use only.

Share State

Values: DerivedShare, Not Shared, Root Share
Internal Identifier: ShareState
Indicates whether this item is shared. Not Shared means that the item is
not shared. Root Share means that the item is shared and this item is the
original (or root) reference. DerivedShare means that the item is shared,
but this item is not the original (or root) reference.

Short Comment

Values: text
Internal Identifier: ShortComment
Stores the initial 2000 characters provided as the reason for changing a
requirement's properties. Additional text is stored in the Comment field.

Status

Values: Accepted, Approved, Complete, Deferred, Draft,
Pending, ReadyForCCB, Rejected, Review, Submitted
Internal Identifier: Status
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Field

Description
Indicates the status of this requirement.

Type

Values: Business Requirement, Business Specification,
Hardware Requirement, Hardware Specification, Human
Resources, Information Technology, Software
Requirement, Software Specification
Internal Identifier: Type
Indicates the type of requirement.

Version (Advanced)

Values: number
Internal Identifier: RevisionNumber
The last number in the branch revision number. For example, if the branch
revision number is 1.2, the version is 2.

Working with Requirements
This section contains a list of procedures related to working with requirements.

Creating Requirements and Child Requirements
1. Open the Requirement view.
2. Click Link with Selection in the corresponding view's toolbar.
3. Select the folder in the Server Explorer or in one of the Eclipse Explorers where you wish to create the
requirement.
4. Right-click inside the Requirement view.
5. Choose New... or New in Editor to create a new requirement that is not the child of an existing
requirement.
Alternative: Right-click an existing requirement, and choose New Child Requirement or New Child
Requirement in Editor to create a new requirement that is the child of an existing requirement.
Note: If you choose New..., the New Requirement dialog box appears. If you choose New in
Editor, a New Requirement property editor opens which is embedded in the Eclipse editor. The
embedded property editor allows you to open other items and editors at the same time, and
enables you to drag and drop files or content from other items into the requirement fields. Since
the embedded editor is non-modal, you can continue to do other work while it is open.
6. Click the Requirement tab of the New Requirement dialog box or editor.
a) Type a name for the requirement.
b) Select an owner (i.e., the person ultimately responsible for the fulfillment of the requirement) from
the Owner list box.
c) Optional: Type an external source or reference for the requirement in the External reference text
box.
If you publish requirements from CaliberRM to StarTeam, this field displays the CaliberRM identification
for this requirement.
7. Type the initial description of this requirement in the Description text box.
This description is usually revised over time to eliminate ambiguities.
8. Click the Responsibility tab to list the team members responsible for this requirement.
If notification is enabled, these people will be notified about changes made to any field in the
requirement.
a) Click Add to open a dialog box to select responsible users.
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b) Double-click the name of each person to be added to the list.
Moves from the Users list box to the Responsible Users list box.
9. Click OK.
10.Click the Estimate tab to indicate the best-case and worst-case times for fulfilling this requirement.
The entries are usually in staff days.
a) Type the number of units (usually days) estimated for the fulfillment of this requirement in the
Expected effort text box.
b) Type the number of units (usually days) estimated for the worst-case fulfillment of this requirement in
the High effort text box.
c) Type the number of units (usually days) estimated for the best-case fulfillment of this requirement in
the Low effort text box.
d) Optional: Add any appropriate notes in the Notes text box.
11.Click the Custom tab to provide values for any custom requirement properties that your team leader or
company may have created. To change the default property:
a) Double-click the name of the custom property. The Edit Property dialog box appears.
b) Select a new value for this property.
For integer, text, and real fields, Value is a text box. For enumerated types and user IDs, it is a list
box. For dates and times, Value has a date check box and a time check box, each of which is
followed by a date or time in the format for your locale.
c) Repeat the above two steps for other custom properties.
12.Optional: use the Attachments tab to add additional files to this requirement.
a) Click Add if you want to attach a file. The Open dialog box appears.
b) Select the file to be attached.
c) Click Open.
d) Repeat the above three steps for additional attachments.
13.Click the Comment tab to explain why the requirement is being created or revised.
14.Type comments in the Comment for new revision text box.
15.Click Finish in the New Requirement dialog box, or if using the embedded editor, click Save on the
main toolbar.

Editing Requirements and Child Requirements
1. Open the Requirement view.
2. Select the requirement.
3. Do one of the following:
•
•

Double-click the requirement to open the Requirement Properties dialog box.
Right-click the requirement and choose Edit to open the requirement in the embedded Requirement
property editor.
Note: The embedded editor allows you to open other items and editors at the same time, and
enables you to drag and drop files or content from other items into the requirement fields. Since
the embedded editor is non-modal, you can continue to do other work while it is open.

4. Make any desired changes to the requirement properties.
5. Click Finish in the Requirement Properties dialog box, or if using the embedded editor, click Save on
the main toolbar.

Finding Items
You can search all items displayed in views for the data contained in any displayed field.
1. Select a folder in Server Explorer or in one of the Eclipse Explorers.
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2. Open the Change Request, Requirement, Task, or Topic view.
3. Enter CTRL+F. The Find dialog box opens.
4. Type part or all of the data in the Search For text box.
Do not use wild cards.
5. Select Forward to search the view from the top to the bottom, or select Backward to search the view
from the bottom to the top.
6. Select Starting at: Currently Selected Item to begin searching from the item that is presently selected,
or select Starting at: First Item to search from the first item in the view.
7. Select either All Displayed Fields or This Field.
If you select This field, select the field for which you want to search from the list box.
8. Check Match Case if a case-sensitive search is appropriate.
9. Click Find to search.
Note: Use Ctrl+F to start a search. Use F3 to find the next item that matches the search text and
Shift+F3 to find the previous item that matches the search text

Marking Item Threads Read or Unread
1. Open the Requirement, Task, or Topic view.
2. Click Link with Selection in the corresponding view's toolbar.
3. Select the folder that contains the item list that you want to view in the Server Explorer or in one of the
Eclipse Explorers. A list of items for the selected folder displays in the corresponding view.
4. Select a topic thread in the corresponding view.
Tip: To select multiple threads, display the information in list format by clicking View as List in the
view's toolbar.
5. Choose one of the following:
•
•

Mark Thread as Read to remove the bold format for the item thread.
Mark Thread as Unread to add bold format for the item thread.

Marking Items Read/Unread
To reread all the items on a certain subject, it is sometimes convenient to mark all of the items unread to
ensure that you do not miss any. You can also mark an entire requirement, task, or topic tree as unread.
1. Open the Change Request, Requirement, Task, or Topic view.
2. Select one or more items in the view that you want made unread or read.
3. Right-click the selected items, and choose Mark As Unread or Mark As Read. The items are marked
as specified, and the type style changes accordingly.

Viewing or Modifying Item Properties
Depending on how your team has set up the application, you may see a totally different dialog box called
an alternate property editor (APE). Every time the properties of an item are modified, a new revision of that
item is created. If you modify a property, you should also create a revision comment explaining the
modification using the Comment tab provided in the Properties dialog box.
1. Select an item in one of the StarTeam or Eclipse views.
2. Do one of the following:
•
•

Select an item and double click on it.
Right-click the folder or item, and choose Properties from the context menu.
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Note: If you open the Properties dialog box from one of the Eclipse Explorers, expand StarTeam
Provider in the dialog box to surface the available StarTeam properties. If you open the
Properties dialog box within a StarTeam view or from the Server Explorer, this action is not
required.
3. Modify any of the property fields in the corresponding Properties dialog box.
4. Click OK.

Customizing the Detail View
The name of the template file controls the StarTeam component to be modified. For example, a template
named changerequest.detail.html controls the format and content of the Detail pane display for the
Change Request component.
Note: Sample Detail view templates are installed under the StarTeam for Eclipse installation folder in
the samples\details-templates folder.
1. Create an HTML template file for the corresponding component that you wish to customize.
If you want to format the contents of the Detail view for a change request, you would create a template
file named changerequest.details.html.
You must use the following file names for the component detail panes that you wish to customize:
•
•
•
•
•
•

folder.details.html
file.details.html
changerequest.details.html
task.details.html
topic.details.html
requirement.details.html

Tip: Refer to the links at the end of this topic to review sample template files that you can use as a
starting point for creating your own templates for customizing the Detail view.
2. Make any desired modifications to the template file.
Follow the formatting example in the sample template file. The fields used in the Detail view HTML
templates are recognized by the client when they are contained between double tilde characters.
~~Status~~ represents the Status field found in the Change Request Properties dialog box.
3. Save the template files in the same directory as the starteam-servers.xml and starteamclient-options.xml files.
On a Windows system these files could be located in the C:\Documents and Settings\USER
\Application Data\Borland\StarTeam folder.

Working with Requirement Lists
Requirements are listed in the Requirement view. You can sort the requirements by the data in a column
(when displayed in list format) and change the display based on a predefined filter.

Displaying the List of Requirements
1. Open the Requirement view.
2. Click Link with Selection.
3. Select the folder containing the requirements in the Server Explorer or in one of the Eclipse Explorers.
A list of requirements for the selected folder displays in the Requirement view. All requirements shown
in the Requirement view:
•
•
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•

Match the depth specified by the All Descendants button when selected in the Requirements view
toolbar.

Viewing Requirements
1. Open the Requirement view.
2. Do one of the following:
•

Click View as List. This action displays information in a list format. No relationships among
requirements are shown. However, the list format allows you to:
•

•

See the values of specific fields as columns of data. For example, you can view the status for
each requirement.
• Sort the requirements by any column header.
Click View as Tree. This is the default format. This action displays each requirement as an
expandable requirement tree displaying the relationships between the requirement and its child
requirements. The tree format allows you to:
•
•
•

Click an unexpanded branch of a requirement tree to expands it; click on it again to collapse it.
Double click a requirement to open the Properties dialog box.
View special icons to show whether you have read the requirements for which you are
responsible.

Filters and Queries
A filter is a named arrangement of data that consists of a set of fields (used as column headers), sorting
and grouping information, and (usually) a query. Once a filter has been created, it can be used in every
project that has the same server configuration. Queries limit the items displayed in a view and are usually
used when defining a filter.
In the Change Request, Requirement, Task, Topic, and Audit views, a list box automatically displays a
list of predefined filters. For example, the Change Request view provides a Priority filter that when
selected, automatically sorts and groups change requests by their specified priority. You can create and
edit filters using Filters found in the list box toolbar menu for the Change Request, Requirement, Task,
and Topic views.
You can define and edit additional filters and queries using Filters and Queries found in the corresponding
list box toolbar menu for the Change Request, Requirement, Task, and Topic views. Once you have
created and publicly saved your filters/queries for a server configuration, the list box in the StarTeam
Eclipse Client displays these filters.

Filtering Data
A filter lets you view data in a particular arrangement that consists of a set of fields (used as column
headers), sorting and grouping information, and (usually) a query. Once a filter has been created, you can
use it in every project that has the same server configuration.

Applying Predefined Filters
Any team members who have the appropriate access rights can use public filters on all projects in the
same server configuration. Only your user ID can access filters that you specifically create as private filters.
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open one of the following views:
•

Change Request
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•
•
•
•

Requirement
Task
Topic
Audit Log
3. Select a filter from Filters list box.
Alternative: Choose Filters from the corresponding view's toolbar. Select a filter from the list of
predefined filters.
4. Click OK. Limits the data in the view to the data that matches the filter.

Copying Filters
If the original filter includes a query, the new filter must have the same status (public or private).
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
3. Choose Filters > Filters from the toolbar list box. The Filters dialog box opens.
4. Select a filter from the Filters list box.
5. Click Save As. The Save Filter As dialog box opens.
6. Type a new filter name.
7. Check or uncheck Public.
If the filter includes a query, the status of the new filter must be the same as the status of the original
filter.
8. Click OK. to return to the Filters dialog box.Returns to the Filters dialog box.
9. Do one of the following:
•
•

Click Select to apply the new filter to the view.
Click Close to exit without applying the new filter.

Deleting Filters
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
3. Choose Filters > Filters from the corresponding view's toolbar.
4. Select the filter to be deleted from the Filters list box.
5. Click Delete.A confirmation window opens.
6. Click OK.This action returns you to the Filter dialog box.
7. Click Close.

Editing Filters
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
3. Click the drop-down menu in the corresponding view's toolbar, and choose Filters > Filters. The
Filters dialog box opens.
4. Select a filter from the Filters list box.
5. Edit any of the following:
•
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•
•

Sort Group button, to sort and group items in up to four fields in ascending or descending order.
Query button, to limit the items that display in the view to those that match the query.

6. Click Save As. The Save Filter As dialog box opens.
Note: Do not change the name of the filter.
7. Click OK. Returns you to the Filters dialog box.
8. Do one of the following:
•
•

Click Select to apply the edited filter to the view.
Click Close to exit without applying the edited filter.

Resetting Filters
You can apply a filter, then rearrange the data in the view or apply a new query. After looking at the new
data, you can then reset the filter as it was originally defined on the server.
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
3. Choose Filters > Reset Current Settings. The system asks: Reset filter: <FilterName>?
4. Click OK.
This action resets the filter and removes the asterisk.

Change Request Filters
Use the Filters dialog box to limit the kinds and quantity of change requests that appear in the change
request list. The client ships with a set of default filters for the Change Request view which are listed
below. You can customize these filters or create new ones.
Item

Description

<Show All>

Displays all change requests.

By Status and Responsibility

Groups change requests based on their statuses and the
users who are currently responsible for processing the
requests.

Not a Priority

Displays only the change requests that are not a priority.

Priority

Displays only the change requests that are a priority.

Show Unread Changes

Displays only the change requests that you have not read
(or not read since they were modified).

Status = Closed

Displays only the change requests that are closed.

Status = Deferred

Displays only the change requests that are postponed.

Status = Open

Displays only the change requests that are open and in
progress.

Status = Resolved

Displays all the change requests that have one of the
following statuses:
•
•
•
•
•

As Designed
Cannot Reproduce
Documented
Fixed
Is Duplicate
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Item

Description

Status = Verified

Displays all the change requests that have one of the
following statuses:
•
•
•
•
•

Verified As Designed
Verified Cannot Reproduce
Verified Documented
Verified Fixed
Verified Is Duplicate

Type = Defect

Displays only the change requests that have the type
Defect.

Type = Suggestion

Displays only the change requests that have the type
Suggestion.

Requirement Filters
Filtering allows you to limit the types and numbers of requirements that display in the view. The client ships
with a set of default filters for the Requirement component which are listed below. You can customize
these filters or create new ones.
Tip: You can view and apply the defined requirement filters using the Filter drop-down list box on the
Requirement view's toolbar.
Item

Description

<Show All>

Displays all the requirements.

Flagged Items

Lists only requirements that have been flagged.

Grouped by Creator

Displays groups of requirements, one group for each user
who has created requirements.

Grouped by Status

Displays groups of requirements, one group for each
existing status.

I Am Responsible

Displays only the requirements for which you are
responsible.

Task Filters
Filtering allows you to limit the types and numbers of tasks that display in the view. The client ships with a
set of default filters for the Task component which are listed below. You can customize these filters or
create new ones. Examples of custom task filters that you might create include:
•
•

Responsibility Equals <user name>, which identifies only the tasks for which a specific person
is responsible.
Percent Complete Less Than 100, which identifies unfinished tasks.
Tip: You can view and apply the defined task filters using the Filter list box on the Task view's
toolbar.
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Item

Description

<Show All>

Lists all tasks.
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Topic Filters
Filtering allows you to limit the types and numbers of topics that display in the view. The client ships with a
set of default filters for the Topic component which are listed below. You can customize these filters or
create new ones.
Tip: You can view and apply the defined topic filters using the Filter list box on the Topic view's
toolbar.
Item

Description

<I Am Recipient>

Identifies all the topics that name you as a recipient.

By Creator

Groups the topics by their original authors.

Show Active

Identifies all topics and responses that have Active status.

Show All

Identifies all topics (the default).

Audit Filters
Filtering allows you to limit the types and numbers of audit log entries that display in the Audit view. The
client ships with a set of default filters available in the Audit view which are listed below. You can
customize these filters or create new ones.
Examples of custom audit log filters that you might create include:
•
•
•
•

Event – to display only the entries that were modified
Class Name – to display only actions performed on a specific type of item (for example, change
requests)
Created Time – to display only entries created from the specified date to the present
User – to display only the entries about actions performed by a specific user
Tip: You can view and apply the defined audit filters using the Filter drop-down list box on the Audit
view's toolbar.

Item

Description

<Show All>

Displays all entries (the default).

By Class and Event

Displays audit entries sorted by their value in the Class
Name 1 field (type of item) and Event (type of action)
field.

Querying Data
You can build and run queries to limit the data you view in the various StarTeam components in the
Change Request, Requirement, Task, Topic, or Audit Log views. Queries are more complex than filters
which control the arrangement of the information presented.

Applying Queries
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open one of the following views:
•
•
•

Change Request
Requirement
Task
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•
•

Topic
Audit Log
3. Choose Filters > Queries. The Queries dialog box opens.
4. Select a query in the list box.
5. Click Select to apply the query to the items shown in the view. This action changes the contents of the
view by displaying only those items that meet the specifications of the query.
If you are not satisfied with the results of the query, reopen the Queries dialog box, and click Clear Query
to return to the previously displayed list of items.

Matching Existing Queries
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, or Topic view.
This option is not available in the Audit Log view.
3. Choose Select > By Query The Select Query dialog box opens listing all existing queries.
4. Select the query of interest.
5. Click OK. This action highlights the items in the view that match this query.

Copying Queries
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
3. Choose Filters > Queries from the list box. The Queries dialog box opens.
4. Select the query to be edited from the list.
Public queries have a multi-user icon to the left of the query name; private queries have a single-user
icon.
5. Click Copy. The Copy Query dialog box opens.
6. Type the name for the new query in the Query Name text box.
7. Check the Public check box to add this query to the project (and the server configuration).
This allows anyone with the appropriate access rights to use it. If you do not check the Public check
box, the query will be private, available only to your user ID.
8. Click OK.The new query displays in the Queries dialog box.
9. Click Close.

Creating Queries
Tip: When creating a query condition, it is best to use the condition or logical operation that will result
in the fewest matches as the first condition or logical operation.
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
3. Choose Filters > Queries in the corresponding view's toolbar. The Queries dialog box opens.
4. Click New. The New Query dialog box opens.
5. Type a name for your query, and check Public to add this query to the project and the server
configuration.
This allows anyone with the appropriate access rights to use this query. If you do not check the Public
check box, the query is private and available only to your user ID.
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6. Select a Field and Operator.
7. Type or select a Value.
8. Click Add to place this condition in the Query tree.
By default, the Query tree box contains the AND operator as the root of the tree, which you cannot
delete. If there is only one condition, StarTeam ignores the logical operator.
Note: Click View as Text to view the query in text format. Notice that the default logical AND
operator was not included in your query. Click OK to close the window.
9. Optional: Click one of the following Logical Node buttons to create a new Query tree node:
•
•
•

AND
OR
NOT
10.Select the fields for this new condition.
11.Click Add.
12.Add any other conditions, then click Save.
If this is a public query, you might want to grant access rights.
The Queries dialog box now contains your new query enabling you to select it for querying data.

Creating Me Queries
"Me" queries allow query setup that evaluates the currently logging in user ("Me"), rather than specifying a
username at the time of query creation.
To create a "Me" query:
1. Select a folder in the Folder Tree.
2. Select the component tab in the upper right pane for the item type to query.
3. Click the filter drop-down button and choose Queries. The Queries dialog box appears.
4. Click New to open the New Query dialog box.
5. Type a name for the query. For example, type Me.
6. Check Public to add the query to the project and the server configuration. This allows everyone with
the appropriate access rights to use this query. Do not check Public to make the query private. No one
else can see this query except for the user logged into this system.
7. Choose Created By in the Field drop down in the Condition Node area.
8. Choose Equals in the Operator drop down.
9. Choose 'Me' in the Value drop down.
10.Click Add to place this condition in the Query tree. By default, the Query tree contains the And
operator as the root of the tree, which you cannot delete. If there is only one condition, StarTeam
ignores the logical operator.
11.Click Save. The Queries dialog box contains the new "Me" query. Select it to filter data created by the
person logged into the computer as the user.

Deleting Queries
Note:
•
•

You must have the appropriate access rights to delete a public query.
You cannot delete a query that is referenced by a filter.

1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
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3. Choose Filters > Queries in the corresponding view's toolbar. The Queries dialog box opens.
4. Select the query you want to delete.
5. Click Delete.
6. Click OK. The query is removed from the Queries dialog box.
7. Click Close.

Editing Queries
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Open the Change Request, Requirement, Task, Topic, or Audit Log view.
3. Choose Filters > Queries in the corresponding view's toolbar. The Queries dialog box opens.
4. Select the query to be edited from the list, then click Edit. The Edit Query dialog box opens.
5. Edit the appropriate nodes of the tree.
6. Click Save. This action redisplays the Queries dialog box.
7. Click Close.

Predefined Queries
Initially, the Queries dialog box lists default queries that are predefined for the current component (change
request, requiremement, and so on). You can apply a default query, edit a default query, create a new
query, or delete a default query.
Note: Default queries that do not appear in your list might have been deleted after installation.
Component

Predefined Queries

File

Files to Check In, Files to Check Out, Flagged Items

Change Request

Flagged Items, Not a Priority, Priority, Status=Closed, Status=Open,
Status=Resolved, Status=Verified, Type=Defect, Type=Suggestion, Unread
Changes

Requirement

Flagged Items, I Am Responsible

Task

Flagged Items

Topic

Flagged Items, I Am Recipient, Show Active

Folder

Folders Not In View

Audit

None

Relational Operators Used in Queries
Relational Operators Used in Queries
The relational operators that you can use to define conditions in a query vary according to the type of field:
•
•
•

Text fields.
Boolean, enumerated type, and numeric fields.
Date/time fields.

Relational Operators Used on Text Fields
The relational operators that can be used on text fields are
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•
•
•
•
•
•
•
•

Equals
Is Not
Contains (ignore case)
Contains (match case)
Starts with (ignore case)
Starts with (match case)
Ends with (ignore case)
Ends with (match case)

Relational Operators Used on Boolean, Enumerated Type, and Numeric fields
The relational operators that can be used on Boolean, enumerated type, and numeric fields are:
•
•
•
•
•
•

Less Than
Same or Less
Equals
Same or Greater
Greater Than
Is Not

Relational Operators Used on Date/Time Fields
The relational operators that can be used on date/time fields are listed below. Relational operators that
compare both the date and the time parts of date/time fields:
•
•
•
•
•
•

Before
On or Before
On
On or After
After
Not On

Relational operators that compare only the date part of date/time fields:
•
•
•
•
•

Before Date
On or Before Date
On Date
On or After Date
After Date

Relational operators that match all dates starting with the date that was the specified number of days or
weeks ago:
•
•

Last (?) Days
Last (?) Weeks

Relational operators that match all the dates prior to and including the date that was the specified number
of days or weeks ago:
•
•

Older Than (?) Days
Older Than (?) Weeks
Note: In date fields, StarTeam treats blanks as zeroes. That means that â€œno dateâ€ is less than
any specific date. For example, if you write a query that searches for change requests that were
closed prior to some specific date, all the change requests with no date in the Closed On field are
included in the results, even though they have not been closed yet. It is easy to eliminate the change
requests that contain blanks in the Closed On field from such a query. You can AND the condition
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that searches for change requests closed on or before a specific date with another condition that
searches for change requests closed after the date zero.

New Query Options
Click New to define a new query in the New Query dialog box.
Item

Description

Query

Displays the query definition parameters.

Logical node

Condition Node
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Name

Enter a unique name for the new query.

Public check box

Check to give the query public status.
Public queries can be used by anyone
with the appropriate access rights,
while private queries are available only
to your user ID. Once a query has been
saved with a specific status, its status
cannot be changed. However, you can
copy a query and change the state of
the new query.

Query list box

Displays the query definition. By
default, the AND condition appears as a
starting logical condition.

Use to choose the logical operator for each condition.
AND button

Click to add an AND condition to the
query.

OR button

Click to add an OR condition to the
query.

NOT button

Click to add a NOT condition to the
query.

AND->OR->NOT button

Click to toggle the default AND
condition to an OR or NOT condition.

Remove button

Click to delete the currently selected
condition. You must confirm the
deletion.

Use to define the conditions for the logical operator.
Field

Lists all the fields available for this
component.

Operator

Lists all of the operators that can be
specified for the selected field.

Value

Use to specify a value for this field and
condition.

Show advanced fields check box

Select to display all possible fields
including the advanced fields.

Show deleted users check box
(optional)

For components with user fields only
(such as the Change Requests
component), select to show deleted
users in the query results.

Item

Description
Alphabetical check box (optional)

For enumerated fields only (fields that
have specified values), select to
alphabetize the query results rather
than list them in the order in which they
appear in the enumeration list.

Add button

Click to add the condition to the query
definition.

Modify button

Click to modify the selected query
condition.

Delete button

Click to delete the selected query
condition.

View as Text button

Displays the current query definition in a text box.

Save button

Saves the new query.

Cancel button

Cancels the query definition.

Queries Options
Use the Queries dialog box to view and apply the currently defined queries.
Item

Description

Queries list box

Lists all existing queries for this component. Note that the multi-person icon
left of the query name indicates a public query; a single-person icon indicates
a private query.

Close button

Closes the Queries dialog box.

Select button

Applies the selected query to the data listed in the selected component.

Clear Query button

Clears the current query and displays all data.

New button

Opens the New Query dialog box for you to define a new query.

Edit button

Opens the selected query definition in the Edit Query dialog box for you to
edit.

Copy button

Opens the Copy Query dialog box for you to enter a name for your new
query.

Delete button

Deletes the selected query definition.

Access Rights button

Allows you to assign access rights to a query.

Tasks
The Task component allows the creation of task lists and work assignments. As a standalone, the Task
component is very useful for managing a project. It allows team members to indicate who should do what
and when, see current task status, estimate hours required to complete a task, record hours spent
completing the task, and compare estimated to actual times. Because the application contains both a
version control system and a change request system, it also allows tasks to be linked to the files and
product defects or suggestions with which they are associated.
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The Task component can be used independently or interoperate with data from Microsoft Project. It can
display tasks in a tree format, which clearly shows the relationship between tasks and subtasks, or in a list
format, which allows tasks to be sorted, grouped, or queried, or specific fields to be selected for display. To
improve efficiency, each task displays icons that identify its status, priority, milestone, and need for
attention. For information about interoperating with Microsoft Project, see the documentation for the
StarTeam Microsoft Project Integration.
With the Task component, you can create an individual task or a summary task that has a set of subtasks.
It is recommended that you plan tasks before entering them because:
•

•

A task that has even one subtask cannot have work records added to it, although work records can be
added to subtasks. Some customers name the task to indicate the goal or milestone that will be
reached when the subtasks are completed.
After a work record has been added to a task, you cannot create subtasks for it.
Note: Regardless of whether work records can be added to a task, you should assign the
responsibility for its completion to a specific team member. If work records can be added to a task,
you should also estimate how long the task should take.

Task Properties
Task
The following properties are on the Task page.
Property

Description

Subtask Of

Displays the name of task for which this item is a subtask
(if this item is a subtask).

Name

Displays the name of task or subtask.

Responsibility

Displays the name of the person responsible for the
completion of this task or subtask. Other people can be
assigned as additional resources.

Milestone

Indicates that the task or subtask should be treated as a
milestone.

Status

Displays the task status:
Pending – Waiting for completion of a predecessor task.
Ready To Start – Work can be started on the task.
In Progress – Work has been entered for the task.
Finished – Work is finished on the task.
Closed – Task is completed and closed.
Hold – Work temporarily stopped on the task, usually to
wait for completion of another task.
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Priority

Displays the task priority level. The default is Medium.
These priorities are identical to those in MS Project.Do
Not Level is a Microsoft Project-specific term you should
ignore.

Duration

Indicates the number of hours expected for completion of
the task.

Percent Complete

Displays the percentage of work that has been completed
on a task.
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Property

Description

Needs Attention

Notifies team leaders or task reviewers that this task
requires attention. Enter the information about why this
task needs attention in the text box below the Needs
Attention check box.

Resources
The Resources page lists the task resources. You can assign responsibility to team members by adding
them to the list with the Add button, and you can remove them using the Remove button.
Time
The following properties are on the Time page.
Property

Description

Plan Start

Displays the start date for the task.

Plan Finish

Displays the finish date for the task.

Plan Work

Indicates the number of hours estimated to complete this
task.

Actual Start

Displays the actual start date calculated from work record
entry.

Actual Finish

Displays the actual finish date task status changes to
Finished.

Actual Work

Indicates the actual number of hours taken to complete
the task, calculated from Work Records.

Variance Start

Displays the variance in days between expected start
date and actual start date. This is read-only calculated
value.

Variance Finish

Displays the variance in days between expected finish
date and actual finish date. This is read-only calculated
value.

Variance Work

Displays the variance in number of hours between
estimated and actual duration. This is read-only
calculated value.

Work
The Work page lists all the work records entered for this task. Each work record has the following
properties.
Property

Description

User Name

Displays the name of person who performed the work for
this work record entry.

Date

Displays the date of work record entry.

Work Hours

Indicates the number of hours worked for this work record
entry.
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Property

Description

Remaining Work

Indicates the remaining number of hours left to complete
the task.

Comments

Displays text comments explaining what work was done
for this work record.

Total Actual Work

Displays read-only calculated field of the total time spent
on this task based on the work records entered.

Notes
The Notes page is a text box for capturing notes about the task.
Custom
You can create custom properties for an item which will display in the item Properties dialog box.
The following properties are on the Custom page.
Property

Description

Property

Displays each custom property name.

Value

Displays the values for each custom property. Doubleclick the property name to edit the value.

Attachments
The Attachments page contains a list of all the files attached to the current item.
Comment
The following properties are on the Comment page.
Property

Description

Comment For This Revision

Displays the reason for the changes to the current
revision.

Comment For New Revision

Displays the reason for the changes to the new revision.

Sample Task Detail View Template
You can use the following sample for customizing the Detail view for the task component.
Sample Task HTML Template
<html>
<head></head>
<body>
<b><b>MS WBS Code:</b> ~~StTaskWBSCode~~ <br>
<b>Attention Notes:</b> ~~StTaskAttentionNotes~~ <br>
<b>Estimated Start:</b> ~~StTaskEstimatedStart~~ <br>
<b>My Lock:</b> ~~MyLock~~ <br>
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<b>Folder Path:</b> ~~Folder Path~~ <br>
<b>Estimated Hours Variance:</b> ~~StTaskEstimatedHoursVariance~~ <br>
<b>Task Duration:</b> ~~StTaskDuration~~ <br>
<b>Version:</b> ~~RevisionNumber~~ <br>
<b>Resource IDs:</b> ~~StTaskResourceIDs~~ <br>
<b>Flag:</b> ~~Flag~~ <br>
<b>Short Comment:</b> ~~ShortComment~~ <br>
<b>Created By:</b> ~~CreatedUserID~~ <br>
<b>Responsibility:</b> ~~StTaskResponsibility~~ <br>
<b>Constraint Date:</b> ~~StTaskConstraintDate~~ <br>
<b>Created Time:</b> ~~CreatedTime~~ <br>
<b>Share State:</b> ~~ShareState~~ <br>
<b>Locked By:</b> ~~ExclusiveLocker~~ <br>
<b>Priority:</b> ~~StTaskPriority~~ <br>
<b>Resource Count:</b> ~~StTaskResourceCount~~ <br>
<b>Estimated Finish:</b> ~~StTaskEstimatedFinish~~ <br>
<b>Actual Start:</b> ~~StTaskActualStart~~ <br>
<b>Actual Finish:</b> ~~StTaskActualFinish~~ <br>
<b>Estimated Hours:</b> ~~StTaskEstimatedHours~~ <br>
<b>Is My Task?:</b> ~~StTaskIsMyTask~~ <br>
<b>Attachment IDs:</b> ~~AttachmentIDs~~ <br>
<b>Estimated Start Variance:</b> ~~StTaskEstimatedStartVariance~~ <br>
<b>Deleted By:</b> ~~DeletedUserID~~ <br>
<b>Dot Notation:</b> ~~DotNotation~~ <br>
<b>Parent Task ID:</b> ~~StTaskParentID~~ <br>
<b>MS Task Unique ID:</b> ~~StTaskUniqueID~~ <br>
<b>Status:</b> ~~StTaskStatus~~ <br>
<b>Notes:</b> ~~StTaskNotes~~ <br>
<b>Read Status:</b> ~~ReadStatus~~ <br>
<b>Children Count:</b> ~~ChildrenCount~~ <br>
<b>Constraint Type:</b> ~~StTaskConstraintType~~ <br>
<b>Last Work/Dependency Update:</b> ~~StWorkDependencyLastUpdate~~ <br>
<b>Modified By:</b> ~~ModifiedUserID~~ <br>
<b>New Revision Comment:</b> ~~NewRevisionComment~~ <br>
<b>Non-Exclusive Lockers:</b> ~~NonExclusiveLockers~~ <br>
<b>Resource Names:</b> ~~StTaskResourceNames~~ <br>
<b>Read Status User List:</b> ~~ReadStatusUserList~~ <br>
<b>Task Type:</b> ~~StTaskType~~ <br>
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<b>Estimated Finish Variance:</b> ~~StTaskEstimatedFinishVariance~~ <br>
<b>Actual Hours:</b> ~~StTaskActualHours~~ <br>
<b>Revision Flags:</b> ~~RevisionFlags~~ <br>
<b>Percent Complete:</b> ~~StTaskPercentComplete~~ <br>
<b>Task Name:</b> ~~StTaskName~~ <br>
<b>Attachment Count:</b> ~~AttachmentCount~~ <br>
<b>CommentID:</b> ~~CommentID~~ <br>
<b>Is Replicated:</b> ~~Is Replicated~~ <br>
<b>Flag User List:</b> ~~FlagUserList~~ <br>
<b>Object ID:</b> ~~ID~~ <br>
<b>Task Origin:</b> ~~StTaskOrigin~~ <br>
<b>Modified Time:</b> ~~ModifiedTime~~ <br>
<b>MS Project File Name:</b> ~~StTaskMSProjectFileName~~ <br>
<b>Deleted Time:</b> ~~DeletedTime~~ <br>
<b>Milestone:</b> ~~StTaskMilestone~~ <br>
<b>Work Record Count:</b> ~~WorkRecCount~~ <br>
<b>Configuration Time:</b> ~~ConfigurationTime~~ <br>
<b>Last MS Project Update:</b> ~~StTaskMSProjectLastUpdate~~ <br>
<b>MS Task GUID:</b> ~~StTaskGUID~~ <br>
<b>End Modified Time:</b> ~~EndModifiedTime~~ <br>
<b>Task Number:</b> ~~StTaskNumber~~ <br>
<b>Needs Attention:</b> ~~StTaskNeedsAttention~~ <br>
<b>Attachment names:</b> ~~AttachmentNames~~ <br>
<b>Comment:</b> ~~Comment~~ <br>
<b>Read Only:</b> ~~ReadOnly~~ <br>
</body>
</html>
Fields Used in Detail View Templates
The fields used in the Detail view HTML templates are recognized by the client when they are contained
between double tilde ~~ characters. For example: ~~StTaskEstimatedStart~~ represents the
estimated start date field found in the Task Properties dialog box. Refer to the link at the bottom of this
topic for more information about the fields that you can use in the Detail view templates.

Task Fields
This section lists all the task fields in alphabetical order.
Field

Description

Actual Finish

Values: date/time
Internal Identifier: StTaskActualFinish
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Field

Description
The actual finish date for a task.

Actual Hours

Values: number
Internal Identifier: StTaskActualHours
The number of hours spent completing the task.

Actual Start

Values: date/time
Internal Identifier: StTaskActualStart
The actual start date for a task.

Attachment Count

Values: number
Internal Identifier: AttachmentCount
The number of files attached to a task.

Attachment IDs (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [00 00 00 00 02 00 00 00] indicates two specific
attachments.
Internal Identifier: AttachmentIDs
Can not be used in queries. The ID numbers assigned to attachments. For
example, the first attachment within a project is 00 00 00 00.

Attachment Names

Values: text containing a series of file names separated by spaces
Internal Identifier: AttachmentNames
The names of the files attached to a task.

Attention Notes

Values: text
Internal Identifier: StTaskAttentionNotes
The text in the Needs Attention note.

Children Count

Values: number
Internal Identifier:ChildrenCount
The number of responses that are subtasks of this task. This is a clientcalculated field.

Comment

Values: text
Internal Identifier: Comment
The initial 2000 characters provided as the reason for changing a change
request's properties are stored in the Short Comment field. This field, the
Comment field, stores those 2000 characters and any additional text.
Changing a task's properties causes the application to create a new revision.

CommentID (Advanced)

Values: number
Internal Identifier: CommentID
The ID number assigned to revision comment. Displays -1 if no revision
comment was supplied.

Configuration Time

Values: date/time
Internal Identifier: ConfigurationTime
Indicates the time to which a task is configured. If you configure a task to a
specific time, this field contains that time. If you configure a task to a label or
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Field

Description
promotion state, this field shows either the time at which the label was created
or the time at which the label associated with the promotion state was created.

Constraint Date

Values: date/time
Internal Identifier: StTaskConstraintDate
A task's constraint date from MS Project.

Constraint Type

Values: As Late As Possible, As Soon As Possible, Finish
No Earlier Than, Finish No Later Than, Must Finish On,
Must Start On, Start No Earlier Than, Start No Later

Than
Internal Identifier: StTaskConstraintType
A task's constraint type from MS Project.
Created By

Values: list of users, <None>
Internal Identifier: StTaskConstraintType
The name of the user who created the first revision in the view. This is the user
who initiated the task.

Created Time

Values: date/time
Internal Identifier: CreatedTime
The time at which the first revision in the view was created.

Deleted By

Values: list of users, <None>
Internal Identifier: DeletedUserID
The name of the user who deleted a task. Because deleted tasks do not
appear in the list, this information is unavailable to users. Internal Use Only.

Deleted Time

Values: date/time
Internal Identifier: DeletedTime
The time at which a task was deleted. Because deleted tasks do not appear in
the list, this information is unavailable to users. Internal Use Only.

Dot Notation

Values: text
Internal Identifier: DotNotation
The branch revision number, for example, 1.2.

End Modified Time (Advanced)

Values: date/time
Internal Identifier: EndModifiedTime
The date and time at which a revision ceased to be the tip revision. Although
this field can be displayed in the view, its value is always blank. This is
because, at any given configuration time, the item is still the tip revision.

Estimated Finish

Values: date/time
Internal Identifier: StTaskEstimatedFinish
The estimated finish date for a task.

Estimated Finish Variance

Values: date/time
Internal Identifier: StTaskEstimatedFinishVariance
The difference between the estimated and the actual finish date for a task.
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Field

Description

Estimated Hours

Values: number
Internal Identifier: StTaskEstimatedHours
The number of hours spent completing the task.

Estimated Hours Variance

Values: number
Internal Identifier: StTaskEstimatedHoursVariance
The difference between the estimated and the actual number of hours spent
completing the task.

Estimated Start

Values: date/time
Internal Identifier: StTaskEstimatedStart
The estimated start date for a task.

Estimated Start Variance

Values: date/time
Internal Identifier: StTaskEstimatedStartVariance
The difference between the estimated and the actual start date for a task.

Flag

Values: No, Yes
Internal Identifier: Flag
A flag specifically marks/bookmarks tasks in the view on your workstation. This
is a client-calculated field.

Flag User List (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: FlagUserList
Can not be used in queries. Identifies users who have set flags on a given
item.

Folder Path

Values: text
Internal Identifier: Folder Path (contains spaces)
The path to the folder that stores the task. This is a client-calculated field.

Is My Task?

Values: No, Yes
Internal Identifier: IsMyTask?
Indicates whether the logged on user is responsible for a task. This is a clientcalculated field.

Is Replicated

Values: No, Yes
Internal Identifier: Is Replicated (contains spaces)
Indicates whether the task is from MS Project task.

Item Deleted By

Values: list of users, None
Internal Identifier: ItemDeletedUserID
The name of the user who deleted this item. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Item Deleted Time

Values: date/time
Internal Identifier: ItemDeletedTime
The time at which the item was created. Because deleted items do not appear
in the list, this information is unavailable to users. Internal Use Only.
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Field

Description

Last MS Project Update

Values: date/time
Internal Identifier: StTaskMSProjectLastUpdate
The date that a task was last updated from MS Project.

Last Work/Dependency Update

Values: date/time
Internal Identifier: StWorkDependencyLastUpdate
The last time that a work record or a dependency (task successor or
predecessor) was added, edited, or deleted. This field is for use with MS
Project.

Locked By

Values: list of users, <None>
Internal Identifier: ExclusiveLocker
The name of user who has exclusively locked a task.

Milestone

Values: No, Yes
Internal Identifier: StTaskMilestone
Indicates whether a task represents a milestone. In MS Project, the definition
for a milestone is a task of zero time length. It serves as a heading for one or
more tasks to which a time length has been assigned.
In the application, a task has a milestone check box. After work is assigned to
a task, it is no longer a milestone.

Modified By

Values: list of users, <None>
Internal Identifier: ModifiedUserID
The name of the user who last modified a task.

Modified Time

Values: date/time
Internal Identifier: ModifiedTime
The time at which a task was last modified.

MS Project File Name (Advanced)

Values: text
Internal Identifier: StTaskMSProjectFileName
The name of the MS project file from which a task was exported.

MS Task GUID (Advanced)

Values: text
Internal Identifier: StTaskGUID
The GUID for a task in MS Project.

MS Task Unique ID (Advanced)

Values: number
Internal Identifier: StTaskUniqueID
The unique ID for a task in MS Project.

MS WBS Code (Advanced)

Values: text
Internal Identifier: StTaskWBSCode
A task's WBS code from MS Project.

Needs Attention

Values: No, Yes
Internal Identifier: StTaskNeedsAttention
Indicates that the check box for Needs Attention has been selected.
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Field

Description

New Revision Comment (Advanced) Values: text
Internal Identifier: NewRevisionComment
Internal use only. The client uses this value during the item update process.
The field always appears empty if added to the view. This is a client-calculated
field.
Non-Exclusive Lockers

Values: text
Internal Identifier: NonExclusiveLockers
The names of the users who have locked the task non-exclusively.

Notes

Values: text
Internal Identifier: StTaskNotes
The text of the note that accompanies the Needs Attention field.

Object ID

Values: number
Internal Identifier: ID
Each task is assigned an object ID when it is added to a view.

Parent Task ID (Advanced)

Values: number
Internal Identifier: StTaskParentID
The object ID of a task in the parent view. The Parent ID is -1 if this view has
no parent view.

Percent Complete

Values: number
Internal Identifier: StTaskPercentComplete
A percentage indicating how much of a task has been completed.

Priority

Values: Do Not Level, High, Higher, Highest, Low, Lower, Lowest, Medium,
Very High, Very Low
Internal Identifier: StTaskPriority
Indicates the priority given to a task. These priorities are identical to those in
MS Project.

Read Only (Advanced)

Values: No, Yes
Internal Identifier: ReadOnly
Indicates whether the task's configuration is read-only (as in a rollback
configuration of a view).

Read Status

Values: Read, Unread
Internal Identifier: ReadStatus
Indicates whether a task is considered read or not read. This is a clientcalculated field.

Read Status User List

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: ReadStatusUserList
Can not be used in queries. Identifies users for whom a given item's status is
Unread.

Resource Count

Values: number
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Field

Description
Internal Identifier: StTaskResourceCount
The number of users listed as resources for a task.

Resource IDs (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: StTaskResourceIDs
Can not be used in queries. The ID numbers assigned to the users who are
this task's resources.

Resource Names

Values: text containing a series of user names separated by spaces
Internal Identifier: StTaskResourceNames
The names of the users who are this task's resources.

Responsibility

Values: list of users, <None>
Internal Identifier: StTaskResponsibility
The name of the user who is currently responsible for the task.

Revision Flags (Advanced)

Values: 0
Internal Identifier: RevisionFlags
Internal use only.

Share State

Values: DerivedShare, Not Shared, Root Share
Internal Identifier: ShareState
Indicates whether this item is shared. Not Shared means that the item is
not shared. Root Share means that the item is shared and this item is the
original (or root) reference. DerivedShare means that the item is shared,
but this item is not the original (or root) reference.

Short Comment

Values: text
Internal Identifier: ShortComment
Stores the initial 2000 characters provided as the reason for changing a task's
properties. Additional characters are stored in the Comment field.

Status

Values: Closed, Finish, Hold, In Progress, Pending, Ready To

Start
Internal Identifier: STTaskStatus
Indicates the status of the task.
Task Duration

Values: number
Internal Identifier: STTaskDuration
The number of hours during which any user is working on a task. For example
if two people will work eight hours on a task, the duration is eight hours if they
work at the same time or a maximum of 16 hours if they do the work on
different days.

Task Name

Values: text
Internal Identifier: STTaskName
The name of the task.

Task Number
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Values: number

Field

Description
Internal Identifier: StTaskNumber
The number assigned to a task. For example, if the Object ID is 0, the task
number is 1.

Task Origin

Values: MSProject, StarTeam
Internal Identifier: STTaskOrigin
Indicates whether the task was created in the application or exported to the
application from Microsoft Project.

Task Type

Values: Fixed Duration, Fixed Units, Fixed Work
Internal Identifier: StTaskType
A task's type in MS Project.

Version (Advanced)

Values: number
Internal Identifier: RevisionNumber
The last number in the branch revision number. For example, if the branch
revision number is 1.2, the version is 2.

Work Record Count

Values: number
Internal Identifier: WorkRecCount
The number of work records currently added to a task.

Working with Tasks
This section contains procedures related to using StarTeam Eclipse Client tasks.

Creating Tasks and Subtasks
1. Open the Task view.
2. Click Link with Selection.
3. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
4. Do one of the following:
•

Right-click inside the Task view and choose New... or New in Editor to create a new task that is not
a subtask of an existing task.

If you choose New..., the New Task dialog box appears. If you choose New in Editor, a New Task
property editor opens which is embedded in the Eclipse editor. The embedded property editor allows
you to open other items and editors at the same time, and enables you to drag and drop files or content
from other items into the task fields. Since the embedded editor is non-modal, you can continue to do
other work while it is open.
•

Right-click an existing task, and choose New Subtask or New Subtask in Editor to create a new
task that is the subtask of an existing task.

5. Type the Name of the task.
You can use up to 255 characters for the task name. Although the Responsibility field names the
person primarily responsible for the completion of a task, additional people can be designated on the
Resources tab.
6. Optional: Check Milestone to indicate that the task should be treated as a milestone task.
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You can display the Milestone column in the task list and sort for the tasks that have been designated
as milestones.
7. Select the current status of the task from the Status drop-down list.
8. Select thePriority level from the drop-down list.
The priorities are identical to those used in Microsoft Project. Do not use the priority Do Not Level. This
priority is a Microsoft Project-specific term.
9. Type the Duration which is the number of hours the task will take to complete.
This field is disabled if the task contains subtasks since the duration of a task is dependent upon the
duration of its subtasks.
10.Type the Percent Complete which is the percentage of work already completed for this task.
This field may range from 0-100. The default is 0 for new tasks.
11.Optional: Check Needs Attention to notify team leaders or task reviewers that this task requires
attention.
Explain why this task needs attention in the text box.
12.Click Finish in the New Task dialog box, or if using the embedded editor, click Save on the main
toolbar.

Editing Tasks and Subtasks
1. Open the Task view and do one of the following:
•
•

Double-click the task or subtask to open it in the Task Properties dialog box.
Right-click the task or subtask and choose Edit to open it in the embedded Task Properties editor.
Note: The embedded editor allows you to open other items and editors at the same time, and
enables you to drag and drop files or content from other items into the task or subtask fields. Since
the embedded editor is non-modal, you can continue to do other work while it is open.

2. Make any desired changes to the task properties.
3. Click Finish in the Task Properties dialog box, or if using the embedded editor, click Save on the main
toolbar.
Note: Additional tabs in the New Task dialog box provide additional tracking options and features.

Assigning Task Resources
1. Open the Task view.
2. Click Link with Selection.
3. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
4. Double click on a task or subtask in the task tree or list. The Properties dialog box opens.
5. Click the Resources tab.
6. Click Add. The Select Task Resources dialog box opens.
7. Select the team members you want assign to the task from the Users list.
8. Click Add. This action moves the team member names to the Assigned Resources list.
9. Click OK to return to the Resources tab. The selected team members appear in the Task resources
assignment list.
10.Click Apply.
11.Click Next or Previous to review another task in the list.
12.Click OK.

246

| Borland StarTeam Eclipse Client

Estimating Time Required for Tasks
1. Open the Task view.
2. Click Link with Selection.
3. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
4. In the Task view, double click on a task or subtask in the task tree or list. The Properties dialog box
opens.
5. Select the Time tab.
6. Use the Start and Finish buttons to select a start and finish date.
The rest of the Time tab is disabled; however, the values for Actual and Variance automatically
calculate when the Work value changes.
7. Click OK.

Adding Notes to Tasks
1. Choose Task > Link with Selection.
2. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
3. Double click on a task or subtask in the task tree. The Properties dialog box opens.
4. Select the Notes tab.
5. Type notes about the task in the Notes text box.
6. Click OK.

Work Records in Tasks
After working on a task or subtask, you should add a work record to indicate what was done and the time
spent. For example, if you work on a task for one hour on Day 1 and for three hours on Day 2, you would
enter two work records, one for each day. You can edit or delete previously entered work records
Important: After you have added a work record to a task, you cannot create subtasks for that task.

Adding Work Records to Tasks
1. Open the Task view.
2. Click Link with Selection.
3. Select the folder in the Server Explorer or in one of the Eclipse Explorers that contains the task that you
want to modify.
4. In the Task view, double click on a task or subtask in the task tree or list. The Properties dialog box
opens.
5. Do one of the following:
•
•

Double-click a task or subtask in the Task view to open the Task Properties dialog box. Select the
Work tab, and click Add.
Right-click on a task, and choose Add Work.

The Work Record dialog box opens and displays your User Name in the list box.
6. Use the list box to specify a Date for the work record.
7. Type the number of hours worked in the Work text box.
8. Type the number of hours it will take to complete the task in the Remaining Work text box.
9. Type comments about the progress that has been made in the Comments text box.
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10.Click OK.
Editing a Task Work Record
1. Open the Task Properties dialog box.
2. Select the Work tab.
3. Select a record from the Work Records list and click Edit. This opens the Work Record dialog box.
4. Make any changes to the work record.
5. Click OK.
Deleting Task Work Records
1. Open the Task Properties dialog box.
2. Select the Work tab.
3. Select a record from the Work Records list, and click Delete. The message, "Delete Work Record?"
displays. Click OK to confirm the deletion.
4. Click OK to close the Task Properties dialog box.

Reviewing or Modifying Task Properties
1. Open the Task view.
2. Click Link with Selection in the corresponding view toolbar.
3. Select the folder in the Server Explorer or in one of the Eclipse Explorers that contains the task that you
want to modify.
4. In the Task view, double click on a task or subtask in the task tree or list. The Properties dialog box
opens.
5. Select any of the available tabs, and review or edit the task properties.
6. Select the Comment tab, and type the reason for your changes.
7. Click OK. StarTeam creates a new revision of the task.

Marking Item Threads Read or Unread
1. Open the Requirement, Task, or Topic view.
2. Click Link with Selection in the corresponding view's toolbar.
3. Select the folder that contains the item list that you want to view in the Server Explorer or in one of the
Eclipse Explorers. A list of items for the selected folder displays in the corresponding view.
4. Select a topic thread in the corresponding view.
Tip: To select multiple threads, display the information in list format by clicking View as List in the
view's toolbar.
5. Choose one of the following:
•
•

Mark Thread as Read to remove the bold format for the item thread.
Mark Thread as Unread to add bold format for the item thread.

Marking Items Read/Unread
To reread all the items on a certain subject, it is sometimes convenient to mark all of the items unread to
ensure that you do not miss any. You can also mark an entire requirement, task, or topic tree as unread.
1. Open the Change Request, Requirement, Task, or Topic view.
2. Select one or more items in the view that you want made unread or read.
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3. Right-click the selected items, and choose Mark As Unread or Mark As Read. The items are marked
as specified, and the type style changes accordingly.

Finding Items
You can search all items displayed in views for the data contained in any displayed field.
1. Select a folder in Server Explorer or in one of the Eclipse Explorers.
2. Open the Change Request, Requirement, Task, or Topic view.
3. Enter CTRL+F. The Find dialog box opens.
4. Type part or all of the data in the Search For text box.
Do not use wild cards.
5. Select Forward to search the view from the top to the bottom, or select Backward to search the view
from the bottom to the top.
6. Select Starting at: Currently Selected Item to begin searching from the item that is presently selected,
or select Starting at: First Item to search from the first item in the view.
7. Select either All Displayed Fields or This Field.
If you select This field, select the field for which you want to search from the list box.
8. Check Match Case if a case-sensitive search is appropriate.
9. Click Find to search.
Note: Use Ctrl+F to start a search. Use F3 to find the next item that matches the search text and
Shift+F3 to find the previous item that matches the search text

Working With Task Lists
Tasks are listed in the Task view. You can sort the tasks by the data in a column (when displayed in list
format) and change the display based on a predefined filter.
Displaying the List of Tasks
1. Open the Task view.
2. Click Link with Selection.
3. Select the folder containing the task in the Server Explorer or in one of the Eclipse Explorers.
A list of tasks for the selected folder displays in the Task view. All tasks shown in the Task view:
•
•
•

Are attached to the folder selected from the Server Explorer or Eclipse Explorers.
Match the filter selected in the Task view toolbar from the Filter list box.
Match the depth specified by the All Descendants button when selected in the Task view toolbar.

Viewing Tasks
1. Open the Task view.
2. Do one of the following:
•

Click View as List. This action displays information in a list format. No relationships among tasks
are shown. However, the list format allows you to:
•

•

See the values of specific fields as columns of data. For example, you can view the status for
each task.
• Sort the tasks by any column header.
Click View as Tree. This is the default format. This action displays each task as an expandable task
tree displaying the relationships between the task and its child tasks. The tree format allows you to:
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•
•
•

Click an unexpanded branch of a task tree to expands it; click on it again to collapse it.
Double click a task to open the Task dialog box.
View special icons to show whether you have read the tasks for which you are responsible.

Customizing the Detail View
The name of the template file controls the StarTeam component to be modified. For example, a template
named changerequest.detail.html controls the format and content of the Detail pane display for the
Change Request component.
Note: Sample Detail view templates are installed under the StarTeam for Eclipse installation folder in
the samples\details-templates folder.
1. Create an HTML template file for the corresponding component that you wish to customize.
If you want to format the contents of the Detail view for a change request, you would create a template
file named changerequest.details.html.
You must use the following file names for the component detail panes that you wish to customize:
•
•
•
•
•
•

folder.details.html
file.details.html
changerequest.details.html
task.details.html
topic.details.html
requirement.details.html

Tip: Refer to the links at the end of this topic to review sample template files that you can use as a
starting point for creating your own templates for customizing the Detail view.
2. Make any desired modifications to the template file.
Follow the formatting example in the sample template file. The fields used in the Detail view HTML
templates are recognized by the client when they are contained between double tilde characters.
~~Status~~ represents the Status field found in the Change Request Properties dialog box.
3. Save the template files in the same directory as the starteam-servers.xml and starteamclient-options.xml files.
On a Windows system these files could be located in the C:\Documents and Settings\USER
\Application Data\Borland\StarTeam folder.

Topics
Topics are threaded conversations. They are a series of messages that indicate how the messages are
related. Each series of messages forms a tree with the initial message at its root. The Topic component
provides threaded conversations that you can place in specific project folders and link to specific project
items. For example, you can link a topic to the change requests and file revisions that result from the topic
discussion.
The Topic view consists of topics and a series of responses to each topic. A series of topic trees are
eventually formed, each of which consists of a root topic and its responses. The topic tree resembles a
conversation that may go on among several people. By reading each response in a thread, one after the
other, and the responses to those responses, you can see how the discussion has evolved. A number of
other operations can be performed on topics or responses such as moving or sharing them.
Historical Value of Topics
Topics can raise general questions about the project or start very specific discussions about issues, such
as feature implementation. While the responses can lead to resolution of these issues, the historical value
of these conversations to the project can be even more significant. Future team members can:
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•
•
•

Reassess decisions more capably
Avoid retrying solutions that were previously found faulty
Understand why a particular solution to a problem became necessary and, therefore, not replace that
solution with one that does not meet all the necessary criteria

How Topics Can Help
Any type of threaded messaging improves teamwork on product development. However, because
StarTeam has tightly integrated components, it enables team members to:
•
•
•
•
•
•
•
•
•

Search topics and responses for specific words or phrases
Sort topics and responses
Filter topics and responses
View relationships between topics and their responses
Move and share topics (from the tree format)
Link topics directly to folders or other items, such as change requests.
Ask questions and quickly receive input while working on a file.
Attach notes to a topic explaining why a particular method was used.
Point out aspects of the project that may need to change in a later release.

Topic Properties
This topic presents the topic properties and their descriptions as displayed in the Topic Properties dialog
box. The Topic Properties dialog box contains the following tabbed pages of properties.
Topic
The following properties are on the Topic page.
Property

Description

Title

Displays the title of the topic.

Created By

Displays the name of person who created the topic.

Created On

Displays the date on which topic was created.

Attachments

Displays the number of attachments to the topic.

Modified By

Displays the name of the last person who modified the
topic.

Modified On

Displays the date on which the topic was last modified.

Content

Displays the text contents of the topic.

Options
The following properties are on the Options page.
Property

Description

Recipients

Displays the list of intended recipients of the topic or
response.
Note: You cannot delete yourself as a recipient
unless you delete all the recipients. When there
are recipients, StarTeam does not allow you to
remove yourself from the notification list.
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Property

Description

Priority

Displays the topic priority:
Low, Normal, or High.

Status

Displays the topic status:
Active or Inactive.

Custom
You can create custom properties for an item which will display in the item Properties dialog box.
The following properties are on the Custom page.
Property

Description

Property

Displays each custom property name.

Value

Displays the values for each custom property. Doubleclick the property name to edit the value.

Attachments
The Attachments page contains a list of all the files attached to the current topic.
Comment
The following properties are on the Comment page.
Property

Description

Comment For This Revision

Displays the reason for the changes to the current
revision.

Comment For New Revision

Displays the reason for the changes to the new revision.

Sample Topic Detail View Template
Use the following sample for customizing the Detail view for the topic component.
Cut and paste the HTML contents below into a file named topic.details.html, and place it in the
Application Data\Borland\StarTeam folder for the current user. For example, on a Windows
system, this file would be located in the C:\Documents and Settings\USER\Application Data
\Borland\StarTeam folder.
Sample Topic HTML Template
<html>
<head></head>
<body>
<b>Flag User List</b>: ~~FlagUserList~~<br>
<b>Version</b>: ~~RevisionNumber~~<br>
<b>Status</b>: ~~Status~~<br>
<b>Read Status User List</b>: ~~ReadStatusUserList~~<br>
<b>Modified Time</b>: ~~ModifiedTime~~<br>
<b>Attachment IDs</b>: ~~AttachmentIDs~~<br>
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<b>Created Time</b>: ~~CreatedTime~~<br>
<b>Content</b>: ~~Description~~<br>
<b>Share State</b>: ~~ShareState~~<br>
<b>CommentID</b>: ~~CommentID~~<br>
<b>Created By</b>: ~~CreatedUserID~~<br>
<b>Deleted Time</b>: ~~DeletedTime~~<br>
<b>Children Count</b>: ~~ChildrenCount~~<br>
<b>Title</b>: ~~Title~~<br>
<b>Non-Exclusive Lockers</b>: ~~NonExclusiveLockers~~<br>
<b>Topic Number</b>: ~~TopicNumber~~<br>
<b>Recipient IDs</b>: ~~RecipientIDs~~<br>
<b>Short Comment</b>: ~~ShortComment~~<br>
<b>Recipient Count</b>: ~~RecipientCount~~<br>
<b>Locked By</b>: ~~ExclusiveLocker~~<br>
<b>Folder Path</b>: ~~Folder Path~~<br>
<b>Object ID</b>: ~~ID~~<br>
<b>Flag</b>: ~~Flag~~<br>
<b>Recipient Names</b>: ~~RecipientNames~~<br>
<b>Read Only</b>: ~~ReadOnly~~<br>
<b>My Lock</b>: ~~MyLock~~<br>
<b>Configuration Time</b>: ~~ConfigurationTime~~<br>
<b>Comment</b>: ~~Comment~~<br>
<b>Revision Flags</b>: ~~RevisionFlags~~<br>
<b>End Modified Time</b>: ~~EndModifiedTime~~<br>
<b>Am I Recipient?</b>: ~~AmIRecipient~~<br>
<b>New Revision Comment</b>: ~~NewRevisionComment~~<br>
<b>Attachment Count</b>: ~~AttachmentCount~~<br>
<b>Type</b>: ~~Type~~<br>
<b>Priority</b>: ~~Priority~~<br>
<b>Modified By</b>: ~~ModifiedUserID~~<br>
<b>Deleted By</b>: ~~DeletedUserID~~<br>
<b>Attachment names</b>: ~~AttachmentNames~~<br>
<b>Dot Notation</b>: ~~DotNotation~~<br>
<b>Read Status</b>: ~~ReadStatus~~<br>
<b>Parent Topic ID</b>: ~~ParentTopicID~~<br>
</body>
</html>

Borland StarTeam Eclipse Client

| 253

Fields Used in Detail View Templates
The fields used in the Detail view HTML templates are recognized by the client when they are contained
between double tilde ~~ characters. For example: ~~Status~~ represents the represents the Status field
found in the field found in the Topic Properties dialog box. Refer to the link at the bottom of this topic for
more information about the fields that you can use in the Detail view templates.

Topic Fields
This section lists all the topic fields in alphabetical order.
Field

Description

Am I Recipient?

Values: No, Yes
Internal Identifier: AmIRecipient?
Indicates whether the logged on user is a recipient of a topic. This is a clientcalculated field.

Attachment Count

Values: number
Internal Identifier: AttachmentCount
The number of files attached to a topic.

Attachment IDs (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [00 00 00 00 02 00 00 00] indicates two specific
attachments.
Internal Identifier: AttachmentIDs
Can not be used in queries. The ID numbers assigned to attachments. For
example, the first attachment within a project is 00 00 00 00.

Attachment Names

Values: text containing a series of file names separated by spaces
Internal Identifier: AttachmentNames
The names of the files attached to a topic.

Children Count

Values: number
Internal Identifier: ChildrenCount
The number of responses that are children of this topic. This is a clientcalculated field.

Comment

Values: text
Internal Identifier: Comment
The initial 2000 characters provided as the reason for changing a topicâ€™s
properties are stored in the Short Comment field. This field, the Comment
field, stores those 2000 characters and any additional text. Changing a topicâ
€™s properties causes the application to create a new revision.

CommentID (Advanced)

Values: number
Internal Identifier: CommentID
The ID number assigned to revision comment. Displays -1 if no revision
comment was supplied.

Configuration Time

Values: date/time
Internal Identifier: ConfigurationTime
Indicates the time to which a topic is configured. If you configure a topic to a
specific time, this field contains that time. If you configure a topic to a label or
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Field

Description
promotion state, this field shows either the time at which the label was created
or the time at which the label associated with the promotion state was created.

Content

Values: text
Internal Identifier: Description
The text of a topic.

Created By

Values: list of users, <None>
Internal Identifier: CreatedUserID
The name of the user who created the first revision in the view. This is the user
who initiated the topic.

Created Time

Values: date/time
Internal Identifier: CreatedTime
The time at which the first revision in the view was created.

Deleted By

Values: list of users, <None>
Internal Identifier: DeletedUserID
The name of the user who deleted a topic. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Deleted Time

Values: date/time
Internal Identifier: DeletedTime
The time at which a topic was deleted. Because deleted items do not appear in
the list, this information is unavailable to users. Internal Use Only.

Dot Notation

Values: text
Internal Identifier: DotNotation
The branch revision number, for example, 1.2.

End Modified Time (Advanced)

Values: date/timeInternal Identifier: EndModifiedTimeThe date and time at
which a revision ceased to be the tip revision. Although this field can be
displayed in the view, its value is always blank. This is because, at any given
configuration time, the item is still the tip revision.

Flag

Values: No, Yes
Internal Identifier: Flag
A flag specifically marks/bookmarks topics and/or responses in the view on
your workstation. This is a client-calculated field.

Flag User List (Advanced)

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: FlagUserList
Can not be used in queries. Identifies users who have set flags on a given
item.

Folder Path

Values: text
Internal Identifier: Folder Path (contains spaces)
The path to the folder that stores the topic. This is a client-calculated field.

Item Deleted By

Values: list of users, None
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Field

Description
Internal Identifier: ItemDeletedUserID
The name of the user who deleted this item. Because deleted items do not
appear in the list, this information is unavailable to users. Internal Use Only.

Item Deleted Time

Values: date/time
Internal Identifier: ItemDeltedTime
The time at which the item was created. Because deleted items do not appear
in the list, this information is unavailable to users. Internal Use Only.

Locked By

Values: list of users, <None>
Internal Identifier: ExclusiveLocker
The name of the user who has exclusively locked a topic.

Modified By

Values: list of users, <None>
Internal Identifier: ModifiedUserID
The name of the user who last modified a topic.

Modified Time

Values: date/time
Internal Identifier: ModifiedTime
The time at which a topic was last modified.

My Lock

Values: Exclusively Locked By Me, Non-exclusively Locked
By Me, No Locked By Me
Internal Identifier: MyLock (contains spaces)
Indicates whether the current user has the topic locked and, if so, whether that
lock is exclusive or not. This is a client-calculated field.

New Revision Comment (Advanced) Values: text
Internal Identifier: NewRevisionComment
Internal use only. the client uses this value during the item update process.
The field always appears empty if added to the view. This is a client-calculated
field.
Non-Exclusive Lockers

Values: text
Internal Identifier: NonExclusiveLockers
The names of the users who have locked the topic non-exclusively.

Object ID

Values: number
Internal Identifier: ID
Each topic is assigned an object ID when it is added to a view.

Parent Topic ID (Advanced)

Values: number
Internal Identifier: ParentTopicID
The object ID of a topic in the parent view. The Parent ID is -1 if this view has
no parent view.

Priority

Values: High, Low, Normal
Internal Identifier: Priority
The value of the Priority field. You can use repository customization to
change the names of these values or include other values.
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Field

Description

Read Only (Advanced)

Values: No, Yes
Internal Identifier: ReadOnly
Indicates whether a topic's configuration is read-only(as in a rollback
configuration of a view).

Read Status

Values: Read, Unread
Internal Identifier: ReadStatus
Indicates whether a topic is considered read or not read. This is a clientcalculated field.

Read Status User List

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: ReadStatusUserList
Cannot be used in queries. Identifies users for whom a given item's status is
Unread.

Recipient Count

Values: number
Internal Identifier: RecipientCount
The number of recipients to whom a topic is addressed.

Recipient IDs

Values: byte array; displayed as a bracketed series of numbers in hex format.
For example, [14 00 00 00] indicates a specific user.
Internal Identifier: RecipientIDs
Can not be used in queries. The ID numbers assigned to the users who are
recipients (people to be notified about this topic).

Recipient Names

Values: text containing a series of users names separated by spaces.
Internal Identifier: Recipient Names
The names of the recipients designated for notification about this topic.

Revision Flags (Advanced)

Values: 0
Internal Identifier: RevisionFlags
Internal use only.

Share State

Values: DerivedShare, Not Shared, Root Share
Internal Identifier: ShareState
Indicates whether this item is shared. Not Shared means that the item is
not shared. Root Share means that the item is shared and this item is the
original (or root) reference. DerivedShare means that the item is shared,
but this item is not the original (or root) reference.

Short Comment

Values: text
Internal Identifier: ShortComment
Stores the initial 2000 characters provided as the reason for changing a topic's
properties. Additional text is stored in the Comment field.

Status

Values: Active, Inactive
Internal Identifier: Status
Indicates the status of this topic.

Title

Values: text
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Field

Description
Internal Identifier: Title
The text of the Title field.

Topic Number

Values: number
Internal Identifier: TopicNumber
The number assigned to a topic. For example, if the Object ID is 0, the topic
number is 1.

Type

Values: Response, Topic
Internal Identifier: Type
Indicates whether the item is a topic (root of a topic tree) or a response
(branch of a topic tree). This is a client-calculated field.

Version (Advanced)

Values: number
Internal Identifier: RevisionNumber
The last number in the branch revision number. For example, if the branch
revision number is 1.2, the version is 2.

Working With Topics
This section contains tasks related to using topics.

Creating Topics and Responses
To start a threaded conversation, you must first create a topic.
1. Open the Topic view, and click Link with Selection.
2. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
3. Do one of the following:
•
•

Right-click inside the Topic view and choose New... or New in Editor to create a new topic that is
not a response to an existing topic.
Right-click an existing topic and choose Respond... or Respond in Editor to create a response to
an existing topic.

If you choose New..., the New Topic dialog box appears. If you choose New in Editor, a New Topic
property editor opens which is embedded in the Eclipse editor. The embedded property editor allows
you to open other items and editors at the same time, and enables you to drag and drop files or content
from other items into the topic fields. Since the embedded editor is non-modal, you can continue to do
other work while it is open.
4. Click the Topic tab, and type the title of your topic in the Title text box.
5. Click the Description tab, and type the content for this topic in the Content text box.
6. Optionally, do any of the following:
•
•
•

Use the Options tab if you want to send the topic to specific team members, assign a priority to the
topic, or indicate a status for the topic.
If your administrator created additional topic properties, you can access them on the Custom tab.
Use the Attachments tab if you want to attach a file or graphic with your topic.

7. Optionally, select the Comment tab to add additional notes or a comment in the Comment for new
revision text box.
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8. Click Finish in the New Topic dialog box, or if using the embedded editor, click Save on the main
toolbar. The new topic displays in the Topic view.

Sending a Topic to Team Members Set Priority or Set Status
1. Select the Options tab.
2. Click Add. The Select Topic Recipients dialog box opens.
3. Select the team members from the list.
4. Click Add.
If you change a topic to delete its recipients, you cannot delete yourself as a recipient unless you delete
all of the recipients. When there are recipients, StarTeam does not allow you to remove yourself from
the notification.
5. To assign a priority to the topic, select Low, Normal, or High from the Priority list box.
6. To specify a topic status, select either Active or Inactive from the Status list box.
The default status is Active.
7. Click Save.

Setting the Values for Custom Properties
1. Select the Custom tab.
2. Double-click the name of a custom property. The Edit Property dialog box opens.
3. Select a new value for this property.
For integer, text, and real fields, Value is a text box. For enumerated types and user IDs, it is a list box.
For dates and times, Value has a date check box and a time check box, each of which is followed by a
date or time in the format for your locale.
4. Repeat the previous two steps for other custom properties.

Reviewing and Modifying Topic Properties
If you have appropriate privileges, you can modify any of the following topic and response properties:
•
•
•
•
•
•
•

Title and text.
Priority (Low, Normal, and High).
Status (Active or Inactive).
Recipients (list of people who received the topic or response).
Attachments (additional files included with the topic or response).
Values of any custom fields.
Additional revision comments or notes.

After you modify a property and confirm your changes, StarTeam creates a new revision of the topic or
response.
1. Open the Topic view.
2. Click Link with Selection in the corresponding view's toolbar.
3. Select the folder in the Server Explorer or in one of the Eclipse Explorers that contains the topic or
response that you want to modify.
4. In the Topic view, double click on a topic or response in the topic tree or list. The Properties dialog box
opens.
5. Change the properties, as desired.
6. Type remarks on the Comment tab to explain why you have made these changes.
7. Click OK.
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Editing Topics and Responses
1. Open the Topic view, and do one of the following:
•
•

Double-click a topic to open it in the Topic dialog box.
Right-click a topic and choose Edit and open the topic in the embedded Topic Properties editor.

Note: The embedded editor allows you to open other items and editors at the same time, and
enables you to drag and drop files or content from other items into the topic fields. Since the
embedded editor is non-modal, you can continue to do other work while it is open.
2. Make any desired changes to the topic properties.
3. Click Finish in the Topic Properties dialog box, or if using the embedded editor, click Save on the
main toolbar.

Marking Item Threads Read or Unread
1. Open the Requirement, Task, or Topic view.
2. Click Link with Selection in the corresponding view's toolbar.
3. Select the folder that contains the item list that you want to view in the Server Explorer or in one of the
Eclipse Explorers. A list of items for the selected folder displays in the corresponding view.
4. Select a topic thread in the corresponding view.
Tip: To select multiple threads, display the information in list format by clicking View as List in the
view's toolbar.
5. Choose one of the following:
•
•

Mark Thread as Read to remove the bold format for the item thread.
Mark Thread as Unread to add bold format for the item thread.

Marking Items Read/Unread
To reread all the items on a certain subject, it is sometimes convenient to mark all of the items unread to
ensure that you do not miss any. You can also mark an entire requirement, task, or topic tree as unread.
1. Open the Change Request, Requirement, Task, or Topic view.
2. Select one or more items in the view that you want made unread or read.
3. Right-click the selected items, and choose Mark As Unread or Mark As Read. The items are marked
as specified, and the type style changes accordingly.

Finding Items
You can search all items displayed in views for the data contained in any displayed field.
1. Select a folder in Server Explorer or in one of the Eclipse Explorers.
2. Open the Change Request, Requirement, Task, or Topic view.
3. Enter CTRL+F. The Find dialog box opens.
4. Type part or all of the data in the Search For text box.
Do not use wild cards.
5. Select Forward to search the view from the top to the bottom, or select Backward to search the view
from the bottom to the top.
6. Select Starting at: Currently Selected Item to begin searching from the item that is presently selected,
or select Starting at: First Item to search from the first item in the view.
7. Select either All Displayed Fields or This Field.
If you select This field, select the field for which you want to search from the list box.
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8. Check Match Case if a case-sensitive search is appropriate.
9. Click Find to search.
Note: Use Ctrl+F to start a search. Use F3 to find the next item that matches the search text and
Shift+F3 to find the previous item that matches the search text

Displaying the List of Topics
1. Open the Topic view.
2. Click Link with Selection.
3. Select the folder containing the topics in the Server Explorer or in one of the Eclipse Explorers.
A list of topics for the selected folder displays in the Topic view. All topics shown in the Topic view:
•
•
•

Are attached to the folder selected from the Server Explorer or Eclipse Explorers.
Match the filter selected in the Topic view toolbar from the Filter list box.
Match the depth specified by the All Descendants button when selected in the Topic view toolbar.

Viewing Topics
1. Open the Topic view.
2. Do one of the following:
•

Click View as List. This action displays information in a list format. No relationships among topics
are shown. However, the list format allows you to:
•

•

See the values of specific fields as columns of data. For example, you can view the status for
each topic.
• Sort the topics by any column header.
Click View as Tree. This is the default format. This action displays each topic as an expandable
topic tree displaying the relationships between the topic and its child topics. The tree format allows
you to:
•
•
•

Click an unexpanded branch of a topic tree to expands it; click on it again to collapse it.
Double click a topic to open the Topic dialog box.
View special icons to show whether you have read the topics for which you are responsible.

Customizing the Detail View
The name of the template file controls the StarTeam component to be modified. For example, a template
named changerequest.detail.html controls the format and content of the Detail pane display for the
Change Request component.
Note: Sample Detail view templates are installed under the StarTeam for Eclipse installation folder in
the samples\details-templates folder.
1. Create an HTML template file for the corresponding component that you wish to customize.
If you want to format the contents of the Detail view for a change request, you would create a template
file named changerequest.details.html.
You must use the following file names for the component detail panes that you wish to customize:
•
•
•
•
•
•

folder.details.html
file.details.html
changerequest.details.html
task.details.html
topic.details.html
requirement.details.html
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Tip: Refer to the links at the end of this topic to review sample template files that you can use as a
starting point for creating your own templates for customizing the Detail view.
2. Make any desired modifications to the template file.
Follow the formatting example in the sample template file. The fields used in the Detail view HTML
templates are recognized by the client when they are contained between double tilde characters.
~~Status~~ represents the Status field found in the Change Request Properties dialog box.
3. Save the template files in the same directory as the starteam-servers.xml and starteamclient-options.xml files.
On a Windows system these files could be located in the C:\Documents and Settings\USER
\Application Data\Borland\StarTeam folder.

Links Internal and External
An internal link is a connection between two folders, two items, or a folder and an item on the same server.
An external link is a connection between two folders, two items, or a folder and an item on two different
server. You can view links by using the Link view. Creating links can have a number of benefits. For
example, when you are reviewing a file and the change requests that affect that file have been linked to it,
you can review the change requests without selecting the Change Request view.
In addition, linking files to change requests enables you to mark the change requests as fixed when you
check in the corresponding files. In turn, if you link each set of files to the requirements document that the
files fulfill, you can easily refer to or update the document. For more information on linking and unlinking
items, refer to the links at the end of this topic.
A link does not provide a connection to a single share (or reference), but to all related shares and branches
of an item. Links are not affected by any item operations, such as branching, moving, sharing, and so on.
By default, a link connects the tip revisions of the linked pair.
Columns in the Link View
Each link has two ends: a source and a target. Each row in the Link view defines a link that has the source
item or folder as one of its ends. Because you cannot see the other end of the link, columns in the link list
identify it for you.
The table below explains the columns provided in the Link view.
Column

Description

Created By

The name of the user who created the link.

Created On

The date/time the link was created.

View

The assumption is that you want to locate items in the
current view whenever possible, so the view field
contains one of the following:
-The name of the current view if the link was created in
the current view, or if the link was created in another view
but a shared copy of the item (to which the current item is
linked) exists in the current view.
-The name of the view containing the link. If the view is a
reference view, this is the name of the parent view.

Folder
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The name of the folder in which the folder or item in the
link list resides.

Column

Description

Item Type

Identifies the type of item the target end of the link is
attached to. This item is the one listed in the link list. The
values that can appear in this column are Folder, File,
Change Request, Task, and Topic.

Item

Identifies the item that the target end of the link is
attached to by its folder name, filename, change request
number, task number, and so on.

Item Details

Describes the item, using a folder description, file
description, change request synopsis, task name, or topic
title.

Item Version

When the ends of a link are pinned to specific revisions of
the folders or items, those revisions appear in the Item
Version and the Selection Version columns of the link list
(if that revision is in the current view).

Selection Version

The Item Version displays the version number of the
target end of the link if that revision is in the current view.
The Selection Version displays the revision number the
source end of the link. The source is either the folder
selected from the Server Explorer or the item selected
from the specified open view (when viewing the link for an
item).
When no revision number is in the column, that end of the
link is floating rather than pinned.

Comment

From the Link Properties dialog box, you can enter a
comment about this particular link. That comment
appears in this column.

File Status

Displays file status, such as Current, Missing, or Merge.

Locked By

If the file is locked, shows who the file has locked the file.

Folder Path

Shows folder path information only when the linked item
is in the same view. Otherwise, displays the following
message: Unavailable. Item in another

view.
Pinned and Floated Links
Pinning a link means that you can lock the link to the tip revision. The context menu in the Link view
enables you to pin links to the source or target items or both.
Floating a link means that you allow the link source or target to change from tip revision to tip revision as
new revisions are created. The context menu in the Link view enables you to float links to the source or
target items or both.

Customizing Link Item Properties
1. Click Link with Selection in the Link view's toolbar.
2. Select an item in one of the StarTeam views, Server Explorer, or Eclipse Explorers that links to a folder
or another item.
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3. In the Link view, right-click on a link, and choose Properties. The Properties dialog box opens. This
dialog box displays information about both the Source Item and Target Item.

Customizing Link Properties
1. Click Link with Selection in the Link view toolbar.
2. Select an item in one of the StarTeam views, Server Explorer, or Eclipse Explorers that links to a folder
or another item. The Link view displays all links for the selected item.
3. Right-click on a link in the Link view and choose Properties. The Properties dialog box opens.
4. Select the Link node to view or modify certain link properties.
5. Click OK.

Deleting Links
1. Open the Link view.
2. Click Link with Selection.
3. Select the folder or item that is the source or target of the link in one of the StarTeam views, Server
Explorer, or Eclipse Explorers that links to a folder or another item.
4. In the Link view, select one or more links to delete.
5. Right-click the selected links, and choose Delete Link.

Finding Files Associated with Active Process Items
When you have files associated with an active process item, you can quickly find all associated file
changes by following the steps below.
1. Open the view containing the active process item.
You can see what item is the active process item by looking at the Eclipse Status Bar.
The Status Bar displays the Active Process Item icon, followed by the name of the item.

2.
3.
4.
5.

Tip: The Server Explorer also reflects when you have an active process item specified at the view
level on the View icon followed the active process item informational text.
Open the Link view.
Click Link with Selection in the toolbar.
Select the active process item in the appropriate Change Request, Requirement, or Task view.
Right click on a link and choose Select Linked Item. The view opens containing the target of the
associated item.

Linking Files to Process Items
To link and pin a file revision to a process item
1. From one of the Eclipse Explorers, choose Team > Check In from the context menu.
The Check In dialog box opens.
2. Expand Process Item, and check Link and pin process item.
3. Click Select. The Select Process Item dialog box opens.
4. Select one of the following to limit the list of possible process items:
•
•
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List All Permitted Items: Displays all items that can be used as process items. If process rules are
not enforced, the list contains all change requests, requirements, and tasks.
List All Permitted Items Assigned To Me: Displays all the items for which you are responsible that
can be used as process items.
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•

List Linked Items: Lists the process items that are already linked to at least one of the files you are
checking in. No process item appears on the list more than once, even if it is linked to several files.
Also, when a process item is linked to more than one file, the dialog box displays the name of only
one file. Despite this fact, the application will update or create links for every file being added.

5. Select the Change Request, Requirement, Task, or Custom Component tab to restrict the list to a
specific type of item.
6. Select one item in the list to be the active process item and click OK.
7. Optional: In the Check In dialog box select one or both of the following check boxes:
a) Check Mark selected process item to closed state if work on the process item is completed.
a) To make changes to the selected process item's properties during the check-in process, check
Show property editor for selected process item.
8. Complete filling in the fields in the Check In dialog box and click OK.
Tip: If process rules are enforced, the use of some change requests, requirements, or tasks as
process items may not be permitted because of their status. If you select such an item and click OK,
the application notifies you of this fact.
To link and pin a file revision to the active process item
1. Click the File tab and select a file or files to be checked in.
2. Choose Team > Check In from the context menu to display the Check In dialog box.
If you have already specified a process item, it will appear by default in the Link and pin process item
field.
3. Check Link and pin process item to accept this active process item.
4. Optionally, in the Check In dialog box, check Mark selected process item to closed state if work on
the active process item is completed.
Note: Selecting this option will change the value of the process item's status property to the
Closed State specified on the Project Properties dialog box.
5. Complete filling in the fields in the Check In dialog box and click OK.

Linking Items Internally and Externally
It is possible to link two items, either internally in the same server configuration, or linking between two
items located on different server configurations, called external linking.
In StarTeam, an item is a file, change request, requirement, task, or topic. A link is a connection between
two folders, two items, or a folder and an item. Creating links can be quite useful. For example, linking a file
to a change request allows you to mark it as fixed when you check in the edited file. By linking files to the
requirements document that the files fulfill, you can easily refer to or update the document.
You can create several links at the same time if you want to link several items of the same type to one
particular item. For example, you might wish to link several change requests to a single file. To accomplish
this, you can create links using the context menu or Link button on the toolbar.
Note: When creating external links between items on different server configurations, both server
configurations need to be opened in Eclipse to be able to create or view the external links.
1. Open a StarTeam perspective. If you want to link two items on different server configurations, open
both server configurations and perspectives.
2. Select file(s) or folder(s) in the Server Explorer or in one of the Eclipse Explorers, or by selecting the
item(s) in one of the StarTeam Change Request, Requirement, Task, or Topic views.
3. Click Create/Complete Link in the main toolbar.
4. Complete the link by selecting:
•

A folder.
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•
•
•
•
•

One or more other files.
One or more change requests.
One or more requirements.
One or more topics and/or responses.
One or more tasks and/or subtasks.

To locate all items, you may need to switch to a different StarTeam view or use the All Descendants
button located on the toolbar of the Change Request, Requirement, Task, and Topic views.
5. To complete the link, click Create/Complete Link again in the main toolbar.
You can also view a link by selecting either of its ends. The end you select, whether a folder or an item, is
called the source. The other end of the link is called the target and is listed in the Item Type column on the
Link view.
Tip: If you change your mind about creating a link after you have started to create it, but before you
have finished completing it, you can press Esc.

Linking Specific Revisions
1. Open the Link view, and click Link with Selection in the Link view toolbar.
2. Select an item in one of the StarTeam views, Server Explorer, or Eclipse Explorers that links to a folder
or another item. The Link view displays all links for the selected item.
3. Select a link in the Link view.
4. Right-click the selected link and choose Properties. The Properties dialog box opens.
5. Select the Link node.
6. Optional: Type a description or comment about the link in the Comment text box. This text displays in
the Comment column of the Link view.
7. Do one of the following in the Source Item group box:
•
•

Click Pin to display the Select Version dialog box. Select a specific folder or item revision from the
list. This revision number displays in the Selection Version column of the Link view.
Click Float so that the link is always connected to the tip revision of this item.

8. Do one of the following in the Is Linked to Target Item group box:
•
•

Click Pin to display the Select Version dialog box. Select a specific folder or item revision from the
list. This revision number displays in the Item Version column of the Link view.
Click Float so that the link is always connected to the tip revision of this item.

9. Click OK.

Reviewing Linked Change Requests
1. Select the file that is linked to the change request in one of the Eclipse Explorers.
2. Right-click on the file, and choose Team > Check In. The Check In dialog box opens.
3. Expand the Change Requests section. This section expands and displays a list of any Change
Requests Linked In This View.
Note: No change request displays in the list more than once, even if it is linked to several of the files
you are checking in. When a change request is linked to more than one file, the list displays the name
of only one of the files.
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User-defined Property Fields
StarTeam enables you to customize the repository by adding user-defined property fields to files, change
requests, requirements, topics, and tasks.
You can also change the properties of some existing items. For example, you can customize the Priority
change request field. Instead of using the default values (Yes and No), your company can change the item
properties so that StarTeam prioritizes change requests on a scale from 1 (high) to 10 (low).
The application adds new property fields and modified property fields to the database used by your current
server configuration. These fields are available in the same locations as other item property fields.
Note: When you customize the database, you should use the stcmd command line to exclusively
lock the server. For more information, contact your StarTeam Server Administrator.
Modifications to Existing Fields
You can modify some existing property fields and any custom fields that have been created. The property
fields that can be modified are always enumerated types.
For example, Priority is an existing change request property that can be customized. On the Synopsis tab
of the Change Request Properties dialog box, Priority has the values Yes and No, but is implemented as
an enumerated type with Yes having the numeric code of 1 and No having the numeric code of 0. If your
company prefers to prioritize change requests on a scale from 1 (high) to 10 (low), you can add additional
values. You can use the current numeric codes 0 and 1 with new names or disable them.
Note: Try to take advantage of the existing codes in some way.
For example, you might change the name of the enumerated value No to Not Prioritized. Then you can
query for Priority equal to 0 to identify the change requests that need to be prioritized.
You might also change the name Yes to Priority 1, as it already has the code 1. Then you can add
additional values for Priority 2 through Priority 10. Any numeric codes that you assign must have a value
greater than 100, because the application reserves the values 0 through 100 for internal uses. So you
might add a value with the name Priority 2 and the numeric code 101, Priority 3 with the numeric code 102,
and so on.
Tip: Queries use the numeric codes to make comparisons based on enumerated values. Using the
above codes, you can write a query to locate Priorities 1, 2, and 3, by querying for Priority greater
than 0 and less than 103.
By default, sort and list boxes display items in the order that they appear in the Add Field or Modify Field
dialog boxes. You can use the sort options to sort by name in ASCII or alphabetical order.

Configuring New Property Fields
Before creating custom fields, have your StarTeam Server Administrator use the stcmd command line to
exclusively lock the server to ensure that other users cannot access it.
You can create any number of property fields for application items. A new field can be any of the following
types: date/time, enumerated, integer, Real, Text, or UserID.
1. Right click a file or folder from the Server Explorer, and choose Advanced > Customize.
•
•

Alternative 1: Open the Change Request, Requirement, Task, or Topic views, right click on an item,
and choose Advanced > Customize.
Alternative 2: Right click a file or folder from one of the Eclipse Explorers, and choose Team >
Advanced > Customize.

The Customize dialog box opens.
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2. Review the Customize dialog box to find the fields that can be customized.
The fields and icon graphics accompanying them are as follows:
•
•
•

An application field. It is always an enumerated type and is fully customizable. You can add, disable,
rename, and reorder its values.
A new field. It can be one of several types and is fully customizable. If the new field is disabled, the
icon is grayed-out
A restricted enumerated type. You can change only the names the application displays for the
values of this field.

Usually these fields have workflow characteristics that cannot be altered.
3. Click Add. The Add Field dialog box opens.
4. Type the name for the new field to be used by the database in the Field name text box.
Use only alphanumeric characters and no spaces in this name. The name should be less than 31 ASCII
characters (including Usr_) and not contain the following characters, which are not accepted by one or
more of the databases that the application supports: = \\.^$@,;!:#*&<>?-//%|[](())+" Be careful about
selecting the field name, as it cannot be changed once you click OK.
5. Type the name that the application will display to users in the Display Name text box.
6. Select a type from the Type list box and follow the steps in the procedure for that type.

Configuring Date/Time Fields
1. Right click a file or folder from the Server Explorer, and choose Advanced > Customize.
•
•

Alternative 1: Open the Change Request, Requirement, Task, or Topic views, right click on an item,
and choose Advanced > Customize.
Alternative 2: Right click a file or folder from one of the Eclipse Explorers, and choose Team >
Advanced > Customize.

The Customize dialog box opens.
2. Review the Customize dialog box to find the fields that can be customized.
The fields and icon graphics accompanying them are as follows:
•
•
•

An application field. It is always an enumerated type and is fully customizable. You can add, disable,
rename, and reorder its values.
A new field. It can be one of several types and is fully customizable. If the new field is disabled, the
icon is grayed-out
A restricted enumerated type. You can change only the names the application displays for the
values of this field.

Usually these fields have workflow characteristics that cannot be altered.
3. Click Add. The Add Field dialog box opens.
4. Type the name for the new field to be used by the database in the Field name text box.
Use only alphanumeric characters and no spaces in this name. The name should be less than 31 ASCII
characters (including Usr_) and not contain the following characters, which are not accepted by one or
more of the databases that the application supports: = \\.^$@,;!:#*&<>?-//%|[](())+" Be careful about
selecting the field name, as it cannot be changed once you click OK.
5. Type the name that the application will display to users in the Display Name text box.
6. Select Time in the Type text box.
7. Optional: Type a default date or time in the Default value text box, using the appropriate format for your
locale. This value automatically becomes the value used for all existing items that have the field as a
property. It also becomes the default value for newly created items. You can change this value
manually on the Custom tab of the item Properties dialog box. If you do not set a default, no value is
placed in the database for any item with this field, unless you set the field to a value manually.
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8. Click OK.

Configuring Text Fields
1. Right click a file or folder from the Server Explorer, and choose Advanced > Customize.
•
•

Alternative 1: Open the Change Request, Requirement, Task, or Topic views, right click on an item,
and choose Advanced > Customize.
Alternative 2: Right click a file or folder from one of the Eclipse Explorers, and choose Team >
Advanced > Customize.

The Customize dialog box opens.
2. Review the Customize dialog box to find the fields that can be customized.
The fields and icon graphics accompanying them are as follows:
•
•
•

3.
4.

5.
6.

An application field. It is always an enumerated type and is fully customizable. You can add, disable,
rename, and reorder its values.
A new field. It can be one of several types and is fully customizable. If the new field is disabled, the
icon is grayed-out
A restricted enumerated type. You can change only the names the application displays for the
values of this field.

Usually these fields have workflow characteristics that cannot be altered.
Click Add. The Add Field dialog box opens.
Type the name for the new field to be used by the database in the Field name text box.
Use only alphanumeric characters and no spaces in this name. The name should be less than 31 ASCII
characters (including Usr_) and not contain the following characters, which are not accepted by one or
more of the databases that the application supports: = \\.^$@,;!:#*&<>?-//%|[](())+" Be careful about
selecting the field name, as it cannot be changed once you click OK.
Type the name that the application will display to users in the Display Name text box.
In Type, select Text.
Note: A default value cannot be set for a text field, because most text fields contain unique data.

7. Use the default maximum length (255 characters) or type a number of characters from 2 to 20,000 in
the Length text box.
Note: Verify the Length is adequate, because you cannot change it after exiting the dialog box.
8. Check Input required if you want to make the field required.
Required fields are rarely used with files, because they affect the File Properties dialog box only.

Configuring User ID Fields
1. Right click a file or folder from the Server Explorer, and choose Advanced > Customize.
•
•

Alternative 1: Open the Change Request, Requirement, Task, or Topic views, right click on an item,
and choose Advanced > Customize.
Alternative 2: Right click a file or folder from one of the Eclipse Explorers, and choose Team >
Advanced > Customize.

The Customize dialog box opens.
2. Review the Customize dialog box to find the fields that can be customized.
The fields and icon graphics accompanying them are as follows:
•

An application field. It is always an enumerated type and is fully customizable. You can add, disable,
rename, and reorder its values.
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•
•

A new field. It can be one of several types and is fully customizable. If the new field is disabled, the
icon is grayed-out
A restricted enumerated type. You can change only the names the application displays for the
values of this field.

Usually these fields have workflow characteristics that cannot be altered.
3. Click Add. The Add Field dialog box opens.
4. Type the name for the new field to be used by the database in the Field name text box.
Use only alphanumeric characters and no spaces in this name. The name should be less than 31 ASCII
characters (including Usr_) and not contain the following characters, which are not accepted by one or
more of the databases that the application supports: = \\.^$@,;!:#*&<>?-//%|[](())+" Be careful about
selecting the field name, as it cannot be changed once you click OK.
5. Type the name that the application will display to users in the Display Name text box.
6. In Type, select UserID.
7. Check Input required to make this a required field.
Required fields are rarely used with files, because they affect the File Properties dialog box only.
8. Click OK.

Displaying Custom Property Fields
1. Select the folder in the Server Explorer or the Eclipse Explorers that contains the task that you want to
modify.
2. Do one of the following:
•
•

Open an item view, such as, the Change Request, Requirement, Task, or Topic views.
Select a file in either the Server Explorer or in one of the Eclipse Explorers.

3. Choose Properties. The Properties dialog box opens.
4. Do one of the following:
•

If selecting a file from one of the Eclipse Explorers, expand StarTeam Provider, select the File
node, and click the Custom tab.

•

If working in one of the item views, click the Custom tab.

The Custom tab contains any custom fields created for the selected item.
5. Click OK.

Possible Field Changes
The following sections describe the possible field changes that you can make when modifying an existing
property field.
Enumerated Types
You can modify enumerated types as follows:
•
•
•
•
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Add values to possible values (all fields but those with an icon displaying a small yellow lock in its
bottom left corner).
Change the names of possible values.
Change its default value (all fields but those with an icon displaying a small yellow lock in its bottom left
corner).
Change the display name (only fields with an icon displaying a pencil in its center or an icon displaying
the head and shoulders of a person).
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•
•
•

Disable possible values (all fields but those with an icon displaying a small yellow lock in its bottom left
corner).
Enable disabled values (all fields but those with an icon displaying a small yellow lock in its bottom left
corner).
Reorder possible values (all fields but those with an icon displaying a small yellow lock in its bottom left
corner).

Integer or Real Types
You can modify integer or real types as follows:
•
•

Change the display name.
Enter a new default value

Text Types
You can modify text types as follows:
•
•

Change the display name.
Indicate whether the field is required or elective.
Note: You cannot change maximum length.

Date/Time Types
You can modify date/time types as follows:
•
•

Change the display name.
Enter a new default value

User ID Types
You can modify user ID types as follows:
•
•

Change the display name.
Indicate whether the field is required or elective.

User-defined Property Field Types
The following table lists the data types you can use when creating a user-defined field.
Field Type

Description

Real

Indicates that the field is numeric and can contain a decimal point. The range is
1.7E +/- 308 (15 digits); however, the range may be limited by your database.
For example, Microsoft SQL Server ignores all but the first 32 characters.

Enumerated

Indicates that the field will contain a value from a set of enumerated values. For
example, the enumerated values for a field named Traffic light would be red,
yellow, and green.

Integer

Indicates that the field contains a whole number. The range is limited to nine
digits to ensure that you can migrate from database to database successfully.

Text

Indicates that the field is a string of the length that you specify.

Date/Time

Indicates that the field will contain a date and time.

User ID

Indicates that the field will contain a user's name from the set of values in the list
of users.
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StarTeam Keywords
By enabling keyword expansion for a project, you can embed keywords within text files. These keywords
are automatically expanded during file check-outs, to provide file and revision information within the file.
You should use only one keyword per line.
Item

Description

$Author$

User who checked in the revision.

$Date$ and $DateUTC$

Date and time stamps for the revision. $DateUTC$ is the same
as $Date$ except that a UTC time replaces the local time. UTC
times end in a "Z" which makes them readily identifiable.

$Header$ and $HeaderUTC$

Combinations of Workfile, Revision, Date, and Author.

$HeaderUTC$ is the same as $Header$ except that a UTC
time replaces the local time. UTC times end in a "Z", which makes
them readily identifiable. For Java users, $Header$ can cause
problems if \u (for unicode) appears in the expanded header. For
example, suppose that a file named foo.java is stored in D:
\util The first time you compile it with $Header$, the header
is expanded to: $Header$: D:\util\foo.java, 1,

7/27/99 11:05:48 AM, StarTeam Server
Administrator$
Even though this header is contained in a Java comment, the
Java compiler always looks for \u. The second time you compile
foo.java, a compiler error occurs.

$History$

Added to the source file, typically within a comment field. The
$History$ keyword creates a history record for the latest (tip)
revision and places the information after the keyword. For
example, after the file is checked-out for the first time, the file
would contain the following:

// ...
// $History
// 1 YourProject 1.0 2005-11-19 00:06:57Z

Joe Smith
// This is a revision comment.
// $
StarTeam adds the history information to the file and places it
outside of the "$" signs so that it becomes a versioned part of
the file. Since the history records become part of the versioned file
content, you can delete extra or excessive history records at any
time. If this file is modified and checked-in, any subsequent checkout adds one additional record immediately after the $History$
keyword:

// $History
// 2 YourProject 1.0 2006-06-01 00:06:57Z
Joe Smith
// This is a another revision comment.
// $
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Item

Description

// 1 YourProject 1.0 2005-11-19 00:06:57Z
Joe Smith
// This is a revision comment.
StarTeam uses the MD5 and local file timestamp of the postexpanded file for sync records. Accordingly, when you check-out a
tip revision, StarTeam reports a current status for the file even
though a compare tool would show an additional history record in
the locally-stored file as compared to the version of the file saved
on the Server.
Important: Do not delete the standalone // $ line. StarTeam
places the most recent historical revision information within
the // $ delimiter. The rest of the revision entries are outside
of this delimiter. StarTeam does not recognize the $History$
keyword if you remove this line.

$Id$

Similar to $HeaderUTC$ except that it is a combination of
Workfile, the branch revision number (preceded by "v" for version;
for example, v 1.2.1.0), UTC time, and Author. The branch
revision number is in dot notation.

$Locker$

User who has the file exclusively locked (if any).

$Log$, $Log[x]$, $LogUTC$, and
$LogUTC[x]$

File change history. $Log$ is a special keyword because it
expands to a multiline entry. The $Log$ keyword expands to
include information for each revision of the file. Revision history
includes Revision Number, Date, Author, and Reason for Check
In.
Use $Log$ to retain entries for each revision within the file.
Use $Log[x]$ to limit the number of revisions for which entries
are retained. Replace x with the number of entries to be retained.
For example, $Log[8]saves the entries for the most recent 8
revisions. If you replace x with a number less than 1 or with a
non-numeric character, StarTeam ignores x and retains all entries
(as with $Log$). $LogUTC$ and $LogUTC[x]$ are the same
as $Log$ and $Log[x]$ except that a UTC time replaces the
local time. UTC times end in a "Z".

$NoKeywords$

Turn off keyword expansion for the rest of the file.

$Project$

Name of the project.

$Revision$

Revision number (an integer).

$Folder$

Name of the folder.

$Workfile$

Unqualified name of the working file (for example, foo.cpp).

Caution: Never use a keyword in a revision comment, as it will be expanded during the keyword
expansion process.

Terminology
This section defines some of the more common terms used in StarTeam that are used throughout the
documentation.
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Access rights

A security feature. The rights granted (or denied, in exceptional cases) to
users or groups that allow team members to see, modify, create, and
delete items.

Adding files

Process of placing files under version control by adding them to a project
view.

Administrator

A functional role in the operation of the application. Administrators install,
configure/set up, create and/or import projects, manage server
configurations, users and groups, and so on.

Alternate working folder

Allows you to store project files on your workstation at a specific location
you have selected. Using an alternate working folder for the root of a
view or a branch in an application folder hierarchy can also alter the path
of the working folders used for child folders.

Application file

A file under version control; therefore, a file that is in an application
project.

Application folder

A folder in the application folder hierarchy. Application folders help
organize the project view into discrete understandable parts. Each folder
has a working folder that corresponds to it and exists on your hard drive.

Application folder hierarchy

The hierarchy of folders as it appears in the Server Explorer. When you
map a view and use the folder hierarchy, the folder structure on the
virtual disk matches the folder structure you see in the application. This
may or may not match the working folder structure on your workstation.

Archive

File or group of files that makes it possible to recreate past revisions of a
file under version control. An archive can also be, as in the application,
the folder that stores such files.

Audit entry

Record of an action performed on an application project that appears in
the audit log.

Audit log

Chronological record kept by the application that shows all actions
performed on folders and items, such as files and change requests.

Author

User that created a revision.

Blank branching view

An empty branching view. It has no correlation to the parent view. Also
called non-derived view.

Branch

An independent item derived from a corresponding item in a parent view.
In the case of a text file, the branched item can later be merged with the
file from which it originated. This term also refers to a branch of a tree,
such as the folder hierarchy or a topic tree.

Branch revision

A number is assigned by the application to a revision of an item. It
indicates how many consecutive revisions have been made in a view; it
branches when the item is branched into a new view.

Branching view

A view that may or may not be derived from a parent view. When not
derived from a parent view, it is a blank branching view. Branching views
always permit branching. If they float and have the Branch on change
option set, they are updated by the parent view on a file-by-file basis until
the file changes in the branching view. If they float and do not have the
Branch on change option set, updates are sent to the parent view until
the Branch on change option is set. If they are based on a label, a
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promotion state, or a moment in time, they are read-only, unless the
Branch on change option is set.
Build

The process of compiling, assembling, and linking all project files in
proper sequence to produce a software product. Also an event in the life
cycle of a product chosen to represent a quantifiable step in progress for
a project.

Build label

Label for a particular product build; in the application, a view label may
serve as a build label.

Change request

Item that reports a fault or error in a product or suggests an
enhancement.

Check in

Operation that stores a new file revision in the repository. The person
who checks the file in can keep it locked or release the file to others by
unlocking it.

Check out

Operation that retrieves a revision of a file from the application Server
and places it in a working folder for the user. A user can check out a file
with or without the intention of altering that file. Locking the file marks the
beginning of a revision.

Compression

Data transferred between your workstation and the server can be
compressed to reduce the amount of traffic on the network. However, the
time to compress and decompress the data is added to the transfer time.

Configuration

A relative arrangement of parts or elements. An application configuration
isolates a view, folder, or item to a particular revision. For example, you
can configure a view to be current or based on a view label, a promotion
state, or a selected date and time.

Container

Term indicating the ability to contain other types of items. For example a
project is a container for views, folders, and items. Views and folders are
also containers.

Current

File status. Content of the file in the working folder is the same as the
content of the tip revision of the file.

Delta storage

Method of computing differences between progressive revisions of a file.

Exclusive lock

An exclusive lock indicates to others that you intend to make changes on
an item. For a file, the icon others see is yellow padlock, while you see
an icon with a small yellow key and the head and shoulders of a person.
Other people cannot check in an item that you have exclusively locked.

File compression

Technique for reducing the size of a file by removing redundant
information. Most disk files contain repetitions of common sequences of
characters. Compression algorithms remove the additional occurrences
of these sequences and save the information that permits their
restoration. Selecting file compression may reduce vault space
requirements, as well as improve performance.

Filter

Criteria used to select a few items from among many. The Filter list box
allows you to display only the items that are of interest. Applying a filter
may also control what columns are displayed, what columns are sorted,
and how the values are grouped in the sorted columns.

Fixed change request

Designation indicating that a change request has been resolved.
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Float

For views, a floating view is one that stays current with its parent view. In
other words, updates to the parent view are sent to the child view. If the
child is not read-only, updates to the child view also go to the parent.

Folder hierarchy

Hierarchical display of an application view and its associated folders. The
folder hierarchy is always displayed in the Server Explorer.

Frozen

An item is said to be frozen (and, therefore, read-only) if it is based on
the state of the corresponding item in the parent view at a specific
moment in time and cannot be branched. An item is also frozen if you
reconfigure it to a specific label, promotion state, or time in its past.

History list

List of revisions for the file selected from the Server Explorer or from one
of the Eclipse Explorers. The application displays the History list when
you open the History view.

Item

The application object or element. Items include files, change requests,
requirements, tasks, topics, responses, and audit entries. A folder is also
treated as an item, even though it is a container for items.

Keyword

Reserved words beginning and ending with a dollar sign ($). When used
in a text file, the application replaces these words with the data that they
represent. For example $Author$ is replaced by the name of the user
who checked in the file.

Keyword expansion

A technique used to insert information in a text file. Keywords are
replaced by the data they represent.

Label

In version control, the act of attaching a view or revision label (name) to
one or more folders and/or items.

Labeled configuration

The basis for a new or reconfigured view. The view contains only the
items with the label you specify.

Link

Method of connecting any two folders, items, or a folder and an item. If
you select an item, the client provides a Link view that shows all other
items to which it is linked.

Lock

File locking is a technique used to inform others that you are revising a
file (exclusive lock) or considering its revision (non-exclusive lock).
Checking files out or in does not imply automatic locking or unlocking in
the application, as these operations can be performed manually. Locks
can also be overridden and broken.

MAPI

Acronym for Mail Application Programming Interface, a programming
interface that permits an application to send and receive electronic mail
via the Microsoft Mail messaging system. The application uses SMTP
and not MAPI.

Merge

File status that indicates that the working file is not based on the tip
revision of the file. When you check this file in or out, the application asks
if you want to merge it with the tip revision; or
Process of combining a working file with the tip revision of that file or
combining a branched file with the original file from which it was
branched. This operation involves a three-way comparison, in which both
files are compared with the file revision that is their most recent common
ancestor. The combined file can be inspected or revised by the user
before it is checked in.
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Milestone

An event in the life cycle of a product that represents a significant step in
its progress, for example, its final release. In the application, when you
reach a milestone, you can apply a view label (usually a build label) to
indicate that the milestone has been reached.
In Microsoft Project, a milestone is a type of task that represents a
significant landmark, development, or turning point in the life of a
scheduled project. You usually define a milestone by entering a task
name and assigning it a duration of zero. Milestones typically signal that
the work has started or is completed and do not represent the act of
doing of the work.

Missing

ile status indicating that the file is not in your working folder. You may
want to check the file out.

Modified

File status indicating that the working file has been altered and is based
on the tip revision of this file. You may want to check this file in.

Non-exclusive lock

A lock that notifies others that you are considering changing the file.
When you have a file locked non-exclusively, others can check the file in.

Not In View

File status that indicates the file is in the working folder, but not in the
application view. You may want to add this file to the view.

Notification of events

If this feature is enabled, the application notifies that you have become
responsible for a change request, that a requirement or task for which
you are responsible has changed, or that a topic for which you are a
recipient has changed. The notification appears as an appropriate icon
on the status bar.

Object

Generic term used in object-oriented programming and elsewhere to
indicate something upon which operations can be performed.

Out Of Date

File status indicating that your working file is a copy of an old revision of
the file. If you need the current revision, check it out.

Preferences

User-selectable choices for the behavior of the application on a specific
workstation.

Pooled connections

Concurrent connections controlled internally by the server that the server
opens to the database engine. The range is usually database-specific
and may also depend upon the number of database licenses.

Project

A project is a set of related folders and their contents that usually
represents a single product under application version control. Large,
complex projects have many folders and files that are worked on by
many team members. A project is the collection and organization of all
these files and folders. A project might contain the files that comprise a
software program, a technical publication, a legal case, a financial
forecast, a building, an aircraft, or anything involving numerous files,
each of which may undergo many revisions as the job progresses.

Promotion state

A state through which a product passes. For example, a software
application that goes through a development, test, and release cycle
could use the promotion states Development, Test, and Release. In the
application, each promotion state has a view label assigned to it.

Promotion state configuration

Basis for a new or reconfigured view. The view contain only items with
the promotion state you specify.
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Properties

Attributes stored for each item and each revision of an item under
version control.

Protocol

Set of rules governing how something is done.

Query

Criteria used to select a few items from among many. You can apply a
query to items in the view to display only the items of interest.

Read-only reference view

A reference view is a view that either cannot be changed at all or
changes only when its parent view changes. If it floats, it is updated as its
parent changes. If it is based on a label and the items with the specified
label change in the parent view, the read-only reference view reflects that
fact. If it is based on a specific date and time, it is frozen, to show what
the parent view looked like at that point in time and cannot be rolled
back.

Reconfiguring

A view, folder, or item can be reconfigured to a point in the past, as
defined by a label, promotion state, or a point in time.

Reference count

List of the items that reference another item. For example, a file may be
shared by two projects on the same server and, therefore, have two
references to it.

Reference view

A view derived from a parent view. It generally uses a different folder as
a root folder and the same working folders as those of its parent. If it
floats, it receives updates as the parent view changes. If it floats and is
not read-only, it sends updates to the parent view as it changes. If the
reference view is based a specific label or date and time within the
parent view, it is frozen at that moment in time and is read-only.

Repository

The database and hive associated with a particular server configuration.
Each hive contains an Archives and a Cache folder for file storage.

Repository customization

The application feature that allows you to modify values of existing
enumerated fields and create customized fields for items to represent
information specific to your working environment. Your license
determines whether you have this feature.

Requirement component

The application component that allows users to create, track, and
complete requirements related to the project.

Response

Replies to a topic that, along with the topic, form a hierarchical structure
called a topic tree.

Revision

Set of changes to an item. As an item is revised, each set of changes is
saved as a revision.

Revision label

Method of identifying a revision of an item or a set of revisions by name;
used primarily for files. For example, when you check in a group of files
that may need to be checked out together, you can give them a revision
label.

Revision number

The revision number is an identification number assigned by the
application to a revision of an item. It indicates how many consecutive
revisions have been made since the item was originally created.

Root folder

The top folder in an application folder hierarchy. It has the same name as
the view.
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Secondary sort

Sorting items by group in a list that is already sorted (primary sort). For
example a File list might be sorted by extension, then sorted by name
within groups of the same extension.

Server

A computer or system that provides services to clients and is running the
StarTeam Server software. The clients may be other computers. The
server controls the repository, which is a storage place for file revision
archives, and a database that contains information about files, such as
their descriptions, the number of revisions, and so on.

Server configuration

Contains the repository and option settings selected when you set up the
application server. For example, the administrator may want projects to
use encryption and compression, so the server configuration specifies
these features. The application items, such as folders and files, can be
shared provided their projects use the same server configuration. You
can start a server with any one of several server configurations, but that
configuration controls what projects, views, and so on that you can
access during that session.

Shortcut

A file that starts another application, often with a specific document or set
of data. The shortcut is usually stored as an icon on your desktop.

SMTP

Simple Mail Transfer Protocol, commonly used for Internet and UNIX
mail systems. It usually uses port 25. Sending items via email in the
application requires SMTP.

Sort

To place items in ascending or descending order in the view, based on
the value in one column. Depending on the values in the column, values
are sorted numerically, alphanumerically, or by an internal order or key.
Click the column header to change the sort order from ascending to
descending or vice versa.

Status

File status is the relationship between the working file and the tip revision
in the repository. The file statuses are: In View, Not in View, Missing,
Current, Merge, Modified, Out of Date, and Unknown.

Storage method

Revisions stored in the archive (or vault) for a specific file can be
changed from one type of storage and compression to another. There
are two types of storage: forward delta storage, which is recommended
for text files, and full revision storage, which is recommended for binary
files and text files that change massively from revision to revision.

Task component

Users can create, track, and resolve tasks related to their projects with
this component if your company has licensed Enterprise Advantage or
Enterprise. The component also interoperates with Microsoft Project.

TCP/IP

A protocol for communication between computers used by the Internet;
acronym for Transmission Control Protocol/Internet Protocol.

Test command

Command that you enter so that the application can perform an
automated procedure to test a defect.

Text file or ASCII file

File that contains only printable text characters, spaces, carriage returns,
and sometimes tabs and an end-of-file marker, without formatting codes.
The application identifies as text files any files that contain no null
characters. All other files are binary.

Time stamp

Information maintained by the application about files and revisions. For
file revisions, the time stamp is the date and time that the file was
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checked into the application. For files, it is the date and time for the
working file.
Tip revision

Most recent revision to an item. The tip revision is based on your view
configuration. For example, if your view is configured to a particular label,
the tip revision is the revision with that label. If your view is configured to
a particular date and time, the tip revision is the one that was checked in
just prior to that point in time.

Title bar

Bar that shows the name of the application and, if it is maximized, of the
selected child window. For a view, the child window name includes both
the project name and the view name, followed by the current working
folder for the root folder.

Toolbar

Bar that contains buttons or icons, each of which performs a variety of
functions. Usually located at the top of the screen, but can be dragged to
any edge of the window or float in a separate window that can move
anywhere on the screen.

Topic

First message on a particular subject attached to a folder in the
application folder hierarchy. After this message has been submitted by a
team member, others may respond to it, creating a topic tree.

Topic tree

Topic tree represents a threaded conversation of the topic with its
responses and the responses to those responses.

Unknown

File status indicating that a file in the working folder has the same name
as a file in the view, but that the file has not been checked out from the
repository. You may have copied the file from another location.
Use the Update Status command to determine the correct status.
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Unlock

The process of releasing a locked file, indicating to others that you no
longer wish to change the file.

User

An individual given access to an application server configuration and the
projects it manages.

Vault

Folder in which revisions of the files that are under version control are
stored.

Vault file

File in the vault that stores file revisions.

Version control

Version control is the process of storing and tracking changes (revisions)
to one or more files. The main advantage of using an automated version
control system is fast, easy recall of previous revisions. The application
also tracks revisions of other items, such as change requests.

Version control system

Application software that permits you to manage multiple revisions of the
same file. It maintains the revision history that is generated as files
evolve into their final forms.

View

A view, also called a project view, is a way of looking at a project. It
enables you to see the parts of the project you need to see, without the
confusion of seeing the entire project. A view consists of an application
folder hierarchy and the items associated with each folder in that
hierarchy. The name of a project and its root view are often identical. A
view may or may not permit branching, be read only, or have a
connection to its parent view.
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View label

Serves as a time stamp for the entire contents of a view. Having a view
label allows you to roll back a view to that label and see everything that
existed at that point in time. Unless the view label is frozen, you can
adjust it by attaching or detaching it from items. You can also move a
view label from one revision to another.

Work around

Steps users must take to avoid a problem in the product. Workarounds
are frequently offered until the resolution of a defect becomes available.

Working file

Any file in a working folder can be considered a working file. Often, these
files have been checked out for modification. When checked in, a
working file becomes a revision.

Working folder

Workstation folder to which copies of application files are checked out
and from which files are added and checked in to the application folder.

Contacting Support
Borland (a Micro Focus company) is committed to providing world-class services in the areas of consulting
and technical support. Qualified technical support engineers are prepared to handle your support needs on
a case-by-case basis or in an ongoing partnership. Micro Focus provides worldwide support, delivering
timely, reliable service to ensure every customer's business success.
For more information about Borland support services, visit the Micro Focus SupportLine Web site at http://
supportline.microfocus.com where registered users can find product upgrades as well as previous versions
of a product. Additionally, users can find the Knowledge Base, Product Documentation, Community
Forums, and support resources.
When contacting support, be prepared to provide complete information about your environment, the
product version, and a detailed description of the problem, including steps to reproduce the problem.
For support on third-party tools or documentation, contact the vendor of the tool.
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