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Introduction
This Help provides all the information you need to install and uninstall SilkTest. It describes hardware and
software requirements and details the various setup options.

SilkTest Product Suite
The SilkTest product suite includes the following components:
•

SilkTest Workbench – SilkTest Workbench is the new, native quality testing environment that
offers .NET scripting for power users and innovative storyboard-based visual tests to make testing more
accessible.
Silk4NET – The Silk4NET Visual Studio plug-in enables you to create Visual Basic or C# test scripts
directly in Visual Studio.
Silk4J – The Silk4J Eclipse plug-in enables you to create Java-based test scripts directly in your Eclipse
environment.
SilkTest Recorder – SilkTest Recorder enables you to record and replay tests using a GUI and then
export those tests to SilkTest Classic, Silk4J, or Silk4NET.
SilkTest Classic – SilkTest Classic is the traditional, 4Test SilkTest product.
SilkTest Agents – The SilkTest Agent is the software process that translates the commands in your
tests into GUI-specific commands. In other words, the Agent drives and monitors the application you
are testing. One Agent can run locally on the host machine. In a networked environment, any number of
Agents can run on remote machines.

•
•
•
•
•

The product suite that you install determines which components are available. To install all components,
choose the complete install option. To install all components with the exception of SilkTest Classic, choose
the standard install option.

System Requirements and Prerequisites
The following section identifies the system requirements for installing and running SilkTest.

Hardware Requirements
We recommend the following hardware requirements:
System Area

Requirement

Processor

Intel or AMD DualCore processor running at 2 GHz

RAM

2 GB

Hard disk space

2 GB of free disk space

Platform Support
Platforms
SilkTest 2011 runs on the following platforms:
•
•

Windows XP SP3
Windows Vista SP1 or SP2
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•
•
•
•

Windows 7
Windows 7 SP1
Windows 2008
Windows 2008 R2

Technology Domains and Browsers
SilkTest 2011 supports applications that use the following browsers or are developed in:
Technology Type

Supported Version for SilkTest Workbench,
SilkTest Recorder, Silk4NET, Silk4J, SilkTest
Classic using the Open Agent

Supported Version for SilkTest Classic
using the Classic Agent

Adobe Flex

3.0, 3.2, 3.3, 3.4, 3.5, 4.0, 4.1, 4.5.1

not supported

Firefox

3.5, 3.6 (playback only), 4.0 (playback only) , 5.0
(playback only), 6.0 (playback only)

not supported

Internet Explorer

6, 7, 8, 9

6, 7, 8, 9

Java AWT/Swing

Java 1.6

Java 1.6

Java SWT

3.2, 3.3, 3.4, 3.5, 3.6, 3.7

not supported

SAP

SAPGUI client 7.10, SAPGUI client 7.20

not supported

Silverlight

3 (Silverlight Runtime 4), 4 (Silverlight Runtime 4) not supported

Rumba

8.1, 8.2

not supported

Win 32

any

any

WinForms

.NET 2.0, 3.0, 3.5, 3.5 SP1, 4.0

not supported

WPF

.NET 3.5 SP1, 4.0

not supported

Databases
SilkTest 2011 supports the following databases with the noted operating systems for SilkTest Workbench
asset storage:
•
•
•
•

SQL Server 2008 (SP1) + Express
SQL Server 2005 (SP3) + Express
Oracle 11.1
Oracle 11.2
Note: If you choose to install SQL Server 2008 Express SP1 during the SilkTest installation, ensure
that you have one of the supported operating systems:
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•
•
•
•

Windows 7
Windows Server 2008
Windows Server 2008 R2
Windows Vista SP1 or SP2

•

Note: For Windows Vista SP1, you must install the full version of .NET 3.5 SP1 or 4.0 on
your computer before you can install SQL Server. Otherwise, SQL Server Express might not
install. To install the full version of .NET 3.5 SP1 or 4.0, download it from the Microsoft Web
site.
Windows XP Service Pack 3

Tested Configurations
Tested configurations, by platform, are listed below. Note that it is not possible to test all combinations.
Experience indicates that various combinations can result in different behavior with SilkTest. Micro Focus
makes every attempt to test as many of these combinations as possible.
Note: While you can use SilkTest on 64-bit operating systems, SilkTest only supports testing 64-bit
applications for Java, .NET, and Windows API-based applications.
Note: You must have local administrator rights to use SilkTest.
Platform Type

Tested Configurations for SilkTest
Tested Configurations for SilkTest
Workbench, SilkTest Recorder, Silk4NET,
Classic using the Classic Agent
Silk4J, SilkTest Classic using the Open Agent

Microsoft Windows Windows Internet Explorer 8
7 (32bit)
Mozilla Firefox 3.6 (playback only)
Microsoft Windows
Mozilla Firefox 5.0
Server 2008 SP2
Flex 3.5, 4.1, 4.5.1
(32bit)

Windows Internet Explorer 8 (playback only)
Win 32

Java 1.6 (AWT/Swing)
SWT 3.5, 3.6
.NET 3.5 (WinForms)
.NET 4.0 (WPF, WinForms)
Win 32 (
SAPGUI client 7.10 patch 13 (Microsoft Windows
Server 2008 SP2 (32bit))
SAPGUI client 7.20 patch 6 (Microsoft Windows
7 (32bit))
Microsoft Silverlight 4 (Silverlight Runtime 4)
Rumba 8.1
Microsoft Windows Windows Internet Explorer 7
Vista SP2 (32bit)
Mozilla Firefox 3.6

Windows Internet Explorer 7 (playback only)
Win 32

Flex 3.5, 4.1, 4.5.1
Java 1.6 (AWT/Swing)
SWT 3.5, 3.6
.NET 3.5 (WinForms)
.NET 4.0 (WPF, WinForms)
Win 32
SAPGUI client 7.10 patch 13
Microsoft Silverlight 4 (Silverlight Runtime 4)
Rumba 8.1
Microsoft Windows Windows Internet Explorer 6
XP SP3 (32bit)
Mozilla Firefox 3.0

Windows Internet Explorer 8 (playback only)
Win 32
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Platform Type

Tested Configurations for SilkTest
Tested Configurations for SilkTest
Workbench, SilkTest Recorder, Silk4NET,
Classic using the Classic Agent
Silk4J, SilkTest Classic using the Open Agent
Flex 4.1
Java 1.6 (AWT/Swing)
SWT 3.5, 3.6
.NET 3.5 (WinForms)
.NET 4.0 (WPF, WinForms)
Win 32
SAPGUI client 7.10 patch 13
Microsoft Silverlight 4 (Silverlight Runtime 4)
Rumba 8.1

Microsoft Windows Windows Internet Explorer 9 (32 bit)
7 SP1 (64bit)
Mozilla Firefox 6.0 (32 bit)
.NET 4.0 (WPF, WinForms)
Win 32
SWT 3.6.1
Java 1.6 (AWT/Swing)
Microsoft Silverlight 4 (Silverlight Runtime 4)
Rumba 8.2
Microsoft Windows Windows Internet Explorer 8 (32 bit)
Vista SP2 (64bit)
Mozilla Firefox 3.6 (32 bit)(Microsoft Windows
Microsoft Windows Server 2008)
Server 2008 R2
Mozilla Firefox 5.0 (32 bit)(Microsoft Windows
SP1(64bit)
Vista)
.NET 4.0 (WPF)
Win 32
SWT 3.6.1
Java 1.6 (AWT/Swing)
Microsoft Silverlight 4 (Silverlight Runtime 4)
Rumba 8.2

Adobe Flex Support
SilkTest supports testing Flex 3.0, 3.2, 3.3., 3.4, 3.5, 4.0, 4.1, and 4.5.1 using the following:
•
•
•
•
•
•
•
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Internet Explorer 9 (GA)
Internet Explorer 8 (GA)
Internet Explorer 7 (GA)
Internet Explorer 6 (SP 1 and SP 2)
Firefox 3.5
Firefox 3.6 (playback only)
Firefox 4 (playback only)

•

Adobe AIR 2.0 (built with Flex 4.x)

Java Support
Open Agent Support
SilkTest supports the following Java components for SilkTest Workbench, SilkTest Recorder, Silk4NET,
Silk4J, SilkTest Classic using the Open Agent:
•
•
•
•
•

SWT 3.2, 3.3, 3.4, 3.5, 3.6, and 3.7 standalone and Rich Client Platform (RCP) applications (SWT
standalone applications executed as an applet in the browser not supported)
Java version 1.6
AWT
Swing (including Java Foundation Classes)
Applets (in all supported browsers)

Classic Agent Support
SilkTest supports the following Java components for SilkTest Classic using the Classic Agent:
•
•
•
•
•

Java version 1.6
AWT
Java Foundation Classes (JFC, Swing)
Symantec Visual Café
Applets
Note: Applets are not supported on Internet Explorer 8.

SilkTest Classic DSN Support
SilkTest Classic's Data Driven Workflow supports:
•
•
•
•
•
•

Text files and comma separated value files (*.txt and *.csv files)
MS Excel
MS Access
MS SQL Server
Oracle (partial support)
SyBase SQL Anywhere

SilkTest Classic accesses the preceding databases using ODBC and therefore supports the versions of
those databases that have a working ODBC driver.
Note: The SilkTest Classic Select Data Source dialog box allows you to choose either the Silk DDA
Excel or the Segue DDA Excel data source. For new data driven testcases, choose the Silk DDA
Excel data source. Choose the Segue DDA Excel data source for backward compatibility. This allows
existing .g.t files that reference Segue DDA Excel to continue to work.

Dual-boot Machines
If you are installing SilkTest and have a dual-boot machine with more than one Windows operating system,
for example, both Windows Vista and Windows XP, you must install SilkTest in different directories under
the two operating systems. Otherwise, you risk causing problems with the Uninstall program. For example,
if you want to install SilkTest on both the Windows Vista and Windows XP partitions on a dual-boot
machine, install into C:\silkvista and D:\silknt, respectively.
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Administrator Privileges
You must have local administrator privileges to install SilkTest. Once SilkTest is properly installed, you
must also have administrator privileges in order to run SilkTest.

Forte, PeopleSoft or Developer 2000 Extensions
If you are installing SilkTest and are currently using the Forte, PeopleSoft or Developer 2000 extensions,
copy the associated files from your current SilkTest installation directory to another location before
uninstalling SilkTest. SilkTest no longer supports these extensions. You may continue to use them;
however SilkTest does not install these extensions, so you must save the appropriate files before
uninstalling your current version of SilkTest. After installing SilkTest, copy the files associated with the
unsupported extension that you are using to <SilkTest installation directory>/extend.

Database Testing Functions
To use the database testing functions (functions whose names begin with DB_), you must have ODBC
version 3 installed.
In addition, ensure that an ODBC driver, such as odbc32.dll (SQL Server) or sqora32.dll (Oracle), is
either on your path or in the System directory in order for SilkTest to find it. The name of this DLL may
vary, depending on the specifications and vendor of your ODBC driver.

Items Included with SilkTest
When you install SilkTest, the following items are available:
•
•
•
•
•
•
•

SilkTest Workbench
SilkTest Classic
SilkTest Agents
SilkTest Recorder
Silk4NET
Silk4J
Online Help topics

•

Access the help from within each product from the Help menu.
Release Notes

•

Access the Release Notes from Start > Programs > Silk > SilkTest 2011 > Release Notes or from
http://supportline.microfocus.com/Documentation/books/ASQ/SilkTest/2011/en/
SilkTest_ReleaseNotes_en.pdf.
Tutorials
Access the tutorials from Help > Tutorials and Start > Programs > Silk > SilkTest 2011 >
Documentation > SilkTest Tutorials.

•

You must have Adobe Acrobat Reader™ to view PDF documents.
Sample applications that you can install
Download and install sample applications from http://techpubs.borland.com/silk_gauntlet/SilkTest/.
Sample applications include:
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•

•

Technology Platform

Sample Application Name

Java AWT

AWT Test Application

Java Swing

Swing Test Application

Java SWT

SWT Test Application 3.2, 3.3, 3.4, 3.5, and 3.6, SWT Test Application (IBM), SWT
Test Application (SUN)

Microsoft .NET

Windows Forms Sample Application 3.5 and 4.0, WPF Sample Application 3.5 and
4.0, WPF Calculator 3.5, WPF Notepad 3.5, .NET 1.1 Test Application, .NET 2.0
Test Application

Win32

Simplified Chinese Test Application (32 bit and 64 bit), Test Application (32 bit and
64 bit), Text Editor (32 bit)

Sample applications that you can access online
•

Adobe Flex sample applications

•

Access Flex sample applications at: http://demo.borland.com/flex/SilkTest2010R2/index.html.
Insurance Company Web application

•

Use the Insurance Company Web application with SilkTest Workbench’s and SilkTest Classic’s
tutorials. You can access the Web application at: http://demo.borland.com/InsuranceWebExtJS/.
Green Mountain Outpost (GMO) Web application

Use the GMO application with SilkTest Classic’s tutorials. You can access the Web application at:
http://demo.borland.com/gmopost
SQL Server Management Studio
The Microsoft SQL Server Management Studio is available for download from the SilkTest download
Web page to enable you to configure, manage, and administer SQL server, if necessary.
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SilkTest Licensing
This section describes how to obtain a license policy for SilkTest and how to install SilkMeter. You must
have administrator privileges to install SilkMeter.
Note: SilkTest requires SilkMeter version 2008 or later as well as a SilkTest license policy.
Install SilkMeter once per license server. If you have multiple license servers, you need multiple license
policy files, each one tied to a particular license server. A single SilkMeter license server can administer
license policies for multiple products.
If you have received a SilkTest license policy, install the license policy on your license server. If you have
not received a license policy, generate a license policy.

Generating a SilkTest License Policy
You need a license policy to run SilkTest. You can use our online license generator to generate a license
policy. The online license generator requires an SSL-capable browser, such as Firefox or Internet Explorer.
You will receive an email with instructions on how to generate your license policy. If you did not receive
these instructions, contact customer care at http://support.microfocus.com.

Finding the Host ID
1. On the license server, open a command prompt and enter the command ipconfig/all.
The license server lists its connection addresses.
2. Note the host ID, which is the MAC Address or Physical Address of your LAN card, such as 00BF-00-1C-D3-3D.
You must enter this information to obtain a license policy for SilkTest.
Tip: Depending on your system setup, including virtual machines and VPN connections, your
computer might have several MAC addresses. Be sure to note the host ID of your physical LAN
card.

SilkMeter Installation
If you have the SilkTest license policy, you can install it when you install SilkMeter. To obtain a SilkTest
license policy, access the online License Generator to generate a license policy.
A SilkTest license policy is not required to install SilkMeter on your license server. Using the SilkMeter
User Policy Administrator, you can import the SilkTest license policy later. However, you must import the
license policy before you can run SilkTest.
Install SilkMeter once per license server. If you have multiple license servers, you need multiple license
policy files, each one tied to a particular license server. A single SilkMeter license server can administer
license policies for multiple products.
SilkMeter License Server Requirements
Before installing SilkMeter, refer to the Release Notes to ensure that the license server meets the
requirements.
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Uninstalling a Previous Version of SilkMeter
If SilkMeter is installed on the license server, you must uninstall it before installing the latest version of
SilkMeter.
1. Choose Start > Programs > Silk > SilkMeter > Uninstall.
2. Click Yes to uninstall SilkMeter.
The Remove Settings dialog box opens.
3. Click No to keep your SilkMeter settings.
Attention: You must click No to preserve license policies that currently exist on your SilkMeter
license server.
4. Reboot your computer.
SilkMeter is uninstalled, and you can install the latest version of SilkMeter.

Installing SilkMeter on Your License Server
Before installing SilkMeter, verify the following information:
•
•

Your user account possesses administrator privileges.
An instance of SilkMeter is not installed on your license server.

1. Locate the SilkMeter executable file SilkMeter.exe and perform the appropriate steps, as follows:
•

•

If you have a SilkTest CD, insert the CD. If the setup program does not start automatically, manually
start the SilkMeter setup program by choosing Start > Run and entering <cddrive>:\SilkMeter
\SilkMeter.exe.
If you have already downloaded SilkMeter, perform the following steps:

•

1. Navigate to the location where you saved the EXE file.
2. Double-click the EXE file.
If you are downloading SilkMeter:
1. Visit http://www.borland.com/downloads/lservers/silkmeter/index.html.
2. Click SilkMeter 2008 and then click Save File.
3. Specify the location to which you want to save this file, and then click Save.
Alternative: Run the file from your browser by double-clicking the EXE file.
4. Navigate to the location where you saved the EXE file.
5. Double-click the EXE file.

2.
3.
4.
5.
6.

The InstallShield wizard opens.
Click Next to continue.
Setup extracts the files to a temporary directory.
Click Next to continue.
The License Agreement opens.
Read the license agreement carefully. If you accept the terms of the agreement, click Yes to continue.
The Enter Installation Path and Configuration Directory for SilkMeter Runtime page opens.
Click Next to install SilkMeter in the default directory and to use the default configuration folder, \cfg.
The Enter Host Name page opens.
Enter or verify the hostname and port, then click Next.
Note: The hostname is the name of the computer on which SilkMeter is installed.
The Select Program Folder page opens.
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7. In the Program Folders text box, accept the default program folder, Silk\SilkMeter, or specify a
different program folder, and then click Next to continue.
Setup installs SilkMeter. Upon completion, the Install SilkMeter Policy page opens.
8. Perform one of the following steps:
•

•

If you already have a SilkTest license policy, click [...] to navigate to the location where you saved
the SilkTest license policy file, license.pol, and then click Open. Click Finish to install the
SilkTest license policy.
If you do not have a SilkTest license policy, click Finish. You can import the SilkTest license policy
when you receive it. Instructions for importing SilkTest license files are available from the online
License Generator and in SilkMeter Runtime Help.

The View Release Notes page opens.
9. Click Yes to view the SilkMeter Release Notes, or click No to continue the installation without viewing
the release notes.
The InstallShield Wizard Complete page opens.
10.Click Finish to complete the installation process.
Important: If setup prompts you to restart the computer, make sure to do so.

Modifying Your License Server Configuration
Use the Select SilkMeter License Server utility to modify or repair your license server configuration. This
utility is installed with your SilkTest installation and checks your local system for the existence of SilkMeter
license server configuration files. If the files are found, the configuration and type of license server are
displayed and used for licensing. If no configuration data is found, the Select SilkMeter License Server
dialog box displays the default settings.
1. Choose Start > Programs > Silk > SilkTest > Administration Tools > Change your License Server
Configuration.
The Select SilkMeter License Server utility opens.
2. In the Application list box, select the product for which you want to configure the license server.
3. Click the Using local or remote server option button to configure a SilkMeter license server.
4. In the License Server Host text box, type the computer name for the SilkMeter license server.
Unless your network administrator has defined a different port, do not change the Port Number.
5. Click Apply to generate the license server configuration.
6. Click Test Connection to verify that a SilkMeter server is accessible on the specified host and port.
If the connection is successful, the Status text box displays a SUCCESS message.
Note: In some cases, specifying the simple name of the license server in the License Server
Host text box, such as licenseserver, might not work. A message box stating there is no
license server running on the hostname you specified opens. To resolve this
issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.
7. Click Close to complete the license server configuration.
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Installing SilkTest
This section explains the setup options that are available when installing SilkTest.

Installation Prerequisites
Before installing SilkTest, verify the following information:
•
•

•

Your user account possesses local administrator privileges.
The file msvcp60.dll is installed in the Windows System32 directory (windows\system32 or winnt
\system32).
This file is installed automatically as part of the standard Windows installation. If msvcp60.dll is not in
your System32 directory, use Windows Explorer to search for the file, then copy it to the System32
directory. If you cannot find this file on your system, search for the file on your installation CD, or
upgrade to the latest service pack.
On Windows 2008 R2 64-bit machines, ensure that .NET 3.5 SP1 is installed.
You can install the .NET Framework 3.5.1 Features from the Add Features Wizard in Server
Manager. Or you can download it from the Microsoft Web site.

•

•

Note: To use .NET Framework with a server system, for example Windows Server 2008, enable
the .NET Framework in Server Manager. If you do not enable the .NET Framework, a dialog box
opens, which states that you must use the Role Management Tool, and the SilkTest setup process
stops.
On Windows Vista SP1 machines, ensure that the full version of .NET 3.5 SP1 is installed if you plan to
install SQL Server 2008 during the SilkTest installation. Otherwise, SQL Server Express might not
install. To install the full version of .NET 3.5 SP1, download it from the Microsoft Web site.
If you plan to integrate SilkTest Workbench with SilkCentral Test Manager (SCTM), ensure that you
install SilkTest Workbench before you install SCTM. Otherwise, errors occur when you execute tests
from SCTM.

Resetting the TEMP Environment Variable
If your Windows TEMP environment variable does not point to a valid directory, an error message is
displayed. To successfully install SilkTest, your TEMP environment variable must point to a valid directory.
1. Choose Start > Settings > Control Panel.
2. Double-click System.
3. Click the Advanced tab, and then click Environment Variables.
4. Under User Variables or System Variables, double-click the TEMP variable.
5. Enter a valid directory, and then click OK.
6. Restart the SilkTest installation by double-clicking the EXE file.

Downloading the SilkTest Executable File
Download the SilkTest executable file if you do not have the installation CD.
1. Navigate to http://supportline.microfocus.com/.
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2. Type your customer ID and password in the User Name and Password text boxes.
3. Click Submit and then navigate to SilkTest and select the version that you want to install.
4. Specify the location to which you want to save this file, and then click Save.
Alternative: Run the file from your browser by double-clicking the EXE file.
Use the executable file to install SilkTest.

Installing the Standard Suite of SilkTest Products
Before you start, download the SilkTest executable file or insert the SilkTest CD into the CD drive.
Install the standard installation of SilkTest, including SilkTest Workbench, the SilkTest Agents, SilkTest
Recorder, Silk4J, and Silk4NET. The standard installation enables you to record, script, execute, and view
the results of tests.
1. Locate and double-click the SilkTest executable file.
If you have a SilkTest CD, insert your CD. If the setup program does not start automatically, manually
start the SilkTest setup program by choosing Start > Run and entering <cddrive>:\setup.exe.
Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install SilkTest, your TEMP environment variable must point
to a valid directory.
The InstallAnywhere wizard opens.
2. If you previously installed a version of SilkTest, click Uninstall and then click Next to remove all
installed features.
You must uninstall any earlier versions before you install a new version.
3. Click Next.
The License Agreement opens.
4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.
5. Click Next.
The Choose Install Set page opens.
6. Ensure that Standard is selected from the list.
The standard installation enables you to record, script, execute, and view the results of tests and it is
the default setting.
7. To include additional shortcut icons, check one or both of the following check boxes:
•
•

On the Desktop – Adds icons to the desktop.
In the Quick Launch Bar – Adds icons to the Quick Launch toolbar.

8. Click Next.
The Microsoft SQL Server 2008 Express Edition page opens.
9. Specify whether you want to install the default Microsoft SQL Server 2008 Express Edition database.
SilkTest Workbench requires a database. If you choose not to install the default database, you must
configure a supported database. For more information, see Configuring a SilkTest Workbench
Database. Additionally, you can customize the default SQL Server 2008 Express database prior to
installing SilkTest Workbench. For more information, see Customizing the Default SQL Server Express
2008 Database.
10.Click Next.
The Choose Install Folder page opens.
11.To change the default installation directory, perform the following steps:
a) Click Choose.
The Browse For Folder dialog box opens.
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b) Specify the folder in which you want to install SilkTest, and then click OK to return to the Choose
Install Folder page.
Note: SilkTest must be installed on a local drive. An error message appears if you specify an
invalid installation destination.
The location displays in the Where Would You Like to Install? text box.
12.Click Next.
The Welcome to Silk4J page opens.
13.Specify whether you want to install a new Eclipse environment when you install Silk4J.
a) Click one of the following option buttons:
•

Download Eclipse (92MB) and install Silk4J – To install Silk4J and an Eclipse 3.5
environment, click this option.
• Install Silk4J and use an existing Eclipse environment – To use an existing Eclipse
environment with Silk4J, click this option. Click Browse and navigate to the Eclipse environment
that you want to use.
• Install Silk4J manually – To install Silk4J into an Eclipse environment manually, click this
option. A folder named dropins is created in the SilkTest installation directory. Copy this folder
into a valid Eclipse directory to use Silk4J.
b) Click Next.
When installation completes, access the Eclipse environment by choosing Start > Programs > Silk >
SilkTest 2011 > Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.
14.Specify whether you want to install Silk4NET for use with an existing Visual Studio environment.
The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.
a) Click one of the following option buttons:
•

Install Silk4NET and use an existing Visual Studio 2010 environment – To use an existing
Visual Studio 2010 environment, click this option.
• Install Silk4NET manually – To complete the installation of Silk4NET at a later time, click this
option. If Visual Studio 2010 is not installed on your machine, you must choose this option. Refer
to Installing Silk4NET Visual Studio Plug-in Manually later in this guide for instructions.
b) Click Next.
When you start Visual Studio, a menu option appears for Silk4NET and the Silk4NET project is
available from the Installed Templates list.
15.Specify whether you want to create Windows firewall exceptions.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
a) Click one of the following option buttons:
•

Yes – To have setup create firewall exceptions for all SilkTest executable files. As a result, you
are not prompted to block or allow the executable files when you launch them.
• No – To be prompted when you launch the SilkTest executable file.
b) Click Next.
16.Review the provided information and perform one of the following steps:
•
•

To change any settings, click Previous to return to the appropriate page.
If you are satisfied with the settings, click Install to start the installation process.
Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
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\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.
The status bar provides information about the installation process. Upon completion, the Choose
Licensing Mode page opens.
17.Click one of the following option buttons:
•

Evaluation version Installs an evaluation version of SilkTest, which grants you full product
functionality for 30 days. To upgrade to a full version at a later point in time, contact your sales
representative.
• Full version – Installs an unrestricted version of SilkTest, which requires a license.
18.To install the license file, perform the following steps:
a) Click Configure your license server and then click Next.
The license utility checks your local system for the existence of SilkMeter license server
configuration files. If the files are found, the configuration and type of license server are displayed
and used for licensing. If no configuration data is found, the Select SilkMeter License Server page
is displayed with the default settings.
b) From the Application list box, select SilkTest as the application you are licensing.
c) Click one of the following option buttons:
Using local or
remote server

In the License Server Host text box, type the name of the computer on which
SilkMeter is installed. Do not change the default port number, 5461, unless your
network administrator has defined a different port. Click Apply to generate your
license server configuration. Click Test Connection to verify that a SilkMeter
server is accessible on the specified host and port. Testing the connection to the
license server might fail during installation as required system libraries, which are
installed later with the software package, might not yet be available.
Note: In some cases, specifying the simple name of the license server in
the License Server Host text box, such as licenseserver, might not
work. A message box stating there is no license server
running on the hostname you specified opens. To resolve this
issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Not using
server
(standalone)

Runs SilkMeter standalone. You are prompted to import a SilkMeter license file.
Click Yes and specify the location of your license file.

d) Click Close.
Fastpath: A working network connection is required when running SilkTest with a remote
SilkMeter license server. If you need to verify that the network is working, choose Start > Run,
and then type ping localhost or ping <license server name>, or open a command
prompt and type either of those commands.
The Install Complete page opens.
19.Click Done.

Installing the Complete Suite of SilkTest Products
Before you start, download the SilkTest executable file or insert the SilkTest CD into the CD drive.
Install the complete installation of SilkTest. The complete installation includes SilkTest Classic, Classic
Agent, and Silk TrueLog Explorer in addition to SilkTest Workbench, the SilkTest Open Agent, SilkTest
Recorder, Silk4J, and Silk4NET.
1. Locate and double-click the SilkTest executable file.
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If you have a SilkTest CD, insert your CD. If the setup program does not start automatically, manually
start the SilkTest setup program by choosing Start > Run and entering <cddrive>:\setup.exe.
Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install SilkTest, your TEMP environment variable must point
to a valid directory.
The InstallAnywhere wizard opens.
2. If you previously installed a version of SilkTest, click Uninstall and then click Next to remove all
installed features.
You must uninstall any earlier versions before you install a new version.
3. Click Next.
The License Agreement opens.
4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.
5. Click Next.
The Choose Install Set page opens.
6. Select Complete from the list.
The complete installation enables you to record, script, execute, and view the results of tests.
Checkmarks display next to each option except SilkTest Runtime.
Note: The complete installation includes the SilkTest Windows and .NET extension kits, which are
included as part of the SilkTest Classic Agent installation.
7. To include additional shortcut icons, check one or both of the following check boxes:
•
•

On the Desktop – Adds icons to the desktop.
In the Quick Launch Bar – Adds icons to the Quick Launch toolbar.

8. Click Next.
The Microsoft SQL Server 2008 Express Edition page opens.
9. Specify whether you want to install the default Microsoft SQL Server 2008 Express Edition database.
SilkTest Workbench requires a database. If you choose not to install the default database, you must
configure a supported database. For more information, see Configuring a SilkTest Workbench
Database. Additionally, you can customize the default SQL Server 2008 Express database prior to
installing SilkTest Workbench. For more information, see Customizing the Default SQL Server Express
2008 Database.
10.Click Next.
The Choose Install Folder page opens.
11.To change the default installation directory, perform the following steps:
a) Click Choose.
The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install SilkTest, and then click OK to return to the Choose
Install Folder page.
Note: You cannot install SilkTest and SilkTest Runtime on the same machine.
Note: SilkTest must be installed on a local drive. An error message appears if you specify an
invalid installation destination.
The location displays in the Where Would You Like to Install? text box.
12.Click Next.
The Welcome to Silk4J page opens.
13.Specify whether you want to install a new Eclipse environment when you install Silk4J.
a) Click one of the following option buttons:

Installing SilkTest

| 19

•

Download Eclipse (92MB) and install Silk4J – To install Silk4J and an Eclipse 3.5
environment, click this option.
• Install Silk4J and use an existing Eclipse environment – To use an existing Eclipse
environment with Silk4J, click this option. Click Browse and navigate to the Eclipse environment
that you want to use.
• Install Silk4J manually – To install Silk4J into an Eclipse environment manually, click this
option. A folder named dropins is created in the SilkTest installation directory. Copy this folder
into a valid Eclipse directory to use Silk4J.
b) Click Next.
When installation completes, access the Eclipse environment by choosing Start > Programs > Silk >
SilkTest 2011 > Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.
14.Specify whether you want to install Silk4NET for use with an existing Visual Studio environment.
The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.
a) Click one of the following option buttons:
•

Install Silk4NET and use an existing Visual Studio 2010 environment – To use an existing
Visual Studio 2010 environment, click this option.
• Install Silk4NET manually – To complete the installation of Silk4NET at a later time, click this
option. If Visual Studio 2010 is not installed on your machine, you must choose this option. Refer
to Installing Silk4NET Visual Studio Plug-in Manually later in this guide for instructions.
b) Click Next.
When you start Visual Studio, a menu option appears for Silk4NET and the Silk4NET project is
available from the Installed Templates list.
15.Select a default language to use when testing browser applications with the Classic Agent.
To switch to another language later, see the Help.
The browser include (.inc) file for the language you select is installed in the <SilkTest install>
\Extend directory. All browser include files are installed in the <SilkTest Install>\Locale
directory.
16.Verify the default browser for Web application testing and then click Next.
The Setup Program preselects the option in this dialog based on browser settings on your machine. For
instance, if you are using Internet Explorer, it displays the version of IE installed on your machine.
To specify a different default browser for SilkTest Classic, select the appropriate browser. If you are not
testing a Web application, click None, and then click Next.
Regardless of what you select, you can change this setting later within SilkTest Classic. Refer to the
SilkTest Classic Help for instructions on changing your default browser or browser extensions after
installation.
Note: If your default browser is Internet Explorer, you might receive a message that your
browser’s third-party extensions are not enabled. You must enable this option in order for SilkTest
Classic to recognize objects in browser pages. You can enable this option and then continue with
the installation, or you can wait and enable the option after the installation is complete.
17.Specify whether you want to create Windows firewall exceptions.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
a) Click one of the following option buttons:
•

Yes – To have setup create firewall exceptions for all SilkTest executable files. As a result, you
are not prompted to block or allow the executable files when you launch them.
• No – To be prompted when you launch the SilkTest executable file.
b) Click Next.
18.Review the provided information and perform one of the following steps:
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•
•

To change any settings, click Previous to return to the appropriate page.
If you are satisfied with the settings, click Install to start the installation process.
Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process. Upon completion, the Choose
Licensing Mode page opens.
19.Click one of the following option buttons:
•

Evaluation version Installs an evaluation version of SilkTest, which grants you full product
functionality for 30 days. To upgrade to a full version at a later point in time, contact your sales
representative.
• Full version – Installs an unrestricted version of SilkTest, which requires a license.
20.To install the license file, perform the following steps:
a) Click Configure your license server and then click Next.
The license utility checks your local system for the existence of SilkMeter license server
configuration files. If the files are found, the configuration and type of license server are displayed
and used for licensing. If no configuration data is found, the Select SilkMeter License Server page
is displayed with the default settings.
b) From the Application list box, select SilkTest as the application you are licensing.
c) Click one of the following option buttons:
Using local or
remote server

In the License Server Host text box, type the name of the computer on which
SilkMeter is installed. Do not change the default port number, 5461, unless your
network administrator has defined a different port. Click Apply to generate your
license server configuration. Click Test Connection to verify that a SilkMeter
server is accessible on the specified host and port. Testing the connection to the
license server might fail during installation as required system libraries, which are
installed later with the software package, might not yet be available.
Note: In some cases, specifying the simple name of the license server in
the License Server Host text box, such as licenseserver, might not
work. A message box stating there is no license server
running on the hostname you specified opens. To resolve this
issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Not using
server
(standalone)

Runs SilkMeter standalone. You are prompted to import a SilkMeter license file.
Click Yes and specify the location of your license file.

d) Click Close.
Fastpath: A working network connection is required when running SilkTest with a remote
SilkMeter license server. If you need to verify that the network is working, choose Start > Run,
and then type ping localhost or ping <license server name>, or open a command
prompt and type either of those commands.
The Install Complete page opens.
21.Specify whether you want to restart the system to complete the installation and then click Done.
Attention: You must restart your computer for SilkTest Classic to work properly.
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Installing SilkTest Workbench
SilkTest Workbench is the new, native quality testing environment that offers .NET scripting for power
users and innovative storyboard-based visual tests to make testing more accessible. SilkTest Workbench
is automatically installed when you choose a complete or standard installation. If you choose a basic
installation, you can install SilkTest Workbench without any other components. When you install SilkTest
Workbench, the Open Agent is also installed. The Open Agent is required to run SilkTest Workbench.
1. Locate and double-click the SilkTest executable file.
If you have a SilkTest CD, insert your CD. If the setup program does not start automatically, manually
start the SilkTest setup program by choosing Start > Run and entering <cddrive>:\setup.exe.
Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install SilkTest, your TEMP environment variable must point
to a valid directory.
The InstallAnywhere wizard opens.
2. If you previously installed a version of SilkTest, click Uninstall and then click Next to remove all
installed features.
You must uninstall any earlier versions before you install a new version.
3. Click Next.
The License Agreement opens.
4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.
5. Click Next.
The Choose Install Set page opens.
6. Select Basic from the list.
The basic installation installs SilkTest Workbench, SilkTest Recorder, and the Open Agent.
7. To include additional shortcut icons, check one or both of the following check boxes:
•
•

On the Desktop – Adds icons to the desktop.
In the Quick Launch Bar – Adds icons to the Quick Launch toolbar.

8. Click Next.
The Microsoft SQL Server 2008 Express Edition page opens.
9. Specify whether you want to install the default Microsoft SQL Server 2008 Express Edition database.
SilkTest Workbench requires a database. If you choose not to install the default database, you must
configure a supported database. For more information, see Configuring a SilkTest Workbench
Database. Additionally, you can customize the default SQL Server 2008 Express database prior to
installing SilkTest Workbench. For more information, see Customizing the Default SQL Server Express
2008 Database.
10.Click Next.
The Choose Install Folder page opens.
11.To change the default installation directory, perform the following steps:
a) Click Choose.
The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install SilkTest, and then click OK to return to the Choose
Install Folder page.
Note: You cannot install SilkTest and SilkTest Runtime on the same machine.
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Note: SilkTest must be installed on a local drive. An error message appears if you specify an
invalid installation destination.
The location displays in the Where Would You Like to Install? text box.
12.Click Next.
The Firewall Exceptions page opens.
13.Specify whether you want to create Windows firewall exceptions.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
a) Click one of the following option buttons:
•

Yes – To have setup create firewall exceptions for all SilkTest executable files. As a result, you
are not prompted to block or allow the executable files when you launch them.
• No – To be prompted when you launch the SilkTest executable file.
b) Click Next.
14.Review the provided information and perform one of the following steps:
•
•

To change any settings, click Previous to return to the appropriate page.
If you are satisfied with the settings, click Install to start the installation process.
Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process. Upon completion, the Choose
Licensing Mode page opens.
15.Click one of the following option buttons:
•

Evaluation version Installs an evaluation version of SilkTest, which grants you full product
functionality for 30 days. To upgrade to a full version at a later point in time, contact your sales
representative.
• Full version – Installs an unrestricted version of SilkTest, which requires a license.
16.To install the license file, perform the following steps:
a) Click Configure your license server and then click Next.
The license utility checks your local system for the existence of SilkMeter license server
configuration files. If the files are found, the configuration and type of license server are displayed
and used for licensing. If no configuration data is found, the Select SilkMeter License Server page
is displayed with the default settings.
b) From the Application list box, select SilkTest as the application you are licensing.
c) Click one of the following option buttons:
Using local or
remote server

In the License Server Host text box, type the name of the computer on which
SilkMeter is installed. Do not change the default port number, 5461, unless your
network administrator has defined a different port. Click Apply to generate your
license server configuration. Click Test Connection to verify that a SilkMeter
server is accessible on the specified host and port. Testing the connection to the
license server might fail during installation as required system libraries, which are
installed later with the software package, might not yet be available.
Note: In some cases, specifying the simple name of the license server in
the License Server Host text box, such as licenseserver, might not
work. A message box stating there is no license server
running on the hostname you specified opens. To resolve this
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issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.
Not using
server
(standalone)

Runs SilkMeter standalone. You are prompted to import a SilkMeter license file.
Click Yes and specify the location of your license file.

d) Click Close.
Fastpath: A working network connection is required when running SilkTest with a remote
SilkMeter license server. If you need to verify that the network is working, choose Start > Run,
and then type ping localhost or ping <license server name>, or open a command
prompt and type either of those commands.
The Install Complete page opens.
17.Click Done.

Enabling Third-party Browser Extensions
If your default browser is Internet Explorer, you may receive a message that your browser’s third-party
extensions are not enabled. You must enable third-party browser extensions in order for SilkTest to
recognize objects in browser pages.
1.
2.
3.
4.

In Internet Explorer, choose Tools > Internet Options.
Click the Advanced tab.
Under Browsing, check the Enable third-party browser extensions check box, then click OK.
Restart your browser by closing and reopening the browser window.
You do not have to reboot your computer for the new setting to take effect; just close and reopen the
browser window.

Installing SilkTest Runtime or the SilkTest Agents
Before you start, download the SilkTest executable file or insert the SilkTest CD into the CD drive.
Use SilkTest Runtime to execute a set of tests and view the results.
Install the SilkTest Agent software on machines that are used for distributed testing.
1. Locate and double-click the SilkTest executable file.
If you have a SilkTest CD, insert your CD. If the setup program does not start automatically, manually
start the SilkTest setup program by choosing Start > Run and entering <cddrive>:\setup.exe.
Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install SilkTest, your TEMP environment variable must point
to a valid directory.
2.

3.
4.
5.
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The InstallAnywhere wizard opens.
If you previously installed a version of SilkTest, click Uninstall and then click Next to remove all
installed features.
You must uninstall any earlier versions before you install a new version.
Click Next.
The License Agreement opens.
Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.
Click Next.

The Choose Install Set page opens.
6. From the drop-down list, select Agent/Runtime Only and check the check boxes for the components
that you want to install.
•
•
•

Check the Open Agent check box to perform distributed testing on tests in Silk4J, SilkTest
Workbench, SilkTest Recorder, Silk4NET, and most of the technology types for SilkTest Classic.
Check the SilkTest Classic Agent check box to perform distributed testing in a traditional 4Test
environment. The SilkTest Classic Agent software includes the SilkTest Unix Agent.
Check the SilkTest Classic Runtime check box to execute a set of tests and view the results.
Note: The Agent installation includes the SilkTest Windows and .NET extension kits, which are
included as part of the SilkTest Classic Agent installation.

7. Click Next.
The Choose Install Folder page opens.
8. To change the default installation directory, perform the following steps:
a) Click Choose.
The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install SilkTest, and then click OK to return to the Choose
Install Folder page.
Note: You cannot install SilkTest and SilkTest Runtime on the same machine.
Note: SilkTest must be installed on a local drive. An error message appears if you specify an
invalid installation destination.
9. Click Next.
The Firewall Exceptions page opens.
10.Specify whether you want to create Windows firewall exceptions.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
a) Click one of the following option buttons:
•

Yes – To have setup create firewall exceptions for all SilkTest executable files. As a result, you
are not prompted to block or allow the executable files when you launch them.
• No – To be prompted when you launch the SilkTest executable file.
b) Click Next.
11.Review the provided information and perform one of the following steps:
•
•

To change any settings, click Previous to return to the appropriate page.
If you are satisfied with the settings, click Install to start the installation process.
Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process. Upon completion, the Choose
Licensing Mode page opens.
12.Click one of the following option buttons:
•

•

Evaluation version Installs an evaluation version of SilkTest, which grants you full product
functionality for 30 days. To upgrade to a full version at a later point in time, contact your sales
representative.
Full version – Installs an unrestricted version of SilkTest, which requires a license.

13.To install the license file, perform the following steps:
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a) Click Configure your license server and then click Next.
The license utility checks your local system for the existence of SilkMeter license server
configuration files. If the files are found, the configuration and type of license server are displayed
and used for licensing. If no configuration data is found, the Select SilkMeter License Server page
is displayed with the default settings.
b) From the Application list box, select SilkTest as the application you are licensing.
c) Click one of the following option buttons:
Using local or
remote server

In the License Server Host text box, type the name of the computer on which
SilkMeter is installed. Do not change the default port number, 5461, unless your
network administrator has defined a different port. Click Apply to generate your
license server configuration. Click Test Connection to verify that a SilkMeter
server is accessible on the specified host and port. Testing the connection to the
license server might fail during installation as required system libraries, which are
installed later with the software package, might not yet be available.
Note: In some cases, specifying the simple name of the license server in
the License Server Host text box, such as licenseserver, might not
work. A message box stating there is no license server
running on the hostname you specified opens. To resolve this
issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Not using
server
(standalone)

Runs SilkMeter standalone. You are prompted to import a SilkMeter license file.
Click Yes and specify the location of your license file.

d) Click Close.
Fastpath: A working network connection is required when running SilkTest with a remote
SilkMeter license server. If you need to verify that the network is working, choose Start > Run,
and then type ping localhost or ping <license server name>, or open a command
prompt and type either of those commands.
The Install Complete page opens.
14.Specify whether you want to restart the system to complete the installation and then click Done.
Attention: You must restart your computer for SilkTest Classic to work properly.
Note: If you purchase a license for a SilkTest Agent but not SilkTest itself, then only the Agent,
documentation and the SilkTest Bitmap Tool are accessible after you install SilkTest.

Installing the Classic Agent for Unix
After you install the SilkTest Agent software, additional steps are required if you want to use the SilkTest
Classic Agent for Unix.
1. On the computer where you installed the SilkTest Classic Agent software, locate the directory where the
SilkTest Unix Agent TAR files are.
By default, this location is c:\Program Files\Silk\SilkTest\unix_agent.
2. Copy the TAR file that is appropriate for your Unix machine.
SilkTest provides the following files:
•
•
•
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linux21_sp3.tar.gz – For Linux 2.1
linux30_sp3.tar.gz – For Linux 3.0
solaris_sp3.tar.gz – For Solaris 9 and 10

3. Extract the TAR file on your Unix machine by typing tar xzf <filename>.tar.gz.
where <filename> is the appropriate file name for your version of Unix.
4. Change to the bin directory and then run a shell or cshell script.
For instance, type:
cd bin
csh <filename>
5. Start the Agent.

Installing Silk4J
The Silk4J Eclipse plug-in enables you to create Java based test scripts directly in your Eclipse
environment. Silk4J is automatically installed when you choose a standard or complete installation. If you
choose a basic or custom installation, you can install Silk4J at a later time. When you install Silk4J,
SilkTest Recorder and the Open Agent are also installed. SilkTest Recorder enables you to record tests
rather than manually coding them. The Open Agent is required to run Silk4J and SilkTest Recorder.
1. Locate and double-click the SilkTest executable file.
If you have a SilkTest CD, insert your CD. If the setup program does not start automatically, manually
start the SilkTest setup program by choosing Start > Run and entering <cddrive>:\setup.exe.
Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install SilkTest, your TEMP environment variable must point
to a valid directory.
The InstallAnywhere wizard opens.
2. If you previously installed a version of SilkTest, click Uninstall and then click Next to remove all
installed features.
You must uninstall any earlier versions before you install a new version.
3. Click Next.
The License Agreement opens.
4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.
5. Click Next.
The Choose Install Set page opens.
6. From the drop-down list, select Custom and then check the Silk4J check box.
Silk4J, SilkTest Recorder, and the Open Agent will be installed.
7. Click Next.
The Choose Install Folder page opens.
8. To change the default installation directory, perform the following steps:
a) Click Choose.
The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install SilkTest, and then click OK to return to the Choose
Install Folder page.
The location displays in the Where Would You Like to Install? text box.
9. Click Next.
The Welcome to Silk4J page opens.
10.Specify whether you want to install a new Eclipse environment when you install Silk4J.
a) Click one of the following option buttons:
•

Download Eclipse (92MB) and install Silk4J – To install Silk4J and an Eclipse 3.5
environment, click this option.
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•

Install Silk4J and use an existing Eclipse environment – To use an existing Eclipse
environment with Silk4J, click this option. Click Browse and navigate to the Eclipse environment
that you want to use.
• Install Silk4J manually – To install Silk4J into an Eclipse environment manually, click this
option. A folder named dropins is created in the SilkTest installation directory. Copy this folder
into a valid Eclipse directory to use Silk4J.
b) Click Next.
When installation completes, access the Eclipse environment by choosing Start > Programs > Silk >
SilkTest 2011 > Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.
11.Specify whether you want to create Windows firewall exceptions.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
a) Click one of the following option buttons:
•

Yes – To have setup create firewall exceptions for all SilkTest executable files. As a result, you
are not prompted to block or allow the executable files when you launch them.
• No – To be prompted when you launch the SilkTest executable file.
b) Click Next.
12.Review the provided information and perform one of the following steps:
•
•

To change any settings, click Previous to return to the appropriate page.
If you are satisfied with the settings, click Install to start the installation process.
Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process. Upon completion, the Choose
Licensing Mode page opens.
13.Click one of the following option buttons:
•

Evaluation version Installs an evaluation version of SilkTest, which grants you full product
functionality for 30 days. To upgrade to a full version at a later point in time, contact your sales
representative.
• Full version – Installs an unrestricted version of SilkTest, which requires a license.
14.To install the license file, perform the following steps:
a) Click Configure your license server and then click Next.
The license utility checks your local system for the existence of SilkMeter license server
configuration files. If the files are found, the configuration and type of license server are displayed
and used for licensing. If no configuration data is found, the Select SilkMeter License Server page
is displayed with the default settings.
b) From the Application list box, select SilkTest as the application you are licensing.
c) Click one of the following option buttons:
Using local or
remote server
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In the License Server Host text box, type the name of the computer on which
SilkMeter is installed. Do not change the default port number, 5461, unless your
network administrator has defined a different port. Click Apply to generate your
license server configuration. Click Test Connection to verify that a SilkMeter
server is accessible on the specified host and port. Testing the connection to the
license server might fail during installation as required system libraries, which are
installed later with the software package, might not yet be available.

Note: In some cases, specifying the simple name of the license server in
the License Server Host text box, such as licenseserver, might not
work. A message box stating there is no license server
running on the hostname you specified opens. To resolve this
issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.
Not using
server
(standalone)

Runs SilkMeter standalone. You are prompted to import a SilkMeter license file.
Click Yes and specify the location of your license file.

d) Click Close.
Fastpath: A working network connection is required when running SilkTest with a remote
SilkMeter license server. If you need to verify that the network is working, choose Start > Run,
and then type ping localhost or ping <license server name>, or open a command
prompt and type either of those commands.
The Install Complete page opens.
15.Click Done.
16.Restart Eclipse if it was running when you performed the Silk4J installation.
When installation completes, access the Eclipse environment by choosing Start > Programs > Silk >
SilkTest 2011 > Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.

Installing the Silk4J Eclipse Plug-in Manually
The Silk4J Eclipse plug-in enables you to create Java-based test scripts directly in your Eclipse
environment. You can install the Silk4J Eclipse plug-in when you install SilkTest using the SilkTest
installation wizard.
Use this procedure:
•
•
•

If you upgrade your version of Eclipse after you install the Silk4J plug-in.
If you chose the Install Silk4J manually option during installation.
If you did not install the Silk4J Eclipse plug-in when you installed SilkTest, and you want to install it
manually.

1. Perform one of the following steps:
•

•

If you chose the Install Silk4J Manually option during installation, locate the dropins folder in the
SilkTest installation directory.
By default the location is C:\Program Files\Silk\SilkTest\dropins.
Create a dropins folder in the SilkTest installation directory and then create a Silk4J.link file
that contains the following text:
path=<SilkTest Install Directory>/ng/Silk4J
For example, you might add:
path=C:/Program Files/Silk/SilkTest/ng/Silk4J
Note: The path requires forward slashes.

2. Copy the Silk4J.link file and paste it into the Eclipse dropins folder.
For example, if your Eclipse environment is installed at C:\Eclipse, copy the Silk4J.link file to C:
\Eclipse\dropins.
3. Restart Eclipse if it was running when you performed the Silk4J installation.
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When installation completes, access the Eclipse environment by choosing Start > Programs > Silk >
SilkTest 2011 > Silk4J. For instructions for using the plug-in, refer to the online help within the plug-in.
Tip: If you encounter problems starting Silk4J, start Eclipse with the parameter -clean one time.

Enabling and Disabling Rumba
Rumba is the world's premier Windows desktop terminal emulation solution. Rumba provides connectivity
solutions to mainframes, mid-range, UNIX, Linux, and HP servers.
Enabling Support
Before you can record and replay Rumba scripts, you need to enable support:
1. Install Rumba desktop client software version 8.1 or later.
2. Click Start > Silk > SilkTest {version} > Administration Tools > Rumba plugin > Enable SilkTest
Rumba plugin.
Disabling Support
Click Start > Silk > SilkTest {version} > Administration Tools > Rumba plugin > Disable SilkTest
Rumba plugin.

Installing Silk4NET
The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio. Silk4NET is automatically installed when you choose a standard or complete installation. If you
choose a basic or custom installation, you can install Silk4NET at a later time. When you install Silk4NET,
SilkTest Recorder and the Open Agent are also installed. SilkTest Recorder enables you to record tests
rather than manually coding them. The Open Agent is required to run Silk4NET and SilkTest Recorder.
1. Locate and double-click the SilkTest executable file.
If you have a SilkTest CD, insert your CD. If the setup program does not start automatically, manually
start the SilkTest setup program by choosing Start > Run and entering <cddrive>:\setup.exe.
Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install SilkTest, your TEMP environment variable must point
to a valid directory.
2.

3.
4.
5.
6.
7.
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The InstallAnywhere wizard opens.
If you previously installed a version of SilkTest, click Uninstall and then click Next to remove all
installed features.
You must uninstall any earlier versions before you install a new version.
Click Next.
The License Agreement opens.
Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.
Click Next.
The Choose Install Set page opens.
From the drop-down list, select Custom and then check the Silk4NET check box.
Silk4NET, SilkTest Recorder, and the Open Agent will be installed.
Specify whether you want to install Silk4NET for use with an existing Visual Studio environment.
The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.

a) Click one of the following option buttons:
•

Install Silk4NET and use an existing Visual Studio 2010 environment – To use an existing
Visual Studio 2010 environment, click this option.
• Install Silk4NET manually – To complete the installation of Silk4NET at a later time, click this
option. If Visual Studio 2010 is not installed on your machine, you must choose this option. Refer
to Installing Silk4NET Visual Studio Plug-in Manually later in this guide for instructions.
b) Click Next.
When you start Visual Studio, a menu option appears for Silk4NET and the Silk4NET project is
available from the Installed Templates list.
8. To include additional shortcut icons, check one or both of the following check boxes:
• On the Desktop – Adds icons to the desktop.
• In the Quick Launch Bar – Adds icons to the Quick Launch toolbar.
9. Click Next.
The Choose Install Folder page opens.
10.To change the default installation directory, perform the following steps:
a) Click Choose.
The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install SilkTest, and then click OK to return to the Choose
Install Folder page.
The location displays in the Where Would You Like to Install? text box.
11.Click Next.
12.Specify whether you want to create Windows firewall exceptions.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
a) Click one of the following option buttons:
•

Yes – To have setup create firewall exceptions for all SilkTest executable files. As a result, you
are not prompted to block or allow the executable files when you launch them.
• No – To be prompted when you launch the SilkTest executable file.
b) Click Next.
13.Review the provided information and perform one of the following steps:
•
•

To change any settings, click Previous to return to the appropriate page.
If you are satisfied with the settings, click Install to start the installation process.
Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.

The status bar provides information about the installation process. Upon completion, the Choose
Licensing Mode page opens.
14.Click one of the following option buttons:
•

Evaluation version Installs an evaluation version of SilkTest, which grants you full product
functionality for 30 days. To upgrade to a full version at a later point in time, contact your sales
representative.
• Full version – Installs an unrestricted version of SilkTest, which requires a license.
15.To install the license file, perform the following steps:
a) Click Configure your license server and then click Next.
The license utility checks your local system for the existence of SilkMeter license server
configuration files. If the files are found, the configuration and type of license server are displayed
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and used for licensing. If no configuration data is found, the Select SilkMeter License Server page
is displayed with the default settings.
b) From the Application list box, select SilkTest as the application you are licensing.
c) Click one of the following option buttons:
Using local or
remote server

In the License Server Host text box, type the name of the computer on which
SilkMeter is installed. Do not change the default port number, 5461, unless your
network administrator has defined a different port. Click Apply to generate your
license server configuration. Click Test Connection to verify that a SilkMeter
server is accessible on the specified host and port. Testing the connection to the
license server might fail during installation as required system libraries, which are
installed later with the software package, might not yet be available.
Note: In some cases, specifying the simple name of the license server in
the License Server Host text box, such as licenseserver, might not
work. A message box stating there is no license server
running on the hostname you specified opens. To resolve this
issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Not using
server
(standalone)

Runs SilkMeter standalone. You are prompted to import a SilkMeter license file.
Click Yes and specify the location of your license file.

d) Click Close.
Fastpath: A working network connection is required when running SilkTest with a remote
SilkMeter license server. If you need to verify that the network is working, choose Start > Run,
and then type ping localhost or ping <license server name>, or open a command
prompt and type either of those commands.
The Install Complete page opens.
16.Click Done.
17.Restart Visual Studio if it was running when you performed the Silk4NET installation.
When installation completes, a menu option appears for Silk4NET and the Silk4NET project is available
from the Installed Templates list.

Installing the Silk4NET Visual Studio Plug-in Manually
The Silk4NET Visual Studio plug-in enables you to create Visual Basic or C# test scripts directly in Visual
Studio. You can install the Silk4NET Visual Studio plug-in when you install SilkTest using the SilkTest
installation wizard.
Use this procedure:
•
•

If you upgrade your version of Visual Studio after you install the Silk4NET plug-in.
If you chose the Install Silk4NET manually option during installation.

1. Locate the ItemTemplates and ProjectTemplates folders in SilkTest\installation
directory\ng\Silk4NET.
By default the location is C:\Program Files\Silk\SilkTest\ng\Silk4NET.
2. Copy the ItemTemplates and ProjectTemplates folders and paste them to Visual Studio
2010 installation directory\Common7\IDE\
For example, if your Visual Studio environment is installed at C:\Program Files\Microsoft
Visual Studio\, copy the folders to C:\Program Files\Microsoft Visual Studio
9.0\Common7\IDE.
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3. In Visual Studio, choose Tools > Options > Environment > Add-in/Macros Security.
4. Click Add and then add the path to SilkTest\installation directory\ng\Silk4NET\Addins.
A menu option appears for Silk4NET and the Silk4NET project is available from the Installed
Templates list.
Note: If the Silk4NET menu option and templates list do not display, start the devenv.com with
the parameter "/setup". For instance, type:
"<VS10InstallDir>\Common7\IDE\devenv.com /setup"
5. If you are upgrading from one version to another, you must manually remove the online help by typing
the following command:
HelpLibManager.exe /product VS /version 100 /locale en-us /uninstall /
silent /vendor "Micro Focus" /mediaBookList "Silk4NET" /productName
"SilkTest 2010"
By default, the Help Library Manager EXE file is located at C:\Program Files\Microsoft Help
Viewer\v1.0.
6. To install the Silk4NET online help, type:
HelpLibManager.exe /product VS /version 100 /locale en-us /silent /
sourceMedia "<SilkTest installation directory>\ng\Silk4NET\Documentation
\helpcontentsetup.msha"
By default, the Help Library Manager EXE file is located at C:\Program Files\Microsoft Help
Viewer\v1.0.

Installing SilkTest Classic
Before you start, download the SilkTest executable file or insert the SilkTest CD into the CD drive.
SilkTest Classic is automatically installed when you choose a complete installation. If you choose a custom
installation, you can install SilkTest Classic to use only the traditional 4Test interface and tools. When you
install SilkTest Classic, SilkTest Recorder, SilkTest Classic Agent, and the Open Agent are also installed.
SilkTest Recorder enables you to record tests rather than manually coding them. SilkTest Classic uses the
Classic Agent or the Open Agent to connect to supported technology domains. While the Open Agent is
required for the SilkTest Recorder.
1. Locate and double-click the SilkTest executable file.
If you have a SilkTest CD, insert your CD. If the setup program does not start automatically, manually
start the SilkTest setup program by choosing Start > Run and entering <cddrive>:\setup.exe.
Note: If your Windows TEMP environment variable does not point to a valid directory, an error
message is displayed. To successfully install SilkTest, your TEMP environment variable must point
to a valid directory.
The InstallAnywhere wizard opens.
2. If you previously installed a version of SilkTest, click Uninstall and then click Next to remove all
installed features.
You must uninstall any earlier versions before you install a new version.
3. Click Next.
The License Agreement opens.
4. Read the license agreement carefully. If you accept the terms of the agreement, click I accept the
terms of the License Agreement.
5. Click Next.
The Choose Install Set page opens.
6. From the drop-down list, select Custom and check the check box for SilkTest Classic IDE.
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When you install SilkTest Classic, SilkTest Recorder, SilkTest Classic Agent, and the Open Agent are
also installed.
7. To include additional shortcut icons, check one or both of the following check boxes:
•
•

On the Desktop – Adds icons to the desktop.
In the Quick Launch Bar – Adds icons to the Quick Launch toolbar.

8. Click Next.
The Choose Install Folder page opens.
9. To change the default installation directory, perform the following steps:
a) Click Choose.
The Browse For Folder dialog box opens.
b) Specify the folder in which you want to install SilkTest, and then click OK to return to the Choose
Install Folder page.
Note: You cannot install SilkTest and SilkTest Runtime on the same machine.
Note: SilkTest must be installed on a local drive. An error message appears if you specify an
invalid installation destination.
The location displays in the Where Would You Like to Install? text box.
10.Click Next.
11.Select a default language to use when testing browser applications with the Classic Agent.
To switch to another language later, see the Help.
The browser include (.inc) file for the language you select is installed in the <SilkTest install>
\Extend directory. All browser include files are installed in the <SilkTest Install>\Locale
directory.
12.Verify the default browser for Web application testing and then click Next.
The Setup Program preselects the option in this dialog based on browser settings on your machine. For
instance, if you are using Internet Explorer, it displays the version of IE installed on your machine.
To specify a different default browser for SilkTest Classic, select the appropriate browser. If you are not
testing a Web application, click None, and then click Next.
Regardless of what you select, you can change this setting later within SilkTest Classic. Refer to the
SilkTest Classic Help for instructions on changing your default browser or browser extensions after
installation.
Note: If your default browser is Internet Explorer, you might receive a message that your
browser’s third-party extensions are not enabled. You must enable this option in order for SilkTest
Classic to recognize objects in browser pages. You can enable this option and then continue with
the installation, or you can wait and enable the option after the installation is complete.
13.Specify whether you want to create Windows firewall exceptions.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
a) Click one of the following option buttons:
•

Yes – To have setup create firewall exceptions for all SilkTest executable files. As a result, you
are not prompted to block or allow the executable files when you launch them.
• No – To be prompted when you launch the SilkTest executable file.
b) Click Next.
14.Review the provided information and perform one of the following steps:
•
•
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To change any settings, click Previous to return to the appropriate page.
If you are satisfied with the settings, click Install to start the installation process.

Tip: If a message appears stating that there is not enough space while files are copying, redefine
the TEMP area to a drive that contains more space. The installer uses the TEMP area for
unzipping files. For example, if your TEMP area is d:\temp and you are installing to e:
\SilkTest, the E drive may contain enough space for the installation, but the D drive is the
limiting factor.
The status bar provides information about the installation process. Upon completion, the Choose
Licensing Mode page opens.
15.Click one of the following option buttons:
•

Evaluation version Installs an evaluation version of SilkTest, which grants you full product
functionality for 30 days. To upgrade to a full version at a later point in time, contact your sales
representative.
• Full version – Installs an unrestricted version of SilkTest, which requires a license.
16.To install the license file, perform the following steps:
a) Click Configure your license server and then click Next.
The license utility checks your local system for the existence of SilkMeter license server
configuration files. If the files are found, the configuration and type of license server are displayed
and used for licensing. If no configuration data is found, the Select SilkMeter License Server page
is displayed with the default settings.
b) From the Application list box, select SilkTest as the application you are licensing.
c) Click one of the following option buttons:
Using local or
remote server

In the License Server Host text box, type the name of the computer on which
SilkMeter is installed. Do not change the default port number, 5461, unless your
network administrator has defined a different port. Click Apply to generate your
license server configuration. Click Test Connection to verify that a SilkMeter
server is accessible on the specified host and port. Testing the connection to the
license server might fail during installation as required system libraries, which are
installed later with the software package, might not yet be available.
Note: In some cases, specifying the simple name of the license server in
the License Server Host text box, such as licenseserver, might not
work. A message box stating there is no license server
running on the hostname you specified opens. To resolve this
issue, specify the hostname by using a fully qualified name, such as
licenseserver.mycompany.com.

Not using
server
(standalone)

Runs SilkMeter standalone. You are prompted to import a SilkMeter license file.
Click Yes and specify the location of your license file.

d) Click Close.
Fastpath: A working network connection is required when running SilkTest with a remote
SilkMeter license server. If you need to verify that the network is working, choose Start > Run,
and then type ping localhost or ping <license server name>, or open a command
prompt and type either of those commands.
The Install Complete page opens.
17.Specify whether you want to restart the system to complete the installation and then click Done.
Attention: You must restart your computer for SilkTest Classic to work properly.
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Installing Sample Applications
SilkTest provides several sample applications that you can use with tutorials or to create sample tests.
When you download the sample applications, you also download sample projects.
1. Navigate to http://techpubs.borland.com/silk_gauntlet/SilkTest/.
2. To download sample applications and projects for Java AWT, Java Swing, Java SWT, Microsoft .NET
(including Windows Forms and WPF applications), Windows-based client server, and xBrowser
applications, click SampleApplications.
You are prompted to open or save the SampleApplications.zip file.
3. After you download the sample zip files, unzip and install the sample applications.
Note: We no longer provide Adobe Flex sample applications that you can install. However, you can
access Flex sample applications at http://demo.borland.com/flex/SilkTest2011/index.html.

Customizing the Default SQL Server Express 2008
Database
Important: We recommend that a database administrator or person with general knowledge of
database administration perform this task.
You can customize specific database settings, such as the security mode or password, of the default SQL
Server Express 2008 database prior to installing SilkTest Workbench. After customizing the database
settings, you can then run the installation wizard to complete the database installation process.
Note: SQL Server Express 2008 requires Windows Installer version 4.5 and Microsoft .Net
Framework 3.5 SP1.
1. Install the required SilkTest Workbench database instance and specify the desired database settings.
Open a command prompt and point to the SQL Server Express executable file directory location.
The 32-bit executable name is SQLEXPR_x86_ENU.exe. The 64-bit executable name is
SQLEXPR_x64_ENU.exe. Both EXE files include Service Pack 1.
2. Type one of the following commands depending on your computer's specifications:
32-bit:
SQLEXPR_x86_ENU.exe /Q /ACTION=Install /FEATURES=SQLEngine /
INSTANCENAME=SilkTestW
/SECURITYMODE=SQL /SAPWD=silktestw /BROWSERSVCSTARTUPTYPE=Automatic
/SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE"
/SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS"
64-bit:
SQLEXPR_x64_ENU.exe /Q /ACTION=Install /FEATURES=SQLEngine /
INSTANCENAME=SilkTestW
/SECURITYMODE=SQL /SAPWD=silktestw /BROWSERSVCSTARTUPTYPE=Automatic
/SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE"
/SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS"
Note: These are the default settings used by the installation wizard to install a SilkTest Workbench
database instance. You can modify any of these settings with the exception of the /
INSTANCENAME, which must be SilkTestW. To see the progress of the installation, use the /QS
command rather than /Q. To hide the installation progress entirely, use /Q /HIDECONSOLE.
3. Run the installation wizard and choose the option to install a SQL Server Express Database.
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The installation wizard detects the previously created database instance and creates the required
SilkTest Workbench database tables.

Uninstalling SilkTest
When you install a new version of SilkTest, the wizard prompts you to uninstall any existing versions of
SilkTest. You can also uninstall SilkTest from the programs menu at any time.
1. Choose Start > Programs > Silk > SilkTest 2011 > SilkTest Uninstall.
The InstallAnywhere wizard opens the Uninstall SilkTest 2011 page.
2. To remove all files from the installation directory, check the Remove all files check box.
If you check this check box, the following items or folders are removed:
•
•
•

Any sample applications that you have installed
The Access database and samples
The contents of [AppDATA]/Silk/SilkTest

•

For example, on Windows 7 this directory is located at: C:\Users\[username]\AppData
\Roaming\Silk\SilkTest
The contents of [commonAppData]/Silk/SilkTest

•

For example, on Windows 7 this directory is located at: C:\ProgramData\SilkTest
The contents of [commonAppData]/Silk/SilkTest Workbench
For example, on Windows 7 this directory is located at: C:\ProgramData\SilkTest Workbench

3. Click Uninstall.
If any files were not removed, a list of the files is provided.
4. Click Done.

SilkTest Silent Mode Installation
During a typical user-driven installation, the install process gets its information from a user responding to
dialog boxes. However, during a silent installation, the installation process gets its information from a
properties file. Silent installation is especially useful if you want to distribute software over a LAN or the
Internet by using remote installation tools. You can execute silent installs of the following types:
•
•
•
•

Complete – Installs SilkTest Workbench, the SilkTest Agents, SilkTest Recorder, Silk4J, Silk4NET, and
SilkTest Classic.
Standard – Installs SilkTest Workbench, the SilkTest Open Agent, SilkTest Recorder, Silk4J, and
Silk4NET.
Basic – Installs SilkTest Workbench and the SilkTest Open Agent.
Agent/Runtime – Installs SilkTest Runtime and the SilkTest Agents.

Creating a Silent Installation Properties File
Before you can run the installation package in silent mode, you must create a properties file that includes
the settings for the installation.
1. Open a text editor, such as Notepad.
2. Paste the following example into the text editor, name the file, and then save the file with
a .properties extension.
For example, you might call the file SilentInstall.properties.
# Silent Installation Execution Instructions:
################################
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# Start the Install.exe (not Setup.exe) with the following arguments:
# -i silent -f [path to properties file][properties file] (You may use the
direct or the relative path to the properties file. )
#
# example: install.exe -i silent -f SilentInstall.properties
#
# SilkTest installation path - use "\\" to separate directories
# (default: [System_Programs_Folder]\\Silk\\SilkTest)
################################
# USER_INSTALL_DIR=C:\\Program Files\\Silk\\SilkTest
#
# Select an install set:
# (default: 1)
################################
# 0 - Basic (Workbench)
# 1 - Standard (Workbench, Silk4J, Silk4NET)
# 2 - Complete
# 3 - Agent/Runtime Only
# Custom mode is not supported in Silent mode
# SELECTED_INSTALL_SET=1
#
# Microsoft SQL Server 2008 Express Edition installation option:
# (default: No)
################################
# USER_INPUT_INSTALL_SQL=Yes
#
# Shortcut locations: enter the location(s) for icons (allowed: Desktop,
QuickLaunch)
# (default: no shortcuts)
################################
# SHORTCUT_LOCATIONS=Desktop,QuickLaunch
#
# Path to the existing Eclipse directory (containing eclipse.exe) into
which Silk4J will be integrated
# (default: USER_INSTALL_DIR)
################################
# ECLIPSE_CHOSEN_DIR=C:\\Eclipse
#
# Silk4NET installation option: if set to 1, Silk4NET will be integrated
into an existing VS2010
# (default: 0)
################################
# USER_INPUT_SILK4NET_INTEGRATE=1
#
# Classic Agent browser options:
################################
# Default language: English
#
(allowed one at a time: English, Simplified Chinese, French,
German, Japanese)
# USER_INPUT_BROWSER_LANGUAGE=English
#
# Default browser:
# Default Value: System Default Browser if supported by Classic Agent,
otherwise None
#
(allowed one at a time: None, Firefox, Internet Explorer)
# USER_INPUT_DEFAULT_BROWSER=None
#
# Internet Explorer version number:
#
Set if selected default browser is Internet Explorer
#
(allowed one at a time: 6, 7, 8)
# IE_VERSION=7
#
# Mozilla Firefox version number:
#
Set if selected default browser is Firefox
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#
(allowed one at a time: 1_5, 2_0)
# FIREFOX_DOMEX_VERSION=2_0
#
# Firewall exceptions:
# (default: no exceptions)
#########################
# USER_INPUT_FIREWALL=Yes
#
# Licensing Mode (no default value)
###############################
# Use to install an evaluation license
# USER_VERSION_EVAL=1
#
# Use to install a full license
# USER_VERSION_FULL=1
#
# Settings that specify the license server and port
# (no default values)
################################
# LICENSE_SERVER=localhost
# Port of license server
# LICENSE_PORT=5461

Setting Up the Silent Installer
Before you can set up the properties for the silent installer, you must create a properties file that includes
the settings for the installation.
Note: To set a property value, make sure to remove the hash (#) sign from the property value string.
1. In a text editor, open the properties file that you created for the silent installation.
2. Locate the SELECTED_INSTALL_SET property and set the value to match the type of installation that
you want to complete.
Choices include:
# 0 - Basic (Workbench)
# 1 - Standard (Workbench, Silk4J, Silk4NET)
# 2 - Complete
# 3 - Agent/Runtime Only
Note: Custom mode is not supported for silent installation.
For example, to install the complete version of SilkTest, type:
SELECTED_INSTALL_SET=2
3. To install Microsoft SQL Server 2008 Express Edition, locate the USER_INPUT_INSTALL property and
specify Yes.
SilkTest Workbench requires a database and runs with SQL Server, Access, or Oracle.
4. To include additional shortcut icons, locate the SHORTCUT_LOCATIONS property and specify one or
both of the following options:
•
•

Desktop – Adds icons to the desktop.
QuickLaunch – Adds icons to the Quick Launch toolbar.

For example to install both the Desktop and Quick Launch icons, type:
SHORTCUT_LOCATIONS=Desktop,QuickLaunch
5. To integrate an existing Eclipse environment with the Silk4J Java Testing Framework (JTF), locate the
ECLIPSE_CHOSEN_DIR property and specify the Eclipse directory location.
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For example, you might specify:
ECLIPSE_CHOSEN_DIR=C:\\Eclipse
where C:\\Eclipse is the directory where Eclipse is installed.
Note: Directory levels are specified with a double \\.
6. To install Silk4NET for use with an existing Visual Studio environment, locate the
USER_INPUT_SILK4NET_INTEGRATE property and specify one of the following options:
•
•

0 – Silk4NET is not set up for use.
1 – Silk4NET is set up for use.

The Silk4NET Visual Studio plug-in enables you to create VB.NET or C# test scripts directly in Visual
Studio.
For example, you might specify:
USER_INPUT_SILK4NET_INTEGRATE=1
7. To specify the language for the Classic Agent browser application, locate the
USER_INPUT_BROWSER_LANGUAGE property and specify one of the following languages:
By default, English is specified.
•
•
•
•
•

English
Simplified Chinese
French
German
Japanese

For example, you might specify:
USER_INPUT_BROWSER_LANGUAGE=English
8. To specify the default browser for the Classic Agent, locate the USER_INPUT_DEFAULT_BROWSER
property and specify one of the following choices:
By default, the installer uses the default system browser, if it supported by SilkTest.
•
•
•

None - Choose None if you do not test with the Classic Agent or if you do not test web applications.
Firefox
Internet Explorer

For example, you might specify:
USER_INPUT_DEFAULT_BROWSER=Firefox
9. To specify the Internet Explorer version for the Classic Agent, locate the IE_VERSION property and
specify 6, 7, or 8.
For example, you might specify:
IE_VERSION=7
10.To specify the FireFox version for the Classic Agent, locate the FIREFOX_DOMEX_VERSION property
and specify 1_5 or 2_0.
For example, you might specify:
FIREFOX_DOMEX_VERSION=2_0
11.Specify whether the installation includes Windows firewall exceptions for all SilkTest executable files.
Note: This step is only available for Windows XP, Windows Vista, Windows 7, and Windows
Server 2008.
By default, no firewall exceptions are set.
For example, to create Windows firewall exceptions specify:
USER_INPUT_FIREWALL=Yes
12.Specify whether the installation requires an evaluation license or a full license.
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•
•

To use a 30-day trial evaluation license, type:
USER_VERSION_EVAL=1
To use a full license, type:
USER_VERSION_FULL=1

13.To specify the license server name, locate the LICENSE_SERVER property and specify the server
name.
This value is not set by default. To use your local machine, in most cases, you type localhost.
14.To specify the license server port, locate the LICENSE_PORT section.
This value is not set by default. To use the predefined port, type 5461.
15.Save the file.
Run the silent installation command to launch the installation.

Installing in Silent Mode
Before you can run the installation package in silent mode, you must
•
•

Create a properties file that includes the settings for the installation.
Install Windows Installer version 4.5 on the host machine.
When you use the Installation wizard, Windows Installer version 4.5 is installed automatically. When
you use Silent mode, you must manually install this component if it is not already on the machine.
Caution: Ensure that earlier versions of SilkTest have been uninstalled before proceeding. If an
earlier version of SilkTest, such as SilkTest 2009, is located on the computer, SilkTest overwrites the
existing files without notification. Do not install multiple versions of SilkTest on the same machine.

Install in silent mode to install SilkTest without any user interaction.
1. Ensure that the installation package has been extracted to an empty directory on your hard drive.
If you are using an installation CD, copy the contents of the CD to an empty directory on your hard
drive.
2. To execute silent installation, enter the following command from a DOS shell or batch file.
install.exe -i silent -f [path to properties file]\[properties file]
Important: Start the silent mode with the [device]:\Disk1\InstData\VM\install.exe
executable and not the [device]:\setup.exe.
Note: The properties file is a text file with the extension .properties . You can name the file
whatever you choose.
For example, if the silent installation properties file is located in the same directory as the
install.exe, you might specify:
install.exe -i silent -f SilentInstall.properties
If the install.exe is not located in the same directory as the silent installation properties file, specify
the absolute path to the properties file location. For example:
install.exe -i silent -f C:\temp\SilentInstall.properties
Note: To make the installation package run with the GUI again, launch the setup.exe file rather
than the install.exe file.
SilkMeter is a licensing tool; when you run the silent installer it “skips” detecting a SilkMeter server. If you
have not already configured your license server, you may have to do so after you install SilkTest with the
silent installer.

Installing SilkTest

| 41

Verifying the Success of the Silent Installer
When you run the Silent Installer, you may not see any messages or SilkTest dialog boxes. It may be
difficult to know whether the installation was a success. You can, however, review the
SilkTest_2011_InstallLog.log file, which contains the status of the install. By default, the
SilkTest_2011_InstallLog.log file is generated in the SilkTest installation directory. We
recommend examining the log file before you make the Silent Installer available for others to use.
: If an earlier version of SilkTest, such as SilkTest 2009, is detected on the computer, SilkTest continues
the installation and does not include an entry in the log file. Do not install multiple versions of SilkTest on
the same machine.
1. Locate the SilkTest_2011_InstallLog.log file and open it in a text editor.
2. To determine whether the Silent Installer succeeded, review the status messages for each action
performed by the setup.
The installation log records SUCCESSFUL, WARNING, or ERROR for each action the installer executes.
The installation log also includes a summary which tallies the number of successes, warnings, non-fatal
errors, or errors.
For example, an action might look like the following:
Install File: C:\Program Files\Silk\SilkTest\ng\recorder\plugins\
com.borland.silktest.recorder_11.1.0.4440\plugin.xml
Status: SUCCESSFUL
The summary might look like the following:
Summary
------Installation: Successful.
2497 Successes
0 Warnings
0 NonFatalErrors
0 FatalErrors

Viewing Error Codes
View the installation error codes to analyze the errors that occurred during silent installation.
1. Create a batch file to start the installation and run it.
For example, you might create a file named install.bat with the following code:
@echo off
install.exe -I silent -f SilentInstall.properties
echo %errorlevel%
pause
2. Review the installation codes.
The following table lists possible return values for the Code keyname.
Table 1: Installer Exit Codes
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Code

Description

0

Success: The installation completed successfully without any warnings or errors.

1

The installation completed successfully, but one or more of the actions from the installation
sequence caused a warning or a non-fatal error.

-1

One or more of the actions from the installation sequence caused a fatal error.

Code

Description

1000

The installation was cancelled by the user.

1001

The installation includes an invalid command line option.

2000

Unhandled error.

2001

The installation failed the authorization check, may indicate an expired version.

2002

The installation failed a rules check. A rule placed on the installer itself failed.

2003

An unresolved dependency in silent mode caused the installer to exit.

2004

The installation failed because not enough disk space was detected during the execution of the
Install action.

2005

The installation failed while trying to install on a Windows 64-bit system, but installation did not
include support for Windows 64-bit systems.

2006

The installation failed because it was launched in a UI mode that is not supported by this installer.

3000

Unhandled error specific to a launcher.

3001

The installation failed due to an error specific to the lax.main.class property.

3002

The installation failed due to an error specific to the lax.main.method property.

3003

The installation was unable to access the method specified in the lax.main.method property.

3004

The installation failed due to an exception error caused by the lax.main.method property.

3005

The installation failed because no value was assigned to the lax.application.name
property.

3006

The installation was unable to access the value assigned to the
lax.nl.java.launcher.main.class property.

3007

The installation failed due to an error specific to the lax.nl.java.launcher.main.class
property.

3008

The installation failed due to an error specific to the

lax.nl.java.launcher.main.method property.
3009

The installation was unable to access the method specified in the

lax.nl.launcher.java.main.method property.
4000

A Java executable could not be found at the directory specified by the java.home system
property.

4001

An incorrect path to the installer jar caused the relauncher to launch incorrectly.

Uninstalling in Silent Mode
Uninstall in silent mode to uninstall SilkTest without any user interaction.
Note: You can uninstall SilkTest with silent mode regardless of how you installed the product.
However, if you install SilkTest in silent mode, the uninstall mode is executed silently also.
1. Locate the Uninstall_SilkTest 2011 folder.
The Uninstall SilkTest 2011.exe is located in this folder.
2. To execute the silent mode uninstallation procedure, enter one of the following commands from a DOS
shell or batch file.
•

If you installed SilkTest in silent mode, enter the following command.
<SilkTest Install Directory>\Silk\SilkTest\Uninstall_SilkTest
2011\Uninstall Silk 2011.exe
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•

If you did not install SilkTest in silent mode, enter the following command.
<SilkTest Install Directory>\Silk\SilkTest\Uninstall_SilkTest
2011\Uninstall SilkTest 2011.exe -I silent

For example, you might type the following command if you did not install SilkTest in silent mode:
C:\Program Files\Silk\SilkTest\Uninstall_SilkTest 2011\Uninstall SilkTest
2011.exe -I silent

What To Do Next
Try the tutorials
If you are new to SilkTest, we recommend that you try the SilkTest tutorials, available from Start >
Programs > Silk > SilkTest 2011 > Documentation > SilkTest Tutorials.
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Configuring a SilkTest Workbench
Database
This section contains topics describing how to configure a SilkTest Workbench database.

Configuring a SQL Server Database Overview
Important: We recommend that a database administrator or person with general knowledge of
database administration performs the database setup and configuration.
SilkTest Workbench stores and accesses test assets stored in a database configured for use with SilkTest
Workbench. This section describes how to configure the following SQL Server databases to use as a
SilkTest Workbench database:
•
•
•
•

SQL Server 2008
SQL Server 2008 Express
SQL Server 2005
SQL Server 2005 Express

SQL Server Requirements
A SQL Server database configured for use with SilkTest Workbench has the following requirements:
•
•
•

Each computer running SilkTest Workbench must be able to access the computer where the SQL
Server database resides and have a new data source configured.
SilkTest Workbench must be installed on all computers accessing the database.
The SilkTest Workbench database connection file must be configured to point to the SQL Server
database.

For SQL Server 2008 Express, the following configuration requirements are automatically performed by the
SilkTest installer:
•
•
•
•

SQL Server 2008 Express database with instance SilkTestw and password silktestw.
User with admin rights SilkTestAdmin with password SilkTestAdmin. General user
SilkTestUser with password SilkTestUser.
Data source name (DSN) SilkTest_SQL.
Database owner/schema SilkTestDB.
Note: SilkTest cannot use 64-bit DSNs. As a result, for 64-bit machines, SilkTest creates 32-bit DSNs
during installation. You can review the default DSNs and ODBC drivers for 64-bit machines using the
WOW64 tools, which are located at C:\Windows\SysWow64.

For more information about maintaining the default SilkTest Workbench SQL Server 2008 Express
database, refer to the SilkTest Workbench Help topic “Database Maintenance”.

Creating a New SQL Server Database
This section describes how to create a SQL Server 2005/2008 database using SQL Server Management
Studio. In addition to the following procedures, you must also populate the database with SilkTest
Workbench tables using the SilkTest Workbench Database Maintenance utility.
1. In the Object Explorer of SQL Server Management Studio, right-click the Databases folder and choose
New Database.

Configuring a SilkTest Workbench Database

| 45

The New Database dialog box opens.
2. Enter a name for the database in the Database name text box.
3. Click OK.

Creating a New SQL Server Admin User
A SQL Server user with system administrator rights is required to perform subsequent setup steps.
Note: For SQL Server 2008 Express, SilkTest Workbench automatically creates a user with admin
rights SilkTestAdmin and password SilkTestAdmin.
1. To create a new user with system administrator rights, perform the following steps:
a) In the Object Explorer of SQL Server Management Studio, navigate to the Security folder and
expand it.
b) Right-click the Logins folder and choose New Login.
The Login - New dialog box opens.
c) Select the General page, and then enter a user name in the Login name text box.
d) Select SQL Server Authentication and enter a password.
e) Select the default database from the Default database list.
f) Select the Server Roles page, and then check the sysadmin check box in the Server roles list.
g) Select the User Mapping page.
h) In the Map column, check the check box for the database that the new login can access.
By default, the login name appears in the User column. Leave this value.
i) In the Database role membership for list, check the db_owner check box.
j) Click OK.
2. To create a new schema for the new user, perform the following steps:
a) In the Object Explorer, navigate to the database in which you want to create a schema.
b) Expand the database object tree to show the Schemas folder.
The Schemas folder is a child of the Security folder for the database.
For example, if you are adding a schema to the master database, expand the following folders to
show the Schemas folder: Databases > System Databases > master > Security.
c) Right-click the Schemas folder and choose New Schema.
d) In the Schema name text box, type a name for the new schema.
The new schema name must match the name of the previously created user with system admin
rights.
e) Assign the new user with system administrator rights as the owner of the schema.
f) Click OK.
3. Select the newly created user and set the default schema to the newly created schema.

Setting Up Users in SQL Server
The following procedure should be performed on the database server computer for each user who needs
to connect to the SQL server database.
1. In the Object Explorer of SQL Server Management Studio, navigate to the Security folder and expand
it. Right-click the Logins folder and choose New Login.
The Login - New dialog box opens.
2. Select the General page, and then enter a name for the database in the Login name text box.
3. Select either Windows Authentication or SQL Server Authentication.
4. Select the default database from the Default database list.
5. Select the User Mapping page.
6. In the Map column, check the check box for the database that your login can access.
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By default, the login name appears in the User column. Leave this value.
7. In the Default Schema column, enter the default schema.
For use with SilkTest Workbench, the default schema must match the schema of the previously created
user with system admin rights.
8. In the Database role membership for list, leave the default option public selected.
9. Check the db_datareader and db_datawriter check boxes.
10.Click OK.
Important: To use SQL Server Express with multiple users, each SQL Server Express installation
must be enabled for remote connectivity. To enable SQL Server Express for remote connectivity,
refer to the Microsoft support article How to enable remote connections on SQL Server .

Preparing the SQL Server SilkTest Workbench
Database
You must prepare your new SQL Server database for use with SilkTest Workbench. This section describes
how to use the Database Maintenance utility to populate the database with SilkTest Workbench tables.
Note: SQL Server Authentication Mode must be set to: SQL Server and Windows (Mixed Mode) to
allow connection to the SQL Server database through the Database Maintenance utility. This setting
can be changed after any database maintenance tasks are performed.
1. Choose Start > Programs > Silk > SilkTest > Administration Tools > Database Maintenance to
start the Database Maintenance utility.
2. Choose File > New Database > SQL Server.
The SQL Server Data Source Connection dialog box opens.
3. Type the name of the new SQL Server data source or click Browse and select a data source name
from the Select ODBC Data Source dialog box.
4. In the appropriate text boxes, type the name of the database owner, the SQL Server user ID, and
password, and then click Create.
Note: Only one schema can be associated with a DSN name (ODBC connection). If the chosen
DSN name is already associated with a schema, click Replace to change the association of the
DSN name from its current schema to the new schema (users will no longer be able to access
SilkTest Workbench tables in the old schema), or click Alias to create an alias for the DSN name.
You are now ready to start SilkTest Workbench and log on.

Configuring an Oracle Database Overview
This section describes how to set up an Oracle database with SilkTest Workbench.
Note: The following instructions assume familiarity with the Oracle database management system.
We recommend that a database administrator or a person with general knowledge of database
administration performs database setup and configuration.
Each client computer requires an ODBC data source to connect to the database. As a result, connecting to
an Oracle database for SilkTest Workbench has the following requirements:
•
•
•
•

Each computer running SilkTest Workbench must be able to access the computer where the database
resides and have a new data source configured.
SilkTest Workbench must be installed on all computers that access the database.
The appropriate database client connectivity software must be installed on any computer that runs
SilkTest Workbench.
The database connection must be configured for use with SilkTest Workbench.
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Selecting an Authentication Method
SilkTest Workbench supports the use of either Oracle OS authentication (Windows NT) or Oracle database
authentication. There are additional installation procedures required when using Oracle OS authentication.

Oracle OS Authentication
This topic provides instructions for creating users and granting connection rights when using Oracle OS
authentication. Prior to performing these steps, consider the following:
•
•
•
•
•

You must be a member of the ORA_DBA group and have SYSDBA privileges.
Users must be created in such a way that Oracle knows they are authenticated via a DOMAIN
controller.
Use SQL*Plus or SQL*Plus Worksheet to create users. If you are not familiar with SQL*Plus, consult
your Oracle documentation.
Users must be created within a Windows NT domain and added to the ORA_DBA group. Refer to your
Microsoft Windows documentation for more information about using a Windows domain.
When setting up users for SilkTest Workbench in Oracle, create a schema to house the actual tables in
addition to the remotely authenticated users. The schema is not domain authenticated, but is password
authenticated.

1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "DOMAIN\USERNAME" IDENTIFIED EXTERNALLY, and
grant connection rights and system privileges as shown in the following example.
For each user as "DOMAIN\USERNAME". Type DOMAIN\USERNAME in uppercase and between double
quotation marks, where DOMAIN\USERNAME is each user’s domain and user name.
For example:
CREATE USER "NT-DOMAIN\JEFF" IDENTIFIED EXTERNALLY;
GRANT SELECT ANY SEQUENCE TO "NT-DOMAIN\JEFF";
GRANT UNLIMITED TABLESPACE TO "NT-DOMAIN\JEFF";
GRANT "CONNECT" TO "NT-DOMAIN\JEFF";
GRANT "RESOURCE" TO "NT-DOMAIN\JEFF";
GRANT "SELECT_CATALOG_ROLE" TO "NT-DOMAIN\JEFF";
Important: Microsoft operating systems return the DOMAIN\USERNAME when the user is queried.
If this does not match what is defined in the database, Oracle OS authentication will fail with
ORA-1017.
4. Test that Oracle OS authentication is set up correctly by connecting to the database via SQL*Plus.
a) Type a "/" for the user name.
b) Leave the Password text box empty, and enter the host string appropriately.
c) Click OK.
If you can log on, Oracle OS authentication is working properly.

Oracle Database Authentication
This topic provides instructions for creating users and granting connection rights when using Oracle
database authentication. Prior to performing these steps, consider the following:
•
•
•
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•
•

Users must be created within a Windows NT domain and added to the ORA_DBA group. Refer to your
Microsoft Windows documentation for more information about using a Windows domain.
When setting up users for SilkTest Workbench in Oracle, create a schema to house the actual tables in
addition to the remotely authenticated users. The schema is not domain authenticated, but is password
authenticated.

1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "USERNAME" IDENTIFIED BY “ORACLEPASSWORD”, and
grant connection rights and system privileges as shown in the following example.
For each user as "USERNAME". Type USERNAME in uppercase and between double quotation marks,
where DOMAIN\USERNAME is each user’s user name.
For example:
CREATE USER "JEFF" IDENTIFIED BY “ORACLEPASSWORD”;
GRANT SELECT ANY SEQUENCE TO "JEFF";
GRANT UNLIMITED TABLESPACE TO "JEFF";
GRANT "CONNECT" TO "JEFF";
GRANT "RESOURCE" TO "JEFF";
GRANT "SELECT_CATALOG_ROLE" TO "JEFF";

Creating a New Oracle Database
Create a new Oracle database with character set UTF8. For more information, refer to the Oracle product
documentation.

Setting Up Oracle Authentication
Note: This procedure is only necessary if you use Oracle OS authentication. If you use Oracle
database authentication, you must set up the Oracle client.
1. On the server where the database is located, locate the Oracle Initialization file in the directory where
Oracle was installed.
2. In the Oracle Initialization file, set values for the following parameters:
•
•
•

remote_login_passwordfile = none
remote_os_authent = true
os_authent_prefix = ““
Note: If any of the parameters and values do not exist, you must add them. In Oracle 11g, the
remote_os_authent and os_authent_prefix parameters are set by default.

3. Locate the SQLNET.ORA file in the directory where Oracle was installed.
The file is located in ORACLE_HOME\Network\Admin directory under the main Oracle installation
directory where ORACLE_HOME is the name assigned for the Oracle home during installation.
4. Open SQLNET.ORA and set the value of the following parameter as follows:
sqlnet.authentication_services = (NTS)
Note: Ensure this parameter is not commented out with a # at the beginning of the line. You may
need to add this parameter.
5. Access the Run dialog box from the Start menu.
6. In the Open text box, type regedit and then click OK.
The Registry Editor dialog box opens.
7. In the path HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOMEn (where n is the number associated
with the Oracle installation), right-click HOMEn and choose New > String Value.
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A new string value appears in the right pane of the registry editor.
8. Replace the default name, New Value #1 with OSAUTH_PREFIX_DOMAIN.
9. Double-click the string value you just created.
The Edit String dialog box opens.
10.In the Value data text box, type TRUE and then click OK.

Setting Up the Oracle Client
On the client computer from which you will connect:
1. Locate the SQLNET.ORA file in the directory where Oracle was installed.
The file is located in ORACLE_HOME\Network\Admin directory under the main Oracle installation
directory where ORACLE_HOME is the name assigned for the Oracle home during installation.
2. Open SQLNET.ORA and set the value of the following parameter as follows:
sqlnet.authentication_services = (NTS)
Note: Ensure this parameter is not commented out with a # at the beginning of the line. You may
need to add this parameter.
3. Open the TNSNAMES.ORA file in the directory where Oracle was installed.
This file is located in ORACLE_HOME\Network\Admin directory.
4. Copy the server’s database entry to the TNSNAMES.ORA file on the client computer.
For example:
ORACLE_SID.DOMAIN.COM=
(DESCRIPTION=
(ADDRESS_LIST=
(ADDRESS=(PROTOCOL=TCP)(HOST=SERVERNAME)(PORT=1521))
)
(CONNECT_DATA=
(SERVICE_NAME=ORACLE_SID)
)
)

Preparing the Oracle Database for Client Connectivity
Note: This procedure is only necessary if you are using Oracle OS authentication and an Oracle
client to set up the SilkTest Workbench database. If you are using Oracle database authentication,
you can begin to set up users.
1. On the computer that has User Manager for Domains, access the Windows Control Panel, and then
choose Administrative Tools > Computer Management
The Computer Management utility opens.
2. In the tree view, click Local Users and Groups.
3. Click Groups.
If Oracle is installed, you should see a group named ORA_DBA. If not, you must add it.
Next, create server access for users.

Creating the ORA_DBA Group
1. In the tree view of the Computer Management utility, right-click Groups and choose New Group.
The New Group dialog box opens.
2. In the Group Name text box, type ORA_DBA.
3. Click Create.
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4. Click Close.

Creating Server Access for Users
To create individual user accounts:
1. In the tree view of the Computer Management utility, click Local Users and Groups.
2. Click Groups.
3. In the right pane, double-click ORA_DBA.
The ORA_DBA Properties dialog box opens.
4. Click Add.
The Select Users, Computers, or Groups dialog box opens.
5. Click Advanced, then use the Common Queries tab to search for users, click Find Now and select
users from the list.
Alternatively, click in the Enter the object names to select text box and type the following: domain
name\user ID
Where domain name is the name of the domain where the user is located and user ID is the network
ID of the user you want to give access to.
6. Click OK to save the user information and return to the ORA_DBA Properties dialog box.
Repeat steps 4–6 to create any additional user accounts.
7. Click OK in the Users Properties dialog box to return to the Computer Management utility.

Setting Up Users for SilkTest Workbench in Oracle
This section provides instructions for creating users and granting connection rights for users. This
procedure is necessary when using either Oracle OS authentication or Oracle database authentication.
Separate instructions are provided for each type of authentication.
Oracle OS Authentication
Users must be created in such a way that Oracle knows they are authenticated via a DOMAIN controller.
Important:
When setting up users for SilkTest Workbench in Oracle, a schema must be also created to house
the actual tables in addition to the remotely authenticated users. The schema is not domain
authenticated, but is password authenticated. For more information, see Creating the Password
Authenticated Schema.
Users must be created within a Windows NT domain. Refer to your Microsoft Windows
documentation for more information about using a Windows domain.
Users must be added to the ORA_DBA group. Use SQL*Plus or SQL*Plus Worksheet to create
users. If you are not familiar with SQL*Plus, consult your Oracle documentation.
The user performing these steps must be a member of the ORA_DBA group and have SYSDBA privileges.
To specify users that can access the Oracle database:
1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "DOMAIN\USERNAME" IDENTIFIED EXTERNALLY, and
grant connection rights for each user as "DOMAIN\USERNAME". Type DOMAIN\USERNAME in
uppercase and between double quotation marks, where DOMAIN\USERNAME is each user’s domain and
user name. For example:
SQL> create user "NT-DOMAIN\JEFF" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "NT-DOMAIN\JEFF";
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Note: SELECT_ANY_SEQUENCE and SELECT_CATALOG_ROLE must also be granted to the user.
For example:
SQL> grant select_any_sequence to "JEFF";
SQL> grant select_catalog_role to "JEFF";
Microsoft operating systems return the DOMAIN\USERNAME when the user is queried. If this does
not match what is defined in the database, NT authentication will fail with ORA-1017.
4. Test that Windows NT authentication is set up correctly by connecting to the database via SQL*Plus.
Type a "/" for the user name. Leave the Password field blank, and enter the host string appropriately.
Click OK. If you are able to log on, Windows NT authentication is working properly.
Oracle Database Authentication
Important: When setting up users for SilkTest Workbench in Oracle, a schema must also be created
to house the actual tables in addition to the remotely authenticated users. The schema is password
authenticated. For more information, see Creating the Password Authenticated Schema.
Use SQL*Plus to create users. If you are not familiar with SQL*Plus, consult your Oracle documentation.
The user performing these steps must be a member of the ORA_DBA group and have SYSDBA privileges.
To specify users that can access the Oracle database:
1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "USERNAME" IDENTIFIED BY “ORACLEPASSWORD”, and
grant connection rights for each user as "USERNAME". Type USERNAME in uppercase and between
double quotation marks, where DOMAIN\USERNAME is each user’s user name. For example:
SQL> create user "JEFF" IDENTIFIED BY “ORACLEPASSWORD”;
SQL> grant connect, resource to "JEFF";
Note: SELECT_ANY_SEQUENCE and SELECT_CATALOG_ROLE must also be granted to the user.
For example:
SQL> grant select_any_sequence to "JEFF";
SQL> grant select_catalog_role to "JEFF";

Creating the Password Authenticated Schema
To set up the password authenticated schema into which the SilkTest Workbench tables are stored,
perform the following steps:
Note: The password authenticated schema should not be more than five characters in length
because of Oracle character limitations in SQL series.
1. Start SQL*Plus or SQL*Plus Worksheet.
2. Log on as SYSTEM and connect as SYSDBA.
3. Type commands to create each user as "USERNAME" IDENTIFIED BY "ORACLEPASSWORD", and
grant connection rights for each user as "USERNAME".
Type USERNAME in uppercase and between double quotation marks, where USERNAME is each user’s
user name. For example:
SQL> create user "TOM" IDENTIFIED BY "ORACLEPASSWORD";
SQL> grant connect, resource to "TOM";

Preparing the Oracle Database
You must prepare your new Oracle database for use with SilkTest Workbench. This section describes how
to use the Database Maintenance utility to populate the database with SilkTest Workbench tables.
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1. Choose Start > Programs > Silk > SilkTest > Administration Tools > Database Maintenance to
start the Database Maintenance utility.
2. Choose File > New Database > Oracle.
The Oracle Data Source Connection dialog box opens.
3. Type the name of the new Oracle data source or click the Browse button and select a data source
name from the Select ODBC Data Source dialog box.
4. In the appropriate boxes, type the name of the Oracle user ID, and password, and then click Create.
The Schema box is filled in automatically with the same information as the User ID.
You are now ready to start SilkTest Workbench and log on.

Setting Up a SQL Server or Oracle Database Without a
Domain
We strongly recommend that you use authentication within a domain when setting up an Oracle or SQL
Server database with SilkTest Workbench. However, if you are not on a domain, it is still possible to set up
these databases.
This section provides specific instructions for setting up a SQL Server or Oracle database with a domain.

Creating Users Without a Domain
To set up a SQL Server or Oracle database without a domain, you must first create a user account on both
the client and server computers.
Note: This procedure only applies when using Windows NT authentication.
1. Access the Windows Control Panel, and then choose Administrative Tools > Computer
Management
The Computer Management utility opens.
2. In the left pane, click Local Users and Groups.
3. Under Local Users and Groups, right-click the Users folder and choose New User.
The New User dialog box opens.
4. Type a valid user name in the User name text box, and the corresponding user’s full name in the Full
Name text box.
5. Type a valid password in both the Password and Confirm password text boxes, and then click
Create.
6. Repeat these steps on each client computer using the username and password.

Setting Up SQL Server Without a Domain
To set up SQL server without a domain:
1. Access the Windows Control Panel, and then choose Administrative Tools > Computer
Management
The Computer Management utility opens.
2. In the left pane, expand Local Users and Groups, and then click Groups.
3. In the right pane, double-click Users.
The Users Properties dialog box opens.
4. Click Add.
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The Select Users, Computers, or Groups dialog box opens.
5. Click Advanced, then use the Common Queries tab to search for users.
6. Click Find Now, and then select users from the list.
Alternatively, click in the Enter the object names to select text box and enter the [user ID] of the
user you want to give access.[user ID],:
7. Click OK to save the user information and return to the Users Properties dialog box.
8. Repeat the previous steps to create additional user accounts.
9. Click OK.

Setting Up an Oracle Database Without a Domain
To set up Oracle without a domain, follow the procedure for creating server access for individual user
accounts; however, substitute the user name you created in the procedure for creating users without a
domain.
1. In the Enter the object names to select text box, type the user name instead of [domain name]\
[user ID] or [domain name]\[group name].
The Computer Management utility appears.
2. Set up users.
When using SQL*Plus to create users, substitute [computer name\user name] for [domain name
\user name] as shown in the following example.
SQL> create user "FH0002RED\USER1" IDENTIFIED EXTERNALLY;
SQL> grant connect, resource to "FH0002RED\USER1";
Note:
For the [computer name\user name], use uppercase and enclose in quotes.

Creating a Data Source Name Overview
On each computer that connects to the SilkTest Workbench SQL Server, Access, or Oracle database, you
must create a data source name (DSN) using the ODBC utility.
Note: This step does not apply to default SQL Server Express and Access databases installed by the
SilkTest Workbench installer. For these databases, a data source name is automatically created.

Creating a Data Source Name for an Access Database
On each client computer connecting to an Access database, perform the following steps to set up a DSN:
1. Access the Control Panel, and then choose Administrative Tools > Data Sources (ODBC).
The ODBC Data Source Administrator dialog box opens.
2. Click the System DSN tab, then click Add.
The Create New Data Source dialog box opens. This dialog box lists the available ODBC drivers.
3. From the list of drivers, select the Microsoft Access Driver and click Finish.
The ODBC Microsoft Access Setup dialog box opens.
4. In the Data Source Name text box, type the data source name.
Enter a logical name as this name appears as the database name in the logon dialog box.
5. In the Description text box, type a description for the data source.
For example, Connection to SilkTest Workbench database.
6. Click Select and browse for your Access database.
7. On the ODBC Microsoft Access Setup dialog box, click OK.
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8. On the ODBC Administrator dialog box, click OK to complete the process.

Creating a Data Source Name for a SQL Server
Database
Note: SilkTest Workbench cannot use 64-bit DSNs. To create a DSN for a 64-bit machine, create a
32-bit DSN using the WOW64 tools located at C:\WINDOWS\SysWOW64\odbcad32.exe.
On each client computer connecting to a SQL server database, perform the following steps to set up a
DSN:
1. Access the Control Panel, and then choose Administrative Tools > Data Sources (ODBC).
The ODBC Data Source Administrator dialog box opens.
2. Click the System DSN tab, then click Add.
The Create New Data Source dialog box opens. This dialog box lists the available ODBC drivers.
3. From the list of drivers, select the SQL Native Client and click Finish.
The Create a New Data Source to SQL Server dialog box opens.
4. In the Name box, type the data source name.
Enter a logical name as this name appears as the database name in the logon screen.
5. In the Description text box, type a description for the data source.
For example, Connection to SilkTest Workbench database.
6. In the Server text box, enter the server name or select it from the drop-down list.
7. Click Next.
8. Perform one of the following:
•

If user(s) using the DSN to access the SQL Server database are connecting with non-native
credentials, select the With Windows authentication using the network login ID option.
• If user(s) using the DSN to access the SQL Server database are connecting with native
authentication, select the With SQL Server authentication using a login ID and password
entered by the user option. Make sure the Connect to SQL Server to obtain the default settings
for the additional configuration options check box is checked. Type the users native SQL Server
logon credentials in the Login ID and Password text boxes.
9. Click Next.
10.Check the Change the default database to check box, and then select your database name from the
list.
11.Accept all the other entries and click Next until the last panel in the wizard appears.
12.Accept the defaults and click Finish.
13.To test the connection, click Test Data Source.
The SQL Server ODBC Data Source Test dialog box opens.
14.Click OK.
The ODBC Data Source Administrator dialog box reappears. The newly created data source appears
in the System Data Sources list.
15.Click OK.

Creating a Data Source Name for an Oracle Database
On each client computer connecting to an Oracle database, perform the following steps to set up a DSN:
1. Access the Control Panel, and then choose Administrative Tools > Data Sources (ODBC).
The ODBC Data Source Administrator dialog box opens.
2. Click the System DSN tab, then click Add.
The Create New Data Source dialog box opens. This dialog box lists the available ODBC drivers.

Configuring a SilkTest Workbench Database

| 55

3. From the list of drivers, select the appropriate Oracle ODBC driver for the version of Oracle database
being used (not the Microsoft ODBC for Oracle driver), and then click Finish.
The Oracle ODBC Driver Configuration dialog box opens.
4. In the Oracle Data Source Name text box, type the data source name.
Enter a logical name as this name appears as the database name in the logon dialog box.
5. In the Description text box, type a description for the data source.
For example, Connection to SilkTest Workbench database.
6. In the TNS Service Name text box, select the service name for the database you want to connect to in
the format ORACLE_SID.DOMAIN, where ORACLE_SID is the Oracle SID you assigned to the database
upon creation and domain is the domain to which you are connecting.
7. If using Oracle authentication, type a valid user ID for the database being connected to in the User ID
text box. Otherwise, leave the User ID text box empty.
8. To test the connection, click Test Connection.
Note: When using Oracle database authentication, type a username, and then a password. For
Oracle OS authentication, do not specify a username.
A message box appears stating the connection was successful.
9. Click OK.

Connecting to a Database Overview
After installing SilkTest Workbench and configuring a database, you must create a database connection.
This connection defines the relationship between a SilkTest Workbench database and the local SilkTest
Workbench installation. This section contains topics describing how to log on and create a database
connection.

Logging On
1. Select Start > Programs > Silk > SilkTest <version> > SilkTest Workbench.
SilkTest Workbench starts and displays the Login to SilkTest Workbench dialog box.
2. Type a user name in the User Name text box and a password in the Password text box.
If you are using SilkTest Workbench for the first time, an administrative user name and password may
be required. The default user name is Admin and the default password is admin. Change this
password after logging on to prevent unauthorized access. You can change your logon password at any
time.
3. Select the database to use from the Database list.
For a database to appear in the Database list, you must first configure its database connection for use.
To configure a database connection, click Configure on the Logon dialog box.
4. Click OK.
The Start Screen opens.

Changing Your Logon Password
Use the following procedure to change your logon password.
1. Click Tools > Change Password.
The Change Password dialog box opens.
2. Change your password and then click OK.
Changes take affect the next time the User ID is used to log on.
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Configuring a Database Connection
Before you can use a database with SilkTest Workbench, you must configure its database connection. The
configuration process consists of using the Configure Database Connection dialog box to perform the
following tasks:
•
•
•

Specify the database connection data required to initiate the database connection.
Verify the connection to the database.
Save the database connection data.

All configured database connections appear in the Database list that is located on the SilkTest Workbench
dialog box.
You can also use the Configure Database Connection dialog box to view, edit, and remove any existing
configured database connections.
Note: Before configuring a database connection for use with SilkTest Workbench, you must create
and configure a database instance and ODBC Data Source Name (DSN).
Note: SilkTest Workbench cannot use 64-bit DSNs. To create a DSN for a 64-bit machine, create a
32-bit DSN using the WOW64 tools located at C:\WINDOWS\SysWOW64\odbcad32.exe.
1. Click Configure on the Login to SilkTest Workbench dialog box.
The Configure Database Connection dialog box opens.
2. In the Data Source Type section, select the type of data source.
3. From the Select Data Source list, select from the list of available DSNs.
4. Check the Use as a SilkTest Workbench database check box to add the selected DSN to the list of
configured database connections that appear in the Database list on the Login to SilkTest Workbench
dialog box.
You must check this check box when configuring a database connection for the first time. For existing
configured database connections, unchecking the Use as a SilkTest Workbench database check box
and clicking Apply removes the selected DSN from the Database list on the dialog box. SilkTest
Workbench does not retain the associated database connection data.
5. In the Database Settings section, specify the appropriate information for the selected DSN.
For Access, the Database box is read-only and displays the location of the database file. This value is
read directly from the ODBC DSN. The other Database Settings text boxes are not applicable for
Access and are disabled. For Oracle, the Server text box is read-only and displays only the database
name. This value is read directly from the ODBC DSN.
6. In the Database box, type the appropriate value.
For SQL Server/MSDE, the Database text box is modifiable and allows you to type the appropriate
database name.
7. In the Owner box, type the appropriate value.
8. Select a type of authentication.
Authentication options only apply to Oracle or SQL Server/MSDE databases. You can choose to use
either Windows NT authentication or authenticate using the database’s native authentication
capabilities. When selecting database authentication, you must provide the user name and password in
the appropriate text boxes.
9. Click Validate to verify that you can connect to the database using the specified database connection
data.
10.Click Apply to save the database connection data.
11.Click Close to dismiss the dialog box.
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