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Quick Start Tutorial for the SilkTest Recorder

This tutorial provides a step-by-step introduction to using the SilkTest Recorder to test a Web site. The Recorder
uses dynamic object recognition to record and replay test cases that use XPath queries to find and identify
objects.

The Recorder can test the following application types:

• Adobe Flex
• Java SWT/RCP
• Windows API-based client/server
• Windows Forms
• xBrowser (Web applications)

For the sake of simplicity, this guide assumes that you have installed the Recorder and are using the Insurance
Company sample Web site, http://demo.borland.com/InsuranceWebExtJS/.

For additional information about Recorder, refer to the Recorder Help. To view the help, open Recorder and
then choose Help ➤ Help Contents.

Starting the SilkTest Recorder

Choose Start ➤ Programs ➤ Silk ➤ SilkTest <version> ➤ SilkTest Recorder.
Recorder opens and the SilkTest Open Agent icon appears in the system tray.

Recording a Test Case for the Insurance Company Web Site
Record a test case for the Insurance Company sample Web site to see how the Recorder creates a test.

1. Perform one of the following steps:

• Click  in the toolbar.
• Choose Record ➤ Start Recording.

The New Application Configuration wizard opens.

2. Double-click Web Site Test Configuration.
The New Web Site Configuration page opens.

3. From the Browser Type list box, select Internet Explorer.

You can use Firefox to replay tests but not to record them.

4. Perform one of the following steps:

• Use existing browser – Click this option button to use a browser that is already open when you configure
the test. For example, if the Web page that you want to test is already displayed in a browser, you might
want to use this option.

• Start new browser – Click this option button to start a new browser instance when you configure the
test. Then, in the Browse to URL text box specify the Web page to open.
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For this tutorial, close all open browsers and then click Start new browser and specify
http://demo.borland.com/InsuranceWebExtJS/.

5. Click Finish.
The Web site opens. The Recorder creates a base state and starts recording.

6. In the Insurance Company Web site, perform the following steps:

a) From the Select a Service or login list box, select Auto Quote.
The Automobile Instant Quote page opens.

b) Type a zip code and email address in the appropriate text boxes, click an automobile type, and then
click Next.

c) Specify an age, click a gender and driving record type, and then click Next.
d) Specify a year, make, and model, click the financial info type, and then click Next.

A summary of the information you specified appears.
e) Point to the Zip Code that you specified and press Ctrl+Alt to add a verification to the script.

You can add a verification for any of the information that appears.

The Verify Properties dialog box opens.
f) Check the textContents check box and then click OK.

A verification action is added to the script for the zip code text.

An action that corresponds with each step is recorded.

7. In the Recorder, perform one of the following steps:

• Click  in the toolbar.
• Choose Record ➤ Stop Recording.

8. Choose File ➤ Save.

a) Navigate to the location in which you want to save the test.
b) In the File name text box, type the name for the test and then click Save.

For example, type ZipTest.

Replay the test to ensure that it works as expected.You can modify the test to make changes if necessary.

Replaying the Test Case for the Insurance Company Web
Site

Replay a test to ensure that it works as expected.

1. On the main window, from the Replay speed list box, select the speed to use to replay the test.

• Fast – This option is the fastest choice for test replay and the true speed at which scripts are executed.
The other speeds use a delay mechanism, so you can see the test run.

• Medium – In most cases, this option enables you to see each action.
• Slow – To ensure that you see each action, choose this option.

You can determine the speed of the test by checking the Replay duration time posted next the Replay
speed list box.

2. To replay the entire test, click  in the toolbar or choose Replay ➤ Replay All.
The Recorder plays back the test.

3. If an error occurs, perform one of the following steps:
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Click Retry to replay the current action.•
• Click Stop to end the test.
• Click Skip to advance to the next action in the test.

Export the test to use it with SilkTest or Silk4J. Or, modify the test to make changes if necessary.

Exporting a Test Case or Project
Use the following procedures to export a test case or project to SilkTest or to Silk4J.

Exporting a Project to Silk4J
Export projects to use Silk4J as the primary GUI for tests and to organize test methods.

1. Choose File ➤ Export.
The Export wizard opens.

2. Double-click Export as Silk4J Project.
The Export as Silk4J Project page opens.

3. In the Project location text box, specify the location to which to export the project.

Optional: Click  and navigate to the folder that you want to use.

4. In the Project name text box, specify the project name.
For example, type Web Sample Project.

5. In the Package text box, specify the package name.
For example, type com.example.

6. In the Test class text box, specify the class name to which the test belongs.
For example, type AutoTests.

7. In the Test method text box, specify a name for the test method.
For example, type testAutoInput.

8. From the File encoding list box, click the type of file encoding to use.

9. Click Finish.

The Recorder creates a project and exports it to Silk4J.

Import the project with Silk4J. The new project contains a base state and test method and is ready for testing.
For details about importing a project, refer to the Silk4J User Guide.

Exporting a Test Method to Silk4J
Export test methods to use Silk4J as the primary GUI for tests or to copy the JTF script to the Clipboard.

1. Choose File ➤ Export.
The Export wizard opens.

2. Double-click Export as JTF Script.
The Export to JTF page opens.

3. From the Export to list box, click one of the following options:
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Clipboard – Copies the JTF script to the clipboard.You might choose this option if you want to copy
and paste the script into an existing JTF script.

•

• JTF Script – Exports the script to Silk4J.You might choose this option if you want to create a new script
or overwrite an existing JTF script.

4. In the Test method text box, specify a name for the test method.
For example, type testAutoInput.

5. In the Package text box, specify the package name.
For example, type com.example.

6. In the Test class text box, specify the class name to which the test belongs.
For example, type AutoTests.

7. In the Source folder text box, specify the location to which to export the test.

Optional: Click  and navigate to the folder that you want to use.

8. From the File encoding list box, click the type of file encoding to use.

9. To include the base state in the exported script, check the Use base state check box.

The base state makes sure that the application that you want to test is running and in the foreground. This
ensures that tests will always start with the same application state, which makes them more reliable. In
order to use the base state, it is necessary to specify what the main window looks like and how to launch
the application that you want to test if it is not running. Creating a base state is optional. However, it is
recommended as a best practice.

If you export to JTF, a separate silk4J.settings file is created for the base state. If you export to the
Clipboard, a Before method includes the base state.

10. Click Finish.

The Recorder creates a Java script and exports it to Silk4J or to the Clipboard.

Exporting a Project to SilkTest
Export projects to use SilkTest as the primary GUI, group test cases into projects, or to share data with other
products such as SilkCentral Test Manager.

1. Choose File ➤ Export.
The Export wizard opens.

2. Double-click Export as SilkTest Project.
The Export as SilkTest Project page opens.

3. In the Project location text box, specify the location to which to export the project.

Optional: Click  and navigate to the folder that you want to use.

4. In the Project name text box, specify the project name.
For example, type Web Sample Project.

5. In the 4Test script text box, specify the script file name.
For example, type AutoTests.t.

Optional: Click  and navigate to the folder that you want to use.

6. In the Test case text box, specify a name for the test case.
For example, type testAutoInput.
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7. To start SilkTest after the test case is exported, check the Open the exported project in SilkTest check
box.

8. Click Finish.

The Recorder creates a project that includes a script that uses the 4Test language and a recovery file and
exports the project to SilkTest.

Use SilkTest to work with the exported project. The new project contains a base state and test case and is
ready for testing.

Exporting a Test Case to SilkTest
Export test cases to use SilkTest as the primary GUI or to copy the script to the Clipboard.

1. Choose File ➤ Export.
The Export wizard opens.

2. Double-click Export as 4Test Script.
The Export to 4Test Script page opens.

3. From the Export to list box, click one of the following options:

• Clipboard – Copies the script to the clipboard.You might choose this option if you want to copy and
paste the script into an existing 4Test script.

• 4Test Script – Exports the script to SilkTest.You might choose this option if you want to create a new
script or overwrite an existing script.

4. In the Test case text box, specify a name for the test case.
For example, type testAutoInput.

5. In the 4Test script text box, specify the script file name.
For example, type AutoTests.t.

Optional: Click  and navigate to the folder that you want to use.

6. To start SilkTest after the test case is exported, check the Open the exported script in SilkTest check
box.

7. Click Finish.

The Recorder creates a script that uses the 4Test language and exports it to SilkTest or the Clipboard.

Modifying the Test Case for the Insurance Company Web
Site

After you record a test case, perform this step to manually modify the test. For example, you might add an
additional action, change the order of the recorded steps, or change the parameters for a specific action.

1. Open the test that you want to modify.

2. Navigate to the Web page on which the test ended in the initial recording.
For instance, if the existing test includes multiple Web pages, navigate to the last page in the test.

In this case, the existing test recording ended on the Automobile Instant Quote summary page. We want
to return to the Home page, which the base state will do automatically when we record.

3. To record the modifications, perform the following steps:
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Click  in the toolbar.a)

b) From the Select a Service or login list box, select Agent Lookup.
The Find an Insurance Co. Agent page opens.

c) Click  in the toolbar.

4. To change an existing action, parameter, or locator string, perform the following steps:

a) Click the row that you want to change in the Actions grid.
For example, click the row that contains the SetText action for the e-mail address parameter.
The Action Details tab shows the Locator, Action, and Parameters.

b) To change the locator, type a string in the Locator text box.

The locator string identifies the object that you want to test.

c) Click Validate Locator.
The Recorder validates the new locator. If the string is not valid or the object cannot be found, an error
is displayed.

d) To change the action, select an action from the Action list.
e) To change the parameters, type a parameter value in the appropriate text box.

For example, change the text parameter to "tutorial@yourcompany.com" for the SetText action.

Any changes that you make display in the Actions grid immediately.

5. To manually add an action, perform the following steps:

Typically, you record actions that you want to add to a test. However, you can also manually add an action
by copying and pasting an existing action that you then modify.

a) Click an action in the Actions list.

Note: You can insert multiple actions by pressing Ctrl or Shift and then clicking the actions
that you want to copy.

b) Perform one of the following steps:

• Choose Edit ➤ Copy Selected Actions and then choose Edit ➤ Paste Actions.
• Press Ctrl+C and then press Ctrl+V.

A new action displays below the action that you selected.
c) In the Action Details view, modify the action to meet your needs by changing the locator, action name,

or parameters as needed.

6. Choose File ➤ Save.

Replay the test to ensure that it works as expected.
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