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SilkCentral Test Manager 2010 R2
Welcome to SilkCentral Test Manager 2010 R2.
SilkCentral® Test Manager™ (Test Manager) is a powerful, all-inclusive, software test-management tool. Test
Manager builds quality and productivity into your testing process, speeding the delivery of successful software
projects while minimizing the risks of application failures. It consolidates all the critical software-testing phases
within a single, scalable, Web-based testing system, enabling your local and distributed software-development
teams to share experiences, resources, and critical information.
•
•

Borland has contracted for support of this product to be provided by its strategic partner Micro Focus. For
support visit http://support.microfocus.com/.
To contact Borland visit http://www.borland.com

Getting Started
Test Manager promotes product quality throughout the development cycle.
Today's e-business systems are increasingly complex, and reliability is more important than ever. Therefore,
assuring product quality throughout the development cycle is an important key to success. The best way to
check a product’s quality over time is to perform key tests on a daily basis. Test Manager helps in this regard
by automating test executions that follow freely configurable schedules, both during product development and
after deployment. By providing reports with different levels of detail, checking the status of products in
development is as straightforward as checking an HTML report in a Web browser.
With complex software projects, thorough testing of new builds is critically important. Test Manager saves time
and man hours by automating this process.

What's New in SilkCentral Test Manager 2010 R2
SilkCentral Test Manager 2010 R2 (Test Manager) introduces significant enhancements and changes.

Configuration Testing
You can now use configuration testing in Test Manager. Configuration testing is the process of testing a system
with each of the supported software and hardware configurations.
The Execution unit supports configuration testing through allowing reuse of the assigned test definitions. You
can create configuration suites with a set of assigned test definitions, and all execution definitions that you
add to the configuration suite will also have the set of test definitions assigned.You can also create configuration
suites from existing execution definitions. Test Manager enables you to add or remove parameters, keywords,
and manual testers to or from the configurations.
Each execution definition in the configuration is displayed in an in-line editable grid. You can see the execution
definitions or configurations that contain a specific test definition in the Properties tab of the test definition.
You can also view the execution definitions or configurations that are associated with a specific requirement
in the Assigned Test Definitions tab of the requirement.
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For test definitions or test packages that are included in a configuration suite, the status is an aggregation of
all statuses of all configurations within the suite:
•

If the test is assigned only to the configuration suite, the status is Passed only if it is passed in all
configurations. If the status is not Passed in all configurations, the status of the worst run is propagated,
with the following top-down priority:
1.
2.
3.
4.

•

•

Not Scheduled
Not Executed
Failed
Passed

The status of a requirement that is assigned to the test is Failed if the test fails in one or more of the
configurations.
We do not recommend to assign the test to a configuration suite and one or more simple execution definitions.
However, in this case, the aggregate of the configuration statuses is one status, and the last statuses of
the execution definitions are other statuses. The status that was executed last determines the last status
of the test.
If the test is assigned to a simple execution definition only, the status is updated in response to the status
of the last test run.

Quality Goals
Quality goals are a new feature that allow you to define a set of testing metrics that a project must meet in
order for the quality to be considered acceptable. They are created at the project level and are composed of
the values in an attribute or property of List type with a corresponding percentage weight.
Quality Goals also contains two corresponding reports: Quality Goal Planning Report and Quality Goals
Execution Report.

Video Capturing
You can now capture a video of a test, which is added to the result files in the Files page of the Test Definition
Run Results dialog box. You can then analyze the video, for example if an error occurs during the test.
To capture videos of your tests, you have to enable video capturing. When video capturing is enabled, you
will receive a WMV video file as a result of your test.
You can switch between always, where a video is added to the results for every test, and onError, where
the video is added to the results only if an error occurs during execution.

Code Analysis
Code Analysis for .NET
Test Manager now supports .NET code analysis using DevPartner Studio. Customers who have .NET
applications can change their code analysis profile to DevPartner Studio in order to collect run time details of
their .NET code.
Code Analysis APIs
Test Manager now contains open APIs that enable you to create an integration for your own code analysis
tools.
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Usability Enhancements
The following usability enhancements have been made throughout Test Manager.
Tagging a Build
You can now tag a build in Administration ➤ Configuration ➤ Products to prevent all run results for this
build from being deleted.
Attributes
Data types for requirement properties and test definition attributes have been updated for consistency. Attributes
and properties now offer the following data types: Date, List, Number, and Text. In the Settings unit you can
review and manage all attributes and properties for a selected project.
Asset

Old Data Type

New Data Type

Test Definition Attribute

Edit

Text

Test Definition Attribute

NA

Number

Test Definition Attribute

NA

Date

Test Definition Attribute

Normal

List, single select

Test Definition Attribute

Set

List, multi select

Requirement Property

String

Text

Requirement Property

Integer

Number

Requirement Property

Date

Date

Requirement Property

Boolean

List, single select
Note: For existing requirement management tool integrations that
use booleans, they will be migrated as single select lists.

Table 1: Data Type Migration Path
Reusing a Test Package
When you copy a test package, the information that provides the internal structure of the copied package is
not accurate. To reuse the test package, you can now revert the copied test package to the parent test definition,
apply your changes to the test definition, and then create a new consistent package out of the modified test
definition.
Cleaning Up a Test Package
When a test package contains tests are no longer executed by the system, you can now clean up the package
by clicking the new Clean Up Test Package entry in the context menu of the package.
Easier Creation of Test Containers
If you do not intent to check out test sources from or check in test sources to a new test container, you can
now select the new default value (None) as the source control profile during the creation of the test container.
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Test Plan Properties Page
The Properties page in the Test Plan unit now displays the execution definitions that the test definition is
assigned to in the new Assigned Executions grid. The grid includes the status of the last run of the test
definition in every execution definition.

Execution Enhancements
The following execution enhancements ease the execution of tests and improve the performance of test
executions.
Status of Test Definitions in a Folder or Project
You can view the status of all test definitions included in a folder or project in the Status column of the folder
or project in Executions ➤

.

Execution Definition Parameters
To apply a specific configuration to an execution definition, you can now override the parameters that you have
assigned to a test definition in the Parameters page of the execution definition.

Integration Enhancements
The following changes enhance the integration of Test Manager with other applications or enhance applications
already integrated into Test Manager.
Subversion
You can now use Subversion source control profiles with SSH in Test Manager.

Technology Updates
The following versions of third-party software are supported or unsupported due to enhancements in Test
Manager:
Quality Manager 6.0.1
Test Manager now supports Quality Manager 6.0.1 (Changepoint 2009, Changepoint 2009 SP2).

Reporting Enhancements
The following new reports have been added to Test Manager.
Not Passed Test Definitions Report
This new report provides a detailed listing of all the not-passed tests of a folder or project in the Execution
unit.
Not Passed Test Definitions per Execution Definition Report
This new report provides a detailed listing of all the not-passed test definitions for each execution definition
that is included in a selected configuration suite, execution folder, or project in the Execution unit.
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Execution Status Overview Report
The new Execution Status Overview report presents an overview of the execution status of the selected node
and all execution definitions below the node.
Quality Goals Planning Report
Represents the number of tests in each goal criteria along with the planned time rolled up to the goal criteria.
Quality Goals Execution Report
Represents the total number of tests that match the quality goal broken into the result status of the test (Pass,
Fail, No Result).

Tour of the UI
This topic provides an overview of the Test Manager user interface.
Basic UI Structure
The GUI of Test Manager has four main components:

•

•

A: Workflow bar - Facilitates the primary actions related to test management. Click an icon to display the
corresponding test management area in the unit window below. The workflow bar is designed around the
natural progression of test management activities, from the creation of shared steps objects and the
establishment of new projects and requirements all the way through to issue management and reporting.
B: Navigation Tree - Provides the same functionality as the workflow bar. Additionally provides access to
Issue Tracking, Administration, and Help. Click the separator bar along the right side of the navigation
tree to hide or display the tree. The display setting of the navigation tree is saved for each user account.
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•

C: Unit window - Shows the functional work area of the currently selected Test Manager unit. This view
changes based on the unit you are working in and your activities.

•
D: Environmental Info - Displays your user name and the active project. Click

to log out of Test Manager.

Workflow Bar
The workflow bar gives you quick access to the core functional units of Test Manager.

Workflow Button
Libraries

Projects

Settings

Requirements

Description
Click Libraries to go to the Libraries unit, where you can
use shared steps objects to share manual test steps across
multiple test definitions in different projects.
Click Projects to go to the Projects unit, which offers a
high-level test-manager’s view of all projects in your Test
Manager installation. The Projects unit enables you to move
between projects, see high-level project status details, and
view current execution statistics.
Click Settings to configure system settings such as filters,
project settings, change notification, and more. The available
functionality varies based on your user role.
Click Requirements to go to the Requirements unit, which
enables you to maintain control over your project's
requirements during development. You can perform the
following tasks in the Requirements unit:
•
•
•
•

Test Plan

Execution

Click Test Plan to go to the Test Plan unit, which enables
you to create and manage test plans, including the creation
of test definitions of both automated tests and manual tests.
Click Execution to go to the Execution unit, which enables
you to perform the following tasks:
•
•
•
•
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Create, modify, and delete requirements
Associate test definitions with requirements
Track the change history of requirements
Generate test plans from requirement lists

Configure test execution definitions
Assign test definitions to execution definitions
Set-up execution-definition dependencies
Configure execution-server deployment

Workflow Button
Activities

Code Analysis

Reports

Description
Click Activities to go to the Activities page in the Projects
unit.The Activities page displays recently-executed, current,
and upcoming execution definition activity on a per-project
basis.
Click Code Analysis to go to the Code Analysis unit where
you can evaluate the degree to which the code in your
Application Under Test (AUT) is covered by test cases. You
can then make informed estimates regarding effort, cost,
and risk associated with specific code changes.
Click Reports to go to the Reports unit where you can
perform the following tasks:
•
•
•
•

Generate reports
Download report templates
Edit report parameters
Create new reports based on pre-installed templates

Print this Page
Click

to print the current Test Manager page.

Bookmark this Page
Click
to bookmark the current Test Manager page. This
is especially useful for bookmarking reports, where the
current parameters are saved in the bookmarked URL.
Go to Administration
Click
to view or edit the administration settings in the
Overview page. For more information on the Overview
page, refer to the SilkCentral Administration Module Help.
Online Help
Click

to view context-sensitive help for the current page.

Context Menu Commands
Test Manager supports Windows-style context menus across many test management elements, for example
test definitions, requirements, execution definitions, folders, containers, reports, and more. Available through
right mouse-click, context menu commands typically include those commands that are available from each
unit's toolbar. For elements listed in tree views, context menus offer commands for expanding and collapsing
tree view elements. Commands that are not available to selected elements are grayed out.

Installing and Licensing Test Manager
For information regarding the installation and licensing of Test Manager, refer to the Test Manager Installation
Help, which is also available from both the Test Manager installation CD and the Test Manager download site.

SilkCentral Test Manager 2010 R2

| 13

SilkCentral Issue Manager
SilkCentral Issue Manager (Issue Manager), the issue-tracking tool of SilkCentral, is fully integrated with Test
Manager, enabling you to correlate issues with system requirements and executed tests.
Test-definition issues can be added and managed through Test Manager ➤ Test Plan ➤
more information, refer to the Issue Manager documentation.

➤ Issues. For

Note: StarTeam and IBM Rational ClearQuest are also supported by Test Manager “out of the box”.
Additional issue tracking systems can be configured by installing a custom plug-in. For more information,
refer to the Test Manager API Help.

Browser Settings
The tasks in this section describe how to optimize your browser settings for optimal performance of Test
Manager.

Cache Information with Internet Explorer
For optimal performance when working with Test Manager, ensure that your browser does not reload Web
pages after each update.
To cache information with Microsoft Internet Explorer:
1. Select Start ➤ Settings ➤ Control Panel ➤ Internet Options.
2. On the Internet Properties dialog box, select the General tab, if not already selected.
3. In the Temporary Internet files area, which is the Browsing history area in Microsoft Windows XP , click
Settings.
4. The Settings dialog box displays. In the Check for newer versions of stored pages section, select
Automatically.
5. Click OK.
6. Click OK again on the following dialog box.

Add the Test Manager Server to the List of Trusted Sites
For optimal performance when working with Test Manager, add the Test Manager server to the list of trusted
sites in Internet Explorer.
To add the Test Manager server to the list of trusted sites:
1. Select Start ➤ Settings ➤ Control Panel ➤ Internet Options.
2. On the Internet Properties dialog box, select the Security tab.
3. Click Trusted sites.
4. Click Sites.
5. Enter the URL of your Test Manager host in the Add this Web site to the zone text box, for example
http://<MyTestManagerHost>.
6. Click Close.
7. Click OK to complete the configuration.
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Logging In and Out of Test Manager
The procedures in this section explain how to log into and out of Test Manager.

Logging into Test Manager
To log into Test Manager:
1. Navigate to the IP address or URL of your Test Manager installation.
Note: Speak to your system administrator about the URL, username, and password you should use
to log into Test Manager.
2. On the Test Manager login page, enter your Username and Password .
3. Check the Remember login check box to have Test Manager auto-complete usernames and remember
your password when you begin typing your username.
4. Click Login to begin working with Test Manager.
Note: When logging in for the first time, you will be directed to the Project Overview in the Projects unit.
Upon subsequent login, you will automatically be directed to the URL you were visiting when you logged
out of Test Manager during your previous visit. For example, if when you previously logged out of Test
Manager you had a certain test definition selected, you will automatically be directed to that test definition
upon login.

Logging out of Test Manager
To log out of Test Manager
1. ClickLog Out in the upper-right corner.
2. Your user session is terminated.

Working with SilkPerformer Projects
SilkPerformer is fully integrated with the test planning and test execution functionality of Test Manager.
SilkPerformer projects can be integrated into Test Manager test plans and directly executed through Test
Manager. This allows for powerful test-result analysis and reporting. It also enables unattended testing, which
means tests are run automatically by Test Manager based on pre-configured schedules.
Refer to the SilkPerformer Help for details on configuring the integration of SilkPerformer with Test Manager.
SilkPerformer project files can be directly opened in SilkPerformer from Test Manager, where scripts and
settings can be edited. Edited SilkPerformer projects can subsequently be checked back into Test Manager
to make them available for future test executions.
Test Manager provides information on execution definition run properties during SilkPerformer test executions.
Use the AttributeGet methods to access execution definition run properties in the SilkPerformer script.
You can access the following properties in the script:
•
•
•
•

#sctm_execdef_id
#sctm_execdef_name
#sctm_product
#sctm_version
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•
•

#sctm_build
#sctm_keywords
Note: The term Project is used differently in SilkPerformer than it is in Test Manager. A SilkPerformer
project, when uploaded to Test Manager, becomes the core element of a Test Manager test definition.
Test Manager projects are high-level entities that may include multiple SilkPerformer projects, test
definitions, execution definitions, and requirements.

Working with Silk Performance Explorer
Silk Performance Explorer (Performance Explorer) is used for in-depth analysis of test runs. Performance
Explorer results analysis can be started directly from Test Manager's Executions unit and Test Plan unit
through execution runs on the Runs page or from Performance Explorer itself. Refer to the Performance
Explorer documentation for details regarding Performance Explorer's integration with Test Manager.
The results of load-test runs in SilkPerformer can also be uploaded to Test Manager and associated with test
definitions. Refer to the SilkPerformer Help for more details.
For additional information about Test Manager’s integration with SilkPerformer, refer to the SilkPerformer Help
and the Performance Explorer User Guide.

SilkCentral Administration Module
SilkCentral products are based on SilkCentral Architecture (SCA), which allows for common administration of
Web-based products. These administrative tasks are performed through the SilkCentral Administration Module.

SilkCentral Architecture
SilkCentral products are based on SilkCentral Architecture (SCA), which allows for common administration of
Web-based products.
The following sections describe the SilkCentral components.
•
•
•
•
•
•
•
•
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Overview

Front-End Server
The front-end server is responsible for the graphical user interface. This server is based on HTML and is
accessible from any Web browser, such as Internet Explorer or Firefox. A user sends an appropriate HTTP
request to the front-end server and receives a login page for authentication. After successful login, the user
can use the corresponding application based on the respective user rights. The front-end server can operate
as a stand-alone HTTP server, or it can be attached to a Web server, such as IIS via ISAPI filter. The front-end
server uses port 19120. For secure connections with SSL, the server also uses port 443.
Application Server
The application server synchronizes tasks such as the distribution of schedules, control of execution servers,
and management of database configuration. These tasks require a centralized agency to ensure the consistent,
reliable behavior of the application. The application server also evaluates results, saves them to the database,
and sends alerts based on success conditions. The application server uses port 19122.
Execution Server
The execution server executes automated tests that are scheduled by authorized users. Users are responsible
for the proper configuration of execution servers and additional resources that are required for test executions.
The system allows for the installation and configuration of multiple execution servers working independently
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of one another. The execution server uses port 19124. For secure connections with SSL, the server also uses
port 19125.
Chart Server
The chart server is used to generate charts that are viewed in reports. The system allows for the configuration
of a pool of chart servers. A built-in load balancing mechanism uses the pool to distribute chart generation.
The chart server is also used to generate reports and deliver them directly to the end-user for viewing within
a browser. The chart server uses port 19126.
Database Server
System persistency is implemented using a RDBMS (Relational Database Management System).The database
server uses ports 1433 and 1521.
SilkMeter License Server
SilkMeter, the licensing software that accompanies Silk products, determines the SilkCentral-application
functionality that you may access. For more information on licensing, refer to the installation guide of the
respective product. SilkMeter uses port 5461.
Manual Testing Client
The Manual Testing Client enables testers to manage their tests and track results without the need of an
Internet connection. The Manual Testing Client offers the core, manual-test execution functionality that Test
Manager provides, but through a Windows-based client tool.
Agent Computers
SilkPerformer and SilkTest Classic agent computers are assigned to particular SilkPerformer or SilkTest Classic
projects from the pool of agent computers that are available to the controller computer. In combination with
Test Manager, the controller computer acts as an execution server.
SilkPerformer Agents

SilkPerformer agent computers host the virtual users that are run during load tests.
As many agent computers as necessary can be added to a SilkPerformer project
so that the required quantity of virtual users can be run. Configuration of agents is
done through SilkPerformer. Refer to the SilkPerformer documentation for details
on configuring agents.

SilkTest Classic Agents The same rules that apply to SilkPerformer agents apply to SilkTest Classic agents,
except SilkTest Classic agents host SilkTest Classic tests.

Access and Licensing
SilkMeter, the licensing software that accompanies Silk products, determines the SilkCentral-application
functionality that you may access. For more information on licensing, see the respective product’s installation
instructions.

Test Manager, Risk Based Testing, and Quality Goals
Often times during software development, a balance must be struck between testing scope, time, and cost.
One commonly used method in determining this balance is risk based testing.
A key practice of risk based testing is the process of categorizing test assets based off of factors important to
the quality and to the end users of the application.
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Based off of this categorization process, quality practitioners can determine the appropriate set of tests based
off of time available and the desired goals of the quality process. Executing a subset of tests involves some
amount of risk. Quantifying this risk in a way that is relevant ensures the stakeholders are informed throughout
the process, which is key for a successful implementation of risk based testing.
In SilkCentral, factors used for risk based testing are completely customizable using Quality Goals. A
quality goal can be created for any List type custom attribute or requirement property which are used to
categorize testing assets. This allow users to define a subset of tests that need to be executed in order for the
project to meet specific quality criteria. Quality goal reporting allows users to communicate to stakeholders the
test planning and execution process, relevant scope, time, and quality metrics on testing assets.
At a high level, the below steps illustrate a workflow of how a user can use quality goals to implement a risk
based testing approach. The data for the below example has also been included in the Demo project that is
included with new versions of SilkCentral.
For a given project, a user wants to balance the scope of testing and time while still ensuring the application
is of acceptable quality. In this project, the stakeholders are interested in ensuring enough of the test bed has
been executed as well as ensuring the most important requirements have been sufficiently tested.
1. Select a project and create a requirement property of type List called Business Value to capture the
importance of the requirement. For example: Business Value with values: Low, Medium, and High.
2. Create a test attribute of type List called Level to capture the type of purpose of the tests. For example:
Level with values: Full, Regression , Smoke.
3. Select the Projects unit and the Quality Goals tab.
4. Create a new quality goal called Business Value for requirement property with Goal % of High-100%,
Medium-75%, and Low-50%.
5. Create a new quality goal called Test Objectives for the test attribute with Goal % of Full-80%,
Regression-50%, and Smoke-100%.
6. After the test assets are developed, assign the attributes/properties to the requirements and test definitions.
7. To determine the testing scope and ensure stakeholder agreement in the testing scope, go to the Reports
unit and click Test Plan ➤ Status Report ➤ Quality Goals Planning Report.
8. This report will show you the number and percentage of tests for each quality goal value, total planned time
for manual tests, and the number of tests required to meet the goal vs. the number of test available in the
project.
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9. After agreement on the plan is has occurred and the project is progressing through testing execution, testing
status for the Quality Goals can be easily evaluated using the Quality Goals Execution Report.
Go to the Reports unit and click Test Plan ➤ Status Report ➤ Quality Goals Execution Report.
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Quick Start Tasks
This section includes the quick start tasks that are available in Test Manager. Quick start tasks are high-level
overviews of the main tasks that you will likely need to perform with Test Manager. These tasks can serve as
tutorials in guiding you step-by-step through the best practice usage of the core functionality of Test Manager.

Managing Shared Step Libraries - Quick Start Task
To manage your shared step libraries, you will need to perform some or all of the following tasks.
Creating a Shared Step Library
1. Navigate to Test Manager ➤ Libraries.
2. In the Libraries tree, select the root node, which is called Shared Steps Libraries.
3.
In the toolbar, click
.
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Note: You can also right click on the root node and click New Library.
Creating a Shared Steps Object
You can create a shared steps object in the Steps page of any manual test definition or shared steps object.
To create a shared steps object:
1. Navigate to the Steps page of the manual test definition or shared steps object that includes the steps you
want to share.
2. Select the steps with CTRL + CLICK or SHIFT + CLICK.
3.
Click
.
The Create Shared Steps dialog box opens.
4. Enter a name for the new shared steps object in the Name text box.
5. Choose the location where you want to place the new shared steps object in the Libraries tree.
6. Click OK.
The shared steps object is created and the selected steps are replaced by a call to the shared steps object.
Adding a Call to Shared Steps
To add a call to a shared steps object:
1. Click Test Plan to add the shared steps to a test definition or Libraries to add the shared steps to another
shared steps object.
2. In the corresponding tree, click on the node to which you want to add the shared steps.
3. Click the Steps tab.
4.
To add the shared steps to the end of the steps list, click
. To insert it above the selected step, click
.
The Call to Shared Steps dialog box opens.
5. Select the shared steps node, whose steps you want to add, from the tree.
Note: For a test definition, the tree displays only the libraries that are visible to the active project. For
more information, see the Visibility Page.
6. Click Ok.
Editing Manual Test Steps
Edit the manual test steps of a test definition or a shared steps object in the Steps page.
To edit a manual test step:
1.
2.
3.
4.

Select the node whose steps you want to edit in the Test Plan or Libraries tree.
Click the Steps tab.
Click on the test step that you want to edit. The details of the test step are shown in the Edit Step view.
Edit the name, action description, expected results, and step properties of the test step in the corresponding
text boxes.
Note: You can insert values from data sources into manual test steps in the form of parameters.
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Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
5. Perform one of the following actions to finish editing the test step:
•
•
•

Click Ok and New Step to save your changes and add a new step after the current.
Click Ok to save your changes.
Click Reset to revert your changes.

Creating a Version
To be able to revert a set of changes you want to apply to a shared steps object or a manual test, create a
version of the element.
To create a version of a shared steps object or a manual test:
1. For a shared steps object, click Libraries in the workflow bar. For a manual test, click Test Plan in the
workflow bar.
2. Select the shared steps object in the Libraries tree, or the manual test in the Test Plan tree.
3.
Click
in the toolbar.
This action is only enabled if the shared steps object or the manual test was changed.
The Create Versions dialog box opens.
4. Optional: Enter a comment on the version in the Comment text box.
5. Click Ok. The new version is shown in the History page.
Comparing Versions
To view the differences between two versions of a shared steps object or a manual test, compare the versions.
To compare two versions of a shared steps object or a manual test:
1. For a shared steps object, click Libraries in the workflow bar. For a manual test, click Test Plan in the
workflow bar.
2. Select the shared steps object in the Libraries tree, or the manual test in the Test Plan tree.
3. Click the History tab.
4. Select the two versions you want to compare with CTRL + CLICK.
5. Right click on the selection.
6. Select Compare Versions. The Compare Versions dialog box opens, displaying all the added, changed,
and removed content.
Note: Use the arrows to change the version numbers and compare additional versions.
Reverting to a Previous Version
To undo changes to a shared steps object or a manual test, revert to a previous version.
To revert a shared steps object or a manual test to a previous version:
1. For a shared steps object, click Libraries in the workflow bar. For a manual test, click Test Plan in the
workflow bar.
2. Select the shared steps object in the Libraries tree, or the manual test in the Test Plan tree.
3. Click the History tab.
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4. Right-click on the version to which you want to revert the shared steps object to.
5. Click Revert to Version <ID>.
6. The shared steps object or manual test is reverted to the selected version and a new version is created in
the History page. Attachments, parameters, and data sets are not reverted for manual tests.

Configuring Projects - Quick Start Task
To configure a project, you will need to perform some or all of the following tasks.
Configuring Project Settings
To customize the project settings:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Project Settings tab to view the current settings.
The Project Settings page opens.
3. Click Edit to modify the current project settings.
4. The Edit Project Settings dialog box displays. You can specify the following information:
Build Information File Name

Build information files contain project information, including build number,
build log location, error log location, and build location. Enter the name
of your project’s build information file in this text box. All test executions
will read the build information from this specified file.

Project Release Date

Specify the planned release date for your project.

File Extensions to ignore in
Results

Specify result file types or other file types that should not be saved as
results for test executions.

Note: File extensions must be separated by commas, for example, xlg, *_, res. Changes made in the
Build Information File Name and File Extensions to ignore in Results fields will not effect scheduled
test definitions. To redistribute tasks to execution servers, you must reschedule the test definitions, or
disconnect from and reconnect to the database.
5. Click Save to save your project settings.
Creating Custom Attributes
To create a custom attribute:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Attributes tab to view the list of current attributes.
3. Click New Attribute.
The New Attribute dialog box displays.
4. Type a Name for the new attribute. This name will be displayed in list boxes when the attribute becomes
available for use.
5. Type a Description for the new attribute.
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6. Select the attribute Type. See the Test Definition Attribute and Requirement Property Types topic for
descriptions of each type of attribute.
7. Click OK.
Creating Filters
To create a filter:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Filters tab to view the list of available filters.
3. Click New Filter.
The New Filter dialog box displays.
4. Type a Name for the new filter.
This name will be displayed in list boxes when the filter becomes available.
5. Select a Category for the new filter from the list box to make the filter available in a specific Test Manager
unit.
Category

Unit

Requirement

Requirements

Test Definition

Test Plan

Execution

Execution

6. Type a Description for the new filter.
7. Select a category of filter criteria from the Selection criteria list box. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Definition Filter or Nested Requirements
Filter. Selecting one of these categories allows you to include an existing filter in your new filter.
8. Select a Property, Operator, and Value for the filter from the respective list boxes.
Property

Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected
an attribute category, the property list includes custom attributes to query against.

Operator

Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the following
operators are available:
Operator

Description

=

The string equals the defined value.

not

The string is different than the defined value.

contains

The string contains the defined value.

not contains

The string does not contain the defined value.
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Value

Enter the value that you want to filter out. Depending on the property type that you have
selected, values will either be strings that you can enter into the text box, or a selection of
predefined values that you can select from the list box.

9. Optional: Click More if you want to add more than one filter category to the new filter. Repeat this procedure
to define new categories.
Note: If you define more than one filter category, you must define whether the categories need to be
fulfilled in addition to the existing categories (AND relationship), or if the filter returns true when one of
the filter categories is fulfilled (OR relationship). Select either AND or OR to define the filter category
relationship. You cannot define nested AND, OR relationships.
10. Optional: To remove filter categories, click Fewer. This removes the last filter category.
11. Click OK to save the new filter, or click Cancel to abort the operation.
Enabling Change Notification
To enable change notification:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Notifications tab.
3. Click Configure Notification to open the Configure Change Notification dialog box.
4. If you want to be notified by email when changes are made to requirements in the currently selected project,
check the Changes on Requirements check box.
5. If you want to be notified by email when changes are made to test plans within the currently selected project,
check the Changes on Test Plan check box.
6. Click OK to save the notification settings, or click Cancel to abort the operation without saving changes.
You will be notified by email about changes for which you have activated notification.
Creating Step Properties
To create a new step property:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Step Properties tab.
3. Click New Property.
The New Step Property dialog box opens.
4. Enter a name for the new property in the Name text box.
Note: Step property fields are always declared as type string.
5. Click OK to make your property available to all manual test steps in the selected Test Manager project.
Note: To create a step property for a library, select the library node in the Libraries tree and continue
with the second step.
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Analyzing Test Results - Quick Start Task
To analyze the results of a test, you will need to perform some or all of the following tasks.
Creating New Reports
To create a new report:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the folder in which you want the new report to display.
This determines where the report is stored in the directory tree.
3.
Click
on the toolbar.
The Create New Report dialog box opens.
4. Type the name of the new report.
This is the name that is displayed in the Reports tree.
5. Check the Share this report with other users check box if you want to make this report available to other
users.
6. In the Timeout [s] field, type the maximum time period in seconds that Test Manager should wait for SQL
queries to complete.
7. From the Default tab list box, select the tab that you want to be directed to when you select this report from
one of the context-sensitive report lists.
8. Select the corresponding result type from the Result category list box.
This setting specifies the database table and view that is to be filtered for the report. The following result
types are available:
Result Type

Description

Requirement

Returns requirements available in the Requirements module that
meet the query criteria.

Test Definition

Returns test definitions available in the Test Plan module that meet
the query criteria.

Test Definition Execution

Returns executed test definition results from the Executions module
that meet the query criteria.

Execution Definition

Returns execution definitions from the execution module.

Issue

Returns issues, including imported issues.

Requirement Progress Builds

Contains information on requirements progress per build so that
you can see how requirements develop across builds.

Requirement Progress Days

The same as Requirement Progress Builds, but shows development
on a daily basis.

Test Definition Progress Builds

Shows how test definitions develop across builds.

Test Definition Progress Days

Same as above, but shows development on a daily basis.

Each result type offers a set of selection criteria. Based on the result type you have selected, specify an
appropriate Selection criteria for your report. These criteria typically group properties based on a view or
some other intuitive grouping, for example custom properties.
9. From the Property list box, select the property that is to be filtered on.
For some selection criteria, properties are dynamic.
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10. Select an Operator for the query.
The available operators depend on the property. Example operators are =, not, like, and not like.
Strings are always compared lowercase. Allowed wildcards for strings are "*" and "?", where * matches
any characters and ? matches exactly one character.
11. Select or specify the Value that the query is to be filtered on.
For date-based properties, the Value field is replaced with a calendar tool that you can use to select a
specific date.
12. Optional: To add an additional query string to this report, click More. An existing query string can be deleted
by clicking the string’s Delete button. When multiple query strings are defined, AND and OR option buttons
are displayed next to More. Use these option buttons to define if the queries should be considered
cumulatively, or if only one query string’s criteria needs to be met.
13. Click Next to configure report columns on the New Report dialog box.
14. Click Add Columns.
The Add Columns dialog box lists all available report columns.
15. Select the columns that you want to have included in the report and click OK.
You can select multiple columns with CTRL + CLICK.
Note: For test-planning reports, the list of available column names is enhanced with the column names
from the LQM_v_tests table. For details, refer to the Test Manager Database Model Help.
The selected columns display in tabular format on the New Report dialog box.
16. Optional: Configure how each report column is to be displayed. For each column, specify a sort direction,
ascending, descending, or unsorted, using the up/down arrows in the Sorting column.
17. When multiple columns are selected for sorting, a list box is displayed in the Sort Order column that allows
you to more easily edit the column-sort order. Set these numbers as required.
18. Give each column an Alias.
This is the name by which each column will be labeled in the generated report.
19. With grouping, you can take advantage of SQL aggregation features, for example when selecting a number
of elements or querying a total sum of values. Check the Group by check box to specify that SQL group
by functions are to be applied.
20. Columns that are not selected for SQL group by functions are set to aggregation by default, which means
a single aggregate value is calculated. From the Aggregation list box, select the appropriate aggregation
type.
The following types are available:
•
•
•
•
•

Count
Sum
Average
Minimum
Maximum

21. The Actions column enables you to move column listings up and down in the view, or to delete a column.
The Move Up and Move Down functions do not affect the outcome of the report.
22. Click Finish to complete your new report.
Editing Report Properties
To edit the properties of a report:
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1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Report tab.
4. Click the Properties tab.
5. Click Edit.
The Edit Report dialog box displays.
6. Modify the Name and Description of the report as required.
7. Ensure that the Share this report with other users check box is checked if you intend to have this report
shared with other users.
8. From the Default tab list box, select the tab that you want to be directed to when you select this report from
one of the context-sensitive report lists.
9. Specify one of the following options to indicate how the report can be edited:
Option

Description

Simple report

You can modify the selection criteria—thus changing the results of the selected
report—or you can click Advanced Query to modify the SQL query code.

Advanced report

If you have familiarity with SQL, you may edit the query code in the Report data
query text box. To assist you in editing SQL queries, a list box of function
placeholders (for example, “variables”) is available. To insert one of the available
pre-defined functions, select the corresponding placeholder from the Insert
placeholder list box.

•

Advanced report: If you have familiarity with SQL, you may edit the query code in the Report data query
field. To assist you in editing SQL queries, a list box of function placeholders, for example “variables”,
is available. To insert one of the available pre-defined functions, select the corresponding placeholder
from the Insert placeholder list box.
Note: If you manually edit the SQL code for the query, upon finishing, click Check SQL to confirm
your work.

10. Click Finish to save your changes.
Editing Report Parameters
To edit the parameters of a report:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Parameters tab.
If the report has parameters defined for it, the parameters are listed here.
4. Click Edit Parameters.
The Edit Parameters dialog box displays.
5. Edit the Label or Value of the listed parameters as required.
6. From the Usage list box, select the usage type of the parameter.
•
•
•

constant value
start time
end time

7. Click OK to save your changes.
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Writing Advanced Queries with SQL
Advanced reports can be created through manual SQL coding. Virtually any reporting option is available if you
know the database schema. Clicking Advanced Query hides the query string list boxes and opens the Report
data query text box in which you can insert existing code or write new SQL code.
One approach is to begin query-string construction using the list boxes as outlined in Creating New Reports.
If the report criteria are valid, the equivalent SQL statement will be generated and displayed, and then move
to advanced mode for further modifications.
Note: You cannot move from advanced mode back to simple mode.
To write an advanced query directly in SQL:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the folder in which you want the new report to display.
This determines where the report is stored in the directory tree.
3.
Click
on the toolbar.
The Create New Report dialog box opens.
4. Type the name of the new report.
This is the name that is displayed in the Reports tree.
5. Check the Share this report with other users check box if you want to make this report available to other
users.
6. Type a description of the report in the Description text box.
7. Click Advanced Query to open the Report data query text box. Insert previously written code as necessary,
or write new code directly in the text box.
To assist you in writing SQL queries, a list box of Test Manager function placeholders is available. For
details, see SQL Functions for Custom Reports. To insert one of the available pre-defined functions, select
the corresponding placeholder from the Insert placeholder list box.
Note: If you manually edit SQL code for the query, click Check SQL to confirm your work.
8. Once you have completed editing the report’s properties, click Finish to save your settings.
Customizing BIRT Report Templates
With BIRT RCP Designer (BIRT), you can customize the pre-installed report templates of Test Manager and
create custom report templates. For details on using BIRT, refer to the SilkCentral Administration Module Help
and the BIRT RCP Designer documentation.
To download an existing template for editing:
1. Select a report that utilizes the BIRT Report Template from Test Manager ➤ Reports.
2. Click the Properties tab.
3. Click Download BIRT report template.
You receive the report data as an empty generic BIRT report template. The datasource is already configured.
4. Once you have saved the template to your local system, modify it as required.
For detailed information on configuring BIRT report templates, refer to the SilkCentral Administration Module
Help.
5. Upload the modified report template by using the Upload link on Administration ➤ Reports ➤ Report
Templates.
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Adding Subreports
To aggregate the results from multiple reports into the currently selected report, you can add subreports. When
adding a report as a subreport, the result columns and rows of the subreport are concatenated to the results
of the selected report.
To add a report as a subreport:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Properties tab.
4. Click Add Subreport.
The Add Subreport dialog box displays.
5. From the Reports tree, select the subreport you want to append to the current report.
6. Click OK to complete the addition of the subreport.
Subreports are displayed on the associated report’s Properties page in the Subreports section.
Viewing Reports
Because each template expects a certain data format to produce a useful graph, not all templates can be
applied to all report queries. You will receive an error message if you attempt to generate a report through an
incompatible report template. For example, selecting the Four Values Per Row As Horizontal Bar template to
display the Requirements Status Overview report works because this particular Microsoft Excel template
requires exactly the four values, failed, passed, not executed, and not covered that the report query
delivers.
To generate a report:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the report that you want to generate.
3. Click the Report tab.
4. Click the Select Report Template icon.
The Select Report Template dialog box opens.
5. Select the template you wish to use.
6. Click OK to display the report.
7. Optional: If necessary, select an alternate view magnification for the report from the list box.
100% is the default magnification. Other options are 50%, 75%, 150%, and 200%.
Displaying Charts
To display a chart:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree for which you want to view a chart.
3. Click the Chart tab to display the default chart.
4. To select a required chart type, click .
5. On the Select Chart Type dialog box, select a chart type from the list box.
6. Check the view properties that you want to apply to the chart.
•
•

3D view
Show horizontal grid lines
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•
•

Show vertical grid lines
Show legend

7. Specify how these chart options are to be saved:
•
•

Click the For current user only option button to have these chart settings override the report’s standard
settings whenever the current user views this chart.
Click the As report standard option button to have these chart settings presented to all users who don’t
have overriding user settings defined. This setting does not effect individual user settings.

8. Click OK to display the new chart type.
Note: The chart configurations you define here become the defaults for this report. When standard
charts and graphs are not able to deliver the specific data that you require, or when they cannot display
data in a required format, you can customize the appearance of queried data using the Test Manager
reporting functionality. To open the current chart in a separate browser window, click
the Chart page.

at the top of

Generating Code-Change Impact Reports
To generate a code-change impact report:
1. Navigate to Test Manager ➤ Projects.
2. Select the project for which you want to analyze code-coverage data.
3. Navigate to Test Manager ➤ Code Analysis.
4. Click Create Code Change Impact Report on the toolbar.
The Select Classes for Report dialog box displays.
5. Select a Product and Version, if you want to change the pre-selected values.
Click Add to add the class file(s) to the Selected classes pick list.
You can remove classes in the Selected classes pick list by selecting entries and clicking Remove. Click
Remove All to remove all selected classes from the Selected classes pick list.
6. In the Filter text box, type criteria to filter the packages/namespaces.
For example, entering the string “published” will only list packages/namespaces that contain the string
“published” in their names.
7. Select a package from the Packages/Namespaces list box.
Use CTRL + CLICK to select multiple packages/Namespaces.
The classes that are available in the selected package/namespace are displayed in the Classes list box.
8. In the Classes list box, select a class that you want to have included as a source in your report.
Use CTRL + CLICK to select multiple classes.
9. Click Add.
The selected classes are added to the Selected classes list box.
10. Repeat the preceding steps to add the class files to the Selected classes list box until you have added all
required classes to the Selected classes list.
11. Select a report from the Select report list box.
12. Click OK to generate the report.

Managing Requirements - Quick Start Task
To manage your requirements with Test Manager, you will need to perform some or all of the following tasks.
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Creating Requirements
Note: Newly created Test Manager projects do not contain requirements.
To create a new requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Click New Requirement on the toolbar.
Note: If the project you are working with does not yet have any requirements associated with it, click
the <Click here to add Requirements> link in the Requirements tree to open the New Requirement
dialog box.
The New Requirement dialog box opens.
3. Type a meaningful Name and Description for the requirement.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for description
text boxes.
4. Select the appropriate Priority, Risk, and Reviewed status from the list boxes.
5. If custom requirements have been defined, they are listed below the Reviewed list box. Type in the
corresponding text box any custom property data that you want tracked with this requirement.
Note: The Priority, Risk, Reviewed, and any Custom Property fields will be configured automatically
with the corresponding properties of the parent requirement if you check the Inherit from parent check
boxes for these properties.
6. Click OK to create a new top-level requirement. Alternatively, you can click OK and New Requirement to
both save the newly created requirement and open the New Requirement dialog box to create an additional
top-level requirement. Or, you can click OK and New Child Requirement to have the New Child
Requirement dialog box open after the new top-level requirement is created.
Configuring Requirement Types
A requirement without a configured requirement type is not available for upload to a requirements management
system (RMS). When you import a requirement from an RMS, the appropriate requirement type is automatically
configured.
Note: For requirements with the type CaliberRM, Requisite Pro, and DOORS, you can only configure the
requirement type for top-level tree elements, which are requirements that are a direct child of the project
node. All other requirements share the requirement type of their parents.
To configure the type of a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Click the Properties tab.
The Properties page displays the properties of the selected tree-element.
4. Click Map Requirement to select a requirement type from the list. Requirement type is a categorization
used by CaliberRM, Requisite Pro, and DOORS, and is required for synchronization.
Note: Map Requirement is only enabled when external requirements integration is enabled in the
Requirements Management page of the Settings unit and the requirement has not been uploaded
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to the external requirements management tool. Additionally, the option Enable upload of requirements
to... must be enabled.
5. Click OK to save your settings and close the dialog box.
Attaching a File to a Requirement
To attach a file to a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the requirement in the Requirements tree.
4. Click the Attachments tab.
When requirements management integration has been enabled between a Test Manager project and a
CaliberRM project, the Attachments page includes an Open CaliberRM button, which enables you to
manage requirement attachments directly in CaliberRM.
5. Click Upload File
The Upload File dialog box opens.
6. Click Browse and select the file that you want to attach from your local file system.
7. Type a Description for the attachment.
8. Click OK.
The attachment is uploaded to the server and associated with the selected requirement.
Note: Attaching files to a requirement may not work in Mozilla Firefox. Firefox requires usage of three
slashes, for example file:///, for a file link, while other browsers require only two, for example file://.
Aditionally, Firefox includes a security feature blocking links from remote files to local files and directories.
For more information, see http://kb.mozillazine.org/Firefox_:_Issues_:_Links_to_Local_Pages_Don't_Work
Attaching a Link to a Requirement
To attach a link to a requirement
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the requirement in the Requirements tree.
4. Click the Attachments tab.
When requirements management integration has been enabled between a Test Manager project and a
CaliberRM project, the Attachments page includes an Open CaliberRM button, which enables you to
manage requirement attachments directly in CaliberRM.
5. Click Attach Link.
The Attach Link dialog box opens.
6. Type the URL in the Link text box.
7. Type a Description for the attached link.
8. Click OK.
The link is associated with the selected requirement.
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Generating Test Plans from Requirements View
You can generate test plans directly out of the Requirements tree and assign test definitions to specific
requirements. The Requirements tree serves as a template for the test-folder/test-definition structure of the
new Test Plan tree.
To generate a new test plan from Requirements View:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Right-click the requirement or project node that you want to convert into a test plan and select Generate
Test Plan.
The Generate Test Plan from Requirements dialog box displays. This dialog box enables you to specify
whether the leaves, which means the lowest-level nodes, of the selected requirements subtree should be
converted into test definitions or test folders and whether the tree should be generated into a new test
container or an existing container.
4. Enter a name for the new test container in the Enter Name text box and select a product from the Select
Product list box to create the container within the active Test Manager project.
The Select Product list box is populated with the products that are configured by a project manager. For
detailed information, refer to the SilkCentral Administration Module Help or ask your project manager.
5. If you have defined a source control profile, select the source control profile you want to use for managing
the test definition sources from the Select Source Control Profile list box.
For detailed information on source control profiles, see Source Control Profiles or ask your Test Manager
administrator.
6. To include all child requirements of the selected requirement in the test plan, check the Include child
requirements check box.
The check box is checked by default.
7. To have the new test definitions automatically assigned to the requirements from which they are created,
check the Assign newly generated Test Definitions to Requirements check box.
If this option is not selected, test definitions must be manually associated with requirements.
Note: This option is not available when checking Generate Test Folders from Requirement Tree
leaves.
8. Click OK to create the test plan.
The new test plan has the same structure as the Requirements tree.
9. A message box displays, asking if you want to switch directly to the Test Plan unit. Click Yes to view the
test plan in the Test Plan unit, or click No to remain in the Requirements unit.
Creating Filters
To create a filter:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Filters tab to view the list of available filters.
3. Click New Filter.
The New Filter dialog box displays.
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4. Type a Name for the new filter.
This name will be displayed in list boxes when the filter becomes available.
5. Select a Category for the new filter from the list box to make the filter available in a specific Test Manager
unit.
Category

Unit

Requirement

Requirements

Test Definition

Test Plan

Execution

Execution

6. Type a Description for the new filter.
7. Select a category of filter criteria from the Selection criteria list box. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Definition Filter or Nested Requirements
Filter. Selecting one of these categories allows you to include an existing filter in your new filter.
8. Select a Property, Operator, and Value for the filter from the respective list boxes.
Property

Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected
an attribute category, the property list includes custom attributes to query against.

Operator

Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the following
operators are available:

Value

Operator

Description

=

The string equals the defined value.

not

The string is different than the defined value.

contains

The string contains the defined value.

not contains

The string does not contain the defined value.

Enter the value that you want to filter out. Depending on the property type that you have
selected, values will either be strings that you can enter into the text box, or a selection of
predefined values that you can select from the list box.

9. Optional: Click More if you want to add more than one filter category to the new filter. Repeat this procedure
to define new categories.
Note: If you define more than one filter category, you must define whether the categories need to be
fulfilled in addition to the existing categories (AND relationship), or if the filter returns true when one of
the filter categories is fulfilled (OR relationship). Select either AND or OR to define the filter category
relationship. You cannot define nested AND, OR relationships.
10. Optional: To remove filter categories, click Fewer. This removes the last filter category.
11. Click OK to save the new filter, or click Cancel to abort the operation.
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Creating Advanced Filters
Advanced custom filters enable you to combine simple filters to create complex filters that apply multiple filter
criteria simultaneously.
To create an advanced custom filter:
1. Click the appropriate button, Execution, Requirements, or Test Plan, on the workflow bar.
2. Create a new custom filter.
For additional information, see Creating Filters.
3. Click More to display a second set of filter-parameter fields with which you can define a second set of filter
parameters.
4. Select a logical operator for the application of the filtering queries. For example, with the operator and
filtered elements must meet both sets of criteria and with the operator or filtered elements must meet one,
but not both, of the criteria sets.
5. To delete a filter-parameter string, click .
6. To display additional filter-parameter fields and create additional filter queries, click More. To remove excess
filter-parameter sets, click Fewer.
Generating Test Plans from Requirements View
You can generate test plans directly out of the Requirements tree and assign test definitions to specific
requirements. The Requirements tree serves as a template for the test-folder/test-definition structure of the
new Test Plan tree.
To generate a new test plan from Requirements View:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Right-click the requirement or project node that you want to convert into a test plan and select Generate
Test Plan.
The Generate Test Plan from Requirements dialog box displays. This dialog box enables you to specify
whether the leaves, which means the lowest-level nodes, of the selected requirements subtree should be
converted into test definitions or test folders and whether the tree should be generated into a new test
container or an existing container.
4. Enter a name for the new test container in the Enter Name text box and select a product from the Select
Product list box to create the container within the active Test Manager project.
The Select Product list box is populated with the products that are configured by a project manager. For
detailed information, refer to the SilkCentral Administration Module Help or ask your project manager.
5. If you have defined a source control profile, select the source control profile you want to use for managing
the test definition sources from the Select Source Control Profile list box.
For detailed information on source control profiles, see Source Control Profiles or ask your Test Manager
administrator.
6. To include all child requirements of the selected requirement in the test plan, check the Include child
requirements check box.
The check box is checked by default.
7. To have the new test definitions automatically assigned to the requirements from which they are created,
check the Assign newly generated Test Definitions to Requirements check box.
If this option is not selected, test definitions must be manually associated with requirements.
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Note: This option is not available when checking Generate Test Folders from Requirement Tree
leaves.
8. Click OK to create the test plan.
The new test plan has the same structure as the Requirements tree.
9. A message box displays, asking if you want to switch directly to the Test Plan unit. Click Yes to view the
test plan in the Test Plan unit, or click No to remain in the Requirements unit.

Managing Test Executions - Quick Start Task
To manage the execution of a test, you will need to perform some or all of the following tasks.
Creating Execution Definitions
To create an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select an existing folder in the Execution tree, or select the project node.
4.
Click
on the toolbar or right-click the selected node and choose New Child Execution Definition.
The New Execution Definition dialog box displays.
5. Type a name and description for the execution definition.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
6. Select a test container from the Test Container list box.
You can only associate one test container to a test execution.
The version and build that are associated with the product that the container belongs to are populated
automatically in the Version and Build list boxes.
7. Select a product Version and Build from the list boxes.
If a build information file is available on the execution server, you have the option to check the Read from
Build Information file check box, in which case build and information will be read from the build information
file for the test run, overriding any manual settings that have been selected on the New Execution Definition
dialog box.
8. Select a Priority for the execution definition from the list box.
9. Optional: In the Source Control Label text box you can specify that the execution definition is of an earlier
version than the latest version.
Note: The Source Control Label property is only enabled if the associated test container uses a
source control profile that supports versioning.
10. Click OK to update the Execution tree with the newly created execution definition.
Manually Assigning Test Definitions to Execution Definitions
The test definitions that are assigned to the selected execution definitions are listed on the Assigned Test
Definitions page.
To manually assign test definitions to an execution definition:
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1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition to which you want to assign the selected test definitions.
4. Click the Assigned Test Definitions tab.
5. Click the Manual assignment option button.
All test definitions of the test container which is associated with the selected execution are displayed in the
Test Plan tree. If you have created a test definition filter, you can select it from the filter list above the Test
Plan tree. To create a new test definition filter, navigate to the Test Plan unit and click New Filter on the
toolbar.
6.
In the tree, click
left of the test definition that you want to assign to the currently selected execution
definition.
Clicking the assign arrow of a folder or the top-level container assigns all child test definitions of that parent
to the selected execution definition.
Assigning Test Definitions from Grid View to Execution Definitions
The test definitions that are assigned to the selected execution definitions are listed on the Assigned Test
Definitions page.
To assign one or more test definitions from the test plan Grid View to one or more execution definitions:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Select the test definitions you want to assign to execution definitions.
Use CTRL + CLICK or SHIFT + CLICK to select multiple test definitions using standard browser multi-select
functions.
4. Right-click the selected test definitions and choose Save Selection.
5. Navigate to Test Manager ➤ Execution.
6. Click
on the toolbar.
7. Select the execution definition to which you want to assign the selected test definitions.
8. Click the Assigned Test Definitions tab.
9. Click Assign Saved Selection.
Note: Only test definitions that reside in the execution definitions test container are inserted. You can
insert the selected test definitions to more than one execution definitions. You can not insert them into
requirements in a different project. The selection persists until you make a different selection or close
Test Manager.
Assigning Test Definitions to Execution Definitions through a Filter
The test definitions that are assigned to the selected execution definitions are listed on the Assigned Test
Definitions page.
To use a filter to assign one or more test definitions to an execution definition:
1. Create a filter in the Test Plan unit.
See Creating Filters for details. If the filter already exists, skip this step.
2. Navigate to Test Manager ➤ Execution.
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3. Click
on the toolbar.
4. Select the execution definition to which you want to assign test definitions.
5. Click the Assigned Test Definitions tab.
6. Select Assignment by filter from the test definition assignment types.
7. Choose the filter from the list box.
Note: If you assign test definitions to an execution definition in Test Plan ➤ Grid View, the test definition
assignment type is automatically set to Manual Assignment, but the previously-filtered test definitions
remain in the Assigned Test Definitions page.
Creating a Custom Schedule for an Execution Definition
To create a custom schedule for a selected execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to configure a custom schedule.
Note: To schedule a folder for execution, select a folder node. To save an edited version of a global
schedule as a custom schedule, click Edit while the global schedule is selected in the list box. This
enables you to edit the global schedule and save the result as a custom schedule.
4. Click the Schedule tab.
5. Click the Custom option button to enable the scheduling controls.
6. Click Edit.
7.
Click
next to the From field and use the calendar tool to specify the time and date when the execution
schedule should begin.
8. Specify the Interval at which the tests should be executed.
9. In the Run section, specify when the schedule schould end.
Select on of the following options:
•
•
•

Click Forever to define a schedule with no end.
Click n Time(s).
Click
next to the until field and use the calendar tool to specify the time and date when the execution
schedule should end.

10. Optional: Click Add Exclusion to define times when scheduled execution definitions should not be executed.
11. Optional: Click Add Definite Run to define times when unscheduled executions should be executed.
12. Click Save to save your custom schedule.
Configuring Setup and Cleanup Executions
To define a test definition as a setup or cleanup test definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Click the execution definition for which you want to configure a setup or cleanup test definition.
4. Click the Setup/Cleanup tab.
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•
•

To define a setup test definition, proceed with the following step.
To define a cleanup test definition, proceed with step 8.

5. Optional: To define a setup test definition, click Edit in the Setup Test Definition section.
The Edit Setup Test Definition dialog box displays.
6. To define a cleanup test definition, click Edit in the Cleanup Test Definition section.
The Edit Cleanup Test Definition dialog box displays.
7. In the Test Plan tree, select the test definition that you want to configure.
8. Click OK.
The configured test definition displays in the corresponding section of the Setup/Cleanup page.
Adding Dependent Execution Definitions
To add a dependent execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition that will act as the master execution definition.
4. Click the Dependencies tab.
5. Click Add dependent Execution Definition.
The Add dependent Execution Definition dialog box displays.
6. From the Condition selection list, select the condition that is to trigger the dependent execution definition.
•
•
•
•

Passed
Failed
Not Executed
Any

The Any status means that the dependent test execution will trigger no matter what the status of the previous
test execution.
7. From the tree menu in the dialog box, select the execution definition that is to be dependent.
8. Specify where the dependent execution definition is to be deployed.
Option

Description

As specified in the
dependent Execution
Definition

Automated test definitions assigned to the dependent execution definition will
be executed on the execution server specified for the dependent execution
definition on the Deployment page. Manual test definitions assigned to the
dependent execution definition will be assigned to the users specified for the
dependent execution definition on the Deployment page.

Same as <selected
execution definition’s
execution server>

Automated test definitions assigned to the dependent execution definition will
be executed on the execution server specified for the master execution
definition on the Deployment page. Manual test definitions assigned to the
dependent execution definition will be assigned to the users specified for the
master execution definition on the Deployment page.

Specific: Execution
Server/Manual Tester

Select a pre-configured execution server and/or a manual tester from the list
boxes. Automated test definitions assigned to the dependent execution
definition will be executed on the specified execution server. Manual test
definitions assigned to the dependent execution definition will be assigned
to the specified manual tester. If only a specific manual tester is defined and
no server, only manual test definitions will be executed. If only a specific

SilkCentral Test Manager 2010 R2

| 41

Option

Description
execution server is defined and no manual tester, only automated test
definitions will be executed.

9. Click OK to create the dependency.
Note: Test Manager will not allow you to create cyclical execution dependencies. You can select
conditions to fulfill for manual test definitions. For example if the selected condition is Failed and all
manual tests passed, but some automated tests failed, only automated test definitions assigned to the
dependent execution definition are executed.
Assigning Keywords to Execution Definitions
To assign keywords to execution definitions:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Deployment tab.
5. In the Execution Environment section of the page, click Edit.
The Assign Keywords dialog box displays. All keywords that have been defined for your execution
environment are listed here.
Note: For automated execution definitions, the default reserved keywords for each execution server,
#<execution name>@<location name>,are included in the list.
6. Select keywords in the Select keywords list box that reflect your execution environment requirements.
Use CTRL + CLICK or SHIFT + CLICK to select multiple keywords using standard browser multi-select
functions.
Tip: The Enter keywords text box is auto-complete enabled. When you enter alphanumeric characters
into this field, the field is dynamically updated with an existing keyword that matches the entered
characters. The text box is disabled when multiple keywords are selected in the Select keywords or
Assigned keywords list boxes.
Tip: For automated execution definitions, if you only have a few execution servers and do not require
hardware provisioning, it might be enough to use only the default, reserved keywords that are created
for each execution server. In such cases, it is not necessary that you select additional keywords.
7. Click > to move the keyword into the Assigned keywords list box.
Note: For automated execution definitions, the execution servers that match the assigned keywords
are listed below in the dynamically-updated Matching execution servers list box. This list updates
each time you add or remove a keyword. Click on the name of an execution server in the list to access
the execution servers in Administration ➤ Locations.
8. Click OK to save the keywords and close the Assign Keywords dialog box.
Executing Individual Tests
To run an execution definition independent of a schedule:
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1. Navigate to Test Manager ➤ Execution.
2. In the Execution tree, select the execution definition that you want to execute.
3. Click Run on the toolbar.
The Run dialog box displays.
4. Define which test definitions you want to execute.
The execution definition is then queued on the specified execution server. Test definitions are executed in
the order in which they are listed on the Assigned Test Definitions page. Details of executions can be
viewed in the Activities page.
5. If the execution definition does not contain pending manual tests, the Go To Activities dialog box displays.
Click Yes to view the Activities page, or click No if you want to remain on the current Web page.
Note: Check the Don't show this dialog again (during this login session) check box if you do not
want to be asked about switching to the Activities page again in the future. This setting will be discarded
when you log out of Test Manager.
Viewing Test Definition Run Details
To view the details of a test definition run:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition in the Execution tree.
4. Click the Runs tab.
5. Click the Run ID of the execution for which you want to see details.
The Test Definition Run Results dialog box displays.
6. Click the Details tab.

Managing Test Plans - Quick Start Task
To organize your test plan, you will need to perform some or all of the following tasks.
Creating Test Definitions
To create a new test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Select a container or folder node in the Test Plan tree where you want to insert a new test definition.
4.
Click
on the toolbar or right-click within the tree and choose New Child Test Definition.
A new test definition node is appended to the tree view, and the New Test Definition dialog box opens.
5. Type a name and description for the test definition.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
6. Select the test-definition type from the Type list box:
7. Click Next and proceed to the appropriate topic for the selected test type in Configuring Test Definition
Properties.
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Note: The well-defined public API of Test Manager enables you to implement a proprietary solution that
meets your automated test needs. Test Manager is open and extensible to any external tool that can be
invoked from a Java implementation or through a command-line call.
Note: Throughout the test-definition configuration process and across all test definition types, Inherit
from parent check box options are provided where applicable, enabling you to accept settings of any
existing parent entity.
Editing Test Definitions
To edit a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Select the test definition or the test package that you want to edit.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
4. Click Edit on the toolbar.
You can also click the Properties tab and click Edit or right-click the test definition or test package and
select Edit.
The Edit Test Definition dialog box displays.
5. Edit the name and description of the selected test definition.
If the selected test definition is a test package, the Update Package Structure on Result check box is
available. Check the Update Package Structure on Result check box if you want to update the structure
of the test package according to the results of the test execution run.
6. Configure the properties of the test definition or the test package according to the test definition type as
described in Configuring Test Definition Properties.
Creating a Test Package
To create a new test package out of a third-party test definition:
1. Run the test definition once to create the output.xml file, which contains the structure of the test package.
For additional information on executing a test definition, see Executing Individual Tests.
2. Navigate to Test Manager ➤ Test Plan.
3. In the Test Plan tree, right-click the test definition and choose Convert to Test Package.
The selected test definition is converted to a hierarchy representing the structure of the last execution result.
Creating Data-Driven Test Definitions
To create a data-driven test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Create a new test definition.
For information about creating a test definition, see Creating Test Definitions.
4. Click the newly created test definition's Properties tab.
select the Edit icon to open the Data-driven Properties dialog box.
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5.
Scroll down to the Data-driven Properties section of the Properties tab and click
.
The Data-driven Properties dialog box opens.
6. Select a pre-configured data source from the Data Source list box.
For information on configuring data sources, refer to the SilkCentral Administration Module Help.
7. Click Next to continue.
8. Select a data set from the Data Set list box.
In the case of Excel data sources, this is a worksheet name. In the case of database data sources, this is
a table name.
9. Check the Each data row is a single test definition check box to have each row in your data set considered
to be a separate test definition, or do not check this check box to create a single test definition for all data
rows of your data set.
10. Optional: You can enter a SQL query into the Filter query text box to filter your data set based on a
SQL-syntax query.
Note: Only simple WHERE clause queries are supported.
11. Check the Enable data-driven properties check box to enable data-driven functionality.
12. Click Finish to save your settings.
Note: Data-driven property settings are visible in the lower portion of each test definition’s Properties
page.
Note: To use the data-driven test functionality of Test Manager with SilkPerformer scripts, data sources
with column names matching the corresponding SilkPerformer project attributes must be used in
conjunction with AttributeGet methods.
Assigning Attributes to Test Definitions
To assign an attribute to a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3.
4.
5.
6.

Select the test definition to which you want to assign an attribute.
Click the Attributes tab.
Click Add Attribute to display the Add Attributes dialog box.
Click the plus symbol (+) in the Add column of the attribute that you want to assign.
Based on the attribute type you have selected, an Edit Attribute dialog box displays, where you can specify
which of the available attribute values you want to assign to the test definition.
7. Select attribute value and click OK to assign the attribute to the test definition.
Adding Predefined Parameters to Test Definitions
To add a predefined parameter to a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select the test definition node to which you want to add a predefined parameter.
4. Click the Parameters tab.
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5. Click Add Predefined Parameter.
Note: For SilkPerformer test definitions, the Add Predefined Parameter button is only available for
test definitions for which the Project property is already defined.
The Add Predefined Parameter dialog box displays, which lists all of the project attributes that are available
in the project file.
6. To add any of the listed parameters, click the corresponding add icon.
7. On the dialog box that displays, specify the actual value for the parameter.
8. Click Save to add the parameter to the active Test Plan tree node.
Creating Filters
To create a filter:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Filters tab to view the list of available filters.
3. Click New Filter.
The New Filter dialog box displays.
4. Type a Name for the new filter.
This name will be displayed in list boxes when the filter becomes available.
5. Select a Category for the new filter from the list box to make the filter available in a specific Test Manager
unit.
Category

Unit

Requirement

Requirements

Test Definition

Test Plan

Execution

Execution

6. Type a Description for the new filter.
7. Select a category of filter criteria from the Selection criteria list box. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Definition Filter or Nested Requirements
Filter. Selecting one of these categories allows you to include an existing filter in your new filter.
8. Select a Property, Operator, and Value for the filter from the respective list boxes.
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Property

Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected
an attribute category, the property list includes custom attributes to query against.

Operator

Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the following
operators are available:
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Operator

Description

=

The string equals the defined value.

Value

Operator

Description

not

The string is different than the defined value.

contains

The string contains the defined value.

not contains

The string does not contain the defined value.

Enter the value that you want to filter out. Depending on the property type that you have
selected, values will either be strings that you can enter into the text box, or a selection of
predefined values that you can select from the list box.

9. Optional: Click More if you want to add more than one filter category to the new filter. Repeat this procedure
to define new categories.
Note: If you define more than one filter category, you must define whether the categories need to be
fulfilled in addition to the existing categories (AND relationship), or if the filter returns true when one of
the filter categories is fulfilled (OR relationship). Select either AND or OR to define the filter category
relationship. You cannot define nested AND, OR relationships.
10. Optional: To remove filter categories, click Fewer. This removes the last filter category.
11. Click OK to save the new filter, or click Cancel to abort the operation.
Assigning Requirements to Test Definitions
To manually assign requirements to test definitions:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select the test definition to which you want to assign requirements.
4. Click the Assigned Requirements tab.
Note: If you have created a requirements filter, you can select it from the filter list above the Available
Requirements tree. To create a new requirements filter, navigate to Test Manager ➤ Requirements
and click

on the toolbar.

All requirements that are available for assignment are displayed in the Available Requirements tree.
5.

Click
to the left of a requirement or double-click on the requirement to assign it to the selected test
definition.
Note: Newly generated test definitions can automatically be assigned to the requirements from which
they are generated by checking the Assign newly generated Test Definitions to Requirements
check box on the Generate Test Plans from Requirements dialog box. This is the default behavior.

Attaching Files to Test Plan Elements
To attach a file to a test plan element:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a container, folder, or test definition.
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4. Click the Attachments tab.
5. Click Upload File.
The Upload File dialog box opens.
6. Click Browse to select a file from your local file system.
7. Enter a description for the attachment.
8. Click Ok to upload the attachment to the server and associate it with the selected element.
Note: Attaching files to a test plan element may not work in Mozilla Firefox. Firefox requires usage of
three slashes, for example file:///, for a file link, while other browsers require only two, for example
file://. Aditionally, Firefox includes a security feature blocking links from remote files to local files and
directories. For more information, see
http://kb.mozillazine.org/Firefox_:_Issues_:_Links_to_Local_Pages_Don't_Work.
Attaching Links to Test Plan Elements
To attach a link to a test plan element:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a container, folder, or test definition.
4. Click the Attachments tab.
5. Click Attach Link.
The Attach URL dialog box opens.
6. Type the URL in the URL text box.
7. Type a description for the attached link.
8. Click Attach URL to associate the link with the selected element.

Libraries
This section provides information regarding the usage of libraries in Test Manager.

Shared Step Libraries
Shared step libraries (libraries), are collections of test steps which are shared between test definitions in
multiple projects. Sharing the steps reduces the amount of steps that a test engineer needs to maintain.
Libraries are displayed, organized, and maintained through a hierarchical tree structure, called the Libraries
tree. The Libraries tree enables you to organize shared steps in any number of hierarchy levels. You can edit
or delete any node in the tree. Right click on a node in the tree to cut it, or to copy and paste it to another
location. Use the Visibility page to define for which projects the selected library is visible. When you create
a new call to a shared steps object from a project that has visibility on the library, the library is displayed in the
Call to Shared Steps dialog box.
To view the properties of a node in the Libraries tree, select the node and click the Properties tab. To create,
edit, or view step properties for a library node in the Libraries tree, select the node and click the Step Properties
tab. To create, edit, or view the shared steps included in a shared steps object in the Libraries tree, select
the shared steps object and click the Steps tab. The Usages page of each shared step object in the tree lists
test definitions and other shared step objects that are calling the selected object, allowing you to estimate the
impact of a change to the object.
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When you create a baseline of a project, the baselined test definitions call the same shared steps objects as
the original test definitions.
The root node of the Libraries tree is called Shared Steps Libraries and cannot be edited.
Note: Objects in the Libraries unit can be created, edited, and viewed by the Test Manager, Tester, and
SuperUser roles. The Test Manager and SuperUser roles can additionally delete objects from the Libraries
unit. Users with the roles Project Manager, Analyst, or Reporter can view objects in the Libraries unit.

Creating a Shared Step Library
1. Navigate to Test Manager ➤ Libraries.
2. In the Libraries tree, select the root node, which is called Shared Steps Libraries.
3.
In the toolbar, click
.
Note: You can also right click on the root node and click New Library.

Library Properties Page
Test Manager ➤ Libraries ➤ Properties
The Properties page displays the following properties of the selected node in the Libraries tree:
Property

Description

Name

The name of the node.

ID

The identifier of the node.

Description

A description of the contents
of the node.

Created On

Date and time this node was
created.

Created By

Name of the user who
created this node.

Changed On

The date and time this node
was last changed.

Changed By

Name of the user who last
changed this node.

Planned Time [hh:mm]

Estimated execution. Only for
shared steps objects.

Step Properties Page
Test Manager ➤ Settings ➤ Step Properties
Test Manager ➤ Libraries ➤ <Library> ➤ Step Properties
The Step Properties page lists all properties that can be populated into manual test steps across the active
project. To create a new step property, click New Property.
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Step Property
Actions

Name

Description
The actions that can be performed on the property are
Delete, Move Up, and Move Down.
Name of the step property.

Library Visibility Page
Test Manager ➤ Libraries ➤ Visibility
The visibility of a selected library to a project is defined by the permissions of the active user. In the Visibility
page, you can additionally enable or disable the visibility of the selected library in a specific project. To change
the visibility of a the selected library to a project, click Edit Visibility.
When a baseline of a project that calls shared steps objects is created, the libraries that include the shared
steps objects are by default visible to the new project baseline. For more information on project baselines,
refer to the SilkCentral Administration Module Help.
For each project, the page shows the following properties:
Property

Description

Project

The name of the project.

ID

The identifier of the project.

Description

A description of the project.

Is Active

Whether the project is active
or not.

Has Usages

Whether the project uses
objects from the selected
library or not.

Edit Visibility Dialog Box
The Edit Visibility dialog box displays the projects that can be assigned to the library by the current user.
The dialog box includes the following items:
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Item

Description

All Projects

Click this option button to
assign all projects to the
library.

Selected Projects

Click this option button to
assign selected projects from
the list to the library.

Select All

Click to assign all listed
projects to the library.

Deselect All

Click to unassign all listed
projects from the library.
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Note: Projects that are currently using the library are grayed out and you cannot unassign them from the
library.

Shared Steps Objects
A shared steps object is a collection of manual test steps, included in a library, that can be used by multiple
test definitions in multiple projects.

Calling Shared Steps
To reduce the effort for maintaining the same test steps in various test definitions and projects, you can add
shared steps from a library as a single step to a test definition or shared steps object.
You can only add a call to all steps in a shared steps object, not to a selection of them. When a call to a shared
steps object is added, all shared steps are displayed as a single step in the calling test definition or shared
steps object and you can add additional steps before and after the called steps. The initial shared steps are
only displayed during execution of the referencing test definition. The shared steps object cannot be deleted.
To delete the shared steps object, you first have to remove all calls to it.
The name of the shared steps object, whose steps are called, is displayed as the name of the step in the Steps
page. Click on the name to access the called shared steps object.
Adding a Call to Shared Steps
To add a call to a shared steps object:
1. Click Test Plan to add the shared steps to a test definition or Libraries to add the shared steps to another
shared steps object.
2. In the corresponding tree, click on the node to which you want to add the shared steps.
3. Click the Steps tab.
4.
To add the shared steps to the end of the steps list, click
. To insert it above the selected step, click
.
The Call to Shared Steps dialog box opens.
5. Select the shared steps node, whose steps you want to add, from the tree.
Note: For a test definition, the tree displays only the libraries that are visible to the active project. For
more information, see the Visibility Page.
6. Click Ok.
Call to Shared Steps Dialog Box
The Call to Shared Steps dialog box enables you to browse shared steps objects in the Libraries tree. To
open the dialog box, choose a manual test definition in the test plan or a shared steps object in the Libraries
tree, click the Steps tab and click

.

To search for existing libraries, folders, and shared steps objects in the Libraries tree, type the name you are
searching for in the Find text box of the dialog box and press Enter. The search is case-insensitive and not
limited to entire words. Libraries and folders returned by the search are displayed with their entire subtree.
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Creating a Shared Steps Object
You can create a shared steps object in the Steps page of any manual test definition or shared steps object.
To create a shared steps object:
1. Navigate to the Steps page of the manual test definition or shared steps object that includes the steps you
want to share.
2. Select the steps with CTRL + CLICK or SHIFT + CLICK.
3.
Click
.
The Create Shared Steps dialog box opens.
4. Enter a name for the new shared steps object in the Name text box.
5. Choose the location where you want to place the new shared steps object in the Libraries tree.
6. Click OK.
The shared steps object is created and the selected steps are replaced by a call to the shared steps object.

Detaching Shared Steps from Libraries
To make a manual test definition or a shared steps object independent of other shared steps objects, detach
the steps from the libraries that contain the shared steps objects. All called steps are then copied into the
manual test definition or shared steps object.
To detach the shared steps included in a manual test definition or a shared steps object:
1. Click Test Plan to resolve the shared steps in a manual test definition or Libraries to resolve the shared
steps in a shared steps object.
2. In the corresponding tree, click on the node in which you want to resolve the shared steps.
3. Click the Steps tab.
4. Select the calls that you want to resolve in the grid with CTRL + CLICK or SHIFT + CLICK.
5.
Click

and confirm the resolving in the message box.

Editing Manual Test Steps
Edit the manual test steps of a test definition or a shared steps object in the Steps page.
To edit a manual test step:
1.
2.
3.
4.

Select the node whose steps you want to edit in the Test Plan or Libraries tree.
Click the Steps tab.
Click on the test step that you want to edit. The details of the test step are shown in the Edit Step view.
Edit the name, action description, expected results, and step properties of the test step in the corresponding
text boxes.
Note: You can insert values from data sources into manual test steps in the form of parameters.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.

5. Perform one of the following actions to finish editing the test step:
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•
•
•

Click Ok and New Step to save your changes and add a new step after the current.
Click Ok to save your changes.
Click Reset to revert your changes.

Steps Page
Test Manager ➤ Test Plan ➤ Steps
Test Manager ➤ Libraries ➤ <Shared Steps Object> ➤ Steps
The Steps page lists all manual test steps that are included in the selected test definition or shared steps
object. The page supports standard Windows Explorer style multi-select functionality.
To create a new shared steps object, select the steps you want to share and click

.

The page includes the following toolbar items:
Toolbar Item

Description
Add a new test step to the end of the list.

Insert a new test step before the selected step.

Add a call to a shared steps object to the end of the list.

Add a call to shared steps from a library before the selected
step.
Delete the selected test steps from the list.

Cut the selected test step from the list and move it to the
clipboard.
Copy the selected test steps to the clipboard.

Paste a copy of the test steps held on the clipboard to the
row above the selected in the list.
Move the selected test step one position up in the list.

Moves the selected test step one position down in the list.

Opens the Attachments dialog box, where you can perform
the following actions:
Upload File

Upload and attach a file to the
selected test step.

Attach Link

Attach a link to the selected test step.

Delete

Delete the file or link.
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Toolbar Item

Description
When steps of the test definition or shared steps object call
a shared steps object in a library, click here to view the
original steps. The resolved steps are marked with an arrow,
and you can access them by clicking on their name. You
cannot edit steps while this view is enabled.
View steps called from a shared steps object in a library as
a single step. Enable this view to edit test steps.
Create a shared steps object out of the selected steps.

Detach calls from other shared steps objects. Copies all
steps in the calls you have selected in the grid into the
manual test definition or shared steps object.

The Steps page supports the following keyboard functions (shortcuts) for test plan elements:
Key

Normal

SHIFT

CTRL

-

Move up

+

Move down

A

Select All

X

Cut

C

Copy

V

Paste

N

New

Ins

Insert

Del

Delete

The steps are displayed in a grid with the following columns:
Column

Description

Order

Number of the step in the execution sequence.

Name

Name of the test step.

Action Description

Action you must perform to execute the test step.

Expected Results

Expected result of the test step.

Attachments

Amount of links or files that are attached to the test step.

The Edit Step view shows the details of the selected test step and allows you to edit the name, action
description, expected results, and step properties of the test step.
The following buttons are available in the Edit Step view:
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Button

Description

OK and New Step

Click when you are finished with editing the current step and
you wish to save your changes and add a new step after the
current.

OK

Click when you are finished with editing the current step and
you wish to save your changes.

Reset

Click to revert your changes.

Usages Page
The Usages page displays the test definitions and shared steps objects that use the selected shared steps
object.
To access the usages page of a shared steps object, select the shared steps object in the Libraries tree and
click the Usages tab.
For each call to the selected shared steps object, the Usages page displays the following properties:
ID

Identifier of the calling test definition or shared steps object.
Hidden by default.

Name

The name of the calling test definition or shared steps object.
Click on the name to access the test definition or shared
steps object. The icon in front of the name indicates if the
calling object is a test definition or another shared steps
object.

Created On

Date and time the calling test definition or shared steps
object was created.

Created By

Name of the user who created the calling test definition or
shared steps object.

Project ID

Identifier of the project in which the calling test definition
resides. Hidden by default. Empty if the calling object is
another shared steps object.

Project Name

Name of the project in which the calling test definition
resides. Empty if the calling object is another shared steps
object.

Versions
A version of a shared steps object or a manual test is a revision of the element in a certain state. The version
contains the information included in the element and the individual steps of the element at the creation time
of the version. Attachments, parameters, and data sets are not included in the version for manual tests.
You can manually create versions of shared steps objects or manual tests or revert to previous versions. All
versions of a shared steps object or a manual test are listed in the History page of the element. When you
copy a project, the versions are also copied.
Creating a Version
To be able to revert a set of changes you want to apply to a shared steps object or a manual test, create a
version of the element.
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To create a version of a shared steps object or a manual test:
1. For a shared steps object, click Libraries in the workflow bar. For a manual test, click Test Plan in the
workflow bar.
2. Select the shared steps object in the Libraries tree, or the manual test in the Test Plan tree.
3.
Click
in the toolbar.
This action is only enabled if the shared steps object or the manual test was changed.
The Create Versions dialog box opens.
4. Optional: Enter a comment on the version in the Comment text box.
5. Click Ok. The new version is shown in the History page.
Viewing a Version
To see if a specific version of a shared steps object or a manual test applies to your testing needs, view the
details of the version.
To view the details of a version of a shared steps object or a manual test:
1. For a shared steps object, click Libraries in the workflow bar. For a manual test, click Test Plan in the
workflow bar.
2. Select the shared steps object in the Libraries tree, or the manual test in the Test Plan tree.
3. Click the History tab.
4. Right click on the version of which you want to see the details.
5. Click View version <ID>.
6. The View Version dialog box opens. If the version includes attachments, you can view the attachments
by clicking on their number in the Attachments column of the Steps section.
Note: Use the arrows to change the version number and view additional versions.
Comparing Versions
To view the differences between two versions of a shared steps object or a manual test, compare the versions.
To compare two versions of a shared steps object or a manual test:
1. For a shared steps object, click Libraries in the workflow bar. For a manual test, click Test Plan in the
workflow bar.
2. Select the shared steps object in the Libraries tree, or the manual test in the Test Plan tree.
3. Click the History tab.
4. Select the two versions you want to compare with CTRL + CLICK.
5. Right click on the selection.
6. Select Compare Versions. The Compare Versions dialog box opens, displaying all the added, changed,
and removed content.
Note: Use the arrows to change the version numbers and compare additional versions.
Reverting to a Previous Version
To undo changes to a shared steps object or a manual test, revert to a previous version.
To revert a shared steps object or a manual test to a previous version:
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1. For a shared steps object, click Libraries in the workflow bar. For a manual test, click Test Plan in the
workflow bar.
2. Select the shared steps object in the Libraries tree, or the manual test in the Test Plan tree.
3. Click the History tab.
4. Right-click on the version to which you want to revert the shared steps object to.
5. Click Revert to Version <ID>.
6. The shared steps object or manual test is reverted to the selected version and a new version is created in
the History page. Attachments, parameters, and data sets are not reverted for manual tests.
Library History Page
The History page displays the history of the selected shared steps object.
The History page includes an entry for each version of the selected shared steps object, and allows you to
create new versions, view version details, revert to a previous version, and view the differences between
versions.
To display only versions in the History page, and no other entries, right click on the Version column, select
Filter and type 0 in the > text box.
The page shows the following items for each listed entry:
Item

Description

Actions

Only for version entries. The actions you can perform on a
selected version are View Version, Delete Version and
Revert to Version.

Version

Only for version entries. The version of the shared steps
object.

Comment

A comment on the changes.

Created On

Date and time this history entry was created.

Created By

Name of the user who created this history entry.

Projects
This section explains how to manage projects in Test Manager. The Projects unit offers a high-level
test-manager’s view of all projects in your Test Manager installation, and enables you to move between projects,
see high-level project status details, and view current execution statistics.

Build Information
Build information files contain version and build information that is used for execution runs. The build information
files are typically stored and searched for on the execution server that is executing the exeution run. If a build
information file is not found on the execution server, the file is searched for on the application server. This
behavior is beneficial when you have several execution servers and use a single build information file across
all execution servers. You need to maintain only a single build information file on the application server. The
build information files for automated test definitions that have no execution server assigned, and for all manual
test definitions, are immediately searched for on the application server.
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Test Manager is able to match up test results with build information and display test results for specific build
numbers.

Build Information Updates
Build information files must be created and configured manually. Whenever a new build becomes available
for testing on an execution server, update the build information to reflect the new build number.
You can update the build information in two different ways:
•
•

Manually, by editing the files each time a new build is installed.
Automatically, if you are using an automated build update process to update the build information file, for
example through a VB Script.

Creating Build Information Files
To create a build information file:
1. On both the application and execution servers, navigate to: C:\Documents and Settings\All
Users\Application Data\SilkCentral\BuildInfos.
2. Create a build info file for your project based on the template file BuildInfoExample.xml. The template
file contains the following code:
<?xml version="1.0" encoding="utf-8"?>
<ProjectBuildInfo>
<BuildEntryList>
<BuildEntry name="Demo Product">
<Version>3.1</Version>
<BuildNr>350</BuildNr>
</BuildEntry>
<BuildEntry name="Product2">
<Version>4.2</Version>
<BuildNr>613</BuildNr>
</BuildEntry>
</BuildEntryList>
</ProjectBuildInfo>
Note: To improve the structure of build information files, an element called BuildEntryList which
contains a list of BuildEntry elements has been created. BuildEntry tags refer to specific products
that are defined by the name attribute of BuildEntry elements.
3. Modify the file content to fit your environment.
Version

Used on both application and execution servers. The number of the version that is
currently available for testing.The number is not necessarily the same for each execution
server.

BuildNr

Used on both application and execution servers.The number of the build that is currently
available for testing. The number is not necessarily the same for each execution server.

4. Distribute the build information file to the execution servers: C:\Documents and Settings\All
Users\Application Data\SilkCentral\BuildInfos.
Note: When stored on both the application server and execution servers, build information files must
have the exact same name.
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5. Once you have created the build information files on the application server and each execution server, you
must specify the file name in the settings of the corresponding project. Select the Projects unit to view the
list of projects assigned to you. Select the project to which you want to link the build information.
Note: This must be done before the scheduling of any test definitions for the project. Otherwise
previously scheduled test definitions will not be updated.
6. Click the Project Settings tab.
7. Click Edit to edit the project settings of the selected project.
The Edit Project Settings dialog box opens.
8. Specify the name of the previously created XML file in the Build information file name text box.
9. Click OK to update the information. With all future test executions, Test Manager will read build information
from the corresponding file and match test results with that information.

Comparing a Project with a Baseline
For baselined projects, you can use the Baseline Comparison report to see all the changes to the test definitions
in the project since the moment the project was baselined.
To view the report:
1. Navigate to Test Manager ➤ Projects.
2. Click the Projects tab.
3. Use SHIFT + CLICK to select the project and the baseline of the project that you want to compare.
Tip: For easier selection of the baselines, don't click on the name of the baseline. Click into another
column instead.
4. Right click on the selection.
5. Select Reports ➤ Baseline Comparison.
Note: The Baseline Comparison report must be executed once to display in the context-menu. If the
report is grayed out, execute the report once in the Reports unit.

Selecting Projects
To select a project:
1. Navigate to Test Manager ➤ Projects.
2. Click the Projects tab.
3. Click the name of the project to select it.
The selected project is activated.

Projects Page
Test Manager ➤ Projects ➤ Projects
The Projects page hierachically displays all the projects and project baselines associated with your Test
Manager installation. The page supports filtering, but does not support sorting. The displayed projects are
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sorted by name. Inactive projects and inactive project baselines are not displayed, except if they are needed
to display the hierarchy, in which case they are grayed out.
Project baselines are sorted by their date of creation, marked with a special icon, and shown as subnodes of
the original project. For more information on baselines, refer to the SilkCentral Administration Module Help.
The following columns are displayed for each project and project baseline:
Column

Description

Project

Name of the project.

Project ID

The identifier of the project.

Description

Project description.

Created On

Date the project was created.

Created By

User who created the project.

Note: Only your system administrator has rights to set up new projects.

Overview Page
Test Manager ➤ Projects ➤ Overview
The Overview page displays the Project Overview Report, which offers a high-level overview of the status
of the selected project. The Project Overview Report includes the following sections:
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Section

Description

General Report Information

General information like the
name of the current project,
the report description, and
the planned release date.

Requirements

Test coverage status for the
Requirements unit. Shows
the percentage of test
coverage in tabular and
graph format both all
requirements and
requirements with high
priority.

Test Plan

Test-type distribution and
test-execution results in chart
and tabellary form for the
Test Plan unit.

Issues

The amount of found, fixed,
deffered, and currently open
in the backlog issues, that are
linked to test definitions in the
test plan unit, in tabular and
graph format.
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Quality Goals
Quality goals (exit criteria) are a definable set of testing metrics that the project must meet in order for the
quality to be considered acceptable. Each Test Manager project can contain one or more quality goals. Test
Manager uses quality goals as a primary means to implement risk based testing, allowing you to plan, to test,
and to report on only the most important tests in a given testing cycle.
In Test Manager, a quality goal is comprised of the following two elements:
•
•

A requirement or test definition.
A custom attribute or property of type List with a corresponding percentage value.

Quality Goal Example
If a requirement has a property of Risk with values of High, Medium, and Low, it should be possible to define
a quality goal of:
Requirement Goal - Risk

High = 100%
Medium = 50%
Low = 10%

The 100% means that all of the tests that meet that criteria (linked to a requirement that has the High attribute
value) must execute and pass to meet that goal.
Permissions
Quality goals are permission based. See Quality Goals Permissions for details of permission.

Quality Goals Page
Test Manager ➤ Projects ➤ Quality Goals
The following controls are available on the Quality Goals tab allowing you to create, edit, or delete quality
goals for a project:
Quality Goals Grid
Column
Goal Name

Description
The name of the goal.
Select the drop-down list on the column name and then
select Show in Groups to show all goals in a list.

Name

Goal (%)

Each value of the attribute or property List type is
itemized in the Name column.
This text field must contain a numeric value from 0 to
100. The value represents the percentage of tests
required to meet the defined quality goal.
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Buttons
•
•
•

Manage Goals - Click to show the Manage Quality Goals dialog box.
Planning Report - Click to show the Quality Goals Planning Report.
Execution Report - Click to show the Quality Goals Execution Report.

Adding Quality Goals
Before creating a quality goal, you need create a test definition custom attribute or requirement custom property
of type List that you want to use for your quality goals.
For example, if you want a quality goal to track a requirement custom property with values of High, Medium,
and Low, first go to the Settings unit and create a List type custom property that contains these values.
1. Navigate to Test Manager ➤ Projects.
2. Click the Projects tab.
3. Select a project.
4. Click the Quality Goals tab.
5. Click Manage Goals.
The Manage Quality Goals dialog box opens.
6. In the New Goal Name field, enter the name for your goal.
7. In the Attributes/Custom Properties list, select either the requirement property or test definition attribute
List type that contains the values that you want to use for your quality goal.
Note: You can only use a property or attribute as a quality goal once per project.
8. Click Add New Goal.
9. Click Close.
The Manage Quality Goals dialog box closes and the new goal is added to the Quality Goals grid.
10. For each value in the list, enter a numeric value from 0 to 100 in the Percentage of Tests Required to
Meet Goal.

Deleting Quality Goals
To delete a quality goal:
1. Navigate to Test Manager ➤ Projects.
2. Click the Projects tab.
3. Select a project.
4. Click the Qualiy Goals tab.
5. Click Manage Goals.
The Manage Quality Goals dialog box opens.
6. Click the Delete icon next to the quality goal that you want to delete.

Activities Page
Test Manager ➤ Projects ➤ Activities
The Activities page offers a centralized location from which you can manage upcoming, current, and recently
executed test runs for a project. The grid views on the Activities page offer filtering, sorting, and grouping
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options that are configurable for each user separately. You can display or hide columns, adjust the width of
columns, and move columns around using click and drag.
The Activities page is split into three sections: Next Executions, Current Executions, and Last Executions.
The grid views can be resized by dragging the separators between the views.
Context-sensitive menu commands are available for each test run. These commands enable you to link directly
to listed execution definitions, continue manual tests, manage test-run results, and more.
The Activities page makes it easier to identify match points between execution definitions and to find specific
execution-definition information. Standard Windows keyboard shortcuts can be used to select test run entries,
making it easy to select and manipulate specific sets of execution definitions and test results. Sorting, grouping,
and filtering functions are available through context-menu commands to help you better organize and group
test runs. All of your view-customization preferences are saved along with your project and will be available
to you each time you visit the Activities page.
Note: Data on the Activities page is not automatically refreshed. Click Reload near the paging buttons
at the bottom of each view to refresh the page's contents.
Note: You can use CTRL + SHIFT to select multiple queued executions and abort them all with one
click.
Next Executions
The Next Executions view lists the execution definitions that are scheduled to run in the future. To enhance
performance when you have numerous execution definitions, only the upcoming 50 execution definitions are
displayed. You can access additional future execution definitions by using the available filtering features. To
edit an execution definition, right-click the execution definition and choose Go to Execution Definition
or click on the name of the execution definition. This takes you to the Executions unit where you can view
and edit the details of the execution definition.
By default, all execution definitions are sorted by Start Time. Columns in the Next Executions view can not
be sorted or grouped.
Next Executions view can be collapsed and expanded by clicking the double-arrow button on the right-hand
side of the view's title bar.
For each execution definition, the Next Executions view displays the following columns:
Column

Description

ID

Identifier of the scheduled execution definition. This column
is hidden by default.

Execution Definition/Folder

Name of the schedules execution definition or folder.

Keywords

Keywords that are assigned to the scheduled execution
definition.

Manual Testers

For manual tests, this column contains the user name of the
manual tester that is assigned to the test. This column is
blank when no manual testers are assigned to the test.

Priority

The priority that has been assigned to the execution
definition.

Start Time

Scheduled start time of the test run.

Execution Definition Parent

The configuration suite or folder in the context of which the
execution definition is executed. Click to access the suite or
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Column

Description
folder in the execution tree. If the execution definition is not
included in a configuration suite or folder, nothing is
displayed.

Current Executions
The Current Executions view lists the execution definitions that are currently running (both automated and
manual test runs).
To abort an execution definition that is currently in progress, click Abort in the Actions column of the execution
definition. To view or edit an execution definition, right-click the execution definition and select Go to Execution
Definition or click on the name of the execution definition. To view the execution's progress, right-click the
automated execution definition and select View Details or click the execution definition's Run ID/Task ID link.
As long as a manual test remains open, the corresponding execution definition remains in the list of Current
Executions with a status of Pending. Right-click a manual test execution definition and select Continue
Manual Test, or click the execution definition's Continue Manual Test button in the Actions column, to
continue a manual test in the Manual Test Execution view.
To view the results of a manual test, right-click the manual execution definition and select View Details, or
click the execution definition's Run ID/Task ID link, to open the Results for Execution Definition page. From
there, click the name of the manual test definition in the Assigned Test Definitions section to open the Results
dialog box. Detailed results of the manual test definition are displayed there. Back on the Results for Execution
Definition page, click Manual Test Results to go to Manual Test Execution view, where read-only information
about the status of the assigned manual test definition is available.
Page views of current executions are broken into views of 20 execution definitions each. You can advance
through pages using First, Last, Next, and Previous located in the lower part of the Current Executions
view. Or you can type a page number into the Page text box and press Enter.
For each execution definition, the Current Executions view displays the following columns:
Column

Description

Actions

You can perform the following actions on the execution
definition:
Abort

Click to cancel the current execution.
Alternatively, press Delete. When you
abort executions, these executions are
grayed out until the background process
completes the deletion.

Continue
Manual Test

Click to go to Manual Test view and
execute the test.

Manual
Click to open the Manual Testing Client.
Testing Client This button is available to users that are
assigned as testers to the selected test.
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Identifier of the execution definition. This column is hidden
by default.

Execution Definition

Name of the execution definition.
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Column

Description

Run ID/Task ID

Manual test definitions receive a Run ID when they are
executed. When the manual test is completed, the Run ID
carries over to the Last Executions view. Automated test
definitions receive a Task ID when they are executed. The
Task ID is not carried over to the Last Executions view.
Completed execution definitions receive a Run ID in the
Last Executions view.

Status

Status of the active execution definition or manual test. For
automated tests, the status is indicated with a text-based
value, Pending or Active. For manual tests, the status
is indicated with a colored histogramm. Automated-test
statuses are described textually and can be filtered. Manual
tests can be filtered by checking relevant properties on the
Filter submenu.
•
•
•

Pending manual execution
Pending manual setup execution
Pending manual cleanup execution

Keywords

Keywords that are assigned to the execution definition.

Executed By

Only for manual tests. The users who are assigned to
perform the manual test. This column is blank when no
manual testers are assigned to the test.

Priority

Priority that has been assigned to the current execution
definition or manual test.
•
•
•

Low
Normal
High

Start Time

Time when the execution definition run started.

Time Left

Amount of time remaining until the test is complete. For
manual tests that do not have an estimated time, this column
has a value of unknown.

Start Type

Shows how the test run was started. Manually, through a
Web Service, or from a schedule.

Starter Name

Name of the schedule, tester, or Web Service user.

Start Scope

The scope defined in the Run dialog box.

Execution Definition Parent

The configuration suite or folder in the context of which the
execution definition is executed. Click to access the suite or
folder in the execution tree. If the execution definition is not
included in a configuration suite or folder, nothing is
displayed.
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Last Executions
The Last Executions view lists all past execution definition runs, except deleted runs, for which results were
collected from the execution server. You can filter the listed execution definition runs, for example by the start
time.
To view or edit an execution definition, right-click the execution definition and choose Go to Execution
Definition, or click on the name of the execution definition. To display the Results for Execution Definition
page of an execution definition run, right-click the run and select View Details, or click the Run ID link of the
execution definition. This page shows details for the selected execution definition run and includes any files
and messages, for example LiveLink VMware configuration captures, that were generated during the execution.
To open the Results dialog box of a test definition, click on the Run ID of the test definition in the Assigned
Test Definitions portion of the Results for Execution Definition page.
To compare two execution definition runs, use Ctrl + Shift to select the two runs. Right click on your
selection and click Reports ➤ Execution Definition Run Comparison ....
Right-click on an execution definition and click Run Execution Definition to run the execution definition. Test
Manager uses the configuration currently defined in the Execution unit for the re-run, not the original
configuration of the selected execution-definition run.
For execution definitions that are deployed to virtual servers: To open VMware Lab Manager and restore a
captured LiveLink configuration, expand the Messages link on an execution definition run's Results for
Execution Definition page and select LiveLink.
To delete a test run, right-click a run entry and choose Delete Results or click Delete in the Actions column
of the run.
Test-result page views are broken into views of 20 test results each. You can advance through pages using
First, Last, Next, and Previous at the bottom of the Last Executions view. Or you can enter a page number
into the Page text box and press Enter.
The Last Executions view can be collapsed/expanded by clicking the double-arrow button on the right-hand
side of the view's title bar.
For each execution definition, the Last Executions view displays the following columns:
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Column

Description

Actions

You can perform the following actions on the
execution definition:
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Delete

Click to delete the test run results.
When you delete executions, these
executions are grayed out until the
background process completes the
deletion. Alternatively, press
Delete to delete test definitions.
For tagged builds, you have to verify
that you want to remove the results,
and when you have selected
multiple runs, results from tagged
builds are not removed.

View
Manual
Test
Results

Click to open the Current Run page
in read-only mode; or right-click a
manual execution definition run and
select View Manual Test Results.

Column

Description

ID

The identifier of the executed execution
definition. Unassigned test definitions have an
ID value of N/A. This column is hidden by
default.

Execution Definition

Name of the executed execution definition. Click
on the name to view or edit the execution
definition.

Run ID

ID assigned to the test run. Click the link to view
details of the test run.

Status

Result status of the test run. Passed,
Failed, or Not Executed. Filtering,
sorting, and grouping are not available for the
Status column in the Last Executions view.

Keywords

Keywords that were assigned to the execution
definition at execution time.

Executed By

Only for manual tests. The user that performed
the manual test. This column is blank when no
manual testers were assigned to the test.

Start Time

Time when the execution definition run started.

Duration

The duration of the test run.

Product

The product under test. This column is hidden
by default.

Version

The version of the product under test. This
column is hidden by default.

Build

The build number of the product under test. If
the build is tagged, it is marked bold and with
.

Start Type

Shows how the test run was started. Manually,
through a Web Service, or from a schedule.

Starter Name

Name of the schedule, tester, or Web Service
user.

Start Scope

The scope specified in the Run dialog box.

Execution Definition Parent

The configuration suite or folder in the context
of which the execution definition is executed.
Click to access the suite or folder in the
execution tree. If the execution definition is not
included in a configuration suite or folder,
nothing is displayed.
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Cross-Project Activities Page
Test Manager ➤ Projects ➤ X-Project Activities
The X-Project Activities page enables a user with SuperUser privileges to see all execution related activities
across projects. It provides all the options the Activities page offers, and additional options across projects.
This allows some conclusion about the execution queue. The SuperUser can remove executions from the
queue to resolve bottlenecks.
The X-Project Activities page is visible to the SuperUser only. The page is split into the same three sections
as the Activities page: Next Executions, Current Executions, and Last Executions. All three sections
include an additional column with the Project ID.
Item

Description

Project ID

The ID of the project to which the execution definition
belongs to.

Settings Configuration
This section explains how to configure settings in Test Manager.
If you have SuperUser, Administrator, or Project Manager privileges, you can specify project-wide settings for
Test Manager projects. Once global project settings are defined, they are available to all users who have
access to those projects. Global project settings include the definition of filters, attributes, external product
integrations, change notifications, build information, source files, file extensions, and more.

Project Settings
Project settings are settings that are specific to a project, for example the project release date.

Configuring Project Settings
To customize the project settings:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Project Settings tab to view the current settings.
The Project Settings page opens.
3. Click Edit to modify the current project settings.
4. The Edit Project Settings dialog box displays. You can specify the following information:
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Build Information File Name

Build information files contain project information, including build number,
build log location, error log location, and build location. Enter the name
of your project’s build information file in this text box. All test executions
will read the build information from this specified file.

Project Release Date

Specify the planned release date for your project.
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File Extensions to ignore in
Results

Specify result file types or other file types that should not be saved as
results for test executions.

Note: File extensions must be separated by commas, for example, xlg, *_, res. Changes made in the
Build Information File Name and File Extensions to ignore in Results fields will not effect scheduled
test definitions. To redistribute tasks to execution servers, you must reschedule the test definitions, or
disconnect from and reconnect to the database.
5. Click Save to save your project settings.

Project Settings Page
Test Manager ➤ Settings ➤ Project Settings
The Project Settings page lists the following high-level details about the active project:
Item

Description

Build information file name

Build information files contain project information, including
build number, build log location, error log location, and build
location. Enter the name of the active project’s build
information file in this field. All test executions will read the
build information from this specified file.

Project release date

Scheduled release date of the active project in the format
MM/DD/YYYY.

File extensions to ignore in results

Result file types or other file types that should not be saved
as results for test executions.

Filters
Filters provide an efficient means of finding exactly the information you need, while excluding extraneous detail.
Filters highlight only those elements that are relevant to your needs, and enable you to quickly sort through
requirements, test plan elements, and execution definitions. By defining global filters, you can create complex
filter criteria that are available through out Test Manager without defining filter criteria each time you need to
filter a list.
Based on your needs, you can create new filters, edit existing filters, select filters, delete filters, or turn filtering
off at the project level. Projects do not contain any default filters. You can access and edit filters from the
toolbars int the Test Manager units and from the Settings unit.
Note: Filters are not applied to reports. The Recent Changes filter enables you to view project-wide
changes and additions that other users have made to test definitions since your last change
acknowledgement. The Show Changes/Show All toggle button and the Acknowledge button in the Test
Plan unit help you to find out what changes other users have made. Your system administrator can
configure email notifications that alert you to changes that are made to test definition settings. Email alerts
include links that take you directly to a view of recent changes.

Creating Filters
To create a filter:
1. Navigate to Test Manager ➤ Settings.
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Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Filters tab to view the list of available filters.
3. Click New Filter.
The New Filter dialog box displays.
4. Type a Name for the new filter.
This name will be displayed in list boxes when the filter becomes available.
5. Select a Category for the new filter from the list box to make the filter available in a specific Test Manager
unit.
Category

Unit

Requirement

Requirements

Test Definition

Test Plan

Execution

Execution

6. Type a Description for the new filter.
7. Select a category of filter criteria from the Selection criteria list box. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Definition Filter or Nested Requirements
Filter. Selecting one of these categories allows you to include an existing filter in your new filter.
8. Select a Property, Operator, and Value for the filter from the respective list boxes.
Property

Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected
an attribute category, the property list includes custom attributes to query against.

Operator

Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the following
operators are available:

Value

Operator

Description

=

The string equals the defined value.

not

The string is different than the defined value.

contains

The string contains the defined value.

not contains

The string does not contain the defined value.

Enter the value that you want to filter out. Depending on the property type that you have
selected, values will either be strings that you can enter into the text box, or a selection of
predefined values that you can select from the list box.

9. Optional: Click More if you want to add more than one filter category to the new filter. Repeat this procedure
to define new categories.
Note: If you define more than one filter category, you must define whether the categories need to be
fulfilled in addition to the existing categories (AND relationship), or if the filter returns true when one of
the filter categories is fulfilled (OR relationship). Select either AND or OR to define the filter category
relationship. You cannot define nested AND, OR relationships.
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10. Optional: To remove filter categories, click Fewer. This removes the last filter category.
11. Click OK to save the new filter, or click Cancel to abort the operation.

Editing Filters
To edit a filter:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2.
3.
4.
5.

Click the Filters tab to view the list of available filters.
Click the name of the filter you want to edit. The Edit Filter dialog box displays.
Edit the Name and Description of the filter.
Select a category of filter criteria from the Selection criteria list box. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Definition Filter or Nested Requirements
Filter. Selecting one of these categories allows you to include an existing filter in your new filter.

6. Select a Property, Operator, and Value for the filter from the respective list boxes.
Property

Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected
an attribute category, the property list includes custom attributes to query against.

Operator

Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the following
operators are available:

Value

Operator

Description

=

The string equals the defined value.

not

The string is different than the defined value.

contains

The string contains the defined value.

not contains

The string does not contain the defined value.

Enter the value that you want to filter out. Depending on the property type that you have
selected, values will either be strings that you can enter into the text box, or a selection of
predefined values that you can select from the list box.

7. Click OK to save the edited filter definition.

Deleting Filters
To delete a filter:
1. Navigate to Test Manager ➤ Settings.
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Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Filters tab to view the list of available filters.
3. Click Delete Filter for the filter that you want to delete.
A confirmation dialog box displays, asking you you to confirm the deletion.
4. Click Yes to delete the selected filter or No to abort the operation.
If you click Yes, you will be returned to the filters list and the deleted filter is no longer displayed.

Filters Page
Test Manager ➤ Settings ➤ Filters
The Filters page lists the filters that are available to the active project. For each filter, the Filters page displays
the following columns:
Item

Description

Actions

Actions that can be
performed on the filter.
Currently only Delete.

Name

Name of the filter.

Type

Filter category. Requirement,
test plan, or execution.

Created On

When the filter was created.

Created By

User who created the filter.

Changed On

When the filter was most
recently modified.

Changed By

User who most recently
modified the filter.

Attributes
You can use custom attributes to customize the information for test definitions in the Test Plan unit. While
some attributes are made available by the integrated functionality of Test Manager, such as priority, components,
and platforms, you may want to define custom attributes to categorize test definitions to your needs, or to make
test definitions compatible with specific test cases.

Creating Custom Attributes
To create a custom attribute:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Attributes tab to view the list of current attributes.
3. Click New Attribute.
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The New Attribute dialog box displays.
4. Type a Name for the new attribute. This name will be displayed in list boxes when the attribute becomes
available for use.
5. Type a Description for the new attribute.
6. Select the attribute Type. See the Test Definition Attribute and Requirement Property Types topic for
descriptions of each type of attribute.
7. Click OK.

Test Definition Attribute and Requirement Property Types
Test Manager suports the following types of test definition attributes and requirement properties:
Date
List

The Date type supports date values.
The List type supports single select or multi-select lists. It has the following controls:
•

New Item: Allows you to create entries in the list. Click to show the New Item dialog box.
Enter the Name and Numeric Weight for the list item and click OK.
Note: The value of the Numeric Weight field is used during filtering when the filter criteria
uses any of the following operators: >, >=, <, or <=. When the filter criteria uses the = or
not operators, the value from the Name field is used for comparisons.

•
•

Number

Allow Multiselect: click this check box to allow users to select more than one value from the
list.
Actions: use the icons in this row to delete, to move up, to move down or to edit each item
in the list.

The Number type supports integer or decimal numeric values. It has the following fields:
•
•
•

Minimum value: represents the smallest value that you can enter into the field.
Maximum value: represents the largest value that you can enter into the field.
Decimal places: used to define how many values to the right of the decimal point are valid.
Select 0 for an integer value or 1, 2, 3, or 4 for a decimal value.
Note: Custom attributes and requirement properties display their current value if an update
is made to their definition (for example, changes to Minimum value or Maximum value).
In order to apply the new definition, open and save the asset.

Text

The Text type supports any alphanumeric value. It has the following fields:
•

Maximum length: represents the maximum number of characters that can be entered into
the field.

Editing Custom Attributes
To edit a custom attribute:
1. Navigate to Test Manager ➤ Settings.
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Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Attributes tab to view the list of current attributes.
3. Click the name of the attribute that you want to edit.
The Edit Attribute dialog box displays.
4. Edit the Name of the attribute.
When the attribute is available for use, the name will display in list boxes for filters and test definitions.
Attributes can be used in global filters for filtering by test definition attributes and can be applied to test
definitions.
5. Edit the Description of the attribute.
6. See the Test Definition Attribute and Requirement Property Types topic for descriptions of each type of
attribute. You have different editing options depending on the attribute data type.
7. Click OK.
You are returned to the Attributes list.

Deleting Custom Attributes
To delete a custom attribute:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Attributes tab to view the list of current attributes.
3. Before you can delete an attribute, you must first deactivate it. In the Status column, click the Active link
or icon and then click Yes on the confirmation dialog box to deactivate the attribute.
4. Once the attribute is inactive, click Delete Attribute to remove it.
A confirmation dialog box displays, asking you to confirm the deletion.
5. Click Yes to remove the selected attribute; or click No to abort the operation.
If you click Yes you will be returned to the Attributes page, where the removed attribute is no longer
displayed.
6. If an error displays, ensure that the selected attribute is not applied to any test definitions or used in any
global filters. You can only delete unused attributes.

Attributes Page
SilkCentral ➤ Settings ➤ Attributes
The Attributes page lists the attributes that have been created for the current project. For each attribute, the
Attributes page displays the following columns:
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Column

Description

Actions

Available actions that can be performed on the attribute.

Name

Name of the attribute. When the attribute is available for use, the
name will display in list boxes for filters and test definitions.
Attributes can be used in global filters for filtering by test definition
attributes and can be applied to test definitions.
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Column

Description
Click the Edit icon to edit the name of the attribute.

Type

Attribute type. See the Test Definition Attribute and Requirement
Property Types topic for descriptions of each type of attribute.

Status

Status of the attribute, active or inactive.

Column

The column name of the attribute in the LQM Reporting table.
Use this column name to query the selected attribute within the
LQM Reporting table. See the database model documentation
for detailed information.

Created On

When the attribute was created.

Created By

User who created the attribute.

Changed On

When the attribute was most recently modified.

Changed By

User who most recently modified the attribute.

Custom Requirement Properties
You can add custom property fields across all requirements in the selected project in the Settings unit. Custom
properties can subsequently be edited alongside the default properties on the Edit Requirements dialog box.
Custom properties are displayed in Requirements View on the Properties page of the Requirements unit,
but not in Document View.

Creating a Custom Requirement Property
To create a new custom requirement property:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2.
3.
4.
5.

Click the Requirement Properties tab.
Click New Property to display the New Custom Requirement Property dialog box.
Type a name for the new property in the Name text box.
Select the data Type of the new property from the Type list box. See the Test Definition Attribute and
Requirement Property Types topic for descriptions of each type of attribute.
6. Click OK.
Your custom property is available to all requirements in the active project.

Test Definition Attribute and Requirement Property Types
Test Manager suports the following types of test definition attributes and requirement properties:
Date
List

The Date type supports date values.
The List type supports single select or multi-select lists. It has the following controls:
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•

New Item: Allows you to create entries in the list. Click to show the New Item dialog box.
Enter the Name and Numeric Weight for the list item and click OK.
Note: The value of the Numeric Weight field is used during filtering when the filter criteria
uses any of the following operators: >, >=, <, or <=. When the filter criteria uses the = or
not operators, the value from the Name field is used for comparisons.

•
•

Number

Allow Multiselect: click this check box to allow users to select more than one value from the
list.
Actions: use the icons in this row to delete, to move up, to move down or to edit each item
in the list.

The Number type supports integer or decimal numeric values. It has the following fields:
•
•
•

Minimum value: represents the smallest value that you can enter into the field.
Maximum value: represents the largest value that you can enter into the field.
Decimal places: used to define how many values to the right of the decimal point are valid.
Select 0 for an integer value or 1, 2, 3, or 4 for a decimal value.
Note: Custom attributes and requirement properties display their current value if an update
is made to their definition (for example, changes to Minimum value or Maximum value).
In order to apply the new definition, open and save the asset.

Text

The Text type supports any alphanumeric value. It has the following fields:
•

Maximum length: represents the maximum number of characters that can be entered into
the field.

Editing Custom Requirement Properties
To edit a previously created custom requirement property:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Requirement Properties tab.
3. Click the name of the property you want to edit.
The Edit Custom Requirement Property dialog box displays.
4. Edit the name of the property in the Name text box.
When the property is available for use, the name will display in list boxes for filters and requirements.
Properties can be used in global filters for filtering by requirement properties and can be applied to
requirements.
5. Edit the Description of the property.
6. See the Test Definition Attribute and Requirement Property Types topic for descriptions of each type of
requirement property. You have different editing options depending on the property data type.
7. Click OK to save your changes.
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Deleting Custom Requirement Properties
To delete a previously created custom requirement property:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Requirement Properties tab.
3.
Click
.
The Delete Custom Requirement Property confirmation dialog box displays.
4. Click Yes to confirm the deletion.

Custom Requirement Properties Page
Test Manager ➤ Settings ➤ Requirement Properties
The Requirement Properties page lists the custom requirement properties that are available to the active
project. For each custom requirement property, the Requirement Properties page displays the following
columns:
Column

Description

Actions

Available actions that can be performed on the custom property.

Name

Name of the requirement property.
Click the Edit icon to edit the name of the requirement property.

Type

Property type. See the Test Definition Attribute and Requirement Property
Types topic for descriptions of each type of attribute.

Status

Status of the property, active or inactive.

Created On

When the property was created.

Created By

User who created the property.

Changed On

When the property was most recently modified.

Changed By

User who most recently modified the property.

Step Properties
Use step properties to extend a manual test step with additional properties. Add a custom step property to a
project in the Settings unit to add the property to all manual test steps in the project. Add a custom step
property to a library in the Libraries tree to add a custom step property to all manual test steps in the library.
Step properties can subsequently be edited alongside the default properties on the Edit Manual Test Definition
Step dialog box.

Creating Step Properties
To create a new step property:
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1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Step Properties tab.
3. Click New Property.
The New Step Property dialog box opens.
4. Enter a name for the new property in the Name text box.
Note: Step property fields are always declared as type string.
5. Click OK to make your property available to all manual test steps in the selected Test Manager project.
Note: To create a step property for a library, select the library node in the Libraries tree and continue
with the second step.

Editing Step Properties
To edit a previously created step property
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Step Properties tab.
3. Click on the name of the property that you want to edit.
The Edit Step Property dialog opens.
4. Edit the name of the property in the Name text box.
5. Click OK to save your changes, or click Cancel to abort the operation without saving.

Deleting Step Properties
To delete a previously created step property
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Step Properties tab.
3. Click Delete Property in the Actions column of the property that you want to delete.
A confirmation dialog box displays, asking you to confirm the deletion.
4. Click Yes to complete the operation, or No to abort.

Step Properties Page
Test Manager ➤ Settings ➤ Step Properties
The Step Properties page lists all properties that can be populated into manual test steps across the active
project. For each custom step property, the Step Properties page displays the following columns:
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Column

Description

Name

Name of the step property.

Actions

The following actions can be performed on a property:
•
•
•

Delete Property
Move Up
Move Down

Change Notification
Test Manager can notify you by email when requirements or test plans are changed by other users. Each user
has the option of activating change-notification. Once notification has been enabled, you can view and
acknowledge changes that have occurred since your last acknowledgment. To avoid numerous notifications,
only a single email alert is sent to you when a change is made, regardless of how many changes other users
may have made since your last acknowledgment. Email alerts include links that take you directly to a view of
recent changes.
Before you can activate change notification for requirements or test plan, you must configure your email address
in the user settings of Test Manager. Refer to the SilkCentral Administration Module Help for details.
Note: Change notification only works if an email server has been configured by your administrator. If
change notification has not been enabled, please contact your SilkCentral administrator.

Enabling Change Notification
To enable change notification:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Notifications tab.
3. Click Configure Notification to open the Configure Change Notification dialog box.
4. If you want to be notified by email when changes are made to requirements in the currently selected project,
check the Changes on Requirements check box.
5. If you want to be notified by email when changes are made to test plans within the currently selected project,
check the Changes on Test Plan check box.
6. Click OK to save the notification settings, or click Cancel to abort the operation without saving changes.
You will be notified by email about changes for which you have activated notification.

Disabling Change Notification
To disable change notification:
1. Navigate to Test Manager ➤ Settings.
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Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Notifications tab.
3. Click Configure Notification to open the Configure Change Notification dialog box.
4. If you do not want to be notified by email when changes are made to requirements in the currently selected
project, uncheck the Changes on Requirements check box.
5. If you do not want to be notified by email when changes are made to test plans in the currently selected
project, uncheck the Changes on Test Plan check box.
6. Click OK to save the notification settings or click Cancel to abort the operation without saving changes.

Changes Triggering Change Notification
When you have activated change notification to inform you of changes that are made to requirements or test
plans an email alert is sent to you, following your logout. The email alert is sent to you if one or more of the
following settings are changed:
Unit
Requirements

Changes
•
•
•
•
•
•
•

Test Plan

Notifications Page
Test Manager ➤ Settings ➤ Notification
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•
•
•
•
•
•
•
•
•
•
•
•
•

A requirement is created or deleted.
The name or description of a requirement is edited.
A system property is edited.
A requirement is set as obsolete.
A requirement is recovered.
A test definition is assigned to or removed from a
requirement.
A custom property of a requirement is created, edited,
or deleted.

A container is created or edited.
A product is edited.
A source control profile is edited.
"Clear working folder" is edited.
The root node is edited.
The custom data directory is edited.
The include directory is edited.
The hidden test properties are edited.
The SilkTest Classic interface is edited.
A test folder is created, edited, or deleted.
A test definition is created, edited, or deleted.
The planned time is edited.
A test step is added or edited.

The Notifications page lists the notification events for the active project. For each notification event, the
Notifications page displays the following columns:
Column

Description

Notification Events

Name of the notification event that has been set up for the
active project.

Status

Status of the notification event. Active or inactive.

Click the Configure... button in each section to edit the values.
Email
When an email notification event is activated, a notification email is sent to the user that activated the event,
the first time one of the specified settings is changed.
Note: You must have specified an email address to be able to receive email notifications. To specify an
email address, refer to the SilkCentral Administration Module Help.
Requirement Flagging
You can configure notifications differently for internal and external requirements. All requirement flagging is
enabled by default. For more information, see the Flags topic.

External Requirements Management Tools
This section explains how to work with external requirements management tools.

Requirements Management Configuration
Integrating external requirements-management enables you to coordinate the requirements-management
features of Test Manager with other tools you may already be working with. External requirements-management
integration is pre-installed for CaliberRDM, CaliberRM, IBM® Rational® RequisitePro®, and Telelogic DOORS®.
Integration is configured on the Requirements Management page in the Settings unit. The page is divided
into a separate section for each installed plug-in. Initially, the view is divided into sections, one for each
pre-installed requirements-management tool.
Test Manager supports integration with external requirements-management systems (RMS) through its open
interface. Creating a plug-in and integrating it into Test Manager allows integrating any RMS. Refer to the Test
Manager API Help for information about the interfaces that enable proper integration of external RMS.
Before you can configure CaliberRM integration, you must install the CaliberRM client on the SilkCentral
application server and on the front-end server. Additionally, make sure that MPX support is enabled in CaliberRM.
Before you can configure RequisitePro integration, you must install the IBM Rational RequisitePro client on
the SilkCentral front-end server.
Before you can configure DOORS integration, you must install the Telelogic DOORS client on the SilkCentral
front-end server.
For information on the supported versions, refer to the Test Manager Release Notes.You can download add-ins
for Rational RequisitePro and Telelogic DOORS from the Tools unit in Help. These add-ins can be installed
on appropriate server and client computers. For details, refer to the ReadMe files that are included in the
downloadable archives.
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•
•

The add-in for RequisitePro enhances the RequisitePro menu with an entry providing a link to the Test
Manager front-end server’s project selection.
The Add-In for DOORS enables Test Manager to communicate with DOORS. This add-in must be installed
on the DOORS client on the SilkCentral front-end server.
Note: Configuring integration with CaliberRM requires the definition of CaliberRM login credentials.
Whenever requirements are synchronized between Test Manager and Test Manager, these credentials
are used to login to Test Manager, thus checking out a Test Manager license. The license is set free as
soon as the synchronization process has completed. We recommend creating a dedicated Test Manager
user for synchronization purposes, which should be used by all Test Manager requirements integrations.
This ensures that only a single CaliberRM license is used for the process of synchronization.

Requirements Management Page
Test Manager ➤ Settings ➤ Requirements Management
The Requirements Management page lists the requirements-management integrations that have been
configured for the current project.
CaliberRM Integration
This section lists details related to the integration of the CaliberRM requirements management system.
Note: If integration has not been enabled, you will only see the Status property.
The following items are included for CaliberRM:
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Item

Description

Status

Status of integration, enabled or disabled.

Hostname

Machine where the external server is installed.

Username

Credential for the requirements management server.

Project Name

External project with which the Test Manager project is
integrated.

Baseline

Baseline of the external project with which the Test Manager
project is integrated.

Requirement Types

Requirement types within the project that are integrated.

Schedule

Schedule to automatically synchronize requirements with
CaliberRM.

Create Requirements

Indicates whether or not the Enable creation of unassigned
requirements option is active. Enables creation and editing
of unmapped requirements in Test Manager projects that
are configured for integration with CaliberRM.

Upload Requirements

Indicates whether or not the Enable upload of
requirements to CaliberRM option is active. Enables the
upload of unmapped or unassigned requirements from Test
Manager to CaliberRM. This allows you to upload additional
previously unmapped requirement trees to CaliberRM and
then have those requirements mapped within Test Manager.
When this option is enabled, the Map Requirement button
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Item

Description
in Requirements ➤ Properties becomes enabled, enabling
configuration of top level requirements for external
requirement types, which is required when uploading
unmapped requirements.

Property Mappings

Actions

Lists any external to internal property mappings that have
been defined between the internal and external requirements
management systems.
•
•
•
•
•
•

Edit Configuration
Edit Property Mapping
Edit Schedule
Edit Notification
Disable Configuration
Remove Configuration

IBM® Rational® RequisitePro® Integration
This section lists details related to the integration of the IBM Rational RequisitePro requirements management
system.
Note: If integration has not been enabled, you will only see the Status property.
The following items are included for IBM Rational RequisitePro:
Item

Description

Status

Status of integration, enabled or disabled.

UNC Project Path

Machine where the external server is installed.

UNC Username

Credential for the UNC file-path, which is required for the
integration with IBM Rational RequisitePro.

UNC Password

Credential for the UNC file-path, which is required for the
integration with IBM Rational RequisitePro.

User name

Credential for the requirements management server.

Password

Credential for the requirements management server.

Packages

The requirement packages from the external project that are
integrated with the Test Manager project.

Requirement Types

Requirement types within the packages that are integrated.

Create Requirements

Indicates whether or not the Enable creation of unassigned
requirements option is active. Enables creation and editing
of unmapped requirements in Test Manager projects that
are configured for integration with IBM Rational RequisitePro.

Upload Requirements

Indicates whether or not the Enable upload of
requirements to RequisitePro option is active. Enables
the upload of unmapped/unassigned requirements from Test
Manager to RequisitePro. This allows you to upload
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Item

Description
additional previously unmapped requirement trees to
RequisitePro and then have those requirements mapped
within Test Manager. When this option is enabled, the Map
Requirement button in Requirements ➤ Properties
becomes enabled, enabling configuration of top level
requirements for external requirement types, which is
required when uploading unmapped requirements.

Property Mappings

Lists any external to internal property mappings that have
been defined between the internal and external requirements
management systems.

Telelogic DOORS® Integration
This section lists details related to the integration of the Telelogic DOORS requirements management system.
Note: If integration has not been enabled, you will only see the Status property.
The following items are included for Telelogic DOORS:
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Item

Description

Status

Status of integration, enabled or disabled.

RM Service URL

The URL of Test Manager's Telelogic DOORS requirement
Web Service. The default value should point to the correct
location already.

Username

Credential for the requirements management server.

Password

Credential for the requirements management server.

DOORS Installation Path

Client installation path within the front-end server directory
structure.

Project Name

External project with which the Test Manager project is
synchronized.

Requirement Types

Requirement types within the project that are synchronized.

Schedule

Any defined synchronization schedule.

Create Requirements

Indicates whether or not the Enable creation of unassigned
requirements option is active. Enables creation and editing
of unmapped requirements in Test Manager projects that
are configured for integration with Telelogic DOORS.

Upload Requirements

Indicates whether or not the Enable upload of
requirements to Telelogic DOORS option is active. Enables
the upload of unmapped or unassigned requirements from
Test Manager to Telelogic DOORS. This allows you to
upload additional previously unmapped requirement trees
to DOORS and then have those requirements mapped within
Test Manager. When this option is enabled, the Map
Requirement button in Requirements ➤ Properties
becomes enabled, enabling configuration of top level
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Item

Description
requirements for external requirement types, which is
required when uploading unmapped requirements.

Property Mappings

Lists any external to internal property mappings that have
been defined between the internal and external requirements
management systems.

Issue Tracking Profiles
Issue tracking profiles enable Test Manager to integrate with external issue tracking systems. The following
issue tracking software packages are currently supported by Test Manager “out of the box”:
•
•
•
•
•
•
•
•

SilkCentral Issue Manager
Borland StarTeam
IBM Rational® ClearQuest®
Issue Tracking Web Service. For additional information, refer to the Test Manager API Help.
Bugzilla
Atlassian JIRA
Microsoft Team Foundation Server
Compuware Changepoint

Additional issue tracking systems can be configured by installing a custom plug-in. For additional information,
refer to the SilkCentral Issue Manager API Help. Defining issue tracking profiles allows you to link test definitions
within the Test Plan unit to issues in third-party issue-tracking systems. Linked issue states are updated
periodically from the third-party issue tracking system.

Mapping Issue States
After defining a new issue tracking profile, you should map the existing issue states of the external issue
tracking system to the issue states of Test Manager. Doing this enables Test Manager to list issues correctly
when querying internal and external issues.
To map issue states:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. In the Actions column of the issue tracking profile you want to edit, click Edit mapping of issue tracking
profile ....
The Edit Status Mapping dialog box opens.
4. Map internal issue states to corresponding external issue states by selecting the respective entries from
the list boxes.
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The existing issue states of the external issue tracking software are listed in the External column. The
internal issue states of Test Manager are available in the list boxes in the Internal column.
5. Once you have mapped each external issue state to an internal state, click OK to save your settings, or
click Cancel to abort the operation.

SilkCentral Issue Manager
This section describes how to configure SilkCentral Issue Manager issue tracking profiles to integrate with
Test Manager.
SilkCentral Issue Manager is a robust issue tracking tool that manages bug fixes and enhancement issues
related to your company’s software projects. Being fully customizable, SilkCentral Issue Manager meets the
challenges of your business environment - working across multiple products, releases, and locations. Because
SilkCentral Issue Manager’s flexible defect tracking workflow allows development and quality assurance to
work more closely together, it increases productivity, resulting in an improved development process.
For a list of the SilkCentral Issue Manager versions that are supported for integration with Test Manager, refer
to the Test Manager Release Notes.
Adding SilkCentral Issue Manager Issue Tracking Profiles
To add a SilkCentral Issue Manager issue tracking profile:
1. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
2. Click New Profile to open the New Issue Tracking Profile dialog box.
3. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
4. Type a Description for the new profile.
5. Select Issue Manager from the Type list box, or select Issue Manager 3.3 to connect to an Issue Manager
version 3.3 installation.
6. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
7. Type the Issue Manager URL of your Issue Manager installation. This is the URL you use to login to Issue
Manager, though without the login extension at the end.
For example, if your standard Issue Manager URL is http://IssueManager/login, then the correct
service URL is http://IssueManager.
8. If you selected Issue Manager 3.3 from the Type list box, proceed with the next step.
If you selected Issue Manager from the Type list box, proceed as follows:
1. Click Load Projects. This action will populate the Project list box with all initialized Issue Manager
projects to which the specified user has access to. Note that only those projects display for which Issue
Manager user groups have been defined, and the defined user is a member of at least one user group.
2. Select the Project where Issue Manager issues are maintained.
Caution: We recommend not to use identical projects for Issue Manager and Test Manager, as this
limits flexibility in working with both tools on different future projects.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
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Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
10. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing SilkCentral Issue Manager Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing Issue Manager issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Issue Manager URL of your Issue Manager installation if the location has changed.
This is the URL you use to login to Issue Manager, though without the login extension at the end. For
example, if your standard Issue Manager URL is http://IssueManager/login, then the correct service
URL would be http://IssueManager.
9. To change the StarTeam project, click Load Project to load all projects from the server and update the
Project list box, then select a project from the Project list box.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.
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StarTeam Issue Tracking Profiles
This section describes how to configure StarTeam issue tracking profiles to integrate with Test Manager.
StarTeam is a software change management and configuration management tool that enables coordination
and management of the software delivery process.
To work with StarTeam profiles and use the go-to-link functionality for change requests in StarTeam, you must
have the StarTeam Cross-Platform Client software installed on the computer where the browser is running.
For a list of the StarTeam versions that are supported for integration with Test Manager, refer to the Test
Manager Release Notes.
Adding StarTeam Issue Tracking Profiles
To add a StarTeam issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Type a Description for the new profile.
6. Select StarTeam from the Type list box
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Type the Hostname of your StarTeam server and the Port that is used to connect to the server. If this
setting has not been changed, use the default port 49201.
9. Specify the type of Encryption that the profile supports.
10. Click Load Project to load all projects from the server and populate the Project list box, then select a
project from the Project list box.
11. Click Load View to load all views for the selected project and populate the View list box, then select a view
from the View list box.
12. Click Load Status Field to load all enumeration fields for change requests and populate the Status Field
list box, then select a status field from the Status Field list box.
If you are using a custom workflow in StarTeam, this field is the workflow driver field in StarTeam that maps
to the Test Manager issue state.
13. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
14. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
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•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing StarTeam Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing StarTeam issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Hostname of your StarTeam server and the Port that is used to connect to the server.
9. Modify the type of Encryption that the profile supports.
10. To change the StarTeam project, click Load Project to load all projects from the server and update the
Project list box, then select a project from the Project list box.
11. To change the view, click Load View to load all views for the selected project and populate the View list
box, then select a view from the View list box.
12. To change the workflow driver field, click Load Status Field to load all enumeration fields for change
requests and populate the Status Field list box, then select a status field from the Status Field list box.
If you are using a custom workflow in StarTeam, this field is the workflow driver field in StarTeam that maps
to the Test Manager issue state.
13. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
14. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

SilkCentral Test Manager 2010 R2

| 89

Atlassian JIRA
This section describes how to configure Atlassian JIRA (JIRA) issue tracking profiles to integrate with Test
Manager.
The JIRA plug-in relies on the SilkCentral Java API for integration. Test Manager communicates with JIRA
through the JIRA Web-service by using the Apache Axis library.
Note: See the sources of the package com.borland.sctm.issuetracking.jira to see how these
elements fit together.
For a list of the JIRA versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding Atlassian JIRA Issue Tracking Profiles
To integrate Test Manager with JIRA, enable the System Soap Services plug-in in JIRA. For detailed information,
refer to the JIRA documentation.
To add a JIRA issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Atlassian JIRA from the Type list box.
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Type the Hostname of your JIRA server and the Port that is used to connect to the server.
9. Click Load Project to load all projects from the server and populate the Project list box, then select a
project from the Project list box.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•
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Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.
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Editing Atlassian JIRA Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing Atlassian JIRA issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Hostname of your JIRA server and the Port that is used to connect to the server.
9. To change the JIRA project, click Load Project to load all projects from the server and update the Project
list box, then select a project from the Project list box.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Bugzilla
This section describes how to configure Bugzilla issue tracking profiles to integrate with Test Manager.
The Bugzilla plug-in relies on the SilkCentral Java API for integration. Test Manager communicates with Bugzilla
through the XML-RPC Bugzilla Web-service introduced with Bugzilla 3.0 by using the Redstone XML-RPC
library. To enable Bugzilla integration, ensure that you have installed a SOAP::Lite package for the web server.
For example, for the Debian distribution install the libsoap-lite-perl package.
Note: See the sources of com.segue.scc.issuetracking.bugzilla3.Bugzilla3Profile and
com.segue.scc.issuetracking.bugzilla3.Bugzilla3Issue to see how these elements fit
together.
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For a list of the Bugzilla versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding Bugzilla Issue Tracking Profiles
To add a Bugzilla issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Bugzilla from the Type list box.
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Enter the URL of your Bugzilla installation. For example, http://bugzillaserver/cgi-bin/bugzilla3.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
10. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing Bugzilla Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing Bugzilla issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
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This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the URL of your Bugzilla installation.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
10. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

IBM Rational ClearQuest
This section describes how to configure IBM Rational ClearQuest issue tracking profiles to integrate with Test
Manager.
IBM Rational ClearQuest products provide flexible defect/change tracking and automated workflow support.
The two key products are IBM Rational ClearQuest (ClearQuest) and IBM Rational ClearQuest MultiSite
(ClearQuest Multisite). To work with ClearQuest profiles, you must have the ClearQuest client software installed
on the computer where the SilkCentral front-end server is running. For detailed information about installing
ClearQuest, refer to the ClearQuest documentation.
For a list of the ClearQuest versions that are supported for integration with Test Manager, refer to the Test
Manager Release Notes.
Adding ClearQuest Issue Tracking Profiles
To add a ClearQuest issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select IBM Rational ClearQuest from the Type list box.
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
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8. Enter the Repository Info of your ClearQuest installation.
This is the database name that is defined in the ClearQuest client software.
9. Specify the Record Type, which is the issue type of ClearQuest.
When entering an issue in Test Manager, ClearQuest will save the issue with the issue type you define in
this text box. The default issue type is Defect.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing ClearQuest Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing ClearQuest issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Repository Info of your ClearQuest installation.
This is the database name that is defined in the ClearQuest client software.
9. Change the Record Type, which is the issue type of ClearQuest.
When entering an issue in Test Manager, ClearQuest saves the issue with the issue type you define in this
field.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
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Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Team Foundation Server
This section describes how to configure Team Foundation Server (TFS) issue tracking profiles to integrate
with Test Manager.
For a list of the TFS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding TFS Issue Tracking Profiles
Note: You need to configure a TFS proxy before you can add a new TFS issue tracking profile.
To add a TFS issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Team Foundation Server 2010 from the Type list box.
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Type the Domain of the TFS user.
9. Enter the URL of your TFS installation.
For example, http://tfsserver:8080/tfs.
10. Type the Collection to which your project belongs.
For example DefaultCollection.
All projects in the collection are listed in the Projects list box.
11. Select the Project from the list box.
12. Type the URL of your TFS proxy. For example
http://tfsproxyserver/DotNetTfsWebServiceProxy_deploy/TfsWebServiceProxy.asmx.
13. Click Load Work Item Type.
The Work Item Type list box is populated with the available work item types.
14. Select the Work Item Type from the list box.
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15. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
16. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Installing a TFS Proxy Service
To communicate with a TFS, you need to install a TFS proxy service as an interface to the TFS.
To install a TFS proxy service:
1. Install Microsoft Visual Studio Team Explorer 2010 from
http://www.microsoft.com/downloads/details.aspx?FamilyID=fe4f9904-0480-4c9d-a264-02fedd78ab38.
2. Install IIS and the Web Deployment Tool, for example with the Web Platform Installer from
http://www.microsoft.com/web/downloads/default.aspx.
3. Open a command shell and type DotNetTfsWebServiceProxy.deploy.cmd /Y to install the proxy
service. If an an error message box displays, stating that ASP.NET 4 is required, refer to
http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx.
4. Open the IIS Manager.
5. Verify that the new website exists.
6. In the root folder of the virtual directory, open the Web.config file.
7. In the appSettings section of the file, modify the value of the key WorkItemTrackingCacheRoot to a local
directory.
For example:
<appSettings>
<add key="WorkItemTrackingCacheRoot" value="C:\temp" />
</appSettings>
8. If the directory you have specified does not exist, create it.
9. Grant Everyone full rights on the specified directory.
For additional information on deploying an ASP.NET Web Application, refer to
http://msdn.microsoft.com/en-us/library/ee942158.aspx.
Editing TFS Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing TFS issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
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The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Domain of the TFS user.
9. Edit the URL and Collection of your TFS installation.
10. Select a different Project.
11. Edit the URL and port of your TFS proxy.
12. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

Changepoint
This section describes how to configure Changepoint issue tracking profiles.
Changepoint is an IT management and governance tool that enables organizations to maximize the business
value of the entire IT portfolio including projects, applications, and infrastructure.
This integration allows you to connect Test Manager to Changepoint to store issues.
Important: The Changepoint environment must have the Changepoint API installed and the
CPWebService configured.
Known Issues
Workflow

Do not change the Changepoint workflows for requests after submitting them in Test Manager.
Do not use different workflows in requests when assigning external issues. The filter criteria
used in workflows should be based on fields used in the Test Manager Issue Tracking
Profile. Otherwise, unexpected states may be assigned to requests in Test Manager.

Synchronizing the Time for the Changepoint and Test Manager Servers
This section describes how to ensure that the Changepoint server and Test Manager server communicate
properly.
1. Open the web.config file located in the ../Changepoint/CP Web Services directory.
2. Add the following key to the security section:
<timeToleranceInSeconds>86400</timeToleranceInSeconds>
3. Save the file.
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Opening Changepoint Issues in Context
In order to open Test Manager issues in the Changepoint system, you need to follow the steps below to install
a connection file on the Changepoint server.
1. In Test Manager, click Help ➤ Tools to view the Downloadable Client Tools page.
2. Click the Changepoint Request Form link.
3. When prompted, choose to save the ChangepointRequestForm.zip file to disk.
4. Extract CPRequestForm.html from ChangepointRequestForm.zip.
5. CPRequestForm.html needs to be manually copied to the Changepoint server and placed into the virtual
directory in which Changepoint is running.
Creating a Changepoint Issue Tracking Profile
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Compuware Changepoint from the Type list box.
7. Type a valid Username and Password for the issue tracking system.
Note: In order to select a project and to submit a new issue, the Username field must contain a
Changepoint user who has the project's Edit Project Plan permission.
8. Enter the URL of your Changepoint installation in the Changepoint Server URL field.
9. Enter the URL of your Changepoint web service server in the Changepoint WebSerivce URL field.
10. Click Load Initiator to load your Changepoint initiators.
11. Select an initiator from the Initiator list box.
12. Click Load Client to load your Changepoint clients.
13. Select a client from the Client list box.
14. Click Load Initiative to load your Changepoint initiatives.
15. Select an initiative from the Initiative list box.
16. Click Load Project to load your Changepoint projects.
17. Select a project from the Project list box.
18. Click Load Request Type to load your Changepoint request types.
19. Select a request type from the Request Type list box.
20. Click Load Application to load your Changepoint applications.
Select an application from the Application list box.
21. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
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Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
22. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Deleting Issue Tracking Profiles
To delete an issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. In the Actions column of the issue tracking profile you wish to delete, click Delete issue tracking profile
....
A confirmation dialog box displays.
4. Click Yes.

Issue Tracking Profiles Page
Test Manager ➤ Settings ➤ Issue Tracking
Use this page to configure profiles for the integration of external issue tracking systems into Test Manager.
Click New Profile to create a new issue tracking profile. For each issue tracking profile, the page displays the
following columns:
Column

Description

Name

The name of the profile as it displays in the SilkCentral GUI
and in reports. Click the name to edit a profile.

Type

The external issue tracking system.

Login

The login name with which SilkCentral connects to the issue
tracking system.

Repository Info

The physical location of the issue tracking system. Hostname
or URL.

Created On

Date when the issue tracking profile was created.

Created By

The user who created the issue tracking profile.
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Column
Actions

Description
The following actions can be performed on an issue tracking
profile:
•
•

Delete issue tracking profile
Edit mapping of issue tracking profile

Source Control Profiles
Source control profiles enable Test Manager to integrate with external source control systems. Defining source
control profiles allows you to define where Test Manager’s execution servers should retrieve program sources
for test execution.
You need double the amount of free disk space on the execution server to accommodate the source files
because SilkCentral checks out the source control tree and then generates a working directory with the
executable source files.
The following source control systems are currently supported by Test Manager “out of the box”:
•
•
•
•
•
•
•
•
•

Borland StarTeam
SilkTest Workbench
Serena® Version Manager™ (PVCS®)
Concurrent Version System (CVS)
Microsoft® Visual SourceSafe® (MSVSS)
Universal Naming Convention (UNC) (file-system access)
Subversion
Apache Commons Virtual File System (VFS)
TestPartner

Additional source control systems can be configured by installing a custom plug-in. For detailed information,
refer to the Test Manager API Help.

TestPartner
This section describes how to configure TestPartner source control profiles.
TestPartner is a Micro Focus product that tests Web- and Microsoft Windows-based applications that use
Microsoft technologies. TestPartner records user actions to quickly produce powerful tests. Each recorded
test displays as a series of actions in clear, concise steps that can be easily understood by all testers, from
novice to expert. You can record user sessions with the application, add validation functions, and replay the
sessions later to ensure that the application works as expected.
Adding TestPartner Source Control Profiles
To create a TestPartner source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
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The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select TestPartner from the Source control system list box.
Note: When connecting to a TestPartner Oracle database, there is a TestPartner requirement that
the TNS name must be the same as the host server name.
6. Select a database type from the Database type list box, either SQL Server or Oracle.
7. Type the name of the database server in the Database server text box.
8. Type the name of the database in the Database name text box.
9. Type the port number of the database server in the Database port text box.
10. Type the database schema or owner name in the Database schema/owner name text box.
11. Type the name of the database user in the Database user text box.
12. Type the password for the database user in the Database password text box.
13. Type a valid Username and Password.
These credentials will be used to access your repository.
14. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
15. Use the Project path text box to filter which scripts from the database are available to use as tests. Click
Browse to display the Select Project Path dialog box.
The Select Project Path dialog box provides a tree of three levels that you can choose from:
First level

The entire TestPartner database. Note that if you select this level, the
Project path text box will remain blank.

Second level

The TestPartner project.

Third level

The script type within a specified TestPartner project.

Select one of the preceeding options and click OK. The path will be added to the Project Path text box.
16. Click OK.
Editing TestPartner Source Control Profiles
To modify a TestPartner source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
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This is the name that is displayed in the Test Manager GUI.
5. Choose from the following options:
•
•
•
•
•
•
•

Edit the TestPartner Database type.
Edit the TestPartner Database server.
Edit the TestPartner Database name.
Edit the TestPartner number of the TestPartner database server.
Edit the TestPartner Database schema/owner name.
Edit the TestPartner Database user.
Edit the TestPartner Database password.

6. Edit the Username and Password.
These credentials are used to access your repository.
7. Edit the Project path you want this profile to use.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Click OK.

Serena Version Manager (PVCS)
This section describes how to configure Serena Version Manager (PVCS) source control profiles.
Serena Version Manager, from the makers of PVCS, is the full-featured solution for version control and revision
management in software projects. More than simply storing code revisions, Version Manager is a robust,
full-featured solution with security, high performance, and varying levels of support for distributed teams. For
information on the supported versions, refer to the Test Manager Release Notes.
Adding PVCS Source Control Profiles
To create a PVCS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select PVCS from the Source control system list box.
6. Type the UNC path of the PVCS Repository you want to access.
If you do not know the UNC path of the repository, consult your PVCS administrator.
7. Type a valid UNC username and UNC password.
These credentials are required to access the UNC path of the configuration file.
8. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
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9. Type the Execution path. This is the local path of the PVCS installation, where the command line tool
pcli.exe is located. The default path is C:\Program Files\Serena\vm\win32\bin.
Note: The PVCS client software must be installed on the front-end server and each execution server.
PVCS must be installed in identical paths on each machine. For example, if you install PVCS on the
TestPartner front-end server to C:\Program Files\Serena\, you must install PVCS in the same
path on the execution servers.
10. Type a valid Username and Password.
These credentials will be used to access your repository.
11. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
12. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing PVCS Source Control Profiles
To modify a PVCS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the UNC path of the PVCS Repository.
If you do not know the UNC path of the repository, consult your PVCS administrator.
6. Edit the UNC username and UNC password as required.
These credentials are required to access the repository UNC path you specified above.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Edit the Execution path. This is the local path of the PVCS installation, where the command line tool
pcli.exe is located. The default path is C:\Program Files\Merant\vm\win32\bin.
Note: The PVCS client software must be installed on the front-end server and each execution server.
PVCS must be installed in identical paths on each machine. For example, if you install PVCS on the
Test Manager front-end server to C:\Program Files\Serena\, you must install PVCS in the same
path on the execution servers.
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9. Edit the Username and Password.
These credentials are used to access your repository.
10. Edit the Project path you want this profile to use.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

StarTeam Source Control Profiles
This section describes how to configure StarTeam source control profiles.
StarTeam promotes team communication and collaboration through centralized control of all project assets.
Protected yet flexible access ensures that team members can work whenever and wherever they like through
an extensive choice of Web, desktop, IDE, and command-line clients. StarTeam offers a uniquely comprehensive
solution that includes integrated requirements management, change management, defect tracking, file versioning,
threaded discussions, and project and task management.
For a list of the StarTeam versions that are supported for integration with Test Manager, refer to the Test
Manager Release Notes.
Adding StarTeam Source Control Profiles
To create a StarTeam source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select StarTeam from the Source control system list box.
6. Type the Hostname of your StarTeam server.
7. Type the Port that is to be used to connect to the StarTeam server.
If the port is not changed, use the default port 49201.
8. Type a valid Username and Password.
These credentials will be used to access your repository.
9. Specify if the profile supports Encryption.
10. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
11. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
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The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
12. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing StarTeam Source Control Profiles
To modify a StarTeam source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Choose from the following options:
•
•
•

Edit the Hostname of your StarTeam server.
Edit the port that is to be used to connect to the StarTeam server. If the port is not changed, use the
default port 49201.
Specify if the profile supports Encryption.

6. Edit the Project path you want this profile to use.
7. Edit the Username and Password.
These credentials are used to access your repository.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Concurrent Version System (CVS)
This section describes how to configure CVS source control profiles.
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CVS is a powerful source control tool that handles complete source code trees. It can be customized using
scripting languages such as PERL and Korn. CVS is decentralized so that users can maintain their own source
directory trees. It also enables concurrent file editing.
For a list of the CVS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding CVS Source Control Profiles
To create a CVS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5.
6.
7.
8.

Choose CVS from the Source control system list box.
Type the CVS server name or IP address in the Hostname text box.
Type the port that is to be connected to in the Port text box.
Specify the connection method in the Method text box.
Currently, the ext, pserver, and local connection methods are supported.

This makes the Port setting optional.
9. Specify the URL of the CVS Repository you want to access.
For example, /var/lib/cvs. If you do not know the URL of the repository, please consult your CVS
administrator.
10. Type a valid CVS Username and Password.
These credentials will be used to access your CVS repository.
Note: These settings are optional when using the ext connection method.
11. Specify the CVS Module that is to be used.
12. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
13. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
14. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
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Editing CVS Source Control Profiles
To modify a CVS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Choose from the following options:
•
•
•
•

Edit the CVS server name or IP address in the Hostname text box.
Edit the port that is to be connected to in the Port text box.
Edit the URL of the CVS Repository you want to access. If you do not know the URL of the repository,
consult your CVS administrator.
Edit the CVS Module that is to be used.

6. Edit the Username and Password.
These credentials are used to access your issue tracking system.
Note: These settings are optional when using the ext connection method.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Specify the connection method in the Method text box.
Currently, the ext, pserver, and local connection methods are supported.
This makes the Port setting optional.
9. Edit the Project path you want this profile to use.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Microsoft Visual SourceSafe
This section describes how to configure Microsoft Visual SourceSafe (MSVSS) source control profiles.
MSVSS is a version-control system for managing software and Web-site development. Fully integrated with
the Visual Basic-, Visual C++-, Visual J++-, Visual InterDev-, and Visual FoxPro development environments,
as well as with Microsoft Office applications, MSVSS provides easy-to-use, project-oriented version control.
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MSVSS works with any file produced with any development language, authoring tool, or application. Users
can work at both the file and project level while promoting file reuse.
For a list of the MSVSS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding MSVSS Source Control Profiles
Tip: SourceSafe clients must be installed on all front-end, application, and execution servers.
To create a MSVSS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select MSVSS or MSVSS (cmd line) from the Source control system list box.
MSVSS (cmd line) utilizes the MSVSS command line plug-in, which works exactly like MSVSS, except
that SilkCentral users are automatically logged out of MSVSS when the user logs out from SilkCentral.
When selecting MSVSS, SilkCentral users remain logged in to MSVSS for an indefinite time.
6. If you selected MSVSS (cmd line), specify the location of the SourceSafe executable ss.exe.
SourceSafe must be installed identically on all execution servers and the front-end server. This allows you
to specify a definite path. For example, C:\Program Files\Microsoft Visual
Studio\VSS\win32\ss.exe. If SourceSafe is installed in different locations, see Configuring the location
of a SourceSafe Client.
7. In the SourceSafe database (srcsafe.ini) text box, type the UNC path and file name of the SourceSafe
configuration file you want to access or click Browse to locate the SourceSafe configuration file..
Note: SourceSafe configuration files use the name srcsafe.ini.
8. Type a valid UNC username and UNC password.
These credentials are required to access the UNC path of the configuration file.
9. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
10. Type a valid Username and Password.
These credentials will be used to access your repository.
11. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
12. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
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Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing MSVSS Source Control Profiles
To modify a MSVSS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. If you selected MSVSS (cmd line), specify the location of the SourceSafe executable ss.exe.
SourceSafe must be installed identically on all execution servers and the front-end server. This allows you
to specify a definite path. For example, C:\Program Files\Microsoft Visual
Studio\VSS\win32\ss.exe. If SourceSafe is installed in different locations, see Configuring the location
of a SourceSafe Client.
6. In the SourceSafe database (srcsafe.ini) text box, edit the UNC path and file name of the SourceSafe
configuration file, or click Browse to locate the file.
If you do not know the location of the configuration file, consult your SourceSafe administrator.
Note: SourceSafe configuration files use the name srcsafe.ini.
7. Edit the UNC username and UNC password.
These credentials are required to access your configuration file’s UNC path.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Edit the Username and Password.
These credentials are used to access your repository.
10. Edit the Project path you want this profile to use.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Configuring the Location of a SourceSafe Client
To configure the location of a SourceSafe client:
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1. In the SourceSafe executable text box, type ss.exe without any path information.
2. On each execution server and on the front-end server, type the local path of the SourceSafe executable
ss.exe to the Windows system path. To do this, click Start ➤ Settings ➤ Control Panel ➤ System.
The System Properties dialog box displays.
3. Click the Advanced tab and click Environment Variables.
The Environment Variables dialog box displays.
4. Select the Path variable in the System variables section and click Edit.
5. Add the local path of the SourceSafe executable to the list of existing Variable values. You can append a
new variable value to existing values by entering a semicolon (;) followed by the path information.
6. Repeat this procedure for each execution server and for the front-end server.

Subversion
This section describes how to configure Subversion (SVN) source control profiles.
Subversion (SVN) is the successor to the Concurrent Versions System (CVS). Subversion manages versions
using transaction numbers. With each commit, the transaction number is incrementally increased.
What other source control systems call labels, Subversion refers to as tags. These tags are encoded in the
Subversion URL. For example, http://MyHost/svn/MyApp/trunk is a Subversion URL and
http://MyHost/svn/MyApp/tags/build1012 is a Subversion tag.
Test Manager supports Subversion tags. If a Subversion URL contains the trunk directory, you can define
a label tags/build1012. This label replaces trunk in the Subversion URL.
Note: If a Subversion URL does not contain trunk and you define a label, Test Manager throws an error.
Adding Subversion Source Control Profiles
To create a Subversion source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Choose Subversion from the Source control system list box.
6. Type the URL of the Subversion Repository you want to access.
If you do not know the URL of the repository, consult your Subversion administrator.
Note: To use SSH, add ssh to the URL, for example svn+ssh://<hostname>:<port>.
7. Type a valid Username and Password.
These credentials will be used to access your repository.
8. Type a valid SSH username and SSH password or SSH keyfile.
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These credentials are used to access the SSH server. The password overrides the keyfile, so if you only
have a keyfile, leave the SSH password text box empty. If you use a keyfile, the path to the keyfile must
be valid on every execution server that uses the source control profile.
9. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
10. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing Subversion Source Control Profiles
To modify a Subversion source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the URL of the Subversion repository you want to access.
If you do not know the URL of the repository, please consult your Subversion administrator.
Note: If you cannot check out files, when editing the URL of the Subversion Repository, delete the
source control mirrors directory on your execution server. For example, C:\Documents and
Settings\All Users\Application Data\Silk\SCC35\SrcCtrlMirrors.
Note: To use SSH, add ssh to the URL, for example svn+ssh://<hostname>:<port>.
6. Edit the Username and Password.
These credentials are used to access your repository.
7. Type a valid SSH username and SSH password or SSH keyfile.
These credentials are used to access the SSH server. The password overrides the keyfile, so if you only
have a keyfile, leave the SSH password text box empty. If you use a keyfile, the path to the keyfile must
be valid on every execution server that uses the source control profile.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
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9. Edit the Project path you want this profile to use.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Universal Naming Convention
This section describes how to configure Universal Naming Convention (UNC) source control profiles.
Short for Universal Naming Convention or Uniform Naming Convention, UNC is a PC format for specifying the
location of resources on a local-area network (LAN). UNC uses the following format:
\\server-name\shared-resource-pathname.
For example, to access the file test.txt in the directory examples on the shared server silo, you would
write: \\silo\examples\test.txt.
You can also use UNC to identify shared peripheral devices, such as printers. The idea behind UNC is to
provide a format so that each shared resource can be identified with a unique address.
UNC is only supported on Microsoft Windows operating systems. If you plan to use a non-windows execution
server you can use the Apache Commons VFS source control profile instead.
Adding UNC Source Control Profiles
To create a UNC source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select UNC from the Source control system list box.
6. Type the UNC path that you want to access.
This is the path to the location where your test definition sources are located.
7. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Type a valid UNC username and UNC password.
These credentials are required to access the UNC path of the configuration file.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
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Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing UNC Source Control Profiles
To modify a UNC source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the UNC path.
This is the path to where your test definition sources are located.
6. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
7. Edit the UNC username and UNC password.
These credentials are required to access your configuration file’s UNC path.
8. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Apache Commons Virtual File System
This section describes how to configure Virtual File System (VFS) source control profiles.
A VFS is an abstraction layer on top of a more concrete file system. The purpose of a VFS is to allow client
applications to access different types of concrete file systems in a uniform way. Apache Commons VFS provides
a single API for accessing various file systems. It presents a uniform view of the files from various sources.
The protocols that are currently supported for VFS by Test Manager are:
Protocol

Description

http

Copies the given file. This protocol type is also supported for copying and unpacking ZIP,
JAR, or other zipped files. It is required to specify a .zip file on a http server. For example,
zip:http://myTestServer/myTests.zip.The .zip file will be extracted on the execution
server.
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Protocol

Description

ftp

Copies the given file. This protocol type is also supported for copying and unpacking ZIP,
JAR, or other zipped files.

smb

Server Message Block (smb) copies all files and folders. This protocol can be used instead
of a UNC profile. For example, the VFS smb path
smb://server-name/shared-resource-path is equivalent to the UNC path
\\server-name\shared-resource-path.

Note: When you create a new ProcessExecutor test that uses VFS for source control, you need to specify
the complete path to the executable in the Executable Name text box.
Adding VFS Source Control Profiles
To create a VFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select VFS from the Source control system list box.
6. Type the URL of the VFS Repository you want to access.
Specify the appropriate protocol type in the URL:
FTP

ftp://<ftp server URL>

HTTP

http://<http server URL>

SMB

smb://<Samba server url>

Note: HTTP, FTP and SMB are also supported for zipped files. In order to point to a zipped file the
URL must be adjusted to <zipped file type>:<protocol>://<server URL pointing to
zipped file> to include the type of the zipped file. For example,
zip:http://193.80.200.135/<path>/archive.zip or
jar:http://193.80.200.135/<path>/archive.jar.
7. Type a valid VFS Username and Password.
These credentials will be used to access your VFS repository. The SMB protocol allows including the domain
name in the username in the following form: domain/username.
8. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
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The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing VFS Source Control Profiles
To modify a VFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the URL of the VFS Repository you want to access.
6. Edit the Username and Password.
These credentials are used to access your repository.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Edit the Project path you want this profile to use.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

SilkTest Workbench
This section describes how to configure SilkTest Workbench source control profiles.
SilkTest Workbench is an automated testing tool that accelerates the functional testing of complex applications.
SilkTest Workbench provides support for testing applications developed in a wide variety of development tools
including Java, .NET, browser-based web applications, and COM components, including both ActiveX controls
and automation objects. With SilkTest Workbench, you can record user sessions with your applications to
create tests, enhance the test by adding validation and test logic, and play back tests to ensure that the
applications work as expected.
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Adding SilkTest Workbench Source Control Profiles
To create a SilkTest Workbench source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select SilkTest Workbench Test from the Source control system list box.
6. Select a database type from the Database type list box, either SQL Server or Oracle.
Note: The Microsoft Office Access database type is not supported. When connecting to a SilkTest
Workbench Oracle database, there is a SilkTest Workbench requirement that the TNS name must be
the same as the host server name.
7. Enter the name of the SilkTest Workbench database server in the Database server text box.
8. Enter the name of the SilkTest Workbench database in the Database name text box.
9. Enter the port number of the SilkTest Workbench database server in the Database port text box.
10. Enter the SilkTest Workbench database schema or owner name in the Database schema/owner name
text box.
11. Enter the name of the database user in the Database user text box.
12. Enter the password for the database user in the Database password text box.
13. Enter the name of a valid SilkTest Workbench user in the SilkTest Workbench User name text box.
14. Enter the password for the SilkTest Workbench user in the SilkTest Workbench password text box.
15. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
16. Click Retrieve.
All projects are listed in the Projects list.
17. Select one or more projects.
18. Click OK.
Editing SilkTest Workbench Source Control Profiles
To modify a SilkTest Workbench source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
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The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the SilkTest Workbench Database type.
Note: The Microsoft Office Access database type is not supported.
6. Choose from the following options:
•
•
•
•
•
•
•
•

Edit the SilkTest Workbench Database server.
Edit the SilkTest Workbench Database name.
Edit the Database port number of the SilkTest Workbench database server.
Edit the SilkTest Workbench Database schema/owner name.
Edit the SilkTest Workbench Database user.
Edit the SilkTest Workbench Database password.
Edit the SilkTest Workbench User name.
Edit the SilkTest Workbench Password.

7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Select one or more projects from the Projects list.
9. Click OK.

Microsoft Team Foundation Server 2010
This section describes how to configure Team Foundation Server (TFS) source control profiles.
For a list of the TFS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding TFS Source Control Profiles
To add a TFS source control profile, the Microsoft Visual Studio Team Explorer Everywhere 2010 command-line
client needs to be installed on the front-end server and every execution server, on which you want to use the
source control profile. You can download the CLC from the Microsoft Download Center.
To create a TFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select Team Foundation Server 2010 from the Source control system list box.
6. Enter the URL of your TFS installation.
For example, http://tfsserver:8080/tfs.
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7. Type the Domain of the TFS user.
8. Type a valid Username and Password.
These credentials will be used to access your repository.
9. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
10. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing TFS Source Control Profiles
To add a TFS source control profile, the Microsoft Visual Studio Team Explorer Everywhere 2010 command-line
client needs to be installed on the front-end server and every execution server, on which you want to use the
source control profile. You can download the CLC from the Microsoft Download Center.
To modify a TFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the URL of the TFS Repository you want to access.
6. Edit the Username and Password.
These credentials are used to access your repository.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Edit the Project path you want this profile to use.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
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If the trial connection is successful, you are returned to the Source Control page.

Deleting Source Control Profiles
To remove a source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. In the Actions column of the issue tracking profile you wish to delete, click Delete source control profile
....
A confirmation dialog box displays.
4. Click Yes.
You are returned to the Source Control page.

Source Control Profiles Page
Test Manager ➤ Settings ➤ Source Control
Use this page to configure profiles to integrate external source control systems with Test Manager. Click New
Profile to create a new source control profile. For each source control profile, the page displays the following
columns:
Item

Description

Name

The name of the profile as it displays in the SilkCentral GUI
and in reports. Click the name to edit a profile.

Type

The external source control system.

Working Folder

Local or mapped working folder to which temporary sources
are checked out to.

Created On

Date when the source control profile was created.

Created By

The user who created the source control profile.

Changed On

Date when the source control profile was last modified.

Changed By

The user who last modified the source control profile.

Actions

Delete source control profile

Data Sources for Data-Driven Tests
Data-driven tests are tests that are derived from values in an existing data source, such as a spreadsheet or
a database. The data sources are managed in a project-specific scope.
Tip: To aknowledge changes in your data source to Test Manager, you must synchronize your data
source profile with your data source whenever your data source is updated or changed.
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Configuring JDBC Data Sources
Caution: The concatenated length of all primary keys may not exceed 255 characters in length for JDBC
data sources.
To configure a JDBC data source:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Data Sources tab.
The Data Sources page displays, listing all of the data sources that have been created for the system.
3. Click New Data Source to open the New Data Source dialog box.
4. Type a Name for the data source.
5. From the Data source type list box, select JDBC.
Note: If you are setting up an ODBC data source, you need to manually insert your ODBC Driver
class and URL. For example, Driver class: sun.jdbc.odbc.JdbcOdbcDriver, URL:
jdbc:odbc:MyDatabaseName. You must also set up an ODBC data source in MS Windows in the
Administrative Tools. For more information, refer to Microsoft Windows Help. If you have your front-end
server and your application server on different machines, make sure that the name of your system
data source set-up in Microsoft Windows is the same as the ODBC data source. These names are
case-sensitive.
6. If you select JDBC as the Data source type, the Driver class text box is populated automatically. In the
URL text box, replace the host name value, <hostname>, with the name of the computer that is hosting
the data source and replace the database name value, <databasename>, with the name of the target
database.
7. In the Username and Password text boxes, enter valid database credentials.
8. Optional: If you are working with a database that includes multiple tables, and you want to narrow down
the data source to specific tables, you can browse to and select specific tables for inclusion:
1. Click [...] next to the Table filter text box.
2. The Select Table Filter dialog box displays. Select the tables that you want included as your data
source.
3. Click OK.
9. Optional: Key column selection is used by test definitions to define which worksheet columns within a data
source are used as primary key. This is helpful if your data source will undergo edits, for example when
you add or remove rows within a worksheet. Even if your data source is edited, test definitions will still be
able to identify which columns or rows should be used. Test definitions created from data-driven data
sources use key column values in their names, rather than column numbers.
To configure a key column:
1. Click [...] next to the Key column text box.
2. The Select Key Column dialog box displays. Select a column from the column list that is to act as a
key column.
3. Click OK.
10. Click OK on the New Data Source dialog box.
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Configuring Microsoft Excel or CSV Data Sources
Caution: Excel worksheets using password protection can not be configured as data sources for Test
Manager. Turn off a worksheet's password protection to use it as data source for data-driven testing.
Values within any cell of an Excel or CSV data source may not exceed 255 characters in length. Additionally,
the concatenated length of all primary keys may also not exceed 255 characters in length for Excel and
CSV.
To configure a Microsoft Excel or CSV data source:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Data Sources tab.
The Data Sources page displays, listing all of the data sources that have been created for the system.
3. Click New Data Source to open the New Data Source dialog box.
4. Type a Name for the data source.
5. From the Data source type list box, select MS Excel to configure a Microsoft Excel data source, or select
CSV to configure a CSV data source.
6. From the Source control profile list box, select the pre-configured source control profile that hosts your
data file. For detailed information regarding the configuration of source control profiles, see Source Control
Profiles.
7. Click Browse to open the Select Source Control Path dialog box. Browse to and select a data source file
of the selected type in your source control path.
8. Optional: MS Excel only. If you are working with an Excel spreadsheet that includes multiple worksheets,
and you want to narrow down the data source to specific worksheets, you can browse to and select specific
worksheets for inclusion. To do this:
1. Click [...] next to the Worksheet filter text box.
2. The Select Worksheet Filter dialog box displays. Select the worksheets that you want included as your
data source.
3. Click OK.
9. Optional: Key column selection is used by test definitions to define which worksheet columns within a data
source are used as primary key. This is helpful if your data source will undergo edits, for example when
you add or remove rows within a worksheet. Even if your data source is edited, test definitions will still be
able to identify which columns or rows should be used. Test definitions created from data-driven data
sources use key column values in their names, rather than column numbers.
Note: MS Excel only: If the data source includes multiple worksheets, only columns with identical
names are available to be defined as key columns.
To configure a key column:
1. Click [...] next to the Key column text box.
2. The Select Key Column dialog box displays. Select a column from the column list that is to act as a
key column.
3. Click OK.
10. Click OK on the New Data Source dialog box.
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Downloading Excel Files from a Data Source
Note: Files can not be downloaded from JDBC and ODBC data sources.
To download an Excel file from a data source:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Data Sources tab.
The Data Sources page displays, listing all of the data sources that have been created for the system.
3. Click the Download icon in the Actions column of the data source you want to download from.
The File Download dialog box displays.
4. Click Open to open the file immediately, or click Save to specify where on your local system you want to
save the file to.

Synchronizing Data Sources
You must synchronize a data source each time it is changed or updated, if you want to make SilkCentral aware
of the changes. Synchronizing a data source propagates recent changes to associated test definitions.
To synchronize an updated data source:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Data Sources tab.
The Data Sources page displays, listing all of the data sources that have been created for the system.
3. Click the Synchronize icon in the Actions column that corresponds to your data source to propagate the
updated file to the associated test definitions.
4. A confirmation dialog box displays, asking you to confirm the synchronization. Click Yes to synchronize all
test definitions with the updated data source, or click No to abort the synchronization.
Caution: When you synchronize a data source, all running executions depending on this data source
are aborted. Results of incomplete test definitions within these executions are lost.
5. Click OK on the success message dialog box.

Uploading Updated Excel Files to a Data Source
Note: Files can not be uploaded to JDBC and ODBC data sources.
To upload an updated Excel file to a data source:
1. Navigate to Test Manager ➤ Settings.
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Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Data Sources tab.
The Data Sources page displays, listing all of the data sources that have been created for the system.
3. Click the Upload icon in the Actions column of the data source you want to download from.
4. Click Browse... on the Upload File dialog box.
5. Select the updated Excel file that you want to replace the currently uploaded Excel file with. Click Open.
6. Click OK on the Upload File dialog box.
7. A confirmation dialog box displays, asking you to confirm the overwriting of the existing file. Click Yes to
continue.
8. After uploading the updated data source file, another dialog box displays, asking you if you want to
synchronize the test definitions with the updated data source. Click Yes to synchronize immediately, or
click No if you want to synchronize later.
Note: After uploading an updated data source file, you must synchronize the data source so that
associated test definitions are updated.

Deleting Data Sources
Note: Data sources that are being used by test definitions can not be deleted.
To delete a data source:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Data Sources tab.
The Data Sources page displays, listing all of the data sources that have been created for the system.
3. Click the Delete icon in the Actions column of the data source that you want to delete.
4. A confirmation dialog box displays. Click Yes to remove the data source, or click No to abort the deletion.

Data Sources Configuration Page
Test Manager ➤ Settings ➤ Data Sources
The Data Sources page lists all data sources that are configured for the integration of data-driven tests into
Test Manager. Click New Data Source to create a new data source. For each data source, the page displays
the following columns:
Column

Description

Name

The name of the data source as it displays in the SilkCentral
GUI and in reports. Click the name to modify the data source
settings.
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Column

Description

Type

Data source type:
•
•
•

CSV
JDBC
MS Excel

Created On

Date when the data source was created.

Created By

User who created the data source.

Changed On

Date when the data source was last modified.

Changed By

User who last modified the data source.

Actions

You can perform the following actions on a data source:
•
•
•
•

Delete
Download
Upload
Synchronize

Requirements
This section explains how to manage requirements in Test Manager.
The Requirements unit enables you to maintain control over system requirements during development. You
can manage the creation, modification, and deletion of requirements, associate test definitions with requirements,
track the change history, and generate test plans directly from requirement lists. As with all Test Manager
functionality, the Requirements unit is 100% Web enabled and accessible through a Web browser.

Managing Requirements
This section describes the tasks you can perform on requirements in Test Manager.

Creating Requirements
Note: Newly created Test Manager projects do not contain requirements.
To create a new requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Click New Requirement on the toolbar.
Note: If the project you are working with does not yet have any requirements associated with it, click
the <Click here to add Requirements> link in the Requirements tree to open the New Requirement
dialog box.
The New Requirement dialog box opens.
3. Type a meaningful Name and Description for the requirement.
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Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for description
text boxes.
4. Select the appropriate Priority, Risk, and Reviewed status from the list boxes.
5. If custom requirements have been defined, they are listed below the Reviewed list box. Type in the
corresponding text box any custom property data that you want tracked with this requirement.
Note: The Priority, Risk, Reviewed, and any Custom Property fields will be configured automatically
with the corresponding properties of the parent requirement if you check the Inherit from parent check
boxes for these properties.
6. Click OK to create a new top-level requirement. Alternatively, you can click OK and New Requirement to
both save the newly created requirement and open the New Requirement dialog box to create an additional
top-level requirement. Or, you can click OK and New Child Requirement to have the New Child
Requirement dialog box open after the new top-level requirement is created.

Creating Child Requirements
The hierarchical Requirements tree enables you to create both top-level requirements and child requirements,
which are sub-requirements of higher-level requirements. When you create a child requirement, you can specify
whether the child requirement inherits the properties of the parent requirement or not.
To create a child requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement under which you want to create a child requirement.
3. Click New Child Requirement in the toolbar.
The New Child Requirement dialog box opens.
4. Type a meaningful Name and Description for the requirement.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for description
text boxes.
5. For each of the available requirement property fields, define whether the child requirement should inherit
the values from the parent or not.
By default, all Inherit from parent check boxes are checked and all parent values are inherited. To specify
a property value other than that held by the parent, uncheck the corresponding Inherit from parent check
box to unlock that property’s list box or text box. Then select the specific value that the child requirement
is to have. In Document View, asterisks (*) are placed next to requirement properties for which values
have been inherited from parent requirements.
Note: You can create child requirements at any level in the tree view hierarchy other than the top
level. There is virtually no limit to the number of child requirements that can be inserted at a single
hierarchy level.

Editing Requirements
To edit the properties of a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
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3. Select the requirement in the Requirements tree.
4. Click the Properties tab.
The Properties page displays the properties of the selected tree-element.
5. Click Edit Properties.
The Edit Requirement dialog box opens.
Note: You can also access the Edit Requirement dialog box by clicking the Edit icon in the toolbar
or by right-clicking the requirement in the Requirements tree and selecting Edit.
6. Edit the values displayed on the Edit Requirements dialog box as required. The default behavior is to
inherit values from the parent requirement. Uncheck Inherited from parent check boxes to disable value
inheritance.
7. Click OK to save your changes.
Note: For details regarding creating, editing, and deleting custom requirement properties, see Custom
Requirement Properties.

Configuring Requirement Types
A requirement without a configured requirement type is not available for upload to a requirements management
system (RMS). When you import a requirement from an RMS, the appropriate requirement type is automatically
configured.
Note: For requirements with the type CaliberRM, Requisite Pro, and DOORS, you can only configure the
requirement type for top-level tree elements, which are requirements that are a direct child of the project
node. All other requirements share the requirement type of their parents.
To configure the type of a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Click the Properties tab.
The Properties page displays the properties of the selected tree-element.
4. Click Map Requirement to select a requirement type from the list. Requirement type is a categorization
used by CaliberRM, Requisite Pro, and DOORS, and is required for synchronization.
Note: Map Requirement is only enabled when external requirements integration is enabled in the
Requirements Management page of the Settings unit and the requirement has not been uploaded
to the external requirements management tool. Additionally, the option Enable upload of requirements
to... must be enabled.
5. Click OK to save your settings and close the dialog box.

Marking Requirements as Obsolete
Rather than deleting requirements, which destroys them permanently, it is sometimes preferable to mark them
as obsolete. Obsolete requirements can optionally be enabled for viewing or conversely hidden from view.
To mark a requirement as obsolete:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement in the Requirements tree.
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3.
Click
in the toolbar or right-click the requirement and select Delete.
4. Uncheck the Destroy permanently check box and click Yes.
Note: Obsolete requirements are displayed in italics in the Requirements tree.

Activating an Obsolete Requirement
To convert an obsolete requirement to active status:
1. Navigate to Test Manager ➤ Requirements.
2. Right-click on the obsolete requirement in the Requirements tree and select Recover.
Note: Obsolete requirements are displayed in italics in the Requirements tree.

Permanently Deleting an Obsolete Requirement
To permanently delete an obsolete requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement in the Requirements tree.
3.
Click
in the toolbar or right-click the requirement and select Delete.
4. Check the Destroy permanently check box and click Yes.
5. Click Yes on the Delete Requirement dialog box.

Requirements Toolbar Functions
Test Manager ➤ Requirements
The requirements toolbar provides important commands for managing your requirements.
Note: The commands in the requirements toolbar are also available through context menus in the
Requirements tree.
The following commands are included in the requirements toolbar:
Command

Icon

Description

Document View

Displays the Document View, which shows selected properties of all
requirements in a single view.

Requirements View

Displays the Requirements View, which enables you to drill deeply into
the properties of a single requirement.

New Requirement

Add a new requirement to the active project.

New Child Requirement

Add a new child requirement to the selected requirement.

Edit

Open the selected requirement for editing.

SilkCentral Test Manager 2010 R2

| 127

Command

Icon

Description

Delete

Marks the selected requirement in the tree as obsolete. The requirement
will subsequently be displayed in italics if you right-click the project node
and select Show obsolete Requirements. Check the Destroy
permanently check box on the Delete Requirement dialog box to
permanently delete a requirement from the system.

Cut

Cut a requirement element from the Requirements tree and save it to
the clipboard.

Copy

Copy a requirement element from the Requirements tree to the clipboard.

Paste

Paste a requirement element from the clipboard to the Requirements
tree.

Paste as Child

Paste a requirement from the clipboard as a child requirement to the
currently selected requirement.

Move Up

Move a requirement up within the Requirements tree.

Move Down

Move a requirement down within the Requirements tree.

Find

Search through all requirements in the active project based on
configurable parameters.

Replace

Replace instances of found values with a new value.

New Filter

Create a new custom filter for the Requirements tree.

Filters

Lists the available filters for the Requirements tree

Edit Filter

Edit the currently selected custom filter.

Delete Filter

Delete the currently selected custom filter.

Show Changes

Show recent changes to the Requirements tree.

Acknowledge

Acknowledge changes to the Requirements tree.

Show Direct Coverage
Show Full Coverage

Toggles between full and direct coverage modes. Full coverage mode
offers a cumulative view of test-definition-to-requirement coverage that
considers the status of all child requirements. In direct coverage mode,
the requirement status is calculated based on the test definitions that
are assigned directly to requirements.

Requirements Tree
Requirements are displayed, organized, and maintained through a hierarchical tree structure, the Requirements
tree. Each node in the Requirements tree represents a requirement. Each requirement can have any number
of child requirements associated with it. The Requirements tree enables you to organize requirements in any
number of hierarchical levels.
Note: When the Requirements tree includes more elements than can be displayed at once without
impacting response time, elements are displayed in increments. Page number links at the bottom of the
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tab allow you to browse through the elements included in the tree one page at a time. To display all
elements as a single list, select the [All] link.

Collapsing or Expanding the Requirements Tree
To collapse or expand the Requirements tree:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement folder in the Requirements tree and continue with one of the following options:
•

Click

•

to the left of the name of the requirement folder to expand the folder.

Click
to the left of the name of the requirement folder to collapse the folder.
Right-click on the folder and select Expand or Collapse.

•

Requirements Document View
Test Manager ➤ Requirements
Click Document View to access Document View
Document View displays the status of all tests that have been assigned to the active project, including the
number and percentage of Passed, Failed, Not Executed, and Not Covered tests. Document View
displays this coverage status information in a “heat field” chart, with the following colors:
Color

Description

Green

Passed tests.

Red

Failed tests.

Brown

Tests that are not executed yet.

Grey

Test with other status.

Requirements that are not covered by test definitions are listed as Not Covered.
Note: Test definition totals accumulate to the parent level. For example, the requirement totals include
test definitions from child requirements and the project totals include test definitions from all requirements.

Requirement Properties
You can add custom property fields across all requirements in the selected project in the Settings unit. Custom
properties can subsequently be edited alongside the default properties on the Edit Requirements dialog box.
Custom properties are displayed in Requirements View on the Properties page of the Requirements unit,
but not in Document View.
For additional information on custom requirement properties, see Custom Requirement Properties.

Replacing Requirement Properties
In the Requirements unit, you can locate requirements that meet certain search criteria with the Find command.
You can also replace identified property data with alternate data that you specify with the Replace command.
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Both commands offer Find Next and Find Previous functions that allow you to step through all identified
properties.
To replace a requirement property:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement in the Requirements tree.
3.
Click
on the toolbar.
Note: This command can also be executed by right-clicking a requirement and selecting Replace.
The Replace dialog box opens.
4. From the Find in list box, select a requirement property to be searched.
This list is automatically populated with all standard property fields and any custom property fields you may
have created.
5. Define your search criteria in the Find what portion of the dialog box.
The Find what portion of the dialog box offers fields and list boxes with pre-populated values that are based
on the property you select in the Find in list box above. The UI controls available in the Find what portion
of the dialog box also vary based on the property type selected in the Find in list box. For example, selecting
a custom date-type property enables one or more date fields. To specify an exact date, select exactly from
the Find in list box. Then click
next to the date field to specify a date using the calendar tool.
Alternatively, you can select before or after from the list box. To select a date range, select between from
the list box. Then click
next to the date fields to specify start and end dates. Selecting the Reviewed
property enables a list box from which you can select either Yes or No. Selecting the Requirement name
or Description property enables a text box in which you can enter a text string.
6. In the Replace with text box, enter the alternate property data that you want to have replace the identified
data.
7. Click OK to find the first instance of the property you want to replace.
The first requirement that meets the search criteria will be highlighted in the tree view.
8. Click Replace to replace only the selected instance of the property data. Click Replace all to replace all
instances of the property data throughout all requirements in the project.
Note: Using the Replace all option will overwrite inherited requirement properties with the new value,
thus removing the inheritance setting of a child requirement. Use the Replace option only on a parent
requirement if you want the child requirements to inherit the new value.
9. Click Find Next on the Find dialog box to advance to the next requirement in the list that meets your search
criteria. Or click Find Previous on the Find dialog box to return to the previous requirement in the list that
meets your search criteria.

Finding Requirement Properties
In the Requirements unit, you can locate requirements that meet certain search criteria with the Find command.
You can also replace identified property data with alternate data that you specify with the Replace command.
Both commands offer Find Next and Find Previous functions that allow you to step through all identified
properties.
To find a requirement:
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1. Navigate to Test Manager ➤ Requirements.
2. Select
on the toolbar to open the Find dialog box.
Note: This command can also be executed by right-clicking a requirement and selecting Find.
3. From the Find in list box, select a requirement property to be searched.
This list is automatically populated with all standard property fields and any custom property fields you may
have created.
4. Define your search criteria in the Find what portion of the dialog box.
The Find what portion of the dialog box offers fields and list boxes with pre-populated values that are based
on the property you select in the Find in list box above. The UI controls available in the Find what portion
of the dialog box also vary based on the property type selected in the Find in list box. For example, selecting
a custom date-type property enables one or more date fields. To specify an exact date, select exactly from
the Find in list box. Then click
next to the date field to specify a date using the calendar tool.
Alternatively, you can select before or after from the list box. To select a date range, select between from
the list box. Then click
next to the date fields to specify start and end dates. Selecting the Reviewed
property enables a list box from which you can select either Yes or No. Selecting the Requirement name
or Description property enables a text box in which you can enter a text string.
5. Click OK to begin your search. The first requirement that meets the search criteria will be highlighted in the
tree view.
The first requirement that meets the search criteria will be highlighted in the tree view.
6. Click Find Next on the Find dialog box to advance to the next requirement in the list that meets your search
criteria. Click Find Previous on the Find dialog box to return to the previous requirement in the list that
meets your search criteria.
Note: When you reach the last or first requirement that meets the search criteria and respectively click
Find Next or Find Previous, the search starts from the beginning.

Requirement Properties Page
Test Manager ➤ Requirements ➤ Properties
The Properties page displays high-level information about the selected requirement or project.
When requirements are synchronized with an external requirements management system, items are sometimes
marked with an exclamation mark (!). This means that the marked field is not mapped to the external
requirements management system. Use the property mapping feature to map property fields. If you don't use
the property mapping feature, only the name and the description of the requirements are mapped. For more
information, see Editing Property Mapping.
Item values that are marked with an asterisk (*) are values that are inherited from the parent requirement.
Click Edit Properties to edit the displayed properties.
The following table only applies to requirements that have a flag set.
Item

Description

Flagged By

Indicates who set the flag and when the flag was set.

Comment

Indicates the comments for the flag.
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Item

Description

Clear Flag

Click to remove the flag.

The following table lists the properties of the selected requirement or project that are displayed on the Properties
page.
Property

Description

Requirement Name

Name of the requirement.

Requirement ID

Identifier of the requirement.

Description

Description of the requirement.

Priority

Priority that has been configured for the requirement.

Risk

Risk that has been configured for the requirement.

Reviewed

Current review status of the requirement. Yes or No.

Custom Properties

If custom properties have been configured for the
requirement, they are listed here.

Document

Source document (if any) from which this requirement was
derived.

Created On

Date on which this requirement was created.

Created By

Name of the user who created this requirement.

Changed On

Date on which this requirement was last updated.

Changed By

Name of the user who last updated this requirement.

Requirement Attachments
You can upload multiple files or links as attachments to requirements or delete attachments. When you cut
and paste requirements that have attachments, the attachments are automatically included with the copies.
The following attachment types are available:
•
•
•

Uploaded Files (.gif, .png, .jpg, .doc, .rtf, .txt, .zip, .xls, .csv, and more)
References to UNC paths
References to URLs, including StarTeam URLs

Attaching a File to a Requirement
To attach a file to a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the requirement in the Requirements tree.
4. Click the Attachments tab.
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When requirements management integration has been enabled between a Test Manager project and a
CaliberRM project, the Attachments page includes an Open CaliberRM button, which enables you to
manage requirement attachments directly in CaliberRM.
5. Click Upload File
The Upload File dialog box opens.
6. Click Browse and select the file that you want to attach from your local file system.
7. Type a Description for the attachment.
8. Click OK.
The attachment is uploaded to the server and associated with the selected requirement.
Note: Attaching files to a requirement may not work in Mozilla Firefox. Firefox requires usage of three
slashes, for example file:///, for a file link, while other browsers require only two, for example file://.
Aditionally, Firefox includes a security feature blocking links from remote files to local files and directories.
For more information, see http://kb.mozillazine.org/Firefox_:_Issues_:_Links_to_Local_Pages_Don't_Work

Attaching a Link to a Requirement
To attach a link to a requirement
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the requirement in the Requirements tree.
4. Click the Attachments tab.
When requirements management integration has been enabled between a Test Manager project and a
CaliberRM project, the Attachments page includes an Open CaliberRM button, which enables you to
manage requirement attachments directly in CaliberRM.
5. Click Attach Link.
The Attach Link dialog box opens.
6. Type the URL in the Link text box.
7. Type a Description for the attached link.
8. Click OK.
The link is associated with the selected requirement.

Viewing a Requirement Attachment
To view a requirement attachment:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the requirement in the Requirements tree.
4. Click the Attachments tab.
When requirements management integration has been enabled between a Test Manager project and a
CaliberRM project, the Attachments page includes an Open CaliberRM button, which enables you to
manage requirement attachments directly in CaliberRM.
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A list of all attachments that are associated with the requirement opens. Each attachment name serves as a
link. File-attachment links open Save As dialog boxes, enabling you to download attachments to your local
file system. Link-attachments link directly to link destinations in newly spawned browser windows.

Deleting a Requirement Attachment
To delete a requirement attachment:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the requirement in the Requirements tree.
4. Click the Attachments tab.
When requirements management integration has been enabled between a Test Manager project and a
CaliberRM project, the Attachments page includes an Open CaliberRM button, which enables you to
manage requirement attachments directly in CaliberRM.
5.
Click
in the Actions column of the attachment that you want to delete.
6. Click Yes on the confirmation dialog to delete the attachment from the project.
Note: Only one attachment at a time can be deleted.

Requirement Attachments Page
Test Manager ➤ Requirements ➤ Attachments
The Attachments page lists files and links that are attached to the selected requirement. The attachments
are displayed in the order in which they are uploaded, though the list of attachments can be sorted by Name,
Created On, and Created By properties.
Note: To display any attachments that are associated with child requirements of the selected requirement,
check the Include Child Attachments check box.
Note: The file icons indicate whether documents are directly attached to the selected requirement, or
whether they are attached to a child requirement of the selected requirement.
Single icon

The file is directly attached to the selected requirement.

Double icon

The file is attached to a child requirement of the selected requirement.

The Attachments page displays the following columns for each listed attachment:
Column

Description

Actions

You can perform the following
actions to a requirement
attachment:
•

Attachment Icon
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Depends on the type of the
attachment.

Column

Description

Name

Name of the attachment.

Size

Size of the attachment.

Description

Description of the
attachment.

Created On

When the attachment was
created.

Created By

User who created the
attachment.

Working with Test Plans
This section describes how to use test plans in the Requirements unit.

Assigning Test Definitions from Grid View to Requirements
To assign one or more test definitions from the test plan Grid View to one or more requirements:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Select the test definitions that you want to assign to requirements.
You can use your keyboard's CTRL and SHIFT keys to select multiple test definitions using standard browser
multi-select functions.
4. Right-click the selected test definitions and select Save Selection.
5. Navigate to Test Manager ➤ Requirements.
6. Select the requirement to which you want to assign the selected test definitions.
7. Click the Assigned Test Definitions tab.
8. Click Assign Saved Selection.
Note: Only test definitions that reside in the requirements test container are assigned. You can assign
the selected test definitions to more than one requirement but you cannot assign them into requirements
in a different project. The selection persists until you make a different selection or close Test Manager.

Assigning Test Definitions to Requirements Manually
To manually assign test definitions to a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement in the Requirements tree.
3. Click
in the toolbar.
4. Click the Assigned Test Definitions tab.
All test definitions that are available for assignment are displayed in the Test Plan window.
5. If you have created a test definition filter, you can select it from the filter list above the Test Plan window.
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To create a new test definition filter, navigate to the Test Plan unit and click New Filter on the toolbar.
6.

Click

left of any test definition you want to assign to the currently selected requirement.

Clicking
left of a test container or test folder assigns the test definitions that are located in those
containers or folders to the selected requirement. Test definitions that are located within sub-folders of
those containers and folders are also assigned.

Locating Assigned Test Definitions in the Test Plan Tree
To locate an assigned test definition in the Test Plan tree:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select a requirement in the Requirements tree that has at least one test definition assigned to it.
4. Click the Assigned Test Definitions tab.
5.
In the Actions column of a test definition, click
to find out in which test folder or container the test
definition is stored in.
The corresponding test folder or container is highlighted in the Test Plan window.

Removing Test Definition Assignments
To remove a test-definition assignment:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select a requirement in the Requirements tree that has at least one test definition assigned to it.
4.
In the Actions column of the assigned test definition you want to remove, click
.
5. Click Yes on the confirmation dialog box to confirm deletion of the assignment.
Note: To remove all test-definition assignments from the selected requirement, click Remove All.

Generating Test Plans from Requirements View
You can generate test plans directly out of the Requirements tree and assign test definitions to specific
requirements. The Requirements tree serves as a template for the test-folder/test-definition structure of the
new Test Plan tree.
To generate a new test plan from Requirements View:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Right-click the requirement or project node that you want to convert into a test plan and select Generate
Test Plan.
The Generate Test Plan from Requirements dialog box displays. This dialog box enables you to specify
whether the leaves, which means the lowest-level nodes, of the selected requirements subtree should be
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converted into test definitions or test folders and whether the tree should be generated into a new test
container or an existing container.
4. Enter a name for the new test container in the Enter Name text box and select a product from the Select
Product list box to create the container within the active Test Manager project.
The Select Product list box is populated with the products that are configured by a project manager. For
detailed information, refer to the SilkCentral Administration Module Help or ask your project manager.
5. If you have defined a source control profile, select the source control profile you want to use for managing
the test definition sources from the Select Source Control Profile list box.
For detailed information on source control profiles, see Source Control Profiles or ask your Test Manager
administrator.
6. To include all child requirements of the selected requirement in the test plan, check the Include child
requirements check box.
The check box is checked by default.
7. To have the new test definitions automatically assigned to the requirements from which they are created,
check the Assign newly generated Test Definitions to Requirements check box.
If this option is not selected, test definitions must be manually associated with requirements.
Note: This option is not available when checking Generate Test Folders from Requirement Tree
leaves.
8. Click OK to create the test plan.
The new test plan has the same structure as the Requirements tree.
9. A message box displays, asking if you want to switch directly to the Test Plan unit. Click Yes to view the
test plan in the Test Plan unit, or click No to remain in the Requirements unit.

Assigned Test Definitions Page
Test Manager ➤ Requirements ➤ Assigned Test Definitions
The Assigned Test Definitions page lists all test definitions that are assigned to the selected requirement.
If a test definition is assigned to more than one execution definition and the Display in Execution Context
check box is checked, the test definition is displayed in a separate line of the grid for each execution definition.
All test definitions that are available for assignment are displayed in the right-hand Test Plan tree. To assign
a test definition to the selected requirement, double-click on the entry in the tree or click
entry.

to the left of the

If you have created a test definition filter, you can select it from the filter list above the Test Plan tree. To create
a new test definition filter, navigate to the Test Plan unit and click New Filter on the toolbar.
To automatically assign newly generated test definitions to the requirements from which they are generated,
check the Assign newly generated Test Definitions to Requirements check box on the Generate Test
Plan from Requirements dialog box.
The default view displays only those test definitions that are assigned directly to the selected requirement.
Check the Full Coverage check box to additionally display all test definitions that are assigned to child
requirements of the selected requirement. When Full Coverage is checked, test definitions that are not assigned
to the selected requirement, but are assigned to a child of the requirement, are displayed with an overlay over
the test-type icon.
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If you have copied a set of test definitions from the Test Plan unit's Grid View to the clipboard, click Assign
Saved Selection to assign the entire set to the selected requirement. Click Remove All to remove all assigned
test definitions from the requirement.
The Assigned Test Definitions page displays the following columns for each listed test definition:
Column

Description

Actions

You can perform the following
actions on an assigned test
definition:
•
•

Test Definition

Name of the assigned test
definition. Click to view and
edit the test definition. For
configuration testing, the test
definition is separately listed
for each configuration.

Execution Definition

This column is only displayed
if the Display in Execution
Context check box is
checked. Name of the
execution definition that
includes the assigned test
definition. For configuration
testing.

Execution Definition Parent

The configuration suite or
folder in the context of which
the execution definition is
executed. Click to access the
suite or folder in the
execution tree. If the
execution definition is not
included in a configuration
suite or folder, nothing is
displayed.

Status

Status of the assigned test
definition in each execution
definition to which the test
definition is assigned. To
display the status of all runs
of the displayed test
definitions in each execution
definition, check the Display
in Execution Context check
box.
•
•
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Passed
Failed

Column

Description
•
•

Not Executed
Not Scheduled

For test definitions or test
packages that are included in
a configuration suite, the
status is an aggregation of all
statuses of all configurations
within the suite:
•

If the test is assigned only
to the configuration suite,
the status is Passed
only if it is passed in all
configurations. If the
status is not Passed in
all configurations, the
status of the worst run is
propagated, with the
following top-down
priority:
1.
2.
3.
4.

•

•

Not Scheduled
Not Executed
Failed
Passed

The status of a
requirement that is
assigned to the test is
Failed if the test fails in
one or more of the
configurations.
We do not recommend to
assign the test to a
configuration suite and
one or more simple
execution definitions.
However, in this case, the
aggregate of the
configuration statuses is
one status, and the last
statuses of the execution
definitions are other
statuses. The status that
was executed last
determines the last status
of the test.
If the test is assigned to a
simple execution
definition only, the status
is updated in response to
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Column

Description
the status of the last test
run.

Last Execution

Time and date of the last
execution of the test
definition.

Issues

This column is only displayed
if the Display in Execution
Context check box is not
checked. Issues that are
associated with this test
definition.

Coverage
This section describes how to cover your requirements with tests.

Coverage Modes
Test Manager provides two modes for coverage. Full coverage and direct coverage.The status of a requirement
in the full coverage mode considers the status of the child requirements and offers a cumulative view of the
test definitions that cover the requirement. If one or more child requirements have the status Not Covered,
then the full coverage status of the selected requirement is also Not Covered, even if the coverage status
of the requirement is Covered. The full coverage mode enables easy evaluation of whether or not requirements
are covered by test definitions.
The status of a requirement in the direct coverage mode is calculated based only on the status of the test
definitions that are directly assigned to the requirement. Child requirements are not considered in calculations.

Switching Between Coverage Modes
To switch between full- and direct-coverage modes:
1. Navigate to Test Manager ➤ Requirements.
2. Click / to respectively view direct coverage or full coverage.

Coverage Page
Test Manager ➤ Requirements ➤ Coverage
The Coverage page, which you can access in Requirements View only, displays basic properties of the
selected requirement or project. It also displays the status of all tests that have been assigned to the requirement,
including the number and percentage of Passed, Failed, Not Executed, and Not Covered tests. A
summary of all assigned tests is listed under Total. Requirements that are not covered by test definitions are
listed as Not Covered.
The Requirements Document View displays the same coverage status information in a “heat field” chart.
To view the status of all tests that are assigned to child requirements of the selected requirement in addition
to all tests that are directly assigned to the requirement, check the Full coverage check box.

140

| SilkCentral Test Manager 2010 R2

Note: In both Document View and the Coverage page, test definition totals accumulate to the parent
level. For example, requirement totals include test definitions from child requirements and project totals
include test definitions from all requirements.
The Coverage page displays the following properties for each selected requirement or project:
Property

Description

Requirement Name

Name of the selected
requirement or project.

Project Name
Priority

Priority that has been
assigned to the selected
requirement.

Risk

Risk that has been assigned
to the selected requirement.

# Requirements (Calc.)

Total number of all covered
requirements. Not included in
this number are uncovered
requirements and folders that
do not have a test definition
assigned to them. For
example folders that inherit
the coverage of their child
requirements but are not
actually a requirement
themselves.

# Requirements (Total)

Total number of all
requirements beneath the
selected entity, including
folders.

Requirement Status
Project Status

Status of the selected
requirement or project.
•
•
•
•

Passed
Failed
Not Executed
Not Covered

# Requirements Passed

Total and percentage of
requirements in the project
that have test definitions that
have passed.

# Requirements Failed

Total and percentage of
requirements in the project
that have test definitions that
have failed.

# Requirements Not Executed

Total and percentage of
requirements in the project
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Property

Description
that have test definitions that
have not been executed.

# Requirements Not Covered

Total and percentage of
requirements in the project
that are not covered by test
definitions.

Total

Total number of requirements
in the project.

Requirement History
Test Manager provides a complete history of all changes that are made to requirements. History information
is read-only, and cannot be edited or permanently deleted.
The Recent Changes filter, which you can access by clicking
on the toolbar, enables you to efficiently
view and acknowledge the latest changes and additions that have been made to requirements.
Note: When you delete a requirement with the Destroy permanently option, you delete a requirement
that is marked as obsolete, or if you acknowledge all recent changes, a change history entry is added to
the history file of the project, to which the requirements belong.

Viewing Recent Changes
To view recent changes to requirements:
1. Navigate to Test Manager ➤ Requirements.
2.
Click
to filter out all requirements except those that have been changed since your last change
acknowledgement.
Note: The recent changes filter is selected automatically in the Filter list box.
3.
When you have reviewed the changes, you can accept them by clicking
The acknowledge function resets the recent changes filter.
4.
Click

again to remove filtering and see all requirements.

Tracking the History of a Requirement
To view a requirement’s history:
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the requirement in the Requirements tree.
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.

4. Click the History tab.
5. Optional: When requirements management integration between a Test Manager project and a CaliberRM
project is enabled, you can click Open CaliberRM in the History page to view the history of synchronized
requirements directly in CaliberRM.
The properties of all revisions that have been logged by Test Manager are displayed in tabular format.

Requirement History Page
Test Manager ➤ Requirements ➤

➤ History

The History page details the revision history of the selected requirement or project. The following actions
generate requirement history entries:
•
•
•
•
•
•

Adding a new requirement
Editing a requirement
Marking a requirement as obsolete
Adding an attachment to a requirement
Deleting an attachment from a requirement
Importing or updating a requirement through MS Word or MS Excel

For each change, the page displays the following columns:
Column

Description

Rev.

Revision number. 1-n.

Changed On

Date and time of the change.

Changed By

User that made the change.

Notes

Automatically generated description of the change. For
example, “deleted” or “created”.

Note: When the page includes more elements than can be displayed at once without impacting response
time, elements are displayed in increments. Page number links at the bottom of the page allow you to
browse through the elements included on the page one page at a time. To display all elements as a single
list, click the [All] link.

Requirement Change Notification
You can configure email notifications to alert you to changes that are made to requirement settings for specified
projects. For more information on change notification, see Change Notification.

Requirements Reports
This section describes the requirements-related reports that ship with Test Manager. Requirements reports
detail the status of functional requirements, for example compatibility requirements, GUI requirements, or
feature requirements, which must be met during development. Requirements may also relate to product
management objectives such as reliability, scalability, and performance.The requirement-management reports
help managers to determine if adequate test coverage is established to verify that system requirements are
met during development. When a report references a requirement that includes HTML-formatted content, that
content is rendered in the report.
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Status Reports
The following status reports are available for the Requirements unit:
Report

Description

Requirements Status
Overview

Represents a grouped summary of all requirements by current requirement
coverage. Coverage is expressed by the statuses Passed, Failed, Not
Executed, and Not Covered.

Top-Level Requirement
Coverage

Represents a listing of all top-level requirements. For each requirement the
number of covered and not-covered, by test definitions, child requirements is
displayed.

Status of Requirements
with Priority Higher than
'X'

Represents a summary of all requirements by current requirement coverage.
The returned group of requirements is restricted by the Priority parameter,
which specifies the lowest requirement priority that is considered in the data.

Requirement Impact
Analysis Report

Displays the test definition details grouped by the execution definition that is
associated to the requirement. This report allows the user to gain insight into
testing assets that may be impacted by a change to the requirement. The report
contains the name, status, date/time of last execution, manual testers, planned
time, and issues of each test definition. The following statuses are used:

Project Requirement
Traceability Report

Status

Description

Passed

The test definition passed.

Failed

The test definition failed.

Not Scheduled

The test definition is associated to a requirement but
is not submitted for execution.

Not Executed

The test definition is associated to a requirement and
is submitted for execution but not executed yet.

Displays all requirements in a project along with their associated test definitions
and issues. The following statuses are used:
Status

Description

Passed

The test definition passed.

Failed

The test definition failed.

Not Scheduled

The test definition is associated to a requirement but
is not submitted for execution.

Not Executed

The test definition is associated to a requirement and
is submitted for execution but not executed yet.

Progress Reports
The following progress reports are available for the Requirements unit:
Report

Description

Requirements Coverage Across Builds Represents a summary of all requirements by current requirement
'X' and 'Y'
coverage. The returned group of requirements is restricted by the
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Report

Description
Priority parameter, which specifies the lowest requirement
priority that is considered in the data.

Requirements Coverage Over the Past Represents a trend in requirements coverage by considering overall
'X' Days
requirements coverage over 'X' days.
Specific Requirements Coverage Over Represents a trend in requirements coverage by considering specific
the Past 'X' Days
requirements coverage over 'X' days.

Document Reports
The following document reports are available for the Requirements unit:
Report

Description

All Requirements

All requirements are represented with full requirement information.

Requirement with Child
Requirements

The selected requirement is shown with its requirement ID. Full details
regarding the requirement’s child requirements are displayed.

All Related Issues Report
The All Related Issues report provides a detailed list of all issues related to the assigned test definitions for a
requirement, and explains the relationship between requirements, the assigned test definitions, and issues
that have occurred.
Input Parameters
The input parameter for the All Related Issues report is the identifier of the requirement.
General Report Information
This section provides the following general information about the report:
Element

Description

Project Name

Name of the active project.

Report Description

Description of the report.

Report Executed By

User who executed the report.

Requirement Information
This section provides the following information about the requirement:
Element

Description

ID

Identifier of the requirement.

Name

Name of the requirement.

Description

Description of the requirement.

Test Coverage

Status of all test definitions that have been assigned to the requirement.

Nr. of Issues

Amount of issues related to the requirement or sub-requirements of the
requirement.
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Related Issues
Shows all issues related to the requirement or sub-requirements of the requirement in tabular form. The table
provides the following information for each issue:
Column

Description

ID

Identifier of the issue. If an identifier is provided by the issue tracking system,
this external identifier is used. The identifier is clickable if an external link is
defined for the issue.

Synopsis

Meaningful short-description of the issue.

Status

Current status of the issue. If the status is provided by the issue tracking system,
this external status is used.

Assigned by

Person who assigned the issue to the test definition.

Test ID

Identifier of the test definition in which the issue was discovered.

Test Definition

Name of the test definition in which the issue was discovered.

Flags
Flags indicate that a requirement has changed or needs to be reviewed. Requirements with flags appear in
the requirements tree with flag icons. There is also a section in the requirement properties to view flag
information.
You can add and remove flags as needed and others will see the flag when they look at the requirement. You
can also flag a requirement and all of its children. There can only be one flag on an item at a time and setting
a flag on an item that already has a flag will overwrite the flag. Changes to the requirement flag are maintained
in the requirements change history.
If you are integrating with an external requirements management tool, you will also see flags from new or
updated external requirements. The following are scenarios about how flags are applied for integrated
requirements:
•

•

If you add a requirement to the requirements management tool after initial synchronization, then a subsequent
synchronization is performed, when the new requirement is added to Test Manager, it will display with an
added flag to indicate it was created during an update.
If you edit a requirement that has been synchronized to Test Manager, the requirement in Test Manager
will be flagged with a updated flag to indicate it was updated.

Setting a Flag
To set a flag on a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement in the Requirements tree.
3. Right click the requirement and choose Flag ➤ Set Flag.
The Set Flag dialog box opens.
4. Type a comment for the flag in the Comment text box.
5. To set the flag for all children of the currently selected requirement, click the Set flag on child requirements
check box.
6. Click Ok.
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Note: The flag information is available on the Properties page of the requirement.

Clearing a Flag
To clear a flag from a requirement:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement in the Requirements tree.
3. To clear a single flag: Right click the requirement and choose Flag ➤ Clear Flag.
4. To clear the flag for all children of the selected requirement: Right click the requirement and choose Flag
➤ Clear Flag - Include Children.
The flag information is removed from the Properties page of the requirement.
Note: You can also clear the flag by clicking Clear Flag on the Properties page of the requirement.

Creating a Filter for Flagged Requirements
To create a filter for flagged requirements:
1. Navigate to Test Manager ➤ Requirements.
2. Click New Filter.
The New Filter dialog box opens.
3. Select Requirements Property from the Selection Criteria list.
4. Select Requirement State from the Property list.
5. Select = from the Operator list.
6. Select one of the following values from the Value list:
None

No flag is selected

Flagged Manual

User manual added a flag to a requirement.

Flagged New

Requirement was created.

Flagged Updated

Requirement was updated.

Obsolete

Requirement is marked as obsolete.

7. Click Save and Apply.
Note: If child requirements are flagged, but one or more parent requirements are not flagged, the full
path to the flagged child requirements will display, but with the parent requirements disabled. You
cannot set or clear the flag for parent requirements that are in this state.

Requirements Import
Test Manager enables you to import requirements from Microsoft Word (Word) into Test Manager. You can
import a requirement into the Requirements unit and then maintain all included requirements in Test Manager.
The import is a one-time event.
Note: Before you can import requirements, you need to create a requirements file in Word. For more
information , see Requirements File.
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Test Manager uses the information stored in the Word file and in a mapping file to determine what data to
store and captures only the information that is mapped with certain styles. Test Manager uses a mapping file
to map the requirements in the Word file to the Test Manager requirements. A default mapping file named
RequirementsPropertiesDefaultMapping.xml is preselected for the import.You can choose your own
customized mapping file to map your requirements. For more information about mapping files, see Requirements
Mapping File. If you already have requirements Word documents that you used with the Office Import Tool in
previous versions of Test Manager, use the mapping file OITCompatibleRequirementsMapping.xml.
Note: Currently, Test Manager supports only Microsoft Word 97-2003 (.doc) files for import. Note that
Word 2007 contains the option to save files as Word 97-2003 documents.

Importing Requirements from a Word File
To import requirements from a Word file into the Requirements unit:
1. Navigate to Test Manager ➤ Requirements.
2. Right-click the requirement that you want to use as the parent node of the imported requirements and
choose Import from Word....
The Import Requirements from Word File dialog box opens.
3. Select the mapping file from the Choose Mapping File list box.
The default mapping file is RequirementsPropertiesDefaultMapping.xml. If you want to import
requirements from Word documents that you used with the Office Import Tool in previous versions of Test
Manager, use the mapping file OITCompatibleRequirementsMapping.xml.
4. Optional: Edit the requirements mapping file.
5. Either type the fully qualified path of the requirements file into the Requirements File text box or click
Browse to search for the requirements file.
6. Click OK.
A message informs you if the import was successful. Click OK to close the message.

Requirements Update
Test Manager enables you to update requirements that were imported from Microsoft Word (Word). You can
change the requirements in the Word document and then update them in the Requirements unit.
You can also change the mapping file to change the mapping of the requirements in the Requirements unit.
Note: You can only update a requirement for which a unique external ID is defined in the mapping file.

Updating Requirements from a Word File
To update requirements from a Word file:
1. Navigate to Test Manager ➤ Requirements.
2. Right-click the requirement that you want to use as the parent node of the updated requirements and choose
Update from Word....
Note: Update from Word... is only active if the selected requirement has been imported into Test
Manager.
The Update Requirements from Word File dialog box opens.
3. Select the mapping file from the Choose Mapping File list box.
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Note: You can only update a requirement for which a unique external ID is defined in the mapping
file.
The default mapping file is RequirementsPropertiesDefaultMapping.xml. If you want to import
requirements from Word documents that you used with the Office Import Tool in previous versions of Test
Manager, use the mapping file OITCompatibleRequirementsMapping.xml.
4. Either type the fully qualified path of the requirements file into the Requirements File text box or click
Browse to search for the requirements file.
5. Click OK.
A message informs you if the import was successful. Click OK to close the message.

Requirements File
You can create a requirements file in Word to import requirements into Test Manager. In the requirements file,
you can define requirements and their hierarchy, along with their priorities, risks, review status, and custom
properties.
To map the requirements in your requirements file to the requirements in Test Manager, use an XML mapping
file. The mapping file maps the styles in the Word document to the requirement properties in Test Manager.
You can name the Word styles as you want, as long as you map them appropriately in your mapping file.
If you want to be able to update the requirements, you must define a style for the external ID in the mapping
file and assign a unique external ID to each of the requirements in the requirement file. The following example
shows a sample requirement, two subrequirements, and the corresponding external IDs:
MyRequirement_1
MyExternalID_1
MyRequirement_1.1
MyExternalID_1.1
MyRequirement_1.2
MyExternalID_1.2
Note: Currently, Test Manager supports only Microsoft Word 97-2003 (.doc) files for import. Note that
Word 2007 contains the option to save files as Word 97-2003 documents.

Requirements Mapping File
The XML mapping file enables Test Manager to translate the information included in the Word requirements
file into Test Manager requirements. The default mapping file is located on your front-end server in
C:\Documents and Settings\All Users\Application
Data\Silk\SCC35\OfficeImportMappingFiles\requirements\RequirementsPropertiesDefaultMapping.xml.
The following tags map the Word styles to Test Manager requirements properties:
Title

Optional:
Description

Defines a requirement and it's level in the hierarchy. Style name="Heading 1"
level="0" defines a top-level requirement, Style name="Heading 2" level="1"
defines a second-level requirement, and so on.
When a Word style is defined for this tag, all contents with the defined style are used as
the description of the requirement. If no style is defined, all contents with styles that are
not defined for the other tags are concatenated for the description of the requirement.
The Description tag features basic Word text-formatting, including tables. Each image
that is included in the description is attached to the requirement as an attachment.
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ExternalID

Priority

Defines the external ID of the requirement, which enables the requirement to be found
in the requirements tree and to be updated.
Defines the priority of a requirement. The following values are allowed:
•
•
•
•

Risk

Defines the risk of a requirement. The following values are allowed:
•
•
•
•

Reviewed
CustomProperty

Low
Medium
High
Critical

Low
Medium
High
Critical

Defines if a requirement has been reviewed or not. Allowed values are Yes and No.
Defines the custom properties that you have defined in Test Manager. You can define
properties with number, text, date, and list data-types.The date format in the source
document must be dd.mm.yyyy.
For multiple-select list items, separate the items using a semi-colon without spaces. For
number type items, the precision must match the precision defined in the custom property
definition in the Settings unit.
RequirementsPropertiesDefaultMapping.xml defines mappings for three sample
custom properties: MyInteger, MyString, and MyDate.

The following code sample displays the contents of RequirementsPropertiesDefaultMapping.xml.
<Title>
<Style name="Heading 1" level="0"/>
<Style name="Heading 2" level="1"/>
<Style name="Heading 3" level="2"/>
<Style name="Heading 4" level="3"/>
<Style name="Heading 5" level="4"/>
</Title>
<ExternalId>
<Style name="ExternalID"/>
</ExternalId>
<Priority>
<Style name="Priority" />
</Priority>
<Risk>
<Style name="Risk" />
</Risk>
<Reviewed>
<Style name="Reviewed" />
</Reviewed>
<CustomProperty propertyName="MyInteger" type="integer">
<Style name="MyInteger"/>
</CustomProperty>
<CustomProperty propertyName="MyString" type="string">
<Style name="MyString"/>
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</CustomProperty>
<CustomProperty propertyName="MyDate" type="date">
<Style name="MyDate"/>
</CustomProperty>
</Mapping>

Editing the Requirements Mapping File
To edit the requirements mapping file:
1. Navigate to Test Manager ➤ Requirements.
2. Select a requirement from the Requirements tree.
3. Right-click the requirement that you want to use as the parent node of the imported requirements and
choose Import from Word....
The Import Requirements from Word File dialog box opens.
4. Click Edit Mapping.
The Edit Mapping dialog box opens.
5. Edit the variables of the requirements file in the text boxes.
Note: For information on the variables included in the requirements file, see Requirements File.
6. Optional: Edit the name of the mapping file.
7. Click OK to save your changes or click Cancel to cancel your changes.

External Requirements Management Tools
This section explains how to work with external requirements management tools.

Synchronizing Requirements
Enabling synchronization of requirements between Test Manager and an external RMS enables Test Manager
to receive changes that occur in the external RMS whenever a synchronization is executed. If a project has
external RMS integration enabled, the master system for requirements is automatically the external system.
This means that synchronization is always from the external RMS tool to Test Manager. Requirements can
no longer be edited in Test Manager. An exception are newly created requirements that don't exist in the
external tool, which are uploaded to the external (master) system only if the option Enable upload of
requirements is enabled in Settings ➤ Requirements Management.
Property mapping functionality allows you to map property fields between Test Manager and external requirement
tools. For example, a custom field in Test Manager called User might be equivalent to a property field in
CaliberRM called Field_2. The property mapping feature ensures that changes to requirement-property fields
are accurately refreshed between projects. If you don't use the property mapping feature, only the name and
the description of the requirements are mapped. For more information, see Editing Property Mapping.
Requirements can be synchronized in one of several ways:
Manual synchronization Click Synchronize Changes at the root folder level on the Properties page to
synchronize only requirements that have changed since the last synchronization.
This option is not available for IBM Rational RequisitePro.
Forced manual
synchronization

Click Synchronize All at the root folder level on the Properties page to force
synchronization of all requirements.
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Automatic scheduled
synchronization

Based on globally defined Test Manager schedules.

Automatic online
synchronization

Changes to requirements are automatically propagated between tools.This option
is available for CaliberRM only. It requires CaliberRM client installation on the
application server and MPX enabled. To enable automatic synchronization
between CaliberRM and Test Manager, add the file ss.jar to the application
server at Program Files\Silk\SC Test Manager <version>\lib and
restart the application server. Contact customer care to obtain the file.
Requirement data is automatically updated in Test Manager when changes are
made in CaliberRM and traces in CaliberRM are updated when test definition
assignment changes are performed in Test Manager. This type of online
synchronization is only available when projects are configured with the current
baseline.

Automatic synchronization of requirements between Test Manager and external requirements management
tools can be configured to occur based on global schedules. For details on configuring global schedules, refer
to the SilkCentral Administration Module Help.
Note: The Open CaliberRM buttons open whatever program is registered as the default program for
opening files of extension .crm. On some machines, this may be the requirement viewer, rather than
CaliberRM. This behavior can be changed by your administrator. The client program is called
caliberrm.exe. When properly configured, the program opens to the requirement that is selected in
Test Manager.
The binder icon on the project node of the Requirements tree indicates the status of RM integration for the
project:
No configuration

RM integration is not available.

Manual configuration

Requirement import, upload, and synchronization can be done only by
clicking the corresponding buttons on the project node in Requirements
➤

➤ Properties.

At the project level, the Properties page includes the following properties:
Property

Description

System

The external tool with which integration has been enabled.

Status

Whether or not integration has been enabled.

Project Name

The name of the external project that the Test Manager
project is associated with.

Requirement Types

The requirement types that are shared between projects.

Note: When integration between CaliberRM and Test Manager has been enabled, the project node
displays the current status of the online requirements change listener. The three possible statuses for
such projects are: Connected (synchronized), Reconnected (synchronization recommended), and
Disconnected.
Synchronizing Requirements Across Tools
Note: Use the property mapping feature to map property fields. If you don't use the property mapping
feature, only the name and the description of the requirements are mapped. For more information, see
Editing Property Mapping.
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To synchronize requirements between Test Manager and an externally configured requirements management
tool
1. Navigate to Test Manager ➤ Requirements.
2. Click
in the toolbar.
3. Select the Project node in the Requirements tree.
4. Click the Properties tab.
The Properties page displays the properties of the selected tree-element.
5. Click Synchronize Changes.
6. Click Yes on the Synchronize Requirements confirmation dialog box to begin synchronization.
A dialog box opens when synchronization is complete, displaying synchronization statistics, including the
number of requirements that have been created, updated, and deleted.
7. Click OK to complete the synchronization.
Any updates that were made to mapped requirements in your externally configured requirements
management tool are now reflected in the Requirements tree.
Synchronizing Requirements based on Schedules
You can configure global schedules to automatically synchronize requirements between Test Manager and
an external requirements management tool. To enable automatic synchronization between CaliberRM and
Test Manager, add the file ss.jar to the application server at Program Files\Silk\SC Test Manager
<version>\lib and restart the application server. To obtain the file, contact customer care.
To synchronize requirements based on globally defined schedules:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Requirements Management tab.
3. Click Edit Schedule.
The Edit Schedule dialog box opens.
4. Click the Global option button.
5. Select a pre-defined global schedule from the selection list.
Note: For details about configuring a global schedule, refer to the SilkCentral Administration Module
Help.
6. Click OK.
Defining Email Notification for Automatic Synchronization Events
You can define an email notification to alert users when errors occur during automated synchronization of
requirements between Test Manager and external requirements management tools. All notification recipients
receive copies of the synchronization log files.
To define an email notification for automatic synchronization events:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Requirements Management tab.
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3. Click Edit Notification.
The Edit Notification dialog box displays.
4. Check the Enable notification check box.
5. Select a user name from the Username list box.
Note: For details about defining users, refer to the SilkCentral Administration Module Help.
6. If required, add additional email addresses for other recipients in the Other email addresses text box. Use
semicolons to separate multiple email addresses.
7. Click OK.

CaliberRM Integration
This section describes how to integrate CaliberRM with Test Manager.
Note: CaliberRM user defined attribute Multiple selection user list and Multiple selection group list
must be mapped to the Test Manager text attribute type and not list type.
Enabling Integration with CaliberRM
To enable integration with CaliberRM:
1. Navigate to Test Manager ➤ Projects.
2. Select the project to which you want to establish integration.
3. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
4. Click the Requirements Management tab.
5. In the Borland® CaliberRM Integration section, click Configure.
The Edit Configuration dialog box opens.
6. Type the Hostname of the machine where the external server is installed.
7. Type valid Username and Password credentials for the requirements management server.
8. Click Test Connection to confirm that the host and user credentials you have entered are correct.
Click Browse to advance to the Browse Projects dialog box.
If the settings are correct, a Test connection was successful dialog box opens.
Note: If you are not able to establish a connection, consult your system administrator.
9. Click OK.
10. From the Project list box, select the external project with which the Test Manager project is to be integrated.
The requirement types that are available with the selected project are automatically populated into the
Requirement Types field. The baselines that are available with the selected project are automatically
populated into the Baseline field.
11. Select a Baseline from the external project that should be integrated with the Test Manager project.
Your selections are displayed on the Edit Configuration dialog box.
12. Click OK.
13. Select one or more requirement types from the external project that should be integrated with the Test
Manager project.
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Use CTRL + Click to select multiple requirement types.
14. Optional: Check the Enable creation of unassigned requirements check box to enable creation and
editing of unmapped requirements in Test Manager projects that are configured for integration with CaliberRM.
15. Optional: Check the Enable upload of requirements to CaliberRM check box to enable the upload of
unmapped or unassigned requirements from Test Manager to CaliberRM.
This allows you to upload additional previously unmapped requirement trees to CaliberRM and then have
those requirements mapped within Test Manager. The Map Requirement button in Test Manager ➤
Requirements ➤ Properties becomes enabled, allowing configuration of top level requirements for external
requirement types, which is required when uploading unmapped requirements.
16. Click OK to save your settings.
Baseline Support for CaliberRM Integration
You can select the current baseline or existing user-defined baselines for CaliberRM integration. When you
select a user-defined baseline, the Map Requirement button in Test Manager ➤ Requirements ➤ Properties
is disabled and requirements are not updated in the integrated CaliberRM project.
You cannot import modified baselined requirements into Test Manager. Requirements that are not of the
current baseline can only be changed in CaliberRM if the version of the requirement that is used for the baseline
is changed. Such changes are only updated within Test Manager requirements when a manual or scheduled
synchronization is performed.
You can change a baseline after you import it into Test Manager. You can change the configured baseline to
a different user-defined baseline or the current baseline. After such a change, the next synchronization of the
baseline, either manual or scheduled, will update the Test Manager project and update, create, or delete
requirements as required. When a baseline is changed, a message displays that states that the changes will
take effect after the next synchronization. When a baseline is changed from the current baseline to a user-defined
baseline, a message displays informing you that, for user defined baselines, upload of requirements is disabled.
Note: With user-defined baselines, you can use the same requirement type of a CaliberRM project more
then once. With current baselines, a requirement type of a CaliberRM project is allowed only once.
Handling Test Definition Assignments in CaliberRM
Assigned test definitions are displayed, managed, and created as traces (“Trace to”) of synchronized
requirements in CaliberRM.
When synchronized requirements are assigned to test definitions in Test Manager, the test-definition assignments
are pushed out to and displayed within CaliberRM. Conversely, when test definitions are assigned to
synchronized requirements from CaliberRM, the assignments are pushed out to and displayed within Test
Manager.
Copying CaliberRM-Integrated Projects
To manage CaliberRM baselines when copying Test Manager projects:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Requirements Management tab.
3. Verify that the baseline you want to save is selected.
Note: If a baseline is changed, you must perform a synchronization to update the project requirements
with the baseline changes, before you can copy an associated Test Manager project. The integration
configuration is only copied if you select a baseline other than the current baseline. If you select the
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current baseline, you need to specify if you want to keep the integration configuration in the original
project or move it to the copied project.
4. If the baseline that you want to save is not selected, click Edit Configuration.
The Edit Configuration dialog box displays.
5. Click Browse next to the Project name text box.
The Browse Projects dialog box opens.
6. Select the baseline you want to save, then confirm your selection.
7. Navigate to Administration ➤ Projects.
8.

Click

in the Actions column of the project you want to copy.

Note: For full details on copying a project, refer to the SilkCentral Administration Module Help.
The Copy Project dialog box displays.
9. Select the items you want to copy into the new project, then confirm your selection.
10. Apply the baseline that you want to continue working with to the Test Manager project.
Note: After copying a project, the original project and the copy are identical. Define on which you will
continue working on by applying the corresponding baseline.
Creating a Baseline for a CaliberRM-Integrated Project
To create a baseline of a CaliberRM-integrated Test Manager project:
1. Create a baseline of the Test Manager project.
For more information on creating a baseline, refer to the SilkCentral Administration Module Help.
A SilkCentral message box displays during the process, asking if you want to enable the CaliberRM
integration for the new baseline.
2. Click Yes.
When the new baseline is created, the Baseline Project - Adapt Project Settings dialog box opens.
3. Click Edit to change the requirements integration settings.
The Edit Configuration dialog box opens.
4. Click Browse next to the Project name text box.
The Browse Projects dialog box opens.
5. Select a CaliberRM project, a baseline, and the requirement type for synchronization.
6. Click Ok to close the Browse Projects dialog box.
7. Click Ok to close the Edit Configuration dialog box.
8. Click Finish to close the Baseline Project - Adapt Project Settings dialog box.

Enabling Integration with IBM Rational RequisitePro
To enable integration with IBM Rational RequisitePro:
1. Navigate to Test Manager ➤ Projects.
2. Select the project to which you want to establish integration.
3. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
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4. Click the Requirements Management tab.
5. In the IBM® Rational® RequisitePro® Integration section, click Configure.
The Edit Configuration dialog box opens.
6. Type the UNC project path to the machine where the external server is installed. Or click Browse and
select the path.
7. Type valid UNC Username and UNC Password credentials for the machine where the external server is
installed.
8. Type valid Username and Password credentials for the requirements management server.
9. ClickTest Connection to confirm that the host and user credentials are correct.
If the settings are correct, a Test connection was successful message displays.
10. Click OK.
Note: Consult your system administrator if you are not able to establish a connection.
11. Click Edit Packages and Requirement Types.
Your selections are then displayed on the Edit Configuration dialog.
Note: Only requirements of explicitly selected packages will be synchronized. Selecting a parent
package does not select the child packages of the parent.
The Browse Packages & Requirement Types dialog box opens. The packages and requirement types
that are available with the selected project are automatically populated into the Packages and Requirement
Types list boxes.
12. From the Packages list box, select one or more packages from the external project that should be integrated
with the Test Manager project.
Use CTRL + CLICK to select multiple packages.
13. From the Requirement types list box, select one or more requirement types from the external project that
should be integrated with the Test Manager project.
Use CTRL + CLICK to select multiple requirement types.
14. Click OK.
The Browse Packages & Requirement Types dialog box closes.
15. Optional: Check the Enable creation of unassigned requirements check box to enable creation and
editing of unmapped requirements in Test Manager projects that are configured for integration with
RequisitePro.
16. Optional: Check the Enable upload of requirements to RequisitePro check box to enable the upload of
unmapped or unassigned requirements from Test Manager to RequisitePro.
This allows you to upload additional previously unmapped requirement trees to RequisitePro and then have
those requirements mapped within Test Manager. The Map Requirement button in Test Manager ➤
Requirements ➤ Properties becomes enabled, allowing configuration of top level requirements for external
requirement types, which is required when uploading unmapped requirements.
17. Click OK to save your settings.

Telelogic DOORS Integration
This section describes how to integrate Test Manager and Telelogic DOORS® (DOORS).
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Installing Telelogic DOORS on the Front-End Server
To integrate Test Manager and Telelogic DOORS, install the DOORS client on the Test Manager front-end
server machine. If you use more than one front-end server machine, you must install the DOORS client to the
same directory on each of the machines.
To install the DOORS client on the Test Manager front-end server machine:
1. Navigate to Help ➤ Tools ➤ Downloadable Client Tools.
2. Click Test Manager Add-In for Telelogic DOORS to download the DOORS plug-in package.
The package contains two ZIP-Archives:
•
•

DoorsRM.zip
DoorsClientLibs.zip

3. Create a new folder with the name testmanager in the …\lib\dxl folder of your Telelogic DOORS client
installation.
The default path for this folder is C:\Program
Files\Telelogic\DOORS_8.20\lib\dxl\testmanager.
4. Extract all DOORS script files from DoorsClientLibs.zip to this folder.
The plug-in package DoorsRMPlugin.zip is automatically installed to the Plugins folder of your Test
Manager application server installation during the setup process. During startup of the application server, this
plug-in will be published to all front-end servers.
Configure a Project for Integration with DOORS
To configure a project for requirements integration with DOORS:
1. From the Test Manager project to which you want to establish integration, navigate to Test Manager ➤
Settings ➤ Requirements Management.
2. In the Telelogic DOORS® Integration section, click Configure.
The Edit Configuration dialog box opens.
3. In the RM service URL text box, type the URL of the Test Manager DOORS requirement Web Service.
The default value should point to the correct location already. For example
http://MySCTMHost:19120/services/doorsrequirementsmanagement.
4. Type valid Username and Password credentials for the requirements management server.
5. The default DOORS client installation path is displayed in the DOORS Installation Path text box. If this
path is not correct, click Browse to browse to and select the correct destination in the front-end server
directory structure.
6. Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.
Note: Consult your system administrator if you are not able to establish a connection.
7. Click Browse next to the Project name text box to open the Browse Requirement Types dialog box.
From the Project text box, select the external project with which the Test Manager project is to be
synchronized.
The requirement types that are available with the selected project are automatically populated into the
Requirement types text box. Select the requirement types that are to be synchronized and click OK. Use
CTRL + CLICK to select multiple requirement types.
8. Your selections are now displayed on the Edit Configuration dialog box. Click OK.
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9. Optional: Check the Enable creation of unassigned requirements check box to enable creation and
editing of unmapped requirements in Test Manager projects that are configured for integration with Telelogic
DOORS.
10. Optional: Check the Enable upload of requirements to Telelogic DOORS® check box to enable the
upload of unmapped or unassigned requirements from Test Manager to DOORS.
This allows you to upload additional previously unmapped requirement trees to DOORS and then have
those requirements mapped within Test Manager. The Map Requirement button in Test Manager ➤
Requirements ➤ Properties becomes enabled, allowing configuration of top level requirements for external
requirement types, which is required when uploading unmapped requirements.
11. Click OK to save your settings.
Caution: As the DOORS application object is used for communication, and this object does not support
login data, but rather requires a running DOORS client, Test Manager starts each DOORS client
process with the provided login data and then uses that same data for all subsequent application
objects. Therefore only one set of DOORS login credentials is supported for communication at one
time. It is recommended that you use the same DOORS credentials for all configurations so that
integration tasks can be performed on the front-end server for all projects at the same time. When a
second set of credentials is used, the second set only works after all sessions using of the first set of
credentials have timed out.

Enabling Integration with CaliberRDM
To enable integration with CaliberRDM:
1. From the Test Manager project to which you want to establish integration, navigate to Test Manager ➤
Settings ➤ Requirements Management.
2. In the CaliberRDM Integration section, click Configure.
The Edit Configuration dialog box opens.
3.
4.
5.
6.

Enter the Hostname of the machine where the external server is installed.
Enter the Port number on which the external server is listening.
Enter valid Username and Password credentials for the requirements management server.
Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.
Note: Consult your system administrator if you are not able to establish a connection.

7. From the Project name text box, select the external project with which the Test Manager project is to be
integrated.
8. Check the Enable creation of unassigned requirements check box to enable creation and editing of
unmapped requirements in Test Manager projects that are configured for integration with CaliberRDM.
9. Click OK to save your settings.

Generating Test Definitions from External Requirements
From the RMSs currently shipped with Test Manager, only CaliberRDM supports generating test definitions.
If you want to use another RMS to generate test definitions, the RMS must be able to generate tests. The Test
Manager plug-in API includes a method to verify that the RMS is able to create tests. For more information,
see Requirements Plug-In API Interfaces.
To generate test definitions from external requirements:
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1. Establish integration with the external requirement system.
For additional information, see Enabling Integration with CaliberRDM.
2. Select the requirement in the Requirements tree from which you wish to generate tests.
Note: To be able to generate tests, the RMS plug-in needs to implement the RMTestProvider
interface, and the interface method isTestGenerationSupported needs to return true for the
type of the selected requirement.
3. Click Generate Tests.
The Generate Tests dialog box displays.
4. Use SHIFT + CLICK or CTRL + CLICK to select the tests that you want to generate.
5. Click Generate All to generate all tests, or click Generate Selected to generate the selected tests.
The Test Plan tree displays.
6. Select the folder to which you want to add the generated tests.
Note: Tests that already exist in the selected destination folder are not created, but updated. No tests
in the folder are deleted.
7. Click OK.

Working with External Properties
This section explains how to work with external properties in Test Manager.
Editing External Properties
To edit external properties:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement for which you intend to edit external properties.
3. Click the Properties tab.
The Properties page displays the properties of the selected tree-element.
4. Click Edit External Properties.
The Edit External Properties dialog box displays. All properties of the external requirement are displayed
here. Edit all properties as required.
Note: Editable properties on this dialog box offer input fields and controls with which you can edit the
properties. If a mapping rule exists for an attribute, the attribute will be tagged with a trailing asterisk
(*).
5. Click OK to save your changes and close the dialog box.
Viewing External Properties
To view external properties:
1. Navigate to Test Manager ➤ Requirements.
2. Select the requirement.
3. Click the Properties tab.
The Properties page displays the properties of the selected tree-element.
4. Click View External Properties.
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The View External Properties dialog box displays. All properties of the external requirement are displayed
here.
5. Close the dialog box.

Editing Property Mapping
The property-mapping functionality allows you to map property fields between Test Manager and external
requirements-management tools. For example, a custom requirement property in Test Manager called User
might be equivalent to a custom property in CaliberRM called User_ID. The property-mapping feature ensures
that requirement-property fields are accurately populated between projects during requirement uploading and
importing. If there are multiple requirement types, you must map each type separately.
Note: If you don't use the property mapping feature, only the name and the description of the requirements
are mapped.
To edit property mapping:
Note: The following applies for synchronizing properties with boolean values: since Test Manager does
not support the boolean data type, you need to create a single select list with the the following two list
items:
•
•

Name = Yes, Numeric Weight = 1
Name = No, Numeric Weight = 0

Note: When you map lists, requirement properties from both products need to have the same named
options for each list item, and they are case sensitive.
1. Select the project.
2. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
3. Click the Requirements Management tab.
4. Click Edit Property Mapping for the configured external tool.
The Edit Property Mapping dialog box opens.
5. Select an external requirement type from the Requirement types list. All custom requirements of that type
are then displayed below in the selection box.
6. Select the custom requirement property for which you are establishing mapping.
7. From the list box on the right, select the Test Manager custom property to establish mapping to the external
custom property you have selected.
8. Click Add Mapping to map the requirements.
The results are displayed in the Custom property mapping box.
9. The System property mapping box displays the two pre-configured mappings for requirement name and
description, which cannot be removed.
10. Click OK to save your changes.

Deleting Property-Mapping Value Pairs
To delete a property-mapping value pair:
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1. Select the project.
2. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
3. Click the Requirements Management tab.
4. Click Edit Property Mapping for the configured external tool.
The Edit Property Mapping dialog box opens.
5. Select the property-mapping value pair in the Custom property mapping select box.
6. Click Remove Mapping.
7. Click OK to save your changes.

Disabling Requirements-Management Integration
To disable requirements-management integration configuration:
1. Select the project.
2. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
3. Click the Requirements Management tab.
4. Click the Disable Configuration button of the requirements-management tool for which you want to disable
integration.
All integration data and functionality is disabled, but not deleted from the project.

Removing Requirements-Management Integration
To remove requirements-management integration:
1. Select the project.
2. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
3. Click the Requirements Management tab.
4. Click Remove Configuration of the requirements-management tool for which you want to remove integration.
This button is only enabled if the configuration is disabled.
The Remove External Association dialog box displays.
5. Click Yes.
All related data is removed from the database.

Test Plan
This section explains how to manage test plans in Test Manager.
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The Test Plan unit enables you to maintain control over test planning across the system development lifecycle.
You can create and manage test plans, including creating and scheduling test definitions of both automated
tests and manual tests. You can upload and associate files and links as attachments to test containers and
test definitions. You can easily associate found issues with the test definitions that led to their discovery. You
can also track the full change history of the test plan in the unit.

Test Plan Document View
Test Manager ➤ Test Plan ➤
The Document View provides a high-level view of the important information, the status, and the last executions
of all test plans in the selected project.
For each test container, test folder, and test definition, the Document View displays the following columns:
Item

Description

Status

The status of the last test
execution.
•
•
•
•

Passed
Failed
Not Executed
Not Scheduled

For test containers and
folders, a status bar displays
the number of test definitions
with the corresponding
status.
Test Definitions

Number of test definitions

Planned Time

Roll up of Planned Time of
the manual test definitions.

Assigned Issues

Number of Issues assigned
to the test definition.

Last Execution

Time of the last execution of
the selected test definition or
project.

Last Build

Build on which the last
execution was performed.

Changed On

Last time the selected test
plan element was changed.

Changed By

User that changed the
selected test plan element for
the last time.
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Working with the Test Plan Tree
Test Manager ➤ Test Plan ➤
As with requirements, test plans are displayed, organized, and maintained through a hierarchical tree structure,
the Test Plan tree. The Test Plan tree enables you to organize test definitions in any number of hierarchy
levels. Each node in the tree represents either a test definition, a test folder, or a test container.
In the Contents page you can view, cut, copy, and paste the child elements of any selected test plan element.
The page supports standard Windows Explorer style multi-select functionality.
Note: When the Test Plan tree includes more elements than can be displayed at once without impacting
response time, elements are displayed in increments. Page number links at the bottom of the tab allow
you to browse through the elements included on the tab one page at a time. To display all elements as a
single list, click the [All] link.

Expanding or Collapsing the Test Plan Tree
You can consolidate levels of the Test Plan tree or display all levels of the tree based on your viewing needs.
To collapse or expand levels of the Test Plan tree:
1. Navigate to Test Manager ➤ Test Plan.
2. Select the test container or test folder in the Test Plan tree and continue with one of the following options:
•
•
•

Click

to the left of the name of the test plan element to expand the element.

Click
to the left of the name of the test plan element to collapse the element.
Right-click on the element and select Expand or Collapse.

Cutting, Copying, Pasting, and Deleting Test Plan Elements
The toolbar in the Test Plan unit enables you to easily cut, copy, paste, and delete test-plan elements within
the Test Plan tree, both within the current project and between projects. These editing functions simplify the
process of building and managing the test plan of your project.
The data types that are copied along with test definitions and test folders are properties, attributes, parameters,
and attachments. Assignments, issues, runs, and history are not copied.
Tip: In the Contents page, you can view, cut, copy, and paste the child elements of any selected test
plan element. The page supports standard Windows Explorer style multi-select functionality. Before you
can paste a test plan element into the Contents page you must explicitly select an element within the
page to gain the application's focus.
Note: Containers cannot be copied or pasted.
To cut, copy, paste, or delete a test plan element:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, select the container, folder, or test definition that you wish to edit.
4. Click the appropriate toolbar button:
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Button

Description
Deletes the selected element from the tree.
Cuts the selected element from the tree and moves it to the clipboard.
Copies the selected element to the clipboard.
Pastes a copy of the element held on the clipboard to the same level of the
currently selected element.
Pastes a copy of the element held on the clipboard as a sub-node of the
currently selected element.

Note: The commands are also available through the context menu in the Test Plan tree.

Copying and Pasting a Test Plan Element from One Project to Another
To copy and paste a test folder or test definition between projects:
1. Navigate to Test Manager ➤ Projects.
2. Select the source project.
3. Navigate to Test Manager ➤ Test Plan.
4. Click
or
on the toolbar.
5.
Click
to cut or
to copy the element to the clipboard.
6. Navigate to Test Manager ➤ Projects.
7. Select the destination project.
8. Select the destination container and folder.
9.
Click
.
Note: The commands are also available through the context menu in the Test Plan tree.

Reordering Test Plan Elements
To reorder a test definition, test folder, or test container:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, select the test plan element that you wish to reorder.
4.
Click
to move the test plan element up one step or click
to move the test plan element down one
step.
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Setting a Test Plan Node as Integration Default for External Agile Planning
Tools
To use the Web service calls to create tests in Test Manager through an external agile planning tool, set a
folder or container in the test plan tree as the integration default node, where the Web service will create the
test. If you do not specify the integration default node, an error message box displays.
To specify the integration default node in the test plan tree:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, select the folder or container which you want to set as the integration default node.
4. Right-click the folder or container and select Set as Integration Default.
Note: If an integration default node already exists, the default node is changed to the new node.
5. The integration default node is set to the selected node, enabling the agile planning tool to create tests at
this location.
Note: The integration default node is shown in the Properties page of the project, in which the node
is located.
The integration default node is set to the selected node, enabling the agile planning tool to create tests at this
location.
Note: The integration default node is shown in the Properties page of the project, in which the node is
located.

Filtering on a Folder or Container
To filter on a folder or container:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Right-click the folder or container in the tree that you want to filter and select Filter Subtree.
The tree displays only the contents of the selected folder or container and the hierarchy up to the root node
of the tree.
Note: To remove filtering and display all elements, select <No Filter> from the Filter list box on the
toolbar. Empty folders are not shown in the filtered subtree.

Test Plan Properties Page
Test Manager ➤ Test Plan ➤

➤ Properties

The Properties page offers detail on all properties and relevant information for the selected test definition,
test folder, test package, or test container. For test definition nodes, the following properties are configured
when test definitions are created:
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Property

Description

Test Definition Name

Name of the test definition.

Test Definition ID

Database identifier of the test definition.

Description

Description of the test definition.
Note: Test Manager supports HTML formatting and
cutting and pasting of HTML content for Description
text boxes.

Status

For test definitions or test packages that are included in a
configuration suite, the status is an aggregation of all
statuses of all configurations within the suite:
•

If the test is assigned only to the configuration suite, the
status is Passed only if it is passed in all configurations.
If the status is not Passed in all configurations, the
status of the worst run is propagated, with the following
top-down priority:
1.
2.
3.
4.

•

•

Not Scheduled
Not Executed
Failed
Passed

The status of a requirement that is assigned to the test
is Failed if the test fails in one or more of the
configurations.
We do not recommend to assign the test to a
configuration suite and one or more simple execution
definitions. However, in this case, the aggregate of the
configuration statuses is one status, and the last statuses
of the execution definitions are other statuses. The status
that was executed last determines the last status of the
test.
If the test is assigned to a simple execution definition
only, the status is updated in response to the status of
the last test run.

Last Execution

Last time this test definition was executed. For test definitions
that are part of a running execution definition, the last
execution is updated based on the current test run.

Assigned Executions

Lists all execution definitions that the selected test definition
is assigned to. For each execution definition in the list, the
grid displays the following columns:
Column

Description

Execution
Definition

Name of the execution definition. Click to
view or edit the execution definition.

Status

The status of the last run of the test
definition in the execution definition. The
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Property

Description
Column

Description
status is Not Executed, if the test
definition was not executed in the last run
of the execution definition. For data-driven
test definitions or test packages, the status
of all last runs is displayed in a bar graph.

Last
Execution

Last time the test definition was executed
as part of the execution definition.

Execution
Definition
Parent

The configuration suite or folder in the
context of which the execution definition is
executed. Click to access the suite or folder
in the execution tree. If the execution
definition is not included in a configuration
suite or folder, nothing is displayed.

Created On

Date and time the test definition was created.

Created By

Name of the user who created the test definition.

Changed On

Date and time the test definition was last changed.

Changed By

Name of the user who last changed the test definition.

Planned Time [hh:mm]

Planned execution time of the test definition. Only for manual
test definitions.

Test Properties

Test properties that are specific to the test type.

Success Conditions

All success conditions that have been configured for the test
definition. For test package nodes, all success conditions
except the execution time-out are disabled and hidden.

Integration Default Folder

Shows the name of the default container or folder, where
tests from external RMSs are created.

Test Plan Contents Page
Test Manager ➤ Test Plan ➤

➤ Contents

The Contents page displays the child elements of the selected project, test container, or folder in the Test
Plan tree. The page supports Standard Windows Explorer style multi-select functionality.
Tip: To drill down into the selected folder or container, press Enter or double-click the selected item.
Press Backspace or click

on the toolbar to navigate one level up.

Note: You cannot copy or paste a test container.
For each child element of the selected project, test container, or folder, the Contents page displays the following
columns:
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Column

Description

Name

Name of the test plan element.

Changed On

Date the test plan element was last edited.

Changed By

User who last edited the test plan element.

Tip: As with test plan elements listed in the Test Plan tree, you can right-click the elements listed on the
Contents page to access context-relevant commands through a context menu. Commands that are not
available are grayed out. Before you can paste a test plan element into the Contents page you must
explicitly select an element within the page to gain the application's focus.
Note: When the Contents page includes more elements than can be displayed at once without impacting
response time, elements are displayed in increments. Page number links at the bottom of the page allow
you to browse through the elements included on the page one page at a time. To display all elements as
a single list, click the [All] link.
The Contents page supports the following keyboard functions (shortcuts) for test plan elements:
Key

Normal

SHIFT

CTRL

Up

Move selection up

Extend selection up

Move up

Down

Move selection down

Extend selection down.

Move down

Left

Deselect

Right

Deselect

A

Select All

X

Cut

C

Copy

V

Paste

Pos1

Select first item

Select up to first item

End

Select last item

Select down to last item

Ins

Insert

Del

Delete

F2

Edit

Keyboard Functions for Test Plan Elements
The following mouse and keyboard combination functions are available. Following these functions, actions
like cut, copy, or paste can be performed on the selected nodes:
Keyboard Function

Description

Click

Select a row and remember it as the current row.

Ctrl+Click

Toggle the selection status of the clicked row and remember it as the current
row.

Shift+Click

Select the span from the currently-selected row to a newly selected row.
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Keyboard Function

Description

Ctrl+Shift+Click

When a row is already selected, this function adds the span from the current
row to the clicked row to the selection. If no row is currently selected, this
function removes the span from the current row to the clicked row from the
selection and selects the clicked row.

Note: Containers cannot be copied or pasted.

Test Plan Toolbar Functions
Test Manager ➤ Test Plan
The test-plan toolbar provides important commands for managing your test plans.
Note: The commands in the test-plan toolbar are also available through context menus in the Test Plan
tree.
The following commands are included in the test-plan toolbar:
Command
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Icon

Description

Document View

Displays the Document View, which shows selected properties of all test
elements in a single view.

Test Plan View

Displays the Test Plan View, which enables you to drill deeply into the
properties of a single requirement.

Grid View

Displays the Grid View, which shows all test definitions in a grid.

Up

Navigates one level up in the hierarchy of the navigation tree, regardless of
the current cursor focus.

New Test Container

Enables creation of new test containers.

New Child Test
Folder

Enables creation of new test folders as sub-nodes of the selected folder or
container.

New Child Test
Definition

Enables creation of new test definitions as sub-nodes of the selected folder
or container.

Edit

Edit the selected test plan element.

Create Version

Create a new version of the selected manual test.

Delete

Delete the selected test plan element.

Cut

Cut a test-plan element from the Test Plan tree and save it to the clipboard.

Copy

Copy a test-plan element from the Test Plan tree to the clipboard.
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Command

Icon

Description

Paste

Paste a test-plan element from the clipboard to the Test Plan tree.

Paste as Child

Paste a test-plan element from the clipboard as a child element to the currently
selected test-plan element.

Move Up

Move a test-plan element up within the Test Plan tree.

Move Down

Move a test-plan element down within the Test Plan tree.

Find

Search through all test-plan elements in the active project based on
configurable parameters.

Replace

Replace instances of found values with a new value.

New Filter

Create a new custom filter for the Test Plan tree.

Filters

Lists the available filters for the Test Plan tree

Edit Filter

Edit the currently selected custom filter.

Delete Filter

Delete the currently selected custom filter.

Show Changes

Show recent changes to the test plan.

Acknowledge

Acknowledge changes to the test plan.

Test Plan Reports
This section explains the test-plan-related reports that ship with Test Manager. Test plan reports give you an
overview of the progress of your test definitions and the status of defects over a period of time or over a range
of builds.

Status Reports
The following status reports are available for the Test Plan unit:
Report

Description

Test Definition Status Overview

Represents a status overview of all test definitions, structured by the
statuses Passed, Failed, Not Executed, and Not Scheduled.

Test Definition Status Overview (per Represents a status overview of all test definitions contained in a
test container)
specific test container, structured by the statuses Passed, Failed,
Not Executed, and Not Scheduled.
Test Definitions per Component

Represents an overview of coverage of components by test definition;
makes it easier to see where testing activity is needed.

Test Definitions (per test container) Represents a success rate for each test container by listing the
number of passed test definitions.
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Report

Description

Implemented Test Definitions (per
component)

Represents an overview of coverage of components by test definitions
that have the Implemented attribute set to Yes.

Failed Test Definitions (per
component)

Represents an overview of failed test definitions per component;
makes it easier to identify the most critical components in the
environment.

Progress Reports
The following progress reports are available for the Test Plan unit:
Report

Description

Test Definition Progress Across
Builds 'X' and 'Y'

Represents a trend in test definition progress resulting from viewing
test definition statuses in context with builds. The user must specify
a build range consisting of a start- and an end-build.

Manual Test Coverage since Build
<x> (cumulative)

Represents a trend in manual test definition progress, excluding all
kind of automated tests, resulting from viewing test definition statuses
in context with builds. The user must specify a starting buildnumber
which is used as basis for calculating a cumulative progress.

Automated Test Coverage for Builds Represents the automated test-definition coverage resulting from
(non-cumulative)
viewing test definition statuses in context with builds. The user must
specify a version and a product and the report shows the test
coverage that could be achieved with the automated tests per build.
Test Definition Progress this Month Represents a trend in test definition progress resulting from viewing
test definition statuses for the current month.
Specific Test Plan Node Progress
Over the Past 'X' Days

Represents a trend in requirements coverage by considering a
specific test plan node over the past 'X' days.

Test Definitions Created in the Past Represents a listing of new test definitions per component over the
'X' Days (per component)
past 'X' days. Assists in identifying components that lack testing
activity.
Test Definition Progress Over the
Past 'X' Days

Represents a trend in test definition progress by considering test
definition statuses over the past 'X' days.

Percentage Testing Success Over
the Past 'X' Days (per component)

Represents a percentage listing of successful test definitions per
component over the past 'X' days; assists in identifying the
components in the environment that are most critical.

Manual Test Reports
The following manual-test reports are available for the Test Plan unit:
Report

Description

Planned vs. Actual Execution Time of Represents an overview of the deviation between planned and
Manual Tests (Summary)
actual time for execution of manual tests, viewed on a daily basis.
Historic Planned vs. Actual Execution Represents an overview of planned and actually required execution
Time (per user)
time for completed manual test definitions per user over a specific
period of time.
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Report

Description

Planned vs. Actual Execution Time
(status per user)

Represents progress in terms of planned vs. actual hours of
currently pending manual test definitions per user. Manual test
definitions are only considered if test results have been entered by
the user and are assigned to the user who enters the results.

Manual Test Definition Result
Document

An easily printable manual test case result report for a single test
definition.

Manual Test Definition Document

An easily printable manual test case report for a single test
definition.

Baseline Comparison Report
Test Manager ➤ Reports ➤ <Active Project> ➤ Test Plan ➤ Baseline Comparison ➤ Baseline
Comparison
The Baseline Comparison report compares a baselined project with the baseline and displays the number of
changed, deleted, and created test definitions.
Input Parameters
The input parameters for the Baseline Comparison report are the identifiers of the project and the baseline.
General Report Information
This section provides a description of the report and the name of the user who executed the report.
Project and Baseline Information
This section provides the information on the project and the baseline, including data related to the creation of
the baseline.
Project and Baseline Summary
This section provides a sum of the created, changed, and deleted test definitions in the baseline and the project,
in both tabular and graphical form.
Changes
This section provides a detailed list of all changed test definitions in the project and the baseline, with links to
the test definitions.

Test Definition Run Comparison Report
Test-definition run-comparison reports present an overview of the comparison between two runs of a test
definition.
Note: Run-comparison reports are not suitable for the comparison of manual tests to automated tests.
When the name of the report includes (Last Two Runs), you can compare only the last two runs of the
execution definition or test definition.
The test-definition run-comparison report provides the following information:
•
•

Changes to the status of the test definition
Number of errors
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•
•
•
•
•
•

Number of warnings
Context in which the test definition was executed
Execution duration of the assigned tests
Attributes and properties of the test definition
Parameters of the test definition
Success conditions for the test definition

General Report Information
This section provides the following general information about the report:
Element
Project Name
Report Description
Report Executed By

Description
Name of the active project.
Description of the report.
User who executed the report.

Test Definition Information
This section provides the following information about the test definition:
Element
ID
Name
Description

Description
Identifier of the test definition.
Name of the test definition.
Description of the test definition.

Execution Information
This section provides the following information about each execution:
Element
Execution Definition ID
Execution Definition Name
Run ID
Product
Version
Build
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Description
ID of each execution definition.
Name of each execution definition.
ID of each execution definition run.
Name of the product.
Version of the product.
Build of the product.

Test Definition Run Comparison
This section identifies the following differences between the two runs:
Element
Status
Execution Timestamp
Duration
Errors
Warnings
Previous Status
Changed by
Change Comment

Description
Status of each run.
Timestamp of each run.
Duration of each run.
Number of errors in each test definition run.
Number of warnings in each test definition run.
Status of each run previous to the last manual change.
User who performed the last manual change to the status.
Describes the reason of the manual status change.

Attributes and Properties
This section identifies the attributes and properties of the two runs of the test definition at execution time.
Parameters
This section lists the parameters of the two runs of the test definition at execution time.
Success Conditions
This section lists the conditions at execution time for each of the two runs to be considered successful. If a
condition is not satisfied, the test definition run is considered unsuccessful. Satisfied conditions are marked
green, while unsatisfied conditions are marked red.

Success Conditions
Use success conditions to determine whether a test is successful or not. You can assign one or more success
conditions to each test node or suite node in the test plan. If a success condition is not met during the execution
of the test definition it is assigned to, the execution run is marked as Failed, except for the execution time-out
success condition, for which the test definition execution is marked as Not Executed. For a test package,
all success conditions except the execution time-out are disabled and hidden.
In Test Plan View, when you select a node in the Test Plan tree, the Success Conditions table in the
Properties page of the node displays all success conditions that are configured for the selected node. The
table includes the name of each condition,whether or not the condition is active, the maximal value of the
condition, and whether or not the condition is inherited.
A success condition is only evaluated when it is active. To activate and deactivate success conditions see
Editing Success Conditions. The available types of success conditions differ depending on the test definition
type. The following success conditions are currently available in Test Manager:

SilkCentral Test Manager 2010 R2

| 175

Success Condition

Description

Errors Allowed

Maximal number of errors allowed for the test. This success
condition is active by default.

Warnings Allowed

Maximal number of warnings allowed for the test.

Execution Time-Out [s]

Maximal time-out allowed for the test in seconds.

Page Time: Avg. Page Time [s]

Maximal allowed average time to load a page.

Page Time: Max. Page Time [s]

Maximal allowed maximum time to load a page.

Transaction Response Time: Avg.
Trans(Busy)ok [s]

Maximal allowed average response time for a transaction in
the test.

Transaction Response Time: Max.
Trans(Busy)ok [s]

Maximal allowed maximum response time for a transaction
in the test.

The inheritance of success conditions is similar to inheritance of properties. Success conditions that are
assigned to a parent node are inherited throughout all sub-folders and child test definitions.

Editing Success Conditions
In Test Plan View, when you select a node in the Test Plan tree, the Properties page of the node displays
the success conditions that are associated with the node. The Success Conditions table includes the name
of each condition,whether or not the condition is active, the maximal value of the condition, and whether or
not the condition is inherited.
Note: For test package nodes, all success conditions except the execution time-out are disabled and
hidden.
To edit the success conditions of a test
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a test container, test folder, or test definition.
4. Click the Properties tab.
The Properties page displays the properties of the selected tree-element.
5.
Click
to the right of the Success Conditions.
The Edit Success Conditions dialog box displays.
6. Uncheck the Inherit from parent check box of any success condition you are editing.
7. Edit values as required.
8. Specify if conditions should be active or inactive by checking or unchecking their Active check boxes.
9. Click OK to save your settings.

Test Containers
This section describes how to use test containers.
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Adding Test Containers
Note: We recommend to use test containers with caution, because they bind the product to the source
control profile.
To add a new test container:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, select the root node or a container to which you want to add the new container as a
sub-node.
4.
Click
on the toolbar or right-click on the node and choose New Test Container.
You can also right-click on the node and choose New Test Container.
A new container root node is added to the Test Plan tree and the New Test Container dialog box displays.
5. Type a Name and Description for the container.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
6. Select any pre-defined Product that is to be associated with this test container from the list box. For details
on adding a product profile, refer to the SilkCentral Administration Module Help.
7. Select a pre-defined source-control profile from the Source Control profile list box.
If you do not intent to check out any test sources for the test container, for example if you only have manual
tests, select ---.
Note: The Test Manager execution servers retrieve the program sources for the tests included in the
container from the defined source-control profile. The root node of the source control profile is set in
the root node of the test container.
8. Optional: Check the Clear working folder before each test execution check box.
If you check the check box, the source control profile working folder is cleared before a test execution is
performed. For example, the sources will be checked out before each execution.This check box is unchecked
by default.
Note: If you use an external source control system, consider that using the Clear working folder
before each test execution option in conjunction with MS VSS can lead to longer wait times than
when used in conjunction with CVS or Subversion.
9. To specify the default root path where the container is to be saved, click Browse... and navigate to the
location.
10. Optional: When Test Manager is integrated with SilkPerformer® 7.1 or higher, you can define the Custom
data directory and Custom include directory.
In SilkPerformer, the Include directory is divided into a System Include directory and a Custom
Include directory. The Data directory is divided into a System Data directory and a Custom Data
directory. For additional information, refer to the SilkPerformer documentation.
11. The Hidden Test Properties portion of the dialog box allows you to specify the test property types that are
to be displayed on the test container’s Properties page, and the Properties pages of all test folders within
the container.
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These settings do not affect the display of individual test definitions.
12. Click Edit to adjust the hidden test property settings.
The Hidden Test Properties dialog box displays.
13. Uncheck the check boxes of all test types for which you want to have properties displayed.
14. Click OK to save your settings and close the Hidden Test Properties dialog box.
15. Click Save to save your settings.
The new container is added to the Test Plan tree.

Adding Links to Containers
In the Test Plan tree, you can add a link to a test container in the same project. Linked test containers are
displayed in read-only mode at the position in the tree where the link is inserted.
To add a link to a test container:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Right-click the node in the Test Plan tree under which you want the linked test container to display.
4. Choose New Link if you want to link the test container at the hierarchy level of the selected node, or choose
New Child Link to link the test container one level below the selected node.
The Select Test Container For Linking dialog box displays.
5. Select the test container that you want to reference.
Note: If the referenced test container and the container in which you add the link use different
source-control profiles, a confirmation dialog box displays, asking you if you really want to create the
link. Linking inside a test container to another test container with a different source-control profile can
lead to problems when you download or execute a test definition within the linked container. Click No
if you want to change the custom include directory of one of the containers first, or click Yes to create
the link anyway.
6. Click OK to confirm your selection.
The linked container is placed within the selected container as a read-only entity. Any changes to the original
test container will be reflected in the linked container.

Editing Test Containers
To edit the properties of a test container:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, select the test container that you want to edit.
4. Click
in the toolbar.
You can also right-click on the test container and select Edit.
The Edit Test Container dialog box displays.
5. Edit the properties of the test container.
6. Click OK to apply your changes.
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Test Folders
This section describes how you can use test folders to organize your test plans.

Adding Test Folders
To add a new test folder:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, select the test-plan element after which you want to add the new folder.
4. Click
on the toolbar.
You can also right-click on the element and choose New Test Folder to add the new folder after the selected
element or choose New Child Test Folder as a sub-node to the selected element.
Note: For test containers you can add test folders only as sub-nodes.
A new folder node is appended to the Test Plan tree and the New Folder dialog box displays.
5. Provide a name and description for the folder.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
6. Click OK to save your settings.
The new folder is added to the Test Plan tree.

Editing Test Folders
To modify test folder properties:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Select the folder in the tree.
4. Click
in the toolbar.
You can also right-click on the test folder and select Edit.
The Edit Test Folder dialog box displays.
5. Edit the name and description of the folder as required.
6. Click OK to accept your changes.

Sorting Test Folders
To move a folder up or down within the Test Plan tree:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
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3. Select the folder in the tree.
4.
Click
on the toolbar to move the folder one step up in the tree or
down.

to move the folder one step

Test Packages
Test packages provide support for the structure of third-party test types in Test Manager, and consist of a
package root as well as an arbitrary hierarchy of suite nodes and test nodes. Test packages also provide users
with detailed information about a test execution run. Test packages, suite nodes, and test nodes can be
individually assigned, along with their issues and attachments, to requirements. This functionality is similar to
the functionality of every other test definition. After a third-party test definition is converted into a test package,
all tests contained in the package can be run individually, if the third-party test type supports conversion. Test
nodes and suite nodes contained in a test package are provided with an additional property, the External
ID.
An advantage of test packages is that the structure can be maintained automatically with every test execution.
The structure of a test package can be updated according to the results of its runs. The file <Test Manager
installation folder>\wwwroot\silkroot\xsl\output.xsd contains an XML schema for the
structure of the output XML files of test packages.
Test packages enable all functionalities of the individual tests, with the following exceptions:
•
•
•

Test containers that contain test packages cannot be linked.
Test packages cannot be data-driven because they do not possess data-driven properties.
All success conditions except the execution time-out are disabled and hidden for test package nodes.
Note: SilkPerformer test definitions, SilkTest Classic test definitions, and manual test definitions cannot
be converted to test packages, as the structure of these tests is supported in Test Manager by default.

The information that provides the internal structure of a test package is specific, and is no longer consistent
when you copy the test package. To reuse a test package, you have to copy the test package, revert the copied
package into the parent test definition, apply the test definition to your needs, and then convert the changed
test definition to a test package.

Creating a Test Package
To create a new test package out of a third-party test definition:
1. Run the test definition once to create the output.xml file, which contains the structure of the test package.
For additional information on executing a test definition, see Executing Individual Tests.
2. Navigate to Test Manager ➤ Test Plan.
3. In the Test Plan tree, right-click the test definition and choose Convert to Test Package.
The selected test definition is converted to a hierarchy representing the structure of the last execution result.

Using External IDs
You can use External IDs to uniquely identify test nodes and suite nodes in test packages. An External
ID is provided as a property for each test node and each suite node. The automatically generated External
ID identifies a unique test method by the fully qualified name of the class and the method with an "~" prepended.
For JUnit tests, the following schema is used for the automatically generated External ID: ~<package
name>.<class name>#<method name>.
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When refactoring JUnit test classes, the automatic generation of the External ID is not applicable, because
the result information of tests previous to the refactoring will be lost when creating a new test. In this case the
External ID for the test must be manually defined. The refactored method is reidentifiable, because the
External ID remains unchanged while moving a JUnit test or changing its name. The External ID can
be manually set in the source code as an annotation.
The following code example shows such an annotation for JUnit tests:
import java.lang.annotation.Retention;
import java.lang.annotation.RetentionPolicy;
@Retention(RetentionPolicy.RUNTIME)
public @interface ExternalId {
String externalId();
}
The annotation can be used in a JUnit test to annotate classes and test methods as shown:
import static org.junit.Assert.*;
import org.junit.Test;
import com.borland.runner.ExternalId;
@ExternalId(externalId="JUnit4test")
public class JUnit4test {
@Test
@ExternalId(externalId="MyExtId1")
public void test1() {
...
}
@Test
@ExternalId(externalId="MyExtId2")
public void test2() {
...
}
}
Be aware that using External IDs with JUnit runner 'org.junit.runners.Parameterized' is not supported for
test methods, because the External ID is not unique for repeated runs of a method with different parameters.
As a work around an External ID could be specified on class level, but must be omitted on method level.
An example follows:
@RunWith(Parameterized.class)
@ExternalId(externalId="parameterizedWithExtId")
public class TestCaseParameterizedWithExternalId {
@Parameters
public static Collection<Object[]> parameterFeeder() {
return Arrays.asList(new Object[][] {
{ "param_name1", "param_value1" }, // set of parameters per run, type
matching constructor must exist!
{ "param_name3", "param_value3" },
{ "param_name2", "param_value2" },
}
);
}
private String paramName;
private String paramValue;
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public TestCaseParameterizedWithExternalId(String paramName, String paramValue)
{
this.paramName = paramName;
this.paramValue = paramValue;
}
@Test
public void testWithParams() {
System.out.println(String.format("run with parameter: name='%s', value='%s'",
paramName, paramValue));
}
}
Note: The setting of the External ID for a JUnit test is only possible for tests using JUnit 4.4 or higher.

Reusing a Test Package
The information that provides the internal structure of a test package is specific, and is no longer consistent
when you copy the test package. To reuse a test package, you have to copy the test package, revert the copied
package into the parent test definition, apply the test definition to your needs, and then convert the changed
test definition to a test package.
To reuse the information in a test package:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Right-click the test package that you want to reuse in the Test Plan tree and select Copy.
4. Select the node in the Test Plan tree to which you want to add the copied test package.
5. Right-click the selected node and select Paste, to add the copied package to the same level in the tree, or
select Paste as Child to add the copied test package as a subnode to the selected node.
Caution: The information now contained in the copied test package is not consistent.
6. Right-click the copied package and select Revert Package to Test.
The package information is removed from the parent test definition.
7. Edit the test definition to apply it to your needs.
For additional information, see Editing Test Definitions.
8. Right-click on the edited test definition and select Convert to Test Package.
You now have a copy of the original test package with different properties.

Reverting a Test Package to the Test Definition
To revert a test package to the original test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Right-click the test package in the Test Plan tree.
4. Click Revert Package to Test.
The test package is reverted to the original test definition.
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Cleaning Up a Test Package
To clean up a test package:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Right-click the test package in the Test Plan tree.
4. Click Clean Up Test Package.
All tests that were not executed during the last execution of the test package are removed from the test package.

Test Plan History
Test Manager provides a complete history of all changes that are made to test plans. History information is
read-only, and cannot be edited or permanently deleted.
The Recent Changes filter, which you can access by clicking
on the toolbar, enables you to efficiently
view and acknowledge the latest changes and additions that have been made to requirements.
Note: When you delete a test plan element, a change entry is added to the history file of the project to
which the test plan element belongs.

Viewing Recent Changes
To view recent changes to test plans:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
to filter out all test plan elements except those that have been changed since your last change
acknowledgement.
Note: The recent changes filter is selected automatically in the Filter list box.
3.
When you have reviewed the changes, you can accept them by clicking
The acknowledge function resets the recent changes filter.

.

4.
Click

again to remove filtering and see all test definitions.

Note: All test-plan changes generate time-stamped entries in the test plan history.

Tracking the History of a Test Plan Element
To track a test plan element’s history:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test plan element in the Test Plan tree.
4. Click the History tab.
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The properties of the test plan element are displayed in tabular format.

Test Plan History Page
Test Manager ➤ Test Plan ➤ History
The History page details the revision history of the selected test definition, test container, folder, or project. It
also includes an entry for every project baseline that includes the selected element, with links to the baseline
and the corresponding element in the baseline. If the selected element was created as part of a project baseline,
the first entry in the History page includes links to the original project and the corresponding element in the
original project. You can use the links only to access active projects or baselines. For more information on
project baselines, refer to the SilkCentral Administration Module Help.
For manual tests, the History page additionally includes an entry for each version of the selected manual test,
and allows you to create new versions, revert to a previous version, and view the changes between two selected
versions.
For each change, the page displays the following columns:
Column

Description

Actions

Only for version entries. For a version of a manual test, the
actions you can perform are View Version, Revert to
Version and Delete Version.

Version

Only for version entries. The version of the manual test.

Comment

A comment on the changes.

Created On

Date and time of the change.

Created By

User that made the change.

Note: When the page includes more elements than can be displayed at once without impacting response
time, elements are displayed in increments. Page number links at the bottom of the page allow you to
browse through the elements included on the page one page at a time. To display all elements as a single
list, click the [All] link.

Upload Manager
SilkCentral’s Upload Manager offers a convenient means of uploading files, typically test scripts, to the
SilkCentral file pool where they are accessible to Test Manager.
For information about uploading files to Issue Manager, refer to the SilkCentral Issue Manager Help. Through
the integration of Issue Manager with TechSmith’s SnagIt screen capture utility, Issue Manager users can
easily capture screen images of error conditions and upload them to Issue Manager where they can attach
them to existing issues or use them as the basis for new issues.
Once you have downloaded Upload Manager to your local system, you can directly start Upload Manager as
a standalone application, independent of Test Manager.
You can access Upload Manager in two ways:
•
•
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Start the Upload Manager executable from the program directory to which it has been installed. For example,
C:\Program Files\Silk\SC Test Manager <version>\Upload Manager\UploadManager.exe.
Issue Manager users only: Use a hotkey keyboard combination. For example, Ctrl+Print Screen. This
option is enabled when the SnagIt screen capture utility is configured for use with Issue Manager. For
details, refer to the SilkCentral Issue Manager Help.

| SilkCentral Test Manager 2010 R2

Downloading and Installing Upload Manager
To download and install Upload Manager:
1. Navigate to Help ➤ Tools ➤ Downloadable Client Tools.
2. Click the Upload Manager link and save SetupUploadManager.exe to your local system by using the
download dialog box of your browser.
3. Double-click SetupUploadManager.exe to start the InstallShield Wizard for Upload Manager.
4. Follow the InstallShield Wizard’s prompts to enter your name, the company name, and the target destination
for the installation.
5. Click Finish to complete the installation.

Uploading Files to the SilkCentral File Pool
To upload a file to the SilkCentral file pool:
1. Start Upload Manager by double-clicking the application’s executable file, UploadManager.exe.
The Select target location dialog box opens.
2. Click the SilkCentral (server file pool) option button.
3. Click Next.
The Select file to upload dialog box opens.
4. If the file you want to upload is not visible in the Filename field, click Add to browse to and select the file.
Note: It is not possible to add file descriptions when uploading files to the file pool.
5. When the file that you want to upload displays in the Filename field, click Next.
The Specify connection parameters dialog box opens.
6. Enter the connection parameters for your SilkCentral installation, beginning with the Hostname of the
computer that hosts your Test Manager installation.
The name should not include a protocol designation. For example, 10.3.2.62.
7. Enter the installation’s Port.
For example, 19120.
8. Check the Secure check box if the connection is a secure connection, such as HTTPS.
9. Enter the Username and Password login credentials that are required for your SilkCentral server.
10. Optional: Click Set as Default to have these parameters presented to you automatically the next time you
run Upload Manager.
11. Optional: Click Internet Options to configure Internet settings for your connection, for example proxy server
settings.
12. Click Next.
In the Upload files field, verify the information you have entered. Click Back if you need to make any
changes on a previous page.
Accept the default setting for the Close this window when the upload is complete check box.
13. Click Finish to begin the upload process.
When the upload is complete, Upload Manager closes and the uploaded file is available in the SilkCentral file
pool.
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Upload Manager Command-Line Options
You can define the settings for Upload Manager through command-line options. Defining command line options
optimizes SnagIt’s integration with SilkCentral by automating formatting and configuration operations that you
would otherwise have to execute manually with each file upload.
Note: Settings configured through command line options override any conflicting settings that may have
been manually configured using the SnagIt GUI.
Use the following format to construct a command-line option:
UploadManager.exe {options} {UploadFileNameList}
•
•
•

The order in which the option settings are listed does not affect the behavior of the application.
Option parsing is case-insensitive.
Option parameters do not require blank spaces as separators.

Upload Manager supports the following command-line options:
Option
-HOSTNAME:<HostName>

Description
The target server. For example, -HOSTNAME:tm.mycompany.com.
Note: The server name is not preceded by a protocol.

-USERNAME:<UserName>

-PASSWORD:<Password>

-PORT:<PortNo>

-SECURE:<0 or 1>

The user name to be used for server login. For example,
-USERNAME:admin.
The password to be used for server login. For example,
-PASSWORD:secret.
The targeted server port. The default http:// port is 80. The default
https:// port is 443. The default test server port is 19120.For example,
-PORT:19120.
For https://myhost:myport/ connections:
•
•

0 sets a standard HTTP connection.
1 sets a secure HTTPS connection.

For example, -SECURE:1.
-CONFIG: <ConfigurationId>

The configuration ID of the targeted server, used for uploading files
to Issue Manager and SilkCentral:
•
•

2 is used for uploading files to Issue Manager.
3 is used for uploading files to the SilkCentral server file pool.

For example, CONFIG:2.
-PROJECT:<ProjectId>
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To identify the ID of an Issue Manager, move your cursor over an
active project name on the Issue Manager Projects page. Then look
for the following string in your browser’s status bar: imPrj=<project
ID #>. 0 is the default demo project in Issue Manager. For example,
-PROJECT:0.

Option

Description

-DEFID:<DefectId>

The ID of a specific issue in Issue Manager to which a file is to be
attached. Use 0 to create a new issue. For example, DEFID:156.

-DESC:<AttachmentFileDescription> Issue Manager only: The description of the attached file. For example,
-DESC:Screen Shot Attachment.
-AUTOCLOSE

Checks a check box in the Upload Manager dialog box that instructs
Upload Manager to close after it successfully completes an upload.

-AUTOUPLOAD:<WizardStepIndex> Instructs Upload Manager to attempt automatic file upload through a
specified wizard step (WizardStepIndex). Upload Manager then
prompts the user for manual input at the specified wizard step.
Automatic file upload will stop at any step within which a configuration
failure is detected. For example, -AUTOUPLOAD:10.
-VERBOSE

<UploadFileNameList>

Causes a dialog box to display if a dependent component is missing,
for example if a SilkPerformer compiler is unavailable when a
SilkPerformer project is to be uploaded to SilkCentral.
Use paths to upload multiple files to the SilkCentral file pool. Any
parameter passed to Upload Manager that is not preceded by a dash
(-) is recognized as an absolute file path. For example,
C:\TEMP\MyScreenShot.jpg.

Test Definitions
This section describes how to use test definitions in Test Manager.

Creating Test Definitions
To create a new test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Select a container or folder node in the Test Plan tree where you want to insert a new test definition.
4.
Click
on the toolbar or right-click within the tree and choose New Child Test Definition.
A new test definition node is appended to the tree view, and the New Test Definition dialog box opens.
5. Type a name and description for the test definition.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
6. Select the test-definition type from the Type list box:
7. Click Next and proceed to the appropriate topic for the selected test type in Configuring Test Definition
Properties.
Note: The well-defined public API of Test Manager enables you to implement a proprietary solution that
meets your automated test needs. Test Manager is open and extensible to any external tool that can be
invoked from a Java implementation or through a command-line call.
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Note: Throughout the test-definition configuration process and across all test definition types, Inherit
from parent check box options are provided where applicable, enabling you to accept settings of any
existing parent entity.

Editing Test Definitions
To edit a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Select the test definition or the test package that you want to edit.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
4. Click Edit on the toolbar.
You can also click the Properties tab and click Edit or right-click the test definition or test package and
select Edit.
The Edit Test Definition dialog box displays.
5. Edit the name and description of the selected test definition.
If the selected test definition is a test package, the Update Package Structure on Result check box is
available. Check the Update Package Structure on Result check box if you want to update the structure
of the test package according to the results of the test execution run.
6. Configure the properties of the test definition or the test package according to the test definition type as
described in Configuring Test Definition Properties.

Executing a Trial Run of a Test Definition
You can perform a trial run of a test definition to check if the test definition works as intended.
To perform a trial run of a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Right-click the test definition that you want to try out in the Test Plan tree.
4. Select Try Run Test Definition.
5. The Go To Activities dialog box displays. Click Yes if you want to analyze the results on the Activities
page, or click No if you want to remain on the current Web page.
For additional information, see Activities.
Note: Check the Don't show this dialog again (during this login session) check box if you don’t
want to be asked about switching to the Activities page again in the future. This setting will be discarded
when you log out of Test Manager.

Configuring Test Definition Properties
This section describes how to configure the test properties for each available test definition type.
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Finding Test Definition Properties
The Find command in the Test Plan unit enables you to locate test definition property values that meet specified
search criteria. Use the Next, Previous, First, and Last functions to step through the results of a search for
a specified property value. Find is enabled across all Test Manager plug-ins and functional categories.
Note: Data-driven test property values can be found using the Find command.
Note: When the Test Plan tree is constrained by a filter, Find is only executed against those test definitions
that are presented in the Test Plan tree after filtering.
To find a specific test definition property value:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3.
Click
on the toolbar.
The Find dialog box opens.
4. From the Category list box, select the functional category or Test Manager plug-in across which you want
to search.
Tip: When you define a custom plug-in property, it is automatically added to the list.
5. From the Find in list box, select the property within which the query should search for the value.
The properties available in this list vary based on the selected category.
6. In the Find what text box, type the alphanumeric string the query should search for.
Optional settings are available for qualifying the query further. Check the check boxes of those that are
appropriate:
7. Choose the location in the Test Plan tree where the search should begin.
The following options are available:
Option Button

Description

Start from selection

Specifies that the search begins from the currently selected test plan
element.

Start from top

Specifies that the search begins from the root of the Test Plan tree.

Find in subtree only

Specifies that the search runs only in the sub-tree which has the
currently selected element of the Test Plan tree as its root node.

8. Check the appropriate check boxes to further qualify the query.
The following check boxes are available:
Check Box

Description

Case sensitive

Specifies that the string is searched case-sensitively.
Note: When using a case sensitive SQL Server, case-insensitive
searching is not supported for the following fields: test definition
description, manual step description, manual step action description, and
manual step expected results.
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Check Box

Description

Match whole word only

Specifies that search results only include complete standalone instances of
the query string.

Include read-only values Specifies that search results include text strings that cannot be directly edited
because they are inherited from another test definition, referenced from a
linked test container, or called from a data source in the course of data-driven
testing.
9. Click Find to begin the search and advance to the first test container, test folder, or test definition returned
by the query.
10. If your query returns multiple test plan elements, you are presented with options to advance through the
elements.
Note: The Find command allows you to search test plan elements where the search string is an
inherited value.
Replacing Test Definition Properties
The Replace command enables you to replace identified property values with new values. Replace is enabled
across all Test Manager plug-ins and functional categories.
Note: Data-driven test property values cannot be replaced using the Replace command.
Note: When the Test Plan tree is constrained by a filter, Replace is only executed against those test
definitions that are presented in the Test Plan tree after filtering.
To replace an identified test definition property value:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3.
Click
on the toolbar.
The Replace dialog box opens.
4. From the Category list box, select the functional category or Test Manager plug-in across which you want
to search.
Tip: When you define a custom plug-in property, it is automatically added to the list.
5. From the Find in list box, select the property within which the query should search for the value.
The properties available in this list vary based on the selected category.
6. In the Find what text box, type the alphanumeric string the query should search for.
Optional settings are available for qualifying the query further. Check the check boxes of those that are
appropriate:
7. In the Replace with text box, type the alphanumeric string with which you want to replace the found values.
8. Click Find to begin the search and advance to the first test container, test folder, or test definition returned
by the query. Or click Replace all to replace all instances of the queried string with the replacement string.
9. If your query returns multiple test plan elements, you are presented with options to advance through the
elements.
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Note: The Replace command does not allow you to search test plan elements where the search string
is an inherited value.
Configuring SilkTest Classic Plan Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure the properties of a SilkTest Classic plan test definition:
1. On the New Test Definition dialog box, select SilkTest Classic Plan from the Type list box and then click
Next.
The Plan Properties dialog box opens.
2. In the Plan file text box, type the fully qualified name of the test plan file to be executed.
Click Browse to browse for the file.
3. In the SilkTest Classic project file text box, type the name of the SilkTest Classic project containing the
file and environmental settings.
Click Browse to browse for the project file.
4. In the Option set text box, type the fully qualified name of the option set file containing environmental
settings.
Click Browse to browse for the option set file.
5. In the Data file for attributes and queries text box, type the default path of the test plan initialization file.
Click Browse to browse for the test plan initialization file.
6. In the Test plan query name text box, type the fully qualified name of the saved test plan query.
7. Click Finish.
Configuring TestPartner Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure TestPartner test properties:
1. On the New Test Definition dialog box, select TestPartner Test from the Type list box.
2. Click Next.
The Test Properties - Select Test Script dialog box opens.
3. Click Browse.
The Choose File dialog box opens. The assets available in this dialog box are based on the Project Path
defined in the associated TestPartner source control profile.
4. Select a script from the list and click OK.
Note: To add multiple TestPartner tests, see Adding Multiple TestPartner Tests.
5. In the Playback Options text box, type in the name of a predefined TestPartner playback option or leave
the default value of System Defaults.
6. Click Finish.
Adding Multiple TestPartner Tests
To add multiple TestPartner tests, you must first follow the steps described in Creating Test Definitions.
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To add multiple TestPartner tests:
1. On the New Test Definition dialog box, select TestPartner Test from the Type list box.
2. Click Next.
The Test Properties - Select Test Script dialog box opens.
3. Click Browse.
The Choose File dialog box opens. The assets available in this dialog box are based on the Project Path
defined in the associated TestPartner source control profile.
4. In the Playback Options text box, type in the name of a predefined TestPartner playback option or leave
the default value of System Defaults.
Note: The import gives the defined playback option to all imported scripts. If you need to change the
playback option for any scripts, edit the test definition after the import.
5. Click Next.
The Test Properties - Select Scripts dialog box opens.
6. In the TestPartner Scripts text box, select the scripts to import by clicking CTRL + Click.
7. Click Finish.
Configuring .Net Explorer Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure .NET Explorer test properties:
1. On the New Test Definition dialog box, select .NET Explorer Test from the Type list box and then click
Next.
The .NET Explorer Test Properties dialog box opens.
2. Browse to and select the .NET Explorer script to apply to the test definition.
The script is a .nef file.
3. Browse to and select the NetExplorer.exe executable that executes the selected script file.
For example C:\Program Files\MyCustomSPFolder\DotNET Explorer\NetExplorer.exe.
4. In the Test case text box, type the name of the .NET Explorer script to execute.
If this text box is left blank, all test cases within the script are executed.
Note: The test cases InitTestCase and EndTestCase are always executed.
5. Click Finish.
Configuring JUnit Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure JUnit test properties:
1. On the New Test Definition dialog box, select JUnit Test from the Type list box and then click Next.
The JUnit Test Properties dialog box opens.
2. In the Test class text box, type the fully qualified name of the JUnit test class.
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3. In the Test method text box, type the name of the appropriate test method.
The method must be available in the test class. If the Test method text box is left blank, all tests that are
included in the suite will be executed.
4. Set the Java home directory to the installation path of the Java Runtime Environment (JRE).
The path must be valid on the execution server on which the test definition runs.
5. Specify a valid Java Classpath to use on the execution server.
We recommend to use a relative classpath. The relative classpath is then expanded to the full classpath
on the execution server. By using a relative classpath, changes on the location of the source control profile
do not require additional changes to the classpath.
The relative classpath must point to the root node of the test container containing the JUnit test definition,
for example JUnit_tests. The relative classpath on the execution server is then expanded to include the
working folder of the source control profile, for example C:\temp, and the test file names, for example
JUnit4Test.jar.
To use a previous version of JUnit, you can also add the relative classpath to junit.jar to the classpath,
with the appropriate JUnit version. Test Manager supports JUnit 4.4 or later. For example, if the working
folder of the source control profile is C:\temp, the specified relative paths
junit-4.4.jar;JUnit4Test.jar are expanded to
C:\temp\JUnit_tests\junit-4.4.jar;C:\temp\JUnit_tests\JUnit4Test.jar on the execution
server. By default, if no relative classpath to the junit.jar is specified, Test Manager uses JUnit 4.8.1.
You can also use a fully qualified classpath. The fully qualified classpath must point to the archive or folder
in which the test classes reside. Further, junit.jar must be added to the classpath, with the appropriate
JUnit version, as the following examples show:
•
•

C:\Java\junit4.4\junit.jar;C:\MyApps\main.jar;C:\MyApps\utils.jar
${junit_home}\junit.jar;${apps_home}\main.jar;${apps_home}\utils.jar

6. Optional: In the JVM options text box, you can specify the command-line options and environmental
variables that can affect the performance characteristics of the JVM. You can specify multiple options, but
you have to type them in the right order. For example, to use the client VM and set the maximum size of
the heap to 512MB, type -client -Xmx512m.
7. In the Coverage path text box, type the JAR libraries or the specific class files to monitor for code coverage
information.
We recommend using the relative coverage path from the test container root node, which is then expanded
on the execution server. You can also use a fully qualified path. Use semicolons to separate multiple jar
files, as the following examples show:
•
•

C:\MyApps\main.jar;C:\MyApps\utils.jar
${apps_home}\main.jar;${apps_home}\utils.jar
Note: The coverage path setting is disregarded if the Record external AUT Coverage check box is
checked.

8. Check the Record external AUT Coverage check box to get code coverage for the application under test
that is defined for the execution definition in the Code Analysis Settings portion of Execution ➤
Deployment.
If the check box is not checked, code coverage is recorded from the executing virtual machine. The check
box is by default not checked.
9. Click Finish.
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Note: Parameters are passed to the Java process as system properties, for example
-Dhost_under_test=10.5.2.133. Use the System.getProperty() method to access the system
properties. For example, to access the previously passed host_under_test property, use
System.getProperty(“host_under_test”);.
Configuring Manual Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure manual test properties:
1. On the New Test Definition dialog box, select Manual Test from the Type list box.
2. In the Planned time text box, type the expected amount of time for this manual step to execute and then
click Next.
The Add Manual Test Definition Step dialog box displays.
Note: Manual test steps are automatically timed in seconds from the moment you begin execution.
These values are available in Detail view, not Step-by-Step view.
3. Specify a name, an action description, and the expected results for the first step of the manual test.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
4. Click OK.
5. Optional: Click New Step to add additional steps to your manual test.
Configuring NUnit Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
Note: We recommend that you add the .\bin folder of your NUnit installation to the system path. Click
Start ➤ Control Panel ➤ System ➤ Advanced ➤ Environment Variables to add a path like
C:\Program Files\NUnit 2.2\bin to the system environment variable PATH.
To configure NUnit test properties:
1. On the New Test Definition dialog box, select NUnit Test from the Type list box and then click Next.
The NUnit Properties dialog box displays.
2. Click Browse to locate and select the NUnit assembly from which you want to pull a test definition.
3. Type the working directory in the NUnit Directory text box.
This directory is the local path to the file nunit-console.exe, such as C:\Program Files\NUnit
2.2\bin.
4. In the NUnit Options text box, type one or more NUnit console command-line options to specify how NUnit
tests are specified.
For example, to define that the Flex4TestApp NUnit test, located in SilkTest.Ntf.Test.Flex, should
be executed, set the fixture option as follows:
/fixture:SilkTest.Flex.Flex4TestApp
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Note: When you add multiple options, you have to separate the options by writing one option in each
line in the text box.
5. Click Finish.
Configuring SilkPerformer Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure SilkPerformer test properties:
1. On the New Test Definition dialog box, select SilkPerformer Test from the Type list box and then click
Next.
The Test Properties - Select Project dialog box opens.
2. Perform one of the following steps to define the SilkPerformer project from which your test case is taken:
•
•

Click Browse to select a SilkPerformer project that has been saved to your local file system.
Click Import to import a SilkPerformer project that is saved to the file pool. A file in the file pool can be
used anywhere in the Test Plan tree.

3. On the Import Project From File Pool dialog box, either select a saved .ltz SilkPerformer project package
from the File pool entry list box or click Browse to select a SilkPerformer project package that has been
saved to the source-control system.
If you check the Remove file from file pool check box before you click Finish, the selected SilkPerformer
file is deleted from the file pool.
4. Perform one of the following steps to upload SilkPerformer projects to the file pool:
•
•
•
•

From Administration ➤ Files, click Upload and browse to the appropriate LTZ file. For more information,
refer to the SilkCentral Administration Module Help.
Use the upload mechanism offered by SilkPerformer.
Use the Upload Manager in SilkCentral.
Use an existing project directory by way of a UNC path. Create a new test definition, click Browse to
select the appropriate LTP file, and then select a workload.

5. On the Test Properties - Select Project dialog box, click Next.
6. On the Test Properties - Select Workload dialog box, select one of the workload profiles that has been
defined for the project from the Workload list box.
7. Click Finish to create the test case.
Test Manager is fully integrated with SilkPerformer.
Configuring SilkTest Classic Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure SilkTest Classic test properties:
1. On the Test Properties - Select Test Script dialog box, click Browse and select the test script file from
either the defined SilkTest Classic project or the source control directory.
Express the source control directory as a relative path to the root node defined in the test container.
2. Click Next.
The Test Properties - Select Testcase dialog box opens.
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Note: If the SilkTest Classic script is a data-driven .g.t file, for example SilkTestScript1.g.t,
then data sources are completely controlled within the script file and not through the data-driven
properties of Test Manager. The Data-driven check box is checked by default when you use a
data-driven script file. For more information about data-driven SilkTest Classic tests, refer to the SilkTest
Classic documentation.
3. Select a test case from the available test cases in the defined script file or specify a custom test case.
4. Optional: Type additional execution arguments into the Test data text box.
These arguments are processed by SilkTest Classic during the execution of the test.
5. Define whether the test should provide a TrueLog.
Note: This setting does not apply to the open agent. For more information, refer to the SilkTest Classic
documentation.
6. If required, specify an option set file.
7. Click Finish to create the SilkTest Classic test definition.
Note: If you possess SilkTest Classic test cases that require more than one hour to complete, adjust
the time-out settings for Test Manager. Otherwise, Test Manager assumes an error has occurred and
terminates the execution. For details about time-out settings, refer to the SilkCentral Administration
Module Help.
8. To import multiple SilkTest Classic testcases at the same time select SilkTest Classic Multi-testcase
import from the Type list box in the New Test Definition dialog box and click Next. Follow the steps
described above to complete the task.
Configuring SilkTest Workbench Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure SilkTest Workbench test properties:
1. On the Test Properties - Select Scripts dialog box, select one or more scripts from the SilkTest Workbench
Test list box.
2. In the Playback Options text box, type in the name of a predefined SilkTest Workbench playback option
or leave the default value of System Defaults.
Note: A playback option must be set for a SilkTest Workbench test definition. The delete option on a
SilkTest Workbench test definition will reset the playback option to the default value of System
Defaults.
3. Click Finish.
Configuring Windows Scripting Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure Windows scripting test properties:
1. On the New Test Definition dialog box, select Windows Scripting Test from the Type list box and then
click Next.

196

| SilkCentral Test Manager 2010 R2

The Windows Scripting Properties dialog box opens.
2. Click Browse and select a Windows scripting test script.
3. Specify the location of any required additional parameters in the Switches text box.
Note: You may add other switches to be passed to the script. For more details on the switches that
can be used, see Windows Script Host Tests and refer to the MS Scripting Host documentation.
4. Click Finish.
Configuring Process Executor Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure process executor test properties:
1. On the New Test Definition dialog box, select ProcessExecutor Test from the Type list box and then
click Next.
The ProcessExecutor Test Properties dialog box opens.
2. In the Executable Name text box, type the fully qualified name of the executable.
3. In the Argument List text box, type all arguments of the process executor test method.
Note: Multiple arguments must be on separate lines in the text box.
4. Set the Working Folder.
This is the folder where the executable is executed.
During execution of the executable the following two environment variables can be used:
Environment Variable

Description

SCTM_EXEC_RESULTSFOLDER

All files in this folder are saved as result files in Test Manager. If
an output.xml file is created during execution in this directory,
it is processed by Test Manager.

SCTM_EXEC_SOURCESFOLDER

This is the folder where all source files used during the execution
are located.

Example
The following example contains a ProcessExecutor test type that runs the Windows Script
Host from the command line with the /c switch and two parameters:

•
•

/c - command that specifies that the command line should terminate after execution.
cscript - Windows Script Host.
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•
•

parareadwrite.js - the jscript file named parareadwrite.js
%SCTM_EXEC_RESULTSFOLDER% - the Test Manager variable that contains the location
of the Result folder on the execution server machine. Files stored in this location are
automatically uploaded to Test Manager and available in the Files tab of the Test
Definition Run. In this example, the parareadwrite.js script produces an
output.xml file that is written to the Result folder and uploaded back to Test Manager.

Configuring FitNesse Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure the properties of a FitNesse test definition:
1. On the New Test Definition dialog box, select FitNesse from the Type list box and then click Next.
The FitNesse Test Properties dialog box opens.
2. To specify the fully qualified URL of the FitNesse installation, choose one of the following choices:
•

•

Type the values of the FitNesse host, the port that is used to communicate with FitNesse, and the
FitNesse test-suite into the corresponding Host, Port, and Test Suite text boxes. For example, type
localhost, 8080, and FitNesse.SuiteAcceptanceTests.
Type the fully qualified URL of the FitNesse installation into the FitNesse URL text box. For example,
type localhost:8080/FitNesse.SuiteAcceptanceTests.

3. In the Suite Filter text box, type the name of a filter that you want to use to filter the FitNesse test-suite.
4. To specify whether FitNesse should generate the test output in HTML or XML format, type html or xml in
the Execution Method (html|xml) text box.
5. Optional: In the FitNesse URL text box, type the URL of the computer where FitNesse is installed.
If you leave this text box blank the test will still be executed, because the URL can be generated using the
values in the Host, Port and Test Suite text boxes.
6. Click Finish.

Working With Test Definitions in Grid View
Test Manager ➤ Test Plan ➤ Grid View
The Test Plan unit's Grid View complements the unit's Document View and Test Plan View by facilitating
the filtering, sorting, and grouping of large numbers of test definitions. Grid View eases identifying match
points between test definitions and finding specific test-definition information. Standard Windows keyboard
shortcuts can be used, making it easy to select and manipulate specific sets of test definitions within Grid
View. You can execute trial runs of tests and access test definitions from Grid View. You can also create
execution definitions through multi-selecting test definitions within Grid View.
Grid View offers a number of view-customization features that can help you better manage large numbers of
test definitions.You can display or hide columns, adjust the width of columns, and move columns around using
drag-and-drop. To enhance performance when you have numerous test definitions, page views are broken
into views of 50 test definitions each.You can advance through pages using the First, Last, Next, and Previous.
Or you can enter a page number into the Page text box and press Enter to access the specified page. Sorting,
grouping, and filtering functions are available through context-menu commands to help you better organize
your test definitions, group test definitions, and identify matching points between test definitions. All of your
view-customization preferences are saved along with your project and will be available to you the next time
you visit Grid View.
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Accessing Test Definitions from Grid View
You can access a test definition in Test Plan view directly from the Grid View.
To access a test definition's Properties page from Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Click on the Name of the test definition that you want to access.
Alternatively, right click the row of the test definition and select Go to test.
Creating an Execution Definition in Grid View
To create an execution definition in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Select the test definitions you want to assign to your execution definition, by using the multi-select feature
of the Grid View.
4. Right-click the test definitions and choose Create Execution Definition.
The New Execution Definition dialog box displays.
5. Enter the specifications of your new execution definition.
Note: All selected test definitions must be in the same container. If not, the execution definition is not
created and an error message displays. The test container is preselected in the New Execution Definition
dialog box and can not be altered.
Modifying Attributes for Multiple Test Definitions
To modify attribute values for multiple test definitions:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Select the test definitions for which you want to edit the attributes.
4. Right click and choose Multi-Edit.
The Multi-Edit dialog box opens. This dialog lets you set the value of the selected attribute to the same
value for all selected test definitions.
Tip: Right-clicking on a cell of a specific attribute column preselects this attribute in the Multi-Edit
dialog.
5.
6.
7.
8.

Select Attributes from the Category list.
Select the Name of the attribute to modify.
Select the Value of the attribute that will apply to all selected test definitions.
Click OK.
The selected attribute value is applied to all selected test definitions.

Displaying and Hiding Columns in Grid View
To display and hide columns in Grid View:
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1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click a column header.
4. Expand the Columns submenus to view all the columns that are available in the project.
5. Check the check boxes of all the columns you want to have displayed in Grid View.
Your column-display preferences will be saved and displayed each time you open the active project.
Grouping Test Definitions in Grid View
Beyond simply sorting by column, you can chunk test definitions into groups to facilitate viewing. Groups are
based on commonly-shared values within the column that the grouping is based on.
To group test definitions in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click the header of the column that the sort is to be based on and select Group by This Field.
Test definitions are organized into groups based on commonly-shared values within the column you have
selected.
Removing Grouping of Test Definitions in Grid View
To remove the grouping of test definitions in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click any column.
4. Uncheck the Show in Groups check box.
Sorting Test Definitions in Grid View
To sort test definitions in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click the header of the column you want the test definitions to be sorted by.
4. Select Sort Ascending to have the test definitions sorted in ascending order or select Sort Descending
to have the test definitions sorted in descending order.
Your sort preferences are saved and displayed each time you open the active project.
Reordering Columns in Grid View
To reorder columns in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Select the column header of the column you want to move.
4. Drag the column to the desired position and release it.
Your column-order preferences are saved and displayed each time you open the active project.
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Resizing Columns in Grid View
To adjust the width of a column in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Select the vertical column-header divider of the column you want to adjust.
4. Drag the column boundary to the desired position and release it.
Your column-width preferences are saved and displayed each time you open the active project.
Filtering Test Definitions in Grid View
You can filter the test-definition list based on column values. You can specify the following:
•
•
•

Filter strings to be applied to text-based data fields.
Calendar filters for date-based fields, using Before, After, or On operators.
Numerical operators for number-based fields. >, <, and =.

Filtering Text-Based Values in Grid View
To filter text-based values in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click the header of the text-based column that the filter is to be based on.
4. Expand the Filters submenu on the context menu to display the Filters text box.
5. Type the text string into the text box.
6. Press Enter.
All test definitions that match the filter criteria, for example, in the case of test definition names, all
test-definition names that include the specified string, are then dynamically displayed in the filtered list.
Filtering Date-Based Values in Grid View
To filter date-based values in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click the header of the date-based column that the filter is to be based on.
4. Hold your cursor over Filter on the context menu to display the Before, After, and On submenu.
5. Hold your cursor over After to define a date before which (and including) all test definitions should be
excluded. Hold your cursor over Before to define a date after which (and including) all test definitions should
be excluded. Hold your cursor over On to exclude all test definitions except those that have the specified
date.
The calendar tool displays.
6. Select a date using the calendar tool or click Today to specify today's date.
Tip: You must explicitly click a date on the calendar tool or click Enter to activate date-based filtering
changes.
All test definitions that match the filter criteria are dynamically displayed in the filtered list.
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Filtering Number-Based Values in Grid View
To filter number-based values in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click the header of the number-based column that the filter is to be based on.
4. Expand the Filters submenu on the context menu to display the >, <, and = operators.
5. Enter a number in the > text box to define a number less than which (and including) all test definitions
should be excluded. Enter a number in the < text box to define a number greater than which (and including)
all test definitions should be excluded. Enter a number in the = text box to exclude all test definitions except
those that have the specified number.
Note: Number values are rounded to two decimal places.
6. Press Enter.
All test definitions that match the filter criteria are dynamically displayed in the filtered list.
Filtering Boolean Values in Grid View
To filter boolean values in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click the header of the boolean-based column that the filter is to be based on.
4. Expand the Filters submenu on the context menu to display the available values.
5. Click one of the Yes or No option buttons.
All test definitions that match the filter criteria are dynamically displayed in the filtered list.
Filtering Values Using a Predefined List in Grid View
To filter values using a predefined list in Grid View:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click the header of the column that has a predefined filter value, for example NodeType, that the filter
is to be based on.
4. Expand the Filters submenu on the context menu to display the available values.
5. Check the check boxes of the filter values that you are interested in.
All test definitions having one of the selected criteria will be displayed.
Removing Specific Grid View Filters
Note: You can identify filtered columns by their titles, which are displayed in bold, italic text. Hiding a
column removes all filters that have been applied to the column.
To remove a specific Grid View filter:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
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3. Right-click the header of the column that has the filter you want to remove.
4. Uncheck the Filters check box.
Removing All Grid View Filters
Note: You can identify filtered columns by their titles, which are displayed in bold, italic text. Hiding a
column removes all filters that have been applied to the column.
To remove all Grid View filters:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click any column header and select Reset Filters.
Restoring Default Grid View Settings
Restoring default Grid View settings resets all user-defined settings for the current project. The user-defined
settings are the following:
•
•
•
•
•
•

Column order
Column width
Shown and hidden columns
Applied filters
Sorting
Grouping

To restore the default Grid View settings:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Right-click any column header and select Reset View.

Working with Manual Tests
Converting Manual Tests to Automated Tests
You can convert a manual test to one of the supported automated test types, SilkPerformer, SilkTest Classic,
NUnit, and JUnit, and all installed plug-ins. The process carries manual test parameters over to the automated
test, and adds automated parameters to the new automated test definition.
The manual test parameters that are carried over to automated test definitions are:
•
•
•
•
•
•
•

Name
Description
Assigned requirements
Assigned execution definitions
Assigned issues
Attachments
Test steps

Converting Manual Test Definitions to Automated Tests
To convert a manual test definition to an automated test:
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1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. Right-click the manual test definition in the Test Plan tree and select Automate with....
4. Select the automated test type from the list.
5. For information on filling out the dialog, see the appropriate topic in Configuring Test Definition Properties.
Editing Manual Test Steps
Edit the manual test steps of a test definition or a shared steps object in the Steps page.
To edit a manual test step:
1.
2.
3.
4.

Select the node whose steps you want to edit in the Test Plan or Libraries tree.
Click the Steps tab.
Click on the test step that you want to edit. The details of the test step are shown in the Edit Step view.
Edit the name, action description, expected results, and step properties of the test step in the corresponding
text boxes.
Note: You can insert values from data sources into manual test steps in the form of parameters.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.

5. Perform one of the following actions to finish editing the test step:
•
•
•

Click Ok and New Step to save your changes and add a new step after the current.
Click Ok to save your changes.
Click Reset to revert your changes.

Using External Tools to Create Manual Tests
You can use the open interface of Test Manager to create manual test definitions outside of Test Manager’s
user interface. You can create your own solutions and automatically create manual test definitions by using
Test Manager’s Web Service calls.
The following calls in the tmplanning Web Service assist you in creating manual test definitions:
•
•
•
•
•
•
•
•

getTestContainers
addManualTest
getCustomStepPropertyNames
getChildNodes
getNodeDetails
addNode
updateNode
startExecution

For a detailed explanation of these Web Service calls, see Available Web Services.
Printing Manual Test Definitions
To print manual test definitions:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
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3. Use Ctrl + Click or Shift + Click to select the manual test definitions that you want to print.
4. Right-click the selection and choose Print.
Thre Manual Test Definition Document dialog box opens.
5. Click Print.
Tip: To print a single manual test definition, you can also right-click the test definition in the Test Plan
tree and select Print.
Steps Page
Test Manager ➤ Test Plan ➤ Steps
Test Manager ➤ Libraries ➤ <Shared Steps Object> ➤ Steps
The Steps page lists all manual test steps that are included in the selected test definition or shared steps
object. The page supports standard Windows Explorer style multi-select functionality.
To create a new shared steps object, select the steps you want to share and click

.

The page includes the following toolbar items:
Toolbar Item

Description
Add a new test step to the end of the list.

Insert a new test step before the selected step.

Add a call to a shared steps object to the end of the list.

Add a call to shared steps from a library before the selected
step.
Delete the selected test steps from the list.

Cut the selected test step from the list and move it to the
clipboard.
Copy the selected test steps to the clipboard.

Paste a copy of the test steps held on the clipboard to the
row above the selected in the list.
Move the selected test step one position up in the list.

Moves the selected test step one position down in the list.

Opens the Attachments dialog box, where you can perform
the following actions:
Upload File

Upload and attach a file to the
selected test step.
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Toolbar Item

Description
Attach Link

Attach a link to the selected test step.

Delete

Delete the file or link.

When steps of the test definition or shared steps object call
a shared steps object in a library, click here to view the
original steps. The resolved steps are marked with an arrow,
and you can access them by clicking on their name. You
cannot edit steps while this view is enabled.
View steps called from a shared steps object in a library as
a single step. Enable this view to edit test steps.
Create a shared steps object out of the selected steps.

Detach calls from other shared steps objects. Copies all
steps in the calls you have selected in the grid into the
manual test definition or shared steps object.

The Steps page supports the following keyboard functions (shortcuts) for test plan elements:
Key

Normal

SHIFT

CTRL

-

Move up

+

Move down

A

Select All

X

Cut

C

Copy

V

Paste

N

New

Ins

Insert

Del

Delete

The steps are displayed in a grid with the following columns:
Column

Description

Order

Number of the step in the execution sequence.

Name

Name of the test step.

Action Description

Action you must perform to execute the test step.

Expected Results

Expected result of the test step.

Attachments

Amount of links or files that are attached to the test step.

The Edit Step view shows the details of the selected test step and allows you to edit the name, action
description, expected results, and step properties of the test step.
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The following buttons are available in the Edit Step view:
Button

Description

OK and New Step

Click when you are finished with editing the current step and
you wish to save your changes and add a new step after the
current.

OK

Click when you are finished with editing the current step and
you wish to save your changes.

Reset

Click to revert your changes.

SilkTest Classic Test Definitions
When you observe running SilkTest Classic executions on the Activities page, the currently running execution
definition offers a hyperlink that opens a Details View. This view allows you to closely monitor the state of the
currently running execution definition. For SilkTest Classic test definition executions, the center component of
this view consists of two parts: The upper part shows general information about the test definition, script, test
case, and test data. The lower part shows all output messages generated by SilkTest Classic, along with their
severity.
Test Manager’s SilkTest Classic interface offers a reliable means of automating SilkTest Classic users. Each
test case of a SilkTest Classic script executes within its own test definition execution and produces its own
results.
In previous versions of Test Manager, SilkTest Classic invocation was implemented through a commandline
interface. The new interface works using interprocess communication. You can specify whether or not Test
Manager’s SilkTest Classic interface should be used by configuring test-container settings.
For all SilkTest Classic test parameters that are not defined through SilkTest Classic test properties in the Test
Manager GUI, the SilkTest Classic default settings are used, for example from partner.ini.
You can define the following SilkTest Classic test properties:
Test Property

Description

Test script

The test script, with file extension .t or .g.t, is defined relative to the test container’s
root node in the source control profile. This setting is required for all SilkTest Classic
test definitions.

Testcase

You can select the test case from a list box or type it manually. If the test definition is
not defined as data driven, the test case is required.

Test data

Optional: If several arguments are passed to SilkTest Classic, they have to be separated
by a comma (,). If a String argument is passed to SilkTest Classic, the argument must
be set in quotation marks (“). When test data is more complex, we recommend that you
use parameters in the test data, for example${ParameterName}. Parameters are
replaced automatically within test definition executions.

Data driven

When a SilkTest Classic test requires input data from an external datasource, this flag
must be enabled. Default execution mode for data-driven tests is plan-based.When you
use script-based execution mode for a data driven test, change the DataDrivenScriptMode
setting in the SilkTest Classic element of SccExecServerBootConf.xml.

Option set

Optional: By default, Test Manager closes all open SilkTest Classic option set files. To
specify an option set file, specify the file name relative to the test container’s root node
in the source control profile.
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When the custom test case field is already populated, the SilkTest Classic test definition was automatically
created, using the export functionality within SilkTest Classic. When you use the custom field to specify the
test case, you can terminate the test case name with a parenthesis "()". Inside the parenthesis, you can specify
test data, including parameters.
Note: Specifying data in the custom field will override the values of the Test data property.

Test Definition Attributes
Attributes are administrator-created characteristics that can be applied to tests. You can filter the test plan for
the test definitions with a specific attribute and assign all such test definitions to execution definitions. Examples
include a platform attribute that can be applied to product components and a priority attribute that can be
applied to test definitions.
Assigning Attributes to Test Definitions
To assign an attribute to a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3.
4.
5.
6.

Select the test definition to which you want to assign an attribute.
Click the Attributes tab.
Click Add Attribute to display the Add Attributes dialog box.
Click the plus symbol (+) in the Add column of the attribute that you want to assign.
Based on the attribute type you have selected, an Edit Attribute dialog box displays, where you can specify
which of the available attribute values you want to assign to the test definition.
7. Select attribute value and click OK to assign the attribute to the test definition.
Editing Test Definition Attributes
To edit a test definition attribute:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition for which you want to edit an assigned attribute.
4. Click the Attributes tab.
5. Click the Edit Attribute button of the attribute you are editing.
The Edit Attribute dialog box displays. The available options in the Edit Attribute dialog box vary depending
on the attribute type that you have selected.
6. Select the required value and click OK to save your settings.
Deleting Attributes from Test Definitions
To delete an attribute from a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition from which you want to delete an assigned attribute.
4. Click the Attributes tab.
5. Click the delete icon of the attribute you want to delete.
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The Delete Attribute confirmation dialog box displays.
6. Click Yes to delete the attribute.
Note: Inherited attributes cannot be deleted.
Test Plan Attributes Page
Test Manager ➤ Test Plan ➤

➤ Attributes

The Attributes page in Test Plan View displays all project attributes that are assigned to the selected test
definition. For each attribute, the Attributes page includes the following columns:
Column

Description

Actions

Actions you can perform on the attribute. Delete or Edit.

Attribute

Name of the attribute.

Value

The value of the attribute that is assigned to the test definition.

Type

Attribute type.

Inherited

Whether the attribute is inherited from a parent.

Note: Inheritance of attributes is similar to inheritance of properties and success conditions. Attributes
that are assigned to a parent node are inherited throughout all sub-folders and child test definitions.

Test Definition Parameters
Parameters are freely configurable input values that can be assigned to different test types and used in a
variety of ways. They help to define test definitions by defining test data.
For example, SilkPerformer test definitions use pre-defined parameters that represent the project attributes
that are defined in a selected SilkPerformer test definition.
For JUnit test definitions, any JUnit test class can access a custom parameter of the underlying test definition
as a Java system property; the launcher passes these parameters to the executing virtual machine using the
-D VM argument.
For SilkTest Classic test definitions, parameters serve as symbols within test data properties. You can also
use parameters to parameterize input data for manual test steps.
For details on custom test types, refer to the Test Manager API Help.
Note: For all other test definition types, including custom test types, only custom parameters are supported.
The custom parameters are freely defined by the user. How parameters are applied for each test definition
type varies depending on how the test types, or the plug-ins for external test types, are implemented. The
built-in external test types are currently only of relevance for JUnit. The JUnit test type passes all parameters
to the executing Java VM as Java system properties.
For configuration testing, you can override the test definition parameters in an execution definition. For additional
information, see Execution Definition Parameters.
Creating Custom Parameters
To create a custom parameter:
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1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition node for which you want to create a new parameter.
4. Click the Parameters tab.
5. Click Add Custom Parameter.
The Set Custom Parameter dialog box displays.
6. Provide a name for the parameter.
7. In the Type list box, select the parameter type.
•
•
•
•
•
•

String
Number
Float
Boolean
Password
Character

8. Define the parameter value that you want to assign to the selected test definition.
Note: Values for parameters of type String must be set in quotation marks (“) if you want to use the
parameter in SilkTest Classic executions.
9. Click OK.
Note: Parameters are automatically assigned to all sub-folders and child test definitions of the nodes
to which they’ve been assigned.
The parameter now displays in the Parameters page of the selected node.
Adding Predefined Parameters to Test Definitions
To add a predefined parameter to a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select the test definition node to which you want to add a predefined parameter.
4. Click the Parameters tab.
5. Click Add Predefined Parameter.
Note: For SilkPerformer test definitions, the Add Predefined Parameter button is only available for
test definitions for which the Project property is already defined.
The Add Predefined Parameter dialog box displays, which lists all of the project attributes that are available
in the project file.
6. To add any of the listed parameters, click the corresponding add icon.
7. On the dialog box that displays, specify the actual value for the parameter.
8. Click Save to add the parameter to the active Test Plan tree node.
Editing Predefined Parameters
To edit a predefined parameter:
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1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition node for which you are editing an existing parameter.
4. Click the Parameters tab.
5. In the parameter you want to edit, click Edit.
The Set Custom Parameter dialog box displays.
6. Edit the parameter values as required.
Note: Inherited parameters cannot be edited. Uncheck the Inherit from parent check box to enable
editing of the parameter’s Value setting. Parameter Name and Type settings cannot be edited.
Deleting Predefined Parameter Assignments
To delete a predefined parameter assignment:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select the test definition node for which you are deleting the assignment of an existing
parameter.
4. Click the Parameters tab.
5. Click Delete in the Actions column of the parameter that you want to delete.
Note: Inherited parameters cannot be deleted. Uncheck the Inherit from parent check box on the
Set Parameter dialog box to enable deletion of an inherited parameter.
6. Click Yes on the Delete Parameter dialog box to delete the parameter.
Parameters within Parameter Values
You can use parameter values that contain parameters. The evaluation result of such parameter values is
shown in a bold font in the GUI. The following example shows how to use such a parameter:
parameterA := aaa
parameterB := bbb + ${parameterA}
Evaluated values:
parameterA = aaa
parameterB = bbb + aaa
Parameter Notations
The following parameter notations are supported:
For all test definitions:
${<parameter>}
All characters are allowed for parameter names, except $, {, }, and #.
Deprecated notation for manual test definitions:
#<parameter>#
For manual test definitions, the following characters are allowed for parameter names: 0-9, a-z, A-Z, and _.
Additional notation for SilkTest Classic test definitions:
$<parameter>
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For SilkTest Classic test definitions, the following characters are allowed for parameter names: 0-9, a-z, A-Z,
and _.
Parameter-Token Replacement Upon Execution
Any string input for a property of a test definition may contain placeholders in the following form:
${parametername}. parametername must match the name of a parameter defined or inherited for the test
definition. At execution time, the placeholder is replaced by the value entered for the parameter with the denoted
name. This makes recurring strings in properties more customizable and facilitates the editing of common
definitions.
When Test Manager finds a parameter with the notation ${<parameter>}, it first checks if the parameter is
included in the defined parameters, and if not, it checks if the parameter is an environmental variable.
For example, if the value of a JUnit classpath property is junit.jar;${MyWorkingDir}/myclasses and
the parameter MyWorkingDir has the value C:/Temp/MyWorking, the resultant effective property value is
junit.jar;C:/Temp/MyWorking/myclasses.
Note: The value of a parameter may also contain other parameter placeholders, which allows nesting
based on the same principle.
Test Plan Parameters Page
Test Manager ➤ Test Plan ➤

➤ Parameters

In Test Plan View, the Parameters page displays the test parameters that are assigned to the selected test
definition. For each parameter, the page display the following columns:
Column

Description

Actions

The actions that you can perform on the parameter. Delete and
Edit.

Parameter

Name of the assigned parameter.

Value

The selected parameter value for this test definition.

Type

Inherited

•
•
•
•
•
•

String
Number
Float
Boolean
Password
Character

Indicates if the parameter has been inherited from a parent.

Note: Test definition parameters that are contained within a property of a test definition, for example
testdata for SilkTest Classic test definitions, are listed at the top of the Parameters page. Unused
parameters are appended to the bottom of the list and grayed out, analogous to a disabled state.
Note: When the Parameters page includes more elements than can be displayed at once without impacting
response time, elements are displayed in increments. Page number links at the bottom of the tab allow
you to browse through the elements included on the page one page at a time. To display all elements as
a single list, select the [All] link.
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Test Plan Parameters Page - SilkTest Workbench
Test Manager ➤ Test Plan ➤ Data Set
When passing parameters from a Test Manager test definition to a SilkTest Workbench visual test – the
following data types should be used:
Test Manager

SilkTest Workbench

String

Text

Number

Number (Long)

Number

Number (Long Long)

Number

Enumeration

Float

Number (Double)

Boolean

Boolean (True/False)

Associating Requirements with Test Definitions
This section explains how to assign requirements to test definitions.
Assigning Requirements to Test Definitions
To manually assign requirements to test definitions:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select the test definition to which you want to assign requirements.
4. Click the Assigned Requirements tab.
Note: If you have created a requirements filter, you can select it from the filter list above the Available
Requirements tree. To create a new requirements filter, navigate to Test Manager ➤ Requirements
and click

on the toolbar.

All requirements that are available for assignment are displayed in the Available Requirements tree.
5.

Click
to the left of a requirement or double-click on the requirement to assign it to the selected test
definition.
Note: Newly generated test definitions can automatically be assigned to the requirements from which
they are generated by checking the Assign newly generated Test Definitions to Requirements
check box on the Generate Test Plans from Requirements dialog box. This is the default behavior.

Sorting Assigned Requirements
To sort the assigned requirements:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a test definition.
4. Click the Assigned Requirements tab.
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5. Click the column header of the property by which you want to sort the requirements.
A small upward or downward pointing arrow indicates both which column the sort is based and the direction
of the sort, ascending or descending.
6. If required, click the column header again to reverse the direction of the sort.
Locating Assigned Requirements
To locate assigned requirements in the Available Requirements tree:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a test definition.
4. Click the Assigned Requirements tab.
5.
In the Actions column of a requirement, click
tree the requirement is stored in.

to find out in which node in the Available Requirements

The corresponding parent-requirement node is expanded and the assigned requirement is highlighted.
Removing Requirement Assignments
To remove a requirement assignment:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a test definition that has at least one requirement assigned to it.
4. Click the Assigned Requirements tab.
5. In the Actions column of the assigned requirement, click .
6. Click Yes on the confirmation dialog box to confirm deletion of the assignment.
Note: To remove all requirement assignments from the selected test definition, click Remove All.
Test Plan Assigned Requirements Page
Test Manager ➤ Test Plan ➤

➤ Assigned Requirements

The Assigned Requirements page lists the requirements that have been assigned to the selected test definition
or project, and allows you to assign additional requirements. The Available Requirements tree lists all
requirements that can be assigned.
Note: If you have created a requirements filter, you can select it from the filter list above the Available
Requirements tree. To create a new requirements filter, navigate to Test Manager ➤ Requirements
and click

on the toolbar.

For each assigned requirement, the page displays the following columns:
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Column

Description

Actions

Actions that you can perform on the selected requirement. Remove
Requirement, Locate, and View Description.

Requirement

Name of the assigned requirement. Click to open the Requirements ➤
Properties page.
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Column

Description

Priority

Priority of the requirement.

Risk

Potential risk associated with the requirement.

Reviewed

Review status of the requirement.

Working with Test Plan Attachments
This section describes how to work with attachments in the Test Plan unit.
Attaching Files to Test Plan Elements
To attach a file to a test plan element:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a container, folder, or test definition.
4. Click the Attachments tab.
5. Click Upload File.
The Upload File dialog box opens.
6. Click Browse to select a file from your local file system.
7. Enter a description for the attachment.
8. Click Ok to upload the attachment to the server and associate it with the selected element.
Note: Attaching files to a test plan element may not work in Mozilla Firefox. Firefox requires usage of
three slashes, for example file:///, for a file link, while other browsers require only two, for example
file://. Aditionally, Firefox includes a security feature blocking links from remote files to local files and
directories. For more information, see
http://kb.mozillazine.org/Firefox_:_Issues_:_Links_to_Local_Pages_Don't_Work.
Attaching Links to Test Plan Elements
To attach a link to a test plan element:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a container, folder, or test definition.
4. Click the Attachments tab.
5. Click Attach Link.
The Attach URL dialog box opens.
6. Type the URL in the URL text box.
7. Type a description for the attached link.
8. Click Attach URL to associate the link with the selected element.
Viewing Test Plan Attachments
For a selected test plan element, the Attachments page lists the attached files and links. The attachments
are by default displayed in the order in which they are uploaded, but you can sort the attachments by columns.
To display the attachments that are associated with child elements of the selected element, check the Include
Child Attachments check box.
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To view a test plan attachment:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select the element for which you want to view an attachment.
4. Click the Attachments tab.
5. Click on the name of the attachment.
The name of each listed attachment serves as a link. File-attachment links open a Save As dialog box,
enabling you to download the attachment to your local file system. Link-attachments link directly to the link
destinations in a new browser window.
Deleting Attachments from Test Plan Elements
To delete an attachment from a test plan element:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select the element from which you want to delete an attachment.
4. Click the Attachments tab.
5.
In the Actions column of the attachment you want to delete, click
.
6. Click Yes on the confirmation dialog box to delete the attachment from the project.
Note: Only one attachment at a time can be deleted.
Test Plan Attachments Page
Test Manager ➤ Test Plan ➤

➤ Attachments

The Attachments page lists all files and links that have been uploaded as attachments to the selected test
containers, folders, and test definitions. Check the Include Child Attachments check box to additionally
display all attachments of child test definitions, folders, and test containers of the selected node. For each
listed attachment, the page displays the following columns:
Column

Description

Actions

Actions that can be taken on the attachment. Delete.

Name

Name of the attachment.

Size

Size of the attached file.

Description

Description that has been defined for the attachment.

Created On

When the attachment or link was uploaded.

Created By

User who uploaded the attachment.

Assigned Executions
Viewing Assigned Executions
To view a list of executions that are assigned to a test definition:
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1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition for which you want to view the assigned executions.
4. Click the Properties tab.
The complete list of executions that are assigned to the selected test definition is displayed in the Assigned
Executions grid.

Test Plan Runs Page
Test Manager ➤

➤ Test Plan ➤ Runs

The Runs page is available on test-definition nodes in Test Plan View and offers a listing of test execution
results for the selected test definition.
The data grid representation of the Runs page facilitates the filtering, sorting, and grouping of large numbers
of test definition runs.
To compare two test definition runs, use Ctrl + Shift to select the two runs. Right click on your selection and
click Reports ➤ Test Definition Run Comparison.
For each run, the page displays the following columns:
Column

Description

Actions

Actions that you can perform
on the test definition run.
New
Issue

Click to open the
New Issue dialog
box and create a
new issue for the
test definition.

Assign Assign an issue
External from an
Issue externally-configured
issue-tracking
system to the test
definition.
Run ID

The ID of the test definition
run. Click to open the Test
Definition Run Results
dialog box. If the test
definition is running, click to
view details of the execution.

Run Type

The Run Type column shows
the test definition type during
each run. The test type might
change between two runs, for
example when you convert
the test from manual to
automated.
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Column

Description

Start Time

Time the run started. If the
test is a manual test and
currently running, Test
Manager adds (Running) to
the date and time.

Duration

Duration of the test definition
run in h/mm/ss.

Execution Definition Name

The name of the assigned
execution definition, or
Unassigned Tests if the
execution was a try-run or
results were uploaded. Click
to open the execution
definition.

Status

Status of the execution. For
test definitions that are part
of a running execution
definition, the status is
updated in response to the
current status of the test run.
If the current run is aborted,
the status is reset to the
status before the run.

Issues Found

Displays the amount of
issues that are assigned to
the test definition run. When
no issues are assigned to the
test definition run, the column
is empty. Click on the link to
access the issue in the
Issues page of the Test Plan
unit.

Executed By

The execution server from
which the test was run.

Errors

Number of errors that were
generated during the run.

Warnings

Number of warnings that
were generated during the
run.

Version

Version that the test was run
against.

Build

Build number that the test
was run against.

Execution Definition Parent

The configuration suite or
folder in the context of which
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Column

Description
the execution definition is
executed. Click to access the
suite or folder in the
execution tree. If the
execution definition is not
included in a configuration
suite or folder, nothing is
displayed.

Test Plan Issues Page
Test Manager ➤ Test Plan ➤

➤ Issues

The Issues page enables you to enter and track issues related to the selected test definition, container, or
folder.
Click New Issue to assign a new issue to the selected test definition. This button is only displayed if the currently
selected object is a test definition.
Click Assign External Issue to assign an issue from an external issue tracking system to the selected test
definition. This button is only displayed if the currently selected object is a test definition.
For each issue, the page displays the following columns:
Column

Description

Actions

Actions that can be performed on the issue. Delete.

Issue ID

ID that has been automatically assigned to the issue.

Assigned Test Definition

Test definition that has been assigned to the issue. This
column is only displayed if the currently selected object is a
container or a folder.

Synopsis

Synopsis of the issue.

Status

Status of the issue.

External ID

Indicates if the issue is tracked by an external issue tracking
system. Click an external issue number to link directly to the
external issue tracking system.

Test Definition Run

The ID of the test definition run that the issue is assigned
to. Click on the ID to access the Details page of the Test
Definition Run Results dialog box in the Execution unit.

Created On

When the issue was created.

Created By

User who created the issue.

Profile

Name of the issue tracking profile, as defined in Test
Manager ➤ Settings ➤ Issue Tracking.

New Issue

Assign a new issue to the selected test definition. This button
is only displayed if the currently selected object is a test
definition.
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Column

Description

Assign External Issue

Assign an issue from an external issue tracking system to
the selected test definition. This button is only displayed if
the currently selected object is a test definition.

Data-Driven Tests
Data-driven tests are tests that are derived from values in an existing data source, such as a spreadsheet or
a database. Before you can work with data-driven tests, you need to configure a data source. For details on
data sources, refer to the SilkCentral Administration Module Help.
Creating Data-Driven Test Definitions
To create a data-driven test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Create a new test definition.
For information about creating a test definition, see Creating Test Definitions.
4. Click the newly created test definition's Properties tab.
select the Edit icon to open the Data-driven Properties dialog box.
5.
Scroll down to the Data-driven Properties section of the Properties tab and click
.
The Data-driven Properties dialog box opens.
6. Select a pre-configured data source from the Data Source list box.
For information on configuring data sources, refer to the SilkCentral Administration Module Help.
7. Click Next to continue.
8. Select a data set from the Data Set list box.
In the case of Excel data sources, this is a worksheet name. In the case of database data sources, this is
a table name.
9. Check the Each data row is a single test definition check box to have each row in your data set considered
to be a separate test definition, or do not check this check box to create a single test definition for all data
rows of your data set.
10. Optional: You can enter a SQL query into the Filter query text box to filter your data set based on a
SQL-syntax query.
Note: Only simple WHERE clause queries are supported.
11. Check the Enable data-driven properties check box to enable data-driven functionality.
12. Click Finish to save your settings.
Note: Data-driven property settings are visible in the lower portion of each test definition’s Properties
page.
Note: To use the data-driven test functionality of Test Manager with SilkPerformer scripts, data sources
with column names matching the corresponding SilkPerformer project attributes must be used in
conjunction with AttributeGet methods.
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Adding a Data Source Value to a Manual Test Step
To add a data source value to a manual test step:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Create a new data-driven test definition.
Select Manual as the test type and configure test steps.
Note: To view the values included in your data source, click the Data Set tab of the test definition.
4. Click the Steps tab.
5. Select the test step that should reference the data source value.
6. In the Action description text box, enter a parameter that references the relevant column in your data
source, using the syntax ${<column name>}.
For example, if you want a test step to retrieve password parameters from a spreadsheet that has a column
called Password, you would write the parameter as ${Password}. When you execute the manual test
step, the parameter is replaced by an actual value in the corresponding data-driven data source.
Downloading CSV Data From a Data Source
To download CSV data from a data source:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select a test definition that relies on the data source from which you want to download data.
4. Click the Properties tab.
5. In the Actions column of either the data source or the data set, depending on which entity contains the
data you want to download, click Download.
6. Specify the location on your local system to where the data is to be downloaded.
7. Click OK to download the data in CSV format.
Editing Data-Driven Properties
To edit data-driven properties:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition that has the property you want to edit.
4. Click the Properties tab.
5.
In the Actions column of the property you are editing, click
.
6. Edit the property as required.
7. Click OK to save your changes.
Single and Multiple Data-Driven Test Definition Instances
When planning data-driven tests, you should first be aware of the following two different data-driven test types
that are available in Test Manager:
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Single data-driven test
definition instance

A single test definition result is generated for all data rows of your data source.
This means that the test definition is only successful if the execution with every
single data row is successful. If the execution with one data row fails, the whole
test definition is marked as failed.

Multiple data-driven test
definition instance

Each data row of your data source is represented by a test definition of its own.
This means that each data row produces a failed or passed test definition result.
For example, if your data source is a spreadsheet with four rows, you will have
the original test definition you created as a parent test definition in addition to
four new child definitions, one for each of the data rows.

Note: The parent test definition created in this process does not have parameters associated with it, since
it only represents a structuring instance for its child test definitions and no longer functions as an actual
test definition. All values found in the data source will be listed on the parent test definition’s Data Set
page.
Note: When assigning a parent test definition to a requirement, links to requirements are only inherited
when using single data-driven test definition instances.
Note: You can not assign the parent test definition of a multiple data-driven test definition instance to a
setup or cleanup test execution, as such a parent node is treated as a folder. You can assign one of its
child nodes though, and you can also assign a single data-driven test definition instance to a setup or
cleanup test execution.
Worksheet Handling
If your data source is a Microsoft Excel worksheet, you should follow these guidelines to ensure a successful
and maintainable data-driven test definition setup:
•
•
•

Make your column names self-describing. This will make the data source setup in Test Manager easier to
maintain.
If you use multiple worksheets, use consistent column names across the worksheets. This will make it
easier for you to apply filters for selecting columns for your data source setup.
Use certain columns as “key” columns. Key columns will allow you to maintain your data source file, while
Test Manager is still able to identify specific data rows due to the value in the key column, despite changes
in row orders. Values within a key column should be unique.

Data Import Considerations
When importing data rows from an external data source, Test Manager does not account for row sorting
functionality used in the external data source. Due to this, the order of data rows in Test Manager might differ
from the row order in the external data source. Test Manager also ignores any format settings that have been
applied in the external data source. For example, if you formatted date cells in an Excel worksheet to display
the date in a certain way, Test Manager will ignore this setting and import any date values in the base format
"YYYY.MM.DD HH:MM:SS.M".
Test Plan Data Set Page
Test Manager ➤ Test Plan ➤

➤ Data Set

The Data Set page lists all data that is defined for data-driven testing with the selected test definition.
The Filter query row at the top of the list displays the filter value that is defined for this data set. The values
of the configured data set are displayed below this row.
Note: Data sets and filters are defined through the SilkCentral Administration Module.
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For each data set, the page displays the following columns:
Column

Description

Actions

Actions that can be
performed on the data set or
filter. Edit and Delete.

Property

The name of the data set or
filter.

Value

The value of the filter or data
set for the selected test
definition.

Inherited

Indicates whether or not the
data set or filter was inherited
from a parent test container
or test definition.

Note: When the page includes more elements than can be displayed at once without impacting response
time, elements are displayed in increments. Page number links at the bottom of the page allow you to
browse through the elements included on the page one page at a time. To display all elements as a single
list, click the [All] link.

Windows Script Host Tests
Windows Script Host (WSH) is part of the Windows platform and creates an environment for hosting scripts.
When a script is to be run at the execution server, WSH plays the role of host. It makes objects and services
available for the script and provides a set of guidelines within which the script is executed. Among other things,
WSH manages security and invokes the appropriate script engine.
The following online WSH resources might be of value to you:
•
•
•

http://labmice.techtarget.com/scripting/WSH.htm
http://www.winguides.com/links.php?guide=scripting
Downloadable Script Interpreters: http://aspn.activestate.com/ASPN/

Supported Script Languages
WSH is language-independent for WSH-compliant scripting engines. Natively, the Windows platform supports
Visual Basic Scripts, with file extension .vbs, and scripts written in the Java Script language, with file extension
.js.
For other scripting languages, a dedicated script interpreter must be installed on the execution server. For
example, if you install a Perl interpreter on an execution server, this will register a Perl scripting engine at the
WSH environment for the extension .pls. Whenever a file with extension .pls is passed to the WSH tool,
with the executable cscript.exe, it will invoke the appropriate interpreter because of the file extension. So
the client of WSH, in this case the SilkCentral Execution Server, does not need to know about the installation
of the Perl interpreter.
Note: After installing a script interpreter, for example Active Perl, try to execute a script locally on the
execution server by calling the WSH command line tool with a sample script before executing the script
in Test Manager. To do so, open a command shell on the execution server and type cscript
<somescript>, where <somescript> is the path to a script of your choice that is available on your
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execution server. This is exactly what Test Manager will call when executing a WSH test definition on an
execution server. If the script is executed, then the scripting engine has been registered successfully.
The following scripting languages are WSH compatible:
Scripting Language

File Extension

Perl

.pls

Python

.py, .pyw

REXX

.REXX

TCL

.tcl

WSH Test Properties
Property

Description

Script

You can define any file where a script engine is registered for the script language the file contains.
Script files under source control are deployed automatically to execution servers, comparable
to test sources for other test definition types.

Switches

You can enter and pass the following settings to cscript.exe during the execution of the
test:
//B

Batch mode suppresses all non-command-line console UI requests from the
script. We recommended that you use this option to prevent a script from
waiting for user input during unattended executions at the execution server.

//U

We recommend to that you use unicode for redirected I/O from the console.

//T:nn

Time-out, in seconds. The maximum time the script can run, by default = no
limit. This option is used to prevent excessive execution of scripts. It sets a
timer. When execution time exceeds the specified value, Cscript interrupts
the script engine using the IActiveScript::InterruptThread
method and terminates the process. There is a callback hook. If the time-out
is invoked, the OnTimeOut function is called to permit cleanup. Although
it is possible to create infinite loops using this feature, it is more useful than
harmful.

//logo

Displays an execution banner at execution time that is visible at the beginning
of the log.txt log file. This is the default setting.

//nologo

Prevents display of the execution banner at execution time.

//D

Enables active debugging.

//E:engine

Use the engine to execute a script.

//Job:xxxx

Execute a WSF job.

//X

Execute the script in debugger.

Using Parameters in WSH Tests
Parameters that are defined for a WSH test definition automatically add a name and value pair to the command
line as an additional argument and set the parameters as environment variables for the called process. This
functionality allows you to access all parameters defined for your test definition within the WSH script.
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For example a WSH test definition is defined with myscript.js as script and //B as switch. Additionally the
test requires a parameter called IPAddress with the value 192.168.1.5 and another parameter called Port
with the value 1492. The resulting command line for the WSH execution in this example is:
csript myscript.js //B IPAddress=192.168.1.5 Port=1492

Viewing Information Returned from WSH
To collect results of a WSH execution, the WSH script must generate a file called output.xml in the current
working directory of the WSH test. All files residing in this directory are stored in the database and are
downloadable through the list of files for the test definition execution. Files are excluded from storage when
their extensions are defined under the file extensions to ignore in results property in the Projects unit.
Note: The current working directory is dynamically created for each WSH execution. Do not use an
absolute path when creating the file. Any relative path used will correctly refer to the current working
directory.
Any information that a script writes to the WSH standard output goes into the log.txt text file that resides
in the current working directory. This file is stored in the database and can be viewed as it is included in the
file list of the test definition execution.
The following example shows how to print log information from a script:
WScript.Echo "This info will be written to the log.txt file"
The XML structure of output.xml begins with an element ResultElement that defines an attribute named
TestItem, which specifies the name of the ResultElement.
The ResultElement must contain an element named ErrorCount, optionally an element named WarningCount,
and a list of Incident elements.
The ErrorCount and WarningCount elements must contain a positive number or zero. The ErrorCount and
WarningCount of the top-level ResultElement are used for evaluating success conditions, which determine if
a test has passed or failed. The XML file might contain additional elements that are not visible in the Test
Manager GUI. The output.xml file is however stored in the database and is viewable as it is included in the
file list of the executed test definition.
The Incident element represents an event that happened during the execution of the WSH test. Message and
Severity are shown in the messages list of test definition executions in the Test Manager GUI. An Incident
element must contain a Message and a Severity element.
The Severity element must hold one of the following values:
•
•
•
•

Info
Warning
Error (or Exception)
Failure

You can store additional information in the result file. The ResultElement may contain any number of
sub-ResultElements, so information can be easily grouped. Sub-ResultElements make the result file easier to
read. For compatibility reasons related to unit tests, JUnit and NUnit, ResultElement can be named TestSuite
or Test.
The ResultElement may contain the following additional elements:
•
•
•

FailureCount, which is treated the same way as error count
RunCount, if a test is run multiple times
Timer, for example for the duration of the test
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•
•

WasSuccess, for compatibility with NUnit result files
Asserts, for compatibility with NUnit result files

The Incident element may contain a list of Detail elements.
The Detail element represents detailed information about an Incident. It must define a TestName element and
an Info element. The TestName is used to give detailed information about where the Incident happened. The
Info element holds detailed information about the Incident, for example a stack trace.
Note: Up through Test Manager 8.1, the value of the Message and Info elements had to be URL encoded
(ISO-8859-1). Since version 8.1.1, URL encoding is no longer allowed.
Sample Result File
<ResultElement TestItem="WshOutputTest">
<ErrorCount>1</ErrorCount>
<WarningCount>1</WarningCount>
<Incident>
<Message>some unexpected result</Message>
<Severity>Error</Severity>
<Detail>
<TestName>function main()</TestName>
<Info>some additional info; eg. stacktrace</Info>
</Detail>
</Incident>
<Incident>
<Message>some warning message</Message>
<Severity>Warning</Severity>
<Detail>
<TestName>function main()</TestName>
<Info>some additional info; eg. stacktrace</Info>
</Detail>
</Incident>
</ResultElement>

Java Script Sample
The following script was used to generate the sample result file. To try this script save it
with the extension .js.
function dumpOutput(dumpFile)
{
dumpFile.WriteLine("<ResultElement TestItem=\"WshOutputTest\">");
dumpFile.WriteLine(" <ErrorCount>1</ErrorCount>");
dumpFile.WriteLine(" <WarningCount>1</WarningCount>");
dumpFile.WriteLine(" <Incident>");
dumpFile.WriteLine("
<Message>some unexpected result</Message>");
dumpFile.WriteLine("
dumpFile.WriteLine("
dumpFile.WriteLine("
dumpFile.WriteLine("
stacktrace</Info>");
dumpFile.WriteLine("
dumpFile.WriteLine("
dumpFile.WriteLine("
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<Severity>Error</Severity>");
<Detail>");
<TestName>function main()</TestName>");
<Info>some additional info; eg.
</Detail>");
</Incident>");
<Incident>");

dumpFile.WriteLine("

<Message>some warning message</Message>");

dumpFile.WriteLine("
<Severity>Warning</Severity>");
dumpFile.WriteLine("
<Detail>");
dumpFile.WriteLine("
<TestName>function main()</TestName>");
dumpFile.WriteLine("
<Info>some additional info; eg.
stacktrace</Info>");
dumpFile.WriteLine("
</Detail>");
dumpFile.WriteLine(" </Incident>");
dumpFile.WriteLine("</ResultElement>");
}
function main()
{
var outFile;
var fso;
fso = WScript.CreateObject("Scripting.FileSystemObject");
outFile = fso.CreateTextFile("output.xml", true, true);
outFile.WriteLine("<?xml version=\"1.0\" encoding=\"UTF-16\"?>");
dumpOutput(outFile);
outFile.Close();
WScript.Echo("Test is completed");
}
main();
WScript.Quit(0);

Visual Basic Script Sample
The following Visual Basic script also generates the sample result file, and saves it as
Output.xml. To try this script save it with the extension .vbs.
WScript.Echo "starting"
Dim outFile
Dim errCnt
Dim warningCnt
outFile = "output.xml"
errCnt = 1 ' retrieve that from your test results
warningCnt = 1 ' retrieve that from your test results
Set FSO = CreateObject("Scripting.FileSystemObject")
Set oTX = FSO.OpenTextFile(outFile, 2, True, -1) ' args: file,
8=append/2=overwrite, create, ASCII
oTX.WriteLine("<?xml version=""1.0"" encoding=""UTF-16""?>")
oTX.WriteLine("<ResultElement TestItem=""PerlTest"">")
oTX.WriteLine(" <ErrorCount>" & errCnt & "</ErrorCount>")
oTX.WriteLine(" <WarningCount>" & warningCnt & "</WarningCount>")
oTX.WriteLine(" <Incident>")
oTX.WriteLine("
<Message>some unexpected result</Message>")
oTX.WriteLine("
<Severity>Error</Severity>")
oTX.WriteLine("
<Detail>")
oTX.WriteLine("
<TestName>function main()</TestName>")
oTX.WriteLine("
<Info>some additional info; eg.
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stacktrace</Info>")
oTX.WriteLine("
</Detail>")
oTX.WriteLine(" </Incident>")
oTX.WriteLine(" <Incident>")
oTX.WriteLine("
<Message>some warning message</Message>")
oTX.WriteLine("
<Severity>Warning</Severity>")
oTX.WriteLine("
<Detail>")
oTX.WriteLine("
<TestName>function main()</TestName>")
oTX.WriteLine("
<Info>some additional info; eg.
stacktrace</Info>")
oTX.WriteLine("
</Detail>")
oTX.WriteLine(" </Incident>")
oTX.WriteLine("</ResultElement>")

Test Plan Import
This section describes how to import test plans from Microsoft Excel into Test Manager.
Test Manager enables you to import test plan elements from Microsoft Excel (Excel) into any container or
folder in the Test Plan unit and then maintain and execute all included tests in Test Manager. The import is a
one-time event.
Before you can import test plans, you need to create a test plan file in Excel. For more information , see Test
Plan File.
Test Manager uses the information stored in the Excel file and in a mapping file to determine what data to
store and captures only the information that is mapped with certain styles. Test Manager uses a mapping file
to map the test plan elements in the Excel file to the test plan. When you map the special Test Manager styles
to your Excel file, you indicate that you want to create a test based on the test plan elements in the Excel file.
A default mapping file named TestPropertiesDefaultMapping.xml is preselected for the import. You
can choose your own customized mapping file to map your test plan elements. For more information about
mapping files, see Test Plan Mapping File.
Note: Currently, Test Manager supports only Microsoft Excel 2007 (.xslx) files for import, and the import
is limited to manual tests.

Importing a Test Plan from an Excel File
To import a test plan from an Excel file into the Test Plan unit:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, right-click the folder or container that you want to use as the parent node of the
imported test plan and choose Import from Excel File.
The Import Test Plan from Excel File dialog box opens.
4. Select the mapping file from the Choose Mapping File list box.
The default mapping file is TestPropertiesDefaultMapping.xml. For information about creating
customized mapping files, see Test Plan Mapping File.
5. Optional: Click Edit Mapping to edit the test plan mapping file.
6. Either type the fully qualified path of the test plan file into the Test Plan File text box or click Browse to
search for the test plan file.
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7. Click OK.
8. A message informs you if the import was successful. Click OK to close the message.

Test Plan Mapping File
The XML mapping file enables Test Manager to translate the information included in the Excel test plan file
into the actual test plan. The tags in the XML file point Test Manager to the location of the test plan elements
in the Excel test plan file. The default mapping file is located in C:\Documents and Settings\All
Users\Application
Data\SilkCentral\OfficeImportMappingFiles\testplan\TestPropertiesDefaultMapping.xml.
Note: The column names which are tagged in the XML mapping file can be standard Excel columnn
names or custom names.
The following administrative tags are required:
Tag

Description

HeaderRow

The row in the Excel spreadsheet in which Test Manager searches for the
column headers.

FirstDataRow

The row in the Excel spreadsheet in which Test Manager seeks for the
first test data. If the row is empty, Test Manager imports the next row with
data.

MultiValueSeparatorCharacters Lists the separator characters for multivalue attributes.
The following test-definition tags are required:
Tag

Description

Path

Identifies the column in the Excel spreadsheet that defines the path from the
test plan root node to the test element.

TestName

Identifies the column in the Excel spreadsheet that defines the name of the test.

PlannedTime

Identifies the column in the Excel spreadsheet that defines the expected
execution duration of the manual test.

TestDescription

Identifies the column that defines the description of the test.

If the tests include test steps, the following test-step tags are required:
Tag

Description

StepName

Identifies the column that defines the name of the test step.

StepActionDescription

Identifies the column that defines the action performed by the test
step.

StepResultDescription

Identifies the column that defines the result of the test step.

You can also define the following optional tags as necessary:
Tag

Description

CustomStepProperty

Any custom property that you want to define for the test step.

Attribute

Any custom attribute that you want to define for the test step. An attribute can
possess multiple values. For example, <MappingDef columnID="Level">
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Tag

Description
<Attribute multiValue="true">Level</Attribute> defines the column
named Level and assigns to it the multivalued attribute Level.

Parameter

Any custom parameter that you want to define for the test step.

By default, all tags are mapped with their names, not the Excel column IDs. You can use any mix of Excel
column IDs and names in your own mapping files. The following example shows a typical mapping file with
Excel column IDs, such as columnID="C", and names, such as columnID="TestDefinitionName".
<HeaderRow>1</HeaderRow>
<FirstDataRow>2</FirstDataRow>
<MultiValueSeparatorCharacters>,;</MultiValueSeparatorCharacters>
<Path columnID="A"/>
<TestName columnID="TestDefinitionName"/>
<PlannedTime columnID="C"/>
<TestDescription columnID="D"/>
<StepName columnID="StepName"/>
<StepActionDescription columnID="F"/>
<StepResultDescription columnID="G"/>
<MappingDef
columnID="H"><CustomStepProperty>StepProp1</CustomStepProperty></MappingDef>
<MappingDef
columnID="StepProperty2"><CustomStepProperty>StepProp2</CustomStepProperty></MappingDef>
<MappingDef columnID="J"><Attribute>Browser</Attribute></MappingDef>
<MappingDef columnID="Level"><Attribute
multiValue="true">Level</Attribute></MappingDef>
<MappingDef columnID="Parameter1"><Parameter
type="string">Para1</Parameter></MappingDef>
<MappingDef columnID="Parameter2"><Parameter
type="password">Para2</Parameter></MappingDef>

Editing the Test Plan Mapping File
To edit the test plan mapping file:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
or
on the toolbar.
3. In the Test Plan tree, right-click the folder or container that you want to use as the parent node of the
imported test plan and choose Import from Excel File.
The Import Test Plan from Excel File dialog box opens.
4. Click Edit Mapping.
The Edit Mapping dialog box opens.
5. Edit the variables of the test plan file in the text boxes.
Note: For information on the variables included in the test plan file, see Test Plan File.
6. Optional: Edit the name of the mapping file.
7. Click Save to save your changes or click Cancel to cancel your changes.
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Test Plan File
You can create a test plan file in Excel to import test plans into Test Manager. In the test plan file, you can
define all tests and test steps, along with their properties, attributes, and parameters.
To map the tests in your test plan file to the test plan in Test Manager, use an XML mapping file. The mapping
file defines the location of the elements in your test plan file to Test Manager. You can give the items included
in the test plan file any name you like, as long as you map them appropriately in your mapping file. For more
information about mapping files, see Test Plan Mapping File.
Define the following items for a test and a test step in the test plan file:
Item

Description

Test

Define the name of the test. Optionally, you can also define a description for the test, the
estimated duration of the test, and the path to the test from the root folder. If you define no
path, the test is added directly into the root folder. Additionally, you can define properties,
attributes, and parameters for the test.

Test Step

Define the name of the test step. Optionally, you can also define the action that is performed
in the test step, and the result that you expect of the test step. Additionally, you can define
test step properties for the test step.

Note: Currently, Test Manager supports only Microsoft Excel 2007 (.xslx) files for import, and the import
is limited to manual tests.

SilkTest Classic Test Plans
SilkTest Classic test plan files can be uploaded from SilkTest Classic directly into Test Manager. Exported test
plans are then displayed in the Test Plan tree.
For full details on exporting test plan files, refer to the SilkTest Classic documentation.

Importing SilkTest Classic Test Plans
To upload a test plan from SilkTest Classic:
1.
2.
3.
4.

Create a test plan in SilkTest Classic. For details, refer to the SilkTest Classic documentation.
From the SilkTest Classic Testplan menu, select Upload to Test Manager.
The SilkCentral Administration Module Login screen displays. Enter your user name and password.
On the Upload Testplan file to Test Manager dialog box, select the Test Manager project to which you
are uploading the file from the Project list box.
5. Click OK.
6. Click OK on the Upload Testplan Complete confirmation dialog box.
7. In Test Manager, navigate to the Test Plan unit.
The uploaded project is added as a test container to the Test Plan tree with the same name as the imported
SilkTest Classic test plan.
Note: To work with the new test container, you may have to edit source control profile settings or other
settings.
8. To edit the test container, select the container in the Test Plan tree.
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9. Click the Properties tab.
10. Click Edit to open the Edit Test Container dialog box. Edit the criteria for the test container as required.
Note: You can find the inherited SilkTest Classic symbols on the Parameters page in the Test Plan
View. Inherited test definition attributes can be found on the Attributes page in both Test Plan View
and in the Settings unit. Inherited SilkTest Classic queries can be found on the Filters tab in the
Settings unit.

Integrating Test Manager into Rally
To use the project management tool Rally with Test Manager, you have to integrate Test Manager into Rally.
A mashup is shipped with Test Manager, that enables you to display user-story related test-coverage information
from Test Manager in Rally. You can link each test definition in Test Manager to one or more user stories in
Rally. To link test definitions to a user story, assign an attribute with the value of the formatted user-story ID
in Rally to each test definition.

Creating a Mashup Tab in Rally
Create an HTML or JavaScript mashup tab in Rally to display user-story related test-coverage information.
To create a mashup tab:
1. Navigate to the tab in Rally where your mashup tab should reside.
2. Click New Custom Tab.
3. Type a name for your new tab in the Name text box. For example, Iteration Status.
4. Optional: Check the Share with all Users check box if you wish other users to be able to see your mashup.
5. Select Custom Mashup as the type of the mashup.
6. Download the Rally Iteration Status Mashup from Test Manager ➤ Tools.
7. Paste the content of the Rally Iteration Status Mashup into the HTML text box.
8. Configure the script in the text box to match your Test Manager environment:
•
•
•
•
•

Check if the valid script source is set, for example <script type="text/javascript"
src="http://localhost:19120/silkroot/script/sctm-toolkit.js"></script>.
Check if the valid URL for Test Manager is set, for example var SCTM_URL =
"http://localhost:19120/".
Check if a valid Test Manager project ID is set, for example var SCTM_PROJECT_ID = 0.
Check if a valid attribute name is set, for example var SCTM_ATTRIBUTE_FOR_RALLY_US =
"rallyattr".
Make sure usage of the FormattedID from Rally is enabled, var USE_FORMATTED_ID = true.

9. Click Save & Close.
The mashup table is created.

Linking User Stories from Rally to Test Definitions
Link Rally user stories to test definitions in Test Manager.
To link Rally user stories to Test Manager test definitions:
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1. Select the project in Test Manager which contains the test definitions you want to link the Rally user stories
to.
2. Navigate to Test Manager ➤ Settings.
3. Click the Attributes tab.
4. Click New Attribute.
The New Attribute dialog box opens.
5. Type rallyattr in the Name text box.
6.
7.
8.
9.

Select Edit from the Attribute type radio box.
Click OK to create the new attribute.
Assign the new attribute to each test definition that you want to link user stories from Rally to.
Set the value of the attribute to be the value of the FormattedID of the appropriate Rally user story for each
test definition. If you assign multiple stories to a single test definition, separate the IDs with a comma and
put no whitespace characters between them. For example, US10,US12,US14.

Execution
This section explains how to manage execution definitions, including assigning test definitions, scheduling test
runs, setting up dependencies, configuring dynamic hardware-provisioning with keywords, and configuring a
deployment environment.
The Execution unit enables you to maintain control over test executions during development and testing. The
unit enables you to configure execution definitions, schedule execution definitions, assign test definitions to
execution definitions, set up execution-definition dependencies, configure execution-server deployment, and
configure dynamic hardware-provisioning with keywords. Executions are displayed, organized, and maintained
through a hierarchical tree structure, the Execution tree. Each execution may have any number of child test
definitions associated with it. The Execution tree enables you to organize executions within folders, in any
number of hierarchy levels.

Execution Document View
Test Manager ➤ Execution ➤
The Execution unit offers two views of execution properties, Document View and Execution View. Document
View provides a high-level, read-only view of properties for all executions in the selected project.
The properties on this view are defined when execution definitions are created. The view displays the following
columns for a selected element in the Execution tree:
Column

Description

Status

Status of all test definitions included in the element
as a bar graph.

Assigned Test Definitions

Total number of assigned test definitions.

Build

Build that the execution was based on.

Version

Version that the execution was based on.

Product

Product that the execution was based on.
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Column

Description

Priority

Priority of the execution.

Last Execution

Last time the execution occurred.

Planned Time

Total planned time for all manual test definitions.

Duration

Duration of the execution.

Next Execution

Next scheduled execution.

Test Container

Test container containing the test definition that this
execution is based on.

Working with the Execution Tree
Test Manager ➤ Execution ➤
Executions are displayed, organized, and maintained through a hierarchical tree structure, the Execution tree.
The Execution tree enables you to organize execution definitions in any number of hierarchy levels. Each
node in the tree represents either an execution definition or an execution folder.
Note: When the Execution tree includes more elements than can be displayed at once without impacting
response time, elements are displayed in increments. Page number links at the bottom of the tree allow
you to browse through the elements included on the tree one page at a time. To display all elements as
a single list, click the [All] link.

Expanding or Collapsing the Execution Tree
You can consolidate levels of the Execution tree or display all levels of the hierarchy based on your viewing
needs.
To collapse or expand levels of the Execution tree:
1. Navigate to Test Manager ➤ Execution.
2. Select a folder in the Execution tree and continue with one of the following options:
•
•
•

Click

to the left of the name of the folder to expand the folder.

Click
to the left of the name of the folder to collapse the folder.
Right-click on the folder and select Expand or Collapse.

Execution Properties Page
Test Manager ➤ Execution ➤

➤ Properties

The Properties page lists basic properties that are relevant to the selected project, folder, execution definition,
or configuration suite. For execution definitions and configuration suites, the following properties are configured
when the execution definitions or configuration suites are created:
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Execution Definition Name/Configuration Suite Name

Name of the execution definition or the configuration suite.
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Property

Description

Execution Definition ID/Configuration Suite ID

Database identifier of the execution definition or the
configuration suite.

Description

Description of the execution definition or the configuration
suite.
Note: Test Manager supports HTML formatting and
cutting and pasting of HTML content for Description
text boxes.

Test Container

Test container the execution definition or configuration suite
is associated with. Click to access the test container in the
Test Plan unit.

Version

Product version the execution definition or configuration
suite is associated with.

Build

Product build the execution definition or configuration suite
is associated with.

Priority

Priority of the execution definition.
•
•
•

Low
Medium
High

SilkTest Classic AUT Host NameSource Control Label

Hostname of the application under test. For SilkTest Classic
execution definitions only.

Test Definitions

Test definitions associated with this execution definition or
configuration suite.

Source Control Label

Not existing for configuration suites. In the Source Control
Label text box you can optionally specify that the execution
definition is of an earlier version than the latest version. The
label must refer to a version in the source control system
that the test container is associated with. If this text box is
left blank, the latest version of the execution definition will
be fetched.
The Source Control Label property is only enabled if the
associated test container uses a source control profile that
supports versioning.
Make sure to have enough free disk space on the execution
server or servers when working with multiple versions of
source files. Each version will be saved in its own folder on
every execution server.

Status of last run

Status of the last run of the execution definition or
configuration suite.
•
•
•

Passed
Failed
Not Executed
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Property

Description

Last Execution

Last time this execution definition or configuration suite was
executed.

Duration

Length of time required for execution of the execution
definition or configuration suite.
In the simplest case, automated tests on a single execution
server or only manual tests, the duration is the time displayed
for the latest run on the Runs page. If the last execution
involved automated tests that were executed on more than
one execution server, duration on the server on which
execution lasted the longest is considered. If the last
execution involved both automated and manual tests, only
the automated or manual tests will be considered, depending
which tests last the longest. This is because automated and
manual tests are executed in parallel. If the execution
definition contains multiple test definitions, the duration is
measured from the time when the first test definition begins
executing and ends when the last test definition completes
execution. This includes the overhead time, which is needed
for stopping/starting test definitions between executions. If
an execution definition contains only a single test definition,
this overhead is not included in the duration.

Next Execution

Next time this execution definition or configuration suite will
be executed.

Created On

Date and time the execution definition or configuration suite
was created.

Created By

Name of the user who created the execution definition or
configuration suite.

Changed On

Date and time the execution definition or configuration suite
was last changed.

Changed By

Name of the user who last changed the execution definition
or configuration suite.

Execution Definitions
Execution definitions are collections of assigned test definitions that are stored in a single test container.
Execution definitions can be run at configurable schedules and deployed on specified execution servers.
The process of adding and editing execution definitions is the same for both automated execution definitions
and manual execution definitions.

Working with Execution Definitions
Creating Execution Definitions
To create an execution definition:
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1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select an existing folder in the Execution tree, or select the project node.
4.
Click
on the toolbar or right-click the selected node and choose New Child Execution Definition.
The New Execution Definition dialog box displays.
5. Type a name and description for the execution definition.
Note: Test Manager supports HTML formatting and cutting and pasting of HTML content for Description
text boxes.
6. Select a test container from the Test Container list box.
You can only associate one test container to a test execution.
The version and build that are associated with the product that the container belongs to are populated
automatically in the Version and Build list boxes.
7. Select a product Version and Build from the list boxes.
If a build information file is available on the execution server, you have the option to check the Read from
Build Information file check box, in which case build and information will be read from the build information
file for the test run, overriding any manual settings that have been selected on the New Execution Definition
dialog box.
8. Select a Priority for the execution definition from the list box.
9. Optional: In the Source Control Label text box you can specify that the execution definition is of an earlier
version than the latest version.
Note: The Source Control Label property is only enabled if the associated test container uses a
source control profile that supports versioning.
10. Click OK to update the Execution tree with the newly created execution definition.
Creating an Execution Definition in Grid View
To create an execution definition in Grid View:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the test definitions you want to assign to your execution definition, by using the multi-select feature
of the Grid View.
4. Right-click the test definitions and choose Create Execution Definition.
The New Execution Definition dialog box displays.
5. Enter the specifications of your new execution definition.
Note: All selected test definitions must be in the same container. If not, the execution definition is not
created and an error message displays.
Note: The test container is preselected in the New Execution Definition dialog box and cannot be
altered.
Creating Data-Driven Execution Definitions
Note: For details on configuring data sources for data-driven tests, refer to the SilkCentral Administration
Module Help. For details on configuring test definitions for data-driven tests, see Data-Driven Tests.
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To create an execution definition for a data-driven test:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Create an execution definition from a test container that contains data-driven test definitions.
Note: When a test definition is specified as having each data row as a single test definition, the
execution definition includes a separate test definition for each data row. To create an execution
definition with only a selection of data-driven test definitions, you need to assign test definitions with
the filter option. See the related concept for details.
Editing Execution Definitions
To edit an existing execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition you want to edit.
4.
Click
on the toolbar or right-click the execution definition and select Edit.
The Edit Execution Definition dialog box displays.
5. Edit the execution definition by modifying the criteria, such as the description and values, defined in the
Edit Execution Definition dialog box.
If there are no runs and no test definitions assigned to the execution definition, you can choose an alternative
test container for the execution definition from the Test Container list box.
6. Click OK to save the edited execution definition.
Copying Execution Definitions
To copy and paste an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to copy.
4.
Click
on the toolbar or right-click the execution definition and select Copy .
5. Select the target folder where the execution definition is to be pasted.
6.
Click
on the toolbar or right-click the execution-definition node and select Paste.
The Execution tree is updated with a copy of the pasted execution definition. All assigned test definitions,
filters, and scheduling parameters are copied along with the execution definition.
Viewing Execution Activities for Data-Driven Tests
To view execution activities for data-driven tests:
1. Navigate to Test Manager ➤ Execution.
2. Select an execution definition that is based on a data-driven test definition.
3. Navigate to Test Manager ➤ Activities.
4. Click the Run ID of the relevant execution definition.
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5. In the Assigned Test Definitions table, click the name of a data-driven test definition.
Note: If you are running a multiple data-driven test, you will see one test definition for each data row
in your data source.
The results page for that particular test definition opens.
6. Click the Data Driven tab. Here you can view all instances of the test definition that were executed.
Note: The test definition’s data-driven properties are listed on the Details page in the Data-driven
Properties table.
7. Click an instance name to view test-definition run details for that specific instance.
Note: If you are working with multiple data-driven test definition instances, a separate instance will be
created for each data row in your data source.
8. Click the Parameters tab to view the data source values that were used during this specific test run.
Deleting Execution Definitions
To delete an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to delete.
4.
Click
on the toolbar or right-click the execution-definition node and select Delete.
5. Click Yes on the deletion confirmation dialog to remove the execution definition from the Execution tree.
When deleting an execution definition, the run results of assigned test definititions are also deleted. The test
definition run results may still appear in reports, because they are stored in the database, which is not
immediately updated after the deletion of the execution definition.

Dynamic Hardware Provisioning with Keywords
The hardware-provisioning technology of Test Manager helps you manage test environments that include
numerous execution servers. Rather than having to configure a one-to-one static execution-server assignment
for each automated execution definition, keywords enable Test Manager to automatically select the most
appropriate execution server for each execution definition. This is done through dynamic comparison of each
execution definition's keyword list with the keyword lists of all active execution servers.
Keywords typically describe your execution environment requirements, for example platform, operating system,
and pre-installed applications. There are different uses for keywords, depending on whether the execution
definition is executed automatically or manually.
Automated execution
definitions

When an automated execution definition is executed, Test Manager compares
the execution definition's keywords with the keywords of all available
execution servers. The execution is then run on the first-identified execution
server that has a matching keyword list.

Manual execution definitions For manual execution definitions, the manual tester can reflect the test
environment by using keywords.
If you require an automated execution definition to be run on multiple execution servers, create a copy of the
execution definition and assign additional keywords to the execution definition that match other execution
servers.

SilkCentral Test Manager 2010 R2

| 239

Reserved Default Keywords
If you do not require hardware provisioning to execute automated execution definitions, you can use the
reserved keywords that are created automatically for each execution server. In such cases, it is not necessary
that you manually assign keywords to your execution servers. Instead, you can configure a one-to-one static
execution-server assignment for each execution definition.
A reserved keyword is assigned automatically to each newly created execution server. Reserved keywords
are structured in the following form: #<execution server name>@<location name>.
Reserved keywords are only available when assigning keywords to execution definitions. They are neither
available or applicable when assigning keywords to execution servers.
In addition to the reserved keywords that are set up automatically for each defined execution server, reserved
keywords are also set up for each execution server type:
#PHYSICAL

Limits execution-server provisioning to physical execution servers.

#VIRTUAL

Limits execution-server provisioning to virtual execution servers.

Keywords and Virtual Execution Servers
Keywords are assigned to virtual execution servers in the same way that they are assigned to physical execution
servers. When you configure at least one virtual execution server, the #VIRTUAL keyword is dynamically
created and made available for assignment to all execution definitions. If you prefer that an execution occur
on a virtual machine, select the #VIRTUAL keyword for the execution definition. When an execution definition
has neither the #VIRTUAL and #PHYSICAL keywords, the execution may occur on either a virtual or a physical
execution server, assuming the settings of the execution environments are the same. When an
execution-definition's keywords match multiple virtual execution servers, the first matching virtual execution
server that is identified is selected.
Folder Execution
Execution definitions can be combined into execution folders, where a folder can include execution subfolders
and execution definitions. The options for an execution definition execution are also available for an execution
folder execution.
When executing a folder, the contained subfolders and execution definitions are treated as follows:
Keywords of Executed Folder

Keywords of Contained Execution
Definition/Subfolder

Execution of Contained Execution
Definition/Subfolder

Has no keywords

Has no keywords

Execution definitions without keywords
obtain status NOT EXECUTED after
execution

Has no keywords

Has keywords

Execution servers are assigned based
on the execution definition/subfolder
keywords

Has keywords

Has no keywords

Execution servers are assigned based
on the folder keywords

Has keywords

Has keywords

Execution servers are assigned based
on the folder keywords

Note: When a folder is executed manually and there are no keywords assigned, or no execution server
exists for the assigned keywords, the default execution server is used for execution. If the default execution
server is not available, these execution definitions are marked as Not Executed.
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Upgrading Execution Definitions
Automated execution definitions created with Test Manager 2008 or lower could be assigned to multiple
execution servers. With the new dynamic hardware provisioning, introduced in Test Manager 2008 R2,
automated execution definitions are assigned to one physical execution server only. If you upgrade to Test
Manager 2008 R2, all automated execution definitions that previously had multiple execution servers assigned
will be assigned to one of the previously defined execution servers. Modified automated execution definitions
will be marked with an exclamation mark (!) in front of them in the Execution tree. Additionally, a log file is
generated on the application server, listing the exact changes to each of the modified automated execution
definitions. The generated log file, dbupgrade6001.xml, resides on the application server in the Documents
and Settings\<username>\Application Data\Silk\SCC35\log\ folder. If the application server
runs under the system user, the default path is Documents and Settings\All Users\Application
Data\Silk\SCC35\log\.

Test Status Calculation
Each execution definition has one of the following status conditions:
Status

Condition

Passed

All considered test definition executions have the status Passed.

Failed

At least one considered test definition execution has the status Failed, but
none of the definition executions has the status Not Executed.

Not Executed

At least one considered test definition has the status Not Executed.

A test definition gets its status from the result of the latest test execution run. If you manually change the status
of the latest test execution run, the test definition status changes also.
Note: If the latest test execution run is deleted, the status of the test definition resets to the status of the
latest existing test execution run. Only test execution runs with status Passed or Failed are used to
reset the test definition status, test execution runs with status Not Executed are ignored. If the deleted
test execution run was the only existing test execution run, the status of the test definition is set to Not
Scheduled, as if the test definition was newly created.

Assigned Test Definitions
Assigning Test Definitions from Grid View to Execution Definitions
The test definitions that are assigned to the selected execution definitions are listed on the Assigned Test
Definitions page.
To assign one or more test definitions from the test plan Grid View to one or more execution definitions:
1. Navigate to Test Manager ➤ Test Plan.
2.
Click
on the toolbar.
3. Select the test definitions you want to assign to execution definitions.
Use CTRL + CLICK or SHIFT + CLICK to select multiple test definitions using standard browser multi-select
functions.
4. Right-click the selected test definitions and choose Save Selection.
5. Navigate to Test Manager ➤ Execution.
6. Click
on the toolbar.
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7. Select the execution definition to which you want to assign the selected test definitions.
8. Click the Assigned Test Definitions tab.
9. Click Assign Saved Selection.
Note: Only test definitions that reside in the execution definitions test container are inserted. You can
insert the selected test definitions to more than one execution definitions. You can not insert them into
requirements in a different project. The selection persists until you make a different selection or close
Test Manager.
Manually Assigning Test Definitions to Execution Definitions
The test definitions that are assigned to the selected execution definitions are listed on the Assigned Test
Definitions page.
To manually assign test definitions to an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition to which you want to assign the selected test definitions.
4. Click the Assigned Test Definitions tab.
5. Click the Manual assignment option button.
All test definitions of the test container which is associated with the selected execution are displayed in the
Test Plan tree. If you have created a test definition filter, you can select it from the filter list above the Test
Plan tree. To create a new test definition filter, navigate to the Test Plan unit and click New Filter on the
toolbar.
6.
In the tree, click
left of the test definition that you want to assign to the currently selected execution
definition.
Clicking the assign arrow of a folder or the top-level container assigns all child test definitions of that parent
to the selected execution definition.
Assigning Test Definitions to Execution Definitions through a Filter
The test definitions that are assigned to the selected execution definitions are listed on the Assigned Test
Definitions page.
To use a filter to assign one or more test definitions to an execution definition:
1. Create a filter in the Test Plan unit.
See Creating Filters for details. If the filter already exists, skip this step.
2. Navigate to Test Manager ➤ Execution.
3. Click
on the toolbar.
4.
5.
6.
7.

Select the execution definition to which you want to assign test definitions.
Click the Assigned Test Definitions tab.
Select Assignment by filter from the test definition assignment types.
Choose the filter from the list box.
Note: If you assign test definitions to an execution definition in Test Plan ➤ Grid View, the test definition
assignment type is automatically set to Manual Assignment, but the previously-filtered test definitions
remain in the Assigned Test Definitions page.
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Locating Test Definitions Assigned to Execution Definitions
To locate manually assigned test definitions in the Test Plan tree:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3.
4.
5.
6.

Select the execution definition for which you want to locate the assigned test definitions.
Click the Assigned Test Definitions tab.
Optional: Select Manual assignment, if it is not selected.
In the Actions column of a test definition, click
definition is stored in.

to find out in which test folder or container the test

The corresponding parent folder is expanded in the Test Plan tree and the assigned test definition is highlighted
in blue.
Removing Test Definition Assignments
To remove a manually assigned test definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition from which you want to remove the assignment.
4. Click the Assigned Test Definitions tab.
5.
In the Actions column of the assigned test definition, click
.
Repeat this step for all assignments that you want to delete.
Tip: To remove all assigned test definitions, click Remove All.
Execution Assigned Test Definitions Page
Test Manager ➤ Execution ➤

➤ Assigned Test Definitions

The Assigned Test Definitions page lists all test definitions that are assigned to the selected execution
definition or configuration suite. Use this page to assign additional test definitions to the execution definition
or configuration suite, to remove test definitions from the execution definition or configuration suite, or to change
the execution order of the assigned test definitions.
If you have created a test definition filter, you can select it from the filter list above the Test Plan tree. To create
a new test definition filter, navigate to the Test Plan unit and click New Filter on the toolbar.
Note: All changes in this page are immediately applied.
Note: When you access the page from a sub-element of a configuration suite, the page is read-only.
The page includes the following items:
Item

Description

Manual assignment

Click to manually assign test definitions to the execution
definition or configuration suite.
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Item

Description

Use test plan order

Check to set the execution order of the assigned test
definitions to follow the execution order in the Test Plan
unit.

Assign Saved Selection

Click to assign a selection of test definitions from Test Plan
➤ Grid View.

Assignment by filter

Click to automatically assign test definitions to the execution
definition or configuration suite based on a pre-defined filter.
The available filters are listed in the list box.

Assigned Test Definitions

Amount of test definitions that are assigned to the execution
definition or configuration suite.

Planned Time

The estimated time to execute all tests in the execution
definition or configuration suite. For configuration suites, the
Planned time is the sum of the planned times of all the
configurations in the suite.
Note: Planned Time is for manual test definitions only.

Assigned Test Definitions List

For each assigned test definition, the page displays the
following columns:
Order

The execution order of the test definition.
Uncheck the Use test plan order check box to
change the execution order. Click in the text
box, type the new order of the test definition,
and then press Enter to confirm the change.
Each change in each of the text boxes must be
confirmed by pressing Enter. If you change
the orders of multiple test definitions without
pressing Enter each time, just the last change
before pressing Enter is taken.

Actions

You can perform the following actions on the
assigned test definitions when the Manual
assignment option button is clicked:
Action

Description
Remove the selected test
definition from the list.
Locate the selected test
definition in the test plan tree.

Test
Name of the test definition. Click to access the
Definition test definition in the Test Plan unit.
Status
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Status of the last run of the test definition in the
context of the execution definition or the
configuration suite. When the test definition is
executed outside of the context of the execution

Item

Description
definition or configuration suite, the displayed
status remains unchanged. If the test definition
has not yet been executed in the context of the
execution definition or configuration suite, the
status is Not Scheduled.
For test definitions or test packages that are
included in a configuration suite, the status is
an aggregation of all statuses of all
configurations within the suite:
•

If the test is assigned only to the
configuration suite, the status is Passed
only if it is passed in all configurations. If the
status is not Passed in all configurations,
the status of the worst run is propagated,
with the following top-down priority:
1.
2.
3.
4.

•

•

Not Scheduled
Not Executed
Failed
Passed

The status of a requirement that is assigned
to the test is Failed if the test fails in one
or more of the configurations.
We do not recommend to assign the test to
a configuration suite and one or more simple
execution definitions. However, in this case,
the aggregate of the configuration statuses
is one status, and the last statuses of the
execution definitions are other statuses. The
status that was executed last determines
the last status of the test.
If the test is assigned to a simple execution
definition only, the status is updated in
response to the status of the last test run.

Last
Date and time of the last run of the test definition
Execution in the context of the execution definition or
configuration suite. When the test definition is
executed outside of the context of the execution
definition or configuration suite, the displayed
time and date remain unchanged.
Planned The estimated time for the execution of the test
Time
definition.
Note: Planned Time is for manual test
definitions only.
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Item

Description

Test Plan

Shows all test definitions in the Test Plan tree that are
available for assignment to the selected execution definition
or configuration suite. Double-click a test definition or use
to assign the test definitions to the execution definition
or configuration suite. For information about inserting multiple
test definitions from the Test Plan unit to the execution
definition or configuration suite, see Assigning Test
Definitions from Grid View to Execution Definitions.

Execution Definition Parameters
To apply a specific configuration to an execution definition, you can override the parameters that you have
assigned to a test definition in the Parameters page of the execution definition. For additional information on
test definition parameters, see Test Definition Parameters.
Creating an Execution Definition Parameter
To add a new parameter to an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition to which you want to add a new parameter.
4. Click the Parameters tab.
5. Click New Execution Definition Parameter.
The New Execution Definition Parameter dialog box displays.
6. Type the Name and Value for the new parameter into the corresponding text boxes.
7. Click Save to add the parameter to the execution definition.
Note: You cannot create execution-definition parameters with the same name as an existing
test-definition parameter, which is included in the execution definition.
Overriding a Test Definition Parameter
If there exist more than one parameters with in the same name and different types in the test definitions, you
can override only one of them. Only the values of parameters with the same type and name are replaced with
the overriding value during execution.
To override a test-definition parameter in an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition in which you want to override a test definition parameter.
4. Click the Parameters tab.
5.
In the Actions column of the parameter that you want to override, click
.
The Set Execution Definition Parameter Value dialog box displays.
6. Type the new Value into the text box.
7. Click OK.
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Note: Click

in the Actions column of the parameter to undo the override.

Removing an Execution Definition Parameter
Note: You cannot remove test-definition parameters in an execution definition. You can only remove
execution-definition parameters.
To remove an execution-definition parameter:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition from which you want to add a new parameter.
4. Click the Parameters tab.
5.
Click
.
Execution Parameters Page
Test Manager ➤ Execution ➤

➤ Parameters

The Parameters page displays the parameters of all test definitions that are assigned to the execution definition.
You can override the parameters of the test definitions for the execution definition. For configuration testing,
you can create multiple execution definitions that include the same test definitions and you can then define
different configurations in the Parameters page. Parameters from different test definitions that have the same
name and type are displayed only once in the page. If multiple parameters from different test definitions have
the same name, you can only override one of these parameters.
Click New Execution Definition Parameter to define a new execution-definition parameter that is used for
the execution of all test definitions that are included in the execution definition. New execution-definition
parameters are always of the type string and you cannot define a different type.
The page displays the following columns for each parameter:
Column
Actions

Description
Actions you can perform on the parameter. Click
the parameter value, or click

to undo your changes.

Name

Name of the parameter.

Type

A parameter can have one of the following types:
•
•
•
•
•
•

Value

to edit

String
Number
Float
Boolean
Password
Character

The parameter value.
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Setup and Cleanup Test Definitions
The pre-test setup and post-test cleanup functionality of Test Manager enables you to define a setup test
definition and a cleanup test definition for each execution definition. Setup test definitions are typically built
upon scripts or manual procedures that prepare testing environments in anticipation of tests. Cleanup test
definitions typically include scripts or manual procedures that restore test environments to their original state
following tests. When setup test definitions are aborted, regular tests do not execute, however cleanup test
definitions do execute to restore the testing environment to its original state.
You must create your setup and cleanup test definitions before you can assign them to execution definitions.
Any test definition can serve as a setup or cleanup test definition, except parent test definitions of multiple
data-driven test definition instances. They require no special configuration and can be either automated or
manual. The only requirement is that they perform the required setup and cleanup processes within your test
environment. In the case of automated test definitions these are scripts that perform required setup and cleanup
tasks. In the case of manual test definitions, these are manual setup and cleanup tasks.
Note: The challenge in executing setup and cleanup test definitions is preventing their results from being
aggregated with the results of the regular test definitions that they support. Test Manager addresses this
concern by running setup and cleanup test definitions, both automated and manual, in independent
execution definitions, thereby isolating actual test results from incidental performance fluctuations that
may be caused by setup and cleanup test definitions.
Combining Automated and Manual Test Definitions
Test Manager supports execution definitions that include combinations of automated test definitions and manual
test definitions. For such execution definitions, Test Manager withholds execution of regular test definitions,
both automated and manual, until setup test definitions are complete. Test Manager also ensures that all
regular test definitions are complete before cleanup test definitions are run.
When manual test definitions are combined with automated tests, automated tests, on all execution servers,
do not begin until the setup processes are complete. In the case of manual setup test definitions, regular
automated tests begin only after manual setup routines are complete.
Configuring Setup and Cleanup Executions
To define a test definition as a setup or cleanup test definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Click the execution definition for which you want to configure a setup or cleanup test definition.
4. Click the Setup/Cleanup tab.
•
•

To define a setup test definition, proceed with the following step.
To define a cleanup test definition, proceed with step 8.

5. Optional: To define a setup test definition, click Edit in the Setup Test Definition section.
The Edit Setup Test Definition dialog box displays.
6. To define a cleanup test definition, click Edit in the Cleanup Test Definition section.
The Edit Cleanup Test Definition dialog box displays.
7. In the Test Plan tree, select the test definition that you want to configure.
8. Click OK.
The configured test definition displays in the corresponding section of the Setup/Cleanup page.
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Execution Setup/Cleanup Page
Test Manager ➤ Execution ➤

➤ Setup/Cleanup

The Setup/Cleanup page lists the setup and cleanup test definitions that are defined for this execution definition.
Note: When failed tests are rerun, the corresponding setup/cleanup routines are also rerun. Setup/cleanup
test definitions are not run with Try Run test runs because such executions do not rely on execution
definitions.
Setup Test Definition
In the Setup Test Definition section, the page displays the following items:
Item

Description

Actions

Delete and View
Description.

Test Definition

Type and name of the
configured setup test
definition.

Edit

Opens the Edit Setup Test
Definition dialog box where
you can select a setup test
definition. You cannot assign
a test definition to the same
execution definition as both
a setup test definition and a
regular or cleanup test
definition. Assigned test
definitions can come from
any test container within your
project. It is therefore
possible to assign test
definitions that have
associated products and
source control profiles that
vary from their host execution
definitions.

Cleanup Test Definition
In the Cleanup Test Definition section, the page displays the following items:
Item

Description

Actions

Delete and View
Description.

Test Definition

Type and name of the
configured cleanup test
definition.

Edit

Opens the Edit Cleanup
Test Definition dialog box

SilkCentral Test Manager 2010 R2

| 249

Item

Description
where you can select a
cleanup test definition. You
cannot assign a test definition
to the same execution
definition as both a setup test
definition and a regular or
cleanup test definition.
Assigned test definitions can
come from any test container
within your project. It is
therefore possible to assign
test definitions that have
associated products and
source control profiles that
vary from their host execution
definitions.

Execution Definition Schedules
Once you have defined the test definitions that are to be included in an execution definition, you can define
the schedule by which the execution definition is to be executed in the Schedule page.
Three scheduling options are available:
•
•
•

None
Global
Custom
Note: You can define schedules for entire folders as well as for individual execution definitions. If a
schedule is defined for a folder, all execution definitions that are included in the selected folder will be
executed at the specified schedule. Execution definitions with no keywords assigned get the status Not
Executed when executed in a schedule. The scheduling options for parts of a project copy or baseline
are set to none to prevent loosing the last execution status. For more information on copies and baselines
of projects, refer to the SilkCentral Administration Module Help.

Definite Runs
Definite runs enable you to define times at which test definitions will be executed regardless of configured
schedules.
Creating a Custom Schedule for an Execution Definition
To create a custom schedule for a selected execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to configure a custom schedule.
Note: To schedule a folder for execution, select a folder node. To save an edited version of a global
schedule as a custom schedule, click Edit while the global schedule is selected in the list box. This
enables you to edit the global schedule and save the result as a custom schedule.
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4. Click the Schedule tab.
5. Click the Custom option button to enable the scheduling controls.
6. Click Edit.
7.
Click
next to the From field and use the calendar tool to specify the time and date when the execution
schedule should begin.
8. Specify the Interval at which the tests should be executed.
9. In the Run section, specify when the schedule schould end.
Select on of the following options:
•
•
•

Click Forever to define a schedule with no end.
Click n Time(s).
Click
next to the until field and use the calendar tool to specify the time and date when the execution
schedule should end.

10. Optional: Click Add Exclusion to define times when scheduled execution definitions should not be executed.
11. Optional: Click Add Definite Run to define times when unscheduled executions should be executed.
12. Click Save to save your custom schedule.
Specifying Global Schedules for Execution Definitions
Test Manager offers the possibility of defining global schedules, which can be reused in Test Manager for the
scheduling of test definitions. Global schedules can speed up the process of scheduling test definitions, since
the need to define individual schedules for each test definition is reduced to only those test definitions that
require special scheduling.
To select a pre-defined schedule that is globally available throughout Test Manager:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to configure a schedule.
Note: To schedule a folder for execution, select a folder node.
4. Click the Schedule tab.
5. Click the Global option button.
6. Select the required pre-defined schedule from the list box.
Details of the pre-defined schedule are displayed in a read-only calendar view. To save an edited version
of a global schedule as a custom schedule, click Edit.
Note: You can configure global schedules in Administration ➤ Configuration ➤ Schedules.
Specifying No Schedule for Execution Definitions
To specify that no schedule should be defined for an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to define not to be executed based on schedules.
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4. Click the Schedule tab.
5. Click the None option button.
Schedule Exclusions
A schedule exclusion is a regularly occurring time period during which executions should be suspended, for
example during a weekly planned system downtime or during weekends. You can add as many exclusions to
a schedule as you need. Exclusions enable you to define weekdays and time-of-day intervals during which
test definitions are not to be executed, regardless of configured schedules. For example, you may not want
tests to be executed on weekends.
Adding Exclusions
Note: You must have administrator rights to edit global schedules. To define a scheduling exclusion for
a global schedule, navigate to Administration ➤ Configuration ➤ Schedule.
To add an exclusion to a custom schedule:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3.
4.
5.
6.
7.

Select an execution definition for which you want to add a scheduling exclusion.
Click the Schedule tab.
Click the Custom option button to enable the scheduling controls.
Click Add Exclusion.
On the Configure Schedule Exclusion page, select the weekdays on which test definitions should be
suppressed.
8. Define the specific time intervals on those days during which execution should be suppressed.
9. Click OK.
Your exclusion settings are now listed on the Schedule page.
10. Click Save to add the exclusion to the current schedule, or continue adding additional exclusions.
Editing Exclusions
To edit an exclusion:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to edit a previously configured exclusion.
4. Click the Schedule tab.
5.
In the Actions column of the exclusion, click
.
6. Edit the exclusion as required and click OK.
7. Click Save.
Deleting Exclusions
To delete an exclusion:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to delete a previously configured exclusion.

252

| SilkCentral Test Manager 2010 R2

4. Click the Schedule tab.
5. In the Actions column of the exclusion, click

.

Definite Runs
A definite run is a run of an execution definition that you schedule to run at a specific time, independent of the
schedule that is configured for the execution definition. You can add as many definite runs to a schedule as
you need.
Adding Definite Runs
Note: You must have administrator rights to edit global schedules. To define a definite run for a global
schedule, navigate to Administration ➤ Configuration ➤ Schedule.
To add a definite run to a custom schedule:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3.
4.
5.
6.
7.

Select the execution definition for which you want to add a definite run.
Click the Schedule tab.
Click the Custom option button to enable the scheduling controls.
Click Add Definite Run.

On the Configure Definite Run page, click
and select the date and time when the execution definition
should definitely be run.
8. Click OK.
Your definite run settings are listed on the Schedule page.
9. Click Save to add the definite run to the current schedule, or continue adding definite runs.
Editing Definite Runs
To edit a definite run:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to edit a previously configured definite run.
4. Click the Schedule tab.
5.
In the Actions column of the definite run, click
.
6. Edit the definite run criteria as required and then click Save.
Deleting Definite Runs
To delete a definite run:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you want to delete a previously configured definite run.
4. Click the Schedule tab.
5. In the Actions column of the definite run, click .
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Execution Schedule Page
Test Manager ➤ Execution ➤

➤ Schedule

The Schedule page is used to define schedules for execution definitions.
The page provides the following schedule types:
Schedule Type

Description

None

Click this option button to define that the execution definition
is not executed based on a schedule. All schedules included
in a copy or baseline of a project are initially set to none.

Global

Click this option button to select a pre-defined schedule from
the list box for the execution definition. Selecting a global
schedule includes the schedule exclusions and definite runs
which are defined in the global schedule. For information on
defining global schedules, refer to the SilkCentral
Administration Module Help. Selecting a global schedule
displays the schedule details below the Custom option
button.

Custom

Click this option button to define a custom schedule for the
execution definition. Click Edit to edit the custom schedule
in the fields below.

For each selected schedule type, the page displays details. For a custom schedule, the details are editable.
Caution: If test definitions assigned to an execution definition schedule are not executed, this might be
caused by too many running tests. In such a case, test definitions that are already included in a schedule
are not executed when triggered manually or by a schedule. Click the Application Server Log tab in
Administration ➤ Reports to view the application server logfile. If there is a warning in the logfile that
states that the schedule interval might be to short, increase the schedule interval.
Schedule Details
The page displays details for the selected schedule type, which are editable for a custom schedule.
Item

Description

From
Specifies when the execution schedule begins. Click
next to the specified date to change the date and time.
Interval

Specifies the interval at which the execution's tests are
executed.

Adjust schedule to daylight savings

Check heck this check box to automatically have your
schedule adjust to daylight savings time. Note that daylight
adjustment only works for intervals of two-hour multiples to
avoid duplicate runs when setting time back one hour.

Run

Specifies when the execution ends:
Forever
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Click this option button to specify that the
execution should not stop executing.

Item

Description
Time(s)

Click this option button and select a number
from the list box to define a specific number of
executions.

Until

Click this option button to pick a specific time
at which test executions are to end. Click
next to the specified date to change the date
and time.

Exclusion

The exclusions that are defined for the schedule. To add an
exclusion, click Add Exclusion.

Definite Runs

The definite runs that are defined for the schedule. To add
a definite run, click Add Definite Run. Click
in the
action column of a selected definite run to access the
calendar tool and specify when the definite run is to take
place.

Caution: If test definitions assigned to an execution definition schedule are not executed, this might be
caused by too many running tests. In such a case, test definitions that are already included in a schedule
are not executed when triggered manually or by a schedule. Navigate to Administration ➤ Logs ➤
Application Server Log to view the application server logfile. If there is a warning in the logfile that states
that the schedule interval might be to short, increase the schedule interval.

Configuring Deployment Environments
Adding a SilkTest Classic AUT Host
For execution definitions that run SilkTest Classic tests, you may have a setup where the SilkTest Classic
agent is on a different computer than the execution server. In this case, you can define the location of the
SilkTest Classic agent, the SilkTest Classic AUT (Agent Under Test) Hostname.
To add a a SilkTest Classic AUT host to the selected execution definition or edit the host:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition to which you want to assign the SilkTest Classic AUT host.
4. Click the Deployment tab.
5. In the SilkTest Classic AUT Hostname section, click Edit.
The Edit SilkTest Classic AUT Hostname dialog box displays.
6. In the Hostname text box, type the name of the computer where the SilkTest Classic agent runs.
Proper configuration of option files is required. For details on the command-line option -m, refer to the
SilkTest Classic documentation.
7. Click OK to add the SilkTest Classic AUT host to the selected execution definition.
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Adding Manual Testers
For execution definitions that include manual tests, the Deployment page enables you to assign users as
manual testers to a selected execution definition. You can assign multiple manual testers to the execution
definition.
To assign a manual tester to an execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Deployment tab.
5. Click Edit in the Manual Testers section.
The Manual Testers dialog box displays.
6. In the Available list box, select the user group of which the tester is a member.
The list box is populated with all members of the user group.
7. Select the name of the user you want to assign as a manual tester.
8. Click Add to add the user to the Selected list box; or click Add All to add all of the group’s members and
testers.
9. Click OK to close the Manual Testers dialog box.
Removing a Tester Assignment from an Execution Definition
To remove a tester assignment from the selected execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition for which you are removing a tester assignment.
4. Click the Deployment tab.
5. Click Edit in the Manual Testers section.
The Manual Testers dialog box displays.
6. From the Selected list box, select the name of the assigned user that you want to remove.
7. Click Remove to remove the user from the Selected list; or click Remove All to remove all tester
assignments.
8. Click OK to close the Manual Testers dialog box.
Creating New Keywords
To create new keywords:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Deployment tab.
5. In the Execution Environment section of the page, click Edit.
The Assign Keywords dialog box displays. All keywords that have been defined for your execution
environment are listed here.
Note: For automated execution definitions, the default reserved keywords for each execution server,
#<execution name>@<location name>,are included in the list.
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6. Type an alphanumeric keyword into the Keyword text box that describes the required environment for the
execution definition.
For example, the keyword might be the name of the platform, operating system, or pre-installed
applications.The following characters can not be used in keywords: #$?*\,;'".
Note: Keywords are case insensitive. For example, “Vista” and “vista” are handled as the same
keyword.
7. Press Enter.
The new keyword is now available for assignment.
Assigning Keywords to Execution Definitions
To assign keywords to execution definitions:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Deployment tab.
5. In the Execution Environment section of the page, click Edit.
The Assign Keywords dialog box displays. All keywords that have been defined for your execution
environment are listed here.
Note: For automated execution definitions, the default reserved keywords for each execution server,
#<execution name>@<location name>,are included in the list.
6. Select keywords in the Select keywords list box that reflect your execution environment requirements.
Use CTRL + CLICK or SHIFT + CLICK to select multiple keywords using standard browser multi-select
functions.
Tip: The Enter keywords text box is auto-complete enabled. When you enter alphanumeric characters
into this field, the field is dynamically updated with an existing keyword that matches the entered
characters. The text box is disabled when multiple keywords are selected in the Select keywords or
Assigned keywords list boxes.
Tip: For automated execution definitions, if you only have a few execution servers and do not require
hardware provisioning, it might be enough to use only the default, reserved keywords that are created
for each execution server. In such cases, it is not necessary that you select additional keywords.
7. Click > to move the keyword into the Assigned keywords list box.
Note: For automated execution definitions, the execution servers that match the assigned keywords
are listed below in the dynamically-updated Matching execution servers list box. This list updates
each time you add or remove a keyword. Click on the name of an execution server in the list to access
the execution servers in Administration ➤ Locations.
8. Click OK to save the keywords and close the Assign Keywords dialog box.
Removing Keywords from Execution Definitions
To remove execution-definition keyword assignments:
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1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Deployment tab.
5. In the Execution Environment section of the page, click Edit.
The Assign Keywords dialog box displays. All keywords that have been defined for your execution
environment are listed here.
Note: For automated execution definitions, the default reserved keywords for each execution server,
#<execution name>@<location name>,are included in the list.
6. Select the no longer needed keywords in the Assigned keywords list box.
Use CTRL + CLICK or SHIFT + CLICK to select multiple keywords using standard browser multi-select
functions.
7. Click < to remove the keyword assignments.
8. Click OK to save the keywords and close the Assign Keywords dialog box.
Note: Keywords that are not in use anymore are automatically deleted from the system.
Execution Deployment Page
Test Manager ➤ Execution ➤

➤ Deployment

The Deployment page displays all of the hardware-provisioning keywords that are defined for this execution
definition. These keywords are used to describe the execution environment requirements for the execution
definition. An execution server only matches the selected automated execution definition if it has all keywords
assigned the execution definition requires. The Deployment page also displays the users who are assigned
to execute manual tests, as well as the SilkTest Classic AUT hosts that are assigned to execute SilkTest
Classic tests.
Note: New execution servers are set-up in the Administration ➤ Locations. For details on how to set-up
an execution server, as well as configuring the integration of Test Manager with VMware Lab Manager,
refer to the SilkCentral Administration Module Help.
Execution Environment
The Deployment page displays the following items in the Execution environment section:
Item

Description

Assigned keywords

Lists the keywords that are assigned to the execution
definition.

Edit
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Automated
execution
definitions

Keywords are used to automatically
identify an appropriate execution
server for each test execution.

Manual execution
definitions

Keywords are used by the manual
tester to reflect the test
environment.

Click to edit the execution definition's keywords.

Item

Description

Matching execution servers

Lists the active execution servers that have keyword lists
that match the keywords list of this execution definition. All
keywords in the keywords list of the execution definition must
be included in the keyword list of the execution server. Click
on the name of an execution server in the list to access the
execution server list in Administration ➤ Locations.

Capturing Options
Note: Only VMware Lab Manager configurations are captured. LiveLink URLs are attached to execution
definition results as links on the Messages page and as separate html files that contain the LiveLinks.
The following VMware LiveLink capturing options are available for VMware Lab Manager configurations:
Option

Description

Never

Don't capture configurations.

Immediately on error

Once a failed test definition is completed, no further test definitions are
executed and the configuration is captured.

After completing all test
definitions

Upon failure conditions, continue test execution and capture the
configuration after executing all tests of the execution definition.

Always

Capture configuration with each run of the test execution.

Manual Testers
Lists all manual testers who are assigned to this execution definition or folder. Click Edit to edit the list of
manual testers.
SilkTest Classic AUT Hostname
Lists all SilkTest Classic AUT hosts that are defined for this execution definition. Click Edit to edit the list of
SilkTest Classic AUT hosts.
Code Analysis Settings
Details code-analysis settings that are defined for this execution definition. Click Active/Inactive to enable or
disable code analysis for this execution definition.
For virtual execution on VMware Lab Manager configurations, the internal IPs of the affected machines within
the configuration must be configured here.
Video Recording
Defines whether a video is recorded during the execution of the execution definition. This setting overrides the
video recording settings of the individual test definitions that are assigned to the execution definition. You can
select one of the following values:
Value

Description

---

Video recording is disabled, except for those assigned test definitions where the
recordVideo is set.
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Value

Description

Never

Video recording is always disabled, even for those assigned test definitions where
the recordVideo is set.

Always

Records a video on every execution of the execution definition.

On Error

Records a video when an error occurs during the execution of the execution definition.

Configuring Execution Dependencies
An execution dependency allows you to configure the automatic execution of one execution definition based
on the results of another execution definition. For example, “If execution definition 'A' fails, automatically execute
execution definition 'B'.”
Adding Dependent Execution Definitions
To add a dependent execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition that will act as the master execution definition.
4. Click the Dependencies tab.
5. Click Add dependent Execution Definition.
The Add dependent Execution Definition dialog box displays.
6. From the Condition selection list, select the condition that is to trigger the dependent execution definition.
•
•
•
•

Passed
Failed
Not Executed
Any

The Any status means that the dependent test execution will trigger no matter what the status of the previous
test execution.
7. From the tree menu in the dialog box, select the execution definition that is to be dependent.
8. Specify where the dependent execution definition is to be deployed.
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Option

Description

As specified in the
dependent Execution
Definition

Automated test definitions assigned to the dependent execution definition will
be executed on the execution server specified for the dependent execution
definition on the Deployment page. Manual test definitions assigned to the
dependent execution definition will be assigned to the users specified for the
dependent execution definition on the Deployment page.

Same as <selected
execution definition’s
execution server>

Automated test definitions assigned to the dependent execution definition will
be executed on the execution server specified for the master execution
definition on the Deployment page. Manual test definitions assigned to the
dependent execution definition will be assigned to the users specified for the
master execution definition on the Deployment page.

Specific: Execution
Server/Manual Tester

Select a pre-configured execution server and/or a manual tester from the list
boxes. Automated test definitions assigned to the dependent execution
definition will be executed on the specified execution server. Manual test
definitions assigned to the dependent execution definition will be assigned
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Option

Description
to the specified manual tester. If only a specific manual tester is defined and
no server, only manual test definitions will be executed. If only a specific
execution server is defined and no manual tester, only automated test
definitions will be executed.

9. Click OK to create the dependency.
Note: Test Manager will not allow you to create cyclical execution dependencies. You can select
conditions to fulfill for manual test definitions. For example if the selected condition is Failed and all
manual tests passed, but some automated tests failed, only automated test definitions assigned to the
dependent execution definition are executed.
Editing a Dependency
Note: To edit an existing dependency, you must select the master execution definition, which is the
definition for which a specific condition will trigger the execution of the dependent execution definition.
You cannot edit dependency settings from the dependent execution definition.
To edit a previously configured dependency:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Dependencies tab.
5.
In the Dependent Execution Definitions section, click
in the Actions column of the dependent
execution definition.
The Edit Dependency dialog box opens.
6. From the Condition selection list, select the condition that is to trigger the dependent execution definition.
•
•
•
•

Passed
Failed
Not Executed
Any

The Any status means that the dependent test execution will trigger no matter what the status of the previous
test execution.
7. Specify where the dependent execution definition is to be deployed.
Option

Description

As specified in the
dependent Execution
Definition

Automated test definitions assigned to the dependent execution definition will
be executed on the execution server specified for the dependent execution
definition on the Deployment page. Manual test definitions assigned to the
dependent execution definition will be assigned to the users specified for the
dependent execution definition on the Deployment page.

Same as <selected
execution definition’s
execution server>

Automated test definitions assigned to the dependent execution definition will
be executed on the execution server specified for the master execution
definition on the Deployment page. Manual test definitions assigned to the
dependent execution definition will be assigned to the users specified for the
master execution definition on the Deployment page.
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Option

Description

Specific: Execution
Server/Manual Tester

Select a pre-configured execution server and/or a manual tester from the list
boxes. Automated test definitions assigned to the dependent execution
definition will be executed on the specified execution server. Manual test
definitions assigned to the dependent execution definition will be assigned
to the specified manual tester. If only a specific manual tester is defined and
no server, only manual test definitions will be executed. If only a specific
execution server is defined and no manual tester, only automated test
definitions will be executed.

Deleting a Dependency
To delete a dependency:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the master execution definition from which you want to delete a dependency.
4. Click the Dependencies tab.
5.
In the Dependent Execution Definitions section, click
in the Actions column of the dependent
execution definition.
6. Click Yes on the Delete Dependency dialog box to delete the dependency.
Execution Dependencies Page
Test Manager ➤ Execution ➤ Dependencies
The Dependencies page lists dependent execution definitions and master execution definitions of the selected
execution definition.
The page is divided into two parts. For the selected execution definition, the page shows both the Master
Execution Definitions, which are the execution definitions for which a specific condition triggers the selected
execution definition, and the Dependent Execution Definitions, which are the execution definitions that will
be triggered if the selected execution definition results in a specific condition.
Master Execution Definitions
For each execution definition in the list, the page displays the following columns:
Column

Description

Name

Name of the master execution definition that the selected
execution definition is dependent upon.

Condition

Condition of the master execution definition that must be
met for the selected execution definition to be triggered.

Dependent Execution Definitions
For each execution definition in the list, the page displays the following columns:
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Column

Description

Name

Name of the dependent execution definition that the selected
execution definition serves as the master of.
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Column

Description

Condition

Condition of the selected execution definition that must be
met for the dependent execution definition to be triggered.

Execution Server / User(s)

Execution server where the dependent execution definition
is to be run or, in the case of a manual test execution,
manual tester who is to perform the manual test.

Actions

Actions that can be performed on the selected dependency.
Edit Settings and Delete Dependency.

Execution Notifications Page
Test Manager ➤ Execution ➤

➤ Notifications

The Notifications page includes check boxes which allow you to check whether you want to be notified based
on the outcome of the execution.
Notification only works if an email server has been configured by your administrator. You also have to specify
an email address for your account in Administration ➤ Users ➤ Accounts. If notification has not been
enabled, refer to the SilkCentral Administration Module Help or contact your administrator.
Check Box

Description

Execution definition runs finishing successfully

Check to receive a notification email each time an execution
run finishes successfully.

Execution definition runs finishing with not passed test Check to receive a notification email each time an execution
definitions
finishes with status not executed or failed.
Execution definition runs finishing with changed number Check to receive a notification email each time the number
of not passed test definitions
of failed or not executed tests changes in comparison to the
previous run, when an execution finishes.

Run Dialog Box
Test Manager ➤ Execution
The Run dialog box enables you to specify which test definitions you want to execute based on filter criteria
and to specify which product build the test should be run against. To open the Run dialog box, select an
execution definition or an execution folder and click Run on the toolbar.
Item

Description

All test definitions

Select this option to execute all test definitions.

Test definitions...

Select this option to only execute test definitions that meet
certain filter criteria. For example, Failed status, or test
definitions that have not been executed since before a
specified build number.

Test definitions that have had issues fixed since their
last execution

Select this option to only execute those test definitions that
have had issues advanced to the Fixed state since the
test definition's last execution.
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Item

Description

Set build for execution definition

Select a past build from the Set build for execution
definition list box to have the test run against a specific past
build. This field defaults to the current build. Note that this
option is not available if the execution definition is configured
to read the build number from a build information file. If an
execution folder contains execution definitions with different
product versions assigned to each, the build cannot be
selected for the execution of the execution folder.

Run Type

Choose Run as Specified to run all selected tests with their
own test type, or choose Run automated tests manually
to re-run all selected tests manually.

Go to Activities page

Check this check box to advance to the Activities page after
you define test definitions for execution.

Configuration Testing
Configuration testing is the process of testing a system with each of the supported software and hardware
configurations.
The Execution unit supports configuration testing through allowing reuse of the assigned test definitions. You
can create configuration suites with a set of assigned test definitions, and all execution definitions that you
add to the configuration suite will also have the set of test definitions assigned.You can also create configuration
suites from existing execution definitions and copy and paste or cut and paste execution definitions in the
Execution tree into a configuration suite. Test Manager enables you to add or remove parameters, keywords,
and manual testers to or from the configurations. When you create a configuration suite out of an existing
execution definition, all the results of the execution definition are preserved in the configuration suite. If you
copy-paste an execution definition into an existing configuration-suite, these results are not preserved.
Each execution definition in the configuration suite is displayed in an in-line editable grid. You can view the
execution definitions or configurations that contain a specific test definition in the Properties tab of the test
definition. You can also view the execution definitions or configurations that are associated with a specific
requirement in the Assigned Test Definitions tab of the requirement.

Creating a Configuration Suite
To create a configuration suite:
1. Navigate to Test Manager ➤ Execution.
2. Right-click the root node or a folder in the Execution tree and select New Child Configuration Suite or

3.
4.
5.
6.
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click
in the toolbar.
The New Configuration Suite dialog box displays.
Type a Name and Description for the new configuration suite.
Select a Test Container from the list box.
Select a Version and Build from the list boxes, or check the Read from Build Information File check box
to read the version and build from a file.
Optional: In the Source Control Label text box you can specify that the execution definition is of an earlier
version than the latest version.
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Note: The Source Control Label property is only enabled if the associated test container uses a
source control profile that supports versioning.
7. Click OK.

Creating a Configuration Suite from an Execution Definition
To create a configuration suite from an existing execution definition:
1. Navigate to Test Manager ➤ Execution.
2. Right-click the execution definition, from which you want to create a configuration suite, in the Execution
tree and select Convert to Configuration Suite.
Test Manager creates a new configuration-suite node, with the same name as the selected execution
definition, in the Execution tree and adds the execution definition as a configuration sub-node to the
configuration suite.
When you create a configuration suite out of an existing execution definition, all the results of the execution
definition are preserved in the configuration suite. If you copy-paste an execution definition into an existing
configuration-suite, these results are not preserved.

Adding Parameters to a Configuration
To add a predefined parameter to a configuration:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the configuration node to which you want to add a parameter.
4. Click the Configurations tab.
5. Click Add/Remove Parameters.
The Add/Remove Parameters dialog box opens. The Assigned parameters list box on the right side of
the dialog box lists all of the parameters that are defined for the configuration.
6. Select parameters in the Select or enter parameters list box that reflect your execution environment
requirements.
Use CTRL + CLICK or SHIFT + CLICK to select multiple parameters using standard browser multi-select
functions.
7. To add any of the parameters listed in the Select or enter parameters list box, select the parameter and
click >.
8. To create a new parameter, type the name of the parameter in the Enter parameters text box, and press
Enter or click >.
Tip: The Enter Parameters text box is auto-complete enabled. When you enter alphanumeric characters
into this field, the field is dynamically updated with an existing parameter that matches the entered
characters. The text box is disabled when multiple parameters are selected in the Select parameters
or Assigned parameters list boxes.
9. Click OK.
The Add/Remove Parameters dialog box closes and a new column is added to the grid for each new
parameter.
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Removing Parameters from a Configuration
To remove a predefined parameter from a configuration:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the configuration node from which you want to remove a parameter.
4. Click the Configurations tab.
5. Click Add/Remove Parameters.
The Add/Remove Parameters dialog box opens. The list box on the right side of the dialog box lists all of
the parameters that are defined for the configuration.
6. To remove a parameter from the list box, select the parameter and click <.
7. Click OK.
The Add/Remove Parameters dialog box closes and the column of the removed parameter is removed
from the grid.

Assigning Keywords to a Configuration
To assign keywords toa configuration:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the configuration suite that you want to edit.
4. Click the Configurations tab.
5. Click into the Keywords column of the configuration that you want to add a keyword to.
The Assign Keywords dialog box opens.
6. Select keywords in the Select keywords list box that reflect your execution environment requirements.
Use CTRL + CLICK or SHIFT + CLICK to select multiple keywords using standard browser multi-select
functions.
Tip: The Enter keywords text box is auto-complete enabled. When you enter alphanumeric characters
into this field, the field is dynamically updated with an existing keyword that matches the entered
characters. The text box is disabled when multiple keywords are selected in the Select keywords or
Assigned keywords list boxes.
Tip: For automated execution definitions, if you only have a few execution servers and do not require
hardware provisioning, it might be enough to use only the default, reserved keywords that are created
for each execution server. In such cases, it is not necessary that you select additional keywords.
7. Click > to move the keyword into the Assigned keywords list box.
Note: For automated execution definitions, the execution servers that match the assigned keywords
are listed below in the dynamically-updated Matching execution servers list box. This list updates
each time you add or remove a keyword. Click on the name of an execution server in the list to access
the execution servers in Administration ➤ Locations.
8. Click OK to save the keywords and close the Assign Keywords dialog box.
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Removing Keywords from a Configuration
To remove keyword assignments from a configuration:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the configuration suite that you want to edit.
4. Click the Configurations tab.
5. Click into the Keywords column of the configuration that you want to remove a keyword from.
The Assign Keywords dialog box opens.
6. Select the no longer needed keywords in the Assigned keywords list box.
Use CTRL + CLICK or SHIFT + CLICK to select multiple keywords using standard browser multi-select
functions.
7. Click < to remove the keyword assignments.
8. Click OK to save the keywords and close the Assign Keywords dialog box.
Note: Keywords that are not in use anymore are automatically deleted from the system.

Adding Manual Testers to Configurations
For configurations that include manual tests, the Configurations page enables you to assign users as manual
testers to a selected configuration. You can assign multiple manual testers to the configuration.
To assign a manual tester to a configuration:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the configuration suite that you want to edit.
4. Click the Configurations tab.
5. Click into the Manual Testers column of the configuration that you want to add a manual tester to.
The Manual Testers dialog box opens.
6. In the Available list box, select the user group of which the tester is a member.
The list box is populated with all members of the user group.
7. Select the name of the user you want to assign as a manual tester.
8. Click Add to add the user to the Selected list box; or click Add All to add all of the group’s members and
testers.
9. Click OK to close the Manual Testers dialog box.

Removing a Tester Assignment from a Configuration
To remove a tester assignment from a configuration:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the configuration node from which you want to remove a tester assignment.
4. Click the Configurations tab.
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5. Click into the Manual Testers column of the configuration that you want to remove a manual tester from.
The Manual Testers dialog box opens.
6. From the Selected list box, select the name of the assigned user that you want to remove.
7. Click Remove to remove the user from the Selected list; or click Remove All to remove all tester
assignments.
8. Click OK to close the Manual Testers dialog box.

Configurations Page
The Configurations page displays the configurations that are included in a configuration suite, in a grid. The
grid provides data for the automated generation of child execution definitions.
Each configuration that you add to the grid results in a new execution definition, which is executed with the
configuration suite.
For each listed configuration, the page displays the following columns:
Column
Actions

Description
•
Click
•

Click

to delete the configuration from the list.
to create a copy of the configuration.

Name

The name of the configuration. Click on the name to change
it.

Keywords

The list of the execution keywords that are assigned to the
configuration. Click on the link to change the list.

Manual Testers

The list of the manual testers that are assigned to the
configuration. Click on the link to change the list.

Parameters

The grid can have multiple parameter columns. Click
Add/Remove Parameters to add parameters to or remove
parameters from the grid. For additional information on
adding configuration parameters, see Adding Parameters
to a Configuration.

Click New Configuration to add a new configuration to the configuration suite.

VMware Lab Manager Integration
This section explains the integration of Test Manager with VMware Lab Manager (Lab Manager).

VMware Lab Manager Virtual Configurations
VMware images are virtual computer systems. Lab Manager is used to manage VMware images, or
"configurations", which are combinations of images, for example database server, application server, and
execution server. VMware configurations offer an effective means of virtualizing complex software-testing lab
environments. Configurations are typically deployed from Lab Manager libraries, and are turned on and off
just like individual VMware images. Multiple instances of the same configuration can be deployed simultaneously,
with separate tests run in each instance. VMware configurations are “network-fenced,” meaning that they do
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not influence each others' network behavior. VMware LiveLink technology enables you to take “snapshots” of
complete configurations that can later be recreated (or “restored”) on demand.
The integration of Lab Manager with Test Manager enables users to manage Lab Manager directly from the
Test Manager UI. Integrated functionality includes configuration deployment, test execution, result collection,
and automatic undeployment of configurations. Test Manager can support multiple Lab Manager installations
and configurations. Configurations captured using LiveLink technology are viewed using VMware Lab Manager.
Refer to the VMware Lab Manager documentation for full details regarding LiveLink configuration captures
and other Lab Manager functionality. For details on configuring the integration of Test Manager with Lab
Manager, refer to the SilkCentral Administration Module Help.
Note: At least one Test Manager execution server must exist within each configuration. These execution
server instances control test execution within configurations and retrieve test results.
Note: Lab Manager users must have administrator rights to access the Lab Manager API.

Analyzing Test Runs
This section describes how you can analyze test runs with Test Manager.

Calculating the Test Definition Status
When executing a test, the status of the test steps changes the overall status of the test definition.
The following statuses are available for a test step or test definition:
•
•
•
•
•
•

Not Executed
Passed
Failed
Unsupported
Unresolved
In Progress (only test definitions)

The calculation of the test definition status is based on the following rules, where the rules with lower numbers
override the rules with higher numbers:
1. If the status of the test definition is Not Executed, and you change the status of a test step, the test
definition status is set to In Progress.
2. As long as there is at least one step with status Not Executed, the test definition status remains In
Progress.
3. If there is at least one step with status Failed or Unresolved, the test definition status is set to Failed.
4. If the status of every test step is Passed or Unsupported, the test definition status is set to Passed.

Changing the Status of a Test Definition Run
To manually change the status of a test definition run:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Runs tab.
5. Select the execution definition run.
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The test definition section of the Runs page lists the test definition runs.
6. Click on the Run ID of the test definition.
The Test Definition Run Results dialog box displays.
7. Click the Details tab.
8. Click Change Status.
The Change Status dialog box opens.
9. Select the new status for the test definition run from the New Status list box.
10. Type an explanation for the manual status change in the Comment text box.
Note: Inserting a comment is mandatory.
11. Click OK to confirm the status change.
Note: Status changes produce history changes. To view the history of all status changes for the test
definition run, click the Messages tab in the Test Definition Run Results dialog box.

Viewing Test Definition Run Details
To view the details of a test definition run:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition in the Execution tree.
4. Click the Runs tab.
5. Click the Run ID of the execution for which you want to see details.
The Test Definition Run Results dialog box displays.
6. Click the Details tab.

Deleting Test Run Results
To delete the results of a specific test run:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select the execution definition that you want to edit.
4. Click the Runs tab.
5.
In the Actions column of the test run for which you want to delete results, click
6. Click Yes on the subsequent confirmation dialog box to complete the deletion.

Deleting the Results of an Execution Definition
To delete some or all of the run results of an execution definition, a folder, or a project:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Right click on the element in the Execution tree and select Delete Results.
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.

4. The Delete Results dialog box displays. Select which results you want to delete.
Option

Description

All runs except the last run

Deletes the results of all execution definition runs except the results of
the most recent run.

All runs within the time span

Deletes the results of all execution definition runs in the specified time
span. With this option selected, click
next to the From and To
fields to specify dates using the calendar tool.

5. Click OK to confirm the deletion.
Note: Results of tagged builds cannot be deleted. To delete these results, untag the build in
Administration ➤ Configuration ➤ Products. For more information, refer to the SilkCentral
Administration Module Help.

Execution Definition Run Results
Test Manager ➤ Projects ➤ Activities ➤ Last Executions ➤ Run ID
The Execution Definition Run Results dialog box lists the details of an execution definition run.
You can also access the dialog box from Test Manager ➤ Execution. Select the execution definition for which
you want to see details, click the Runs tab, right click on the run and choose View details.
The dialog box shows detailed information about the following items:
Item

Description

Execution Definition Name

Name of the execution definition.

Execution Definition ID

Unique identifier of the execution definition.

Execution Definition Run ID

Identifier of the excution definition run.

Start Time

Time the run was started.

Duration

Duration of the run.

Execution Server

Execution server assigned to the execution definition.

Warnings/Errors

Amount of warnings and errors generated during the run.

Status

Status of the test definitions that are assigned to the
execution definition after the run.

Version/Build

Version and build of the product specified for the run.

SilkTest Classic AUT Host Name

Name of the SilkTest Classic AUT (Agent Under Test) Host.

Setup Test Definition

Test definition that prepared the testing environment in
anticipation of the test. Click on the name of the test definition
to view or edit it. Click on the ID of the test definition run to
open the Test Definition Run Results dialog box.

Cleanup Test Definition

Test definition that restored the testing environment to its
original state following the test. Click on the name of the test
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Item

Description
definition to view or edit it. Click on the ID of the test definition
run to open the Test Definition Run Results dialog box.

The Execution Definition Run Results dialog box provides additional information about the files included
and the messages generated during the execution definition run. It also lists all the assigned test definitions
for the execution definition.
For manual tests click Manual Test Results to get a read-only version of the Current Runs page, with detailed
information on the manual test.
Uncheck the Hide passed test definition runs check box to show all test definitions. The Hide passed test
definition runs check box is checked by default to show only the not passed test definitions.
The Assigned Test Definitions section lists all test definitions that are assigned to this execution definition.
Click on the name of a test definition to view or edit it, or click on the Run ID of a test definition to open the
Test Definition Run Results dialog box.

Test Definition Run Results
Test Manager ➤ Execution ➤ Runs ➤ Assigned Test Definitions ➤ <Run ID>
The Test Definition Run Results dialog box lists run details of a test definition. You can access the dialog
box from the following locations:
•
•
•

Test Manager ➤ Test Plan ➤ <Test Definition> ➤ Runs ➤ <Run ID>
Test Manager ➤ Execution ➤ Runs ➤ Assigned Test Definitions ➤ <Run ID>
Test Manager ➤ Activities ➤ Last Executions ➤ <Run ID> ➤ Assigned Test Definitions ➤ <Run ID>

The Test Definition Run Results dialog box displays the following tabs:
Tab
Details

Description
Shows the details of the test definition run, including its
Duration, Execution Path, the Execution Definition Run
ID of the execution definition run that included the test
definition run, and any Warnings/Errors.This tab also allows
you to change the status of the test definition run. This option
is useful if you need to manually overrule the status of a test
run.
Uncheck the Hide passed test definition runs check box
below the Assigned Test Definitions in the Execution
Definition Run Results Dialog to show all test definitions.
The default setting shows only the not passed test definitions
to enhance performance. Only a part of the total test
definitions have to be displayed. Additionally the information
presented is of more use to the viewer. All parent nodes are
displayed with the full status information.
When a manual status change is performed, the details of
the change are reflected in this tab's Status, Status
Changed On, Status Changed By, Previous Status, and
Status Change Comment fields.
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Tab

Description

Specific

Only displayed for SilkTest Classic, SilkPerformer, and
manual test definitions. This tab includes details that are
specific to the selected test definition type. For example,
when a SilkTest Classic test definition is selected, this view
includes the selected test case, test data, and any warnings
that were displayed during the test run.

Files

Lists all files that were generated by this test run, along with
file sizes.The names of SilkTest Classic .rex files act as
download links. Once downloaded, these files can be viewed
directly in a text editor.
The upper table lists files that are associated with the test
definition, such as result files or manually uploaded files for
manual test definitions. The lower table lists files that are
associated with the execution definition, for example
execution log files or code analysis results.
Click Download All Files to download all result files
generated by the test definition run, as a zipped package.
For SilkTest Workbench, click the result.stwx file to
open SilkTest Workbench in context of the result file.
For SilkTest Workbench, click the error.png to see the
the last screenshot for a Visual Test when a playback error
occurs.

Messages

Lists all messages that were generated by this test run, along
with the severity of the messages.
Messages that are associated with an execution definition
as a whole, and not to one of the individual test definitions,
can be viewed in Test Manager ➤ Activities ➤ Messages

Success Conditions

Only displayed for automated test definitions. This tab shows
all the success conditions that are defined for the test in Test
Manager ➤ Test Plan ➤ Properties during the test planning
process, and the result values from the execution run.
Success conditions are used to determine if a test is
“successful” or if it has “failed.”

Data Driven

Only displayed for data-driven test definitions using the
option of having a single test definition for all data rows of
the data set. This tab lists the status of each instance (data
row) run of the test definition. Clicking an instance brings up
another instance of the Test Definition Run Results dialog
box with run details of the selected instance.

Attributes

Any attributes that are configured for the test definition.

Parameters

Any parameters that are configured for the test definition.

The following table lists the UI elements that are used to step through the test definition results of an execution
run. These elements are only visible when accessing the Test Definition Run Results dialog box from an
execution definition.
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Item

Description

Skip Passed

Used to determine which test definition run results should
be displayed when browsing using the Previous Result and
Next Result buttons. Checking this option only displays test
definitions with a status other than Passed.

< Previous Result

Jumps to the result details of the previous test definition in
the selected execution definition run.

Next Result >

Jumps to the result details of the next test definition in the
selected execution definition run.

Execution Runs Page
Test Manager ➤ Execution ➤

➤ Runs

The Runs page shows statistics regarding all the runs of the selected execution definition. For configuration
suites, the page displays all the runs of the included configurations. The page is split into two separate sections,
one listing the execution definition runs, and the second listing the test definition runs for the execution definition
run selected in the first section.
The grid views on the Runs page offer view settings, including resizing and reordering of columns, filtering,
sorting, and grouping options that are configurable on a per-user basis. You can display or hide columns,
adjust the width of columns, and move columns around by clicking on a column and dragging it to the desired
location. You can also use the keyboard to navigate through the runs.
To open the Execution Definition Run Results dialog box, right-click on a run and choose View Details. To
compare two execution definition runs, use Ctrl + Click or Shift + Click to select the two runs. Right-click on
your selection and select Reports ➤ Execution Definition Run Comparison ....
The execution definition runs section lists the runs of the selected execution definition. The section is paged
with fifty runs shown on a page. Use the arrow buttons to navigate through the pages. The page shows the
following columns for each run:
Column

Description

Actions

Actions that you can perform
on the execution definition.
Delete Click to delete the
Run
results of this run.
Results When you delete
the results for
selected runs, Test
Manager removes
the runs from the
Runs page. The
runs are grayed out
until the
background
process completes
the deletion.
Alternatively, press
Delete to delete
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Column

Description
the test run results.
For tagged builds,
you have to verify
that you want to
remove the results,
and when you have
selected multiple
runs, results from
tagged builds are
not removed.
View Click to view the
Manual Current Run page
Test
in read-only mode.
Results

Execution Definition

The name of the execution
definition that was
executed.This column is only
displayed for configuration
suites.

Status

Status summary of the run. A
bar lists the amount of
passed, failed, and not
executed test definitions. The
run status of each assigned
test definition is shown in the
second section of the page.

Run ID

Identifier of the execution
definition run. Click to access
the results of the run.

Keywords

Keywords assigned to the
execution definition.

Executed By

Name of the execution server
on which the run was
executed. For manual test
definitions the name of the
person who executed the run
is listed.

Errors

Number of errors that
occurred in the run.

Warnings

Number of warnings that
occurred in the run.

Product

The application under test.

Version

Version of the product. This
information can be set in
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Column

Description
Administration ➤
Configuration ➤ Products.

Build

Build number of the product
version. This information can
be set in Administration ➤
Configuration ➤ Products.
If the build is tagged, it is
marked bold and with

.

Start Time

Time the run started.

Duration

Duration of the test run in
h/mm/ss.

Start Type

Shows how the test run was
started. Manually, through a
Web Service, or from a
schedule.

Starter Name

Name of the schedule, tester,
or Web Service user.

Start Scope

The scope specified in the
Run dialog box.

The test definition runs section lists the test definition runs for the selected execution definition run. The section
is paged with fifty runs shown on a page. Use the arrow buttons to navigate through the pages. The page
shows the following columns for each run:
Column

Description

Actions

Actions that you can perform on the test definition run.
View or
download
results

If the test definition, to which the run
belongs, is of a test-definition type that
generates result files, click on the icons
to view or download the result files.

New Issue

Click to open the New Issue dialog box
and create a new issue for the test
definition.

Assign External Assign an issue from an
Issue
externally-configured issue-tracking
system to the test definition.
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Run ID

Identifier of the test definition run. Click to open the Test
Definition Run Results dialog box.

ID

Identifier of the test definition. This column is hidden by
default.

Test Definition

Name of the test definition. Click to access the test definition
in the Test Plan unit. The icon corresponds to the test type.
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Column

Description

Start Time

Date and time the run started.

Duration

Duration of the test definition run in h/mm/ss.

Status

Status summary of the run. For a single test definition a
single status is shown. A bar lists the amount of passed,
failed, and not executed test definitions for a test package
or suite node.

Executed By

Name of the execution server on which the run was
executed. For manual test definitions the name of the person
who executed the run is listed.

Issues Found

Displays the amount of issues that are assigned to the test
definition run. When no issues are assigned to the test
definition run, the column is empty. Click on the link to access
the issue in the Issues page of the Test Plan unit.

Errors

Number of errors that occurred in the run.

Warnings

Number of warnings that occurred in the run.

Executing Manual Tests
Manual test results integrate seamlessly with automated test results. The analysis features for project status
and test definition status in Test Manager operate the same with manual test results as they do with automated
test results. The results of manual test definition executions are saved alongside the results of automated test
definition executions in a central repository. The scheduling of manual tests and the association of manual
test definitions with execution definitions also works the same as with automated tests. You can also attach
result files, for example screengrabs, to manual test definitions.
Although manual tests are scheduled and managed alongside automated execution definitions, their actual
execution is quite different as they must be physically executed by a human tester. The Execution unit includes
a manual testing interface that facilitates the running of manual tests.

Executing Manual Tests through the User Interface
Tip: We recommend to use the Manual Testing Client, an Eclipse-based client tool, for executing manual
tests with Test Manager.
To execute a manual test through the Test Manager user interface:
1. Navigate to Test Manager ➤ Execution.
2. In the Execution tree, select the manual execution definition that you want to execute.
3. Click Run on the toolbar.
The Run dialog box displays.
4. Define which test definitions you want to execute and click OK.
Tip: To go directly to the Current Run page, uncheck Go to Activities page.
Note: When you choose the Run command on a manual test execution node, you must perform the
manual test yourself. When you choose the Run command on a folder, all included manual tests within
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the folder must be executed by the testers who are assigned to the folder on the Deployment page,
not the testers who are assigned to the individual execution definitions.
Note: Unless you have an automated test definition incorporated into the selected execution definition,
a dialog box opens, informing you that “No execution server has been specified for this execution
definition.” Manual tests do not use execution servers, so you can ignore this message and close the
dialog box.
5. If there are already pending manual tests in the selected execution definition, the Manual Tests In Progress
dialog box displays.
•
•
•

Click Start New to create a new execution of the manual tests.
Click Remove All Tests to finish all pending manual tests and set their status to Not Executed.
Select a pending execution and click Continue to continue the selected execution.

6. On the Current Run page, proceed with the manual test execution.

Executing Manual Tests in the Current Run Page
The Current Run page allows easily finishing a manual test run. All required information is displayed in the
two grid views, and the status of each test and test step can be changed with two clicks.You can see if someone
is working on the test, in which case the tests status is In Progress, who is working on the test, and which
test steps are already finished.
Tip: We recommend to use the Manual Testing Client, an Eclipse-based client tool, for executing manual
tests with Test Manager.
To execute a manual test using the current run page:
1. Navigate to Test Manager ➤ Execution.
2. In the Execution tree, select the execution definition with the assigned manual test that you want to execute.
3. Click Run on the toolbar.
The Run dialog box displays.
4. Define which test definitions you want to execute and click OK.
5. Optional: If the selected test is already in progress, a new test run starts. Click Cancel to close the Manual
Tests In Progress dialog box.
6. The Current Run page opens.
The page provides detailed information on every test step.
7. Click on the Status of a test step and change it to the appropriate status.
8. Repeat the previous step for all test steps.
9. Optional: Use Ctrl + Click and Shift + Click to select multiple test steps using standard browser multi-select
functions. Right click on your selection and set the status of the selected test steps to the selected status.
10. Optional: Click Finish Run to finish a run without finishing every test definition. The Finish Run dialog box
opens. Choose the appropriate build and the action to perform on the unfinished test definitions.
11. The Status of the manual test is changed to the cummulated status of the test steps when the test run
finishes. If one test step fails, the whole test is marked as failed.
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Aborting Manual Test Executions
Tip: We recommend to use the Manual Testing Client, an Eclipse-based client tool, for executing manual
tests with Test Manager.
To abort a manual test execution:
1. Navigate to Test Manager ➤ Activities.
2.
In the Current Executions section, click
to remove.

in the Actions column of the manual test definition you want

Manual Testing Client
The Manual Testing Client is an Eclipse-based client tool that provides the full functionality you need to efficiently
execute manual tests. The client enables testers to manage their tests, edit test definitions, and track results
without the need of an Internet connection.
Tip: We recommend to use the Manual Testing Client, an Eclipse-based client tool, for executing manual
tests with Test Manager.
Note: The Manual Testing Client supports running test executions with code analysis information. If a
test execution is already enabled to gather code analysis information within Test Manager, the settings
are automatically available in the Manual Testing Client. Code analysis can also be enabled for execution
definitions from within the Manual Testing Client.
Tour of the Manual Testing Client UI
Note: Eclipse does not initialize views until they are activated for the first time, so certain tabs within the
Manual Testing Client will not display their contents until they are selected. For example, the Attachments
page will not display the number of attachments it tracks until it is selected.
The following image displays the eight main areas of the UI of the Manual Testing Client.
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Menu Bar
The menu bar provides editing options for test definitions and views. You can use the menu bar to edit user,
appearance, or test settings, to navigate between execution packages, or to access Help. The following list
displays the available menus:
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Menu

Description

File

Provides the same functionality as the workflow bar and additional functionality for package
import and export, changing users, switching the Manual Testing Client between online and
offline mode, and storing executed package results to Test Manager.

Edit

The edit menu includes the following items:
Item

Description

Set as <Status>

Set the execution status of the execution package or test
definition to the selected status.
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Menu

Go
Window

Help

Description
Item

Description

Add Result File...

Add a result file to an execution package or test definition.

Edit Build Number...

Select the build number for an execution package.

Edit Code Analysis
Settings...

Specify hostnames to include in code coverage runs for an
execution package. The hostnames must be separated by
commas. For example: labmachine1, 192.168.0.1:19129.

Delete

Delete an execution package. You can delete only execution
packages with completed runs.

Navigate between the available execution packages and test definitions.
Edit the view and the preferences of the Manual Testing Client. The menu includes the following
items:
Item

Description

Show View

Activate and deactivate the available views in Manual Testing
Client's Workspace.

Reset Perspective...

Reset the current Manual Testing Client perspective to the
default state.

Preferences...

Set the preferences for the Manual Testing Client.

Access the documentation and About page of the Manual Testing Client.

Workflow Bar
The workflow bar gives you quick access to the basic functions you can perform with the Manual Testing Client.
The following buttons are available in the workflow bar:
Button

Description

Download

Download the execution packages from Test Manager.

Execute

Execute a test in the Manual Testing Client.

Finish

Stop the execution of a test before the test is fully executed.

Upload

Upload the execution packages to Test Manager.

Inbox
The Inbox lists all execution packages that have been downloaded to the Manual Testing Client for manual
execution. Multiple execution packages can be selected within the Inbox window using standard Windows
keyboard shortcuts. The Inbox includes the following properties for the selected test definition:
Property

Description

Package Name

Name of the execution package that has been downloaded from Test Manager.
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Property

Description

ID

Execution package number that has been generated for this execution package.

Status

Status of the execution package. Status values cannot be edited on the Completed
Runs page.The available values are Not Executed, Passed, Failed, Unresolved,
and Unsupported. Execution package status values cannot be edited. The overall
package status is determined by the composition of the test definition statuses, and by
extension the statuses of the test steps, that are contained within a package. For
example, overall package status remains Not Executed as long as a test step of one
of the contained test definitions has a status of Failed. So, even if some of a test
definition's steps have passed, the overall status of the package will remain Not
Executed until the package is finished and all unexecuted test definitions are assigned
a status on the Finish Run dialog box. The overall status will be considered Passed
when one or more test steps or test definitions in a package are Passed and all
unexecuted steps and test definitions are resolved through the Finish Run dialog box.

Priority

Priority of the execution package.

Keywords

All keywords that are assigned to the execution package.

Started At

When testing of the execution package began.

Project

Name of the Test Manager project from which the execution package was derived.

Version
Build
Execution Path

Product version from which the execution package was derived.
Product build from which the execution package was derived.
File path where this execution definition resides in Test Manager's Execution tree.

Completed Runs
The Completed Runs page lists all execution packages for which testing is complete. The Completed Runs
page includes the following properties for the selected execution package:
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Property

Description

!

This column offers a status icon that indicates the upload status of corresponding
execution packages. A red arrow icon indicates that a package's results have not yet
been uploaded. A checkmark icon over a faint arrow icon indicates that a package's
results have already been uploaded to the server. Double-click this icon to open the
Execute Test dialog for the first test definition of this execution package.

Package Name

Name of the execution package that has been downloaded from Test Manager.

ID

Execution package number that has been generated for this execution package.

Status

Status of the execution package. Status values cannot be edited on the Completed
Runs page. The available values are Not Executed, Passed, Failed, Unresolved,
and Unsupported. Execution package status values cannot be edited. The overall
package status is determined by the composition of the test definition statuses, and by
extension the statuses of the test steps, that are contained within a package. For example,
overall package status remains Not Executed as long as a test step of one of the
contained test definitions has a status of Failed. So, even if some of a test definition's
steps have passed, the overall status of the package will remain Not Executed until
the package is finished and all unexecuted test definitions are assigned a status on the
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Property

Description
Finish Run dialog box. The overall status will be considered Passed when one or more
test steps or test definitions in a package are Passed and all unexecuted steps and test
definitions are resolved through the Finish Run dialog box.

Priority

Priority of the execution package.

Keywords

All keywords that are assigned to the execution package.

Started At

When testing of the execution package began.

Finished At

When testing of the execution package ended.

Project

Name of the Test Manager project from which the execution package was derived.

Version
Build
Execution Path

Product version from which the execution package was derived.
Product build from which the execution package was derived.
File path where this execution definition resides in Test Manager's Execution tree.

Test Definitions
The Test Definitions page includes all information related to the manual test definition that is selected above
in the Inbox or Completed Runs page.
Multiple test definitions can be selected within the Test Definitions window using standard Windows keyboard
shortcuts. To apply a status change to selected test definitions, right-click the selection and select a new status
value from the context menu.
The Test Definitions page includes the following properties for each test definition:
Property

Description

#

Number that has been automatically generated for the test definition.

Name

Test definition name.

Status

Status of the test definition. The available values are Not Executed, Passed,
Failed, Unresolved, and Unsupported. This value can be changed by
right-clicking the current value and selecting an alternative value from the context
menu.

Last Status

Status that this test definition held before the current status.

Steps

Number of steps in the selected manual test definition.

Planned Time

Estimated time for completion of the test in [hh:mm:ss].

Used Time

This field tracks the elapsed time in [hh:mm:ss] since the start of the test
execution. This field can be manually edited. The timer will stop during editing.
After editing this field the timer will continue tracking time from the manually
adjusted time.

Test Definition Path

File path where this test definition resides in Test Manager's Test Plan tree.

Attachments
The Attachments page lists any attachments related to the selected manual test definition. This page is also
available on the Execute Test dialog box.
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When you have selected a test definition in the Test Definitions window, you have the option of supplementing
the list of displayed attachments by selecting an Include attachments of value. Select Test Container/Folders
to include all attachments from the selected test definition's test container or folder. Or select Test Steps to
include attachments from the test steps of the test definition.
The Attachments page includes the following properties for each attachment:
Property

Description

Name

Name of the attachment.

Type

Attachment file type.

Description

Description that has been created for the attachment, if any.

Source

File path where this attachment's test definition resides in Test Manager's Test
Plan tree.

Image Preview

If the attachment is an image, you can use the Image Preview controls to view
the attachment. Right-click the image, or click the buttons to the right of the window,
to access the following commands: Show Actual Size, Scale to Fit, and Scale
to Fit — Keep Aspect Ratio. Click Open as Detached Window to open Image
Preview in a separate window.

Result Files
The Result Files page lists any result files that are related to the selected manual test definition. This page is
also available on the Execute Test dialog box. The Result Files page includes the following properties for
each result file:
Property

Description

Name

Name of the result file.

Source

File path where this result file's test definition resides in Test Manager's Test Plan
tree.

Add File

Click to browse to and select a new result file for upload to this test definition.

Paste Image

Click to paste an image from your computer's clipboard and attach the image to
this test definition.

Remove

Click to remove the selected result file attachment from this test definition.

Image Preview

If the result file is an image, you can use the Image Preview controls to view the
result file. Right-click the image, or use the buttons to the right of the window, to
access the following commands: Show Actual Size, Scale to Fit, and Scale to
Fit — Keep Aspect Ratio. Click Open as Detached Window to open Image
Preview in a separate window.

Issues
The Issues page lists any issues related to the selected manual test definition. This page is also available on
the Execute Test dialog box. The Issues page includes the following properties of each issue:
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Issue ID

ID that has been assigned to this issue.

Synopsis

Synopsis that has been written for this issue.

Status

Status of the issue.
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External ID

Indicates if the issue is tracked by an external issue tracking system. If this
issue is tracked by an external issue tracking system, and that issue has been
assigned an ID, you can click the external ID number in this field to link directly
to the issue in the external issue tracking system.

Created On

When the issue was created.

Created By

User who created the issue.

Outline
Shows the content tree of the selected execution package or the location of the selected test definition in the
execution package.
Description
Shows the description of the selected execution package or test definition.
Status Bar
Shows the current amount and status of the execution packages and test definitions in the currently active
view.
Button

Description

Online/Offline

Click to switch Manual Testing Client's mode from online to offline and
back.

Installing Manual Testing Client
The Manual Testing Client is a separate executable from Test Manager. Using Java Web Start technology,
the Manual Testing Client can be deployed with a single click over the network. Java Web Start ensures the
most current version of Manual Testing Client is deployed, as well as the correct version of the Java Runtime
Environment (JRE).
Prerequisite: Java Runtime Environment (JRE) version 1.5 or higher must be installed on your computer to
use Manual Testing Client with Java Web Start technology. You can download JRE from
http://java.sun.com/javase/downloads/index.jsp.
Alternately you can install Manual Testing Client on your computer by navigating to Test Manager ➤ Help ➤
Tools ➤ Manual Testing Client.
Tip: To start the Manual Testing Client, navigate to Start ➤ Programs ➤ Silk ➤ SilkCentral ➤ Test
Manager 2010 R2 ➤ Manual Testing Client .
To install and start Manual Testing Client:
1. When clicking a link to the Manual Testing Client Web Start URL, http://<Test Manager
host>/webstart/mtc/), for example in a manual testing notification email, a File Download dialog box
opens.
2. Click Open.
If Manual Testing Client is not installed on your computer, the Java Web Start dialog box opens and
immediately starts downloading Manual Testing Client. The download can take up to several minutes. If
Manual Testing Client is already installed on your computer, Manual Testing Client opens and the following
steps are not applicable.
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When the download has completed, a Warning — Security dialog box opens, asking you if you want to
run the digitally signed application.
3. Check the Always trust content from this publisher check box, then click Run.
The Manual Testing Client opens.
Uninstalling Manual Testing Client
To uninstall the Manual Testing Client:
1. Open a command line window.
2. In the Windows command line window, type javaws —viewer and press Enter.
The Java Cache Viewer opens.
3. In the Show list box, select Applications, if not already selected.
4. The table should now list Manual Testing Client — Web Start. Select this application and click the delete
button (X) on the toolbar.
5. Manual Testing Client is now removed from your computer and you can close the Java Cache Viewer and
Java Control Panel dialog boxes.
Test Definitions in the Manual Testing Client
While in Edit mode, the Manual Testing Client offers a full range of test definition editing functionality, including
the addition, reordering, and removal of test steps and the insertion of step properties. You can edit manual
test definition properties in both online and offline modes. You can synchronize changes made in offline mode
with the server whenever an Internet connection is available.
Edit mode enables editing of all test definition elements that can be edited through the Test Manager Web
client. On the Details page this includes the following values:
•
•
•
•
•

Planned Time
Step Names
Step Property Values
Step Description
Expected Result

On the Description page the Test Definition Description field can be edited, including the insertion of step
property parameters.
In Edit mode, multiple test steps can be selected within the Test Definitions window using standard Windows
keyboard shortcuts. To apply a status change to selected test steps, right-click the selection and select a new
status value.
In normal mode, you can only enter test results into the Result column and edit the status of test definitions
and individual test steps. Statuses are changed by right-clicking status values and selecting an alternative
status value.
Note: Editing of data-driven test definitions is not supported.
Parameters
Step property parameters can be inserted into test definition and test step descriptions. Parameters can be
inserted into the Test Definition Description, Step Description, and Expected Result fields. In normal
mode, parameter values are resolved (their parsed values are displayed in place of the parameters themselves).
In Edit mode parameters are not resolved; the parameters themselves are displayed. When in Edit mode,
using the Parameters list box on the Description tab toolbar, you can select preconfigured Test Manager
parameters for insertion.
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Change Conflict Handling
With the Manual Testing Client's offline editing functionality it's possible for multiple users to edit the same test
definition at the same time. Test Manager automatically merges all uploaded changes into the Test Plan tree
unless change conflicts arise, for example if two users simultaneously edit the same manual test step. If your
uploaded changes conflict with recent changes made by another user, upon upload, you will be presented
with the Test Definition Conflicts dialog box so that you can manage the conflict.
Using the Test Definition Conflicts dialog box you can specify if your changes should be saved as a part of
the test definition and included in future runs of the test definition, or if they should be ignored. If you opt to
have your changes ignored, they will still remain a part of the test results from the test run in which they were
included.
Configuring the Manual Testing Client
This section explains how to configure the Manual Testing Client.
Configuring Connection Parameters
Connection parameters are configured automatically the first time you start the Manual Testing Client.
To edit login credentials and validate your connection:
1. In the Manual Testing Client, navigate to Window ➤ Preferences.
The Preference Settings dialog box opens.
2. Type the URL of your Test Manager installation in the Test Manager server URL text box.
3. Select Remember Credentials if you want the Manual Testing Client to insert your login credentials
automatically the next time you start the application.
4. Enter your Test Manager Username and Password.
5. Click Validate Connection to test your login settings.
6. Click OK on the confirmation dialog box.
7. Click OK to save your settings.
Configuring Other Settings
To configure other settings:
1. In the Manual Testing Client, navigate to Window ➤ Preferences.
The Preference Settings dialog box opens.
2. In the Other settings section, check or uncheck one or more of the following check boxes:
Download attachments
automatically

Download attached files automatically when execution definition
packages are downloaded from Test Manager. This option must be
enabled if you intend to work offline after you download your assigned
execution packages.

Ask for build number when
completing packages

Before uploading packages to Test Manager, display a prompt
requesting the build number on which the test was performed.

Show execution dialog always
on top

Have the Execute Test dialog box display on top of other open windows
on your computer desktop to facilitate manual testing. When enabled,
the Execute Test dialog box stays on top even when another window
has the focus. When executing manual tests, you may want to keep
the Execute Test dialog box on top so that you can easily enter your
test results. If your computer monitor is too small to contain both the
Execute Test dialog box and the application under test, you should
leave this setting unchecked.
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Ask for uploading workspace to Display a confirmation prompt before closing the Manual Testing Client.
SilkCentral Test Manager before
closing main window
3. Click OK to save your preference settings.
Configuring Package Upload Preferences
To configure execution-package upload preferences:
1. In the Manual Testing Client, navigate to Window ➤ Preferences.
The Preference Settings dialog box opens.
2. In the Packages area of the dialog box, check the Remove uploaded packages check box to define an
option for automatic deletion of execution definition packages from the Manual Testing Client after packages
are uploaded to Test Manager.
3. Click one of the following deletion option buttons:
•
•

Immediately
After <x> days. Type a value in the days text box if you select this option.

4. Check the Upload completed packages immediately check box if you want to have completed test run
packages uploaded to Test Manager automatically after test runs are completed.
Managing Attachments with the Manual Testing Client
This section explains how to manage attachments with the Manual Testing Client.
Pasting Screen Captures
To upload a screen-captured image directly from the clipboard:
1. Copy a screen capture to your computer’s clipboard.
The Paste Image button on the Result Files page of the Manual Testing Client becomes enabled.
2. Click Paste Image.
3. Specify a File Name for the image on the Paste From Clipboard dialog box.
4. Click OK to save the copied screen capture as an image file attachment.
Uploading Attachments to the Manual Testing Client
When during the course of testing you encounter a relevant result file, which can be a screen-captured image,
an error log, or another file, you can upload the file as an attachment to a test definition.
To upload a result file as an attachment:
1.
2.
3.
4.

In the Manual Testing Client, select a test definition in the Test Definitions page.
Click the Result Files tab.
Click Add File to browse to and select the result file you want to upload.
Click Open to attach the file.

Viewing Attached Images Within the Manual Testing Client
To view an attached image file:
1. In the Manual Testing Client, select an image file in the Attachments page.
The image displays in the Image Preview field.
2. Use the following viewing tools next to the Image Preview field to manipulate the image:
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•
•
•
•

Show Actual Size
Scale to Fit
Scale to Fit - Keep Aspect Ratio
Open as Detached Window

Viewing Attachments Within the Manual Testing Client
To view a test definition attachment from within the Manual Testing Client:
1. In the Manual Testing Client, select a test definition in the Test Definitions page.
2. The Attachments page lists all of the result files that are associated with the selected test definition.
3. Using the Test Container/Folders and Test Steps check boxes, you can filter the list of attachments to
include only those attachments that are related to the selected test container, test folder, or test step.
Working with Execution Packages
Downloading Execution Packages
After the Manual Testing Client is configured, the first step in running manual tests is downloading copies of
the manual execution definitions that are assigned to you.
Note: Execution definitions remain online in Test Manager; only copies of the execution definitions are
downloaded to the Manual Testing Client.
To download the execution packages that are assigned to you:
1. In the Manual Testing Client, click Download on the toolbar.
2. If your connection settings are correctly configured, and execution definitions are started in Test Manager,
the execution packages that are assigned to you display in the Inbox.
Exporting Execution Packages
Downloaded execution packages can be both exported from and imported to the Manual Testing Client. This
allows for easy exchange of execution packages between testers over email. Downloaded attachments are
automatically included in exported packages.
Note: Execution packages have the .zpkg extension.
To export an execution package:
1.
2.
3.
4.

In the Manual Testing Client, right-click an execution package in the Inbox page.
Select Export Package.
On the Export to dialog box, browse to the location where the package is to be saved and click Save.
Click OK on the confirmation dialog box notifying you that the export was successful.

Importing Execution Packages
Downloaded execution packages can be both exported from and imported to the Manual Testing Client. This
allows for easy exchange of execution packages between testers over email. Downloaded attachments are
automatically included in exported packages.
Note: Execution packages have the .zpkg extension.
To import an execution package:

SilkCentral Test Manager 2010 R2

| 289

1. In the Manual Testing Client, navigate to File ➤ Import Package.
2. On the Import from dialog box, browse to the package that is to be imported and click Open.
3. Click OK on the confirmation dialog box notifying you that the import was successful.
Editing Package Build Numbers
To edit the build number of an execution package:
1. In the Manual Testing Client, right-click an execution package in the Inbox page.
2. Select Edit Build Number.
The Select Build Number dialog box opens.
3. Select a build number from the Build list box.
Note: You can refresh the build list by clicking Refresh build list.
Note: If you want to be prompted to specify a build number each time a test run is completed, check
the Ask for build number when completing packages check box.
4. Click OK.
Uploading Test Results to Test Manager
To upload test results from finished packages:
1. In the Manual Testing Client, complete a manual test by clicking Finish Run on the Execute Test dialog
box or Finish on the toolbar.
Note: If you attempt to complete testing of a test package while any of the package's test definitions
have a status of Not Executed, the Finish Run dialog box will display on which you can define how
unexecuted test definitions should be handled.
2. Click the Completed Runs tab.
3. Right-click a completed test run and select Upload to Test Manager, or select Upload from the File menu,
to upload your test results to Test Manager.
Note: Execution definition statuses are updated automatically in the SilkCentral database when you
are working online.
Storing Test Results to Test Manager
To store test results from Manual Testing Client in Test Manager:
1. In the Manual Testing Client, select Store Results to SilkCentral from the File menu.
2. Alternatively, when closing Manual Testing Client, you can upload your entire workspace to Test Manager.
Adding an Internal Issue with the Manual Testing Client
The Manual Testing Client enables you to create an internal issue and map an external issue to this internal
issue. To create the internal issue and map the external issue:
1. In the Manual Testing Client, click the Inbox tab.
2. Select an execution definition package.
The test definitions included in the selected package are listed in the Test Definitions page.
3. In the Test Definitions page, double-click a test definition.
4. Click New Internal Issue.
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The New Issue dialog box opens.
5. Fill out the text boxes.
6. Click OK.
Note: You must be online during this procedure.
Enabling Code Analysis Within the Manual Testing Client
To enable code analysis for an execution definition from within the Manual Testing Client:
1. In the Manual Testing Client, navigate to Edit ➤ Edit Code Analysis Settings.
The Edit Code Analysis Settings dialog box opens.
2. Check the Enable code analysis for package <Package Name> check box.
Note: After code analysis is enabled, you can execute your test definitions in the Manual Testing
Client. However, you need to click Code Analysis: Start on the Details page of the Execute Test
dialog box before you actually start testing. This way Test Manager will collect code analysis information
while you execute the manual test. When you are done testing, click Stop to halt the collection of code
analysis information.
3. Select a profile from the Code Analysis Profile list box.
4. In the Hostnames text box, enter a comma-separated list of hostnames, with port, if default port 19129 is
not used, from which code analysis information is to be gathered.
For example labmachine1, labmachine2:8000, 198.68.0.1. For each execution definition, you
need to define the host names of the machine resources where the AUT is running. For example, with a
client/server system, you must not only gather code coverage information on the client, which probably
runs directly on an execution server, but also on the server, which likely runs on a different machine. This
applies to all multi-tiered applications.
Note: For JUnit code analysis runs, you do not need to specify a hostname.
5. Click OK to save your settings.
Working Offline with the Manual Testing Client
If you plan to work without access to an Internet connection, select offline work mode so that the Manual
Testing Client will not attempt to connect to Test Manager automatically.
To work in offline mode:
1. In the Manual Testing Client, select File ➤ Work Offline or click Online in the bottom right corner.
2. Once you have completed your tests and have access to an Internet connection, proceed with uploading
your test results.
Execute Test Dialog Box
When you execute a manual execution definition in the Manual Testing Client, the Execute Test dialog box
displays. This dialog box enables you to execute the test steps that are included in the selected execution
definition, and track the results of the test steps.
The Execute Test dialog box includes the following pages: Description, Details, Attachments, Result Files,
and Issues.
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Description
In normal mode, the Description page offers a read-only Test Definition Description text box for the selected
test definition and the Test Definition Name text box. In edit mode, these text boxes can be edited. Click
Open Description in Separate Window to open the most recently saved version of the test definition description
in a separate window. The detached window always remains on top to assist in manual testing.
Details
The Details page offers a read-only description of the selected test definition.
The page includes the following items:
Item

Description

Test Definition Status

Current status of the test definition. In edit mode this text
box can be edited.

Last Status

Status of the test definition in the previous test run.

Planned Time

Estimated time for completion of the test in hh:mm:ss. In
edit mode this text box can be edited.

Used Time

This text box tracks elapsed time in hh:mm:ss since the
beginning of test execution. This text box can be manually
edited. The timer stops during editing. After editing this text
box the timer continues tracking from the manually adjusted
time.

Start

Initiates code analysis. Enter the host names for which you
want to run code analysis.

Test Steps

Lists the manual test steps the selected test definition
includes.You can select multiple test steps in the Test Steps
section by using the standard Windows keyboard shortcuts.
To change the status of the selected test steps, right-click
on the steps and choose a new status value.

Result

The result of each test step as observed by the tester. Edit
this text box after you have completed this step.

Status

Status of each step. Edit this text box after you have
completed this step.

Step Description

Describes the action you must perform in this step.

Expected Result

The expected result or success condition of each test step.

Execute Test Toolbars
The Execute Test dialog box includes the following toolbars:
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Toolbar

Description

Test Steps

Use to manage your manual test steps during a test execution. The toolbar includes the following
items:
Item

Description

Add Test Step

Add a new test step to the end of the Test Steps
list.

Insert Test Step

Insert a new test step above the selected test step
in the Test Steps list.

Duplicate Test Step

Create a copy of the selected test step in the Test
Steps list.

Delete Test Step

Delete the selected test step from the Test Steps
list.

Move Test Step Up

Move the selected test step up one position in the
Test Steps list.

Move Test Step Down

Move the selected test step down one position in
the Test Steps list.

Text
Use to formate the Test Definition Description, Step Description, and Expected Result
Formatting descriptions. Click Parameters to insert parameters into your descriptions. The toolbar includes
the following items:
Item

Description

Bold

Apply bold formatting to the selected text.

Italics

Apply italicized formatting to the selected text.

Underline

Apply underlined formatting to the selected text.

Align Left

Align the selected text to the left side.

Align Center

Align the selected text to the center.

Align Right

Align the selected text to the right side.

Justify

Apply a justified alignment to the selected text.

Bulleted List

Convert the selected text to a bulleted list.

Indent Left

Apply a left-side indent to the selected text.

Indent Right

Apply a right-side indent to the selected text.

Undo Change

Undo the last action you performed in a text
description text box.

Redo Change

Redo the last action you performed in a text
description text box.

Font

Apply a different font type to the selected text.

Font Size

Apply a different font size to the selected text.
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Toolbar

Navigation

Description
Item

Description

Format

Apply a different pre-defined formatting style to the
selected text. For example, Heading 1, Heading 2,
...

Parameters

Insert preconfigured Test Manager custom step
properties, which are also called project parameters,
into text descriptions. In normal mode, the dialog
box displays the parsed values of the resolved
parameters. In Edit mode, the dialog box displays
the actual parameters.

Use to manage your manual test execution and to navigate between test definitions. The toolbar
includes the following items:
Item

Description

Edit

Edit the properties of the selected test definition.

New Internal Issue

Add an internal issue to the selected test definition.

Go To Issues

View the issues of the selected manual test
definition in Test Manager, or assign new issues to
the test definition.

Previous Test

Return to the previous test step in the manual test
execution.

Next Test

Advance to the next test step in the manual test
execution.

Finish Run

Close the Execute Test dialog box when you have
completed all test steps in the active manual test
definition.

Video Capturing in the Manual Testing Client
You can capture a video of a test in Manual Testing Client, which you can then add to the Manual Testing
Client result files. You can then analyze the video, for example if an error occurs during the test.
Note: Video capturing is currently enabled only for Microsoft Windows operating systems. To use video
capturing on a Windows 2008 system, you need to install the following server features:
•
•

Desktop Experience
Quality Windows Audio Video Experience

Note: The main display of your system is recorded. Secondary displays are not included in the video.
During the recording, some tasks are not enabled. To perform such tasks, stop the recording.
Recording Videos in the Manual Testing Client
To enable video capturing in the Manual Testing Client:
1. In the Manual Testing Client, click on the package that includes the test that you want to execute in the
Inbox.
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The test definitions in the selected package are displayed in the Test Definitions.
2. Double-click on the test definition that you want to execute.
The Execute Test dialog box opens.
3. Click the Details tab.
The Details page opens.
4. In the Test Definition Details section, click Start on Video Recording.
A red button indicates that a video of the test is being recorded.
5. When you no longer want to record, click Stop on Video Recording.
The Add Video to Result Files dialog box opens.
6. Type a name for the video file, and click OK, to save the video, or click Cancel to delete the video file.
The video is added to the result files of the test definition.
7. To view the video, click the Result Files tab and double click on the video file.

Current Run Page
Test Manager ➤ Execution ➤

➤ Current Run

To access the Current Run page of an execution definition, select the execution definition in the Execution
tree and click the Current Run tab.
The Current Run page shows information about the active manual test run and enables you to see who is
working on which test step. You can execute the manual test run with a few clicks. The page features two grid
views, Assigned Test Definitions and Test Steps. Assigned Test Definitions shows information about the
active manual test run, and Test Steps shows information for each of the steps in the manual test. You can
filter the test definition runs in the Assigned Test Definitions view by selected columns, through right-clicking
the desired column. When multiple runs of a manual test definition are in progress, the one first started is
shown. Three additional views display additional information on the execution definition, the active test definition,
and the selected test step.
The two grid views offer view settings that are configurable on a per-user basis. Display or hide columns, adjust
the width of columns, and move columns around by clicking on a column and dragging it to the desired location.
Use Ctrl + Click or Shift + Click to select multiple test definitions or test steps using standard browser
multi-select functions. Right click on your selection and set the status of the selected test steps to the selected
status.
You can perform the following general actions on the Current Run page:
Action

Description

Reload

Click to reload the Current Run page.

Synchronize Run

Click to update the tasks shown in the Current Run page.
The following items are updated:
Item

Description

Assigned test Only when you start the run with scope
definitions
Run all Tests and click Synchronize Run,
test definitions that are newly assigned to
the execution definition are shown, and
test definitions that are no longer assigned
to the execution definition are removed, if
the test definitions are not already started.
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Action

Finish Run

Description
Item

Description

Test
properties

The name, the description, the
attachments, and the other test properties
of the assigned test definitions.

Test step
properties

The name, the description, the
attachments, and the other test-step
properties of the steps in the assigned test
definitions.

Click to finish the test execution and to open the Finish Run
dialog box. From the Build list box, choose the appropriate
build. The build of the execution definition on which the
manual test was started is preselected from the list. If there
exist test definitions in the execution definition run with status
Not Executed, you can choose an action to perform
from the Status list box. The following items are available
in the dialog box:
Item

Description

Remove test
definitions from
this run

Removes all test definitions with
status Not Executed from the
execution definition run. This action is
only available if the run includes tests
with status Not Executed.

Set to Passed,
Failed,
Unsupported, or
Unresolved

Sets all test definitions with status
Not Executed to the selected
status. This action is only available if
the run includes tests with status Not
Executed.

Select Build

Select the build number for the
execution definition run from the list
box.

The Execution Definition Run Details view displays the following information on the execution definition run,
which has the active manual test run assigned:
•
•
•

•
•
•
•
•
•
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The ID of the execution definition run.
The name of the execution definition.
The configuration suite or folder in the context of which the execution definition is executed. Click to access
the suite or folder in the execution tree. If the execution definition is not included in a configuration suite or
folder, nothing is displayed.
The keywords assigned to the execution definition run.
The version of the execution definition's product.
The build of the execution definition's product.
The run type of the execution definition run.
The start type of the execution definition run.
The name of the tester, schedule, or Web Service user that started the execution definition run.
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•
•

The start scope of the execution definition run, specified in the Run dialog box.
The start time of the execution definition run.
Note: You can show or hide the Execution Definition Run Details view by clicking on the arrows in the
top-right corner. The view is collapsed by default.

The Assigned Test Definitions view provides the following information for the manual test definition run:
Columns

Description

Actions

Actions that can be performed during the run. Some of these
actions are not available for data-driven tests. The following
actions can be performed:
Add Result File

Add a result file to the test definition.

New Issue

Create a new issue for the test
definition.

Assign External Assign an issue from an
Issue
externally-configured issue-tracking
system to the test definition.
Edit Test
Definition

Edit the test definition in the Edit Test
Definition dialog box. When you close
the dialog box, Test Manager
automatically synchronizes the test run.

#

Order of the test definition in the execution definition run.

ID

Identifier of the test definition. This column is hidden by
default.

Test Definition

Name of the test definition. Click on the name to view the
test definition, or to perform an action on the test definition.

Status

Current status of the test. Click on the status to change it.

Executed By

Name of the user that has started the test run.

The Test Steps view provides the following information for each test step:
Item

Description

Actions

Actions that can be performed during the run.
Edit

Edit the test step in the Edit Step dialog box.
When you close the dialog box, Test Manager
automatically synchronizes the test run.

#

Order of the step in the test.

Step Name

Name of the step. Click to access the step in Test Plan ➤
Steps.

Status

Execution status of the step. Click on the status to change
it.

Result

Result of the step. Click on the text box to edit the result.
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Tip: You can hide the Test Steps view by clicking on the arrows in the top-right corner.
The Test Definition Details view displays the following information for the active manual test definition:
•
•
•
•
•
•

The name of the test definition.
The planned time for the execution of the test definition (manual test definitions only).
The amount of attachments attached to the test definition. Click on the link to access the attachments.
The amount of issues assigned to the test definition. Click on the link to access the issues.
Result files generated for the test definition. Click on the links to access the result files.
The description of the test definition.

The Step Details view displays the following information for the selected step:
•
•
•
•
•

The name of the step.
A description of the action the step performs.
The expected result of the step.
The result of the step, when the test run is finished.
The attachments to the step.
Tip: You can hide the Step Details view by clicking on the arrows in the top-right corner.

If other execution definition runs are started while the Current Run page is open, a note displays, stating that
newer runs are available. You can see information on those runs in the Activities page.
For automated tests, the Current Run page shows the progress of the execution.

Running Automated Tests
This section explains how to run automated tests with Test Manager.
You can either run a test immediately, in which case the execution definition is queued on the specified execution
server, you can re-run any test definitions that failed during the most recently executed test, or you can proceed
with manual testing.
Changes that are made to test-plan properties are automatically deployed to execution servers and used for
executions. The Test Plan unit is designed to enable you to perform modifications and extensions to test plans
without concern whether properties are valid and consistent for execution.

Executing Individual Tests
To run an execution definition independent of a schedule:
1. Navigate to Test Manager ➤ Execution.
2. In the Execution tree, select the execution definition that you want to execute.
3. Click Run on the toolbar.
The Run dialog box displays.
4. Define which test definitions you want to execute.
The execution definition is then queued on the specified execution server. Test definitions are executed in
the order in which they are listed on the Assigned Test Definitions page. Details of executions can be
viewed in the Activities page.
5. If the execution definition does not contain pending manual tests, the Go To Activities dialog box displays.
Click Yes to view the Activities page, or click No if you want to remain on the current Web page.
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Note: Check the Don't show this dialog again (during this login session) check box if you do not
want to be asked about switching to the Activities page again in the future. This setting will be discarded
when you log out of Test Manager.

Manually Executing Automated Tests
Automated tests might sometimes deliver unexpexted results because of environmental issues. When such
a test fails in a system, and you want to verify if the failure is caused by a system component, or you know
that the problem is caused by a currently disfunctional system component, you can re-run the automated test
manually.
To run an automated test manually, perform the following steps:
1. Navigate to Test Manager ➤ Execution.
2. In the Execution tree, select the execution definition that you want to execute.
3. Click Run on the toolbar.
The Run dialog box displays.
4. Define which test definitions you want to execute.
5. Select Run automated tests manually in the Run type list box.
All selected tests are then treated as manual tests, and the Current Run page opens.

Working with SilkPerformer Projects
SilkPerformer is fully integrated with the test planning and test execution functionality of Test Manager.
SilkPerformer projects can be integrated into Test Manager test plans and directly executed through Test
Manager. This allows for powerful test-result analysis and reporting. It also enables unattended testing, which
means tests are run automatically by Test Manager based on pre-configured schedules.
Refer to the SilkPerformer Help for details on configuring the integration of SilkPerformer with Test Manager.
SilkPerformer project files can be directly opened in SilkPerformer from Test Manager, where scripts and
settings can be edited. Edited SilkPerformer projects can subsequently be checked back into Test Manager
to make them available for future test executions.
Test Manager provides information on execution definition run properties during SilkPerformer test executions.
Use the AttributeGet methods to access execution definition run properties in the SilkPerformer script.
You can access the following properties in the script:
•
•
•
•
•
•

#sctm_execdef_id
#sctm_execdef_name
#sctm_product
#sctm_version
#sctm_build
#sctm_keywords
Note: The term Project is used differently in SilkPerformer than it is in Test Manager. A SilkPerformer
project, when uploaded to Test Manager, becomes the core element of a Test Manager test definition.
Test Manager projects are high-level entities that may include multiple SilkPerformer projects, test
definitions, execution definitions, and requirements.
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Downloading SilkPerformer Projects
Whereas opening a SilkPerformer project may involve checking out a SilkPerformer project from a source-control
tool, editing the project in SilkPerformer, and checking the project back into Test Manager, downloading a
project involves downloading a copy of a project and working with it independently of Test Manager. Changes
you make to downloaded projects are not automatically migrated back to Test Manager.
To download a SilkPerformer project:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a SilkPerformer test definition.
4. Click the Properties tab.
5. Scroll down to the SilkPerformer Test Properties section.
6.
Click
.
A file download dialog box displays, asking you to confirm that you wish to download the specified
SilkPerformer project to your local system.
7. Click Save to open the file in SilkPerformer.
If not already open in the background, SilkPerformer is invoked.
8. The Select Target Directory dialog box displays, loaded with the default directory path to which the specified
SilkPerformer project will be saved. If you approve of the specified pathname, click OK, otherwise click
Browse to specify an alternate path.
Note: Even if you have configured source-control integration, you will not be prompted to check out
the SilkPerformer project from your source-control system because you are working with this file
independently of Test Manager.
Note: SilkPerformer projects utilized by Test Manager can also be downloaded directly from the
SilkPerformer user interface. For additional information, refer to the SilkPerformer documentation.

Opening SilkPerformer Projects
To open a SilkPerformer project from Test Manager:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3.
4.
5.
6.

In the Test Plan tree, select a SilkPerformer test definition.
Click the Properties tab.
Scroll down to the SilkPerformer Test Properties section.

Click .
A file download dialog box displays, asking you to confirm that you wish to open the specified SilkPerformer
command file (.spwbcmd) in SilkPerformer.
7. Click Open to open the file in SilkPerformer. If not already open in the background, SilkPerformer is invoked.
The Select Target Directory dialog box opens, loaded with the default directory path to which the specified
SilkPerformer project will be saved.
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8. If you approve of the specifed pathname, click OK, otherwise click Browse to specify an alternate path.
9. If you have configured source-control integration for Test Manager, for example Visual SourceSafe, you
are presented with a login screen for your source-control client. Enter valid user connection settings and
click OK to continue.
Note: SilkPerformer projects utilized by Test Manager can also be opened directly from SilkPerformer.
For additional information, refer to the SilkPerformer documentation.

Executing Attended SilkPerformer Tests
Attended tests are SilkPerformer tests that are executed manually in SilkPerformer and are not executed
automatically based on a pre-defined schedule in Test Manager.
Note: To use Test Manager's data-driven test functionality with SilkPerformer scripts, data sources with
column names matching the corresponding SilkPerformer project, attributes must be used in conjunction
with AttributeGet methods.
To execute an attended test run in SilkPerformer:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a SilkPerformer test definition.
4. Click the Properties tab.
5. Scroll down to the SilkPerformer Test Properties section.
6.
Click
.
A file download dialog box displays, asking you to confirm that you wish to run the specified SilkPerformer
command file (.spwbcmd).
7. Click Open to open the project in SilkPerformer.
If not already open in the background, SilkPerformer is invoked. The Select Target Directory dialog box
displays, loaded with the default directory path to which the specified SilkPerformer project will be saved.
8. If you approve of the specified pathname, click OK, otherwise click Browse to specify an alternate path.
The SilkPerformer Workload Configuration dialog box opens with all of the workload settings that are
associated with the SilkPerformer project.
9. Edit the workload settings as required and click Run to begin the test and monitor the test results with
SilkPerformer.
Note: Clicking Run without editing any workload settings executes the SilkPerformer test in exactly
the same way as if the test had been executed directly from Test Manager as an unattended test.

Editing SilkPerformer Test Properties
Note: To use the data-driven test functionality of Test Manager with SilkPerformer scripts, you have to
use data sources with column names that match the corresponding SilkPerformer project attributes in
conjunction with AttributeGet methods.
To edit SilkPerformer test properties:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.

SilkCentral Test Manager 2010 R2

| 301

3.
4.
5.
6.
7.

In the Test Plan tree, select a SilkPerformer test definition.
Click the Properties tab.
Scroll down to the SilkPerformer Test Properties section.
Click Edit SilkPerformer Test Properties.
Proceed with the configuration of your SilkPerformer test.

Analyzing SilkPerformer Test Results
Performance Manager enables in-depth analysis of SilkPerformer test results. The Analyze Results option
downloads only selected results, in contrast to “Downloading result packages”. To assist you in analyzing the
results of your optimization efforts, Performance Explorer even allows you to compare statistics from multiple
test runs side-by-side in cross load-test reports.
The results of tests that are run using Test Manager can be automatically loaded into Performance Manager
through commands on the Runs page in the Test Plan unit.
For full details on using Performance Manager and integrating Performance Manager with Test Manager, refer
to the Performance Manager documentation.
To open SilkPerformer test results in Performance Manager:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition you are interested in viewing.
4. Click the Runs tab.
5.
Click
in the Actions column of the test execution for which you want to download results.
A File Download dialog box displays, showing you the name of the Performance Manager command file,
.sppecmd, that you are about to download.
6. Click Open to open the results in Performance Manager. Alternatively, you can click Save to save the
results locally.
7. If not already open in the background, Performance Manager now opens, connected directly to your Test
Manager installation, and fetches the results of the selected execution run.
Note: To prepare for a cross load-test report that compares the results of multiple executions in a
single report, you may download the results of additional executions from the Runs page. Additional
execution results are displayed in the existing instance of Performance Manager on the Performance
Manager Test Manager tab. For additional details on cross load-test reports, refer to the Performance
Manager documentation.

Downloading SilkPerformer Test Result Packages
Downloading result packages is the ideal option if you want to analyze the complete results set of a test run,
or if you want to download the complete results set for offline analysis. Because result packages often include
large TrueLog On Error files, result packages can be compressed and downloaded to your local hard drive as
.lrz files. Downloading results locally can also be useful when you are working from a slow Internet connection.
To download SilkPerformer test results:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
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3. In the Test Plan tree, select a SilkPerformer test definition.
4. Click the Runs tab.
5.
Click
in the Actions column of the test execution for which you want to download results.
A File Download dialog box displays, showing you the name of the compressed results package file, .ltz
that you are about to download.
6. Click Open to open the results in Performance Manager. Alternatively, you can click Save to save the
results locally.
7. If not already open in the background, Performance Manager now opens.You are presented with an Import
Project dialog box that indicates the target directory to which the results will be saved. Click OK to accept
the default path, or click Browse to select an alternate path. The downloaded results are then displayed
in Performance Manager.
Note: If you accept the default projects directory where result packages are typically stored, which
we generally recommend, then the results will be stored with all otherSilkPerformer results and will be
readily accessible through the Performance Manager Add Loadtest Results command.

Uploading SilkPerformer Test Results
Once you have completed running an attended test in SilkPerformer, you can upload the test results to Test
Manager and associate the results with a test definition.
To upload results from an attended SilkPerformer test:
1. Run an attended SilkPerformer test.
For additional information, see Executing Attended SilkPerformer Tests.
2. When the test is complete, select Upload Results to Test Manager from the Results menu.
The Login screen of the Upload Results to Test Manager wizard displays.
3. Enter your Password and click Next.
Note: Because this is an attended test, the wizard already knows the appropriate hostname and
username of the test definition to which these results are to be uploaded.
4. If not already selected by default in the project list, select the Test Manager project to which you want to
upload the SilkPerformer results.
5. If not already selected by default in the tree list, select the test definition to which you want to upload the
results. Click Next.
Note: You can right-click in the tree and use the commands on the context menu to create a new test
definition, child test definition, test folder, or child test folder to which the results can be saved.
6. On the subsequent screen you can specify Version and Build numbers for the assigned Product to which
the uploaded results belong. Also specify the SilkPerformer test result status, for example Passed, Failed.
Note: If any errors occured during the test run, the test result status is set to Failed by default.
7. Click Finish to upload the results.
The uploaded results are displayed in the Test Definition Runs column in Test Manager ➤ Test Plan ➤
Runs.
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SilkTest Classic Tests
This section describes how to execute test definitions in SilkTest Classic.

Automated Execution of SilkTest Classic Test Definitions
All test definitions within an execution definition use the same SilkTest Classic instance for tests. The SilkTest
Classic GUI is opened once with the first SilkTest Classic test definition execution and is closed automatically
after the last SilkTest Classic test definition execution. Each SilkTest Classic test definition execution produces
its own results. If for any reason the SilkTest Classic GUI closes during a test, it will reopen automatically with
the next SilkTest Classic test definition execution.

Automated Execution of Data-Driven SilkTest Classic Testcases
If the data driven check box is checked in SilkTest Classic test properties, each SilkTest Classic test will be
repeated once for each data row in the external datasource. By default, plan-based execution mode is used
for data driven tests. This means that the results of all data rows will be listed under a single node in the .res
result file. If execution mode is switched to script-based data driven in SccExecServerBootConf.xml, a
result node will be created in the .res result file for each data row.

Specifying Agent Under Test (AUT)
When a SilkTest Classic agent cannot run on the same machine as the Test Manager execution server, for
example when tests are run on platforms other than Windows, the hostname and port may be specified by the
SilkTest Classic AUT Hostname setting in the Deployment page of an execution definition. If the setting has
not been defined, SilkTest Classic default values are used, for example from partner.ini. The syntax for
AUT is hostname:port. The agent must be started manually prior to test execution and configured to listen
at the specified port. By default, the TCP/IP protocol is used for communication between SilkTest Classic
instances and SilkTest Classic agents. Ensure that both programs have been configured to use the same
protocol.
Note: Be careful when you have multiple execution servers assigned to an execution definition as SilkTest
Classic agents can only work with one SilkTest Classic instance at a time.

SilkTest Classic Time-out Settings
If you have SilkTest Classic test cases that require more than 1 hour to complete, you must adjust the time-out
settings in Test Manager. Otherwise, Test Manager assumes that something has gone wrong in the execution
and terminates SilkTest Classic. For details about setting the SilkTest Classic time-out, refer to the SilkCentral
Administration Module Help.

SilkTest Classic Logs
The RMS log file in SilkTest Classic is used to log data for each test case as test runs progress. Three types
of data records are written to this file: status, memory and user records. By monitoring this file, the RMS Remote
Agent has a means of determining the progress of each test run.
You can write your own comments into the user records of the log file by executing the PrintToRMSLog 4Test
function.
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Examples:
PrintToRMSLog ("Error", "An intended error")
PrintToRMSLog ("Info", "testcase sleep1 started")
PrintToRMSLog ("Warning", "TestCase 1 started a second time")
Definition of user function in rms.inc:
PrintToRMSLog (STRING sMessageType, STRING sUserMessage)
Writes to the log file in the following format:
U|{sTestCaseName}|{sScriptName}|{sArgStr}|{sUserMessage}|{sMessageType}

Activities
This section explains how to manage upcoming, current, and recently-executed test runs.

Deleting Last Executions Runs
To delete a run from the Last Executions list:
1. Navigate to Test Manager ➤ Activities.
2. In the Last Executions area of the Activities page, right-click the test run you want to delete and select
Delete Run Results.
3. Confirm the deletion by clicking OK.

Displaying or Hiding Columns on the Activities Page
To display or hide columns on the Activities page:
1. Navigate to Test Manager ➤ Activities.
2. Right-click a column header.
3. Expand the Columns submenus to view all the columns that are available in the project.
4. Select the checkboxes of all the columns that you want to have displayed.
Your column-display preferences will be saved and displayed each time you open the active project.

Entering Issues From the Activities Page
New issues can be entered directly on the Activities page.
To enter an issue from the Activities page:
1. Navigate to Test Manager ➤ Activities.
2. In the Last Executions area, click the Run ID of the relevant execution definition to view test-execution
results.
Each test definition associated with the execution run is listed in the Assigned Test Definitions table at
the bottom of the view.
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3. In the Actions column of the test definition to which you want to associate the issue, click Create a new
issue for this test definition.
4. Proceed with defining the issue.

Filtering Test Runs on the Activities Page
You can filter the views on the Activities page based on column values. You can specify filter strings to be
applied to:
•
•
•

Text-based data fields.
Calendar filters (using Before, After or On operators) for date-based fields.
Numerical operators (>, <, and =) for number-based fields.

Filtering Text-Based Values on the Activities Page
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the text-based column that the filter is to be based on.
3. Expand the Filter submenu on the context menu to display the Filter text box.
4. Enter a text string into the text box.
5. Press Enter.
All entries that match the filter criteria are dynamically displayed in the filtered list.

Filtering Date-Based Values on the Activities Page
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the date-based column that the filter is to be based on.
3. Hold your cursor over Filter on the context menu to display the Before, After, or On submenu.
4. Choose from the following:
a) Hold your cursor over After to define a date before which (and including) all entries should be excluded.
b) Hold your cursor over Before to define a date after which (and including) all entries should be excluded.
c) Hold your cursor over On to exclude all entries except those that have the specified date.
The calendar tool displays.
5. Select a date using the calendar tool (or click Today to specify today's date).
Tip: You must explicitly click a date on the calendar tool or press Enter to activate date-based filtering
changes.
All entries that match the filter criteria are dynamically displayed in the filtered list.

Filtering Number-Based Values on the Activities Page
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the number-based column that the filter is to be based on.
3. Expand the Filter submenu on the context menu to display the > (greater than), < (less than), and =
(equals) operators.
4. Choose from the following:
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a) Enter a number in the > text box to define a number less than which (and including) all entries should
be excluded.
b) Enter a number in the < text box to define a number greater than which (and including) all entries should
be excluded.
c) Enter a number in the = text box to exclude all entries except those that have the specified number.
Note: Number values are rounded to two decimal places.
5. Press Enter.
All entries that match the filter criteria are dynamically displayed in the filtered list.

Filtering Boolean Values on the Activities Page
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the boolean-based column that the filter is to be based on.
3. Expand the Filter submenu on the context menu to display the available values.
4. Click one of the Yes or No option buttons.
All entries that match the filter criteria are dynamically displayed in the filtered list.

Filtering Values Using a Predefined List on the Activities page
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the column that has a predefined filter value that the filter is to be based on.
3. Expand the Filter submenu on the context menu to display the Filter text box.
4. Check the check boxes of the filter values that you want to use.
All entries that have one of the selected criteria will be displayed.

Grouping Test Runs on the Activities Page
Beyond simply sorting by column, you can chunk entries into groups to facilitate viewing. Groups are based
on commonly-shared values within the column that grouping is based on.

Applying Groups to Test Runs on the Activities Page
To group entries on the Activities page:
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the column that the sort is to be based on.
3. Select Group by This Field.
Entries are then organized into groups based on commonly-shared values within the column you have
selected.

Removing Grouping from Test Runs on the Activities Page
To remove grouping:
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1. Navigate to Test Manager ➤ Activities.
2. Right-click any column.
3. Uncheck the Show in Groups check box.

Removing Activities Filters
Note: Hiding a column removes all filters that have been applied to the column.
To remove one or more filters:
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the column that has the filter you want to remove.
Note: You can identify filtered columns by their titles, which are displayed in bold, italic text.
3. Do one of the following:
a) To remove a specific filter: Uncheck the Filter check box.
b) To remove all filters: Select Reset Filters.

Reordering Columns on the Activities Page
To reorder columns on the Activities page:
1. Navigate to Test Manager ➤ Activities.
2. Select the column header of the column you want to move.
3. Drag the column to the desired position and release it.
Your column-order preferences will be saved and displayed each time you open the active project.

Resizing Columns on the Activities Page
To adjust the width of columns on the Activities page:
1. Navigate to Test Manager ➤ Activities.
2. Select the vertical column-header divider of the column you want to adjust.
3. Drag the column boundary to the desired position and release it.
Your column-width preferences will be saved and displayed each time you open the active project.

Restoring Default Activities Page View Settings
Restoring default view settings resets all user-defined settings, which are column order, column width,
shown/hidden columns, applied filters, sorting, and grouping, for the current project.
To restore default view settings:
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1. Navigate to Test Manager ➤ Activities.
2. Right-click any column header.
3. Select Reset View.

Sorting Test Runs on the Activities Page
To sort test runs on the Activities page:
1. Navigate to Test Manager ➤ Activities.
2. Right-click the header of the column you want the test runs to be sorted by.
3. Select Sort Ascending to have the test runs sorted in ascending order or select Sort Descending to have
the test runs sorted in descending order.
Your sort preferences will be saved and displayed each time you open the active project.

Activities Page
Test Manager ➤ Projects ➤ Activities
The Activities page offers a centralized location from which you can manage upcoming, current, and recently
executed test runs for a project. The grid views on the Activities page offer filtering, sorting, and grouping
options that are configurable for each user separately. You can display or hide columns, adjust the width of
columns, and move columns around using click and drag.
The Activities page is split into three sections: Next Executions, Current Executions, and Last Executions.
The grid views can be resized by dragging the separators between the views.
Context-sensitive menu commands are available for each test run. These commands enable you to link directly
to listed execution definitions, continue manual tests, manage test-run results, and more.
The Activities page makes it easier to identify match points between execution definitions and to find specific
execution-definition information. Standard Windows keyboard shortcuts can be used to select test run entries,
making it easy to select and manipulate specific sets of execution definitions and test results. Sorting, grouping,
and filtering functions are available through context-menu commands to help you better organize and group
test runs. All of your view-customization preferences are saved along with your project and will be available
to you each time you visit the Activities page.
Note: Data on the Activities page is not automatically refreshed. Click Reload near the paging buttons
at the bottom of each view to refresh the page's contents.
Note: You can use CTRL + SHIFT to select multiple queued executions and abort them all with one
click.
Next Executions
The Next Executions view lists the execution definitions that are scheduled to run in the future. To enhance
performance when you have numerous execution definitions, only the upcoming 50 execution definitions are
displayed. You can access additional future execution definitions by using the available filtering features. To
edit an execution definition, right-click the execution definition and choose Go to Execution Definition
or click on the name of the execution definition. This takes you to the Executions unit where you can view
and edit the details of the execution definition.
By default, all execution definitions are sorted by Start Time. Columns in the Next Executions view can not
be sorted or grouped.
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Next Executions view can be collapsed and expanded by clicking the double-arrow button on the right-hand
side of the view's title bar.
For each execution definition, the Next Executions view displays the following columns:
Column

Description

ID

Identifier of the scheduled execution definition. This column
is hidden by default.

Execution Definition/Folder

Name of the schedules execution definition or folder.

Keywords

Keywords that are assigned to the scheduled execution
definition.

Manual Testers

For manual tests, this column contains the user name of the
manual tester that is assigned to the test. This column is
blank when no manual testers are assigned to the test.

Priority

The priority that has been assigned to the execution
definition.

Start Time

Scheduled start time of the test run.

Execution Definition Parent

The configuration suite or folder in the context of which the
execution definition is executed. Click to access the suite or
folder in the execution tree. If the execution definition is not
included in a configuration suite or folder, nothing is
displayed.

Current Executions
The Current Executions view lists the execution definitions that are currently running (both automated and
manual test runs).
To abort an execution definition that is currently in progress, click Abort in the Actions column of the execution
definition. To view or edit an execution definition, right-click the execution definition and select Go to Execution
Definition or click on the name of the execution definition. To view the execution's progress, right-click the
automated execution definition and select View Details or click the execution definition's Run ID/Task ID link.
As long as a manual test remains open, the corresponding execution definition remains in the list of Current
Executions with a status of Pending. Right-click a manual test execution definition and select Continue
Manual Test, or click the execution definition's Continue Manual Test button in the Actions column, to
continue a manual test in the Manual Test Execution view.
To view the results of a manual test, right-click the manual execution definition and select View Details, or
click the execution definition's Run ID/Task ID link, to open the Results for Execution Definition page. From
there, click the name of the manual test definition in the Assigned Test Definitions section to open the Results
dialog box. Detailed results of the manual test definition are displayed there. Back on the Results for Execution
Definition page, click Manual Test Results to go to Manual Test Execution view, where read-only information
about the status of the assigned manual test definition is available.
Page views of current executions are broken into views of 20 execution definitions each. You can advance
through pages using First, Last, Next, and Previous located in the lower part of the Current Executions
view. Or you can type a page number into the Page text box and press Enter.
For each execution definition, the Current Executions view displays the following columns:
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Column

Description

Actions

You can perform the following actions on the execution
definition:
Abort

Click to cancel the current execution.
Alternatively, press Delete. When you
abort executions, these executions are
grayed out until the background process
completes the deletion.

Continue
Manual Test

Click to go to Manual Test view and
execute the test.

Manual
Click to open the Manual Testing Client.
Testing Client This button is available to users that are
assigned as testers to the selected test.
ID

Identifier of the execution definition. This column is hidden
by default.

Execution Definition

Name of the execution definition.

Run ID/Task ID

Manual test definitions receive a Run ID when they are
executed. When the manual test is completed, the Run ID
carries over to the Last Executions view. Automated test
definitions receive a Task ID when they are executed. The
Task ID is not carried over to the Last Executions view.
Completed execution definitions receive a Run ID in the
Last Executions view.

Status

Status of the active execution definition or manual test. For
automated tests, the status is indicated with a text-based
value, Pending or Active. For manual tests, the status
is indicated with a colored histogramm. Automated-test
statuses are described textually and can be filtered. Manual
tests can be filtered by checking relevant properties on the
Filter submenu.
•
•
•

Pending manual execution
Pending manual setup execution
Pending manual cleanup execution

Keywords

Keywords that are assigned to the execution definition.

Executed By

Only for manual tests. The users who are assigned to
perform the manual test. This column is blank when no
manual testers are assigned to the test.

Priority

Priority that has been assigned to the current execution
definition or manual test.
•
•
•

Low
Normal
High
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Column

Description

Start Time

Time when the execution definition run started.

Time Left

Amount of time remaining until the test is complete. For
manual tests that do not have an estimated time, this column
has a value of unknown.

Start Type

Shows how the test run was started. Manually, through a
Web Service, or from a schedule.

Starter Name

Name of the schedule, tester, or Web Service user.

Start Scope

The scope defined in the Run dialog box.

Execution Definition Parent

The configuration suite or folder in the context of which the
execution definition is executed. Click to access the suite or
folder in the execution tree. If the execution definition is not
included in a configuration suite or folder, nothing is
displayed.

Last Executions
The Last Executions view lists all past execution definition runs, except deleted runs, for which results were
collected from the execution server. You can filter the listed execution definition runs, for example by the start
time.
To view or edit an execution definition, right-click the execution definition and choose Go to Execution
Definition, or click on the name of the execution definition. To display the Results for Execution Definition
page of an execution definition run, right-click the run and select View Details, or click the Run ID link of the
execution definition. This page shows details for the selected execution definition run and includes any files
and messages, for example LiveLink VMware configuration captures, that were generated during the execution.
To open the Results dialog box of a test definition, click on the Run ID of the test definition in the Assigned
Test Definitions portion of the Results for Execution Definition page.
To compare two execution definition runs, use Ctrl + Shift to select the two runs. Right click on your
selection and click Reports ➤ Execution Definition Run Comparison ....
Right-click on an execution definition and click Run Execution Definition to run the execution definition. Test
Manager uses the configuration currently defined in the Execution unit for the re-run, not the original
configuration of the selected execution-definition run.
For execution definitions that are deployed to virtual servers: To open VMware Lab Manager and restore a
captured LiveLink configuration, expand the Messages link on an execution definition run's Results for
Execution Definition page and select LiveLink.
To delete a test run, right-click a run entry and choose Delete Results or click Delete in the Actions column
of the run.
Test-result page views are broken into views of 20 test results each. You can advance through pages using
First, Last, Next, and Previous at the bottom of the Last Executions view. Or you can enter a page number
into the Page text box and press Enter.
The Last Executions view can be collapsed/expanded by clicking the double-arrow button on the right-hand
side of the view's title bar.
For each execution definition, the Last Executions view displays the following columns:
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Column

Description

Actions

You can perform the following actions on the
execution definition:
Delete

Click to delete the test run results.
When you delete executions, these
executions are grayed out until the
background process completes the
deletion. Alternatively, press
Delete to delete test definitions.
For tagged builds, you have to verify
that you want to remove the results,
and when you have selected
multiple runs, results from tagged
builds are not removed.

View
Manual
Test
Results

Click to open the Current Run page
in read-only mode; or right-click a
manual execution definition run and
select View Manual Test Results.

ID

The identifier of the executed execution
definition. Unassigned test definitions have an
ID value of N/A. This column is hidden by
default.

Execution Definition

Name of the executed execution definition. Click
on the name to view or edit the execution
definition.

Run ID

ID assigned to the test run. Click the link to view
details of the test run.

Status

Result status of the test run. Passed,
Failed, or Not Executed. Filtering,
sorting, and grouping are not available for the
Status column in the Last Executions view.

Keywords

Keywords that were assigned to the execution
definition at execution time.

Executed By

Only for manual tests. The user that performed
the manual test. This column is blank when no
manual testers were assigned to the test.

Start Time

Time when the execution definition run started.

Duration

The duration of the test run.

Product

The product under test. This column is hidden
by default.

Version

The version of the product under test. This
column is hidden by default.

SilkCentral Test Manager 2010 R2

| 313

Column

Description

Build

The build number of the product under test. If
the build is tagged, it is marked bold and with
.

Start Type

Shows how the test run was started. Manually,
through a Web Service, or from a schedule.

Starter Name

Name of the schedule, tester, or Web Service
user.

Start Scope

The scope specified in the Run dialog box.

Execution Definition Parent

The configuration suite or folder in the context
of which the execution definition is executed.
Click to access the suite or folder in the
execution tree. If the execution definition is not
included in a configuration suite or folder,
nothing is displayed.

Code Analysis
The goal of conventional code coverage is to deliver information about what code is covered by tests. This
approach is typically used to gain code-coverage information for unit tests. The code-analysis functionality in
Test Manager goes well beyond this, delivering data for unit, functional, and load tests, both automated and
manual, in managed environments. Code coverage measurements are utilized to track test progress and guide
test planning. This innovative approach in Test Manager to code coverage draws on the relationship between
specific tests and the code they test. This approach enables you to perform impact/dependency analysis of
code changes from the testing perspective. It also assists you in optimizing your testing, by helping you identify
the test runs that are most relevant to a specific code change.
The Code Analysis unit offers code-coverage data for AUT (Applications Under Test), packages/namespaces,
classes, methods, and statements, enabling you to perform test-impact analysis, which determines the tests
that should be run in response to specific code changes, and effort analysis, which determines how many
hours of automated testing and manual testing are required to adequately cover specific code changes. Each
of these code-analysis tasks can be addressed by running pre-configured reports. The unit features a navigation
tree that lists all products that have been created for the selected project. You can drill down into products to
select specific versions, and at the deepest level, specific builds.

Enabling Code Analysis
You must configure Test Manager to gather code coverage data from an application under test. You can
configure any number of execution definitions listed in Test Manager ➤ Execution ➤ Deployment.

Java Code Analysis
Java Limitations and Prerequisites
The following sections display the known limitations and prerequisites that must be performed to enable java
code analysis with Test Manager.
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White Spaces Are Prohibited
Whitespaces cannot be ignored or added when modifying batch files or syntax. Otherwise, java.lang.error
messages will be encountered. For example: Please note that unnecessary whitespace within
the command line will result in an error on initiation as follows. Exception in
thread "main" java.lang.NoClassDefFoundError: ….. Directory not empty.
You Must Start the Application Under Test Before You StartTest Manager
The application under test must be started before code coverage execution is kicked off. The AUT must be
started independently of Test Manager so that code coverage can hook into it.
Java Prerequisites
To find out which classes and methods of an application under test (AUT) have been invoked within jar files,
you must locate the file sctmcc.dll in the directory from which the AUT is executed. You can download this
file directly from your Test Manager GUI by selecting Help ➤ Tools ➤ Java Code Analysis Agent. Code
analysis works with Java versions 1.4, 1.5, and 1.6. However, there is a difference in how the DLL can be
loaded when starting up the virtual machine (VM).
When starting up the application under test from the command line, the following arguments must be passed
to the VM in order to load sctmcc.dll:
Java 1.4

-Xrunsctmcc:port=19129,<options>

Java 1.5 and 1.6

-agentlib:sctmcc=<options>

Java Code Analysis Options
You can use the following options for all supported Java versions:
Option

Description

port=19129

Port of code coverage service.

coveragetype="line"

Possible values are line or method. To get
code coverage information with Test Manager,
you must use line.

coveragepath={"library1.jar";“library2.jar"} Jar-libraries to monitor for code coverage
information.
name="ServerName"

Name of the monitored application.

Java Code Analysis Examples
Java 1.5 and 1.6:
"<java_home_directory>\bin\java" -agentlib:sctmcc=port=19129,
coveragetype="line",
coveragepath={"C:\dev\deploy\lib\library1.jar";"C:\dev\deploy\lib\library2.jar"},
name="myAUTserver" com.caucho.server.http.HttpServer
Java 1.4:
C:\Java\j2sdk1.4.2_06\bin\java.exe -Xrunsctmcc:port=19129,
coveragetype="line",
coveragepath={"C:\Program
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Files\Silk\SilkTest\JavaEx\JFC\swingall.jar";
"C:\Program Files\Micro
Focus\SilkTest\JavaEx\JFC\Swing11TestApp.jar"},
name="Test Application" -Dsilktest.tafont=arialuni.ttf -cp
.;%FontDir% ta

.NET Code Analysis
.NET Code Analysis and Manual Testing
The following sections detail the required steps to install and use the DevPartner .NET code coverage
components shipped with Test Manager. The example below will get you started by using manual testing and
a single AUT. If you plan to use automated testing, first read and understand the steps below, and then see
the topic titled Structuring Your Tests with Code Analysis.
Note: In order to use the Test Manager/.NET code coverage functionality, the Test Manager - DevPartner
components must be used. The Test Manager-DevPartner components cannot be installed on machines
that have DevPartner 10.1 or below previously installed.
Note: .NET code analysis requires the PDB files generated at compile time of the .NET application under
test (AUT) to be located in the same directory as the AUT's executable(s). If the PDBs for the AUT are not
available, it is not possible to leverage the .NET code analysis functionality.
Installing the Windows Code Analysis Framework and DevPartner Analytics
1. Go to the machine that hosts the application to test.
2. Open Test Manager.
3. Go to Help ➤ Tools and click Windows Code Analysis Framework. This will prompt a download of
CAFramework.exe. CAFramework.exe includes the installation for the Code Analysis Framework
and the DevPartner Analytics package.
Note: Multiple execution servers running tests against the same Code Analysis Framework at the
same time is not supported.
4. Double click the download file to start the installation. Walk-through the installation of the Windows Code
Analysis Framework. At the end of the installation, you will be prompted to install DevPartner
Analytics. Ensure that the DevPartner Analytics Installation checkbox is checked on the appropriate
installation screen and install this component.
At the end of this installation, all required files are installed and the proper service is started. The name of
the service is SilkCentral Code Analysis Service.
Configuring DPAnalysis to launch Your AUT
1. Create a .BAT file that points to DPAnalysis.exe. An example would be:
"C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe" /cov
/USE_AUTOMATION_INTERFACE
/W "C:\Common\Development\MYAPP"
/P "C:\Common\Development\MYAPP\MyApp.exe"
2. For readability, the example above is on multiple lines. Your .BAT file should be on one line. Make the
following modifications:
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a. Ensure that the first line is your installation path to dpanalysis.exe. The two switches are mandatory.
b. The second line contains a mandatory switch and needs to include the path to your executable and
PDBs.
c. The third line contains a mandatory switch and needs to include the absolute path to your test application
and the application name.
3. Double-click the .BAT file to have DPAnalysis launch your application.
Note: For more information on running DPAnalysis.exe, see the topic titled Using DpAnalysis.exe.
That topic and related topics contain information on additional switches and how to use a configuration
file if you have multiple applications to test.
Configuring Test Manager
1. Open an existing execution definition in Test Manager that contains a manual test definition with steps to
test functionality for your AUT.
2. Click the Deployment tab.
3. Under Code Analysis Settings, click Edit to view the Edit Code Analysis Settings dialog box.
4. Ensure that Enable Code Analysis is checked.
5. Select DevPartner .NET Code Analysis from the Code Analysis Profile list.
6. For the Hostnames field, type in the host name followed by colon and the port number. For example:
localhost:19129
The default code analysis framework port is 19129. You can configure the code analysis framework to run
at a given port using the following xml file: <install dir>\Code Analysis\CodeAnalysisConfig.xml
7. Click OK.
8. Run the test by clicking Run in the Execution unit.
9. On the Run dialog box, ensure that All Test Definitions is checked.
10. In the Set build for execution definition, select the proper build for your execution definition.
11. Click OK.
Running Manual Tests
1.
2.
3.
4.
5.
6.

Start the Manual Testing Client.
Double click your manual test that appears in the Inbox of the Manual Testing Client.
On the Execute Test dialog box, click the Details tab.
Click Start situated next to the Code Analysis label.
On your AUT, perform your manual tests.
When you have finished, return to the Manual Testing Client and click Stop.
Do not use Resume or all previous testing coverage will be lost and only the analysis for the last
Resume-Stop will be reported.

7. In the Test Steps list, give each step a proper status.
8. Click Finish Run and then Close.
9. Click Upload on the Manual Testing Client.
10. Return to Test Manager and go to the Code Analysis unit.
11. Click the proper Product and Build nodes and then review your code coverage results.
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.NET Code Analysis and Automated Testing
This topic describes two scenarios that you may encounter when executing your tests that use code coverage.
It also provides proper ways to structure your test definitions within an execution definition.
The examples used in the following sections are specific to DevPartner Code Analysis, but the structure is
similar for other code analysis tools. For example, you will have different startup/cleanup parameters in your
execution definition.
Configuring One or More Test Definitions with One AUT
If you have the scenario where you have one or more test definitions in a single execution definition and they
test against a single application under test, you should structure your testing as follows:
•

Create a ProcessExecutor test definition that will start your code analysis application. The
ProcessExecutor Argument List should start your code analysis program. For example: start cmd
/c start cmd /c D:\sctm\dps\startDPS_Simple1.bat, where startDPS_Simple1.bat
contains:
"C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe" /cov
/USE_AUTOMATION_INTERFACE /O "D:\SCTM\temp"
/W "D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug"
/P
"D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe"

•
•
•
•
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Create an execution definition and add the previously created test definition as the Setup Test Definition.
Click the Execution unit, select an execution definition and click the Setup/Cleanup tab.
Add a test definition to the execution definition that automates your application under test with an automated
testing tool.
Optionally add another test definition to the execution definition that automates your application under test
with an automated testing tool.
Create a ProcessExecutor test definition and add it as the Cleanup Test Definition. Click the Execution
tab, select an execution definition and click the Setup/Cleanup tab. The ProcessExecutor Argument
List should close your program: start cmd /c taskkill /IM SCTMCodeAnalysisTestApp.exe.
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Configuring One or More Test Definitions with Multiple AUTs
If you have the scenario where you have one or more test definitions in a single execution definition and they
test against multiple AUTs, you should structure your testing as follows:
•

Create a ProcessExecutor test definition and add it as the Setup Test Definition. Click the Execution
unit, select an execution definition and click the Setup/Cleanup tab. The ProcessExecutor Argument
List should start your code analysis program. For example: start cmd /c start cmd /c
D:\sctm\dps\two_app_dps.cmd.
In the example above, two_app_dps.cmd would have "C:\Program Files\Micro
Focus\DevPartner\Analysis\dpanalysis.exe" /config
D:\SCTM\DPS\configuration_file.xml
Where configuration_file.xml contains:
<?xml version="1.0" ?>
<ProductConfiguration>
<RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true"
/>
<Targets RunInParallel="true">
<Process CollectData="true" Spawn="true" NoWaitForCompletion="true"
NM_USE_AUTOMATION_INTERFACE="1" >
<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1"
NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
<Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
<Arguments></Arguments>
<WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
</Process>
<Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1"
NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
<Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\
QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
<Arguments></Arguments>
<WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\
SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
</Process>
</Targets>
</ProductConfiguration>

•
•
•

Add a test definition to the execution definition. This test should automate your first application under test
with an automated testing tool.
Add another test definition to the execution definition. This test should automate your second application
under test with an automated testing tool.
Create a ProcessExecutor test definition and add it as the Cleanup Test Definition. Click the Execution
tab, select an execution definition and click the Setup/Cleanup tab. The ProcessExecutor Argument
List should close your programs: start cmd /c taskkill /IM application1.exe /IM
Application2.exe.
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Using DPAnalysis.exe
DPAnalysis.exe is the DevPartner code coverage application that allows you to profile .NET applications.
The application is started using the command line.
You can use the application with traditional switches as documented in these topics, or you can add an additional
switch that points to a configuration file. You may want to use a configuration file if you have an exceptionally
long command line string or you want to run multiple applications in a single session.
The /USE_AUTOMATION_INTERFACE switch is mandatory. It causes the automation interface environment
needed for the interaction with the framework to be established. It also causes license checking to be bypassed.
This switch does not take any parameters.
Running DPAnalysis.exe from the Command Line
The DevPartner Studio Code Coverage installation includes DPAnalysis.exe, a command line executable
that is installed in the \Program Files\Micro Focus\DevPartner Studio\Analysis\ directory.
Use the following syntax and switches to run the DevPartner Studio Code Coverage tool from the command
line:
DPAnalysis [/Cov] [/USE_AUTOMATION_INTERFACE] [/E|/D|/R]
[/W workingdirectory] [/PROJ_DIR] [/H hostmachine]
[/NOWAIT] [/NO_UI_MSG] [/N] [/F] [/A C:\temp1;C:\temp2]
[/NO_QUANTUM /NM_METHOD_GRANULARITY /EXCLUDE_SYSTEM_DLLS
/NM_ALLOW_INLINING /NO_OLEHOOKS /NM_TRACK_SYSTEM_OBJECTS]
{/P|/S} target [target arguments]
Example
You can use DPAnalysis.exe directly from the command line, using switches to direct the analysis session.
For example, the following command line launches a code coverage session for the application
SCTMCodeAnalysisTestApp.exe.
dpanalysis.exe /cov /USE_AUTOMATION_INTERFACE /W
"D:\SCTM\DPSCoverageIntegration\Test App\
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SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin\Debug" /P
"D:\SCTM\DPSCoverageIntegration\Test
App\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin
\Debug\SCTMCodeAnalysisTestApp.exe"

Switches
Analysis Type Switches
Name

Description

/Cov[erage]

Sets analysis type to DevPartner Coverage Analysis

Note: DPAnalysis.exe does not instrument unmanaged code. To collect performance or coverage
analysis data for an unmanaged application, you must first instrument the application.

Data Collection Switches
Syntax:
Enables or disables data collection for a given target, but does not launch the target. Optional.
Name

Description

/E[nable]

Enables data collection for the specified process or service.

/D[isable]

Disables data collection for the specified process or service.

/R[epeat]

Profiling will occur any time you run the specified process until you use the /D switch to disable
profiling.

Other Switches
Syntax:
These switches are optional.
Name

Description

/W[orkingDir]

Specify the working directory for the target process or service.

/PROJ_DIR

Specify directory of DevPartner Studio project, used to locate playlists, etc.

/N[ewconsole]

Run the process in its own command window. If you use DPAnalysis.exe to analyze a
console application that requires keyboard input, you must use the /NewConsole switch to
open a console window to accept the input.

/INCLUSION_FILTER
The /INCLUSION_FILTER switch is optional and allows an Inclusion Filter file to be
<filterFile>
specified. This file is used when the coverage data is provided to the framework in the
SCTM-specific XML format. It causes the report generation program to filter out all classes
that are not specified in the filter file. This switch takes a single parameter as shown here.

/INCLUSION_FILTER <filterFile>
where <filterFile> is the fully-qualified path of the filter file to be used for the duration
of the program.
The sample Inclusion_Filter file below is a simple XML file that contains the set of classes
to be included in the generated report. It also contains a value, <filterClasses>, which indicates
whether the filter is to be applied.

<?xml version="1.0" encoding="utf-8"?>
<!--D:\Public\SCTM Work\ProdAPI_Tester_CSharp_LINES.dpcov-->
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Name

Description

<inclusionInfo>
<filterClasses>false</filterClasses>
<includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_MsgStream</includedClass>
<includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_RecvTask</includedClass>
<includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_TimeStamp</includedClass>
<includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_Tracer</includedClass>
<includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CMsgRegisterClientReqMB</includedClass>
</inclusionInfo>
/A[ssembly_dir]

For coverage analysis only. A list of paths that contain referenced DLL/PDB files. Use this
switch to specify any referenced but not loaded DLL/PDB files to display in a coverage session
file. Separate multiple paths with a semicolon (;).

Analysis Options
Syntax:
Example of the analysis options is:
<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1"
NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
Column

Type

/NM_USE_AUTOMATION_INTERFACE

A required switch in the analysis options section of the coniguration
file. The value must equal "1".

/NO_QUANTUM

Disables excluding time spent on other threads.

/NM_ALLOW_INLINING

Enable run-time instrumentation of inline methods (Coverage and
Performance only).

/NO_OLEHOOKS

Disable collection of COM.

Target Switch
Syntax:
Identifies target to follow as either a process or service. Required. Pick only one. All arguments that follow the
target name or path will be arguments to the target.
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Name

Description

/P[rocess]

Specify a target process (followed by arguments to process)

/S[ervice]

Specify a target service (followed by arguments to service)

/C[onfig]

Path to configuration file
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DPAnalysis Configuration File
To manage analysis sessions with an XML configuration file, run DPAnalysis.exe from the command line
with the /config switch and a properly structured XML configuration file as its target. For example:
dpanalysis.exe /config c:\temp\configuration_file.xml
By using a configuration file, you can profile and manage multiple processes or services. The ability to profile
multiple processes can be especially useful for analyzing Web applications.
Sample Configuration File
<?xml version="1.0" ?>
<ProductConfiguration>
<RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true"
/>
<Targets RunInParallel="true">
<Process CollectData="true" Spawn="true" NoWaitForCompletion="true"
NM_USE_AUTOMATION_INTERFACE="1" >
<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1"
NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
<Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
<Arguments></Arguments>
<WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
</Process>
<Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1"
NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
<Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
<Arguments></Arguments>
<WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
</Process>
</Targets>
</ProductConfiguration>

AnalysisOptions Element
Attributes that work with AnalysisOptions vary depending on the type of analysis session you run.
Note: DPAnalysis.exe ignores attributes mismatched with the type of analysis.
<AnalysisOptions
SESSION_DIR = "c:\MyDir"
SESSION_FILENAME = "myfile.dpcov"
NM_METHOD_GRANULARITY = "1"
EXCLUDE_SYSTEM_DLLS = "1"
NM_ALLOW_INLINING = "1"
NO_OLEHOOKS = "1"
NM_TRACK_SYSTEM_OBJECTS = "1"
NO_QUANTUM="1"
NO_MACH5 = "1"
FORCE_PROFILING = "1"
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ASSEMBLY_DIR = "C:\TEMP1;C:\TEMP2"
/>
SESSION_DIR
Optional. Use with Coverage, Memory, Performance, and Performance Expert. Specify a directory for saving
the session file generated by the profiled target. Without this attribute, the resulting session file will be placed
in the user's My Documents directory. If both SESSION_DIR and SESSION_FILENAME are absent,
DPAnalysis.exe prompts you for the save location at the end of the session.
SESSION_FILENAME
Optional. Use with Coverage, Memory, Performance, and Performance Expert. Specify a session name for
the session file generated for this target. Without this attribute, DPAnalysis.exe creates a unique name by
combining the target's image name with a number (for example, iexplore1.dpprf). If you specify a name
but no directory, the file will be placed in user's My Documents directory. If both SESSION_FILENAME and
SESSION_DIR are absent, DPAnalysis.exe prompts you for the save location at the end of the session.
NM_METHOD_GRANULARITY
Optional. Use with Performance to set data collection granularity to method-level (line-level is default). Specify
a value of 1 to set the attribute. Omitting the attribute disables it.
EXCLUDE_SYSTEM_DLLS
Optional. Use with Performance to exclude system images. Specify a value of 1 to set the attribute. Omitting
the attribute disables it.
NM_ALLOW_INLINING
Optional. Use with Coverage and Performance to specify level of analysis detail. Enables run-time
instrumentation of inline methods. Equivalent to the Instrument Inline Functions property. Specify a value
of 1 to instrument inline functions. Omit the attribute to disable it.
NO_OLEHOOKS
Optional. Use with Performance analysis to activate tracking of system objects. Specify a value of 1 to set the
attribute. Omitting the attribute disables it.
NM_TRACK_SYSTEM_OBJECTS
Optional. Use with Memory analysis to ignore system or third-party object allocations when tracking allocated
objects. Specify a value of 1 to set the attribute. Omitting the attribute disables it. The default state (disabled)
enables you to see memory allocations made when your application uses system or other non-profiled resources.
NO_QUANTUM
Optional. Use with Performance and Performance Expert analysis to exclude time spent in threads of other
running applications. Specify a value of 1 to set the attribute. Omitting the attribute disables it.
FORCE_PROFILING
Optional. Use with Performance and Coverage analysis to force profiling of applications written without managed
code or DevPartner Native C/C++ Instrumentation. Specify a value of 1 to set the attribute. Omitting the attribute
disables it.
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ASSEMBLY_DIR
Optional. Use with coverage analysis to specify the absolute path(s) containing referenced but not loaded
assemblies to be shown in the Coverage session file. Separate multiple locations with a semicolon. Omitting
the attribute disables it.
Element Information
Number of Occurrences

0 or 1 per Process or Service.

Parent Elements

Process, Service

Contents

None

Remarks
Optional. Defines run time attributes for the specified target process or service. Attributes correspond to
DevPartner Coverage, Memory, and Performance properties accessible from the Properties Window in Visual
Studio.
Example
The following example shows a construction using AnalysisOptions within a Service.
<Service CollectData="true">
<AnalysisOptions NM_METHOD_GRANULARITY="1" EXCLUDE_SYSTEM_DLLS="1"
NM_ALLOW_INLINING="1"
NO_OLEHOOKS="1" ASSEMBLY_DIR="C:\TEMP">
</Service>

Arguments Element
Syntax
<Arguments>/arg1 /arg2 /arg3</Arguments>
Attributes
None
Element Information
Number of Occurrences

0 or 1 per Process or Service.

Parent Elements

Process, Service

Contents

None

Remarks
Optional. No default if omitted. Arguments to be passed to the target process or service.
Example
The following example uses Arguments within a Process element.
<Process CollectData="true">
<Arguments>/arg1 /agr2 /arg3</Arguments>
</Process>
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ExcludeImages Element
Syntax
<ExcludeImages>
<Image>ClassLibrary1.dll</Image>
<Image>ClassLibrary2.dll</Image>
</ExcludeImages>
Attribues
None.
Element Information
Number of Occurrences

0 or 1 per Process or Service.

Parent Elements

Process, Service

Contents

Image

Remarks
Optional. No default if omitted. Provide a list of at least one image (no maximum) which, if loaded by the target
process or service, will not be profiled.
Example
The following example shows a construction using ExcludeImages within a Process element. Note the Image
elements contained within ExcludeImages.
<Process CollectData="true">
<ExcludeImages>
<Image>ClassLibrary1.dll</Image>
<Image>ClassLibrary2.dll</Image>
</ExcludeImages>
</Process>

Host Element
Syntax
<Host>hostmachine</Host>
Attributes
None.
Element Information
Number of Occurrences

0 or 1 per Process or Service.

Parent Elements

Process, Service.

Contents

Name of the host machine.

Remarks
Optional. No default if omitted. Sets the host machine of the target process or service.
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Example
The following example shows a construction using Host within a Service. Note that the example includes
the required Name element.
<Service CollectData="true">
<Name>ServiceApp</Name>
<Host>remotemachine</Host>
</Service>

Name Element
Syntax
<Name>MyServiceName</Name>
Attributes
None.
Element Information
Number of Occurrences

1.

Parent Elements

Service.

Contents

Service name.

Remarks
Required. The name of the service as registered with the service control manager. This is the same name you
would use for the system's NET START command.
Example
The following example shows a construction using Name within a Service.
<Service CollectData="true">
<Name>ServiceApp</Name>
</Service>

Path Element
Syntax
<Path> c:\MyDir\target.exe </Path>
Attributes
None.
Element Information
Number of Occurrences

1.

Parent Elements

Process.

Contents

Path to the executable.
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Remarks
Required. Specify a fully qualified or relative path to the executable. You can specify the executable name
without the path if the executable exists in the current directory.
Example
The following example shows a construction using Path within a Process element.
<Process CollectData="true">
<Path>ClientApp.exe</Path>
</Process>

Process Element
Syntax
<Process CollectData="true or false"
Spawn="true or false"
NoWaitForCompletion="true or false"
NewConsole="true or false"
RepeatInjection="true or false"> ...
</Process>
Attributes
Profiling will occur any time you run the specified process until you use the /D switch to disable profiling.
CollectData

Optional. Specify true or false. Defaults to true if omitted. Specifies whether profiling
will be enabled for the target process.

Spawn

Optional. Specify true or false. Defaults to true if omitted. Specifies if
DPAnalysis.exe will spawn the specified target. Do not set to true for
aspnet_wp.exe or w3wp.exe. DevPartner cannot spawn the ASP.NET worker
process directly. Launch the ASP.NET worker process by opening the target Web
page.

NoWaitForCompletion Optional. Specify true or false. Defaults to false if omitted. The default is to wait
until the process has completed. If set to true, causes DPAnalysis.exe to wait
only until the target has started executing. DPAnalysis.exe will not wait for
processes on remote machines (using the Host element). The
MaximumSessionDuration attribute in the RuntimeAnalysis element overrides
NoWaitForCompletion.
NewConsole

RepeatInjection

Optional. Specify true or false. Defaults to false if omitted. Causes
DPAnalysis.exe to run the target in its own console window. The default is to use
the same console that you typed the DPAnalysis.exe command line in. If you use
DPAnalysis.exe to analyze a console application that requires keyboard input,
you must use the /NewConsole switch to open a console window to accept the
input.
Optional. Specify true or false. Defaults to false if omitted. Causes
DPAnalysis.exe to profile the target in every time it runs until you explicitly specify
false.

Element Information
Number of Occurrences
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1 or more.

Parent Elements

Target.

Contents

AnalysisOptions, Path, Arguments, WorkingDirectory,
ExcludeImages.

Remarks
Specifies a target executable.
Example
The following example shows a construction using Process and includes AnalysisOptions, Path, Arguments,
and WorkingDirectory tags.
<Targets RunInParallel="true">
<Process CollectData="true" Spawn="true" NoWaitForCompletion="true"
NewConsole="true">
<AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir"
/>
<Path>ClientApp.exe</Path>
<Arguments>/arg1 /agr2 /arg3</Arguments>
<WorkingDirectory>c:\temp</WorkingDirectory>
</Process>
</Targets>

RuntimeAnalysis Element
Syntax
<RuntimeAnalysis Type="Coverage" NoUIMsg="false"
NM_INCLUSION_FILTER="Q:\AppDir\InclusionFilter.xml">
Attributes
Type
MaximumSessionDuration

NoUIMsg

NM_INCLUSION_FILTER

Required: Possible choices are: Performance; Coverage; Memory; or Expert.
Specifies the analysis types for all targets listed.
Optional: If omitted, no default used. If specified, DPAnalysis.exe will limit a
session run for this amount of time. For example, if you specify
MaximiumSessionDuration="60" and then begin profiling a service (with
RestartAtEndOfRun="true" for the service), after 60 seconds,
DPAnalysis.exe will stop the service and then restart the service.
Optional: If omitted, false is used by default. If set to true DPAnalysis.exe
suppresses all UI error messages that may appear during the duration of the
session. Setting this to true is useful when sessions are run unattended or
when running a large number of consecutive tests.
Optional: Allows an Inclusion Filter file to be specified. This file is used when the
coverage data is provided to the framework in the SCTM-specific XML format.
It causes the report generation program to filter out all classes that are not
specified in the filter file. This switch takes a single parameter.
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Element Information
Number of Occurrences

1.

Parent Elements

ProductConfiguration.

Contents

None.

Remarks
Required. Defines the type of analysis and maximum session time.
Example
The following example shows a construction using RuntimeAnalysis following a ProductConfiguration tag. In
this example, the Type attribute specifies a performance analysis with a maximum duration of 1000 seconds
and suppression of UI error messages.
<?xml version="1.0" ?>
<ProductConfiguration xmlns="http://www.microfocus.com/products">
<RuntimeAnalysis Type="Performance" MaximumSessionDuration="1000" NoUIMsg="true"/>

Service Element
Syntax
<Service
CollectData = "true or false"
Start = "true or false"
RestartIfRunning = "true or false"
RestartAtEndOfRun = "true or false"
RepeatInjection = "true or false"
>
...
</Service>
Attributes
CollectData
Start

RestartIfRunning

Optional. Specify true or false. Defaults to true if omitted. Specifies whether
profiling will be enabled for the target service.
Optional. Specify true or false. Defaults to true if omitted. Specifies if
DPAnalysis.exe will start the specified target. If set to false, profiling will be
enabled for this target but it will not be started; profiling will begin the next time the
service is started (by whatever means).
Optional. Specify true or false. Defaults to false if omitted. When you set
RestartIfRunning to true, DPAnalysis.exe will attempt to restart the specified
service if it is running on the host computer.

RestartAtEndOfRun Optional. Specify true or false. Defaults to false if omitted. When you specify
true, DPAnalysis.exe will attempt to restart the service (generating a session
file) at the end of the run. If the service is the only process to be profiled, set this
attribute to false.
RepeatInjection
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Optional. Specify true or false. Defaults to false if omitted. Causes
DPAnalysis.exe to profile the target in every time it runs until you explicitly specify
false.

Element Information
Number of Occurrences

The configuration file must contain at least 1 Process or 1 Service
element.

Parent Elements

Targets.

Contents

AnalysisOptions, Path, Arguments, Working Directory, ExcludeImages,
Name, Host.

Remarks
Specifies a target service.
Example
The following example shows a construction using Service within a Targets element.
<Targets RunInParallel="true">
<Service CollectData="true" Start="true" RestartIfRunning="true"
RestartAtEndOfRun="true">
<Name>ServiceApp</Name>
</Service>
</Targets>

Targets Element
Syntax
<Targets RunInParallel="true or false">
</Targets>

...

Attributes
RunInParallel

Optional. Specify true or false. Defaults to true if omitted. If you specify more than one
target, defines how the targets are run. When RunInParallel is true, DPAnalysis starts
the target processes and services one right after the other; multiple targets will run at the
same time (parallel). Otherwise, DPAnalysis starts target N + 1 only after process N has
launched and exited; targets run one at a time (serial).

Element Information
Number of Occurrences

1.

Parent Elements

RuntimeAnalysis.

Contents

Process, Service.

Remarks
Required. Begins a block of one or more <Process> or <Service> entries. Target processes and services
are started in the order they are listed in the configuration file.
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Example
The following example shows a construction using Targets to specify analysis of one <Service> and two
<Process> elements. Note that RunInParallel is true so that, for this example, the targets would run in parallel.
<Targets RunInParallel="true">
<Service CollectData="true" Start="true">
<AnalysisOptions NM_METHOD_GRANULARITY="0" EXCLUDE_SYSTEM_DLLS="1" />
<Name>ServiceApp</Name>
<Host>remotemachine</Host>
</Service>
<Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
<AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir"
/>
<Path>ClientApp.exe</Path>
<WorkingDirectory>c:\temp</WorkingDirectory>
</Process>
<Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
<AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir"
/>
<Path>TestApp02.exe</Path>
<WorkingDirectory>c:\temp</WorkingDirectory>
</Process>
</Targets>

WorkingDirectory Element
Syntax
<WorkingDirectory> c:\MyWorkingDir </WorkingDirectory>
Attributes
None.
Element Information
Number of Occurrences

1 per Process or Service.

Parent Elements

Process, Service.

Contents

Path to the target directory.

Remarks
Optional. No default if omitted. Set the working directory of the target process or service.
Example
The following example shows a construction using WorkingDirectory nested within a parent Process element.
<Process CollectData="true">
<WorkingDirectory>c:\temp</WorkingDirectory>
</Process>

Enabling Code Analysis for Execution Definitions
To enable code analysis for an execution definition:
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1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. In the Execution tree, select an execution definition.
4. Click the Deployment tab.
5. In the Code Analysis Settings section of the Deployment page, click Edit.
The Edit Code Analysis Settings dialog box displays.
6. Check the Enable code analysis check box.
7. Select a profile from the Code Analysis Profile list box.
8. In the Hostnames text box, enter a comma-separated list of hostnames, with port, if default port 19129 is
not used, from which code analysis information is to be gathered.
For example labmachine1, labmachine2:8000, 198.68.0.1. For each execution definition, you
need to define the host names of the machine resources where the AUT is running. For example, with a
client/server system, you must not only gather code coverage information on the client, which probably
runs directly on an execution server, but also on the server, which likely runs on a different machine. This
applies to all multi-tiered applications.
Note: For JUnit code analysis runs, you do not need to specify a hostname.
9. Click OK to save your settings.
Note: Once code analysis has been defined for an execution definition, each future run of that execution
definition will gather code coverage information from the defined hostnames. While monitoring an execution
on the Activities page, you will see that after gathering the sources for test definitions, Test Manager
gathers full code coverage information before beginning test runs. The Code Coverage Controller, which
is integrated into each Test Manager execution server, controls all defined hosts during execution runs.
For each test definition of an execution definition, the controller starts and stops all associated instances,
collects XML-based code coverage files for the test definition, and merges the results into a single file.
The test definition then saves the merged code coverage file to its execution results.

Code Analysis Details Page
Test Manager ➤ Code Analysis ➤ Details
The Details page displays code-coverage information for selected products, versions, and builds at the product,
package, and class levels.
Product level view displays a list of covered and not-covered packages for specific products and product
builds. By clicking a package name in Product view you can drill down to view code-coverage information for
the classes that are included in that package.
Product view displays the following attributes for a selected product:
Attribute

Description

Name

Product name

Statements

Total amount of statements
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Attribute

Description

Packages/Namespaces

Histogram bar view that includes the following figures:
•
•
•

Classes

Histogram bar view that includes the following figures:
•
•
•

Methods

Total percentage of packages/namespaces that are
covered
Number of covered packages/namespaces, in green
Number of uncovered packages/namespaces, in red

Total percentage of classes that are covered
Number of covered classes, in green
Number of uncovered classes, in red

Histogram bar view that includes the following figures:
•
•
•

Total percentage of methods that are covered
Number of covered methods, in green
Number of uncovered methods, in red

Package level view displays a list of covered and not-covered classes for specific products and product builds.
By clicking a class name in Package view you can drill down to view code-coverage information for the methods
that are included in that class.
Package view displays the following attributes for each package in the selected product, across multiple rows:
Attribute

Description

Package

Package name

Statements

Total statements

Classes

Histogram bar view that includes the following figures:
•
•
•

Methods

Total percentage of classes that are covered
Number of covered classes, in green
Number of uncovered classes, in red

Histogram bar view that includes the following figures:
•
•
•

Total percentage of methods that are covered
Number of covered methods, in green
Number of uncovered methods, in red

Class level view displays a list of covered and not-covered methods for specific products and product builds.
Class view displays the following attributes for each method, across multiple rows:
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Attribute

Description

Name

Method name

Signature

Method signature

Statements

Total statements
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Attribute

Description

Covered

Covered status of method:
•
•

True indicates that the method is covered
False indicates that the method is not covered

Note: When the page includes more elements than can be displayed at once without impacting response
time, elements are displayed in increments. Page number links at the bottom of the page allow you to
browse through the elements included on the page one page at a time. To display all elements as a single
list, click the [All] link.

Latest Builds and Build Versions
When you select a product in the navigation tree, the list of packages and classes with coverage information
for the latest covered version, which implies the latest covered build for the version, is displayed automatically.
When you select a product version in the navigation tree, coverage information for the latest covered build of
the version is displayed automatically.
Note: If you are running multiple applications against the same build, the coverage from all of the
applications will be merged together.
Note: Code analysis across a range of builds is not supported by Test Manager currently.

Results Compilation
Once an execution definition’s test executions are complete, you can view its results. You will notice that there
is a new result file for the execution definition called FullCoverageInfo.xml and an additional
CodeCoverageInfo.xml file for each test definition result. Test Manager uses these result files to aggregate
and calculate all code analysis data.
Note: Aggregated data is not immediately available and calculations may take time to compile.

Code Analysis and the Manual Testing Client
The Manual Testing Client supports running test executions with code analysis information. If a test execution
has already been enabled to gather code analysis information within Test Manager, the settings are automatically
available in the Manual Testing Client. If you want to enable code analysis for an execution definition from
within the Manual Testing Client though, see Enabling Code Analysis with the Manual Testing Client.

Enabling Code Analysis Within the Manual Testing Client
To enable code analysis for an execution definition from within the Manual Testing Client:
1. In the Manual Testing Client, navigate to Edit ➤ Edit Code Analysis Settings.
The Edit Code Analysis Settings dialog box opens.
2. Check the Enable code analysis for package <Package Name> check box.
Note: After code analysis is enabled, you can execute your test definitions in the Manual Testing
Client. However, you need to click Code Analysis: Start on the Details page of the Execute Test
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dialog box before you actually start testing. This way Test Manager will collect code analysis information
while you execute the manual test. When you are done testing, click Stop to halt the collection of code
analysis information.
3. Select a profile from the Code Analysis Profile list box.
4. In the Hostnames text box, enter a comma-separated list of hostnames, with port, if default port 19129 is
not used, from which code analysis information is to be gathered.
For example labmachine1, labmachine2:8000, 198.68.0.1. For each execution definition, you
need to define the host names of the machine resources where the AUT is running. For example, with a
client/server system, you must not only gather code coverage information on the client, which probably
runs directly on an execution server, but also on the server, which likely runs on a different machine. This
applies to all multi-tiered applications.
Note: For JUnit code analysis runs, you do not need to specify a hostname.
5. Click OK to save your settings.

Generating Code-Change Impact Reports
To generate a code-change impact report:
1. Navigate to Test Manager ➤ Projects.
2. Select the project for which you want to analyze code-coverage data.
3. Navigate to Test Manager ➤ Code Analysis.
4. Click Create Code Change Impact Report on the toolbar.
The Select Classes for Report dialog box displays.
5. Select a Product and Version, if you want to change the pre-selected values.
Click Add to add the class file(s) to the Selected classes pick list.
You can remove classes in the Selected classes pick list by selecting entries and clicking Remove. Click
Remove All to remove all selected classes from the Selected classes pick list.
6. In the Filter text box, type criteria to filter the packages/namespaces.
For example, entering the string “published” will only list packages/namespaces that contain the string
“published” in their names.
7. Select a package from the Packages/Namespaces list box.
Use CTRL + CLICK to select multiple packages/Namespaces.
The classes that are available in the selected package/namespace are displayed in the Classes list box.
8. In the Classes list box, select a class that you want to have included as a source in your report.
Use CTRL + CLICK to select multiple classes.
9. Click Add.
The selected classes are added to the Selected classes list box.
10. Repeat the preceding steps to add the class files to the Selected classes list box until you have added all
required classes to the Selected classes list.
11. Select a report from the Select report list box.
12. Click OK to generate the report.
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Select Classes for Report Dialog Box
Test Manager ➤ Code Analysis ➤ Create Code Change Impact Report
The Select Classes for Report dialog box enables you to select class files to be included as sources in a
Code-Change Impact Report. The dialog box includes the following elements:
Element

Description

Product

Name of the product for which code analysis information is
required.

Version

Version of the product for which code analysis information
is required.

Filter

Enter criteria for filtering the packages. For example, if you
type the string published, the Code-Change Impact
Report displays only packages that contain the string
“published” in their names.

Packages/Namespaces

Product packages/namespaces that are specified for
coverage in the selected version.

Classes

All classes included in the selected package.

Add

Click to add the selected classes for code-coverage analysis.

Selected Classes

Displays the classes that are already selected for
code-coverage analysis.

Remove

Click to remove the selected class from the Selected
Classes list box.

Remove All

Click to remove all classes from the Selected Classes list
box.

Select Report

Type of the Code-Change Impact Report.

Viewing Code-Coverage Information for
Packages/Namespaces
To view code-coverage information for a package/namespace:
1. Navigate to Test Manager ➤ Projects.
2. Select the project for which you want to view code-coverage information.
3. Navigate to Test Manager ➤ Code Analysis.
4. In the Code Analysis tree, expand the project node in the navigation tree to display the products that are
available for the selected project.
5. Expand a product node to display the versions that are available for that product.
6. Expand a version node to display the builds that are available for that version.
7. Select a specific build.
Code coverage information for the selected build displays on the Details page.
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Note: To view code-analysis information for all products click Show all products on the toolbar. Products
of other projects are then listed under the Other Projects node.

Video Capturing
You can enable video capturing for a test plan element or an execution definition. The videos are added as a
WMV video file to the result files in the Files page of the Test Definition Run Results dialog box. You can
then analyze the videos, for example if errors have occured during tests.
The Video Recording setting in the Deployment page of an execution definition can override the setting for
a specific test plan element, which is included in the execution definition.
Note: Video capturing is currently enabled only for execution servers with Microsoft Windows as their
operating system. To use video capturing on a Windows 2008 execution server, you need to install the
following server features:
•
•

Desktop Experience
Quality Windows Audio Video Experience

Attention: The process of capturing videos is very CPU-intensive. Use this functionality only when needed.
To use this functionality you require a system with sufficient CPU power, for example a system with multiple
CPUs.
Capturing a video for each individual test case in a suite is supported out of the box for JUnit 4 tests and
SilkTest Classic Plan tests. To use this feature for other test types, use the methods in the
TestCaseStartFinishSocketClient interface. For additional information, see Indicating Start and Finish
for Video Capturing.

Enabling Video Capturing for a Test Definition
To enable video capturing for a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a container, folder, or test definition.
4. Click the Parameters tab.
5. Click Add Custom Parameter.
The Set Custom Parameter dialog box opens.
6. In the Name text box, type recordVideo.
7. From the Type list box, select String.
8. In the Value text box, type one of the following:
•
•
•
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always, if you want to add a video to the result files on every execution of the execution definition.
onError, if you want to add a video to the result files when an error occurs during the execution of the
execution definition.
Any other string or nothing, if you do not want to add a video to the result files.
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Issues
Describes how to work with issues in Test Manager.

Creating New Issues
The Issues page enables you to easily enter issues related to the selected test definition.
To create a new issue:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3.
4.
5.
6.

Select the test definition for which you want to create a new issue.
Click the Issues tab.
Click New Issue to open the New Issue dialog box.
Select the Profile of the issue-tracking system you are submitting the issue to.
The Profile list box shows the always available internal issue-tracking profiles and any external issue-tracking
profiles that you may have created. Select Internal to save the issue only to the Test Manager database.
Select an external profile to have the new issue saved to both the external tool and Test Manager.
Note: The profile you select here becomes the default selection for when you enter new issues in the
future. When adding a new issue to an external tracking system, you will be prompted to provide login
credentials for the external system. The credentials that you provide will be automatically preselected
for you in the future. If you do not provide credentials, the default credentials stored in the profile will
be used.

7. Enter a brief Synopsis of the issue.
8. Enter a meaningful Description of the issue.
9. Specify the Status of the issue.
•
•
•
•
•

Open
Fixed
Verified
Deferred
Closed

When using an external profile, status is set by the external tool.
10. Specify the ExternID of the corresponding issue in the external issue-tracking profile.
Note: The ExternID is the corresponding issue ID in the external tool. This option is disabled when
you have specified an external issue-tracking profile because the external tool sets this value. When
the Internal profile is selected, this value can be set manually.
11. Specify the ExternLink of the issue-tracking profile.
Note: The ExternLink is the HTTP link to the issue in the external tool. This option is disabled when
you have specified an external issue-tracking profile because the external tool sets this value, when
the tool offers direct HTTP links to issues, as is the case with Issue Manager. When a link is specified,
the ExternID is shown as a link in the issue list. Depending on the issue-tracking profile you are working
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with, the New Issue dialog box may include other tracking fields that are specific to the external
issue-tracking tool.
12. Click Save to save the new issue.
Note: Issue Manager determines the ID numbers of newly created issues.

Viewing Issue Statistics in Document View
To view issue statistics in Document View:
1. Navigate to Test Manager ➤ Issues.
2.
Click
on the toolbar.
3. In the Issues tree, select the project, issue-tracking system, or product for which you want to view statistics.

Issues Document View
Test Manager ➤ Issues ➤
The Document View displays issue statistics for the selected project in tabular format.
Column

Description

Date

Date and time when issue details were updated.

Open

Number of issues in the selected project, database, or
product that have a status of Open.

Fixed

Number of issues in the selected project, database, or
product that have a status of Fixed.

Verified

Number of issues in the selected project, database, or
product that have a status of Verified.

Closed

Number of issues in the selected project, database, or
product that have a status of Closed.

Deferred

Number of issues in the selected project, database, or
product that have a status of Deferred.

Viewing Issue Statistics in Details View
To view issue statistics in Details View:
1. Navigate to Test Manager ➤ Issues.
2.
Click
on the toolbar.
3. In the Issues tree, select the project, issue-tracking system, or product for which you want to view statistics.
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4. The calendar tool feature enables you to specify the time period over which you want to view issue statistics.
Click the time-frame dates link to expand the calendar.
For additional information, see Specifying a Calendar Range.
5. Using the calendar’s From and To list boxes, specify start and end times for issue statistics.
6. Click Update to update the chart view based on the specified time range.

Issues Page
Test Manager ➤ Issues ➤

➤ Issues

The Issues page lists issues from both internal and external databases that are configured for the selected
project. The page includes the following items:
Item

Description

Calendar Tool

Allows you to specify a time-frame for which issues should
be reported.Click the time-frame date link to expand the
calendar tool. For additional information, see Specifying a
Calendar Range.

Update

Updates the Issues View based on calendar changes. The
button is displayed only when changes exist.

Assigning External Issues
The Issues page enables you to assign issues from externally configured issue tracking systems to a selected
test definition.
To assign an existing external issue to a test definition:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3.
4.
5.
6.
7.

Select the node of the test definition for which you want to assign an external issue.
Click the Issues tab.
Click Assign External Issue to open the Assign External Issue dialog box.
Select the profile of the pre-configured, external issue-tracking system where the issue is tracked.
In the External ID text box, type the unique alpha-numeric ID of an existing issue in the external
issue-tracking system.
8. Click OK.
Note: You can also assign an existing external issue to a currently running execution definition in the
Current Run page, the Execution Runs page, and the Test Plan Runs page.

Synchronizing Internal and External Issue States
To synchronize issue states between Test Manager and an external issue tracking-system:
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1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the node of the test definition for which you are updating a corresponding external issue.
4. Click the Issues tab.
5. Click Update states of external Issues to synchronize the state of the issues listed in Test Manager with
the corresponding issues in the external tool.

Deleting Issues
To delete an issue from the issue-tracking system:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition from which you want to delete an issue.
4. Click the Issues tab.
5.
In the Actions column of the issue that you want to delete, click
6. Click Yes on the Delete Issue dialog box to confirm the deletion.
7. External issues are not effected when internal issues are deleted.

.

Specifying a Calendar Range
To view issues within a specific calendar time frame:
1. Navigate to Test Manager ➤ Issues.
2. Select an issue in the menu tree.
3.
Click
on the toolbar.
4.
Click
in the top-left corner of the tab view to open the calendar.
5.
Specify the From and To date/time for which you want to view issues by clicking the respective
.
6. Click Update to refresh the page with the issue listings that are included within the specified time frame.

Calendar Tool
The calendar tool provides the following features:
,

These buttons move the time frame forward or backward in
time at an interval roughly equivalent to the current
timeframe. For example, if the current timeframe
encompasses about 1 week, clicking
timeframe into the future one week.

will advance the

Increases the timeframe by 50 percent so that more test
executions are included in the list.
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Decreases the timeframe by 50 percent so that fewer test
executions are included in the list.
day

Moves the selected timeframe backward or forward one day.

week

Moves the selected timeframe backward or forward one
week.

month

Moves the selected timeframe backward or forward one
month.

quarter

Moves the selected timeframe backward or forward one
quarter.

Last 7 days

Sets the past 7 days as the selected timeframe.

Last 31 days

Sets the past 31 days as the selected timeframe.

Integrations
SCTM integrates with many different tools for many different purposes. The following topics detail integration
details for all SCTM integrations.

Code Analysis Tools Integration
DevPartner Code Coverage Integration
Test Manager integrates with the Code Analysis component of DevPartner Studio. You can perform code
analysis on .NET applications using this integration.
For more information, see the sections on code analysis for .NET.

Issue Tracking Profile Integrations
Atlassian JIRA
This section describes how to configure Atlassian JIRA (JIRA) issue tracking profiles to integrate with Test
Manager.
The JIRA plug-in relies on the SilkCentral Java API for integration. Test Manager communicates with JIRA
through the JIRA Web-service by using the Apache Axis library.
Note: See the sources of the package com.borland.sctm.issuetracking.jira to see how these
elements fit together.
For a list of the JIRA versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding Atlassian JIRA Issue Tracking Profiles
To integrate Test Manager with JIRA, enable the System Soap Services plug-in in JIRA. For detailed information,
refer to the JIRA documentation.
To add a JIRA issue tracking profile:
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1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Atlassian JIRA from the Type list box.
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Type the Hostname of your JIRA server and the Port that is used to connect to the server.
9. Click Load Project to load all projects from the server and populate the Project list box, then select a
project from the Project list box.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing Atlassian JIRA Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing Atlassian JIRA issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
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6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Hostname of your JIRA server and the Port that is used to connect to the server.
9. To change the JIRA project, click Load Project to load all projects from the server and update the Project
list box, then select a project from the Project list box.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Bugzilla
This section describes how to configure Bugzilla issue tracking profiles to integrate with Test Manager.
The Bugzilla plug-in relies on the SilkCentral Java API for integration. Test Manager communicates with Bugzilla
through the XML-RPC Bugzilla Web-service introduced with Bugzilla 3.0 by using the Redstone XML-RPC
library. To enable Bugzilla integration, ensure that you have installed a SOAP::Lite package for the web server.
For example, for the Debian distribution install the libsoap-lite-perl package.
Note: See the sources of com.segue.scc.issuetracking.bugzilla3.Bugzilla3Profile and
com.segue.scc.issuetracking.bugzilla3.Bugzilla3Issue to see how these elements fit
together.
For a list of the Bugzilla versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding Bugzilla Issue Tracking Profiles
To add a Bugzilla issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Bugzilla from the Type list box.
7. Type a valid Username and Password.
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These credentials will be used to access the issue tracking system.
8. Enter the URL of your Bugzilla installation. For example, http://bugzillaserver/cgi-bin/bugzilla3.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
10. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing Bugzilla Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing Bugzilla issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the URL of your Bugzilla installation.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
10. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•
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Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.
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Changepoint
This section describes how to configure Changepoint issue tracking profiles.
Changepoint is an IT management and governance tool that enables organizations to maximize the business
value of the entire IT portfolio including projects, applications, and infrastructure.
This integration allows you to connect Test Manager to Changepoint to store issues.
Important: The Changepoint environment must have the Changepoint API installed and the
CPWebService configured.
Known Issues
Workflow

Do not change the Changepoint workflows for requests after submitting them in Test Manager.
Do not use different workflows in requests when assigning external issues. The filter criteria
used in workflows should be based on fields used in the Test Manager Issue Tracking
Profile. Otherwise, unexpected states may be assigned to requests in Test Manager.

Synchronizing the Time for the Changepoint and Test Manager Servers
This section describes how to ensure that the Changepoint server and Test Manager server communicate
properly.
1. Open the web.config file located in the ../Changepoint/CP Web Services directory.
2. Add the following key to the security section:
<timeToleranceInSeconds>86400</timeToleranceInSeconds>
3. Save the file.
Opening Changepoint Issues in Context
In order to open Test Manager issues in the Changepoint system, you need to follow the steps below to install
a connection file on the Changepoint server.
1. In Test Manager, click Help ➤ Tools to view the Downloadable Client Tools page.
2. Click the Changepoint Request Form link.
3. When prompted, choose to save the ChangepointRequestForm.zip file to disk.
4. Extract CPRequestForm.html from ChangepointRequestForm.zip.
5. CPRequestForm.html needs to be manually copied to the Changepoint server and placed into the virtual
directory in which Changepoint is running.
Creating a Changepoint Issue Tracking Profile
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.

SilkCentral Test Manager 2010 R2

| 347

This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Compuware Changepoint from the Type list box.
7. Type a valid Username and Password for the issue tracking system.
Note: In order to select a project and to submit a new issue, the Username field must contain a
Changepoint user who has the project's Edit Project Plan permission.
8. Enter the URL of your Changepoint installation in the Changepoint Server URL field.
9. Enter the URL of your Changepoint web service server in the Changepoint WebSerivce URL field.
10. Click Load Initiator to load your Changepoint initiators.
11. Select an initiator from the Initiator list box.
12. Click Load Client to load your Changepoint clients.
13. Select a client from the Client list box.
14. Click Load Initiative to load your Changepoint initiatives.
15. Select an initiative from the Initiative list box.
16. Click Load Project to load your Changepoint projects.
17. Select a project from the Project list box.
18. Click Load Request Type to load your Changepoint request types.
19. Select a request type from the Request Type list box.
20. Click Load Application to load your Changepoint applications.
Select an application from the Application list box.
21. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
22. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

IBM Rational ClearQuest
This section describes how to configure IBM Rational ClearQuest issue tracking profiles to integrate with Test
Manager.
IBM Rational ClearQuest products provide flexible defect/change tracking and automated workflow support.
The two key products are IBM Rational ClearQuest (ClearQuest) and IBM Rational ClearQuest MultiSite
(ClearQuest Multisite). To work with ClearQuest profiles, you must have the ClearQuest client software installed
on the computer where the SilkCentral front-end server is running. For detailed information about installing
ClearQuest, refer to the ClearQuest documentation.
For a list of the ClearQuest versions that are supported for integration with Test Manager, refer to the Test
Manager Release Notes.
Adding ClearQuest Issue Tracking Profiles
To add a ClearQuest issue tracking profile:
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1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select IBM Rational ClearQuest from the Type list box.
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Enter the Repository Info of your ClearQuest installation.
This is the database name that is defined in the ClearQuest client software.
9. Specify the Record Type, which is the issue type of ClearQuest.
When entering an issue in Test Manager, ClearQuest will save the issue with the issue type you define in
this text box. The default issue type is Defect.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing ClearQuest Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing ClearQuest issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.

SilkCentral Test Manager 2010 R2

| 349

This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Repository Info of your ClearQuest installation.
This is the database name that is defined in the ClearQuest client software.
9. Change the Record Type, which is the issue type of ClearQuest.
When entering an issue in Test Manager, ClearQuest saves the issue with the issue type you define in this
field.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

SilkCentral Issue Manager
SilkCentral Issue Manager (Issue Manager), the issue-tracking tool of SilkCentral, is fully integrated with Test
Manager, enabling you to correlate issues with system requirements and executed tests.
Test-definition issues can be added and managed through Test Manager ➤ Test Plan ➤
more information, refer to the Issue Manager documentation.

➤ Issues. For

Note: StarTeam and IBM Rational ClearQuest are also supported by Test Manager “out of the box”.
Additional issue tracking systems can be configured by installing a custom plug-in. For more information,
refer to the Test Manager API Help.
Adding SilkCentral Issue Manager Issue Tracking Profiles
To add a SilkCentral Issue Manager issue tracking profile:
1. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
2. Click New Profile to open the New Issue Tracking Profile dialog box.
3. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
4. Type a Description for the new profile.
5. Select Issue Manager from the Type list box, or select Issue Manager 3.3 to connect to an Issue Manager
version 3.3 installation.
6. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
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7. Type the Issue Manager URL of your Issue Manager installation. This is the URL you use to login to Issue
Manager, though without the login extension at the end.
For example, if your standard Issue Manager URL is http://IssueManager/login, then the correct
service URL is http://IssueManager.
8. If you selected Issue Manager 3.3 from the Type list box, proceed with the next step.
If you selected Issue Manager from the Type list box, proceed as follows:
1. Click Load Projects. This action will populate the Project list box with all initialized Issue Manager
projects to which the specified user has access to. Note that only those projects display for which Issue
Manager user groups have been defined, and the defined user is a member of at least one user group.
2. Select the Project where Issue Manager issues are maintained.
Caution: We recommend not to use identical projects for Issue Manager and Test Manager, as this
limits flexibility in working with both tools on different future projects.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
10. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing SilkCentral Issue Manager Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing Issue Manager issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Issue Manager URL of your Issue Manager installation if the location has changed.
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This is the URL you use to login to Issue Manager, though without the login extension at the end. For
example, if your standard Issue Manager URL is http://IssueManager/login, then the correct service
URL would be http://IssueManager.
9. To change the StarTeam project, click Load Project to load all projects from the server and update the
Project list box, then select a project from the Project list box.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
11. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

StarTeam Issue Tracking Profiles
This section describes how to configure StarTeam issue tracking profiles to integrate with Test Manager.
StarTeam is a software change management and configuration management tool that enables coordination
and management of the software delivery process.
To work with StarTeam profiles and use the go-to-link functionality for change requests in StarTeam, you must
have the StarTeam Cross-Platform Client software installed on the computer where the browser is running.
For a list of the StarTeam versions that are supported for integration with Test Manager, refer to the Test
Manager Release Notes.
Adding StarTeam Issue Tracking Profiles
To add a StarTeam issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Type a Description for the new profile.
6. Select StarTeam from the Type list box
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Type the Hostname of your StarTeam server and the Port that is used to connect to the server. If this
setting has not been changed, use the default port 49201.
9. Specify the type of Encryption that the profile supports.
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10. Click Load Project to load all projects from the server and populate the Project list box, then select a
project from the Project list box.
11. Click Load View to load all views for the selected project and populate the View list box, then select a view
from the View list box.
12. Click Load Status Field to load all enumeration fields for change requests and populate the Status Field
list box, then select a status field from the Status Field list box.
If you are using a custom workflow in StarTeam, this field is the workflow driver field in StarTeam that maps
to the Test Manager issue state.
13. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
14. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing StarTeam Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
To edit an existing StarTeam issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Hostname of your StarTeam server and the Port that is used to connect to the server.
9. Modify the type of Encryption that the profile supports.
10. To change the StarTeam project, click Load Project to load all projects from the server and update the
Project list box, then select a project from the Project list box.
11. To change the view, click Load View to load all views for the selected project and populate the View list
box, then select a view from the View list box.
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12. To change the workflow driver field, click Load Status Field to load all enumeration fields for change
requests and populate the Status Field list box, then select a status field from the Status Field list box.
If you are using a custom workflow in StarTeam, this field is the workflow driver field in StarTeam that maps
to the Test Manager issue state.
13. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
14. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Team Foundation Server
This section describes how to configure Team Foundation Server (TFS) issue tracking profiles to integrate
with Test Manager.
For a list of the TFS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Installing a TFS Proxy Service
To communicate with a TFS, you need to install a TFS proxy service as an interface to the TFS.
To install a TFS proxy service:
1. Install Microsoft Visual Studio Team Explorer 2010 from
http://www.microsoft.com/downloads/details.aspx?FamilyID=fe4f9904-0480-4c9d-a264-02fedd78ab38.
2. Install IIS and the Web Deployment Tool, for example with the Web Platform Installer from
http://www.microsoft.com/web/downloads/default.aspx.
3. Open a command shell and type DotNetTfsWebServiceProxy.deploy.cmd /Y to install the proxy
service. If an an error message box displays, stating that ASP.NET 4 is required, refer to
http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx.
4. Open the IIS Manager.
5. Verify that the new website exists.
6. In the root folder of the virtual directory, open the Web.config file.
7. In the appSettings section of the file, modify the value of the key WorkItemTrackingCacheRoot to a local
directory.
For example:
<appSettings>
<add key="WorkItemTrackingCacheRoot" value="C:\temp" />
</appSettings>
8. If the directory you have specified does not exist, create it.
9. Grant Everyone full rights on the specified directory.
For additional information on deploying an ASP.NET Web Application, refer to
http://msdn.microsoft.com/en-us/library/ee942158.aspx.
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Adding TFS Issue Tracking Profiles
Note: You need to configure a TFS proxy before you can add a new TFS issue tracking profile.
To add a TFS issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Type a Description for the new profile.
6. Select Team Foundation Server 2010 from the Type list box.
7. Type a valid Username and Password.
These credentials will be used to access the issue tracking system.
8. Type the Domain of the TFS user.
9. Enter the URL of your TFS installation.
For example, http://tfsserver:8080/tfs.
10. Type the Collection to which your project belongs.
For example DefaultCollection.
All projects in the collection are listed in the Projects list box.
11. Select the Project from the list box.
12. Type the URL of your TFS proxy. For example
http://tfsproxyserver/DotNetTfsWebServiceProxy_deploy/TfsWebServiceProxy.asmx.
13. Click Load Work Item Type.
The Work Item Type list box is populated with the available work item types.
14. Select the Work Item Type from the list box.
15. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
16. If the trial connection is successful, a confirmation dialog box displays, asking you if you want to map internal
issue states to the states of the newly defined profile.
•
•

Click Yes to proceed with the related Mapping Issue States procedure.
Click No to map issue states later.

Editing TFS Issue Tracking Profiles
When the server or login credentials of your issue tracking system change, you must edit your issue tracking
profile accordingly.
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To edit an existing TFS issue tracking profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Issue Tracking tab.
The Issue Tracking page opens, listing all of the issue tracking profiles that have been created for the
system.
3. Click on the name of the issue tracking profile that you want to modify.
The Edit Issue Tracking Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the Description of the profile.
6. Optional: Select a new Type for the issue tracking profile from the list box.
7. Edit the Username and Password.
These credentials are used to access your issue tracking system.
8. Edit the Domain of the TFS user.
9. Edit the URL and Collection of your TFS installation.
10. Select a different Project.
11. Edit the URL and port of your TFS proxy.
12. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.

Other Integrations
Integrating Test Manager into Rally
To use the project management tool Rally with Test Manager, you have to integrate Test Manager into Rally.
A mashup is shipped with Test Manager, that enables you to display user-story related test-coverage information
from Test Manager in Rally. You can link each test definition in Test Manager to one or more user stories in
Rally. To link test definitions to a user story, assign an attribute with the value of the formatted user-story ID
in Rally to each test definition.
Creating a Mashup Tab in Rally
Create an HTML or JavaScript mashup tab in Rally to display user-story related test-coverage information.
To create a mashup tab:
1. Navigate to the tab in Rally where your mashup tab should reside.
2. Click New Custom Tab.
3. Type a name for your new tab in the Name text box. For example, Iteration Status.
4. Optional: Check the Share with all Users check box if you wish other users to be able to see your mashup.
5. Select Custom Mashup as the type of the mashup.
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6. Download the Rally Iteration Status Mashup from Test Manager ➤ Tools.
7. Paste the content of the Rally Iteration Status Mashup into the HTML text box.
8. Configure the script in the text box to match your Test Manager environment:
•
•
•
•
•

Check if the valid script source is set, for example <script type="text/javascript"
src="http://localhost:19120/silkroot/script/sctm-toolkit.js"></script>.
Check if the valid URL for Test Manager is set, for example var SCTM_URL =
"http://localhost:19120/".
Check if a valid Test Manager project ID is set, for example var SCTM_PROJECT_ID = 0.
Check if a valid attribute name is set, for example var SCTM_ATTRIBUTE_FOR_RALLY_US =
"rallyattr".
Make sure usage of the FormattedID from Rally is enabled, var USE_FORMATTED_ID = true.

9. Click Save & Close.
The mashup table is created.
Linking User Stories from Rally to Test Definitions
Link Rally user stories to test definitions in Test Manager.
To link Rally user stories to Test Manager test definitions:
1. Select the project in Test Manager which contains the test definitions you want to link the Rally user stories
to.
2. Navigate to Test Manager ➤ Settings.
3. Click the Attributes tab.
4. Click New Attribute.
The New Attribute dialog box opens.
5. Type rallyattr in the Name text box.
6.
7.
8.
9.

Select Edit from the Attribute type radio box.
Click OK to create the new attribute.
Assign the new attribute to each test definition that you want to link user stories from Rally to.
Set the value of the attribute to be the value of the FormattedID of the appropriate Rally user story for each
test definition. If you assign multiple stories to a single test definition, separate the IDs with a comma and
put no whitespace characters between them. For example, US10,US12,US14.

Microsoft Office
This section describes how Test Manager integrates with Microsoft Office.
Introducing Office Import Tool
The Office Import Tool enables you to import requirements and manual tests from Microsoft Word or Excel
into Test Manager.
Regardless of how your requirements or manual tests are displayed in Microsoft Word or Excel, Test Manager
can track and save that information. For example, in Microsoft Word, Test Manager completes this task by
looking at the styles that you apply to the paragraphs within your document. When you apply the special Test
Manager styles to your document, you indicate that you want to create a test based on that requirement or
manual test. Just as you possess control over the appearance of styles in Microsoft Word or Excel, you can
change the appearance of Test Manager styles. The only property you cannot change about the styles is their
name.
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Note: Before you start to work with Test Manager, verify that Microsoft Word and Excel are installed on
your computer and that you are familiar with styles.
The Office Import Tool supports Microsoft Word and Excel versions 2000, 2002, and 2003. For more information
about currently supported environments, refer to the SilkCentral Test Manager Release Notes.
For information about how to install and uninstall the Office Import Tool, refer to the Test Manager Installation
Help.

VMware Lab Manager Integration
This section explains the integration of Test Manager with VMware Lab Manager (Lab Manager).
VMware Lab Manager Virtual Configurations
VMware images are virtual computer systems. Lab Manager is used to manage VMware images, or
"configurations", which are combinations of images, for example database server, application server, and
execution server. VMware configurations offer an effective means of virtualizing complex software-testing lab
environments. Configurations are typically deployed from Lab Manager libraries, and are turned on and off
just like individual VMware images. Multiple instances of the same configuration can be deployed simultaneously,
with separate tests run in each instance. VMware configurations are “network-fenced,” meaning that they do
not influence each others' network behavior. VMware LiveLink technology enables you to take “snapshots” of
complete configurations that can later be recreated (or “restored”) on demand.
The integration of Lab Manager with Test Manager enables users to manage Lab Manager directly from the
Test Manager UI. Integrated functionality includes configuration deployment, test execution, result collection,
and automatic undeployment of configurations. Test Manager can support multiple Lab Manager installations
and configurations. Configurations captured using LiveLink technology are viewed using VMware Lab Manager.
Refer to the VMware Lab Manager documentation for full details regarding LiveLink configuration captures
and other Lab Manager functionality. For details on configuring the integration of Test Manager with Lab
Manager, refer to the SilkCentral Administration Module Help.
Note: At least one Test Manager execution server must exist within each configuration. These execution
server instances control test execution within configurations and retrieve test results.
Note: Lab Manager users must have administrator rights to access the Lab Manager API.

Requirement Management Tools
IBM Rational RequisitePro
The topics in this section describe the integration between IBM Rational RequisitePro and Test Manager.
Enabling Integration with IBM Rational RequisitePro
To enable integration with IBM Rational RequisitePro:
1. Navigate to Test Manager ➤ Projects.
2. Select the project to which you want to establish integration.
3. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
4. Click the Requirements Management tab.
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5. In the IBM® Rational® RequisitePro® Integration section, click Configure.
The Edit Configuration dialog box opens.
6. Type the UNC project path to the machine where the external server is installed. Or click Browse and
select the path.
7. Type valid UNC Username and UNC Password credentials for the machine where the external server is
installed.
8. Type valid Username and Password credentials for the requirements management server.
9. ClickTest Connection to confirm that the host and user credentials are correct.
If the settings are correct, a Test connection was successful message displays.
10. Click OK.
Note: Consult your system administrator if you are not able to establish a connection.
11. Click Edit Packages and Requirement Types.
Your selections are then displayed on the Edit Configuration dialog.
Note: Only requirements of explicitly selected packages will be synchronized. Selecting a parent
package does not select the child packages of the parent.
The Browse Packages & Requirement Types dialog box opens. The packages and requirement types
that are available with the selected project are automatically populated into the Packages and Requirement
Types list boxes.
12. From the Packages list box, select one or more packages from the external project that should be integrated
with the Test Manager project.
Use CTRL + CLICK to select multiple packages.
13. From the Requirement types list box, select one or more requirement types from the external project that
should be integrated with the Test Manager project.
Use CTRL + CLICK to select multiple requirement types.
14. Click OK.
The Browse Packages & Requirement Types dialog box closes.
15. Optional: Check the Enable creation of unassigned requirements check box to enable creation and
editing of unmapped requirements in Test Manager projects that are configured for integration with
RequisitePro.
16. Optional: Check the Enable upload of requirements to RequisitePro check box to enable the upload of
unmapped or unassigned requirements from Test Manager to RequisitePro.
This allows you to upload additional previously unmapped requirement trees to RequisitePro and then have
those requirements mapped within Test Manager. The Map Requirement button in Test Manager ➤
Requirements ➤ Properties becomes enabled, allowing configuration of top level requirements for external
requirement types, which is required when uploading unmapped requirements.
17. Click OK to save your settings.

CaliberRDM Integration
The topics in this section describe the integration between CaliberRDM and Test Manager.
Note: If you change databases for a Test Manager instance that is integrated with CaliberRDM, you may
not be able to perform a synch afterwards. If this happens, restart the front-end server and application
server.
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Note: If you are migrating from 2010 R1 to 2010 R2, your Magnitude (Text type) attribute used in test
definitions created from synchronized requirements will be renamed to Magnitude_Old. For 2010 R2,
Magnitude is a numeric attribute on which you can can filter.
Enabling Integration with CaliberRDM
To enable integration with CaliberRDM:
1. From the Test Manager project to which you want to establish integration, navigate to Test Manager ➤
Settings ➤ Requirements Management.
2. In the CaliberRDM Integration section, click Configure.
The Edit Configuration dialog box opens.
3.
4.
5.
6.

Enter the Hostname of the machine where the external server is installed.
Enter the Port number on which the external server is listening.
Enter valid Username and Password credentials for the requirements management server.
Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.
Note: Consult your system administrator if you are not able to establish a connection.

7. From the Project name text box, select the external project with which the Test Manager project is to be
integrated.
8. Check the Enable creation of unassigned requirements check box to enable creation and editing of
unmapped requirements in Test Manager projects that are configured for integration with CaliberRDM.
9. Click OK to save your settings.
Generating Test Definitions from External Requirements
From the RMSs currently shipped with Test Manager, only CaliberRDM supports generating test definitions.
If you want to use another RMS to generate test definitions, the RMS must be able to generate tests. The Test
Manager plug-in API includes a method to verify that the RMS is able to create tests. For more information,
see Requirements Plug-In API Interfaces.
To generate test definitions from external requirements:
1. Establish integration with the external requirement system.
For additional information, see Enabling Integration with CaliberRDM.
2. Select the requirement in the Requirements tree from which you wish to generate tests.
Note: To be able to generate tests, the RMS plug-in needs to implement the RMTestProvider
interface, and the interface method isTestGenerationSupported needs to return true for the
type of the selected requirement.
3. Click Generate Tests.
The Generate Tests dialog box displays.
4. Use SHIFT + CLICK or CTRL + CLICK to select the tests that you want to generate.
5. Click Generate All to generate all tests, or click Generate Selected to generate the selected tests.
The Test Plan tree displays.
6. Select the folder to which you want to add the generated tests.

360

| SilkCentral Test Manager 2010 R2

Note: Tests that already exist in the selected destination folder are not created, but updated. No tests
in the folder are deleted.
7. Click OK.

CaliberRM Integration
This section describes how to integrate CaliberRM with Test Manager.
Note: CaliberRM user defined attribute Multiple selection user list and Multiple selection group list
must be mapped to the Test Manager text attribute type and not list type.
Enabling Integration with CaliberRM
To enable integration with CaliberRM:
1. Navigate to Test Manager ➤ Projects.
2. Select the project to which you want to establish integration.
3. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
4. Click the Requirements Management tab.
5. In the Borland® CaliberRM Integration section, click Configure.
The Edit Configuration dialog box opens.
6. Type the Hostname of the machine where the external server is installed.
7. Type valid Username and Password credentials for the requirements management server.
8. Click Test Connection to confirm that the host and user credentials you have entered are correct.
Click Browse to advance to the Browse Projects dialog box.
If the settings are correct, a Test connection was successful dialog box opens.
Note: If you are not able to establish a connection, consult your system administrator.
9. Click OK.
10. From the Project list box, select the external project with which the Test Manager project is to be integrated.
The requirement types that are available with the selected project are automatically populated into the
Requirement Types field. The baselines that are available with the selected project are automatically
populated into the Baseline field.
11. Select a Baseline from the external project that should be integrated with the Test Manager project.
Your selections are displayed on the Edit Configuration dialog box.
12. Click OK.
13. Select one or more requirement types from the external project that should be integrated with the Test
Manager project.
Use CTRL + Click to select multiple requirement types.
14. Optional: Check the Enable creation of unassigned requirements check box to enable creation and
editing of unmapped requirements in Test Manager projects that are configured for integration with CaliberRM.
15. Optional: Check the Enable upload of requirements to CaliberRM check box to enable the upload of
unmapped or unassigned requirements from Test Manager to CaliberRM.
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This allows you to upload additional previously unmapped requirement trees to CaliberRM and then have
those requirements mapped within Test Manager. The Map Requirement button in Test Manager ➤
Requirements ➤ Properties becomes enabled, allowing configuration of top level requirements for external
requirement types, which is required when uploading unmapped requirements.
16. Click OK to save your settings.
Baseline Support for CaliberRM Integration
You can select the current baseline or existing user-defined baselines for CaliberRM integration. When you
select a user-defined baseline, the Map Requirement button in Test Manager ➤ Requirements ➤ Properties
is disabled and requirements are not updated in the integrated CaliberRM project.
You cannot import modified baselined requirements into Test Manager. Requirements that are not of the
current baseline can only be changed in CaliberRM if the version of the requirement that is used for the baseline
is changed. Such changes are only updated within Test Manager requirements when a manual or scheduled
synchronization is performed.
You can change a baseline after you import it into Test Manager. You can change the configured baseline to
a different user-defined baseline or the current baseline. After such a change, the next synchronization of the
baseline, either manual or scheduled, will update the Test Manager project and update, create, or delete
requirements as required. When a baseline is changed, a message displays that states that the changes will
take effect after the next synchronization. When a baseline is changed from the current baseline to a user-defined
baseline, a message displays informing you that, for user defined baselines, upload of requirements is disabled.
Note: With user-defined baselines, you can use the same requirement type of a CaliberRM project more
then once. With current baselines, a requirement type of a CaliberRM project is allowed only once.
Handling Test Definition Assignments in CaliberRM
Assigned test definitions are displayed, managed, and created as traces (“Trace to”) of synchronized
requirements in CaliberRM.
When synchronized requirements are assigned to test definitions in Test Manager, the test-definition assignments
are pushed out to and displayed within CaliberRM. Conversely, when test definitions are assigned to
synchronized requirements from CaliberRM, the assignments are pushed out to and displayed within Test
Manager.
Copying CaliberRM-Integrated Projects
To manage CaliberRM baselines when copying Test Manager projects:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Requirements Management tab.
3. Verify that the baseline you want to save is selected.
Note: If a baseline is changed, you must perform a synchronization to update the project requirements
with the baseline changes, before you can copy an associated Test Manager project. The integration
configuration is only copied if you select a baseline other than the current baseline. If you select the
current baseline, you need to specify if you want to keep the integration configuration in the original
project or move it to the copied project.
4. If the baseline that you want to save is not selected, click Edit Configuration.
The Edit Configuration dialog box displays.
5. Click Browse next to the Project name text box.
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The Browse Projects dialog box opens.
6. Select the baseline you want to save, then confirm your selection.
7. Navigate to Administration ➤ Projects.
8.
Click
in the Actions column of the project you want to copy.
Note: For full details on copying a project, refer to the SilkCentral Administration Module Help.
The Copy Project dialog box displays.
9. Select the items you want to copy into the new project, then confirm your selection.
10. Apply the baseline that you want to continue working with to the Test Manager project.
Note: After copying a project, the original project and the copy are identical. Define on which you will
continue working on by applying the corresponding baseline.
Creating a Baseline for a CaliberRM-Integrated Project
To create a baseline of a CaliberRM-integrated Test Manager project:
1. Create a baseline of the Test Manager project.
For more information on creating a baseline, refer to the SilkCentral Administration Module Help.
A SilkCentral message box displays during the process, asking if you want to enable the CaliberRM
integration for the new baseline.
2. Click Yes.
When the new baseline is created, the Baseline Project - Adapt Project Settings dialog box opens.
3. Click Edit to change the requirements integration settings.
The Edit Configuration dialog box opens.
4. Click Browse next to the Project name text box.
The Browse Projects dialog box opens.
5. Select a CaliberRM project, a baseline, and the requirement type for synchronization.
6. Click Ok to close the Browse Projects dialog box.
7. Click Ok to close the Edit Configuration dialog box.
8. Click Finish to close the Baseline Project - Adapt Project Settings dialog box.

Telelogic DOORS Integration
This section describes how to integrate Test Manager and Telelogic DOORS® (DOORS).
Installing Telelogic DOORS on the Front-End Server
To integrate Test Manager and Telelogic DOORS, install the DOORS client on the Test Manager front-end
server machine. If you use more than one front-end server machine, you must install the DOORS client to the
same directory on each of the machines.
To install the DOORS client on the Test Manager front-end server machine:
1. Navigate to Help ➤ Tools ➤ Downloadable Client Tools.
2. Click Test Manager Add-In for Telelogic DOORS to download the DOORS plug-in package.
The package contains two ZIP-Archives:
•
•

DoorsRM.zip
DoorsClientLibs.zip
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3. Create a new folder with the name testmanager in the …\lib\dxl folder of your Telelogic DOORS client
installation.
The default path for this folder is C:\Program
Files\Telelogic\DOORS_8.20\lib\dxl\testmanager.
4. Extract all DOORS script files from DoorsClientLibs.zip to this folder.
The plug-in package DoorsRMPlugin.zip is automatically installed to the Plugins folder of your Test
Manager application server installation during the setup process. During startup of the application server, this
plug-in will be published to all front-end servers.
Configure a Project for Integration with DOORS
To configure a project for requirements integration with DOORS:
1. From the Test Manager project to which you want to establish integration, navigate to Test Manager ➤
Settings ➤ Requirements Management.
2. In the Telelogic DOORS® Integration section, click Configure.
The Edit Configuration dialog box opens.
3. In the RM service URL text box, type the URL of the Test Manager DOORS requirement Web Service.
The default value should point to the correct location already. For example
http://MySCTMHost:19120/services/doorsrequirementsmanagement.
4. Type valid Username and Password credentials for the requirements management server.
5. The default DOORS client installation path is displayed in the DOORS Installation Path text box. If this
path is not correct, click Browse to browse to and select the correct destination in the front-end server
directory structure.
6. Click Test Connection to confirm that the host and user credentials you have entered are correct.
A Connection successful message box displays if the settings are correct. Click OK to continue.
Note: Consult your system administrator if you are not able to establish a connection.
7. Click Browse next to the Project name text box to open the Browse Requirement Types dialog box.
From the Project text box, select the external project with which the Test Manager project is to be
synchronized.
The requirement types that are available with the selected project are automatically populated into the
Requirement types text box. Select the requirement types that are to be synchronized and click OK. Use
CTRL + CLICK to select multiple requirement types.
8. Your selections are now displayed on the Edit Configuration dialog box. Click OK.
9. Optional: Check the Enable creation of unassigned requirements check box to enable creation and
editing of unmapped requirements in Test Manager projects that are configured for integration with Telelogic
DOORS.
10. Optional: Check the Enable upload of requirements to Telelogic DOORS® check box to enable the
upload of unmapped or unassigned requirements from Test Manager to DOORS.
This allows you to upload additional previously unmapped requirement trees to DOORS and then have
those requirements mapped within Test Manager. The Map Requirement button in Test Manager ➤
Requirements ➤ Properties becomes enabled, allowing configuration of top level requirements for external
requirement types, which is required when uploading unmapped requirements.
11. Click OK to save your settings.
Caution: As the DOORS application object is used for communication, and this object does not support
login data, but rather requires a running DOORS client, Test Manager starts each DOORS client
process with the provided login data and then uses that same data for all subsequent application
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objects. Therefore only one set of DOORS login credentials is supported for communication at one
time. It is recommended that you use the same DOORS credentials for all configurations so that
integration tasks can be performed on the front-end server for all projects at the same time. When a
second set of credentials is used, the second set only works after all sessions using of the first set of
credentials have timed out.

Source Control Profile Integrations
Apache Commons Virtual File System
This section describes how to configure Virtual File System (VFS) source control profiles.
A VFS is an abstraction layer on top of a more concrete file system. The purpose of a VFS is to allow client
applications to access different types of concrete file systems in a uniform way. Apache Commons VFS provides
a single API for accessing various file systems. It presents a uniform view of the files from various sources.
The protocols that are currently supported for VFS by Test Manager are:
Protocol

Description

http

Copies the given file. This protocol type is also supported for copying and unpacking ZIP,
JAR, or other zipped files. It is required to specify a .zip file on a http server. For example,
zip:http://myTestServer/myTests.zip.The .zip file will be extracted on the execution
server.

ftp

Copies the given file. This protocol type is also supported for copying and unpacking ZIP,
JAR, or other zipped files.

smb

Server Message Block (smb) copies all files and folders. This protocol can be used instead
of a UNC profile. For example, the VFS smb path
smb://server-name/shared-resource-path is equivalent to the UNC path
\\server-name\shared-resource-path.

Note: When you create a new ProcessExecutor test that uses VFS for source control, you need to specify
the complete path to the executable in the Executable Name text box.
Adding VFS Source Control Profiles
To create a VFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select VFS from the Source control system list box.
6. Type the URL of the VFS Repository you want to access.
Specify the appropriate protocol type in the URL:
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FTP

ftp://<ftp server URL>

HTTP

http://<http server URL>

SMB

smb://<Samba server url>

Note: HTTP, FTP and SMB are also supported for zipped files. In order to point to a zipped file the
URL must be adjusted to <zipped file type>:<protocol>://<server URL pointing to
zipped file> to include the type of the zipped file. For example,
zip:http://193.80.200.135/<path>/archive.zip or
jar:http://193.80.200.135/<path>/archive.jar.
7. Type a valid VFS Username and Password.
These credentials will be used to access your VFS repository. The SMB protocol allows including the domain
name in the username in the following form: domain/username.
8. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing VFS Source Control Profiles
To modify a VFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the URL of the VFS Repository you want to access.
6. Edit the Username and Password.
These credentials are used to access your repository.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
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8. Edit the Project path you want this profile to use.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Concurrent Version System (CVS)
This section describes how to configure CVS source control profiles.
CVS is a powerful source control tool that handles complete source code trees. It can be customized using
scripting languages such as PERL and Korn. CVS is decentralized so that users can maintain their own source
directory trees. It also enables concurrent file editing.
For a list of the CVS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding CVS Source Control Profiles
To create a CVS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5.
6.
7.
8.

Choose CVS from the Source control system list box.
Type the CVS server name or IP address in the Hostname text box.
Type the port that is to be connected to in the Port text box.
Specify the connection method in the Method text box.
Currently, the ext, pserver, and local connection methods are supported.

This makes the Port setting optional.
9. Specify the URL of the CVS Repository you want to access.
For example, /var/lib/cvs. If you do not know the URL of the repository, please consult your CVS
administrator.
10. Type a valid CVS Username and Password.
These credentials will be used to access your CVS repository.
Note: These settings are optional when using the ext connection method.
11. Specify the CVS Module that is to be used.
12. Type the Working folder to which the Test Manager execution server should copy the source files.
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The working folder must be a local path. For example, C:\TempSources\.
13. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
14. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing CVS Source Control Profiles
To modify a CVS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Choose from the following options:
•
•
•
•

Edit the CVS server name or IP address in the Hostname text box.
Edit the port that is to be connected to in the Port text box.
Edit the URL of the CVS Repository you want to access. If you do not know the URL of the repository,
consult your CVS administrator.
Edit the CVS Module that is to be used.

6. Edit the Username and Password.
These credentials are used to access your issue tracking system.
Note: These settings are optional when using the ext connection method.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Specify the connection method in the Method text box.
Currently, the ext, pserver, and local connection methods are supported.
This makes the Port setting optional.
9. Edit the Project path you want this profile to use.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
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Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Microsoft Team Foundation Server 2010
This section describes how to configure Team Foundation Server (TFS) source control profiles.
For a list of the TFS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding TFS Source Control Profiles
To add a TFS source control profile, the Microsoft Visual Studio Team Explorer Everywhere 2010 command-line
client needs to be installed on the front-end server and every execution server, on which you want to use the
source control profile. You can download the CLC from the Microsoft Download Center.
To create a TFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select Team Foundation Server 2010 from the Source control system list box.
6. Enter the URL of your TFS installation.
For example, http://tfsserver:8080/tfs.
7. Type the Domain of the TFS user.
8. Type a valid Username and Password.
These credentials will be used to access your repository.
9. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
10. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
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Editing TFS Source Control Profiles
To add a TFS source control profile, the Microsoft Visual Studio Team Explorer Everywhere 2010 command-line
client needs to be installed on the front-end server and every execution server, on which you want to use the
source control profile. You can download the CLC from the Microsoft Download Center.
To modify a TFS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the URL of the TFS Repository you want to access.
6. Edit the Username and Password.
These credentials are used to access your repository.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Edit the Project path you want this profile to use.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Microsoft Visual SourceSafe
This section describes how to configure Microsoft Visual SourceSafe (MSVSS) source control profiles.
MSVSS is a version-control system for managing software and Web-site development. Fully integrated with
the Visual Basic-, Visual C++-, Visual J++-, Visual InterDev-, and Visual FoxPro development environments,
as well as with Microsoft Office applications, MSVSS provides easy-to-use, project-oriented version control.
MSVSS works with any file produced with any development language, authoring tool, or application. Users
can work at both the file and project level while promoting file reuse.
For a list of the MSVSS versions that are supported for integration with Test Manager, refer to the Test Manager
Release Notes.
Adding MSVSS Source Control Profiles
Tip: SourceSafe clients must be installed on all front-end, application, and execution servers.
To create a MSVSS source control profile:
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1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select MSVSS or MSVSS (cmd line) from the Source control system list box.
MSVSS (cmd line) utilizes the MSVSS command line plug-in, which works exactly like MSVSS, except
that SilkCentral users are automatically logged out of MSVSS when the user logs out from SilkCentral.
When selecting MSVSS, SilkCentral users remain logged in to MSVSS for an indefinite time.
6. If you selected MSVSS (cmd line), specify the location of the SourceSafe executable ss.exe.
SourceSafe must be installed identically on all execution servers and the front-end server. This allows you
to specify a definite path. For example, C:\Program Files\Microsoft Visual
Studio\VSS\win32\ss.exe. If SourceSafe is installed in different locations, see Configuring the location
of a SourceSafe Client.
7. In the SourceSafe database (srcsafe.ini) text box, type the UNC path and file name of the SourceSafe
configuration file you want to access or click Browse to locate the SourceSafe configuration file..
Note: SourceSafe configuration files use the name srcsafe.ini.
8. Type a valid UNC username and UNC password.
These credentials are required to access the UNC path of the configuration file.
9. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
10. Type a valid Username and Password.
These credentials will be used to access your repository.
11. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
12. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing MSVSS Source Control Profiles
To modify a MSVSS source control profile:
1. Navigate to Test Manager ➤ Settings.
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Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. If you selected MSVSS (cmd line), specify the location of the SourceSafe executable ss.exe.
SourceSafe must be installed identically on all execution servers and the front-end server. This allows you
to specify a definite path. For example, C:\Program Files\Microsoft Visual
Studio\VSS\win32\ss.exe. If SourceSafe is installed in different locations, see Configuring the location
of a SourceSafe Client.
6. In the SourceSafe database (srcsafe.ini) text box, edit the UNC path and file name of the SourceSafe
configuration file, or click Browse to locate the file.
If you do not know the location of the configuration file, consult your SourceSafe administrator.
Note: SourceSafe configuration files use the name srcsafe.ini.
7. Edit the UNC username and UNC password.
These credentials are required to access your configuration file’s UNC path.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Edit the Username and Password.
These credentials are used to access your repository.
10. Edit the Project path you want this profile to use.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Configuring the Location of a SourceSafe Client
To configure the location of a SourceSafe client:
1. In the SourceSafe executable text box, type ss.exe without any path information.
2. On each execution server and on the front-end server, type the local path of the SourceSafe executable
ss.exe to the Windows system path. To do this, click Start ➤ Settings ➤ Control Panel ➤ System.
The System Properties dialog box displays.
3. Click the Advanced tab and click Environment Variables.
The Environment Variables dialog box displays.
4. Select the Path variable in the System variables section and click Edit.
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5. Add the local path of the SourceSafe executable to the list of existing Variable values. You can append a
new variable value to existing values by entering a semicolon (;) followed by the path information.
6. Repeat this procedure for each execution server and for the front-end server.

Serena Version Manager (PVCS)
This section describes how to configure Serena Version Manager (PVCS) source control profiles.
Serena Version Manager, from the makers of PVCS, is the full-featured solution for version control and revision
management in software projects. More than simply storing code revisions, Version Manager is a robust,
full-featured solution with security, high performance, and varying levels of support for distributed teams. For
information on the supported versions, refer to the Test Manager Release Notes.
Adding PVCS Source Control Profiles
To create a PVCS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select PVCS from the Source control system list box.
6. Type the UNC path of the PVCS Repository you want to access.
If you do not know the UNC path of the repository, consult your PVCS administrator.
7. Type a valid UNC username and UNC password.
These credentials are required to access the UNC path of the configuration file.
8. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Type the Execution path. This is the local path of the PVCS installation, where the command line tool
pcli.exe is located. The default path is C:\Program Files\Serena\vm\win32\bin.
Note: The PVCS client software must be installed on the front-end server and each execution server.
PVCS must be installed in identical paths on each machine. For example, if you install PVCS on the
TestPartner front-end server to C:\Program Files\Serena\, you must install PVCS in the same
path on the execution servers.
10. Type a valid Username and Password.
These credentials will be used to access your repository.
11. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
12. Click OK.
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Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing PVCS Source Control Profiles
To modify a PVCS source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the UNC path of the PVCS Repository.
If you do not know the UNC path of the repository, consult your PVCS administrator.
6. Edit the UNC username and UNC password as required.
These credentials are required to access the repository UNC path you specified above.
7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Edit the Execution path. This is the local path of the PVCS installation, where the command line tool
pcli.exe is located. The default path is C:\Program Files\Merant\vm\win32\bin.
Note: The PVCS client software must be installed on the front-end server and each execution server.
PVCS must be installed in identical paths on each machine. For example, if you install PVCS on the
Test Manager front-end server to C:\Program Files\Serena\, you must install PVCS in the same
path on the execution servers.
9. Edit the Username and Password.
These credentials are used to access your repository.
10. Edit the Project path you want this profile to use.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

SilkTest Workbench
This section describes how to configure SilkTest Workbench source control profiles.
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SilkTest Workbench is an automated testing tool that accelerates the functional testing of complex applications.
SilkTest Workbench provides support for testing applications developed in a wide variety of development tools
including Java, .NET, browser-based web applications, and COM components, including both ActiveX controls
and automation objects. With SilkTest Workbench, you can record user sessions with your applications to
create tests, enhance the test by adding validation and test logic, and play back tests to ensure that the
applications work as expected.
Adding SilkTest Workbench Source Control Profiles
To create a SilkTest Workbench source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Issue Tracking Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select SilkTest Workbench Test from the Source control system list box.
6. Select a database type from the Database type list box, either SQL Server or Oracle.
Note: The Microsoft Office Access database type is not supported. When connecting to a SilkTest
Workbench Oracle database, there is a SilkTest Workbench requirement that the TNS name must be
the same as the host server name.
7. Enter the name of the SilkTest Workbench database server in the Database server text box.
8. Enter the name of the SilkTest Workbench database in the Database name text box.
9. Enter the port number of the SilkTest Workbench database server in the Database port text box.
10. Enter the SilkTest Workbench database schema or owner name in the Database schema/owner name
text box.
11. Enter the name of the database user in the Database user text box.
12. Enter the password for the database user in the Database password text box.
13. Enter the name of a valid SilkTest Workbench user in the SilkTest Workbench User name text box.
14. Enter the password for the SilkTest Workbench user in the SilkTest Workbench password text box.
15. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
16. Click Retrieve.
All projects are listed in the Projects list.
17. Select one or more projects.
18. Click OK.
Editing SilkTest Workbench Source Control Profiles
To modify a SilkTest Workbench source control profile:
1. Navigate to Test Manager ➤ Settings.
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Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the SilkTest Workbench Database type.
Note: The Microsoft Office Access database type is not supported.
6. Choose from the following options:
•
•
•
•
•
•
•
•

Edit the SilkTest Workbench Database server.
Edit the SilkTest Workbench Database name.
Edit the Database port number of the SilkTest Workbench database server.
Edit the SilkTest Workbench Database schema/owner name.
Edit the SilkTest Workbench Database user.
Edit the SilkTest Workbench Database password.
Edit the SilkTest Workbench User name.
Edit the SilkTest Workbench Password.

7. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Select one or more projects from the Projects list.
9. Click OK.

StarTeam Source Control Profiles
This section describes how to configure StarTeam source control profiles.
StarTeam promotes team communication and collaboration through centralized control of all project assets.
Protected yet flexible access ensures that team members can work whenever and wherever they like through
an extensive choice of Web, desktop, IDE, and command-line clients. StarTeam offers a uniquely comprehensive
solution that includes integrated requirements management, change management, defect tracking, file versioning,
threaded discussions, and project and task management.
For a list of the StarTeam versions that are supported for integration with Test Manager, refer to the Test
Manager Release Notes.
Adding StarTeam Source Control Profiles
To create a StarTeam source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
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The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select StarTeam from the Source control system list box.
6. Type the Hostname of your StarTeam server.
7. Type the Port that is to be used to connect to the StarTeam server.
If the port is not changed, use the default port 49201.
8. Type a valid Username and Password.
These credentials will be used to access your repository.
9. Specify if the profile supports Encryption.
10. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
11. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
12. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing StarTeam Source Control Profiles
To modify a StarTeam source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Choose from the following options:
•
•
•

Edit the Hostname of your StarTeam server.
Edit the port that is to be used to connect to the StarTeam server. If the port is not changed, use the
default port 49201.
Specify if the profile supports Encryption.
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6. Edit the Project path you want this profile to use.
7. Edit the Username and Password.
These credentials are used to access your repository.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Subversion
This section describes how to configure Subversion (SVN) source control profiles.
Subversion (SVN) is the successor to the Concurrent Versions System (CVS). Subversion manages versions
using transaction numbers. With each commit, the transaction number is incrementally increased.
What other source control systems call labels, Subversion refers to as tags. These tags are encoded in the
Subversion URL. For example, http://MyHost/svn/MyApp/trunk is a Subversion URL and
http://MyHost/svn/MyApp/tags/build1012 is a Subversion tag.
Test Manager supports Subversion tags. If a Subversion URL contains the trunk directory, you can define
a label tags/build1012. This label replaces trunk in the Subversion URL.
Note: If a Subversion URL does not contain trunk and you define a label, Test Manager throws an error.
Adding Subversion Source Control Profiles
To create a Subversion source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Choose Subversion from the Source control system list box.
6. Type the URL of the Subversion Repository you want to access.
If you do not know the URL of the repository, consult your Subversion administrator.
Note: To use SSH, add ssh to the URL, for example svn+ssh://<hostname>:<port>.
7. Type a valid Username and Password.
These credentials will be used to access your repository.
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8. Type a valid SSH username and SSH password or SSH keyfile.
These credentials are used to access the SSH server. The password overrides the keyfile, so if you only
have a keyfile, leave the SSH password text box empty. If you use a keyfile, the path to the keyfile must
be valid on every execution server that uses the source control profile.
9. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
10. Type the Project path you want this profile to use. Click Browse to display the Select Project Path dialog
box.
The Select Project Path dialog box opens. Select the desired project path in the tree view and click OK.
Leaving this text box empty sets the project path to the root directory.
11. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing Subversion Source Control Profiles
To modify a Subversion source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the URL of the Subversion repository you want to access.
If you do not know the URL of the repository, please consult your Subversion administrator.
Note: If you cannot check out files, when editing the URL of the Subversion Repository, delete the
source control mirrors directory on your execution server. For example, C:\Documents and
Settings\All Users\Application Data\Silk\SCC35\SrcCtrlMirrors.
Note: To use SSH, add ssh to the URL, for example svn+ssh://<hostname>:<port>.
6. Edit the Username and Password.
These credentials are used to access your repository.
7. Type a valid SSH username and SSH password or SSH keyfile.
These credentials are used to access the SSH server. The password overrides the keyfile, so if you only
have a keyfile, leave the SSH password text box empty. If you use a keyfile, the path to the keyfile must
be valid on every execution server that uses the source control profile.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
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The working folder must be a local path. For example, C:\TempSources\.
9. Edit the Project path you want this profile to use.
10. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

TestPartner
This section describes how to configure TestPartner source control profiles.
TestPartner is a Micro Focus product that tests Web- and Microsoft Windows-based applications that use
Microsoft technologies. TestPartner records user actions to quickly produce powerful tests. Each recorded
test displays as a series of actions in clear, concise steps that can be easily understood by all testers, from
novice to expert. You can record user sessions with the application, add validation functions, and replay the
sessions later to ensure that the application works as expected.
Adding TestPartner Source Control Profiles
To create a TestPartner source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select TestPartner from the Source control system list box.
Note: When connecting to a TestPartner Oracle database, there is a TestPartner requirement that
the TNS name must be the same as the host server name.
6. Select a database type from the Database type list box, either SQL Server or Oracle.
7. Type the name of the database server in the Database server text box.
8. Type the name of the database in the Database name text box.
9. Type the port number of the database server in the Database port text box.
10. Type the database schema or owner name in the Database schema/owner name text box.
11. Type the name of the database user in the Database user text box.
12. Type the password for the database user in the Database password text box.
13. Type a valid Username and Password.
These credentials will be used to access your repository.
14. Type the Working folder to which the Test Manager execution server should copy the source files.
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The working folder must be a local path. For example, C:\TempSources\.
15. Use the Project path text box to filter which scripts from the database are available to use as tests. Click
Browse to display the Select Project Path dialog box.
The Select Project Path dialog box provides a tree of three levels that you can choose from:
First level

The entire TestPartner database. Note that if you select this level, the
Project path text box will remain blank.

Second level

The TestPartner project.

Third level

The script type within a specified TestPartner project.

Select one of the preceeding options and click OK. The path will be added to the Project Path text box.
16. Click OK.
Editing TestPartner Source Control Profiles
To modify a TestPartner source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Choose from the following options:
•
•
•
•
•
•
•

Edit the TestPartner Database type.
Edit the TestPartner Database server.
Edit the TestPartner Database name.
Edit the TestPartner number of the TestPartner database server.
Edit the TestPartner Database schema/owner name.
Edit the TestPartner Database user.
Edit the TestPartner Database password.

6. Edit the Username and Password.
These credentials are used to access your repository.
7. Edit the Project path you want this profile to use.
8. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
9. Click OK.

Universal Naming Convention
This section describes how to configure Universal Naming Convention (UNC) source control profiles.
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Short for Universal Naming Convention or Uniform Naming Convention, UNC is a PC format for specifying the
location of resources on a local-area network (LAN). UNC uses the following format:
\\server-name\shared-resource-pathname.
For example, to access the file test.txt in the directory examples on the shared server silo, you would
write: \\silo\examples\test.txt.
You can also use UNC to identify shared peripheral devices, such as printers. The idea behind UNC is to
provide a format so that each shared resource can be identified with a unique address.
UNC is only supported on Microsoft Windows operating systems. If you plan to use a non-windows execution
server you can use the Apache Commons VFS source control profile instead.
Adding UNC Source Control Profiles
To create a UNC source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click New Profile to open the New Source Control Profile dialog box.
4. Type a Name for the new profile.
This is the name that is displayed in lists where the profiles are available for selection.
5. Select UNC from the Source control system list box.
6. Type the UNC path that you want to access.
This is the path to the location where your test definition sources are located.
7. Type the Working folder to which the Test Manager execution server should copy the source files.
The working folder must be a local path. For example, C:\TempSources\.
8. Type a valid UNC username and UNC password.
These credentials are required to access the UNC path of the configuration file.
9. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.
Editing UNC Source Control Profiles
To modify a UNC source control profile:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Source Control tab.
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The Source Control page opens, listing all of the source control profiles that have been created for the
system.
3. Click on the name of the source control profile that you want to modify.
The Edit Source Control Profile dialog box opens.
4. Edit the Name of the profile.
This is the name that is displayed in the Test Manager GUI.
5. Edit the UNC path.
This is the path to where your test definition sources are located.
6. Edit the Working folder to which the Test Manager execution server copies the source files.
The working folder must be a local path. For example, C:\TempSources\.
7. Edit the UNC username and UNC password.
These credentials are required to access your configuration file’s UNC path.
8. Click OK.
Test Manager attempts a trial connection to the external system using the information you have provided.
Note: If an error occurs, please review the information that you have supplied, or consult your
administrator.
If the trial connection is successful, you are returned to the Source Control page.

Test Automation Tools
JUnit Integration
The topics in this section describe the integration between JUnit and Test Manager. You can use the JUnit
test type to create Silk4J tests.
Configuring JUnit Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure JUnit test properties:
1. On the New Test Definition dialog box, select JUnit Test from the Type list box and then click Next.
The JUnit Test Properties dialog box opens.
2. In the Test class text box, type the fully qualified name of the JUnit test class.
3. In the Test method text box, type the name of the appropriate test method.
The method must be available in the test class. If the Test method text box is left blank, all tests that are
included in the suite will be executed.
4. Set the Java home directory to the installation path of the Java Runtime Environment (JRE).
The path must be valid on the execution server on which the test definition runs.
5. Specify a valid Java Classpath to use on the execution server.
We recommend to use a relative classpath. The relative classpath is then expanded to the full classpath
on the execution server. By using a relative classpath, changes on the location of the source control profile
do not require additional changes to the classpath.
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The relative classpath must point to the root node of the test container containing the JUnit test definition,
for example JUnit_tests. The relative classpath on the execution server is then expanded to include the
working folder of the source control profile, for example C:\temp, and the test file names, for example
JUnit4Test.jar.
To use a previous version of JUnit, you can also add the relative classpath to junit.jar to the classpath,
with the appropriate JUnit version. Test Manager supports JUnit 4.4 or later. For example, if the working
folder of the source control profile is C:\temp, the specified relative paths
junit-4.4.jar;JUnit4Test.jar are expanded to
C:\temp\JUnit_tests\junit-4.4.jar;C:\temp\JUnit_tests\JUnit4Test.jar on the execution
server. By default, if no relative classpath to the junit.jar is specified, Test Manager uses JUnit 4.8.1.
You can also use a fully qualified classpath. The fully qualified classpath must point to the archive or folder
in which the test classes reside. Further, junit.jar must be added to the classpath, with the appropriate
JUnit version, as the following examples show:
•
•

C:\Java\junit4.4\junit.jar;C:\MyApps\main.jar;C:\MyApps\utils.jar
${junit_home}\junit.jar;${apps_home}\main.jar;${apps_home}\utils.jar

6. Optional: In the JVM options text box, you can specify the command-line options and environmental
variables that can affect the performance characteristics of the JVM. You can specify multiple options, but
you have to type them in the right order. For example, to use the client VM and set the maximum size of
the heap to 512MB, type -client -Xmx512m.
7. In the Coverage path text box, type the JAR libraries or the specific class files to monitor for code coverage
information.
We recommend using the relative coverage path from the test container root node, which is then expanded
on the execution server. You can also use a fully qualified path. Use semicolons to separate multiple jar
files, as the following examples show:
•
•

C:\MyApps\main.jar;C:\MyApps\utils.jar
${apps_home}\main.jar;${apps_home}\utils.jar
Note: The coverage path setting is disregarded if the Record external AUT Coverage check box is
checked.

8. Check the Record external AUT Coverage check box to get code coverage for the application under test
that is defined for the execution definition in the Code Analysis Settings portion of Execution ➤
Deployment.
If the check box is not checked, code coverage is recorded from the executing virtual machine. The check
box is by default not checked.
9. Click Finish.
Note: Parameters are passed to the Java process as system properties, for example
-Dhost_under_test=10.5.2.133. Use the System.getProperty() method to access the system
properties. For example, to access the previously passed host_under_test property, use
System.getProperty(“host_under_test”);.

NUnit Integration
The topics in this section describe the integration between NUnit and Test Manager. You can use the NUnit
test type to create Silk4NET tests.
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Configuring NUnit Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
Note: We recommend that you add the .\bin folder of your NUnit installation to the system path. Click
Start ➤ Control Panel ➤ System ➤ Advanced ➤ Environment Variables to add a path like
C:\Program Files\NUnit 2.2\bin to the system environment variable PATH.
To configure NUnit test properties:
1. On the New Test Definition dialog box, select NUnit Test from the Type list box and then click Next.
The NUnit Properties dialog box displays.
2. Click Browse to locate and select the NUnit assembly from which you want to pull a test definition.
3. Type the working directory in the NUnit Directory text box.
This directory is the local path to the file nunit-console.exe, such as C:\Program Files\NUnit
2.2\bin.
4. In the NUnit Options text box, type one or more NUnit console command-line options to specify how NUnit
tests are specified.
For example, to define that the Flex4TestApp NUnit test, located in SilkTest.Ntf.Test.Flex, should
be executed, set the fixture option as follows:
/fixture:SilkTest.Flex.Flex4TestApp
Note: When you add multiple options, you have to separate the options by writing one option in each
line in the text box.
5. Click Finish.

Process Executor Integration
The topics in this section describe the integration between process executor and Test Manager.
The process executor can be used to launch any executable and extends the published process test launcher
class.
Configuring Process Executor Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure process executor test properties:
1. On the New Test Definition dialog box, select ProcessExecutor Test from the Type list box and then
click Next.
The ProcessExecutor Test Properties dialog box opens.
2. In the Executable Name text box, type the fully qualified name of the executable.
3. In the Argument List text box, type all arguments of the process executor test method.
Note: Multiple arguments must be on separate lines in the text box.
4. Set the Working Folder.
This is the folder where the executable is executed.
During execution of the executable the following two environment variables can be used:
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Environment Variable

Description

SCTM_EXEC_RESULTSFOLDER

All files in this folder are saved as result files in Test Manager. If
an output.xml file is created during execution in this directory,
it is processed by Test Manager.

SCTM_EXEC_SOURCESFOLDER

This is the folder where all source files used during the execution
are located.

Example
The following example contains a ProcessExecutor test type that runs the Windows Script
Host from the command line with the /c switch and two parameters:

•
•
•
•

/c - command that specifies that the command line should terminate after execution.
cscript - Windows Script Host.
parareadwrite.js - the jscript file named parareadwrite.js
%SCTM_EXEC_RESULTSFOLDER% - the Test Manager variable that contains the location
of the Result folder on the execution server machine. Files stored in this location are
automatically uploaded to Test Manager and available in the Files tab of the Test
Definition Run. In this example, the parareadwrite.js script produces an
output.xml file that is written to the Result folder and uploaded back to Test Manager.

SilkPerformer Integration
The topics in this section describe the integration between SilkPerformer and Test Manager.
Configuring SilkPerformer Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure SilkPerformer test properties:
1. On the New Test Definition dialog box, select SilkPerformer Test from the Type list box and then click
Next.
The Test Properties - Select Project dialog box opens.
2. Perform one of the following steps to define the SilkPerformer project from which your test case is taken:
•
•

Click Browse to select a SilkPerformer project that has been saved to your local file system.
Click Import to import a SilkPerformer project that is saved to the file pool. A file in the file pool can be
used anywhere in the Test Plan tree.

3. On the Import Project From File Pool dialog box, either select a saved .ltz SilkPerformer project package
from the File pool entry list box or click Browse to select a SilkPerformer project package that has been
saved to the source-control system.
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If you check the Remove file from file pool check box before you click Finish, the selected SilkPerformer
file is deleted from the file pool.
4. Perform one of the following steps to upload SilkPerformer projects to the file pool:
•
•
•
•

From Administration ➤ Files, click Upload and browse to the appropriate LTZ file. For more information,
refer to the SilkCentral Administration Module Help.
Use the upload mechanism offered by SilkPerformer.
Use the Upload Manager in SilkCentral.
Use an existing project directory by way of a UNC path. Create a new test definition, click Browse to
select the appropriate LTP file, and then select a workload.

5. On the Test Properties - Select Project dialog box, click Next.
6. On the Test Properties - Select Workload dialog box, select one of the workload profiles that has been
defined for the project from the Workload list box.
7. Click Finish to create the test case.
Test Manager is fully integrated with SilkPerformer.
Working with SilkPerformer Projects
SilkPerformer is fully integrated with the test planning and test execution functionality of Test Manager.
SilkPerformer projects can be integrated into Test Manager test plans and directly executed through Test
Manager. This allows for powerful test-result analysis and reporting. It also enables unattended testing, which
means tests are run automatically by Test Manager based on pre-configured schedules.
Refer to the SilkPerformer Help for details on configuring the integration of SilkPerformer with Test Manager.
SilkPerformer project files can be directly opened in SilkPerformer from Test Manager, where scripts and
settings can be edited. Edited SilkPerformer projects can subsequently be checked back into Test Manager
to make them available for future test executions.
Test Manager provides information on execution definition run properties during SilkPerformer test executions.
Use the AttributeGet methods to access execution definition run properties in the SilkPerformer script.
You can access the following properties in the script:
•
•
•
•
•
•

#sctm_execdef_id
#sctm_execdef_name
#sctm_product
#sctm_version
#sctm_build
#sctm_keywords
Note: The term Project is used differently in SilkPerformer than it is in Test Manager. A SilkPerformer
project, when uploaded to Test Manager, becomes the core element of a Test Manager test definition.
Test Manager projects are high-level entities that may include multiple SilkPerformer projects, test
definitions, execution definitions, and requirements.

Downloading SilkPerformer Projects
Whereas opening a SilkPerformer project may involve checking out a SilkPerformer project from a source-control
tool, editing the project in SilkPerformer, and checking the project back into Test Manager, downloading a
project involves downloading a copy of a project and working with it independently of Test Manager. Changes
you make to downloaded projects are not automatically migrated back to Test Manager.
To download a SilkPerformer project:
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1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a SilkPerformer test definition.
4. Click the Properties tab.
5. Scroll down to the SilkPerformer Test Properties section.
6.
Click
.
A file download dialog box displays, asking you to confirm that you wish to download the specified
SilkPerformer project to your local system.
7. Click Save to open the file in SilkPerformer.
If not already open in the background, SilkPerformer is invoked.
8. The Select Target Directory dialog box displays, loaded with the default directory path to which the specified
SilkPerformer project will be saved. If you approve of the specified pathname, click OK, otherwise click
Browse to specify an alternate path.
Note: Even if you have configured source-control integration, you will not be prompted to check out
the SilkPerformer project from your source-control system because you are working with this file
independently of Test Manager.
Note: SilkPerformer projects utilized by Test Manager can also be downloaded directly from the
SilkPerformer user interface. For additional information, refer to the SilkPerformer documentation.
Opening SilkPerformer Projects
To open a SilkPerformer project from Test Manager:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3.
4.
5.
6.

In the Test Plan tree, select a SilkPerformer test definition.
Click the Properties tab.
Scroll down to the SilkPerformer Test Properties section.

Click .
A file download dialog box displays, asking you to confirm that you wish to open the specified SilkPerformer
command file (.spwbcmd) in SilkPerformer.
7. Click Open to open the file in SilkPerformer. If not already open in the background, SilkPerformer is invoked.
The Select Target Directory dialog box opens, loaded with the default directory path to which the specified
SilkPerformer project will be saved.
8. If you approve of the specifed pathname, click OK, otherwise click Browse to specify an alternate path.
9. If you have configured source-control integration for Test Manager, for example Visual SourceSafe, you
are presented with a login screen for your source-control client. Enter valid user connection settings and
click OK to continue.
Note: SilkPerformer projects utilized by Test Manager can also be opened directly from SilkPerformer.
For additional information, refer to the SilkPerformer documentation.
Executing Attended SilkPerformer Tests
Attended tests are SilkPerformer tests that are executed manually in SilkPerformer and are not executed
automatically based on a pre-defined schedule in Test Manager.
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Note: To use Test Manager's data-driven test functionality with SilkPerformer scripts, data sources with
column names matching the corresponding SilkPerformer project, attributes must be used in conjunction
with AttributeGet methods.
To execute an attended test run in SilkPerformer:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a SilkPerformer test definition.
4. Click the Properties tab.
5. Scroll down to the SilkPerformer Test Properties section.
6.
Click
.
A file download dialog box displays, asking you to confirm that you wish to run the specified SilkPerformer
command file (.spwbcmd).
7. Click Open to open the project in SilkPerformer.
If not already open in the background, SilkPerformer is invoked. The Select Target Directory dialog box
displays, loaded with the default directory path to which the specified SilkPerformer project will be saved.
8. If you approve of the specified pathname, click OK, otherwise click Browse to specify an alternate path.
The SilkPerformer Workload Configuration dialog box opens with all of the workload settings that are
associated with the SilkPerformer project.
9. Edit the workload settings as required and click Run to begin the test and monitor the test results with
SilkPerformer.
Note: Clicking Run without editing any workload settings executes the SilkPerformer test in exactly
the same way as if the test had been executed directly from Test Manager as an unattended test.
Editing SilkPerformer Test Properties
Note: To use the data-driven test functionality of Test Manager with SilkPerformer scripts, you have to
use data sources with column names that match the corresponding SilkPerformer project attributes in
conjunction with AttributeGet methods.
To edit SilkPerformer test properties:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3.
4.
5.
6.
7.

In the Test Plan tree, select a SilkPerformer test definition.
Click the Properties tab.
Scroll down to the SilkPerformer Test Properties section.
Click Edit SilkPerformer Test Properties.
Proceed with the configuration of your SilkPerformer test.

Analyzing SilkPerformer Test Results
Performance Manager enables in-depth analysis of SilkPerformer test results. The Analyze Results option
downloads only selected results, in contrast to “Downloading result packages”. To assist you in analyzing the
results of your optimization efforts, Performance Explorer even allows you to compare statistics from multiple
test runs side-by-side in cross load-test reports.
The results of tests that are run using Test Manager can be automatically loaded into Performance Manager
through commands on the Runs page in the Test Plan unit.
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For full details on using Performance Manager and integrating Performance Manager with Test Manager, refer
to the Performance Manager documentation.
To open SilkPerformer test results in Performance Manager:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. Select the test definition you are interested in viewing.
4. Click the Runs tab.
5.
Click
in the Actions column of the test execution for which you want to download results.
A File Download dialog box displays, showing you the name of the Performance Manager command file,
.sppecmd, that you are about to download.
6. Click Open to open the results in Performance Manager. Alternatively, you can click Save to save the
results locally.
7. If not already open in the background, Performance Manager now opens, connected directly to your Test
Manager installation, and fetches the results of the selected execution run.
Note: To prepare for a cross load-test report that compares the results of multiple executions in a
single report, you may download the results of additional executions from the Runs page. Additional
execution results are displayed in the existing instance of Performance Manager on the Performance
Manager Test Manager tab. For additional details on cross load-test reports, refer to the Performance
Manager documentation.
Downloading SilkPerformer Test Result Packages
Downloading result packages is the ideal option if you want to analyze the complete results set of a test run,
or if you want to download the complete results set for offline analysis. Because result packages often include
large TrueLog On Error files, result packages can be compressed and downloaded to your local hard drive as
.lrz files. Downloading results locally can also be useful when you are working from a slow Internet connection.
To download SilkPerformer test results:
1. Navigate to Test Manager ➤ Test Plan.
2. Click
on the toolbar.
3. In the Test Plan tree, select a SilkPerformer test definition.
4. Click the Runs tab.
5.
Click
in the Actions column of the test execution for which you want to download results.
A File Download dialog box displays, showing you the name of the compressed results package file, .ltz
that you are about to download.
6. Click Open to open the results in Performance Manager. Alternatively, you can click Save to save the
results locally.
7. If not already open in the background, Performance Manager now opens.You are presented with an Import
Project dialog box that indicates the target directory to which the results will be saved. Click OK to accept
the default path, or click Browse to select an alternate path. The downloaded results are then displayed
in Performance Manager.
Note: If you accept the default projects directory where result packages are typically stored, which
we generally recommend, then the results will be stored with all otherSilkPerformer results and will be
readily accessible through the Performance Manager Add Loadtest Results command.
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Uploading SilkPerformer Test Results
Once you have completed running an attended test in SilkPerformer, you can upload the test results to Test
Manager and associate the results with a test definition.
To upload results from an attended SilkPerformer test:
1. Run an attended SilkPerformer test.
For additional information, see Executing Attended SilkPerformer Tests.
2. When the test is complete, select Upload Results to Test Manager from the Results menu.
The Login screen of the Upload Results to Test Manager wizard displays.
3. Enter your Password and click Next.
Note: Because this is an attended test, the wizard already knows the appropriate hostname and
username of the test definition to which these results are to be uploaded.
4. If not already selected by default in the project list, select the Test Manager project to which you want to
upload the SilkPerformer results.
5. If not already selected by default in the tree list, select the test definition to which you want to upload the
results. Click Next.
Note: You can right-click in the tree and use the commands on the context menu to create a new test
definition, child test definition, test folder, or child test folder to which the results can be saved.
6. On the subsequent screen you can specify Version and Build numbers for the assigned Product to which
the uploaded results belong. Also specify the SilkPerformer test result status, for example Passed, Failed.
Note: If any errors occured during the test run, the test result status is set to Failed by default.
7. Click Finish to upload the results.
The uploaded results are displayed in the Test Definition Runs column in Test Manager ➤ Test Plan ➤
Runs.
Performance Trend Reports
This section explains the performance trend reports that ship with Test Manager. Performance trend reports
show the evolution of the application under test's performance over a specified period of time. The input data
for the performance reports is provided by SilkPerformer load tests.
Average Page-Time Trend Report
Shows the page times per page for all tests executed for the specified test definition within the specified time
range. The performance trend of the page times for the tested pages is shown in a graph.
Input Parameters
The input parameters for an Average Page-Time Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included in the
report. Use this setting to avoid that outliers skew the trend curve.
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Parameter

Description

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction busy-times
that exceed this value are cut off at the top. This setting is useful to prevent
the flattening of lines caused by outliers.

Measure Filter

Shown measures are limited to those including the specified string in their
name. This field has to be filled out. To display all available measures, set
the measure filter to %. For example, to show only measures that include
the word "unit" at any position in their names, set the measure filter to
%unit%.

Test Definition ID

Identifier of the test definition for which you want to view the report.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Page Time Trend Information
The trend charts show the page time trend over the selected time range for all filtered measures. The minimum,
maximum, and average page time curves are shown in each chart. The displayed values in each chart are cut
at the selected maximum y-axis value.
Average Transaction Busy-Time Trend Report
Shows the transaction busy time per transaction for all tests executed for the specified test definition within
the specified time range. The performance trends of the transaction busy-times for the tested transaction are
displayed in trend charts.
Input Parameters
The input parameters for an Average Transaction Busy-Time Trend report are:

392

Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included in the
report. Use this setting to avoid that outliers skew the trend curve.

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction busy-times
that exceed this value are cut off at the top. This setting is useful to prevent
the flattening of lines caused by outliers.

Test Definition ID

Identifier of the test definition for which you want to view the report.

Transaction Filter

Shown transactions are limited to those including the specified string in
their name. This field has to be filled out. To display all available
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Parameter

Description
transactions, set the transaction filter to %. For example, to show only
transactions that include the word "unit" at any position in their names, set
the transaction filter to %unit%.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Transaction Busy-Time Trend Information
The trend charts show the transaction busy-time trend over the selected time range for all filtered transactions.
The minimum, maximum, and average transaction busy-time curves are shown in each chart. The displayed
values in each chart are cut at the selected maximum y-axis value.
Custom Measure Trend Report
Shows the average, minimum, and maximum values of the defined measure or measures for all tests executed
for the specified test definition within the specified time range. The performance trend of the values for each
tested measure is shown in a graph.
Input Parameters
The input parameters for a Custom Measure Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included in
the report. Use this setting to avoid that outliers skew the trend curve.

Maximum Value for y-Axis

Measure Name

Measure Type

Test Definition ID

Limits the y-axis of the graph to the specified value. Measures that
exceed this value are cut off at the top. This setting is useful to prevent
the flattening of lines caused by outliers.
Name of the custom measure for which you want to view the report.
For example CreateTestDefinition.
Type of the custom measure. For example
Transaction(BusyTime)[s].
Identifier of the test definition for which you want to view the report.
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General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Custom Measure Trend Information
The trend chart shows the performance trend over the selected time range for the selected measure. The
minimum, maximum, and average measure curves are shown in the chart. The displayed values in the chart
are cut at the selected maximum y-axis value.
Overall Page-Time Trend Report
Shows overall page times, aggregated over all user types, for all tests executed for the specified test definition
within the specified time range. The performance trend of the page times for the tested page is shown in a
graph.
Input Parameters
The input parameters for an Overall Page-Time Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included
in the report. Use this setting to avoid that outliers skew the trend
curve.

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction
busy-times that exceed this value are cut off at the top. This setting is
useful to prevent the flattening of lines caused by outliers.

Test Definition ID

Identifier of the test definition for which you want to view the report.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
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Overall Page-Time Trend Information
The trend chart shows the overall page-time trend over the selected time range for all pages. The minimum,
maximum, and average overall page-time curves are shown in the chart. The displayed values in the chart
are cut at the selected maximum y-axis value.
Overall Transaction Busy-Time Trend Report
Shows overall transaction busy-time, aggregated over all user types, for all tests executed for the specified
test definition within the specified time range. The performance trend of the transaction busy-times for the
tested transaction is displayed in a trend chart.
Input Parameters
The input parameters for an Overall Transaction Busy-Time Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included
in the report. Use this setting to avoid that outliers skew the trend
curve.

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction
busy-times that exceed this value are cut off at the top. This setting is
useful to prevent the flattening of lines caused by outliers.

Test Definition ID

Identifier of the test definition for which you want to view the report.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Overall Transaction Busy-Time Trend Information
The trend chart shows the overall transaction busy-time trend over the selected time range for all transactions.
The minimum, maximum, and average transaction busy-time curves are shown in the chart. The displayed
values in the chart are cut at the selected maximum y-axis value.
Working with Silk Performance Explorer
Silk Performance Explorer (Performance Explorer) is used for in-depth analysis of test runs. Performance
Explorer results analysis can be started directly from Test Manager's Executions unit and Test Plan unit
through execution runs on the Runs page or from Performance Explorer itself. Refer to the Performance
Explorer documentation for details regarding Performance Explorer's integration with Test Manager.
The results of load-test runs in SilkPerformer can also be uploaded to Test Manager and associated with test
definitions. Refer to the SilkPerformer Help for more details.
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For additional information about Test Manager’s integration with SilkPerformer, refer to the SilkPerformer Help
and the Performance Explorer User Guide.

SilkTest Workbench Integration
The topics in this section describe the integration between SilkTest Workbench and Test Manager.
Configuring SilkTest Workbench Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure SilkTest Workbench test properties:
1. On the Test Properties - Select Scripts dialog box, select one or more scripts from the SilkTest Workbench
Test list box.
2. In the Playback Options text box, type in the name of a predefined SilkTest Workbench playback option
or leave the default value of System Defaults.
Note: A playback option must be set for a SilkTest Workbench test definition. The delete option on a
SilkTest Workbench test definition will reset the playback option to the default value of System
Defaults.
3. Click Finish.
Opening SilkTest Workbench in the Context of the Result File
1.
2.
3.
4.

Click Execution.
Select your execution definition.
Click the Runs tab.
Click the Run ID hyperlink label.
The Test Definition Run Results dialog box opens.
5. Click the Files tab.
6. Click the result.stwx file to open SilkTest Workbench in context of the result file.
Viewing the Last Screenshot for a Visual Test When a Playback Error Occurs
1.
2.
3.
4.

Click Execution.
Select your execution definition.
Click the Runs tab.
Click the Run ID hyperlink label.
The Test Definition Run Results dialog box opens.
5. Click the Files tab.
6. If error.png is there, click it to view the last screenshot for a Visual Test when a playback error occurs.
Test Plan Parameters Page - SilkTest Workbench
Test Manager ➤ Test Plan ➤ Data Set
When passing parameters from a Test Manager test definition to a SilkTest Workbench visual test – the
following data types should be used:
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Test Manager

SilkTest Workbench

String

Text
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Test Manager

SilkTest Workbench

Number

Number (Long)

Number

Number (Long Long)

Number

Enumeration

Float

Number (Double)

Boolean

Boolean (True/False)

SilkTest Classic Integration
The topics in this section describe the integration between SilkTest Classic and Test Manager.
SilkTest Classic Tests
This section describes how to execute test definitions in SilkTest Classic.
Adding a SilkTest Classic AUT Host
For execution definitions that run SilkTest Classic tests, you may have a setup where the SilkTest Classic
agent is on a different computer than the execution server. In this case, you can define the location of the
SilkTest Classic agent, the SilkTest Classic AUT (Agent Under Test) Hostname.
To add a a SilkTest Classic AUT host to the selected execution definition or edit the host:
1. Navigate to Test Manager ➤ Execution.
2. Click
on the toolbar.
3. Select the execution definition to which you want to assign the SilkTest Classic AUT host.
4. Click the Deployment tab.
5. In the SilkTest Classic AUT Hostname section, click Edit.
The Edit SilkTest Classic AUT Hostname dialog box displays.
6. In the Hostname text box, type the name of the computer where the SilkTest Classic agent runs.
Proper configuration of option files is required. For details on the command-line option -m, refer to the
SilkTest Classic documentation.
7. Click OK to add the SilkTest Classic AUT host to the selected execution definition.
Automated Execution of SilkTest Classic Test Definitions
All test definitions within an execution definition use the same SilkTest Classic instance for tests. The SilkTest
Classic GUI is opened once with the first SilkTest Classic test definition execution and is closed automatically
after the last SilkTest Classic test definition execution. Each SilkTest Classic test definition execution produces
its own results. If for any reason the SilkTest Classic GUI closes during a test, it will reopen automatically with
the next SilkTest Classic test definition execution.
Automated Execution of Data-Driven SilkTest Classic Testcases
If the data driven check box is checked in SilkTest Classic test properties, each SilkTest Classic test will be
repeated once for each data row in the external datasource. By default, plan-based execution mode is used
for data driven tests. This means that the results of all data rows will be listed under a single node in the .res
result file. If execution mode is switched to script-based data driven in SccExecServerBootConf.xml, a
result node will be created in the .res result file for each data row.
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Specifying Agent Under Test (AUT)
When a SilkTest Classic agent cannot run on the same machine as the Test Manager execution server, for
example when tests are run on platforms other than Windows, the hostname and port may be specified by the
SilkTest Classic AUT Hostname setting in the Deployment page of an execution definition. If the setting has
not been defined, SilkTest Classic default values are used, for example from partner.ini. The syntax for
AUT is hostname:port. The agent must be started manually prior to test execution and configured to listen
at the specified port. By default, the TCP/IP protocol is used for communication between SilkTest Classic
instances and SilkTest Classic agents. Ensure that both programs have been configured to use the same
protocol.
Note: Be careful when you have multiple execution servers assigned to an execution definition as SilkTest
Classic agents can only work with one SilkTest Classic instance at a time.
SilkTest Classic Time-out Settings
If you have SilkTest Classic test cases that require more than 1 hour to complete, you must adjust the time-out
settings in Test Manager. Otherwise, Test Manager assumes that something has gone wrong in the execution
and terminates SilkTest Classic. For details about setting the SilkTest Classic time-out, refer to the SilkCentral
Administration Module Help.
SilkTest Classic Logs
The RMS log file in SilkTest Classic is used to log data for each test case as test runs progress. Three types
of data records are written to this file: status, memory and user records. By monitoring this file, the RMS Remote
Agent has a means of determining the progress of each test run.
You can write your own comments into the user records of the log file by executing the PrintToRMSLog 4Test
function.
Examples:
PrintToRMSLog ("Error", "An intended error")
PrintToRMSLog ("Info", "testcase sleep1 started")
PrintToRMSLog ("Warning", "TestCase 1 started a second time")
Definition of user function in rms.inc:
PrintToRMSLog (STRING sMessageType, STRING sUserMessage)
Writes to the log file in the following format:
U|{sTestCaseName}|{sScriptName}|{sArgStr}|{sUserMessage}|{sMessageType}

TestPartner Integration
The topics in this section describe the integration between TestPartner and Test Manager.
Configuring TestPartner Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure TestPartner test properties:
1. On the New Test Definition dialog box, select TestPartner Test from the Type list box.
2. Click Next.
The Test Properties - Select Test Script dialog box opens.
3. Click Browse.
The Choose File dialog box opens. The assets available in this dialog box are based on the Project Path
defined in the associated TestPartner source control profile.
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4. Select a script from the list and click OK.
Note: To add multiple TestPartner tests, see Adding Multiple TestPartner Tests.
5. In the Playback Options text box, type in the name of a predefined TestPartner playback option or leave
the default value of System Defaults.
6. Click Finish.
Executing a TestPartner script on a 64-bit machine
1. Download sqlncli_x64.msi from
http://www.microsoft.com/downloads/en/details.aspx?familyid=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en.
2. Install sqlncli_x64.msi on the 64-bit box.
3. Go to C:\Windows\SysWOW64.
4. Find and Launch odbcad32.exe from this directory.
5. Under the System DSN tab, verify that the SQL Native Client driver version 2005.90.1399.00 is installed.
Adding Multiple TestPartner Tests
To add multiple TestPartner tests, you must first follow the steps described in Creating Test Definitions.
To add multiple TestPartner tests:
1. On the New Test Definition dialog box, select TestPartner Test from the Type list box.
2. Click Next.
The Test Properties - Select Test Script dialog box opens.
3. Click Browse.
The Choose File dialog box opens. The assets available in this dialog box are based on the Project Path
defined in the associated TestPartner source control profile.
4. In the Playback Options text box, type in the name of a predefined TestPartner playback option or leave
the default value of System Defaults.
Note: The import gives the defined playback option to all imported scripts. If you need to change the
playback option for any scripts, edit the test definition after the import.
5. Click Next.
The Test Properties - Select Scripts dialog box opens.
6. In the TestPartner Scripts text box, select the scripts to import by clicking CTRL + Click.
7. Click Finish.

Windows Script Host Tests
Windows Script Host (WSH) is part of the Windows platform and creates an environment for hosting scripts.
When a script is to be run at the execution server, WSH plays the role of host. It makes objects and services
available for the script and provides a set of guidelines within which the script is executed. Among other things,
WSH manages security and invokes the appropriate script engine.
The following online WSH resources might be of value to you:
•
•
•

http://labmice.techtarget.com/scripting/WSH.htm
http://www.winguides.com/links.php?guide=scripting
Downloadable Script Interpreters: http://aspn.activestate.com/ASPN/
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Configuring Windows Scripting Test Properties
To configure the properties of a test, you must first follow the steps described in Creating Test Definitions or
Editing Test Definitions.
To configure Windows scripting test properties:
1. On the New Test Definition dialog box, select Windows Scripting Test from the Type list box and then
click Next.
The Windows Scripting Properties dialog box opens.
2. Click Browse and select a Windows scripting test script.
3. Specify the location of any required additional parameters in the Switches text box.
Note: You may add other switches to be passed to the script. For more details on the switches that
can be used, see Windows Script Host Tests and refer to the MS Scripting Host documentation.
4. Click Finish.
Supported Script Languages
WSH is language-independent for WSH-compliant scripting engines. Natively, the Windows platform supports
Visual Basic Scripts, with file extension .vbs, and scripts written in the Java Script language, with file extension
.js.
For other scripting languages, a dedicated script interpreter must be installed on the execution server. For
example, if you install a Perl interpreter on an execution server, this will register a Perl scripting engine at the
WSH environment for the extension .pls. Whenever a file with extension .pls is passed to the WSH tool,
with the executable cscript.exe, it will invoke the appropriate interpreter because of the file extension. So
the client of WSH, in this case the SilkCentral Execution Server, does not need to know about the installation
of the Perl interpreter.
Note: After installing a script interpreter, for example Active Perl, try to execute a script locally on the
execution server by calling the WSH command line tool with a sample script before executing the script
in Test Manager. To do so, open a command shell on the execution server and type cscript
<somescript>, where <somescript> is the path to a script of your choice that is available on your
execution server. This is exactly what Test Manager will call when executing a WSH test definition on an
execution server. If the script is executed, then the scripting engine has been registered successfully.
The following scripting languages are WSH compatible:
Scripting Language

File Extension

Perl

.pls

Python

.py, .pyw

REXX

.REXX

TCL

.tcl

WSH Test Properties
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Property

Description

Script

You can define any file where a script engine is registered for the script language the file contains.
Script files under source control are deployed automatically to execution servers, comparable
to test sources for other test definition types.
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Property

Description

Switches

You can enter and pass the following settings to cscript.exe during the execution of the
test:
//B

Batch mode suppresses all non-command-line console UI requests from the
script. We recommended that you use this option to prevent a script from
waiting for user input during unattended executions at the execution server.

//U

We recommend to that you use unicode for redirected I/O from the console.

//T:nn

Time-out, in seconds. The maximum time the script can run, by default = no
limit. This option is used to prevent excessive execution of scripts. It sets a
timer. When execution time exceeds the specified value, Cscript interrupts
the script engine using the IActiveScript::InterruptThread
method and terminates the process. There is a callback hook. If the time-out
is invoked, the OnTimeOut function is called to permit cleanup. Although
it is possible to create infinite loops using this feature, it is more useful than
harmful.

//logo

Displays an execution banner at execution time that is visible at the beginning
of the log.txt log file. This is the default setting.

//nologo

Prevents display of the execution banner at execution time.

//D

Enables active debugging.

//E:engine

Use the engine to execute a script.

//Job:xxxx

Execute a WSF job.

//X

Execute the script in debugger.

Using Parameters in WSH Tests
Parameters that are defined for a WSH test definition automatically add a name and value pair to the command
line as an additional argument and set the parameters as environment variables for the called process. This
functionality allows you to access all parameters defined for your test definition within the WSH script.
For example a WSH test definition is defined with myscript.js as script and //B as switch. Additionally the
test requires a parameter called IPAddress with the value 192.168.1.5 and another parameter called Port
with the value 1492. The resulting command line for the WSH execution in this example is:
csript myscript.js //B IPAddress=192.168.1.5 Port=1492
Viewing Information Returned from WSH
To collect results of a WSH execution, the WSH script must generate a file called output.xml in the current
working directory of the WSH test. All files residing in this directory are stored in the database and are
downloadable through the list of files for the test definition execution. Files are excluded from storage when
their extensions are defined under the file extensions to ignore in results property in the Projects unit.
Note: The current working directory is dynamically created for each WSH execution. Do not use an
absolute path when creating the file. Any relative path used will correctly refer to the current working
directory.
Any information that a script writes to the WSH standard output goes into the log.txt text file that resides
in the current working directory. This file is stored in the database and can be viewed as it is included in the
file list of the test definition execution.
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The following example shows how to print log information from a script:
WScript.Echo "This info will be written to the log.txt file"
The XML structure of output.xml begins with an element ResultElement that defines an attribute named
TestItem, which specifies the name of the ResultElement.
The ResultElement must contain an element named ErrorCount, optionally an element named WarningCount,
and a list of Incident elements.
The ErrorCount and WarningCount elements must contain a positive number or zero. The ErrorCount and
WarningCount of the top-level ResultElement are used for evaluating success conditions, which determine if
a test has passed or failed. The XML file might contain additional elements that are not visible in the Test
Manager GUI. The output.xml file is however stored in the database and is viewable as it is included in the
file list of the executed test definition.
The Incident element represents an event that happened during the execution of the WSH test. Message and
Severity are shown in the messages list of test definition executions in the Test Manager GUI. An Incident
element must contain a Message and a Severity element.
The Severity element must hold one of the following values:
•
•
•
•

Info
Warning
Error (or Exception)
Failure

You can store additional information in the result file. The ResultElement may contain any number of
sub-ResultElements, so information can be easily grouped. Sub-ResultElements make the result file easier to
read. For compatibility reasons related to unit tests, JUnit and NUnit, ResultElement can be named TestSuite
or Test.
The ResultElement may contain the following additional elements:
•
•
•
•
•

FailureCount, which is treated the same way as error count
RunCount, if a test is run multiple times
Timer, for example for the duration of the test
WasSuccess, for compatibility with NUnit result files
Asserts, for compatibility with NUnit result files

The Incident element may contain a list of Detail elements.
The Detail element represents detailed information about an Incident. It must define a TestName element and
an Info element. The TestName is used to give detailed information about where the Incident happened. The
Info element holds detailed information about the Incident, for example a stack trace.
Note: Up through Test Manager 8.1, the value of the Message and Info elements had to be URL encoded
(ISO-8859-1). Since version 8.1.1, URL encoding is no longer allowed.
Sample Result File
<ResultElement TestItem="WshOutputTest">
<ErrorCount>1</ErrorCount>
<WarningCount>1</WarningCount>
<Incident>
<Message>some unexpected result</Message>
<Severity>Error</Severity>
<Detail>
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<TestName>function main()</TestName>
<Info>some additional info; eg. stacktrace</Info>
</Detail>
</Incident>
<Incident>
<Message>some warning message</Message>
<Severity>Warning</Severity>
<Detail>
<TestName>function main()</TestName>
<Info>some additional info; eg. stacktrace</Info>
</Detail>
</Incident>
</ResultElement>

Java Script Sample
The following script was used to generate the sample result file. To try this script save it
with the extension .js.
function dumpOutput(dumpFile)
{
dumpFile.WriteLine("<ResultElement TestItem=\"WshOutputTest\">");
dumpFile.WriteLine(" <ErrorCount>1</ErrorCount>");
dumpFile.WriteLine(" <WarningCount>1</WarningCount>");
dumpFile.WriteLine(" <Incident>");
dumpFile.WriteLine("
<Message>some unexpected result</Message>");
dumpFile.WriteLine("
dumpFile.WriteLine("
dumpFile.WriteLine("
dumpFile.WriteLine("
stacktrace</Info>");
dumpFile.WriteLine("
dumpFile.WriteLine("
dumpFile.WriteLine("
dumpFile.WriteLine("

<Severity>Error</Severity>");
<Detail>");
<TestName>function main()</TestName>");
<Info>some additional info; eg.
</Detail>");
</Incident>");
<Incident>");
<Message>some warning message</Message>");

dumpFile.WriteLine("
<Severity>Warning</Severity>");
dumpFile.WriteLine("
<Detail>");
dumpFile.WriteLine("
<TestName>function main()</TestName>");
dumpFile.WriteLine("
<Info>some additional info; eg.
stacktrace</Info>");
dumpFile.WriteLine("
</Detail>");
dumpFile.WriteLine(" </Incident>");
dumpFile.WriteLine("</ResultElement>");
}
function main()
{
var outFile;
var fso;
fso = WScript.CreateObject("Scripting.FileSystemObject");
outFile = fso.CreateTextFile("output.xml", true, true);
outFile.WriteLine("<?xml version=\"1.0\" encoding=\"UTF-16\"?>");
dumpOutput(outFile);
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outFile.Close();
WScript.Echo("Test is completed");
}
main();
WScript.Quit(0);

Visual Basic Script Sample
The following Visual Basic script also generates the sample result file, and saves it as
Output.xml. To try this script save it with the extension .vbs.
WScript.Echo "starting"
Dim outFile
Dim errCnt
Dim warningCnt
outFile = "output.xml"
errCnt = 1 ' retrieve that from your test results
warningCnt = 1 ' retrieve that from your test results
Set FSO = CreateObject("Scripting.FileSystemObject")
Set oTX = FSO.OpenTextFile(outFile, 2, True, -1) ' args: file,
8=append/2=overwrite, create, ASCII
oTX.WriteLine("<?xml version=""1.0"" encoding=""UTF-16""?>")
oTX.WriteLine("<ResultElement TestItem=""PerlTest"">")
oTX.WriteLine(" <ErrorCount>" & errCnt & "</ErrorCount>")
oTX.WriteLine(" <WarningCount>" & warningCnt & "</WarningCount>")
oTX.WriteLine(" <Incident>")
oTX.WriteLine("
<Message>some unexpected result</Message>")
oTX.WriteLine("
<Severity>Error</Severity>")
oTX.WriteLine("
<Detail>")
oTX.WriteLine("
<TestName>function main()</TestName>")
oTX.WriteLine("
<Info>some additional info; eg.
stacktrace</Info>")
oTX.WriteLine("
</Detail>")
oTX.WriteLine(" </Incident>")
oTX.WriteLine(" <Incident>")
oTX.WriteLine("
<Message>some warning message</Message>")
oTX.WriteLine("
<Severity>Warning</Severity>")
oTX.WriteLine("
<Detail>")
oTX.WriteLine("
<TestName>function main()</TestName>")
oTX.WriteLine("
<Info>some additional info; eg.
stacktrace</Info>")
oTX.WriteLine("
</Detail>")
oTX.WriteLine(" </Incident>")
oTX.WriteLine("</ResultElement>")

Communicating with an External System Over SSL
Java Runtime Environment (JRE) version 1.5 or higher must be installed on your computer perform the steps
in this task. You can download JRE from http://java.sun.com/javase/downloads/index.jsp.
If the certificate of the host you want to connect to is self signed, you may receive the following error message:
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sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested
target
Note: This error message does not display for valid certificates, which are certificates that are signed by
Certificate Authorities.
To use a server with a self-signed certificate, you need to perform the following steps:
1. Download the SSL certificate from the server.
Use a browser to view the certificate and export it. For example, in Mozilla Firefox, navigate to Tools ➤
Page Info ➤ Security ➤ View Certificate ➤ Details ➤ Export.
2. Start the key- and certificate-management tool Keytool.
Keytool is part of your JRE installation, and is located in C:\Program Files\Java\jre1.6.0_07\bin.
For additional information on Keytool, see
http://java.sun.com/javase/6/docs/technotes/tools/windows/keytool.html.
3. To add the certificate to the default Java keystore on the front-end server and application server, type for
example the following command in Keytool:
keytool
-importcert
-file CERTIFICATE.crt
-keystore "C:\Program Files (x86)\Silk\SC Test Manager
2010\lib\jre\lib\security\cacerts"
You are prompted to type the password.
4. Type the default keystore password, changeit.
5. Restart the front-end server and the application server to reload the keystore.

Reports
Default Reports
Code-Change Impact Reports
The code-change impact reports enable you to perform testing-impact analysis, effort analysis, and risk analysis.
You can select classes of interest and, by applying report templates, generate reports that help you determine
the test impact that changing the selected classes will result in.
For selected classes, you can choose from report templates that analyze the test impact of proposed code
changes.
Code-Change Impact Report for Test Definitions
This report displays the following columns for each affected test definition:
•
•
•
•
•
•

Unique key: Test definition + Execution definition
Project name
Test name
Test plan hierarchy
Execution definition
Test type
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•
•
•
•
•
•
•
•
•

Duration of test
Status of test, cumulative across all runs of build range
Last build executed
# Times executed for this version
# Times passed for this version + # Times failed for this version
Coverage index: Methods covered by the test for the specified classes / total methods of specified classes.
Time stamp
Test creator
Test executor. Manual tester or execution server

Code-Change Impact Report for Execution Definitions
This report is valuable as it identifies the execution definitions that need to be re-run following code changes.
This report displays the following columns for each affected execution definition:
•
•
•
•
•
•
•
•
•
•

Project name
Execution definition name
# Manual tests
# Automated tests
# Manual tests in coverage path
# Automated tests in coverage path
Duration of manual tests
Duration of automated tests
Duration of manual tests in coverage path
Duration of automated tests in coverage path

Use Cases for Reports
The following typical code-change impact issues can be addressed with code-change impact reports:
Testing impact
analysis

You want to know which tests you should run as a result of a specific change to the
code.
•
•
•

Effort analysis

Select a particular class.
Select and execute the Code Change Impact - Test Definitions report.
Observe the list of tests that cover the classes that were touched in this version.

You want to know how many hours of automated and manual testing will be required
to properly cover a particular set of changes to the code.
•
•
•

Select a particular class .
Select and execute the Code Change Impact - Execution Definitions report.
Observe the required time (cost) for automated and manual tests.

Code Coverage Reports
This section explains the code coverage reports that ship with Test Manager. Code coverage reports offer a
detailed overview of your product's code coverage over a period of time or range of builds.
Code Coverage Trend Report
Shows the improvement trend of code coverage for methods, classes, and packages for a product over a
selected range of builds.
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Input Parameters
The input parameters for a code coverage trend report are:
Parameter

Description

product_ProductVersion

Version of the selected product.

BuildFrom

First build in the range of examined builds.

BuildTo

Last build in the range of examined builds.

General Report Information
Element

Description

Report Description

Description of the report.

Report Executed By

User who executed the report.

Product Information

Name, version, and examined build range of the selected
product.

Code Coverage Trend Graph
Shows the overall percentage of code coverage for the selected product over the selected range of builds.
Code coverage for specific packages/namespaces, classes, and methods is displayed individually.
Code Coverage Trend Details
Displays the information from the Code Coverage Trend Graph in a tabular format.
Method Coverage Comparison Report
Compares method coverage for all included packages/namespaces across two product builds.
Input Parameters
The input parameters for a method coverage comparison report are:
Parameter

Description

Build 1

Number of the first build that is to be compared.

Build 2

Number of the second build that is to be compared.

Product

The examined product.

Threshold

The minimum amount of change that results in a package/namespace appearing
in the report. Packages/namespaces with a smaller percentage of change are
not shown in the report. The threshold range is from 0 to 100 percent.

General Report Information
Element

Description

Project Name

Name of the project.

Report Description

Description of the report.

Report Executed By

User who executed the report.

Product

Name of the selected product.
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Element

Description

Build 1

Number of the first build to be compared.

Build 2

Number of the second build to be compared.

Method Coverage Information
The method coverage table shows the following information for all packages/namespaces that have changes
in method-coverage percentage that are bigger than the threshold:
Element

Description

Package Name

Name of the package.

Statements

Number of statements that are included in the package.

% Method Coverage

Percentage of method coverage in the second build.

% Difference

Difference in the code coverage percentage from the first build to the
second build. The difference is negative when code coverage drops.

Context-Sensitive Reports
The Requirements, Test Plan, and Execution units offer dynamically-generated lists of reports that are
specific to each unit. Context-sensitive report lists are helpful because they offer report types that relate directly
to your current activities.
Requirements unit

Context-sensitive report lists in the Requirements tree offer all reports that take
requirement ID as an input parameter.

Test Plan unit

Context-sensitive report lists in the Test Plan tree offers all reports that take
test-definition ID as an input parameter.

Execution unit

Context-sensitive report lists in the Execution Definition tree offer all reports that
take execution-definition ID as an input parameter. On the execution-definition Runs
tab, context-sensitive report lists offer all reports that have the following configuration:
•
•
•

Result category = Execution Definition
Selection criteria = Execution Definition Run
Property = ID

When you select a report from a context-sensitive report list, you are taken directly to that report's default tab
in the Reports unit. This default destination-tab behavior can be configured using each report's Edit Report
dialog box.
There are two types of reports that appear in the context-sensitive report lists: reports that you have already
accessed and reports that you have not yet accessed. Reports that you have accessed previously appear
above a line separator in the menu. These reports are listed chronologically with the most recently viewed
report at the top of the list. Other default reports that are available, but have not yet been accessed, appear
beneath the line separator.
In addition to the default-configured context-sensitive reports, you can configure new and existing reports to
be included in each unit's context-sensitive report list. Context sensitivity is added to reports on a per-user,
per-report basis only.
Accessing Context-Sensitive Execution Reports
Note: Reports must be enabled as context-sensitive reports to make them available in the Executions
unit.
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To access a context-sensitive execution-definition report:
1. Navigate to Test Manager ➤ Execution.
2. Right-click an execution definition in the Executions tree and choose Reports.
3. Select a report from the Reports sub-menu.
You are taken to the Parameters page of the selected report in the Reports unit where the ID of the
execution definition is pre-populated as a value.
Note: You can configure this destination-tab linking behavior by using each report's Edit Report dialog
box.
4. Edit the parameters of the report as required.
5. Complete configuration of the report on the Data, Report, or Chart page.
Accessing Context-Sensitive Execution-Definition-Run Reports
Note: Reports must be enabled as context-sensitive reports to make them available in the Executions
unit.
To access a context-sensitive execution-definition-run report:
1. Navigate to Test Manager ➤ Execution.
2. Click the Runs tab.
3. Right-click a run and choose Reports.
4. Select a report from the Reports sub-menu.
You are taken to the Parameters page of the selected report in the Reports unit where the ID of the run
is pre-populated as a value.
Note: You can configure this destination-tab linking behavior by using each report's Edit Report dialog
box.
5. Edit the parameters of the report as required.
6. Complete configuration of the report on the Data, Report, or Chart page.
Accessing Context-Sensitive Requirements Reports
Note: Context-sensitive reports are available in the Requirements unit only for those reports that accept
a requirement ID as an input parameter.
To access a context-sensitive requirements report:
1. Navigate to Test Manager ➤ Requirements.
2. Right-click a requirement in the Requirements tree and choose Reports.
3. Select a report from the Reports sub-menu.
You are taken to the Parameters page of the selected report in the Reports unit where the requirement's
ID is pre-populated as a value.
Note: You can configure this destination-tab linking behavior by using each report's Edit Report dialog
box.
4. Edit the parameters of the report as required.
5. Complete configuration of the report on the Data, Report, or Chart page.
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Accessing Context-Sensitive Test-Definition Reports
Note: Context-sensitive reports are available in the Test Plan unit only for those reports that accept a
test-definition ID as an input parameter.
To access a context-sensitive test-definition report:
1. Navigate to Test Manager ➤ Test Plan.
2. Right-click a test definition in the Test Plan tree or the Test Plan Grid View and choose Reports.
Note: When multi-selecting test definitions in the Test Plan Grid View, the context-sensitive reporting
is disabled.
3. Select a report from the Reports sub-menu.
You are taken to the Parameters page of the selected report in the Reports unit where the ID of the test
definition is pre-populated as a value.
Note: You can configure this destination-tab linking behavior by using each report's Edit Report dialog
box.
4. Edit the parameters of the report as required.
5. Complete configuration of the report on the Data, Report, or Chart page.
Enabling Context-Sensitive Execution Reports
Explains how to enable execution-definition and execution-definition-run reports to be displayed in
context-sensitive report lists.
To enable a simple report to be displayed in context-sensitive report lists in the Execution tree or the Runs
page:
1. Create a new report.
For additional information, see Creating New Reports.
2. Select Execution Definition from the Result category list box.
3. Select the Selection criteria for the context-sensitive report.
4. Select ID from the Property list box.
5. Type a value in the Value text box.
For example, the ID number of an existing execution definition or an existing execution-definition run.
6. Click Finish.
Enabling Advanced Context-Sensitive Execution Reports
To enable an advanced report to be displayed in context-sensitive report lists in the Execution tree or on the
Runs page:
1. Create a report that includes one of the following:
•
•

An execution-definition ID as an input parameter for the report to be displayed in the Execution tree.
An execution-definition-run ID as an input parameter for the report to be displayed on the Runs page.

For additional information, see Creating New Reports and Writing Advanced Queries with SQL.
2. To make an advanced query available in the context menu of the Executions unit, insert the parameter
name execProp_Id_0 as input for ExecDef_ID_pk_fk.
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For example, your report's SQL statement might have defined a hard-coded database-column value, such
as ExecDef_ID_pk_fk = 68. To edit this report so that it receives column-name values dynamically,
replace the static value of 68 with ${execProp_Id_0 | 68}.
Note: For additional information about tables and column-name definitions, refer to the Test Manager
Database Model Help.
Enabling Context-Sensitive Requirement Reports
Explains how to enable requirements reports to be displayed in the context-sensitive report list.
To enable a simple report to be displayed in the context-sensitive report list of the Requirements unit:
1. Create a new report.
For additional information, see Creating New Reports.
2. Select Requirement from the Result category list box.
3. Select the Selection criteria for the context-sensitive report.
4. Type a value in the Value text box.
For example, the ID number of an existing requirement.
Enabling Advanced Context-Sensitive Requirement Reports
To enable an advanced report to be displayed in context-sensitive report lists in the Requirements unit:
1. Create a report that includes a requirement ID as an input parameter.
For additional information, see Creating New Reports and Writing Advanced Queries with SQL.
2. To make an advanced query available in the context menu of the Requirements unit, insert the parameter
name reqProp_Id_0 as input for Req_ID_pk_fk.
For example, your report's SQL statement might have defined a hard-coded database-column value, such
as Req_ID_pk_fk = 68. To edit this report so that it receives column-name values dynamically, replace
the static value of 68 with ${reqProp_Id_0 | 68}.
Note: For additional information about tables and column-name definitions, refer to the Test Manager
Database Model Help.
Enabling Context-Sensitive Test-Plan Reports
Explains how to enable test-plan reports to be displayed in the context-sensitive report list.
To enable a simple report to be displayed in the context-sensitive report list of the Test Plan unit:
1. Create a new report.
For additional information, see Creating New Reports.
2. Select Test Definition from the Result category list box.
3. Select the Selection criteria for the context-sensitive report.
4. Type a value in the Value text box.
For example, the ID number of an existing test definition.
Enabling Advanced Context-Sensitive Test Plan Reports
To enable an advanced report to be displayed in context-sensitive report lists in the Test Plan unit:
1. Create a report that includes a test definition ID as an input parameter.
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For additional information, see Creating New Reports and Writing Advanced Queries with SQL.
2. To make an advanced query available in the context menu of the Test Plan unit, insert the parameter name
tdProp_Id_0 as input for TestDef_ID_pk_fk.
For example, your report's SQL statement might have defined a hard-coded database-column value, such
as TestDef_ID_pk_fk = 68. To edit this report so that it receives column-name values dynamically,
replace the static value of 68 with ${tdProp_Id_0 | 68}.
Note: For additional information about tables and column-name definitions, refer to the Test Manager
Database Model Help.

Execution Reports
This section explains the execution reports that ship with Test Manager. To ease the assessment of results,
execution reports give you a detailed overview of the progress of your test executions and the status of defects,
over a period of time, or over a range of builds.
Execution Definition Run Comparison Reports
Execution-definition run-comparison reports present an overview of the comparison between two
execution-definition runs.
Note: Run-comparison reports are not suitable for the comparison of manual tests to automated tests.
When the name of the report includes (Last Two Runs), you can compare only the last two runs of the
execution definition or test definition.
The following reports compare two execution-definition runs:
Report Name
Execution Definition Run Comparison Report

Description
The default execution-definition run-comparison report
that compares two execution-definition runs.

Execution Definition Run Comparison Report
Compares only the failed tests of two execution-definition
– Failed in Newer Run
runs.
Execution Definition Run Comparison Report
Compares only those tests of two execution-definition
– Changed Status
runs, that changed their statuses.
The execution-definition run-comparison report provides the following information:
•
•
•
•
•

Changes to the status of the execution definitions
Number of errors
Number of warnings
Context in which the execution definitions were executed
Execution duration of the assigned tests
Note: When the status of an assigned test changes to Failed between compared runs, the test is marked
red. When the status of an assigned test changes to Passed between compared runs, the test is marked
green.

General Report Information
This section provides the following general information about the report:
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Element

Description

Project Name

Name of the active project.

Report Description

Description of the report.

Report Executed By

User who executed the report.

Execution Definition Run Comparison
This section identifies the following differences between the two runs:
Element

Description

ID

Identifier of the execution definition.

Name

Name of the execution definition.

Start Time

Execution time of each run.

Duration

Duration of each run.

Run ID

ID of each execution definition run.

Product

Name of the product specified for the run.

Version

Version of the product specified for the run.

Build

Build of the product specified for the run.

Status

Status of each execution-definition run.

Test Definition Run Comparison
This section provides the following details about the test definitions assigned to each execution definition run:
Element
ID
Name
Status
Duration
Errors
Warnings

Description
ID of each test definition.
Name of each test definition.
Status of each test definition in each execution-definition run.
Duration of each test definition in each execution-definition run.
Number of errors of each test definition in each execution-definition run.
Number of warnings of each test definition in each execution-definition run.
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Execution Definition Run Errors Report
The Execution Definition Run Errors report provides a detailed list of all test definitions that did not pass an
execution-definition run and the reason they did not pass. All errors that occured during the execution-definition
run are listed in this report. The user can quickly assess results and easily identify any unwanted effects in the
execution-definition run.
Input Parameters
The input parameter for an Execution Definition Run Errors report is the identifier of the execution-definition
run.
General Report Information
This section provides the following general information about the report:
Element
Project Name
Report Description
Report Executed By

Description
Name of the active project.
Description of the report.
User who executed the report.

Execution Definition Information
This section provides the following information about the execution definition:
Element
Execution Definition ID
Execution Definition Name
Run ID
Product
Version
Build
Execution Server
Keywords
Execution Timestamp
Duration
Status
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Description
Identifier of the execution definition.
Name of the execution definition.
Identifier of the execution-definition run.
Name of the product specified for the execution-definition run.
Version of the product specified for the execution-definition run.
Build of the product specified for the execution-definition run.
Execution server where the execution definition was run.
Keywords assigned to the execution-definition run.
Time and date of the execution-definition run.
Duration of the execution-definition run.
Status of all test definitions assigned to the execution definition.

Test Definition Runs
This section provides the following information about each test definition run that did not pass:
Element

Description

ID

Identifier of the test definition.

Name

Name of the test definition.

Duration

Duration of the test definition run.

Errors

Amount of errors that occured during the test definition run.

Warnings

Amount of warnings that occured during the test definition run.

Messages

If there are messages available, the content of the Messages page of the
Test Definition Run Dialog is shown here.

Not Passed Test Definitions Report
The Not Passed Test Definitions Report presents an overview of all not-passed tests of a folder or project in
the Execution unit. You can use this report for error analysis, for example during configuration testing.
Input Parameters
The input parameter for a Not Passed Test Definitions Report is the identifier of the configuration suite, folder,
or project.
General Report Information
This section provides the following general information about the report:
Element

Description

Project Name

Name of the active project.

Report Description

Description of the report.

Report Executed By

User who executed the report.

Specific Information for Each Test Definition
For each test definition, the report provides a grid with an entry for each execution definition in context of which
the test definition is not passed. Click on the name of the test definition to view the Runs page of the test
definition in the Test Plan unit. The grid includes the following columns:
Column
ID
Execution Definition

Description
Identifier of the execution definition.
Name of the execution definition. Click to view the runs of the execution definition
in the Execution unit.
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Column
Status

Run ID

Description
The status of the last run of the test definition in the context of the execution
definition. For data-driven test definitions or test packages, the status is displayed
as a bar graph.
Identifier of the last run of the test definition. Click to view the results of the run in
the Test Definition Run Results dialog box.

Not Passed Test Definitions per Execution Definition Report
The Not Passed Test Definitions per Execution Definition Report presents an overview of all not-passed tests
per configuration of a configuration suite, or per execution definition of a folder or project in the Execution
unit. You can use this report for error analysis, for example during configuration testing.
Input Parameters
The input parameter for a Not Passed Test Definitions per Execution Definition Report is the identifier of the
configuration suite, folder, or project.
General Report Information
This section provides the following general information about the report:
Element

Description

Project Name

Name of the active project.

Report Description

Description of the report.

Report Executed By

User who executed the report.

Specific Information for Each Execution Definition
For each configuration or execution definition, the report provides a grid with an entry for each test in the
configuration or execution definition. Click on the name of the configuration or execution definition to view the
Properties page of the configuration or execution in the Execution unit. The grid includes the following columns
:
Column
ID
Test Definition

Status

Run ID
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Description
Identifier of the test definition.
Name of the test definition. Click to view the runs of the test definition in the Test
Plan unit.
The status of the last run of the test definition in the context of the execution
definition. For data-driven test definitions or test packages, the status is displayed
as a bar graph.
Identifier of the last run of the test definition. Click to view the results of the run in
the Test Definition Run Results dialog box.

Execution Status Overview Report
The Execution Status Overview report presents an overview of the execution status of the selected node and
all execution definitions below the node.
Input Parameters
The input parameter for a Execution Status Overview report is the identifier of the node in the Execution tree.
General Report Information
This section provides the following general information about the report:
Element

Description

Project Name

Name of the project that includes the selected node.

Report Description

Description of the report.

Report Executed By

User who executed the report.

Overall Status Information
Provides an overview, including the aggeregated status, of the selected node and all execution definitions
below the node.
Element

Description

Name

Name of the selected Execution tree node.

Execution Definitions

Amount of execution definitions that are that are below the selected node and
were executed.

Test Definitions

Amount of test definitions that are assigned to the execution definitions below
the selected node.

Status

Duration

The aggregated status of the last run of the execution definitions below the
selected node. The status is displayed as a bar graph.
Accumulated duration of the last run of the execution definitions below the
selected node.

Status of Execution Definitions
Provides detailed information on the execution status of the individual execution definitions, including the
selected node, that are below the selected node. Can include multiple tables, if the selection includes multiple
parent tree nodes.
Column

Description

Name

Name of the execution definition. Click to view the properties of the execution
definition in the Execution unit.

Test Definitions

Amount of test definitions that are assigned to the execution definition.

Status

The status of the last run of the execution definition.

Product

Name of the product that the execution definition is assigned to.

Version

Version of the product that the execution definition is assigned to.

Build

Build of the product that the execution definition is assigned to.
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Column

Description

Start Time

Date and time the last run of the execution definition started.

Duration

Duration of the last run of the execution definition.

Issues Per Component Report
The Issues Per Component report offers an overview of all issues related to each component. In addition to
offering basic issue tracking, this report assists in monitoring the overall issue trend for each component.

Performance Trend Reports
This section explains the performance trend reports that ship with Test Manager. Performance trend reports
show the evolution of the application under test's performance over a specified period of time. The input data
for the performance reports is provided by SilkPerformer load tests.
Average Page-Time Trend Report
Shows the page times per page for all tests executed for the specified test definition within the specified time
range. The performance trend of the page times for the tested pages is shown in a graph.
Input Parameters
The input parameters for an Average Page-Time Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included in the
report. Use this setting to avoid that outliers skew the trend curve.

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction busy-times
that exceed this value are cut off at the top. This setting is useful to prevent
the flattening of lines caused by outliers.

Measure Filter

Shown measures are limited to those including the specified string in their
name. This field has to be filled out. To display all available measures, set
the measure filter to %. For example, to show only measures that include
the word "unit" at any position in their names, set the measure filter to
%unit%.

Test Definition ID

Identifier of the test definition for which you want to view the report.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.

418

| SilkCentral Test Manager 2010 R2

Page Time Trend Information
The trend charts show the page time trend over the selected time range for all filtered measures. The minimum,
maximum, and average page time curves are shown in each chart. The displayed values in each chart are cut
at the selected maximum y-axis value.
Average Transaction Busy-Time Trend Report
Shows the transaction busy time per transaction for all tests executed for the specified test definition within
the specified time range. The performance trends of the transaction busy-times for the tested transaction are
displayed in trend charts.
Input Parameters
The input parameters for an Average Transaction Busy-Time Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included in the
report. Use this setting to avoid that outliers skew the trend curve.

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction busy-times
that exceed this value are cut off at the top. This setting is useful to prevent
the flattening of lines caused by outliers.

Test Definition ID

Identifier of the test definition for which you want to view the report.

Transaction Filter

Shown transactions are limited to those including the specified string in
their name. This field has to be filled out. To display all available
transactions, set the transaction filter to %. For example, to show only
transactions that include the word "unit" at any position in their names, set
the transaction filter to %unit%.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Transaction Busy-Time Trend Information
The trend charts show the transaction busy-time trend over the selected time range for all filtered transactions.
The minimum, maximum, and average transaction busy-time curves are shown in each chart. The displayed
values in each chart are cut at the selected maximum y-axis value.
Custom Measure Trend Report
Shows the average, minimum, and maximum values of the defined measure or measures for all tests executed
for the specified test definition within the specified time range. The performance trend of the values for each
tested measure is shown in a graph.
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Input Parameters
The input parameters for a Custom Measure Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included in
the report. Use this setting to avoid that outliers skew the trend curve.

Maximum Value for y-Axis

Measure Name

Measure Type

Test Definition ID

Limits the y-axis of the graph to the specified value. Measures that
exceed this value are cut off at the top. This setting is useful to prevent
the flattening of lines caused by outliers.
Name of the custom measure for which you want to view the report.
For example CreateTestDefinition.
Type of the custom measure. For example
Transaction(BusyTime)[s].
Identifier of the test definition for which you want to view the report.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Custom Measure Trend Information
The trend chart shows the performance trend over the selected time range for the selected measure. The
minimum, maximum, and average measure curves are shown in the chart. The displayed values in the chart
are cut at the selected maximum y-axis value.
Overall Page-Time Trend Report
Shows overall page times, aggregated over all user types, for all tests executed for the specified test definition
within the specified time range. The performance trend of the page times for the tested page is shown in a
graph.
Input Parameters
The input parameters for an Overall Page-Time Trend report are:
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Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.
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Parameter

Description

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included
in the report. Use this setting to avoid that outliers skew the trend
curve.

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction
busy-times that exceed this value are cut off at the top. This setting is
useful to prevent the flattening of lines caused by outliers.

Test Definition ID

Identifier of the test definition for which you want to view the report.

General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Overall Page-Time Trend Information
The trend chart shows the overall page-time trend over the selected time range for all pages. The minimum,
maximum, and average overall page-time curves are shown in the chart. The displayed values in the chart
are cut at the selected maximum y-axis value.
Overall Transaction Busy-Time Trend Report
Shows overall transaction busy-time, aggregated over all user types, for all tests executed for the specified
test definition within the specified time range. The performance trend of the transaction busy-times for the
tested transaction is displayed in a trend chart.
Input Parameters
The input parameters for an Overall Transaction Busy-Time Trend report are:
Parameter

Description

Date From (DD-MON-YYYY)

Starting date for the time range. For example 06-DEZ-2008.

Date To (DD-MON-YYYY)

End date for the time range. For example 16-JAN-2009.

Exclude Runs with more than
<nnn> Errors

Runs that generate more errors than specified here are not included
in the report. Use this setting to avoid that outliers skew the trend
curve.

Maximum Value for y-Axis

Limits the y-axis of the graph to the specified value. Transaction
busy-times that exceed this value are cut off at the top. This setting is
useful to prevent the flattening of lines caused by outliers.

Test Definition ID

Identifier of the test definition for which you want to view the report.
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General Report Information
Lists overview information like the name of the current project, the report description, and the user who executed
the report.
Test Definition Information
Lists general information about the test definition.
SilkPerformer Project Information
Lists general information about the SilkPerformer project that is used to perform the load test.
Overall Transaction Busy-Time Trend Information
The trend chart shows the overall transaction busy-time trend over the selected time range for all transactions.
The minimum, maximum, and average transaction busy-time curves are shown in the chart. The displayed
values in the chart are cut at the selected maximum y-axis value.

Project Overview Report
Test Manager ➤ Projects ➤ Overview
The Project Overview Report contains a high-level overview of the status of the selected project.

Requirements Reports
This section describes the requirements-related reports that ship with Test Manager. Requirements reports
detail the status of functional requirements, for example compatibility requirements, GUI requirements, or
feature requirements, which must be met during development. Requirements may also relate to product
management objectives such as reliability, scalability, and performance.The requirement-management reports
help managers to determine if adequate test coverage is established to verify that system requirements are
met during development. When a report references a requirement that includes HTML-formatted content, that
content is rendered in the report.
Status Reports
The following status reports are available for the Requirements unit:
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Report

Description

Requirements Status
Overview

Represents a grouped summary of all requirements by current requirement
coverage. Coverage is expressed by the statuses Passed, Failed, Not
Executed, and Not Covered.

Top-Level Requirement
Coverage

Represents a listing of all top-level requirements. For each requirement the
number of covered and not-covered, by test definitions, child requirements is
displayed.

Status of Requirements
with Priority Higher than
'X'

Represents a summary of all requirements by current requirement coverage.
The returned group of requirements is restricted by the Priority parameter,
which specifies the lowest requirement priority that is considered in the data.

Requirement Impact
Analysis Report

Displays the test definition details grouped by the execution definition that is
associated to the requirement. This report allows the user to gain insight into
testing assets that may be impacted by a change to the requirement. The report
contains the name, status, date/time of last execution, manual testers, planned
time, and issues of each test definition. The following statuses are used:
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Report

Project Requirement
Traceability Report

Description
Status

Description

Passed

The test definition passed.

Failed

The test definition failed.

Not Scheduled

The test definition is associated to a requirement but
is not submitted for execution.

Not Executed

The test definition is associated to a requirement and
is submitted for execution but not executed yet.

Displays all requirements in a project along with their associated test definitions
and issues. The following statuses are used:
Status

Description

Passed

The test definition passed.

Failed

The test definition failed.

Not Scheduled

The test definition is associated to a requirement but
is not submitted for execution.

Not Executed

The test definition is associated to a requirement and
is submitted for execution but not executed yet.

Progress Reports
The following progress reports are available for the Requirements unit:
Report

Description

Requirements Coverage Across Builds Represents a summary of all requirements by current requirement
'X' and 'Y'
coverage. The returned group of requirements is restricted by the
Priority parameter, which specifies the lowest requirement
priority that is considered in the data.
Requirements Coverage Over the Past Represents a trend in requirements coverage by considering overall
'X' Days
requirements coverage over 'X' days.
Specific Requirements Coverage Over Represents a trend in requirements coverage by considering specific
the Past 'X' Days
requirements coverage over 'X' days.
Document Reports
The following document reports are available for the Requirements unit:
Report

Description

All Requirements

All requirements are represented with full requirement information.

Requirement with Child
Requirements

The selected requirement is shown with its requirement ID. Full details
regarding the requirement’s child requirements are displayed.

All Related Issues Report
The All Related Issues report provides a detailed list of all issues related to the assigned test definitions for a
requirement, and explains the relationship between requirements, the assigned test definitions, and issues
that have occurred.
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Input Parameters
The input parameter for the All Related Issues report is the identifier of the requirement.
General Report Information
This section provides the following general information about the report:
Element

Description

Project Name

Name of the active project.

Report Description

Description of the report.

Report Executed By

User who executed the report.

Requirement Information
This section provides the following information about the requirement:
Element

Description

ID

Identifier of the requirement.

Name

Name of the requirement.

Description

Description of the requirement.

Test Coverage

Status of all test definitions that have been assigned to the requirement.

Nr. of Issues

Amount of issues related to the requirement or sub-requirements of the
requirement.

Related Issues
Shows all issues related to the requirement or sub-requirements of the requirement in tabular form. The table
provides the following information for each issue:
Column

Description

ID

Identifier of the issue. If an identifier is provided by the issue tracking system,
this external identifier is used. The identifier is clickable if an external link is
defined for the issue.

Synopsis

Meaningful short-description of the issue.

Status

Current status of the issue. If the status is provided by the issue tracking system,
this external status is used.

Assigned by

Person who assigned the issue to the test definition.

Test ID

Identifier of the test definition in which the issue was discovered.

Test Definition

Name of the test definition in which the issue was discovered.

Test Plan Reports
This section explains the test-plan-related reports that ship with Test Manager. Test plan reports give you an
overview of the progress of your test definitions and the status of defects over a period of time or over a range
of builds.
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Status Reports
The following status reports are available for the Test Plan unit:
Report

Description

Test Definition Status Overview

Represents a status overview of all test definitions, structured by the
statuses Passed, Failed, Not Executed, and Not Scheduled.

Test Definition Status Overview (per Represents a status overview of all test definitions contained in a
test container)
specific test container, structured by the statuses Passed, Failed,
Not Executed, and Not Scheduled.
Test Definitions per Component

Represents an overview of coverage of components by test definition;
makes it easier to see where testing activity is needed.

Test Definitions (per test container) Represents a success rate for each test container by listing the
number of passed test definitions.
Implemented Test Definitions (per
component)

Represents an overview of coverage of components by test definitions
that have the Implemented attribute set to Yes.

Failed Test Definitions (per
component)

Represents an overview of failed test definitions per component;
makes it easier to identify the most critical components in the
environment.

Quality Goals Planning Report
Test Manager ➤ Reports ➤ Test Plan ➤ Status Report
Represents the number of tests in each goal criteria along with the planned time rolled up to the goal criteria.
Note: The planned time value is only for manual tests. Automated tests do not have planned time.
This report is split three ways for each quality goal defined in a project:
•
•
•

Testing Scope - compares the total number of tests available against the total number or required tests
for each item in a quality goal.
Required Planned Time - compares the required planned time among the items in the quality goals.
Value table - lists all of the quality goal items along with related metrics: Tests Available, Goal (%), Tests
Required, and Planned Time for Manual Tests.
Note: For a multi select attribute/property, the test will be counted for each matching occurrence.

Quality Goals Execution Report
Test Manager ➤ Reports ➤ Test Plan ➤ Status Report
Visually displays the number of tests executed for each item of each goal. This report is split into two sections
for each quality goal defined in a project:
•
•

Execution Status Graph - lists each quality goal item with a color-coded execution status and summary
value.
Value table - lists all of the quality goal items as well as their execution metrics: Passed, Failed, Not
Executed, Not Scheduled, Total, Test to Meet Goal, and Execution % to Goal.

Progress Reports
The following progress reports are available for the Test Plan unit:
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Report

Description

Test Definition Progress Across
Builds 'X' and 'Y'

Represents a trend in test definition progress resulting from viewing
test definition statuses in context with builds. The user must specify
a build range consisting of a start- and an end-build.

Manual Test Coverage since Build
<x> (cumulative)

Represents a trend in manual test definition progress, excluding all
kind of automated tests, resulting from viewing test definition statuses
in context with builds. The user must specify a starting buildnumber
which is used as basis for calculating a cumulative progress.

Automated Test Coverage for Builds Represents the automated test-definition coverage resulting from
(non-cumulative)
viewing test definition statuses in context with builds. The user must
specify a version and a product and the report shows the test
coverage that could be achieved with the automated tests per build.
Test Definition Progress this Month Represents a trend in test definition progress resulting from viewing
test definition statuses for the current month.
Specific Test Plan Node Progress
Over the Past 'X' Days

Represents a trend in requirements coverage by considering a
specific test plan node over the past 'X' days.

Test Definitions Created in the Past Represents a listing of new test definitions per component over the
'X' Days (per component)
past 'X' days. Assists in identifying components that lack testing
activity.
Test Definition Progress Over the
Past 'X' Days

Represents a trend in test definition progress by considering test
definition statuses over the past 'X' days.

Percentage Testing Success Over
the Past 'X' Days (per component)

Represents a percentage listing of successful test definitions per
component over the past 'X' days; assists in identifying the
components in the environment that are most critical.

Manual Test Reports
The following manual-test reports are available for the Test Plan unit:
Report

Description

Planned vs. Actual Execution Time of Represents an overview of the deviation between planned and
Manual Tests (Summary)
actual time for execution of manual tests, viewed on a daily basis.
Historic Planned vs. Actual Execution Represents an overview of planned and actually required execution
Time (per user)
time for completed manual test definitions per user over a specific
period of time.
Planned vs. Actual Execution Time
(status per user)

Represents progress in terms of planned vs. actual hours of
currently pending manual test definitions per user. Manual test
definitions are only considered if test results have been entered by
the user and are assigned to the user who enters the results.

Manual Test Definition Result
Document

An easily printable manual test case result report for a single test
definition.

Manual Test Definition Document

An easily printable manual test case report for a single test
definition.

Baseline Comparison Report
Test Manager ➤ Reports ➤ <Active Project> ➤ Test Plan ➤ Baseline Comparison ➤ Baseline
Comparison
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The Baseline Comparison report compares a baselined project with the baseline and displays the number of
changed, deleted, and created test definitions.
Input Parameters
The input parameters for the Baseline Comparison report are the identifiers of the project and the baseline.
General Report Information
This section provides a description of the report and the name of the user who executed the report.
Project and Baseline Information
This section provides the information on the project and the baseline, including data related to the creation of
the baseline.
Project and Baseline Summary
This section provides a sum of the created, changed, and deleted test definitions in the baseline and the project,
in both tabular and graphical form.
Changes
This section provides a detailed list of all changed test definitions in the project and the baseline, with links to
the test definitions.
Test Definition Run Comparison Report
Test-definition run-comparison reports present an overview of the comparison between two runs of a test
definition.
Note: Run-comparison reports are not suitable for the comparison of manual tests to automated tests.
When the name of the report includes (Last Two Runs), you can compare only the last two runs of the
execution definition or test definition.
The test-definition run-comparison report provides the following information:
•
•
•
•
•
•
•
•

Changes to the status of the test definition
Number of errors
Number of warnings
Context in which the test definition was executed
Execution duration of the assigned tests
Attributes and properties of the test definition
Parameters of the test definition
Success conditions for the test definition

General Report Information
This section provides the following general information about the report:
Element
Project Name
Report Description

Description
Name of the active project.
Description of the report.
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Element
Report Executed By

Description
User who executed the report.

Test Definition Information
This section provides the following information about the test definition:
Element
ID
Name
Description

Description
Identifier of the test definition.
Name of the test definition.
Description of the test definition.

Execution Information
This section provides the following information about each execution:
Element
Execution Definition ID
Execution Definition Name
Run ID
Product
Version
Build

Description
ID of each execution definition.
Name of each execution definition.
ID of each execution definition run.
Name of the product.
Version of the product.
Build of the product.

Test Definition Run Comparison
This section identifies the following differences between the two runs:
Element
Status
Execution Timestamp
Duration
Errors
Warnings
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Description
Status of each run.
Timestamp of each run.
Duration of each run.
Number of errors in each test definition run.
Number of warnings in each test definition run.

Element
Previous Status
Changed by
Change Comment

Description
Status of each run previous to the last manual change.
User who performed the last manual change to the status.
Describes the reason of the manual status change.

Attributes and Properties
This section identifies the attributes and properties of the two runs of the test definition at execution time.
Parameters
This section lists the parameters of the two runs of the test definition at execution time.
Success Conditions
This section lists the conditions at execution time for each of the two runs to be considered successful. If a
condition is not satisfied, the test definition run is considered unsuccessful. Satisfied conditions are marked
green, while unsatisfied conditions are marked red.

Creating and Customizing Reports
Creating Reports
Test Manager offers reports that quickly and easily transform data into intuitive charts and graphs. Pre-installed
reports are available for the Requirements, Test Plan, and Issues units.
Reports are created using either BIRT RCP Designer, an open-source, Eclipse-based report tool, or Microsoft®
Excel® report templates. Test Manager is tightly integrated with BIRT RCP Designer to make it easy for you
to generate reports on test management data.The reporting functionality in Test Manager is highly customizable.
Numerous pre-installed reports and report templates provide out-of-the-box options for a wide range of reporting
needs. Simple GUI-based tools allow you to edit the pre-installed reports and create reports of your own. For
users with SQL knowledge, there is virtually no limit to how data can be queried and presented in custom
reports.
Tip: If a blank report is generated, the cause may be that there are not any data in the project you selected,
or you may not be connected to the appropriate Test Manager database. Reports are not available offline
unless your Test Manager database is accessible locally.
Sample Report
Below is the code of a pre-installed report called All Requirements. This report has not undergone editing using
the GUI-based tools of Test Manager or SQL. By default, this report displays all properties of all requirements
in the selected project, except those requirements that have been identified as obsolete. Obsolete requirements
are filtered out by the report’s reqProp_Obsolete_0 parameter.
SELECT r.ReqID, r.ReqParentID, r.PositionNumber, r.ProjectID, r.ProjectName,
r.ReqName,
r.Risk, r.Priority, r.ReqDescription, r.ReqCreator, r.ReqCreated, r.ReqReviewed,
r.ReqCoverageStatus,
r.ReqRevision, r.MarkedAsObsolete, r.Obsolete, r.TreeOrder
FROM RTM_V_Requirements r
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WHERE r.ReqID IN (SELECT DISTINCT ReqTreeNodeID_pk as id
FROM TM_RequirementTreeNodes rtn WITH (NOLOCK)
WHERE rtn.ProjectID_fk = 98
AND rtn.MarkedForDeletion=${reqProp_Obsolete_0|0}
AND ParentTreeNodeID_fk IS NOT NULL)
Creating New Reports
To create a new report:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the folder in which you want the new report to display.
This determines where the report is stored in the directory tree.
3.
Click
on the toolbar.
The Create New Report dialog box opens.
4. Type the name of the new report.
This is the name that is displayed in the Reports tree.
5. Check the Share this report with other users check box if you want to make this report available to other
users.
6. In the Timeout [s] field, type the maximum time period in seconds that Test Manager should wait for SQL
queries to complete.
7. From the Default tab list box, select the tab that you want to be directed to when you select this report from
one of the context-sensitive report lists.
8. Select the corresponding result type from the Result category list box.
This setting specifies the database table and view that is to be filtered for the report. The following result
types are available:
Result Type

Description

Requirement

Returns requirements available in the Requirements module that
meet the query criteria.

Test Definition

Returns test definitions available in the Test Plan module that meet
the query criteria.

Test Definition Execution

Returns executed test definition results from the Executions module
that meet the query criteria.

Execution Definition

Returns execution definitions from the execution module.

Issue

Returns issues, including imported issues.

Requirement Progress Builds

Contains information on requirements progress per build so that
you can see how requirements develop across builds.

Requirement Progress Days

The same as Requirement Progress Builds, but shows development
on a daily basis.

Test Definition Progress Builds

Shows how test definitions develop across builds.

Test Definition Progress Days

Same as above, but shows development on a daily basis.

Each result type offers a set of selection criteria. Based on the result type you have selected, specify an
appropriate Selection criteria for your report. These criteria typically group properties based on a view or
some other intuitive grouping, for example custom properties.
9. From the Property list box, select the property that is to be filtered on.
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For some selection criteria, properties are dynamic.
10. Select an Operator for the query.
The available operators depend on the property. Example operators are =, not, like, and not like.
Strings are always compared lowercase. Allowed wildcards for strings are "*" and "?", where * matches
any characters and ? matches exactly one character.
11. Select or specify the Value that the query is to be filtered on.
For date-based properties, the Value field is replaced with a calendar tool that you can use to select a
specific date.
12. Optional: To add an additional query string to this report, click More. An existing query string can be deleted
by clicking the string’s Delete button. When multiple query strings are defined, AND and OR option buttons
are displayed next to More. Use these option buttons to define if the queries should be considered
cumulatively, or if only one query string’s criteria needs to be met.
13. Click Next to configure report columns on the New Report dialog box.
14. Click Add Columns.
The Add Columns dialog box lists all available report columns.
15. Select the columns that you want to have included in the report and click OK.
You can select multiple columns with CTRL + CLICK.
Note: For test-planning reports, the list of available column names is enhanced with the column names
from the LQM_v_tests table. For details, refer to the Test Manager Database Model Help.
The selected columns display in tabular format on the New Report dialog box.
16. Optional: Configure how each report column is to be displayed. For each column, specify a sort direction,
ascending, descending, or unsorted, using the up/down arrows in the Sorting column.
17. When multiple columns are selected for sorting, a list box is displayed in the Sort Order column that allows
you to more easily edit the column-sort order. Set these numbers as required.
18. Give each column an Alias.
This is the name by which each column will be labeled in the generated report.
19. With grouping, you can take advantage of SQL aggregation features, for example when selecting a number
of elements or querying a total sum of values. Check the Group by check box to specify that SQL group
by functions are to be applied.
20. Columns that are not selected for SQL group by functions are set to aggregation by default, which means
a single aggregate value is calculated. From the Aggregation list box, select the appropriate aggregation
type.
The following types are available:
•
•
•
•
•

Count
Sum
Average
Minimum
Maximum

21. The Actions column enables you to move column listings up and down in the view, or to delete a column.
The Move Up and Move Down functions do not affect the outcome of the report.
22. Click Finish to complete your new report.
SQL Functions for Custom Reports
To assist in writing advanced queries, placeholders are available for each function. Function placeholders are
replaced with SQL code upon execution. Functions are used like parameters, but their names have a $ (dollar
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symbol) as a prefix. Unlike parameters, placeholders are defined report elements that cannot be customized
per execution.
The following table lists all available function placeholders:
Function

What it does

$TODAY

Returns the current systemdate on the CreatedAt > ${$TODAY}
database server. You can also write
$TODAY-1 for yesterday or
$TODAY-7 for a week ago.

$DATE(column)

Returns the date but not the time.

$DATE('string')

Converts the given string to a database CreatedAt >
date.
${$DATE('01/10/2005')}

$DAYS[p1;p2]

Calculates the difference in days
between the two given parameters. The
two parameters can be a column within
the table/view or $TODAY.

$WEEK(param)

Returns the week-number of the given
parameter, which can be $TODAY or a
column.

$MONTH(param)

Returns the month of the year as a
number of the given parameter, which
can be $TODAY or a column.

$YEAR(param)

Returns the year as a number of the
given parameter, which can be $TODAY
or a column.

$USERID

The ID of the currently logged in user.

$USERNAME

The name of the currently logged in
user.

$PROJECTID

The ID of the currently selected project.

$PROJECTNAME

The name of the currently selected
project.

$REPORTNAME

The name of the currently selected
report.

$REPORTID

The ID of the currently selected report.

Example

The following example returns the rows
created within the last week:

${$DAYS[CreatedAt;$TODAY]}
> 7

Below is the code of the pre-installed Requirement with Child Requirements report. With this report, a selected
requirement is shown with its requirement ID. Full details regarding the requirement’s child requirements are
displayed. Although not a custom report, this report is a helpful example because it makes use of the
$PROJECTID function. It also includes two parameters, reqID (requirement ID) and reqProp_Obsolete_0 (show
obsolete requirements).
SELECT r.ReqID, r.ReqCreated, r.ReqName, r.TreeOrder
FROM RTM_V_Requirements r INNER JOIN
TM_ReqTreePaths rtp ON (rtp.ReqNodeID_pk_fk = r.ReqID)
WHERE rtp.ParentNodeID_pk_fk=${reqID|22322|Requirement ID} AND
r.ProjectID = ${$PROJECTID} AND
r.MarkedAsObsolete=${reqProp_Obsolete_0|0|Show obsolete Requirements}
ORDER BY r.TreeOrder ASC
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Writing Advanced Queries with SQL
Advanced reports can be created through manual SQL coding. Virtually any reporting option is available if you
know the database schema. Clicking Advanced Query hides the query string list boxes and opens the Report
data query text box in which you can insert existing code or write new SQL code.
One approach is to begin query-string construction using the list boxes as outlined in Creating New Reports.
If the report criteria are valid, the equivalent SQL statement will be generated and displayed, and then move
to advanced mode for further modifications.
Note: You cannot move from advanced mode back to simple mode.
To write an advanced query directly in SQL:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the folder in which you want the new report to display.
This determines where the report is stored in the directory tree.
3.
Click
on the toolbar.
The Create New Report dialog box opens.
4. Type the name of the new report.
This is the name that is displayed in the Reports tree.
5. Check the Share this report with other users check box if you want to make this report available to other
users.
6. Type a description of the report in the Description text box.
7. Click Advanced Query to open the Report data query text box. Insert previously written code as necessary,
or write new code directly in the text box.
To assist you in writing SQL queries, a list box of Test Manager function placeholders is available. For
details, see SQL Functions for Custom Reports. To insert one of the available pre-defined functions, select
the corresponding placeholder from the Insert placeholder list box.
Note: If you manually edit SQL code for the query, click Check SQL to confirm your work.
8. Once you have completed editing the report’s properties, click Finish to save your settings.

Working with Subreports
Adding Subreports
To aggregate the results from multiple reports into the currently selected report, you can add subreports. When
adding a report as a subreport, the result columns and rows of the subreport are concatenated to the results
of the selected report.
To add a report as a subreport:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Properties tab.
4. Click Add Subreport.
The Add Subreport dialog box displays.
5. From the Reports tree, select the subreport you want to append to the current report.
6. Click OK to complete the addition of the subreport.
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Subreports are displayed on the associated report’s Properties page in the Subreports section.
Deleting Subreports
To delete a subreport:
1. Navigate to Test Manager ➤ Reports.
2. Select the report in the Reports tree that has the associated subreport that you want to delete.
3. Click the Properties tab.
4.
Click
in the Actions column of the subreport that you want to delete.
5. Click Yes on the confirmation dialog box to confirm the deletion.

Report Templates
Uploading Report Templates
To upload a template from your local system:
1. Navigate to Test Manager ➤ Reports.
2. Select the report to which you want to associate the template.
3. Click the Report tab.
4. Click the Click here to upload a new report template link to open the Upload Template dialog box.
5. Give the template a meaningful Name and Description.
6. In the Projects list box, select the project to which you would like to make the template available or select
All Projects to have the template associated with all projects.
7. Click Browse to browse to and select the template on your local system.
8. Click OK to upload the template.
Downloading Report Templates
Test Manager report templates render report data into formats that meet your specific needs. Templates can
take the form of Excel spreadsheets, BIRT RCP Designer templates, XML, or CSV files. Downloading Test
Manager report templates to your local system enables you to edit them through BIRT Report Designer or
Microsoft Excel. After you download and edit a report, you can upload it to make it available to other users.
For details see the related Uploading Report Templates procedure.
To download an existing report template for editing:
1. Navigate to Test Manager ➤ Reports.
2. Select a report that utilizes the template you want to modify from the Reports tree.
3. Click the Properties tab.
4. Click the download link of the template you want to download.
The available download links are:
Link

Description

Download You receive an Excel file with a sheet named DATA that contains the data, for example in CSV format. This
Excel
template, so you can specify information in adjoining sheets, for example diagrams.
Report
Template

Download You receive the report data as an empty generic BIRT report template. The datasource is already configure
BIRT
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Link

Description

Report
Template

Download You receive the report data as a Comma Separated Values (CSV) file. Depending on your local settings, you
as CSV character. The date is also formatted based on user settings.

Download You receive the report data as XML. The advantage of this approach over CSV is that you retain all subrep
as XML of Test Manager - You can call a specific URL that offers the report data using the following format:
http://server/servicesExchange?hid=reportData&userName=<username>&passWord=<pas
of the report>&type=<csv|xml>.
5. The File Download dialog box displays. Click Save and download the report file to your local system as a
.rptdesign or .xls file, depending on the report type that you are downloading.
6. Edit the report based on your needs using either the BIRT RCP Designer, for .rptdesign files, or Excel,
for .xls files.
Removing Report Templates
To remove the template of the current report:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the report from which you want to delete a template.
3. Click the Report tab.
4.
Click
.
5. Click Yes on the subsequent confirmation dialog box.

Working with Charts
Displaying Charts
To display a chart:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree for which you want to view a chart.
3. Click the Chart tab to display the default chart.
4. To select a required chart type, click .
5. On the Select Chart Type dialog box, select a chart type from the list box.
6. Check the view properties that you want to apply to the chart.
•
•
•
•

3D view
Show horizontal grid lines
Show vertical grid lines
Show legend

7. Specify how these chart options are to be saved:

SilkCentral Test Manager 2010 R2

| 435

•
•

Click the For current user only option button to have these chart settings override the report’s standard
settings whenever the current user views this chart.
Click the As report standard option button to have these chart settings presented to all users who don’t
have overriding user settings defined. This setting does not effect individual user settings.

8. Click OK to display the new chart type.
Note: The chart configurations you define here become the defaults for this report. When standard
charts and graphs are not able to deliver the specific data that you require, or when they cannot display
data in a required format, you can customize the appearance of queried data using the Test Manager
reporting functionality. To open the current chart in a separate browser window, click
the Chart page.

at the top of

Printing Charts
To print the current chart:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Chart tab.
4. Click Print.
The chart data displays in a new window in printable format.Your system’s print dialog box is also displayed.
5. Configure print settings as necessary and click OK to print the chart.
Removing Charts
Removing a chart only removes the currently selected chart template from the selected report, it does not
remove the chart template entirely.
To remove the current chart template from the selected report:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Chart tab.
4. Click Remove chart type.
The Remove Chart dialog box opens.
5. Select one of the following:
•

Select Remove user settings (and revert to report standard) to have the current user’s chart settings
deleted along with the chart. The chart will subsequently be displayed according to the report’s standard
settings. If no standard settings have been defined, the chart cannot be displayed.
Note: This option is only available when the current user has defined specific chart settings.

•

Select Remove standard chart settings of report to have any standard settings deleted along with the
chart. User-specific settings are not affected by this option.
Note: This option is only available when standard chart settings have been defined for a report.

6. Click OK to delete the chart template. If required, you can click the <Click here to choose a chart type>
link to assign a new chart template to the selected report.
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Report Chart Page
Test Manager ➤ Reports ➤ Chart
The Chart page enables you to define charts and graphs for data analysis. The page relies on the internal
reporting engine of Test Manager to create standard charts and graphs from the data retrieved by the selected
report query.
The following standard chart types are available:
•
•
•
•
•
•

area chart
bar chart
horizontal stacked bar chart
line chart
pie chart
stacked bar chart

Four display properties are also configurable for each chart type.

Customizing Reports with BIRT
Customizing BIRT Report Templates
With BIRT RCP Designer (BIRT), you can customize the pre-installed report templates of Test Manager and
create custom report templates. For details on using BIRT, refer to the SilkCentral Administration Module Help
and the BIRT RCP Designer documentation.
To download an existing template for editing:
1. Select a report that utilizes the BIRT Report Template from Test Manager ➤ Reports.
2. Click the Properties tab.
3. Click Download BIRT report template.
You receive the report data as an empty generic BIRT report template. The datasource is already configured.
4. Once you have saved the template to your local system, modify it as required.
For detailed information on configuring BIRT report templates, refer to the SilkCentral Administration Module
Help.
5. Upload the modified report template by using the Upload link on Administration ➤ Reports ➤ Report
Templates.

Reporting Unit
Viewing Reports
Because each template expects a certain data format to produce a useful graph, not all templates can be
applied to all report queries. You will receive an error message if you attempt to generate a report through an
incompatible report template. For example, selecting the Four Values Per Row As Horizontal Bar template to
display the Requirements Status Overview report works because this particular Microsoft Excel template
requires exactly the four values, failed, passed, not executed, and not covered that the report query
delivers.
To generate a report:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the report that you want to generate.
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3. Click the Report tab.
4. Click the Select Report Template icon.
The Select Report Template dialog box opens.
5. Select the template you wish to use.
6. Click OK to display the report.
7. Optional: If necessary, select an alternate view magnification for the report from the list box.
100% is the default magnification. Other options are 50%, 75%, 150%, and 200%.

Saving Reports
How you save a report locally depends on whether you have selected a BIRT report template or an Excel
template. If you have selected an Excel template, simply click the Download Excel report template link in
the Properties page of the selected report. This will invoke Microsoft Excel on your local computer and the
report will be loaded automatically.
If you have selected a BIRT report template, use the following procedure to save the report.
To export the current BIRT report as PDF:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the report that you want to save.
3. Click the Report tab.
4.
Click
on the Report view toolbar.
5. On the File Download dialog box, click Save to save the PDF document to a location of your choice.

Bookmarking Reports
The bookmark button in the lower-right corner of the workflow bar bookmarks the currently displayed report,
including the parameters that you have set in the Parameters page. You can send bookmark URLs to other
Test Manager users, allowing them to view reports with a single click.
The bookmark URL contains the parameters, prefixed with rp_. Date values are represented as the correlating
Long values in UTC in the URL.

Viewing a Report as a PDF
To view the current report in PDF format within the report browser frame:
1. Navigate to Test Manager ➤ Reports.
2. In the Reports tree, select the report that you want to view.
3. Click the Report tab.
4.
Click
on the report view toolbar.
The report displays in PDF format.

Accessing Most Recently Used (MRU) Reports
To select a recently-viewed report:
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1. Navigate to Test Manager ➤ Reports.
2. On the Reports toolbar, expand the Last Used Reports list box.
3. Select the report that you want to view.

Reports Toolbar Functions
Test Manager ➤ Reports
The Reports toolbar provides important commands for report management. The toolbar includes the following
items:
Item

Icon

Description

New Child Folder

Enables creation of new report folders. Click New Child Folder to define
a name and optional description for a new folder. The new folder displays
as a child of the currently selected node in the Reports tree.

New Child Report

Enables creation of new reports. Click New Child Report to define a new
report using the Create New Report dialog box. A new report displays
as a child of the currently selected node in the Reports tree.

Edit

Edit a report.

Delete

Delete a report.

Cut

Cut a report and add it to the clipboard.

Copy

Copy a report to the clipboard.

Paste

Paste a report from the clipboard into the Reports tree.

Paste as Child

Paste a report from the clipboard into the Reports tree, as a subnode of
the selected node.

Move Up

Move reports up within the Reports tree.

Move Down

Move reports down within the Reports tree.

Last Used Reports

Lists the Most Recently Used (MRU) reports by date/time in descending
order. Select a report name from the list to advance to that report. Each
time a report is accessed by clicking the Data, Chart, or Report tab, that
report is added to the top of the list box. Accessing a report's Properties
or Parameters tab does not result in that report being added to the Last
Used Reports list box.
The Last Used Reports list box is empty for new users and users who
have not yet generated a report. The number of reports that displays in
this list can be configured by your administrator. Refer to the SilkCentral
Administration Module Help for details.
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Report Properties
Editing Report Properties
To edit the properties of a report:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Report tab.
4. Click the Properties tab.
5. Click Edit.
The Edit Report dialog box displays.
6. Modify the Name and Description of the report as required.
7. Ensure that the Share this report with other users check box is checked if you intend to have this report
shared with other users.
8. From the Default tab list box, select the tab that you want to be directed to when you select this report from
one of the context-sensitive report lists.
9. Specify one of the following options to indicate how the report can be edited:
Option

Description

Simple report

You can modify the selection criteria—thus changing the results of the selected
report—or you can click Advanced Query to modify the SQL query code.

Advanced report

If you have familiarity with SQL, you may edit the query code in the Report data
query text box. To assist you in editing SQL queries, a list box of function
placeholders (for example, “variables”) is available. To insert one of the available
pre-defined functions, select the corresponding placeholder from the Insert
placeholder list box.

•

Advanced report: If you have familiarity with SQL, you may edit the query code in the Report data query
field. To assist you in editing SQL queries, a list box of function placeholders, for example “variables”,
is available. To insert one of the available pre-defined functions, select the corresponding placeholder
from the Insert placeholder list box.
Note: If you manually edit the SQL code for the query, upon finishing, click Check SQL to confirm
your work.

10. Click Finish to save your changes.
Report Properties Page
Test Manager ➤ Reports ➤ Properties
The Properties page displays the basic properties of the selected report, enabling you to edit these properties
or the report templates. You can also add subreports to your reports.
The page displays the following items:
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Description

Report Name

Name of the report (customizable)

Report ID

System-defined identifier of the report

Description

A description of the report (customizable)
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Items

Description

Created On

Date the report was created. Default reports are created
when a database is created and connected to.

Created By

User who created the report. Default reports are created by
the user Admin.

Changed On

Date the report was last modified.

Changed By

User who last modified the report.

Renderer

Report template that is currently assigned to the report.

Default Tab

Tab you are directed to when you select this report from one
of the context-sensitive report lists.

Edit

Click to open the Edit Report dialog box.

Add Subreport

Click to add a subreport to the report.

Report Templates

The available pre-installed report templates are:
Link

Description

Download You receive an Excel file with a sheet named DATA that contai
Excel
can specify information in adjoining sheets, for example diagra
Report
Template

Download You receive the report data as an empty generic BIRT report t
BIRT
Report
Template

Download You receive the report data as a Comma Separated Values (C
as CSV The date is also formatted based on user settings.

Download You receive the report data as XML. The advantage of this app
as XML - You can call a specific URL that offers the report data using t

http://server/servicesExchange?hid=reportD
of the report>&type=<csv|xml>.

Report Parameters
Editing Report Parameters
To edit the parameters of a report:
1. Navigate to Test Manager ➤ Reports.
2. Select a report in the Reports tree.
3. Click the Parameters tab.
If the report has parameters defined for it, the parameters are listed here.
4. Click Edit Parameters.
The Edit Parameters dialog box displays.
5. Edit the Label or Value of the listed parameters as required.
6. From the Usage list box, select the usage type of the parameter.
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•
•
•

constant value
start time
end time

7. Click OK to save your changes.
Report Parameters Page
Test Manager ➤ Reports ➤ Parameters
The Parameters page lists customizable statement elements. Parameters can be defined any time before a
report execution by simply changing them on the Parameters page. The syntax of a parameter is:
${parametername|defaultvalue|guiname}. The defaultvalue and the guiname are optional.
Parameter-names cannot contain whitespace characters.
When a report has parameters associated with it, it is possible to edit the values of the parameters before each
report execution. Parameter values are stored in the current user context, which means edited values are
available only to the user who performs the edits. When parameter values are not specified for a given report
execution, the default values from the report definition are used.
Using the Usage list box, you can select the usage type of a parameter. The possible values are constant
value, start time, and end time. start time and end time are used for reports that query for a
specific date range.
When a report has subreports assigned to it, the parameters of those subreports are also shown in the
Parameters page and the values are stored only within the context of the selected report. For example, the
values are only used in conjunction with the current subreport configuration. When creating new reports,
parameters are the values that are defined on the Create New Report dialog box in the Selection criteria
area.

Report Data Page
Test Manager ➤ Reports ➤ Data
The Data page serves as a read-only result preview that shows the result parameters and values of the selected
report in tabular format. The first row contains meta information about the current report that comes from the
report template. Links included in the data are clickable and open the referenced location.
You can access the requirements, test definitions, or execution definitions that you query for directly from the
results list in the Data page. To do so, your query must include the column ProjectID and the respective ID
of the element that you want to link to.
ID

Description

RequID

Query for this column to enable a link to requirements on the Data page of a
report.

TestDefID

Query for this column to enable a link to test definitions on the Data page of a
report.

ExecDefID

Query for this column to enable a link to execution definitions on the Data page
of a report.

If the query's result includes both the ProjectID and either of RequID, TestDefID, or ExecDefID, using
exactly these terms as column names, the Data page will display the values in the element ID's column as a
link. If you click such a link, Test Manager will switch to that element in the tree.
Check the Show header check box to display the additional meta properties for the report, like Name, Project,
Description, and others, in tabular format in Data view.
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Note: Only the first 100 result rows are displayed by default. You can select the following alternate view
options from the list box.
•
•
•

Show all rows
Top 500 rows
Top 1000 rows

Report Page
Test Manager ➤ Reports ➤ Report
The Report page is used to display data as a formatted report. If you have not yet assigned a template for
your report, you can select one in the Report page.
A list box provides a selection of all available report templates. In addition to many system-installed templates,
any custom report templates that were uploaded from Administration ➤ Reports ➤ Report Templates are
also available here. For details on setting up and uploading custom report templates, refer to the SilkCentral
Administration Module Help.
You can also download an existing template by clicking the Properties tab, and then clicking the download
link that corresponds to the report format you are working with, Excel, BIRT, CSV, or XML. From there you
can customize the template to your needs.
Note: Reports are cached to improve the performance of reporting. Click Update to update the report
data immediately.

Test Manager 8.0 Reports
When updating from Test Manager 8.0 to the current version of Test Manager, the reports that existed in the
Test Manager 8.0 installation are displayed in the Reports unit in a folder called Reports < TM 8.2.

Filtering
Filters
Filters provide an efficient means of finding exactly the information you need, while excluding extraneous detail.
Filters highlight only those elements that are relevant to your needs, and enable you to quickly sort through
requirements, test plan elements, and execution definitions. By defining global filters, you can create complex
filter criteria that are available through out Test Manager without defining filter criteria each time you need to
filter a list.
Based on your needs, you can create new filters, edit existing filters, select filters, delete filters, or turn filtering
off at the project level. Projects do not contain any default filters. You can access and edit filters from the
toolbars int the Test Manager units and from the Settings unit.
Note: Filters are not applied to reports. The Recent Changes filter enables you to view project-wide
changes and additions that other users have made to test definitions since your last change
acknowledgement. The Show Changes/Show All toggle button and the Acknowledge button in the Test
Plan unit help you to find out what changes other users have made. Your system administrator can
configure email notifications that alert you to changes that are made to test definition settings. Email alerts
include links that take you directly to a view of recent changes.
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Global Filter Details
Global filters allow you to quickly sort through elements in a Test Manager unit, highlighting only those that
are relevant to your needs.
To view the details of a global filter, navigate to Test Manager ➤ Settings ➤ Filters, and click on the name
of the filter.
The specific Test Manager unit in which a new filter is available is defined by selecting the general filter category.
The following list shows the general filter categories:
General Filter Category

Description

Requirement

The filter will be available in the Requirements unit.

Test Definition

The filter will be available in the Test Plan unit.

Execution

The filter will be available in the Execution unit.

Depending on the general filter category, the following attribute categories are available:
Filter Category
Requirement

Test Definition

Execution

Attribute Category
•
•
•
•
•
•
•
•

Test Definition Attribute
Test Definition Parameter
Test Definition Property
SilkTest Classic Test Definition Property
Requirements Property
Requirements Coverage
Nested Test Definition Filter
Nested Requirement Filter

•
•
•
•
•
•
•
•
•
•
•

Test Definition Attribute
Test Definition Parameter
Test Definition Property
SilkTest Classic Test Definition Property
Third Party Test Definition Property
Test Plan Child Nodes
Requirements Property
Requirements Coverage
Assigned Issues
Nested Test Definition Filter
Nested Requirement Filter

•
•
•
•
•
•

Execution Property
Execution Schedule
Execution Definition Run
Execution Test Container
Execution Definition Deployment
Nested Execution

Each global filter has to have a property, an operator, and a value from the respective list boxes:
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Property

Available properties depend on the filter category. It defines the property for which you are
defining a filter setting. If you selected an attribute category, the property list includes custom
attributes to query against.

Operator

Specifies the filter operator. The operator depends on the property type. For example, if you
select a property that is based on a string field type, the available operators are = (equals
defined value), not (differs from the defined value), contains (contains the defined value
somewhere in the string), and does not contain (does not contain the defined value in
the string).

Value

The value that you want to filter out. Depending on the property type that you have selected,
values will either be strings that you can enter into the text box, or a selection of predefined
values that you can select from the list box.

Recent Changes
The Recent Changes filter enables you to efficiently view and acknowledge changes and additions that other
users have made to requirements, test definitions, or execution definitions project-wide since your last change
acknowledgement.
The two buttons at the far-right of the toolbar, the Show Changes/Show All toggle button and the Acknowledge
button, help you to find out what changes other users have made.
Note: Your system administrator can configure email notifications that alert you to changes that are made
to test definition settings. Email alerts include links that take you directly to a view of recent changes.

Creating Filters
To create a filter:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Filters tab to view the list of available filters.
3. Click New Filter.
The New Filter dialog box displays.
4. Type a Name for the new filter.
This name will be displayed in list boxes when the filter becomes available.
5. Select a Category for the new filter from the list box to make the filter available in a specific Test Manager
unit.
Category

Unit

Requirement

Requirements

Test Definition

Test Plan

Execution

Execution

6. Type a Description for the new filter.
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7. Select a category of filter criteria from the Selection criteria list box. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Definition Filter or Nested Requirements
Filter. Selecting one of these categories allows you to include an existing filter in your new filter.
8. Select a Property, Operator, and Value for the filter from the respective list boxes.
Property

Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected
an attribute category, the property list includes custom attributes to query against.

Operator

Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the following
operators are available:

Value

Operator

Description

=

The string equals the defined value.

not

The string is different than the defined value.

contains

The string contains the defined value.

not contains

The string does not contain the defined value.

Enter the value that you want to filter out. Depending on the property type that you have
selected, values will either be strings that you can enter into the text box, or a selection of
predefined values that you can select from the list box.

9. Optional: Click More if you want to add more than one filter category to the new filter. Repeat this procedure
to define new categories.
Note: If you define more than one filter category, you must define whether the categories need to be
fulfilled in addition to the existing categories (AND relationship), or if the filter returns true when one of
the filter categories is fulfilled (OR relationship). Select either AND or OR to define the filter category
relationship. You cannot define nested AND, OR relationships.
10. Optional: To remove filter categories, click Fewer. This removes the last filter category.
11. Click OK to save the new filter, or click Cancel to abort the operation.

Creating Advanced Filters
Advanced custom filters enable you to combine simple filters to create complex filters that apply multiple filter
criteria simultaneously.
To create an advanced custom filter:
1. Click the appropriate button, Execution, Requirements, or Test Plan, on the workflow bar.
2. Create a new custom filter.
For additional information, see Creating Filters.
3. Click More to display a second set of filter-parameter fields with which you can define a second set of filter
parameters.
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4. Select a logical operator for the application of the filtering queries. For example, with the operator and
filtered elements must meet both sets of criteria and with the operator or filtered elements must meet one,
but not both, of the criteria sets.
5. To delete a filter-parameter string, click .
6. To display additional filter-parameter fields and create additional filter queries, click More. To remove excess
filter-parameter sets, click Fewer.

Applying Filters
After you have created and stored a custom filter, you can apply that filter to the selected tree. Custom filters
can be applied for requirements, test definitions and execution definitions. Only elements that meet applied
filter criteria are displayed in the tree.
Note: Filtered requirements are returned in read-only form and can not be edited. The Edit Properties
button is disabled for filtered requirements.
To apply a stored filter:
1. Click the appropriate button, Execution, Requirements, or Test Plan, on the workflow bar.
2. Select the desired filter from the Filter list box on the toolbar.
3. All elements that meet the filter’s criteria are displayed.
Note: To remove filtering and display all elements, select <No Filter> from the Filter list box on the
toolbar.

Editing Filters
To edit a filter:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2.
3.
4.
5.

Click the Filters tab to view the list of available filters.
Click the name of the filter you want to edit. The Edit Filter dialog box displays.
Edit the Name and Description of the filter.
Select a category of filter criteria from the Selection criteria list box. The available categories depend on
the general filter category you have selected.
Note: You can combine filters by selecting Nested Test Definition Filter or Nested Requirements
Filter. Selecting one of these categories allows you to include an existing filter in your new filter.

6. Select a Property, Operator, and Value for the filter from the respective list boxes.
Property

Available properties depend on the filter category that you have selected in the previous
step. Defines the property for which you are defining a filter setting. If you have selected
an attribute category, the property list includes custom attributes to query against.
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Operator

Value

Specifies the filter operator. The operator depends on the property type you have selected.
For example, if you have selected a property that is based on a string field type, the following
operators are available:
Operator

Description

=

The string equals the defined value.

not

The string is different than the defined value.

contains

The string contains the defined value.

not contains

The string does not contain the defined value.

Enter the value that you want to filter out. Depending on the property type that you have
selected, values will either be strings that you can enter into the text box, or a selection of
predefined values that you can select from the list box.

7. Click OK to save the edited filter definition.

Deleting Filters
To delete a filter:
1. Navigate to Test Manager ➤ Settings.
Note: If you have not selected a project, a warning message opens, asking you to select a project.
Select the project for which you want to define the setting.
2. Click the Filters tab to view the list of available filters.
3. Click Delete Filter for the filter that you want to delete.
A confirmation dialog box displays, asking you you to confirm the deletion.
4. Click Yes to delete the selected filter or No to abort the operation.
If you click Yes, you will be returned to the filters list and the deleted filter is no longer displayed.

HTML Support for Description Text Boxes
Description text boxes in Test Manager support HTML-formatted text. HTML-formatted descriptions from other
applications, for example CaliberRM, and HTML code that is pasted directly into description text-boxes, are
also rendered by Test Manager.
HTML formatting is offered through TinyMCE, a Java-based HTML editor. The TinyMCE editor is available for
the description text boxes of the following Test Manager elements:
•
•
•
•
•
•
•
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Requirements
Test containers
Test folders
Test definitions
Test steps (Description and Expected Results)
Execution folders
Execution definitions
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Linking to External Web Pages and Images
TinyMCE's Insert/Edit HTML link function enables you to specify external Web pages and images for inclusion
in description text boxes. External Web pages are displayed in separate browser windows.
Note: Web pages and images must be hosted on publicly available Web servers. You must specify a
complete URL with a protocol when linking to external pages and images.
Linked images can be resized and repositioned using TinyMCE’s WYSIWYG functions. However, any changes
that are made to images embedded in CaliberRM requirements will not be saved to the CaliberRM server
when synchronizing. These changes will be lost. Images that are embedded in CaliberRM requirements can
however be deleted.
Note: For security reasons, TinyMCE does a cleanup when pasting HTML code into a description text
box, and only allows HTML tags that it supports. This ensures that potentially unsafe scripts cannot be
pasted into description text boxes. When HTML descriptions are included in requirements that are used
as the basis for reports, the HTML descriptions are rendered when displayed in the reports.

Available HTML-Formatting Functions
TinyMCE offers the following well-known HTML-formatting commands:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Cut, Copy
Paste, Paste as Plain Text
Undo
Redo
Text style, font, and font size settings
Bold
Italics
Underline
Text alignment (left, center, right, and justified)
Numbered list
Bullet list
Indentation (decrease and increase)
Font color
Highlight color
Insert/Edit HTML link, Remove HTML link
Insert/Edit Image
Edit HTML Source
Clear Formatting
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