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SilkCentral Administration Module 12.0
Welcome to SilkCentral Administration Module 12.0.

The SilkCentral suite of products includes the applications SilkCentral Issue Manager (Issue Manager) and
SilkCentral Test Manager (Test Manager). SilkCentral products, used individually or in combination,
support the continuous and efficient quality assurance of your software development process. The Web-
based products Issue Manager and Test Manager work together to deliver the information you require to
make informed decisions about product readiness for shipment and live posting. They provide information
on:

• Test coverage and results versus defined requirements
• Component- and system-level risk-assessment metrics
• Defect tracking and closure data

This information is vital for any person or group of people who are responsible for bringing a product or
system into production.

• Borland has contracted for support of this product to be provided by its strategic partner Micro Focus.
For support visit http://support.microfocus.com/.

• To contact Borland visit http://www.borland.com
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Getting Started
This section provides overview information on how to work with SilkCentral.

SilkCentral Architecture
SilkCentral products are based on SilkCentral Architecture, which allows for common administration of
Web-based products.

The following sections describe the SilkCentral components.

• Overview
• Front-End Server
• Application Server
• Execution Server
• Chart Server
• Database Server
• SilkMeter License Server
• Manual Testing Client

Overview

Front-End Server

The front-end server is responsible for the graphical user interface. This server is based on HTML and is
accessible from any Web browser, such as Internet Explorer or Firefox. A user sends an appropriate HTTP
request to the front-end server and receives a login page for authentication. After successful login, the user
can use the corresponding application based on the respective user rights. The front-end server can
operate as a stand-alone HTTP server, or it can be attached to a Web server, such as IIS via ISAPI filter.
The front-end server uses port 19120. For secure connections with SSL, the server also uses port 443.
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Application Server

The application server synchronizes tasks such as the distribution of schedules, control of execution
servers, and management of database configuration. These tasks require a centralized agency to ensure
the consistent, reliable behavior of the application. The application server also evaluates results, saves
them to the database, and sends alerts based on success conditions. The application server uses port
19122.

Execution Server

The execution server executes automated tests that are scheduled by authorized users. Users are
responsible for the proper configuration of execution servers and additional resources that are required for
test executions. The system allows for the installation and configuration of multiple execution servers
working independently of one another. The execution server uses port 19124. For secure connections with
SSL, the server also uses port 19125.

Chart Server

The chart server is used to generate charts that are viewed in reports. The system allows for the
configuration of a pool of chart servers. A built-in load balancing mechanism uses the pool to distribute
chart generation. The chart server is also used to generate reports and deliver them directly to the end-
user for viewing within a browser. The chart server uses port 19126.

Database Server

System persistency is implemented using a RDBMS (Relational Database Management System). The
database server uses ports 1433 and 1521.

SilkMeter License Server

SilkMeter, the licensing software that accompanies Silk products, determines the SilkCentral-application
functionality that you may access. For more information on licensing, refer to the installation guide of the
respective product. SilkMeter uses port 5461.

Manual Testing Client

The Manual Testing Client enables testers to manage their tests and track results without the need of an
Internet connection. The Manual Testing Client offers the core, manual-test execution functionality that
Test Manager provides, but through a Windows-based client tool.

Agent Computers

SilkPerformer and SilkTest Classic agent computers are assigned to particular SilkPerformer or SilkTest
Classic projects from the pool of agent computers that are available to the controller computer. In
combination with Test Manager, the controller computer acts as an execution server.

SilkPerformer
Agents

SilkPerformer agent computers host the virtual users that are run during load tests.
As many agent computers as necessary can be added to a SilkPerformer project so
that the required quantity of virtual users can be run. Configuration of agents is
done through SilkPerformer. Refer to the SilkPerformer documentation for details on
configuring agents.

SilkTest Classic
Agents

The same rules that apply to SilkPerformer agents apply to SilkTest Classic agents,
except SilkTest Classic agents host SilkTest Classic tests.

SilkCentral Test Manager 12.0
SilkCentral® Test Manager™ (Test Manager) is a powerful, all-inclusive, software test-management tool.
Test Manager builds quality and productivity into your testing process, speeding the delivery of successful
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software projects while minimizing the risks of application failures. It consolidates all the critical software-
testing phases within a single, scalable, Web-based testing system, enabling your local and distributed
software-development teams to share experiences, resources, and critical information.

SilkCentral Issue Manager
SilkCentral Issue Manager (Issue Manager), the issue-tracking tool of SilkCentral, is fully integrated with
Test Manager, enabling you to correlate issues with system requirements and executed tests.

Test issues can be added and managed in the menu through Tests > Details View > Issues. For more
information, refer to the Issue Manager documentation.

Note: StarTeam and IBM Rational ClearQuest are also supported by Test Manager “out of the box”.
Additional issue tracking systems can be configured by installing a custom plug-in. For more
information, refer to the Test Manager API Help.

Access and Licensing
SilkMeter, the licensing software that accompanies Silk products, determines the SilkCentral-application
functionality that you may access. For more information on licensing, see the respective product’s
installation instructions.

Configuring the Application Server
After installing a SilkCentral application, there are a number of initial steps that must be performed by the
system administrator before you can begin working with the software. The topics in this section describe
each of the necessary steps.

Note: You must login as an administrator to perform the actions outlined in this section.

Configuring Secure Connections with Microsoft IIS
To use SilkCentral with Secure Sockets Layer (SSL), you must first obtain a certificate from a Certificate
Authority and then apply the certificate to Internet Information Services (IIS).

Applying for a Certificate to use SSL
To apply for a certificate to use SSL:

1. Open the Internet Information Services dialog box by navigating to Start > Programs >
Administrative Tools > Internet Services Manager ( Start > Programs > Administrative Tools >
Internet Information Services (IIS) Manager in Windows 2003).

Tip: If the Administrative Tools menu is not available, navigate to Start > Settings > Control
Panel and double-click the Administrative Tools icon. Double-click the Internet Information
Services icon (Internet Information Services (IIS) Manager in Windows 2003). Here you will find
the name of your host computer and an expandable tree view.

2. Click the plus (+) symbol next to your computer’s name to expand the tree file.

3. On the Internet Information Services dialog box, right-click Default Web Site and select Properties.

Tip: If you are running Windows XP or Windows 2003, expand the Web Sites tree. Then right-
click Default Web Site and select Properties.

The Default Web Site Properties dialog box displays.
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4. Click the Directory Security tab.

5. Click Server Certificate next to the key graphic at the bottom of the Default Security dialog box.The
Welcome to the Web Server Certificate Wizard displays.

6. Click Next.

The IIS Certificate Wizard displays with options for assigning a certificate to a Web site.

7. Choose Create a new certificate and click Next.

Note: If you already have a certificate installed, this dialog box will prompt you with the question
What do you want to do with the currently installed certificate?
If this dialog box displays, skip the remainder of this section.

8. Create a new certificate.

For more information, see Creating a New Certificate to Use SSL.

Creating a New Certificate to Use SSL
Note: To create a new certificate, you first have to perform the steps described in Applying for a
Certificate to use SSL.

To create a new certificate:

1. Click Next in the IIS Certificate Wizard / Delayed or Immediate Request dialog box, or choose when
to send your request. The IIS Certificate Wizard / Name and Security Settings dialog box displays.

2. Type a name of your choice in the Name text box.

This is usually the name of the computer for which you are requesting a certificate.

3. Choose a Bit length in the appropriate text box.

You may leave the default length of 512 or choose the 1024 list box option. Choosing a higher bit length
increases security, but can also affect performance.

4. Click Next.The IIS Certificate Wizard / Organization Information dialog box displays.

5. Type the name of your Organization and the Organizational unit, for example QA, to which your
computer belongs.

6. Click Next.The IIS Certificate Wizard / Your Site’s Common Name dialog box displays.

7. Type the name of your site or computer and click Next. The IIS Certificate Wizard / Geographical
Information dialog box displays.

8. Enter geographical information relevant to the location of your computer or organization and click Next.
The IIS Certificate Wizard / Certificate Request File Name dialog box displays.

9. Type the name of the file in which your certificate is to be located and click Next. The IIS Certificate
Wizard / Request File Summary dialog box displays. All of the information you have entered is
displayed here.

10.If the information is incorrect, click Back to return and change the information. If the information is
correct, click Next to continue. The IIS Certificate Wizard Completion dialog box displays, informing
you that you have completed the wizard. This dialog box provides instructions regarding what you must
do with the file to obtain a certificate. Follow the instructions in the dialog box or ask your system
administrator for assistance.

Applying the Certificate to IIS
Once you have received a response to your certificate query and have the file in which you have stored the
certificate, you may apply the certificate to IIS. For additional information, see Applying for a Certificate to
use SSL.

To apply the certificate to the IIS:

1. Navigate to Start > Programs > Administrative Tools > Internet Services Manager ( Start >
Programs > Administrative Tools > Internet Information Services (IIS) Manager in Windows 2003).
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Tip: If the Administrative Tools menu is not available, navigate to Start > Settings > Control
Panel and double-click the Administrative Tools icon. Double-click the Internet Information
Services icon (Internet Information Services (IIS) Manager in Windows 2003).

2. Expand the tree until Default Web Site is displayed.

3. Right-click Default Web Site and select Properties.The Default Web Site Properties dialog box
opens.

4. Click the Directory Security tab in the Default Web Site Properties dialog box.

5. Click the Server Certificate option next to the key icon at the bottom of the dialog box. The Welcome
to the Web Server Certificate Wizard displays.

6. Click Next. The IIS Certificate Wizard displays with options for proceeding with a pending request.

7. Select Process the pending request and install the certificate. Click Next. The IIS Certificate
Wizard / Process the pending request dialog box displays.

8. Type the location of the Certificate Authority’s response, which is the certificate that they sent you
directly or that you received from your system administrator. Click Next.

The IIS Certificate Wizard / Certificate Summary dialog box displays with information about the
certificate.

9. Click Next to install the certificate. The IIS Certificate Wizard / Completing the Web Server
Certificate Wizard displays.

10.Click Finish to complete the process.

11.Close the Authentication by clicking OK. You may also close the Default Web Site Properties dialog
box by clicking OK.

You have now completed IIS configuration for SSL and can use SSL for secure connections to SilkCentral.

Application Server Location
The application server synchronizes tasks such as the distribution of schedules, control of execution
servers, and management of database configuration. Before you can start working with SilkCentral
applications, you need to specify the location of the application server.

Specifying a Location for the Application Server
When you use the Standard Setup option for installing a SilkCentral application, you do not need to
specify an application server location. Setup automatically configures the localhost to be the application
server. In this case you can skip this procedure. For additional information on setup options, see the
application’s installation instructions.

To specify a location for the application server:

1. Once you have installed the SilkCentral software, connect to SilkCentral using a Web browser.

Tip: If you installed ISAPI Web Server, use http://<Web-server-name>/login as the URL.
If you installed the stand-alone Web Server, use http://<Web-server-name>:19120/login
as the URL. The stand-alone Web server uses port 19120 by default.

You will receive a confirmation stating that the application server connection has not yet been defined.

2. Enter the Host or IP address and the Port of the application server.

The application server is the computer where you installed SilkCentral’s application server component.
The default port is 19122.

3. Click Login to proceed. If your specifications are correct and the respective computer is running with
the installed software, you will be returned to the login page with the message
Application server connected successfully

The Database Administration page displays.
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SilkCentral Repositories
The terms “database” and “repository” are sometimes used interchangeably, but generally a repository is
defined as a central place in which an aggregation of data is kept and maintained. The conceptual model
for SilkCentral is that of a data repository that contains the application data.

A repository is a database used by SilkCentral products to store, maintain, and analyze data. You must first
choose which database system you want to use for your repository and take the necessary steps in the
SilkCentral GUI to access the repository. You must be connected to a repository to work with SilkCentral
products.

You may set up multiple repositories, though only one repository at a time may be active.

To connect to a new SilkCentral database, you must first disconnect from the current database.

Note: You will receive error messages if you try to work with SilkCentral while the database is
disconnected.

We recommend to perform administrative tasks that require the database to be disconnected during off-
hours. If this is not possible, make sure to inform the users about the system-outage and its duration.

Note: If you are not planning on using LDAP authentication, user accounts will be stored in the
repository. If you plan to use multiple repositories, you will have to maintain separate user accounts
for each repository.

Creating a New Repository
Note: If you are currently connected to a SilkCentral repository, you must disconnect from the
repository before you can create a new repository.

To create a new repository:

1. If you have already set up your SilkCentral application server, the Database Administration page will
display in a browser window, and you can proceed to step 3 of this procedure.

Tip: Alternatively, you can browse to your SilkCentral site with a Web browser. The default URL is
http://<computer name>:<port>/login. When you use the Standard Setup option for
installing SilkCentral, the Database Administration page displays immediately after you connect
to the application. On the computer where the front-end server is installed, you can also select
Start > Programs > Silk > SilkCentral > Test Manager 12.0 > Test Manager Home Page .

2. If not already logged in, log in.

admin is the default value for both the username and the password.

3. In the menu, click Administration > System Settings.

4. Click the Database tab.

5. Enter the information for the new database, then click Connect.

You can create a database on the locally installed Microsoft SQL Server 2008 Express, a locally
installed Microsoft SQL Server or Oracle installation, or on a network server that has MS SQL Server or
Oracle installed. SilkCentral supports:

• Microsoft SQL Server 2005 Service Pack 3
• Microsoft SQL Server 2005 Service Pack 2
• Microsoft SQL Server 2008 R2
• Oracle 10g (version 10.2.0.5)
• Oracle 11g (version 11.2.0.2)
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Tip: For detailed information on the individual connection settings, see the Database Settings
Page.

The Create Database dialog box displays.

6. To create a new database, provide the database administrator credentials.

If you installed SilkCentral using the evaluation setup package, type sa in the Username text box and
SilkCentral12!34 in the Password text box, then click OK.

Tip: If you are creating a local or network Microsoft SQL Server or Oracle database, enter the
login information provided to you by your database administrator, then click OK.

Note: This process can take up to a few minutes.

7. Type a unique repository ID into the ALM Repository ID text box in the Create ALM Repository ID
dialog box and click OK.

8. A Messages dialog box may display, informing you of servers that were found on the local computer
and have automatically been added to the system configuration. Confirm this dialog box by clicking OK.
If you receive a warning message stating Couldn't define localhost as Execution Server,
you need to configure your execution servers manually.

9. You will be notified that the repository has been created successfully. Confirm the message by clicking
OK. The login page displays.

10.Log in using your standard username and password.

The default is admin/admin. Do not log in as a database administrator. Information about the currently
connected database is displayed in Administration > System Settings > Database, but other
available databases are not displayed anywhere in the SilkCentral user interface. You must make a
note of the database name for future reference.

Your system is now ready for use.

Accessing an Existing Repository
To access an existing repository:

1. In the menu, click Administration > System Settings.

2. Click the Database tab.

3. If you are already connected to a repository, click Disconnect.A confirmation dialog box displays,
asking you if you really want to disconnect from the current repository. Click Yes to disconnect.

4. Type or confirm the information for the database, then click Connect.

For detailed information on the individual connection settings, see Database Settings Page.

5. If the repository has no ALM repository ID, the Create ALM Repository ID dialog box displays. Enter a
unique repository ID into the ALM Repository ID text box and click OK.

6. After the database connection is established, a confirmation message displays. Confirm the message
by clicking OK. The SilkCentral login page displays.

7. Log in to SilkCentral. After you log in, you should have access to SilkCentral.

The default value for both the username and password is admin.

Repository IDs
Each Test Manager repository must have a unique repository ID. This ID is used in ALM URIs to uniquely
identify Test Manager requirements and tests across multiple Test Manager repositories. The repository ID
must be unique within your company's Test Manager installations. The supplied repository ID will be part of
the ALM URI. For additional information on ALM URIs, see ALM URIs. It is good practice to use a
descriptive ID, for example USCA01, for USA, California, repository #01 or GEBE02, for Germany, Berlin,
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repository #02. Allowed characters are letters, numbers, period (.), and minus (-). IDs must have a length
of 1 to 20 characters.

Caution: Once a repository ID has been set, it cannot be changed.

ALM URIs
Repository IDs are incorporated into Application Lifecycle Management Uniform Resource Identifiers (ALM
URIs). ALM URIs offer a means of addressing elements across ALM Server platform and the ability to
distinguish and track elements between applications. Among other things, ALM URIs are used to uniquely
identify Test Manager requirements and tests across multiple Test Manager repositories.

The ALM element URI syntax is as follows:

<ALM URI> = alm://<source project>/<source element path>[?<source version>]
 <source project> = <source type>!<project identity>

For Test Manager, <source type> = sctm. For Issue Manager, <source type> = scim.

Project identity is built as follows:

<project identity> = <repository ID>_<project ID>

<repository ID> is a unique identifier for each Test Manager and Issue Manager repository. Each
repository generates a unique identifier that is stored inside the repository. Uniqueness is guaranteed
across all repositories that you may have installed. <project ID> is an identifier for a Test Manager or
Issue Manager project. This identifier is unique in the context of each repository.

Source Element Path:

For Test Manager and Issue Manager, the following syntax for referencing artifacts is used:

Test Manager native requirements, which are requirements that are not linked with an external requirement
management system, use the following syntax:

<source element path> = /<requirement ID>;ns=requirement

Test Manager tests use the following syntax:

<source element path> = /<test ID>;ns=test

Test Manager and Issue Manager issues use the following syntax:

<source element path> = /<issue ID>;ns=issue

Example ALM URI:

alm://sctm!USCA01_23/602;ns=test

Test Manager repository USCA01, project ID 23, element ID 602, element type test.

Enabling the TCP/IP Protocol for Microsoft SQL Server
2005
If you are using Microsoft SQL Server 2005, you need to configure the SQL Server to use the TCP/IP
protocol. If you are using a different database system, skip this procedure.

Before you enable the TCP/IP protocol, verify the following settings on the computer hosting the SQL
Server installation:
• The SQL Server Browser service must run on Windows. We recommend that you change the

properties of this service to Startup type: Automatic. Windows Services settings can be found in Start
> Settings > Control Panel > Adminstrative Tools > Services .

• The SQL Server must use the TCP/IP protocol.
To enable the TCP/IP protocol for Microsoft SQL Server 2005:
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1. Run the SQL Server Configuration Manager tool that comes with Microsoft SQL Server 2005.

2. In the displayed tree, select SQL Server 2005 Network Configuration > Protocols for
MSSQLSERVER .

3. In the pane to the right of the tree view, right-click TCP/IP and choose Enable.

4. Back in the tree view pane, select SQL Server 2005 Services.

5. In the pane to the right of the tree view, right-click SQL Server (MSSQLSERVER) and select Restart
from the context menu.

Disconnecting from a SilkCentral Repository
To disconnect from a repository:

1. Browse to your SilkCentral site with a Web browser.

The default URL is http://<computer name>/login.

2. Log in.

The default value for both the username and password is admin.

3. In the menu, click Administration > System Settings.

4. Click the Database tab.

5. Click Disconnect to disconnect from the current database.

Database Settings Page
Administration > System Settings > Database

Use the Database Settings page to configure access to a database. The page icludes the following items:

Item Description

DBMS hostname or IP address The computer name or IP address of the computer
hosting the database management system (DBMS) in the
format <computer name>\<instance name>.

Database
System

Hostname Description

Microsoft SQL
Server 2005 or
Microsoft SQL
Server 2008
R2

<computer name>
\<instance name>, for example
localhost.

Note: An instance name
only needs to be provided if
the DBMS was installed
using an instance.

Microsoft SQL
Server 2008
Express

<computer name>
\<instance name>. The default
MS SQL Server Express instance is
localhost\SQLExpress.

Oracle Server <computer name>, for example
MyDBMSHost. If you plan on
creating custom reports with direct
database access, define a DBMS
hostname or IP address that is
available throughout the network.
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Item Description

DBMS type The type of DBMS you want to access, MSSQL Server
or Oracle.

Port The port on which the DBMS listens. The default port for
Microsoft SQL Server, including Express, is 1433. The
default port for Oracle is 1521.

Database / SID MSSQL Server database name or Oracle SID provided
by your Oracle administrator.

For Oracle database administrators: Configure the Oracle
SID to use the UTF8 character set.

Username Database user with sufficient credentials. The default
Microsoft SQL Server user, including Microsoft SQL
Express, is sa, if not changed by your database
administrator. For Oracle Server, enter the database user
provided by your Oracle administrator.

Important: For Oracle Servers, the database
username cannot contain periods (.).

Password Valid password for the specified Username.

Database
System

Password

Microsoft SQL
Server,
including
Express

These databases enforce password
usage. Ask your database
administrator for the correct login
credentials if you are not sure.

Oracle Server Password for the database user. Ask
your Oracle administrator for the
correct login credentials if you are
not sure.

Read-only Username (optional) An optional database user with read-only rights on all
tables and views in the specified database. Defining a
read-only user enhances database security. If your
DBMS is Microsoft SQL Server, SilkCentral automatically
creates this user if you specify a name and password. If
your DBMS is Oracle, your database administrator needs
to create the user in Oracle and your SilkCentral
administrator needs to add that user to SilkCentral.

Read-only Password (optional) Valid password for the specified Read-only Username
(optional).

Status Displays the status of the SilkCentral connection to the
DBMS.

DBMS version info Displays DBMS and operating system version
information.

ALM Repository ID Displays the ALM URI of the repository.
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Item Description

Connect / Disconnect Depending on the current connection status, use this
button to connect to or disconnect from a DBMS.

Note: When you connect to the database and the version of an execution server is an invalid older
version, but later than or equal to version SilkCentral Test Manager 2009 SP1, the execution server is
automatically upgraded to the current Test Manager version. Test Manager shows a message
concerning the upgrade in the Information column in the list of execution servers. As long as the
upgrade procedure is not complete, the upgrading execution servers are not used.
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Configuring the System
This section describes how to make the initial configurations that are required to work with SilkCentral.
These configurations must be performed by an administrator.

Using the Overview Page
The Overview page displays important configuration items in a single location. The items displayed in the
page are bundled into tasks. Use this page to easily configure all the settings you need for a specific task.

Overview Page
Administration > Overview

The Overview page provides quick access to important configuration items. The page includes the
following sections:

Section Description

System Basic system settings.

Project Management Provides quick access to the Projects page.

Cross-Project Assets Provides access to configurations that are independent of
the current project.

User Management Provides access to Administration > User
Management.

Automated Testing Settings Settings commonly used during setup of automated tests.

Logs Provides access to the log pages in Administration >
Log Files.

Help Provides access to the product documentation, the
downloadable client tools, and the about page.

Secure Web Server Connections with SSL
If you intend to work using a secure connection and have opted to install the ISAPI Web Server, then you
must configure Microsoft Internet Information Services (IIS) to use the Secure Sockets Layer (SSL). You
must first obtain a certificate from a Certificate Authority to gain access to the Secure Sockets Layer.

The SilkCentral default standalone Web server (Tomcat) can also be configured to use SSL (Secure
Sockets Layer).

Configuring Secure Connections with Microsoft IIS
To use SilkCentral with Secure Sockets Layer (SSL), you must first obtain a certificate from a Certificate
Authority and then apply the certificate to Internet Information Services (IIS).

Applying for a Certificate to use SSL
To apply for a certificate to use SSL:
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1. Open the Internet Information Services dialog box by navigating to Start > Programs >
Administrative Tools > Internet Services Manager ( Start > Programs > Administrative Tools >
Internet Information Services (IIS) Manager in Windows 2003).

Tip: If the Administrative Tools menu is not available, navigate to Start > Settings > Control
Panel and double-click the Administrative Tools icon. Double-click the Internet Information
Services icon (Internet Information Services (IIS) Manager in Windows 2003). Here you will find
the name of your host computer and an expandable tree view.

2. Click the plus (+) symbol next to your computer’s name to expand the tree file.

3. On the Internet Information Services dialog box, right-click Default Web Site and select Properties.

Tip: If you are running Windows XP or Windows 2003, expand the Web Sites tree. Then right-
click Default Web Site and select Properties.

The Default Web Site Properties dialog box displays.

4. Click the Directory Security tab.

5. Click Server Certificate next to the key graphic at the bottom of the Default Security dialog box.The
Welcome to the Web Server Certificate Wizard displays.

6. Click Next.
The IIS Certificate Wizard displays with options for assigning a certificate to a Web site.

7. Choose Create a new certificate and click Next.

Note: If you already have a certificate installed, this dialog box will prompt you with the question
What do you want to do with the currently installed certificate?
If this dialog box displays, skip the remainder of this section.

8. Create a new certificate.

For more information, see Creating a New Certificate to Use SSL.

Creating a New Certificate to Use SSL
Note: To create a new certificate, you first have to perform the steps described in Applying for a
Certificate to use SSL.

To create a new certificate:

1. Click Next in the IIS Certificate Wizard / Delayed or Immediate Request dialog box, or choose when
to send your request. The IIS Certificate Wizard / Name and Security Settings dialog box displays.

2. Type a name of your choice in the Name text box.

This is usually the name of the computer for which you are requesting a certificate.

3. Choose a Bit length in the appropriate text box.

You may leave the default length of 512 or choose the 1024 list box option. Choosing a higher bit length
increases security, but can also affect performance.

4. Click Next.The IIS Certificate Wizard / Organization Information dialog box displays.

5. Type the name of your Organization and the Organizational unit, for example QA, to which your
computer belongs.

6. Click Next.The IIS Certificate Wizard / Your Site’s Common Name dialog box displays.

7. Type the name of your site or computer and click Next. The IIS Certificate Wizard / Geographical
Information dialog box displays.

8. Enter geographical information relevant to the location of your computer or organization and click Next.
The IIS Certificate Wizard / Certificate Request File Name dialog box displays.

9. Type the name of the file in which your certificate is to be located and click Next. The IIS Certificate
Wizard / Request File Summary dialog box displays. All of the information you have entered is
displayed here.

10.If the information is incorrect, click Back to return and change the information. If the information is
correct, click Next to continue. The IIS Certificate Wizard Completion dialog box displays, informing
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you that you have completed the wizard. This dialog box provides instructions regarding what you must
do with the file to obtain a certificate. Follow the instructions in the dialog box or ask your system
administrator for assistance.

Applying the Certificate to IIS
Once you have received a response to your certificate query and have the file in which you have stored the
certificate, you may apply the certificate to IIS. For additional information, see Applying for a Certificate to
use SSL.

To apply the certificate to the IIS:

1. Navigate to Start > Programs > Administrative Tools > Internet Services Manager ( Start >
Programs > Administrative Tools > Internet Information Services (IIS) Manager in Windows 2003).

Tip: If the Administrative Tools menu is not available, navigate to Start > Settings > Control
Panel and double-click the Administrative Tools icon. Double-click the Internet Information
Services icon (Internet Information Services (IIS) Manager in Windows 2003).

2. Expand the tree until Default Web Site is displayed.

3. Right-click Default Web Site and select Properties.The Default Web Site Properties dialog box
opens.

4. Click the Directory Security tab in the Default Web Site Properties dialog box.

5. Click the Server Certificate option next to the key icon at the bottom of the dialog box. The Welcome
to the Web Server Certificate Wizard displays.

6. Click Next. The IIS Certificate Wizard displays with options for proceeding with a pending request.

7. Select Process the pending request and install the certificate. Click Next. The IIS Certificate
Wizard / Process the pending request dialog box displays.

8. Type the location of the Certificate Authority’s response, which is the certificate that they sent you
directly or that you received from your system administrator. Click Next.
The IIS Certificate Wizard / Certificate Summary dialog box displays with information about the
certificate.

9. Click Next to install the certificate. The IIS Certificate Wizard / Completing the Web Server
Certificate Wizard displays.

10.Click Finish to complete the process.

11.Close the Authentication by clicking OK. You may also close the Default Web Site Properties dialog
box by clicking OK.

You have now completed IIS configuration for SSL and can use SSL for secure connections to SilkCentral.

Configuring Secure Connections with Tomcat Web
Server
You need to be familiar with Tomcat and SSL configuration to perform this task.

Set up the SilkCentral default standalone Web server (Tomcat) to use SSL (Secure Sockets Layer).

To enable secure communication with SilkCentral:

1. Log on to the SilkCentral server as an Administrator.

2. Stop all SilkCentral services (application, chart, execution, and front-end servers).

3. To generate a unique certificate for your Tomcat Web server, execute the following command in the
SilkCentral Java directory:C:\Program Files\Silk\SC Test Manager 12.0\lib\jre\bin
\keytool -genkey -alias tomcat -keyalg RSA.

4. Specify a keystore password value of changeit.

If you desire to use a unique password, specify it here.
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5. The keytool command prompt sequence will be similar to the following. Respond accordingly.

What is your first and last name?
[Unknown]: hostname.domain.com
What is the name of your organizational unit?
[Unknown]: IT Department (if that is the group creating the certificate)
What is the name of your organization?
[Unknown]: Company Name
What is the name of your City or Locality?
[Unknown]: City
What is the name of your State or Province?
[Unknown]: State
What is the two-letter country code for this unit?
[Unknown]: US
Is CN=xxxx, OU=xxxxxxx, O=xxxxxx, L=xxxxxxxxx, ST=xxxxx, C=xx correct?
[no]: Yes (These values will reflect what you entered previously)
Enter key password for <tomcat> same as keystore password
(RETURN if same as keystore password):

A file named .keystore is generated in the profile folder of the user you are logged in with, for
example C:\Users\Administrator.

Note: By default Tomcat will look for your Keystore with the file name.keystore in the home
directory with the default password changeit. The home directory is generally /home/
user_name/ on Unix and Linux systems, and C:\Documents and Settings\user_name\ or
C:\Users\user_name\ on Microsoft Windows systems.

6. Move the .keystore file to a safe location of your choice.

Note: On some operating systems, Tomcat may encounter problems if you use a location that
contains space characters.

7. Edit the Tomcat configuration file:

Locate the server.xml file in the conf\frontendserver\conf subdirectory of the directory where
SilkCentral is installed.

8. Open the file in a text editor such as Notepad. Comment out the current Connector entry and add the
following text:

<!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->
<Connector port="8443" minSpareThreads="25" URIEncoding="UTF-8" 
compression="on"
compressableMimeType="text/html,text/xml,text/plain,text/css,text/
javascript,application/xml" 
debug="0" scheme="https" secure="true" SSLEnabled="true" clientAuth="false" 
sslProtocol="TLS" keystorePass="changeit" keystoreFile="C:\<file location>
\.keystore"/>

Note: Make sure that the path specified in the keystoreFile parameter matches the location
that you copied the .keystore file to. If you choose to use a different password other than
changeit, you will need to add the keystorePass parameter to the server.xml file entry:

<Connector port="8443" minSpareThreads="25" URIEncoding="UTF-8" 
compression="on"
compressableMimeType="text/html,text/xml,text/plain,text/css,text/
javascript,application/xml" 
debug="0" scheme="https" secure="true" SSLEnabled="true" 
clientAuth="false" 
sslProtocol="TLS" keystorePass="changeit" keystoreFile="C:\<file 
location>\.keystore"
keystorePass="newpassword"/>

For more information, visit the Apache Tomcat 7 Documentation.

9. Optional: Change the Port of the front-end server in the <Connector> tag from 19120 to the desired
port.
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10.To enable BIRT reports on SSL environments, edit the registry key of the chart server in
HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun
2.0\SCCChartServer\Parameters\Java\Options. Add the following text to the key:

-Djavax.net.ssl.trustStore=C:\<file location>\.keystore
-Djavax.net.ssl.trustStorePassword=<Password>

The <Password> is the keystorePass you have defined.

11.Save the file and close the editor.

12.Restart all services that were stopped at the beginning of this procedure.

13.Log on to your SilkCentral server using HTTPS: https://hostname:8443/login.

Application Server Location
The application server synchronizes tasks such as the distribution of schedules, control of execution
servers, and management of database configuration. Before you can start working with SilkCentral
applications, you need to specify the location of the application server.

Specifying a Location for the Application Server
When you use the Standard Setup option for installing a SilkCentral application, you do not need to
specify an application server location. Setup automatically configures the localhost to be the application
server. In this case you can skip this procedure. For additional information on setup options, see the
application’s installation instructions.

To specify a location for the application server:

1. Once you have installed the SilkCentral software, connect to SilkCentral using a Web browser.

Tip: If you installed ISAPI Web Server, use http://<Web-server-name>/login as the URL.
If you installed the stand-alone Web Server, use http://<Web-server-name>:19120/login
as the URL. The stand-alone Web server uses port 19120 by default.

You will receive a confirmation stating that the application server connection has not yet been defined.

2. Enter the Host or IP address and the Port of the application server.

The application server is the computer where you installed SilkCentral’s application server component.
The default port is 19122.

3. Click Login to proceed. If your specifications are correct and the respective computer is running with
the installed software, you will be returned to the login page with the message
Application server connected successfully

The Database Administration page displays.

SilkCentral Repositories
The terms “database” and “repository” are sometimes used interchangeably, but generally a repository is
defined as a central place in which an aggregation of data is kept and maintained. The conceptual model
for SilkCentral is that of a data repository that contains the application data.

A repository is a database used by SilkCentral products to store, maintain, and analyze data. You must first
choose which database system you want to use for your repository and take the necessary steps in the
SilkCentral GUI to access the repository. You must be connected to a repository to work with SilkCentral
products.

You may set up multiple repositories, though only one repository at a time may be active.

To connect to a new SilkCentral database, you must first disconnect from the current database.
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Note: You will receive error messages if you try to work with SilkCentral while the database is
disconnected.

We recommend to perform administrative tasks that require the database to be disconnected during off-
hours. If this is not possible, make sure to inform the users about the system-outage and its duration.

Note: If you are not planning on using LDAP authentication, user accounts will be stored in the
repository. If you plan to use multiple repositories, you will have to maintain separate user accounts
for each repository.

Creating a New Repository
Note: If you are currently connected to a SilkCentral repository, you must disconnect from the
repository before you can create a new repository.

To create a new repository:

1. If you have already set up your SilkCentral application server, the Database Administration page will
display in a browser window, and you can proceed to step 3 of this procedure.

Tip: Alternatively, you can browse to your SilkCentral site with a Web browser. The default URL is
http://<computer name>:<port>/login. When you use the Standard Setup option for
installing SilkCentral, the Database Administration page displays immediately after you connect
to the application. On the computer where the front-end server is installed, you can also select
Start > Programs > Silk > SilkCentral > Test Manager 12.0 > Test Manager Home Page .

2. If not already logged in, log in.

admin is the default value for both the username and the password.

3. In the menu, click Administration > System Settings.

4. Click the Database tab.

5. Enter the information for the new database, then click Connect.

You can create a database on the locally installed Microsoft SQL Server 2008 Express, a locally
installed Microsoft SQL Server or Oracle installation, or on a network server that has MS SQL Server or
Oracle installed. SilkCentral supports:

• Microsoft SQL Server 2005 Service Pack 3
• Microsoft SQL Server 2005 Service Pack 2
• Microsoft SQL Server 2008 R2
• Oracle 10g (version 10.2.0.5)
• Oracle 11g (version 11.2.0.2)

Tip: For detailed information on the individual connection settings, see the Database Settings
Page.

The Create Database dialog box displays.

6. To create a new database, provide the database administrator credentials.

If you installed SilkCentral using the evaluation setup package, type sa in the Username text box and
SilkCentral12!34 in the Password text box, then click OK.

Tip: If you are creating a local or network Microsoft SQL Server or Oracle database, enter the
login information provided to you by your database administrator, then click OK.

Note: This process can take up to a few minutes.

7. Type a unique repository ID into the ALM Repository ID text box in the Create ALM Repository ID
dialog box and click OK.

8. A Messages dialog box may display, informing you of servers that were found on the local computer
and have automatically been added to the system configuration. Confirm this dialog box by clicking OK.
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If you receive a warning message stating Couldn't define localhost as Execution Server,
you need to configure your execution servers manually.

9. You will be notified that the repository has been created successfully. Confirm the message by clicking
OK. The login page displays.

10.Log in using your standard username and password.

The default is admin/admin. Do not log in as a database administrator. Information about the currently
connected database is displayed in Administration > System Settings > Database, but other
available databases are not displayed anywhere in the SilkCentral user interface. You must make a
note of the database name for future reference.

Your system is now ready for use.

Accessing an Existing Repository
To access an existing repository:

1. In the menu, click Administration > System Settings.

2. Click the Database tab.

3. If you are already connected to a repository, click Disconnect.A confirmation dialog box displays,
asking you if you really want to disconnect from the current repository. Click Yes to disconnect.

4. Type or confirm the information for the database, then click Connect.

For detailed information on the individual connection settings, see Database Settings Page.

5. If the repository has no ALM repository ID, the Create ALM Repository ID dialog box displays. Enter a
unique repository ID into the ALM Repository ID text box and click OK.

6. After the database connection is established, a confirmation message displays. Confirm the message
by clicking OK. The SilkCentral login page displays.

7. Log in to SilkCentral. After you log in, you should have access to SilkCentral.

The default value for both the username and password is admin.

Repository IDs
Each Test Manager repository must have a unique repository ID. This ID is used in ALM URIs to uniquely
identify Test Manager requirements and tests across multiple Test Manager repositories. The repository ID
must be unique within your company's Test Manager installations. The supplied repository ID will be part of
the ALM URI. For additional information on ALM URIs, see ALM URIs. It is good practice to use a
descriptive ID, for example USCA01, for USA, California, repository #01 or GEBE02, for Germany, Berlin,
repository #02. Allowed characters are letters, numbers, period (.), and minus (-). IDs must have a length
of 1 to 20 characters.

Caution: Once a repository ID has been set, it cannot be changed.

ALM URIs
Repository IDs are incorporated into Application Lifecycle Management Uniform Resource Identifiers (ALM
URIs). ALM URIs offer a means of addressing elements across ALM Server platform and the ability to
distinguish and track elements between applications. Among other things, ALM URIs are used to uniquely
identify Test Manager requirements and tests across multiple Test Manager repositories.

The ALM element URI syntax is as follows:

<ALM URI> = alm://<source project>/<source element path>[?<source version>]
 <source project> = <source type>!<project identity>

For Test Manager, <source type> = sctm. For Issue Manager, <source type> = scim.
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Project identity is built as follows:

<project identity> = <repository ID>_<project ID>

<repository ID> is a unique identifier for each Test Manager and Issue Manager repository. Each
repository generates a unique identifier that is stored inside the repository. Uniqueness is guaranteed
across all repositories that you may have installed. <project ID> is an identifier for a Test Manager or
Issue Manager project. This identifier is unique in the context of each repository.

Source Element Path:

For Test Manager and Issue Manager, the following syntax for referencing artifacts is used:

Test Manager native requirements, which are requirements that are not linked with an external requirement
management system, use the following syntax:

<source element path> = /<requirement ID>;ns=requirement

Test Manager tests use the following syntax:

<source element path> = /<test ID>;ns=test

Test Manager and Issue Manager issues use the following syntax:

<source element path> = /<issue ID>;ns=issue

Example ALM URI:

alm://sctm!USCA01_23/602;ns=test

Test Manager repository USCA01, project ID 23, element ID 602, element type test.

Enabling the TCP/IP Protocol for Microsoft SQL Server
2005
If you are using Microsoft SQL Server 2005, you need to configure the SQL Server to use the TCP/IP
protocol. If you are using a different database system, skip this procedure.

Before you enable the TCP/IP protocol, verify the following settings on the computer hosting the SQL
Server installation:

• The SQL Server Browser service must run on Windows. We recommend that you change the
properties of this service to Startup type: Automatic. Windows Services settings can be found in Start
> Settings > Control Panel > Adminstrative Tools > Services .

• The SQL Server must use the TCP/IP protocol.

To enable the TCP/IP protocol for Microsoft SQL Server 2005:

1. Run the SQL Server Configuration Manager tool that comes with Microsoft SQL Server 2005.

2. In the displayed tree, select SQL Server 2005 Network Configuration > Protocols for
MSSQLSERVER .

3. In the pane to the right of the tree view, right-click TCP/IP and choose Enable.

4. Back in the tree view pane, select SQL Server 2005 Services.

5. In the pane to the right of the tree view, right-click SQL Server (MSSQLSERVER) and select Restart
from the context menu.

Disconnecting from a SilkCentral Repository
To disconnect from a repository:

1. Browse to your SilkCentral site with a Web browser.
The default URL is http://<computer name>/login.

2. Log in.
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The default value for both the username and password is admin.

3. In the menu, click Administration > System Settings.

4. Click the Database tab.

5. Click Disconnect to disconnect from the current database.

Database Settings Page
Administration > System Settings > Database

Use the Database Settings page to configure access to a database. The page icludes the following items:

Item Description

DBMS hostname or IP address The computer name or IP address of the computer
hosting the database management system (DBMS) in the
format <computer name>\<instance name>.

Database
System

Hostname Description

Microsoft SQL
Server 2005 or
Microsoft SQL
Server 2008
R2

<computer name>
\<instance name>, for example
localhost.

Note: An instance name
only needs to be provided if
the DBMS was installed
using an instance.

Microsoft SQL
Server 2008
Express

<computer name>
\<instance name>. The default
MS SQL Server Express instance is
localhost\SQLExpress.

Oracle Server <computer name>, for example
MyDBMSHost. If you plan on
creating custom reports with direct
database access, define a DBMS
hostname or IP address that is
available throughout the network.

DBMS type The type of DBMS you want to access, MSSQL Server
or Oracle.

Port The port on which the DBMS listens. The default port for
Microsoft SQL Server, including Express, is 1433. The
default port for Oracle is 1521.

Database / SID MSSQL Server database name or Oracle SID provided
by your Oracle administrator.

For Oracle database administrators: Configure the Oracle
SID to use the UTF8 character set.

Username Database user with sufficient credentials. The default
Microsoft SQL Server user, including Microsoft SQL
Express, is sa, if not changed by your database
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Item Description

administrator. For Oracle Server, enter the database user
provided by your Oracle administrator.

Important: For Oracle Servers, the database
username cannot contain periods (.).

Password Valid password for the specified Username.

Database
System

Password

Microsoft SQL
Server,
including
Express

These databases enforce password
usage. Ask your database
administrator for the correct login
credentials if you are not sure.

Oracle Server Password for the database user. Ask
your Oracle administrator for the
correct login credentials if you are
not sure.

Read-only Username (optional) An optional database user with read-only rights on all
tables and views in the specified database. Defining a
read-only user enhances database security. If your
DBMS is Microsoft SQL Server, SilkCentral automatically
creates this user if you specify a name and password. If
your DBMS is Oracle, your database administrator needs
to create the user in Oracle and your SilkCentral
administrator needs to add that user to SilkCentral.

Read-only Password (optional) Valid password for the specified Read-only Username
(optional).

Status Displays the status of the SilkCentral connection to the
DBMS.

DBMS version info Displays DBMS and operating system version
information.

ALM Repository ID Displays the ALM URI of the repository.

Connect / Disconnect Depending on the current connection status, use this
button to connect to or disconnect from a DBMS.

Note: When you connect to the database and the version of an execution server is an invalid older
version, but later than or equal to version SilkCentral Test Manager 2009 SP1, the execution server is
automatically upgraded to the current Test Manager version. Test Manager shows a message
concerning the upgrade in the Information column in the list of execution servers. As long as the
upgrade procedure is not complete, the upgrading execution servers are not used.

Initial Login
Once connected to a repository, you are ready to login using the default system administrator account.

Caution: Because the SuperUser account admin has all administrative privileges, you should
immediately designate a new password for this user to prevent unlimited access to these privileges.
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For more information on changing the password, see Changing the Password of the System
Administrator Account.

Logging in for the First Time
Once connected to a repository, you are ready to login using the default system administrator account.

To login to SilkCentral for the first time:

1. Type admin in the Username text box and admin in the Password text box.

2. Click Login.

Caution: Because the SuperUser account admin has all administrative privileges, you should
immediately designate a new password for this user to prevent unlimited access to these privileges.
For more information on changing the password, see Changing the Password of the System
Administrator Account.

Login Page
Use this page to connect to SilkCentral. The page displays the following items:

Item Description

Username Type your LDAP or SilkCentral username. The default
username for the SuperUser is admin.

Password Enter a valid password for the Username that you
entered.

Remember login If you check the Remember login check box, you will not
have to log in again after being automatically logged out
by the application. You are logged out when you are idle
for more than 30 minutes.

Standard Enables a non-secure login to SilkCentral.

Secure Enables a secure (SSL) login to SilkCentral. This option
only works if SilkCentral is configured for secure
connections. For more information, see Configuring
Secure Connections with Microsoft IIS.

Login Logs you in to SilkCentral, if the entered credentials are
valid.

System Administrator Accounts
Adding user accounts allows different users to create projects and have access rights to work with them.

By default, the SuperUser account admin is available in the set-up installation with the password admin.
For information on the other user types and their capabilities, see User Roles and Permissions.

Caution: Because the SuperUser account admin has all administrative privileges, you should
immediately designate a new password for this user to prevent unlimited access to these privileges.
For more information on changing the password, see Changing the Password of the System
Administrator Account.
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Changing the Password of the System Administrator
Account
Describes how to change the password of the default SuperUser account.

To designate a new password for the default SuperUser:

1. In the menu, click Administration > User Management.
2. Click the Accounts tab.

The page displays all available user accounts. When you access this page for the first time, the
SuperUser account admin is the only user listed.

3. Click the name of the admin user.

The Configure existing user account page displays.

4. Enter a password of your choice.

Click OK.

5. Enter the password again to confirm it.

6. Click OK.

You are returned to the User accounts page and notified that the update was successful.

Chart Server Location
A chart server is a service that computes data and produces graphs. These graphs are viewable within the
SilkCentral application. This service can be installed with the SilkCentral setup on a computer of your
choice. You must specify the location of your chart server in order to display graphs.

Note: You can define as many chart servers as you want; SilkCentral automatically implements a
load balancing mechanism for chart generation.

Adding Chart Servers
Describes how to add a chart server.

Note: You can only add a chart server if the respective chart server service is installed on the
computer you want to add to the list of available chart servers. For more information, refer to the
installation instructions of your SilkCentral application.

To add a new chart server:

1. In the menu, click Administration > System Settings.

2. Click the Chart Servers tab.

3. If a chart server was installed with the application server on the same computer, Setup will have already
defined localhost as the chart server.

4. Click New Chart Server. The Configure chart server page displays.

5. On this page you are asked to specify the hostname or IP address, the port, and the URL where the
charting service has been installed. The only change you will have to make to the default settings is the
name of the computer on which the server is located. The default port is 19126 and the default URL is
ChartServer.

6. After inserting the appropriate information, click Check to establish a test connection to the chart
server.

If the test is successful, a test image will be displayed. If the test is not successful and no chart is
displayed, an error message will appear. In such a case you should check the hostname or IP address
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of the chart server and verify that a chart server is actually installed on the target machine. Then repeat
the steps outlined above.

7. Click Back to return to the chart server configuration. If the test connection was successful, check the
status check box and click Save.

8. You will be returned to the list of chart servers, which now includes the chart server you have just
added.

You can click New Chart Server to add more chart servers.

Editing Chart Servers
Describes how to edit a chart server.

To modify the settings of a chart server:

1. In the menu, click Administration > System Settings.

2. Click the Chart Servers tab.

3. Click the chart server you want to modify. The Configure chart server page displays.

4. On this page you can modify the hostname or IP address, the port, and the URL where the charting
service has been installed. You can also activate/deactivate the chart server by checking/un-checking
the Active check box. If you only want to activate or de-activate the chart server, please proceed with
step 5.

5. After inserting the appropriate information, click Check to establish a test connection to the chart
server.

If the test is successful, a test image will be displayed. If the test is not successful and no chart is
displayed, an error message will appear. In such a case you should check the hostname or IP address
of the chart server and verify that a chart server is actually installed on the target machine. Then repeat
the steps outlined above.

6. Click Back to return to the chart server configuration. Since the test connection was successful, set the
status check box to active.

7. Click Save. You will be returned to the list of chart servers.

Removing Chart Servers
Describes how to remove a chart server.

Note: Removing a chart server does not remove the installation of the service; it only removes the
availability of the service to the application. To reconnect to the service at a later time, see Adding
Chart Servers.

To remove a chart server:

1. In the menu, click Administration > System Settings.

2. Click the Chart Servers tab.

3. Click the Chart Server URL of the chart server that you want to remove.

4. Uncheck the Active check box and click save.You are returned to the Chart Servers page.

5. Click  in the Actions column of the chart server you want to remove.

6. A confirmation dialog box displays, where you can confirm the deletion by clicking Yes.

Chart Servers Page
Administration > System Settings > Chart Servers

Use this page to manage your chart servers. The page displays the following columns for each listed chart
server:
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Column Description

Actions Perform a trial connection to the chart server by receiving a sample chart, or delete a
chart server connection.

Chart Server URL The URL to connect to the chart server. Syntax: http://<computer name or
IP address>:<port>/ChartServer. The default port is 19126.

Status Displays whether the connection to the chart server is active or inactive.

Created On Date when the chart server connection was created.

Created By The user who created the chart server connection.

Changed On Date when the chart server connection was modified.

Changed By The user who modified the chart server connection.

LDAP Authentication
Configure LDAP authentication to enable SilkCentral logins through an LDAP server.

Lightweight Directory Access Protocol (LDAP) is an open network protocol standard that is designed to
provide access to directory services. LDAP provides a mechanism for querying and modifying information
that resides in a directory information tree (DIT). A directory information tree typically contains a broad
range of information about different types of network objects including users, printers, applications, and
other network resources.

SilkCentral LDAP integration
The most important aspect of LDAP integration in SilkCentral is user authentication. In most directories it is
not possible to retrieve a user’s password, so LDAP must be accessed each time a user needs to be
authenticated.

SilkCentral LDAP integration supports plain-text authentication and SSL authentication. The directory
service must either allow anonymous queries or a user with read rights on the directory must be provided.

The following properties must be provided for LDAP servers:

• LDAP server URL
• LDAP port
• Base DN (root node, base distinguished name)
• Optional: username and password
• Filter, for querying user (object)

LDAP Authentication Logic
Standard mode authentication means that a user can only authenticate against LDAP, if an LDAP server is
defined and active. Mixed mode authentication means that a user can login with either LDAP or local
credentials.

Note: For either authentication mode, a user can only be logged in when their username exists in the
SilkCentral database.

Standard Mode Authentication

Standard mode authentication is enabled when at least one LDAP server is active. When no LDAP server
is defined, users will only be able to login with local credentials. Each defined LDAP server is checked to
determine if a user (with specific username and password) can be authenticated. Access is granted when
authentication succeeds on one of the servers.
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Mixed Mode Authentication

When no LDAP server is defined, users will only be able to login with local credentials. If at least one LDAP
server is active and a user account is set to use mixed mode authentication, each defined LDAP server is
checked to determine if a user (with specific username and password) can be authenticated. If the user is
unknown on all defined LDAP servers, then local database authentication is attempted. Access is denied
when a user is also unknown based on local credentials. If a user is known on an LDAP server, but the
credentials are incorrect, access is denied.

Adding LDAP Servers
Describes how to configure an LDAP server for usage with SilkCentral.

To add a new LDAP server:

1. In the menu, click Administration > System Settings.

2. Click the LDAP Servers tab.

3. Click New LDAP Server. The New LDAP Server dialog box displays.

4. Type a Name for the server and optionally a Description.

5. Check the Active check box to activate the server for use with SilkCentral.

6. Type the Hostname or IP-address of the LDAP server and the Port used for the LDAP service.

7. Check the Use SSL check box to connect to the server through SSL.

8. Optional: In the Bind DN text box, type the domain name of the user who is to be used to bind to the
LDAP service. Type the Password of the user defined by Bind DN.

9. Type the Base DN root for LDAP queries and the Filter that is to be used for querying LDAP.

10.Click Test to perform a test connection to the LDAP server.

For additional information, see Testing LDAP Servers.

11.Click OK to save your settings.

Editing LDAP Servers
Describes how to edit an LDAP server profile.

To edit an LDAP server profile:

1. In the menu, click Administration > System Settings.

2. Click the LDAP Servers tab.

3. Click the name of the LDAP server profile you want to edit. The Edit LDAP Server dialog box displays.

4. Edit theName and Description of the server as required.

5. Check the Active check box to activate the server for use with SilkCentral.

6. Edit the Hostname or IP-address of the LDAP server and the Port used for the LDAP service as
required.

7. Check the Use SSL check box to connect to the server through SSL.

8. Optional: In the Bind DN field, modify the domain name of the user who is to be used to bind to the
LDAP service as required. Enter the Password of the user defined by Bind DN.

9. Edit the Base DN root for LDAP queries and the Filter that is to be used for querying LDAP as required.

10.Click Test to perform a test connection to the LDAP server.

For additional information, see Testing LDAP Servers.

11.Click OK to save your settings.
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Testing LDAP Servers
Describes how to test the connection to an LDAP server.

To test the connection to an LDAP server:

1. When adding or editing an LDAP server profile in SilkCentral, the Add LDAP Server dialog box,
respectively the Edit LDAP Server dialog box display a Test button.

2. Click Test to display the Test LDAP Configuration dialog box.

3. In the Test username text box, enter a username to be used for testing LDAP authentication.

4. Fill in the Test password associated with the user who is to be used for testing LDAP authentication.

5. Click Test to execute an authentication test.

Note: LDAP error codes are included when tests are unsuccessful. A list of LDAP error codes and
their meaning is available at http://ldapwiki.willeke.com/wiki/LDAPResultCodes.

You will be presented with a dialog box stating whether or not the test was successful.

6. Click Close to return to the Add LDAP Server dialog box, respectively the Edit LDAP Server dialog
box. If the test connection was not successful, edit your settings or ask your system administrator for
assistance, then start over at step 2 again.

Deleting LDAP Servers
Describes how to remove an LDAP server profile.

To delete an LDAP server:

1. In the menu, click Administration > System Settings.

2. Click the LDAP Servers tab.

3. If the LDAP server is active, you need to deactivate it before you can delete it. Click the name of the
LDAP server profile that you want to delete. The Edit LDAP Server dialog box displays.

4. Uncheck the Active check box to deactivate the server and click OK.

5. Click  in the Actions column of the LDAP server you want to delete.

6. Click Yes on the subsequent dialog box to confirm the deletion.

LDAP Servers Page
Administration > System > LDAP Servers

The LDAP Servers page lists all previously configured LDAP servers. Use this page to manage your
LDAP servers.

In this page you can perform the following actions:

• Click New LDAP Server to configure a new LDAP server.
• Select an existing LDAP server from the list to edit the settings.
• Click  in the Actions column to remove a deactivated LDAP server.

New LDAP Server Dialog Box
Tip: The Edit LDAP Server dialog box contain the same items as the New LDAP Server dialog box.

The dialog box includes the following items:
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Item Description

Name Specifies the name of the LDAP server as it should
appear in the SilkCentral GUI. You can define any name
for the LDAP server; this text box has no impact on the
actual LDAP settings.

Description A description of the LDAP server. You can enter any text
for the description of the LDAP server; this text box has
no impact on the actual LDAP settings.

Active Activates the LDAP server, if checked. If unchecked, the
LDAP server's services are not available to SilkCentral.

Hostname The LDAP server URL.

Port The LDAP port. The default port is 389. When using
SSL, the default LDAP port is 636.

Use SSL Defines whether SilkCentral connects to the LDAP server
through SSL (if checked) or without SSL (if unchecked).
This check box is closely related to the settings defined in
the Port text box.

Bind DN (optional) The distinguished name of the user who is to be used to
bind to the LDAP service. This user must have read rights
on the directory from the given Base DN root. If this text
box is left empty, anonymous access will be used, except
for LDAP servers that do not support anonymous access.

Password (optional) The password of the user defined in the Base DN text
box. This is not required when anonymous access is
allowed.

Base DN Base Distinguished Name (DN) root node for LDAP
queries. For example DC=comp,DC=net.

Filter The filter that is to be used for querying LDAP. Filters
must contain a placeholder enclosed in braces.
Additionally to the default placeholder {%username}
SilkCentral also supports more complex expressions.

Example 1: (sAMAccountName={%username})

Example 2: (sAMAccountName =
{user.firstName.substring(0,
1).toLowerCase()}
{user.lastName.toLowerCase()})

The second example builds the sAMAccountName by
appending the lowercase representation of the user's last
name to the lowercase representation of the first
character of the user's first name.

SilkPerformer Load-Test Agent Clusters
In addition to assigning workload to individual agents, you have the option of assigning SilkPerformer
workload to clusters of agents with defined capabilities. SilkPerformer's dynamic workload-assignment
functionality matches specific load-test requirements to the replay capabilities of available agent computers
at execution time. The capabilities that are defined for test agents in SilkPerformer are used to optimize
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workload-to-agent assignment. For example, if a test requires a workload that only an agent computer with
a SAPGUI client can deliver, then dynamic workload-assignment functionality can ensure that the test's
workload is assigned only to available agents with SAPGUI clients. Additionally, the percentage of required
workload or virtual users that can be allocated to each agent can be configured, thereby ensuring that
agents are not pushed beyond their capacities.

Upon execution of a SilkPerformer test, a SilkCentral load-test agent-clusters XML file is checked out of the
appropriate execution server and used for dynamic workload assignment during execution. You must
specify the location of your project's load-test agent-clusters XML file by way of Administration > System
settings.

An advantage of dynamic assignment of workload to load-test agent clusters is that successful execution of
tests is not contingent on maintaining a static test-execution environment. SilkPerformer can dynamically
assign an unavailable agent's workload to an available agent in the same cluster that has the same
capabilities. This feature is of particular value when SilkPerformer load tests are managed and executed
based on predefined schedules in SilkCentral. The manner in which workload is balanced across agents
and the health of individual agents are not issues to consider from the SilkCentral perspective.

For details regarding dynamic workload assignment, refer to the SilkPerformer Help.

Uploading Load Test Agent Cluster Files
Describes how to add or change your project's load-test agent-clusters file in support of SilkPerformer
dynamic workload assignment.

To change your project's agent-clusters file definition:

1. In the menu, click Administration > System Settings.

2. Click the Load Test Agent Clusters tab.

3. Click Upload.

4. On the Upload Agent Clusters File dialog box, browse to the location of the agent-cluster file on your
local disk.

When you upload the file, it is displayed in the Load Test Agent Clusters page.

5. Click OK to confirm your selection.

Deleting Load Test Agent Clusters Files
Delete a load-test agent clusters file to remove it from the application server.

To delete a load-test agent clusters file:

1. In the menu, click Administration > System Settings.

2. Click the Load Test Agent Clusters tab.

3. Click Delete.

4. Click Yes confirm the deletion of the settings.

Editing Load Test Agent Cluster Files
To edit your project's agent-clusters file definition:

1. In the menu, click Administration > System Settings.

2. Click the Load Test Agent Clusters tab.

3. Click on the name of the load-test agent-clusters file that you want to change.

4. Donwload the file.

5. Edit the file with an editor.

6. Upload the file.
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For additional information, see Uploading Load Test Agent Cluster Files.

Load Test Agent Clusters Page
Administration > System Settings > Load Test Agent Clusters

The Load Test Agent Clusters page shows the currently configured load-test agent-clusters XML file. Use
this page to manage SilkPerformer load-test agent-cluster files in support of dynamic workload assignment.

From this page you can perform the following actions:

• Click Upload to upload a load-test agent-clusters XML file.
• Click Delete to remove an existing load-test agent-clusters XML file.
• Click on the name of the load-test agent-cluster file to download the file.

Mail Host Location
To have reports emailed to you to update you about results from your application, you must specify the
location of your mail server. You may only configure email settings if you have administrator privileges.

Note: SilkCentral supports basic SMTP authentication (LOGIN PLAIN).

Specifying a Location for the Mail Host
Describes how to specify the location of up to three mail servers.

To specify the location of up to three mail servers:

1. In the menu, click Administration > System Settings.

2. Click the Notification tab.

3. In the Server 1, Server 2 and Server 3 text boxes, type the mail server hostname or IP address of your
email server(s).

4. Type the Email address of system administrator, and the 'From' address to use for emails.

5. To confirm that the configuration is functional, click Check. Then verify that the system administrator
receives a test email notification from the application.

If you receive an error message, or if you do not receive an email, review your mail settings. Ensure
that the hostname of your email server is correct and that the SMTP protocol is running on that
computer.

6. If you receive a notification that the test mail has been sent, click Save.

Email notification is now ready for use.

Notification Page
Administration > System Settings > Notification

Use this page to configure a mail server for your SilkCentral applications. The page displays the following
items:

Item Description

Email address of system administrator Specifies the mail address of the SilkCentral system
administrator. You must enter an address here to
complete the configuration. You may add any valid email
address.
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Item Description

'From' address to use for emails Specifies the name that is to appear in the From field
when someone receives an email from the system. This
can be any email address, for example
System_message@mycompany.com.

Server 1

Server 2

Server 3

The names or IP addresses of the servers that send your
mail. For many companies, this server is simply called
mail. If your mail server uses SMTP authentication
(LOGIN PLAIN), you must enter a valid user and
password for the mail server. Contact your mail server
administrator if you do not know the login credentials.

Check Sends a test email to the recipient defined in the Email
address of system administrator text box.

Reset Clears all items on this page.

Save Saves your settings.

System Proxies
Configure a system proxy to enable execution servers of a certain location to communicate with the
application server through the proxy. Once you have specified the location of a proxy server, you can
select the defined proxy server in your location configuration. Enabling this setting will force all execution
servers of the location to communicate with the application server through the defined system proxy.

Configuring a System Proxy
This procedure explains how to configure a system proxy. To use a proxy for your location you must
configure a system proxy.

To configure a system proxy:

1. In the menu, click Administration > System Settings.

2. Click the System Proxy tab.

3. Specify the Host and the Port of the proxy that should be used.

4. Specify Username and Password if required by the proxy.

5. To confirm that the configuration has been successful, click Check. A message informs you whether or
not connection to the proxy server has been successful.

6. If you receive an error message, review your system proxy settings. Make sure that a system proxy is
installed and running on the host you specified.

7. Click Save.

Your system proxy is now ready for use.

System Proxy Page
Administration > System Settings > System Proxy

Use this page to configure a system proxy. The page displays the following items:
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Item Description

Host The hostname or IP-address of the computer that is
intended to serve as system proxy.

Port The port number on which the system proxy listens. The
default port is 8080.

Username (if required) Type a valid username if the proxy server requires login
credentials.

Password (if required) A valid password for the specified Username.

Reset Clears all items on this page.

Check Tests the connection to the proxy with the credentials you
provided.

Save Saves your settings.
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Configuring the Application
This section contains conceptual information about user accounts, projects, locations, and execution
servers. It also covers the administration of custom reports and managing uploaded files, and the
configuration of other common entities.

Once you have completed the initial configuration of SilkCentral (system configuration), this section will
guide you through the steps required to set up user accounts, projects, locations, execution servers, and
more. These tasks must be performed by an administrator.

User Roles and Permissions
When working with SilkCentral, tasks are assigned to designated groups of users who have access to
assigned projects. Within groups, users are granted specific roles within those projects. User permissions
are configured based on user role type and group membership. This topic defines each permission type
and details the specific permissions that are associated with each user role.

Each user account can belong to one or multiple groups. A group specifies which roles a user has within
that group. Groups are assigned to projects. So the permissions that each individual user has are derived
from the group/role assignments that have been defined for them. Defined permissions apply only to the
projects that are assigned to the groups in which each user has a group/role assignment.

User Roles
There are seven predefined user roles:

• SuperUser
• Administrator
• Project Manager
• Test Manager
• Tester
• Analyst
• Reporter

These roles cannot be modified or deleted. They can however be copied and thereby used as the basis for
customized roles.

SuperUser

The SuperUser role is a special role that is granted all privileges across SilkCentral applications.

Administrator

Administrator tasks include the configuring of application-, Web-, and chart-server locations; setting up and
maintaining repositories and notification settings; creating accounts; configuring locations and execution
servers, and others.

Administrators are granted all privileges across SilkCentral and Issue Manager.

Project Manager

Project Managers maintain the projects for which they are responsible. Project Managers do not have write
access to the SilkCentral Administration Module. Project Managers can only access the projects to which
they have been assigned as Project Managers, where they have full write access to all project-related
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features. Project Managers also have all Issue Manager permissions for projects that are assigned to
them.

Test Manager

Test Manager responsibilities include the planning and execution of tests, including the deletion of tests.
Test Managers also have full access to libraries of shared steps and full read access to the Requirements
area in Test Manager.

Tester

The Tester role relates to Test Manager privileges. The Tester’s tasks include the planning and execution
of tests—though Testers cannot delete tests. Testers also have full read access to the Requirements
area, and can view, create, and edit all objects in libraries of shared steps.

Analyst

Analysts analyze the results of projects that have been assigned to them. They cannot modify project
settings or schedules and have read-only privileges.

Reporter

In addition to having all the rights of Analysts, Reporters additionally have the right to edit and delete
reports in Advanced mode. Advanced mode allows reporters to enter, modify, and delete SQL statements
for advanced reports. For details on advanced reports, refer to the SilkCentral application Help.

Adding User Roles
To add a user role:

1. In the menu, click Administration > User Management.
2. Click the Roles tab.

3. Click New Role.

The New Role page displays.

4. Type a Name for the new role.

5. Optional: Type a Description for the role.

6. In the Permission Settings list, check the Allow text box for all permissions you want to grant to this
role.

Note: Checking a top-level parent task automatically checks all child tasks of that parent. When
some but not all child tasks of a parent task are selected, the parent task is checked with a grayed-
out check mark, indicating partial permissions in that area.

7. Click Save to save your permission settings for this role.

Editing User Roles
Note: Predefined user roles cannot be edited. Custom user roles can be edited.

To edit a user role:

1. In the menu, click Administration > User Management.
2. Click the Roles tab.

3. Click the name of the role that you want to edit in the Roles list.

The Edit Role page displays.

4. Edit the Name of the role as required.

5. Edit the Description of the role as required.
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6. In the Permission Settings list, check the Allow check boxes of all permissions that you want to grant
to this role. Uncheck any selected permissions that are not to be granted to this role.

Note: Checking a top-level parent task automatically checks all child tasks of that parent. When
some but not all child tasks of a parent task are selected, the parent task is checked with a grayed-
out check mark, indicating partial permissions in that area.

7. Click Save to save your permission settings for this role.

Copying User Roles
Tip: Copying existing user roles is the first step in creating a custom user role. After copying an
existing role, rename it and edit its permissions to meet your needs.

To copy a user role:

1. In the menu, click Administration > User Management.

2. Click the Roles tab.

3. In the Actions column of the user role that you want to copy, click Duplicate Role.

The copy of the role then displays in the list of user roles where you can rename it and customize it as
required.

Deleting User Roles
Note: Predefined user roles cannot be deleted. Custom user roles can be deleted.

To delete a user role:

1. In the menu, click Administration > User Management.

2. Click the Roles tab.

3. In the Actions column of the user role that you want to remove, click Delete. A confirmation dialog box
displays.

4. Click Yes to confirm the operation; click No to abort. If you choose Yes, you will be returned to the list
of user roles where the deleted role will no longer be listed.

Roles Settings Page
Administration > User Management > Roles

The Roles Settings page is used to configure user roles. The page displays the following items:

Item Description

Actions
Click  to duplicate a role and use it
as the basis for a new, custom role.

Click  to delete a user role.

Name The name of the user role as it
displays in the GUI.

Allow New Assignment Click to allow or prevent an existing
user role from accepting new user
assignments. This is useful when a
user role has been discontinued while
some user accounts still retain the
role.

Description Description of the user role.
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Item Description

Created On Date the role was created.

Created By User who created the role.

Permission Definitions
To display the permissions in Test Manager: In the menu, click Administration > User Management.
Click the Roles tab. Click on a role in the grid. The permissions for that role display.

This section explains the permissions that govern user ability to perform tasks and access secure areas
within SilkCentral. There is a separate list for each permission category.

Note: Permissions for predefined roles cannot be edited.

Requirements Permissions
The following permissions are available for requirements:

Administrator Project
Manager

Analyst Tester Test Manager Reporter

View
requirements

X X X X X

Manage
requirements

X

Delete
requirements

X

Manage
requirements
management
integrations

X X

Delete
requirements
management
integrations

X

Libraries Permissions
The following permissions are available for libraries:

Administrator Project
Manager

Analyst Tester Test Manager Reporter

View libraries X X X X X

Manage
libraries

X X

Delete libraries X

Tests and Executions Permissions
The following permissions are available for tests and executions:
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Administrato
r

Project
Manager

Analyst Tester Test
Manager

Reporter

View tests and executions X X X X X

Manage tests and executions X X

Delete tests and executions X

Manage source control
integrations

X X

Delete source control
integrations

X X

Manual Execution Planning Permissions
The following permissions are available for manual execution planning:

Administrator Project
Manager

Analyst Tester Test Manager Reporter

View testing
cycles and
configurations

X X X X X

Manage
testing cycles
and
configurations

X

Delete testing
cycles and
configurations

X

Issues Permissions
The following permissions are available for issues:

Administr
ator

Project
Manager

Analyst Tester Test
Manager

Reporter

Manage issue tracking integrations X X

Delete issue tracking integrations X X

Quality Goals Permissions
The following permissions are available for quality goals:

Administrator Project
Manager

Analyst Tester Test Manager Reporter

View quality
goals

X X X X X

Manage quality
goals

X X

Delete quality
goals

X X
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Reports Permissions
The following permissions are available for reports:

Administrator Project
Manager

Analyst Tester Test Manager Reporter

View reports X X X X X

Manage
reports

X X X X

Manage
advanced
reports

X

Delete reports X X X X

Projects Permissions
The following permissions are available for projects:

Administrator Project
Manager

Analyst Tester Test Manager Reporter

Manage
projects

X X

Delete projects X X

Project Settings Permissions
The following permissions are available for project settings:

Administrator Project
Manager

Analyst Tester Test Manager Reporter

View project
settings

X X X X X

Manage
project settings

X X X

Delete project
settings

X X

Manage filters X X X

Delete filters X X X

Modify private
filters of other
users

X X

Delete private
filters of other
users

X X

Administration Permissions
The following permissions are available for administration:
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Administra
tor

Project
Manager

Analyst Tester Test
Manager

Reporter

View system settings X X X X

Manage system settings X

View administration
settings

X X X X

Manage administration
settings

X

Delete administration
settings

X

View and delete log files X X X X

Manage execution
servers

X

Delete execution servers X

Dashboard Panel Permissions
To view or edit the content of a certain dashboard panel, you need the following permissions:

Panel Permission

Custom Information Manage projects required for editing.

No permission required for viewing.

Introduction No permission required.

Issue Life Cycle View project settings.

Issues Created per Tester View tests and executions.

Manual Tests Assigned to Me Manage tests and executions.

Quality Goal Progress View quality goals.

Requirements Coverage Status View requirements.

Testing Cycle Progress View testing cycles and configurations.

Testing Cycle Result Summary View testing cycles and configurations.

Testing Progress Across Testing Cycles View testing cycles and configurations.

Volatile Tests View tests and executions.

User and Group Accounts
A user account must be created for each user working with SilkCentral. One or more groups of users are
assigned to specific projects. Only with a user account, a user role, and a group assignment can a user
work with a SilkCentral project.

Maintaining User Accounts
User accounts track login data and configuration settings for individual users. They also enable user login.
User accounts are typically assigned to group accounts with one or more specific user roles for specific
projects. The SuperUser is the only user role that can, among other things, configure the application-,
Web-, and chart server locations; and set up and maintain repositories and notification settings.
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Caution: Because the SuperUser account admin has all administrative privileges, you should
immediately designate a new password for this user to prevent unlimited access to these privileges.
For more information on changing the password, see Changing the Password of the System
Administrator Account.

Adding User Accounts
To add a user account:

1. In the menu, click Administration > User Management.
2. Click the Accounts tab.

The page displays all available user accounts. When you access this page for the first time, the
SuperUser account admin is the only user listed.

3. Click New User. The Add new user account page displays.

4. Type a username and password for the user. Type the password a second time to confirm it.

5. Check the Mixed mode authentication (LDAP) check box to enable both LDAP and local-credential
based authentication.

6. Set the login to Locked if you want to prevent the user from logging in.

7. Type the user’s first name, last name and email address.

8. Type the user’s local time zone and select a date format, a short date format, and the first day of the
week.

9. Type the Page refresh time in seconds, the CSV separator string, and a Default execution server.
10.Select a group and role definition from the respective list boxes.

11.Click Add Assignment to add the group and role combination to the user account.

12.Repeat the previous two steps to assign all desired group and role combinations to the user account.

13.To remove a group and role combination from the current user account, click the Delete icon in the
Actions column.

14.Click Save to save your settings.

Editing User Accounts
Once a user account is set up you may edit any of the parameters, except the Login name.

Note: Changes to a user account become active upon the next login of the changed user account.
Please notify the user to logout and login again.

To edit a user account:

1. In the menu, click Administration > User Management.
2. Click the Accounts tab.

The page displays all available user accounts. When you access this page for the first time, the
SuperUser account admin is the only user listed.

3. Click the Login name of the user account that you want to edit. The Configure existing user page
displays.

4. Edit the password of the user as required. Type the password a second time to confirm it.

5. Check the Mixed mode authentication (LDAP) check box to enable both LDAP and local-credential
based authentication.

6. Edit other user settings as required.

7. Select a group and role definition from the respective list boxes.

8. Click Add Assignment to add the group and role combination to the user account.

9. Repeat the previous two steps to assign all desired group and role combinations to the user account.

10.To remove a group and role combination from the current user account, click Delete in the Actions
column.
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11.Click Save to save your settings.

Deleting User Accounts
Caution: Deleting a user account is not reversible. You may lock a user account instead, if you want
to temporarily make an account unavailable. For additional information about locking user accounts,
see Editing User Accounts.

To delete a user account:

1. In the menu, click Administration > User Management.

2. Click the Accounts tab.

The page displays all available user accounts. When you access this page for the first time, the
SuperUser account admin is the only user listed.

3. In the Actions column of the user account you want to remove, click Delete. A confirmation dialog box
displays.

4. Click Yes to confirm the operation; click No to abort. If you choose Yes, you will be returned to the list
of user accounts where the deleted account will no longer be listed.

User Settings Page
Administration > User Management > Accounts > New/Edit User

Use the User Settings page to configure user accounts. User account settings are closely related to group
account settings.

You can click on the name of the user in the menu to access the User Settings page for the logged-in
user.

Note: You must define at least one group and role assignment to save a user account.

Login Data Item Description

Login The username to be stored in the SilkCentral repository.
If you check Mixed mode authentication (LDAP) below,
the entered username must match the defined LDAP
username.

Password Enter a valid password for the Login that you entered.
This password is not related to the LDAP password.

Confirm password Enter the password again to confirm it.

Mixed mode authentication (LDAP) Check this check box to enable both LDAP and local-
credential based authentication. If an LDAP server exists,
not checking this check box results in LDAP-only
authentication.

Locked Check this check box if you want to prevent the user from
logging in with the given credentials. This makes the user
account inactive.

General Data Item Description

First name Type the user’s first name. This information does not
affect the behavior of SilkCentral; it simply tracks user
contact information.
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General Data Item Description

Last name Type the user’s last name. This information does not
affect the behavior of SilkCentral; it simply tracks user
contact information.

Email Type the user’s email address. This information is used
for notification purposes.

Time zone The user’s local time zone. Time zone information is used
to display times and dates in the user’s local time zone.

Date format The selected date format is presented to the user in lists,
reports, and in the calendar whenever SilkCentral
displays a long date format.

Short date format The selected date format is presented to the user in lists,
reports, and in the calendar whenever SilkCentral
displays a short date format.

First day of week The first day of the week determines the weekly view in
reports.

Page refresh time The page refresh time in seconds. This setting
determines the time interval at which report pages are
refreshed automatically when the selected calendar
range is set to last 24 hours. Type 0 (default value)
if you do not want reports to refresh automatically. The
page refresh time only affects pages that support
automatic page refreshing.

CSV separator string This string is used as a row separator for the user’s
downloaded CSV-files. Reports can be downloaded as
CSV-files.

Default Execution Server The default execution server is used for try runs of
automated tests, and when no available execution server
is set for the execution plan.

Group and Role Assignments Item Description

Group and Role Assignments table Lists all existing user group/user role assignments of the
user. You can also delete group and role assignments by

clicking  next to the assignment you want to remove.

Group Select a group to which the user is to be assigned. This
list box lists the user groups that have been defined by a
SilkCentral administrator.

User role Select the user role with which the user is to be assigned
to the selected group.

The list is populated with the pre-defined system roles
and the custom user roles.

Add Assignment Click this button to create a new user group/user role
assignment with the group and user role you selected.
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Maintaining Group Accounts
Group accounts define access to specific projects. Each user can be associated with one or more group
accounts from which they inherit the access rights to the projects that are defined for the selected group
account.

Note: Users can be added to group accounts with multiple roles, allowing advanced user permission
configuration.

Adding Group Accounts
To add a group account:

1. In the menu, click Administration > User Management.

2. Click the Groups tab.

3. Click New Group. The Add new group account page displays.

4. In the Group name text box, type a group name for the new group.

5. In the Description text box, enter a description for the new group.

6. Select a user with a role assignment from the respective list boxes, then click Add Selection to add the
user and role combination to the new group account.

Note: Any user roles that have been defined as not accepting new user assignments are not
displayed in this list. These settings are controlled through the Allow New Assignment buttons at
Administration > User Management > Roles .

7. Repeat the previous step to assign all desired user and role combinations to the user account.

8. To remove a user and role combination from the current group account, click  in the Actions column.

9. In the Project Assignment(s) section you can assign any existing projects to this group.

10.Click Save. You will be returned to the User groups page where the new group is listed.

Editing Group Accounts
To edit a group account:

1. In the menu, click Administration > User Management.

2. Click the Groups tab.

3. Click the group name of the group account you want to edit. The Configure existing user group page
displays.

4. In the Group Name text box, edit the name as required.

5. In the Description text box, edit the group's description as required.

6. Select a user with a role assignment from the respective list boxes, then click Add Selection to add the
user and role combination to the new group account.

Note: Any user roles that have been defined as not accepting new user assignments are not
displayed in this list. These settings are controlled through the Allow New Assignment buttons at
Administration > User Management > Roles .

7. Repeat the previous step to assign all desired user and role combinations to the user account.

8. To remove a user and role combination from the current group account, click  in the Actions column.

9. In the Project Assignment(s) section you can assign any existing projects to this group.

10.Click Save to return to the Groups page.

Deleting Group Accounts
Describes how to delete a group account.
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Note: Before you can delete a group account, you must remove all user and role assignments from
the group. For additional information about modifying group accounts, see Editing Group Accounts.

To delete a group account:

1. In the menu, click Administration > User Management.
2. Click the Groups tab.
3. In the Actions column of the group account you want to remove, click . A confirmation dialog box

displays.
4. Click Yes to confirm the operation; click No to abort. If you choose Yes, you will be returned to the list

of user accounts where the deleted account will no longer be listed.

Group Settings Page
Administration > User Management > Groups > New/Edit Group

Use the Group Settings page to configure group accounts. Group account settings are closely related to
user account settings. The page displays the following items:

Item Description

Group name Specifies the name of the group as it should display in the
GUI. You can define any name for the group.

Description A description of the group account. You can enter any
text for the description.

Account and Role Assignment(s) Lists all existing user user/role role assignments of the
group. You can also delete user and role assignments by

clicking  next to the assignment you want to remove.

User This list box lists the user accounts that have been
defined by an administrator. Select a user to be assigned
to the group.

User role The list is populated with the pre-defined system roles
and the custom user roles.

Select the user role with which the user is to be assigned
to the selected group.

Add Selection Click to create a new user account and user role
assignment with the selected user and user role.

Project Assignment(s) Lists all existing projects and whether they are assigned
to the group account. Check the check box next to a
project to assign the project to the group account. If no
projects exist, you may assign them later after you have
created them.

Select All Checks the check boxes of all listed projects.

Deselect All Un-checks the check boxes of all listed projects.

Managing Projects
This topic describes the conceptual background of projects in SilkCentral.

Projects are a prerequisite for beginning work with any SilkCentral application. Projects serve as containers
for related sets of tasks and results. Resources such as project managers and analysts are allocated to
projects by assigning them to user groups, which have access rights to certain projects.
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Note: Projects can be created and maintained by the administrator, project manager, and SuperUser
roles.

Adding Projects
To create a project:

1. In the menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.

2. Click New Project. The Project Settings page displays.

3. Type a Project name and Description.

4. Select the Project Owner.

5. Optional: To create a project based on the Agile project template, choose Agile Project Template from
the Project Template list box.

6. The Groups section includes a list of registered user groups. Check the Assigned check boxes of the
user groups that will work with this project.

7. A list of locations is located at the bottom of the page. Select the location(s) from which this project's
tasks are to be executed. Click Select All to assign all locations to the project, or click Deselect All to
select no locations.

8. Click Save to save your settings. You are returned to the Project List page where the new project is
listed.

Editing Projects and Project Baselines
To edit an existing project or project baseline:

1. In the menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.

2. Click  in the Actions column of the project name of the project or project baseline you want to edit.

Note: The project or project baseline must be inactive.

3. Edit the Project name and Description as required.

4. Change the Project Owner as required.

5. Check the Active check box to activate the project or project baseline.

6. The Groups section includes a list of registered user groups. Check the Assigned check boxes of the
user groups that will work with this project.

7. A list of locations is located at the bottom of the page. Select the location(s) from which this project's
tasks are to be executed. Click Select All to assign all locations to the project, or click Deselect All to
select no locations.

8. Click Save to save your settings. You are returned to the Project List page.

Activating or Deactivating Projects and Project
Baselines

Note: You can also activate or deactivate an existing project or project baseline from the Project List
page. For additional infomation, see Editing Projects.

To activate or deactivate an existing project or project baseline:

1. In the menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.
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2. Click Active/Inactive in the Status column of the project or project baseline you want to activate or
deactivate. A confirmation dialog box displays, asking you if you are sure about the activation or
deactivation.

3. Confirm to toggle the project status to Active or Inactive.

Copying Projects or Project Baselines
Describes how to copy an existing project or project baseline to a new project.

Caution: Copying a project or project baseline can lock the database for several minutes, depending
on the size of the project or project baseline that is being copied. It is recommended to copy projects
or project baselines during off-hours, when user activity on SilkCentral is minimal.

Note: If the original project or baseline includes schedules, the scheduling options are set to none
during the copy.

To copy a project or project baseline:

1. In the menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.

2. Click  in the Actions column of the project or project baseline you want to copy. The Copy Project
dialog box displays.

3. In the New project name text box, type a name for the new project.

4. Check the check boxes of any additional information types you want to have copied along with the new
project. When you check the Test history check box, the versions are also copied.

For detailed information on the check boxes, see Copy Project Dialog Box.

5. Click OK.

If your project or project baseline is initialized for Issue Manager, the Copy Project - Issue Manager
dialog box displays.

If your project or project baseline is not initialized for Issue Manager, or you have not installed Issue
Manager, you will receive a message indicating that no Issue Manager depending data will be copied.

Refer to the Issue Manager documentation for detailed information on how to initialize a project for
Issue Manager.

6. Check the Copy Issues check box to copy all of the source project’s existing issues to the new project.

7. Check Copy Archived Issues to copy all of the source project’s archived issues to the new project.

8. Click OK.

9. Click Yes on the Copy Project dialog box, confirming that you want to begin the copy process and that
you know the process may take several minutes. When the copy process is complete, a dialog box
informs you what has been copied and asks you if you want to activate the project, thereby making the
project available in Test Manager’s project view.

Deleting Projects and Project Baselines
Caution: When you delete a project or project baseline you permanently remove all related results
from the repository. You also destroy all content associated with the project or project baseline. If you
want to keep results, we recommend that you set a project or project baseline to inactive rather than
delete it. For information on deactivating projects and project baselines, see Activating or Deactivating
Projects or Project Baselines.

To delete a project or project baseline:

1. In the menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.

2. Click  in the Actions column of the project or project baseline you want to remove.
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Note: The project or project baseline must be inactive.

A confirmation dialog box displays, asking you to confirm the deletion.

3. Click Yes to remove the project or project baseline; or click No to abort the operation. If you choose
Yes, you will be returned to projects list, where the deleted project or project baseline is no longer
listed.

Copy Project Dialog Box
Projects > Projects List > Copy Project

Use this dialog box to copy an existing project to a new project.

Note: Check the check boxes of any additional information types you want to have copied along with
the new project. If you don’t select additional information types, an empty project with only group
assignments, location assignments, and project settings is copied.

Item Description

New project name Specifies the name of the new project to which the
existing project is copied to.

New project description Specifies the description of the new project to which the
existing project is copied to.

Settings Check this check box to copy project settings, filters,
attributes, custom requirement properties, change
notification, and integration configuration setting
information to the new project. Third-party integration
configuration setting information is not copied.

Requirements tree (includes Requirements settings) Check this check box to copy the requirements tree with
all information for each requirement, for example
properties, attachments, and others. Third-party
requirement information is not copied. When a project
has been configured for an external requirements
management system, you are asked if you want to
transfer the RMS settings to the copy of the project.

Requirements history Check this check box to copy the historical information for
each requirement. This option is only available when
Requirements tree is checked.

Tests tree (includes Tests settings) Check this check box to copy the tests tree with all
information for each test. When both Requirements tree
and Tests tree are checked, in addition to the information
listed above, the information related to the relationship
between requirements and tests (assigned requirements
and assigned tests) is also copied

Tests history Check this check box to copy the historical information for
each test. This option is only available when Tests tree is
checked.

Execution Plans tree (includes Tests tree) Check this check box to copy the execution tree with all
information for each execution plan.

Last runs of tests Check this check box to copy the last run of each test.
This option is only available when Execution Plans tree
is checked. When Requirements tree, Execution Plans

54 | Configuring the Application



Item Description

tree, and Last runs of tests are checked, all trees are
copied in their entirety. The relationship between the
trees is also established.

Reports Check this check box to copy all project-related reports to
the new project.

For Issue Manager, the dialog box displays the following additional check boxes:

Copy Project — Issue Manager Dialog Item Description

Copy Issues Check this check box to copy all of the source project’s
existing issues to the new project.

Copy Archived Issues Check this check box to copy all of the source project’s
archived issues to the new project.

If you do not check either check box, issue data will not be copied to the new project.

Source project configurations are automatically copied to the new project. These include:

• Products
• GUI configuration
• Notification rules and systemwide triggers
• Routing rules
• Workflow
• User views on inboxes
• Workgroups
• Inboxes
• User account configuration

Project Settings Page
Project > New Project

Use the Project Settings page to configure projects. The page displays the following items:

Item Description

Project Name Specifies the name of the project as it should appear in
the GUI and in reports.

Description A description of the project. You can enter any text for the
description.

Project Owner Specifies the owner of the project. The selected user
account does not have any special privileges; this setting
is purely informative.

Active Check this check box to activate the project. Inactive
projects are not visible in your application.

Project Template This list box defines whether a project is based on the
Agile project template or not. Choose Agile Project
Template to base the project on the template for Agile
project-management tools, or <None> to create a simple
project.
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Item Description

Groups Lists all existing user groups and whether they are
assigned to the project. Check the check box next to a
user group to assign the group to the project. If no user
groups exist, you may assign them later after you have
created them. You can also configure the group/project
assignment on the Group Settings page. Privileges vary
based on user roles. For information about user
privileges, see User Roles and Permissions.

Select All Checks the check boxes of all listed groups.

Deselect All Un-checks the check boxes of all listed groups.

Location Lists all existing locations and whether they are available
to the project.Check the check box next to a location to
assign the location to the project. If no locations exist, you
may assign them later after you have created them. You
can also configure the location/project assignment on the
Location Settings page.

Select All Checks the check boxes of all listed locations.

Deselect All Un-checks the check boxes of all listed locations.

Project Baselines
This topic describes the conceptual background of project baselines in SilkCentral.

A project baseline is a snapshot of a project at a given time and can be created for any project or even
another project baseline. The last run of each execution plan in the project is also included in the project
baseline. The schedule options included in a project baseline are initially set to none, to prevent losing the
execution status of the last runs. An example usage of a project baseline is to save a snapshot of a project
immediately after a release. The Baseline Comparison report in Test Manager shows the amount of tests
that are currently different in the project compared to the project baseline. For more information on the
report, refer to the Test Manager Help.

For each new project baseline that includes an element of the Tests area, the History page of the element
includes an entry with links to the project baseline and the corresponding element in the project baseline. If
the element itself was created as part of a project baseline, the first entry in the History page includes links
to the original project and the corresponding element in the original project.

When tests in the original project include calls to shared steps objects from libraries, you can define during
the creation of the project baseline whether all calls are resolved or kept. The project baseline has the
same visibility on the libraries as the original project. For more information on shared steps objects, refer to
the Test Manager Help.

Note: Project baselines can be created by the administrator, project manager, and SuperUser roles.

Creating a Baseline for a Project
Caution: Creating a baseline for a project can lock the database for several minutes, depending on
the size of the project that the baseline is created for. We recommend to create a baseline for a
project during off-hours, when user activity on SilkCentral is minimal.

Note: If the original project includes schedules, the scheduling options in the new baseline are set to
none to prevent losing the last execution status. When tests in the original project include calls to
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shared steps objects, the baselined tests also call the same shared steps objects. When you create a
baseline, the History page of each Test item included in the baseline is updated with an entry for the
baseline.

To create a baseline for a project:

1. In the menu, click Projects > Project List . The Projects page displays, listing all existing projects and
project baselines.

2. In the Actions column of the project you want to create a baseline for, click . The Baseline Project -
Test Manager dialog box displays.

3. Type a name and a description for the new baseline.

4. Optional: If the project contains tests that use shared steps from libraries, define the handling of the
shared steps in the Library Assets Handling section.

• Click Detach Library Assets to detach all manual test steps from the containing shared steps
objects into the tests of the baseline. Choose this option to create a project baseline for historical or
auditing purposes.

• Click Keep References to Library Assets to keep all references from manual test steps to the
shared steps objects in the tests of the baseline. Choose this option to create a working copy for
ongoing testing purposes, for example a new version of the project.

5. Optional: If the project contains manual tests, define in the Test asset versioning section whether a
new version should be created for the tests in the original project and in the baseline.

• Check the Create new versions for all assets in original project check box to create new
versions for all manual tests with shared steps in the original project.

• Check the Create new versions for all assets in new baseline check box to create new versions
for all manual tests with shared steps in the baseline.

Note: Versions are not created for data-driven instances.

6. Click OK. The Baseline Project dialog box displays and informs you that the operation may take
several minutes to complete.

7. Click Yes to continue. The Baseline Project - Adapt Project Settings dialog box opens. The dialog
box displays the requirement integration settings along with all source control profiles that are
configured for the original project.

8. Click the corresponding Edit button to link the project baseline to the appropriate baseline, branch,
label, or other point of reference in the source control profile, or to change the requirement integration
settings.

Note: For more information on editing source control profiles, refer to the Test Manager Help.

9. Click Finish to finish creating the baseline.

10.Click Yes in the Baseline Project dialog box to activate the new baseline.

Project Templates
This topic describes the conceptual background of project templates in SilkCentral.

The Agile project template is used to support the interaction between SilkCentral and VersionOne or other
Agile project management tools. The template is a project with the specific attributes sprint and release.
When you create a new project based on this template, a default test container and a default folder are
also created. When the project management tool creates a test, the test is added to the default folder. No
source control profile and no product are specified for the test container and the folder, therefore they are
marked as incomplete.
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Managing Locations
This topic describes the conceptual background of locations in SilkCentral.

Locations are logical containers for execution servers. For information on setting up execution servers, see
Setting Up Execution Servers. Since SilkCentral supports worldwide distribution of Points of Presence
(PoP) — the distribution of execution servers — it is desirable to group execution servers into locations.

Note: SilkCentral automatically creates a default location called Local.

Adding Locations
To add a new location:

1. In the menu, click Administration > Execution Servers.

2. Click New Location. 

The New location dialog box displays.

3. Type a Location Name.

4. If you have specified the location of a proxy server, select Use System Proxy by checking the
respective check box.

For more information, see Configuring a System Proxy.

5. In the Location Proxy section, you can define a proxy server through which the execution servers of
this location will communicate with the application server.

6. In the Host text box, type the name of the computer hosting the proxy service.

7. In the Port text box, type the port number of the proxy host.

8. If the proxy server requires a username/password authentication, type the valid credentials in the User
and Password text boxes.

9. The Projects section includes a list of existing projects. Check the Assigned check boxes of the
projects that you want to assign to this location.

10.Click Save to add the new location. You are returned to the Locations page where the new location is
listed.

Editing Locations
Describes how to edit a location.

To edit a location:

1. In the menu, click Administration > Execution Servers.

2. In the Actions column of the location you want to modify, click . 

The Edit Location dialog box displays.

3. Modify the Location Name as required.

4. If you have specified the location of a proxy server, select Use System Proxy by checking the
respective check box.

For more information, see Configuring a System Proxy.

5. In the Location Proxy section, you can define a proxy server through which the execution servers of
this location will communicate with the application server.

6. In the Host text box, type the name of the computer hosting the proxy service.

7. In the Port text box, type the port number of the proxy host.
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8. If the proxy server requires a username/password authentication, type the valid credentials in the User
and Password text boxes.

9. The Projects section includes a list of existing projects. Check the Assigned check boxes of the
projects that you want to assign to this location.

10.Click Save. You are returned to the Locations page.

Deleting Locations
Tip: Before you can delete a location, you must first remove all assigned execution servers from the
location. For more information, see Deleting Execution Servers.

To delete a location:

1. In the menu, click Administration > Execution Servers.

2. In the Actions column of the location you want to remove, click . A confirmation dialog box displays,
asking you to confirm the deletion.

3. Click Yes if you want to remove the location, or click No to abort the operation. If you choose Yes, you
will be returned to the list of locations, where the deleted location will no longer be listed.

New Location Dialog Box
Administration > Execution Servers > Locations > New/Edit Location

Use the New Location dialog box to configure locations.

Item Description

Name Specifies the name of the location as it should appear in
the GUI and in reports.

Use system proxy Enabling this setting will force all execution servers of this
location to communicate with the application server
through the defined system proxy. If this setting is not
enabled, the application server will communicate directly
with the execution servers, unless you define a location
proxy. This check box is disabled if no system proxy is
defined.

Location proxy Use this area to define a proxy server through which the
execution servers of this location will communicate with
the application server. Leave the fields empty if you want
the execution servers of this location to communicate
directly with the application server, or if you checked the
Use system proxy option. You can also define a system
proxy and a location proxy, in which case the
communication will be tunneled through both proxies.

You may only define a location proxy that supports
Secure Sockets Layer (SSL). All execution servers must
use the SSL port of the proxy. For detailed information
about execution server settings, see Setting Up
Execution Servers.

Hostname The name of the computer hosting the proxy service.

Port The port number of the proxy host. Default is port 443.

Username If the proxy server requires a username/password
authentication, enter a valid username.
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Item Description

Password If the proxy server requires a username/password
authentication, enter a valid password for the username
specified in the Username text box.

Assigned Projects Lists all existing projects. Check the check box next to a
project to assign the project to the location. If no projects
exist, you can assign them later after you have created
them. For more information, see Adding Projects.
Selected projects will have access to the execution
servers at this location.

Select All Checks the check boxes of all listed projects.

Deselect All Un-checks the check boxes of all listed projects.

Setting Up Execution Servers
SilkCentral execution servers are responsible for executing scheduled tests, for example SilkTest Classic
and SilkPerformer scripts. To execute SilkTest Classic and SilkPerformer tests, SilkTest Classic or
SilkPerformer software must be installed on the same computer on which SilkCentral execution servers are
installed.

When executing SilkPerformer scripts against multibyte applications or Web pages, review the Multibyte
Support section in the SilkPerformer Help.

For further details regarding the installation of execution servers, refer to the respective SilkCentral
product’s Help. For information regarding SilkTest Classic and SilkPerformer, refer to the respective
product documentation.

Hardware Provisioning with Keywords
The hardware-provisioning technology of Test Manager helps you manage test environments that include
numerous execution servers. Rather than having to configure a one-to-one direct relationship between
each execution server and execution plan, keywords enable Test Manager to select the most appropriate
execution server for each execution plan. This is done through dynamic comparison of an execution plan's
keyword list with the keyword lists of all active execution servers.

Keywords typically describe the environment of an execution server, for example platform, operating
system, and pre-installed applications. When an execution plan is executed, Test Manager compares the
execution plan's keywords with the keywords of all available execution servers. The execution is then run
on the execution server that matches the execution-plan's keyword list. If there is no matching execution
server, the execution will not be run. If there are multiple execution servers with matching keyword lists, the
execution will be run on the first identified execution server.

Reserved Default Keywords

If you do not require hardware provisioning, you can rely on the reserved keywords that are created
automatically for each execution server. In such cases, it is not necessary that you manually assign
keywords to your execution servers. Instead, you can configure a one-to-one static execution-server
assignment for each execution plan.

A reserved keyword is assigned automatically to each newly created execution server. Reserved keywords
are structured in the following form:

 #<execution name>@<location name>

.

60 | Configuring the Application



Reserved keywords are available when assigning keywords to execution plans. They are neither available
or applicable when assigning keywords to execution servers.

In addition to the reserved keywords that are set up automatically for each defined execution server,
reserved keywords are also set up for each execution server type:

#PHYSICAL Limits execution-server provisioning to physical execution servers.

#VIRTUAL Limits execution-server provisioning to virtual execution servers.

Keywords and Virtual Execution Servers

Keywords are assigned to virtual execution servers in the same way that they are assigned to physical
execution servers. When you configure at least one virtual execution server, the #VIRTUAL keyword is
dynamically created and made available for assignment to all execution plans. If you prefer that an
execution is executed on a virtual machine, select the #VIRTUAL keyword for the execution plan. When an
execution plan has neither (or both) the #VIRTUAL and #PHYSICAL keywords, the execution may occur
on either a virtual or a physical execution server, assuming the settings of the execution environments are
the same. When an execution-plan's keywords match multiple virtual execution servers, the first matching
virtual execution server that is identified is selected.

Configuring Physical Execution Servers
To configure a physical execution server:

1. In the menu, click Administration > Execution Servers.

2. Click on the name of the location for which you want to configure a physical execution server.

• To create a new execution server, click New Execution Server.
• To edit an existing execution server, click the respective Edit button in the Actions column.

Note: Execution servers must be deactivated before their properties can be edited. Keyword-lists
of active execution servers can however be edited.

3. Enter a Name and Description for the execution server.

4. Click the Physical execution server option button.

5. Enter a valid IP address or hostname in the Hostname or IP address text box.

6. Specify the port on which the execution server listens in the Port text box.

Note: Check the Use SSL check box if you want to connect to the execution server through SSL.

Tip: To connect to the execution server through a non-standard SSL port, see Configuring a Non-
Standard SSL Port for Execution Servers.

7. Type a responsiveness timeout in seconds in the Responsiveness Timeout text box.

8. Click Keywords to select keywords from a list or add new keywords that describe the execution server.

These keywords are analyzed at execution time to dynamically select an appropriate server for each
execution. For more information, see Creating New Execution-Server Keywords and Assigning
Keywords to an Execution Server.

9. Check the Active check box to activate the execution server.

Note: If the version of the execution server is an invalid older version, but later than or equal to
SilkCentral Test Manager 2009 SP1, the execution server is automatically upgraded to the current
Test Manager version. Test Manager shows a message concerning the upgrade in the
Information column in the list of execution servers. As long as the upgrade procedure is not
complete, the upgrading execution server is not used.
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Note: Click Test Connection to establish a test connection to the execution server. You will
receive a message stating that the execution server has successfully been connected. If you
receive an error message, ensure that your settings are correct, the network is configured
properly, and that the required software is installed on the execution server you are setting up.

10.Click OK to save your settings. The server now displays on the Locations tab in the list of available
execution servers. Tests can now be run on this execution server.

Creating New Execution-Server Keywords
To create new execution-server keywords

1. In the menu, click Administration > Execution Servers.

2. Click the name of a defined location to go to the list of defined execution servers for that location.

3. In the Actions column of a predefined execution server, click , or click New Execution Server to
create keywords for a new execution server.

Any currently assigned keywords are listed in the Keywords section of the resulting dialog box. For
additional information on configuring a physical execution server, see Configuring Physical Execution
Servers. For additional information on configuring a virtual execution server, see Configuring Virtual
Execution Servers on VMware Lab Manager.

4. Click Keywords. The Assign Keywords dialog box displays.

5. Type an alphanumeric keyword into the Keyword text box that describes the environment on the
execution server, like the platform, operating system, or pre-installed applications.

The following characters cannot be used in keywords:

• #
• $
• ?
• *
• \
• ,
• ;
• '
• "

Note: Keywords are case insensitive. For example, “Vista” and “vista” are handled as the same
keyword.

6. Press Enter. The new keyword is now available for assignment.

Assigning Keywords to an Execution Server
To assign keywords to an execution server:

1. In the menu, click Administration > Execution Servers.

2. Click the name of a defined location to go to the list of defined execution servers for that location.

3. In the Actions column of a predefined execution server, click , or click New Execution Server to
assign keywords to a new execution server.

Any currently assigned keywords are listed in the Keywords section of the resulting dialog box. For
additional information on configuring a physical execution server, see Configuring Physical Execution
Servers. For additional information on configuring a virtual execution server, see Configuring Virtual
Execution Servers on VMware Lab Manager.

4. Click Keywords.

5. On the Assign Keywords dialog box, select a keyword in the Select keywords list.
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All available, unassigned keywords are listed in the Select keywords column. If you are working with a
new Test Manager installation you may not see any available keywords.

Note: Though not visible on the Assign Keywords dialog box, reserved keywords are created for
each execution server that is configured for the system. These reserved keywords are only
available when assigning keywords to execution plans.

6. Select keywords in the Select keywords list that describe the environment on the execution server, like
the platform, operating system, and pre-installed applications.

You can use Ctrl + Click or Shift + Click to select multiple keywords using standard Windows multi-
select functions.

Tip: The Select keywords box is auto-complete enabled. When you enter alphanumeric
characters into this box, the box is dynamically updated with an existing keyword that matches the
entered characters. Note that this box is disabled when multiple keywords are selected in the
Select keywords or Assigned Keywords list boxes.

Note: If you do not require hardware provisioning, you can use the default, reserved keywords that
are created for each execution server. In such cases, it is not necessary that you assign additional
keywords to the execution server.

7. Click Add (>) to move the keyword into the Assigned Keywords list.

8. Click OK to save the keywords and close the Assign Keywords dialog box.

Activating or Deactivating Execution Servers
To activate or deactivate an existing execution server:

1. In the menu, click Administration > Execution Servers.

2. Click the name of the location to which the execution server is assigned.

3. In the Status column of the execution server you want to activate or deactivate, click Inactive/Active. A
confirmation dialog box displays, asking you to confirm the activation or deactivation.

4. Click Yes to activate or deactivate the execution server; or click No to leave the current status
unchanged. You are returned to the list of execution servers. The status toggles to active or inactive.

Note: If the version of the execution server is an invalid older version, but later than or equal to
SilkCentral Test Manager 2009 SP1, the execution server is automatically upgraded to the current
Test Manager version. Test Manager shows a message concerning the upgrade in the
Information column in the list of execution servers. As long as the upgrade procedure is not
complete, the upgrading execution server is not used.

Deleting Execution Servers
Tip: To prevent data inconsistency, you need to deactivate an execution server before you can delete
it. For asdditional information, see Activating or Deactivating Execution Servers.

Note: Deleting an execution server does not remove the actual software installation. Deletion simply
disconnects the execution server. You can add a previously deleted execution server again.

To delete an execution server:

1. In the menu, click Administration > Execution Servers.

2. Click the name of the location to which the execution server is assigned. A list of execution servers
assigned to the selected location displays.

3. In the Actions column of the execution server you want to remove, click . A confirmation dialog box
displays, asking you to confirm the deletion.

4. Click Yes if you want to remove the execution server or click No to abort the operation. If you choose
Yes, you are returned to the list of execution servers where the deleted execution server will no longer
be listed.
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Configuring a Non-Standard SSL Port for Execution
Servers
The default SSL port through which the application server communicates with execution servers is 19125.

Note: This procedure needs to be performed for each execution server that you want to connect to
through a non-standard SSL port.

To configure a non-standard SSL port for an execution server:

1. Deactivate the execution server for which you want to configure a non-standard SSL port.

2. Stop the execution server.

3. Open the SccExecServerBootConf.xml file with a text editor.

This file is located in the /conf/execserver folder of the SilkCentral directory on the execution
server.

4. Locate the <SSLPort> XML tag. By default, the tag is set to <19125>.

Set the value to the port number that you want to use for SSL communication.

5. Save and close the XML file.

6. In SilkCentral, set the SSL port of the execution server to the value that you have specified in the XML
file.

7. Restart the execution server.

8. Reactivate the execution server.

New/Edit Execution Server Dialog Box
Administration > Execution Servers > Location > New/Edit Execution Server

Use the New/Edit Execution Server dialog box to configure execution servers within a location.

Item Description

Name Defines a name for the execution server. This name will
appear in all tables and result reports for executions
from this specific computer. You can enter up to 100
characters.

Description A description of the execution server. You can enter any
text for the description.

Physical execution server Select this option to specify a physical machine as
execution server.

Host or IP-address Specifies the name of the host or the IP-address of the
computer on which the execution server is installed.

Some networks may only find the execution server if you
specify the full name of the host, including the name of
the domain, for example MyHost.MyDomain.

Virtual machine Select this option to specify an execution server running
on a virtual image of a VMware Lab Manager
configuration.

VMware Lab
Manager Server

Select the VMware Lab Manager
installation which hosts the virtual
machine. The list box lists all
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Item Description

installations which are configured
in Administration > System
Settings > VMware Lab Manager
Servers .

Configuration Lists all available configurations
within the selected VMware Lab
Manager Server.

Machine Lists all available virtual images
within the selected
Configuration.

Port Specifies the port of the computer defined in the Host or
IP-address text box on which the execution server
listens. The default port is 19124.

Use SSL Check this check box if you want the application server
to connect to the execution server through Secure
Sockets Layer (SSL). The default SSL port is 19125.

If you selected to use a proxy server for the location to
which this execution server is assigned, you must check
Use SSL with port 443.

Responsiveness timeout [s] Enter a responsiveness timeout in seconds, or leave the
default value of 120 seconds for physical execution
servers, 300 seconds for virtual execution servers. The
responsiveness timeout is the period of time after which
the application server will time out if the execution server
does not respond. After 2/3 of the time defined here, the
administrator will be warned through email that the
execution server is no longer available.

Keywords Lists the keywords that have been defined for this
execution server. Keywords enable Test Manager's
hardware-provisioning technology to dynamically identify
the most appropriate execution server for each test
execution. Click Keywords to edit the keywords list for
this execution server.

Status Check this check box to activate the execution server. If
you do not activate the execution server, it will not be
available for monitor executions.

Test Connection Click this button to establish a test connection to the
execution server. You will receive a message stating
that the execution server has successfully been
connected. If you receive an error message, ensure that
your settings are correct, the network is configured
properly, and that the required software is installed on
the execution server you are setting up.
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Working with VMware Lab Manager
VMware Lab Manager (Lab Manager) is integrated with Test Manager to enable managing Lab Manager
directly from the UI of Test Manager. Integrated functionality includes configuration deployment, test
execution, result collection, and automatic undeployment of configurations. Test Manager can support
multiple Lab Manager installations and configurations. Configurations captured through LiveLink
technology are viewed using Lab Manager.

Note: For full details regarding LiveLink configuration captures and other Lab Manager functionality,
refer to the Lab Manager Documentation.

Lab Manager Virtual Configurations
VMware images are virtual computer systems. Lab Manager is used to manage VMware images, or
"configurations", which are combinations of images, for example database server, application server, and
execution server. VMware configurations offer an effective means of virtualizing complex software-testing
lab environments. Configurations are typically deployed from Lab Manager libraries. Configurations are
turned on and off just like individual VMware images. Multiple instances of the same configuration can be
deployed simultaneously, with separate tests run in each instance. VMware configurations are “network-
fenced,” meaning that they do not influence each others' network behavior. VMware LiveLink technology
enables you to take “snapshots” of complete configurations that can later be recreated (or “restored”) on
demand.

Note: For full details regarding LiveLink configuration captures and other Lab Manager functionality,
refer to the Lab Manager Documentation.

Note: At least one Test Manager execution server must exist within each configuration. These
execution server instances control test execution within configurations and retrieve test results.

Configuring Access to Lab Manager Servers
To configure access to a Lab Manager server:

1. In the menu, click Administration > System Settings.

2. Click the VMware Lab Manager Servers tab.

3. Click New VMware Lab Manager Server. The New VMware Lab Manager Server dialog box displays.

4. Type a Name for the server you are configuring.

5. Enter a Hostname for the server you are configuring.

6. Enter the Port number.

7. If the connection to the Lab Manager server is to be SSL-encrypted, check the Use SSL check box.

8. Enter Username and Password credentials for the Lab Manager server that you are configuring.

The Status is set to Active by default.

Note: Lab Manager users must have admin rights to perform this task.

9. Optional: Type the Lab Manager Organization.

Lab Manager uses organizations to determine which resources a user can access. If the user is not
assigned to the selected organization in Lab Manager, an error message displays in Test Manager. For
more information on organizations in Lab Manager, refer to the Lab Manager documentation.

10.Click OK. Test Manager checks the availability of the configured Lab Manager server and adds the
server to the Lab Manager Servers list.
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Configuring Virtual Execution Servers on Lab Manager
Describes how to configure a virtual execution server on a Lab Manager installation.

To configure an execution server on a virtual image of a Lab Manager configuration:

1. In the menu, click Administration > Execution Servers.

2. Click the name of the location to which on which you want to configure a virtual execution server.

3. To create a new execution server, click New Execution Server. To edit an existing execution server,

click  in the Actions column.

Note: Execution servers must be deactivated before their properties can be edited. Keyword lists
of active execution servers can be edited while the server is active.

4. Type a Name and Description for the virtual execution server.

5. Click the Virtual machine option button.

6. From the VMware Lab Manager list box, select the VMware Lab Manager installation that hosts the
virtual machine you want to configure.

7. Select the Lab Manager configuration you want from the Configuration list box.

8. From the Machine list box, select the machine where the Test Manager execution server runs.

This is required to communicate and drive tests in the configuration.

9. Specify the port on which the execution server listens in the Port text box.

Note: Check the Use SSL check box if you want to connect to the execution server through SSL.

Tip: To connect to the execution server through a non-standard SSL port, see Configuring Non-
Standard SSL Port for Execution Server.

10.Type a responsiveness timeout in seconds in the Responsiveness Timeout text box.

11.Check the Active check box to activate the execution server.

12.Click Test Connection to establish a test connection to the execution server.

You will receive a message stating that the execution server has successfully been connected. If you
receive an error message, ensure that your settings are correct, the network is configured properly, and
that the required software is installed on the execution server you are setting up. Executing a Test
Connection results in the complete configuration being deployed and Test Manager attempts to
connect to the execution server on the configuration and subsequently undeploy the configuration. This
process can take some time to complete.

13.Click OK to save the configuration. The virtual server now displays on the Locations tab in the list of
available execution servers. Tests can now be run on this virtual execution server.

VMware Lab Manager Servers Page
Administration > System Settings > VMware Lab Manager Servers

Use this page to manage your Lab Manager servers. For each listed server, the page displays the
following columns:

Column Description

Actions Edit or delete a Lab Manager server
connection. These actions are only
allowed if the Lab Manager
connection is disabled. See Status.
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Column Description

Name Specifies the name of the Lab
Manager server as it should appear in
the SilkCentral GUI. You can define
any name for the server; this field has
no impact on the actual Lab Manager
settings.

Status Displays whether the connection to
the Lab Manager server is active or
inactive. If inactive, the Lab Manager
server's services are not available to
SilkCentral.

Clicking the status of a VMware Lab
Manager server toggles the status to
active/inactive.

Host The hostname and port of the server
hosting Lab Manager.

Path The path to VMware Lab Manager's
Web service API. The default path
is/LabManager/SOAP/
LabManager.asmx?WSDL.

SSL Displays whether SilkCentral
connects to the Lab Manager server
using SSL or not.

Created On Date when the Lab Manager server
connection was created.

Created By The user who created the Lab
Manager server connection.

Changed On Date when the Lab Manager server
connection was modified.

Changed By The user who modified the Lab
Manager server connection.

Click New VMware Lab Manager Server to create a new Lab Manager connection.

Managing Report Templates
SilkCentral offers a variety of pre-installed reports that let you quickly and easily transform data into
presentation-quality information for analysis. The default reports can be customized with either Microsoft
Excel or BIRT, an Eclipse-based, open source reporting tool for Web applications. You can also use these
tools to create entirely new reports. To customize reports created with Microsoft Excel, you need a copy of
Microsoft Excel.

SilkCentral reports do not support bitmap (.bmp) image file format. For proper display, images must be in
JPEG, GIF, or PNG format.

Managing Custom Report Templates with BIRT
SilkCentral is tightly integrated with Business Intelligence and Reporting Tools (BIRT) RCP Designer to
make it easy for you to generate reports for your test-, build-, defect-, and requirement data.
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After downloading a copy of BIRT RCP Designer, you can customize the core SilkCentral reports and add
your own reports. For information about running and customizing reports, please refer to the application's
Help.

For additional information on BIRT RCP Designer, refer to BIRT RCP Designer’s online help system. You
can find further information, examples, and demonstrations for BIRT RCP Designer at http://
www.eclipse.org/birt. An active newsgroup (news.eclipse.org) is also available.

The software prerequisites to work with BIRT custom reports are:

• BIRT RCP Designer
• Access to SilkCentral with administrator privileges

Note: SilkCentral reports do not support bitmap (.bmp) image file format. For proper display, images
must be in JPEG, GIF, or PNG format.

Installing BIRT from SilkCentral
This procedure explains how to install BIRT RCP Designer from your SilkCentral installation. By installing
BIRT this way, all necessary configurations for SilkCentral are done automatically.

To install BIRT from SilkCentral:

1. Navigate to Help > Tools .

2. Click the BIRT RCP Report Designer link.

3. After downloading the compressed installer package to your local system, extract the compressed files
to a directory on your system, for example C:\BIRT.

Note: If you encounter an error when extracting the installer files using Windows compressed
folder functionality, use an extraction tool instead, for example WinZip or WinRAR, to extract the
files.

4. Start BIRT.exe from the directory you extracted the files to.

Configuring BIRT for SilkCentral
If BIRT is already installed on your computer, or you are installing BIRT from another location, for example
from the Eclipse homepage, you need to configure BIRT for use with SilkCentral after the installation. If you
have installed BIRT from SilkCentral as described in Installing BIRT from SilkCentral, you do not need to
perform the steps outlined in this procedure.

To configure BIRT RCP Designer for use with SilkCentral:

1. Copy the jtds.jar and ojdbc6.jar files, available in the \lib directory of your SilkCentral front-
end server installation folder, to the plugins
\org.eclipse.birt.report.data.oda.jdbc_<version>\drivers directory of your BIRT
installation.

This will allow JDBC access to your SilkCentral installation.

2. Copy the scc.jar file, available in the \lib directory of your SilkCentral front-end server installation
folder, to the plugins\org.eclipse.birt.report.viewer_<version>\birt\WEB-INF\lib
directory of your BIRT installation.

3. Create a directory to store the reports you intend to create, for example C:\MyBirtReports. Create a
subdirectory called conf within the newly created directory.

4. Within the conf directory, create a directory called birt. You should now have a directory structure
that resembles the following: C:\MyBirtReports\conf\birt.

5. Copy the file library.rptlibrary, available in the \conf\Birt directory of your SilkCentral front-
end server installation folder, to the \conf\birt directory that you created in the previous step.

6. Launch BIRT by executing the BIRT.exe file, located in the local directory where you extracted the
application’s compressed files.
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7. From within BIRT RCP Designer, select Preferences from the Window menu.

8. In the Preferences window, select Report Design > Resource in the directory tree in the left-hand
pane.

9. In the Resource folder text box, enter the directory that you created.

For example C:\MyBirtReports\conf\birt.

10.Click Apply, then click OK.

Establishing Database Access For a New Report Template
Before you can create a new report template with BIRT RCP Designer, you need to establish database
access to the SilkCentral repository you want to query.

To establish database access for a new report template:

1. From within BIRT RCP Designer, select the menu File > New > New Report .

2. Follow the steps in the New Report wizard.

3. Open the Resource Explorer.

4. In the Resource Explorer, click Shared Resources > conf > birt > library.rptlibrary > Data Sources
> Data Source and drag the required datasource into your report’s Data Sources directory, which is
located in the Outline window.

5. In the Resource Explorer, click Shared Resources > conf > birt > library.rptlibrary > Report
Parameters and drag the four report parameters sourceUser, sourcePassword, sourceURL, and
sourceDriver into your report’s Report Parameters directory, which is located in the Outline
window.

6. Double-click the newly imported data source to open the Edit Data Source dialog box.

7. Type a valid Driver Class and Database URL.

For additional information, see BIRT Data Source Settings topic.

8. Click Test Connection to test your settings. If the database connection has been established, you can
proceed with designing your new report template.

9. Click OK.

BIRT Data Source Settings
Use the BIRT New JDBC Data Source Profile dialog box to establish database access to an existing
SilkCentral repository. To access the New JDBC Data Source Profile dialog box, right-click Data
Sources in the Outline pane, click New Data Source, select JDBC Data Source, and click Next >.

To connect to a MS SQL Server or a MS SQL Server Express database, use the following credentials:

Item String

Driver Class net.sourceforge.jtds.jdbc.Driver

Driver URL MS SQL Server jdbc:jtds:sqlserver://<HOST>:<PORT>/
<DATABASE>

MS SQL Server
Express

jdbc:jtds:sqlserver://<HOST>:<PORT>/
<DATABASE>;instance=<INSTANCENAME>

HOST Host name or IP-address of the computer hosting the database
server.

PORT Port number of the database management system. Default is 1433.

DATABASE The name of the database.
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Item String

INSTANCENAME Only for MS SQL Server Express. Instance name of the database
instance. The default MS SQL Server Express instance is
localhost\SQLExpress.

To connect to an Oracle database, use the following credentials:

Item String

Driver Class oracle.jdbc.OracleDriver

Driver URL jdbc:oracle:thin:@<HOST>:<PORT>:<DATABASE>

HOST Host name or IP-address of the computer hosting the database server.

PORT Port number of the database management system. Default is 1521.

DATABASE Oracle SID.

Adapting Existing Report Templates
SilkCentral allows you to download and adapt BIRT report templates that contain all the information you
need to create custom report templates for use with SilkCentral modules.

Note: SilkCentral reports do not support bitmap (.bmp) image file format. For proper display, images
must be in JPEG, GIF, or PNG format.

To create a report based on a SilkCentral template:

1. In the menu, click Administration > Report Templates . The Report Templates page displays, listing
all of the report templates that have been uploaded.

2. Click  in the Actions column.

3. Save the template file <filename>.rptdesign to your local system.

4. Open the downloaded template file in BIRT RCP Designer.

5. Redesign the report as necessary.

For instructions on report design, refer to BIRT RCP Designer’s online help system.

6. To preview your report, click the Preview tab.

If you click the Preview tab for the first time, the Enter Parameters dialog box opens, where you need
to specify a valid session ID.

7. To generate a session ID, execute the following URL in a web browser.
http://<HOST>:<PORT>/services/sccsystem?
method=logonUser&userName=<USERNAME>&plainPasswd=<PASSWORD>.

Parameter Description

HOST Host name or IP-address of the computer hosting SilkCentral.

PORT Port number of the SilkCentral front-end server. Default is 19120 if you
access SilkCentral through a standalone Web server, and 80 if you access
SilkCentral through IIS.

USERNAME/
PASSWORD

Valid credentials of a SilkCentral user.

Note: The order of the valid credentials USERNAME and PASSWORD is very important.
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8. If at some point your edited report does not return any data, the likely cause is that the session ID has
timed out. Click Show Report Parameters in the Preview window to enter a new session ID. To
generate a new session ID, repeat the previous step.

Setting and Editing Report Permissions and
Associations
The report administrator sets and edits the permissions that determine who can print reports and who can
change report names and descriptions. You may want to change the projects, modules, or categories with
which reports are associated. You also may find it helpful to change a report’s description or name to assist
users in interpreting reports.

Once you have created a new custom report using BIRT RCP Designer or Excel and uploaded the report
to SilkCentral, you need to set permissions to make the report available to users.

To set or edit permissions for a SilkCentral report template:

1. In the menu, click Administration > Report Templates . The Report Templates page displays, listing
all of the report templates that have been uploaded.

2. Click the name of the report template for which you would like to edit or set permissions and
associations. The Edit Report Template dialog box displays.

3. You can change a report’s permission settings by modifying the selections in the Projects and
Modules list boxes.

This will determine which users have access to the selected report template.

4. Once you are done editing, click OK to save your changes to the report template.

The edits you have made are applied immediately. Users will see changes the next time they access or
refresh the report list.

Downloading Report Templates
The report template of the selected report, including the layout, is downloaded. Downloading SilkCentral
report templates to your local system enables you to edit them through BIRT Report Designer or Microsoft
Excel. After you download and edit a report, you can upload it to make it available to other users. For more
information, see Uploading Report Templates.

To download a SilkCentral report template:

1. In the menu, click Administration > Report Templates . The Report Templates page displays, listing
all of the report templates that have been uploaded.

2. Click  in the Action column of the report you want to download. The File Download dialog box
displays.

3. Click Save and download the report file to your local system as a .rptdesign or .xls file, depending
on the report type that you are downloading.

4. Now edit the report based on your needs using either BIRT RCP Designer, for .rptdesign files, or
Excel, for .xls files.

Uploading Report Templates
Uploading SilkCentral report templates makes them available for others to use. You may want to upload a
report template after you have edited it with BIRT RCP Designer or Microsoft Excel. You can only run a
report if you have access to the project and module to which the report is associated.

Note: SuperUser, Administrator, or Reporter privileges are required to create and upload custom
reports. You cannot upload or update reports with other user privileges.
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Tip: Templates must be configured with additional information so that they can be identified once they
are uploaded to SilkCentral.

Note: SilkCentral reports do not support bitmap (.bmp) image file format. For proper display, images
must be in JPEG, GIF, or PNG format.

To upload a customized template as a new report:

1. In the menu, click Administration > Report Templates . The Report Templates page displays, listing
all of the report templates that have been uploaded.

2. Click Upload at the bottom of the page. The Upload Report Template dialog box displays.

3. Type a Name for the report.

4. Optional: Type a Description of the report.

5. From the Projects list box, select the projects with which the report is to be associated.

Hold down the Ctrl key to select multiple projects.

6. From the Modules list box, select the modules with which the report is to be associated.

Hold down the Ctrl key to select multiple modules.

7. Click Browse next to the File field.

8. Browse to and select the template file that is to serve as the basis for the report template.

The file you select must have the .rptdesign or .xls file extension.

9. Click OK to upload the report template for use in SilkCentral.

Updating Report Sources
Updating an existing SilkCentral report template allows you to move a report you have customized with
BIRT RCP Designer or Microsoft Excel into SilkCentral and make it available to other users.

Note: SuperUser, Administrator, or Reporter privileges are required to create and upload custom
reports. You cannot upload or update reports with other user privileges.

Caution: Report templates that ship with SilkCentral are automatically patched when you upgrade to
a new version. It is therefore important that you save your customized report templates in a dedicated
custom folder, or that you upload customized report templates as new templates. For more
information, see Uploading Report Templates.

To update a report template with a modified template file:

1. In the menu, click Administration > Report Templates . The Report Templates page displays, listing
all of the report templates that have been uploaded.

2. Click  in the Action column of the report you want to update.

3. Click Browse on the Update Report Template dialog box to browse to and select the template file that
is to overwrite the existing template file.

The file you select must have the .rptdesign or .xls file extension.

4. Click OK to upload the file, and thereby overwrite the file that the report template was previously based
on.

Deleting Report Templates
You can remove a SilkCentral report from the list of available reports.

To delete a SilkCentral report:

1. In the menu, click Administration > Report Templates . The Report Templates page displays, listing
all of the report templates that have been uploaded.

2. Click  in the Action column of the report you want to remove. A confirmation dialog box displays.
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3. Click Yes to remove the report from the list.

Report Templates Page
Administration > Report Templates

Use the Report Templates page to manage the report templates which you want to make available to the
SilkCentral applications for reporting.

Click Upload to upload a new report template from your hard disk or a UNC to SilkCentral.

For each listed report, the page displays the following columns:

Column Description

Title The name of the report template as it displays in the
application's GUI.

File Name The physical file name of the report template.

Uploaded On Date when the report template was uploaded to
SilkCentral.

Uploaded By The user who uploaded the report template to
SilkCentral.

Project The project to which the report template is associated.
Only the specified project can use that template for
reporting purposes. If a template is assigned to All
Projects, then any project can use it.

Module The SilkCentral application which may access the
reporting template. If a template is assigned to no
module, then any application can use it.

Actions This column contains action icons which allow the user to
perform the following actions on a report template:

Action Description

Update Replaces the currently uploaded template
with a new one.

Download Downloads the template to your local
computer.

Delete Deletes the template permanently.

Audit Log
Administration > Log Files > Audit Log

The audit log allows administrators to view all recorded SilkCentral user activity. The log file stores all login
and logout information, as well as all changes to the SilkCentral database, for example projects, monitors,
and schedules.

You can manage the listed log entries to suit your information needs by using the available features.

Sorting Data by Column

Clicking a column header sorts all listed data by that column. Clicking the same column header multiple
times toggles the sort order between ascending and descending.

74 | Configuring the Application



Selecting a Range From the Calendar

Click the displayed time range to expand the calendar. The From and To rows of the calendar allow you to
specify start and end times for the period of time for which you want to view data. After specifying From
and To times with the list boxes, click Update to update the audit log based on the new time range.

The day, week, month, quarter, [last 7 days], [last 31 days] links allow you to bypass the calendar and
instead view information for set time periods.

You can also use the Forward and Backward arrows to increase and decrease the selected time range by
the following intervals:

• one day
• one week
• one month
• one quarter

Use  and  for increasing and decreasing the range of time covered by the audit log. Clicking  one
time enlarges the period of time by 50%. Clicking  one time reduces the period of time by 50%.

When the calendar displays a custom interval, for example after zooming in or out, you can use the left-
most arrows, Earlier and Later, to move the selected period of time forward or backward in time by half of
the selected interval.

Tip: After specifying a new time period, click Update to update the report.

Filtering Data

Filter options enable you to better target the audit log information you want to analyze.

You can filter listed data by:

Login Displays the actions of a specified user login.

Object Displays actions taken on a specified database item, for example project, monitor, or location.

Operation Displays selected operations, for example login, logoff, create, or delete.

Accessing and Viewing the Audit Log
To view the audit log:

1. In the menu, click Administration > Log Files.

2. Click the Audit Log tab.

3. Select a calendar range to limit the listed log entries.

4. Use the filter options to better target the audit log information you want to analyze.

Audit Log Page
Administration > Log Files > Audit Log

Use the Audit Log page to view all recorded SilkCentral user activity.

Item Description

Calendar area Select a calendar range to limit the listed log entries.

Filter area Use the filter options to better target the audit log
information you want to analyze. Click Update to refresh
the list according to your filter settings.
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Item Description

Result area This section displays the logged information. Use the
page numbers to move between pages. Click the column
headers to sort by the defined column.

For detailed information about the calendar and filtering options, see Audit Log.

Server Log Files
The front-end server, the application server, and the execution server write log files. These files provide
valuable information for error analysis. SilkCentral allows administrators to view, search, and download
these files directly from its Web interface.

Downloading Server Log Files
You can download a server log file to your local computer in CSV format to allow for further data analysis,
for example in Microsoft Excel.

To download a server log file:

1. In the menu, click Administration > Log Files .

2. Click the tab of the server to which the log file belongs.

• Front-end Server Log
• Application Server Log
• Execution Server Log

A list of log files is displayed in chronological order. Log file names are made up of server component
name and a suffix with a timestamp. The current log files are named FrontendServer.log,
AppServer.log, and ExecServer.log.

Note: To locate an execution server log file, navigate to the respective execution server through its
location.

3. In the Actions column of the log file, click .

Alternative: To view the contents of the log file before downloading it, click the name of the log file you
want to download. The selected log file displays, along with chronologically sorted log entries. Click
Download as CSV at the bottom of the page.

4. To view the data in a spreadsheet program, select Open on the subsequent dialog box. To save the
data on your hard drive, select Save on the subsequent dialog box.

Analyzing Server Log Files
To analyze a server log file:

1. In the menu, click Administration > Log Files .

2. Click the tab of the server to which the log file belongs.

• Front-end Server Log
• Application Server Log
• Execution Server Log

A list of log files is displayed in chronological order. Log file names are made up of server component
name and a suffix with a timestamp. The current log files are named FrontendServer.log,
AppServer.log, and ExecServer.log.
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Note: To locate an execution server log file, navigate to the respective execution server through its
location.

3. Click the name of the log file you want to view. The selected log file is displayed, along with
chronologically sorted log entries.

4. Filter options allow you to page recorded log information.

You can filter listed data by:

Severity Displays events of a selected severity.

• error
• warning
• informational

Log level Displays events that match a selected log level.

• overview
• detailed
• verbose
• debug

More detailed log information can only be displayed when the log level is set accordingly on
the server. For more information about configuring a server’s log level, see Log Levels.

Module Displays log information for a selected module. Log entries can only be displayed when the
respective products (modules) are installed and connected to the front-end server that is
being accessed.

Deleting Server Log Files
Caution: Deleting a log file permanently removes the file from the server. You will not be able to view
log data from the deleted file anymore.

To delete a server log file:

1. In the menu, click Administration > Log Files .

2. Click the tab of the server to which the log file belongs.

• Front-end Server Log
• Application Server Log
• Execution Server Log

A list of log files is displayed in chronological order. Log file names are made up of server component
name and a suffix with a timestamp. The current log files are named FrontendServer.log,
AppServer.log, and ExecServer.log.

Note: To locate an execution server log file, navigate to the respective execution server through its
location.

3. In the Actions column of the log file you want to delete, click . A confirmation dialog box displays.

4. Click No to avoid deleting the log file; or click Yes to remove the log file from the list.

If you choose Yes, the list of log files redisplays, with the deleted log file no longer listed.

Log File Management
Each of the SilkCentral servers writes its activities to log files. For more information about SilkCentral
servers, see Architecture. When application errors or system failures occur, these log files provide valuable
information regarding the root causes of problems. You can customize the level of detail that is written to
server log files.
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The log files for the SilkCentral servers are accessible through Administration > Log Files.

Changing Log Levels of the SilkCentral Servers
The following servers generate log files:

• Front-end server
• Application server
• Execution server

To change the log level of a SilkCentral server:

1. Stop the server for which you want to change the log level.

2. Open the appropriate file with a text editor, depending on the server for which you want to change the
log level:

Front-end server SccFrontendBootConf.xml, located in the /conf/frontendserver folder
of the SilkCentral directory on the front-end server.

Application server SccAppServerBootConf.xml, located in the /conf/appserver folder of the
SilkCentral directory on the application server.

Execution server SccExecServerBootConf.xml, located in the /conf/execserver folder of
the SilkCentral directory on the execution server(s).

3. Locate the <LogLevel> XML tag in the <Log> section of the file.

4. Set the value to the log level at which you want the server to write information. The following log levels
are available:

Value Log level Description

0 Overview The server writes only the most important information to the log files. This is the
default setting.

1 Detailed The server writes additional information to the log files:

Front-end server Connection- and event-dispatcher information.

Application server Result-writer and result-fetcher activities.

Execution server Transaction-execution activities.

2 Verbose The server writes additional information to the log file:

Front-end server User administration information, for example cookie
management.

Application server Detailed result-writer and result-fetcher information.

Execution server Detailed transaction-execution and bandwidth information.

3 Debug This is the most detailed log level and should only be used for debugging severe
issues.

5. Save and close the XML file, then restart the server.

Front-End Server Log Page
Administration > Log Files > Front-end Server Log

Use this page to view logging information from the SilkCentral front-end server service.

For each log file, the page displays the following columns:
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Column Description

Actions This column contains action icons which allow the user to perform the following actions on a
log file:

Download Downloads the log file to your local computer.

Delete Deletes the log file permanently.

Name The name of the log file. Click the file name to view logging details.

Size The physical size of the log file in bytes.

Date Date when the log file was last physically saved.

Administration > Log Files > Front-end Server Log > Front-end server log file name .

When clicking on the name of a log file, the logging details list displays. The list includes the following
items:

Item Description

Filter area Use the filter options to filter the log list information by
severity, log level, and module. Click Update
to refresh the list according to your filter settings.

Table area Displays the following logging information:

Severity Severity of the event:

• Info

• Warning

• Error

Log Level Log level of the event:

• OV = Overview

• DT = Detailed

• VB = Verbose

• DB = Debug

Click Back to return to the Front-end Server Log page. Click Download as CSV to download the log file
as a CSV file to your local computer.

Application Server Log Page
Administration > Log Filess > Application Server Log

Use this page to view logging information from theSilkCentral application server service.

For each log file, the page displays the following columns:

Column Description

Actions This column contains action icons which allow the user to perform the following actions on a
log file:

Download Downloads the log file to your local computer.

Delete Deletes the log file permanently.
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Column Description

Name The name of the log file. Click the file name to view logging details.

Size The physical size of the log file in bytes.

Date Date when the log file was last physically saved.

Administration > Log Files > Application Server Log > Application server log file name .

When clicking on the name of a log file, the logging details list displays. The list includes the following
items:

Item Description

Filter area Use the filter options to filter the log list information by
severity, log level, and module. Click Update
to refresh the list according to your filter settings.

Table area Displays the following logging information:

Severity Severity of the event:

• Info

• Warning

• Error

Log Level Log level of the event:

• OV = Overview

• DT = Detailed

• VB = Verbose

• DB = Debug

Click Back to return to the Application Server Log page. Click Download as CSV to download the log file
as a CSV file to your local computer.

Execution Server Log Page
Administration > Log Files > Execution Server Log

Use this page to view logging information from the SilkCentral execution server service.

For each location, the page displays the following columns:

Column Description

Location Displays all available locations.

Execution Servers Displays the amount of execution servers per location.

Status Displays a summary status of the execution servers in the location.

Administration > Log Files > Execution Server Log > Location name

When clicking on the name of a location, the list of execution servers in the selected location displays. The
list displays the following columns for each execution server.

Column Description

Execution Server Name The name of the execution server.
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Column Description

Host The name of the computer hosting the execution server.

Type The SilkCentral application that the execution server is
configured for. For Test Manager, the type is always Test
Manager.

Assigned Tasks The amount of tasks that are currently scheduled on the
execution server.

Status The status of the execution server. Active or
Inactive.

Click Back to return to the list of locations.

Administration > Log Files > Execution Server Log > Location name > Execution server name

When clicking on the name of an execution server, the list of log files for the selected execution server
displays. For each log file, the page displays the following columns:

Column Description

Actions This column contains action icons which allow the user to perform the following actions on a
log file:

Download Downloads the log file to your local computer.

Delete Deletes the log file permanently.

Name The name of the log file. Click the file name to view logging details.

Size The physical size of the log file in bytes.

Date Date when the log file was last physically saved.

Click Back to return to the list of execution servers.

Administration > Log Files > Execution Server Log > Location name > Execution server name >
Execution server log file name

When clicking on the name of a log file, the logging details list displays. The list includes the following
items:

Item Description

Filter area Use the filter options to filter the log list information by
severity, log level, and module. Click Update
to refresh the list according to your filter settings.

Table area Displays the following logging information:

Severity Severity of the event:

• Info

• Warning

• Error

Log Level Log level of the event:

• OV = Overview

• DT = Detailed

• VB = Verbose
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Item Description

• DB = Debug

Click Back to return to the Execution Server Log page. Click Download as CSV to download the log file
as a CSV file to your local computer.

Integrating Task Management Tools
A variety of external task management tools can integrate their tests with Test Manager through the Agile
project template.

The Agile project template is a Test Manager project with the preselected attributes release and sprint.
When you create a project based on the Agile project template, an empty subfolder and test container are
created for the new project. The external task management tool can then insert tests into the template. For
information about how to create a project based on the Agile project template, see Adding Projects.

The task management tools that are currently supported by Test Manager “out of the box” are:

Task Management
Tool

Description

VersionOne VersionOne is a project planning and management tool specifically designed for
agile software development. It incorporates agile and iterative management
practices such as release planning, iteration planning and tracking, user story or
backlog item management, and task management.

Integrating VersionOne in Test Manager
To integrate tests from VersionOne into Test Manager:

1. Add a new Test Manager project and apply the Agile project template to the project.

For information on how to add a project based on the Agile template to Test Manager, see Adding
Projects.

2. Open the file Explorer.

3. Navigate to the VersionOne configuration XML file, VersionOneConfig.xml.

The default path for the file is C:\Program Files\Silk\SC Test Manager <version>
\wwwrootAS\VersionOneIntegration.

4. Open the VersionOne configuration XML file with an editor.

5. Configure the VersionOne configuration XML file with the appropriate settings.

For detailed information on the settings in the VersionOne configuration XML file, refer to the comments
in VersionOneConfig.xml.

6. Save and close the configuration file.

Note: You do not need to restart the application server after you edit the configuration file because
the file is automatically updated.

7. In Test Manager, navigate to the Tests area. The empty test container is displayed as incomplete,
because you have to select a product.

8. Click on the container, select the Properties tab, and click on the product link to browse for the product.

VersionOne is now integrated with Test Manager. New test tasks in VersionOne, for which you have
defined the appropriate user, are inserted as manual tests into the default integration folder in the defined
Test Manager project. The test status is now exchanged between Test Manager and VersionOne.
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Refer to the VersionOneIntegration.log log file for information about changes to the VersionOne
integration. The default path for the log file is C:\Documents and Settings\All Users
\Application Data\SilkCentral\log\.

Note: To integrate VersionOne with a Japanese Test Manager, change the start options of the
Application Server service in the registry to -Dfile.encoding=utf-8.

Managing Products and Platforms
SilkCentral enables you to create and organize products, product components, versions of products, and
build numbers of product versions. Product specifications can then be associated with tests, versions and
builds can be associated with execution plans. You can even import products and components that were
defined previously in Issue Manager.

• Components are discrete product elements that are tracked separately for testing purposes.
• Versions are product releases that are tracked separately for development and testing purposes.
• Builds are iterations of versions that are tracked separately for development and testing purposes.

SilkCentral also enables you to set up platform designations for tests, for example operating systems. As
with product, version, and build setup, platforms can be assigned names, descriptions, and active/inactive
status.

Managing Builds
Builds are iterations of versions that are tracked separately for development and testing purposes.

Adding Builds
To add a new build to a version:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. In the Builds for Version list box, select the version for which you want to add a build.

5. Click New Build. The New Build dialog box displays.

6. Type a name for the new build in the Name text box.

7. Type a description for the build in the Description text box.

8. Check the Active check box to make this build available for association with versions.

9. Click OK to save the build, or click Cancel to abort the operation.

Editing Builds
To edit an existing build within a version:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Select the build you want to edit.

5. The Edit Build dialog box displays, detailing the Name, Description, and Active status of the selected
build. Make all required changes, then click OK.

6. Check the Tagged check box to tag the build.
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Activating and Deactivating Builds
To activate or deactivate an existing build:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Click the Status icon associated with the build you want to activate or deactivate. A confirmation dialog
box displays, asking you if you are sure about the activation or deactivation.

5. Confirm the message to toggle the build status to active or inactive.

Sorting the Builds List
To move a build up or down in the list or sort the builds list alphabetically by name:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. In the Builds for Version list box, select the version for which you want to see the builds.

5. In the Actions column of the item you want to move, click  or .

6. To sort the list alphabetically by name, click Sort by Name.

Tagging Builds
To tag an existing build:

Note: You can delete runs of tagged builds. If the selection of the runs that you are trying to delete
contains tagged builds, then you get a warning and you have to confirm the action. Tagged builds will
not get deleted if you perform a bulk delete (all or for a specific time span) by right clicking on the
execution node.

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. In the Builds section, click  in the Actions column of the build that you want to tag. A confirmation
dialog box displays.

5. Click Yes to continue with the tagging or click No to abort the tagging.

Deleting Builds
To delete an existing build from a version:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Deactivate the build you want to delete.

For additional information, see Activating and Deactivating Builds.

5. In the actions column of the build, click . A confirmation dialog box displays.

6. Click Yes to continue with the deletion or click No to abort the deletion.

Managing Components
Components are discrete product elements that are tracked separately for testing purposes.
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Adding Components
To add a new component to a product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Click New Component. The New Component dialog box displays.

5. Type a name for the new component in the Name text box.

6. Type a description for the component in the Description text box.

7. Select the Type of the component.

Available values are Software and Documentation.

8. Check the Active check box to make this component available for association with products.

9. Click OK to save the component, or click Cancel to abort the operation.

Editing Components
To edit an existing component within a product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Select the component you want to edit.

5. The Edit Component dialog box displays, detailing the Name, Description, and Active status of the
selected component. Make all required changes, then click OK.

Note: The type of a component can only be edited if you deactivate the component first. For
additional information, see Activating and Deactivating Components.

Activating and Deactivating Components
To activate or deactivate an existing component:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Click the Status icon associated with the component you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

5. Confirm the message to toggle the component status to active or inactive.

Sorting the Components List
To move a component up or down in the list or sort the components list alphabetically by name:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. In the Component Type list box, select the component type for which you want to see the components.

5. In the Actions column of the item you want to move, click  or .

6. To sort the list alphabetically by name, click Sort by Name.
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Deleting Components
To delete an existing component from a product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Deactivate the component you want to delete.

For additional information, see Activating and Deactivating Components.

5. In the actions column of the component, click . A confirmation dialog box displays.

6. Click Yes to continue with the deletion or click No to abort the deletion.

Managing Platforms
Set up platform designations for tests, for example operating systems. As with product, version, and build
setup, platforms can be assigned names, descriptions, and active or inactive status.

Adding Platforms
To add a new platform:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Platforms tab. The Platforms page displays, listing all existing platforms.

3. Click New Platform. The New Platform dialog box displays.

4. Type a name for the new platform in the Name text box.

5. Type a description for the platform in the Description text box.

6. Check the Active check box to make this platform available for association with tests.

7. Click OK to save the platform.

Editing Platforms
To edit an existing platform:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Platforms tab. The Platforms page displays, listing all existing platforms.

3. In the Actions column of the platform that you want to edit, click .

4. The Edit Platform dialog box displays, detailing the Name, Description, and Active status of the
selected platform. Make all required changes, then click OK.

Activating and Deactivating Platforms
Note: Platforms that are associated with a test cannot be deactivated.

To activate or deactivate an existing platform:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Platforms tab. The Platforms page displays, listing all existing platforms.

3. Click the Status icon associated with the platform you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

4. Confirm the message to toggle the platform status to active or inactive.
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Sorting the Platforms List
To move a platform up or down in the list or sort the platforms list alphabetically by name:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Platforms tab. The Platforms page displays, listing all existing platforms.

3. In the Actions column of the item you want to move, click  or .

4. To sort the platforms list alphabetically by name, click Sort by Name.

Deleting Platforms
To delete an existing platform:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Platforms tab. The Platforms page displays, listing all existing platforms.

3. Deactivate the platform you want to delete.

For additional information, see Activating and Deactivating Platforms.

4. In the Actions column of the platform that you want to delete, click . A confirmation dialog box
displays.

5. Click Yes to continue with the deletion or click No to abort the deletion.

Platform Configuration Page
Administration > Platforms

Use this page to configure platforms.

To create a new platform, click New Platform. For additional information, see Adding Platforms.

To sort the platforms list alphabetically by name, click Sort by Name. For additional information, see
Sorting the Platforms List.

For each listed platform, the page displays the following columns:

Columns Description

Actions The user can perform the following
actions on a platform:

Moves the platform up one
row in the list.

Moves the platform down one
row in the list.

Deletes the platform
permanently. Platforms need
to be inactive before you can
delete them, and deletion is
not allowed if a platform is
already associated to a test.

Name The name of the platform as it
displays in the GUI and in reports.
Click the name of a platform to modify
the name, description, and status of
the platform.
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Columns Description

Description A textual description of the platform.

Status The status of the platform, Active
or Inactive. Click the status to
toggle between Active and
Inactive.

Created On Date when the platform was created.

Created By The user who created the platform.

Managing Products
Describes how to configure products in SilkCentral.

Adding Products
To add a new product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click New Product. The New Product dialog box displays.

4. Type a name for the new product in the Name text box.

5. Type a description for the product in the Description text box.

6. Check the Active check box to make this product available for association with tests.

7. Click OK to save the product.

Note: When creating a product, SilkCentral automatically creates a new default version 1.0 and a
new default build 1 for the new product.

Editing Products
To edit an existing product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. In the Actions column of the product that you want to edit, click . The Edit Product dialog box
displays.

4. Make all required changes to the Name, Description, and Active status of the selected product, then
click OK.

Activating and Deactivating Products
To activate or deactivate an existing product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click the Status icon associated with the product you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

4. Confirm the message to toggle the product status to active or inactive.

Sorting the Products List
To move a product up or down in the list or sort the products list alphabetically by name:
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1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. In the Actions column of the item you want to move, click  or .

4. To sort the list alphabetically by name, click Sort by Name.

Deleting Products
To delete an existing product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Deactivate the product you want to delete.

For additional information, see Activating and Deactivating Products.

4. In the Actions column of the product that you want to delete, click . A confirmation dialog box
displays.

5. Click Yes to continue with the deletion or click No to abort the deletion.

Product Configuration Page
Administration > Products, Versions, and Builds > Products

Use this page to configure products, components, versions, and builds.

Click New Product to create a new product. Click Sort by Name to sort the products alphabetically by
name.

For each listed product, the page displays the following columns:

Column Description

Actions You can perform the following actions on a product:

Moves the product up one row in the list.

Moves the product down one row in the list.

Edit the name, description, and status of the
product.

Deletes the product permanently. Products need
to be inactive before you can delete them, and
deletion is not allowed if a product is already
associated to a test.

Name The name of the product as it displays in the GUI and in
reports. Click the name of a product to modify the
product's components, versions, and builds.

Description A textual description of the product.

Status The status of the product, Active or Inactive. Click
the status to toggle between Active and Inactive.

Created On Date when the product was created.

Created By The user who created the product.

For a selected product, the page displays the details of the included components, versions, and builds.

The page displays the following columns for the components of the product:
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Column Description

Actions You can delete the component in this column.

Name The name of the component. Click to open the Edit
Component dialog box.

Description The description of the component.

Created On Date when the component was created.

Created By The user who created the component.

Status The status of the component. Active or Inactive.
Click to toggle the status.

Click New Component to create a new component. Click Sort by Name to sort the components
alphabetically by name. Click Update to update the components list.

The page displays the following items for the versions of the product:

Item Description

Actions You can delete the version in this column, or move the
version up or down in the list.

Name The name of the version. Click to open the Edit Version
dialog box.

Description The description of the version.

Created On Date when the version was created.

Created By The user who created the version.

Status The status of the version. Active or Inactive. Click
to toggle the status.

Click New Version to create a new version. Click Sort by Name to sort the versions alphabetically by
name.

The page displays the following items for the builds of the product:

Item Description

Actions You can delete the build or tag the build.

Name The name of the build. Click to open the Edit Build dialog
box.

Description The description of the build.

Created On Date when the build was created.

Created By The user who created the build.

Status The status of the build. Active or Inactive. Click to
toggle the status.

Click New Build to create a new build. Click Sort by Name to sort the builds list alphabetically by name.
Click Update to update the components list.

Note: You have to select a specific version in the Builds list box to enable these buttons.

Click Back to return to the product list.
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Managing Versions
Versions are product releases that are tracked separately for development and testing purposes.

Adding Versions
To add a new version to a product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Click New Version. The New Version dialog box displays.

5. Type a name for the new version in the Name text box.

6. Type a description for the version in the Description text box.

7. Check the Active check box to make this version available for association with products.

8. Click OK to save the version, or click Cancel to abort the operation.

Editing Versions
To edit an existing version within a product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Select the version you want to edit. The Edit Version dialog box displays.

5. Make all required changes to the Name, Description, and Active status of the selected version, then
click OK.

Activating and Deactivating Products
To activate or deactivate an existing product:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click the Status icon associated with the product you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

4. Confirm the message to toggle the product status to active or inactive.

Sorting the Versions List
To move a version up or down in the list or sort the versions list alphabetically by name:

1. In the menu, click Administration > Products, Versions and Builds .

2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. In the Actions column of the item you want to move, click  or .

5. To sort the list alphabetically by name, click Sort by Name.

Deleting Versions
To delete an existing version from a product:

1. In the menu, click Administration > Products, Versions and Builds .
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2. Click the Products tab. The Products page displays, listing all existing products.

3. Click a product name. The Product Detail page for the product opens.

4. Deactivate the version you want to delete.

For additional information, see Activating and Deactivating Versions.

5. In the Actions column of the product that you want to delete, click . A confirmation dialog box
displays.

6. Click Yes to continue with the deletion or click No to abort the deletion.

Maintaining Value Lists
Value lists are used to populate custom properties within custom issue tabs that can be configured for
Issue Manager in Issues > Configuration . For details regarding custom issue properties and tabs, refer
to the SilkCentral Issue Manager Administration Guide.

Adding Value Lists
To add a new value list:

1. In the menu, click Administration > Lists of Values .

2. Click New List. The New List Of Values dialog box displays.

3. Type a name for the new value list in the Name text box and a description for the value list in the
Description text box.

4. From the Grouped by list box, select a parameter by which this list is to be grouped.

This selection is definite and cannot be edited once you save your new list. Grouping values means that
each value in your list must be assigned a value from the list you selected in the Grouped by list box.
Not grouping values means that you can define custom values manually.

5. Click New Value to add a value to the list. The New Value dialog box displays.

6. Type a Name and Description for the new value.

7. Select a value from the Grouped by list box, if applicable.

8. Select the position of the new value within the list of existing values from the Insert after list box, or
select <last entry> to add the new value to the end of the list.

9. Click OK to save the value. The New List Of Values dialog box displays the newly added value.

10.Add as many additional values as are required to complete the value list.

11.Click OK to save the value list.

Editing Value Lists
To edit an existing value list:

1. In the menu, click Administration > Lists of Values .

2. Click the name of the value list you want to edit. The Edit List of Values dialog box displays.

3. Change the Name, Description, and Group by setting of the selected value list, then click OK.

Note: Each individual value that is configured for the list is also available for editing. For details on
editing individual values, see Editing Individual Values.

Editing Individual Values
To edit an individual value within a value list:

1. In the menu, click Administration > Lists of Values .
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2. Click the name of the value list you want to edit. The Edit List of Values dialog box displays.

3. Click the name of the value you want to edit. The Edit Value dialog box displays.

4. Edit the Name and Description of the value as required.

5. Click OK to save your changes.

Activating and Deactivating Value Lists
Note: You cannot deactivate the value list Issue Types, as this list is required by Issue Manager.

To activate or deactivate an existing value list:

1. In the menu, click Administration > Lists of Values .

2. Click the Status icon associated with the value list you want to activate or deactivate. A confirmation
dialog box displays, asking you if you are sure about the activation or deactivation.

3. Confirm the message to toggle the value list status to Active or Inactive.

Note: Each individual value that is configured for the list can also be activated or deactivated. For
details on activating or deactivating individual values, see Activating and Deactivating Individual
Values.

Activating and Deactivating Individual Values
To activate or deactivate an individual value within a value list:

1. In the menu, click Administration > Lists of Values .

2. Click the name of the value list that includes the value you want to activate or deactivate. The Edit List
of Values dialog box displays.

3. Click the Status icon associated with the value you want to activate or deactivate. A confirmation dialog
box displays.

4. Click OK to save the updated value list.

Sorting Values within Value Lists
To move a value up or down within a value list or sort the value list alphabetically by value name:

1. In the menu, click Administration > Lists of Values .

2. Click the name of the value list that includes the value you want to sort. The Edit List of Values dialog
box displays.

3. In the Actions column of the item you want to move, click  or .

4. To sort the value list alphabetically by value name, click Sort by Value. The Sort By Value dialog box
displays.

5. Select the sort order, Ascending or Descending and click OK.

6. Click OK on the Edit List Of Values dialog box to save the updated value list.

Deleting Value Lists
To delete an existing value list:

1. In the menu, click Administration > Lists of Values .

2. Deactivate the value list you want to delete.

For additional information, see Activating and Deactivating Value Lists.
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3. In the Actions column of the value list that you want to delete, click . A confirmation dialog box
displays.

4. Click Yes to continue with the deletion or click No to abort the deletion.

Note: Each individual value that has been configured for the list is also available for deletion. For
details on deleting individual values, see Deleting Individual Values.

Deleting Individual Values
To delete an individual value within a value list:

1. In the menu, click Administration > Lists of Values .

2. Click the name of the value list that includes the value you want to delete. The Edit List of Values
dialog box displays.

3. Deactivate the value you want to delete. For additional information, see Activating and Deactivating
Individual Values.

4. In the Actions column of the value that you want to delete, click .

5. Click OK on the Edit List Of Values dialog box to save the updated value list.

List of Values Configuration Page
Administration > Lists of Values

Use this page to configure value lists. For each listed list of values, the page displays the following
columns:

Column Description

Name The name of the value list as it displays in the GUI and in
reports. Click the name of a value list to modify the name,
description, and values of the value list.

Grouped By Displays if a value list is grouped by Product or Issue
Types, or if it is Not Grouped.

Status The status of the value list, Active or Inactive.
Click the status to toggle the between Active and
Inactive. The default value list, Issue Types, cannot
be deactivated, because it is a key component used in
Issue Manager.

Created On Date when the value list was created.

Created By The user who created the value list.

Changed On Date when the value list was last modified.

Changed By The user who last modified the value list.

Actions You can perform the following actions on a value list:

Deletes the value list permanently. Value lists
need to be inactive before you can delete them,
and deletion is not allowed if a value list is already
associated with issues.

Click New List to create a new value list.
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Configuring Global Schedules
You can define global schedules that can be re-used in Test Manager for the scheduling of execution
plans. Global schedules speed up the process of scheduling execution plans since the need to define
individual schedules is reduced to only those execution plans that require special scheduling. For detailed
information on schedules, refer to the SilkCentral Test Manager Help.

Exclusions

You can define weekdays and time-of-day intervals during which tests are not to be executed. For
example, you may not want tests to take place on weekends.

Definite Runs

You can define points in time at which tests must execute, regardless of configured schedules.

Adding Global Schedules
To add a new global schedule:

1. In the menu, click Administration > Schedules . The Schedules page displays, listing all existing
global schedules.

2. Click New Schedule. The Configure Schedule page displays.

3. Type a name for the new schedule in the Name text box.

4. Type a description for the schedule in the Description text box.

5. Click  next to From to define a start date and time for the schedule.

6. Define the Interval at which an execution should repeat. The available time range is from 1 minute to
36 days.

7. Check the Adjust schedule to daylight savings check box to have scheduled executions
automatically adjust to daylight-saving time changes.

8. Click  next to run to define the date and time at which execution should end. Click Forever to
execute for an undefined time period, or until to execute for a defined period.

9. To define weekdays and time-of-day intervals at which the test should not execute, click Add
Exclusion.

For additional information, see Scheduling Exclusions.

10.To define a point in time when the test must execute, click Add Definite Run.

For additional information, see Scheduling Definite Runs.

11.Click Save when you have finished defining the schedule.

Editing Global Schedules
To modify a global schedule:

1. In the menu, click Administration > Schedules . The Schedules page displays, listing all existing
global schedules.

2. Click the name of the schedule you want to edit. The Configure Schedule page displays.

3. Change the name of the schedule in the Name text box.

4. Change the description of the schedule in the Description text box.

5. Click  next to From to define a new start date and time for the schedule.
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6. Change the Interval at which an execution should repeat. The available time range is from 1 minute to
36 days.

7. Check the Adjust schedule to daylight savings check box to have scheduled executions
automatically adjust to daylight-saving time changes.

8. Click  next to run to define the date and time at which execution should end. Click Forever to
execute for an undefined time period, or until to execute for a defined period.

9. To define weekdays and time-of-day intervals at which the test should not execute, click Add
Exclusion.

For additional information, see Scheduling Exclusions.

10.To define a point in time when the test must execute, click Add Definite Run.

For additional information, see Scheduling Definite Runs.

11.Click Save when you have finished modifying the schedule.

Activating and Deactivating Global Schedules
To activate or deactivate an existing product:

1. In the menu, click Administration > Schedules . The Schedules page displays, listing all existing
global schedules.

2. Click the Status icon associated with the schedule that you want to activate or deactivate. A
confirmation dialog box displays, asking you if you are sure about the activation or deactivation.

3. Confirm the message to toggle the schedule status to Active or Inactive.

Deleting Global Schedules
To delete an existing global schedule:

1. In the menu, click Administration > Schedules . The Schedules page displays, listing all existing
global schedules.

2. In the Actions column of the schedule that you want to delete, click . A confirmation dialog box
displays.

3. Click Yes to remove the current schedule, including all exclusions and definite runs, or click No to abort
the deletion.

Note: Once a global schedule is in use by a test, you cannot delete it. You must first re-schedule
all tests to another schedule.

Scheduling Exclusions
To schedule exclusions:

1. In the menu, click Administration > Schedules . The Schedules page displays, listing all existing
global schedules.

2. Click the name of the schedule you want to edit.

3. On the Configure Schedule page, click Add Exclusion.

4. On the Configure Schedule Exclusion page, select the weekdays on which tests should be
suppressed.

5. Define the specific time intervals on those days during which execution should be suppressed.

6. Click OK once you have completed definition of exclusion settings, or click Cancel to abort. Exclusion
settings are now listed on the Configure Schedule page.

7. Click Save to add the exclusion to the current schedule, or continue adding additional exclusions.
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Tip: You can edit and delete exclusions by clicking  or  in the Actions column of the
exclusion that you want to modify.

Scheduling Definite Runs
To schedule definite runs:

1. In the menu, click Administration > Schedules . The Schedules page displays, listing all existing
global schedules.

2. Click the name of the schedule you want to edit.

3. On the Configure Schedule page, click Add Definite Run.

4. On the Configure Definite Run page, click  to define a point in time for the definite run.

5. Click OK once you have completed definition of the definite run, or click Cancel to abort. Definite run
settings are now listed on the Configure Schedule page.

6. Click Save to add the definite run to the current schedule, or continue adding additional definite runs.

Tip: You can edit and delete definite runs by clicking  or  in the Actions column of the
definite run that you want to modify.

Schedules Configuration Page
Administration > Schedules

Use this page to configure global schedules for Test Manager. For each schedule, the page displays the
following columns:

Column Description

Actions This column contains action icons which allow the user to perform the following
actions on a schedule:

Deletes the schedule permanently. Deletion is not allowed if a schedule is
already associated with execution plans.

Name The name of the schedule as it displays in the GUI and in reports. Click the name of a
schedule to modify the name, description, and status of the schedule.

Description A textual description of the schedule.

Status The status of the schedule, Active or Inactive. Click the status to toggle
between Active and Inactive.

Created On Date when the schedule was created.

Created By The user who created the schedule.

Click New Schedule to create a new schedule.

Managing the File Pool
The file pool is an upload and download area on the SilkCentral Web server, which is called the front-end
server. SuperUsers and Administrators can upload files to this area and make them available for the
creation of new tests.

You can upload a file from your hard disk or UNC path through the browser interface.
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Note: Creating a test from an uploaded file does not remove that file from the file pool; it creates an
independent instance. To remove files from the file pool, navigate to Administration > Files and click
the Delete icon of the file you want to remove.

Uploading Files from a Browser
To upload a file from a browser:

1. In the menu, click Administration > Files .

2. Click the File Pool tab. The File Pool page displays, listing the files that have been uploaded to the file
pool.

3. Click Upload From Browser to open the Upload file to file pool page.

4. Type a Description for the file you want to upload.

5. To make the uploaded file available only to a specific project, select the project name from the Project
list box. If the file is to be accessible by all projects, select No specific project.

6. Optionally, you can assign an Owner to the uploaded file.

This enables users to filter the file pool based on the owners of files.

7. In the Select file for upload text box you can manually enter a valid local path or a UNC path to the file
you want to upload. Alternately, you can browse for the file using Browse.

SilkCentral only allows .sep, .stp, .zip, and .ltz files for test creation.

8. Click Upload to upload the file to the SilkCentral file pool. You are be returned to the File Pool page
where the file you uploaded is listed. The file is now available for the creation of new tests in Test
Manager.

File Pool Page
Administration > Files

Use the File Pool page to upload files to the file pool and to download files from the file pool.

Filter options enable you to better target the uploaded files you want to access. The page allows you to set
the following filter items:

Filter Item Description

Uploaded By Displays files uploaded by the selected user, or files
uploaded by any user.

Project Displays files associated to the selected project.
Selecting Any Project will display all uploaded files,
while selecting No specific project will display
only files that are not associated to any project.

Owner Displays files associated to the selected owner. Selecting
Any Owner will display all uploaded files, while
selecting No Owner will display only files that are not
associated to an owner.

Update Updates the list of displayed files according to your filter
settings.

For each listed file, the page displays the following columns:
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Table Item Description

Actions This column contains action icons
which allow the user to perform the
following actions on a file:

Deletes a file permanently
from the file pool.

Downloads a file to your local
computer.

File The filename of a file.

File Size The size of the file.

Uploaded On Date when the file was uploaded.

Uploaded By The user who uploaded the file.

Project The project to which the file is
associated. Files can also be
associated to no specific project,
indicating that they can be used by
any project.

Owner The user who owns the file. If a file
has no owner, any user with
permission to access the file pool can
access or modify this file.

Upload Buttons Description

Upload From Browser Uploads a file from your hard disk or a UNC path through
the browser interface.

Upload From SilkPerformer Provides information on how to upload a project from
SilkPerformer.

Time Zones
SilkCentral is designed to execute tests over a network of execution servers. Because the Internet enables
such networks to be spread worldwide across multiple time zones, it is important to understand time-zone
handling in SilkCentral.

All date and time values are saved in GMT to the database. The presentation of values is set based on the
Time zone setting specified in the user settings. For more information, see Adding User Accounts.

The following requirements apply:

• The application server and front-end server should be in the same time zone. Separating these servers
locally within a WAN does not make sense because the application server communicates closely with
one or several front-end servers. Also, front-end servers as well as the application server have direct
database access.

• Execution servers may be in different time zones, separated both from the application server and from
other execution servers.
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Configuring Advanced Settings
This section describes how to configure advanced settings to customize your SilkCentral system.

Login Options
The following two enhanced login configurations are available:

Remember Login

Changing the default setting for the Remember login option on the SilkCentral login page.

Normally when users work with multiple browser windows, each browser session checks out a unique
license. Enabling Remember login allows individual users to work with multiple browser sessions on a
single computer while checking out only a single license.

Each user may enable or disable the Remember login option as required; the administrator can however
set the default setting.

Cookie Duration

Each time a user accesses SilkCentral, a cookie containing encoded login information is created. These
cookies are destroyed when users log out, or when sessions time out. When the Remember login option
is enabled however, cookies are not destroyed when sessions time-out. Instead, they remain active for a
set duration of time. This enables users to continue working with SilkCentral without re-entering login
information after each session time-out. By default, cookies remain active for 30 days. The duration setting
can be adjusted by the administrator.

Configuring the Remember Login Option
To enable or disable the remember login option:

1. Stop the front-end server.

2. Open the SccFrontendBootConf.xml file with a text editor.

This file is located in the /conf/frontendserver folder of the SilkCentral directory on the front-end
server.

3. Locate the BootConf\Options\Login\RememberLogin XML tag.

By default, the tag is set to <RememberLogin>true</RememberLogin>.

4. Set the value to false to have the login page open with an unchecked Remember Login check box
by default. Set the value to true to have the login page open with a checked Remember Login check
box by default.

5. Save and close the XML file.

6. Re-start the front-end server.

Adjusting the Cookie Duration
To set the duration of login cookies:

1. Stop the front-end server.

2. Open the SccFrontendBootConf.xml file with a text editor.
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This file is located in the /conf/frontendserver folder of the SilkCentral directory on the front-end
server.

3. Locate the BootConf\Options\Login\MaxCookieAge XML tag.

By default, the tag is set to <MaxCookieAge>30</MaxCookieAge>.

4. Set the value to the number of days you want login cookies to remain active on user computers.

5. Save and close the XML file.

6. Re-start the front-end server.

Using the SilkCentral Service Manager
The SilkCentral Service Manager is a tool that is used to manage the SilkCentral services and to view their
log files. The following services are available:

• Execution server
• Front-end server
• Application server
• Chart server

Log Files

SilkCentral servers write their activities to log files. When application errors or system failures occur, these
log files provide valuable information regarding the root causes of problems.

SilkCentral Services
Setup automatically installs the Service Manager when any of the four services are installed. You can
access the Service Manager either from the SilkCentral program group, or from its Windows task bar tray
icon. The Windows services, which are viewable in the Windows Services window, are called SilkCentral
<name> Server, for example SilkCentral Application Server.

Note: The Service Manager does not work out-of-the box on Windows platforms that use User
Account Control (UAC), like for example Microsoft Windows Vista, Microsoft Windows 7, or Microsoft
Windows Server 2008. To enable the Service Manager to work on these platforms, you either need to
disable UAC or stop the Service Manager and start it again with the option Run as administrator.

All four services must be running to enable operation of SilkCentral. The services can be distributed over
different computers or run on a single machine. For information about installing services, refer to the Test
Manager Installation Help.

Tip: Stopping and restarting services is an administrative task that only needs to be done when a
system is not operating as intended, or when maintenance tasks are required.

SilkCentral Execution Server
The SilkCentral execution server can be run as both a Windows system service and as a Windows
process.

By default, SilkCentral launches an execution server as Windows process.

While a Windows process is launched with the credentials of the currently logged in user, a system service
is launched with the local system account, by default the Windows system account. A system service
remains active even after the user logs off; thus the SilkCentral execution server is available until the
computer is turned off completely.

To execute and monitor SilkTest Classic, Citrix, and SAP scripts you must launch the SilkCentral execution
server as a Windows process, with valid user credentials.
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Managing Which SilkCentral Services Shall Be
Running At System Start
SilkCentral services are services that will start automatically when the system is started. You can change
this behavior if you want to deactivate a service, or if you want to switch an execution server permanently
from service mode to process mode.

To manage which individual SilkCentral services shall be running at system start:

1. Double-click the SilkCentral Service Manager tray icon in the Windows task bar. The SilkCentral
Service Manager displays, with up to five tabs visible, depending on the services that are installed on
this computer.

2. Click the tab that corresponds to the service you want to access:

• SilkCentral Execution Server
• Execution Server (Process)
• SilkCentral Front-End Server
• SilkCentral Application Server
• SilkCentral Chart Server

3. Check the Run at start-up check box if you want the selected service to start automatically.

4. Click OK to finish managing the servers. The SilkCentral Service Manager closes, but remains active in
the system tray.

Note: The Execution Server (Process) will only start after a logon to the Windows server.

Starting or Stopping All SilkCentral Services
Caution: SilkCentral will not operate properly when the four services are not running.

To start or stop all SilkCentral services at once:

1. Right-click the SilkCentral Service Manager tray icon in the Windows task bar.

2. Click one of the following:

Start all Services All SilkCentral services currently installed on the computer begin running.

Stop all Services All SilkCentral services installed on the computer are stopped.

3. To start or stop individual services, see Starting or Stopping Individual Services.

Starting or Stopping Individual SilkCentral Services
Caution: SilkCentral will not operate properly when the four services are not running.

To start or stop individual services:

1. Double-click the SilkCentral Service Manager tray icon in the Windows task bar. The SilkCentral
Service Manager displays, with up to five tabs visible, depending on the services that are installed on
this computer.

2. Click the tab of the service you want to manage.

To run the SilkCentral Execution Server as a Windows process, rather than as a system service like the
other servers, see Running the Execution Server as a Windows Process.

3. Click Start or Stop to start or stop the selected service.

4. Click Query Status to check the current status of a service.
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Note: Make sure the service status is running to enable the operation of SilkCentral.

The execution server runs as a Windows process, rather than as a system service like the other
servers. Therefore, you can launch the SilkCentral Execution Server with a console window that
displays real-time activity.

Note: This option is disabled for the front-end, application, and chart servers.

5. To launch the SilkCentral execution server with a console window:

1. On the Execution Server (Process) tab, click Start with console.
2. Click Stop.
3. Click Start.

6. Click OK to finish managing the services. The Service Manager closes, but remains active in the
system tray.

Starting The SilkCentral Execution Server As Windows
Process
Per default, an execution server runs as a Windows system service under the system account. For
executing GUI-level tests or browser-driven tests however, the execution server must run as a process
using the credentials of an actual user.

Tip: Both execution server modes, service and process, should not be run simultaneously. Before
beginning a new execution server mode, first stop the currently running execution server.

To start the SilkCentral execution server as a Windows process:

1. Double-click the SilkCentral Service Manager tray icon in the Windows task bar. The SilkCentral
Service Manager displays, with up to five tabs visible, depending on the services that are installed on
this computer.

2. Click the SilkCentral Execution Server tab.

This tab represents the SilkCentral execution server, running as a Windows system service.

3. Click Stop to stop the SilkCentral execution server system service.

4. Click Query Status to check the service’s status.

Make sure that the service status is stopped.

5. Uncheck Run at start-up to prevent that the service is started after computer re-boot.

6. Click the Execution Server (Process) tab.

This tab represents the SilkCentral execution server, running as a Windows process.

Note: The Windows process is launched with the credentials of the user who is currently logged
in. Make sure that this user has sufficient privileges to accomplish the tasks you are planning to
execute with SilkCentral execution server.

7. Click Start to start the SilkCentral execution server as a Windows process.

To start the SilkCentral execution server with a console window that displays real-time activity, see
Starting or Stopping Individual SilkCentral Services.

8. Check Run at start-up so that the process is started after computer re-boot and re-login.

9. Click OK to finish managing the SilkCentral execution server. The Service Manager closes, but remains
active in the system tray.
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Viewing Log Files from the SilkCentral Service
Manager Console
To view SilkCentral log files from the SilkCentral Service Manager console:

1. Double-click the SilkCentral Service Manager tray icon in the Windows task bar. The SilkCentral
Service Manager displays, with up to five tabs visible, depending on the services that are installed on
this computer.

2. Select the tab representing the server of which you want to view the log file.

3. Click the Logfile link of the server.

The log file opens in the registered text editor. Microsoft Notepad by default.

4. On the SilkCentral Service Manager, click OK or Cancel to close the Service Manager. The Service
Manager closes, but remains active in the system tray.

Suspicious Execution Duration
The execution durations of tests vary, however if an execution takes too long, the user that made the last
change to the execution plan can get notified by email.

SilkCentral sends a notification when test execution takes longer than a certain amount of time. The user
can define how long a test execution may take before an email is sent.

Note: You can also set a timeout for each specific test by setting the Execution Time-Out [s]
property in the Success Conditions section of the Tests area.

Setting the Suspicious Execution Duration
To set the suspicious execution duration:

1. Stop the application server.

2. Open the TmAppServerHomeConf.xml file with a text editor.

This file is located in the /conf/appserver folder of the SilkCentral directory on the application
server.

3. Locate the Config\ExecutionTracking\SuspicousDuration XML tag.

By default, the tag is set to <SuspicousDuration>360</SuspicousDuration>.

4. Set the duration value to the number of minutes after which SilkCentral should notify the administrator
about test executions that take too long.

5. Save and close the XML file.

6. Restart the application server service.

Disable Updating of External Issue Statistics
Updating the issue statistics of external issue tracking profiles may use much memory. This may also slow
down performance. To disable updating:

1. Stop the application server.

2. Open the TmAppServerHomeConf.xml file with a text editor.

This file is located in the /conf/appserver folder of the SilkCentral directory on the application
server.

3. Locate the Config/IssueStateUpdate/UpdateIssueUnitStatistics XML tag.
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By default, the tag is set to true.

4. Set the value to false to disable updating.

5. Save and close the XML file.

6. Restart the application server service.

Date and Time Formats
SilkCentral offers user-defined date and time format settings. Each SilkCentral user can change their user
settings, which include options for displaying custom date formats in the form of long or short date formats.
For additional information, see Editing User Accounts.

SilkCentral presents lists of pre-defined date and time formats from which users may choose. SilkCentral
administrators can populate these lists with customized formats.

Pattern Definition

Date and time formats are specified by date and time pattern strings. Within date and time pattern strings,
unquoted letters from "A" to "Z" and from "a" to "z" are interpreted as pattern letters representing the
components of a date or time string. Text can be quoted using single quotes (') to avoid interpretation. "''"
represents a single quote. All other characters are not interpreted; they are simply copied into the output
string during formatting or matched against the input string during parsing.

The following pattern letters are defined. All other characters from "A" to "Z" and from "a" to "z" are
reserved:

Letter Date or Time Component Presentation Examples

G Era designator Text AD

y Year Year 1996; 96

M Month in year Month July; Jul; 07

w Week in year Number 27

W Week in month Number 2

D Day in year Number 189

d Day in month Number 10

F Day of week in month Number 2

E Day in week Text Tuesday; Tue

a Am/pm marker Text PM

H Hour in day (0-23) Number 0

k Hour in day (1-24) Number 24

K Hour in am/pm (0-11) Number 0

h Hour in am/pm (1-12) Number 12

m Minute in hour Number 30

s Second in minute Number 55

S Millisecond Number 978

z Time zone General time zone Pacific Standard Time;
PST; GMT-08:00

Z Time zone RFC 822 time zone -0800
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Pattern letters are usually repeated, as their number determines the exact presentation.

The following list explains the items in the Presentation column in the table above:

Item Description

Text For formatting, when the number of pattern letters is 4 or more, the full form is used;
otherwise an abbreviated form is used, when available. For parsing, both forms are
accepted, independent of the number of pattern letters.

Number For formatting, the number of pattern letters is the minimum number of digits, and shorter
numbers are zero-padded to this amount. For parsing, the number of pattern letters is
ignored unless it is needed to separate two adjacent fields.

Year For formatting, when the number of pattern letters is 2, the year is truncated to 2 digits;
otherwise it is interpreted as a Number.

Month When the number of pattern letters is 3 or more, the month is interpreted as Text;
otherwise, it is interpreted as a Number.

General time
zone

Time zones are interpreted as Text when they have names. When the number of pattern
letters is less than 4, the time zone abbreviation is displayed, for example PST. When the
number of pattern letters is 4 or more, the full name is displayed, for example Pacific
Standard Time.

RFC 822 time
zone

The RFC 822 4-digit time zone format is used, for example -0800.

Examples

The following examples show how date and time patterns are interpreted in the U.S.
The given date and time are 2001-07-04 12:08:56 local time, Pacific Standard Time
zone.

Date and Time Pattern Result

"yyyy.MM.dd G 'at' HH:mm:ss z" 2001.07.04 AD at 12:08:56 PDT

"EEE, MMM d, ''yy" Wed, Jul 4, '01

"h:mm a" 12:08 PM

"hh 'o''clock' a, zzzz" 12 o'clock PM, Pacific Daylight Time

"K:mm a, z" 0:08 PM, PDT

"yyyyy.MMMMM.dd GGG hh:mm
aaa"

02001.July.04 AD 12:08 PM

"EEE, d MMM yyyy HH:mm:ss Z" Wed, 4 Jul 2001 12:08:56 -0700

"yyMMddHHmmssZ" 010704120856-0700

Customizing Date and Time Formats
To customize date and time formats:

1. Stop the front-end server.

2. Open the SccFrontendBootConf.xml file with a text editor.

This file is located in the /conf/frontendserver folder of the SilkCentral directory on the front-end
server.

3. Locate the DateFormats XML tag.
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The XML tags <LongDateFormats> and <ShortDateFormats> show the date formats that are
available by default. You can add or remove any formats you want to make available or unavailable to
users.

4. Type time formats based on Java’s SimpleDateFormat class.

5. Save and close the XML file.

6. Re-start the front-end server.

HTML Response Compression
The SilkCentral front-end server offers an option for automatically sending gzip-compressed responses.
Enabling this feature speeds up load times of SilkCentral HTML pages, but results in a slight increase of
load on the front-end server, depending on the amount of HTML requests, which is the number of
concurrent SilkCentral users, that you expect.

HTML response compression only works when the Web browsers of the users support HTML response
compression.

For the current list of supported browsers, refer to the release notes.

Enabling or Disabling HTML Response Compression
To enable or disable HTML response compression:

1. Stop the front-end server.

2. Open the Server.xml file with a text editor.

This file is located in the /conf/frontendserver folder of the SilkCentral directory on the front-end
server.

3. Locate the Connector XML tag.

4. Add compression="on" and compressableMimeType="text/html,text/xml,text/
plain,text/css,text/javascript,application/xml" to the connectors.

The servlet will compress any response with gzip. Gzip is taken from Apache Tomcat Native.

5. Save and close the XML file.

6. Re-start the front-end server.

Host Name Display
When you are working with Web applications on multiple front-end servers, it can be useful to know which
host you are working on. SilkCentral offers a setting that displays the host name of the front-end server in
the title bar of your Web browser.

Displaying or Hiding the Host Name in the Title Bar of
Your Web Browser
To display or hide the host name in the title bar of your Web browser:

1. Stop the front-end server.

2. Open the SccFrontendBootConf.xml file with a text editor.

This file is located in the /conf/frontendserver folder of the SilkCentral directory on the front-end
server.

3. Locate the DisplayHostNameInTitleBar XML tag in the Options section of the file.
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4. If you set the value to true, which is the default value, the host name of the front-end server will be
displayed in the title bar of Web browsers when accessing SilkCentral. If you set the value to false, no
host name will be displayed, and if you set the value to any other string, the specified string will be
displayed.

For example, when the XML tag is set to true, the browser displays: HURRICANE - SilkCentral -
Micro Focus - Administration: System - Microsoft Internet Explorer.

When the tag is set to false, the browser displays: SilkCentral - Micro Focus -
Administration: System - Microsoft Internet Explorer.

When the tag is set to MyHost, the browser displays: MyHost - SilkCentral - Micro Focus -
Administration: System - Microsoft Internet Explorer.

5. Save and close the XML file.

6. Re-start the front-end server.

CVS Repository Access using Ext Method (using PuTTY)
PuTTY is a free, open-source, SSH-, Telnet-, rlogin-, and raw-TCP-client. For full details regarding PuTTY,
or to download a copy, visit http://www.chiark.greenend.org.uk/~sgtatham/putty/.

The ext method in CVS indicates that an external application is to be used to communicate with the CVS
server. To let the CVS command know what program to use, the program path must be specified in the
environment variable CVS_RSH. When using PuTTY, this needs to be the path of Plink.exe.

When using an ext method to connect to a CVS repository, the hostname and the credentials are
combined and stored in a PuTTY session. When specifying this session in a SilkCentral Test Manager
CVS profile, the servername, the username, and the password are ignored.

For additional information on CVS and other source control profiles, refer to the Test Manager Help.

Accessing a CVS Repository using Ext Method (using
PuTTY)
For additional information on CVS and other source control profiles, refer to the Test Manager Help.

To create a PuTTY profile to access a CVS repository by using ext method:

1. From within PuTTY, select the Session node in the Category tree.

2. Type your CVS server name in the Host name text box.

3. In the Load, save or delete a stored session area, define the session name by selecting a saved
session or loading a new session.

4. Select the Connection node in the Category tree.

5. Specify an Auto login username.

This username will be used by PuTTY to log into the target application when a username is not
specified. This setting will override any username set-up in CVS profile settings when using the ext
method.

6. Select the SSH/Auth node in the Category tree.

7. In the Private key for authentication text box, set the key file that is to be used for authentication.

Note: You can create private and public keys with the putty program puttygen.exe. Public/
Private key authentication enables you to login to the system without a password. The public key
will be installed on the server, the private key will be saved in a local file. Specify the local filename
in the Private key for authentication field. To optionally secure the key with a password, you
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need to use the PuTTY program pageant.exe. This program runs in the system tray and
maintains the password for private keys.

8. Select the Session node in the Category tree again, and click Save.

9. Now click Open to test your settings. You should now be able to execute putty @cvs-server and
generate a login shell. When you create a CVS profile in Test Manager you will need to enter the name
of the putty session as the servername, without the @ symbol.

Data Caching in Tests
Test Manager uses caching in Tests to improve the scalability of the front-end server and to reduce
database load when multiple users work on the same project simultaneously. The Tests tree and test
filters have significant impact on the front-end and database servers. Because information from the Tests
tree and filters for specific projects can be shared among users, these areas are well suited to caching.

Tests Tree Caching

The Tests tree cache retains all tree information for projects that are currently in use in memory and
regularly checks the database for changes to the tree. Administrators can influence the behavior of the
cache by setting Cache/TestPlanTree/CheckForChangesInterval in the
TMFrontendBootConf.xml configuration file. This is the maximum interval in seconds that tree
information may remain outdated. Regardless of this setting, if a change occurs to a test, folder, or
container on the same front-end server, the cache will be immediately updated with the change. The
Cache/TestPlanTree/CheckForChangesInterval setting is only relevant when a change occurs on
a different front-end server. When a project is not used by a user for more than an hour, the entire project
tree cache is cleared and the project is reloaded the next time a user accesses it.

Test Filter Caching

With filter caching, the IDs of tests that match the criteria of specific filters are cached for a specified period
of time, based on the minimum cache time setting and the execution time of each filter. Administrators can
influence this behavior by setting two properties at Cache/FilterCache/ in the
TMFrontendBootConf.xml configuration file.

The first property, MinimalLifeTime, defines the minimum time in seconds before a filter result can be
removed from the cache. The second property, LifeTimeMultiplier, makes this minimum setting
dependent on the time it takes to execute the filter query. For example, if you define a multiplier of > 0, the
maximum time that a result can remain in the cache is MinimalLifeTime, or the query execution time,
multiplied by the LifeTimeMultiplier. So, if you have a filter query that takes 1 second to execute, and
you use the default values, both 30, for MinimalLifeTime and LifeTimeMultiplier, then the filter
result will be cached for 30 seconds. If the filter query takes half a second to execute, then the filter result
will still be cached for 30 seconds. If however the filter query takes 2 seconds to execute, then the filter
result will be cached for 60 seconds.

JMX Measures for Caching

Test Manager offers JMX read measures to monitor underlying Java processes and other process-specific
measures. JMX information for the Tests tree cache and the test filter cache can be found in the JMX
measures tree at borland.com/Frontend/TM.

Note: Silk Performance Explorer and other tools can be used to track these and other measures.
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JMX Measures for Caching in Tests
JMX read measures are available to monitor the underlying Java process and other process-specific
measures in Test Manager. JMX information for the Tests tree cache and the filter cache can be found in
the JMX measures tree at borland.com/Frontend/TM.

Tests Tree Cache Measures

Two primary measures are available for the Tests tree cache. TestPlanTreeCache only delivers a
measure, NumberOfCachedProjects, on how many projects are currently cached. All details of the cache
of the project are available from the second measure, TestPlanTreeCache_0. This measure is actually
made out of the following measures:

Measure Description

Hits The number of times the cache was
used, and database requests were
not required.

LastUpdateCheckDurationInMillis The duration in milliseconds the last
update took, see
LastUpdateCheckTime, to check for
updates in the database.

LastUpdateCheckTime The time when the last update check
occurred.

LastUpdateDurationInMillis The duration in milliseconds the last
update took, see LastUpdateTime, to
update the cache after a change
occurred.

LastUpdateTime The time when the last update to the
cache occurred due to a change in
the Tests tree.

TreeInitializationTimeInMillis The duration in milliseconds it took to
load the whole project tree into the
cache. This value will not change as
long as the project cache is loaded.

TreeSize The number of test nodes, which are
test containers, test folders, and
tests, in the project.

UpdateChecks The number of checks for changes of
the Tests tree for this project since
the project tree cache was initialized.

Updates The number of updates of the cached
tree due to changes in the Tests tree.

Test Filter Cache Measures

The TestPlanFilterCache measure is comprised of the following three measures:

Measure Description

Hits The number of times the cache was
used and no separate execution of
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Measure Description

the filter on the database was
necessary.

Misses The number of times the filter cache
was not used, but the filter was
executed against the database.

Size The current number of cached filter
results.

JMX Measures for LQM Reporting Updater
Test Manager offers JMX read measures to monitor underlying Java processes and other process-specific
measures. JMX information on the LQM Reporting Updater can be found on your application server in the
JMX measures tree at borland.com/LQMReporting/TM.

Note: These measures only measure the common LQM Reporting updater, not an updater running
on a database upgrade. Silk Performance Explorer and other tools can be used to track these and
other measures.

Configuring the LQM Reporting Updater
Describes how to configure the interval and other settings of the thread that updates the LQM Reporting
tables (LQM Reporting Updater). For detailed information about the LQM Reporting tables, refer to the
Database Model Help.

To configure the LQM Reporting Updater settings:

1. Stop the application server.

2. Open the TMAppServerHomeConf.xml file with a text editor.

This file is located in the /conf/appserver folder of the SilkCentral directory on the application
server.

3. Locate the LQMReporting XML tag.

You can modify the following settings:

UpdateInterval Defines the interval in seconds when the LQM Reporting tables
are updated with the most current data.

MSSqlUpdateBatchSize Number of test tables processed at once. The batch size
determines how much memory and processor resources are used
on the application server for the update process. This setting only
affects MS SQL Server databases.

OracleUpdateBatchsize Same as MSSqlUpdateBatchSize, but for Oracle databases.

QueryTimeout Specifies the time-out in seconds after which queries in the LQM
Reporting update process are aborted. 0 or a negative value
specifies that the queries never time out.

OracleCheckForUpdateStrategy Determines how the update process reads from the source tables.
Allowed values are NOWAIT and WAIT.

• NOWAIT: When the update process wants to read from the
source tables and another process is currently writing to these
tables, the update process terminates and retries the next time
it is called.
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• WAIT: The update process grabs a table lock and waits until
other processes have finished accessing the tables, then reads
from the source tables. The advantage is that the process
always executes because it doesn't have to wait until a table is
unlocked. The disadvantage is that all other processes that try
to access a table after the LQM update process are blocked
and have to wait until the process releases the table lock.

4. Save and close the XML file.

5. Restart the application server service.

Configuring the Report Update Interval
To configure the report updater interval:

1. Stop the chart server.

2. Open the SccChartServerBootConf.xml file with a text editor.

This file is located in the /conf/chartserver folder of the SilkCentral directory on the application
server.

3. Locate the Options XML tag.

4. Change the value in MaxCacheAge to define the interval in seconds when the reports are updated with
the most current data.

5. Save and close the XML file.

6. Restart the chart server service.

JMX Measures for Monitoring the LQM Reporting
Updater
Test Manager offers JMX read measures to monitor underlying Java processes and other process-specific
measures. JMX information on the LQM Reporting Updater can be found on your application server in the
JMX measures tree at borland.com/LQMReporting/TM.

Note: The measures only measure the common LQM Reporting Updater, not an updater running on a
database upgrade.

LQM Reporting Updater Measures

The following measures are available:

Measure Description

LastDataLoadResetTime Gives the time when the last reset of
the LQM reporting tables was
performed. If this attribute is null, then
no reset was performed during the
lifetime of the process.

LastRunFromDate Gives the start of the time span
processed for the current update
cycle.

LastRunToDate Gives the end of the time span
processed for the current update
cycle.
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Measure Description

LastUpdatesNeededCheckDurationInMillis The duration (in milliseconds) of the
last check for new or changed data.

LastTotalUpdateDurationInMillis Total time used for the last update
run.

LastUpdateFixedAttributesDurationInMillis Duration of the last update of fixed
attributes.

LastDeleteDurationInMillis Time used to remove deleted nodes
from the LQM Reporting tables.

LastDeleteTestsCnt Number of tests deleted in the last
run.

LastInsertLQMTestsDuration Time used to insert new tests in the
LQM_Tests table.

LastUpdatesNeededCheckOracleWaitForTableLocksDuration Oracle requires special handling
when checking for updated tests. It
may be necessary to wait for other
processes to finish their transactions
on test tables. The time waited for
these transactions is measured by
this attribute.

LastInsertLQMTestUDAsDuration Time used to insert new tests in the
LQM_TestUDAs table.

LastSelectChangedDataQueryDurationInMillis Time used for querying changed
data.

LastUpdateTestsDurationInMillis Duration of the last update of
properties in the LQM_Tests table.

Configuring JMX Settings
Test Manager offers a set of default ports for the configuration of JMX settings.

Available Locations for Configuring JMX Settings

The communication on the default ports is by default unencrypted, meaning no SSL is running.

Setting Description

Dcom.sun.management.jmxremote.ssl=false The SSL is set to false by default.

Dcom.sun.management.jmxremote.authenticate=false The authentication is set to false by
default.

JMX settings can be configured in the following locations:

Location Settings

Application
Server

Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun
2.0\SCCAppServer\Parameters\Java Settings: ‘Options’. The default port for the application server
is: Dcom.sun.management.jmxremote.port=19142.
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Location Settings

Front-End
Server

Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun
2.0\SCCFrontendServer\Parameters\Java Settings: ‘Options’. The default port for the front-end
server is: Dcom.sun.management.jmxremote.port=19140.

Execution
Server

Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun
2.0\SCCExecServer\Parameters\Java Settings: ‘Options’. The default port for the execution server
is: Dcom.sun.management.jmxremote.port=19144.

Chart Server Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun
2.0\SCCChartServer\Parameters\Java Settings: ‘Options’. The default port for the chart server is:
Dcom.sun.management.jmxremote.port= 19146.

Execution Server Host Name Resolution
An execution server may no longer be recognized by the application server if the execution server's IP
address has changed. Re-starting the application server means the execution server should be recognized
again.

Java uses a cache to store the host name resolution to guard against DNS spoofing attacks. In SilkCentral
the result of positive host name resolutions are cached forever, but this can be changed by editing the file
java.security on the application server. This enables the application server to recognize execution
servers even if their IP address has changed.

More information on this Java setting can be found at http://java.sun.com/j2se/1.5.0/docs/guide/net/
properties.html.

Disabling The Caching of Host Name Resolutions
To specify that host name resolutions are never cached:

1. Stop the application server.

2. Open the java.security file with a text editor.

This file is located in the /lib/jre/lib/security folder of the SilkCentral directory on the
application server.

3. Locate the line #networkaddress.cache.ttl=-1 and change it to
networkaddress.cache.ttl=0.

Note: The "#" character needs to be removed to uncomment this line.

Caution: This change should be discussed with your network administrator, as there may be
security concerns in doing this.

4. Save and close the file.

5. Restart the application server service.

Configuring the Test Manager Location in Issue Manager
Describes how to configure the location of your Test Manager installation in Issue Manager. This enables
the traceability from issues in Issue Manager to related tests in Test Manager. For additional information on
using the traceability feature, refer to the Issue Manager documentation.

To configure the Test Manager location in Issue Manager:

1. Stop the front-end server.
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2. Open the SRFrontendBootConf.xml file with a text editor.

This file is located in the /conf/frontendserver folder of the SilkCentral directory on the front-end
server.

3. Locate the Alm\ElementServiceEndpoint and Alm\LinkServiceEndpoint XML tags.

4. Replace the default values localhost:19120 with the host and port information of your Test Manager
installation in both tags.

If your Test Manager installation uses the same front-end server as your Issue Manager installation,
and you use Tomcat Web server with the default port, then you can leave the default values.

5. Save and close the XML file.

6. Re-start the front-end server.

Disabling Unused Ports on Execution Servers
Depending on whether you use SSL or insecure communication between the application server and the
execution servers, you may want to disable the respective unused port. You can also disable the default
Tomcat port, which is never used by SilkCentral.

The following procedure needs to be performed on each execution server where you want to enable
persistent result data storage.

To disable unused ports on the execution server:

1. Stop the execution server.

2. Open the SccExecServerBootConf.xml file with a text editor.

This file is located in the /conf/execserver folder of the SilkCentral directory on the execution
server.

3. Locate the InsecurePort and SSLPort XML tags in the RmiProxy section of the file.

4. Depending on whether you use SSL or insecure communication between application server and
execution server, proceed as follows:

SSL communication Set the value of InsecurePort to 0.

Insecure communication Set the value of SSLPort to 0.

5. Save and close the XML file.

6. Restart the execution server.

Disabling Unused Ports on Front-End Servers
To disable the unused Tomcat port:

1. Stop the front-end server.

2. Open the server.xml file with a text editor.

This file is located in the /conf/frontendserver/conf folder of the SilkCentral directory on the
front-end server.

3. Change the port setting in the first line of the file from <Server port="19132"
shutdown="SHUTDOWN"> to <Server port="0" shutdown="SHUTDOWN">.

4. Save and close the XML file.

5. Re-start the front-end server.
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Setting Maximum Number of MRU Reports
To set the maximum number of MRU reports that displays in the Last Used Reports list box:

1. Open the SccFrontendBootconf.xml file with a text editor.

This file is located in the /conf/frontendserver folder of your SilkCentral installation.

2. Locate the <MRUListSize> tag in the <Report> section of the file.

The default value for this tag is 10.

3. Set the value to the maximum number of reports that you want to have displayed in the Last Used
Reports list box.

4. Save and close the XML file.

Memory Settings for SilkCentral Servers
This section describes how you can change the memory settings of the SilkCentral servers when out-of-
memory errors occour.

The Java heap size of the SilkCentral front-end and application servers is set by default to 512 MB. If you
are experiencing out-of-memory errors, for example while copying a project in Test Manager, try to
increase the heap size on the front-end or application server to 1024 MB or more.

The following error is an indicator that the Java heap size is to small: java.lang.RuntimeException:
java.lang.OutOfMemoryError: Java heap space at
com.segue.scc.webgui.module.console.ProjectsUnit
$CopyProjectThread.run(ProjectsUnit.java:1473) Caused by:
java.lang.OutOfMemoryError: Java heap space. This error is reported in the logfile of the front-
end server or the application server. Another indicator is the error message The system is now
working close to capacity. For security reasons no more users will be
permitted to login, which displays when you try to login to Test Manager.

Increasing the Java Heap Size on a SilkCentral Server
Increase the Java heap size on a SilkCentral server when you receive out-of-memory errors.

To increase the Java heap size on a front-end or application server:

1. Stop all SilkCentral services.

2. Click Start > Run.

3. In the Run dialog box, type regedit into the Open text box.

4. Click OK. The Register Editor opens.

5. In the menu tree, choose one of the following locations, depending on your operating system and the
server type:

Operating System and Server Location

32bit and front-end server HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software
Foundation\Procrun 2.0\SCCFrontendServer\Parameters\Java

32bit and application server HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software
Foundation\Procrun 2.0\SCCAppServer\Parameters\Java
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Operating System and Server Location

64bit and front-end server HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache
Software Foundation\Procrun 2.0\SCCFrontendServer\Parameters
\Java

64bit and application server HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache
Software Foundation\Procrun 2.0\SCCAppServer\Parameters\Java

6. Double-click JvmMx. The Edit DWORD Value dialog box opens.

7. In the Value data text box, type 1024.

Note: The value of the Java heap size cannot exceed the available physical RAM on the front-end
server machine and enough memory should be left available for other necessary processes. For
example, if 2GB of RAM are available, you can increase the Java heap size to a value of 1.5GB,
which corresponds to a value of 1536 in the Value data text box, depending on what other
processes are running.

8. In the Base section of the dialog box, click the Decimal option button.

Important: If you leave the Base on the default value, Hexadecimal, you may experience
memory overflows.

9. Restart all SilkCentral services.

Configuring Advanced Settings | 117



Index
A

accessing
audit log 75
repositories 14, 25

accessing CVS repositories
creating PuTTY profiles 108
using PuTTY 108

accounts
system administrator 29

activating
builds 84
components 85
execution servers 63
individual values 93
platforms 86
products 88, 91
project baselines 52
projects 52
schedules 96
value lists 93

adding
builds 83
chart servers 30
components 85
group accounts 50
LDAP servers 33
locations 58
platforms 86
products 88
projects 52
schedules 95
user roles 41
value lists 92
versions 91

adjusting
cookie duration 100

Administrator
user roles 40

advanced settings
configuring 100

agent computers
overview 8

Analyst
user roles 40

analyzing
server log files 76

application configuration
overview 40

application server
location 12, 23
specifying location 12, 23

application server log
page 79

application servers
configuring 10
configuring secure connections with IIS 10, 19
overview 8

architecture
overview 8

audit log
accessing 75
features 74
overview 74
page 75
viewing 75

B

baselines
creating for project 56
projects 56

BIRT
adapting report templates 71
configuring 69
data source settings 70
establishing database access 70
installing 69

browser-driven testing
execution server configuration 103

builds
activating 84
adding 83
deactivating 84
deleting 84
editing 83
managing 83
sorting list 84
tagging 84

C

caching
JMX measures in tests 110

changing
SuperUser password 30
system administrator account password 30

chart servers
adding 30
editing 31
locations 30
overview 8
page 31

components
activating 85
adding 85
deactivating 85
deleting 86
editing 85
managing 84
sorting list 85

configuring
advanced settings 100
application servers 10
BIRT 69
JMX settings 113

118 | Index



LQM report updater interval 112
LQM reporting updater 111
non-standard SSL ports for execution servers 64
remeber login option 100
schedules 95
system 19
Test Manager location 114
virtual execution servers on Lab Manager 67

configuring secure connections
Tomcat 21

cookie duration
adjusting 100

copy project
dialog box 54

copying
project baselines 53
projects 53
user roles 42

creating
execution-server keywords 62
project baselines 56
repositories 13, 24

creating PuTTY profiles
accessing CVS repositories 108

custom reports
BIRT 68
software prerequisites 68

customizing
date and time formats 106

CVS repositories
accessing with PuTTY 108

D

data caching
tests 109

database servers
overview 8

database settings
page 16, 27

databases
BIRT report templates 70

date and time
user-defined settings 105

date formats
customizing 106

deactivating
builds 84
components 85
execution servers 63
individual values 93
platforms 86
products 88, 91
project baselines 52
projects 52
schedules 96
value lists 93

definite runs
scheduling 97

deleting
builds 84
components 86

execution servers 63
group accounts 50
individual values 94
LDAP servers 34
locations 59
platforms 87
products 89
project baselines 53
projects 53
report templates 73
schedules 96
server log files 77
value lists 93
versions 91

disabling
caching of host name resolutions 114
HTML response compression 107
unused ports on execution servers 115
unused ports on front-end servers 115

disconnecting
repositories 16, 26

displaying
host name on Web browsers 107

downloading
report templates 72
server log files 76

E

edit execution server
dialog box 64

Edit LDAP Server
dialog box 34

editing
builds 83
chart servers 31
components 85
individual values 92
LDAP servers 33
locations 58
platform 86
products 88
project baselines 52
projects 52
report permissions 72
schedules 95
user roles 41
value lists 92
versions 91

email notification
page 37

enabling
HTML response compression 107

exclusions
schedules 96

execution duration
suspicious 104

execution server
using 101

execution server log
page 80

execution servers

Index | 119



activating 63
assigning keywords 62
configuring non-standard SSL ports 64
configuring physical 61
creating keywords 62
deactivating 63
deleting 63
disabling unused ports 115
hardware provisioning 60
host name resolution 114
keywords 60
overview 8
setting up 60
starting as Windows process 103

F

file pool
managing 97
page 98
uploading files from browser 98

formats
date and time 105

front-end server log
page 78

front-end servers
disabling unused ports 115
overview 8

G

group accounts
adding 50
creating 50
deleting 50
editing 50
maintaining 50

group settings
page 51

GUI-level testing
execution server configuration 103

H

hiding
host name on Web browsers 107

host name
displaying on Web browsers 107
hiding on Web browsers 107

host name display
Web browsers 107

host name resolution
disabling caching 114

HTML response compression
disabling 107
enabling 107
gzip 107

I

increasing

server Java heap sizes 116
installing

BIRT 69
integrating

task management tools 82
VersionOne 82

J

Java heap sizes
increasing 116

JMX measures
LQM reporting updater 111
monitoring LQM reporting updater 112

JMX settings
configuring 113

K

keywords
assigning to execution servers 62
execution servers 60

L

LDAP
authentication 32
integration 32

LDAP authentication
logic 32
mixed mode 32
standard mode 32

LDAP servers
adding 33
deleting 34
editing 33
page 34
testing connection 34

list of values
configuration page 94

load test agent cluster files
editing 36

load test agent clusters
page 37
removing 36
SilkPerformer 35
uploading 36

load test agent clusters file
adding 36
changing 36
deleting 36

locations
adding 58
deleting 59
editing 58
managing 58

log files
level of detail 77
managing 77
servers 76

logging in

120 | Index



first-time 29
login

configuring remember login option 100
cookie duration 100
enhanced options 100
first-time 28
page 29
remember login 100

login options
adjusting cookie duration 100
configuring remember login option 100
enhanced 100

LQM report updater
configuring interval 112

LQM reporting updater
configuring 111
JMX measures 111

M

mail host
location 37

mail host location
specifying 37

maintaining
value lists 92

managing
builds 83
components 84
file pool 97
locations 58
platforms 86
products 88
products and platforms 83
projects 51
report templates 68
versions 91

Manual Testing Client
overview 8

memory settings
servers 116

Microsoft SQL Server 2005
enabling TCP/IP protocol 15, 26

MRU reports
setting maximum number 116

N

new execution server
dialog box 64

New LDAP Server
dialog box 34

new location
dialog box 59

O

overview
page 19
product 8

overview page

using 19

P

permissions
administration 45
executions 43
issues 44
libraries 43, 44
log files 45
manual execution planning 44
project settings 45
projects 45
quality goals 45
reports 45
requirements 43
tests 43

platform configuration
page 87

platforms
activating 86
adding 86
deactivating 86
deleting 87
editing 86
managing 86
sorting list 87

ports
disabling unused on execution servers 115
disabling unused on front-end servers 115

product
overview 8

products
activating 88, 91
adding 88
configuration page 89
deactivating 88, 91
deleting 89
editing 88
managing 88
sorting list 88

project baselines
activating 52
copying 53
creating 56
deactivating 52
deleting 53
editing 52
overview 56

Project Manager
user roles 40

project settings
page 55

projects
activating 52
adding 52
copying 53
deactivating 52
deleting 53
editing 52
managing 51
templates 57

Index | 121



R

report templates
deleting 73
downloading 72
editing permissions 72
establishing database access 70
managing 68
page 74
setting permissions 72
updating sources 73
uploading 72

Reporter
user roles 40

repositories
accessing 14, 25
ALM URIs 15, 25
creating 13, 24
disconnecting 16, 26
IDs 14, 25
overview 13, 23

response compression
HTML 107

roles settings
page 42

S

schedules
activating 96
adding 95
configuration page 97
configuring 95
deactivating 96
deleting 96
editing 95
scheduling definite runs 97
scheduling exclusions 96

scheduling
definite runs 97
schedule exclusions 96

secure Web server connections
configuring with Tomcat 21

server log files
analyzing 76
changing level of detail 78
deleting 77
downloading 76
level of detail 77
managing 77

servers
increasing Java heap sizes 116
log files 76
memory settings 116

service manager
running services at system start 102
starting all services 102
starting execution server as Windows process 103
starting individual services 102
stopping all services 102
stopping individual services 102
using 101

viewing log files 104
services

overview 101
setting

report permissions 72
suspicious execution duration 104

setting maximum number
MRU reports 116

SilkCentral
access 10
licensing 10

SilkCentral Administration Module
welcome 7

SilkCentral Issue Manager
overview 10

SilkMeter license server
overview 8

SilkPerformer
load test agent clusters 35

sorting
builds 84
components 85
platforms 87
products 88
values in value lists 93
versions 91

SSL
applying certificate to IIS 11, 21
applying for a certificate 10, 19
configuring secure connections with IIS 10, 19
creating a certificate 11, 20
secure Web server connections 19

starting all services
service manager 102

starting individual services
service manager 102

stopping all services
service manager 102

stopping individual services
service manager 102

SuperUser
user roles 40

SuperUser password
changing 30

suspicious execution duration
setting 104

system administrator
accounts 29
changing password 30

system configuration
overview 19

system proxies
configuring 38
overview 38

system proxy
page 38

T

tagging
builds 84

task management tools

122 | Index



integrating 82
Test Manager

user roles 40
welcome 9

Test Manager location
configuring in Issue Manager 114

Tester
user roles 40

testing
connection to LDAP servers 34

tests
data caching 109
JMX measures for caching 110

time formats
customizing 106

time zones
overview 99

Tomcat
configuring secure Web server connections 21

U
updating

report template sources 73
uploading

report templates 72
uploading files

browser 98
user accounts

adding 47
assigning groups 47
assigning roles 47
deleting 48
editing 47
maintaining 46

user and group accounts
overview 46

user roles
adding 41
copying 42
deleting 42
description 40
editing 41
permissions 43

user roles and permissions
overview 40

user settings
page 48

using
execution server 101

overview page 19
service manager 101

V

value lists
activating 93
adding 92
deactivating 93
deleting 93
editing 92
maintaining 92
overview 92
sorting values 93

values
activating 93
deactivating 93
deleting 94
editing 92

VersionOne
integrating 82

versions
adding 91
deleting 91
editing 91
managing 91
sorting list 91

viewing
audit log 75

viewing log files
service manager 104

virtual configurations
Lab Manager 66

VMware Lab Manager
configuring access 66
configuring virtual execution servers 67
overview 66
virtual configurations 66

VMware Lab Manager Servers
page 67

W

Web browsers
displaying host name 107
hiding host name 107
host name display 107

Web server connections
SSL 19

Index | 123


	Contents
	SilkCentral Administration Module 12.0
	Getting Started
	SilkCentral Architecture
	SilkCentral Test Manager 12.0
	SilkCentral Issue Manager
	Access and Licensing
	Configuring the Application Server
	Configuring Secure Connections with Microsoft IIS
	Applying for a Certificate to use SSL
	Creating a New Certificate to Use SSL
	Applying the Certificate to IIS

	Application Server Location
	Specifying a Location for the Application Server


	SilkCentral Repositories
	Creating a New Repository
	Accessing an Existing Repository
	Repository IDs
	ALM URIs
	Enabling the TCP/IP Protocol for Microsoft SQL Server 2005
	Disconnecting from a SilkCentral Repository
	Database Settings Page


	Configuring the System
	Using the Overview Page
	Overview Page

	Secure Web Server Connections with SSL
	Configuring Secure Connections with Microsoft IIS
	Applying for a Certificate to use SSL
	Creating a New Certificate to Use SSL
	Applying the Certificate to IIS

	Configuring Secure Connections with Tomcat Web Server

	Application Server Location
	Specifying a Location for the Application Server

	SilkCentral Repositories
	Creating a New Repository
	Accessing an Existing Repository
	Repository IDs
	ALM URIs
	Enabling the TCP/IP Protocol for Microsoft SQL Server 2005
	Disconnecting from a SilkCentral Repository
	Database Settings Page

	Initial Login
	Logging in for the First Time
	Login Page

	System Administrator Accounts
	Changing the Password of the System Administrator Account

	Chart Server Location
	Adding Chart Servers
	Editing Chart Servers
	Removing Chart Servers
	Chart Servers Page

	LDAP Authentication
	SilkCentral LDAP integration
	LDAP Authentication Logic
	Adding LDAP Servers
	Editing LDAP Servers
	Testing LDAP Servers
	Deleting LDAP Servers
	LDAP Servers Page
	New LDAP Server Dialog Box

	SilkPerformer Load-Test Agent Clusters
	Uploading Load Test Agent Cluster Files
	Deleting Load Test Agent Clusters Files
	Editing Load Test Agent Cluster Files
	Load Test Agent Clusters Page

	Mail Host Location
	Specifying a Location for the Mail Host
	Notification Page

	System Proxies
	Configuring a System Proxy
	System Proxy Page


	Configuring the Application
	User Roles and Permissions
	User Roles
	Adding User Roles
	Editing User Roles
	Copying User Roles
	Deleting User Roles
	Roles Settings Page

	Permission Definitions
	Requirements Permissions
	Libraries Permissions
	Tests and Executions Permissions
	Manual Execution Planning Permissions
	Issues Permissions
	Quality Goals Permissions
	Reports Permissions
	Projects Permissions
	Project Settings Permissions
	Administration Permissions
	Dashboard Panel Permissions


	User and Group Accounts
	Maintaining User Accounts
	Adding User Accounts
	Editing User Accounts
	Deleting User Accounts
	User Settings Page

	Maintaining Group Accounts
	Adding Group Accounts
	Editing Group Accounts
	Deleting Group Accounts
	Group Settings Page


	Managing Projects
	Adding Projects
	Editing Projects and Project Baselines
	Activating or Deactivating Projects and Project Baselines
	Copying Projects or Project Baselines
	Deleting Projects and Project Baselines
	Copy Project Dialog Box
	Project Settings Page

	Project Baselines
	Creating a Baseline for a Project

	Project Templates
	Managing Locations
	Adding Locations
	Editing Locations
	Deleting Locations
	New Location Dialog Box

	Setting Up Execution Servers
	Hardware Provisioning with Keywords
	Configuring Physical Execution Servers
	Creating New Execution-Server Keywords
	Assigning Keywords to an Execution Server
	Activating or Deactivating Execution Servers
	Deleting Execution Servers
	Configuring a Non-Standard SSL Port for Execution Servers
	New/Edit Execution Server Dialog Box

	Working with VMware Lab Manager
	Lab Manager Virtual Configurations
	Configuring Access to Lab Manager Servers
	Configuring Virtual Execution Servers on Lab Manager
	VMware Lab Manager Servers Page

	Managing Report Templates
	Managing Custom Report Templates with BIRT
	Installing BIRT from SilkCentral
	Configuring BIRT for SilkCentral
	Establishing Database Access For a New Report Template
	BIRT Data Source Settings

	Adapting Existing Report Templates
	Setting and Editing Report Permissions and Associations
	Downloading Report Templates
	Uploading Report Templates
	Updating Report Sources
	Deleting Report Templates
	Report Templates Page

	Audit Log
	Accessing and Viewing the Audit Log
	Audit Log Page

	Server Log Files
	Downloading Server Log Files
	Analyzing Server Log Files
	Deleting Server Log Files
	Log File Management
	Changing Log Levels of the SilkCentral Servers

	Front-End Server Log Page
	Application Server Log Page
	Execution Server Log Page

	Integrating Task Management Tools
	Integrating VersionOne in Test Manager

	Managing Products and Platforms
	Managing Builds
	Adding Builds
	Editing Builds
	Activating and Deactivating Builds
	Sorting the Builds List
	Tagging Builds
	Deleting Builds

	Managing Components
	Adding Components
	Editing Components
	Activating and Deactivating Components
	Sorting the Components List
	Deleting Components

	Managing Platforms
	Adding Platforms
	Editing Platforms
	Activating and Deactivating Platforms
	Sorting the Platforms List
	Deleting Platforms
	Platform Configuration Page

	Managing Products
	Adding Products
	Editing Products
	Activating and Deactivating Products
	Sorting the Products List
	Deleting Products
	Product Configuration Page

	Managing Versions
	Adding Versions
	Editing Versions
	Activating and Deactivating Products
	Sorting the Versions List
	Deleting Versions


	Maintaining Value Lists
	Adding Value Lists
	Editing Value Lists
	Editing Individual Values
	Activating and Deactivating Value Lists
	Activating and Deactivating Individual Values
	Sorting Values within Value Lists
	Deleting Value Lists
	Deleting Individual Values
	List of Values Configuration Page

	Configuring Global Schedules
	Adding Global Schedules
	Editing Global Schedules
	Activating and Deactivating Global Schedules
	Deleting Global Schedules
	Scheduling Exclusions
	Scheduling Definite Runs
	Schedules Configuration Page

	Managing the File Pool
	Uploading Files from a Browser
	File Pool Page

	Time Zones

	Configuring Advanced Settings
	Login Options
	Configuring the Remember Login Option
	Adjusting the Cookie Duration

	Using the SilkCentral Service Manager
	SilkCentral Services
	SilkCentral Execution Server
	Managing Which SilkCentral Services Shall Be Running At System Start
	Starting or Stopping All SilkCentral Services
	Starting or Stopping Individual SilkCentral Services
	Starting The SilkCentral Execution Server As Windows Process
	Viewing Log Files from the SilkCentral Service Manager Console

	Suspicious Execution Duration
	Setting the Suspicious Execution Duration

	Disable Updating of External Issue Statistics
	Date and Time Formats
	Customizing Date and Time Formats

	HTML Response Compression
	Enabling or Disabling HTML Response Compression

	Host Name Display
	Displaying or Hiding the Host Name in the Title Bar of Your Web Browser

	CVS Repository Access using Ext Method (using PuTTY)
	Accessing a CVS Repository using Ext Method (using PuTTY)

	Data Caching in Tests
	JMX Measures for Caching in Tests

	JMX Measures for LQM Reporting Updater
	Configuring the LQM Reporting Updater
	Configuring the Report Update Interval
	JMX Measures for Monitoring the LQM Reporting Updater

	Configuring JMX Settings
	Execution Server Host Name Resolution
	Disabling The Caching of Host Name Resolutions

	Configuring the Test Manager Location in Issue Manager
	Disabling Unused Ports on Execution Servers
	Disabling Unused Ports on Front-End Servers
	Setting Maximum Number of MRU Reports
	Memory Settings for SilkCentral Servers
	Increasing the Java Heap Size on a SilkCentral Server



