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Manual Testing Client

The Manual Testing Client is an Eclipse-based client tool that provides the full functionality you need to
efficiently execute manual tests. The client enables testers to manage their tests, edit tests, and track
results without the need of an Internet connection.

() Tip: If many users work on manual tests in parallel, we recommend to use the Manual Testing Client,
g an Eclipse-based client tool, to execute the manual tests.

[y Note: The Manual Testing Client supports running test executions with code analysis information. If a

test execution is already enabled to gather code analysis information within Test Manager, the
settings are automatically available in the Manual Testing Client. Code analysis can also be enabled
for execution plans from within the Manual Testing Client.

Tour of the Manual Testing Client Ul

Note: Eclipse does not initialize views until they are activated for the first time, so certain tabs within
the Manual Testing Client will not display their contents until they are selected. For example, the
Attachments page will not display the number of attachments it tracks until it is selected.

The following image displays the eight main areas of the Ul of the Manual Testing Client.

B SilkCentral Manual Testing Client - admin

[ inbox, 13| 7] Conpleted Rurs

[ [ stotus. [ Priocty | tarted it - [ Project

EH Essentisls_Win2x. 4396 O Not Executed Low Wed, Nov 12, 2008 3:02:09 PM Demo Project

] Expoute Monusl 43 @ Passed Low Mon, Oct 27, 2008 2:13:53FM Tukorial

3 Unassigned Tests 432 O MotEweoed  Low Mon, Oct 20, 2008 12:54:03PM  Tukorial

< I 2

@, Tost Defirkions 53 | ]| @

& | Hame | seatus | Last Status | steps | [Used Tme | Test

4l | 2l |
‘mmmjﬂmﬂn'&mm: | DD:LZD'W'*""E-‘ =0o]

Is500 0 | Synopss (2ot [Eternalio [ crestedon [crestedey |

-]
3pchages i nbor, | packages resdy or upload 2 [orinn |
® Menu Bar @ Workflow Bar @ Inbox/Completed Runs @ Test Definitions
Attachments/Result

®) Files/lssues (8) outine (7) vescription Status Bar

Menu Bar

The menu bar provides editing options for tests and views. You can use the menu bar to edit user,
appearance, or test settings, to navigate between execution packages, or to access Help. The following list
displays the available menus:
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Menu Description

File Provides the same functionality as the workflow bar and additional functionality for package
import and export, changing users, switching the Manual Testing Client between online and
offline mode, and storing executed package results to Test Manager.

Edit The edit menu includes the following items:
Item Description
Set as <Status> Set the execution status of the execution package or test to the
selected status.
Add Result File... Add a result file to an execution package or test.
Edit Build Number...  Select the build number for an execution package.

Edit Code Analysis Specify hostnames to include in code coverage runs for an
Settings... execution package. The hostnames must be separated by commas.
For example: labmachinel, 192.168.0.1:19129.

Delete Delete an execution package. You can delete only execution
packages with completed runs.

Go Navigate between the available execution packages and tests.

Window Egit the view and the preferences of the Manual Testing Client. The menu includes the
following items:

Iltem Description
Show View Activate and deactivate the available views in Manual Testing Client's
Workspace.
Reset Perspective... Reset the current Manual Testing Client perspective to the default
state.
Preferences... Set the preferences for the Manual Testing Client.
Help Access the documentation and About page of the Manual Testing Client.

Workflow Bar

The workflow bar gives you quick access to the basic functions you can perform with the Manual Testing
Client. The following buttons are available in the workflow bar:

Button Description

Download Download the execution packages from Test Manager.
Execute Execute a test in the Manual Testing Client.

Finish Stop the execution of a test before the test is fully executed.
Upload Upload the execution packages to Test Manager.

o

Inbox

The Inbox lists all execution packages that have been downloaded to the Manual Testing Client for manual
execution. Multiple execution packages can be selected within the Inbox window using standard Windows
keyboard shortcuts. The Inbox includes the following properties for the selected test:
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Property
Package Name
ID

Status

Priority
Keywords
Started At
Project

Version

Build

Description
Name of the execution package that has been downloaded from Test Manager.
Execution package number that has been generated for this execution package.

Status of the execution package. Status values cannot be edited on the Completed
Runs page. The available values are Not Executed, Passed, Failed,
Unresolved, and Unsupported. Execution package status values cannot be edited.
The overall package status is determined by the composition of the test statuses, and
by extension the statuses of the test steps, that are contained within a package. For
example, overall package status remains Not Executed as long as a test step of one
of the contained tests has a status of Fai led. So, even if some of a test's steps have
passed, the overall status of the package will remain Not Executed until the package
is finished and all not executed tests are assigned a status on the Finish Run dialog
box. The overall status will be considered Passed when one or more test steps or tests
in a package are Passed and all not executed steps and tests are resolved through the
Finish Run dialog box.

Priority of the execution package.
All keywords that are assigned to the execution package.
When testing of the execution package began.

Name of the Test Manager project from which the execution package was derived.
Product version from which the execution package was derived.

Product build from which the execution package was derived.

Execution Path Fjle path where this execution plan resides in Test Manager's Execution Plans tree.

Completed Runs

The Completed Runs page lists all execution packages for which testing is complete. The Completed
Runs page includes the following properties for the selected execution package:

Property

Package Name
ID
Status

Manual Testing Client

Description

This column offers a status icon that indicates the upload status of corresponding
execution packages. A red arrow icon indicates that a package's results have not yet
been uploaded. A checkmark icon over a faint arrow icon indicates that a package's
results have already been uploaded to the server. Double-click this icon to open the
Execute Test dialog for the first test of this execution package.

Name of the execution package that has been downloaded from Test Manager.
Execution package number that has been generated for this execution package.

Status of the execution package. Status values cannot be edited on the Completed
Runs page. The available values are Not Executed, Passed, Fai led,
Unresolved, and Unsupported. Execution package status values cannot be edited.
The overall package status is determined by the composition of the test statuses, and
by extension the statuses of the test steps, that are contained within a package. For
example, overall package status remains Not Executed as long as a test step of one
of the contained tests has a status of Fai led. So, even if some of a test's steps have
passed, the overall status of the package will remain Not Executed until the package
is finished and all not executed tests are assigned a status on the Finish Run dialog
box. The overall status will be considered Passed when one or more test steps or tests



Property Description

in a package are Passed and all not executed steps and tests are resolved through the
Finish Run dialog box.

Priority Priority of the execution package.

Keywords All keywords that are assigned to the execution package.

Started At When testing of the execution package began.

Finished At When testing of the execution package ended.

Project Name of the Test Manager project from which the execution package was derived.
Version Product version from which the execution package was derived.

Build Product build from which the execution package was derived.

Execution Path Fijle path where this execution plan resides in Test Manager's Execution Plans tree.

Tests

The Tests page includes all information related to the manual test that is selected above in the Inbox or
Completed Runs page.

Multiple tests can be selected within the Tests window using standard Windows keyboard shortcuts. To
apply a status change to selected tests, right-click the selection and select a new status value from the
context menu.

The Tests page includes the following properties for each test:

Property Description

# Number that has been automatically generated for the test.

Name The test name.

Status Status of the test. The available values are Not Executed, Passed, Failed,

Unresolved, and Unsupported. This value can be changed by right-clicking the
current value and selecting an alternative value from the context menu.

Last Status  Status that this test held before the current status.
Steps Number of steps in the selected manual test.
Planned Time Estimated time for completion of the test in [hh:mm:ss].

Used Time This field tracks the elapsed time in [hh-mm:ss] since the start of the test execution.
This field can be manually edited. The timer will stop during editing. After editing this field
the timer will continue tracking time from the manually adjusted time.

Test Path File path where this test resides in Test Manager's Tests tree.

Attachments

The Attachments page lists any attachments related to the selected manual test. This page is also
available on the Execute Test dialog box.

When you have selected a test in the Tests window, you have the option of supplementing the list of
displayed attachments by selecting an Include attachments of value. Select Test Container/Folders to
include all attachments from the selected test's test container or folder. Or select Test Steps to include
attachments from the test steps of the test.

The Attachments page includes the following properties for each attachment:

Manual Testing Client | 7



Property Description

Name Name of the attachment.

Type Attachment file type.

Description Description that has been created for the attachment, if any.

Source File path where this attachment's test resides in Test Manager's Tests tree.

Image Preview If the attachment is an image, you can use the Image Preview controls to view the
attachment. Right-click the image, or click the buttons to the right of the window, to
access the following commands: Show Actual Size, Scale to Fit, and Scale to Fit —
Keep Aspect Ratio. Click Open as Detached Window to open Image Preview in a
separate window.

Result Files

The Result Files page lists any result files that are related to the selected manual test. This page is also
available on the Execute Test dialog box. The Result Files page includes the following properties for each

result file:

Property Description

Name Name of the result file.

Source File path where this result file's test resides in Test Manager's Tests tree.
Add File Click to browse to and select a new result file for upload to this test.

Paste Image  Click to paste an image from your computer's clipboard and attach the image to this test.

Remove Click to remove the selected result file attachment from this test.

Image Preview |f the result file is an image, you can use the Image Preview controls to view the result
file. Right-click the image, or use the buttons to the right of the window, to access the
following commands: Show Actual Size, Scale to Fit, and Scale to Fit — Keep
Aspect Ratio. Click Open as Detached Window to open Image Preview in a separate
window.

Issues

The Issues page lists any issues related to the selected manual test. This page is also available on the
Execute Test dialog box. The Issues page includes the following properties of each issue:

Issue ID ID that has been assigned to this issue.
Synopsis  Synopsis that has been written for this issue.
Status Status of the issue.

External ID Indicates if the issue is tracked by an external issue tracking system. If this issue is tracked
by an external issue tracking system, and that issue has been assigned an ID, you can click
the external ID number in this field to link directly to the issue in the external issue tracking
system.

Created On When the issue was created.

Created By User who created the issue.
Outline

Shows the content tree of the selected execution package or the location of the selected test in the
execution package.
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Description

Shows the description of the selected execution package or test.

Status Bar
Shows the current amount and status of the execution packages and tests in the currently active view.
Button Description

Online/Offline  Click to switch Manual Testing Client's mode from online to offline and back.

Installing Manual Testing Client

The Manual Testing Client is a separate executable from Test Manager. Using Java Web Start technology,
the Manual Testing Client can be deployed with a single click over the network. Java Web Start ensures
the most current version of Manual Testing Client is deployed, as well as the correct version of the Java
Runtime Environment (JRE).

Prerequisite: Java Runtime Environment (JRE) version 6 or higher must be installed on your computer to
use Manual Testing Client with Java Web Start technology. You can download JRE from http://
java.sun.com/javase/downloads/index.jsp.

Alternately you can install Manual Testing Client on your computer by navigating to Help > Tools >
Manual Testing Client .

) Tip: To start the Manual Testing Client, navigate to Start > Programs > Silk > SilkCentral > Test
~ Manager 12.0 > Manual Testing Client .

To install and start Manual Testing Client:

1. When clicking a link to the Manual Testing Client Web Start URL, http://<Test Manager
host>:<port>/webstart/mtc/), for example in a manual testing notification email, a File
Download dialog box opens.

2. Click Open.

If Manual Testing Client is not installed on your computer, the Java Web Start dialog box opens and
immediately starts downloading Manual Testing Client. The download can take up to several minutes. If
Manual Testing Client is already installed on your computer, Manual Testing Client opens and the
following steps are not applicable.

When the download has completed, a Warning — Security dialog box opens, asking you if you want to
run the digitally signed application.

3. Check the Always trust content from this publisher check box, then click Run. The Manual Testing
Client opens.

Uninstalling Manual Testing Client

To uninstall the Manual Testing Client:

1. Open a command line window.

2. In the Windows command line window, type javaws —viewer and press Enter. The Java Cache
Viewer opens.

3. In the Show list box, select Applications, if not already selected.

4. The table should now list Manual Testing Client — Web Start. Select this application and click the
delete button (X) on the toolbar.

5. Manual Testing Client is now removed from your computer and you can close the Java Cache Viewer
and Java Control Panel dialog boxes.
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Tests in the Manual Testing Client

While in Edit mode, the Manual Testing Client offers a full range of test-editing functionality, including the
addition, reordering, and removal of test steps and the insertion of step properties. You can edit manual
test properties in both online and offline modes. You can synchronize changes made in offline mode with
the server whenever an Internet connection is available.

Edit mode enables editing of all test elements that can be edited through the Test Manager Web client. On
the Details page this includes the following values:

¢ Planned Time

e Step Names

e Step Property Values
* Step Description

* Expected Result

On the Description page the Test Description field can be edited, including the insertion of step property
parameters.

In Edit mode, multiple test steps can be selected within the Tests window using standard Windows
keyboard shortcuts. To apply a status change to selected test steps, right-click the selection and select a
new status value.

In normal mode, you can only enter test results into the Result column and edit the status of tests and
individual test steps. Statuses are changed by right-clicking status values and selecting an alternative
status value.

i Note: Editing of data-driven tests is not supported.

Parameters

Step property parameters can be inserted into test and test step descriptions. Parameters can be inserted
into the Test Description, Step Description, and Expected Result fields. In normal mode, parameter
values are resolved (their parsed values are displayed in place of the parameters themselves). In Edit
mode parameters are not resolved; the parameters themselves are displayed. When in Edit mode, using
the Parameters list box on the Description tab toolbar, you can select pre-configured Test Manager
parameters for insertion.

Change Conflict Handling

With the Manual Testing Client's offline editing functionality it's possible for multiple users to edit the same
test at the same time. Test Manager automatically merges all uploaded changes into the Tests tree unless
change conflicts arise, for example if two users simultaneously edit the same manual test step. If your
uploaded changes conflict with recent changes made by another user, upon upload, you will be presented
with the Test Conflicts dialog box so that you can manage the conflict.

Using the Test Conflicts dialog box you can specify if your changes should be saved as a part of the test
and included in future runs of the test, or if they should be ignored. If you opt to have your changes
ignored, they will still remain a part of the test results from the test run in which they were included.

Inserting Test Manager Parameters into Description Text
Boxes

To insert a Test Manager parameter into a description text box:
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1. Inthe Manual Testing Client, in Edit mode, navigate to Execute Test > Description or Execute Test >
Details .

You can insert any pre-configured Test Manager parameter into the Test Description, Step
Description, and Expected Result text boxes.

2. Place your cursor into the text box.
3. Click Parameters on the toolbar.
4. Select a pre-configured Test Manager parameter from the list box.

Configuring the Manual Testing Client

This section explains how to configure the Manual Testing Client.

Configuring Connection Parameters

Connection parameters are configured automatically the first time you start the Manual Testing Client.

To edit login credentials and validate your connection:

1. In the Manual Testing Client, navigate to Window > Preferences . The Preference Settings dialog box
opens.

2. Type the URL of your Test Manager installation in the Test Manager server URL text box.

Select Remember Credentials if you want the Manual Testing Client to insert your login credentials
automatically the next time you start the application.

Enter your Test Manager Username and Password.
Click Validate Connection to test your login settings.
Click OK on the confirmation dialog box.

Click OK to save your settings.

w

N o o s

Configuring Other Settings

To configure other settings:

1. Inthe Manual Testing Client, navigate to Window > Preferences . The Preference Settings dialog box
opens.

2. In the Other settings section, check or uncheck one or more of the following check boxes:
Download attachments  Download attached files automatically when execution plan packages are

automatically downloaded from Test Manager. This option must be enabled if you intend
to work offline after you download your assigned execution packages.

Ask for build number Before uploading packages to Test Manager, display a prompt requesting
when completing the build number on which the test was performed.
packages

Show execution dialog  Have the Execute Test dialog box display on top of other open windows

always on top on your computer desktop to facilitate manual testing. When enabled, the
Execute Test dialog box stays on top even when another window has the
focus. When executing manual tests, you may want to keep the Execute
Test dialog box on top so that you can easily enter your test results. If
your computer monitor is too small to contain both the Execute Test
dialog box and the application under test, you should leave this setting
unchecked.

Manual Testing Client | 11
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Ask for uploading Display a confirmation prompt before closing the Manual Testing Client.
workspace to

SilkCentral Test

Manager before closing

main window

3. Click OK to save your preference settings.

Configuring Package Upload Preferences
To configure execution-package upload preferences:

1. In the Manual Testing Client, navigate to Window > Preferences . The Preference Settings dialog box
opens.

2. In the Packages area of the dialog box, check the Remove uploaded packages check box to define
an option for automatic deletion of execution plan packages from the Manual Testing Client after
packages are uploaded to Test Manager.

3. Click one of the following deletion option buttons:
* Immediately
« After <x> days. Type a value in the days text box if you select this option.

4. Check the Upload completed packages immediately check box if you want to have completed test
run packages uploaded to Test Manager automatically after test runs are completed.

Managing Attachments with the Manual Testing Client

This section explains how to manage attachments with the Manual Testing Client.

Pasting Screen Captures

To upload a screen-captured image directly from the clipboard:

1. Copy a screen capture to your computer’s clipboard.
The Paste Image button on the Result Files page of the Manual Testing Client becomes enabled.
2. Click Paste Image.
3. Specify a File Name for the image on the Paste From Clipboard dialog box.
4. Click OK to save the copied screen capture as an image file attachment.

Uploading Attachments to the Manual Testing Client

When during the course of testing you encounter a relevant result file, which can be a screen-captured
image, an error log, or another file, you can upload the file as an attachment to a test.

To upload a result file as an attachment:

In the Manual Testing Client, select a test in the Tests page.

Click the Result Files tab.

Click Add File to browse to and select the result file you want to upload.
Click Open to attach the file.

A wnh e
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Viewing Attached Images Within the Manual Testing
Client

To view an attached image file:

1. Inthe Manual Testing Client, select an image file in the Attachments page. The image displays in the
Image Preview field.
2. Use the following viewing tools next to the Image Preview field to manipulate the image:

e Show Actual Size

e Scale to Fit

» Scale to Fit - Keep Aspect Ratio
e Open as Detached Window

Viewing Attachments Within the Manual Testing Client

To view a test attachment from within the Manual Testing Client:

1. Inthe Manual Testing Client, select a test in the Tests page.
2. The Attachments page lists all of the result files that are associated with the selected test.

3. Using the Test Container/Folders and Test Steps check boxes, you can filter the list of attachments to
include only those attachments that are related to the selected test container, test folder, or test step.

Working with Execution Packages

Downloading Execution Packages

After the Manual Testing Client is configured, the first step in running manual tests is downloading copies
of the manual execution plans that are assigned to you.

Note: Execution plans remain online in Test Manager; only copies of the execution plans are
downloaded to the Manual Testing Client.

To download the execution packages that are assigned to you:

1. In the Manual Testing Client, click Download on the toolbar.

2. If your connection settings are correctly configured, and execution plans are started in Test Manager,
the execution packages that are assigned to you display in the Inbox.

Exporting Execution Packages

Downloaded execution packages can be both exported from and imported to the Manual Testing Client.
This allows for easy exchange of execution packages between testers over email. Downloaded
attachments are automatically included in exported packages.

f Note: Execution packages have the .zpkg extension.

To export an execution package:

1. In the Manual Testing Client, right-click an execution package in the Inbox page.

2. Select Export Package.

3. On the Export to dialog box, browse to the location where the package is to be saved and click Save.
4. Click OK on the confirmation dialog box notifying you that the export was successful.
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Importing Execution Packages

Downloaded execution packages can be both exported from and imported to the Manual Testing Client.
This allows for easy exchange of execution packages between testers over email. Downloaded

attachments are automatically included in exported packages.

i Note: Execution packages have the .zpkg extension.

To import an execution package:

1.

In the Manual Testing Client, navigate to File > Import Package .

2. On the Import from dialog box, browse to the package that is to be imported and click Open.

3.

Click OK on the confirmation dialog box notifying you that the import was successful.

Editing Package Build Numbers

To edit the build number of an execution package:

1.
2.
3.

4.

In the Manual Testing Client, right-click an execution package in the Inbox page.
Select Edit Build Number. The Select Build Number dialog box opens.
Select a build number from the Build list box.

f Note: You can refresh the build list by clicking Refresh build list.

Note: If you want to be prompted to specify a build number each time a test run is completed,
check the Ask for build number when completing packages check box.

Click OK.

Uploading Test Results to Test Manager

To upload test results from finished packages:

1.

In the Manual Testing Client, complete a manual test by clicking Finish Run on the Execute Test
dialog box or Finish on the toolbar.

Note: If you attempt to complete testing of a test package while any of the package's tests have a
status of Not Executed, the Finish Run dialog box will display on which you can define how not
executed tests should be handled.

Click the Completed Runs tab.

Right-click a completed test run and select Upload to Test Manager, or select Upload from the File
menu, to upload your test results to Test Manager.

Note: Execution plan statuses are updated automatically in the SilkCentral database when you are
working online.

Managing Change Conflicts upon Upload

To manage change conflicts during upload:

1.
2.

After completing your manual test edits, click Upload to upload your results to the server.

Click Yes to confirm that you want to have your changes committed to the Tests tree on the server. If
your changes conflict with recent changes made by another user, the Test Conflicts dialog box will
display, listing the tests that are in conflict.

To directly access a conflicting test in Test Manager and view the changes, right-click the test and
select Go to Test in Test Manager.
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4. Click Upload Changes to ignore changes made by other users and commit your changes to Test
Manager, thereby overwriting any recent changes that conflict with your changes, or click Revert
Changes to not have your changes saved to the test.

If you opt for Revert Changes, your changes will not be committed to the Tests tree, however your
changes will be visible in the execution results you are uploading. Your changes will not be included in
future runs of the test.

Storing Test Results to Test Manager

To store test results from Manual Testing Client in Test Manager:

1. Inthe Manual Testing Client, select Store Results to SilkCentral from the File menu.

2. Alternatively, when closing Manual Testing Client, you can upload your entire workspace to Test
Manager.

Adding an Internal Issue with the Manual Testing Client

The Manual Testing Client enables you to create an internal issue and map an external issue to this
internal issue. To create the internal issue and map the external issue:

1. In the Manual Testing Client, click the Inbox tab.

2. Select an execution plan package.

The tests included in the selected package are listed in the Tests page.
In the Tests page, double-click a test.

Click New Internal Issue. The New Issue dialog box opens.

Fill out the text boxes.

Click OK.

o 0k w

i Note: You must be online during this procedure.

Enabling Code Analysis Within the Manual Testing Client

To enable code analysis for an execution plan from within the Manual Testing Client:

1. Inthe Manual Testing Client, navigate to Edit > Edit Code Analysis Settings . The Edit Code
Analysis Settings dialog box opens.

2. Check the Enable code analysis for package <Package Name> check box.

Note: After code analysis is enabled, you can execute your tests in the Manual Testing Client.
However, you need to click Code Analysis: Start on the Details page of the Execute Test dialog
box before you actually start testing. This way Test Manager will collect code analysis information
while you execute the manual test. When you are done testing, click Stop to halt the collection of
code analysis information.

3. Select a profile from the Code Analysis Profile list box.

4. In the Hostnames text box, enter a comma-separated list of hostnames, with port, if default port 19129
is not used, from which code analysis information is to be gathered.

For example labmachinel, labmachine2:8000, 198.68.0.1. For each execution plan, you
need to define the host names of the machine resources where the AUT is running. For example, with a
client/server system, you must not only gather code coverage information on the client, which probably
runs directly on an execution server, but also on the server, which likely runs on a different machine.
This applies to all multi-tiered applications.
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i Note: For JUnit code analysis runs, you do not need to specify a hostname.

5. Click OK to save your settings.

Working Offline with the Manual Testing Client

If you plan to work without access to an Internet connection, select offline work mode so that the Manual
Testing Client will not attempt to connect to Test Manager automatically.

To work in offline mode:

1. Inthe Manual Testing Client, select File > Work Offline or click Online in the bottom right corner.

2. Once you have completed your tests and have access to an Internet connection, proceed with
uploading your test results.

Execute Test Dialog Box

When you execute a manual execution plan in the Manual Testing Client, the Execute Test dialog box
displays. This dialog box enables you to execute the test steps that are included in the selected execution
plan, and track the results of the test steps.

The Execute Test dialog box includes the following pages: Description, Details, Attachments, Result
Files, and Issues.

Description

In normal mode, the Description page offers a read-only Test Description text box for the selected test
and the Test Name text box. In edit mode, these text boxes can be edited. Click Open Description in
Separate Window to open the most recently saved version of the test description in a separate window.
The detached window always remains on top to assist in manual testing.

Details
The Details page offers a read-only description of the selected test.

The page includes the following items:

Item Description

Test Status Current status of the test. In edit mode this text box can
be edited.

Last Status Status of the test in the previous test run.

Planned Time Estimated time for completion of the test in hhzmm:ss.

In edit mode this text box can be edited.

Used Time This text box tracks elapsed time in hhzmm:ss since the
beginning of test execution. This text box can be
manually edited. The timer stops during editing. After
editing this text box the timer continues tracking from the
manually adjusted time.

Start Initiates code analysis. Enter the host names for which
you want to run code analysis.

Test Steps Lists the manual test steps the selected test includes.
You can select multiple test steps in the Test Steps
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Item Description

section by using the standard Windows keyboard
shortcuts. To change the status of the selected test steps,
right-click on the steps and choose a new status value.

Result The result of each test step as observed by the tester.
Edit this text box after you have completed this step.

Status Status of each step. Edit this text box after you have
completed this step.

Step Description Describes the action you must perform in this step.
Expected Result The expected result or success condition of each test
step.

Execute Test Toolbars

The Execute Test dialog box includes the following toolbars:

Toolbar Description

Test Steps  Use to manage your manual test steps during a test execution. The toolbar includes the
following items:

Item Description

Add Test Step Add a new test step to the end of the Test
Steps list.

Insert Test Step Insert a new test step above the selected test

step in the Test Steps list.

Duplicate Test Step Create a copy of the selected test step in the
Test Steps list.

Delete Test Step Delete the selected test step from the Test
Steps list.
Move Test Step Up Move the selected test step up one position in

the Test Steps list.

Move Test Step Down Move the selected test step down one position
in the Test Steps list.

Text Use to format the Test Description, Step Description, and Expected Result
Formatting descriptions. Click Parameters to insert parameters into your descriptions. The toolbar
includes the following items:

Item Description

Bold Apply bold formatting to the selected text.
Italics Apply italicized formatting to the selected text.
Underline Apply underlined formatting to the selected text.
Align Left Align the selected text to the left side.

Align Center Align the selected text to the center.

Align Right Align the selected text to the right side.

Justify Apply a justified alignment to the selected text.
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Toolbar Description

Item Description

Bulleted List Convert the selected text to a bulleted list.
Indent Left Apply a left-side indent to the selected text.
Indent Right Apply a right-side indent to the selected text.
Undo Change Undo the last action you performed in a text

description text box.

Redo Change Redo the last action you performed in a text
description text box.

Font Apply a different font type to the selected text.

Font Size Apply a different font size to the selected text.

Format Apply a different pre-defined formatting style to
the selected text. For example, Heading 1,
Heading 2, ...

Parameters Insert pre-configured Test Manager custom

step properties, which are also called project
parameters, into text descriptions. In normal
mode, the dialog box displays the parsed
values of the resolved parameters. In Edit
mode, the dialog box displays the actual
parameters.

Navigation  Use to manage your manual test execution and to navigate between tests. The toolbar
includes the following items:

Item Description

Edit Edit the properties of the selected test.

New Internal Issue Add an internal issue to the selected test.

Go To Issues View the issues of the selected manual test in

Test Manager, or assign new issues to the test.

Previous Test Return to the previous test step in the manual
test execution.

Next Test Advance to the next test step in the manual test
execution.

Finish Run Close the Execute Test dialog box when you
have completed all test steps in the active
manual test.

Video Capturing in the Manual Testing Client

You can capture a video of a test in Manual Testing Client, which you can then add to the Manual Testing
Client result files. You can then analyze the video, for example if an error occurs during the test.

Note: Video capturing is currently enabled only for Microsoft Windows operating systems. To use
video capturing on a Windows 2008 system, you need to install the following server features:
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» Desktop Experience
* Quality Windows Audio Video Experience

Note: The main display of your system is recorded. Secondary displays are not included in the video.
During the recording, some tasks are not enabled. To perform such tasks, stop the recording.

Recording Videos in the Manual Testing Client

To enable video capturing in the Manual Testing Client:

1. Inthe Manual Testing Client, click on the package that includes the test that you want to execute in the
Inbox. The tests in the selected package are displayed in the Tests page.

2. Double-click on the test that you want to execute. The Execute Test dialog box opens.

3. Click the Details tab. The Details page opens.

4. In the Test Details section, click Start on Video Recording. A red button indicates that a video of the
test is being recorded.

5. When you no longer want to record, click Stop on Video Recording. The Add Video to Result Files
dialog box opens.

6. Type a name for the video file, and click OK, to save the video, or click Cancel to delete the video file.
The video is added to the result files of the test.

7. To view the video, click the Result Files tab and double click on the video file.
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