## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Micro Focus Visual COBOL 3.0 for Visual Studio Release Notes</td>
<td>4</td>
</tr>
<tr>
<td>What’s New</td>
<td>5</td>
</tr>
<tr>
<td>Significant Changes in Behavior or Usage</td>
<td>12</td>
</tr>
<tr>
<td>Known Issues</td>
<td>15</td>
</tr>
<tr>
<td>Resolved Issues</td>
<td>17</td>
</tr>
<tr>
<td>Other Issues Resolved in This Release</td>
<td>35</td>
</tr>
<tr>
<td>Unsupported Functionality</td>
<td>37</td>
</tr>
<tr>
<td>Installation</td>
<td>38</td>
</tr>
<tr>
<td>Before Installing</td>
<td>38</td>
</tr>
<tr>
<td>Downloading the Product</td>
<td>38</td>
</tr>
<tr>
<td>On Windows</td>
<td>38</td>
</tr>
<tr>
<td>Basic Installation</td>
<td>42</td>
</tr>
<tr>
<td>Installing</td>
<td>42</td>
</tr>
<tr>
<td>Advanced Installation Tasks</td>
<td>43</td>
</tr>
<tr>
<td>On Windows</td>
<td>43</td>
</tr>
<tr>
<td>After Installing</td>
<td>44</td>
</tr>
<tr>
<td>On Windows</td>
<td>45</td>
</tr>
<tr>
<td>Licensing Information</td>
<td>47</td>
</tr>
<tr>
<td>To activate Visual COBOL Personal Edition</td>
<td>47</td>
</tr>
<tr>
<td>To request and activate a 30-day trial license for Visual COBOL</td>
<td>48</td>
</tr>
<tr>
<td>To buy and activate a full unlimited license</td>
<td>49</td>
</tr>
<tr>
<td>To start Micro Focus License Administration</td>
<td>49</td>
</tr>
<tr>
<td>Installing licenses</td>
<td>49</td>
</tr>
<tr>
<td>If you have a license file</td>
<td>49</td>
</tr>
<tr>
<td>If you have an authorization code</td>
<td>50</td>
</tr>
<tr>
<td>To obtain more licenses</td>
<td>50</td>
</tr>
<tr>
<td>Updates and SupportLine</td>
<td>51</td>
</tr>
<tr>
<td>Further Information and Product Support</td>
<td>51</td>
</tr>
<tr>
<td>Information We Need</td>
<td>51</td>
</tr>
<tr>
<td>Creating Debug Files</td>
<td>52</td>
</tr>
<tr>
<td>Copyright and Disclaimer</td>
<td>53</td>
</tr>
</tbody>
</table>
Micro Focus Visual COBOL 3.0 for Visual Studio Release Notes

These release notes contain information that might not appear in the Help. Read them in their entirety before you install the product.

Note:

- This document contains a number of links to external Web sites. Micro Focus cannot be responsible for the contents of the Web site or for the contents of any site to which it might link. Web sites by their nature can change very rapidly and although we try to keep our links up-to-date, we cannot guarantee that they will always work as expected.
- Check the Product Documentation section of the Micro Focus SupportLine Web site and the Micro Focus Infocenter for any updates to the documentation which might have been uploaded.

Product Overview

Visual COBOL enables you to develop COBOL applications within Microsoft Visual Studio. You use the Visual Studio integrated development environment (IDE) to edit, compile and debug COBOL applications. The IDE provides all the functionality to manage projects and build applications.


Upgrading from earlier Micro Focus products

Application executables that were compiled using earlier Micro Focus products must be recompiled from the sources using Visual COBOL.
What's New

This release provides enhancements in the following areas:

- Integration with Visual Studio
- Application Server JCA support for Enterprise Server
- Azure support
- Building applications
- COBOL language enhancements
- Code analysis
- Code coverage
- Compiler control
- Data File Tools
- Database access - DB2
- Database access - MySQL
- Database access - OpenESQL
- Documentation
- Enterprise Server
- Interface Mapping Toolkit
- iFileshare
- Micro Focus Unit Testing Framework
- XML processing

Integration with Visual Studio

This release provides enhancements in the following areas:

- Integration with Microsoft's Visual Studio 2017, the most recent version of world's most popular integrated development environment (IDE) for the Windows platform, offering significant benefits for developers and businesses developing software for Windows.
- COBOL Editor:
  - Brace completion - a closing quote mark or bracket is automatically inserted when you type the opening quote mark or bracket at the end of a line.
  - Brace matching for IF and EVALUATE statements - clicking on any of the clauses of these statements highlights the opening and closing statements and all clauses. Use CTRL + ] to move the cursor to the next clause in the statement.
  - Collapse to definitions - closes all sections, entry points and methods in an open file. Use the Outlining > Collapse to Definitions editor context menu command.
  - Colorization is now available for QuickInfo, completion tooltips and signature help.
  - Completion of statements - IF and EVALUATE statements are now automatically aligned and completed.
  - Indentation - smart indentation is now available to control how lines indent within IF and PERFORM statements and after continuation statements.
  - Locate definition, on the COBOL toolbar enables you to search for data items and identifiers by specifying any string of characters that might be part of their name. This command replaces Edit > Go To Location.
  - Outlining - outlining is now available for 01 level for group items (for expanding and collapsing the entire group)
  - Quick actions (a feature of Visual Studio versions 2015 and later) - Visual COBOL now supports Visual Studio's quick actions for rename refactoring, and finding or creating missing copybooks.
• Tooltips are now available for managed COBOL members.

• COBOL toolbar - the commands on the COBOL toolbar have been updated in order to optimize your editing experience. A number of commands (renumber and unnumber) have been removed from the context menu in the editor and are now only available from the toolbar.

• Directives determination - there is now a preview dialog box when the IDE scans your sources for Compiler directives. This enables you to review and approve the directives before they are set.

• Error reporting - you can now sort the errors and warnings Error List window by their COBOL error code.

• Import, export and synchronization of the IDE options - you can now export a number of the COBOL global options as a Visual Studio .settings file. You can import the file into other instances of Visual COBOL.

Visual COBOL for Visual Studio 2015 and later now supports the automatic synchronization of a number of COBOL settings across the copies of Visual Studio installed on different machines. The settings are synchronized through your MSDN account. See the MSDN for more details and for information on any restrictions to the functionality.

• Project Details window - provides a number of enhancements, including performance improvement. It is now possible to filter on project or solution, perform a search, and sync with Solution Explorer. Tooltips are available in the Overrides column to show the override directives.

• Net Express import wizard - provides a new option for including copybooks in a project.

• Rename refactoring - this release introduces rename refactoring for COBOL code that can help to improve the readability of COBOL elements or make their purpose clearer. You can rename elements such as variables and identifiers, section and paragraph names, classes, and methods across a program or a solution.

• Support for standalone files - various improvements have been made to how you work with files that are not part of a project:

  • When you first open a standalone file, the editor displays an alert bar with options to browse for a symbols (.idy) file to use to compile the standalone file or to configure the Compiler directives.

  • You can now use the file’s properties window to edit the Compiler directives and to specify options for debugging.

In previous versions of Visual COBOL, standalone files were known as "single files". References to "single files" in the IDE and the product help have been changed to "standalone files".

Application Server JCA support for Enterprise Server

Restriction: This feature applies only when the Enterprise Server feature is enabled.

In this release, EJBGEN has been updated to generate an EAR file as a part of the COBOL deployment process, which enables you to deploy EJBs to Java Application Server.

Azure support

Visual COBOL now supports the following versions of Microsoft Azure SDK - version 2.9.6 with Visual Studio 2013 and version 3.0 with Visual Studio 2015 and later.

Building applications

This release provides the following improvements:

• Support for faster, parallel building on multi-CPU machines - support has been added for multi-processor compilation of the sources in native COBOL projects on multi-CPU machines.
You can specify the maximum number of concurrent compilations from the IDE preferences - **Tools > Options > Micro Focus > Projects**. In Visual Studio, multi-processor compilation must also be enabled in the project’s properties.

**Back to Top**

**COBOL language enhancements**
This release includes the following enhancements to the COBOL syntax:

- The DISPLAY-OF and NATIONAL-OF intrinsic functions are now able to process conversions using any IBM CCSID value.

The following enhancements are available in managed COBOL:

- To avoid an exception being thrown if an explicit conversion fails, use the AS IF syntax, which results in the target object being set to null and no exception thrown.

**Back to Top**

**Code analysis**
This release provides the following improvements:

- A new group of predefined rule sets for 64-bit readiness is now included in Visual COBOL.
- Support for importing code analysis reports produced with one of Micro Focus’s advanced tools for code analysis, Enterprise Analyzer or COBOL Analyzer.

**Back to Top**

**Code coverage**
The following improvements are available within the IDE:

- Information about unexecuted programs - the code coverage reports in the **Code Coverage** window now show the unexecuted programs.
- Code coverage support for standalone COBOL files - you can import existing code coverage reports in the **Code Coverage** window and use it to supply code coverage information for standalone files.

If you are using Test Coverage from the command line, you can now use the following features:

- A new Compiler directive, COLLECTION - the directive enables test coverage to gather information about unexecuted programs. In the IDE, this directive is automatically set on a project when you enable code coverage for it.
- A new command line utility, tcutil - the utility enables you to convert the test coverage binary results file into XML format.
- It is now possible to integrate test coverage in a Continuous Integration (CI) system. You can use tcutil and an XSLT processor to transform test coverage data into a format suitable for including in a CI.

**Back to Top**

**Compiler control**
The following Compiler directives are new in this release:

- COLLECTION - provides a mechanism for code coverage to identify unexecuted programs.
- ILSTDLIB - helps you to ensure that your .NET COBOL code compiles with the correct version of the .NET Framework Microsoft Common Object assembly mscorlib.d1l. When building from Visual Studio or using MSBuild to compile a COBOL project, the NOILSTDLIB directive is set, and an ILREF is generated pointing at the version of mscorlib appropriate for the target framework selected in the project’s properties.

The following Compiler directives have been updated:
• **ALIGN** - this directive has new parameters (FIXED and OPT) that can be used in conjunction with the integer taken, which can aid performance. The default is **ALIGN"8 OPT"**; see the Comments section of the **ALIGN** Compiler directive topic for details of its affect on memory boundaries.

• **ARITH** - this directive emulates the IBM mainframe option of the same name. Defines the maximum number of digits for numeric data items.

• **FASTINIT** - this directive is now on by default when setting the MF dialect; it remains not set by default for other dialects.

• **SSRANGE** - this directive now has an additional option (3), which permits zero-length reference modified items at run time when bounds checking.

• **XMLPARSE** - includes a change in the way entities are processed when **XMLPARSE**(COMPAT) is set.

---

**Data File Tools**

This release provides the following enhancements to Data File Tools:

• Opening files in shared mode - it is now possible to switch between read-only shared and edit modes. While a file is open in shared mode, others users can only open it in shared mode to ensure data consistency between users.

• Enterprise Server-level of security when accessing files - there is an improved level of security when exchanging data between Data File Tools and the targeted enterprise server instance. Users must now provide a user ID, group and a password when they try to access and view datasets in enterprise server instances. These are used for authentication and authorization checks to provide the same access level as Enterprise Server.

• Opening datasets using SSL - communication to a region is now possible using SSL. To enable the SSL communication, you need to provide a Java trust store which contains either a CA root certificate or a self-signed certificate of the region that it is communicating to. Java and the targeted region SSL configurations need to meet each other's standards in order for the communication to succeed. This feature enables you to secure the information exchange between Data File Tools and the targeted enterprise server.

• Auditing of access and updates on datasets - Audit Manager now audits the access and updates on datasets via Data File Tools.

• Support for existing .pro files - enables you to use your existing editor profiles.

• Support for existing .str files - enables you to use your existing COBOL structure files.

• Automatic timeout - if no internal operations or external actions (such as a mouse click) have been detected for 30 minutes, Data File Tools now displays a countdown message. If the user does not take any decision within the specified period, Data File Tools closes all opened files.

---

**Database access - DB2**

This release provides a new **DB2(QUALIFY-CALL)** Compiler directive that enables stored procedure invocations to include a schema name.

Back to Top

**Database access - MySQL**

This release provides support for **MySQL** with ODBC.

Back to Top

**Database access - OpenESQL**

This release provides the following new features:
• Statement prefixes for the SQL(CHECK) Compiler directive that enable the creation of temporary tables and other SQL objects at compile time, ensuring full SQL syntax checking during compilation.
• SQL(OPTIMIZECURSORS) Compiler directive that enhances processing for traditional embedded SQL cursors that use WITH HOLD and FOR UPDATE clauses.
• SQL(CLOSE_ON_COMMIT) Compiler directive to leave cursors open for further result set processing after a commit.
• SQL(GEN-SQLCA) Compiler directive that generates an SQLCA similar to the z/OS DB2 directive STDSQL(YES).

Documentation
The following new section have been added to the product help:
• Where do I start? - located on the launch page of the product help, this section provides the information you need in order to get started depending on which aspects of the product you need to get to grips with first.

Enterprise Server
Improvements are available in the following areas:

Integration with Visual Studio:
• Exporting an enterprise server definition from the IDE in XML format.
• Importing an enterprise server into the IDE using its definition file.
• In Visual Studio, it is now possible to configure an enterprise server to produce a core dump file directly from the IDE, from the server properties.

Long user IDs and passwords:
• Enterprise Server now supports user IDs and passwords of up to 100 characters. It is possible to map IDs from long to short (or vice versa) to enable compatibility with programs that do not support long names.

SHA-256 support in DemoCA:
• By default, the Demonstration Certificate Authority (CA) now signs certificates with SHA-256. This ensures that the demonstration or evaluation certificates will be accepted by modern browsers and other software that has enhanced security requirements.

Syslog auditing:
• Enterprise Server now supports auditing using syslog events, which can be consumed by a wide range of Security Information and Event Management (SIEM) products. This replaces the Audit Manager auditing solution. Syslog auditing provides a much more efficient auditing mechanism, with significantly less impact on overall speed.

Interface Mapping Toolkit
The Interface Mapping Toolkit (IMTK) contains the following enhancements in this release:
• Cross Origin Resource Sharing (CORS) support for REST Web services, enabling Web service access from a CORS-supported Web browser.
iFileshare

iFileshare is no longer considered an Early Adopter Program, and contains the following enhancements in this release:

- An improved failover and recovery process. iFileshare now supports full recovery of nodes in the group. For high availability (HA-VSAM) groups, servers can now rejoin the group without the entire group having to be restarted. In addition:
  - A primary failover now results in a takeover from the most suitable node.
  - If configured, external clients will automatically reconnect to the new primary and will issue a notification if the transaction has been lost.
  - A failed node, when restarted, will rejoin the group, recover its files and request a log update from the current primary. Once this task has completed it will be considered an active hot-standby and will continue to process replication requests as normal.
  - Users will experience a higher level of uptime/availability with their Fileshare configuration and will be able to recover from errors more easily.
- A new exit procedure, ifsexitproc.cbl, can be configured to automate some aspects of iFileshare behavior.
- The iFileshare Control page in ESMAC contains details of the current iFileshare high availability group.
- The following new iFileshare-specific environment variables are available:
  - FSWRKDIR - enables you to specify the Fileshare working directory, overriding the default, which is the system directory of the region.
  - FSCHKLFH - determines if a check is performed when a high availability group is started, to test the consistency of the data files within the group.
- The database reference file (dbase.ref) now supports wildcard matching for filenames, allowing you to perform operations on multiple files at once; for example: `fs /d dbase.ref /f data\*` adds the entire contents of the data directory to the database reference file.

The Micro Focus Unit Testing Framework

The Micro Focus Unit Testing Framework is now available from within the IDE. It includes much of the architecture you would expect of an xUnit framework to create, compile, run and debug unit tests, including the following features:

- A unit test project template.
- A test creation wizard that enables you to generate tests from your source code.
- Code snippets for each element of a test case.
- Support for running tests with Code Coverage enabled.
- The Micro Focus Unit Testing window, where you can manage your test runs and view test output.

There has been a number of enhancements to the command line version of the Micro Focus Unit Testing Framework. Support has been added for:

- Generating NUnit-style reports.
- Running test fixture files using Apache Ant.
- Applying traits to your test cases, then performing a test run based on those traits.
- Applying a high, medium, or low priority to test cases, which affects the order in which they are run.
- Adding coded command line options directly into your test code.
- Using a test run-specific configuration file, in which you can set environment variables.
XML processing

XML PARSE now works in a purely managed COBOL environment. It is now supported in JVM COBOL and, in both .NET and JVM COBOL, it has a fully managed implementation. XML PARSE working without calling out to native code ensures it can be used in restricted rights environments.

Back to Top
Significant Changes in Behavior or Usage

This section describes significant changes in behavior or usage. These changes could potentially affect the behavior of existing applications or impact the way the tools are used.

Where present, the numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem Incident (RPI) number (in parentheses).

- Compatibility AddPack
- Compiler
- Documentation
- Enterprise Server
- File Handling
- IDE
- Micro Focus Directory Server
- OpenESQL
- Reserved words
- SQL Option for DB2

Compatibility AddPack for Visual COBOL

Back to the list

Compatibility AddPack for Visual COBOL is now deprecated and will not be available with release 3.0 and later.

The Dialog System GUI and run-time components and Dialog System Character Mode (on Windows and UNIX) which were part of the AddPack are now installed as part of Visual COBOL for Visual Studio. The run-time components are installed as part of COBOL Server. These are only included for backward compatibility and Micro Focus does not recommend that you use them for new development.

The other components which were part of the AddPack, the Character-Based Data File Editor, CSBIND and Screens, will be available upon request from Micro Focus SupportLine.

Compiler

Back to the list

- Replacing a partial token no longer causes the second part of the token to appear on a new line. This could happen if the new text was larger than the text being replaced.

2869185 (1105763)

Documentation

Back to the list

- There have been a number of new reserved words added to the language in this release; these are all in effect under MFLEVEL"19", which is the default level when running under the MF dialect. Any of the following words are now not allowed under default conditions, and you will need to remove/rename them, or specifically configure your environment to allow them: ALLOCATE FREE JSON END-JSON

Enterprise Server

Back to the list
• WEB CONVERSE now supports a value of 0 for the USERLEN and PASSWORDLEN options which matches the behavior on the mainframe. There is no change to the behavior of WEB SEND (client) which is to return LENERR 139/140 when USERLEN or PASSWORDLEN are 0.

2989188 (1108602)

IDE

Back to the list

• Disabling CICS support from the properties of a file in your project within the IDE now correctly sets the NOCICSECM Compiler directive on that file.

File Handling

Back to the list

• A problem that generated a 39 error when attempting to access a VSAM file via an alternate index PATH element has been fixed.

2874622 (1106562)

Micro Focus Directory Server

Back to the list

• In the Enterprise Server Administration HTML GUI, the "Scripts" page functionality is only available if administration access is restricted and the logged on user has sufficient authority.

3101625 (1109025)

• Some additional CSRF security measures have been added to the Enterprise Server Administration HTML GUI.

3101205 (1108916)

OpenESQL

Back to the list

The new OpenESQL OPTIMIZECURSORS SQL compiler directive option is turned on by default for both ADO.NET (DBMAN=ADO) and ODBC (DBMAN=ODBC). For ADO.NET, this reduces cursor memory consumption thereby providing optimal performance. This also ensures that, for ODBC, embedded SQL cursors that use WITH HOLD and FOR UPDATE clauses have the same data integrity across all databases.

If your applications require the OpenESQL preprocessor to use the behavior provided in an earlier release, compile them using OPTIMIZECURSORS=NO.

Reserved words

Back to the list

• There have been a number of new reserved words added to the COBOL language; these are all in effect under MFLEVEL"19", which is the default level when running under the MF dialect. Any of the following words are now not allowed under default conditions, and you will need to remove/rename them, or specifically configure your environment to allow them:

    ALLOCATE
    FREE
    JSON
    END-JSON
SQL Option for DB2

Back to the list

- Help buttons previously available on the XDB Server Configuration Utility, XDB Service Controller, Options Dialog, Bind Utility, and Linker Config (Link Profile) UIs have been removed with the exception of error messages in the SQLWizard, Migrate, and Declaration Generator.
Known Issues

Refer to the Known Issues and Restrictions topic in the Product Information section of your product Help.

In addition, note the following:

- Azure support
- Debugging
- Enterprise Server
- Resource Adapters
- REST/JSON IMTK implementation and the same-origin policy (SOP)
- Visual Studio

Azure support

- When compiling COBOL Azure Role projects in Visual COBOL for Visual Studio 2013 you receive warnings at build time and the code fails to execute when deployed to Azure.

  To work around this issue, you need to manually add the code below to the configuration section of the Web.config file in your project for Web Roles or in the app.config file for Worker Roles:

  ```xml
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Data.Services.Client" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-5.7.0.0" newVersion="5.7.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Data.OData" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-5.7.0.0" newVersion="5.7.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Data.Edm" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-5.7.0.0" newVersion="5.7.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b26ae35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-8.0.0.0" newVersion="8.0.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>

  This information is added automatically when you create COBOL Azure projects in Visual Studio 2015 or later.

Debugging

- When debugging .gnt code on early builds of Windows 10 and Windows Server 2016, execution fails to stop at COBOL breakpoints. To resolve this, you should install the most recent Windows updates for your operating system, as this problem is only known to be present with the earlier versions.
Enterprise Server

- On Windows 10, if you are using Microsoft’s EDGE browser to access the Enterprise Server Administration GUI, issues with EDGE can cause the automatic refresh feature to display a dialog asking whether you want to resubmit a form. To work around this issue, cancel the resubmit request and then refresh the server list page or the Home page of Enterprise Server Administration. You can also turn off the automatic refresh by setting the Auto-refresh interval setting on the Home page of Enterprise Server Administration to 0.

Resource Adapters

- Trying to deploy the local resource adaptor mfcobol-localtx.rar to WebLogic may fail with a ClassCastException. To work around this issue, you need to deploy mfcobol-xa.rar first, then need to undeploy this file and deploy the local one, mfcobol-localtx.rar. If there are issues deploying using the WebLogic GUI, you can use the command line. If there are issues with this as well, try reducing the length of the command (for example, by moving the file to a location with a shorter path).

REST/JSON IMTK implementation and the same-origin policy (SOP)

- HTTP requests sent from scripts within a web browser to REST services deployed on an enterprise server might fail due to the same-origin policy (SOP). Some browsers might implement (or support plugins that implement) techniques for relaxing SOP such as cross-origin resource sharing (CORS) that enable sending cross-origin requests successfully. For REST services, Enterprise Server does not implement a method for relaxing SOP. This means that browsers that implement CORS (or any other SOP relaxation technique) might still forbid requests made from scripts due to Enterprise Server not implementing the equivalent technique on the server side.

Visual Studio

- The Visual Studio 2017 option Lightweight Solution Load is not supported for COBOL. It must not be used with solutions that contain COBOL projects as it could result in problems with building the projects properly.

- In certain installation scenarios, after you install Visual COBOL for Visual Studio 2015, the COBOL language service can be uninstalled. This results in the following features missing from the COBOL editor: colorization, IntelliSense for COBOL and any other COBOL language support. This is an issue with Visual Studio’s MEF component cache becoming corrupted.

To resolve this issue and restore COBOL language support in the editor:

1. From a command prompt, navigate to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE.
2. Execute the following commands:

   devenv /updateconfiguration

   And then:

   devenv /clearcache

   Known Issues
Resolved Issues

The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem Incident (RPI) number (in parentheses).

- Adis
- COBOL to XML Schema generation
- Codeset Support
- Common Communications Interface
- Compiler
- Data Tools
- Debugger
- Documentation
- Editor Writing Assistance
- Embedded HTML Pre-Processor
- Enterprise Server
- File Handling
- IDE
- Interface Mapping Toolkit
- Micro Focus Directory Server
- Monitoring and Management
- OLE Class Library
- OpenSSL
- REX Support
- RM/COBOL
- Run-Time System
- SQL: COBSQL
- SQL: OpenESQL
- SQL Option for DB2
- XML Support

**Adis**

*Back to the list*

- PIC N items are now filled with double-byte space when required by ADISCTRL options 15 and 16.
  2913183 (1108448)

**COBOL to XML Schema generation**

*Back to the list*

- CBL2XML now handles namespace correctly.
  2861655 (1104748)
- CBL2XML now correctly handles non-default type within <restriction>.
  2826345 (1100279)

**Codeset Support**

*Back to the list*
• The Codeset DBCS tables MFTR0886.A2E MFTR0886.E2A have been updated to match the latest IBM Traditional Chinese conversion tables below: Description of 9027: T-Ch Host Double-Byte including 6204 UDC including euro. Description of 21427: T-Ch DBCS-PC (IBM BIG-5) including 13493 CNS, 566 IBM selected, 6204 UDC & euro.
3104948 (1109314)

Common Communications Interface

Back to the list

• Using CCI shared memory and receiving data with a max receive length less than the total amount of data received resulted in the data being received incorrectly on the final receive. This has now been fixed.
• After a communications failure, Enterprise Server shared-memory listeners would sometimes stop accepting new connections. This has now been fixed.

Compiler

Back to the list

• Level-88 VALUE clauses that inadvertently contain fixed point numeric literals, which cannot be matched with the associated numeric type, are now flagged with an E-level message.
3106909 (1109479)
• A new ARITH"COMPAT|EXTEND" Compiler directive is now supported to emulate the IBM mainframe option of the same name. This option defines the maximum number of digits for numeric data items.
3105597 (1109340)
• An extended ACCEPT of a PIC N data item now compiles successfully, as expected.
3101615 (1108944)
• The reference to an ASSIGN name in the SELECT clause is now included in the IDE's 'Find All References' list irrespective of whether the ASSIGN name is explicitly declared later in the source or not.
3100084 (1108817)
• When an intrinsic function is used as a parameter to an inline method invoke, which is also a parameter to another inline method invoke, the Compiler would produce invalid code, leading to a COBRT200 error. This is now fixed.
2991106 (1108786)
• Prototype checking for OMITTED parameters in inline method invokes is now working as expected.
2991031 (1108800)
• An error when an OBJECT PROPERTY is used in subscript calculation, or reference modification index or length calculation, has been fixed.
2990388 (1108738)
• A directives file with an explicit end of file character is now processed correctly.
2913115 (1108474)
• A DISPLAY of ADDRESS OF <data item> now executes as expected.
2913005 (1108635)
• Prototype checking for nested inline method invokes is now working as expected.
2912463 (1108437)
• A bug where compilation of very large managed projects could fail with error "COBCH1500: memory allocation failure – module ‘allocmem’" has been fixed.
2886156 (1108156)
• Using COBSQL with CP for a program with complex multi-line COPY REPLACING no longer results in spurious errors.
  2884493 (1107939)
• A move from a group to a reference modified PIC N field now executes as expected.
  2884093 (1107883)
• Sign-included numeric usage DISPLAY items now display as expected under a mainframe dialect; that is, they display with the included sign shown exactly as stored, without conversion for readability.
  2879364 (1107340)
• The use of N" national literals in STRING statements no longer produces incorrect results.
  2878504 (1107053)
• A bug where COBDATA was set prior to starting the Visual Studio IDE, and was then blank when applications were executed, has been fixed.
  2878431 (1107160)
• A user class condition where the subject has the potential to be zero length now compiles and executes as expected when compiled with a mainframe dialect (which sets the ZEROLENGTHFALSE directive).
  2878426 (1107044)
• The same names used for data items in both method local and object storage could sometimes result in wrong execution results when the wrong duplicated name was used.
  2878370 (1107207)
• Class conditions defined in the SPECIAL-NAMES paragraph now work when SELECT statements are defined before the SPECIAL-NAMES paragraph.
  2876808 (1106853)
• Under CHARSET(EBCDIC), a MOVE of PIC G/N data items to PIC N/G data items now pad with x"4040" (an EBCDIC DBCS space). Comparisons of such data items will now also work correctly.
  2876109 (1106752)
• VALUE clauses with hex literals now pad correctly with x"40" under CHARSET(EBCDIC).
  2875748 (1106704)
• Statements involving properties and 'OCCURS DEPENDING ON' tables now compile and execute as expected.
  2875074 (1106626)
• Concatenation of alphanumeric literals in a VALUE clause for a national item is now treated as intended.
  2873871 (1106451)
• Queries of reference modified national data items now work as expected.
  2873639 (1106443)
• Using INSPECT <national-data-item> with the BY SPACE clause now works as expected. When dealing with national data items, SPACE is now treated as a national space - NX"0020£.
  2873388 (1106390)
• A user class condition test, where the item being tested is a reference modified item with a length that is an expression, and when the directive ARITHMETIC(OSVS) is set, no longer causes an internal error on compilation.
  2873219 (1106409)
• Nested inline method invokes now work as expected.
  2872741 (1106315)
• A MOVE statement referencing a property name now compiles and executes as expected.
  2872488 (1106304)
• A program containing DBCS characters in the sequence area of an otherwise blank line now compiles correctly and without error.
  2868802 (1105699)
• An issue with using DECLARATIVES without a USE statement has been fixed.
  2867168 (1105446)
• If more than one report shared the same FD, for example: REPORTS ARE REPORT-1 REPORT-2. then under HOSTRW, the record length was wrong. This has been corrected.
  2865849 (1105553)
• The use of the HOSTRW and CURRENT-DATE directives no longer causes an excessive number of lines in a report produced from the Report Writer.
  2853789 (1105472)
• A USE FOR DEBUGGING statement that references a table item and is triggered by a condition where the table item is referenced but not evaluated (due to short-circuit evaluation) now executes as expected.
  2433731 (1073167)
• A bug in the Compiler, when REPLACE is used and the final line in the main source file is a copy statement containing a separate program, has been fixed.
• An error reporting the size of return-code by the Eclipse IDE has been fixed.
• A bug has been fixed in programs compiled with CHECKDIV"OSVS" that contain a statement of the form: COMPUTE r = a / (b - b)
  3105637 (1109410)
• A bug in ON SIZE ERROR for arithmetic statements using floating point variables has been fixed.
  2886077 (1108151)
• A bug has been fixed in generated code on Linux/390 for statements of the form: compute rounded a = b / constant where a and b are both comp-3 variables, and constant is an integral power of 10 (e.g. 10, 100, 1000).
  2874143 (1106479)
• A COBRT114 error that was occurring at run time in generated code has been fixed.
  2871410 (1106100)
• An error in debugging on Intel 32-bit platforms, such that a breakpoint set on an "exit method" statement is ignored if it immediately follows a statement such as "end-perform", "end-if" or "end-evaluate", has been fixed.
  2861424 (1104587)
• A bug in generated code with the opt(3) directive, on Intel x86 64 bit (Linux and Windows) and Linux/390 has been fixed.
• A spurious warning 'Reference to undeclared extern assembly' is no longer generated for programs using the PREXML preprocessor, when built in Visual Studio.
  3106908 (1109475)
• Icons consisting of PNG images are now being loaded successfully into applications using the ILICON directive, and no longer causing compile-time errors. (The ILICON directive is generated implicitly in Visual Studio when an icon is selected in the 'Icon and manifest' drop-down in Project Properties.)
  2988305 (1108523)
• In some cases, use of the PROFILE directive could generate invalid code; those cases have been fixed.
  2882325 (1107625)
• If the level 66 RENAMES phrase refers to two items in different 01 level records (which is non-standard and not recommended), the offset of the resulting item is no longer calculated wrongly; previously it was, leading to incorrect behavior at run time.
2882119 (1107568)
• If the first procedure in a PERFORM...THROUGH statement terminated (e.g. with GOBACK or STOP RUN), then the PERFORM itself terminated, and control did not trickle through beyond the PERFORM statement. The compiler has now been modified to recognize this condition, which means that the procedure division can be broken down into disjoint methods, avoiding stack overflow during program execution.

2880315 (1107465)
• An arithmetic expression involving an intrinsic function and a non-integer COBOL numeric item (e.g. PIC 9V9) no longer produces a result with incorrect decimal alignment.

2878918 (1107116)
• A load failure, which was the result of bad code caused by a constructor containing a GO TO statement that referenced a label (either a section or a paragraph) at the start of the procedure division, no longer occurs.

2878817 (1107114)
• The use of report-writer syntax in a class program no longer leads to bad code generation. Previously, it could result in 'field not found' errors when the class was loaded.

2878260 (1107158)
• When a PIC X data definition is used as a parameter to a method expecting an IEnumerable<char>, or when used as the object for an extension method on IEnumerable<char> (e.g. System.Linq.Enumerable.ToArray<char>), bad code is no longer generated.

2877859 (1106974)
• Use of the DIALECT"ENTCOBOL" directive no longer causes incorrect behavior when dealing with EXTERNAL files.

2875493 (1106685)
• When compiling for managed code, specifying an object reference in the file section will now produce an appropriate error message. Previously, the Compiler was allowing the use of object references in the file section, which was causing the generation of bad code, and inappropriate system error messages.

2872605 (1106287)
• Report Writer syntax directly under class-id (that is, not within static/end static or object/end object) no longer causes the generation of invalid code, which was leading to errors at run time.

2872555 (1106283)
• In managed COBOL, a large amount of CONTROL clauses no longer causes the SCREEN SECTION to produce a buffer overflow.

2870942 (1106053)
• When ILSMARTLINKAGE was specified for a program compiled with the directive ODOSLIDE (which is set automatically when a mainframe dialect is used), and when the program contained a linkage section record with multiple OCCURS DEPENDING ON items, then illegal code was being produced with multiple error messages. This is now fixed.

2870166 (1105899)

Data Tools

Back to the list

• Vision and RM files that contain a null (0x00) byte in the key now function correctly in the Data File Editor.

2882159 (1107598)
• The following minor enhancements have been made to the Data File Editor: - Previous filter conditions are now remembered for each file when the dialog is loaded. - The default filter operator now defaults to 'Contains'. - Field attributes for reference conditions now default to 1:max-rec-length, instead of 1:1.
Debugger

Back to the list

- Querying DBCS items in Character Animator now works as expected.
  3107408 (1109521)
- The debugger no longer hangs when debugging remote Enterprise Server regions.
  2882367 (1107659)
- Examining the value of large data items in 64-bit applications or when debugging remote applications no longer causes the debugger to exit.
  2872732 (1106322)
- When debugging .gnt code, execution fails to stop at COBOL breakpoints. To resolve this, you should install the most recent Windows updates for your operating system, as this problem is only known to be present with early Windows builds of both Windows 10 and Windows Server 2016.

Documentation

Back to the list

- The product documentation has been updated to include information and syntax for secure access to MFDS (mfds /b).
  2854625 (1103606)
- Documentation for environment variables has been improved.
- The casstart /w parameter prevents the casstart process from exiting until the region has either started or failed to start correctly.
  2868898 (1105712)
- A "redundant" or "high-availability" mode is now available in the Enterprise Server External Security Facility. It enables you to configure multiple equivalent Security Managers and let processing continue as long as at least one Security Manager is available. To enable this feature, add the following to the configuration text area for the security configuration (either in the default Enterprise Server Security, the MFDS Security, or on the Security tab for a specific enterprise server): [Operation] redundant=yes
  2989911 (1108665)
- Additional information on the Web Services and J2EE conversation type has been added to the "Configuring Listener Conversation Types" chapter in the product documentation.
  2877270 (1106896)
- The product documentation has been updated to include information on converting the input file used by casrdtup from EBCDIC to ASCI.
  2863611 (1104940)
- The documentation for bit zero of the ‘thread-state’ parameter of CBL_THREAD_LIST_START and CBL_THREAD_LIST_NEXT has been corrected.
- Documentation of CBL_LOCATE_FILE parameter corrected.
- The installation instructions included incorrect information about users having to stop and uninstall an existing Micro Focus Directory Server (MFDS) or CCITCP2 Windows service (on Windows) or a process (on UNIX) from an existing product. This has been removed from the product help.
  2877431 (1106934)

Editor Writing Assistance

Back to the list
• IntelliSense and Content Assist now provide the appropriate suggestions after a CONTAINS expression.

Enterprise Server

Back to the list

• An issue where SOAP elements were not mapped to COBOL code has been resolved.
  3106199 (1109416)
• When SOAP headers were part of the SOAP request, you no longer receive a "SOAP header malformed" response.
  3105803 (1109367)
• An issue where a handler program in the pipeline caused issues with JSON GET/DELETE/HEAD requests has been fixed.
  3104977 (1109274)
• An UNDEFINED_ELEMENT error message occurred when a JSON message (under CICS WEB SERVICES) did not include an object that was present as a "record 1" item in the wsbind or the jsbind files.
  3102943 (1109085)
• When a CICS Web Service was invoked with no port in the URI, the default port for the scheme was not set up.
  3100280 (1108870)
• EXEC CICS SEND and CONVERSE commands now send all user-written headers (EXEC CICS WRITE HTTPHEADER) even if the user provided values that contain null bytes. When browsing headers with EXEC CICS WEB READNEXT HTTPHEADER, CICS will now initialize the buffers that were supplied for the header name and value.
  2990561 (1108733)
• A problem where a system process (CASTRC) was unable to allocate any local storage and, as a result, became unresponsive, has been resolved.
  2886741 (1108236)
• Casout commands running in a loop from the same process used to exhausting resources. This was caused by an invalid path concatenation.
  2886407 (1108426)
• An issue resulting in a Run-Time System error 205 "Invalid mainframe pointer" has been fixed.
  2885280 (1108041)
• TRANSFORM was failing in situations where an XMLTODATA TRANSFORM contained an XML declaration with EBCDIC encoding.
  2885262 (1108040)
• The EZASOKET traces are now controlled by a COMMS trace flag.
  2884491 (1108174)
• Caching has been added for TS queues security checks.
  2884070 (1108789)
• Commarea overrides are now honored for non-facility transactions.
  2884049 (1107879)
• Usernamelen and passwordlen options are not mandatory on exec cics web converse and web send (client).
  2880669 (1107365)
• Previously, using multiple CICS LINK statements (linking A to B to C and so on) could result in an RTS error 114 in the CAS system modules.
2880542 (1107372)
- The spool active job queue will now display any jobs that were started prior to resetting the time for DST but that have not completed yet.

2879116 (1107204)
- The debug file name generated when using CICS Web Services now includes the process ID and the task number. For example - inquireCatalogClient-19556(00028)-CWS-REQUESTER.TXT.

2878485 (1107077)
- The SOAP to COBOL mapping under CICS Web services was incorrect when an optional element had no child elements (where the schema defined a minimum of one such child element and these child elements have been mapped to a container). In such cases, the number of instances of the child element would have an incorrect value of 1 where it should be 0.

2877043 (1106879)
- If you used XA with more than 7281 transactions or had a number of JCL jobs that used XA, a record could be split across multiple blocks. After restarting the enterprise server, a large number of CASXO0029I errors were reported in the console log file. A block that can hold up to 7282 records is now used.

2874024 (1106621)
- When casout is used to release a job, casmgr now attempts to dispatch the job immediately rather than waiting for its next dispatch cycle which previously could take 20 seconds.

2873224 (1106621)
- If there were more than 20 TRANCLASS instances specified in the startup list, this could cause memory corruption.

2868129 (1105682)
- The ESFCA0401I Cache Termination message is now available for JES, IMS DB, IMS TM, MQ, and iFileshare processes.

2866750 (1105376)
- A duplicate security check about whether the user has enough permissions to run a JCL job has been removed.

2866526 (1105336)
- When eci-tpn is used on a call to ECI for CTG or the Micro Focus implementation of ECI, Enterprise Server now verifies the transaction exist and is enabled. If the transaction is disabled, an abend AZI6 is returned. This is mainframe-compatible behavior.

2863500 (1105165)
- An EXEC CICS LINK to a non-CICS module now handles the data context correctly and you no longer receive CDDC abends on any further LINKs.

2858747 (1104275)
- CASxx5006I messages now display a return code.

2853609 (1103516)
- All ESMAC pages are now secured. Users who are not authorized now receive an error message when trying to access any of these pages in their browser.

2843901 (1102247)
- The CICS WEB services now support SOAP 1.2.

2822822 (1099723)
- An issue that could cause an RTS error 119 on a casout command when starting a batch initiator has been fixed.
- An issue with certain length DNs that could cause DNs to become truncated has now been fixed.

3103303 (1109366)
• If nested groups (user groups containing other groups) were used with LDAP-based security for Enterprise Server, it could result in Enterprise Server hanging at region startup, or users might not be assigned all of their groups. This has now been fixed.

2988205 (1108935)

• The "check TLQ first" option has been added to the MLDAP ESM. The option can change the Rule processing algorithm. This option might improve performance when there are large numbers of resources in a class.

2875051 (1106874)

• Enterprise Server no longer crashes on startup if LDAP-based external security with the "all-groups" and "redundant" options are both specified, but the "federated groups" option is not.

2874010 (1106529)

• If the esfupdate utility is used to request an update of security information for a user, and that user was originally signed onto the system using a lowercase representation of their user ID, the update now correctly identifies and updates the user.

2871297 (1106164)

• If the MFDS Security Configuration specifies that verify requests should be cached and the cache TTL and limit values are non-zero, for example, the MF Directory Server Security configuration page Security Facility configuration text contains: [Cache] requests=verify If a new password was specified in a Web interface logon request, then previously it was being ignored. Previously, if the user was logging on with an expired password and attempting to change the password the request would also be ignored and an expired password error would be returned.

2868342 (1105626)

• An RTS 205 error during the execution of an AMODE application could occur when Assembler address 0 was erroneously de-registered. This is now fixed.

3104561 (1109229)

• Under heavy loads, the ESFCA0401I log messages were not appearing at the correct intervals.

2863222 (1104948)

• Enterprise Server listeners that are configured for TLS (also known as SSL) no longer hang if a client connects to them without sending any data.

2873177 (1106408)

• In some HotFix releases of earlier versions of Enterprise Developer and Enterprise Server, SSL or TLS connections to an Enterprise Server could hang if client certificates were used and there was a delay of at least several seconds before the certificate was sent.

Embedded HTML Pre-Processor

Back to the list

• The XML run-time system did not handle data items with the OCCURS clause correctly.

3107418 (1109566)

File Handling

Back to the list

• The ESF LDAP Security Administration Web Interface now has a logoff button.

2871551 (1106117)

• If data compression is specified when trying to open a fixed block file, when running under a mainframe dialect, the File Handler now checks to see if it is trying to open a VB file. If it isn't, compression will be turned off and the file will be opened as normal.
2870022 (1105956)
• An internal field used to store the current file status was being overwritten by the allocation of a buffer. Now we store it off beforehand so its value can be restored, and an accurate file status returned.

2868664 (1105707)
• When certain in-flight rewritten records were rolled back at the end of a transaction, the File Handler was setting incorrect values for the length field in some records and various warning messages were displayed during index file validation.

2864802 (1106106)
• A CBL_FREE_MEM statement in Fileshare was missing a 'by value' clause, which was causing a run-time error. This is now fixed.

2883421 (1107767)
• When running under Fileshare, a delete on a locked record no longer results in a record locked status if the same user had previously obtained a read lock on the file.

2832909 (1108287)
• When REBUILDing from SEQ into IND with duplicate key, you will no longer get a corrupted file if you do not specify the target flag /t.

2880311 (1107302)
• CSF to ZD negative sign conversion is now handled correctly during a sort operation.

3103118 (1109125)
• JCL SORT no longer abends if no record is rewritten to a DUMMY data set.

3102468 (1109052)
• Sorting ESDS files to RRDS files no longer truncates the first 4 bytes of each record.

3101385 (1109112)
• Variable length SORT OUTFIL files are now created correctly when more than one data set is specified in the targeted OUTFIL.

2881629 (1107551)
• MFSORT INCLUDE will no longer include the first record in the concatenated file if, according to the parameters, that record should be excluded; previously, the first record was included regardless of the parameters.

2876259 (1106785)
• For an MFJSORT, a combination of numeric tests and logical comparisons now returns the correct records.

2870986 (1106216)
• When copying concatenated files in MFJSORT, for sequential fixed block, the correct number of record is now used.

2870506 (1106057)
• MFJSort now produces the correct number of records regardless of the value of the SORTSPACE setting.

2867668 (1105534)
• An error when writing the ICETOOL listing from an empty input file has been corrected.

2866176 (1106459)

IDE

Back to the list
• Attempting to evaluate a class condition when debugging .NET COBOL code could cause the debugger to crash.
Previously, you could only use the environment variables specified using the "Environment" button on the Application tab in the project's properties when running the project. There is now a new option, "Use variables when building the project", which enables you to apply these variables when the project is compiled.

Restarting debugging of native projects is now successful.

Native COBOL projects that contain an Application.config file now build cleanly when this file is read-only.

The Web Publish option now works correctly for COBOL ASP.NET applications.

The COBOL margins are now displayed correctly when stepping into an assembly that is not part of the solution being debugged.

The performance while stepping through a Mainframe Subsystem application running on a remote machine has been improved.

It is now possible to create projects in folders that contain accented characters.

By default, Visual Studio is now configured to insert spaces in the COBOL code when the tab key is pressed in the editor. If you are upgrading from an earlier version of this product, and have changed your tab settings, they will be reset to the default IDE settings as part of the upgrade. For Enterprise Developer, this change also applies to Assembler, BMS, IMS, JCL and PL/I programming code.

Interface Mapping Toolkit

A problem with Enterprise Server that caused an alphanumeric data item mapped to a SOAP Boolean to give results that were incompatible with the mainframe for invalid data values has been fixed.

The performance of a COBOL Web client has been improved when processing services with interface parameters containing unbounded arrays.

When a path specified as part of an ls2ws parameter contained at least one space, ls2ws would fail. This has been fixed.

EJB generation/deployment has been enhanced to produce an EAR file. Unlike the EAR file produced during client generation, this deploy-time EAR does not contain a WAR file and thus does not contain any JSP files.

Micro Focus Directory Server

Fixed a memory leak in the MFDS process.
• A memory leak in the MFDS process occurred if non-SSL-enabled connection attempts were made against an SSL-enabled MFDS. This has now been fixed.
  2869493 (1106567)
• The MFDS -g command-line option now correctly handles the import of multiple region definitions from a single XML file.
  2840162 (1101798)
• An issue that could potentially cause heap corruption in MFDS if the configuration data for an individual object was greater than 1K has been fixed.
• The "Renew" option available in the Enterprise Server Administration Web interface now works if SSL is enabled.

Monitoring and Management
Back to the list
• Spurious STEP BYPASSED events for dummy steps were being passed to the user exit and the HSF exit.
  2873504 (1106446)
• An issue where duplicate HSF records could be created has been fixed.
  2856941 (1103977)

OLE Class Library
Back to the list
• A problem with accelerator keys being handled by an ActiveX control has been fixed.
  2990224 (1108719)

OpenSSL
Back to the list
• The version of OpenSSL included in this product has been updated to version 1.0.2j.

REX Support
Back to the list
• When running a REXX EXEC under Enterprise Server or Enterprise Server for .NET, an "Invalid Expression" error occurred for an assignment statement where the expression being assigned to the variable had been omitted. An empty string is now assigned to the variable if the expression is omitted.
  2880655 (1107390)
• A REXX exec could fail with a S0C4 abend or an RTS 114 error if it was greater than 4096 bytes in length and specified either as in-stream data or catalogued as an RECFM=F or RECFM=V dataset.
  2878613 (1107100)

RM/COBOL
Back to the list
• When FILETYPE(21) was specified for a LINE SEQUENTIAL print file, you could receive a Run-Time System error "13". Writing to a printer from a Visual COBOL program through the RM File Manager (filetype 21) now works correctly.
  2874987 (1106616)
Run-Time System

Back to the list

- Adis SCREEN SECTION ACCEPT statements for PIC N DISPLAY-1 items now correctly accept DBCS characters with a lead byte of x"87".
  3104586 (1109231)
- A error when using very long command lines with Profiler (or cobprof on UNIX) has been fixed.
  2884968 (625185)
- You can now double-click (to run) managed executables that use the ACUFH file handler; previously, they may have failed with a COBRT198 error.
  2880827 (1107388)
- When debugging a native Object COBOL application, the debugger no longer fails with an intermittent COBRT114 run-time error when getting the type and value of an object's handle.
  2875531 (1106808)
- A multi-threaded application that makes use of the COBOL syntax for handling mutexes, monitors, events and semaphores, or the corresponding CBL_ APIs, no longer fails intermittently with various run-time errors due to memory corruption.
  2860205 (1104446)
- Animating a core file that has been moved to a different directory, for a core file produced by an application compiled to executable, no longer fails with a "Program is not animatable" error. Previously, it would on certain platforms.
  2856631 (1103933)
- Detaching from animation that was started using the debug_on_error tunable could cause animation to re-start again for the initial error - this has now been resolved.
- In managed COBOL, a CANCEL data-name statement no longer fails or crashes if the contained program name is not space-terminated.
  2887392 (1108320)
- Using user-defined class conditions in managed code no longer gives incorrect results.
  2887005 (1108290)
- When executing a SQLCLR stored procedure for a second time, programs not found during the first execution might not be found dynamically.
  2879012 (1107201)
- The backtab key now works correctly when performing ADIS screen i/o operations in managed code applications.
  2877480 (1106928)
- Using the CBL_FILENAME_CONVERT library routine resulted in receiving an exception in managed COBOL if bit 3 was set for the function parameter and CTF tracing was then enabled.
  2876179 (1106763)
- An environment variable with a value containing a leading space is no longer treated as having been deleted.
  2872919 (1106405)
- A CANCEL of a dataname containing low values no longer causes a Run-Time System error in managed COBOL code.
  2872140 (1106247)

SQL: COBSQL

Back to the list
• A problem that caused the COBSQL preprocessor to incorrectly parse comments beyond column 72 has been fixed.
  3101746 (1108980)
• A problem with COBSQL producing a duplicated cursor data item when KEEPCOMP was used has been fixed.
  2874051 (1106531)
• A problem that caused the COBSQL preprocessor to incorrectly process source lines with characters in column 73 and beyond has been fixed.
  2869958 (1109899)

SQL: OpenESQL

Back to the list

• A problem that occurred when SQLCODE was set incorrectly and an EXECUTE IMMEDIATE statement was executed multiple times has been fixed.
  2990794 (1108754)
• A problem using SQL(PROCOB) and SQL(DATE=EXTERNAL) with Oracle fully managed data access provider for .NET has been fixed.
  2989291 (1108639)
• Performance when using SQL(PROCOB) with OpenESQL ADO.NET runtime and Oracle unmanaged provider has been improved by reducing occasions where Oracle's ALL_SYNONYMS table is accessed.
  2913100 (1108599)
• A problem that occurred when a stored procedure that makes dynamic COBOL CALLS executes an EXEC SQL CLOSE <cursorName> WITH RETURN TO CALLER statement has been fixed. For this fix to be effective, the stored procedure must not be compiled using SQL(OPTIMIZE=PCURSORS).
  2887060 (1108265)
• A problem fetching from a cursor defined for a stored procedure call that doesn't return a result set has been fixed.
  2885499 (1108075)
• A problem with DESCRIBE CURSOR in COBOL SQLCLR stored procedures for cursors that retrieve result sets from nested stored procedure calls has been fixed.
  2883792 (1107841)
• A problem in COBOL stored procedures that occurred when a COBOL CALL followed a cursor OPEN for a TSQL procedure call has been fixed.
  2881606 (1107529)
• For .NET applications accessing Oracle databases, character values used in numeric host variables caused performance degradation. This has been fixed.
  2877103 (1107035)
• A problem that caused OpenESQL to incorrectly handle FETCH statements when the number of host variables did not match the number of columns in the result set has been fixed. Host variables in excess of result columns remain unchanged. If the number of host variables is fewer than the number of result columns, SQLWARN 3 is set to 'W' in the SQLCA. Note: When using PostgreSQL with ODBC, you must adjust the DSN configuration to disable updatable cursors because OpenESQL provides its own support for updatable cursors with PostgreSQL.
  2876426 (1106813)
• A COBOL stored procedure could not retrieve multiple result sets from an OpenESQL cursor via a nested stored procedure call. This has been corrected, and the retrieval of multiple result sets from a COBOL stored procedure is now supported.
  2875262 (1106668)
• The OpenESQL preprocessor incorrectly expanded a group host variable used in a CURSOR SELECT statement, resulting in a run-time error. The preprocessor has been modified to generate a COBES0130 error message in this case.

3104602 (1109289)

• A problem the prevented OpenEQL applications calling SQL Server stored procedures with no parameters when using the legacy 'SQL Server' ODBC driver has been fixed. Important: We strongly discourage use of the legacy 'SQL Server' ODBC driver. Instead, we recommend that for best performance and functionality, use the ODBC driver that corresponds to the version of SQL Server used by the application.

3100550 (1109071)

• A problem with HCOSS code generation that occurred when duplicating input host variable references (for example when substr() is used with 2 rather than 3 parameters) has been fixed.

3100098 (1108819)

• A problem with the OpenEQL native routine that provides DSNTIAR emulation sometimes caused an RTS114 error. This has been fixed.

2989595 (1108699)

• A new OpenEQL directive, GEN-SQLCA, has been added to generate the SQLCA copybook in a program when it has not been explicitly included. This directive provides additional support when migrating applications compiled with STDSQL(YES) on the mainframe.

2887858 (1108368)

• A problem with the MSSQL XA switch module sometimes causing a CICS transaction to abort if it ended without closing all FORWARD and READ ONLY cursors has been fixed.

2887074 (1108340)

• An inconsistency in reporting data truncation warnings when using PostgreSQL has been fixed.

2886648 (1108201)

• OpenEQL and OCI have been updated to to prevent RTS198 errors when using DSNTIAR with ODBC. To take advantage of this new functionality, specify the cob -d command flag to resolve DSNTIAR with the correct callable shared object. For example, to compile a COBOL program into an executable on a 64-bit platform with OESQL DSNTIAR: cob -x program.cbl -d DSNTIAR@cobmfdsntiar64.so -L$COBDIR/lib -lmfpliz -lplidump -llmgr -l Or, to compile a PL/I program into an executable on a 32-bit platform with OESQL DSNTIAR, execute the following two commands: mfplx -c PROGRAM.pli -sql odbc -optsql "behavior=mainframe nosmftrace" cob -x PROGRAM.o -d DSNTIAR@cobmfdsntiar.so -L$COBDIR/lib -lmfpliz -lplidump -llmgr -l

2884651 (1107997)

• A problem when using OpenEQL for JDBC with the "Use Dynamic Calls" project option has been fixed.

2883500 (1107955)

• A problem with SQL(AUTOFETCH) that affected SQL Server FORWARD READ ONLY WITH HOLD cursors performance has been fixed.

2880840 (1107580)

• The ADO.NET Run-Time System for OpenEQL now returns the correct value in SQLERRD(3) after a cursor fetch when other statements are executed between any fetches on the cursor.

2880814 (1107386)

• OpenEQL now allows FREE to be used as an SQL identifier. It is server dependent if this is supported at compile time when using SQL(CHECK) and at run time.

2880673 (1107368)

• A new OpenEQL directive, CLOSE_ON_COMMIT, has been added to provide greater control over cursor behavior on COMMIT for cursors that are not explicitly declared using WITH HOLD.

2879558 (1107305)
- A problem with HCOSS handling of nested table references in DB2 statements has been fixed and error messages when using SQL(STRICTPARSE) have been improved.
  2879503 (1107286)
- The SQLBGPS COBSQL compiler directive option has been added to ensure successful background parsing of EXEC SQL statements when the Pro*C OBOL installation resides on a remote machine and not on the local machine.
  2877618 (1107292)
- A problem that prevented SQL(CHECK) from working correctly on some databases has been fixed.
  2877284 (1107021)
- When used with the SQL(USER-SQ LDA=MAINFRAME) directive, the O penESQL preprocessor could incorrectly generate ES0100 errors if a group variable was used in an EXEC SQL FETCH statement. This has been fixed.
  2876420 (1106803)
- The OpenESQL preprocessor sometimes failed to return comp data items correctly if compiled with SQL(DIALECT=MAINFRAME). This has been fixed.
  2874931 (1106606)
- The OpenESQL preprocessor has been updated to generate a more meaningful message, COBES0129, when it encounters an undefined host variable.
  2874408 (1106624)
- A problem with SQL(NORSLOCATORS) leaking SQL Server server cursors has been fixed.
  2872613 (1106294)
- HCOSS handling of the DB2 CHAR() function did not always properly apply the compile-time settings of DATE and TIME as the default formats when CHAR was called with a date or time value but no date or time format parameter was supplied. This has been fixed.
  2872518 (1106404)
- A new SQL compiler directive option, OPTIMIZECURSORS, has been added to optimize memory consumption when using OpenESQL for ADO.NET with Oracle, DB2, or PostgreSQL. The default setting is SQL(OPTIMIZECURSORS=YES). See the OPTIMIZECURSORS reference topic in the documentation for complete information.
  2871132 (1106056)
- Decimal and host variables with the same length are now converted to EBCDIC correctly when CHARSET(EBCDIC) is enabled; however, if you link native COBOL applications that use display numeric variables in SQL statements using CHARSET(EBCDIC), you might get a link error. To resolve this issue, see the OpenESQL topic under KNown Issues and Restrictions.
  2857755 (1104091)
- A problem with the ODBC switch module not reporting broken connections to Enterprise Server when xa_start() is called has been fixed.
  2843672 (1108847)
- A problem that caused the OpenESQL preprocessor to incorrectly interpret UNICODE(PORTABLE) has been fixed.
- The SQL xa_open string has been updated to include the PACKAGEPATH option, which enables the use of substitution markers to customize the package path based on the current JCL or CICS user name, XA resource name, enterprise server region name, or a combination. In addition, when used with the UserP option, the PACKAGEPATH option value changes when the user for the connection changes.
- A problem using SQL(DATEDELIM) with SQL(DATE=JIS) has been fixed.
- OpenESQL has been updated to enable execution of selected SQL statements at compile time. You can use this functionality to create temporary tables during compilation and to enable the use of SQL(CHECK) with temporary as well as permanent tables.
- The encoding of the sqltype fields in SQLDA has changed and any applications that use dynamic SQL with SQLDAs might require application code change. The new sqltype encoding scheme adds 0x2000
to sqltype when an integer, a small integer or a big integer host variable is COMP and 0x1000 and when any indicator host variable is COMP. Otherwise, COMP-5 is assumed for indicators and for integer, small integer and big integer host variables.

**SQL Option for DB2**

*Back to the list*

- A problem with the Declaration Generator that prevented COBOL copybooks from being generated correctly for tables with timestamps and XML columns has been fixed.
  2875742 (1106868)
- The XDB preprocessor has been updated to support source connect files that previously generated a "File not found" error for EXEC SQL INCLUDE statements located on the source connect drive.
  2912819 (1108471)
- The XDB ECM has been enhanced to handle temporal table query syntax.
  2876438 (1106807)
- Implemented the JDBC ResultSet Interface getBigDecimal methods that do not require a scale argument: getBigDecimal(int columnIndex) and getBigDecimal(String columnLabel).
  2877817 (1106963)
- A problem that caused an X020 syntax error on SELECT DISTINCT (TRIM) has been fixed.
  3105393 (1109324)
- A problem that prevented the XDB engines to successfully process a COUNT(DISTINCT expression) scalar function when the expression was a concatenated expression enclosed in parentheses has been fixed.
  2884227 (1107903)
- A problem that caused a thread stack overflow on scalar function recursions that use CONCAT has been fixed.
  2884046 (1107882)
- A problem with the XUTLB LOAD grammar prevented the reserved word DATE from being used as a table name. This has been fixed.
  2882727 (1107652)
- An problem when correlating a subquery produced a PDMP242 error. This has been resolved.
  2880672 (1107367)
- A problem that caused a FETCH FIRST clause in a scalar subquery to be ignored has been fixed.
  2880671 (1107366)
- A problem using the reserved word DOCUMENT as an identifier in the first argument of a scalar function has been fixed.
  2874154 (1106483)
- CAST AS TIMESTAMP using the special character 'T' as the date/time delimiter was not allowed. This is now allowed.
  2874153 (1106484)
- An issue with the ordering of a result set caused the incorrect row to be returned on a FETCH FIRST ONLY clause. This has been fixed.
  2873390 (1106435)
- An issue with index optimization of LIKE predicate processing has been resolved.
  2873389 (1106391)
- A problem that sometimes caused the XDB Server to shut down before completing location checkpoint operations by maintenance threads has been resolved.
• An problem with LIKE predicate index query optimization that caused missing result set rows has been fixed.

• A problem that prevented the restoration of LOB data from a record with an LOB column after deleting the record and then rolling back from a Save Point has been fixed.
• XDBMONN has been updated to issue the correct error message when it is started, but the server is not running.
• The server Name be displayed in the status bar of the XDB SQL Wizard.

• Using ALLOW EDITING on an SQLWizard result set could result in the query being corrupted. This has now been fixed.

• The restriction that prevented the editing of result sets generated from alias tables has been removed.

• When the SQLWizard is invoked by MFA Drag & Drop to import unload data to a table it no longer returns an X352/X95 error.

• A problem that sometimes occurred when using the DB2(NOHCO) compiler directive option caused the return of incorrect codes at completion of program execution. This has been fixed.

• The DB2 preprocessor has been updated with a new DB2 compiler directive option, QUALIFY-CALL, that works with the QUALIFIER compiler directive option to qualify DB2 EXEC SQL CALL statements with the schema name specified by the DB2 QUALIFIER directive.

• The DB2 ECM has been updated to prevent an undefined ECM error when indicator variable arrays are used in SELECT SQL statements.

• The DB2 ECM preprocessor has been updated to support host variables defined as SQL TYPE IS XML AS BLOB-FILE/CLOB-FILE/DBCLOB-FILE.

XML Support

• XMLPARSE no longer returns -19 in XMLSS mode.

• Opened XML files are now closed when the COBOL program called by JCL is terminated.

• A new directive "OUTENC(INPUT)" is created to ensure encoding of the output text will be the same as the input encoding specified in the XML declaration.

• XMLIO now handles REDEFINE data items correctly.
Other Issues Resolved in This Release

The numbers listed are the Support Incident Numbers followed by the Reported Problem Incident (RPI) number (in parentheses).

- 2884374 (1107928)
- 2875256 (1106645)
- 2871954 (1106649)
- 3103304 (1109198)
- 2857117 (1106716)
- 3106240 (1109462)
- 2989573 (1108689)
- 2874306 (1106666)
- 2848671 (1102872)
- 2876662 (1107084)
- 2864100 (1104959)
- 3101450 (1108990)
- 2884755 (1107973)
- 2884754 (1108098)
- 2883962 (1108118)
- 2883962 (1108119)
- 2878826 (1107101)
- 2878227 (1107012)
- 2877589 (1106938)
- 2875248 (1106679)
- 2874812 (1106627)
- 2874077 (1106516)
- 2872027 (1106210)
- 2869739 (1105894)
- 2868086 (1105954)
- 2864170 (1105040)
- 2864164 (1105035)
- 2909780 (1108760)
- 2884757 (1108096)
- 2883769 (1107830)
- 2851153 (1103313)
- 3101883 (1108971)
- 3101148 (1108902)
- 2885725 (1108103)
- 2884537 (1107964)
- 2878485 (1107076)
- 2876638 (1107036)
- 2872931 (1106328)
- 2872035 (1106199)
- 2867270 (1106437)
- 2837526 (1104757)
- 3101467 (1109005)
- 2879947 (1107389)
- 2879908 (1107247)
- 2878412 (1107371)
- 2852872 (1107046)
- 2989831 (1108862)
- 2879806 (1108822)
- 2879462 (1108480)
- 2879608 (1108372)
- 2879765 (1108319)
- 2879700 (1108214)
- 2884191 (1108331)
- 2886979 (1108286)
- 2879488 (1107196)
- 2881573 (1107673)
- 2878429 (1107279)
- 2876370 (1107219)
- 2867228 (1106143)
- 2867842 (1105600)
- 2867117 (1105493)
- 2853200 (1103409)
- 2885043 (1108044)
- 2867773 (1106847)
- 2869095 (1105803)
- 2865595 (1105786)
- 2860304 (1104472)
- 2883686 (1107844)
- 2865350 (1105129)
- 2864599 (1105025)
- 2873863 (1106487)
- 2870740 (1106000)
- 2866084 (1105259)
- 2864758 (1105772)
- 2999339 (1108666)
- 2878067 (1106990)
- 2877643 (1107028)
- 2873883 (1106635)
- 2819070 (11099603)
- 2657473 (11090356)
- 2869213 (1105788)
- 3103252 (1109178)
- 3103241 (1109176)
- 3010979 (1109785)
- 2887454 (1108358)
- 2882453 (1107614)
- 3100079 (1108823)
- 2887733 (1108399)
- 2888096 (1107464)
- 2877232 (1106950)
- 3102272 (1109059)
- 3101639 (1109086)
- 2886684 (1108370)
- 2884612 (1108024)
- 2879358 (1107190)
- 2878631 (1107110)
- 2877721 (1106966)
- 2876808 (1106856)
- 2876719 (1106845)
- 2875613 (1106730)
- 2873607 (1106420)
- 2873447 (1106429)
<table>
<thead>
<tr>
<th>Issue Number</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>2851640 (1103228)</td>
<td>2885859 (1108130)</td>
</tr>
<tr>
<td>2603382 (1087028)</td>
<td>2885529 (1108083)</td>
</tr>
<tr>
<td>2871769 (1106474)</td>
<td>2884236 (1108000)</td>
</tr>
<tr>
<td>2876285 (1106842)</td>
<td>2883551 (1107800)</td>
</tr>
<tr>
<td>3107224 (1109628)</td>
<td>2881659 (1107500)</td>
</tr>
<tr>
<td>2880556 (1107803)</td>
<td>2881243 (1107455)</td>
</tr>
<tr>
<td>2879876 (1107263)</td>
<td>2881040 (1107414)</td>
</tr>
<tr>
<td>2880593 (1107378)</td>
<td>2881038 (1107416)</td>
</tr>
<tr>
<td>3105620 (1109342)</td>
<td>2881037 (1107419)</td>
</tr>
<tr>
<td>2991280 (1108799)</td>
<td>2881036 (1107423)</td>
</tr>
<tr>
<td>2882386 (1107606)</td>
<td>2880647 (1107399)</td>
</tr>
<tr>
<td>2881902 (1107890)</td>
<td>2879819 (1107333)</td>
</tr>
</tbody>
</table>
Unsupported Functionality

The following features or functionality are no longer supported:

• The HOSTSIGNS Compiler directive is no longer supported. Micro Focus recommends that you use the following Compiler directives instead: SIGN-FIXUP, HOST-NUMMOVE, and HOST-NUMCOMPARE.
Installation

Before Installing

Downloading the Product

You can download Visual COBOL from the Product Updates section of the Micro Focus SupportLine Web site.

On Windows

System Requirements

Hardware Requirements

Visual COBOL has the following requirements in addition to the requirements of Microsoft Visual Studio. See the Visual Studio documentation for details of the Microsoft requirements.

The maximum disk space requirements are, approximately:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual COBOL</td>
<td>1.2Gb</td>
</tr>
<tr>
<td>Sentinel RMS License Manager</td>
<td>75MB</td>
</tr>
</tbody>
</table>

- This includes the space needed to cache information locally so that you can modify the installation without the original source media.
- The disk space requirements include the versions of JRE and .NET Framework supplied with the setup file.

Operating Systems Supported

For a list of the supported operating systems, check the Product Availability section on the Micro Focus SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

Note:

- You can produce both 32-bit or 64-bit applications with Visual COBOL installed on a 64-bit operating system.
- Visual COBOL for Visual Studio is not supported on versions of Windows earlier than Windows 7.
- The Enterprise Server feature is not supported on Windows XP.

Software Requirements

The setup file will check your machine for whether the prerequisite software is installed and will install any missing prerequisites and the product components. A supported version of Microsoft's Visual Studio 2015 or 2017 must, however, be installed in advance.

Note:

- Besides the software listed below, the setup file also installs the 64-bit Java 8 Update 102.
• This product includes OpenSSL version 1.0.2j.

Visual Studio IDE
You must have Microsoft's Visual Studio installed in advance.

You need one of the advanced versions of Visual Studio listed below or the Visual Studio Integrated Shell (only supported by Visual COBOL for Visual Studio 2012 or 2013):

- Professional, Premium, or Ultimate (for Visual Studio 2012)
- Professional, Premium, Ultimate or Community Edition (for Visual Studio 2013)
- Professional, Enterprise or Community Edition (for Visual Studio 2015)
- Professional, Enterprise or Community Edition (for Visual Studio 2017) - see the next section for the Visual Studio components you must install.

Microsoft's Visual Studio Express Edition is not supported.

If there is no Visual Studio installed on your machine, the setup file for Visual COBOL for Visual Studio 2012 or 2013 will install the Visual Studio Integrated Shell. Alternatively, you can download the Visual Studio Integrated Shell from the Microsoft Download Center and install it before you install Visual COBOL.

If you choose to install the Shell, ensure you run the installer to complete the installation - run vsintshell.enu.exe from the location where you installed the download.

Note that some Visual Studio features might not be available with the Shell. This includes WCF or the Visual Studio 2013 Connected IDE experience in the Visual Studio 2013 Shell - the help for more details.

Important:


• Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that there is an advanced edition of Visual Studio 2015 installed on your machine.

• On Windows 8.1 RT, Windows 8.1 or Windows Server 2012 R2, you must have the Windows update KB 2919355 before you install Visual Studio 2015. Download KB 2919355 from the Microsoft Download Center.

• When installing Visual Studio 2017, ensure you select the Help Viewer component for installing to ensure you can view the Visual COBOL product help inside Visual Studio. When you select components to install in the Visual Studio installer, click Individual components and check Help Viewer in the Code tools section.

• Code generation issues in Microsoft's 64-bit JIT (just-in-time) compiler delivered as part of .NET Framework version 4.6 can result in incorrect execution of some COBOL code compiled to .NET. Version 4.6 of the .NET Framework is currently shipped as default with Visual Studio 2015 and Microsoft's Windows 10. The problems include incorrect execution of MOVE and STRING statements applied to alphanumeric operands, and incorrect execution of the ROUNDED phrase for arithmetic statements.

Some of these issues only seem to be reproducible in COBOL language applications compiled to .NET and some can be reproduced in other languages (C# or Visual Basic).

These problems have been reported and acknowledged by Microsoft and it is our belief that they either have resolutions or are working on fixes for all of them. For further information about these issues and guidelines on how to disable the latest version of the 64-bit JIT compiler, see RyuJIT Bug Advisory and Troubleshooting RyuJIT.
As of October 2015, Microsoft have released the following updates that address these issues with the .NET Framework 4.6:


The following software is also required:

- Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft Download Center and search for Windows SDK.
- Microsoft .NET Framework 4.5. This is included with Visual Studio 2012.
- Microsoft .NET Framework 4.5.1. This is included with Visual Studio 2013.
- Microsoft .NET Framework 4.6. This is included with Visual Studio 2015.
- Microsoft .NET Framework 4.6.2. This is included with Visual Studio 2017.

Selecting the Visual Studio 2017 components to install

The Visual Studio 2017 installer enables you to customize and only install the workloads and components that are most suitable for your area of development. For example, you can select the components that are required for .NET desktop development, ASP.NET Web or C++ development.

The Help Viewer component is not installed by default and must be selected before you start the Visual Studio installation to ensure you can view the Visual COBOL product help.

If not already installed, the Visual COBOL setup file will install the following components:

- .NET Framework version 4.6.2
- Debugger
- Visual Studio's Help Viewer
- Data services

A number of workloads and components are optional - for example, Azure, WCF, Web, WPF or SQL CLR application development. If you require any of these, you can select them when you start the Visual Studio 2017 installer or, enable them after completing the installation - see the next section.

Installing Visual Studio 2017 features that are not currently installed

If a feature of Visual Studio 2017 was not installed during the Visual Studio installation, the respective functionality or the project templates for it are not available. You can install a missing feature in one of the following ways:

Rerun the Visual Studio installer:

1. Start the Visual Studio 2017 installer and choose to modify an existing Visual Studio instance.
2. Select the workloads and the components that are missing (for example, ASP.NET and web development or Help Viewer).

Use the Quick Launch control in Visual Studio 2017:

2. Type the name of the feature in the Quick Launch control - for example, type ASP .NET or Help Viewer.
A drop-down list with any features matching your search string appears. If the feature is not already installed, one of the search results will be an option to install it.

Use the Install Missing Feature(s) command in Visual Studio 2017:

2. Click Help > Micro Focus Product Help > Install Missing Feature(s) > Feature Name.
   
   Follow the instructions in the installer to install the missing feature.
3. Alternatively, if a Micro Focus project template requires a Visual Studio feature which is not currently installed, the IDE displays an information bar with instructions to install the feature.

**Internet Explorer 10**

Internet Explorer 10 (IE 10) is required by the installation of Visual Studio 2013. If you are installing Visual COBOL on a machine that has no Visual Studio 2013 installed, the setup file installs Visual Studio 2013 Shell provided that IE 10 is installed beforehand. You can download IE 10 from Microsoft's Web site.

**IIS Express**

IIS Express is required if you want to use the Web development tools. You can download IIS Express from the Microsoft Download Center.

**Other Requirements**

**Important:** This release requires version 10000.2.990 or later of the Micro Focus License Administration tool. For local servers, you do not need to install it separately, as the setup file installs a new Visual COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the client is not able to communicate with license servers of versions older than 10000.2.660. On Windows, you can check the version of your license server by clicking Help > About in the Micro Focus License Administration tool.

You can download the new version of the license server software from the Micro Focus SupportLine Web site: http://supportline.microfocus.com.

**Additional Software Requirements**

To ensure full functionality for some Visual COBOL features, you might be required to obtain and install additional third-party software in addition to the prerequisite software installed automatically by the Visual COBOL setup file.


**Product Co-Existence**

- Visual COBOL and COBOL Server cannot coexist on the same machine.
- Visual COBOL and Enterprise Developer cannot coexist on the same machine regardless of which IDE (Visual Studio or Eclipse) you install.

**Installation Restrictions and Requirements**

Before starting the installation you should consider the following:

- Visual COBOL and Enterprise Developer cannot coexist on the same machine.
- If, when you install Visual COBOL for Visual Studio 2012 or 2013, the machine does not have Microsoft Visual C++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL.
The installation of Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital signatures, into the winsxs directory.

- If, when you install Visual COBOL for Visual Studio 2015, the machine does not have Microsoft Visual C++ 2013 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital signatures, into the winsxs directory.
- You need to be logged in with a user-ID that has write access to the registry structure under HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation software can set the environment appropriately. You also need to be logged on with Administrator privileges.

Basic Installation

The instructions in this section apply when you are performing a basic installation of this product for the first time. If you are an administrator, you can perform a basic installation on a local machine before performing a more advanced installation when rolling out the product to developers within your organization.

For considerations when installing this product as an upgrade, for additional installation options or non-default installations, see Advanced Installation Tasks in your product Help.

Installing

**Note:**

- This version of the product is a full install.
- See Before Installing first for important information. Also, see Installing as an Upgrade, if you have an earlier version of Visual COBOL installed on your machine.

To install this product:

1. Run the vcvs2017_30.exe file (or either vcvs2012_30.exe, vcvs2013_30.exe or vcvs2015_30.exe) and follow the wizard instructions to install the prerequisite software and the product.

**Note:**

- When the installation has completed, on some editions of Windows you might receive a notification that Visual Studio 2012 has compatibility issues. This is a known Microsoft issue. To resolve it, follow the instructions in the notification for obtaining help online, or download the KB2781514 update for Visual Studio 2012 from the Microsoft Download Center.
- If you are installing onto a machine that has an existing Micro Focus product that uses an older Sentinel RMS License Manager, you might be prompted to remove it and install the Micro Focus License Administration. By doing this you maintain the existing Sentinel RMS license files while adding the Micro Focus License Administration. If you are unsure about existing licenses on your computer or removing the Sentinel RMS License Manager, consult your System Administrator. If you want to proceed, remove Sentinel RMS License Manager by using Program and Features (Windows Vista or later), and rerun the installation file.
- Trial licenses cannot be used with remote desktop services. If you want to use your product in this way, please contact Micro Focus SupportLine to obtain a relevant license.
- We recommend that you install any updates for Visual Studio and the .NET Framework that are available at the Microsoft Download site.
- If you install JDK you might be prompted to install the latest update. The latest update is not required for use with Visual COBOL but you can install it if you wish.
Advanced Installation Tasks

This section includes instructions about how to perform a non-default installation, install this product as an upgrade, or about how to install the additional components.

The advanced installation tasks include:

- **Installing as an Upgrade** - included in these Release Notes
- **Command line installation options** - included in these Release Notes
- **Installing on Microsoft Terminal Server and Citrix** - available in the product Help and in the Micro Focus Infocenter


On Windows

Installing as an Upgrade

Installing this release as an upgrade will automatically uninstall any HotFixes of the older version of the product you have installed on your machine.

- Before installing this release as an upgrade, ensure you create a back-up of your Enterprise Server configuration. To do this, on the Enterprise Server Administration home page, click **Export** and then select **Export Enterprise Server configuration and Security Manager definitions**. This creates a backup folder in the `c:\programdata\micro focus\Enterprise Developer\MFDS`. You can restore the Enterprise Server configuration after installing this release - click **Import** on the Enterprise Server Administration home page.

Visual COBOL Installation Options

To install Visual COBOL you run `vcvs2017_30.exe` which contains a number of product `.msi` files (Windows Installer packages). When run, `vcvs2017_30.exe` performs some initial system checks then sequentially installs the `.msi` files.

**Note:** The following applies to `vcvs2012_30.exe` when installing the product for Visual Studio 2012. The following applies to `vcvs2013_30.exe` when installing the product for Visual Studio 2013. The following applies to `vcvs2015_30.exe` when installing the product for Visual Studio 2015.

`vcvs2017_30.exe` can take a number of parameters, enabling you to specify a number of different types of installation:

- **Standard Installation**
  
  **Format:**
  
  `vcvs2017_30.exe`

  **Summary:**
  
  Full installation including License Manager and Visual COBOL. During installation you can specify options including the location to which the components are installed.

- **Non-interactive Installation**
  
  **Format:**
  
  `vcvs2017_30.exe /passive`

  **Summary:**
Full installation, but the components are installed non-interactively using default options and directories.

- Silent Installation

**Format:**
vcvs2017_30.exe /q

**Summary:**
Full installation, but the components are installed non-interactively with no user interface, using default options and directories.

- Modified Silent Installation

**Format:**
vcvs2017_30.exe /q InstallFolder=d:\otherdirectory

**Summary:**
Full installation, but the components are installed non-interactively with no user interface, and Visual COBOL is installed to d:\otherdirectory.

To see what parameters you can use, execute the following from the command line:
vcvs2017_30.exe /?.

**Note:**
- Log files that are created during installation are saved in the folder specified by the TEMP environment variable. To change the location or name of the files, use the /log parameter on your setup command line and specify the path and file name, for example: filename /log d:\temp \log.txt. This creates a log file, named log.txt, in the d:\temp directory.

## Installing Visual COBOL into Several Editions of Visual Studio 2017

Visual Studio 2017 is offered in different editions, Professional, Enterprise or Community Edition, that can all co-exist on the same machine. When you install Visual COBOL, its setup file installs it into any edition of Visual Studio 2017 installed on the machine.

If, after Visual COBOL is installed, you install a different edition of Visual Studio 2017, you can use the MFVSIXINSTALL utility (available in the Visual COBOL installation directory) to plug Visual COBOL into that edition.

To install Visual COBOL in all editions of Visual Studio 2017:

1. Locate MFVSIXInstall.exe in %ProgramFiles(x86)%\Micro Focus\Visual COBOL\vsix.
2. Run MFVSIXInstall.exe.
   This starts the VSIX Installer utility that will install all the required components into the existing editions of Visual Studio 2017.
3. Click **Modify** in the VSIX Installer dialog box to start the installation.
4. Click **Close** when the installation is completed.

You can execute MFVSIXInstall.exe from the command line with different parameters. For example, to uninstall Visual COBOL from all editions of Visual Studio, execute MFVSIXInstall -u.

For a list of all parameters execute MFVSIXInstall -?.

## After Installing

- See Changes in Behavior or Usage in your product documentation and in the Release Notes for important information about changes in this release that might affect existing applications.
- Check the **Product Documentation** section of the Micro Focus SupportLine Web site and the Micro Focus Infocenter for any updates to the documentation which might have been uploaded.
On Windows

Starting the Product

You are now ready to run Visual COBOL:

**Windows 7 and Earlier**
- From your desktop, click **Start > All Programs > Micro Focus Visual COBOL > Visual COBOL for Visual Studio 2017**.
- From your desktop, click **Start > Visual Studio 2017**.

**Windows 8, 8.1, and Windows Server 2012**
- From the **Start** screen, click the **Visual COBOL for Visual Studio 2017** tile.
- Click the **Visual Studio 2017** tile.

**Windows 10 and Later**
- Click **Start > Micro Focus Visual COBOL > Visual COBOL for Visual Studio 2017**.
- Click **Start > Visual Studio 2017**.

Viewing the Product Help

To view the documentation installed with your product:

2. Ensure that the Visual Studio Help Library is pointing to local help - from the Visual Studio menu click **Help > Set Help Preferences > Launch in Help Browser**.
3. Click **Help > View Help**.
   This opens the product help in Microsoft's Help Viewer.

For full details of the Visual Studio Help system, see the MSDN.

If, after Visual COBOL was installed, you do not see its product help in the Help Viewer, you need to install the documentation manually as follows:

1. In Visual Studio 2017, ensure the Visual Studio Help Viewer is installed.
   See **Installing missing components of Visual Studio 2017** in Software Requirements for instructions on how to install it.
2. Start Visual Studio.
3. Click **Help > Add and Remove Content**.
   This starts the Microsoft Help Viewer.
4. Click the **Manage Content** tab and click **Disk**.
5. Click the browse button next to **Disk** and navigate to the %ProgramFiles(x86)\Micro Focus \Visual COBOL\Help folder.
6. Select **helpcontentsetup.msha** and click **Open**.
   This loads the Visual COBOL documentation.
7. Click **Add** and then **Update**.
   After the installation is complete, the Visual COBOL product Help appears in the Help Viewer.

**Note:** On some Windows versions such as Windows 8 or Windows Server 2012, an issue with Microsoft Help Viewer and Internet Explorer's security being turned on can cause the Help content to be displayed as raw HTML code. To resolve the issue, you need to turn off the Internet Explorer Enhanced Security Configuration (IE ESC) for both administrators and users. Check the Microsoft Windows help for more information on how to do this.
Repairing

If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.

Uninstalling

To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs in Control Panel.
3. Select the product and click Remove or Uninstall as appropriate.

When you uninstall, the only files deleted are those that the installation software installed. If the product directory has not been removed, delete any unwanted files and subdirectories within it using Windows Explorer.

Note: The installer creates separate installations for Micro Focus Visual COBOL and Micro Focus License Administration. Uninstalling only Visual COBOL does not automatically uninstall the Micro Focus License Administration or any of the prerequisite software.

To completely remove the product you must uninstall the Micro Focus License Administration as well.

You can optionally remove the prerequisite software. For instructions, check the documentation of the respective software vendor.

Some registry entries are not removed by the uninstallation process and you need to manually delete them.

The following folders might not be removed:

- The Micro Focus Product Name folder in the Start menu - you can delete it manually.
- %systemdrive%\Users\Public\Documents\Micro Focus - includes the binaries and the log files of the samples which you have built.
- %ProgramData%\Micro Focus - includes some data files used by the Micro Focus licensing system.
- %Program Files%\Micro Focus - you can delete it manually.

To silently uninstall the product, you need the setup file and you need to execute the following at the command line:

```
start /wait install-file.exe /quiet /uninstall
```

In addition, the following registry entries are not removed. These are created the first time that an Enterprise Server that has been enabled for performance monitoring starts up:

- Micro Focus Server\Performance\Active Servers
- Micro Focus Server\Performance\PerfIniFile
Licensing Information

Note:

- When you activate Visual COBOL Personal Edition, you can use it for a limited period of 365 days. After this period, you can either register a new Personal Edition license for 365 days or acquire a valid license either for a 30-day trial or full license of Visual COBOL in order to continue using the product.
- If you have purchased licenses for a previous release of this product, those licenses will also enable you to use this release.
- The latest version of the SafeNet licensing software is required. See the Software Requirements section in this document for more details.
- If you are unsure of what your license entitlement is or if you wish to purchase additional licenses, contact your sales representative or Micro Focus SupportLine.

To activate Visual COBOL Personal Edition

To activate Personal Edition:

1. Start Visual COBOL.

   If you have not installed a license for Visual COBOL, starting the IDE and trying to create a COBOL project opens the Micro Focus Visual COBOL Product Licensing dialog box. If you cancel this dialog box, you can invoke it again from Help > Micro Focus Product Help > Product Licensing.

2. Click I want to activate the free product.

3. Ensure that the email address used to register the product is in the Email address text entry field. If you haven’t registered your email address yet, click registration page and follow the instructions on that page.

4. Select one of the following options:

   Automatic Use this if you have Internet access.

   1. Click Activate License to activate your copy of Visual COBOL Personal Edition.

   Manual Use this if you are not connected to the Internet.

   1. Click Send email.

      This opens your default email client and creates a new email filled in with the details to send to Micro Focus about activating your copy of the free Personal Edition of the product.

      Note: If there is no mail client installed on your machine, click next to Send email, and click Display fields. You will be presented with a template that includes the email address, the subject and the contents of an email to send to Micro Focus using a mail client of your choice. Do not modify the details.

         You will receive a response email with details about your authorization request.

2. Paste the contents of the response email in the designated field in the Micro Focus Visual COBOL Product Licensing dialog box.

3. Click Activate License.
This displays a message confirming your request for authorization has been successful.

4. Click Close.

To request and activate a 30-day trial license for Visual COBOL

1. In the IDE, click Help > Micro Focus Product Help > Product Licensing.
   This opens the Micro Focus Visual COBOL Product Licensing dialog box.
2. Type your email address in the Email address text entry field.
   You need to use the same email address you used for the registration.
3. Select one of the following options:
   **Automatic** Use this if you have Internet access.
   1. Click Activate License to activate the trial license for Visual COBOL.
      **Important:** After clicking Finish, if you click the Cancel button in the progress dialog box to stop the activation process, the trial license might have registered on Micro Focus servers but not yet be registered on your machine. If you request a trial again then you can get a message saying that a trial license has already been used. If this happens, you should contact a Micro Focus Sales representative to obtain a new license.
      You can do this by sending an email to VCBuyNow@microfocus.com, or selecting Help > Micro Focus > Buy Now and using the contact options in the dialog box.
   **Manual** Use this if you are not connected to the Internet.
   1. Click Send email.
      This opens your default email client and creates a new email filled in with the details to send to Micro Focus about activating the trial license for Visual COBOL.
      **Note:** If there is no mail client installed on your machine, click next to Send email, and click Display fields. You will be presented with a template that includes the email address, the subject and the contents of an email to send to Micro Focus using a mail client of your choice. Do not modify the details.
   2. Send the email.
      You will receive a response email with details about your authorization request.
   3. Paste the contents of the response email in the designated field in the Micro Focus Enterprise Developer Product Licensing dialog box.
   4. Click Activate License.
      This displays a message confirming your request for authorization has been successful.
   5. Click Close.

After activation, you can see how many days your trial license has remaining by selecting Help > Micro Focus > Product Licensing, or by using Micro Focus License Administration.
To buy and activate a full unlimited license

To buy a license for Visual COBOL, contact your sales representative or Micro Focus SupportLine. For instructions on using the Micro Focus Licensing Administration Tool, see Licensing in the Visual COBOL help.

To start Micro Focus License Administration

Windows 7 and Earlier
• From your desktop, click Start > All Programs > Micro Focus License Manager > License Administration

Windows 8, 8.1, and Windows Server 2012
• From the Start screen, click the License Administration tile

Windows 10 and Later
• Click Start > Micro Focus License Manager > License Administration

Installing licenses

You need either a license file (with a .mflic extension) or an authorisation code which consists of a 16-digit string of letters and numbers.

If you have a license file

1. Start Micro Focus License Administration.
2. Click the Install tab.
3. Do one of the following:
   • Click Browse next to the License file field and select the license file (which has an extension of .mflic).
   • Drag and drop the license file from Windows Explorer to the License file field.
   • Open the license file in a text editor, such as Notepad, then copy and paste the contents of the file into the box below the License file field.
4. Click Install Licenses.

Alternatively, you can install the license file from within the IDE as follows:

1. Start Visual COBOL.
2. Click Help > Micro Focus Product Help > Product Licensing to open the Product Licensing dialog box.
3. Ensure I have a full Visual COBOL license is checked.
4. Click Browse next to the License file field.
5. Select the license file (which has an extension of .mflic), and then click Open.
6. Click Authorize to install the license.

You should see a dialog box with a confirmation that the licenses have been installed successfully.
If you have an authorization code

Authorizing your product when you have an Internet connection

Note:
• It is not possible to install licenses remotely. You must be logged into the machine on which you are installing the licenses.

The following procedure describes how to authorize your product using a local or network license server. The license server is set up automatically when you first install the product.

1. Start Micro Focus License Administration.
2. Click the Install tab.
3. Type the authorization code in the Enter authorization code field.
4. Click Authorize.

If you change the name of the machine running your license server after it has granted licenses, the licenses stop working.

Authorizing your product when you don't have an Internet connection

This method of authorization is required if the machine you want to license does not have an Internet connection or if normal (automatic) authorization fails.

1. Start Micro Focus License Administration.
3. Make a note of the contents of the Machine ID field. You will need this later.
4. Do one of the following:
   • If your machine has an Internet connection, click the SupportLine Web link in the Manual Authorization Information window.
   • If your machine does not have an Internet connection, make a note of the Web address and type it into a Web browser on a machine that has an Internet connection.

The Micro Focus SupportLine Manual product authorization Web page is displayed.
5. Type the authorization code in the Authorization Code field. The authorization code is a 16-character alphanumeric string supplied when you purchased your product.
6. Type the Machine ID in the Machine ID field.
7. Type your email address in the Email Address field.
8. Click Generate.
9. Copy the generated license string (or copy it from the email) and paste it into the box under the License file field on the Install page.
10. Click Install Licenses.

To obtain more licenses

If you are unsure of what your license entitlement is or if you wish to purchase additional licenses for Visual COBOL, contact your sales representative or Micro Focus SupportLine.
Updates and SupportLine

Our Web site gives up-to-date details of contact numbers and addresses.

Further Information and Product Support

Additional technical information or advice is available from several sources. The product support pages contain a considerable amount of additional information, such as:

- The *Product Updates* section of the Micro Focus SupportLine Web site, where you can download fixes and documentation updates.
- The *Examples and Utilities* section of the Micro Focus SupportLine Web site, including demos and additional product documentation.
- The *Support Resources* section of the Micro Focus SupportLine Web site, that includes troubleshooting guides and information about how to raise an incident.

To connect, enter `http://www.microfocus.com` in your browser to go to the Micro Focus home page, then click *Support & Services > Product Support*. In the *Browse by Product* field, click the product you require support for. Click *Log into SupportLine*.

**Note:** Some information may be available only to customers who have maintenance agreements.

If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web site, `www.microfocus.com`. If you obtained the product from another source, such as an authorized distributor, contact them for help first. If they are unable to help, contact us.

Also, visit:

- The Micro Focus Community Web site, where you can browse the Knowledge Base, read articles and blogs, find demonstration programs and examples, and discuss this product with other users and Micro Focus specialists. See `http://community.microfocus.com`.
- The Micro Focus YouTube channel for videos related to your product - see `https://www.youtube.com/user/MicroFocusIntl`.

Information We Need

However you contact us, please try to include the information below, if you have it. The more information you can give, the better Micro Focus SupportLine can help you. But if you don’t know all the answers, or you think some are irrelevant to your problem, please give whatever information you have.

- The name and version number of all products that you think might be causing a problem.
- Your computer make and model.
- Your operating system version number and details of any networking software you are using.
- The amount of memory in your computer.
- The relevant page reference or section in the documentation.
- Your serial number. To find out these numbers, look in the subject line and body of your Electronic Product Delivery Notice email that you received from Micro Focus.

On Windows, if you are reporting a protection violation you might be asked to provide a dump (.dmp) file. To produce a dump file you use the *Unexpected Error* dialog box that is displayed when a protection violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as *Normal*.
(recommended), click **Dump**, then specify a location and name for the dump file. Once the dump file has been written you can email it to Micro Focus SupportLine.

Alternatively, you might be asked to provide a log file created by the Consolidated Tracing Facility (CTF) - a tracing infrastructure that enables you to quickly and easily produce diagnostic information detailing the operation of a number of Micro Focus software components.

On Windows, you can use the Micro Focus SupportLine Support Scan Utility, MFSupportInfo, to create either:

- a **.log** file that contains the details about your environment, Micro Focus SupportLine products, and settings.
- a **.zip** archive that includes the same information as the **.log** file plus some product configuration files from `c:\ProgramData` and the product installation log files.

MFSupportInfo.exe is stored in `<install-dir>\bin`.

To run MFSupportInfo:

1. Start a 32-bit Enterprise Developer command prompt.
2. Enter `MFSupportinfo` at the command prompt to start the utility.
3. Create a **.log** file or a **.zip** archive as follows:
   
   **a.** To create a **.log** file, click **File > Save**.
   
   This prompts to save the **.log** file, MFSupportInfo_Log_MachineName_YYYY-MM-DD_HH-MM-SS.log, in the `%temp%` directory.

   **b.** To create a **.zip** archive, click **Tools > Create Zip Package**.
   
   This creates a **.zip** archive, MFSupportInfo_Log_MachineName_YYYY-MM-DD_HH-MM-SS.zip, in the `%temp%` directory.

4. Send the diagnostic information to your Micro Focus SupportLine representative:
   
   The following requires an Internet connection and an Email client:
   
   **a.** Click **Tools > Email Log to SupportLine** to open the Email Log dialog box.
   **b.** Fill in the required fields and click **Send**.

   If the machine is not connected to the Internet or if there are no Email clients installed, copy either the **.log** file or the **.zip** archive to a machine that is connected to the Internet. Use your Email client to email the files to Micro Focus SupportLine at `supportline@microfocus.com` together with the Support Incident (SI) number, if available, and any additional details that might be useful to diagnose the issues that you are experiencing.

### Creating Debug Files

If you encounter an error when compiling a program that requires you to contact Micro Focus SupportLine, your support representative might request that you provide additional debug files (as well as source and data files) to help us determine the cause of the problem. If so, they will advise you how to create them.
Copyright © Micro Focus 2017. All rights reserved.

The only warranties for this product and any associated updates or services are those that may be described in express warranty statements accompanying the product or in an applicable license agreement you have entered into. Nothing in this document should be construed as creating any warranty for a product, updates, or services. The information contained in this document is subject to change without notice and is provided “AS IS” without any express or implied warranties or conditions. Micro Focus shall not be liable for any technical or other errors or omissions in this document. Please see the product’s applicable end user license agreement for details regarding the license terms and conditions, warranties, and limitations of liability.

Any links to third-party websites take you outside Micro Focus websites, and Micro Focus has no control over and is not responsible for information on third party sites.