Optimal Trace Enterprise and Professional Installation and Configuration Guide
Release 5.1

Restricted Rights Notice
This document and the product referenced in it are subject to the following legends:

Access is limited to authorized users. Use of this product is subject to the terms and conditions of the user’s License Agreement with Compuware Corporation.

© 2001–2008 Compuware Corporation. All rights reserved. Unpublished – rights reserved under the Copyright Laws of the United States.

U.S. GOVERNMENT RIGHTS-Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in Compuware Corporation license agreement and as provided in DFARS 227.7202-1(a) and 227.7202-3(a) (1995), DFARS 252.227-7013(c)(1)(ii)(OCT 1988), FAR 12.212(a) (1995), FAR 52.227-19, or FAR 52.227-14 (ALT III), as applicable. Compuware Corporation.

This product contains confidential information and trade secrets of Compuware Corporation. Use, disclosure, or reproduction is prohibited without the prior express written permission of Compuware Corporation.

Trademarks
© 2008 Compuware Corporation. Optimal Trace™ is a registered trademark of Compuware. All rights reserved. All other trademarks are the property of their respective owners.
1 PREFACE .................................................................................................................. 4
   1.1 Audience .............................................................................................................. 4
   1.2 Conventions used in this document ..................................................................... 4
   1.3 Contacting Optimal Trace Customer Support .................................................... 5

2 SYSTEM REQUIREMENTS ...................................................................................... 6
   2.1 System Requirements for Optimal Trace Professional ....................................... 6
   2.2 System Requirements for Optimal Trace Enterprise .......................................... 6
   2.3 System Requirements for Optimal Trace Server ................................................ 7
   2.4 Prerequisites ....................................................................................................... 7

3 INSTALLING OPTIMAL TRACE™ ENTERPRISE ............................................... 8
   3.1 Optimal Trace Document Import tool installation tips ....................................... 8

4 INSTALLING OPTIMAL TRACE PROFESSIONAL ............................................. 10

5 CONFIGURING THE .LAP AND .CONF FILES .................................................. 11

6 TO UNINSTALL OPTIMAL TRACE ENTERPRISE AND PROFESSIONAL .......... 13

7 UPGRADING FROM OPTIMAL TRACE SERVER 4.1 TO OPTIMAL TRACE SERVER 5.0 14

8 UPGRADING FROM OPTIMAL TRACE 5.0 TO OPTIMAL TRACE 5.1 LOCAL PROJECTS ........................................................................................................... 15

9 MIGRATING FROM OPTIMAL TRACE 5.0 TO OPTIMAL TRACE 5.1 REMOTE PROJECTS ............................................................................................................. 16
   9.1 Backup your data ............................................................................................... 16
      9.1.1 Backing up MySQL Database ...................................................................... 16
      9.1.2 Backing up Oracle 9i Database ..................................................................... 17
      9.1.3 Backing up MS SQL Server 2000/2005 Database ....................................... 17
      9.1.4 Taking Projects ‘offline’ in Optimal Trace™ Enterprise ............................... 19
   9.2 Stop the 5.0 Server ............................................................................................. 19
   9.3 Install Optimal Trace Server 5.1 ......................................................................... 21
   9.4 Create Databases for Optimal Trace 5.1 ............................................................ 21
   9.5 Run Optimal Trace Server 5.1 ............................................................................ 21
   9.6 Running the Migration Utility ............................................................................ 21

10 INSTALLING MYSQL .............................................................................................. 23
   10.1 Obtaining MySQL ............................................................................................. 23
   10.2 Installing MySQL ............................................................................................. 23
      10.2.1 Uninstalling MySQL .................................................................................. 26

11 CONFIGURING ORACLE ...................................................................................... 27
   11.1 Prerequisites .................................................................................................... 27
   11.2 Setting up the Oracle database ......................................................................... 27

12 CONFIGURING MICROSOFT SQL SERVER ...................................................... 29
   12.1 Prerequisites .................................................................................................... 29
   12.2 Setting up the SQL Server database ................................................................. 29
   12.3 Removing the Optimal Trace database ............................................................. 31
12.4 MS SQL Server Notes ................................................................. 31
12.4.1 mssqlserver_Optimal Trace_install.sql ........................................ 32
12.4.2 SQL Server Enterprise Manager .................................................. 32
12.4.3 Other SQL Server utilities ......................................................... 32

13 INSTALLING OPTIMAL TRACE SERVER .............................................. 34
13.1 Installing Optimal Trace™ Server .................................................... 34
13.1.1 Uninstalling Optimal Trace™ Server ............................................ 34

14 RUNNING OPTIMAL TRACE™ SERVER ............................................... 36
14.1 Starting Optimal Trace™ Server ....................................................... 36
14.1.1 Stopping the Optimal Trace™ Server ............................................ 38
14.1.2 Configuring the Optimal Trace™ Server as a windows service .......... 38
14.1.3 Stopping the Optimal Trace™ windows service ............................. 38
14.2 Optimal Trace™ Email Configuration .............................................. 40
14.2.1 Example Email Configuration using GMail .................................. 41
14.3 Optimal Trace™ Server Advanced Configuration .............................. 42

15 RUNNING OPTIMAL TRACE ENTERPRISE ......................................... 44
15.1 Connecting to Optimal Trace Enterprise Server ................................. 44
15.2 Starting Optimal Trace Enterprise .................................................... 44
15.2.1 Server Settings ............................................................................ 44
15.3 User Support in Optimal Trace Enterprise ....................................... 46
15.4 Configuring Optimal Trace™ Enterprise to work through a Optimal Trace™ Server 46

16 LICENSING AND UPGRADING OPTIMAL TRACE™ ENTERPRISE ................. 47
16.1 Evaluating Optimal Trace Enterprise ............................................... 47
16.2 Licensing the application fully or using an extended evaluation license key........ 47
16.3 Upgrading from a previous release .................................................. 47

17 LICENSING AND UPGRADING OPTIMAL TRACE™ PROFESSIONAL .......... 48
17.1 Evaluating Optimal Trace Professional ............................................. 48
17.2 Licensing the application fully or using an extended evaluation license key .... 48
17.3 Upgrading from a previous release ................................................... 48
1 Preface

Optimal Trace is a requirements capture, documentation and modeling suite for teams of Business Analysts, Systems Analysts, Software Architects/Designers, QA Leads, QA Testers, and Project Managers.

It provides an easy to deploy, intuitive interface for capturing, viewing, and managing customer requirements and a sophisticated collaboration mechanism that enables multiple analysts to work concurrently on one or more projects.

There are two versions of Optimal Trace: Enterprise and Professional. Optimal Trace Professional is a streamlined version of Optimal Trace Enterprise and works from the desktop. Whereas, Optimal Trace Enterprise is a fully functional version of Optimal Trace for multiple users that uses the benefits of a server.

The Optimal Trace Server provides access to a centralized repository of Optimal Trace Enterprise projects and manages communication between multiple Optimal Trace Enterprise users. A computer that hosts the Optimal Trace Server software is referred to as a Repository Server.

The Optimal Trace Server controls access to the database, manages concurrent editing of projects by multiple users, and ensures the integrity of data being written to the database. If you wish to make use of the collaboration features in Optimal Trace, you will need at least one repository server on the network.

Optimal Trace Server requires a dedicated server machine on the network to act as the Optimal Trace Server repository server. This machine should be connected to the network and should be accessible from every workstation on which you will be running Optimal Trace Enterprise. Optimal Trace Server connects to a database running locally on the repository server or on another machine available on the network.

1.1 Audience

This document is suitable for administrators installing and configuring the product.

1.2 Conventions used in this document

The conventions used in this document are:

- **Notes** are used to highlight certain aspects of functionality which may be of interest, for example:
  
  **Note:** This is a sample note.

- **Tips** are used to highlight aspects typically associated with process usage which may be of interest in certain usage scenarios, for example:

  **Tip:** This is a sample tip.
1.3  Contacting Optimal Trace Customer Support

For all technical problems and support queries, please logon to frontline at http://frontline.compuware.com. Frontline contains the Optimal Trace forum as well as an FAQ area. Additionally, current release information and contact numbers are provided.

At Compuware, we strive to make our products and documentation the best in the industry. An important part of this effort is the feedback we receive from our customers. For product issues, please be sure to have the following information accessible before calling Compuware’s 24-hour Product Support Hotline:

- The version of Optimal Trace you are using, which is displayed in the About dialog box of Optimal Trace.
- The version of each operating system(s) in which each product component is installed.
- The place in the Optimal Trace software where the problem occurred and the steps taken before the problem occurred.
- The exact Optimal Trace error message, if any.
- System error messages, if any.

Please contact the appropriate Compuware office:

**Compuware North America**
Compuware Corporate Headquarters
One Campus Martius
Detroit, MI 48226-5099
USA
Telephone: (313) 227-7300
Customer Support Hotline: (800) 538-7822

**Compuware United Kingdom**
Compuware Ltd.
163 Bath Road
Slough, Berkshire SL1 4AA
United Kingdom
Telephone: +44 1753 774 000
Facsimile: +44 1753 774 200

**Compuware International Operations**
Compuware Corporate Headquarters
One Campus Martius
Detroit, MI 48226-5099
USA
Telephone: (313) 227-7300

5 Optimal Trace Installation and Configuration Guide
2 System Requirements

The following section provides system requirements for Optimal Trace.

2.1 System Requirements for Optimal Trace Professional

System requirements for Optimal Trace Professional:

- Pentium 4-class processor or equivalent
- 256 MB of RAM
- 150 MB of available hard disk space
- Microsoft Windows 2000, XP, 2003, or Vista
- Microsoft Project 2000 or 2002
- Enterprise Architect 6.5
- Citrix Presentation Server 4.0 with service pack 2005.04
- Citrix Client 8.0, 9.0, 9.15, or 9.23

**Note:** Optimal Trace does not support Citrix Client 9.20 since there are known issues with running Java applications.

- Adobe Acrobat Reader for help files

2.2 System Requirements for Optimal Trace Enterprise

System requirements for Optimal Trace Enterprise:

- Pentium 4-class processor or equivalent
- 256 MB of RAM
- 175 MB of available hard disk space
- Microsoft Windows 2000, 2003, XP, or Vista
- Microsoft Project 2000 or 2002
- Enterprise Architect 6.5
- Citrix Presentation Server 4.0 with service pack 2005.04
- Citrix Client 8.0, 9.0, 9.15, or 9.23

**Note:** Optimal Trace does not support Citrix Client 9.20 since there are known issues with running Java applications.
• Adobe Acrobat Reader for help files

2.3 System Requirements for Optimal Trace Server

• Pentium 4-class processor or equivalent
• 512 MB of RAM (minimum)
• 250 MB of available hard disk space
• Adobe Acrobat Reader for Optimal Trace™ Server Help Files
• MySQL Version 4.1 or 5.0 or
• Oracle 9i Release 2, 10g Release 2, or 11g Release 1, or
• Microsoft SQL Server 2000 (SP4), Microsoft SQL Server 2005

**Note:** There is a known issue with MySQL version 5.0.42, which should be resolved for future MySQL releases. Optimal Trace Enterprise 5.1 does not support MySQL 5.0.42 and recommends using 5.0.37.

2.4 Prerequisites

If User Access Control (UAC) feature is enabled, you must ensure that you have elevated privileges prior to installing Optimal Trace Enterprise, Optimal Trace Server, or Optimal Trace Professional.
3 Installing Optimal Trace™ Enterprise

Optimal Trace Enterprise requires 175mb free disk space. To install Optimal Trace:

**Note:** If using Windows Vista, you must have administrator permissions.

1. Navigate to Optimal Trace on the installation media. Click the version of Optimal Trace to install. The Open File dialog box appears.
2. Click **Open**. The Installation Wizard appears.
3. Click **Next**. The License Agreement screen appears.
4. Accept the agreement and click **Next**. The Customer Information screen appears.
5. Type a name in the **User Name** field and a company name in the **Organization** field.
6. Click **Next**. The Destination Folder screen appears.
7. Click **Change** to choose a destination folder or click **Next** to accept the default folder. If changing the destination folder, the Change Current Destination Folder screen appears. Browse or type a new directory and click **OK**. The Destination Folder reappears. Click **Next**. The Ready to Install the Program screen appears.
8. Click **Install**. The Installation Status screen appears.
9. Click **Next** after the installation completes. The Installation Complete screen appears.
10. Click **Finish**.
11. Install the Document Import Tool. For more information, refer to Optimal Trace Document Import tool installation tips.
12. Install the Optimal Trace Server. For more information, refer to Installing Optimal Trace Server.

3.1 Optimal Trace Document Import tool installation tips

Optimal Trace contains a document import tool which enables the user to mark up word documents and import them into Optimal Trace. This tool uses a plug-in in Microsoft Word. In order to use this plug-in, a dll file must be registered. This file will be registered automatically when Optimal Trace is installed. If you are experiencing difficulty running the document import tool it may because the plug-in is not registered correctly. to register the tool manually:

**Note:** If using Windows Vista, you must have administrator permissions.

1. Shut down Word and Outlook.
2. Shutdown any **Winword.exe** processes that may be running using the Task Manager.
3. Choose **Start>Run**. The Run dialog box appears.
4. Type **cmd** in the **Open** field, and click the **<Return>** key. The Command Prompt dialog box appears.
5. At the command prompt change directory to the Optimal Trace installation folder. For example, `cd c:\Program Files\Compuware\Optimal Trace Enterprise Edition`.

6. At the command prompt type `regsvr32 OptimalTraceWordDocImport.dll`. **Note:** To use the import tool for many users on a single machine, register the `.dll` for each user that logs onto the machine.
4 Installing Optimal Trace Professional

Optimal Trace Professional requires 150mb free disk space. To install Optimal Trace:

**Note:** If using Windows Vista, you must have administrator permissions.

1. Navigate to Optimal Trace on the installation media. Click the version of Optimal Trace to install. The Open File dialog box appears.
2. Click **Open**. The Installation Wizard appears.
3. Click **Next**. The License Agreement screen appears.
4. Accept the agreement and click **Next**. The Customer Information screen appears.
5. Type a name in the **User Name** field and a company name in the **Organization** field.
6. Click **Next**. The Destination Folder screen appears.
7. Click **Change** to choose a destination folder or click **Next** to accept the default folder. If changing the destination folder, the Change Current Destination Folder screen appears. Browse or type a new directory and click **OK**. The Destination Folder reappears. Click **Next**. The Ready to Install the Program screen appears.
8. Click **Install**. The Installation Status screen appears.
9. Click **Next** after the installation completes. The Installation Complete screen appears.
10. Click **Finish**.
5 Configuring the .lap and .conf Files

If User Access Control feature is enabled and the user does not have elevated privileges, the installation will fail to configure several files. If the installation fails, the following files must be configured according to the edition of Optimal Trace installed. The Optimal Trace edition is noted next to the files affected.

- Optimal Trace Server.lap (Server Edition)
- Optimal Trace Admin Tool.lap (Enterprise & Server Edition)
- Optimal Trace Migration Utility.lap (Server Edition)
- Optimal Trace Professional.lap (Professional Edition)
- Optimal Trace Enterprise.lap (Enterprise Edition)
- Optimal Trace Command Line Report.lap (Enterprise Edition)
- Wrapper.conf (Server Edition)

To configure the .lap files:

1. In Windows Explorer, navigate to the installation directory. For example, the default installation directory is C:\Program Files\Optimal Trace Enterprise.
2. Select one of the .lap files to configure and open with a text editor.
3. Search for the placeholder called DLMLOCPLACEHOLDER.
4. Replace the placeholder with <COMMONFILES>\Compuware where <COMMONFILES> is the DLM installation path. For example, the default is C:\Program Files\Common Files\Compuware.
5. Search for the placeholder called DLMJARPLACEHOLDER.
6. Replace the placeholder with <COMMONFILES>\Compuware\DLM40JNI.jar where <COMMONFILES> is the DLM installation path. For example, the default is C:\Program Files\Common Files\Compuware\DLM40JNI.jar.
7. Repeat steps 3 through 6 for the remaining .lap files.

To configure the Wrapper.conf file:

1. In Windows Explorer, navigate to the installation directory. For example, the default installation directory is C:\Program Files\Optimal Trace Server.
2. Select the Wrapper.conf file.
3. Open the Wrapper.conf file in a text editor.
4. Search for the placeholder called SERVICELOGPLACEHOLDER.
5. Replace the placeholder with <ALLUSERSPROFILE>\Application Data\Compuware\Optimal Trace Server\5.1\service.log. For example, the default is C:\Documents and Settings\All Users\Application Data\Compuware\Optimal Trace Server\5.1\service.log.
6. Search for the placeholder called DLMLOCPLACEHOLDER.
7. Replace the placeholder with <COMMONFILES>\Compuware where <COMMONFILES> is the DLM installation path. For example, the default is C:\Program Files\Common Files\Compuware.
8. Search for the placeholder called DLMJARPLACEHOLDER.

9. Replace the placeholder with \<COMMONFILES>\Compuware\DLM40JNI.jar where \<COMMONFILES> is the DLM installation path. For example, the default is C:\Program Files\Common Files\Compuware\DLM40JNI.jar.
6 To Uninstall Optimal Trace Enterprise and Professional

To uninstall Optimal Trace:

**Note:** If using Windows Vista, you must have administrator permissions.

1. Click **Start>Programs>Compuware>Optimal Trace X 5.1>Uninstall.** Where X is **Enterprise, Professional,** or **Server.**
2. Select Optimal Trace Professional, Optimal Trace Enterprise, or Optimal Trace Server and click **Remove.**

**Never** uninstall by deleting files. This may prevent future installations of Optimal Trace from working.

Uninstalling Optimal Trace will leave project files, generated documents and change logs on your hard disk. This allows you to preserve any previously created project documentation if migrating to a new version of Optimal Trace.
7 Upgrading from Optimal Trace Server 4.1 to Optimal Trace Server 5.0

If using an version of Optimal Trace earlier than 5.0, migrate your database to 5.0, then proceed to the Optimal Trace 5.0 to Optimal Trace 5.1 migration. Refer to the Optimal Trace 5.0 Server Users Guide for more information.

Note: If using Windows Vista, you must have administrator permissions.
8 Upgrading from Optimal Trace 5.0 to Optimal Trace 5.1 Local Projects

When attempting to open an Optimal Trace 5.0 local project in Optimal Trace 5.1, you will receive a message asking you to confirm that you want to migrate your data:

Click **Yes** to open the project in Optimal Trace 5.1.

When you click the **Save** icon or you choose **File>Save**, the project is migrated from Optimal Trace 5.0 to Optimal Trace 5.1.

**Note:** It can take several hours to migrate your data from 5.0 to 5.1 format, depending on how big your database is. It may be best to perform this operation overnight.
9 Migrating from Optimal Trace 5.0 to Optimal Trace 5.1 Remote Projects

When migrating Optimal Trace 5.0 to Optimal Trace 5.1, the following custom objects will automatically copy from Optimal Trace 5.0 to Optimal Trace 5.1:

- Custom Project Templates
- Custom Document Profiles
- Custom Queries
- Custom Reports

**Note:** If User Access Control (UAC) feature is enabled, you must have elevated privileges for these objects to automatically copy. If you do not have appropriate Windows privileges, the objects will not copy.

The following user settings will not transfer:

- Custom spell check dictionaries
- Export profiles
- General Options settings

Additionally, Compuware strongly recommends backing up your 5.0 database as a precautionary measure.

The following instructions will help you through the full upgrade procedure from 5.0 to 5.1. Note that you should **not** remove 5.0 before installing 5.1. Only perform that step after your 5.1 server is up and running.

9.1 Backup your data

It is vital that you backup your data before upgrading from 5.0 to 5.1.

Backup your database, take important projects offline, and save them locally on your hard disk. It is important to backup your old data as it can take many hours to migrate your old Optimal Trace data, which could be interrupted by machine or network errors during this time, leaving your data in a half migrated state.

9.1.1 Backing up MySQL Database

To backup the MySQL database:

1. Open a Command Prompt.
2. Change directory to c:\mysql\bin or wherever MySQL is installed.
3. Type `mysqldump -q catalyze3 > c:\temp\OptimalTrace-data-backup.sql`.

**Note:** You may need user/password included in the command line for this.
This creates a backup file called **OptimalTrace-data-backup.sql** in the c:\temp\ directory. You can move this somewhere else for safe keeping.

### 9.1.2 Backing up Oracle 9i Database

Creating a backup of your Catalyze3 tablespace in Oracle is beyond the scope of this document. Please contact your Oracle Database Administrator or refer to Oracle documentation.

**Note:** to avoid a potential problem with Oracle's OPEN_CURSORS setting that you may encounter when migrating, it is best to set this Oracle setting now. To do this, change the value of OPEN_CURSORS to 20000 in the following files:

- init.ora in <oracle_install_dir>\admin\OEMREP\pfile
- init.ora in <oracle_install_dir>\admin\Oracle\pfile
- init.ora in <oracle_install_dir>\admin\prod\pfile

And then reboot the machine. For more information on this Oracle issue, see: http://www.praetoriate.com/oracle_tips_mamt_parameter_file.htm.

### 9.1.3 Backing up MS SQL Server 2000/2005 Database

To backup MS SQL Server database:

1. Launch Enterprise Manager from the Microsoft SQL Server Start menu.
2. Navigate to the catalyze3 database.

3. Choose **Tools>Backup Database**.
4. Modify the configuration as needed.
5. Click **OK**.
9.1.4 Taking Projects 'offline' in Optimal Trace™ Enterprise

To take your important projects offline in Optimal Trace:

1. Open the older version of Optimal Trace Enterprise from the Start menu.
2. Open the remote projects that you want to take offline.
3. Choose Project>Download Repository Project to Local Project or click icon on the toolbar.
4. Type a filename for the project.
5. Click Save.

9.2 Stop the 5.0 Server

Stop the Optimal Trace Enterprise 5.0 server. If the server is running from the GUI, click Stop. If 5.0 server is running as a windows service, stop it as follows:

2. Navigate to Optimal Trace Enterprise Server 5.0.
3. Right-click and choose **Properties** from the menu.

4. Stop the service if it is running.
9.3 Install Optimal Trace Server 5.1

Install Optimal Trace Server 5.1:

1. From the installation media, navigate to the Optimal Trace Server installation directory.
2. Double-click `Optimal_Trace_Server_Install.exe` to start the installation process.
3. Follow the instructions, and click Next to proceed to the next installation step.
4. After completing the wizard steps, click Finish to install.
5. After the installation is complete, Choose Start>Programs>Compuware>Optimal Trace Server to launch Optimal Trace Server.

9.4 Create Databases for Optimal Trace 5.1

Refer to the respective database tool for information about creating databases. For MySQL, refer to Installing MySQL. For Oracle, refer to Configuring Oracle. For SQL, refer to Configuring Microsoft SQL Server.

9.5 Run Optimal Trace Server 5.1

To start the server, click Start.

9.6 Running the Migration Utility

Create a new Optimal Trace 5.1 database, but do not start the server against it. Perform the migration first.

To migrate the database:
1. Choose **Start>Programs>Compuware>Optimal Trace Server 5.1>Database Migration Tool.** The Database Migration Tool appears.

![Database Migration Tool interface](image)

2. Type the database host name in the Database Host Name field.
3. Select the database type (MySQL, SQLSERVER, or Oracle) from the Database Type field.
4. Type the database port number if not using the default port in the Database Port field.
5. Type the 5.0 database name in the Database Name field under the From Database section.
6. Type a 5.0 database user name and password in the appropriate fields under the From Database section.
7. Type the 5.1 database name in the Database Name field under the To Database section.
8. Type a 5.1 database user name and password in the appropriate fields under the To Database section.
9. Click Migrate.

**Note:** It can take several hours to migrate your data from 5.0 to 5.1 format, depending on how big your database is. It may be best to perform this operation overnight.
10 Installing MySQL

MySQL is a popular open source database. Full details can be found at http://www.mysql.com.

10.1 Obtaining MySQL

MySQL version 5.0 software can be downloaded from the MySQL site.

**Note:** Optimal Trace Enterprise 5.1 does not support MySQL 5.0.42 and recommends using 5.0.37.

When finished downloading, you should have the MySQL installation file: `mysql-5.0.X-win.zip`, where X is the minor version number. For example, `mysql-5.0.37-win32.zip`.

10.2 Installing MySQL

To install MySQL:

1. If running an earlier version of MySQL, shut down the service before upgrading. Type `NET STOP mysql` at a command prompt to shut down the service.
2. Unzip `mysql-5.0.37-win32.zip` to a directory. For example, C:\Mysql.
3. Run setup.exe from the directory. For example, C:\Mysql.
4. When prompted for installation type, choose Typical.
5. When finished installing, set up MySQL as a Windows service. To install MySQL on NT/Win2000 as a service:
   a. Create a file named `my.cnf`, which must reside in the root drive where the MySQL installation has been placed. For example, if you installed to c:\mysql then the my.cnf file would be located at c:\my.cnf. If you installed to an e: drive, then the cnf file would be located at: e:\my.cnf.
   b. Place the following entries into the my.cnf file:

```ini
# The MySQL server
[mysqld]
basedir=c:/mysql
datadir=c:/mysql/data
set-variable = max_allowed_packet=100M

innodb_data_file_path = ib:200M:autoextend
innodb_data_home_dir=c:/mysql/ibdata
set-variable = innodb_mirrored_log_groups=1
innodb_log_group_home_dir=c:/mysql/iblogs
set-variable = innodb_log_files_in_group=3
set-variable = innodb_log_file_size=30M
set-variable = innodb_log_file_size=8M
innodb_flush_log_at_trx_commit=1
innodb_log_arch_dir=c:/mysql/iblogs
innodb_log_archive=0
set-variable=innodb_buffer_pool_size=80M
set-variable=innodb_additional_mem_pool_size=10M
set-variable=innodb_file_io_threads=4
```

23 Optimal Trace Installation and Configuration Guide
set-variable=innodb_lock_wait_timeout=50

**Note:** Optimal Trace Server ships a sample MySQL configuration file, called `my.cnf.txt`, which can be found after you install Optimal Trace Server, in the Scripts folder in your Optimal Trace Server installation folder. You can copy this file to the root drive and rename it to `my.cnf`.

To edit a file’s extension string (e.g. `.txt`) using Windows Explorer:
- In Windows, choose **Tools > Folder Options > View.**
- Uncheck **Hide file extensions for known file types.**
- Rename the file to remove `.txt` from the file name.

For the file name example above, `my.cnf.txt`, Windows may hide the string `.cnf` and the file name may appear simply as `my`.

For information on Installing Optimal Trace Server see Section 13.

MySQL also ships with a sample `.cnf` file called: 'my-example.cnf'. This file contains many other additional parameters that can be configured for MySQL. See [http://www.mysql.com/documentation/index.html](http://www.mysql.com/documentation/index.html) if you want to understand these settings. If you have any problems, you can mail to win32@lists.mysql.com. The MySQL mailing list archive is at: [http://www.mysql.com/documentation/index.html](http://www.mysql.com/documentation/index.html)

6. If the installed version of MySQL requires transactional tables to be manually enabled then you must create two sub-directories in the MySQL install directory. Name the newly created directories `ibdata` and `iblogs`. Your Mysql directory structure should now look something like the following:
7. To complete the procedure for installing MySQL as a service on Windows 2000 use a command window by choosing Start>Programs>Accessories>Command Prompt or invoke cmd.exe. Windows 98 users please invoke command.exe, and change the directory to your MySQL installation folder (e.g. c:\mysql\bin) and run:

   mysqld-max-nt --install

   ‘--install’ means mysqld-max-nt expects a parameter

Upon successful installation Service successfully installed will appear on the screen.

Note: mysqld-max is used because it provides support for symbolic links, BDB tables and InnoDB tables. This allows the use of transactional tables, which are used by Optimal Trace Server.

8. Now that MySQL is installed as a service it can be started and stopped, from anywhere on the command screen, using the NET command as follows:

   NET START mysql

Upon a successful start The MySQL service was started successfully message appears on the screen.

   NET STOP mysql

MySQL may take 5 minutes to stop. When it successfully stops, The MySQL service was stopped successfully message appears.

MySQL can also be started from the Services directory by choosing Start>Settings>Control Panel>Administrative Tools>Services>MySQL.

9. Start mysql:

   NET START mysql
When MySQL starts successfully, **The MySQL service was started successfully** message appears on the screen.

Run the following scripts from the command prompt to create the Optimal Trace database and server tables:

1. Move to location where you have installed Optimal Trace Server and copy `mysql_OptimalTrace_install.sql` from the `<ENTERPRISE_SERVER_INSTALL_DIR>\scripts` directory into your `<MySQL install directory>\scripts`.

2. Type the following line to create the database tables:

   ```
   C:\MySql\bin>mysql -uroot < ..\scripts\mysql_Optimal Trace_install.sql
   ```

   Upon successful completion there will be no response, only the prompt `C:\Mysql\bin`.

   **Note:** By default the root user has no password so the above command should work without modification. If the root user’s password has been modified then you will get the following error message:

   ```
   ERROR 1044 at line 1: Access denied for user: '@localhost' to database 'OptimalTrace'
   ```

   If this is the case, an additional password argument must be supplied after the user name. For example,

   ```
   C:\MySql\bin>mysql -uroot -ppassword < ..\scripts\mysql_Optimal Trace_install.sql
   ```

You now have a user with SELECT, INSERT, UPDATE and DELETE privileges on the 'OptimalTrace' database with username ‘OptimalTrace’ and password ‘password’.

Now that you have set up your Optimal Trace Server database, it is time to start the Optimal Trace™ Server application. For a complete description of how to start Optimal Trace Server, see Section 14 Running Optimal Trace™ Server.

### 10.2.1 Uninstalling MySQL

To uninstall MySQL:

1. Choose **Start>Settings>Control Panel>Add/Remove Programs** and click on the version of MySQL to remove.

2. Click **Change/Remove** and an Install Anywhere Uninstaller screen will appear.

3. Click **Uninstall**. This will completely remove all components installed. It will not remove files and folders created after the installation.

   **Note:** Do not attempt to uninstall MySQL by deleting files or folders as this could create problems later.
11 Configuring Oracle

This section details the steps involved in configuring Optimal Trace Server with Oracle.

**Note:** This section is targeted at Oracle database administrators with Windows 2000/NT administration knowledge.

11.1 Prerequisites

The Oracle software is installed. This includes setting up various environment variables unique to your operating system and establishing the directory structure for software and database files.

You need to have the operating system privileges associated with a fully operational database administrator. You must be specially authenticated by your operating system or through a password file, allowing you to start up and shut down an instance before the database is created or opened.

Ensure that there is sufficient memory available to start the Oracle instance, and that there is sufficient disk storage space for the planned database on server.

11.2 Setting up the Oracle database

You can either setup a new Oracle database explicitly for Optimal Trace or reuse an existing database. Setting up an Oracle database is beyond the scope of this document, so to do so, refer to your Oracle system administrator or to Oracle documentation. The rest of these instructions assume that you already have an Oracle database called **OptimalTrace**.

When setting up a new database instance or if reusing an existing database, change the following settings in the Character Set tab of the Wizard:

- Select Use Unicode (AL32UTFR) checkbox.
- Select UTF8-Unicode 3.0 OTF8 Universal Character Set from the National Character Set drop-down list.

The Optimal Trace Server installation **Scripts** directory contains the scripts needed to create tablespaces, tables, and user. Copy the scripts from here to Oracles default location, **ORACLE_HOME\database** on Windows.

To set up the Optimal Trace database objects:

Start SQL*Plus and connect to your Oracle instance AS SYSDBA:

```
SQL> CONNECT SYS/password AS SYSDBA
```
You already have a database set up, so you need to create a tablespace, tables, indexes, sequences and a user. From SQL*Plus command line type:

```
SQL> @"ENTERPRISE_SERVER_INSTALL_DIR \scripts\ oracle_Optimal Trace_install.sql"
```

This script will create a table space for your Optimal Trace Server called **OptimalTrace**, as well as user **OptimalTrace** with password **password**. You can change this username and password when the Optimal Trace Server database is fully set up.

Start the Optimal Trace Server. For a complete description of how to start Optimal Trace Server, see Section 14 Running Optimal Trace™ Server.
12 Configuring Microsoft SQL Server

This section details the steps involved in configuring Optimal Trace Server with Microsoft SQL Server.

**Note:** This section is targeted at SQL Server database administrators with corresponding supporting Operating Systems administration knowledge.

12.1 Prerequisites

Microsoft SQL Server software is installed. This installation is beyond the scope of this document. Refer to all installation documentation provided with the Microsoft SQL Server installation media.

- Major documentation, support, downloads, and etc. for SQL Server is available at [www.microsoft.com/sql/](http://www.microsoft.com/sql/)

- Also when SQL Server is installed, it is packaged with a substantial documentation section available by choosing Start>Programs>Microsoft SQL Server> Books online. This documentation details all areas of usage for SQL Server.

You need to have the privileges associated with a fully operational database administrator and be allowed to start up and shut down an instance of SQL Server before the database is created or opened.

Ensure that there is sufficient memory available to start the SQL Server instance, and that there is sufficient disk storage space for the planned database on server.

12.2 Setting up the SQL Server database

The Optimal Trace Server installation Scripts directory contains the script needed to create the Optimal Trace database, tables, and user privileges. The following steps need to be taken in order to set up the Optimal Trace database objects.
Microsoft SQL Server 2000 Edition

The simplest way to create the Optimal Trace database is to use the Query Analyzer tool supplied with the SQL Server installation.

Run the Query Analyzer as follows:
1. Choose Start>Programs>Microsoft SQL Server>Query Analyzer.
2. Run the isqlw utility from the command line.

For any required information on using the Query Analyzer see 'Using the SQL Server Tools--> UserInterface Reference--> SQL Query Analyzer Help in the SQL Server Books Online documentation provided with the SQL Server installation.

3. Start the Query Analyzer tool and connect to the master database (default) with admin permissions (Windows or SQL Server authentication).
4. Choose File>Open.
5. Go to the Optimal Trace\Optimal Trace Server\scripts directory.
6. Open the file mssqlserver_Optimal Trace_install.sql.
7. Invoke the script using the Execute-Query (F5) command. This will invoke all queries within the script (create Database, Tables and User/Privileges).

Invoking this script will create the database for Optimal Trace OptimalTrace and all the required tables, as well as user OptimalTrace with password password. You can change this username and password when the Optimal Trace Server database is fully set up.

After the script completes, close the opened script file and exit the SQL Server Query Analyzer tool.

Microsoft SQL Server 2005 Edition

The SQL Server Management Studio In Microsoft SQL Server 2005 Edition combines the functionality of the Enterprise and Query managers (used in the 2000 edition) into one easy to use graphical tool.

1. Choose Start>Programs>Microsoft SQL Server 2005 - SQL Server Management Studio to Open the Management Studio.
2. Choose File>Open to go to the Optimal Trace\Optimal Trace Server\scripts directory.
3. Open the file mssqlserver_OptimalTrace_install.sql.
4. select the Execute option from the toolbar. This will invoke all queries within the script (create Database, Tables and User/Privileges).

Invoking this script will create the database for Optimal Trace OptimalTrace and all the required tables, as well as user OptimalTrace with password password. You can change this username and password when the Optimal Trace Server database is fully set up.

After the script completes, close the opened script file and exit the Management Studio.
**Note:** On some installations of Sql Server 2005 edition, security policy does not allow the creation of a database and user using the password *password*. If this problem occurs, modify the `mssqlserver_optimaltrace_install.sql` to make the password more secure, and re-run the script.

Start the Optimal Trace Server. For a complete description of how to start Optimal Trace Server, see Section 14 Running Optimal Trace™ Server.

### 12.3 Removing the Optimal Trace database

If for any reason you need to remove the Optimal Trace database, then the simplest way to do so is using either the SQL Server Query Analyzer or the SQL Server Enterprise Manager tools.

Before attempting to delete, ensure that there are no active connections to the database. These can include a running Optimal Trace Server or open connections to the database within the Query Analyzer or the Enterprise Manager tools.


1. Select the *OptimalTrace* database within the *InstalledServer* list (on the left hand side tree).
2. Right-click and select Delete or click the delete key. This will remove the database.

**Enterprise Manager (2000 Edition)**

1. On the left hand side tree navigate to Microsoft SQL Servers>SQL Server Group>InstalledServer>Databases.
2. Select database *OptimalTrace*.
3. Right-click and select Delete or click the delete key. This will remove the database.

Also the created user can be removed, to do this:

5. Delete the user *OptimalTrace*.

The database can be recreated by following the steps above.

**Management Studio (2005 Edition)**

1. On the left hand side tree navigate to Microsoft SQL Servers>Databases.
2. Select database *OptimalTrace*.
3. Right-click and select Delete or click the Delete key. This will remove the database.

Also the created user can be removed, to do this:

1. Navigate to Microsoft SQL>Scurity>Logins.
2. Delete the user *OptimalTrace*.

### 12.4 MS SQL Server Notes
12.4.1 mssqlserver_Optimal Trace_install.sql

A) The 'OptimalTrace' database is created with default settings (size, growth etc.) as follows:

Create database OptimalTrace

The following command can be used instead to create a database with specified sizes etc. Note that you must ensure that the data path is set correctly to Microsoft SQL Server data path (.mdf + _log file locations))

Create database [OptimalTrace] ON (NAME = N'OptimalTrace', FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL\data\OptimalTrace.mdf', SIZE = 100, FILEGROWTH = 10%) LOG ON (NAME = N'OptimalTrace_log', FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL\data\OptimalTrace_log.LDF', SIZE = 30, FILEGROWTH = 10%)

To use the second command, comment out the first and uncomment the second. Both are given in the script with the second commented out. The administrator can change the specified values given as required.

B) A login called 'OptimalTrace' is created and given a 'db_owner' role on the database.

exec sp_addlogin 'OptimalTrace', 'password', 'OptimalTrace'
exec sp_grantdbaccess 'OptimalTrace'
exec sp_addrolemember 'db_owner', 'OptimalTrace'

The administrator can amend this, but read/write access to the database is required.

12.4.2 SQL Server Enterprise Manager

The Enterprise Manager has very useful functionality for viewing information (structure and values) for the database, the table structures, and the login details. For all information regarding the Enterprise Manager see Using the SQL Server Tools-> UserInterface Reference-> SQL Server Enterprise Manager Help in the SQL Server Books Online documentation provided with the SQL Server installation.

12.4.3 Other SQL Server utilities

Some other useful utilities within Enterprise Manager are the 'Scripting Object..' functionality of the Query Analyzer and the 'Generate SQL Script...', which can be used to see a formatted version of the install script containing default parameter values.

Other useful utilities are items such as:
- Database Maintenance plan Wizard (which runs integrity checks, updates statistics and performs backups)
- Table viewing functionality (in spreadsheet format)
- Profiler
- Adding/Removing Logins GUI (in security)

- And many others.

A detailed description of all of these is outside the scope of this document but is contained in the Books online section in the SQL Server Books Online documentation provided with the SQL Server installation.
13 Installing Optimal Trace Server

This section describes how you may install and uninstall Optimal Trace Server.

13.1 Installing Optimal Trace™ Server

If you are upgrading from older versions 4.0 or prior please see the specific instructions earlier in the document.

Run/click on the Optimal_Trace_Server.exe file to install Optimal Trace™ Server:

- follow the instructions by clicking the 'next' button. During the install you will be prompted to copy over permissions settings to the current release. Click 'Yes' if you wish to do so (it is recommended that you do).
- finally click 'Finish' to install. The install should complete in a matter of minutes.
- Once the installation is complete, launch 'Optimal Trace Server' from 'Compuware/Optimal Trace Server' on the Start menu

13.1.1 Uninstalling Optimal Trace™ Server

To uninstall Optimal Trace™ Server move through Start/Settings/Control Panel/Add/Remove Programs and click on the version of Optimal Trace™ Server that you want to uninstall. Click on the Change/Remove button and an Uninstall screen will appear. Click on the Uninstall
button if you are sure you want to remove the version of Optimal Trace™ Server. This will completely remove all components installed by you. Alternatively you can uninstall Optimal Trace™ Server via the start menu by going to Start/Programs/Compuware/Optimal Trace Server/Uninstall.

**Note:** Do not attempt to uninstall Optimal Trace™ Server by discretely deleting files/folders as this could create problems for you later.
14 Running Optimal Trace™ Server

This section describes how you may run Optimal Trace™ Server. For instructions regarding licensing refer to the Distributed License Management Licensing Guide. For instructions regarding upgrading Optimal Trace™ Server see Section 8 Upgrading Optimal Trace 5.0 to Optimal Trace 5.1.

14.1 Starting Optimal Trace™ Server

To run Optimal Trace™ Server from Windows move through: Start/Programs/Compuware/ Optimal Trace Server/ Optimal Trace Server.

A splash screen will appear, Optimal Trace™ Server will load, and the screen shown below will appear.

Note: If you did not use the default locations when you installed the Optimal Trace™ Server application, then move to the directory where the software is installed and click on the Optimal Trace Server.exe icon in the 'Optimal Trace Server' subfolder.

1. Enter the Username and Password in the text boxes provided.

2. Choose 'MySQL', 'Oracle' or 'SQLSERVER' from the database dropdown menu, as Optimal Trace Server needs to know what kind of database it's connecting to. Note: with Oracle, if you did not create a new 'OptimalTrace' database, replace the 'Database Name' value below with the name of your Oracle database.
3. To start the Optimal Trace™ Server, simply click on the 'Start' button and Optimal Trace™ Server then starts running.

4. Once the server is started, the final step is to check that the Optimal Trace Enterprise Client can connect to and use the Optimal Trace Server ok. To do this, run Optimal Trace Enterprise Client, and select the Options>General Options menu option and then select the 'Server Settings' tab. Enter the host name where your Optimal Trace Server is installed, accept the default 'port' and 'polling interval' settings and hit 'Save'. Finally, create a new Optimal Trace Project (make sure you select 'Create a new remote project in the repository'), add some data and save. There will be no error messages if everything is installed and configured correctly. If there are problems, check the connection by hitting 'Test Connection...' and sending the results to your network administrator. If problems persist, contact the Optimal Trace™ Support Team; see section 1.3 Contacting Optimal Trace Customer Support for contact details.
14.1.1 Stopping the Optimal Trace™ Server
To stop the Optimal Trace™ Server, simply click on the ‘Stop’ button. This will kill all server processes started by the Optimal Trace™ Server.

14.1.2 Configuring the Optimal Trace™ Server as a windows service
Optimal Trace™ Server is automatically registered as a Windows service during installation. Before starting the service you **must** run through the steps in section 14.1 Starting Optimal Trace™ Server to ensure that the server can be started with the specified options. To use the Optimal Trace™ Server service do the following:

2. Before starting the service ensure that Optimal Trace™ Server is not already running.
3. To start/stop the service from the Microsoft Management Console:
   - Go to Start/Settings/Control Panel/Administrative Tools/Services; and
   - right click on 'Optimal Trace Server' and choose Start/Stop.

14.1.3 Stopping the Optimal Trace™ windows service
Open Control Panel and launch 'Administrative Tools' -> 'Services'
navigate to 'Optimal Trace Server':
right click, and select 'Properties':

'Stop' the service (if it is running)
Change the 'Startup type' to 'Manual'.
14.2 Optimal Trace™ Email Configuration

The Optimal Trace™ Email Settings are used to configure access to an SMTP server. Optimal Trace™ notification emails are sent to registered users by the Optimal Trace™ Server using the SMTP server/details you provide. Your mail server administrator should ensure that the Optimal Trace™ Email Settings that you use will allow sending mail to all of your Optimal Trace™ users' email addresses. It is best to discuss the Email Settings that Optimal Trace™ Server uses with your company email Administrator. It is best practice to create a dedicated email account for use by Optimal Trace™ Server.

See the Optimal Trace™ Enterprise Help for more information on the Notifications feature.

Your email administrator needs to provide you with:

- the name of your companies mail server ('SMTP server' setting below)
- the email user name that Optimal Trace™ Server will use ('Username')
- the password for the Optimal Trace™ Server user name ('Password')
- whether or not the email server requires a Secure Connection (SSL).

When you have finished entering the email configuration, you can test that it's working by clicking on the 'Test Email Settings' button (and enter your own email address to receive the test message).

Note also that some spam filters may block this message, so you will need to work through this process with your email Administrator.

Sample values would be something as follows:
SMTP Server: WidgetCoSMTPMailServer
Username: <Optimal Trace server user>@widgetcodomain.widgetco.com
Password: <password>

The test email that you receive will simply contain 'Optimal Trace Email Settings Test' in the subject line. If you do not receive a mail, you may need to check your email servers spam filter as the message may have been blocked (e.g. if you do not specify a domain in your user name, some spam filters may block the message).

**Note:** Optimal Trace™ supports SMTP authentication (RFC 2554 - http://www.ietf.org/rfc/rfc2554.txt) mechanisms LOGIN and PLAIN.

### 14.2.1 Example Email Configuration using GMail

At the time of writing, Google's GMail can be configured to be used by Optimal Trace™ Server as the mail notifier. This can be useful if you are evaluating Optimal Trace™ Server and don't want to set up a dedicated Optimal Trace™ user on your company's email system.

Enter the following settings if you want Optimal Trace™ Server to use your GMail mail account to send notifications from:

SMTP Server: smtp.gmail.com
Username: <you>@gmail.com
Password: <your gmail password>
Use Secure Connection: <tick this option>
14.3 Optimal Trace™ Server Advanced Configuration

The Advanced tab contains default parameters. Change them, if you wish to enhance the performance of Optimal Trace™ Server.

<table>
<thead>
<tr>
<th>Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Monitor Interval</td>
<td>Optimal Trace™ Server maintains a 'keep alive' connection between it and all its Optimal Trace™ clients, so it can monitor these client processes to ensure that the connection between them is valid. The interval specified here is the number of seconds between each 'keep alive' message. This 'keep alive' is a 'ping' that is sent from the Optimal Trace™ clients to the Optimal Trace™ Server. This interval specifies how often this 'ping' should be sent, specified in seconds.</td>
</tr>
<tr>
<td>Server Listener Port</td>
<td>This is the TCP/IP port that Optimal Trace™ Server runs on. If you are running a firewall on your machine, you must ensure that this port is left open for inbound connections to Optimal Trace™ Server.</td>
</tr>
<tr>
<td>Server Disconnect Attempts</td>
<td>The Optimal Trace™ Server will disconnect any Optimal Trace™ clients that have not 'pinged' it, after this specified number of attempts. As part of this disconnect process, all locks held by the client will be released and other clients will be free to work on the Projects that may have been locked by the 'dead' client. By default, if Optimal Trace™ Server does not get any pings from a client after 5 minutes (60 seconds * 5 attempts) the client will be disconnected and any locks on any projects it may have held will be released.</td>
</tr>
</tbody>
</table>
15 Running Optimal Trace Enterprise

This section describes how to run Optimal Trace Enterprise. For licensing and upgrading instructions see Section 16 Licensing and Upgrading Optimal Trace™ Enterprise.

15.1 Connecting to Optimal Trace Enterprise Server

Before using Optimal Trace Enterprise to create and edit repository based projects, you must configure it to connect to Optimal Trace Enterprise Server. See Section 15.4 Configuring Optimal Trace™ Enterprise to work through a Optimal Trace™ Server for more details.

It is possible to load Optimal Trace offline (file based) projects into Optimal Trace Enterprise without having the remote connection set up.

Additionally, local file-based projects can be created from scratch and edited within Optimal Trace Enterprise without setting up the remote connection.

15.2 Starting Optimal Trace Enterprise

Click Start>Programs>Compuware>Optimal Trace Enterprise (version)>Optimal Trace Enterprise.

**Note:** If you did not use the default locations when you installed the software, navigate to the directory where the software is installed and click Optimal Trace Enterprise.exe in the Optimal Trace Enterprise subfolder.

15.2.1 Server Settings

Enter your Server settings as per Table 1 below.

- Click on the Save button.
Figure 1 - General Options – Server Settings screen

Table 1 - Server Settings

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host Name for Server</td>
<td>Enter the host name for the Repository Server. On a standard network this will be the machine name where Optimal Trace™ Enterprise Server is running. If your Repository Server is running on your local computer, you can type 'localhost' in place of the computer's network name. Alternatively if you know the IP address of the server you can enter this.</td>
</tr>
<tr>
<td>Remote Port for Server</td>
<td>Enter the port number that the Repository Server is running on. Ensure that this number matches the setting on the Optimal Trace Server. See the Optimal Trace Server help file for more details on setting this. By default both the server and client side settings are set to 5456.</td>
</tr>
<tr>
<td>Polling Interval</td>
<td>This is the time setting that controls how often the client queries the server for updates. You can adjust this upwards if you wish to have less frequent polling from client to server.</td>
</tr>
</tbody>
</table>

If you want to test the connection to the server hit the 'Test Connection...' button. This will attempt a connection between the client and server using the settings specified. If there is any issue with the connection, a detailed result screen is shown. Copy and paste the contents
of this screen and send it to your Optimal Trace administrator or network administrator for further information.

15.3 User Support in Optimal Trace Enterprise
Optimal Trace™ Enterprise allows several users to work on the same Project simultaneously. When other users edit or add Requirements, Actors or other Project artifacts, the changes will appear dynamically on your screen.

The Optimal Trace Server software monitors all currently connected clients and ensures that all project changes saved to the repository are broadcast simultaneously to all users.

When you are editing an artifact, Optimal Trace™ Enterprise ensures that nobody else can edit that artifact or the artifacts upon which it depends, by locking them. People are free however to edit any Project artifacts that are not directly affected by your edits.

15.4 Configuring Optimal Trace™ Enterprise to work through a Optimal Trace™ Server
If you want to create or edit a remote Project, you must tell Optimal Trace Enterprise where to find the Repository.

From the Menu bar, click on Options
General Options
Server Settings, see Section 15.2.1 Server Settings for details.

| Note 1: A given client can be set to point at a different Server by adjusting the server setting in the Options screen. |

| Note 2: If you do not already have a Repository Server on your network, you will need to install a copy of Optimal Trace™ Enterprise Server before you can use any of the Optimal Trace™ Enterprise collaboration facilities. See the Optimal Trace Enterprise Server user guide for full details on configuring a server. |
16 Licensing and Upgrading Optimal Trace™ Enterprise

This section describes how you license and upgrade the Optimal Trace™ Enterprise application.

16.1 Evaluating Optimal Trace Enterprise

Optimal Trace can be evaluated for a specific period of time without a license key. When you first run Optimal Trace Enterprise you do not require a license therefore.

The evaluation period is calculated from the time of first usage, in other words from the initial running of Optimal Trace.

Once this period of time elapses you must either purchase a full license or else apply for an extension key. See section 1.3 Contacting Optimal Trace Customer Support for more details on how to contact Compuware support.

16.2 Licensing the application fully or using an extended evaluation license key

Aside from the initial evaluation period as outlined in the previous section, Optimal Trace™ Enterprise requires a license to run. Optimal Trace ships with a License Administration utility called the LAU (License Administration Utility). For full details on how to license Optimal Trace, please run the LAU and refer to the LAU help file under the 'Help >> Index...' menu option.

16.3 Upgrading from a previous release

If upgrading from Optimal Trace 4.1, you will need to install new licenses for Optimal Trace into the LAU in order to run Optimal Trace. See section 1.3 Contacting Optimal Trace Customer Support for details on how to contact Compuware support.
17 Licensing and Upgrading Optimal Trace™ Professional

This section describes how you license and upgrade the Optimal Trace™ Professional application.

17.1 Evaluating Optimal Trace Professional

Optimal Trace can be evaluated for a specific period of time without a license key. When you first run Optimal Trace Professional you do not require a license therefore.

The evaluation period is calculated from the time of first usage, in other words from the initial running of Optimal Trace.

Once this period of time elapses you must either purchase a full license or else apply for an extension key. See section 1.3 Contacting Optimal Trace Customer Support for more details on how to contact Compuware support.

17.2 Licensing the application fully or using an extended evaluation license key

Aside from the initial evaluation period as outlined in the previous section, Optimal Trace™ Professional requires a license to run. Optimal Trace ships with a License Administration utility called the LAU (License Administration Utility). For full details on how to license Optimal trace, please run the LAU and refer to the LAU help file under the 'Help >> Index...' menu option.

17.3 Upgrading from a previous release

If upgrading from a previous version of Optimal Trace, you will need to install new licenses for Optimal Trace into the LAU in order to run Optimal Trace. See section 1.3 Contacting Optimal Trace Customer Support for details on how to contact Compuware support.