Borland® Caliber 11.1.0 Release Notes

Last updated: May 14, 2013

Welcome to Caliber

Caliber provides three main components:

Author – Requirement authors deserve a rich, robust authoring environment.  Author provides:

Visualize – Allows users to see visual representation of use cases, process flows and interactive simulation, and directly relate visualizations to requirements. Visualize provides:

Review - Keeps all project stakeholders in sync by facilitating the viewing and searching of Caliber requirements / visualizations, and providing collaborative discussion. Review provides:

 

The Caliber Release Notes describes the system requirements/prerequisites and software compatibility requirements for this release of Caliber. For the latest version of this document, go to http://supportline.microfocus.com/productdoc.aspx.

Contents
What's New Installation and upgrade information Limitations
System Requirements Getting Help
Software Compatibility Known Issues

What's New

Author

Document Factory Filtering Improvements

Document Factory now support refined filtering through dynamic inline filters.

OLE Links Supported in Document Factory Output

If a requirement contains an OLE embedded object, the object now appears in Document Factory reports. Simply right-click the object to view or edit.

Option to Cancel Filter Results

Caliber Author provides an option to return filter results from Document Factory and the Requirements Grid in segments that you can cancel at any time. This improves performance, yielding a quicker return of results as opposed to obtaining all the results at one time.

Trace From Original Requirement When Pasting

When pasting a requirement as a child, use paste special to select an option to trace from the copied requirement.

Support for StarTeam Agile

Stakeholders can now view StarTeam Agile delivery progress directly from Caliber Author. Simply click the Delivery Status tab to view progress of requirements and user stories from the StarTeam Agile. Additionally, you can create stories and requirements or trace to existing items. From Caliber Author, you can also place a requirement on the StarTeam Agile Info stream, the workflow for the an Agile team.

Improved Import and Export Capabilities

Caliber's import/export utility now imports and exports Visualize objects, making it easier to share projects with others, port project to different database, or back up an entire project

Author Installation Improvements

Caliber Author now offers two different installation types:

Full Author Installation: where you can customize your standalone Author installation. This installation package includes all Caliber components, offering a robust selection of Caliber components.

Standalone Author Installation: where you can only install Author and a few core components. This option only includes Spell Checker, StarTeam Toolbar, Samples, and Document Factory. Therefore, it is a smaller file and easier to push to client machines.

Visualize

Usability Enhancements

Visualize has several usability enhancements. They are:

Review

Support for Caliber Author Filters

Caliber Review now supports filters created in Caliber Author. Navigate to a filter listed in Review to view all requirements meeting the criteria.

Activity Hub

The Activity Hub is a single page where you can view recently opened projects or filters, and discussion notifications.

Baseline Signature Support

You can now sign baselines from Caliber Review.

View Rally User Stories

From the traceability view, you can click a link to launch the user story in Rally.

System Requirements and Prerequisites

Clients

Author client

Supported Operating Systems

Windows XP

Professional SP3, 32-bit

Windows Vista

Business, 32-bit

Business SP1, 32-bit

Enterprise, 32-bit

Enterprise SP1, 32-bit

Windows 7

Enterprise, 32-bit

Enterprise, 64-bit

Software requirements

Browsers

Microsoft Internet Explorer 7 or later

Microsoft Office

2003, 2007, 2010 (required for DocFactory, Export, and Import)

Visual Studio Explorer

VS 2010 (required for TFS traceability)

Microsoft Access

MS Access 2003, 2007, 2010 (required for Datamart, Export)

Oracle

9, 10, 11g (required for Datamart, Export)

MS SQL Server

2005, 2008 (required for Datamart, Export)

Adobe Flash

Player 9.0.47 or later (required for Visualization runtime)

Hardware Requirements

RAM

2 GB (4 GB recommended)

Processor

Dual Core CPU

Hard Drive

1 GB free space (5 GB recommended)

Screen Resolution

1280 x 1024 or higher

Visualize and Review client

Supported Operating Systems

Windows XP

Professional SP3, 32-bit

Windows Vista

Business, 32-bit

Business SP1, 32-bit

Enterprise, 32-bit

Enterprise SP1, 32-bit

Windows 7

Enterprise, 32-bit

Enterprise, 64-bit

Apple

Mac OS X

Mobile (Review only)

iOS 4.x

Android 4.x

Software requirements

Web Browser

Microsoft Internet Explorer 8 or later

Mozilla Firefox 4 or later

Google Chrome 18+

Safari 5.x, 6

Adobe Flash

Player 9.0.47 or later

Hardware Requirements

RAM

2 GB (4 GB recommended)

Processor

Dual Core CPU

Hard Drive

1 GB free space (5 GB recommended)

Screen Resolution

1280 x 1024 or higher

 

 

 

 

 

Servers

Caliber Data Server

Supported Operating Systems

Windows Server 2008

Standard Edition R2, 64-bit (recommended)

Standard Edition R2, 32-bit

Standard Edition SP1, 32-bit

Enterprise Edition SP2, 32-bit

Enterprise Edition SP2, 64-bit

Windows 7 (for trials only)

Enterprise, 32-bit

Enterprise, 64-bit

Hardware Requirements

RAM

4 GB (16 GB recommended)

Processor

Dual Core CPU (Quad core recommended)

Hard Drive

20 GB free space (100 GB recommended), recommended 2.5 times DB size for upgrade

Screen Resolution

1280 x 1024 or higher

Virtualization

VMWare

ESX 4.1

Visualize Server

Supported Operating Systems

Windows Server 2008

Standard Edition R2, 64-bit (recommended)

 

Standard Edition SP2, 32-bit

Standard Edition SP1, 32-bit

Enterprise Edition SP2, 32-bit

Enterprise Edition SP2, 64-bit

Windows 7 (for trials only)

Enterprise, 32-bit

Enterprise, 64-bit

Hardware

RAM

4 GB (16 GB recommended)

Processor

Dual Core CPU (Quad core recommended)

Hard Drive

20 GB free space (100 GB recommended)

Screen Resolution

1280 x 1024 or higher

Virtualization

VMWare

ESX 4.1

Review Server

Supported Operating Systems

Windows Server 2008

Standard Edition R2, 64-bit (recommended)

 

Standard Edition R2, 32-bit

Standard Edition SP1, 32-bit

Enterprise Edition SP2, 32-bit

Enterprise Edition SP2, 64-bit

Windows 7 (for trials only)

Enterprise, 32-bit

Enterprise, 64-bit

Windows XP (for trials only)

SP3 (32-bit)

Hardware

RAM

4 GB (16 GB recommended)

Processor

Dual Core CPU (Quad core recommended)

Hard Drive

20 GB free space (100 GB recommended)

Screen Resolution

1280 x 1024 or higher

Virtualization

VMWare

ESX 4.1

Caliber for Eclipse

System Area Requirement
Software Eclipse 3.2, Eclipse 3.3, Eclipse 3.4 downloadable from Eclipse.org
Hardware Requirements Recommended configuration by Eclipse.

Caliber for Microsoft Team Foundation Server

System Area Requirement
Platforms

Refer to the Visual Studio Team Foundation Installation Guide available for download at http://www.microsoft.com/downloads/details.aspx?familyid=ff12844f-398c-4fe9-8b0d-9e84181d9923&displaylang=en

Software

Microsoft Visual Studio 2008 Team Foundation Server

Microsoft Visual Studio 2005 Team Foundation Server

Note: Support for Microsoft Team Foundation Server 2003 has been removed.

Caliber for Microsoft Visual Studio Team System

System Area Requirement
Platforms

Refer to Microsoft system requirements at: http://msdn.microsoft.com/en-us/vsts2008/aa718944.aspx

Processor, RAM

Refer to Microsoft system requirements at:

http://msdn.microsoft.com/en-us/vsts2008/aa718687.aspx for Visual Studio 2005 Team Edition for Software Developers

http://download.microsoft.com/download/A/2/8/A2807F78-C861-4B66-9B31-9205C3F22252/VS2008SP1Readme.htm for Visual Studio 2008 Team Edition for Software Developers

Software

Visual Studio 2010

Visual Studio 2005 Team Suite

Visual Studio 2008 Team Suite

Microsoft Visual Studio 2005 Team Explorer

Microsoft Visual Studio 2008 Team Explorer

Caliber Web

Recommended Apache or IIS system requirements.

System Area Requirement
Web server Apache or IIS (Apache is provided)
Client browser Internet Explorer 6.0 SP1, 7.0, 8.0
JDK/JRE 1.6, 1.6.x.x

Top

Software Compatibility

Borland has tested integrations with the following Borland and third-party supported products.

Caliber Feature

Supported Product

Tested Version

StarTeam Integration (StarTeam Publisher)

StarTeam SDK

13.0

Traceability

Borland Silk Central Test Manager

2010 R2, 2011, 12.0

Borland StarTeam

12.0, 12.5, 13.0

Borland Together for Eclipse

2006, 2007, 2008

Microsoft Visual Studio Team Foundation Server

2005, 2010

Rally Software – Agile Lifecycle Management Solutions

N/A

IBM Rational ClearCase

2003

Merant PVCS Version Manager

6.8

HP Quality Center

9.0, 9.2, 10.0, 11.0

Microsoft Visual SourceSafe

6.0 SP6

Integration with Office tools

Document Generation

Microsoft Office 2003, 2007, 2010 (Document Factory), (only *.doc format)

Data Import

Microsoft Word 2003, 2007, 2010
Microsoft Excel 2003, 2007, 2010

Data Export

MS Access 2003, 2007, 2010

Datamart extraction targets and
analysis tools

Business Objects

6.5, 11

Microsoft Access

2003, 2007, 2010

Microsoft SQL Server

2000, 2005, and 2008

Oracle Database Server

10g, 11g, 11g R2

Integrated Development Environment
(IDE) integrations

Borland Developer Studio
(C++ Builder, C# Builder, Delphi)

2006

Borland JBuilder

2005 and 2006

Microsoft Visual Studio

Visual Studio 2005 SP1 and Visual Studio 2008,

Microsoft Visual Studio Team System

2005 SP1 and 2008

Eclipse

3.2, 3.3, 3.4

Web server

Apache Web Server

2.0

Microsoft Windows Server
Internet Information Services (IIS)

2003 (6.0)

Software license servers

MacroVision FlexLM

8.2a

Microsoft Windows Server
Internet Information Services (IIS)

2003 (6.0)

 

VM ware

VM ware ESX Server

4.1

Top

 

Installation and Upgrade Instructions

If you are upgrading from Caliber 2008 SP1 or Caliber 10.1, carefully review the Performing an Upgrade section of the Caliber installation guide, as the upgrade procedure has changed from previous releases. If you are installing via FTP, go to http://supportline.microfocus.com/productdoc.aspx to obtain the latest installation guide or download the media browser from the FTP site.

In the Caliber 11.1 release, the Caliber SDK no long installs by default. You must choose to install the Caliber SDK separately.

Additionally, if you use StarTeam Publisher, the Caliber installation does not install the StarTeam SDK by default. You must install the StarTeam SDK 13.0 from the Caliber 11.1 media browser in order to use the StarTeam Publisher in Caliber 11.1.

The following information contains notes regarding installation, but does not replace the entire process.

Upgrading Caliber Author

If you are upgrading from a previous release, use the full installation. Otherwise, you must uninstall the previous version and reinstall with the standalone Caliber Author.

Upgrading Caliber Review

After you have installed Caliber Review 11.1, notify all users that they must navigate to the Review URL and press CTL-R to refresh the page.

Installing the Caliber Eclipse Plugin Installer

Before installing the plugin, remove the prior version of the Eclipse plugin:

  1. Navigate to Control Panel> Settings> Add or Remove Programs.
  2. Find an existing entry for Borland Caliber for Eclipse.
  3. Remove the plugin.

To install the new plugin:

  1. From the Product updates page, navigate to the Borland Caliber for Eclipse folder.
  2. Double click on setup.exe to install the plugin. The plugin installs in the Eclipse installation directory. For example, C:\eclipse if eclipse is installed on the C: drive.
  3. Click Next, accepting the defaults until the Destination Folder dialog box appears.

Upgrading Visual Studio Team System Integration

If upgrading from a release prior to Caliber 11.0, uninstall the Visual Studio Team System integration. Then, install the Visual Studio Team System integration for 11.1.

Caliber Server

Top

Caliber for Microsoft Visual Studio Team System

Your Visual Studio Team System administrator must install Caliber for Team Foundation Server once on the machine hosting Team Foundation Server, prior to installing the Caliber for Visual Studio Team System. The Caliber for Microsoft Visual Studio Team System component must be installed by each Visual Studio Team System end user (architect, developer, tester) to access Caliber requirements from within Visual Studio and establish traceability between requirements and Visual Studio Team System work items and tests from Visual Studio.

Top

Visualize Upgrade and Default Ports

Note that the Visualize default ports are different from CaliberRDM default ports as follows:

Configuring Caliber Review

Changing Caliber Review Server

To connect to a different data server:

  1. Stop the Caliber Review Server.
  2. Choose Start>All Programs>Borland Caliber>Caliber Review>Review Configuration Utility and run as Administrator.
  3. Change the address and port number.
  4. Save the changes.
  5. Restart the Caliber Review Server.

Enabling SSL for Caliber Review

By default, SSL is disabled.

To enable SSL:

  1. Stop the Caliber Review Server.
  2. Edit server.xml located in <install directory>/conf.
  3. Uncomment the following section:
  4. <Connector port="11082" minSpareThreads="5" maxSpareThreads="75" protocol="org.apache.coyote.http11.Http11Protocol" enableLookups="true" disableUploadTimeout="true" acceptCount="100" maxThreads="200" scheme="https" secure="true" SSLEnabled="true" keystoreFile="bin/CaliberReview.keystore" keystorePass="Caliber11" clientAuth="false" sslProtocol="TLS"/>

  5. Save the changes.
  6. Restart the Caliber Review Server.

Configuring Cache for Caliber Review

Caliber Review uses caching to efficiently retrieve Projects and Filters.  With caching enabled, the Caliber Review server will query the Caliber Data Server every 10 minutes. With caching enabled users will not  see new Projects and Filters in Review for up to 10 minutes. In a small installation (approximately 20 projects/filters), caching may not provide much benefit or the users may want to see Projects and Filters created immediately. 

To disable caching the administrator:

  1. Stop the Caliber Review service.
  2. Edit webViewer.properties (default directory is dir\lib\webViewer.properties) in a text editor.
  3. Change “useCache.projectList=true” to be “useCache.projectList=false”
  4. Change “useCache.filterList=true” to be “useCache.filterList=false”
  5. Save the changes.
  6. Restart the Caliber Review service.

By disabling caching, users may notice the project list and the filter lists takes longer to retrieve.  However, they will see Projects and Filters immediately after they have been created.

Top

Caliber Known Issues

Localized Documentation

The new features for Caliber 11.1 are not localized for this release. Our international (German, French and Japanese) customers are requested to refer to the English documents for the Caliber 11.1 release (http://supportline.microfocus.com/productdoc.aspx).

The Caliber SDK Programmers Guide is not included in the release media but is available for download from the Borland Documentation Web site mentioned above.

Option in Word influences Document Factory

When creating a .doc report from Document Factory, an error occurs and the report does not open. If creating an xml report, the file opens but displays <<description>> in each requirement description.
Workaround: In Microsoft Word, choose Options > Advanced, and select Typing replaces selected text.

Other Known Issues

Top

Caliber Author

Localization

Documentation

Caliber Author

Document Factory

  1. Open the Paragraph dialog box and click the Line and Page Breaks tab.
  2. Uncheck Keep lines together option. The square no longer appears.

Caliber for Microsoft Visual Studio 2008/ Visual Studio Team Foundation 2008

Top

Caliber for Microsoft Visual Studio 2005

Top

Caliber for Microsoft Visual Studio Team System 2005

Top

Caliber Visualize Known Issues

To grant this access in the Caliber Administrator tool:

  1. In the Caliber Administration tool, click File>Admin>Security Profiles to open the Security Profiles Editor.
  2. Select the appropriate profile and click Edit.
  3. In the Modify section for both Scenarios and Simulations Requirement Types, change Requirement Trace from Owned to Any.
  4. Click OK.
Top
  • Limitations

  • Caliber Data Server

    Top

    Caliber Author

    Top

    Getting Help

    For technical support, contact the Borland Support Center at http://support.borland.com/.Before contacting support, you may want to consult the Borland Support Center Borland Answers at http://support.borland.com/kb.php

    Top

    Copyright © 2013 Micro Focus. All rights reserved. Portions Copyright (c) 1998-2009 Borland Software Corporation (a Micro Focus company). All other marks are the property of their respective owners.