Silk Test 13.5

Silk4NET Tutorial
Contents

Getting Started with Silk4NET ................................................................. 4
Creating a Silk4NET Project ................................................................. 5
Adding a Silk4NET Test to a Project .................................................... 6
Recording a Silk4NET Test ................................................................. 8
Running Silk4NET Tests ................................................................. 10
Enabling TrueLog ............................................................................. 11
Analyzing Test Results ................................................................. 12
Perform the following actions to use Silk4NET:

1. Create a Silk4NET project.
2. Add Silk4NET tests to your project. A project can include any combination of recorded tests and manually scripted tests.
3. Execute the tests.
4. Analyze the test results.
Creating a Silk4NET Project

1. Click Silk4NET > New Project or File > New > Project. The New Project dialog box displays.
2. Under Installed Templates, click Visual Basic or Visual C#, and then double-click Silk4NET Project. The Create a Silk4NET Test dialog box opens.
3. Select how you want to create your Silk4NET test by clicking one of the following option buttons:
   - **Record a Silk4NET test**: Record actions and verifications against your application under test and generate a new test containing the recorded automation statements.
   - **Create an empty Silk4NET test**: Create an empty test that can be filled with automation statements later on.
4. Click OK. If you have selected to create an empty Silk4NET test, a new solution containing the Silk4NET project is created. Additionally, a Silk4NET test is created in the project with the following language-specific file name:
   - UNITEST1.VB
   - UNITEST1.CS
5. If you have selected to record a new Silk4NET test, the New Application Configuration wizard opens. Select the type of application that you want to test.
   - If you want to test a standard application, click Standard Test Configuration.
   - If you want to test a Web application, click Web Site Test Configuration.
6. Click Next.
7. If you have selected to test a standard application, the New Standard Configuration dialog box opens. Click the configuration that corresponds with the application that you want to test.
   - If the application that you want to test does not appear in the list, uncheck the **Hide processes without caption** check box. This option, checked by default, is used to filter only those applications that have captions.
8. If you have selected to test a Web application, the New Web Site Configuration dialog box opens. Select the browser type that you want to test from the Browser Type list box.
   a) In the Browser Instance section, click one of the option buttons:
      - **Use existing browser**: Click this option button to use a browser that is already open. For example, if the Web page that you want to test is already displayed in a browser, you might want to use this option.
      - **Start new browser**: Click this option button to start a new browser instance when you configure the test. Then, in the **Browse to URL** text box, specify the Web page to open.
9. Click Finish. If you have selected an existing instance of Google Chrome, on which you want to replay a test method, Silk Test Recorder checks whether the automation support is included. If the automation support is not included, Silk Test Recorder informs you that Google Chrome has to be restarted. The application and the Recording dialog box open.

**Note:** You can also use the context menu in the Solution Explorer to add Silk4NET projects to an existing solution.
Adding a Silk4NET Test to a Project

You can only add Silk4NET tests to an existing Silk4NET or Test project. If no Silk4NET or Test project exists, create a Silk4NET or Test project before you try to create a Silk4NET test.

1. Click Silk4NET > New Test or Project > Add New Item.
   
   **Note:** If your solution contains more than one Silk4NET projects, select the project to which you want to add the new test from the list in the Project Selector.
   
   The Add New Item dialog box opens.

2. Under Installed Templates, click one of the following:
   
   • If your project is a Visual Basic project, click Common Items > Silk4NET Test.
   • If your project is a Visual C# project, click Visual C# Items > Silk4NET Test.

   The Create a Silk4NET Test dialog box opens.

3. Select how you want to create your Silk4NET test by clicking one of the following option buttons:

   **Record a Silk4NET test** Record actions and verifications against your application under test and generate a new test containing the recorded automation statements.

   **Create an empty Silk4NET test** Create an empty test that can be filled with automation statements later on.

4. Click OK. If you have selected to create an empty Silk4NET test, a new solution containing the Silk4NET project is created. Additionally, a Silk4NET test is created in the project with the following language-specific file name:

   • UnitTest1.vb
   • UnitTest1.cs

5. If you have selected to record a new Silk4NET test, the New Application Configuration wizard opens. Select the type of application that you want to test.

   • If you want to test a standard application, click Standard Test Configuration.
   • If you want to test a Web application, click Web Site Test Configuration.

6. Click Next.

7. If you have selected to test a standard application, the New Standard Configuration dialog box opens. Click the configuration that corresponds with the application that you want to test.

   If the application that you want to test does not appear in the list, uncheck the Hide processes without caption check box. This option, checked by default, is used to filter only those applications that have captions.

8. If you have selected to test a Web application, the New Web Site Configuration dialog box opens. Select the browser type that you want to test from the Browser Type list box.

   a) In the Browser Instance section, click one of the option buttons:

   **Use existing browser** Click this option button to use a browser that is already open. For example, if the Web page that you want to test is already displayed in a browser, you might want to use this option.

   **Start new browser** Click this option button to start a new browser instance when you configure the test. Then, in the Browse to URL text box, specify the Web page to open.

9. Click Finish. If you have selected an existing instance of Google Chrome, on which you want to replay a test method, Silk Test Recorder checks whether the automation support is included. If the automation
support is not included, Silk Test Recorder informs you that Google Chrome has to be restarted. The application and the **Recording** dialog box open.

If you have selected to record the test, the recorded test is added to your project. If you have selected to add an empty test, an empty Silk4NET test is added to your project.

**Note:** You can also use the context menu in the **Solution Explorer** to add Silk4NET tests to your Silk4NET or Test project.
Recording a Silk4NET Test

1. Click Silk4NET > New Test or Project > Add New Item.

   **Note:** If your solution contains more than one Silk4NET projects, select the project to which you want to add the new test from the list in the Project Selector.

   The Add New Item dialog box opens.

2. Under Installed Templates, click one of the following:
   - If your project is a Visual Basic project, click Common Items > Silk4NET Test.
   - If your project is a Visual C# project, click Visual C# Items > Silk4NET Test.

   The Create a Silk4NET Test dialog box opens.

3. Click Record a Silk4NET test.

   **Record a Silk4NET test**
   - Record actions and verifications against your application under test and generate a new test containing the recorded automation statements.

   The New Application Configuration wizard opens.

4. Select the type of application that you want to test.
   - If you want to test a standard application, click Standard Test Configuration.
   - If you want to test a Web application, click Web Site Test Configuration.

5. Click Next.

6. If you have selected to test a standard application, the New Standard Configuration dialog box opens. Click the configuration that corresponds with the application that you want to test.

   If the application that you want to test does not appear in the list, uncheck the Hide processes without caption check box. This option, checked by default, is used to filter only those applications that have captions.

7. If you have selected to test a Web application, the New Web Site Configuration dialog box opens. Select the browser type that you want to test from the Browser Type list box.

   a) In the Browser Instance section, click one of the option buttons:

      **Use existing browser**
      - Click this option button to use a browser that is already open. For example, if the Web page that you want to test is already displayed in a browser, you might want to use this option.

      **Start new browser**
      - Click this option button to start a new browser instance when you configure the test. Then, in the Browse to URL text box, specify the Web page to open.

8. Click Finish. If you have selected an existing instance of Google Chrome, on which you want to replay a test method, Silk Test Recorder checks whether the automation support is included. If the automation support is not included, Silk Test Recorder informs you that Google Chrome has to be restarted. The application and the Recording dialog box open.

9. Perform the interactions, which you want to record, with your application under test.

   For additional information, refer to the Silk Test Recorder Help.

10. When you are finished with recording, click Stop Recording in the Recording dialog box.

    The recorded interactions are added as a file to your project. The default file name of the generated file is UnitTest<Index>.cs or UnitTest<Index>.vb, depending on the default programming language of your project. For example, if you are recording the first test for a Visual Basic project, the name of the generated file is UnitTest1.vb.
*Note:* You can also create a new project and record the new test into the new project.
Running Silk4NET Tests

1. In Visual Studio, click **File > Open > Project/Solution**. The **Open Project** dialog box displays.
2. Browse to the project file of the project which includes the test that you want to run.
   The project file is a `.sln` file, for example `Silk4NETProject1.sln`.
3. Double-click on the project file. The test files that are included in the project file open in the main
   window of Visual Studio.
4. In the toolbar, click **Run All Tests in Solution**. All tests in the open project are executed. When the
   execution is finished, the **Playback Complete** dialog box opens.
5. Click **Explore Results** to examine the results of the tests with TrueLog or click **OK** to close the dialog
   box.
Enabling TrueLog

For new Silk4NET scripts, TrueLog is enabled by default. To enable TrueLog for existing Silk4NET scripts, which are using the Visual Studio Unit Testing Framework, you have to replace the TestClass attribute of all test classes in the script with the SilkTestClass attribute.

To enable TrueLog:

1. Open the script that contains the test class for you want to enable TrueLog.
2. Add the SilkTestClass attribute to the test class.

The TrueLog is created in the TestResults sub-directory of the directory, in which the Visual Studio solution file and the results of the Visual Studio Unit Testing Framework are located. The Visual Studio solution file is the file in which the Silk4NET scripts are located. When the Silk4NET test execution is complete, a dialog box opens, and you can click Explore Results to review the TrueLog for the completed test.

Examples

To enable TrueLog for a class in a Visual Basic script, use the following code:

```vbnet
<SilkTestClass()> Public Class MyTestClass
    <TestMethod()> Public Sub MyTest()
        ' my test code
    End Sub
End Sub
```

To enable TrueLog for a class in a C# script, use the following code:

```csharp
[SilkTestClass]
public class MyTestClass {
    [TestMethod]
    public void MyTest() {
        // my test code
    }
}
```
Analyzing Test Results

1. Run a Silk4NET test. When the execution is finished, the Playback Complete dialog box opens.
2. Click Explore Results to examine the results of the tests with TrueLog. Silk TrueLog Explorer opens.
3. Click through the results in Silk TrueLog Explorer.
   Silk TrueLog Explorer captures a screenshot whenever a test fails.