## Contents

**Preface**
- Audience ........................................ vii
- Organization ..................................... viii
- Conventions ...................................... viii
- Related Manuals ................................. ix
- Online Help ..................................... x

**1 Introducing the Modernization Workbench**

*Modernization Workbench Products* .................................. 1-1
  *Application Analyzer* ........................................ 1-2
  *Enterprise View Express* .................................... 1-3
  *Application Architect* ...................................... 1-3
  *Business Rule Manager* .................................. 1-3
  *Transformation Assistant* .............................. 1-4

*Modernization Workbench Process* ............................... 1-4

*How Modernization Workbench Models Applications* .......... 1-7
  *Understanding Application-Level Information* ............ 1-7
  *Understanding Object-Level Information* ................ 1-8
Workspaces and Projects ........................................... 1-8
Single-User versus Multiuser Environments ............... 1-9
Multiuser Environment Basics ................................... 1-10
  Deployment Scenario ............................................. 1-10
  Workbench Privileges .......................................... 1-12
  Dropping Indexes ................................................. 1-14
  Computing Statistics ........................................... 1-14
Supported Legacy Languages .................................... 1-15
What’s Next? ......................................................... 1-15

2 Modernization Workbench Basics

  Creating a Workspace ............................................ 2-1
  Designating Users for Security Policies ................ 2-6
    Designating New Master Users in a Simple Security Policy 2-6
    Designating Users in a Three-Group Security Policy .... 2-7
  Refreshing the Workspace Path ....................... 2-9
  Connecting to a Workspace ................................ 2-11
  Opening a Workspace .......................................... 2-13
  Registering Source Files ..................................... 2-14
  Verifying Source Files ....................................... 2-16
  Using the Modernization Workbench Main Window ......... 2-18
    Menus .......................................................... 2-19
    Tool Bars ...................................................... 2-21
    Repository Pane ............................................. 2-22
    Object Information ........................................ 2-31
    Activity Log ............................................... 2-32
    Editor and Viewer ......................................... 2-33
    Creating a To Do List ..................................... 2-36
    Viewing Object Properties ............................... 2-38
    Closing and Resizing Panes ............................. 2-39
  Using Tool Windows .......................................... 2-39
    Resizing Panes ............................................. 2-40
    Moving Panes .............................................. 2-41
    Closing Panes ............................................. 2-41
  Managing Tags ................................................... 2-41
  Setting Options ................................................. 2-54
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managing Option Sets</td>
<td>2-56</td>
</tr>
<tr>
<td>Exporting Diagrams and Reports</td>
<td>2-60</td>
</tr>
<tr>
<td>Using the Guide for a Tool</td>
<td>2-61</td>
</tr>
<tr>
<td>What's Next?</td>
<td>2-62</td>
</tr>
</tbody>
</table>

### Appendix A: Object and Construct Model Icons

- Object Model Icons: A-1
- Construct Model Icons: A-3

### Glossary

### Index
Preface

The Modernization Workbench is a suite of PC-based software products for analyzing, re-architecting, and transforming legacy applications. The products are deployed in an integrated environment with access to a common repository of program objects. Language-specific parsers generate repository models that serve as the basis for a rich set of diagrams, reports, and other documentation.

The Modernization Workbench suite consists of customizable modules that together address the needs of organizations at every stage of legacy application evolution: maintenance/enhancement, renovation, and modernization.

Audience

This guide assumes that you are a corporate Information Technology (IT) professional with a working knowledge of the legacy platforms you are using the product to analyze. If you are transforming a legacy application, you should also have a working knowledge of the target platform.
Organization

This guide contains the following chapters:

• Chapter 1, “Introducing the Modernization Workbench,” describes the Modernization Workbench tools, process, basic concepts, and supported legacy languages.

• Chapter 2, “Modernization Workbench Basics,” describes how to start the Modernization Workbench, create workspaces, add files to a workspace, use workbench windows, and set workbench options.

• Appendix A, “Object and Construct Model Icons,” describes the icons used by the Modernization Workbench tools for Cobol, PL/I, and Natural objects and constructs.

• The Glossary defines the names, acronyms, and special terminology used in this guide.

Conventions

This guide uses the following typographic conventions:

• **Bold type:** indicates a specific area within the graphical user interface, such as a button on a screen, a window name, or a command or function.

• *Italic type:* indicates a new term. Also indicates a document title. Occasionally, italic type is used for emphasis.

• **Monospace type:** indicates computer programming code.

• **Bold monospace type:** indicates input you type on the computer keyboard.

• **1A/1B, 2A/2B:** in task descriptions, indicates mutually exclusive steps; perform step A or step B, but not both.
Related Manuals

This document is part of a complete set of Modernization Workbench manuals. Together they provide all the information you need to get the most out of the system.

- *Preparing Projects* describes how to set up Modernization Workbench projects. This guide describes how to load applications in the repository and how to use reports and other tools to ensure that the entire application is available for analysis.

- *Analyzing Projects* describes how to analyze applications at the project level. This guide describes how to create diagrams of applications, how to perform change analysis across applications, and how to estimate application complexity and effort.

- *Analyzing Programs* describes how to analyze applications at the program level. This guide describes how to use HyperView tools to view programs interactively and perform program analysis in stages. It also describes how to set up an application glossary and how to extract business rules.

- *Managing Application Portfolios* describes how to build enterprise dashboards that track survey-based metrics for applications in your portfolio. It also describes how to use Enterprise View Express to browse Web-generated views of application repositories.

- *Creating Components* describes how to use Application Architect to extract program components from legacy applications.

- *Batch Refresh Process* describes how to use the Modernization Workbench Batch Refresh Process utility to batch-synchronize workbench sources with sources at their original location.

- *Transforming Applications* describes how to generate legacy application components in modern languages.

- *Error Messages* lists the error messages issued by Modernization Workbench, with a brief explanation of each and instructions on how to proceed.
Online Help

In addition to the manuals provided with the system, you can learn about the product using the integrated online help. All GUI-based tools include a standard Windows Help menu.

You can display:

- The entire help system, with table of contents, index, and search tool, by selecting Help:Help Topics.
- Help about a particular Modernization Workbench window by clicking the window and pressing the F1 key.

Many Modernization Workbench tools have guides that you can use to get started quickly in the tool. The guides are help-like systems with hyperlinks that you can use to access functions otherwise available only in menus and other program controls.

To open the guide for a tool, choose Guide from the View menu. Use the table of contents in the Page drop-down to navigate quickly to a topic.
Introducing the Modernization Workbench

The Modernization Workbench is a suite of PC-based software products for analyzing, re-architecting, and transforming legacy applications (Figure 1-1). The products are deployed in an integrated environment with access to a common repository of program objects. Language-specific parsers generate repository models that serve as the basis for a rich set of diagrams, reports, and other documentation.

Modernization Workbench Products

The Modernization Workbench suite consists of customizable modules that together address the needs of organizations at every stage of legacy application evolution: maintenance/enhancement, renovation, and modernization. Each module is separately licensed.
Application Analyzer

Application Analyzer is a robust set of non-invasive interactive tools that work with source code, system files, DDL, screen maps, and more. Use it for analyzing and documenting legacy systems at both the application and program levels.

Use Application Analyzer at the application level to:

• Create diagrams of applications.
• Perform change analysis across applications.
• Estimate application complexity and effort.

Use Application Analyzer at the program level to:

• View programs interactively.
• Perform program analysis in stages.
• Perform impact analysis on a program.
• Model and search the repository.
Introducing the Modernization Workbench

Modernization Workbench Products

Enterprise View Express

Enterprise View Express hosts enterprise dashboards that track survey-based metrics for the applications in your portfolio. Its easy-to-use Web interface lets you:

- Create, distribute, and gather responses to surveys about your organization’s business processes and data.
- Collate survey results to define the range of information to collect.
- Display the results in charts, graphs, and tables on Enterprise View Express dashboards.

You can also use Enterprise View Express to browse repositories. Its convenient Web interface makes it the ideal tool for managers, business analysts, testers, and customer support personnel who need ready access to repositories across your organization.

Application Architect

Application Architect offers a variety of advanced algorithms for slicing logic from program source: all the code needed for a computation, for example, or to “specialize” a program based on the value of a variable. You can create a self-contained program, called a component, from the sliced code or simply generate a list of sliced constructs for further analysis.

Both the component generation and list functions are supported in the full version of the Component Maker tool available to users of Application Architect. The list function only is supported in the restricted version of Component Maker, called Logic Analyzer, available to users of Application Analyzer.

Business Rule Manager

Business rules encapsulate your application’s business logic, making the application easier to understand, document, and test. Business rule mining lowers the risk and cost of maintenance and enhancement, and ensures that all business logic is implemented in modernization efforts.
A business rule is a named container for program code that performs a discrete task in a business process. It identifies and documents the code segment that performs this task. A business rule named Calculate Date Difference, for example, might consist of this segment:

\[
\text{COMPUTE WS-DATE-VARIANCE = WS-C-CARD-DATE-CCYYMM - WS-TODAYS-DATE-CCYYMM.}
\]

Business Rule Manager (BRM) offers a powerful set of tools for autodetecting, and autodocumenting, business rules. You can batch edit rule attributes; create custom attributes suited to your particular needs; match input/output data elements with the business names you’ve assigned to them in your project glossary; and much more.

**Transformation Assistant**

Transformation Assistant automates the process of translating applications to new platforms without losing functionality the business depends on. Use it to move whole applications or critical pieces.

- **Screen translation** helps users add event handling to legacy screens and generate the screens for HTML or Java. An emulation facility allows users to validate and refine screen flows without generating or compiling new sources.
- **Business logic translation** generates source program code in Java. It’s also possible to generate the Java bean that gives access to the converted program’s input and output.
- **Database access translation** examines how data is stored in the legacy system and assists in the creation of a relational database schema that describes the design of the database in the application. Object-oriented access methods can be generated and exported for the new database schema.

**Modernization Workbench Process**

Figure 1-2 shows the Modernization Workbench process. Each stage in the process has a corresponding menu in the Modernization Workbench window. (Of course, you will only see a menu if you are licensed to use the product.) Let’s take a brief look at each of the stages.
Prepare
Before you can analyze a legacy application, you need to prepare it. Preparing an application consists of loading, or registering, the application in the repository, and then verifying that the entire application can be understood by the Modernization Workbench parser. You use reports and other tools to ensure that your application can be parsed in its entirety.

Analyze
Application analysis is the basis for all of the remaining stages in the process. You analyze legacy systems at the application or program level.

- Use the application analysis tools to create diagrams of applications and perform change analysis across applications. Other application analysis tools let you estimate project complexity and effort and analyze data flows.
- Use the program analysis tools (collectively called HyperView) to view programs interactively and perform program analysis in stages.
You can also use HyperView to analyze procedure and data flows, extract business rules, and create logical components.

**More On HyperView**
HyperView tools are available within the application analysis tools as well, but “silently” (without your ever actually invoking them as HyperView tools).

**Profile**
Profiles are Enterprise View Express views into a repository that show all of the analysis you have done on an application. Profiles are convenient ways to share information about legacy applications across your organization.

**Architect**
A structured architecture reduces complexity and eases modernization. In this stage, you “slice” a legacy application into new components. It’s a good idea to perform some re-architecting activity (dead code elimination, for example) before undertaking transformation.

**Extract**
Business rule extraction distills business logic from complex code for documentation, gap analysis, application redevelopment, test planning, and other management tasks.

**Transform**
Legacy transformation automates the conversion of legacy applications to modern computing platforms, languages, and/or paradigms. Use the tools to transform program logic, user interfaces, and data structures.
How Modernization Workbench Models Applications

Modernization Workbench is a model-based technology that generates information about legacy applications at two levels:

- Application-level information describes the relationships between the *objects* that comprise an application: its programs, copybooks, JCLs, BMS files, and so forth.

- Object-level information describes the relationships between the abstract syntactical *constructs* that comprise an object: its sections, paragraphs, statements, conditions, variables, and so forth.

At both levels, the models are conceived as *Entity Relationship Diagrams* (ERDs). Each object or construct the parser generates is modeled as an *entity* in one of the diagrams. The models are represented in tree form to users.

**Note:** Appendix A describes the icons used for Cobol, PL/I, and Natural source in the object and construct models.

Understanding Application-Level Information

The *object model* for an application defines the relationships between the objects that comprise the application. These can be physical objects, like program source files or JCLs, or logical objects that identify abstract program elements: entry points, data stores, screens, jobs, and the like.

The *relationships* between objects describe the ways in which they interact. In Figure 1-3 the source file GSS.CBL *defines* the GSS program. The program, in turn, *reads* the data file GSS.FCSTSEC.
Understanding Object-Level Information

The construct model for an object defines its syntax. It shows in abstract form how the syntactical constructs that comprise the object (its sections, paragraphs, statements, conditions, variables, and so forth) are related. A variable, for example, can be related in the construct model to its declaration, a dataport (if it is used in an I/O statement), or a condition (if the condition uses an expression of which the variable forms a part).

Figure 1-4 shows a portion of the construct model for the GSS program. The model shows that the program executes a PERFORM statement if the value of the variable EIBRESP satisfies the condition EIBRESP NOT EQUAL DFHRESP(NORMAL).

Figure 1-4 Use of EIBRESP Variable

If you are interested in investigating other uses of EIBRESP in the program, you can navigate to the declaration of the variable in the construct model, and from the declaration to each instance of the variable’s use in the program.

Workspaces and Projects

Modernization Workbench uses the familiar notions of workspace and project to help users organize application source files conveniently. A workspace is a named container for an application or a portion of an
application. Every workspace has a corresponding database repository of model objects.

You can divide a workspace up into projects that represent different portions of your application. You might have a project for the batch portion of the application and another project for the online portion, for example. You can also use a project to collect items for discrete tasks: all the source files affected by a change request, for example.

When you set up a workspace in the Modernization Workbench, the system creates a default project with the same name as the workspace. You can create new projects and move or copy entities between projects as needed.

A workspace can contain objects coded in different programming languages. You can create multiple workspaces on the same machine.

**Single-User versus Multiuser Environments**

Modernization Workbench can be deployed in a single-user or multiuser environment:

- In a single-user environment, the workspace repository resides on the local machine, and can be accessed by the owner of the machine only. Limited facilities exist for sharing work with other users.
- In a multiuser environment, the workspace repository resides on a database server, and can be accessed by any user with appropriate database privileges.

Most installations deploy Modernization Workbench in a multiuser environment. Single-user mode typically is reserved for special needs.

The guidelines that follow for multiuser environments apply equally to single-user environments. For installation instructions, see the installation guide for your product.
**Multiuser Environment Basics**

A multiuser Modernization Workbench environment gives members of a development team common access to a workspace repository on a database server. Workspace setup is the responsibility of a master user, leaving team members free to focus on their tasks. Common access makes it easy to share insights across the team, and ensures that team members view the same source and work with the same option settings.

**Deployment Scenario**

Figure 1-5 shows a standard deployment scenario for the Modernization Workbench multiuser environment. The role each machine performs and its key relationships are described below. Keep in mind that the view is logical. Machine roles can be combined or separated as required.

**Figure 1-5  Standard Multiuser Deployment**
Mainframe and Network Server

The mainframe hosts the application to be modeled in Modernization Workbench. Application source files are downloaded from the mainframe (and, if necessary, a network server) to the Modernization Workbench server via FTP or SFTP.

Modernization Workbench Server

The Modernization Workbench server hosts workspaces, workspace support files (including the copies of application source files the workbench creates at workspace loading), and workspace output. This server leverages multiple processes to enhance parsing performance in online or batch mode.

Parsed data is sent via ODBC to the database server. Some analysis output is stored on the workbench server as well.

Database Server

The database server hosts the database for one or more multiuser repositories. This server provides centralized, network-accessible storage for parsed data and analysis output.

The workbench server, Enterprise View Express Web Server, and workbench clients access the database server via ODBC. For guidance on database setup, see the installation guide for your product.

Modernization Workbench Client

Workbench clients host the link files that let team members connect to workspaces on the workbench server. These clients access repository data stored in the database server via ODBC.

Modernization Workbench Enterprise View Express Web Server

The Enterprise View Express web server hosts services used by intranet and internet Enterprise View Express clients to access web-based view of repositories. For charts displayed in browser-based dashboards, the Enterprise View Express web server submits requests to the NetCharts application server via HTTP or SSL.
**NetCharts Application Server**

The NetCharts application server receives requests for charts from the Enterprise View Express web server, processes the requests, and returns charts to the Enterprise View Express web server via HTTP or SSL.

**Modernization Workbench Web Client**

Enterprise View Express web clients provide multiuser access to charts and workspace repository data via the Enterprise View Express web server.

**Workbench Privileges**

Privileges in a multiuser environment work on two assumptions:

- Team members typically do not need to modify files until they have completed analysis and are ready to test a proposed change.
- The team lead is best situated to make the change and reverify the modified file.

For these reasons, the workbench multiuser environment has no need for file checkout and locking of the kind seen in conventional multiuser environments.

**Understanding Master Users**

The user who creates a workspace on a Modernization Workbench server machine is referred to as its owner. Initially, only the owner has master user privileges for the workspace. The master user can delete the workspace, upgrade the workspace configuration, register and verify source files, modify source, autoresolve decisions, perform restricted Clipper searches, create, assign, and delete tags, and so forth. The master user can also designate new master users for the workspace.

Ordinary users connect to the workspace from Modernization Workbench client machines. These users can do everything else: analyze programs, mine business rules, extract components, and so on.

If you do not have master user privileges for a workspace, you will not see menu choices for privileged methods. The same team member can be a master user for one workspace and an ordinary user for another.
Understanding Workspace Security Policies

When you create a workspace, you can choose from two workspace security policies:

- The *Simple Security Policy* recognizes two classes of users, master users and ordinary users.
- The *Three-Group Security Policy* recognizes a third class of users, *subject matter experts (SMEs)*, with special privileges to create, assign, and delete tags.

In each policy, the master user can create new master users. For more information, see “Creating a Workspace” on page 2-1.

Using the Optional File Server

When you create a workspace, you can restrict Windows access to workspace source files to master users, while using the optional File Server to make the source files available in the workbench to ordinary users. As long as you set up workspace folder privileges correctly, ordinary users can view and analyze sources in the workbench, but cannot access them otherwise. For more information, see “Creating a Workspace” on page 2-1. For file server installation instructions, see the installation guide for your product.

Public and Private Visibility

In a multiuser environment, the user who creates a workspace resource (a project or a Clipper list, for example) is referred to as its *owner*. Only the owner can *share* the resource with other users.

A shared, or *public*, resource is visible to other members of your team. If the resource is *protected*, these team members can view but not edit or delete the resource. A Clipper list, for example, is always protected.

You can turn sharing on and off in the tool you use to create the resource. Look for a symbol like this one for a shared project 📖 to indicate that the resource is shared. For more information on sharing projects, see *Preparing Projects* in the workbench documentation set.
Protecting Projects

By default, projects are unprotected: any user to whom the project is visible can delete the project, add source files, or remove source files.

The project owner or master user can designate a project as protected, in which case no user can delete or modify the project, including the project owner or master user: the project is read-only, until the project owner or master user turns protection off.

Turn on protection by selecting the project in the Repository pane and choosing Toggle Protection in the Project menu. Choose Toggle Protection again to turn it off. Look for a symbol like this one  to indicate that a project is protected.

Dropping Indexes

If you are a master user with responsibility for verifying source files in a multiuser environment, you will almost always want to drop database indexes to improve verification performance. You will be prompted to drop indexes when you verify the application, or you can drop indexes at a time of your own choosing by selecting Drop Repository Indexes in the Prepare menu.

When you drop indexes, you are prompted to restore the indexes when you analyze the files. If you want to restore indexes at a time of your own choosing, choose Restore Repository Indexes in the Prepare menu.

Computing Statistics

You typically need to gather statistics for your system before the optimizer for your RDBMS can determine the most efficient way to execute SQL statements. If you are a master user with responsibility for verifying source files in a multiuser environment, you will almost always want to gather system statistics after verification to improve performance of the Modernization Workbench analysis tools.

Note: Check with your DBA before gathering system statistics. In Oracle, you must have GATHER_SYSTEM_STATISTICS privileges to execute this method. Make sure to restore indexes before gathering system statistics.
To gather system statistics, choose **Compute Database Statistics** in the **Prepare** menu. You can view the generated statistics in your RDBMS.

**Supported Legacy Languages**

Modernization Workbench tools work with legacy applications written in Cobol, PL/I, Natural, and other programming languages. Your license determines which languages your installation supports. For detailed information, see the support guides provided for each language. You can find the support guides in **Start>All Programs:Micro Focus:Modernization Workbench Documentation**.

**What’s Next?**

Those are all of the basic concepts underlying the Modernization Workbench scheme. The next chapter describes basic workbench features.
Introducing the Modernization Workbench

What's Next?
This chapter looks at some elementary Modernization Workbench tasks: how to create a workspace and project, register and verify source files, use workbench windows, manage tags, set options, and export system diagrams and reports.

Creating a Workspace

You create a workspace on the Modernization Workbench server machine. Other users connect to the workspace from Modernization Workbench client machines, as described in “Connecting to a Workspace” on page 2-11.

The workspace repository resides on a database server, and can be accessed by any user with database privileges to the repository. For background, see “Multiuser Environment Basics” on page 1-10.

Important: Do not modify the name of the workspace after you create it. Doing so will cause unpredictable results.
Before You Begin

Configure an ODBC data source name (DSN) for the database that holds the workspace repository, as described in the installation guide for your product. You will need the following information to create the workspace:

- The data source name.
- The database schema name your DBA created for the repository.
- The database user name and password that give access to the schema.
- If you use DB/2, the name of the tablespace your DBA created for the repository. If the DBA also created a tablespace for database indexes, you will need the name of that tablespace as well.

The folder in which you plan to create workspaces must be shared with team members. It’s usually more convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then refresh the workspace path as described in “Refreshing the Workspace Path” on page 2-9.

To create a workspace:

1A If you have just completed workbench configuration on the server and the Modernization Workbench Administration window is still open, skip to step 2.

1B Otherwise, go to the Programs folder in the Windows Start menu on the server. Choose Micro Focus, then Modernization Workbench Administration. The Modernization Workbench Administration window opens (Figure 2-1).
In the **Administer** menu, choose **New Workspace**. The Create new workspace dialog opens (Figure 2-2).

![Create New Workspace Dialog](image)

In the Create new workspace dialog, double-click the **New Workspace** icon for the RDBMS at your site or select it and click **OK**. The New workspace dialog opens (Figure 2-3).

![New Workspace Dialog](image)

In the Create new workspace dialog, double-click the **New Workspace** icon for the RDBMS at your site or select it and click **OK**. The New workspace dialog opens (Figure 2-3).
4 In the New workspace dialog, choose the location for the workspace in the **Save in** drop-down. In the **File name** field, enter the name of the workspace. Choose a name that describes the legacy application as closely as possible. Click **Save**. The Define Connection Parameters dialog opens (Figure 2-4).

![Figure 2-4 Define Connection Parameters Dialog](image)

5 In the Define Connection Parameters dialog, click the Connection tab. On the Connection tab, enter:

- The ODBC data source name you defined in ODBC data source configuration. If you have not defined a data source name, or want to use a different data source name, click **ODBC Manager** to open the data source name configuration dialog, then follow the instructions for ODBC data source configuration in the installation guide for your product.

- The database schema name your DBA created for the workspace repository.

- The database user name and password that give access to the schema.
• The name of the tablespace your DBA created for the repository in the **Tablespace** field. If your DBA also created a tablespace for database indexes, enter the name of that tablespace in the **Tablespace for Indexes** field.

6 Click the Security tab. In the Policies list box, select:

• **Simple Security Policy** if you want to enforce a workspace security policy that recognizes two classes of users, master users and ordinary users. Designate new master users as described in "Designating New Master Users in a Simple Security Policy" on page 2-6.

• **Three-Group Security Policy** if you want to enforce a workspace security policy that recognizes a third class of users, *subject matter experts (SMEs)*, with special privileges to create, assign, and delete tags. Designate SMEs and new master users as described in "Designating Users in a Three-Group Security Policy" on page 2-7.

In the Files access group box, select:

• **Direct sources access via Windows share** if your site does not restrict Windows access to workspace source files to the master user.

• **Secure sources access via RMW file server** if your site restricts Windows access to workspace source files to the master user, while using the optional file server to make the source files available in the workbench to ordinary users. Make sure the values for the server name and port number fields are correct.

**Note:** For File Server installation and setup instructions, see the installation guide for your product.

Click **OK**. You are notified that the workspace was created successfully. The workbench creates a workspace file (.rwp) and a folder with the same name in the specified location. The workspace folder contains support files and subfolders for workbench output. Open the workspace as described in "Opening a Workspace" on page 2-13.
Designating Users for Security Policies

When you create a workspace, you choose from two workspace security policies:

- The **Simple Security Policy** recognizes two classes of users, master users and ordinary users.
- The **Three-Group Security Policy** recognizes a third class of users, subject matter experts (SMEs), with special privileges to create, assign, and delete tags.

In each policy, the master user can create new master users.

**Designating New Master Users in a Simple Security Policy**

A Simple Security Policy recognizes two classes of users, master users and ordinary users. Initially, only the workspace creator has master user privileges. The master user can designate new master users as described in this section.

**To designate new master users in a Simple Security Policy:**

1. **If you have just completed creating a workspace and the Modernization Workbench Administration window is still open, skip to step 2.**
2. **Otherwise, go to the Programs folder in the Windows Start menu. Choose Micro Focus, then Modernization Workbench Administration.** The Modernization Workbench Administration window opens (Figure 2-1).
3. In the **Administer** menu, choose **Edit Users**. An Edit Users dialog similar to the one shown in Figure 2-3 opens.
4. In the Edit Users dialog, select the workspace (.rwp file) for which you want to designate new master users and click **Open**. The Security dialog opens (Figure 2-5).
4. The Security dialog displays a list of users who have connected to the workspace in the Known Users list box and a list of master users in the Master Users list box. Select a known user and click the > button to move the known user into the list of master users. Select a master user and click the < button to move the master user into the list of known users.

**Tip:** Click Refresh at any time to update the lists.

5. To create a new master user, click (New User...) in the Master User list box. A dialog opens prompting you to enter the name of the new master user. Enter the name and click OK.

6. When you are satisfied with your entries, click Close.

**Figure 2-5  Security Dialog**

---

**Designating Users in a Three-Group Security Policy**

A Three-Group Security Policy recognizes a third class of workspace users in addition to master users and ordinary users: subject matter experts (SMEs), with special privileges to create, assign, and delete tags. The
master user can designate SMEs and new master users as described in this section.

**To designate users in a Three-Group Security Policy:**

1A If you have just completed creating a workspace and the Modernization Workbench Administration window is still open, skip to step 2.

1B Otherwise, go to the **Programs** folder in the Windows **Start** menu. Choose **Micro Focus**, then **Modernization Workbench Administration**. The Modernization Workbench Administration window opens (Figure 2-1).

2 In the **Administer** menu, choose **Edit Users**. An Edit Users dialog similar to the one shown in Figure 2-3 opens.

3 In the Edit Users dialog, select the workspace (.rwp file) for which you want to edit users and click **Open**. The Security dialog opens (Figure 2-6).

![Security Dialog](image)

4 The Subject Matter Experts and Master Users tabs of the Security dialog display a list of users who have connected to the workspace in the Known Users list box and a list of subject matter experts and
master users, respectively, in the opposite list box. Select a known user and click the > button to move the known user into the list of subject matter experts or master users. Select a subject matter expert or master user and click the < button to move the subject matter expert or master user into the list of known users.

Tip: Click Refresh at any time to update the lists.

5 To create a new subject matter expert or master user, click (New User...) in the Subject Matter Experts or Master Users list box. A dialog opens prompting you to enter the name of the new subject matter expert or master user. Enter the name and click OK.

6 When you are satisfied with your entries, click Close.

Refreshing the Workspace Path

The folder in which you plan to create workspaces must be shared with team members. It’s usually more convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then refresh the workspace path as described below. You can also use the refresh path feature when you move a workspace.

Note: For instructions on how to share a workspace folder, see the installation guide for your product.

To refresh the workspace path:

1A If you have just completed workbench configuration and the Modernization Workbench Administration window is still open, skip to step 2.

1B In the Windows Start menu, go to the Programs folder. Choose Micro Focus, then Modernization Workbench Administration. The Modernization Workbench Administration window opens (Figure 2-1).

2 In the Administer menu, choose Refresh Workspace Path. A Refresh Workspace Path dialog similar to the one shown in Figure 2-3 opens.
3 In the Refresh Workspace Path dialog, select the workspace (.rwp file) whose path you want to refresh and click Open. The Workspace directory network path dialog opens (Figure 2-7).

Figure 2-7  Workspace Directory Network Path Dialog

4 In the Workspace directory network path dialog, enter the path of the workspace in the text field. The path must be of the form:

```
\machine_name\share_name\workspace_folder_name
```

where `machine_name` is the name of the machine where the shared folder resides, `share_name` is the value of the Share name field on the Sharing tab of the Properties dialog for the shared folder, and `workspace_folder_name` is the name of the folder for the workspace. Figure 2-8 shows the correct form of the path.

Note: The shared folder is the folder that contains the .rwp file for the workspace, not the workspace folder. The workspace folder (containing support files and subfolders for workbench output) resides on the same level as the .rwp file.

5 When you are satisfied with your entry, click OK.

Figure 2-8  Correct Workspace Directory Network Path
Connecting to a Workspace

Once a workspace has been created on the Modernization Workbench server machine, other users can connect to the workspace from workbench clients. When you connect to a workspace, you create a link file with connection information that points to the workspace. Because the connection information is already stored in the file, you don’t have to enter it again when you reopen the workspace connection. Like a workspace file, a link file has a .rwp extension.

**Before You Begin**

Configure an ODBC data source name (DSN) for the database that holds the workspace repository you want to link to, as described in the installation guide for your product. You will need the following information to link to the workspace:

- The RDBMS in use at your site.
- The data source name.
- The database schema name your DBA created for the repository you want to link to.
- The database user name and password that give access to the schema.

**To link to a workspace:**

1. In the Windows Start menu, go to the Programs folder. Choose Micro Focus, then Modernization Workbench. The Open Existing workspace dialog opens above the Modernization Workbench main window. Click Cancel to dismiss the dialog.

2. In the File menu, choose Build New Connection. The Define Server Workspace Connection dialog opens (Figure 2-9).
In the Define Server Workspace Connection dialog, select the ODBC driver for the RDBMS in use at your site in the **Database Provider** drop-down. In the Required Parameters group box, enter:

- The ODBC data source name you defined in ODBC data source configuration. If you have not defined a data source name, click **ODBC Manager** to open the data source name configuration dialog, then follow the instructions for ODBC data source configuration in the installation guide for your product.
- The database schema name your DBA created for the workspace repository.
- The database user name and password that give access to the schema.

**Note:** The **Tablespace** and **Tablespace for Indexes** fields are for future use.

Click the Browse button for the **Save Link As (.rwp)** field. The Save Server Workspace Connectivity dialog opens (Figure 2-10).
In the Save Server Workspace Connectivity dialog, choose the location for the workspace link in the **Save in** drop-down. In the **File name** field, enter the name of the link. Click **Save**.

The linked workspace opens in the Modernization Workbench main window. The workbench creates a link file (.rwp) in the specified location.

**Figure 2-10  Save Server Workspace Connectivity Dialog**

---

**Opening a Workspace**

The procedure described below for opening a workspace is the same whether you created the workspace or simply connected to it. You can also open a workspace by double-clicking it in the file system. You don’t have to close a workspace before opening another workspace.

**To open a workspace:**

1. In the Modernization Workbench **File** menu, choose **Open Workspace**. The Open existing workspace dialog opens (Figure 2-11).

2A. In the Existing tab, choose the drive and folder for the workspace you want to open. A list of workspaces in the selected folder is displayed in the righthand pane. Double-click the workspace you want to open, or select it and click **OK**.

2B. In the Recent tab, double-click the recently opened workspace you want to open, or select it and click **OK**.
Note: If you created the workspace in a previous release of Modernization Workbench, the system prompts you to upgrade the workspace to the new release. Click Yes.

3 The workspace is displayed in the Modernization Workbench window. If a workspace was already open in the window, the selected workspace replaces it. Modernization Workbench creates a default project with the same name as the workspace.

Figure 2-11  Open Existing Workspace Dialog

Registering Source Files

Before you can analyze application source files in Modernization Workbench, you need to load, or register, the source files in a workspace. Only a master user can register source files in a multiuser environment.

The workbench assumes that input source files are ASCII files in DOS format. Occasionally, files may be converted incorrectly from other for-
mats to DOS-based ASCII with an extra special character (like “M”) at the end of each line. While Modernization Workbench accepts these files as input, some workbench tools may not work correctly with them. Make sure all source files are in valid ASCII format.

You can register source files in compressed formats (ZIP or RAR), as well as uncompressed formats. Modernization Workbench automatically unpacks the compressed file and registers its contents.

The workbench extracts compressed source files using the command line syntax for archiver versions most widely in use. If you use newer archiver versions, specify the command line syntax in the Archivers tab of the User Preferences window.

Workspace Registration options determine registration behavior. The default values for these options are preset based on your configuration and should be appropriate for most installations. You can learn more about the options in Preparing Projects in the workbench documentation set.

**Note:** Make sure you have assigned appropriate file extensions to legacy files before registering them. You can view and add to the recognized extensions in the Extensions tab of the Workspace Registration options window.

**To register source files:**

1. Set registration options as described in Preparing Projects in the workbench documentation set.
2. In the Modernization Workbench Repository pane, create a project for the source files you want to register, or use the default project. To create a project, choose **New Project** in the **Project** menu. The Create Project dialog opens. Enter the name of the new project and click **OK**. The new project is displayed in the Repository pane.
3. Select the project in the Repository pane, then drag-and-drop the file or folder for the source files you want to register onto the Repository pane.

You are notified that you have registered the files successfully and are prompted to verify the files. Click **Close**. The Repository pane displays the contents of the new workspace, organized by file type.
Verify the files as described in “Verifying Source Files” on page 2-16.

Tip: In the notification dialog, select Never ask again if you do not want to be prompted to verify files. In the Environment tab of the User Preferences window, select Ask user about verification if you want to be prompted again.

Verifying Source Files

Parsing, or verifying, an application source file generates the object model for the file. Only a master user can verify source files in a multiuser environment.

You can verify a single file, a group of files, all the files in a folder, or all the files in a project. It’s usually best to verify an entire project. Modernization Workbench parses the files in appropriate order, taking account of likely dependencies between file types. Verify Cobol copybooks only if you plan to use the Data Fusion Facility for copybooks not included in a source file.

If your RPG or AS/400 Cobol application uses copy statements that reference Database Description or Device Description files, or if your MCP Cobol application uses copy statements that reference DMSII DASDL files, you need to generate copybooks for the application before you verify program files, as described in Preparing Projects in the workbench documentation set.

For distributed languages, consult the support notes in the relevant language support guide for pre-verification requirements. You can find the guides in Start:All Programs:Micro Focus:Modernization Workbench Documentation.

Workspace and Project Verification options determine verification behavior. The default values for these options are preset based on your configuration and should be appropriate for most installations. You can learn more about the options in Preparing Projects in the workbench documentation set.
To verify source files:

1. Set verification options as described in Preparing Projects in the workbench documentation set.

2A. In the Modernization Workbench Repository pane, select the project, folder, or files you want to verify and choose Verify in the Prepare menu.

2B. In the Modernization Workbench Repository pane, select the Cobol copybooks you want to verify and choose Verify Copybook in the Prepare menu.

Note: In a multiuser environment, you are prompted to drop repository indexes to improve verification performance. Click Yes. You will be prompted to restore the indexes when you analyze the files. For more information, see “Dropping Indexes” on page 1-14.

The parser builds an object model for each successfully verified file. For an unsuccessfully verified file, the parser builds an object model for as much of the file as it understands.

Verification results are denoted as follows:

- A blue dot means that the parser has verified the file successfully.
- A red dot means that the parser has encountered an error in the file.
- A yellow dot means that the parser has encountered an error in the file, but that the file has been successfully verified under the relaxed parsing option.

Note: When you edit a file, the modified file and any dependent files are invalidated, and need to be verified again.
Using the Modernization Workbench Main Window

The Modernization Workbench main window lets you view and edit projects, set workbench options, and open workbench tools. The window’s state (size, location, menu selections, and option settings) is saved across sessions. Menu selections for the panes in the window are available only if the pane has the focus. Most workbench menu choices have equivalent choices in the right-click menu.

Figure 2-12 shows the Modernization Workbench main window in a typical configuration. This section takes a closer look at the items labeled in the figure.
**Menus**

Modernization Workbench menus let you access workbench tools and other workbench functionality. Menus are displayed only for the products you have enabled in the Configuration Manager. Table 2-1 shows the relationship between menus and products.

<table>
<thead>
<tr>
<th>Product</th>
<th>Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Analyzer</td>
<td>Analyze</td>
</tr>
<tr>
<td>Enterprise View Express</td>
<td>Profile</td>
</tr>
<tr>
<td>Application Architect</td>
<td>Architect</td>
</tr>
<tr>
<td>Business Rule Manager</td>
<td>Extract</td>
</tr>
<tr>
<td>Transformation Assistant</td>
<td>Transform</td>
</tr>
</tbody>
</table>

*Note:* The screens shown in the Modernization Workbench document set display the menu bar with all products installed.

**Customizing Menus**

Modernization Workbench-specific menus are fully customizable. You control which menus, choices, and tool bars the system displays. You can save a menu bar configuration and restore it with a single mouse click.

*Note:* You cannot customize the Windows standard menus (File, Edit, View, and so forth).

**To customize Modernization Workbench menus:**

1. In the **Tools** menu, choose **Customize Menu**. You are prompted to close the Editor pane. Click **OK**. The Customize Menu window opens (Figure 2-13).

2. In the Customize Menu window, deselect the menus and/or menu choices you want to hide. Select the menus and/or choices you want to show.
3 Enter a name for the specified menu configuration in the drop-down list below the Load button.

4A Click Save if you want to save the configuration without dismissing the window.

4B Click OK if you want to save the configuration and dismiss the window. The new configuration is applied in the Modernization Workbench main window.

**Note:** To restore a menu configuration, select its name in the drop-down list and click Load. To restore the default configuration, select (default) in the drop-down list and click Load.

Figure 2-13  **Customize Menu Window**
**Tool Bars**

You can access a Modernization Workbench menu function by clicking its tool bar icon. The tool tip for an icon tells you what it does. Place your cursor over the icon for a moment. The tool tip will display.

The workbench has tool bars for the **File**, **Edit**, and **Project** menus, as well as the menus listed in Table 2-1. A tool bar is displayed only if its corresponding menu is displayed (see “Customizing Menus” on page 2-19). You can change the position of a tool bar by grabbing the delimiter at the left of the tool bar and dragging it to a new location (Figure 2-14).

![Changing the Position of a Tool Bar](image)

**Repository Pane**

The Repository pane displays the contents of the repository for the current workspace, organized by project. Double-click a file to display its source code in the Editor. Place your cursor over an object for a moment to display a tool tip that describes the object in more detail.

The drop-down on the **Project** tool bar displays the current project. You can navigate quickly to another project in the Repository pane by clicking the project name in the drop-down. Select (none) in the drop-down to make the entire workspace current.

**Unverified and Verified Workspaces**

If you have not verified a workspace file, the file is displayed in **bold** type. Since the system has not generated an object model of the file’s contents, only the file itself is displayed.

A verified file shows all the objects in the model generated for the file. Verification results are denoted as follows:
A blue dot ⚫ means that the parser has verified the file successfully.

A red dot ⚫ means that the parser has encountered an error in the file.

A yellow dot ⚫ means that the parser has encountered an error in the file, but that the file has been successfully verified under the relaxed parsing option.

Figure 2-15 compares unverified and verified workspaces. Notice in the verified workspace that the parser has built an object model for DayOfWeek.cbl, but not for DayOfWk.cbl, which contained an error. Generally, the parser creates an object model for as much of the file as it understands.

**Browser View**

The browser view of the Repository pane displays the object model for a workspace, organized in tree form by project, object type, and object relationship (Figure 2-16). The browser view is commonly called the Repository Browser.
Click the **Browser** choice in the **View** menu to show the Repository Browser. Click the plus sign (+) next to a relationship or object to expand its tree one level. Click the minus sign (-) to collapse the tree one level. Click **Refresh Browser** in the **View** menu to refresh the tree.

Select an object or relationship and choose **Expand Subtree** in the right-click menu to expand all levels in its tree in a single step. You can export a subtree to a text file by selecting its parent and choosing **Save Subtree** in the right-click menu. Appendix A describes the icons used in the tree.

By default, the browser displays repository trees for projects only. These trees show only objects you can act on in the browser.

To view all the objects in the workspace, choose **Entire Workspace** in the **View** menu. The workbench displays a folder for the workspace. Click the plus sign (+) next to the folder to expand the repository tree for the workspace.

To search for workspace objects in the Repository pane, choose **Search Criteria** in the **Edit** menu. The Search dialog opens (Figure 2-18). In the **Filter Name** drop-down, choose the filter for the search, then click **Find**. The results are returned in the search view. For instructions on how to set up a filter, see “Creating a Search Filter” on page 2-27.
Note: You can filter objects in a browser subtree using the advanced type ahead select function, as described in “Selecting Objects in the Repository Pane” on page 2-26.

Browser Fetch Buffer Size

When you refresh the repository tree, the browser populates the display from a buffer that contains the objects last fetched from the repository. The browser fetch buffer size specifies the number of objects in the buffer. For very large repositories, you may want to lower the buffer size so that you can work with objects in the browser while the workbench performs subsequent fetches.

To set the buffer size, choose Workspace Options in the Tools menu. In the General tab, specify the buffer size in the Browser Fetch Buffer Size field.

Note: If you use the Select choices in the Edit menu to select objects in the repository tree based on their verification status, and all the objects have not been fetched, the results are returned in the search view.

Search View

The search view of the Repository pane displays a sorted list of workspace objects returned by a search of the repository (Figure 2-17). Click the Search choice in the View menu to show the view.
Choose the filter for the search in the drop-down next to the search button. Click the search button to perform the search. For instructions on how to set up a filter, see “Creating a Search Filter” on page 2-27.

**Tip:** Export a list of objects to a text file by selecting it and choosing Save List in the right-click menu.

By default, the list shows two attributes of an object: its name and file type. Click the attribute column heading to sort the list by that attribute.

You can select additional attributes to display in the Workspace Options window. Choose Workspace Options in the Tools menu. In the General tab, select the attributes in the Display Attributes pane.

**Note:** Only attributes of the selected object are displayed. That is, if you choose the Cyclomatic Complexity attribute while a JCL file is selected, the attribute will not be displayed, because Cyclomatic Complexity is not an attribute of a JCL file.

**Hiding a Browser View or Search View**

You can hide a browser view or search view by selecting it and choosing Hide in the right-click menu. To restore the view, choose Browser or Search as appropriate in the View menu.
Tip: Occasionally, you may be able to improve performance (of a repository refresh, for example) by hiding the browser.

Selecting Objects in the Repository Pane

You select an object in the Repository pane by clicking it with the left mouse button. To select all the objects in the search view or all the objects under the selected workspace, project, or folder in the browser view, choose Select All in the Edit menu. To deselect objects, choose Unselect All in the Edit menu.

To select a range of objects, hold down the Shift key, click the first object in the range, then click the last object in the range. To select objects that are not in a range, hold down the Control key, then click each object you want to select.

Use the Select choices in the Edit menu to select objects based on their verification status. The choices operate on the entire list in the search view and on the objects under the selected workspace, project, or folder in the browser view.

Using the Type Ahead Select Functions

Use the simple type ahead select function to select displayed objects as you type. To use the simple function, make sure the browser view is current, then type the characters you want to match. You cannot use the simple type ahead select function in the search view.

Use the advanced type ahead select function to select objects in the browser or search view whether or not they are currently displayed, and to filter objects in a subtree. To use the advanced function, click an object that has the same type as the object you want to select, then click the button at the bottom of the pane. When the “type ahead select” function has been enabled, click the adjacent button. From the drop-down menu, choose:

- **Select** to match text explicitly.
- **Wildcard Select** to match text using wildcard patterns allowed in LIKE statements by Visual Basic for Applications (VBA).
Enter the text you want to match in the field next to the button. The tool selects matched objects as you type, as long as they are in the same subtree. Click the button to repeat the select with the same criterion.

To select multiple objects, enter the text you want to match in the field next to the button, then click the adjacent button. From the drop-down menu, choose:

- **Select All** to select multiple objects that match text explicitly.
- **Wildcard Select All** to select multiple objects that match text using wildcard patterns allowed in LIKE statements by Visual Basic for Applications (VBA).

The tool selects matched objects as long as they are in the same subtree. Click the button to repeat the select with the same criterion.

To filter objects in a subtree, enter the text you want to match in the field next to the button, then click the adjacent button. From the drop-down menu, choose **Filter**. The tool filters out unmatched objects from the current subtree. The filter and filter text are persistent for the subtree across sessions. To remove the filter and its text, enter an empty string in the text field and choose **Filter** again.

**Creating a Search Filter**

You can use predefined filters to search for objects in the Repository pane or create your own filters. You cannot modify a predefined filter.

**To create a search filter:**

1. In the **Edit** menu, choose **New Criteria**. The Search dialog opens (Figure 2-18).
To filter on object type, select the **Entity Type** check box and choose the entity type in the accompanying pane.

To filter on object name, select the **Object Name Like** check box and enter a matching pattern for the name in the accompanying field. You can use wildcard patterns allowed in LIKE statements by Visual Basic for Applications (VBA), as described in "Using Wildcard Patterns in Searches" on page 2-31.

To filter on verification status, select the **Where Parse Status** check box and choose the status in the accompanying group box.

To filter on a text string in the source, select the **Scan Legacy Sources For** check box, then select the matching pattern for the string in the accompanying combo box. Enter a new matching pattern by typing in the combo box. You can enter plain character strings, regular expressions, or wildcard patterns. Click the radio button for the type of pattern matching you want to use.
For regular expressions and wildcard patterns, click the ▶ button next to the drop-down to display a pop-up menu of elements you can insert in the pattern. Click an element to insert it.

You can use Posix regular expressions and wildcard patterns allowed in LIKE statements by Visual Basic for Applications (VBA), as described in “Using Wildcard Patterns in Searches” on page 2-31.

Tip: The matching pattern is saved when you save or execute the filter.

Select the check boxes below the drop-down if you want the search to match case, skip comments, and/or match whole lines.

6 In the Filter Name drop-down, enter the name of the search filter and click Save.

Tip: Every search filter you execute is saved, whether or not you save it explicitly.

To edit a search filter, select it in the Filter Name drop-down and follow the instructions for creating a filter. To delete a search filter, select it in the Filter Name drop-down and click Delete. To clear a search filter, select it in the Filter Name drop-down and click Clear.

Tip: To execute a search directly from the Search dialog, select the search filter in the Filter Name drop-down and click Find. The results are returned in the search view.

Finding and Replacing Text in Source Files

You can find and replace text in source files from the browser view or the search view. Use the Editor for simple find operations and to replace text in a selection of source code, as described in “Finding and Replacing Source” on page 2-36.

To find and replace text:

1 In the browser or search view, select the objects you want to replace text in and choose Replace in the Edit menu. The Replace dialog opens (Figure 2-19).
In the Scan Source pane, select the matching pattern for the text to find in the accompanying combo box. The drop-down lists matching patterns from previous find operations. Enter a new matching pattern by typing in the combo box. You can enter plain character strings, regular expressions, or wildcard patterns. Click the radio button for the type of pattern matching you want to use.

For regular expressions and wildcard patterns, click the button next to the drop-down to display a list of elements you can insert in the pattern. You can use Posix regular expressions and wildcard patterns allowed in LIKE statements by Visual Basic for Applications (VBA), as described in “Using Wildcard Patterns in Searches” on page 2-31.

Select the check boxes below the drop-down if you want the search to match case, skip comments, and/or match whole lines.

In the Replace with pane, select the replacement text in the accompanying combo box. The drop-down lists text strings from previous replace operations. Enter new replacement text by typing in the combo box.

Tip: If you used regular expressions for the find, click the button next to the drop-down to display a list of elements you can insert in the replacement text field.

Click Replace. You are prompted to confirm the replacement. Click Yes.
Using Wildcard Patterns in Searches

In most searches you perform in the workbench tools you can use wildcard patterns allowed in LIKE statements by Visual Basic for Applications (VBA). Table 2-2 shows the wildcard characters and what they match.

Table 2-2  Wildcard Characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Matches</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Any single character.</td>
</tr>
<tr>
<td>*</td>
<td>Zero or more characters.</td>
</tr>
<tr>
<td>#</td>
<td>Any single digit (0–9).</td>
</tr>
<tr>
<td>[charlist]</td>
<td>Any single character in charlist.</td>
</tr>
<tr>
<td>![charlist]</td>
<td>Any single character not in charlist.</td>
</tr>
</tbody>
</table>

To match the special characters left bracket ([), question mark (?), number sign (#), and asterisk (*), enclose them in brackets. The right bracket (]) cannot be used within a group to match itself, but it can be used outside a group as an individual character.

Specify a range of characters in a charlist by using a hyphen (–) to separate the upper and lower bounds of the range. [A–Z], for example, results in a match if the corresponding character position in a string contains any uppercase letters in the range A–Z. You can specify multiple ranges in brackets without delimiters.

Object Information

The Object Information pane displays comments you have entered for an object. Select the object and choose Object Information in the View menu to show the Object Information pane (Figure 2-20).

Enter comments for an object by selecting the object and choosing Properties in the right-click menu. In the Description tab, enter your comment in the text area and click OK. For more information on object properties, see “Viewing Object Properties” on page 2-38.
Activity Log

The Activity Log is a chronological record of your activities in the current session. Choose Activity Log in the View menu to show the Activity Log pane (Figure 2-21).

**Sorting Entries** Click a column heading in the Activity Log to sort the log by that column.

**Hiding Columns** Hide a column in the Activity Log by deselecting the column name in the Columns choice in the right-click menu.

**Sizing Columns** Grab-and-drag the border of a column heading in the Activity Log to increase or decrease the width of the column.

**Viewing Errors** If the parser generated errors or warnings for a file, double-click the Activity Log entry for the file or select the entry and choose Expand in the right-click menu to show a list of the errors and/or warnings.

- A blue dot • denotes successful parsing.
• A red dot  denotes an error. An error can have one of three severity levels: error, severe, critical, in order of increasing severity.

• A yellow dot  denotes a warning.

Double-click a message to navigate to the offending source in the Editor. Choose Collapse in the right-click menu to collapse the list.

Generating Reports  You can generate a report from the Activity Log by right-clicking in the log and choosing Report in the pop-up menu. For more information on reports, see “Exporting Diagrams and Reports” on page 2-60.

Clearing the Log  You can clear the Activity Log by right-clicking in the log and choosing Clear Log in the pop-up menu. You can clear a given log entry by selecting the entry and choosing Delete in the right-click menu.

Copying Records  To copy Activity Log records to the clipboard, select the records and choose Copy in the right-click menu.

Viewing History  To view Activity Log entries across sessions, choose History in the right-click menu. Click a date to view the session log. You can clear the history in the same way you cleared the log.

Editor and Viewer

The Editor lets you view and edit the source code for a file. The Viewer lets you view renderings of logical objects like screens and transformation target models. Double-click a file in the Repository pane to view it in the Editor (Figure 2-22) or Viewer. Choose Recent Sources in the File menu to open a file from a list of recently opened files.

Note:  When you edit a file, the modified file and any dependent files are invalidated, and need to be verified again. Only a master user can edit and verify source in a multiuser environment.
Editing and Saving Source  You can edit file source as you would text in a word processor (cut-and-paste, drag-and-drop, and so forth). Click Save in the File menu to save your changes. Your edits are saved in the version of the file maintained in the Workspace\Source subfolder. Only a master user can edit source files in a multiuser environment.

Note:  When you edit a file, the modified file and any dependent files are invalidated, and need to be verified again.
**Viewing a List of Errors** Choose **Errors: View Errors** in the **Edit** menu to list the errors and warnings generated for the file in a separate pane below the source code. Choose **Errors: Severity Filter** in the **Edit** menu to filter the list by severity. Deselect **Errors: View Errors** to hide the list. To view only the list of errors and warnings for the file, select it and choose **Show Errors** in the right-click menu.

**Locating Errors** Double-click an error or warning in the error list or Activity Log to navigate to the offending source in the Editor. Choose **Errors: Previous Error** or **Errors: Next Error** in the **Edit** menu to navigate to the previous and next errors, respectively, in the Editor.

**Extracting Copybooks (Cobol, MFS Only)** To extract source code as a copybook, select the code you want to extract, then choose **Extract Copybook** in the **Edit** menu. A dialog box opens, where you can enter the name of the new copybook. Click **OK**. The new copybook is added to the repository and the extracted code is replaced by a COPY statement referencing the new copybook.

**Expanding Copybooks (Cobol, MFS Only)** Choose **Expand Copy Statements** in the **Edit** menu to expand included statements in the current source. The added lines of code are highlighted and a comment line is inserted to identify the source include file.

**Commenting Out Source** Select a block of source and choose **Comment Block** in the **Edit** menu to comment out the block. Choose ** Uncomment Block** to uncomment the block.

**Changing Display Options** Choose **User Preferences** in the **Tools** menu and click the Editor tab in the User Preferences window to change the display characteristics for the Editor:

- The font that source code is displayed in.
- Whether color should be used in the source and, if so, the color of source elements (keywords, comments, and so forth).
- Whether to display DBCS escape control characters, as on a 3270 terminal.

**Tip:** Choose **IBM 3270 Emulation** in the **Edit** menu to toggle this selection on and off.
• The types of errors to include in the error list

The font and color functions use standard Windows controls.

**Printing Source** Click the **Print** choice in the **File** menu to print the source for a file.

**Finding and Replacing Source** Choose **Find** in the **Edit** menu to use the find utility. Choose **Replace** in the **Edit** menu to use the find and replace utility. You can perform find and replace operations on the whole file or a selection. For more information, see “**Finding and Replacing Text in Source Files**” on page 2-29.

**Restoring Line Numbers in Natural Source** Select a Natural source file and choose **Restore Line Numbers in Natural Source** in the **Edit** menu to restore stripped line numbers in the file.

**Creating a To Do List**

A to do list is a record of tasks you need to perform before completing your project. You can create a to do list for a workspace, project, folder, source file, or extracted object.

**To create a to do list:**

1. In the Repository pane, select a workspace, project, folder, source file, or extracted object and choose **ToDo List** in the **View** menu. The ToDo List window opens (Figure 2-23).

**Figure 2-23  ToDo List Window**
2A If you selected a source file or extracted object in step 1 on page 2-37, choose Add in the Edit menu to enter a task for the item.

2B If you selected a workspace, project, or folder in step 1 on page 2-37, choose Add in the Edit menu to enter a task for the item and all the items it contains. Otherwise, choose Add for Item to enter a task for the workspace, project, or folder only.

3 The New Properties dialog opens (Figure 2-24).

Figure 2-24  New Properties Dialog

4 In the Subject field, enter the subject of the task. In the Content field, enter a description of the task. Click OK. The task is listed in the ToDo List window.

To view a to do list:

1 To view the to do list for an item, select the item in the Repository pane and choose ToDo List in the View menu. Use the options in the ToDo List window Edit menu to mark a task as done, delete a task, or view its properties.

Tip: You can generate a report from a to do list by choosing Report in the File menu. For more information on reports, see “Exporting Diagrams and Reports” on page 2-60.
**Viewing Object Properties**

Select an object in the Repository pane and choose **Properties** in the View menu to display a set of tabs with object properties (Figure 2-25):

- **Description** displays comments you have entered for the object.
- **Statistic** displays complexity metrics for the object.
- **Internal** displays settings for key project verification options and other information for the object.
- **Audit** displays information about the creation and last modification of the object.
- **System** displays the dialect and source file for the object.
- **General** displays the name and source file of the object.
- **Relationships** displays the relationships of the object.
- **Object Tags** displays the tags assigned to the object.

Figure 2-25  **Object Properties Window**

**Entering Comments**  Enter comments for an object in the Description tab. The object information pane displays the comments you have en-
tered for the selected object. For more information, see “Object Information” on page 2-31.

**Viewing Properties of Another Object** In the Relationships tab, select an object in the relationships tree and click **Open** to view the properties for that object.

**Closing and Resizing Panes**

Close a pane by clicking the close box in the upper righthand corner of the pane. Reopen the pane by selecting the appropriate choice in the **View** menu. Resize a pane by using the mouse to grab its border with another pane, called a *splitter*, and dragging it to a new location.

**Using Tool Windows**

When you open a Modernization Workbench tool, the window for the tool appears above the workbench main window. Simply move the tool window if you want to work in the main window again.

Tool windows are *modeless*: in principle, you can open as many tool windows as you want. In practice, the workbench will prompt you to close an “unprotected” tool window if the activity you want to perform could result in a repository change (Figure 2-26). An unprotected tool window cannot be updated to reflect a concurrent repository change.

![Close Tools Dialog](image)

A tool window’s state (size, location, configuration, and content) is saved across sessions. Figure 2-27 shows the window for the Change
Analyzer tool, which you use to identify classes of data items that may be affected by a field change.

**Figure 2-27  Change Analyzer Window**

**Resizing Panes**

Resize a pane by using the mouse to grab its border with another pane, called a splitter, and dragging the border to a new location. You can control how panes are resized when you resize the entire tool window by selecting the splitter and choosing one of the following in the right-click menu:

- For a vertical splitter, **Keep First** preserves the size of the panes to the left of the splitter. For a horizontal splitter, **Keep First** preserves the size of the panes above the splitter.
• For a vertical splitter, **Keep Second** preserves the size of the panes to the right of the splitter. For a horizontal splitter, **Keep Second** preserves the size of the panes below the splitter.

• **Keep Proportion** preserves the length and width ratio of the panes on either side of the splitter.

**Moving Panes**

Move a pane in the window by grabbing its title bar to show the “virtual rectangle” for the pane. The virtual rectangle is a dotted color frame that you can drag to the position in the window at which you want the pane to appear. When you are satisfied with the new position, release the mouse button. The other panes in the window are adjusted as necessary.

**Tip:** You may have to drag the virtual rectangle beyond the edge of the tool window to achieve the effect you want.

You can swap the positions of the panes on either side of a splitter by selecting the splitter and choosing **Swap** in the right-click menu. You can change the color of the splitter when it is selected (and of its virtual rectangle) by selecting the splitter and choosing **Color** in the right-click menu. The color functions use standard Windows controls.

**Closing Panes**

Close a pane by clicking the close box in the upper righthand corner of the pane. Reopen the pane by selecting the appropriate choice in the **View** menu.

**Managing Tags**

You use a simple tagging language to identify workspace objects as members of higher-level functional, structural, or other types of groupings. After you set up these groupings, you can chart them in Enterprise View Express or “black-box” them in the Diagrammer.

Each member of the higher-level grouping is identified by a tag: Customer Maintenance, for example. Each grouping can, in turn, reference
a more inclusive grouping: Application Functions, for example. Later, when you generate charts or diagrams, the tags determine what the chart measures or the diagram “black boxes.”

If you assign the Customer Maintenance tag to one set of programs, for example, and the Order Entry tag to another, and both tags reference the Application Functions tag, then when you group diagram objects by Application Functions, the Diagrammer puts the programs in black boxes named Application Functions/Customer Maintenance and Application Functions/Order Entry. For Diagrammer usage, see *Analyzing Projects* in the workbench documentation set.

**Note:** You can assign different tags to the same object. A tag can reference any tag other than itself. The default tag structure is provided for Enterprise View Express use, as described in *Managing Application Portfolios* in the workbench documentation set.

**Understanding the Tag Manager Window**

Figure 2-28 shows the Tag Manager window. By default, the Object List pane displays up to 100 repository objects (and their assigned tags, if any). You can display more objects by clicking the button on the toolbar and selecting “More Objects” or “All Objects.” To manage tags more efficiently, you can filter the set of objects displayed in the Object List pane. See “To filter objects in the Object List pane:” on page 2-43 for details.

By default, all Tag Manager panes are displayed in this window. The **View** menu lets you show and hide individual panes. The toolbar icons provide one-click access to common tasks.
To filter objects in the Object List pane:

As you define filter criteria in Tag Manager panes, the Object List pane (Figure 2-29) is dynamically refreshed, displaying only objects matching all of the filter criteria.
Note: You cannot include both a tag and a category in your filter criteria. To include a tag, go to step 1A, otherwise go to step 1B.

1A In the Tags pane (Figure 2-30), select a tag. The Object List pane is refreshed and displays only objects assigned the selected tag. Go to step 2.
Note: This step is optional. However, if you specify a tag to include in your filter, you must select it first, before making selections in any other panes.

1B In the Category pane (Figure 2-31), choose one of the following:

- **All Objects** to view all repository objects.
- **Generated Objects** to view objects generated by the workbench.
- **Legacy Objects** to view source files registered in the workbench repository.

Figure 2-31  **Category Pane**

<table>
<thead>
<tr>
<th>Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>All Objects</td>
</tr>
<tr>
<td>Generated Objects</td>
</tr>
<tr>
<td>Legacy Objects</td>
</tr>
</tbody>
</table>

Note: If you specify a category, you cannot also include a tag in your filter criteria. To filter by tag, go to step 1A.

2 In the Projects pane (Figure 2-32), choose **Entire Workspace** or select a project name to view only objects contained in a particular project.
3 In the Object Types pane (Figure 2-33), choose All Types or select an object type (such as “Cobol File”) to view only objects matching the specified type.

**Figure 2-33  Object Types Pane**

**Note:** You cannot select multiple object types.
In the Search pane (Figure 2-34), you can perform a wildcard search for specific objects by object name. Enter a search string in the **Object Name** field (using asterisks as wildcards). As you type, the set of objects displayed in the Object List pane is periodically refreshed. Only objects matching the search string (as well as any filter criteria specified in other panes) are shown.

**Figure 2-34  Search Pane**

Note: In large repositories, the Object List pane may not immediately refresh as you type. Press the Enter key at any time to instantly display matching objects for the current string.

To view object properties:

1. Select an object in the Object List pane.
2. Choose Properties in the **Edit** menu (or right-click and choose **Properties**).
3. The Properties window is displayed. Click a tab to view the corresponding properties for the object.

Note: If multiple objects are selected, the properties for the first selected object are displayed.
Public vs. Private Tags

Tags can be marked “public” or “private” to control access and visibility in the multiuser environment. By default, tags you create (as well as those shipped with the workbench) are marked “public”. For each tag in the Tags pane, the Access column displays public/private status and the User column displays the name of the user who created the tag.

Tags marked “public” are visible to all users. A tag marked “private” is only visible to the user who created it.

To set public/private access for tags:

Note: You can only change access settings for tags you created.

1. Right-click an eligible tag in the Tags pane.
2. Choose Set Access in the popup menu.
3. Select “Public” or “Private” (Figure 2-35).

Opening the Tag Manager

In the Analyze menu in the Modernization Workbench main window, choose Tag Manager. The Tag Manager window opens.
**Refreshing the Tag Manager Window**

Click the button on the toolbar (or click the arrow on the icon and select Refresh from the drop-down) to update the Tag Manager window with the latest information from the repository, including changes made by other users.

**Note:** If objects have been deleted from the repository, they will remain visible in the Object List pane until you clean up the Tag Manager window. See “Cleaning Up the Tag Manager Window” on page 2-49 for details.

**Cleaning Up the Tag Manager Window**

When objects are deleted from the repository, Tag Manager continues to display these objects in the Object List pane until you run the Clean Up command. Click the arrow on the toolbar button and select Clean Up from the drop-down to remove deleted objects from the Object List pane.

**Note:** This feature is only available to master users. Running the Clean Up command may take several minutes depending on the size of your repository.

**Assigning Tags to Objects**

Follow the instructions in this section to assign tags to objects. You can also assign tags to objects in the Repository pane, by selecting the objects and choosing Assign/Remove Tags in the right-click menu. Select a project or folder to assign tags to every first-level object in the project or folder.

**To assign tags to objects:**

1. In the Object List pane, select the object(s) you want to assign a tag and choose Assign/Remove Tags in the Edit menu. The Entity Tag Browser window opens (Figure 2-36).
In the Tags pane, select the tag you want to assign and click the **Assign** button.

**Tip:** You can assign multiple tags by using Shift-click or Ctrl-click to select multiple tags.

3. If you are assigning a tag to a legacy source file, check **Apply to Derived Objects** to assign the selected tag(s) to all objects produced from this file by the workbench.

4. Click **OK** to assign the selected tags. In the Objects List pane, the Object Tag column for the selected object(s) is updated to reflect the changes.

**Removing Tags Assigned to Objects**

Follow the instructions in this section to remove tags assigned to objects. Removing a tag simply “unassigns” the tag from the selected object; the tag is not deleted from the repository. You can also remove tags from objects in the Repository pane, by selecting the objects and choosing **Assign/Remove Tags** in the right-click menu.
To remove tags assigned to objects:

1. In the Object List pane, select the object(s) for which you want to remove assigned tags and choose Assign/Remove Tags in the Edit menu. The Entity Tag Browser window opens (Figure 2-37).

   ![Entity Tag Browser Window](image)

2. In the Tags pane, select the tag you want to remove and click the Remove button.

   Tip: You can remove multiple assigned tags by using Shift-click or Ctrl-click to select multiple tags.

3. Click OK to remove the selected tags. In the Objects List pane, the Object Tag column for the selected object(s) is updated to reflect the changes.

Creating Tags

To create a tag, choose Create in the Edit menu. A dialog box prompts you to enter the name of the new tag. Enter the name and click OK.

You can also create tags in the References window, by choosing Reference in the Edit menu and clicking the button on the toolbar. A dia-
log box prompts you to enter the name of the new tag. Enter the name and click **OK**.

**Note:** To control access to a tag in the multiuser environment, see “Public vs. Private Tags” on page 2-48.

**Renaming Tags**
To edit a tag’s name, select it in the Tags pane, then click inside the text box for its name and enter the new text. Click outside the box to save the new name.

**Deleting Tags**
Select one or more tags in the Tags pane and choose **Delete Tags** from the **Edit** menu (or right-click and choose **Delete Tags**). You are prompted to confirm deletion. Select Yes to delete the tag(s), or No to cancel the operation.

You can also delete tags in the References window, by choosing **Reference** in the **Edit** menu and clicking the **Delete** button on the toolbar.

**Creating Relationships Between Tags**
Follow the instructions in this section to create relationships between tags.

**To create relationships between tags:**

1. In the **Edit** menu, choose **Reference**. The References window opens (Figure 2-38).
In the References window, select a tag (or select multiple tags using Shift+click) and click the button on the toolbar.

A Select window prompts you to select the tag to reference. Select the tag and click OK. The tool draws a line between the tags.

For information on the Diagrammer functions in the References window, see Analyzing Projects in the workbench documentation set.

Deleting Relationships Between Tags

To delete a reference from one tag to another, choose Reference in the Edit menu. The References window opens (Figure 2-38). Select the relationship line (or select multiple lines using Shift+click) and click the button on the toolbar.
Generating Object Reports

Click the button on the toolbar to generate a report for all objects currently displayed in the Object List pane. You can preview and print the report using the Page Setup and Print buttons, or export it to a variety of standard formats. Click Save to export the report to HTML, Excel, RTF, Word, formatted text, or CSV. A Save As dialog opens, where you can specify the name, location, and file type of the report.

Refreshing the Tag Manager Window

Click the button on the toolbar to reset the Tag Manager window to the default view.

Setting Options

Modernization Workbench options control the look and feel of the workbench tools and how they perform their tasks. The Tools menu in the main workbench window gives you access to three sets of options:

- **Workspace Options** control the appearance and behavior of workbench tools for the current workspace.
- **Project Options** control the appearance and behavior of workbench tools for the selected project.
- **User Preferences** control the appearance and behavior of the Editor, HyperView, and Change Analyzer across workspaces, and miscellaneous other tasks.

Each tool has an Options choice in the View menu that lets you set the options for that tool.

**Note:** Many options are preset based on your choices in the Modernization Workbench Configuration Manager. For more information, see the installation guide for your product.

Workbench and tool options are described in detail in the relevant sections of the document set. This section shows you how to set user preferences for your workbench environment: whether you want to be
prompted to verify source files after registering them, and the scope of relationship shown in the Object Properties window.

**To set Environment user preferences:**

1. In the **Tools** menu in the Modernization Workbench main window, choose **User Preferences**. The User Preferences window opens. Click the Environment tab.

2. In the After new files are registered group box, choose:
   - **Verify registered files** if you want the workbench to verify files after they have been registered.
   - **Ask user about verification** if you want to be prompted to verify files after they have been registered. Available whether or not the **Verify registered files** is selected.

3. In the Show relationships in the object properties view window group box, choose either:
   - **Restricted to the current project** if you want the object relationships shown in the Relationships tab of the Object Properties window to be limited only to those in the current project.
   - **Workspace wide** if you want the relationships shown in the Relationships tab of the Object Properties window to include all relationships in the current workspace.

4. For Java support, enter the path to the folder for the Java Runtime Environment (JRE) on your machine in the **Path to JRE Folder** field. You can enter the path manually or use the **button to browse for the folder.

5A. Click **Apply** if you want to save your settings without dismissing the User Preferences window.

5B. Click **OK** if you want to save your settings and dismiss the User Preferences window. The new settings take effect immediately.
Managing Option Sets

An option set is a particular configuration of settings for one of the option groupings. In a given Project Options set, for example, you might choose to show GO TO statements in the HyperView Callie tool, while in the other Project Options sets you would not.

Option sets let you switch back and forth between configurations in the same session, without having to change settings manually. You can also
use them to ensure uniform results across your team by sharing settings with team members. Use the Options Manager to define options sets.

**Understanding the Options Manager Window**

Figure 2-40 shows the Options Manager window at startup, with the tab for the Workspace Options grouping selected. For each grouping, there is an initial read-only default option set, denoted by ☑ symbol, that reflects your current workbench configuration. This initial default option set is always shared with other users in the environment, as indicated by a ☑ symbol.

When you assign a Workspace or Project Options set, you make it active for the current workspace or selected project. When you assign a User Preferences option set, you make it active across all workspaces. The active option set is displayed in **bold** type in the Options Manager tab for the grouping. Assignments persist across workbench sessions.

The user who creates an option set is referred to as its owner. Only the owner can share an option set with other users. The owner’s name appears in the Owner column in the Options Manager window displayed to other users (but not in the owner’s Options Manager window). The Used By drop-down at the bottom of the owner’s Options Manager window list the names of other users who have assigned a shared option set.

An owner can make a shared option set the default, in which case it cannot be modified or deleted. Otherwise, owners can delete a shared option set or revoke sharing privileges only if it is not being used.
Opening the Options Manager

In the Tools menu in the Modernization Workbench main window, choose Options Manager. The Options Manager window opens. Click the tab for the options grouping of interest to you.

Creating an Option Set

If there is only a “(Default)” option set for the grouping, select it and click Edit. Otherwise, select any option set and click Edit. Options Manager displays the available tabs for the selected options grouping.

Modify the options displayed on each tab as necessary and click Apply. When you are satisfied with your choices, click OK. The new option set is displayed in the Options Manager window with the name of the grouping.

Note: If a default option set already uses one of the grouping names, Options Manager prepends “Copy of” to the name.
Renaming an Option Set
To rename an option set, select it and click Rename. The system displays the current name in an edit box. Enter the new name in the edit box and click outside the box.

Editing an Option Set
To edit an option set, select it and click Edit, then follow the instructions in “Creating an Option Set.”

Copying an Option Set
To copy an option set, select it and click Copy. Options Manager prepends “Copy of” to the name of the copied option set. Rename the option set as described in “Renaming an Option Set.”

Deleting an Option Set
To delete an option set, select it and click Delete.

Sharing an Option Set
To share an option set, select it and click Sharing. The button is a toggle. Select it again to revoke sharing.

Making an Option Set the Default
To make an option set the default, select it and click Default. In the Project Options tab, a dialog opens that prompts you to select or create a new project. Select the project and click OK.

Assigning an Option Set
To make an option set active, select it and click Assign.

Note: In the Project Options tab, a dialog opens that prompts you to select or create a new project. Select the project and click OK.
Exporting an Option Set

To export an option set, select it and click Export. A Save dialog opens, where you can specify the name and location of the option set.

Importing an Option Set

To import an option set, select it and click Import. A Load dialog opens, where you can specify the option set you want to import.

Exporting Diagrams and Reports

Whenever you generate a diagram or report in the Modernization Workbench, you have the option of exporting it to a file for viewing, editing, or printing. You can export to a wide variety of standard formats.

Note: Word must be installed to save reports to RTF and Word. Excel must be installed to save reports to Excel, CSV, and TXT. Visio 2002 must be installed to save a diagram to Visio. Visio 2002 is not required to save to Visio XML.

Diagram and report generation is described in detail in the relevant sections of the document set. This section shows you how to export a diagram. Exporting a report is similar.

To export a diagram:

1. In the Diagram menu in the Diagrammer window (not shown), choose Save Diagram as. The Save Diagram dialog opens (Figure 2-41).
2 In the **Save in** drop-down, choose the folder to save the diagram file in. In the **File name** field, enter the name of the diagram file. Choose a name that describes the diagram as closely as possible. In the **Save as type** drop-down, choose the type of file you want to save the diagram as. Click **Save**. The diagram file is created in the specified folder.

---

**Specifying the Output Folder for Generated Files**

By default, Modernization Workbench stores generated files in the `\Workspace\Output` folder. You can specify a different folder in the **Target directory** field in the Export tab of the Project Options window (see “Setting Options” on page 2-54). Deselect the **Move Files** check box in the Export tab if you want to copy generated files to both the default and the specified directories.

---

**Using the Guide for a Tool**

Many Modernization Workbench tools have *guides* that you can use to get started quickly in the tool. The guides are help-like systems with hy-
perlinks that you can use to access functions otherwise available only in menus and other program controls.

To open the guide for a tool, choose Guide in the View menu. Use the table of contents in the Page drop-down to navigate quickly to a topic. Figure 2-42 shows the guide for the Application Partitioner tool.

Figure 2-42  Application Partitioner Guide

What’s Next?

That completes your tour of the Modernization Workbench! Now you’re ready to start setting up Modernization Workbench projects, as described in Preparing Projects in the workbench documentation set.
The tables in this appendix describe the icons used for Cobol, PL/I, and Natural source in the object and construct models.

**Object Model Icons**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Cobol File]</td>
<td>Cobol File</td>
</tr>
<tr>
<td>![Copybook File]</td>
<td>Copybook File</td>
</tr>
<tr>
<td>![Data Connector]</td>
<td>Data Connector</td>
</tr>
<tr>
<td>![Data Store]</td>
<td>Data Store</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1" alt="Decision Icon" /></td>
<td>Decision</td>
</tr>
<tr>
<td><img src="image2" alt="Device Description Icon" /></td>
<td>Device Description</td>
</tr>
<tr>
<td><img src="image3" alt="Device File Icon" /></td>
<td>Device File</td>
</tr>
<tr>
<td><img src="image4" alt="File Icon" /></td>
<td>File</td>
</tr>
<tr>
<td><img src="image5" alt="Generated Document Icon" /></td>
<td>Generated Document</td>
</tr>
<tr>
<td><img src="image6" alt="Message Descriptor Icon" /></td>
<td>Message Descriptor</td>
</tr>
<tr>
<td><img src="image7" alt="PL/I File Icon" /></td>
<td>PL/I File</td>
</tr>
<tr>
<td><img src="image8" alt="PL/I Include File Icon" /></td>
<td>PL/I Include File</td>
</tr>
<tr>
<td><img src="image9" alt="Program Icon" /></td>
<td>Program</td>
</tr>
<tr>
<td><img src="image10" alt="Program Entry Point Icon" /></td>
<td>Program Entry Point</td>
</tr>
<tr>
<td><img src="image11" alt="Project Icon" /></td>
<td>Project</td>
</tr>
<tr>
<td><img src="image12" alt="Report Icon" /></td>
<td>Report</td>
</tr>
<tr>
<td><img src="image13" alt="Resource File Icon" /></td>
<td>Resource File</td>
</tr>
<tr>
<td><img src="image14" alt="Screen Icon" /></td>
<td>Screen</td>
</tr>
<tr>
<td><img src="image15" alt="System Program Icon" /></td>
<td>System Program</td>
</tr>
<tr>
<td><img src="image16" alt="Table Icon" /></td>
<td>Table</td>
</tr>
<tr>
<td><img src="image17" alt="Transaction Icon" /></td>
<td>Transaction</td>
</tr>
</tbody>
</table>
## Construct Model Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>ADABAS DB Field</td>
</tr>
<tr>
<td>![Icon]</td>
<td>ALTER Statement</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Assignment Statement</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Block, Do Statement, Otherwise Branch,</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Common Data</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Condition</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Constant</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Database operation</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Data Port, Put Statement, Get Statement</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Data Section, Define Data Section, Global</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Declaration, DDName, Data Item Declaration</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Division</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Entry Statement, Control Constant</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Expression</td>
</tr>
<tr>
<td>![Icon]</td>
<td>GO TO Statement, Next Sentence Statement,</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Handler Statement</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>![I/O Icon]</td>
<td>I/O Statement</td>
</tr>
<tr>
<td>![IF Icon]</td>
<td>IF Statement, Select Statement, DECIDE</td>
</tr>
<tr>
<td>![Label Icon]</td>
<td>Label</td>
</tr>
<tr>
<td>![Paragraph Icon]</td>
<td>Paragraph, Internal Procedure, External Procedure</td>
</tr>
<tr>
<td>![Perform Icon]</td>
<td>Perform Statement, Paragraph Perform, Call,</td>
</tr>
<tr>
<td>![Program Icon]</td>
<td>Program, DDM File</td>
</tr>
<tr>
<td>![Return Icon]</td>
<td>Return Statement</td>
</tr>
<tr>
<td>![Section Icon]</td>
<td>Section</td>
</tr>
<tr>
<td>![SQL Column Icon]</td>
<td>SQL Column Declaration, SQL Column</td>
</tr>
<tr>
<td>![SQL Cursor Icon]</td>
<td>SQL Cursor Usage</td>
</tr>
<tr>
<td>![SQL Table Icon]</td>
<td>SQL Table Usage</td>
</tr>
<tr>
<td>![Stop Icon]</td>
<td>Stop</td>
</tr>
<tr>
<td>![System Icon]</td>
<td>System Function or Variable</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>---------------------------</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Use Label</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Variable, Session Parameter</td>
</tr>
</tbody>
</table>
Glossary

ADABAS
ADABAS is a Software AG relational DBMS for large, mission-critical applications.

API
API stands for application programming interface, a set of routines, protocols, and tools for building software applications.

applet
See Java applet.

AS/400
The AS/400 is a midrange server designed for small businesses and departments in large enterprises.

BMS
BMS stands for Basic Mapping Support, an interface between application formats and CICS that formats input and output display data.

BSTR
BSTR is a Microsoft format for transferring binary strings.
**CDML**
CDML stands for Cobol Data Manipulation Language, an extension of the Cobol programming language that enables applications programmers to code special instructions to manipulate data in a DMS database and to compile those instructions for execution.

**CICS**
CICS stands for Customer Information Control System, a program that allows concurrent processing of transactions from multiple terminals.

**Cobol**
Cobol stands for Common Business-Oriented Language, a high-level programming language used for business applications.

**COM**
COM stands for Component Object Model, a software architecture developed by Microsoft to build component-based applications. COM objects are discrete components, each with a unique identity, which expose interfaces that allow applications and other components to access their features.

**complexity**
An application’s complexity is an estimate of how difficult it is to maintain, analyze, transform, and so forth.

**component**
A component is a self-contained program that can be reused with other programs in modular fashion.

**construct**
A construct is an item in the parse tree for a source file — a section, statement, condition, variable, or the like. A variable, for example, can be related in the parse tree to any of three other constructs — a declaration, a dataport, or a condition.

**copybook**
A copybook is a common piece of source code to be copied into many Cobol source programs. Copybooks are functionally equivalent to C and C++ include files.
CORBA
CORBA stands for Common Object Request Broker Architecture, an architecture that enables distributed objects to communicate with one another regardless of the programming language they were written in or the operating system they are running on.

CSD file
CSD stands for CICS System Definition. A CSD file is a VSAM data set containing a resource definition record for every resource defined to CICS.

database schema
A database schema is the structure of a database system, described in a formal language supported by the DBMS. In a relational database, the schema defines the tables, the fields in each table, and the relationships between fields and tables.

dataport
A dataport is an input/output statement or a call to or from another program.

DB/2
DB/2 stands for Database 2, an IBM system for managing relational databases.

DBCS
DBCS stands for double-byte character string, a character set that uses two-byte (16-bit) characters rather than one-byte (8-bit) characters.

DBMS
DBMS stands for database management system, a collection of programs that enable you to store, modify, and extract information from a database.

DDL
DDL stands for Data Description Language (DDL), a language that describes the structure of data in a database.

decision resolution
Decision resolution lets you identify and resolve dynamic calls and other relationships that the parser cannot resolve from static sources.
DMS
DMS stands for Data Management System, a Unisys database management software product that conforms to the CODASYL (network) data model and enables data definition, manipulation, and maintenance in mass storage database files.

DPS
DPS stands for Display Processing System, a Unisys product that enables users to define forms on a terminal.

ECL
ECL stands for Executive Control Language, the operating system language for Unisys OS 2200 systems.

effort
Effort is an estimate of the time it will take to complete a task related to an application, based on weighted values for selected complexity metrics.

EJB
EJB stands for Enterprise JavaBeans, a Java API developed by Sun Microsystems that defines a component architecture for multi-tier client/server systems.

EMF
EMF stands for Enhanced MetaFile, a Windows format for graphic images.

entity
An entity is an object in the repository model for a legacy application. The relationships between entities describe the ways in which the elements of the application interact.

FCT
FCT stands for File Control Table (FCT), a CICS table that contains processing requirements for output data streams received via a remote job entry session from a host system. Compare PCT.

HTML
HTML stands for HyperText Markup Language, the authoring language used to create documents on the World Wide Web.
IDL
IDL stands for Interface Definition Language (IDL), a generic term for a language that lets a program or object written in one language communicate with another program written in an unknown language.

IDMS
IDMS stands for Integrated Database Management System, a Computer Associates database management system for the IBM mainframe and compatible environments.

IMS
IMS stands for Information Management System, an IBM program product that provides transaction management and database management functions for large commercial application systems.

Java
Java is a high-level object-oriented programming language developed by Sun Microsystems.

Java applet
A Java applet is a program that can be sent with a Web page. Java applets perform interactive animations, immediate calculations, and other simple tasks without having to send a user request back to the server.

JavaBeans
JavaBeans is a specification developed by Sun Microsystems that defines how Java objects interact. An object that conforms to this specification is called a JavaBean.

JCL
JCL stands for Job Control Language, a language for identifying a job to OS/390 and for describing the job’s requirements.

JDBC
JDBC stands for Java Database Connectivity, a standard for accessing diverse database systems using the Java programming language.

Job
A job is the unit of work that a computer operator or a program called a job scheduler gives to the operating system. In IBM main-
frame operating systems, a job is described with job control language (JCL).

**logical component**
A logical component is an abstract repository object that gives you access to the source files that comprise a component.

**MFS**
MFS stands for Message Format Service, a method of processing IMS input and output messages.

**Natural**
Natural is a programming language developed and marketed by Software AG for the enterprise environment.

**object model**
An object model is a representation of an application and its encapsulated data.

**object-oriented programming**
Object-oriented programming organizes programs in terms of objects rather than actions, and data rather than logic.

**ODBC**
ODBC stands for Open Database Connectivity, a standard for accessing diverse database systems.

**orphan**
An orphan is an object that does not exist in the reference tree for any startup object. Orphans can be removed from a system without altering its behavior.

**parser**
The parser defines the object model and parse tree for a legacy application.

**parse tree**
A parse tree defines the relationships between the constructs that comprise a source file — its sections, paragraphs, statements, conditions, variables, and so forth.

**PCT**
PCT stands for Program Control Table, a CICS table that defines the transactions that the CICS system can process. Compare FCT.
PL/I
PL/I stands for Programming Language One, a third-generation programming language developed in the early 1960s as an alternative to assembler language, Cobol, and FORTRAN.

profile
Profiles are HTML views into a repository that show all of the analysis you have done on an application. Profiles are convenient ways to share information about legacy applications across your organization.

QSAM
QSAM stands for Queued Sequential Access Method, a type of processing that uses a queue of data records—either input records awaiting processing or output records that have been processed and are ready for transfer to storage or an output device.

relationship
The relationships between entities in the repository model for a legacy application describe the ways in which the elements of the application interact.

relaxed parsing
Relaxed parsing lets you verify a source file despite errors. Ordinarily, the parser stops at a statement when it encounters an error. Relaxed parsing tells the parser to continue to the next statement.

repository
A repository is a database of program objects that comprise the model for an application.

schema
See database schema.

SQL
SQL stands for Structured Query Language, a standard language for relational database operations.

system program
A system program is a generic program — a mainframe sort utility, for example — provided by the underlying system and used in unmodified form in the legacy application.
**TIP**

TIP stands for Transaction Processing, the Unisys real-time system for processing transactions under Exec control.

**transaction**

A transaction is a sequence of information exchange and related work (such as database updating) that is treated as a unit for the purposes of satisfying a request and for ensuring database integrity.

**VALTAB**

VALTAB stands for Validation Table, which contains the information the system needs to locate, load, and execute transaction programs. See also **TIP**.

**VSAM**

VSAM stands for Virtual Storage Access Method, an IBM program that controls communication and the flow of data in a Systems Network Architecture network.

**XML**

XML stands for Extensible Markup Language, a specification for creating common information formats.
Index

A
accessing tags 2-48
Application Analyzer 1-2
Application Architect 1-3
Application Profiler 1-3

B
browser fetch buffer size 2-24
Business Rule Manager 1-3

C
commenting out source 2-35
comments 2-31, 2-38
computing database statistics 1-14
construct model 1-8
  icons A-3
  overview 1-8
copybooks 2-35
creating a workspace 2-1
creating tags 2-51

database indexes 1-14
database server 1-11
database statistics 1-14
DB/2 tablespace 2-2, 2-5
delete referenced tags 2-53
deleting tags 2-52
diagrams, exporting 2-60
dropping repository indexes 1-14

database server 1-11
database statistics 1-14
DB/2 tablespace 2-2, 2-5
delete referenced tags 2-53
deleting tags 2-52
diagrams, exporting 2-60
dropping repository indexes 1-14

db2 tablespace 2-2, 2-5
delete referenced tags 2-53
deleting tags 2-52
diagrams, exporting 2-60
dropping repository indexes 1-14

dropping repository indexes 1-14

editing source 2-34
Editor 2-33
Enterprise View Express 1-3
errors, viewing 2-35
expanding copybooks 2-35
exporting diagrams and reports 2-60
extracting copybooks 2-35
Index-2

F
file server 1-13
filtering objects in Tag Manager 2-43
filters for searches 2-27
find and replace 2-30, 2-36

G
gathering system statistics 1-14
guides 2-61

H
HyperView 1-6

L
loading source files 2-15

M
master user
  adding new 2-6, 2-8
  privileges 1-12
menus
  customizing 2-19
  overview 2-19
Modernization Workbench
  overview 1-1
moving panes 2-41
multiuser environment
  connecting to a workspace 2-11
  creating a workspace 2-1
  overview 1-10

O
object information pane 2-31
object model
  icons A-1
  overview 1-7
  properties 2-38
  object properties
    viewing in Object Properties window 2-38
    viewing in Tag Manager 2-47
object tags 2-41
opening a workspace 2-13
option set 2-56
options 2-54

P
panes
  moving 2-41
  resizing 2-39, 2-40
parse tree
  icons A-3
Posix regular expressions 2-29, 2-30
printing source 2-36
private tags 2-48
privileges 1-12
project
  browser view 2-23
  commenting out source 2-35
  creating to do lists 2-36
  editing source 2-34
  expanding copybooks 2-35
  extracting copybooks 2-35
  finding and replacing source 2-36
  options 2-54
  overview 1-9
  printing source 2-36
  search view 2-25
  searching for objects 2-27
  selecting objects 2-24
  verifying files 2-16
  viewing errors 2-35
  viewing object properties 2-38
public tags 2-48

R
reference tags 2-52
refreshing the workspace path 2-9
registering files 2-14
relationships 1-7
removing tags 2-50
renaming tags 2-52
replacing matched text 2-30
replacing source 2-36
reports, exporting 2-60
Repository Browser
searching for objects 2-27
selecting objects 2-24
repository indexes 1-14
repository model
overview 1-7
Repository pane
browser view 2-23
search view 2-25
repository, overview 1-9
resizing panes 2-39, 2-40
rwp 2-12

S
searching for objects 2-27
selecting objects 2-24
Simple Security Policy 1-13, 2-5, 2-6
single-user environment, overview 1-9
SME, designating 2-7
source files
registering 2-15
splitters 2-39, 2-40
subject matter expert, designating 2-7
subtree, exporting 2-24, 2-25

system statistics 1-14

T
Tablespace 2-5, 2-12
Tablespace for Indexes 2-5, 2-12
tag manager
assigning tags 2-49
creating relationships between tags 2-52
creating tags 2-51
deleting relationships between tags 2-53
deleting tags 2-52
filtering objects 2-43
opening tag manager window 2-48
public and private tags 2-48
references 2-52
removing assigned tags 2-50
renaming tags 2-52
understanding 2-42
viewing object properties 2-47
window 2-42
tagging objects 2-49
tags 2-41
Three-Group Security Policy 1-13, 2-5, 2-6, 2-7
to do lists 2-36
tool bars 2-21
Transformation Assistant 1-4
type ahead select 2-26

U
user preferences 2-54

V
verifying files 2-16, 2-55
Index-4

Viewer 2-33

W
wildcard patterns 2-31
workbench client 1-11
workbench server 1-11
workspace 1-8
   commenting out source 2-35
   creating in multiuser environment 2-1
   creating to do lists 2-36
   editing source 2-34
   expanding copybooks 2-35
   extracting copybooks 2-35
   finding and replacing source 2-36
   opening 2-13
   options 2-54
   printing source 2-36
   registering files 2-14
   searching for objects 2-27
   selecting objects 2-24
   verifying files 2-16
   viewing errors 2-35
   viewing object properties 2-38
workspace path, refreshing 2-9